Vertragsverwaltung-Klassenbibliothek

Vertragsverwaltung

Vertragsverwaltung (c) 2008/2009 Stefan Hutter Unternehmensberatugn, Bülach

Generated by VBdocman .NET


Vertragsverwaltung -Namespace

Klassen

public class AM_Auftraege_nach_Besitzer_Grafik Unterstützt von .NET Compact Framework |
public class AM_Auftraege_nach_RFCBoard_Grafik Unterstützt von .NET Compact Framework |
public class AM_Auftraege_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class Abgeschlossene_Auftraege_nach_Besitzer Unterstützt von .NET Compact Framework |
public class Abgeschlossene_Auftraege_nach_RFCBoard Unterstützt von .NET Compact Framework |
public class Abgeschlossene_Auftraege_nach_RFCBoard_A4Q Unterstützt von .NET Compact Framework |
public class Abgeschlossene_Auftraege_nach_Status Unterstützt von .NET Compact Framework |
public class Abgeschlossene_Auftraege_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class Applikationsliste_Applikation Unterstützt von .NET Compact Framework |
public class Applikationsliste_Kategorie Unterstützt von .NET Compact Framework |
public class Applikationsliste_KeyUser Unterstützt von .NET Compact Framework |
public class Applikationsliste_Marktbereich Unterstützt von .NET Compact Framework |
public class Applikationsliste_RFCBoard Unterstützt von .NET Compact Framework |
public class Applikationsliste_TeamVerantwortung Unterstützt von .NET Compact Framework |
public class Applikationsliste_Verantwortung Unterstützt von .NET Compact Framework |
public class Applikationsreport Unterstützt von .NET Compact Framework |
public class Auftragsuebersicht Unterstützt von .NET Compact Framework |
public class Avaloq_Gremien Unterstützt von .NET Compact Framework |
public class BE01 Unterstützt von .NET Compact Framework |
public class CachedAM_Auftraege_nach_Besitzer_Grafik Unterstützt von .NET Compact Framework |
public class CachedAM_Auftraege_nach_RFCBoard_Grafik Unterstützt von .NET Compact Framework |
public class CachedAM_Auftraege_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class CachedAbgeschlossene_Auftraege_nach_Besitzer Unterstützt von .NET Compact Framework |
public class CachedAbgeschlossene_Auftraege_nach_RFCBoard Unterstützt von .NET Compact Framework |
public class CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q Unterstützt von .NET Compact Framework |
public class CachedAbgeschlossene_Auftraege_nach_Status Unterstützt von .NET Compact Framework |
public class CachedAbgeschlossene_Auftraege_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_Applikation Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_Kategorie Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_KeyUser Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_Marktbereich Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_RFCBoard Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_TeamVerantwortung Unterstützt von .NET Compact Framework |
public class CachedApplikationsliste_Verantwortung Unterstützt von .NET Compact Framework |
public class CachedApplikationsreport Unterstützt von .NET Compact Framework |
public class CachedAuftragsuebersicht Unterstützt von .NET Compact Framework |
public class CachedAvaloq_Gremien Unterstützt von .NET Compact Framework |
public class CachedBE01 Unterstützt von .NET Compact Framework |
public class CachedCrystalReport1 Unterstützt von .NET Compact Framework |
public class CachedCrystalReport2 Unterstützt von .NET Compact Framework |
public class CachedEA01 Unterstützt von .NET Compact Framework |
public class CachedEA02 Unterstützt von .NET Compact Framework |
public class CachedEO01 Unterstützt von .NET Compact Framework |
public class CachedGeschlossene_IN_nach_Kategorien Unterstützt von .NET Compact Framework |
public class CachedIGA Unterstützt von .NET Compact Framework |
public class CachedIN_AVQ_Remedy Unterstützt von .NET Compact Framework |
public class CachedITSM_Berechtigungen Unterstützt von .NET Compact Framework |
public class CachedIncident_Geloest Unterstützt von .NET Compact Framework |
public class CachedIncident_Geloest_Total Unterstützt von .NET Compact Framework |
public class CachedIncident_Geloest_Total_Prod Unterstützt von .NET Compact Framework |
public class CachedIncident_Geloest_nach_Ma Unterstützt von .NET Compact Framework |
public class CachedIncident_Geloest_nach_Ma_App Unterstützt von .NET Compact Framework |
public class CachedIncident_nach_Besitzer Unterstützt von .NET Compact Framework |
public class CachedIncident_nach_Status Unterstützt von .NET Compact Framework |
public class CachedIncident_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class CachedPE01 Unterstützt von .NET Compact Framework |
public class CachedQU01 Unterstützt von .NET Compact Framework |
public class CachedRFCBoard Unterstützt von .NET Compact Framework |
public class CachedRFCBudget Unterstützt von .NET Compact Framework |
public class CachedRFCBudget_Uebersicht Unterstützt von .NET Compact Framework |
public class CachedStatistik_Applikationen_Nach_Verantwortung Unterstützt von .NET Compact Framework |
public class CachedTE01 Unterstützt von .NET Compact Framework |
public class CachedUM01 Unterstützt von .NET Compact Framework |
public class CachedVI01 Unterstützt von .NET Compact Framework |
public class CachedVertragselement_SecurityLevel Unterstützt von .NET Compact Framework |
public class Cachedit_koordinatoren Unterstützt von .NET Compact Framework |
public class Cachedrfc_budget_total Unterstützt von .NET Compact Framework |
public class CachedÜbersicht_AM_Aufträge_RFC_Status Unterstützt von .NET Compact Framework |
public class CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität Unterstützt von .NET Compact Framework |
public class CachedÜbersicht_Incident_nach_Besitzer Unterstützt von .NET Compact Framework |
public class CachedÜbersicht_Incident_nach_Verantwortung Unterstützt von .NET Compact Framework |
internal (Friend) class ComboBoxIconItem Unterstützt von .NET Compact Framework |
internal (Friend) class ComboBoxTree_TreeView Unterstützt von .NET Compact Framework |
public class ComboIcon Unterstützt von .NET Compact Framework |
public class CrystalReport1 Unterstützt von .NET Compact Framework |
public class CrystalReport2 Unterstützt von .NET Compact Framework |
public class EA01 Unterstützt von .NET Compact Framework |
public class EA02 Unterstützt von .NET Compact Framework |
public class EO01 Unterstützt von .NET Compact Framework |
public class Geschlossene_IN_nach_Kategorien Unterstützt von .NET Compact Framework |
public class IGA Unterstützt von .NET Compact Framework |
public class IN_AVQ_Remedy Unterstützt von .NET Compact Framework |
public class ITSM_Berechtigungen Unterstützt von .NET Compact Framework |
public class Incident_Geloest Unterstützt von .NET Compact Framework |
public class Incident_Geloest_Total Unterstützt von .NET Compact Framework |
public class Incident_Geloest_Total_Prod Unterstützt von .NET Compact Framework |
public class Incident_Geloest_nach_Ma Unterstützt von .NET Compact Framework |
public class Incident_Geloest_nach_Ma_App Unterstützt von .NET Compact Framework |
public class Incident_nach_Besitzer Unterstützt von .NET Compact Framework |
public class Incident_nach_Status Unterstützt von .NET Compact Framework |
public class Incident_nach_Verantwortung Unterstützt von .NET Compact Framework |
public class MyGenericEventHandler Unterstützt von .NET Compact Framework |
public class PE01 Unterstützt von .NET Compact Framework |
public class QU01 Unterstützt von .NET Compact Framework |
public class RFCBoard Unterstützt von .NET Compact Framework |
public class RFCBudget Unterstützt von .NET Compact Framework |
public class RFCBudget_Uebersicht Unterstützt von .NET Compact Framework |
public class Statistik_Applikationen_Nach_Verantwortung Unterstützt von .NET Compact Framework |
public class TE01 Unterstützt von .NET Compact Framework |
public class Treenode_Descriptor Unterstützt von .NET Compact Framework | Treenode-Descriptor zur Befüllung des Tree-Node-Tags
public class UM01 Unterstützt von .NET Compact Framework |
public class VI01 Unterstützt von .NET Compact Framework |
public class Vertragselement_SecurityLevel Unterstützt von .NET Compact Framework |
public class clsGremienverwaltung Unterstützt von .NET Compact Framework |
public class clsResizeControl Unterstützt von .NET Compact Framework |
public class it_koordinatoren Unterstützt von .NET Compact Framework |
public class rfc_budget_total Unterstützt von .NET Compact Framework |
public class Übersicht_AM_Aufträge_RFC_Status Unterstützt von .NET Compact Framework |
public class Übersicht_AM_Aufträge_RFC_Status_Priorität Unterstützt von .NET Compact Framework |
public class Übersicht_Incident_nach_Besitzer Unterstützt von .NET Compact Framework |
public class Übersicht_Incident_nach_Verantwortung Unterstützt von .NET Compact Framework |
internal (Friend) class Crypto Unterstützt von .NET Compact Framework |
internal (Friend) class Globals Unterstützt von .NET Compact Framework |
internal (Friend) class Readme Unterstützt von .NET Compact Framework |

Formulare

public class Form2 Unterstützt von .NET Compact Framework |
public class FrmAktivitaetenListe Unterstützt von .NET Compact Framework |
public class FrmExcelExport Unterstützt von .NET Compact Framework |
public class FrmGenerateActivity Unterstützt von .NET Compact Framework |
public class FrmLizenz Unterstützt von .NET Compact Framework |
public class FrmReleaseLogbuch Unterstützt von .NET Compact Framework |
public class FrmReportSelect Unterstützt von .NET Compact Framework |
public class FrmToolTipEditor Unterstützt von .NET Compact Framework |
public class form1 Unterstützt von .NET Compact Framework |
public class frmAbout Unterstützt von .NET Compact Framework |
public class frmApplSuche Unterstützt von .NET Compact Framework |
public class frmApplikation Unterstützt von .NET Compact Framework |
public class frmApplikationAbhaengigkeit Unterstützt von .NET Compact Framework |
public class frmApplikationNeu Unterstützt von .NET Compact Framework |
public class frmApplikationskontakt Unterstützt von .NET Compact Framework |
public class frmApplikationsuebersicht Unterstützt von .NET Compact Framework |
public class frmAuswertung Unterstützt von .NET Compact Framework |
public class frmAuswertungsParameter Unterstützt von .NET Compact Framework |
public class frmCalendar Unterstützt von .NET Compact Framework |
public class frmDatenbankauswahl Unterstützt von .NET Compact Framework | Form für die Datenbankauswahl
public class frmDokument Unterstützt von .NET Compact Framework |
public class frmDomainEditor Unterstützt von .NET Compact Framework | Form mit generalisiertem Domain-Table-Editor.
public class frmDomainEditorExtTables Unterstützt von .NET Compact Framework | Form mit generalisiertem Domain-Table-Editor.
public class frmFormSelector Unterstützt von .NET Compact Framework |
public class frmGremienverwaltung Unterstützt von .NET Compact Framework |
public class frmKontaktMassenupdate Unterstützt von .NET Compact Framework |
public class frmKuendigungsfrist Unterstützt von .NET Compact Framework | Person
public class frmLeistung Unterstützt von .NET Compact Framework |
public class frmLogin Unterstützt von .NET Compact Framework | Form für den Login. Wird nur angezeigt, sofern in der Tabelle Application Show-Login = true
public class frmMAEinstellung Unterstützt von .NET Compact Framework |
public class frmMain Unterstützt von .NET Compact Framework | Hauptformular der Vertragsverwaltung als MDI-Container
public class frmMsgBox Unterstützt von .NET Compact Framework |
public class frmPendenz Unterstützt von .NET Compact Framework |
public class frmPendenzübersicht Unterstützt von .NET Compact Framework |
public class frmPerson Unterstützt von .NET Compact Framework | Person
public class frmProfilVerwaltung Unterstützt von .NET Compact Framework |
public class frmReferenzvertraege Unterstützt von .NET Compact Framework |
public class frmSLAKatalog Unterstützt von .NET Compact Framework | SLAKatalog-Verwaltung
public class frmServicekatalog Unterstützt von .NET Compact Framework | Servicekatalog-Verwaltung
public class frmSplash Unterstützt von .NET Compact Framework |
public class frmSysadminMenu Unterstützt von .NET Compact Framework |
public class frmSysadminTableSelector Unterstützt von .NET Compact Framework |
public class frmTest Unterstützt von .NET Compact Framework |
public class frmVerbindungEditor Unterstützt von .NET Compact Framework | Verbindungseditor: Verbindet 2 Domain-Tables in einer dritten Tabelle.
public class frmVertragselement Unterstützt von .NET Compact Framework |
public class frmVertragselementApplikation Unterstützt von .NET Compact Framework |
public class frmVertragselementSuche Unterstützt von .NET Compact Framework | Vertragselementsuche
public class frmVertragsereignis Unterstützt von .NET Compact Framework |
public class frmVertragskontakt Unterstützt von .NET Compact Framework |
public class frmVertragspartner Unterstützt von .NET Compact Framework | Vertragsaprtner
public class frmVertragspartnerSuche Unterstützt von .NET Compact Framework | Vertragspartnersuche
public class frmVertragsuebersicht Unterstützt von .NET Compact Framework | Vertragsübersicht: Beachten: TabControl wird von TKB.VV.Utils.clsMyTabControl überschrieben
public class frmcrreporting Unterstützt von .NET Compact Framework |
public class frmvertragsuebersicht_Suche Unterstützt von .NET Compact Framework |


AM_Auftraege_nach_Besitzer_Grafik -Klasse

For a list of all members of this type, see AM_Auftraege_nach_Besitzer_Grafik-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.AM_Auftraege_nach_Besitzer_Grafik

[Visual Basic]
Public Class AM_Auftraege_nach_Besitzer_Grafik
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

AM_Auftraege_nach_Besitzer_Grafik-Member


AM_Auftraege_nach_Besitzer_Grafik-Member

AM_Auftraege_nach_Besitzer_Grafik Übersicht

Öffentliche Konstruktoren

public constructor AM_Auftraege_nach_Besitzer_Grafik -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_Besitzer_Grafik -Klasse


AM_Auftraege_nach_Besitzer_Grafik -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik-Eigenschaften

AM_Auftraege_nach_Besitzer_Grafik Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_Besitzer_Grafik -Klasse


AM_Auftraege_nach_Besitzer_Grafik.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.ReportHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "AM_Auftraege_nach_Besitzer_Grafik.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_Besitzer_Grafik.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Besitzer_Grafik


AM_Auftraege_nach_RFCBoard_Grafik -Klasse

For a list of all members of this type, see AM_Auftraege_nach_RFCBoard_Grafik-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.AM_Auftraege_nach_RFCBoard_Grafik

[Visual Basic]
Public Class AM_Auftraege_nach_RFCBoard_Grafik
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

AM_Auftraege_nach_RFCBoard_Grafik-Member


AM_Auftraege_nach_RFCBoard_Grafik-Member

AM_Auftraege_nach_RFCBoard_Grafik Übersicht

Öffentliche Konstruktoren

public constructor AM_Auftraege_nach_RFCBoard_Grafik -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_RFCBoard_Grafik -Klasse


AM_Auftraege_nach_RFCBoard_Grafik -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik-Eigenschaften

AM_Auftraege_nach_RFCBoard_Grafik Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_RFCBoard_Grafik -Klasse


AM_Auftraege_nach_RFCBoard_Grafik.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Parameter_sqlwhwere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhwere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhwere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "AM_Auftraege_nach_RFCBoard_Grafik.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_RFCBoard_Grafik.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_RFCBoard_Grafik


AM_Auftraege_nach_Verantwortung -Klasse

For a list of all members of this type, see AM_Auftraege_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.AM_Auftraege_nach_Verantwortung

[Visual Basic]
Public Class AM_Auftraege_nach_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

AM_Auftraege_nach_Verantwortung-Member


AM_Auftraege_nach_Verantwortung-Member

AM_Auftraege_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor AM_Auftraege_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_Verantwortung -Klasse


AM_Auftraege_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung-Eigenschaften

AM_Auftraege_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

AM_Auftraege_nach_Verantwortung -Klasse


AM_Auftraege_nach_Verantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.ReportHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "AM_Auftraege_nach_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


AM_Auftraege_nach_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

AM_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Besitzer -Klasse

For a list of all members of this type, see Abgeschlossene_Auftraege_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Abgeschlossene_Auftraege_nach_Besitzer

[Visual Basic]
Public Class Abgeschlossene_Auftraege_nach_Besitzer
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Abgeschlossene_Auftraege_nach_Besitzer-Member


Abgeschlossene_Auftraege_nach_Besitzer-Member

Abgeschlossene_Auftraege_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor Abgeschlossene_Auftraege_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Besitzer -Klasse


Abgeschlossene_Auftraege_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer-Eigenschaften

Abgeschlossene_Auftraege_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Besitzer -Klasse


Abgeschlossene_Auftraege_nach_Besitzer.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Parameter_sqlwhwere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhwere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhwere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Abgeschlossene_Auftraege_nach_Besitzer.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_Besitzer.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Besitzer


Abgeschlossene_Auftraege_nach_RFCBoard -Klasse

For a list of all members of this type, see Abgeschlossene_Auftraege_nach_RFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Abgeschlossene_Auftraege_nach_RFCBoard

[Visual Basic]
Public Class Abgeschlossene_Auftraege_nach_RFCBoard
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Abgeschlossene_Auftraege_nach_RFCBoard-Member


Abgeschlossene_Auftraege_nach_RFCBoard-Member

Abgeschlossene_Auftraege_nach_RFCBoard Übersicht

Öffentliche Konstruktoren

public constructor Abgeschlossene_Auftraege_nach_RFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_RFCBoard -Klasse


Abgeschlossene_Auftraege_nach_RFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard-Eigenschaften

Abgeschlossene_Auftraege_nach_RFCBoard Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_RFCBoard -Klasse


Abgeschlossene_Auftraege_nach_RFCBoard.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Abgeschlossene_Auftraege_nach_RFCBoard.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse

For a list of all members of this type, see Abgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Abgeschlossene_Auftraege_nach_RFCBoard_A4Q

[Visual Basic]
Public Class Abgeschlossene_Auftraege_nach_RFCBoard_A4Q
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q Übersicht

Öffentliche Konstruktoren

public constructor Abgeschlossene_Auftraege_nach_RFCBoard_A4Q -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q-Eigenschaften

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_RFCBoard_A4Q.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_RFCBoard_A4Q


Abgeschlossene_Auftraege_nach_Status -Klasse

For a list of all members of this type, see Abgeschlossene_Auftraege_nach_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Abgeschlossene_Auftraege_nach_Status

[Visual Basic]
Public Class Abgeschlossene_Auftraege_nach_Status
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Abgeschlossene_Auftraege_nach_Status-Member


Abgeschlossene_Auftraege_nach_Status-Member

Abgeschlossene_Auftraege_nach_Status Übersicht

Öffentliche Konstruktoren

public constructor Abgeschlossene_Auftraege_nach_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Status -Klasse


Abgeschlossene_Auftraege_nach_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status-Eigenschaften

Abgeschlossene_Auftraege_nach_Status Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Status -Klasse


Abgeschlossene_Auftraege_nach_Status.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Parameter_sqlwhwere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhwere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhwere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Abgeschlossene_Auftraege_nach_Status.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Status.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Status


Abgeschlossene_Auftraege_nach_Verantwortung -Klasse

For a list of all members of this type, see Abgeschlossene_Auftraege_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Abgeschlossene_Auftraege_nach_Verantwortung

[Visual Basic]
Public Class Abgeschlossene_Auftraege_nach_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Abgeschlossene_Auftraege_nach_Verantwortung-Member


Abgeschlossene_Auftraege_nach_Verantwortung-Member

Abgeschlossene_Auftraege_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor Abgeschlossene_Auftraege_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Verantwortung -Klasse


Abgeschlossene_Auftraege_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung-Eigenschaften

Abgeschlossene_Auftraege_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Abgeschlossene_Auftraege_nach_Verantwortung -Klasse


Abgeschlossene_Auftraege_nach_Verantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Abgeschlossene_Auftraege_nach_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Abgeschlossene_Auftraege_nach_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Abgeschlossene_Auftraege_nach_Verantwortung


Applikationsliste_Applikation -Klasse

For a list of all members of this type, see Applikationsliste_Applikation-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_Applikation

[Visual Basic]
Public Class Applikationsliste_Applikation
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_Applikation-Member


Applikationsliste_Applikation-Member

Applikationsliste_Applikation Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_Applikation -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Applikation -Klasse


Applikationsliste_Applikation -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation-Eigenschaften

Applikationsliste_Applikation Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Applikation -Klasse


Applikationsliste_Applikation.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_Applikation.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Applikation.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Applikation


Applikationsliste_Kategorie -Klasse

For a list of all members of this type, see Applikationsliste_Kategorie-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_Kategorie

[Visual Basic]
Public Class Applikationsliste_Kategorie
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_Kategorie-Member


Applikationsliste_Kategorie-Member

Applikationsliste_Kategorie Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_Kategorie -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Kategorie -Klasse


Applikationsliste_Kategorie -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie-Eigenschaften

Applikationsliste_Kategorie Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Kategorie -Klasse


Applikationsliste_Kategorie.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_Kategorie.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_Kategorie.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Kategorie


Applikationsliste_KeyUser -Klasse

For a list of all members of this type, see Applikationsliste_KeyUser-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_KeyUser

[Visual Basic]
Public Class Applikationsliste_KeyUser
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_KeyUser-Member


Applikationsliste_KeyUser-Member

Applikationsliste_KeyUser Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_KeyUser -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_KeyUser -Klasse


Applikationsliste_KeyUser -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser-Eigenschaften

Applikationsliste_KeyUser Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_KeyUser -Klasse


Applikationsliste_KeyUser.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_KeyUser.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_KeyUser.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_KeyUser


Applikationsliste_Marktbereich -Klasse

For a list of all members of this type, see Applikationsliste_Marktbereich-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_Marktbereich

[Visual Basic]
Public Class Applikationsliste_Marktbereich
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_Marktbereich-Member


Applikationsliste_Marktbereich-Member

Applikationsliste_Marktbereich Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_Marktbereich -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Marktbereich -Klasse


Applikationsliste_Marktbereich -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich-Eigenschaften

Applikationsliste_Marktbereich Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Marktbereich -Klasse


Applikationsliste_Marktbereich.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_Marktbereich.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_Marktbereich.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Marktbereich


Applikationsliste_RFCBoard -Klasse

For a list of all members of this type, see Applikationsliste_RFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_RFCBoard

[Visual Basic]
Public Class Applikationsliste_RFCBoard
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_RFCBoard-Member


Applikationsliste_RFCBoard-Member

Applikationsliste_RFCBoard Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_RFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_RFCBoard -Klasse


Applikationsliste_RFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard-Eigenschaften

Applikationsliste_RFCBoard Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_RFCBoard -Klasse


Applikationsliste_RFCBoard.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_RFCBoard.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_RFCBoard.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_RFCBoard


Applikationsliste_TeamVerantwortung -Klasse

For a list of all members of this type, see Applikationsliste_TeamVerantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_TeamVerantwortung

[Visual Basic]
Public Class Applikationsliste_TeamVerantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_TeamVerantwortung-Member


Applikationsliste_TeamVerantwortung-Member

Applikationsliste_TeamVerantwortung Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_TeamVerantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_TeamVerantwortung -Klasse


Applikationsliste_TeamVerantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung-Eigenschaften

Applikationsliste_TeamVerantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_TeamVerantwortung -Klasse


Applikationsliste_TeamVerantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_TeamVerantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_TeamVerantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_TeamVerantwortung


Applikationsliste_Verantwortung -Klasse

For a list of all members of this type, see Applikationsliste_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsliste_Verantwortung

[Visual Basic]
Public Class Applikationsliste_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsliste_Verantwortung-Member


Applikationsliste_Verantwortung-Member

Applikationsliste_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor Applikationsliste_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Verantwortung -Klasse


Applikationsliste_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung-Eigenschaften

Applikationsliste_Verantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsliste_Verantwortung -Klasse


Applikationsliste_Verantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsliste_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsliste_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsliste_Verantwortung


Applikationsreport -Klasse

For a list of all members of this type, see Applikationsreport-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Applikationsreport

[Visual Basic]
Public Class Applikationsreport
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Applikationsreport-Member


Applikationsreport-Member

Applikationsreport Übersicht

Öffentliche Konstruktoren

public constructor Applikationsreport -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsreport -Klasse


Applikationsreport -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport-Eigenschaften

Applikationsreport Übersicht

Öffentliche Eigenschaften

public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Applikationsreport -Klasse


Applikationsreport.PageHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Applikationsreport.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Applikationsreport.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Applikationsreport


Auftragsuebersicht -Klasse

For a list of all members of this type, see Auftragsuebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Auftragsuebersicht

[Visual Basic]
Public Class Auftragsuebersicht
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Auftragsuebersicht-Member


Auftragsuebersicht-Member

Auftragsuebersicht Übersicht

Öffentliche Konstruktoren

public constructor Auftragsuebersicht -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property DetailSection2

Unterstützt von .NET Compact Framework
public property DetailSection3

Unterstützt von .NET Compact Framework
public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Auftragsuebersicht -Klasse


Auftragsuebersicht -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht-Eigenschaften

Auftragsuebersicht Übersicht

Öffentliche Eigenschaften

public property DetailSection2

Unterstützt von .NET Compact Framework
public property DetailSection3

Unterstützt von .NET Compact Framework
public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Auftragsuebersicht -Klasse


Auftragsuebersicht.DetailSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property DetailSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property DetailSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.DetailSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property DetailSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property DetailSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Auftragsuebersicht.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Auftragsuebersicht.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Auftragsuebersicht


Avaloq_Gremien -Klasse

For a list of all members of this type, see Avaloq_Gremien-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Avaloq_Gremien

[Visual Basic]
Public Class Avaloq_Gremien
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Avaloq_Gremien-Member


Avaloq_Gremien-Member

Avaloq_Gremien Übersicht

Öffentliche Konstruktoren

public constructor Avaloq_Gremien -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Avaloq_Gremien -Klasse


Avaloq_Gremien -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien-Eigenschaften

Avaloq_Gremien Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Avaloq_Gremien -Klasse


Avaloq_Gremien.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Avaloq_Gremien.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


Avaloq_Gremien.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Avaloq_Gremien


BE01 -Klasse

For a list of all members of this type, see BE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.BE01

[Visual Basic]
Public Class BE01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

BE01-Member


BE01-Member

BE01 Übersicht

Öffentliche Konstruktoren

public constructor BE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

BE01 -Klasse


BE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01-Eigenschaften

BE01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

BE01 -Klasse


BE01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "BE01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


BE01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

BE01


CachedAM_Auftraege_nach_Besitzer_Grafik -Klasse

For a list of all members of this type, see CachedAM_Auftraege_nach_Besitzer_Grafik-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAM_Auftraege_nach_Besitzer_Grafik

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAM_Auftraege_nach_Besitzer_Grafik
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAM_Auftraege_nach_Besitzer_Grafik-Member


CachedAM_Auftraege_nach_Besitzer_Grafik-Member

CachedAM_Auftraege_nach_Besitzer_Grafik Übersicht

Öffentliche Konstruktoren

public constructor CachedAM_Auftraege_nach_Besitzer_Grafik -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Besitzer_Grafik -Klasse


CachedAM_Auftraege_nach_Besitzer_Grafik -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_Besitzer_Grafik-Eigenschaften

CachedAM_Auftraege_nach_Besitzer_Grafik Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Besitzer_Grafik -Klasse


CachedAM_Auftraege_nach_Besitzer_Grafik.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_Besitzer_Grafik.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_Besitzer_Grafik.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_Besitzer_Grafik-Methoden

CachedAM_Auftraege_nach_Besitzer_Grafik Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Besitzer_Grafik -Klasse


CachedAM_Auftraege_nach_Besitzer_Grafik.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As AM_Auftraege_nach_Besitzer_Grafik = New AM_Auftraege_nach_Besitzer_Grafik
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_Besitzer_Grafik.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Besitzer_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik -Klasse

For a list of all members of this type, see CachedAM_Auftraege_nach_RFCBoard_Grafik-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAM_Auftraege_nach_RFCBoard_Grafik

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAM_Auftraege_nach_RFCBoard_Grafik
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAM_Auftraege_nach_RFCBoard_Grafik-Member


CachedAM_Auftraege_nach_RFCBoard_Grafik-Member

CachedAM_Auftraege_nach_RFCBoard_Grafik Übersicht

Öffentliche Konstruktoren

public constructor CachedAM_Auftraege_nach_RFCBoard_Grafik -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_RFCBoard_Grafik -Klasse


CachedAM_Auftraege_nach_RFCBoard_Grafik -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik-Eigenschaften

CachedAM_Auftraege_nach_RFCBoard_Grafik Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_RFCBoard_Grafik -Klasse


CachedAM_Auftraege_nach_RFCBoard_Grafik.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik-Methoden

CachedAM_Auftraege_nach_RFCBoard_Grafik Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_RFCBoard_Grafik -Klasse


CachedAM_Auftraege_nach_RFCBoard_Grafik.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As AM_Auftraege_nach_RFCBoard_Grafik = New AM_Auftraege_nach_RFCBoard_Grafik
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_RFCBoard_Grafik.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_RFCBoard_Grafik


CachedAM_Auftraege_nach_Verantwortung -Klasse

For a list of all members of this type, see CachedAM_Auftraege_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAM_Auftraege_nach_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAM_Auftraege_nach_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAM_Auftraege_nach_Verantwortung-Member


CachedAM_Auftraege_nach_Verantwortung-Member

CachedAM_Auftraege_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedAM_Auftraege_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Verantwortung -Klasse


CachedAM_Auftraege_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAM_Auftraege_nach_Verantwortung-Eigenschaften

CachedAM_Auftraege_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Verantwortung -Klasse


CachedAM_Auftraege_nach_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAM_Auftraege_nach_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAM_Auftraege_nach_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAM_Auftraege_nach_Verantwortung-Methoden

CachedAM_Auftraege_nach_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAM_Auftraege_nach_Verantwortung -Klasse


CachedAM_Auftraege_nach_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As AM_Auftraege_nach_Verantwortung = New AM_Auftraege_nach_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAM_Auftraege_nach_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAM_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Besitzer -Klasse

For a list of all members of this type, see CachedAbgeschlossene_Auftraege_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAbgeschlossene_Auftraege_nach_Besitzer

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAbgeschlossene_Auftraege_nach_Besitzer
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAbgeschlossene_Auftraege_nach_Besitzer-Member


CachedAbgeschlossene_Auftraege_nach_Besitzer-Member

CachedAbgeschlossene_Auftraege_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor CachedAbgeschlossene_Auftraege_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Besitzer -Klasse


CachedAbgeschlossene_Auftraege_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_Besitzer-Eigenschaften

CachedAbgeschlossene_Auftraege_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Besitzer -Klasse


CachedAbgeschlossene_Auftraege_nach_Besitzer.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_Besitzer.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_Besitzer.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_Besitzer-Methoden

CachedAbgeschlossene_Auftraege_nach_Besitzer Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Besitzer -Klasse


CachedAbgeschlossene_Auftraege_nach_Besitzer.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Abgeschlossene_Auftraege_nach_Besitzer = New Abgeschlossene_Auftraege_nach_Besitzer
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_Besitzer.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Besitzer


CachedAbgeschlossene_Auftraege_nach_RFCBoard -Klasse

For a list of all members of this type, see CachedAbgeschlossene_Auftraege_nach_RFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAbgeschlossene_Auftraege_nach_RFCBoard

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAbgeschlossene_Auftraege_nach_RFCBoard
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAbgeschlossene_Auftraege_nach_RFCBoard-Member


CachedAbgeschlossene_Auftraege_nach_RFCBoard-Member

CachedAbgeschlossene_Auftraege_nach_RFCBoard Übersicht

Öffentliche Konstruktoren

public constructor CachedAbgeschlossene_Auftraege_nach_RFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard-Eigenschaften

CachedAbgeschlossene_Auftraege_nach_RFCBoard Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard-Methoden

CachedAbgeschlossene_Auftraege_nach_RFCBoard Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Abgeschlossene_Auftraege_nach_RFCBoard = New Abgeschlossene_Auftraege_nach_RFCBoard
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse

For a list of all members of this type, see CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q-Member

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q Übersicht

Öffentliche Konstruktoren

public constructor CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q-Eigenschaften

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q-Methoden

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q -Klasse


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Abgeschlossene_Auftraege_nach_RFCBoard_A4Q = New Abgeschlossene_Auftraege_nach_RFCBoard_A4Q
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_RFCBoard_A4Q


CachedAbgeschlossene_Auftraege_nach_Status -Klasse

For a list of all members of this type, see CachedAbgeschlossene_Auftraege_nach_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAbgeschlossene_Auftraege_nach_Status

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAbgeschlossene_Auftraege_nach_Status
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAbgeschlossene_Auftraege_nach_Status-Member


CachedAbgeschlossene_Auftraege_nach_Status-Member

CachedAbgeschlossene_Auftraege_nach_Status Übersicht

Öffentliche Konstruktoren

public constructor CachedAbgeschlossene_Auftraege_nach_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Status -Klasse


CachedAbgeschlossene_Auftraege_nach_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Status-Eigenschaften

CachedAbgeschlossene_Auftraege_nach_Status Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Status -Klasse


CachedAbgeschlossene_Auftraege_nach_Status.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Status.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Status.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Status-Methoden

CachedAbgeschlossene_Auftraege_nach_Status Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Status -Klasse


CachedAbgeschlossene_Auftraege_nach_Status.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Abgeschlossene_Auftraege_nach_Status = New Abgeschlossene_Auftraege_nach_Status
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Status.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Status


CachedAbgeschlossene_Auftraege_nach_Verantwortung -Klasse

For a list of all members of this type, see CachedAbgeschlossene_Auftraege_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAbgeschlossene_Auftraege_nach_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAbgeschlossene_Auftraege_nach_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAbgeschlossene_Auftraege_nach_Verantwortung-Member


CachedAbgeschlossene_Auftraege_nach_Verantwortung-Member

CachedAbgeschlossene_Auftraege_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedAbgeschlossene_Auftraege_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Verantwortung -Klasse


CachedAbgeschlossene_Auftraege_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Verantwortung-Eigenschaften

CachedAbgeschlossene_Auftraege_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Verantwortung -Klasse


CachedAbgeschlossene_Auftraege_nach_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Verantwortung-Methoden

CachedAbgeschlossene_Auftraege_nach_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAbgeschlossene_Auftraege_nach_Verantwortung -Klasse


CachedAbgeschlossene_Auftraege_nach_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Abgeschlossene_Auftraege_nach_Verantwortung = New Abgeschlossene_Auftraege_nach_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedAbgeschlossene_Auftraege_nach_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAbgeschlossene_Auftraege_nach_Verantwortung


CachedApplikationsliste_Applikation -Klasse

For a list of all members of this type, see CachedApplikationsliste_Applikation-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_Applikation

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_Applikation
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_Applikation-Member


CachedApplikationsliste_Applikation-Member

CachedApplikationsliste_Applikation Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_Applikation -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Applikation -Klasse


CachedApplikationsliste_Applikation -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Applikation-Eigenschaften

CachedApplikationsliste_Applikation Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Applikation -Klasse


CachedApplikationsliste_Applikation.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Applikation.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Applikation.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Applikation-Methoden

CachedApplikationsliste_Applikation Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Applikation -Klasse


CachedApplikationsliste_Applikation.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_Applikation = New Applikationsliste_Applikation
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Applikation.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Applikation


CachedApplikationsliste_Kategorie -Klasse

For a list of all members of this type, see CachedApplikationsliste_Kategorie-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_Kategorie

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_Kategorie
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_Kategorie-Member


CachedApplikationsliste_Kategorie-Member

CachedApplikationsliste_Kategorie Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_Kategorie -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Kategorie -Klasse


CachedApplikationsliste_Kategorie -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_Kategorie-Eigenschaften

CachedApplikationsliste_Kategorie Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Kategorie -Klasse


CachedApplikationsliste_Kategorie.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_Kategorie.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_Kategorie.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_Kategorie-Methoden

CachedApplikationsliste_Kategorie Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Kategorie -Klasse


CachedApplikationsliste_Kategorie.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_Kategorie = New Applikationsliste_Kategorie
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_Kategorie.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Kategorie


CachedApplikationsliste_KeyUser -Klasse

For a list of all members of this type, see CachedApplikationsliste_KeyUser-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_KeyUser

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_KeyUser
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_KeyUser-Member


CachedApplikationsliste_KeyUser-Member

CachedApplikationsliste_KeyUser Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_KeyUser -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_KeyUser -Klasse


CachedApplikationsliste_KeyUser -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_KeyUser-Eigenschaften

CachedApplikationsliste_KeyUser Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_KeyUser -Klasse


CachedApplikationsliste_KeyUser.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_KeyUser.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_KeyUser.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_KeyUser-Methoden

CachedApplikationsliste_KeyUser Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_KeyUser -Klasse


CachedApplikationsliste_KeyUser.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_KeyUser = New Applikationsliste_KeyUser
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_KeyUser.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_KeyUser


CachedApplikationsliste_Marktbereich -Klasse

For a list of all members of this type, see CachedApplikationsliste_Marktbereich-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_Marktbereich

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_Marktbereich
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_Marktbereich-Member


CachedApplikationsliste_Marktbereich-Member

CachedApplikationsliste_Marktbereich Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_Marktbereich -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Marktbereich -Klasse


CachedApplikationsliste_Marktbereich -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_Marktbereich-Eigenschaften

CachedApplikationsliste_Marktbereich Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Marktbereich -Klasse


CachedApplikationsliste_Marktbereich.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_Marktbereich.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_Marktbereich.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_Marktbereich-Methoden

CachedApplikationsliste_Marktbereich Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Marktbereich -Klasse


CachedApplikationsliste_Marktbereich.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_Marktbereich = New Applikationsliste_Marktbereich
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_Marktbereich.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Marktbereich


CachedApplikationsliste_RFCBoard -Klasse

For a list of all members of this type, see CachedApplikationsliste_RFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_RFCBoard

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_RFCBoard
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_RFCBoard-Member


CachedApplikationsliste_RFCBoard-Member

CachedApplikationsliste_RFCBoard Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_RFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_RFCBoard -Klasse


CachedApplikationsliste_RFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_RFCBoard-Eigenschaften

CachedApplikationsliste_RFCBoard Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_RFCBoard -Klasse


CachedApplikationsliste_RFCBoard.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_RFCBoard.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_RFCBoard.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_RFCBoard-Methoden

CachedApplikationsliste_RFCBoard Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_RFCBoard -Klasse


CachedApplikationsliste_RFCBoard.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_RFCBoard = New Applikationsliste_RFCBoard
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_RFCBoard.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_RFCBoard


CachedApplikationsliste_TeamVerantwortung -Klasse

For a list of all members of this type, see CachedApplikationsliste_TeamVerantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_TeamVerantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_TeamVerantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_TeamVerantwortung-Member


CachedApplikationsliste_TeamVerantwortung-Member

CachedApplikationsliste_TeamVerantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_TeamVerantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_TeamVerantwortung -Klasse


CachedApplikationsliste_TeamVerantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_TeamVerantwortung-Eigenschaften

CachedApplikationsliste_TeamVerantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_TeamVerantwortung -Klasse


CachedApplikationsliste_TeamVerantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_TeamVerantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_TeamVerantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_TeamVerantwortung-Methoden

CachedApplikationsliste_TeamVerantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_TeamVerantwortung -Klasse


CachedApplikationsliste_TeamVerantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_TeamVerantwortung = New Applikationsliste_TeamVerantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_TeamVerantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_TeamVerantwortung


CachedApplikationsliste_Verantwortung -Klasse

For a list of all members of this type, see CachedApplikationsliste_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsliste_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsliste_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsliste_Verantwortung-Member


CachedApplikationsliste_Verantwortung-Member

CachedApplikationsliste_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsliste_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Verantwortung -Klasse


CachedApplikationsliste_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsliste_Verantwortung-Eigenschaften

CachedApplikationsliste_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Verantwortung -Klasse


CachedApplikationsliste_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsliste_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsliste_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsliste_Verantwortung-Methoden

CachedApplikationsliste_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsliste_Verantwortung -Klasse


CachedApplikationsliste_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsliste_Verantwortung = New Applikationsliste_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsliste_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsliste_Verantwortung


CachedApplikationsreport -Klasse

For a list of all members of this type, see CachedApplikationsreport-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedApplikationsreport

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedApplikationsreport
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedApplikationsreport-Member


CachedApplikationsreport-Member

CachedApplikationsreport Übersicht

Öffentliche Konstruktoren

public constructor CachedApplikationsreport -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsreport -Klasse


CachedApplikationsreport -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedApplikationsreport-Eigenschaften

CachedApplikationsreport Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedApplikationsreport -Klasse


CachedApplikationsreport.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedApplikationsreport.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedApplikationsreport.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedApplikationsreport-Methoden

CachedApplikationsreport Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedApplikationsreport -Klasse


CachedApplikationsreport.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Applikationsreport = New Applikationsreport
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedApplikationsreport.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedApplikationsreport


CachedAuftragsuebersicht -Klasse

For a list of all members of this type, see CachedAuftragsuebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAuftragsuebersicht

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAuftragsuebersicht
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAuftragsuebersicht-Member


CachedAuftragsuebersicht-Member

CachedAuftragsuebersicht Übersicht

Öffentliche Konstruktoren

public constructor CachedAuftragsuebersicht -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAuftragsuebersicht -Klasse


CachedAuftragsuebersicht -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAuftragsuebersicht-Eigenschaften

CachedAuftragsuebersicht Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAuftragsuebersicht -Klasse


CachedAuftragsuebersicht.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAuftragsuebersicht.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAuftragsuebersicht.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAuftragsuebersicht-Methoden

CachedAuftragsuebersicht Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAuftragsuebersicht -Klasse


CachedAuftragsuebersicht.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Auftragsuebersicht = New Auftragsuebersicht
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAuftragsuebersicht.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAuftragsuebersicht


CachedAvaloq_Gremien -Klasse

For a list of all members of this type, see CachedAvaloq_Gremien-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedAvaloq_Gremien

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedAvaloq_Gremien
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedAvaloq_Gremien-Member


CachedAvaloq_Gremien-Member

CachedAvaloq_Gremien Übersicht

Öffentliche Konstruktoren

public constructor CachedAvaloq_Gremien -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAvaloq_Gremien -Klasse


CachedAvaloq_Gremien -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedAvaloq_Gremien-Eigenschaften

CachedAvaloq_Gremien Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedAvaloq_Gremien -Klasse


CachedAvaloq_Gremien.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedAvaloq_Gremien.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedAvaloq_Gremien.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedAvaloq_Gremien-Methoden

CachedAvaloq_Gremien Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedAvaloq_Gremien -Klasse


CachedAvaloq_Gremien.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Avaloq_Gremien = New Avaloq_Gremien
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedAvaloq_Gremien.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedAvaloq_Gremien


CachedBE01 -Klasse

For a list of all members of this type, see CachedBE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedBE01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedBE01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedBE01-Member


CachedBE01-Member

CachedBE01 Übersicht

Öffentliche Konstruktoren

public constructor CachedBE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedBE01 -Klasse


CachedBE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedBE01-Eigenschaften

CachedBE01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedBE01 -Klasse


CachedBE01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedBE01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedBE01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedBE01-Methoden

CachedBE01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedBE01 -Klasse


CachedBE01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As BE01 = New BE01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedBE01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedBE01


CachedCrystalReport1 -Klasse

For a list of all members of this type, see CachedCrystalReport1-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedCrystalReport1

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedCrystalReport1
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedCrystalReport1-Member


CachedCrystalReport1-Member

CachedCrystalReport1 Übersicht

Öffentliche Konstruktoren

public constructor CachedCrystalReport1 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedCrystalReport1 -Klasse


CachedCrystalReport1 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport1-Eigenschaften

CachedCrystalReport1 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedCrystalReport1 -Klasse


CachedCrystalReport1.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport1.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport1.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport1-Methoden

CachedCrystalReport1 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedCrystalReport1 -Klasse


CachedCrystalReport1.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As CrystalReport1 = New CrystalReport1
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport1.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport1


CachedCrystalReport2 -Klasse

For a list of all members of this type, see CachedCrystalReport2-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedCrystalReport2

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedCrystalReport2
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedCrystalReport2-Member


CachedCrystalReport2-Member

CachedCrystalReport2 Übersicht

Öffentliche Konstruktoren

public constructor CachedCrystalReport2 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedCrystalReport2 -Klasse


CachedCrystalReport2 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedCrystalReport2-Eigenschaften

CachedCrystalReport2 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedCrystalReport2 -Klasse


CachedCrystalReport2.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedCrystalReport2.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedCrystalReport2.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedCrystalReport2-Methoden

CachedCrystalReport2 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedCrystalReport2 -Klasse


CachedCrystalReport2.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As CrystalReport2 = New CrystalReport2
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedCrystalReport2.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedCrystalReport2


CachedEA01 -Klasse

For a list of all members of this type, see CachedEA01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedEA01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedEA01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedEA01-Member


CachedEA01-Member

CachedEA01 Übersicht

Öffentliche Konstruktoren

public constructor CachedEA01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEA01 -Klasse


CachedEA01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA01-Eigenschaften

CachedEA01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedEA01 -Klasse


CachedEA01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA01-Methoden

CachedEA01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEA01 -Klasse


CachedEA01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As EA01 = New EA01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA01


CachedEA02 -Klasse

For a list of all members of this type, see CachedEA02-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedEA02

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedEA02
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedEA02-Member


CachedEA02-Member

CachedEA02 Übersicht

Öffentliche Konstruktoren

public constructor CachedEA02 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEA02 -Klasse


CachedEA02 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEA02-Eigenschaften

CachedEA02 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedEA02 -Klasse


CachedEA02.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEA02.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEA02.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEA02-Methoden

CachedEA02 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEA02 -Klasse


CachedEA02.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As EA02 = New EA02
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEA02.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEA02


CachedEO01 -Klasse

For a list of all members of this type, see CachedEO01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedEO01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedEO01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedEO01-Member


CachedEO01-Member

CachedEO01 Übersicht

Öffentliche Konstruktoren

public constructor CachedEO01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEO01 -Klasse


CachedEO01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedEO01-Eigenschaften

CachedEO01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedEO01 -Klasse


CachedEO01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedEO01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedEO01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedEO01-Methoden

CachedEO01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedEO01 -Klasse


CachedEO01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As EO01 = New EO01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedEO01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedEO01


CachedGeschlossene_IN_nach_Kategorien -Klasse

For a list of all members of this type, see CachedGeschlossene_IN_nach_Kategorien-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedGeschlossene_IN_nach_Kategorien

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedGeschlossene_IN_nach_Kategorien
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedGeschlossene_IN_nach_Kategorien-Member


CachedGeschlossene_IN_nach_Kategorien-Member

CachedGeschlossene_IN_nach_Kategorien Übersicht

Öffentliche Konstruktoren

public constructor CachedGeschlossene_IN_nach_Kategorien -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedGeschlossene_IN_nach_Kategorien -Klasse


CachedGeschlossene_IN_nach_Kategorien -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedGeschlossene_IN_nach_Kategorien-Eigenschaften

CachedGeschlossene_IN_nach_Kategorien Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedGeschlossene_IN_nach_Kategorien -Klasse


CachedGeschlossene_IN_nach_Kategorien.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedGeschlossene_IN_nach_Kategorien.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedGeschlossene_IN_nach_Kategorien.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedGeschlossene_IN_nach_Kategorien-Methoden

CachedGeschlossene_IN_nach_Kategorien Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedGeschlossene_IN_nach_Kategorien -Klasse


CachedGeschlossene_IN_nach_Kategorien.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Geschlossene_IN_nach_Kategorien = New Geschlossene_IN_nach_Kategorien
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedGeschlossene_IN_nach_Kategorien.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedGeschlossene_IN_nach_Kategorien


CachedIGA -Klasse

For a list of all members of this type, see CachedIGA-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIGA

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIGA
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIGA-Member


CachedIGA-Member

CachedIGA Übersicht

Öffentliche Konstruktoren

public constructor CachedIGA -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIGA -Klasse


CachedIGA -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIGA-Eigenschaften

CachedIGA Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIGA -Klasse


CachedIGA.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIGA.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIGA.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIGA-Methoden

CachedIGA Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIGA -Klasse


CachedIGA.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As IGA = New IGA
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIGA.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIGA


CachedIN_AVQ_Remedy -Klasse

For a list of all members of this type, see CachedIN_AVQ_Remedy-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIN_AVQ_Remedy

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIN_AVQ_Remedy
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIN_AVQ_Remedy-Member


CachedIN_AVQ_Remedy-Member

CachedIN_AVQ_Remedy Übersicht

Öffentliche Konstruktoren

public constructor CachedIN_AVQ_Remedy -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIN_AVQ_Remedy -Klasse


CachedIN_AVQ_Remedy -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedIN_AVQ_Remedy-Eigenschaften

CachedIN_AVQ_Remedy Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIN_AVQ_Remedy -Klasse


CachedIN_AVQ_Remedy.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedIN_AVQ_Remedy.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedIN_AVQ_Remedy.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedIN_AVQ_Remedy-Methoden

CachedIN_AVQ_Remedy Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIN_AVQ_Remedy -Klasse


CachedIN_AVQ_Remedy.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As IN_AVQ_Remedy = New IN_AVQ_Remedy
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedIN_AVQ_Remedy.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIN_AVQ_Remedy


CachedITSM_Berechtigungen -Klasse

For a list of all members of this type, see CachedITSM_Berechtigungen-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedITSM_Berechtigungen

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedITSM_Berechtigungen
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedITSM_Berechtigungen-Member


CachedITSM_Berechtigungen-Member

CachedITSM_Berechtigungen Übersicht

Öffentliche Konstruktoren

public constructor CachedITSM_Berechtigungen -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedITSM_Berechtigungen -Klasse


CachedITSM_Berechtigungen -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedITSM_Berechtigungen-Eigenschaften

CachedITSM_Berechtigungen Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedITSM_Berechtigungen -Klasse


CachedITSM_Berechtigungen.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedITSM_Berechtigungen.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedITSM_Berechtigungen.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedITSM_Berechtigungen-Methoden

CachedITSM_Berechtigungen Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedITSM_Berechtigungen -Klasse


CachedITSM_Berechtigungen.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As ITSM_Berechtigungen = New ITSM_Berechtigungen
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedITSM_Berechtigungen.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedITSM_Berechtigungen


CachedIncident_Geloest -Klasse

For a list of all members of this type, see CachedIncident_Geloest-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_Geloest

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_Geloest
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_Geloest-Member


CachedIncident_Geloest-Member

CachedIncident_Geloest Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_Geloest -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest -Klasse


CachedIncident_Geloest -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest-Eigenschaften

CachedIncident_Geloest Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_Geloest -Klasse


CachedIncident_Geloest.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest-Methoden

CachedIncident_Geloest Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest -Klasse


CachedIncident_Geloest.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_Geloest = New Incident_Geloest
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest


CachedIncident_Geloest_Total -Klasse

For a list of all members of this type, see CachedIncident_Geloest_Total-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_Geloest_Total

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_Geloest_Total
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_Geloest_Total-Member


CachedIncident_Geloest_Total-Member

CachedIncident_Geloest_Total Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_Geloest_Total -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total -Klasse


CachedIncident_Geloest_Total -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total-Eigenschaften

CachedIncident_Geloest_Total Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total -Klasse


CachedIncident_Geloest_Total.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total-Methoden

CachedIncident_Geloest_Total Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total -Klasse


CachedIncident_Geloest_Total.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_Geloest_Total = New Incident_Geloest_Total
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total


CachedIncident_Geloest_Total_Prod -Klasse

For a list of all members of this type, see CachedIncident_Geloest_Total_Prod-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_Geloest_Total_Prod

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_Geloest_Total_Prod
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_Geloest_Total_Prod-Member


CachedIncident_Geloest_Total_Prod-Member

CachedIncident_Geloest_Total_Prod Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_Geloest_Total_Prod -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total_Prod -Klasse


CachedIncident_Geloest_Total_Prod -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_Total_Prod-Eigenschaften

CachedIncident_Geloest_Total_Prod Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total_Prod -Klasse


CachedIncident_Geloest_Total_Prod.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_Total_Prod.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_Total_Prod.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_Total_Prod-Methoden

CachedIncident_Geloest_Total_Prod Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_Total_Prod -Klasse


CachedIncident_Geloest_Total_Prod.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_Geloest_Total_Prod = New Incident_Geloest_Total_Prod
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_Total_Prod.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_Total_Prod


CachedIncident_Geloest_nach_Ma -Klasse

For a list of all members of this type, see CachedIncident_Geloest_nach_Ma-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_Geloest_nach_Ma

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_Geloest_nach_Ma
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_Geloest_nach_Ma-Member


CachedIncident_Geloest_nach_Ma-Member

CachedIncident_Geloest_nach_Ma Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_Geloest_nach_Ma -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma -Klasse


CachedIncident_Geloest_nach_Ma -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma-Eigenschaften

CachedIncident_Geloest_nach_Ma Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma -Klasse


CachedIncident_Geloest_nach_Ma.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma-Methoden

CachedIncident_Geloest_nach_Ma Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma -Klasse


CachedIncident_Geloest_nach_Ma.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_Geloest_nach_Ma = New Incident_Geloest_nach_Ma
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma


CachedIncident_Geloest_nach_Ma_App -Klasse

For a list of all members of this type, see CachedIncident_Geloest_nach_Ma_App-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_Geloest_nach_Ma_App

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_Geloest_nach_Ma_App
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_Geloest_nach_Ma_App-Member


CachedIncident_Geloest_nach_Ma_App-Member

CachedIncident_Geloest_nach_Ma_App Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_Geloest_nach_Ma_App -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma_App -Klasse


CachedIncident_Geloest_nach_Ma_App -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_Geloest_nach_Ma_App-Eigenschaften

CachedIncident_Geloest_nach_Ma_App Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma_App -Klasse


CachedIncident_Geloest_nach_Ma_App.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_Geloest_nach_Ma_App.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_Geloest_nach_Ma_App.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_Geloest_nach_Ma_App-Methoden

CachedIncident_Geloest_nach_Ma_App Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_Geloest_nach_Ma_App -Klasse


CachedIncident_Geloest_nach_Ma_App.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_Geloest_nach_Ma_App = New Incident_Geloest_nach_Ma_App
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_Geloest_nach_Ma_App.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_Geloest_nach_Ma_App


CachedIncident_nach_Besitzer -Klasse

For a list of all members of this type, see CachedIncident_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_nach_Besitzer

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_nach_Besitzer
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_nach_Besitzer-Member


CachedIncident_nach_Besitzer-Member

CachedIncident_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Besitzer -Klasse


CachedIncident_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Besitzer-Eigenschaften

CachedIncident_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_nach_Besitzer -Klasse


CachedIncident_nach_Besitzer.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Besitzer.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Besitzer.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Besitzer-Methoden

CachedIncident_nach_Besitzer Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Besitzer -Klasse


CachedIncident_nach_Besitzer.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_nach_Besitzer = New Incident_nach_Besitzer
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Besitzer.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Besitzer


CachedIncident_nach_Status -Klasse

For a list of all members of this type, see CachedIncident_nach_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_nach_Status

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_nach_Status
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_nach_Status-Member


CachedIncident_nach_Status-Member

CachedIncident_nach_Status Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_nach_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Status -Klasse


CachedIncident_nach_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Status-Eigenschaften

CachedIncident_nach_Status Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_nach_Status -Klasse


CachedIncident_nach_Status.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Status.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Status.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Status-Methoden

CachedIncident_nach_Status Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Status -Klasse


CachedIncident_nach_Status.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_nach_Status = New Incident_nach_Status
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Status.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Status


CachedIncident_nach_Verantwortung -Klasse

For a list of all members of this type, see CachedIncident_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedIncident_nach_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedIncident_nach_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedIncident_nach_Verantwortung-Member


CachedIncident_nach_Verantwortung-Member

CachedIncident_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedIncident_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Verantwortung -Klasse


CachedIncident_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedIncident_nach_Verantwortung-Eigenschaften

CachedIncident_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedIncident_nach_Verantwortung -Klasse


CachedIncident_nach_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedIncident_nach_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedIncident_nach_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedIncident_nach_Verantwortung-Methoden

CachedIncident_nach_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedIncident_nach_Verantwortung -Klasse


CachedIncident_nach_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Incident_nach_Verantwortung = New Incident_nach_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedIncident_nach_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedIncident_nach_Verantwortung


CachedPE01 -Klasse

For a list of all members of this type, see CachedPE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedPE01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedPE01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedPE01-Member


CachedPE01-Member

CachedPE01 Übersicht

Öffentliche Konstruktoren

public constructor CachedPE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedPE01 -Klasse


CachedPE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedPE01-Eigenschaften

CachedPE01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedPE01 -Klasse


CachedPE01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedPE01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedPE01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedPE01-Methoden

CachedPE01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedPE01 -Klasse


CachedPE01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As PE01 = New PE01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedPE01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedPE01


CachedQU01 -Klasse

For a list of all members of this type, see CachedQU01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedQU01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedQU01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedQU01-Member


CachedQU01-Member

CachedQU01 Übersicht

Öffentliche Konstruktoren

public constructor CachedQU01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedQU01 -Klasse


CachedQU01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedQU01-Eigenschaften

CachedQU01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedQU01 -Klasse


CachedQU01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedQU01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedQU01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedQU01-Methoden

CachedQU01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedQU01 -Klasse


CachedQU01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As QU01 = New QU01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedQU01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedQU01


CachedRFCBoard -Klasse

For a list of all members of this type, see CachedRFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedRFCBoard

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedRFCBoard
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedRFCBoard-Member


CachedRFCBoard-Member

CachedRFCBoard Übersicht

Öffentliche Konstruktoren

public constructor CachedRFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBoard -Klasse


CachedRFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBoard-Eigenschaften

CachedRFCBoard Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedRFCBoard -Klasse


CachedRFCBoard.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBoard.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBoard.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBoard-Methoden

CachedRFCBoard Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBoard -Klasse


CachedRFCBoard.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As RFCBoard = New RFCBoard
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBoard.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBoard


CachedRFCBudget -Klasse

For a list of all members of this type, see CachedRFCBudget-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedRFCBudget

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedRFCBudget
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedRFCBudget-Member


CachedRFCBudget-Member

CachedRFCBudget Übersicht

Öffentliche Konstruktoren

public constructor CachedRFCBudget -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBudget -Klasse


CachedRFCBudget -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget-Eigenschaften

CachedRFCBudget Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedRFCBudget -Klasse


CachedRFCBudget.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget-Methoden

CachedRFCBudget Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBudget -Klasse


CachedRFCBudget.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As RFCBudget = New RFCBudget
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget


CachedRFCBudget_Uebersicht -Klasse

For a list of all members of this type, see CachedRFCBudget_Uebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedRFCBudget_Uebersicht

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedRFCBudget_Uebersicht
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedRFCBudget_Uebersicht-Member


CachedRFCBudget_Uebersicht-Member

CachedRFCBudget_Uebersicht Übersicht

Öffentliche Konstruktoren

public constructor CachedRFCBudget_Uebersicht -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBudget_Uebersicht -Klasse


CachedRFCBudget_Uebersicht -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedRFCBudget_Uebersicht-Eigenschaften

CachedRFCBudget_Uebersicht Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedRFCBudget_Uebersicht -Klasse


CachedRFCBudget_Uebersicht.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedRFCBudget_Uebersicht.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedRFCBudget_Uebersicht.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedRFCBudget_Uebersicht-Methoden

CachedRFCBudget_Uebersicht Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedRFCBudget_Uebersicht -Klasse


CachedRFCBudget_Uebersicht.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As RFCBudget_Uebersicht = New RFCBudget_Uebersicht
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedRFCBudget_Uebersicht.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedRFCBudget_Uebersicht


CachedStatistik_Applikationen_Nach_Verantwortung -Klasse

For a list of all members of this type, see CachedStatistik_Applikationen_Nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedStatistik_Applikationen_Nach_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedStatistik_Applikationen_Nach_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedStatistik_Applikationen_Nach_Verantwortung-Member


CachedStatistik_Applikationen_Nach_Verantwortung-Member

CachedStatistik_Applikationen_Nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedStatistik_Applikationen_Nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedStatistik_Applikationen_Nach_Verantwortung -Klasse


CachedStatistik_Applikationen_Nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedStatistik_Applikationen_Nach_Verantwortung-Eigenschaften

CachedStatistik_Applikationen_Nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedStatistik_Applikationen_Nach_Verantwortung -Klasse


CachedStatistik_Applikationen_Nach_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedStatistik_Applikationen_Nach_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedStatistik_Applikationen_Nach_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedStatistik_Applikationen_Nach_Verantwortung-Methoden

CachedStatistik_Applikationen_Nach_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedStatistik_Applikationen_Nach_Verantwortung -Klasse


CachedStatistik_Applikationen_Nach_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Statistik_Applikationen_Nach_Verantwortung = New Statistik_Applikationen_Nach_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedStatistik_Applikationen_Nach_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedStatistik_Applikationen_Nach_Verantwortung


CachedTE01 -Klasse

For a list of all members of this type, see CachedTE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedTE01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedTE01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedTE01-Member


CachedTE01-Member

CachedTE01 Übersicht

Öffentliche Konstruktoren

public constructor CachedTE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedTE01 -Klasse


CachedTE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedTE01-Eigenschaften

CachedTE01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedTE01 -Klasse


CachedTE01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedTE01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedTE01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedTE01-Methoden

CachedTE01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedTE01 -Klasse


CachedTE01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As TE01 = New TE01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedTE01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedTE01


CachedUM01 -Klasse

For a list of all members of this type, see CachedUM01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedUM01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedUM01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedUM01-Member


CachedUM01-Member

CachedUM01 Übersicht

Öffentliche Konstruktoren

public constructor CachedUM01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedUM01 -Klasse


CachedUM01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedUM01-Eigenschaften

CachedUM01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedUM01 -Klasse


CachedUM01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedUM01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedUM01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedUM01-Methoden

CachedUM01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedUM01 -Klasse


CachedUM01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As UM01 = New UM01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedUM01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedUM01


CachedVI01 -Klasse

For a list of all members of this type, see CachedVI01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedVI01

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedVI01
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedVI01-Member


CachedVI01-Member

CachedVI01 Übersicht

Öffentliche Konstruktoren

public constructor CachedVI01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedVI01 -Klasse


CachedVI01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVI01-Eigenschaften

CachedVI01 Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedVI01 -Klasse


CachedVI01.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVI01.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVI01.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVI01-Methoden

CachedVI01 Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedVI01 -Klasse


CachedVI01.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As VI01 = New VI01
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVI01.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVI01


CachedVertragselement_SecurityLevel -Klasse

For a list of all members of this type, see CachedVertragselement_SecurityLevel-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedVertragselement_SecurityLevel

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedVertragselement_SecurityLevel
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedVertragselement_SecurityLevel-Member


CachedVertragselement_SecurityLevel-Member

CachedVertragselement_SecurityLevel Übersicht

Öffentliche Konstruktoren

public constructor CachedVertragselement_SecurityLevel -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedVertragselement_SecurityLevel -Klasse


CachedVertragselement_SecurityLevel -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


CachedVertragselement_SecurityLevel-Eigenschaften

CachedVertragselement_SecurityLevel Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedVertragselement_SecurityLevel -Klasse


CachedVertragselement_SecurityLevel.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


CachedVertragselement_SecurityLevel.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


CachedVertragselement_SecurityLevel.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


CachedVertragselement_SecurityLevel-Methoden

CachedVertragselement_SecurityLevel Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedVertragselement_SecurityLevel -Klasse


CachedVertragselement_SecurityLevel.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Vertragselement_SecurityLevel = New Vertragselement_SecurityLevel
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


CachedVertragselement_SecurityLevel.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedVertragselement_SecurityLevel


Cachedit_koordinatoren -Klasse

For a list of all members of this type, see Cachedit_koordinatoren-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.Cachedit_koordinatoren

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class Cachedit_koordinatoren
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Cachedit_koordinatoren-Member


Cachedit_koordinatoren-Member

Cachedit_koordinatoren Übersicht

Öffentliche Konstruktoren

public constructor Cachedit_koordinatoren -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

Cachedit_koordinatoren -Klasse


Cachedit_koordinatoren -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedit_koordinatoren-Eigenschaften

Cachedit_koordinatoren Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Cachedit_koordinatoren -Klasse


Cachedit_koordinatoren.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedit_koordinatoren.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedit_koordinatoren.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedit_koordinatoren-Methoden

Cachedit_koordinatoren Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

Cachedit_koordinatoren -Klasse


Cachedit_koordinatoren.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As it_koordinatoren = New it_koordinatoren
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedit_koordinatoren.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedit_koordinatoren


Cachedrfc_budget_total -Klasse

For a list of all members of this type, see Cachedrfc_budget_total-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.Cachedrfc_budget_total

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class Cachedrfc_budget_total
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Cachedrfc_budget_total-Member


Cachedrfc_budget_total-Member

Cachedrfc_budget_total Übersicht

Öffentliche Konstruktoren

public constructor Cachedrfc_budget_total -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

Cachedrfc_budget_total -Klasse


Cachedrfc_budget_total -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


Cachedrfc_budget_total-Eigenschaften

Cachedrfc_budget_total Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Cachedrfc_budget_total -Klasse


Cachedrfc_budget_total.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


Cachedrfc_budget_total.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


Cachedrfc_budget_total.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


Cachedrfc_budget_total-Methoden

Cachedrfc_budget_total Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

Cachedrfc_budget_total -Klasse


Cachedrfc_budget_total.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As rfc_budget_total = New rfc_budget_total
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


Cachedrfc_budget_total.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Cachedrfc_budget_total


CachedÜbersicht_AM_Aufträge_RFC_Status -Klasse

For a list of all members of this type, see CachedÜbersicht_AM_Aufträge_RFC_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedÜbersicht_AM_Aufträge_RFC_Status

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedÜbersicht_AM_Aufträge_RFC_Status
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedÜbersicht_AM_Aufträge_RFC_Status-Member


CachedÜbersicht_AM_Aufträge_RFC_Status-Member

CachedÜbersicht_AM_Aufträge_RFC_Status Übersicht

Öffentliche Konstruktoren

public constructor CachedÜbersicht_AM_Aufträge_RFC_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status-Eigenschaften

CachedÜbersicht_AM_Aufträge_RFC_Status Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status-Methoden

CachedÜbersicht_AM_Aufträge_RFC_Status Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Übersicht_AM_Aufträge_RFC_Status = New Übersicht_AM_Aufträge_RFC_Status
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Klasse

For a list of all members of this type, see CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität-Member


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität-Member

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität Übersicht

Öffentliche Konstruktoren

public constructor CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität-Eigenschaften

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität-Methoden

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität -Klasse


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Übersicht_AM_Aufträge_RFC_Status_Priorität = New Übersicht_AM_Aufträge_RFC_Status_Priorität
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_AM_Aufträge_RFC_Status_Priorität


CachedÜbersicht_Incident_nach_Besitzer -Klasse

For a list of all members of this type, see CachedÜbersicht_Incident_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedÜbersicht_Incident_nach_Besitzer

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedÜbersicht_Incident_nach_Besitzer
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedÜbersicht_Incident_nach_Besitzer-Member


CachedÜbersicht_Incident_nach_Besitzer-Member

CachedÜbersicht_Incident_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor CachedÜbersicht_Incident_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Besitzer -Klasse


CachedÜbersicht_Incident_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Besitzer-Eigenschaften

CachedÜbersicht_Incident_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Besitzer -Klasse


CachedÜbersicht_Incident_nach_Besitzer.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Besitzer.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Besitzer.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Besitzer-Methoden

CachedÜbersicht_Incident_nach_Besitzer Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Besitzer -Klasse


CachedÜbersicht_Incident_nach_Besitzer.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Übersicht_Incident_nach_Besitzer = New Übersicht_Incident_nach_Besitzer
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Besitzer.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Besitzer


CachedÜbersicht_Incident_nach_Verantwortung -Klasse

For a list of all members of this type, see CachedÜbersicht_Incident_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Vertragsverwaltung.CachedÜbersicht_Incident_nach_Verantwortung

[Visual Basic]
<System.Drawing.ToolboxBitmap(GetType(CrystalDecisions.[Shared].ExportOptions), "report.bmp")> _
Public Class CachedÜbersicht_Incident_nach_Verantwortung
    Inherits Component

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CachedÜbersicht_Incident_nach_Verantwortung-Member


CachedÜbersicht_Incident_nach_Verantwortung-Member

CachedÜbersicht_Incident_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor CachedÜbersicht_Incident_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Verantwortung -Klasse


CachedÜbersicht_Incident_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


CachedÜbersicht_Incident_nach_Verantwortung-Eigenschaften

CachedÜbersicht_Incident_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property CacheTimeOut

Unterstützt von .NET Compact Framework
public property IsCacheable

Unterstützt von .NET Compact Framework
public property ShareDBLogonInfo

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Verantwortung -Klasse


CachedÜbersicht_Incident_nach_Verantwortung.CacheTimeOut -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property CacheTimeOut() As System.TimeSpan Implements CrystalDecisions.ReportSource.ICachedReport.CacheTimeOut
        Get
            Return CachedReportConstants.DEFAULT_TIMEOUT
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


CachedÜbersicht_Incident_nach_Verantwortung.IsCacheable -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property IsCacheable() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.IsCacheable
        Get
            Return true
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


CachedÜbersicht_Incident_nach_Verantwortung.ShareDBLogonInfo -Eigenschaft

Quellcode

[Visual Basic]
    Public Overridable Property ShareDBLogonInfo() As Boolean Implements CrystalDecisions.ReportSource.ICachedReport.ShareDBLogonInfo
        Get
            Return false
        End Get
        Set
            '
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


CachedÜbersicht_Incident_nach_Verantwortung-Methoden

CachedÜbersicht_Incident_nach_Verantwortung Übersicht

Öffentliche Methoden

public method CreateReport

Unterstützt von .NET Compact Framework
public method GetCustomizedCacheKey

Unterstützt von .NET Compact Framework

CachedÜbersicht_Incident_nach_Verantwortung -Klasse


CachedÜbersicht_Incident_nach_Verantwortung.CreateReport -Methode

Quellcode

[Visual Basic]
    Public Overridable Function CreateReport() As CrystalDecisions.CrystalReports.Engine.ReportDocument Implements CrystalDecisions.ReportSource.ICachedReport.CreateReport
        Dim rpt As Übersicht_Incident_nach_Verantwortung = New Übersicht_Incident_nach_Verantwortung
        rpt.Site = Me.Site
        Return rpt
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


CachedÜbersicht_Incident_nach_Verantwortung.GetCustomizedCacheKey -Methode

Parameter

request

Quellcode

[Visual Basic]
    Public Overridable Function GetCustomizedCacheKey(ByVal request As RequestContext) As String Implements CrystalDecisions.ReportSource.ICachedReport.GetCustomizedCacheKey
        Dim key As [String] = Nothing
        '// The following is the code used to generate the default
        '// cache key for caching report jobs in the ASP.NET Cache.
        '// Feel free to modify this code to suit your needs.
        '// Returning key == null causes the default cache key to
        '// be generated.
        '
        'key = RequestContext.BuildCompleteCacheKey(
        '    request,
        '    null,       // sReportFilename
        '    this.GetType(),
        '    this.ShareDBLogonInfo );
        Return key
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CachedÜbersicht_Incident_nach_Verantwortung


ComboBoxIconItem -Klasse

For a list of all members of this type, see ComboBoxIconItem-Member.

System.Object
Vertragsverwaltung.ComboBoxIconItem

[Visual Basic]
Friend Class ComboBoxIconItem

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboBoxIconItem-Member


ComboBoxIconItem-Member

ComboBoxIconItem Übersicht

Öffentliche Konstruktoren

public constructor ComboBoxIconItem -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property ImageIndex

Unterstützt von .NET Compact Framework
public property Text

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method ToString

Unterstützt von .NET Compact Framework

Felder

private field _imageIndex

Unterstützt von .NET Compact Framework
private field _text

Unterstützt von .NET Compact Framework

ComboBoxIconItem -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void ComboBoxIconItem();

[Visual Basic] Public Sub New(String)
[C#] public System.Void ComboBoxIconItem(string);

[Visual Basic] Public Sub New(String, Integer)
[C#] public System.Void ComboBoxIconItem(string, int);

ComboBoxIconItem


ComboBoxIconItem-Eigenschaften

ComboBoxIconItem Übersicht

Öffentliche Eigenschaften

public property ImageIndex

Unterstützt von .NET Compact Framework
public property Text

Unterstützt von .NET Compact Framework

ComboBoxIconItem -Klasse


ComboBoxIconItem.ImageIndex -Eigenschaft

[Visual Basic]
Public Property ImageIndex() As Integer

Quellcode

[Visual Basic]
    Property ImageIndex() As Integer
        Get
            Return _imageIndex
        End Get

        Set(ByVal Value As Integer)
            _imageIndex = Value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


ComboBoxIconItem.Text -Eigenschaft

[Visual Basic]
Public Property Text() As String

Quellcode

[Visual Basic]
    Property Text() As String
        Get
            Return _text
        End Get
        Set(ByVal Value As String)
            _text = Value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


ComboBoxIconItem-Methoden

ComboBoxIconItem Übersicht

Öffentliche Methoden

public method ToString

Unterstützt von .NET Compact Framework

ComboBoxIconItem -Klasse


ComboBoxIconItem.ToString -Methode

[Visual Basic]
Public Overrides Function ToString() As String

Quellcode

[Visual Basic]
    Public Overrides Function ToString() As String
        Return _text
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


ComboBoxIconItem-Felder

ComboBoxIconItem Übersicht

Felder

private field _imageIndex

Unterstützt von .NET Compact Framework
private field _text

Unterstützt von .NET Compact Framework

ComboBoxIconItem -Klasse


_imageIndex -Feld

[Visual Basic]
Private _imageIndex As Integer

Quellcode

[Visual Basic]
    Private _imageIndex As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


_text -Feld

[Visual Basic]
Private _text As String

Quellcode

[Visual Basic]
    Private _text As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


ComboBoxTree_TreeView -Klasse

For a list of all members of this type, see ComboBoxTree_TreeView-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TreeView
Vertragsverwaltung.ComboBoxTree_TreeView

[Visual Basic]
Friend Class ComboBoxTree_TreeView
    Inherits TreeView

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboBoxTree_TreeView-Member


ComboBoxTree_TreeView-Member

ComboBoxTree_TreeView Übersicht

Geschützte Methoden

protected method IsInputKey

Unterstützt von .NET Compact Framework

ComboBoxTree_TreeView -Klasse


ComboBoxTree_TreeView-Methoden

ComboBoxTree_TreeView Übersicht

Geschützte Methoden

protected method IsInputKey

Unterstützt von .NET Compact Framework

ComboBoxTree_TreeView -Klasse


ComboBoxTree_TreeView.IsInputKey -Methode

[Visual Basic]
Protected Overrides Function IsInputKey( _
   ByVal keyData As Keys _
) As Boolean

Parameter

keyData

Quellcode

[Visual Basic]
    Protected Overrides Function IsInputKey(ByVal keyData As System.Windows.Forms.Keys) As Boolean
        If (keyData = Keys.Escape) OrElse (keyData = Keys.Enter) Then
            Return True
        Else
            Return MyBase.IsInputKey(keyData)
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_TreeView


ComboIcon -Klasse

For a list of all members of this type, see ComboIcon-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Vertragsverwaltung.ComboIcon

[Visual Basic]
Public Class ComboIcon
    Inherits ComboBox

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboIcon-Member


ComboIcon-Member

ComboIcon Übersicht

Öffentliche Konstruktoren

public constructor ComboIcon -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property ImageList

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method OnDrawItem

Unterstützt von .NET Compact Framework

Felder

private field ListaImg1

Unterstützt von .NET Compact Framework

ComboIcon -Klasse


ComboIcon -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        DrawMode = DrawMode.OwnerDrawFixed
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboIcon


ComboIcon-Eigenschaften

ComboIcon Übersicht

Öffentliche Eigenschaften

public property ImageList

Unterstützt von .NET Compact Framework

ComboIcon -Klasse


ComboIcon.ImageList -Eigenschaft

[Visual Basic]
Public Property ImageList() As ImageList

Quellcode

[Visual Basic]
    Public Property ImageList() As ImageList
        Get
            Return ListaImg1
        End Get
        Set(ByVal ListaImagem As ImageList)
            ListaImg1 = ListaImagem
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboIcon


ComboIcon-Methoden

ComboIcon Übersicht

Geschützte Methoden

protected method OnDrawItem

Unterstützt von .NET Compact Framework

ComboIcon -Klasse


ComboIcon.OnDrawItem -Methode

[Visual Basic]
Protected Overrides Sub OnDrawItem( _
   ByVal e As DrawItemEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
    Protected Overrides Sub OnDrawItem(ByVal e As System.Windows.Forms.DrawItemEventArgs)
        e.DrawBackground()
        e.DrawFocusRectangle()

        Dim item As New ComboBoxIconItem
        Dim imageSize As New Size
        imageSize = ListaImg1.ImageSize

        Dim bounds As New Rectangle
        bounds = e.Bounds

        Try
            item = Me.Items(e.Index)
            If (item.ImageIndex <> -1) Then
                Me.ImageList.Draw(e.Graphics, bounds.Left, bounds.Top, item.ImageIndex)
                e.Graphics.DrawString(item.Text, e.Font, New SolidBrush(e.ForeColor), bounds.Left + imageSize.Width, bounds.Top)
            Else
                e.Graphics.DrawString(item.Text, e.Font, New SolidBrush(e.ForeColor), bounds.Left, bounds.Top)
            End If
        Catch ex As Exception
            If (e.Index <> -1) Then
                e.Graphics.DrawString(Items(e.Index).ToString(), e.Font, New SolidBrush(e.ForeColor), bounds.Left, bounds.Top)
            Else
                e.Graphics.DrawString(Text, e.Font, New SolidBrush(e.ForeColor), bounds.Left, bounds.Top)
            End If

        End Try
        MyBase.OnDrawItem(e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboIcon


ComboIcon-Felder

ComboIcon Übersicht

Felder

private field ListaImg1

Unterstützt von .NET Compact Framework

ComboIcon -Klasse


ListaImg1 -Feld

[Visual Basic]
Private ListaImg1 As ImageList

Quellcode

[Visual Basic]
    Private ListaImg1 As New ImageList

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboIcon


CrystalReport1 -Klasse

For a list of all members of this type, see CrystalReport1-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.CrystalReport1

[Visual Basic]
Public Class CrystalReport1
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CrystalReport1-Member


CrystalReport1-Member

CrystalReport1 Übersicht

Öffentliche Konstruktoren

public constructor CrystalReport1 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

CrystalReport1 -Klasse


CrystalReport1 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1-Eigenschaften

CrystalReport1 Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

CrystalReport1 -Klasse


CrystalReport1.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "CrystalReport1.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport1.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport1


CrystalReport2 -Klasse

For a list of all members of this type, see CrystalReport2-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.CrystalReport2

[Visual Basic]
Public Class CrystalReport2
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

CrystalReport2-Member


CrystalReport2-Member

CrystalReport2 Übersicht

Öffentliche Konstruktoren

public constructor CrystalReport2 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

CrystalReport2 -Klasse


CrystalReport2 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2-Eigenschaften

CrystalReport2 Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

CrystalReport2 -Klasse


CrystalReport2.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "CrystalReport2.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


CrystalReport2.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

CrystalReport2


EA01 -Klasse

For a list of all members of this type, see EA01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.EA01

[Visual Basic]
Public Class EA01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

EA01-Member


EA01-Member

EA01 Übersicht

Öffentliche Konstruktoren

public constructor EA01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EA01 -Klasse


EA01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01-Eigenschaften

EA01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EA01 -Klasse


EA01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "EA01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA01


EA02 -Klasse

For a list of all members of this type, see EA02-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.EA02

[Visual Basic]
Public Class EA02
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

EA02-Member


EA02-Member

EA02 Übersicht

Öffentliche Konstruktoren

public constructor EA02 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EA02 -Klasse


EA02 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02-Eigenschaften

EA02 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EA02 -Klasse


EA02.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.PageHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "EA02.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EA02.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EA02


EO01 -Klasse

For a list of all members of this type, see EO01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.EO01

[Visual Basic]
Public Class EO01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

EO01-Member


EO01-Member

EO01 Übersicht

Öffentliche Konstruktoren

public constructor EO01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EO01 -Klasse


EO01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01-Eigenschaften

EO01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

EO01 -Klasse


EO01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "EO01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


EO01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

EO01


Geschlossene_IN_nach_Kategorien -Klasse

For a list of all members of this type, see Geschlossene_IN_nach_Kategorien-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Geschlossene_IN_nach_Kategorien

[Visual Basic]
Public Class Geschlossene_IN_nach_Kategorien
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Geschlossene_IN_nach_Kategorien-Member


Geschlossene_IN_nach_Kategorien-Member

Geschlossene_IN_nach_Kategorien Übersicht

Öffentliche Konstruktoren

public constructor Geschlossene_IN_nach_Kategorien -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Geschlossene_IN_nach_Kategorien -Klasse


Geschlossene_IN_nach_Kategorien -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien-Eigenschaften

Geschlossene_IN_nach_Kategorien Übersicht

Öffentliche Eigenschaften

public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Geschlossene_IN_nach_Kategorien -Klasse


Geschlossene_IN_nach_Kategorien.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Geschlossene_IN_nach_Kategorien.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


Geschlossene_IN_nach_Kategorien.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Geschlossene_IN_nach_Kategorien


IGA -Klasse

For a list of all members of this type, see IGA-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.IGA

[Visual Basic]
Public Class IGA
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

IGA-Member


IGA-Member

IGA Übersicht

Öffentliche Konstruktoren

public constructor IGA -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

IGA -Klasse


IGA -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA-Eigenschaften

IGA Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

IGA -Klasse


IGA.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "IGA.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IGA.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IGA


IN_AVQ_Remedy -Klasse

For a list of all members of this type, see IN_AVQ_Remedy-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.IN_AVQ_Remedy

[Visual Basic]
Public Class IN_AVQ_Remedy
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

IN_AVQ_Remedy-Member


IN_AVQ_Remedy-Member

IN_AVQ_Remedy Übersicht

Öffentliche Konstruktoren

public constructor IN_AVQ_Remedy -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

IN_AVQ_Remedy -Klasse


IN_AVQ_Remedy -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy-Eigenschaften

IN_AVQ_Remedy Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

IN_AVQ_Remedy -Klasse


IN_AVQ_Remedy.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "IN_AVQ_Remedy.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


IN_AVQ_Remedy.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

IN_AVQ_Remedy


ITSM_Berechtigungen -Klasse

For a list of all members of this type, see ITSM_Berechtigungen-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.ITSM_Berechtigungen

[Visual Basic]
Public Class ITSM_Berechtigungen
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ITSM_Berechtigungen-Member


ITSM_Berechtigungen-Member

ITSM_Berechtigungen Übersicht

Öffentliche Konstruktoren

public constructor ITSM_Berechtigungen -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property ReportFooterSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

ITSM_Berechtigungen -Klasse


ITSM_Berechtigungen -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen-Eigenschaften

ITSM_Berechtigungen Übersicht

Öffentliche Eigenschaften

public property PageHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property ReportFooterSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

ITSM_Berechtigungen -Klasse


ITSM_Berechtigungen.PageHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.ReportFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "ITSM-Berechtigungen.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


ITSM_Berechtigungen.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ITSM_Berechtigungen


Incident_Geloest -Klasse

For a list of all members of this type, see Incident_Geloest-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_Geloest

[Visual Basic]
Public Class Incident_Geloest
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_Geloest-Member


Incident_Geloest-Member

Incident_Geloest Übersicht

Öffentliche Konstruktoren

public constructor Incident_Geloest -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest -Klasse


Incident_Geloest -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest-Eigenschaften

Incident_Geloest Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest -Klasse


Incident_Geloest.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_Geloest.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest


Incident_Geloest_Total -Klasse

For a list of all members of this type, see Incident_Geloest_Total-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_Geloest_Total

[Visual Basic]
Public Class Incident_Geloest_Total
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_Geloest_Total-Member


Incident_Geloest_Total-Member

Incident_Geloest_Total Übersicht

Öffentliche Konstruktoren

public constructor Incident_Geloest_Total -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_Total -Klasse


Incident_Geloest_Total -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total-Eigenschaften

Incident_Geloest_Total Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_Total -Klasse


Incident_Geloest_Total.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.ReportHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_Geloest_Total.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total


Incident_Geloest_Total_Prod -Klasse

For a list of all members of this type, see Incident_Geloest_Total_Prod-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_Geloest_Total_Prod

[Visual Basic]
Public Class Incident_Geloest_Total_Prod
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_Geloest_Total_Prod-Member


Incident_Geloest_Total_Prod-Member

Incident_Geloest_Total_Prod Übersicht

Öffentliche Konstruktoren

public constructor Incident_Geloest_Total_Prod -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_Total_Prod -Klasse


Incident_Geloest_Total_Prod -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod-Eigenschaften

Incident_Geloest_Total_Prod Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_Total_Prod -Klasse


Incident_Geloest_Total_Prod.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.ReportHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_Geloest_Total_Prod.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_Total_Prod.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_Total_Prod


Incident_Geloest_nach_Ma -Klasse

For a list of all members of this type, see Incident_Geloest_nach_Ma-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_Geloest_nach_Ma

[Visual Basic]
Public Class Incident_Geloest_nach_Ma
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_Geloest_nach_Ma-Member


Incident_Geloest_nach_Ma-Member

Incident_Geloest_nach_Ma Übersicht

Öffentliche Konstruktoren

public constructor Incident_Geloest_nach_Ma -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_nach_Ma -Klasse


Incident_Geloest_nach_Ma -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma-Eigenschaften

Incident_Geloest_nach_Ma Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_nach_Ma -Klasse


Incident_Geloest_nach_Ma.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_Geloest_nach_Ma.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma


Incident_Geloest_nach_Ma_App -Klasse

For a list of all members of this type, see Incident_Geloest_nach_Ma_App-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_Geloest_nach_Ma_App

[Visual Basic]
Public Class Incident_Geloest_nach_Ma_App
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_Geloest_nach_Ma_App-Member


Incident_Geloest_nach_Ma_App-Member

Incident_Geloest_nach_Ma_App Übersicht

Öffentliche Konstruktoren

public constructor Incident_Geloest_nach_Ma_App -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_nach_Ma_App -Klasse


Incident_Geloest_nach_Ma_App -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App-Eigenschaften

Incident_Geloest_nach_Ma_App Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_Geloest_nach_Ma_App -Klasse


Incident_Geloest_nach_Ma_App.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_Geloest_nach_Ma_App.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_Geloest_nach_Ma_App.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_Geloest_nach_Ma_App


Incident_nach_Besitzer -Klasse

For a list of all members of this type, see Incident_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_nach_Besitzer

[Visual Basic]
Public Class Incident_nach_Besitzer
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_nach_Besitzer-Member


Incident_nach_Besitzer-Member

Incident_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor Incident_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Besitzer -Klasse


Incident_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer-Eigenschaften

Incident_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Besitzer -Klasse


Incident_nach_Besitzer.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_nach_Besitzer.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Besitzer.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Besitzer


Incident_nach_Status -Klasse

For a list of all members of this type, see Incident_nach_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_nach_Status

[Visual Basic]
Public Class Incident_nach_Status
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_nach_Status-Member


Incident_nach_Status-Member

Incident_nach_Status Übersicht

Öffentliche Konstruktoren

public constructor Incident_nach_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Status -Klasse


Incident_nach_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status-Eigenschaften

Incident_nach_Status Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Status -Klasse


Incident_nach_Status.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_nach_Status.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Status.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Status


Incident_nach_Verantwortung -Klasse

For a list of all members of this type, see Incident_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Incident_nach_Verantwortung

[Visual Basic]
Public Class Incident_nach_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Incident_nach_Verantwortung-Member


Incident_nach_Verantwortung-Member

Incident_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor Incident_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Verantwortung -Klasse


Incident_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung-Eigenschaften

Incident_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Incident_nach_Verantwortung -Klasse


Incident_nach_Verantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Incident_nach_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


Incident_nach_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Incident_nach_Verantwortung


MyGenericEventHandler -Klasse

For a list of all members of this type, see MyGenericEventHandler-Member.

System.Object
Vertragsverwaltung.MyGenericEventHandler

[Visual Basic]
Public Class MyGenericEventHandler

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyGenericEventHandler-Member


MyGenericEventHandler-Member

MyGenericEventHandler Übersicht

Öffentliche Methoden

public method Aktivitaet_Closed Unterstützt von .NET Compact Framework | Event Formular Aktivitaet Closed absetzen
public method Aktivitaet_Geloescht Unterstützt von .NET Compact Framework |
public method Dokumente_Closed Unterstützt von .NET Compact Framework | Event Formular Dokumente Closed absetzen
public method Dokumente_Geloscht Unterstützt von .NET Compact Framework |
public method Edit_Tooltip Unterstützt von .NET Compact Framework |
public method Ereignis_Closed Unterstützt von .NET Compact Framework | Event Formular Ereignis Closed absetzen
public method Ereignis_Geloescht Unterstützt von .NET Compact Framework |
public method Keine_Leistung_Selektiert Unterstützt von .NET Compact Framework |
public method Kontakte_Closed Unterstützt von .NET Compact Framework | Event Formular Kuendigungsfrist Closed absetzen
public method Kontakte_Geloescht Unterstützt von .NET Compact Framework |
public method Kuendigungsfrist_Closed Unterstützt von .NET Compact Framework | Event Formular Kontakte Closed absetzen
public method Kuendigungsfrist_Geloescht Unterstützt von .NET Compact Framework |
public method Leistung_Selektiert Unterstützt von .NET Compact Framework |
public method Pendenz_Closed Unterstützt von .NET Compact Framework | Event Formular Pendenz Closed absetzen
public method Pendenz_Geloescht Unterstützt von .NET Compact Framework | Event Pendent Deleted absetzen
public method Refernzvertrag_Closed Unterstützt von .NET Compact Framework | Event Formular Refernzvertrag Closed absetzen
public method Refernzvertrag_Geloescht Unterstützt von .NET Compact Framework |
public method ReleaseLobuchClosed Unterstützt von .NET Compact Framework |
public method Service_Geloescht Unterstützt von .NET Compact Framework |
public method Services_Closed Unterstützt von .NET Compact Framework | Event Formular Services Closed absetzen
public method Vertragsapplikation_Closed Unterstützt von .NET Compact Framework | Event Formular Pendenz Closed absetzen
public method Vertragsapplikation_Geloescht Unterstützt von .NET Compact Framework | Event Pendent Deleted absetzen
public method Vertragselement_Closed Unterstützt von .NET Compact Framework | Event Formular "Vertragselement" Closed absetzen
public method Vertragspartner_Closed Unterstützt von .NET Compact Framework | Event Formular Vertragsparter Closed absetzen

Öffentliche Ereignisse

public event Aktivitaet_Deleted

Unterstützt von .NET Compact Framework
public event Dokument_Deleted

Unterstützt von .NET Compact Framework
public event Ereignis_Deleted

Unterstützt von .NET Compact Framework
public event FormularAktivitaet_Cloesd

Unterstützt von .NET Compact Framework
public event FormularDokument_Closed

Unterstützt von .NET Compact Framework
public event FormularEreignis_Closed

Unterstützt von .NET Compact Framework
public event FormularKontakte_Closed

Unterstützt von .NET Compact Framework
public event FormularKuendigungsfrist_Closed

Unterstützt von .NET Compact Framework
public event FormularPendenz_Closed

Unterstützt von .NET Compact Framework
public event FormularReferenzvertrag_Closed

Unterstützt von .NET Compact Framework
public event FormularReleaseLogbuchClosed

Unterstützt von .NET Compact Framework
public event FormularServices_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragelement_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragsapplikation_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragspartner_Closed

Unterstützt von .NET Compact Framework
public event KeineLeistungSelektiert

Unterstützt von .NET Compact Framework
public event Kontakt_Deleted

Unterstützt von .NET Compact Framework
public event Kuendigungsfrist_Deleted

Unterstützt von .NET Compact Framework
public event LeistungSelektiert

Unterstützt von .NET Compact Framework
public event Pendenz_Deleted

Unterstützt von .NET Compact Framework
public event Referenzvertrag_Deleted

Unterstützt von .NET Compact Framework
public event Service_Deleted

Unterstützt von .NET Compact Framework
public event Set_ToolTip

Unterstützt von .NET Compact Framework
public event Update_Uebersicht

Unterstützt von .NET Compact Framework
public event Vertragsapplikation_Deleted

Unterstützt von .NET Compact Framework

MyGenericEventHandler -Klasse


MyGenericEventHandler-Methoden

MyGenericEventHandler Übersicht

Öffentliche Methoden

public method Aktivitaet_Closed Unterstützt von .NET Compact Framework | Event Formular Aktivitaet Closed absetzen
public method Aktivitaet_Geloescht Unterstützt von .NET Compact Framework |
public method Dokumente_Closed Unterstützt von .NET Compact Framework | Event Formular Dokumente Closed absetzen
public method Dokumente_Geloscht Unterstützt von .NET Compact Framework |
public method Edit_Tooltip Unterstützt von .NET Compact Framework |
public method Ereignis_Closed Unterstützt von .NET Compact Framework | Event Formular Ereignis Closed absetzen
public method Ereignis_Geloescht Unterstützt von .NET Compact Framework |
public method Keine_Leistung_Selektiert Unterstützt von .NET Compact Framework |
public method Kontakte_Closed Unterstützt von .NET Compact Framework | Event Formular Kuendigungsfrist Closed absetzen
public method Kontakte_Geloescht Unterstützt von .NET Compact Framework |
public method Kuendigungsfrist_Closed Unterstützt von .NET Compact Framework | Event Formular Kontakte Closed absetzen
public method Kuendigungsfrist_Geloescht Unterstützt von .NET Compact Framework |
public method Leistung_Selektiert Unterstützt von .NET Compact Framework |
public method Pendenz_Closed Unterstützt von .NET Compact Framework | Event Formular Pendenz Closed absetzen
public method Pendenz_Geloescht Unterstützt von .NET Compact Framework | Event Pendent Deleted absetzen
public method Refernzvertrag_Closed Unterstützt von .NET Compact Framework | Event Formular Refernzvertrag Closed absetzen
public method Refernzvertrag_Geloescht Unterstützt von .NET Compact Framework |
public method ReleaseLobuchClosed Unterstützt von .NET Compact Framework |
public method Service_Geloescht Unterstützt von .NET Compact Framework |
public method Services_Closed Unterstützt von .NET Compact Framework | Event Formular Services Closed absetzen
public method Vertragsapplikation_Closed Unterstützt von .NET Compact Framework | Event Formular Pendenz Closed absetzen
public method Vertragsapplikation_Geloescht Unterstützt von .NET Compact Framework | Event Pendent Deleted absetzen
public method Vertragselement_Closed Unterstützt von .NET Compact Framework | Event Formular "Vertragselement" Closed absetzen
public method Vertragspartner_Closed Unterstützt von .NET Compact Framework | Event Formular Vertragsparter Closed absetzen

MyGenericEventHandler -Klasse


MyGenericEventHandler.Aktivitaet_Closed -Methode

Event Formular Aktivitaet Closed absetzen

[Visual Basic]
Public Function Aktivitaet_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Aktivitaet_Closed()
        RaiseEvent FormularAktivitaet_Cloesd()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Aktivitaet_Geloescht -Methode

[Visual Basic]
Public Function Aktivitaet_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Aktivitaet_Geloescht()
        RaiseEvent Aktivitaet_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Dokumente_Closed -Methode

Event Formular Dokumente Closed absetzen

[Visual Basic]
Public Function Dokumente_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Dokumente_Closed()
        RaiseEvent FormularDokument_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Dokumente_Geloscht -Methode

[Visual Basic]
Public Function Dokumente_Geloscht() As Object

Quellcode

[Visual Basic]
    Public Function Dokumente_Geloscht()
        RaiseEvent Dokument_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Edit_Tooltip -Methode

[Visual Basic]
Public Function Edit_Tooltip( _
   ByVal formname As String, _
   ByVal ctlname As String _
) As Object

Parameter

formname
ctlname

Quellcode

[Visual Basic]
    Public Function Edit_Tooltip(ByVal formname As String, ByVal ctlname As String)
        RaiseEvent Set_ToolTip(formname, ctlname)
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Ereignis_Closed -Methode

Event Formular Ereignis Closed absetzen

[Visual Basic]
Public Function Ereignis_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Ereignis_Closed()
        RaiseEvent FormularEreignis_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Ereignis_Geloescht -Methode

[Visual Basic]
Public Function Ereignis_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Ereignis_Geloescht()
        RaiseEvent Ereignis_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Keine_Leistung_Selektiert -Methode

[Visual Basic]
Public Function Keine_Leistung_Selektiert( _
   ByVal Vertragsleistungsnr As Integer _
) As Object

Parameter

Vertragsleistungsnr

Quellcode

[Visual Basic]
    Public Function Keine_Leistung_Selektiert(ByVal Vertragsleistungsnr As Integer)
        RaiseEvent KeineLeistungSelektiert(Vertragsleistungsnr)
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Kontakte_Closed -Methode

Event Formular Kuendigungsfrist Closed absetzen

[Visual Basic]
Public Function Kontakte_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Kontakte_Closed()
        RaiseEvent FormularKontakte_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Kontakte_Geloescht -Methode

[Visual Basic]
Public Function Kontakte_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Kontakte_Geloescht()
        RaiseEvent Kontakt_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Kuendigungsfrist_Closed -Methode

Event Formular Kontakte Closed absetzen

[Visual Basic]
Public Function Kuendigungsfrist_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Kuendigungsfrist_Closed()
        RaiseEvent FormularKuendigungsfrist_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Kuendigungsfrist_Geloescht -Methode

[Visual Basic]
Public Function Kuendigungsfrist_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Kuendigungsfrist_Geloescht()
        RaiseEvent Kuendigungsfrist_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Leistung_Selektiert -Methode

[Visual Basic]
Public Function Leistung_Selektiert( _
   ByVal Vertragsleistungsnr As Integer, _
   ByVal Servicekatalognr As Integer _
) As Object

Parameter

Vertragsleistungsnr
Servicekatalognr

Quellcode

[Visual Basic]
    Public Function Leistung_Selektiert(ByVal Vertragsleistungsnr As Integer, ByVal Servicekatalognr As Integer)
        RaiseEvent LeistungSelektiert(Vertragsleistungsnr, Servicekatalognr)
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Pendenz_Closed -Methode

Event Formular Pendenz Closed absetzen

[Visual Basic]
Public Function Pendenz_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Pendenz_Closed()
        RaiseEvent FormularPendenz_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Pendenz_Geloescht -Methode

Event Pendent Deleted absetzen

[Visual Basic]
Public Function Pendenz_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Pendenz_Geloescht()
        RaiseEvent Pendenz_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Refernzvertrag_Closed -Methode

Event Formular Refernzvertrag Closed absetzen

[Visual Basic]
Public Function Refernzvertrag_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Refernzvertrag_Closed()
        RaiseEvent FormularReferenzvertrag_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Refernzvertrag_Geloescht -Methode

[Visual Basic]
Public Function Refernzvertrag_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Refernzvertrag_Geloescht()
        RaiseEvent Referenzvertrag_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.ReleaseLobuchClosed -Methode

[Visual Basic]
Public Function ReleaseLobuchClosed() As Object

Quellcode

[Visual Basic]
    Public Function ReleaseLobuchClosed()
        RaiseEvent FormularReleaseLogbuchClosed()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Service_Geloescht -Methode

[Visual Basic]
Public Function Service_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Service_Geloescht()
        RaiseEvent Service_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Services_Closed -Methode

Event Formular Services Closed absetzen

[Visual Basic]
Public Function Services_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Services_Closed()
        RaiseEvent FormularServices_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Vertragsapplikation_Closed -Methode

Event Formular Pendenz Closed absetzen

[Visual Basic]
Public Function Vertragsapplikation_Closed() As Object

Quellcode

[Visual Basic]
    Public Function Vertragsapplikation_Closed()
        RaiseEvent FormularVertragsapplikation_Closed()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Vertragsapplikation_Geloescht -Methode

Event Pendent Deleted absetzen

[Visual Basic]
Public Function Vertragsapplikation_Geloescht() As Object

Quellcode

[Visual Basic]
    Public Function Vertragsapplikation_Geloescht()
        RaiseEvent Vertragsapplikation_Deleted()
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Vertragselement_Closed -Methode

Event Formular "Vertragselement" Closed absetzen

[Visual Basic]
Public Function Vertragselement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

Vertragspartnernr
Vertragselementnr

Quellcode

[Visual Basic]
    Public Function Vertragselement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer)
        RaiseEvent FormularVertragelement_Closed(Vertragspartnernr, Vertragselementnr)
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler.Vertragspartner_Closed -Methode

Event Formular Vertragsparter Closed absetzen

[Visual Basic]
Public Function Vertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
) As Object

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
    Public Function Vertragspartner_Closed(ByVal Vertragspartnernr As Integer)
        RaiseEvent FormularVertragspartner_Closed(Vertragspartnernr)
        RaiseEvent Update_Uebersicht()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


MyGenericEventHandler-Ereignisse

MyGenericEventHandler Übersicht

Öffentliche Ereignisse

public event Aktivitaet_Deleted

Unterstützt von .NET Compact Framework
public event Dokument_Deleted

Unterstützt von .NET Compact Framework
public event Ereignis_Deleted

Unterstützt von .NET Compact Framework
public event FormularAktivitaet_Cloesd

Unterstützt von .NET Compact Framework
public event FormularDokument_Closed

Unterstützt von .NET Compact Framework
public event FormularEreignis_Closed

Unterstützt von .NET Compact Framework
public event FormularKontakte_Closed

Unterstützt von .NET Compact Framework
public event FormularKuendigungsfrist_Closed

Unterstützt von .NET Compact Framework
public event FormularPendenz_Closed

Unterstützt von .NET Compact Framework
public event FormularReferenzvertrag_Closed

Unterstützt von .NET Compact Framework
public event FormularReleaseLogbuchClosed

Unterstützt von .NET Compact Framework
public event FormularServices_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragelement_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragsapplikation_Closed

Unterstützt von .NET Compact Framework
public event FormularVertragspartner_Closed

Unterstützt von .NET Compact Framework
public event KeineLeistungSelektiert

Unterstützt von .NET Compact Framework
public event Kontakt_Deleted

Unterstützt von .NET Compact Framework
public event Kuendigungsfrist_Deleted

Unterstützt von .NET Compact Framework
public event LeistungSelektiert

Unterstützt von .NET Compact Framework
public event Pendenz_Deleted

Unterstützt von .NET Compact Framework
public event Referenzvertrag_Deleted

Unterstützt von .NET Compact Framework
public event Service_Deleted

Unterstützt von .NET Compact Framework
public event Set_ToolTip

Unterstützt von .NET Compact Framework
public event Update_Uebersicht

Unterstützt von .NET Compact Framework
public event Vertragsapplikation_Deleted

Unterstützt von .NET Compact Framework

MyGenericEventHandler -Klasse


Aktivitaet_Deleted -Ereignis

[Visual Basic]
Public Event Aktivitaet_Deleted()

Quellcode

[Visual Basic]
    Public Event Aktivitaet_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Dokument_Deleted -Ereignis

[Visual Basic]
Public Event Dokument_Deleted()

Quellcode

[Visual Basic]
    Public Event Dokument_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Ereignis_Deleted -Ereignis

[Visual Basic]
Public Event Ereignis_Deleted()

Quellcode

[Visual Basic]
    Public Event Ereignis_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularAktivitaet_Cloesd -Ereignis

[Visual Basic]
Public Event FormularAktivitaet_Cloesd()

Quellcode

[Visual Basic]
    Public Event FormularAktivitaet_Cloesd()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularDokument_Closed -Ereignis

[Visual Basic]
Public Event FormularDokument_Closed()

Quellcode

[Visual Basic]
    Public Event FormularDokument_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularEreignis_Closed -Ereignis

[Visual Basic]
Public Event FormularEreignis_Closed()

Quellcode

[Visual Basic]
    Public Event FormularEreignis_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularKontakte_Closed -Ereignis

[Visual Basic]
Public Event FormularKontakte_Closed()

Quellcode

[Visual Basic]
    Public Event FormularKontakte_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularKuendigungsfrist_Closed -Ereignis

[Visual Basic]
Public Event FormularKuendigungsfrist_Closed()

Quellcode

[Visual Basic]
    Public Event FormularKuendigungsfrist_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularPendenz_Closed -Ereignis

[Visual Basic]
Public Event FormularPendenz_Closed()

Quellcode

[Visual Basic]
    Public Event FormularPendenz_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularReferenzvertrag_Closed -Ereignis

[Visual Basic]
Public Event FormularReferenzvertrag_Closed()

Quellcode

[Visual Basic]
    Public Event FormularReferenzvertrag_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularReleaseLogbuchClosed -Ereignis

[Visual Basic]
Public Event FormularReleaseLogbuchClosed()

Quellcode

[Visual Basic]
    Public Event FormularReleaseLogbuchClosed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularServices_Closed -Ereignis

[Visual Basic]
Public Event FormularServices_Closed()

Quellcode

[Visual Basic]
    Public Event FormularServices_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularVertragelement_Closed -Ereignis

[Visual Basic]
Public Event FormularVertragelement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
)

Parameter

Vertragspartnernr
Vertragselementnr

Quellcode

[Visual Basic]
    Public Event FormularVertragelement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularVertragsapplikation_Closed -Ereignis

[Visual Basic]
Public Event FormularVertragsapplikation_Closed()

Quellcode

[Visual Basic]
    Public Event FormularVertragsapplikation_Closed()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


FormularVertragspartner_Closed -Ereignis

[Visual Basic]
Public Event FormularVertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
)

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
    Public Event FormularVertragspartner_Closed(ByVal Vertragspartnernr As Integer)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


KeineLeistungSelektiert -Ereignis

[Visual Basic]
Public Event KeineLeistungSelektiert( _
   ByVal Vertragsleistungsnr As Integer _
)

Parameter

Vertragsleistungsnr

Quellcode

[Visual Basic]
    Public Event KeineLeistungSelektiert(ByVal Vertragsleistungsnr As Integer)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Kontakt_Deleted -Ereignis

[Visual Basic]
Public Event Kontakt_Deleted()

Quellcode

[Visual Basic]
    Public Event Kontakt_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Kuendigungsfrist_Deleted -Ereignis

[Visual Basic]
Public Event Kuendigungsfrist_Deleted()

Quellcode

[Visual Basic]
    Public Event Kuendigungsfrist_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


LeistungSelektiert -Ereignis

[Visual Basic]
Public Event LeistungSelektiert( _
   ByVal Vertragsleistungsnr As Integer, _
   ByVal Servicekatalognr As Integer _
)

Parameter

Vertragsleistungsnr
Servicekatalognr

Quellcode

[Visual Basic]
    Public Event LeistungSelektiert(ByVal Vertragsleistungsnr As Integer, ByVal Servicekatalognr As Integer)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Pendenz_Deleted -Ereignis

[Visual Basic]
Public Event Pendenz_Deleted()

Quellcode

[Visual Basic]
    Public Event Pendenz_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Referenzvertrag_Deleted -Ereignis

[Visual Basic]
Public Event Referenzvertrag_Deleted()

Quellcode

[Visual Basic]
    Public Event Referenzvertrag_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Service_Deleted -Ereignis

[Visual Basic]
Public Event Service_Deleted()

Quellcode

[Visual Basic]
    Public Event Service_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Set_ToolTip -Ereignis

[Visual Basic]
Public Event Set_ToolTip( _
   ByVal formname As String, _
   ByVal ctlname As String _
)

Parameter

formname
ctlname

Quellcode

[Visual Basic]
    Public Event Set_ToolTip(ByVal formname As String, ByVal ctlname As String)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Update_Uebersicht -Ereignis

[Visual Basic]
Public Event Update_Uebersicht()

Quellcode

[Visual Basic]
    Public Event Update_Uebersicht()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


Vertragsapplikation_Deleted -Ereignis

[Visual Basic]
Public Event Vertragsapplikation_Deleted()

Quellcode

[Visual Basic]
    Public Event Vertragsapplikation_Deleted()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyGenericEventHandler


PE01 -Klasse

For a list of all members of this type, see PE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.PE01

[Visual Basic]
Public Class PE01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

PE01-Member


PE01-Member

PE01 Übersicht

Öffentliche Konstruktoren

public constructor PE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

PE01 -Klasse


PE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01-Eigenschaften

PE01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ReportHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

PE01 -Klasse


PE01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.ReportHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "PE01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


PE01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(12)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

PE01


QU01 -Klasse

For a list of all members of this type, see QU01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.QU01

[Visual Basic]
Public Class QU01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

QU01-Member


QU01-Member

QU01 Übersicht

Öffentliche Konstruktoren

public constructor QU01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

QU01 -Klasse


QU01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01-Eigenschaften

QU01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

QU01 -Klasse


QU01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "QU01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


QU01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

QU01


RFCBoard -Klasse

For a list of all members of this type, see RFCBoard-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.RFCBoard

[Visual Basic]
Public Class RFCBoard
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

RFCBoard-Member


RFCBoard-Member

RFCBoard Übersicht

Öffentliche Konstruktoren

public constructor RFCBoard -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBoard -Klasse


RFCBoard -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard-Eigenschaften

RFCBoard Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBoard -Klasse


RFCBoard.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "RFCBoard.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBoard.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBoard


RFCBudget -Klasse

For a list of all members of this type, see RFCBudget-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.RFCBudget

[Visual Basic]
Public Class RFCBudget
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

RFCBudget-Member


RFCBudget-Member

RFCBudget Übersicht

Öffentliche Konstruktoren

public constructor RFCBudget -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupFooterSection4

Unterstützt von .NET Compact Framework
public property GroupFooterSection5

Unterstützt von .NET Compact Framework
public property GroupFooterSection6

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBudget -Klasse


RFCBudget -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget-Eigenschaften

RFCBudget Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupFooterSection3

Unterstützt von .NET Compact Framework
public property GroupFooterSection4

Unterstützt von .NET Compact Framework
public property GroupFooterSection5

Unterstützt von .NET Compact Framework
public property GroupFooterSection6

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBudget -Klasse


RFCBudget.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupFooterSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupFooterSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupFooterSection5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupFooterSection6 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection6() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection6() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "RFCBudget.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(11)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(12)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget


RFCBudget_Uebersicht -Klasse

For a list of all members of this type, see RFCBudget_Uebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.RFCBudget_Uebersicht

[Visual Basic]
Public Class RFCBudget_Uebersicht
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

RFCBudget_Uebersicht-Member


RFCBudget_Uebersicht-Member

RFCBudget_Uebersicht Übersicht

Öffentliche Konstruktoren

public constructor RFCBudget_Uebersicht -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBudget_Uebersicht -Klasse


RFCBudget_Uebersicht -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht-Eigenschaften

RFCBudget_Uebersicht Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

RFCBudget_Uebersicht -Klasse


RFCBudget_Uebersicht.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "RFCBudget_Uebersicht.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


RFCBudget_Uebersicht.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

RFCBudget_Uebersicht


Statistik_Applikationen_Nach_Verantwortung -Klasse

For a list of all members of this type, see Statistik_Applikationen_Nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Statistik_Applikationen_Nach_Verantwortung

[Visual Basic]
Public Class Statistik_Applikationen_Nach_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Statistik_Applikationen_Nach_Verantwortung-Member


Statistik_Applikationen_Nach_Verantwortung-Member

Statistik_Applikationen_Nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor Statistik_Applikationen_Nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Statistik_Applikationen_Nach_Verantwortung -Klasse


Statistik_Applikationen_Nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung-Eigenschaften

Statistik_Applikationen_Nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Statistik_Applikationen_Nach_Verantwortung -Klasse


Statistik_Applikationen_Nach_Verantwortung.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Statistik_Applikationen_Nach_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


Statistik_Applikationen_Nach_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Statistik_Applikationen_Nach_Verantwortung


TE01 -Klasse

For a list of all members of this type, see TE01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.TE01

[Visual Basic]
Public Class TE01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

TE01-Member


TE01-Member

TE01 Übersicht

Öffentliche Konstruktoren

public constructor TE01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

TE01 -Klasse


TE01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01-Eigenschaften

TE01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

TE01 -Klasse


TE01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "TE01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


TE01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TE01


Treenode_Descriptor -Klasse

Treenode-Descriptor zur Befüllung des Tree-Node-Tags

For a list of all members of this type, see Treenode_Descriptor-Member.

System.Object
Vertragsverwaltung.Treenode_Descriptor

[Visual Basic]
Public Class Treenode_Descriptor

Hinweise

Treenode-Tags werden mit den 2 Elementen (Type und Keyvalue) befüllt: Type: Vertragspartner, Vertragstyp Keyvalue: Primary-Key des Elementes

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Treenode_Descriptor-Member


Treenode_Descriptor-Member

Treenode_Descriptor Übersicht

Öffentliche Konstruktoren

public constructor Treenode_Descriptor -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Keyvalue

Unterstützt von .NET Compact Framework
public property Type

Unterstützt von .NET Compact Framework
public property Vertragspartnernr

Unterstützt von .NET Compact Framework
public property Vertragstypnr

Unterstützt von .NET Compact Framework

Felder

private field m_keyvalue

Unterstützt von .NET Compact Framework
private field m_type

Unterstützt von .NET Compact Framework
private field m_vertragspartnernr

Unterstützt von .NET Compact Framework
private field m_vertragstypnr

Unterstützt von .NET Compact Framework

Treenode_Descriptor -Klasse


Treenode_Descriptor -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal Type As String, _
   ByVal Keyvalue As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal vertragstypnr As Integer _
)

Parameter

Type
Keyvalue
Vertragspartnernr
vertragstypnr

Quellcode

[Visual Basic]
    Sub New(ByVal Type As String, ByVal Keyvalue As Integer, ByVal Vertragspartnernr As Integer, ByVal vertragstypnr As Integer)
        Me.Type = Type
        Me.Keyvalue = Keyvalue
        Me.Vertragspartnernr = Vertragspartnernr
        Me.Vertragstypnr = vertragstypnr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


Treenode_Descriptor-Eigenschaften

Treenode_Descriptor Übersicht

Öffentliche Eigenschaften

public property Keyvalue

Unterstützt von .NET Compact Framework
public property Type

Unterstützt von .NET Compact Framework
public property Vertragspartnernr

Unterstützt von .NET Compact Framework
public property Vertragstypnr

Unterstützt von .NET Compact Framework

Treenode_Descriptor -Klasse


Treenode_Descriptor.Keyvalue -Eigenschaft

[Visual Basic]
Public Property Keyvalue() As Integer

Quellcode

[Visual Basic]
    Property Keyvalue() As Integer
        Get
            Return m_keyvalue
        End Get
        Set(ByVal value As Integer)
            m_keyvalue = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


Treenode_Descriptor.Type -Eigenschaft

[Visual Basic]
Public Property Type() As String

Quellcode

[Visual Basic]
    Property Type() As String
        Get
            Return m_type
        End Get
        Set(ByVal value As String)
            m_type = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


Treenode_Descriptor.Vertragspartnernr -Eigenschaft

[Visual Basic]
Public Property Vertragspartnernr() As Integer

Quellcode

[Visual Basic]
    Property Vertragspartnernr() As Integer
        Get
            Return m_vertragspartnernr
        End Get
        Set(ByVal value As Integer)
            m_vertragspartnernr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


Treenode_Descriptor.Vertragstypnr -Eigenschaft

[Visual Basic]
Public Property Vertragstypnr() As Integer

Quellcode

[Visual Basic]
    Property Vertragstypnr() As Integer
        Get
            Return m_vertragstypnr
        End Get
        Set(ByVal value As Integer)
            m_vertragstypnr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


Treenode_Descriptor-Felder

Treenode_Descriptor Übersicht

Felder

private field m_keyvalue

Unterstützt von .NET Compact Framework
private field m_type

Unterstützt von .NET Compact Framework
private field m_vertragspartnernr

Unterstützt von .NET Compact Framework
private field m_vertragstypnr

Unterstützt von .NET Compact Framework

Treenode_Descriptor -Klasse


m_keyvalue -Feld

[Visual Basic]
Private m_keyvalue As Integer

Quellcode

[Visual Basic]
    Dim m_keyvalue As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


m_type -Feld

[Visual Basic]
Private m_type As String

Quellcode

[Visual Basic]
    Dim m_type As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


m_vertragspartnernr -Feld

[Visual Basic]
Private m_vertragspartnernr As Integer

Quellcode

[Visual Basic]
    Dim m_vertragspartnernr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


m_vertragstypnr -Feld

[Visual Basic]
Private m_vertragstypnr As Integer

Quellcode

[Visual Basic]
    Dim m_vertragstypnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


UM01 -Klasse

For a list of all members of this type, see UM01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.UM01

[Visual Basic]
Public Class UM01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

UM01-Member


UM01-Member

UM01 Übersicht

Öffentliche Konstruktoren

public constructor UM01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

UM01 -Klasse


UM01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01-Eigenschaften

UM01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

UM01 -Klasse


UM01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "UM01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


UM01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

UM01


VI01 -Klasse

For a list of all members of this type, see VI01-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.VI01

[Visual Basic]
Public Class VI01
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

VI01-Member


VI01-Member

VI01 Übersicht

Öffentliche Konstruktoren

public constructor VI01 -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

VI01 -Klasse


VI01 -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01-Eigenschaften

VI01 Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection3

Unterstützt von .NET Compact Framework
public property GroupHeaderSection4

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

VI01 -Klasse


VI01.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.GroupHeaderSection3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.GroupHeaderSection4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "VI01.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


VI01.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(10)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

VI01


Vertragselement_SecurityLevel -Klasse

For a list of all members of this type, see Vertragselement_SecurityLevel-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Vertragselement_SecurityLevel

[Visual Basic]
Public Class Vertragselement_SecurityLevel
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Vertragselement_SecurityLevel-Member


Vertragselement_SecurityLevel-Member

Vertragselement_SecurityLevel Übersicht

Öffentliche Konstruktoren

public constructor Vertragselement_SecurityLevel -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Vertragselement_SecurityLevel -Klasse


Vertragselement_SecurityLevel -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel-Eigenschaften

Vertragselement_SecurityLevel Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property PageHeaderSection2

Unterstützt von .NET Compact Framework
public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Vertragselement_SecurityLevel -Klasse


Vertragselement_SecurityLevel.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.PageHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property PageHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property PageHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Vertragselement_SecurityLevel.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


Vertragselement_SecurityLevel.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(9)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Vertragselement_SecurityLevel


clsGremienverwaltung -Klasse

For a list of all members of this type, see clsGremienverwaltung-Member.

System.Object
Vertragsverwaltung.clsGremienverwaltung

[Visual Basic]
Public Class clsGremienverwaltung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsGremienverwaltung-Member


clsGremienverwaltung-Member

clsGremienverwaltung Übersicht

Öffentliche Konstruktoren

public constructor clsGremienverwaltung -Konstructor

Unterstützt von .NET Compact Framework

 Klassen Initialisieurng

Öffentliche Methoden

public method Insert_Gremium_Person Unterstützt von .NET Compact Framework |
public method dispose Unterstützt von .NET Compact Framework | Destructor der Klasse

Felder

public field Gremium

Unterstützt von .NET Compact Framework
public field GremiumBereich

Unterstützt von .NET Compact Framework
public field GremiumBereichData

Unterstützt von .NET Compact Framework
public field GremiumGruppe

Unterstützt von .NET Compact Framework
public field GremiumGruppeData

Unterstützt von .NET Compact Framework
public field GremiumPersonData

Unterstützt von .NET Compact Framework
public field Gremiumdata

Unterstützt von .NET Compact Framework
public field Gremiumperson

Unterstützt von .NET Compact Framework
public field Rollen

Unterstützt von .NET Compact Framework
private field std

Unterstützt von .NET Compact Framework

clsGremienverwaltung -Klasse


clsGremienverwaltung -Konstructor

Klassen Initialisieurng

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        Gremiumperson = New TKB.VV.Sysadmin.DomainTable("GremiumPerson", 0, "A")
        Rollen = std.Get_Stammdaten("KONTAKTTYP_GREMIUM", "Bezeichnung")
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


clsGremienverwaltung-Methoden

clsGremienverwaltung Übersicht

Öffentliche Methoden

public method Insert_Gremium_Person Unterstützt von .NET Compact Framework |
public method dispose Unterstützt von .NET Compact Framework | Destructor der Klasse

clsGremienverwaltung -Klasse


clsGremienverwaltung.Insert_Gremium_Person -Methode

[Visual Basic]
Public Sub Insert_Gremium_Person( _
   ByVal PersonNr As Integer, _
   ByVal Bereichnr As Integer _
)

Parameter

PersonNr
Bereichnr

Quellcode

[Visual Basic]
    Sub Insert_Gremium_Person(ByVal PersonNr As Integer, ByVal Bereichnr As Integer)
        Dim gp As New TKB.VV.DB.clsGremiumPerson
        Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        key = dbkey.get_dbkey("GremiumPerson")

        gp.cpMainConnectionProvider = Globals.conn
        gp.iGreminPersonNr = New SqlInt32(CType(key, Int32))
        gp.iPersonNr = New SqlInt32(CType(PersonNr, Int32))
        gp.iGremiumBereichNr = New SqlInt32(CType(Bereichnr, Int32))
        gp.bAktiv = New SqlBoolean(CType(True, Boolean))
        gp.bLeitung = New SqlBoolean(CType(False, Boolean))
        gp.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        gp.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        gp.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        gp.sBeschreibung = New SqlString(CType("", String))
        gp.iRolleNr = New SqlInt32(CType(0, Int32))
        conn.OpenConnection()
        gp.Insert()
        conn.CloseConnection(True)
        Me.Gremiumperson.Tabledata.Tables.Clear()
        Me.Gremiumperson.Load_Bootom_Table("GremiumPerson", 0, "A")
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


clsGremienverwaltung.dispose -Methode

Destructor der Klasse

[Visual Basic]
Public Sub dispose()

Quellcode

[Visual Basic]
    Sub dispose()
        Gremium.dispose()
        GremiumGruppe.dispose()
        GremiumBereich.dispose()
        Gremiumperson.dispose()
        Gremiumdata.Dispose()
        GremiumGruppeData.Dispose()
        GremiumBereichData.Dispose()
        GremiumPersonData.Dispose()
        Rollen.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


clsGremienverwaltung-Felder

clsGremienverwaltung Übersicht

Felder

public field Gremium

Unterstützt von .NET Compact Framework
public field GremiumBereich

Unterstützt von .NET Compact Framework
public field GremiumBereichData

Unterstützt von .NET Compact Framework
public field GremiumGruppe

Unterstützt von .NET Compact Framework
public field GremiumGruppeData

Unterstützt von .NET Compact Framework
public field GremiumPersonData

Unterstützt von .NET Compact Framework
public field Gremiumdata

Unterstützt von .NET Compact Framework
public field Gremiumperson

Unterstützt von .NET Compact Framework
public field Rollen

Unterstützt von .NET Compact Framework
private field std

Unterstützt von .NET Compact Framework

clsGremienverwaltung -Klasse


Gremium -Feld

[Visual Basic]
Public Gremium As DomainTable

Quellcode

[Visual Basic]
    Public Gremium As New TKB.VV.Sysadmin.DomainTable("Gremium")

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


GremiumBereich -Feld

[Visual Basic]
Public GremiumBereich As DomainTable

Quellcode

[Visual Basic]
    Public GremiumBereich As New TKB.VV.Sysadmin.DomainTable("GremiumBereich")

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


GremiumBereichData -Feld

[Visual Basic]
Public GremiumBereichData As DataTable

Quellcode

[Visual Basic]
    Public GremiumBereichData As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


GremiumGruppe -Feld

[Visual Basic]
Public GremiumGruppe As DomainTable

Quellcode

[Visual Basic]
    Public GremiumGruppe As New TKB.VV.Sysadmin.DomainTable("GremiumGruppierung")

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


GremiumGruppeData -Feld

[Visual Basic]
Public GremiumGruppeData As DataTable

Quellcode

[Visual Basic]
    Public GremiumGruppeData As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


GremiumPersonData -Feld

[Visual Basic]
Public GremiumPersonData As DataTable

Quellcode

[Visual Basic]
    Public GremiumPersonData As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


Gremiumdata -Feld

[Visual Basic]
Public Gremiumdata As DataTable

Quellcode

[Visual Basic]
    Public Gremiumdata As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


Gremiumperson -Feld

[Visual Basic]
Public Gremiumperson As DomainTable

Quellcode

[Visual Basic]
    Public Gremiumperson As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


Rollen -Feld

[Visual Basic]
Public Rollen As DataTable

Quellcode

[Visual Basic]
    Public Rollen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


std -Feld

[Visual Basic]
Private std As clsStammdaten

Quellcode

[Visual Basic]
    Dim std As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremienverwaltung


clsResizeControl -Klasse

For a list of all members of this type, see clsResizeControl-Member.

System.Object
Vertragsverwaltung.clsResizeControl

[Visual Basic]
Public Class clsResizeControl

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsResizeControl-Member


clsResizeControl-Member

clsResizeControl Übersicht

Öffentliche Konstruktoren

public constructor clsResizeControl -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Finish Unterstützt von .NET Compact Framework | Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.
public method Paint Unterstützt von .NET Compact Framework |

Andere Methoden

private method ControlMouseDown

Unterstützt von .NET Compact Framework
private method ControlMouseMove

Unterstützt von .NET Compact Framework
private method ControlMouseUp

Unterstützt von .NET Compact Framework
private method GetCurrIndex

Unterstützt von .NET Compact Framework
private method GrabRectMouseClick

Unterstützt von .NET Compact Framework
private method GrabRectMouseDown

Unterstützt von .NET Compact Framework
private method GrabRectMouseMove

Unterstützt von .NET Compact Framework
private method GrabRectMouseUp

Unterstützt von .NET Compact Framework
private method GrabRectMove

Unterstützt von .NET Compact Framework
private method GrabRectPaint

Unterstützt von .NET Compact Framework

Felder

private field GRS

Unterstützt von .NET Compact Framework
public field GrabRectColor

Unterstützt von .NET Compact Framework
private field GrabRects

Unterstützt von .NET Compact Framework
private field InResizeMode

Unterstützt von .NET Compact Framework
private field LastMousePos

Unterstützt von .NET Compact Framework
private field MoveControl

Unterstützt von .NET Compact Framework
private field mMinHeigth

Unterstützt von .NET Compact Framework
private field mMinWidth

Unterstützt von .NET Compact Framework

clsResizeControl -Klasse


clsResizeControl -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal NewControl As Control, _
   ByVal OwnerForm As Form _
)

Parameter

NewControl
OwnerForm

Quellcode

[Visual Basic]
    Sub New(ByVal NewControl As Control, ByVal OwnerForm As Form)
        mControl = NewControl
        mOwnerForm = OwnerForm

        AddHandler mOwnerForm.Paint, AddressOf Paint

        AddHandler mControl.MouseDown, AddressOf ControlMouseDown
        AddHandler mControl.MouseMove, AddressOf ControlMouseMove
        AddHandler mControl.MouseUp, AddressOf ControlMouseUp

        mControl.Cursor = Cursors.SizeAll

        For i As Integer = 0 To GrabRects.Length - 1
            AddHandler GrabRects(i).Paint, AddressOf GrabRectPaint
            AddHandler GrabRects(i).MouseClick, AddressOf GrabRectMouseClick
            AddHandler GrabRects(i).MouseMove, AddressOf GrabRectMouseMove
            AddHandler GrabRects(i).MouseDown, AddressOf GrabRectMouseDown
            AddHandler GrabRects(i).MouseUp, AddressOf GrabRectMouseUp
            AddHandler GrabRects(i).Move, AddressOf GrabRectMove
        Next

        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl-Methoden

clsResizeControl Übersicht

Öffentliche Methoden

public method Finish Unterstützt von .NET Compact Framework | Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.
public method Paint Unterstützt von .NET Compact Framework |

Andere Methoden

private method ControlMouseDown

Unterstützt von .NET Compact Framework
private method ControlMouseMove

Unterstützt von .NET Compact Framework
private method ControlMouseUp

Unterstützt von .NET Compact Framework
private method GetCurrIndex

Unterstützt von .NET Compact Framework
private method GrabRectMouseClick

Unterstützt von .NET Compact Framework
private method GrabRectMouseDown

Unterstützt von .NET Compact Framework
private method GrabRectMouseMove

Unterstützt von .NET Compact Framework
private method GrabRectMouseUp

Unterstützt von .NET Compact Framework
private method GrabRectMove

Unterstützt von .NET Compact Framework
private method GrabRectPaint

Unterstützt von .NET Compact Framework

clsResizeControl -Klasse


clsResizeControl.ControlMouseDown -Methode

[Visual Basic]
Private Sub ControlMouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ControlMouseDown(ByVal sender As Object, ByVal e As MouseEventArgs)
        MoveControl = True
        LastMousePos = New Point(e.X, e.Y)

        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = False
        Next
        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.ControlMouseMove -Methode

[Visual Basic]
Private Sub ControlMouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ControlMouseMove(ByVal sender As Object, ByVal e As MouseEventArgs)
        If MoveControl = True Then
            mControl.Left = mControl.Left + e.X - LastMousePos.X
            mControl.Top = mControl.Top + e.Y - LastMousePos.Y
            mOwnerForm.Refresh()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.ControlMouseUp -Methode

[Visual Basic]
Private Sub ControlMouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ControlMouseUp(ByVal sender As Object, ByVal e As MouseEventArgs)
        MoveControl = False

        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = True
        Next
        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.Finish -Methode

Diese Routine muss aufgerufen werden wenn man die Resize-Funktionalität vom Control entfernen möchte.

[Visual Basic]
Public Sub Finish()

Quellcode

[Visual Basic]
    Public Sub Finish()
        RemoveHandler mOwnerForm.Paint, AddressOf Paint

        RemoveHandler mControl.MouseDown, AddressOf ControlMouseDown
        RemoveHandler mControl.MouseMove, AddressOf ControlMouseMove
        RemoveHandler mControl.MouseUp, AddressOf ControlMouseUp

        For i As Integer = 0 To GrabRects.Length - 1
            RemoveHandler GrabRects(i).Paint, AddressOf GrabRectPaint
            RemoveHandler GrabRects(i).MouseClick, AddressOf GrabRectMouseClick
            RemoveHandler GrabRects(i).MouseMove, AddressOf GrabRectMouseMove
            RemoveHandler GrabRects(i).MouseDown, AddressOf GrabRectMouseDown
            RemoveHandler GrabRects(i).MouseUp, AddressOf GrabRectMouseUp
            RemoveHandler GrabRects(i).Move, AddressOf GrabRectMove

            GrabRects(i).Dispose()
        Next

        GrabRects = Nothing

        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GetCurrIndex -Methode

[Visual Basic]
Private Function GetCurrIndex( _
   ByVal sender As Object _
) As Integer

Parameter

sender

Quellcode

[Visual Basic]
    Private Function GetCurrIndex(ByVal sender As Object) As Integer
        Dim CurrControl As Control = CType(sender, Control)
        For i As Integer = 0 To GrabRects.Length
            If GrabRects(i) Is CurrControl Then
                Return i
            End If
        Next
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectMouseClick -Methode

[Visual Basic]
Private Sub GrabRectMouseClick( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectMouseClick(ByVal sender As Object, ByVal e As MouseEventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectMouseDown -Methode

[Visual Basic]
Private Sub GrabRectMouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectMouseDown(ByVal sender As Object, ByVal e As MouseEventArgs)
        InResizeMode = True
        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = False
        Next
        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectMouseMove -Methode

[Visual Basic]
Private Sub GrabRectMouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectMouseMove(ByVal sender As Object, ByVal e As MouseEventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
        Dim MousePos As Point
        Static Right As Integer
        Static Bottom As Integer

        Select Case Index
            Case 0 : CurrControl.Cursor = Cursors.SizeNWSE
            Case 1 : CurrControl.Cursor = Cursors.SizeNS
            Case 2 : CurrControl.Cursor = Cursors.SizeNESW

            Case 3 : CurrControl.Cursor = Cursors.SizeWE
            Case 4 : CurrControl.Cursor = Cursors.SizeWE

            Case 5 : CurrControl.Cursor = Cursors.SizeNESW
            Case 6 : CurrControl.Cursor = Cursors.SizeNS
            Case 7 : CurrControl.Cursor = Cursors.SizeNWSE
        End Select

        If InResizeMode = True Then
            MousePos = mOwnerForm.PointToClient(Cursor.Position)
            CurrControl.Left = mOwnerForm.PointToClient(Cursor.Position).X 'CurrControl.Left + e.X
            CurrControl.Top = mOwnerForm.PointToClient(Cursor.Position).Y 'CurrControl.Top + e.Y

            Dim TmpHeigth As Integer
            Dim TmpWidth As Integer

            Select Case Index
                Case 0 'TopLeft GrabButton

                Case 1 'TopMiddle GrabButton

                Case 2 'TopRight GrabButton

                Case 3 'MiddleLeft GrabButton

                Case 4 'MiddleRight GrabButton
                    TmpWidth = GrabRects(4).Left - mControl.Left
                    If TmpWidth < mMinWidth Then TmpWidth = mMinWidth
                    mControl.Width = TmpWidth

                Case 5 'BottomLeft GrabButton

                Case 6 'BottomMiddle GrabButton
                    TmpHeigth = CurrControl.Top - mControl.Top
                    If TmpHeigth < mMinHeigth Then TmpHeigth = mMinHeigth
                    mControl.Height = TmpHeigth

                Case 7 'BottomRight GrabButton
                    TmpHeigth = CurrControl.Top - mControl.Top
                    TmpWidth = CurrControl.Left - mControl.Left

                    If TmpHeigth < mMinHeigth Then TmpHeigth = mMinHeigth
                    If TmpWidth < mMinWidth Then TmpWidth = mMinWidth

                    mControl.Size = New Size(TmpWidth, TmpHeigth)
            End Select
            mOwnerForm.Refresh()
        Else
            Right = mControl.Right
            Bottom = mControl.Bottom
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectMouseUp -Methode

[Visual Basic]
Private Sub GrabRectMouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectMouseUp(ByVal sender As Object, ByVal e As MouseEventArgs)
        InResizeMode = False
        For i As Integer = 0 To GrabRects.Length - 1
            GrabRects(i).Visible = True
        Next
        mOwnerForm.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectMove -Methode

[Visual Basic]
Private Sub GrabRectMove( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectMove(ByVal sender As Object, ByVal e As System.EventArgs)
        Dim CurrControl As Control = CType(sender, Control)
        Dim Index As Integer = GetCurrIndex(sender)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.GrabRectPaint -Methode

[Visual Basic]
Private Sub GrabRectPaint( _
   ByVal sender As Object, _
   ByVal e As PaintEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GrabRectPaint(ByVal sender As Object, ByVal e As PaintEventArgs)
        e.Graphics.DrawRectangle(Pens.Black, New Rectangle(0, 0, GRS - 1, GRS - 1))
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl.Paint -Methode

[Visual Basic]
Public Sub Paint( _
   ByVal sender As Object, _
   ByVal e As PaintEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Public Sub Paint(ByVal sender As Object, ByVal e As PaintEventArgs)
        If InResizeMode = True Or MoveControl = True Then Exit Sub
        With e.Graphics
            'Rahmen
            .DrawRectangle(Pens.Gray, New Rectangle( _
            mControl.Location.X - (GRS / 2), _
            mControl.Location.Y - (GRS / 2), _
            mControl.Width + GRS, _
            mControl.Height + GRS))

            'Positionen für die GrabRects in der Reihenfolge:
            'TopLeft, TopMiddle, TopRight, MiddleLeft, MiddleRight, BottomLeft,BottomMiddle,BottomRight
            Dim GrabRectPos() As Point = { _
            New Point(mControl.Location.X - GRS, mControl.Location.Y - GRS), _
            New Point(mControl.Location.X + (mControl.Width / 2) - (GRS / 2), mControl.Location.Y - GRS), _
            New Point(mControl.Location.X + mControl.Width, mControl.Location.Y - GRS), _
            New Point(mControl.Location.X - GRS, mControl.Location.Y + (mControl.Height / 2) - (GRS / 2)), _
            New Point(mControl.Location.X + (mControl.Width), mControl.Location.Y + (mControl.Height / 2) - (GRS / 2)), _
            New Point(mControl.Location.X - GRS, mControl.Location.Y + (mControl.Height)), _
            New Point(mControl.Location.X + (mControl.Width / 2) - (GRS / 2), mControl.Location.Y + (mControl.Height)), _
            New Point(mControl.Location.X + mControl.Width, mControl.Location.Y + (mControl.Height))}

            For i As Integer = 0 To GrabRects.Length - 1
                GrabRects(i).Location = GrabRectPos(i)
                GrabRects(i).Size = New Size(GRS, GRS)
                GrabRects(i).BackColor = Color.White
                GrabRects(i).Parent = mOwnerForm
            Next

            GrabRects(4).BackColor = GrabRectColor
            GrabRects(6).BackColor = GrabRectColor
            GrabRects(7).BackColor = GrabRectColor
        End With
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


clsResizeControl-Felder

clsResizeControl Übersicht

Felder

private field GRS

Unterstützt von .NET Compact Framework
public field GrabRectColor

Unterstützt von .NET Compact Framework
private field GrabRects

Unterstützt von .NET Compact Framework
private field InResizeMode

Unterstützt von .NET Compact Framework
private field LastMousePos

Unterstützt von .NET Compact Framework
private field MoveControl

Unterstützt von .NET Compact Framework
private field mMinHeigth

Unterstützt von .NET Compact Framework
private field mMinWidth

Unterstützt von .NET Compact Framework

clsResizeControl -Klasse


GRS -Feld

[Visual Basic]
Private GRS As Integer

Quellcode

[Visual Basic]
    Private GRS As Integer = 6

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


GrabRectColor -Feld

[Visual Basic]
Public GrabRectColor As Color

Quellcode

[Visual Basic]
    Public GrabRectColor As Color = Color.Yellow

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


GrabRects -Feld

[Visual Basic]
Private GrabRects As Control()

Quellcode

[Visual Basic]
    Private GrabRects() As Control = { _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control, _
        New Control}

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


InResizeMode -Feld

[Visual Basic]
Private InResizeMode As Boolean

Quellcode

[Visual Basic]
    Private InResizeMode As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


LastMousePos -Feld

[Visual Basic]
Private LastMousePos As Point

Quellcode

[Visual Basic]
    Private LastMousePos As Point

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


MoveControl -Feld

[Visual Basic]
Private MoveControl As Boolean

Quellcode

[Visual Basic]
    Private MoveControl As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


mMinHeigth -Feld

[Visual Basic]
Private mMinHeigth As Integer

Quellcode

[Visual Basic]
    Private mMinHeigth As Integer = 20

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


mMinWidth -Feld

[Visual Basic]
Private mMinWidth As Integer

Quellcode

[Visual Basic]
    Private mMinWidth As Integer = 20

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsResizeControl


it_koordinatoren -Klasse

For a list of all members of this type, see it_koordinatoren-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.it_koordinatoren

[Visual Basic]
Public Class it_koordinatoren
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

it_koordinatoren-Member


it_koordinatoren-Member

it_koordinatoren Übersicht

Öffentliche Konstruktoren

public constructor it_koordinatoren -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

it_koordinatoren -Klasse


it_koordinatoren -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren-Eigenschaften

it_koordinatoren Übersicht

Öffentliche Eigenschaften

public property GroupFooterSection1

Unterstützt von .NET Compact Framework
public property GroupFooterSection2

Unterstützt von .NET Compact Framework
public property GroupHeaderSection1

Unterstützt von .NET Compact Framework
public property GroupHeaderSection2

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

it_koordinatoren -Klasse


it_koordinatoren.GroupFooterSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(6)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.GroupFooterSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupFooterSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupFooterSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.GroupHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.GroupHeaderSection2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property GroupHeaderSection2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property GroupHeaderSection2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "it_koordinatoren.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(7)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


it_koordinatoren.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(8)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

it_koordinatoren


rfc_budget_total -Klasse

For a list of all members of this type, see rfc_budget_total-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.rfc_budget_total

[Visual Basic]
Public Class rfc_budget_total
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

rfc_budget_total-Member


rfc_budget_total-Member

rfc_budget_total Übersicht

Öffentliche Konstruktoren

public constructor rfc_budget_total -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_budgetperiode

Unterstützt von .NET Compact Framework
public property Parameter_rfcboard

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

rfc_budget_total -Klasse


rfc_budget_total -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total-Eigenschaften

rfc_budget_total Übersicht

Öffentliche Eigenschaften

public property Parameter_budgetperiode

Unterstützt von .NET Compact Framework
public property Parameter_rfcboard

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

rfc_budget_total -Klasse


rfc_budget_total.Parameter_budgetperiode -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_budgetperiode() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_budgetperiode() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Parameter_rfcboard -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_rfcboard() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_rfcboard() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "rfc_budget_total.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


rfc_budget_total.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

rfc_budget_total


Übersicht_AM_Aufträge_RFC_Status -Klasse

For a list of all members of this type, see Übersicht_AM_Aufträge_RFC_Status-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Übersicht_AM_Aufträge_RFC_Status

[Visual Basic]
Public Class Übersicht_AM_Aufträge_RFC_Status
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Übersicht_AM_Aufträge_RFC_Status-Member


Übersicht_AM_Aufträge_RFC_Status-Member

Übersicht_AM_Aufträge_RFC_Status Übersicht

Öffentliche Konstruktoren

public constructor Übersicht_AM_Aufträge_RFC_Status -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_AM_Aufträge_RFC_Status -Klasse


Übersicht_AM_Aufträge_RFC_Status -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status-Eigenschaften

Übersicht_AM_Aufträge_RFC_Status Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_AM_Aufträge_RFC_Status -Klasse


Übersicht_AM_Aufträge_RFC_Status.Parameter_sqlwhwere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhwere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhwere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Übersicht_AM_Aufträge_RFC_Status.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status


Übersicht_AM_Aufträge_RFC_Status_Priorität -Klasse

For a list of all members of this type, see Übersicht_AM_Aufträge_RFC_Status_Priorität-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Übersicht_AM_Aufträge_RFC_Status_Priorität

[Visual Basic]
Public Class Übersicht_AM_Aufträge_RFC_Status_Priorität
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Übersicht_AM_Aufträge_RFC_Status_Priorität-Member


Übersicht_AM_Aufträge_RFC_Status_Priorität-Member

Übersicht_AM_Aufträge_RFC_Status_Priorität Übersicht

Öffentliche Konstruktoren

public constructor Übersicht_AM_Aufträge_RFC_Status_Priorität -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_AM_Aufträge_RFC_Status_Priorität -Klasse


Übersicht_AM_Aufträge_RFC_Status_Priorität -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität-Eigenschaften

Übersicht_AM_Aufträge_RFC_Status_Priorität Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhwere

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_AM_Aufträge_RFC_Status_Priorität -Klasse


Übersicht_AM_Aufträge_RFC_Status_Priorität.Parameter_sqlwhwere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhwere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhwere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Übersicht_AM_Aufträge_RFC_Status_Priorität.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_AM_Aufträge_RFC_Status_Priorität.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_AM_Aufträge_RFC_Status_Priorität


Übersicht_Incident_nach_Besitzer -Klasse

For a list of all members of this type, see Übersicht_Incident_nach_Besitzer-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Übersicht_Incident_nach_Besitzer

[Visual Basic]
Public Class Übersicht_Incident_nach_Besitzer
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Übersicht_Incident_nach_Besitzer-Member


Übersicht_Incident_nach_Besitzer-Member

Übersicht_Incident_nach_Besitzer Übersicht

Öffentliche Konstruktoren

public constructor Übersicht_Incident_nach_Besitzer -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_Incident_nach_Besitzer -Klasse


Übersicht_Incident_nach_Besitzer -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer-Eigenschaften

Übersicht_Incident_nach_Besitzer Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_Incident_nach_Besitzer -Klasse


Übersicht_Incident_nach_Besitzer.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Übersicht Incident_nach_Besitzer.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Besitzer.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Besitzer


Übersicht_Incident_nach_Verantwortung -Klasse

For a list of all members of this type, see Übersicht_Incident_nach_Verantwortung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CrystalDecisions.CrystalReports.Engine.ReportDocument
CrystalDecisions.CrystalReports.Engine.ReportClass
Vertragsverwaltung.Übersicht_Incident_nach_Verantwortung

[Visual Basic]
Public Class Übersicht_Incident_nach_Verantwortung
    Inherits ReportClass

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Übersicht_Incident_nach_Verantwortung-Member


Übersicht_Incident_nach_Verantwortung-Member

Übersicht_Incident_nach_Verantwortung Übersicht

Öffentliche Konstruktoren

public constructor Übersicht_Incident_nach_Verantwortung -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_Incident_nach_Verantwortung -Klasse


Übersicht_Incident_nach_Verantwortung -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung-Eigenschaften

Übersicht_Incident_nach_Verantwortung Übersicht

Öffentliche Eigenschaften

public property Parameter_sqlwhere

Unterstützt von .NET Compact Framework
public property ReportHeaderSection1

Unterstützt von .NET Compact Framework
public property ResourceName

Unterstützt von .NET Compact Framework
public property Section1

Unterstützt von .NET Compact Framework
public property Section2

Unterstützt von .NET Compact Framework
public property Section3

Unterstützt von .NET Compact Framework
public property Section4

Unterstützt von .NET Compact Framework
public property Section5

Unterstützt von .NET Compact Framework

Übersicht_Incident_nach_Verantwortung -Klasse


Übersicht_Incident_nach_Verantwortung.Parameter_sqlwhere -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Parameter_sqlwhere() As IParameterField

Quellcode

[Visual Basic]
    Public ReadOnly Property Parameter_sqlwhere() As CrystalDecisions.[Shared].IParameterField
        Get
            Return Me.DataDefinition.ParameterFields(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.ReportHeaderSection1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property ReportHeaderSection1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property ReportHeaderSection1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(0)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.ResourceName -Eigenschaft

[Visual Basic]
Public Overrides Property ResourceName() As String

Quellcode

[Visual Basic]
    Public Overrides Property ResourceName() As String
        Get
            Return "Übersicht Incident_nach_Verantwortung.rpt"
        End Get
        Set
            'Do nothing
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.Section1 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section1() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section1() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(1)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.Section2 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section2() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section2() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(2)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.Section3 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section3() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section3() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(3)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.Section4 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section4() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section4() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(4)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Übersicht_Incident_nach_Verantwortung.Section5 -Eigenschaft

[Visual Basic]
<Browsable(false)> _
<DesignerSerializationVisibility(System.ComponentModel.DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Section5() As Section

Quellcode

[Visual Basic]
    Public ReadOnly Property Section5() As CrystalDecisions.CrystalReports.Engine.Section
        Get
            Return Me.ReportDefinition.Sections(5)
        End Get
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Übersicht_Incident_nach_Verantwortung


Form2 -Klasse

For a list of all members of this type, see Form2-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.Form2

[Visual Basic]
Public Class Form2
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Form2-Member


Form2-Member

Form2 Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click Unterstützt von .NET Compact Framework |
private method Form2_Load Unterstützt von .NET Compact Framework |
private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

Felder

private field components

Unterstützt von .NET Compact Framework
private field xvertragspartnernr

Unterstützt von .NET Compact Framework

Form2 -Klasse


Form2-Methoden

Form2 Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click Unterstützt von .NET Compact Framework |
private method Form2_Load Unterstützt von .NET Compact Framework |
private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

Form2 -Klasse


Form2.Button1_Click -Methode

[Visual Basic]
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim dt As New DataTable
        dt = Me.Get_SubStruktur(0, 2, 1)
        Me.ComboBoxTree1.TreeView.Nodes.Clear()
        Me.ComboBoxTree1.TreeView.Nodes.Add("Test")
        Me.Update_Node(dt, Me.ComboBoxTree1.TreeView.Nodes(0), "Vertragspartner", 1)
        Me.ComboBoxTree1.TreeView.ExpandAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.Form2_Load -Methode

[Visual Basic]
Private Sub Form2_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Form2_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.Get_SubStruktur -Methode

Laden der Substruktur

[Visual Basic]
Private Function Get_SubStruktur( _
   ByVal vertragstypnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Details_anzeigen As Integer _
) As DataTable

Parameter

vertragstypnr
Vertragspartnernr
Nummer des aktuellen Vertragspartners
Details_anzeigen

Quellcode

[Visual Basic]
    Private Function Get_SubStruktur(ByVal vertragstypnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Details_anzeigen As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_struktur"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertragstypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Details", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Details_anzeigen))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.Button1 = New System.Windows.Forms.Button
        Me.ComboBoxTree1 = New Vertragsverwaltung.Controls.ComboBoxTree
        Me.SuspendLayout()
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(120, 139)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(75, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "Button1"
        Me.Button1.UseVisualStyleBackColor = True
        '
        'ComboBoxTree1
        '
        Me.ComboBoxTree1.ImageIndex = -1
        Me.ComboBoxTree1.ImageList = Nothing
        Me.ComboBoxTree1.Location = New System.Drawing.Point(22, 52)
        Me.ComboBoxTree1.Name = "ComboBoxTree1"
        Me.ComboBoxTree1.SelectedImageIndex = -1
        Me.ComboBoxTree1.SelectedNode = Nothing
        Me.ComboBoxTree1.Size = New System.Drawing.Size(249, 22)
        Me.ComboBoxTree1.TabIndex = 0
        '
        'Form2
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(292, 273)
        Me.Controls.Add(Me.Button1)
        Me.Controls.Add(Me.ComboBoxTree1)
        Me.Name = "Form2"
        Me.Text = "Form2"
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.LoadNode -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadNode( _
   ByVal oDS As DataSet, _
   ByRef oNode As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer _
)

Parameter

oDS
Input-Dataset
oNode
Aktueller Node
type
Type Vertragspartner oder Vertragstyp
Details

Quellcode

[Visual Basic]
    Private Sub LoadNode(ByVal oDS As DataSet, ByRef oNode As TreeNode, ByVal type As String, ByVal Details As Integer)
        'Dim oTreeView As TreeView = New TreeView()
        Dim oDataRow As DataRow
        For Each oDataRow In oDS.Tables(0).Rows
            If Not oDataRow.IsNull("Parentid") Then
                If oDataRow.Item("Parentid") = 0 Then
                    'If oDataRow.IsNull("Parentid") Then
                    Dim oNode1 As New TreeNode()
                    oNode1.Text = oDataRow("Bezeichnung").ToString()
                    Select Case type
                        Case "Vertragspartner"
                            oNode1.Tag = New Treenode_Descriptor("Vertragstyp", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                            oNode1.ImageIndex = 1
                            oNode1.SelectedImageIndex = 1
                            oNode1.StateImageIndex = 1
                        Case "Vertragstyp"
                            If oDataRow("aktiv") = True Then
                                oNode1.Tag = New Treenode_Descriptor("Vertragspartner", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                oNode1.ImageIndex = 0
                                oNode1.SelectedImageIndex = 0
                                oNode1.StateImageIndex = 0
                            Else
                                oNode1.Tag = New Treenode_Descriptor("Vertragspartner", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                oNode1.ImageIndex = 4
                                oNode1.SelectedImageIndex = 4
                                oNode1.StateImageIndex = 4
                            End If
                    End Select
                    oNode.Nodes.Add(oNode1)
                    RecursivelyLoadNode(oDataRow, oNode1, type, Details)
                End If
            End If
        Next oDataRow
        oDS.Dispose()
        oDS = Nothing
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.RecursivelyLoadNode -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadNode( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer _
)

Parameter

oDataRow
oNode
type
Details

Quellcode

[Visual Basic]
    Private Sub RecursivelyLoadNode(ByVal oDataRow As DataRow, ByRef oNode As TreeNode, ByVal type As String, ByVal Details As Integer)
        Dim oChildRow As DataRow
        For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
            Dim oChildNode As New TreeNode()
            oChildNode.Text = oChildRow("Bezeichnung").ToString()
            oChildNode.Tag = New Treenode_Descriptor("Vertragselement", oChildRow("Vertragselementnr").ToString(), xVertragspartnernr, oDataRow("vertragstypnr").ToString)
            oChildNode.ImageIndex = 2
            oChildNode.SelectedImageIndex = 2
            oChildNode.StateImageIndex = 2
            oNode.Nodes.Add(oChildNode)
            RecursivelyLoadNode(oChildRow, oChildNode, type, Details)
        Next oChildRow
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2.Update_Node -Methode

Parent-Beziehung herstellen und Struktur abfüllen

[Visual Basic]
Private Sub Update_Node( _
   ByVal oSourceData As DataTable, _
   ByRef node As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer _
)

Parameter

oSourceData
node
type
Details

Quellcode

[Visual Basic]
    Private Sub Update_Node(ByVal oSourceData As DataTable, ByRef node As TreeNode, ByVal type As String, ByVal Details As Integer)
        If Not (oSourceData Is Nothing) Then
            Dim oView As DataView = oSourceData.DefaultView
            Dim oTable As DataTable = oView.Table
            Dim oDS As DataSet = New DataSet()
            oDS.Tables.Add(oTable.Copy())

            If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                oDS.Relations.Add("SelfRefenceRelation", _
                    oDS.Tables(0).Columns("Vertragselementnr"), _
                    oDS.Tables(0).Columns("Parentid"))
            End If
            oTable.Dispose()
            oTable = Nothing
            LoadNode(oDS, node, type, Details)
            oDS.Dispose()
            oDS = Nothing
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


Form2-Felder

Form2 Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field xvertragspartnernr

Unterstützt von .NET Compact Framework

Form2 -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


xvertragspartnernr -Feld

[Visual Basic]
Private xvertragspartnernr As String

Quellcode

[Visual Basic]
    Dim xvertragspartnernr As String = 2

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Form2


FrmAktivitaetenListe -Klasse

For a list of all members of this type, see FrmAktivitaetenListe-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmAktivitaetenListe

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class FrmAktivitaetenListe
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmAktivitaetenListe-Member


FrmAktivitaetenListe-Member

FrmAktivitaetenListe Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Fenster schliessen
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Vertragselemente_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf C1Aktivitaeten, damit die Details aktualisiert werden können
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method EreignisAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Ereignis zur Aktivätät anzeigen
private method ErledigtToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FrmAktivitaetenListe_Load Unterstützt von .NET Compact Framework | Load des Formulares
private method Get_Load_Status Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method PendentToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Uebersicht Unterstützt von .NET Compact Framework | Aktualisieren der Aktivitäten-Übersicht
private method StatusSetzenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method StatusSetzenToolStripMenuItem_DropDownItemClicked Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_Click Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion nach Status ändern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Pendenz inaktivieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method VertragselementAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement zur Aktivität anzeigen
private method tsbtnprint_Click Unterstützt von .NET Compact Framework |

Felder

private field Aktivitaet

Unterstützt von .NET Compact Framework
private field Aktivitaeten

Unterstützt von .NET Compact Framework
private field FormReadOnly

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field StatusTable

Unterstützt von .NET Compact Framework
private field Statusdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field daten

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmAktivitaetenListe -Klasse


FrmAktivitaetenListe-Methoden

FrmAktivitaetenListe Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Fenster schliessen
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Vertragselemente_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf C1Aktivitaeten, damit die Details aktualisiert werden können
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method EreignisAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Ereignis zur Aktivätät anzeigen
private method ErledigtToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FrmAktivitaetenListe_Load Unterstützt von .NET Compact Framework | Load des Formulares
private method Get_Load_Status Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method PendentToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Uebersicht Unterstützt von .NET Compact Framework | Aktualisieren der Aktivitäten-Übersicht
private method StatusSetzenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method StatusSetzenToolStripMenuItem_DropDownItemClicked Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_Click Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion nach Status ändern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Pendenz inaktivieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method VertragselementAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement zur Aktivität anzeigen
private method tsbtnprint_Click Unterstützt von .NET Compact Framework |

FrmAktivitaetenListe -Klasse


FrmAktivitaetenListe.BeendenToolStripMenuItem_Click -Methode

Fenster schliessen

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.C1Pendenzen_FetchRowStyle -Methode

Rowstyle von inaktiven Pendenzen

[Visual Basic]
Private Sub C1Pendenzen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Aktivitaeten.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Aktivitaeten.FetchRowStyle
        Try
            If Me.C1Aktivitaeten.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
            If Me.C1Aktivitaeten.Columns("PendenzStatusNr").CellValue(e.Row) < 3 Then
                If Me.C1Aktivitaeten.Columns("Termin").CellValue(e.Row) < Now Then
                    Dim fnt As Font = e.CellStyle.Font
                    e.CellStyle.ForeColor = Color.Red
                End If
            End If

        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.C1Vertragselemente_MouseDown -Methode

Mousedown-Ereignis auf C1Aktivitaeten, damit die Details aktualisiert werden können

[Visual Basic]
Private Sub C1Vertragselemente_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Aktivitaeten.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Aktivitaeten.MouseDown
        Me.C1Aktivitaeten.Bookmark = Me.C1Aktivitaeten.RowContaining(e.Y)
        Me.C1Aktivitaeten.Bookmark = Me.C1Aktivitaeten.RowBookmark(Me.C1Aktivitaeten.RowContaining(e.Y))
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.EreignisAnzeigenToolStripMenuItem_Click -Methode

Ereignis zur Aktivätät anzeigen

[Visual Basic]
Private Sub EreignisAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   EreignisAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub EreignisAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EreignisAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragsereignis(Me.C1Aktivitaeten.Columns("Ereignisnr").Value, 0, True, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.ErledigtToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ErledigtToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ErledigtToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ErledigtToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ErledigtToolStripMenuItem.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.FrmAktivitaetenListe_Load -Methode

Load des Formulares

[Visual Basic]
Private Sub FrmAktivitaetenListe_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmAktivitaetenListe_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_Load_Status()
        Me.StatusToolStripComboBox.SelectedItem = "Pendent"
        Refresh_Uebersicht()
        If Me.FormReadOnly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.Get_Load_Status -Methode

[Visual Basic]
Private Sub Get_Load_Status()

Quellcode

[Visual Basic]
    Private Sub Get_Load_Status()
        '        MsgBox(Me.StatusSetzenToolStripMenuItem.DropDownItems.Count)
        Me.StatusSetzenToolStripMenuItem.DropDownItems.Clear()

        Me.StatusToolStripComboBox.Items.Clear()
        Me.StatusToolStripComboBox.Items.Add("Alle")
        Me.StatusTable.cpMainConnectionProvider = Globals.conn
        Statusdata = Me.StatusTable.SelectAll()
        For Each dr As DataRow In Me.Statusdata.Rows
            If dr.Item("Aktiv") = True Then
                Me.StatusSetzenToolStripMenuItem.DropDownItems.Add(dr.Item("Bezeichnung"))
                Me.StatusToolStripComboBox.Items.Add(dr.Item("Bezeichnung"))
            End If
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(FrmAktivitaetenListe))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.StatusToolStripComboBox = New System.Windows.Forms.ToolStripComboBox
        Me.C1Aktivitaeten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.AktivitaetMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.StatusSetzenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.PendentToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.InBearbeitungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ErledigtToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.EreignisAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragselementAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.tsbtnprint = New System.Windows.Forms.ToolStripButton
        Me.C1PrintPreviewControl1 = New C1.Win.C1Preview.C1PrintPreviewControl
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Aktivitaeten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.AktivitaetMenuStrip.SuspendLayout()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.C1PrintPreviewControl1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(822, 24)
        Me.MenuStrip1.TabIndex = 7
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnDelete, Me.StatusToolStripComboBox, Me.tsbtnprint})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(822, 25)
        Me.ToolStrip1.TabIndex = 8
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'StatusToolStripComboBox
        '
        Me.StatusToolStripComboBox.Items.AddRange(New Object() {"Alle", "Pendent", "In Bearbeitung", "Erledigt"})
        Me.StatusToolStripComboBox.Name = "StatusToolStripComboBox"
        Me.StatusToolStripComboBox.Size = New System.Drawing.Size(121, 25)
        '
        'C1Aktivitaeten
        '
        Me.C1Aktivitaeten.AlternatingRows = True
        Me.C1Aktivitaeten.ContextMenuStrip = Me.AktivitaetMenuStrip
        Me.C1Aktivitaeten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Aktivitaeten.FetchRowStyles = True
        Me.C1Aktivitaeten.FilterBar = True
        Me.C1Aktivitaeten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Aktivitaeten.Images.Add(CType(resources.GetObject("C1Aktivitaeten.Images"), System.Drawing.Image))
        Me.C1Aktivitaeten.Location = New System.Drawing.Point(0, 49)
        Me.C1Aktivitaeten.Name = "C1Aktivitaeten"
        Me.C1Aktivitaeten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Aktivitaeten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Aktivitaeten.PreviewInfo.ZoomFactor = 75
        Me.C1Aktivitaeten.PrintInfo.PageSettings = CType(resources.GetObject("C1Aktivitaeten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Aktivitaeten.Size = New System.Drawing.Size(822, 476)
        Me.C1Aktivitaeten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Aktivitaeten.TabIndex = 13
        Me.C1Aktivitaeten.Text = "C1TrueDBGrid1"
        Me.C1Aktivitaeten.PropBag = resources.GetString("C1Aktivitaeten.PropBag")
        '
        'AktivitaetMenuStrip
        '
        Me.AktivitaetMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.StatusSetzenToolStripMenuItem, Me.ToolStripMenuItem1, Me.EreignisAnzeigenToolStripMenuItem, Me.VertragselementAnzeigenToolStripMenuItem})
        Me.AktivitaetMenuStrip.Name = "AktivitaetMenuStrip"
        Me.AktivitaetMenuStrip.Size = New System.Drawing.Size(211, 76)
        '
        'StatusSetzenToolStripMenuItem
        '
        Me.StatusSetzenToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.PendentToolStripMenuItem, Me.InBearbeitungToolStripMenuItem, Me.ErledigtToolStripMenuItem})
        Me.StatusSetzenToolStripMenuItem.Name = "StatusSetzenToolStripMenuItem"
        Me.StatusSetzenToolStripMenuItem.Size = New System.Drawing.Size(210, 22)
        Me.StatusSetzenToolStripMenuItem.Text = "Status setzen"
        '
        'PendentToolStripMenuItem
        '
        Me.PendentToolStripMenuItem.Name = "PendentToolStripMenuItem"
        Me.PendentToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.PendentToolStripMenuItem.Text = "Pendent"
        '
        'InBearbeitungToolStripMenuItem
        '
        Me.InBearbeitungToolStripMenuItem.Name = "InBearbeitungToolStripMenuItem"
        Me.InBearbeitungToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.InBearbeitungToolStripMenuItem.Text = "In Bearbeitung"
        '
        'ErledigtToolStripMenuItem
        '
        Me.ErledigtToolStripMenuItem.Name = "ErledigtToolStripMenuItem"
        Me.ErledigtToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.ErledigtToolStripMenuItem.Text = "Erledigt"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(207, 6)
        '
        'EreignisAnzeigenToolStripMenuItem
        '
        Me.EreignisAnzeigenToolStripMenuItem.Name = "EreignisAnzeigenToolStripMenuItem"
        Me.EreignisAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(210, 22)
        Me.EreignisAnzeigenToolStripMenuItem.Text = "&Ereignis anzeigen"
        '
        'VertragselementAnzeigenToolStripMenuItem
        '
        Me.VertragselementAnzeigenToolStripMenuItem.Name = "VertragselementAnzeigenToolStripMenuItem"
        Me.VertragselementAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(210, 22)
        Me.VertragselementAnzeigenToolStripMenuItem.Text = "&Vertragselement anzeigen"
        '
        'tsbtnprint
        '
        Me.tsbtnprint.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.tsbtnprint.Image = CType(resources.GetObject("tsbtnprint.Image"), System.Drawing.Image)
        Me.tsbtnprint.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.tsbtnprint.Name = "tsbtnprint"
        Me.tsbtnprint.Size = New System.Drawing.Size(23, 22)
        Me.tsbtnprint.Text = "Drucken"
        '
        'C1PrintPreviewControl1
        '
        Me.C1PrintPreviewControl1.Location = New System.Drawing.Point(103, 52)
        Me.C1PrintPreviewControl1.Name = "C1PrintPreviewControl1"
        '
        'C1PrintPreviewControl1.OutlineView
        '
        Me.C1PrintPreviewControl1.PreviewOutlineView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewOutlineView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewOutlineView.Name = "OutlineView"
        Me.C1PrintPreviewControl1.PreviewOutlineView.Size = New System.Drawing.Size(165, 427)
        Me.C1PrintPreviewControl1.PreviewOutlineView.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewPane
        '
        Me.C1PrintPreviewControl1.PreviewPane.IntegrateExternalTools = True
        Me.C1PrintPreviewControl1.PreviewPane.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewTextSearchPanel
        '
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Dock = System.Windows.Forms.DockStyle.Right
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Location = New System.Drawing.Point(530, 0)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.MinimumSize = New System.Drawing.Size(200, 240)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Name = "PreviewTextSearchPanel"
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Size = New System.Drawing.Size(200, 453)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Visible = False
        '
        'C1PrintPreviewControl1.ThumbnailView
        '
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Name = "ThumbnailView"
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Size = New System.Drawing.Size(165, 348)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewThumbnailView.UseImageAsThumbnail = False
        Me.C1PrintPreviewControl1.Size = New System.Drawing.Size(617, 421)
        Me.C1PrintPreviewControl1.TabIndex = 14
        Me.C1PrintPreviewControl1.Text = "C1PrintPreviewControl1"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Name = "btnHistoryNext"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Size = New System.Drawing.Size(32, 22)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Tag = "C1PreviewActionEnum.HistoryNext"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.ToolTipText = "Next View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Name = "btnHistoryPrev"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Size = New System.Drawing.Size(32, 22)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Tag = "C1PreviewActionEnum.HistoryPrev"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.ToolTipText = "Previous View"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.ToolTipPageNo = Nothing
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Checked = True
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.CheckState = System.Windows.Forms.CheckState.Checked
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.Continuous.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Name = "btnPageContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Tag = "C1PreviewActionEnum.PageContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.ToolTipText = "Continuous View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.Facing.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Name = "btnPageFacing"
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Tag = "C1PreviewActionEnum.PageFacing"
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.ToolTipText = "Pages Facing View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Name = "btnPageFacingContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Tag = "C1PreviewActionEnum.PageFacingContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.ToolTipText = "Pages Facing Continuous View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Text.Find.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Name = "btnFind"
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Size = New System.Drawing.Size(23, 20)
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Tag = "C1PreviewActionEnum.Find"
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.ToolTipText = "Find Text"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Text.SelectText.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Name = "btnSelectTextTool"
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Size = New System.Drawing.Size(23, 20)
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Tag = "C1PreviewActionEnum.SelectTextTool"
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.ToolTipText = "Text Select Tool"
        Me.C1PrintPreviewControl1.Visible = False
        '
        'FrmAktivitaetenListe
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(822, 525)
        Me.Controls.Add(Me.C1PrintPreviewControl1)
        Me.Controls.Add(Me.C1Aktivitaeten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmAktivitaetenListe"
        Me.Text = "Aktivitätenliste"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Aktivitaeten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.AktivitaetMenuStrip.ResumeLayout(False)
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.C1PrintPreviewControl1.ResumeLayout(False)
        Me.C1PrintPreviewControl1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.KontakteMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub KontakteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   AktivitaetMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub KontakteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles AktivitaetMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Aktivitaeten)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.PendentToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub PendentToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PendentToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PendentToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PendentToolStripMenuItem.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.Refresh_Uebersicht -Methode

Aktualisieren der Aktivitäten-Übersicht

[Visual Basic]
Private Sub Refresh_Uebersicht()

Quellcode

[Visual Basic]
    Private Sub Refresh_Uebersicht()
        Me.C1Aktivitaeten.Enabled = False
        Try
            Dim i As Integer = -1
            For Each dr As DataRow In Me.Statusdata.Rows
                If dr.Item("Bezeichnung") = Me.StatusToolStripComboBox.SelectedItem Then i = dr.Item("Aktivitaetstatusnr")
            Next
            '            data = Pendenzen.Get_Pendenzuebersicht(0, Me.StatusToolStripComboBox.SelectedItem)
            '            data = Pendenzen.Get_Pendenzuebersicht(0, i)
            daten = Aktivitaeten.Get_Aktivitaetenliste(i)
            'daten = Aktivitaeten.Get_Aktivitaetenliste(Me.StatusToolStripComboBox.SelectedItem)
        Catch ex As Exception
            Dim i As Integer = -1
            For Each dr As DataRow In Me.Statusdata.Rows
                If dr.Item("Bezeichnung") = Me.StatusToolStripComboBox.SelectedItem Then i = dr.Item("Aktivitaetstatusnr")
            Next
            daten = Aktivitaeten.Get_Aktivitaetenliste(i)
        End Try

        Dim filtertext As String = ""
        Try
            For Each c As C1DataColumn In Me.C1Aktivitaeten.Columns
                If c.FilterText <> "" Then filtertext = filtertext + ";" + c.Caption + ":" + c.FilterText
            Next
        Catch ex As Exception
        End Try
        Me.C1Aktivitaeten.DataSource = daten
        Me.C1Aktivitaeten.DataMember = daten.TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Aktivitaeten, "Aktivitaet", data, False)
        Try
            Dim splitter()
            splitter = filtertext.Split(";")
            If splitter.Length > 1 Then
                For Each s As String In splitter
                    Dim splitter1() As String
                    splitter1 = s.Split(":")
                    Try
                        Me.C1Aktivitaeten.Columns(splitter1(0)).FilterText = splitter1(1)
                    Catch ex As Exception

                    End Try
                Next
            End If
        Catch
        End Try
        Me.C1Aktivitaeten.Enabled = True
        sec.Set_Form_Security(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.StatusSetzenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub StatusSetzenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   StatusSetzenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusSetzenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles StatusSetzenToolStripMenuItem.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.StatusSetzenToolStripMenuItem_DropDownItemClicked -Methode

[Visual Basic]
Private Sub StatusSetzenToolStripMenuItem_DropDownItemClicked( _
   ByVal sender As Object, _
   ByVal e As ToolStripItemClickedEventArgs _
) Handles  _
   StatusSetzenToolStripMenuItem.DropDownItemClicked

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusSetzenToolStripMenuItem_DropDownItemClicked(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs) Handles StatusSetzenToolStripMenuItem.DropDownItemClicked
        Dim i As Integer = -1
        Dim akt As Boolean = False
        For Each dr As DataRow In Me.Statusdata.Rows
            If dr.Item("Bezeichnung") = e.ClickedItem.Text Then
                i = dr.Item("Aktivitaetstatusnr")
                If dr.Item("Aktivitaet_Aktivieren") = True Then akt = True Else akt = False

            End If
        Next
        Me.Aktivitaet.Status_Wechsel(Me.C1Aktivitaeten.Columns("Aktivitaetnr").Value, i, akt)
        Me.Refresh_Uebersicht()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.StatusToolStripComboBox_Click -Methode

[Visual Basic]
Private Sub StatusToolStripComboBox_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   StatusToolStripComboBox.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusToolStripComboBox_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles StatusToolStripComboBox.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.StatusToolStripComboBox_SelectedIndexChanged -Methode

Selektion nach Status ändern

[Visual Basic]
Private Sub StatusToolStripComboBox_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   StatusToolStripComboBox.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusToolStripComboBox_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles StatusToolStripComboBox.SelectedIndexChanged
        Refresh_Uebersicht()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.TSBtnDelete_Click -Methode

Pendenz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(850) = MsgBoxResult.Yes Then
            Me.Aktivitaet.Delete_Aktivitaet(Me.C1Aktivitaeten.Columns("AktivitaetNr").Value)
            Me.Refresh_Uebersicht()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.VertragselementAnzeigenToolStripMenuItem_Click -Methode

Vertragselement zur Aktivität anzeigen

[Visual Basic]
Private Sub VertragselementAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragselementAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragselementAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragselementAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragselement(Me.C1Aktivitaeten.Columns("Vertragselementnr").Value, True, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe.tsbtnprint_Click -Methode

[Visual Basic]
Private Sub tsbtnprint_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   tsbtnprint.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tsbtnprint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles tsbtnprint.Click
        Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
        Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

        With Me.C1Aktivitaeten.PrintInfo
            .PageHeaderStyle.Font = fontbold
            .PageSettings.Margins.Bottom = 20
            .PageSettings.Margins.Top = 20
            .PageSettings.Landscape = True
            .PageFooter = "Seite \p von \P" & vbLf & "Druckdatum " & Now()
            .PageHeader = "Aktivitäten"
            .ShowProgressForm = True
            .UseGridColors = True
            .RepeatColumnHeaders = True
            .VarRowHeight = .RowHeightEnum.StretchToFit
            .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
            .PageBreak = .PageBreaksEnum.OnColumn
            .FillAreaWidth = .FillEmptyEnum.None
            .PrintPreview()
        End With

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmAktivitaetenListe-Felder

FrmAktivitaetenListe Übersicht

Felder

private field Aktivitaet

Unterstützt von .NET Compact Framework
private field Aktivitaeten

Unterstützt von .NET Compact Framework
private field FormReadOnly

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field StatusTable

Unterstützt von .NET Compact Framework
private field Statusdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field daten

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmAktivitaetenListe -Klasse


Aktivitaet -Feld

[Visual Basic]
Private Aktivitaet As clsAktivitaet

Quellcode

[Visual Basic]
    Dim Aktivitaet As New TKB.VV.Vertrag.clsAktivitaet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


Aktivitaeten -Feld

[Visual Basic]
Private Aktivitaeten As clsAktivitaeten

Quellcode

[Visual Basic]
    Dim Aktivitaeten As New TKB.VV.Vertrag.clsAktivitaeten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FormReadOnly -Feld

[Visual Basic]
Private ReadOnly FormReadOnly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadOnly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


StatusTable -Feld

[Visual Basic]
Private StatusTable As clsAktivitaetStatus

Quellcode

[Visual Basic]
    Dim StatusTable As New TKB.VV.DB.clsAktivitaetStatus

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


Statusdata -Feld

[Visual Basic]
Private Statusdata As DataTable

Quellcode

[Visual Basic]
    Dim Statusdata As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


data -Feld

[Visual Basic]
Private data As DataTable

Quellcode

[Visual Basic]
    Dim data As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


daten -Feld

[Visual Basic]
Private daten As DataTable

Quellcode

[Visual Basic]
    Dim daten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmAktivitaetenListe


FrmExcelExport -Klasse

For a list of all members of this type, see FrmExcelExport-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmExcelExport

[Visual Basic]
Public Class FrmExcelExport
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmExcelExport-Member


FrmExcelExport-Member

FrmExcelExport Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

FrmExcelExport -Klasse


FrmExcelExport-Methoden

FrmExcelExport Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

FrmExcelExport -Klasse


FrmExcelExport.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmExcelExport


FrmExcelExport.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.Label1 = New System.Windows.Forms.Label
        Me.ProgressBar1 = New System.Windows.Forms.ProgressBar
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(12, 18)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(261, 13)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Die Daten werden nach Excel-Exportiert. Bitte warten."
        '
        'ProgressBar1
        '
        Me.ProgressBar1.Location = New System.Drawing.Point(15, 57)
        Me.ProgressBar1.Name = "ProgressBar1"
        Me.ProgressBar1.Size = New System.Drawing.Size(353, 23)
        Me.ProgressBar1.TabIndex = 1
        '
        'FrmExcelExport
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(380, 98)
        Me.Controls.Add(Me.ProgressBar1)
        Me.Controls.Add(Me.Label1)
        Me.Name = "FrmExcelExport"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Excel-Export"
        Me.TopMost = True
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmExcelExport


FrmExcelExport-Felder

FrmExcelExport Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

FrmExcelExport -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmExcelExport


FrmGenerateActivity -Klasse

For a list of all members of this type, see FrmGenerateActivity-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmGenerateActivity

[Visual Basic]
Public Class FrmGenerateActivity
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmGenerateActivity-Member


FrmGenerateActivity-Member

FrmGenerateActivity Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

FrmGenerateActivity -Klasse


FrmGenerateActivity-Methoden

FrmGenerateActivity Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework

FrmGenerateActivity -Klasse


FrmGenerateActivity.Button1_Click -Methode

[Visual Basic]
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim datum As String = ""
        datum = Me.DateTimePicker1.Value.ToString
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_generate_activity"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@datum", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, datum))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            Throw New Exception("clsDok::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmGenerateActivity


FrmGenerateActivity.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmGenerateActivity


FrmGenerateActivity.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker
        Me.Button1 = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.CustomFormat = "DD.MM.YYYY"
        Me.DateTimePicker1.Location = New System.Drawing.Point(78, 38)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(200, 20)
        Me.DateTimePicker1.TabIndex = 0
        Me.DateTimePicker1.Value = New Date(2009, 2, 2, 0, 0, 0, 0)
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(78, 104)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(200, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "Aktivitäten generieren"
        Me.Button1.UseVisualStyleBackColor = True
        '
        'FrmGenerateActivity
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(384, 238)
        Me.Controls.Add(Me.Button1)
        Me.Controls.Add(Me.DateTimePicker1)
        Me.Name = "FrmGenerateActivity"
        Me.Text = "FrmGenerateActivity"
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmGenerateActivity


FrmGenerateActivity-Felder

FrmGenerateActivity Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

FrmGenerateActivity -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmGenerateActivity


FrmLizenz -Klasse

For a list of all members of this type, see FrmLizenz-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmLizenz

[Visual Basic]
Public Class FrmLizenz
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmLizenz-Member


FrmLizenz-Member

FrmLizenz Übersicht

Öffentliche Konstruktoren

public constructor FrmLizenz -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Lizenzkäufe_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Lizenzkäufe_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Lizenzkäufe_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzkäufe_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Lizenzköufen
private method C1Lizenzkäufe_Leave Unterstützt von .NET Compact Framework | Prüfung auf Änderungen, sofern das Grid "C1Lizenzkäufe" verlassen wird
private method C1Lizenzkäufe_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf Lizenzkauf
private method C1Lizenzschluessel_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Lizenzschluessel_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Lizenzschluessel_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzschluessel_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Lizenzschlüssel
private method C1Lizenzschluessel_Leave Unterstützt von .NET Compact Framework | Prüfung auf Änderungen, sofern das Grid "C1Lizenzschlüssel" verlassen wird
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method FrmLizenz_Load Unterstützt von .NET Compact Framework |
private method Get_Lizenzkauf Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Lizenzschluessel_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung des Grids Lizenzschlüssel
private method Set_Lizenzkauf_Filter Unterstützt von .NET Compact Framework | Filter in der Spalte Aktiv des Grids C1Lizenzkauf ändern
private method Set_Lizenzschluessel_Filter Unterstützt von .NET Compact Framework | Filter in der Spalte Aktiv des Grids C1Lizenzschluessel ändern
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method ToolStrip1_ItemClicked Unterstützt von .NET Compact Framework |
private method cbLizenzkaufAktiv_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbLizenzkaufAktiv_CheckedChanged_1 Unterstützt von .NET Compact Framework | Anzeige gem. Aktivstatus ändern
private method cbLizenzschluesselAktiv_CheckedChanged Unterstützt von .NET Compact Framework | Anzeige gem. Aktivstatus ändern

Felder

private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikation

Unterstützt von .NET Compact Framework
private field Applikationnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Lizenztyp

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field clsLizenztyp

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmLizenz -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void FrmLizenz();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Integer, Boolean)
[C#] public System.Void FrmLizenz(int, int, bool);

FrmLizenz


FrmLizenz-Methoden

FrmLizenz Übersicht

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Lizenzkäufe_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Lizenzkäufe_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Lizenzkäufe_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzkäufe_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Lizenzköufen
private method C1Lizenzkäufe_Leave Unterstützt von .NET Compact Framework | Prüfung auf Änderungen, sofern das Grid "C1Lizenzkäufe" verlassen wird
private method C1Lizenzkäufe_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf Lizenzkauf
private method C1Lizenzschluessel_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Lizenzschluessel_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Lizenzschluessel_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzschluessel_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Lizenzschlüssel
private method C1Lizenzschluessel_Leave Unterstützt von .NET Compact Framework | Prüfung auf Änderungen, sofern das Grid "C1Lizenzschlüssel" verlassen wird
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method FrmLizenz_Load Unterstützt von .NET Compact Framework |
private method Get_Lizenzkauf Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Lizenzschluessel_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung des Grids Lizenzschlüssel
private method Set_Lizenzkauf_Filter Unterstützt von .NET Compact Framework | Filter in der Spalte Aktiv des Grids C1Lizenzkauf ändern
private method Set_Lizenzschluessel_Filter Unterstützt von .NET Compact Framework | Filter in der Spalte Aktiv des Grids C1Lizenzschluessel ändern
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method ToolStrip1_ItemClicked Unterstützt von .NET Compact Framework |
private method cbLizenzkaufAktiv_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbLizenzkaufAktiv_CheckedChanged_1 Unterstützt von .NET Compact Framework | Anzeige gem. Aktivstatus ändern
private method cbLizenzschluesselAktiv_CheckedChanged Unterstützt von .NET Compact Framework | Anzeige gem. Aktivstatus ändern

FrmLizenz -Klasse


FrmLizenz.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Lizenzkäufe_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Lizenzkäufe.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Lizenzkäufe.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1Lizenzkäufe.Columns.Count - 1
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mutiert_am" Then Me.C1Lizenzkäufe.Columns(i).Value = Now
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mutierer" Then Me.C1Lizenzkäufe.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Lizenzkäufe.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey("Lizenzkauf")
                Me.C1Lizenzkäufe.Columns(0).Value = key
                For i = 0 To Me.C1Lizenzkäufe.Columns.Count - 1
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "securitylevel" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "aktiv" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "extern" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "vertragselementnr" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = Me.Vertragselementnr
                    End If
                    If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "applikationnr" Then
                        Me.C1Lizenzkäufe.Columns(i).Value = Me.Applikationnr
                    End If

                Next
                dbkey.Dispose()
            End If
            Me.Lizenzschluessel_Aktualisieren()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_AfterInsert -Methode

Aktualisierung der Default-Werte

[Visual Basic]
Private Sub C1Lizenzkäufe_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Lizenzkäufe.AfterInsert

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Lizenzkäufe.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1Lizenzkäufe.Columns.Count - 1
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "aktiv" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = 1
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "vertragselementnr" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Me.Vertragselementnr
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "applikationnr" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Me.Applikationnr
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Now
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mutierer" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mandantnr" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1Lizenzkäufe.Columns(i).DataField) = "mandnat" Then
                    Me.C1Lizenzkäufe.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
            Me.Lizenzschluessel_Aktualisieren()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Lizenzkäufe_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Lizenzkäufe.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Lizenzkäufe.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = "DokumentAblageOrt"
        Try
            ts.Feld = Me.C1Lizenzkäufe.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_FetchRowStyle -Methode

Rowstyle von inaktiven Lizenzköufen

[Visual Basic]
Private Sub C1Lizenzkäufe_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Lizenzkäufe.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Lizenzkäufe.FetchRowStyle
        Try
            If Me.C1Lizenzkäufe.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_Leave -Methode

Prüfung auf Änderungen, sofern das Grid "C1Lizenzkäufe" verlassen wird

[Visual Basic]
Private Sub C1Lizenzkäufe_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Lizenzkäufe.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Lizenzkäufe.Leave
        Try
            If Me.Vertragselement.Lizenzinformationen.Lizenzkauf.Tabledata.HasChanges Then
                If msg.Show_MessageYesNoCancel(800) = MsgBoxResult.Yes Then
                    Me.Vertragselement.Lizenzinformationen.Lizenzkauf.Save_Data()
                End If
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzkäufe_MouseDown -Methode

Mousedown-Ereignis auf Lizenzkauf

[Visual Basic]
Private Sub C1Lizenzkäufe_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Lizenzkäufe.MouseDown, _
   C1Lizenzkäufe.MouseUp

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Lizenzkäufe.MouseDown, C1Lizenzkäufe.MouseUp
        Me.Lizenzschluessel_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzschluessel_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Lizenzschluessel_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Lizenzschluessel.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Lizenzschluessel.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1Lizenzschluessel.Columns.Count - 1
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mutiert_am" Then Me.C1Lizenzschluessel.Columns(i).Value = Now
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mutierer" Then Me.C1Lizenzschluessel.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Lizenzschluessel.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey("Lizenzschluessel")
                Me.C1Lizenzschluessel.Columns(0).Value = key
                For i = 0 To Me.C1Lizenzschluessel.Columns.Count - 1
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "securitylevel" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "aktiv" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "extern" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "lizenzkaufnr" Then
                        Me.C1Lizenzschluessel.Columns(i).Value = Me.C1Lizenzkäufe.Columns(0).Value
                    End If

                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzschluessel_AfterInsert -Methode

Aktualisierung der Default-Werte

[Visual Basic]
Private Sub C1Lizenzschluessel_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Lizenzschluessel.AfterInsert

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Lizenzschluessel.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1Lizenzschluessel.Columns.Count - 1
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "aktiv" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = 1
                End If
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "lizenzkaufnr" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = Me.C1Lizenzkäufe.Columns(0).Value
                End If
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = Now
                End If
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mutierer" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mandantnr" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1Lizenzschluessel.Columns(i).DataField) = "mandnat" Then
                    Me.C1Lizenzschluessel.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzschluessel_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Lizenzschluessel_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Lizenzschluessel.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Lizenzschluessel.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = "DokumentAblageOrt"
        Try
            ts.Feld = Me.C1Lizenzschluessel.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzschluessel_FetchRowStyle -Methode

Rowstyle von inaktiven Lizenzschlüssel

[Visual Basic]
Private Sub C1Lizenzschluessel_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Lizenzschluessel.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Lizenzschluessel.FetchRowStyle
        Try
            If Me.C1Lizenzschluessel.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.C1Lizenzschluessel_Leave -Methode

Prüfung auf Änderungen, sofern das Grid "C1Lizenzschlüssel" verlassen wird

[Visual Basic]
Private Sub C1Lizenzschluessel_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Lizenzschluessel.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Lizenzschluessel.Leave
        Try
            If Me.Vertragselement.Lizenzinformationen.Lizenzschluessel.Tabledata.HasChanges Then
                If msg.Show_MessageYesNoCancel(801) = MsgBoxResult.Yes Then
                    Me.Vertragselement.Lizenzinformationen.Lizenzschluessel.Save_Data()
                End If
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    'Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.FrmLizenz_Load -Methode

[Visual Basic]
Private Sub FrmLizenz_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmLizenz_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Vertragselement.Lizenzinformationen.Get_Lizenzkauf(Me.Vertragselementnr, Me.C1Lizenzkäufe, Me.Applikationnr)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Lizenzkäufe, "Lizenzkauf", Me.Vertragselement.Lizenzinformationen.Lizenzkauf.Tabledata)
        Set_Lizenzkauf_Filter()
        Me.Lizenzschluessel_Aktualisieren()
        Me.Applikation.cpMainConnectionProvider = Globals.conn
        Me.Applikation.iApplikationNr = New SqlInt32(CType(Me.Applikationnr, Int32))
        Me.Applikation.SelectOne()
        Me.Text = "Lizenzverwaltung " + Me.Applikation.sBezeichnung.Value
        Me.Applikation.Dispose()

        Me.Lizenztyp.Rows.Clear()
        Me.clsLizenztyp.cpMainConnectionProvider = Globals.conn
        Me.Lizenztyp = Me.clsLizenztyp.SelectAll

        Me.C1LizenztypDropDwon.DataSource = Me.Lizenztyp
        Dim i As Integer
        For i = 0 To Me.C1LizenztypDropDwon.DisplayColumns.Count - 1
            Me.C1LizenztypDropDwon.DisplayColumns(i).Visible = False
        Next
        Me.C1LizenztypDropDwon.DisplayColumns("Bezeichnung").Visible = True
        Me.C1LizenztypDropDwon.ValueMember = "Lizenztypnr"
        Me.C1LizenztypDropDwon.DisplayMember = "Bezeichnung"
        Me.C1LizenztypDropDwon.ValueTranslate = True
        Me.C1Lizenzkäufe.Columns("Lizenztypnr").DropDown = Me.C1LizenztypDropDwon
        Me.C1Lizenzkäufe.Columns("Lizenztypnr").ValueItems.Translate = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.Get_Lizenzkauf -Methode

[Visual Basic]
Private Function Get_Lizenzkauf() As DataTable

Quellcode

[Visual Basic]
    Private Function Get_Lizenzkauf() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_lizenzkauf"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Vertragselementnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@applikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Applikationnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("clsParentelemente::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(FrmLizenz))
        Dim Style1 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style2 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style3 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style4 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style5 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style6 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style7 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style8 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Me.C1Lizenzkäufe = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.cbLizenzschluesselAktiv = New System.Windows.Forms.CheckBox
        Me.cbLizenzkaufAktiv = New System.Windows.Forms.CheckBox
        Me.C1Lizenzschluessel = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.GrpLizenzen = New System.Windows.Forms.GroupBox
        Me.C1LizenztypDropDwon = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.GrpLizenzschlüssel = New System.Windows.Forms.GroupBox
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        CType(Me.C1Lizenzkäufe, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1Lizenzschluessel, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.GrpLizenzen.SuspendLayout()
        CType(Me.C1LizenztypDropDwon, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpLizenzschlüssel.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'C1Lizenzkäufe
        '
        Me.C1Lizenzkäufe.AlternatingRows = True
        Me.C1Lizenzkäufe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Lizenzkäufe.FetchRowStyles = True
        Me.C1Lizenzkäufe.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Lizenzkäufe.Images.Add(CType(resources.GetObject("C1Lizenzkäufe.Images"), System.Drawing.Image))
        Me.C1Lizenzkäufe.Location = New System.Drawing.Point(3, 16)
        Me.C1Lizenzkäufe.Name = "C1Lizenzkäufe"
        Me.C1Lizenzkäufe.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Lizenzkäufe.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Lizenzkäufe.PreviewInfo.ZoomFactor = 75
        Me.C1Lizenzkäufe.PrintInfo.PageSettings = CType(resources.GetObject("C1Lizenzkäufe.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Lizenzkäufe.Size = New System.Drawing.Size(938, 149)
        Me.C1Lizenzkäufe.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Lizenzkäufe.TabIndex = 12
        Me.C1Lizenzkäufe.Text = "C1TrueDBGrid1"
        Me.C1Lizenzkäufe.PropBag = resources.GetString("C1Lizenzkäufe.PropBag")
        '
        'cbLizenzschluesselAktiv
        '
        Me.cbLizenzschluesselAktiv.AutoSize = True
        Me.cbLizenzschluesselAktiv.Checked = True
        Me.cbLizenzschluesselAktiv.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cbLizenzschluesselAktiv.Location = New System.Drawing.Point(89, 0)
        Me.cbLizenzschluesselAktiv.Name = "cbLizenzschluesselAktiv"
        Me.cbLizenzschluesselAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbLizenzschluesselAktiv.TabIndex = 17
        Me.cbLizenzschluesselAktiv.ThreeState = True
        Me.cbLizenzschluesselAktiv.UseVisualStyleBackColor = True
        '
        'cbLizenzkaufAktiv
        '
        Me.cbLizenzkaufAktiv.AutoSize = True
        Me.cbLizenzkaufAktiv.Checked = True
        Me.cbLizenzkaufAktiv.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cbLizenzkaufAktiv.Location = New System.Drawing.Point(56, 0)
        Me.cbLizenzkaufAktiv.Name = "cbLizenzkaufAktiv"
        Me.cbLizenzkaufAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbLizenzkaufAktiv.TabIndex = 16
        Me.cbLizenzkaufAktiv.ThreeState = True
        Me.cbLizenzkaufAktiv.UseVisualStyleBackColor = True
        '
        'C1Lizenzschluessel
        '
        Me.C1Lizenzschluessel.AlternatingRows = True
        Me.C1Lizenzschluessel.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Lizenzschluessel.FetchRowStyles = True
        Me.C1Lizenzschluessel.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Lizenzschluessel.Images.Add(CType(resources.GetObject("C1Lizenzschluessel.Images"), System.Drawing.Image))
        Me.C1Lizenzschluessel.Location = New System.Drawing.Point(3, 16)
        Me.C1Lizenzschluessel.Name = "C1Lizenzschluessel"
        Me.C1Lizenzschluessel.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Lizenzschluessel.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Lizenzschluessel.PreviewInfo.ZoomFactor = 75
        Me.C1Lizenzschluessel.PrintInfo.PageSettings = CType(resources.GetObject("C1Lizenzschluessel.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Lizenzschluessel.Size = New System.Drawing.Size(938, 181)
        Me.C1Lizenzschluessel.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Lizenzschluessel.TabIndex = 15
        Me.C1Lizenzschluessel.Text = "C1TrueDBGrid1"
        Me.C1Lizenzschluessel.PropBag = resources.GetString("C1Lizenzschluessel.PropBag")
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        Me.SplitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.GrpLizenzen)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.GrpLizenzschlüssel)
        Me.SplitContainer1.Size = New System.Drawing.Size(944, 372)
        Me.SplitContainer1.SplitterDistance = 168
        Me.SplitContainer1.TabIndex = 18
        '
        'GrpLizenzen
        '
        Me.GrpLizenzen.Controls.Add(Me.C1LizenztypDropDwon)
        Me.GrpLizenzen.Controls.Add(Me.C1Lizenzkäufe)
        Me.GrpLizenzen.Controls.Add(Me.cbLizenzkaufAktiv)
        Me.GrpLizenzen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpLizenzen.Location = New System.Drawing.Point(0, 0)
        Me.GrpLizenzen.Name = "GrpLizenzen"
        Me.GrpLizenzen.Size = New System.Drawing.Size(944, 168)
        Me.GrpLizenzen.TabIndex = 0
        Me.GrpLizenzen.TabStop = False
        Me.GrpLizenzen.Text = "Lizenzen"
        '
        'C1LizenztypDropDwon
        '
        Me.C1LizenztypDropDwon.AllowColMove = True
        Me.C1LizenztypDropDwon.AllowColSelect = True
        Me.C1LizenztypDropDwon.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1LizenztypDropDwon.AlternatingRows = False
        Me.C1LizenztypDropDwon.CaptionStyle = Style1
        Me.C1LizenztypDropDwon.ColumnCaptionHeight = 17
        Me.C1LizenztypDropDwon.ColumnFooterHeight = 17
        Me.C1LizenztypDropDwon.EvenRowStyle = Style2
        Me.C1LizenztypDropDwon.FetchRowStyles = False
        Me.C1LizenztypDropDwon.FooterStyle = Style3
        Me.C1LizenztypDropDwon.HeadingStyle = Style4
        Me.C1LizenztypDropDwon.HighLightRowStyle = Style5
        Me.C1LizenztypDropDwon.Images.Add(CType(resources.GetObject("C1LizenztypDropDwon.Images"), System.Drawing.Image))
        Me.C1LizenztypDropDwon.Location = New System.Drawing.Point(12, 36)
        Me.C1LizenztypDropDwon.Name = "C1LizenztypDropDwon"
        Me.C1LizenztypDropDwon.OddRowStyle = Style6
        Me.C1LizenztypDropDwon.RecordSelectorStyle = Style7
        Me.C1LizenztypDropDwon.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1LizenztypDropDwon.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1LizenztypDropDwon.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1LizenztypDropDwon.ScrollTips = False
        Me.C1LizenztypDropDwon.Size = New System.Drawing.Size(100, 105)
        Me.C1LizenztypDropDwon.Style = Style8
        Me.C1LizenztypDropDwon.TabIndex = 17
        Me.C1LizenztypDropDwon.Text = "C1TrueDBDropdown1"
        Me.C1LizenztypDropDwon.Visible = False
        Me.C1LizenztypDropDwon.PropBag = resources.GetString("C1LizenztypDropDwon.PropBag")
        '
        'GrpLizenzschlüssel
        '
        Me.GrpLizenzschlüssel.Controls.Add(Me.cbLizenzschluesselAktiv)
        Me.GrpLizenzschlüssel.Controls.Add(Me.C1Lizenzschluessel)
        Me.GrpLizenzschlüssel.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpLizenzschlüssel.Location = New System.Drawing.Point(0, 0)
        Me.GrpLizenzschlüssel.Name = "GrpLizenzschlüssel"
        Me.GrpLizenzschlüssel.Size = New System.Drawing.Size(944, 200)
        Me.GrpLizenzschlüssel.TabIndex = 0
        Me.GrpLizenzschlüssel.TabStop = False
        Me.GrpLizenzschlüssel.Text = "Lizenzschlüssel"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(944, 24)
        Me.MenuStrip1.TabIndex = 19
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(944, 25)
        Me.ToolStrip1.TabIndex = 20
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'FrmLizenz
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(944, 421)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmLizenz"
        Me.Text = "Lizenz"
        CType(Me.C1Lizenzkäufe, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1Lizenzschluessel, System.ComponentModel.ISupportInitialize).EndInit()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.GrpLizenzen.ResumeLayout(False)
        Me.GrpLizenzen.PerformLayout()
        CType(Me.C1LizenztypDropDwon, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpLizenzschlüssel.ResumeLayout(False)
        Me.GrpLizenzschlüssel.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.Lizenzschluessel_Aktualisieren -Methode

Aktualiserung des Grids Lizenzschlüssel

[Visual Basic]
Private Sub Lizenzschluessel_Aktualisieren()

Quellcode

[Visual Basic]
    Private Sub Lizenzschluessel_Aktualisieren()

        Try
            Me.Vertragselement.Lizenzinformationen.Get_Lizenzschluessel(Me.C1Lizenzkäufe.Columns(0).Value, Me.C1Lizenzschluessel)
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Lizenzschluessel, "Lizenzschluessel", Me.Vertragselement.Lizenzinformationen.Lizenzschluessel.Tabledata)
            Set_Lizenzschluessel_Filter()
        Catch ex As Exception
            Exit Sub
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.Set_Lizenzkauf_Filter -Methode

Filter in der Spalte Aktiv des Grids C1Lizenzkauf ändern

[Visual Basic]
Private Sub Set_Lizenzkauf_Filter()

Quellcode

[Visual Basic]
    Private Sub Set_Lizenzkauf_Filter()
        Try
            Select Case Me.cbLizenzkaufAktiv.CheckState
                Case CheckState.Checked
                    Me.C1Lizenzkäufe.Columns("Aktiv").FilterText = True
                Case CheckState.Indeterminate
                    Me.C1Lizenzkäufe.Columns("Aktiv").FilterText = ""
                Case CheckState.Unchecked
                    Me.C1Lizenzkäufe.Columns("Aktiv").FilterText = False
            End Select
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.Set_Lizenzschluessel_Filter -Methode

Filter in der Spalte Aktiv des Grids C1Lizenzschluessel ändern

[Visual Basic]
Private Sub Set_Lizenzschluessel_Filter()

Quellcode

[Visual Basic]
    Private Sub Set_Lizenzschluessel_Filter()
        Try
            Select Case Me.cbLizenzschluesselAktiv.CheckState
                Case CheckState.Checked
                    Me.C1Lizenzschluessel.Columns("Aktiv").FilterText = True
                Case CheckState.Indeterminate
                    Me.C1Lizenzschluessel.Columns("Aktiv").FilterText = ""
                Case CheckState.Unchecked
                    Me.C1Lizenzschluessel.Columns("Aktiv").FilterText = False
            End Select
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Vertragselement.Lizenzinformationen.Lizenzkauf.Save_Data()
        Me.Vertragselement.Lizenzinformationen.Lizenzschluessel.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.ToolStrip1_ItemClicked -Methode

[Visual Basic]
Private Sub ToolStrip1_ItemClicked( _
   ByVal sender As Object, _
   ByVal e As ToolStripItemClickedEventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ToolStrip1_ItemClicked(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolStripItemClickedEventArgs)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.cbLizenzkaufAktiv_CheckedChanged -Methode

[Visual Basic]
Private Sub cbLizenzkaufAktiv_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbLizenzkaufAktiv.CheckStateChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbLizenzkaufAktiv_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbLizenzkaufAktiv.CheckStateChanged
        Set_Lizenzkauf_Filter()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.cbLizenzkaufAktiv_CheckedChanged_1 -Methode

Anzeige gem. Aktivstatus ändern

[Visual Basic]
Private Sub cbLizenzkaufAktiv_CheckedChanged_1( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbLizenzkaufAktiv.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbLizenzkaufAktiv_CheckedChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbLizenzkaufAktiv.CheckedChanged
        Set_Lizenzkauf_Filter()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.cbLizenzschluesselAktiv_CheckedChanged -Methode

Anzeige gem. Aktivstatus ändern

[Visual Basic]
Private Sub cbLizenzschluesselAktiv_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbLizenzschluesselAktiv.CheckStateChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbLizenzschluesselAktiv_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbLizenzschluesselAktiv.CheckStateChanged
        Set_Lizenzschluessel_Filter()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

FrmLizenz


FrmLizenz-Felder

FrmLizenz Übersicht

Felder

private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikation

Unterstützt von .NET Compact Framework
private field Applikationnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Lizenztyp

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field clsLizenztyp

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmLizenz -Klasse


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Applikation -Feld

[Visual Basic]
Private Applikation As clsApplikation

Quellcode

[Visual Basic]
    Dim Applikation As New TKB.VV.DB.clsApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Applikationnr -Feld

[Visual Basic]
Private Applikationnr As Integer

Quellcode

[Visual Basic]
    Dim Applikationnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Lizenztyp -Feld

[Visual Basic]
Private Lizenztyp As DataTable

Quellcode

[Visual Basic]
    Dim Lizenztyp As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Vertragselement -Feld

[Visual Basic]
Private Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
    Dim Vertragselement As New TKB.VV.Vertrag.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


Vertragselementnr -Feld

[Visual Basic]
Private Vertragselementnr As Integer

Quellcode

[Visual Basic]
    Dim Vertragselementnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


clsLizenztyp -Feld

[Visual Basic]
Private clsLizenztyp As clsLizenztyp

Quellcode

[Visual Basic]
    Dim clsLizenztyp As New TKB.VV.DB.clsLizenztyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmReleaseLogbuch -Klasse

For a list of all members of this type, see FrmReleaseLogbuch-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmReleaseLogbuch

[Visual Basic]
Public Class FrmReleaseLogbuch
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmReleaseLogbuch-Member


FrmReleaseLogbuch-Member

FrmReleaseLogbuch Übersicht

Öffentliche Konstruktoren

public constructor FrmReleaseLogbuch -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework |
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DokumentMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method FrmReleaseLogbuch_Load Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt

Felder

private field ApplikationLogbuch

Unterstützt von .NET Compact Framework
private field ApplikationLogbuchNr

Unterstützt von .NET Compact Framework
private field Applikationsnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmReleaseLogbuch -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void FrmReleaseLogbuch();

[Visual Basic] Public Sub New(Integer, Integer, Optional Boolean, Optional Boolean)
[C#] public System.Void FrmReleaseLogbuch(int, int, bool, bool);

FrmReleaseLogbuch


FrmReleaseLogbuch-Methoden

FrmReleaseLogbuch Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework |
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DokumentMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method FrmReleaseLogbuch_Load Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt

FrmReleaseLogbuch -Klasse


FrmReleaseLogbuch.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
            If TypeOf c Is ListBox Then
                Dim ctl As ListBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.C1Dokumente_DoubleClick -Methode

[Visual Basic]
Private Sub C1Dokumente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Dokumente.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Dokumente.DoubleClick
        Try
            Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then
            Return True
            Exit Function
        End If
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_Data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtFachlicheAbnahme.ValueChanged, _
   dtTechnischeAbnahme.ValueChanged, _
   dtFreigabe.ValueChanged, _
   DtReleaseDatum.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _
        dtFachlicheAbnahme.ValueChanged, dtTechnischeAbnahme.ValueChanged, dtFreigabe.ValueChanged, DtReleaseDatum.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(2, s.Length - 2)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If

        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.DokumentAnzeigenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DokumentAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(Me.C1Dokumente.Columns("Dokumentnr").Value, 4, Me.ApplikationLogbuchNr, Me.FormReadonly, False)
            f.ShowDialog()
            Refresh_Dokumente()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.DokumentLöschenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DokumentLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(275) = MsgBoxResult.Yes Then
                Me.ApplikationLogbuch.Dokument.Delete_Dokument(Me.C1Dokumente.Columns("Dokumentnr").Value)
                Me.Refresh_Dokumente()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.DokumentMenuStrip_Opening -Methode

[Visual Basic]
Private Sub DokumentMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   DokumentMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles DokumentMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Dokumente)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.DokumentNeuToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DokumentNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentNeuToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(0, 4, Me.ApplikationLogbuchNr, Me.FormReadonly, True)
            '         f.MdiParent = Me.MdiParent
            f.ShowDialog()
            Refresh_Dokumente()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Dokument_Anzeigen_Dokument_ToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Dokument_Anzeigen_Dokument_ToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Dokument_Anzeigen_Dokument_ToolStripMenuItem.Click
        Try
            Me.ApplikationLogbuch.Dokument.Show_Doc(Me.C1Dokumente.Columns("Dokumentnr").Value)
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.ApplikationLogbuch.Neuer_Datensatz = True Then Me.ApplikationLogbuch.Delete(Me.ApplikationLogbuch.iApplikationLogbuchNr.Value)
            Globals.MyEventHanlder.ReleaseLobuchClosed()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.FrmReleaseLogbuch_Load -Methode

[Visual Basic]
Private Sub FrmReleaseLogbuch_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmReleaseLogbuch_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If
        Me.cboReleaseArt.DataSource = Me.ApplikationLogbuch.Releasearten
        Me.cboReleaseArt.DisplayMember = "Bezeichnung"
        Me.cboReleaseArt.ValueMember = "Releaseartnr"

        Me.cboTecPerson.DataSource = Me.ApplikationLogbuch.Personen
        Me.cboTecPerson.DisplayMember = "Bezeichnung"
        Me.cboTecPerson.ValueMember = "Personnr"

        Me.cboFachperson.DataSource = Me.ApplikationLogbuch.Personen1
        Me.cboFachperson.DisplayMember = "Bezeichnung"
        Me.cboFachperson.ValueMember = "Personnr"

        Me.cboFreigabePerson.DataSource = Me.ApplikationLogbuch.Personen2
        Me.cboFreigabePerson.DisplayMember = "Bezeichnung"
        Me.cboFreigabePerson.ValueMember = "Personnr"

        Me.AddChanges(Me)
        Get_Data(Me.ApplikationLogbuchNr)
        If Me.Neuer_Datensatz = True Then
            Me.ApplikationLogbuch.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly = True Then
            Me.TSBtnSave.Enabled = False
            sec.Set_Form_Readonly(Me)
        End If
        Refresh_Dokumente()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Get_Data -Methode

Person laden und präsentieren

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.ApplikationLogbuch.Get_ApplikationLogbuch(Nr)
        Me.txtReleaseDatum.Text = Me.ApplikationLogbuch.daReleasedatum.ToString
        Me.cboReleaseArt.SelectedValue = Me.ApplikationLogbuch.iReleaseartnr.Value
        Me.txtBezeichnung.Text = Me.ApplikationLogbuch.sBezeichnung.Value
        Me.txtBemerkung.Text = Me.ApplikationLogbuch.sBemerkung.Value

        Me.cboFachperson.SelectedValue = Me.ApplikationLogbuch.iAbnahmeFBPerson.Value
        Me.txtFachlicheAbnahme.Text = Me.ApplikationLogbuch.daAbnahmeFBDatum.ToSqlString
        Me.cboTecPerson.SelectedValue = Me.ApplikationLogbuch.iAbnahmeTecPerson.Value
        Me.txtTechnischeAbnahme.Text = Me.ApplikationLogbuch.daAbnahmeTecDatum.ToString
        Me.cboFreigabePerson.SelectedValue = Me.ApplikationLogbuch.iFreigabedurch.Value
        Me.txtFreigabe.Text = Me.ApplikationLogbuch.daFreigabeDatum.ToString
        Me.cbAktiv.Checked = Me.ApplikationLogbuch.bAktiv.Value = True
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(FrmReleaseLogbuch))
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblReleaseDatum = New System.Windows.Forms.Label
        Me.lblReleaseArt = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.GrpReleaseInfo = New System.Windows.Forms.GroupBox
        Me.txtReleaseDatum = New System.Windows.Forms.MaskedTextBox
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.Label4 = New System.Windows.Forms.Label
        Me.cboReleaseArt = New System.Windows.Forms.ComboBox
        Me.DtReleaseDatum = New System.Windows.Forms.DateTimePicker
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.GrpFreigaben = New System.Windows.Forms.GroupBox
        Me.txtFreigabe = New System.Windows.Forms.MaskedTextBox
        Me.txtTechnischeAbnahme = New System.Windows.Forms.MaskedTextBox
        Me.txtFachlicheAbnahme = New System.Windows.Forms.MaskedTextBox
        Me.dtFreigabe = New System.Windows.Forms.DateTimePicker
        Me.cboFreigabePerson = New System.Windows.Forms.ComboBox
        Me.dtTechnischeAbnahme = New System.Windows.Forms.DateTimePicker
        Me.cboTecPerson = New System.Windows.Forms.ComboBox
        Me.dtFachlicheAbnahme = New System.Windows.Forms.DateTimePicker
        Me.cboFachperson = New System.Windows.Forms.ComboBox
        Me.lblFrachlicheAbnahme = New System.Windows.Forms.Label
        Me.lblTechnischeAbnahme = New System.Windows.Forms.Label
        Me.lblFreigabe = New System.Windows.Forms.Label
        Me.GrpDokumente = New System.Windows.Forms.GroupBox
        Me.C1Dokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DokumentMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DokumentAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripSeparator1 = New System.Windows.Forms.ToolStripSeparator
        Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageListeDocIcon = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolStrip1.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.GrpReleaseInfo.SuspendLayout()
        Me.GrpFreigaben.SuspendLayout()
        Me.GrpDokumente.SuspendLayout()
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DokumentMenuStrip.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(518, 25)
        Me.ToolStrip1.TabIndex = 9
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(518, 24)
        Me.MenuStrip1.TabIndex = 10
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'lblReleaseDatum
        '
        Me.lblReleaseDatum.AutoSize = True
        Me.lblReleaseDatum.Location = New System.Drawing.Point(21, 23)
        Me.lblReleaseDatum.Name = "lblReleaseDatum"
        Me.lblReleaseDatum.Size = New System.Drawing.Size(92, 13)
        Me.lblReleaseDatum.TabIndex = 11
        Me.lblReleaseDatum.Text = "Datum Produktion"
        '
        'lblReleaseArt
        '
        Me.lblReleaseArt.AutoSize = True
        Me.lblReleaseArt.Location = New System.Drawing.Point(21, 48)
        Me.lblReleaseArt.Name = "lblReleaseArt"
        Me.lblReleaseArt.Size = New System.Drawing.Size(62, 13)
        Me.lblReleaseArt.TabIndex = 12
        Me.lblReleaseArt.Text = "Release-Art"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(21, 75)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(86, 13)
        Me.lblBezeichnung.TabIndex = 13
        Me.lblBezeichnung.Text = "Version/Release"
        '
        'GrpReleaseInfo
        '
        Me.GrpReleaseInfo.Controls.Add(Me.txtReleaseDatum)
        Me.GrpReleaseInfo.Controls.Add(Me.cbAktiv)
        Me.GrpReleaseInfo.Controls.Add(Me.txtBemerkung)
        Me.GrpReleaseInfo.Controls.Add(Me.Label4)
        Me.GrpReleaseInfo.Controls.Add(Me.cboReleaseArt)
        Me.GrpReleaseInfo.Controls.Add(Me.DtReleaseDatum)
        Me.GrpReleaseInfo.Controls.Add(Me.txtBezeichnung)
        Me.GrpReleaseInfo.Controls.Add(Me.lblReleaseDatum)
        Me.GrpReleaseInfo.Controls.Add(Me.lblBezeichnung)
        Me.GrpReleaseInfo.Controls.Add(Me.lblReleaseArt)
        Me.GrpReleaseInfo.Location = New System.Drawing.Point(12, 61)
        Me.GrpReleaseInfo.Name = "GrpReleaseInfo"
        Me.GrpReleaseInfo.Size = New System.Drawing.Size(490, 156)
        Me.GrpReleaseInfo.TabIndex = 14
        Me.GrpReleaseInfo.TabStop = False
        Me.GrpReleaseInfo.Text = "Release-Informationen"
        '
        'txtReleaseDatum
        '
        Me.txtReleaseDatum.Location = New System.Drawing.Point(118, 22)
        Me.txtReleaseDatum.Mask = "00/00/0000"
        Me.txtReleaseDatum.Name = "txtReleaseDatum"
        Me.txtReleaseDatum.Size = New System.Drawing.Size(66, 20)
        Me.txtReleaseDatum.TabIndex = 0
        Me.txtReleaseDatum.ValidatingType = GetType(Date)
        '
        'cbAktiv
        '
        Me.cbAktiv.AutoSize = True
        Me.cbAktiv.Location = New System.Drawing.Point(389, 26)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(50, 17)
        Me.cbAktiv.TabIndex = 5
        Me.cbAktiv.Text = "Aktiv"
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(118, 101)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(321, 48)
        Me.txtBemerkung.TabIndex = 4
        '
        'Label4
        '
        Me.Label4.AutoSize = True
        Me.Label4.Location = New System.Drawing.Point(21, 101)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(61, 13)
        Me.Label4.TabIndex = 17
        Me.Label4.Text = "Bemerkung"
        '
        'cboReleaseArt
        '
        Me.cboReleaseArt.FormattingEnabled = True
        Me.cboReleaseArt.Location = New System.Drawing.Point(118, 48)
        Me.cboReleaseArt.Name = "cboReleaseArt"
        Me.cboReleaseArt.Size = New System.Drawing.Size(121, 21)
        Me.cboReleaseArt.TabIndex = 2
        '
        'DtReleaseDatum
        '
        Me.DtReleaseDatum.Format = System.Windows.Forms.DateTimePickerFormat.[Short]
        Me.DtReleaseDatum.Location = New System.Drawing.Point(183, 22)
        Me.DtReleaseDatum.Name = "DtReleaseDatum"
        Me.DtReleaseDatum.Size = New System.Drawing.Size(18, 20)
        Me.DtReleaseDatum.TabIndex = 1
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(118, 75)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(321, 20)
        Me.txtBezeichnung.TabIndex = 3
        '
        'GrpFreigaben
        '
        Me.GrpFreigaben.Controls.Add(Me.txtFreigabe)
        Me.GrpFreigaben.Controls.Add(Me.txtTechnischeAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.txtFachlicheAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.dtFreigabe)
        Me.GrpFreigaben.Controls.Add(Me.cboFreigabePerson)
        Me.GrpFreigaben.Controls.Add(Me.dtTechnischeAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.cboTecPerson)
        Me.GrpFreigaben.Controls.Add(Me.dtFachlicheAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.cboFachperson)
        Me.GrpFreigaben.Controls.Add(Me.lblFrachlicheAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.lblTechnischeAbnahme)
        Me.GrpFreigaben.Controls.Add(Me.lblFreigabe)
        Me.GrpFreigaben.Location = New System.Drawing.Point(12, 233)
        Me.GrpFreigaben.Name = "GrpFreigaben"
        Me.GrpFreigaben.Size = New System.Drawing.Size(490, 112)
        Me.GrpFreigaben.TabIndex = 15
        Me.GrpFreigaben.TabStop = False
        Me.GrpFreigaben.Text = "Abnahmen / Freigaben"
        '
        'txtFreigabe
        '
        Me.txtFreigabe.Location = New System.Drawing.Point(310, 76)
        Me.txtFreigabe.Mask = "00/00/0000"
        Me.txtFreigabe.Name = "txtFreigabe"
        Me.txtFreigabe.Size = New System.Drawing.Size(66, 20)
        Me.txtFreigabe.TabIndex = 7
        Me.txtFreigabe.ValidatingType = GetType(Date)
        '
        'txtTechnischeAbnahme
        '
        Me.txtTechnischeAbnahme.Location = New System.Drawing.Point(310, 50)
        Me.txtTechnischeAbnahme.Mask = "00/00/0000"
        Me.txtTechnischeAbnahme.Name = "txtTechnischeAbnahme"
        Me.txtTechnischeAbnahme.Size = New System.Drawing.Size(66, 20)
        Me.txtTechnischeAbnahme.TabIndex = 4
        Me.txtTechnischeAbnahme.ValidatingType = GetType(Date)
        '
        'txtFachlicheAbnahme
        '
        Me.txtFachlicheAbnahme.Location = New System.Drawing.Point(310, 25)
        Me.txtFachlicheAbnahme.Mask = "00/00/0000"
        Me.txtFachlicheAbnahme.Name = "txtFachlicheAbnahme"
        Me.txtFachlicheAbnahme.Size = New System.Drawing.Size(66, 20)
        Me.txtFachlicheAbnahme.TabIndex = 1
        Me.txtFachlicheAbnahme.ValidatingType = GetType(Date)
        '
        'dtFreigabe
        '
        Me.dtFreigabe.Format = System.Windows.Forms.DateTimePickerFormat.[Short]
        Me.dtFreigabe.Location = New System.Drawing.Point(375, 77)
        Me.dtFreigabe.Name = "dtFreigabe"
        Me.dtFreigabe.Size = New System.Drawing.Size(19, 20)
        Me.dtFreigabe.TabIndex = 8
        '
        'cboFreigabePerson
        '
        Me.cboFreigabePerson.AutoCompleteMode = System.Windows.Forms.AutoCompleteMode.Append
        Me.cboFreigabePerson.AutoCompleteSource = System.Windows.Forms.AutoCompleteSource.ListItems
        Me.cboFreigabePerson.FormattingEnabled = True
        Me.cboFreigabePerson.Location = New System.Drawing.Point(157, 77)
        Me.cboFreigabePerson.Name = "cboFreigabePerson"
        Me.cboFreigabePerson.Size = New System.Drawing.Size(147, 21)
        Me.cboFreigabePerson.TabIndex = 6
        '
        'dtTechnischeAbnahme
        '
        Me.dtTechnischeAbnahme.Format = System.Windows.Forms.DateTimePickerFormat.[Short]
        Me.dtTechnischeAbnahme.Location = New System.Drawing.Point(375, 50)
        Me.dtTechnischeAbnahme.Name = "dtTechnischeAbnahme"
        Me.dtTechnischeAbnahme.Size = New System.Drawing.Size(19, 20)
        Me.dtTechnischeAbnahme.TabIndex = 5
        '
        'cboTecPerson
        '
        Me.cboTecPerson.AutoCompleteMode = System.Windows.Forms.AutoCompleteMode.Append
        Me.cboTecPerson.AutoCompleteSource = System.Windows.Forms.AutoCompleteSource.ListItems
        Me.cboTecPerson.FormattingEnabled = True
        Me.cboTecPerson.Location = New System.Drawing.Point(157, 50)
        Me.cboTecPerson.Name = "cboTecPerson"
        Me.cboTecPerson.Size = New System.Drawing.Size(147, 21)
        Me.cboTecPerson.TabIndex = 3
        '
        'dtFachlicheAbnahme
        '
        Me.dtFachlicheAbnahme.Format = System.Windows.Forms.DateTimePickerFormat.[Short]
        Me.dtFachlicheAbnahme.Location = New System.Drawing.Point(375, 25)
        Me.dtFachlicheAbnahme.Name = "dtFachlicheAbnahme"
        Me.dtFachlicheAbnahme.Size = New System.Drawing.Size(19, 20)
        Me.dtFachlicheAbnahme.TabIndex = 2
        '
        'cboFachperson
        '
        Me.cboFachperson.AutoCompleteMode = System.Windows.Forms.AutoCompleteMode.Append
        Me.cboFachperson.AutoCompleteSource = System.Windows.Forms.AutoCompleteSource.ListItems
        Me.cboFachperson.FormattingEnabled = True
        Me.cboFachperson.Location = New System.Drawing.Point(157, 24)
        Me.cboFachperson.Name = "cboFachperson"
        Me.cboFachperson.Size = New System.Drawing.Size(147, 21)
        Me.cboFachperson.TabIndex = 0
        '
        'lblFrachlicheAbnahme
        '
        Me.lblFrachlicheAbnahme.AutoSize = True
        Me.lblFrachlicheAbnahme.Location = New System.Drawing.Point(21, 27)
        Me.lblFrachlicheAbnahme.Name = "lblFrachlicheAbnahme"
        Me.lblFrachlicheAbnahme.Size = New System.Drawing.Size(101, 13)
        Me.lblFrachlicheAbnahme.TabIndex = 11
        Me.lblFrachlicheAbnahme.Text = "Fachliche Abnahme"
        '
        'lblTechnischeAbnahme
        '
        Me.lblTechnischeAbnahme.AutoSize = True
        Me.lblTechnischeAbnahme.Location = New System.Drawing.Point(21, 53)
        Me.lblTechnischeAbnahme.Name = "lblTechnischeAbnahme"
        Me.lblTechnischeAbnahme.Size = New System.Drawing.Size(111, 13)
        Me.lblTechnischeAbnahme.TabIndex = 13
        Me.lblTechnischeAbnahme.Text = "Technische Abnahme"
        '
        'lblFreigabe
        '
        Me.lblFreigabe.AutoSize = True
        Me.lblFreigabe.Location = New System.Drawing.Point(22, 77)
        Me.lblFreigabe.Name = "lblFreigabe"
        Me.lblFreigabe.Size = New System.Drawing.Size(48, 13)
        Me.lblFreigabe.TabIndex = 12
        Me.lblFreigabe.Text = "Freigabe"
        '
        'GrpDokumente
        '
        Me.GrpDokumente.Controls.Add(Me.C1Dokumente)
        Me.GrpDokumente.Location = New System.Drawing.Point(12, 351)
        Me.GrpDokumente.Name = "GrpDokumente"
        Me.GrpDokumente.Size = New System.Drawing.Size(490, 123)
        Me.GrpDokumente.TabIndex = 16
        Me.GrpDokumente.TabStop = False
        Me.GrpDokumente.Text = "Dokumente"
        '
        'C1Dokumente
        '
        Me.C1Dokumente.AlternatingRows = True
        Me.C1Dokumente.ContextMenuStrip = Me.DokumentMenuStrip
        Me.C1Dokumente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Dokumente.FetchRowStyles = True
        Me.C1Dokumente.FilterBar = True
        Me.C1Dokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Dokumente.Images.Add(CType(resources.GetObject("C1Dokumente.Images"), System.Drawing.Image))
        Me.C1Dokumente.Location = New System.Drawing.Point(3, 16)
        Me.C1Dokumente.Name = "C1Dokumente"
        Me.C1Dokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Dokumente.PreviewInfo.ZoomFactor = 75
        Me.C1Dokumente.PrintInfo.PageSettings = CType(resources.GetObject("C1Dokumente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Dokumente.Size = New System.Drawing.Size(484, 104)
        Me.C1Dokumente.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Dokumente.TabIndex = 0
        Me.C1Dokumente.Text = "C1TrueDBGrid1"
        Me.C1Dokumente.PropBag = resources.GetString("C1Dokumente.PropBag")
        '
        'DokumentMenuStrip
        '
        Me.DokumentMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DokumentAnzeigenToolStripMenuItem, Me.DokumentNeuToolStripMenuItem, Me.DokumentLöschenToolStripMenuItem, Me.ToolStripSeparator1, Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem})
        Me.DokumentMenuStrip.Name = "DrehbuchMenuStrip"
        Me.DokumentMenuStrip.Size = New System.Drawing.Size(181, 98)
        '
        'DokumentAnzeigenToolStripMenuItem
        '
        Me.DokumentAnzeigenToolStripMenuItem.Name = "DokumentAnzeigenToolStripMenuItem"
        Me.DokumentAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'DokumentNeuToolStripMenuItem
        '
        Me.DokumentNeuToolStripMenuItem.Name = "DokumentNeuToolStripMenuItem"
        Me.DokumentNeuToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentNeuToolStripMenuItem.Text = "&Neu"
        '
        'DokumentLöschenToolStripMenuItem
        '
        Me.DokumentLöschenToolStripMenuItem.Name = "DokumentLöschenToolStripMenuItem"
        Me.DokumentLöschenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStripSeparator1
        '
        Me.ToolStripSeparator1.Name = "ToolStripSeparator1"
        Me.ToolStripSeparator1.Size = New System.Drawing.Size(177, 6)
        '
        'Dokument_Anzeigen_Dokument_ToolStripMenuItem
        '
        Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem.Name = "Dokument_Anzeigen_Dokument_ToolStripMenuItem"
        Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.Dokument_Anzeigen_Dokument_ToolStripMenuItem.Text = "&Dokument anzeigen"
        '
        'ImageListeDocIcon
        '
        Me.ImageListeDocIcon.ImageStream = CType(resources.GetObject("ImageListeDocIcon.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeDocIcon.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeDocIcon.Images.SetKeyName(0, "PDF.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(1, "Word5.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(2, "Excel1.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(3, "PowerPoint.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(4, "html.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(5, "Mail.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(6, "Document1.ico")
        '
        'FrmReleaseLogbuch
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(518, 482)
        Me.Controls.Add(Me.GrpDokumente)
        Me.Controls.Add(Me.GrpFreigaben)
        Me.Controls.Add(Me.GrpReleaseInfo)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmReleaseLogbuch"
        Me.Text = "Release-Logbuch-Eintrag"
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.GrpReleaseInfo.ResumeLayout(False)
        Me.GrpReleaseInfo.PerformLayout()
        Me.GrpFreigaben.ResumeLayout(False)
        Me.GrpFreigaben.PerformLayout()
        Me.GrpDokumente.ResumeLayout(False)
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DokumentMenuStrip.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Refresh_Dokumente -Methode

Dokumetne_Aktualisieren

[Visual Basic]
Private Sub Refresh_Dokumente()

Quellcode

[Visual Basic]
    Private Sub Refresh_Dokumente()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Dokumente.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Dokumente.Bookmark

        Me.C1Dokumente.Enabled = False

        Me.ApplikationLogbuch.Get_Dokumente(Me.C1Dokumente, Me.ImageListeDocIcon)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Dokumente, "Dokument", Me.ApplikationLogbuch.dokumente)
        If filtertext <> "none" Then Me.C1Dokumente.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)
        Try
            Me.C1Dokumente.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Dokumente.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.Save_Data -Methode

Daten sichern, sofern Änderungen vorgenommen worden sind

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            If IsDate(Me.txtReleaseDatum.Text) Then
                Me.ApplikationLogbuch.daReleasedatum = New SqlDateTime(CType(Me.txtReleaseDatum.Text, SqlDateTime))
            Else
                Me.ApplikationLogbuch.daReleasedatum = New SqlDateTime(CType(SqlDateTime.Null, SqlDateTime))
            End If

            Me.ApplikationLogbuch.iReleaseartnr = New SqlInt32(CType(Me.cboReleaseArt.SelectedValue, Int32))
            Me.ApplikationLogbuch.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
            Me.ApplikationLogbuch.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))

            Me.ApplikationLogbuch.iAbnahmeFBPerson = New SqlInt32(CType(Me.cboFachperson.SelectedValue, Int32))
            If IsDate(Me.txtFachlicheAbnahme.Text) Then
                Me.ApplikationLogbuch.daAbnahmeFBDatum = New SqlDateTime(CType(Me.txtFachlicheAbnahme.Text, SqlDateTime))
            Else
                Me.ApplikationLogbuch.daAbnahmeFBDatum = New SqlDateTime(CType(SqlDateTime.Null, SqlDateTime))
            End If

            Me.ApplikationLogbuch.iAbnahmeTecPerson = New SqlInt32(CType(Me.cboTecPerson.SelectedValue, Int32))
            If IsDate(Me.txtTechnischeAbnahme.Text) Then
                Me.ApplikationLogbuch.daAbnahmeTecDatum = New SqlDateTime(CType(Me.txtTechnischeAbnahme.Text, SqlDateTime))
            Else
                Me.ApplikationLogbuch.daAbnahmeTecDatum = New SqlDateTime(CType(SqlDateTime.Null, SqlDateTime))
            End If

            Me.ApplikationLogbuch.iFreigabedurch = New SqlInt32(CType(Me.cboFreigabePerson.SelectedValue, Int32))
            If IsDate(Me.txtFreigabe.Text) Then
                Me.ApplikationLogbuch.daFreigabeDatum = New SqlDateTime(CType(Me.txtFreigabe.Text, SqlDateTime))
            Else
                Me.ApplikationLogbuch.daFreigabeDatum = New SqlDateTime(CType(SqlDateTime.Null, SqlDateTime))
            End If
            Me.ApplikationLogbuch.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Get_Data(Me.ApplikationLogbuch.Save_Data)
            Me.FormDataChanged = False
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.ApplikationLogbuch.Delete_ApplikationLogubuch(Me.ApplikationLogbuch.iApplikationLogbuchNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch-Felder

FrmReleaseLogbuch Übersicht

Felder

private field ApplikationLogbuch

Unterstützt von .NET Compact Framework
private field ApplikationLogbuchNr

Unterstützt von .NET Compact Framework
private field Applikationsnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

FrmReleaseLogbuch -Klasse


ApplikationLogbuch -Feld

[Visual Basic]
Private ApplikationLogbuch As clsApplikationLogbuch

Quellcode

[Visual Basic]
    Dim ApplikationLogbuch As New TKB.VV.Applikation.clsApplikationLogbuch

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


ApplikationLogbuchNr -Feld

[Visual Basic]
Private ApplikationLogbuchNr As Integer

Quellcode

[Visual Basic]
    Private ApplikationLogbuchNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


Applikationsnr -Feld

[Visual Basic]
Private Applikationsnr As Integer

Quellcode

[Visual Basic]
    Private Applikationsnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReportSelect -Klasse

For a list of all members of this type, see FrmReportSelect-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmReportSelect

[Visual Basic]
Public Class FrmReportSelect
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmReportSelect-Member


FrmReportSelect-Member

FrmReportSelect Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Formualr schliessen
private method BtnAufbereitenCR_Click Unterstützt von .NET Compact Framework |
private method BtnInitParam_Click Unterstützt von .NET Compact Framework |
private method BtnParamDel1_Click Unterstützt von .NET Compact Framework |
private method ComboboxMAParameter_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method ComboboxMAParameter_VisibleChanged Unterstützt von .NET Compact Framework |
private method Findrow Unterstützt von .NET Compact Framework | Datenrow in den zur Auswertung gehörenden Parameterliste suchen
private method FrmReportSelect_Load Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_SQLWhere Unterstützt von .NET Compact Framework | Where Bedingung für die Abfrage zusammenstellen
private method Init_ParamRow Unterstützt von .NET Compact Framework |
private method Init_Params Unterstützt von .NET Compact Framework | Parameter initialisieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ParamNr Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TXP_Auswertung Unterstützt von .NET Compact Framework |
private method TXP_AuswertungCR Unterstützt von .NET Compact Framework |
private method TreeAuswertungen_AfterSelect Unterstützt von .NET Compact Framework | Nach Selektion eines Nodes Parameter neu aufbereiten und Auswerungsmöglichkeit (CR/CSV) anzeigen
private method TreeAuswertungen_DoubleClick Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method btnAbbruch_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method btnAufbereiten_Click Unterstützt von .NET Compact Framework |
private method btnDeleteSavedParam_Click Unterstützt von .NET Compact Framework |
private method btnSave_Click Unterstützt von .NET Compact Framework |
private method cbandor1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cbparam1_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion Parameter
private method cbvalue1_DropDown Unterstützt von .NET Compact Framework |
private method get_where Unterstützt von .NET Compact Framework | Where zusammenstellen

Felder

private field Auswertungsdaten

Unterstützt von .NET Compact Framework
private field CtrlList

Unterstützt von .NET Compact Framework
private field On_Load

Unterstützt von .NET Compact Framework
private field SQLWhere

Unterstützt von .NET Compact Framework
private field auswertungen

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field dr

Unterstützt von .NET Compact Framework
private field s

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework
private field splits

Unterstützt von .NET Compact Framework
private field tt

Unterstützt von .NET Compact Framework

FrmReportSelect -Klasse


FrmReportSelect-Methoden

FrmReportSelect Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Formualr schliessen
private method BtnAufbereitenCR_Click Unterstützt von .NET Compact Framework |
private method BtnInitParam_Click Unterstützt von .NET Compact Framework |
private method BtnParamDel1_Click Unterstützt von .NET Compact Framework |
private method ComboboxMAParameter_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method ComboboxMAParameter_VisibleChanged Unterstützt von .NET Compact Framework |
private method Findrow Unterstützt von .NET Compact Framework | Datenrow in den zur Auswertung gehörenden Parameterliste suchen
private method FrmReportSelect_Load Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_SQLWhere Unterstützt von .NET Compact Framework | Where Bedingung für die Abfrage zusammenstellen
private method Init_ParamRow Unterstützt von .NET Compact Framework |
private method Init_Params Unterstützt von .NET Compact Framework | Parameter initialisieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ParamNr Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TXP_Auswertung Unterstützt von .NET Compact Framework |
private method TXP_AuswertungCR Unterstützt von .NET Compact Framework |
private method TreeAuswertungen_AfterSelect Unterstützt von .NET Compact Framework | Nach Selektion eines Nodes Parameter neu aufbereiten und Auswerungsmöglichkeit (CR/CSV) anzeigen
private method TreeAuswertungen_DoubleClick Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method btnAbbruch_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method btnAufbereiten_Click Unterstützt von .NET Compact Framework |
private method btnDeleteSavedParam_Click Unterstützt von .NET Compact Framework |
private method btnSave_Click Unterstützt von .NET Compact Framework |
private method cbandor1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cbparam1_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion Parameter
private method cbvalue1_DropDown Unterstützt von .NET Compact Framework |
private method get_where Unterstützt von .NET Compact Framework | Where zusammenstellen

FrmReportSelect -Klasse


FrmReportSelect.AlleKnotenSchliessenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AlleKnotenSchliessenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AlleKnotenSchliessenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AlleKnotenSchliessenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AlleKnotenSchliessenToolStripMenuItem.Click
        Me.TreeAuswertungen.CollapseAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.AlleKnotenÖffnenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AlleKnotenÖffnenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AlleKnotenÖffnenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AlleKnotenÖffnenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AlleKnotenÖffnenToolStripMenuItem.Click
        Me.TreeAuswertungen.ExpandAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.BeendenToolStripMenuItem_Click -Methode

Formualr schliessen

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        btnAbbruch_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.BtnAufbereitenCR_Click -Methode

[Visual Basic]
Private Sub BtnAufbereitenCR_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnAufbereitenCR.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnAufbereitenCR_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnAufbereitenCR.Click
        Me.Cursor = Cursors.WaitCursor
        Me.auswertungen.TitelZeile1 = Me.txtTitel1.Text
        Me.auswertungen.TitelZeile2 = Me.txtTitel2.Text
        If Me.auswertungen.Auswertung.bTXP_Auswertung.Value = True Then
            TXP_AuswertungCR()
            Me.Cursor = Cursors.Default
            Exit Sub
        End If
        Get_SQLWhere()
        Me.Auswertungsdaten = Me.auswertungen.Get_Auswertungsdaten(Me.auswertungen.Auswertung.sSQL.Value, SQLWhere)
        Dim f As New frmcrreporting(Me.Auswertungsdaten, Me.auswertungen.Auswertung.iAuswertungNr.Value, Me.auswertungen, Me.checkboxprintparam.Checked)
        f.MdiParent = Me.MdiParent
        Me.Cursor = Cursors.Default
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.BtnInitParam_Click -Methode

[Visual Basic]
Private Sub BtnInitParam_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnInitParam.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnInitParam_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnInitParam.Click
        Me.Init_Params()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.BtnParamDel1_Click -Methode

[Visual Basic]
Private Sub BtnParamDel1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnParamDel1.Click, _
   BtnParamDel2.Click, _
   BtnParamDel3.Click, _
   BtnParamDel4.Click, _
   BtnParamDel5.Click, _
   BtnParamDel6.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnParamDel1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnParamDel1.Click, BtnParamDel2.Click, _
        BtnParamDel3.Click, BtnParamDel4.Click, BtnParamDel5.Click, BtnParamDel6.Click
        Init_ParamRow(Me.ParamNr(sender.name))
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.ComboboxMAParameter_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub ComboboxMAParameter_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ComboboxMAParameter.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ComboboxMAParameter_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ComboboxMAParameter.SelectedIndexChanged
        If Me.On_Load = True Then Exit Sub
        Try
            Dim s As String = ""
            For Each dr As DataRow In Me.auswertungen.MitarbeiterAuswertungsparameter.Rows
                If dr.Item("Mitarbeiter_AuswertungsparameterNr") = Me.ComboboxMAParameter.SelectedValue Then
                    s = dr.Item("Parameterdaten")
                    Me.txtTitel1.Text = dr.Item("Titelzeile1")
                    Me.txtTitel2.Text = dr.Item("Titelzeile2")
                    Me.checkboxprintparam.Checked = dr.Item("ParamPrint")
                End If
            Next
            If s = "" Then Exit Sub

            Me.Init_Params(False)

            Dim grp() As String = s.Split("|")
            Dim andor As String = grp(0)
            Dim param As String = grp(1)
            Dim op As String = grp(2)
            Dim val As String = grp(3)

            Dim tmpvalue() As String
            Dim ValueItem() As String
            Dim tmpparam() As String
            Dim ParamItem() As String
            Dim tmpop() As String
            Dim opItem() As String
            Dim tmpandor() As String
            Dim andorItem() As String
            Dim tmpcbidx As Integer
            Dim vals() As String

            Dim CTLIndex As Integer
            Dim CTLAndOr As String
            Dim CTLParam As String
            Dim CTLOP As String
            Dim CTLValue As String
            Dim CTLSplit() As String
            Dim SelIndexSet As Boolean

            Dim i As Integer
            For i = 6 To 0 Step -1
                tmpvalue = val.ToString.Split(";")
                If tmpvalue(i).ToString.Length > 2 Then
                    ValueItem = tmpvalue(i).Split("~")
                    CTLIndex = ValueItem(0)
                    CTLValue = ValueItem(1)

                    tmpparam = param.Split(";")
                    ParamItem = tmpparam(i).Split("~")
                    CTLParam = ParamItem(1)

                    tmpop = op.Split(";")
                    opItem = tmpop(i).Split("~")
                    CTLOP = opItem(1)

                    If i > 1 Then
                        tmpandor = andor.Split(";")
                        andorItem = tmpandor(i - 1).Split("~")
                        CTLAndOr = andorItem(1)
                    End If

                    'Parameter
                    Dim l As New List(Of Control)
                    Me.GetControl(Me, "cbparam" + Trim(Str(CTLIndex)), l)
                    Dim x As ComboBox = l(0)

                    SelIndexSet = False
                    Dim ii As Integer = 0
                    For ii = 0 To x.Items.Count - 1
                        If x.Items(ii).ToString = CTLParam Then
                            x.SelectedIndex = ii
                            SelIndexSet = True
                        End If
                    Next
                    If SelIndexSet = False Then x.Text = CTLParam

                    'Operator
                    l.Clear()
                    Me.GetControl(Me, "cbop" + Trim(Str(CTLIndex)), l)
                    x = l(0)
                    SelIndexSet = False
                    For ii = 0 To x.Items.Count - 1
                        If x.Items(ii).ToString = CTLOP Then
                            x.SelectedIndex = ii
                            SelIndexSet = True
                        End If
                    Next
                    If SelIndexSet = False Then x.Text = CTLOP

                    'value
                    l.Clear()
                    Me.GetControl(Me, "cbvalue" + Trim(Str(CTLIndex)), l)
                    x = l(0)
                    SelIndexSet = False
                    For ii = 0 To x.Items.Count - 1
                        If x.Items(ii).ToString = CTLValue Then
                            x.SelectedIndex = ii
                            SelIndexSet = True
                        End If
                    Next
                    If SelIndexSet = False Then x.Text = CTLValue

                    'andor
                    l.Clear()
                    Me.GetControl(Me, "cbandor" + Trim(Str(CTLIndex)), l)
                    x = l(0)
                    SelIndexSet = False
                    For ii = 0 To x.Items.Count - 1
                        If x.Items(ii).ToString = CTLAndOr Then
                            x.SelectedIndex = ii
                            SelIndexSet = True
                        End If
                    Next
                    If SelIndexSet = False Then x.Text = CTLAndOr

                End If
            Next

        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.ComboboxMAParameter_VisibleChanged -Methode

[Visual Basic]
Private Sub ComboboxMAParameter_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ComboboxMAParameter.VisibleChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ComboboxMAParameter_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ComboboxMAParameter.VisibleChanged
        Me.btnDeleteSavedParam.Visible = Me.ComboboxMAParameter.Visible
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.Findrow -Methode

Datenrow in den zur Auswertung gehörenden Parameterliste suchen

[Visual Basic]
Private Function Findrow( _
   ByVal key As String _
) As DataRow

Parameter

key

Quellcode

[Visual Basic]
    Private Function Findrow(ByVal key As String) As DataRow
        For Each dr As DataRow In Me.auswertungen.AuswertungParameter.Rows
            If dr.Item("Bezeichnung") = key Then
                Return dr
            End If
        Next
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.FrmReportSelect_Load -Methode

[Visual Basic]
Private Sub FrmReportSelect_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmReportSelect_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            tt.Set_ToolTips(Me)
            auswertungen.Get_Auswertungen(Me.TreeAuswertungen)
            Me.TreeAuswertungen.CollapseAll()
            Me.TreeAuswertungen.SelectedNode = Me.TreeAuswertungen.Nodes(0)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.Get_SQLWhere -Methode

Where Bedingung für die Abfrage zusammenstellen

[Visual Basic]
Private Sub Get_SQLWhere()

Quellcode

[Visual Basic]
    Private Sub Get_SQLWhere()
        Me.auswertungen.ParamCollection.Clear()
        Dim s As String
        Dim i As Integer
        Me.SQLWhere = ""

        If Me.cbparam1.Text <> "" And Me.cbop1.Text <> "" And Me.cbvalue1.Text <> "" Then
            Me.auswertungen.ParamCollection.Add(cbparam1.Text & " " & cbop1.Text & " " & cbvalue1.Text)
            s = cbparam1.Text & " " & cbop1.Text & " " & cbvalue1.Text
            SQLWhere = SQLWhere + get_where(1)
        End If
        If Me.cbandor1.Text <> "" And Me.cbparam2.Text <> "" And Me.cbop2.Text <> "" And Me.cbvalue2.Text <> "" Then
            If Me.cbandor1.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(2)
            If Me.cbandor1.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(2)
            Me.auswertungen.ParamCollection.Add(cbandor1.Text + " " + cbparam2.Text & " " & cbop2.Text & " " & cbvalue2.Text)
            s = s & "' & Chr(10) & Chr(13) & '" & cbandor1.Text & " " & cbparam2.Text & " " & cbop2.Text & " " & cbvalue2.Text
        End If
        If Me.cbandor2.Text <> "" And Me.cbparam3.Text <> "" And Me.cbop3.Text <> "" And Me.cbvalue3.Text <> "" Then
            If Me.cbandor2.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(3)
            If Me.cbandor2.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(3)
            Me.auswertungen.ParamCollection.Add(cbandor2.Text + " " + cbparam3.Text & " " & cbop3.Text & " " & cbvalue3.Text)
            s = s + " " + cbandor2.Text + " " + cbparam3.Text & " " & cbop3.Text & " " & cbvalue3.Text
        End If
        If Me.cbandor3.Text <> "" And Me.cbparam4.Text <> "" And Me.cbop4.Text <> "" And Me.cbvalue4.Text <> "" Then
            If Me.cbandor3.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(4)
            If Me.cbandor3.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(4)
            Me.auswertungen.ParamCollection.Add(cbandor3.Text + " " + cbparam4.Text & " " & cbop4.Text & " " & cbvalue4.Text)
            s = s + " " + cbandor3.Text + " " + cbparam4.Text & " " & cbop4.Text & " " & cbvalue4.Text
        End If

        If Me.cbandor4.Text <> "" And Me.cbparam5.Text <> "" And Me.cbop5.Text <> "" And Me.cbvalue5.Text <> "" Then
            If Me.cbandor4.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(5)
            If Me.cbandor4.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(5)
            Me.auswertungen.ParamCollection.Add(cbandor4.Text + " " + cbparam5.Text & " " & cbop5.Text & " " & cbvalue5.Text)
            s = s + " " + cbandor4.Text + " " + cbparam5.Text & " " & cbop5.Text & " " & cbvalue5.Text
        End If
        If Me.cbandor5.Text <> "" And Me.cbparam6.Text <> "" And Me.cbop6.Text <> "" And Me.cbvalue6.Text <> "" Then
            If Me.cbandor5.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(6)
            If Me.cbandor5.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(6)
            Me.auswertungen.ParamCollection.Add(cbandor5.Text + " " + cbparam6.Text & " " & cbop6.Text & " " & cbvalue6.Text)
            s = s + " " + cbandor5.Text + " " + cbparam6.Text & " " & cbop6.Text & " " & cbvalue6.Text
        End If
        If Me.cbandor6.Text <> "" And Me.cbparam7.Text <> "" And Me.cbop7.Text <> "" And Me.cbvalue7.Text <> "" Then
            If Me.cbandor6.Text = "und" Then SQLWhere = SQLWhere + " and " + get_where(7)
            If Me.cbandor6.Text = "oder" Then SQLWhere = SQLWhere + " or " + get_where(7)
            Me.auswertungen.ParamCollection.Add(cbandor6.Text + " " + cbparam7.Text & " " & cbop7.Text & " " & cbvalue7.Text)
            s = s + " " + cbandor6.Text + " " + cbparam7.Text & " " & cbop7.Text & " " & cbvalue7.Text
        End If
        Me.auswertungen.FullParam = s
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.Init_ParamRow -Methode

[Visual Basic]
Private Sub Init_ParamRow( _
   ByVal s As String _
)

Parameter

s

Quellcode

[Visual Basic]
    Private Sub Init_ParamRow(ByVal s As String)
        s = s + 1
        CtrlList.Clear()
        Me.GetControl(Me, "cbparam" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            Try
                x.Text = ""
            Catch ex As Exception
            End Try
            x.Enabled = False
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbop" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Text = ""
            x.Enabled = False
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbvalue" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Text = ""
            x.Enabled = False
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbandor" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Text = ""
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.Init_Params -Methode

Parameter initialisieren

[Visual Basic]
Private Sub Init_Params( _
   Optional ByVal Initialize_ComboBox As Boolean = True _
)

Parameter

Initialize_ComboBox
Optional. Der Standardwert ist True.

Quellcode

[Visual Basic]
    Private Sub Init_Params(Optional ByVal Initialize_ComboBox As Boolean = True)
        If Initialize_ComboBox = True Then Me.ComboboxMAParameter.SelectedIndex = -1
        Me.CtrlList.Clear()
        Me.GetControl(Me, "cb*", CtrlList)
        For Each x As ComboBox In CtrlList
            Try
                x.DataSource = Nothing
                x.Items.Clear()
                x.Enabled = False
                x.Text = ""
            Catch ex As Exception
            End Try
        Next

        CtrlList.Clear()
        Me.GetControl(Me, "cbandor*", CtrlList)
        For Each x As ComboBox In CtrlList
            x.Items.Clear()
            x.Items.Add("und")
            x.Items.Add("oder")
        Next

        Me.cbparam1.Enabled = True
        Me.cbop1.Enabled = True
        Me.cbvalue1.Enabled = True
        Me.cbandor1.Enabled = True

        Me.CtrlList.Clear()
        Me.GetControl(Me, "cbparam*", CtrlList)
        For Each x As ComboBox In CtrlList
            For Each dr As DataRow In Me.auswertungen.AuswertungParameter.Rows
                x.Items.Add(dr.Item("Bezeichnung"))
            Next
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(FrmReportSelect))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.btnAufbereitenCSV = New System.Windows.Forms.Button
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TreeAuswertungen = New System.Windows.Forms.TreeView
        Me.TreeContextMenuStrip1 = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.AlleKnotenSchliessenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AlleKnotenÖffnenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.GrpAuswertung = New System.Windows.Forms.GroupBox
        Me.GrpParameter = New System.Windows.Forms.GroupBox
        Me.btnDeleteSavedParam = New System.Windows.Forms.Button
        Me.ComboboxMAParameter = New System.Windows.Forms.ComboBox
        Me.btnSave = New System.Windows.Forms.Button
        Me.BtnParamDel6 = New System.Windows.Forms.Button
        Me.BtnParamDel5 = New System.Windows.Forms.Button
        Me.BtnParamDel4 = New System.Windows.Forms.Button
        Me.BtnParamDel3 = New System.Windows.Forms.Button
        Me.BtnParamDel2 = New System.Windows.Forms.Button
        Me.BtnParamDel1 = New System.Windows.Forms.Button
        Me.BtnInitParam = New System.Windows.Forms.Button
        Me.cbandor6 = New System.Windows.Forms.ComboBox
        Me.cbparam7 = New System.Windows.Forms.ComboBox
        Me.cbvalue7 = New System.Windows.Forms.ComboBox
        Me.cbop7 = New System.Windows.Forms.ComboBox
        Me.cbandor5 = New System.Windows.Forms.ComboBox
        Me.cbparam6 = New System.Windows.Forms.ComboBox
        Me.cbvalue6 = New System.Windows.Forms.ComboBox
        Me.cbop6 = New System.Windows.Forms.ComboBox
        Me.cbandor4 = New System.Windows.Forms.ComboBox
        Me.cbandor3 = New System.Windows.Forms.ComboBox
        Me.cbandor2 = New System.Windows.Forms.ComboBox
        Me.cbandor1 = New System.Windows.Forms.ComboBox
        Me.cbparam5 = New System.Windows.Forms.ComboBox
        Me.cbparam4 = New System.Windows.Forms.ComboBox
        Me.cbparam3 = New System.Windows.Forms.ComboBox
        Me.cbparam2 = New System.Windows.Forms.ComboBox
        Me.cbparam1 = New System.Windows.Forms.ComboBox
        Me.Label6 = New System.Windows.Forms.Label
        Me.cbvalue5 = New System.Windows.Forms.ComboBox
        Me.cbop5 = New System.Windows.Forms.ComboBox
        Me.cbvalue4 = New System.Windows.Forms.ComboBox
        Me.cbop4 = New System.Windows.Forms.ComboBox
        Me.cbvalue3 = New System.Windows.Forms.ComboBox
        Me.cbop3 = New System.Windows.Forms.ComboBox
        Me.cbvalue2 = New System.Windows.Forms.ComboBox
        Me.cbop2 = New System.Windows.Forms.ComboBox
        Me.lblTitelWert = New System.Windows.Forms.Label
        Me.lblTitelOperator = New System.Windows.Forms.Label
        Me.lblParamTitel = New System.Windows.Forms.Label
        Me.cbvalue1 = New System.Windows.Forms.ComboBox
        Me.cbop1 = New System.Windows.Forms.ComboBox
        Me.BtnAufbereitenCR = New System.Windows.Forms.Button
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.grpBeschreibung = New System.Windows.Forms.GroupBox
        Me.txtbeschreibung = New System.Windows.Forms.TextBox
        Me.grpdb = New System.Windows.Forms.GroupBox
        Me.grpcr = New System.Windows.Forms.GroupBox
        Me.Label2 = New System.Windows.Forms.Label
        Me.Label1 = New System.Windows.Forms.Label
        Me.txtTitel2 = New System.Windows.Forms.TextBox
        Me.txtTitel1 = New System.Windows.Forms.TextBox
        Me.checkboxprintparam = New System.Windows.Forms.CheckBox
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.TreeContextMenuStrip1.SuspendLayout()
        Me.GrpAuswertung.SuspendLayout()
        Me.GrpParameter.SuspendLayout()
        Me.grpBeschreibung.SuspendLayout()
        Me.grpdb.SuspendLayout()
        Me.grpcr.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(720, 24)
        Me.MenuStrip1.TabIndex = 4
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(720, 25)
        Me.ToolStrip1.TabIndex = 3
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'btnAufbereitenCSV
        '
        Me.btnAufbereitenCSV.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.btnAufbereitenCSV.ImageIndex = 3
        Me.btnAufbereitenCSV.ImageList = Me.ImageList1
        Me.btnAufbereitenCSV.Location = New System.Drawing.Point(6, 19)
        Me.btnAufbereitenCSV.Name = "btnAufbereitenCSV"
        Me.btnAufbereitenCSV.Size = New System.Drawing.Size(87, 23)
        Me.btnAufbereitenCSV.TabIndex = 27
        Me.btnAufbereitenCSV.Text = "Tabelle"
        Me.btnAufbereitenCSV.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.btnAufbereitenCSV.UseVisualStyleBackColor = True
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "ReportFolder.png")
        Me.ImageList1.Images.SetKeyName(1, "Report.png")
        Me.ImageList1.Images.SetKeyName(2, "BOOK02.GIF")
        Me.ImageList1.Images.SetKeyName(3, "rpt.png")
        Me.ImageList1.Images.SetKeyName(4, "CR.png")
        Me.ImageList1.Images.SetKeyName(5, "Text.ico")
        Me.ImageList1.Images.SetKeyName(6, "README.GIF")
        '
        'TreeAuswertungen
        '
        Me.TreeAuswertungen.ContextMenuStrip = Me.TreeContextMenuStrip1
        Me.TreeAuswertungen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeAuswertungen.HideSelection = False
        Me.TreeAuswertungen.HotTracking = True
        Me.TreeAuswertungen.ImageIndex = 0
        Me.TreeAuswertungen.ImageList = Me.ImageList1
        Me.TreeAuswertungen.Location = New System.Drawing.Point(3, 16)
        Me.TreeAuswertungen.Name = "TreeAuswertungen"
        Me.TreeAuswertungen.SelectedImageIndex = 0
        Me.TreeAuswertungen.Size = New System.Drawing.Size(286, 533)
        Me.TreeAuswertungen.TabIndex = 0
        '
        'TreeContextMenuStrip1
        '
        Me.TreeContextMenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.AlleKnotenSchliessenToolStripMenuItem, Me.AlleKnotenÖffnenToolStripMenuItem})
        Me.TreeContextMenuStrip1.Name = "TreeContextMenuStrip1"
        Me.TreeContextMenuStrip1.Size = New System.Drawing.Size(180, 48)
        '
        'AlleKnotenSchliessenToolStripMenuItem
        '
        Me.AlleKnotenSchliessenToolStripMenuItem.Name = "AlleKnotenSchliessenToolStripMenuItem"
        Me.AlleKnotenSchliessenToolStripMenuItem.Size = New System.Drawing.Size(179, 22)
        Me.AlleKnotenSchliessenToolStripMenuItem.Text = "Alle Knoten schliessen"
        '
        'AlleKnotenÖffnenToolStripMenuItem
        '
        Me.AlleKnotenÖffnenToolStripMenuItem.Name = "AlleKnotenÖffnenToolStripMenuItem"
        Me.AlleKnotenÖffnenToolStripMenuItem.Size = New System.Drawing.Size(179, 22)
        Me.AlleKnotenÖffnenToolStripMenuItem.Text = "Alle Knoten öffnen"
        '
        'GrpAuswertung
        '
        Me.GrpAuswertung.Controls.Add(Me.TreeAuswertungen)
        Me.GrpAuswertung.Dock = System.Windows.Forms.DockStyle.Left
        Me.GrpAuswertung.Location = New System.Drawing.Point(0, 49)
        Me.GrpAuswertung.Name = "GrpAuswertung"
        Me.GrpAuswertung.Size = New System.Drawing.Size(292, 552)
        Me.GrpAuswertung.TabIndex = 0
        Me.GrpAuswertung.TabStop = False
        Me.GrpAuswertung.Text = "Auswertungen"
        '
        'GrpParameter
        '
        Me.GrpParameter.Controls.Add(Me.btnDeleteSavedParam)
        Me.GrpParameter.Controls.Add(Me.ComboboxMAParameter)
        Me.GrpParameter.Controls.Add(Me.btnSave)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel6)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel5)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel4)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel3)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel2)
        Me.GrpParameter.Controls.Add(Me.BtnParamDel1)
        Me.GrpParameter.Controls.Add(Me.BtnInitParam)
        Me.GrpParameter.Controls.Add(Me.cbandor6)
        Me.GrpParameter.Controls.Add(Me.cbparam7)
        Me.GrpParameter.Controls.Add(Me.cbvalue7)
        Me.GrpParameter.Controls.Add(Me.cbop7)
        Me.GrpParameter.Controls.Add(Me.cbandor5)
        Me.GrpParameter.Controls.Add(Me.cbparam6)
        Me.GrpParameter.Controls.Add(Me.cbvalue6)
        Me.GrpParameter.Controls.Add(Me.cbop6)
        Me.GrpParameter.Controls.Add(Me.cbandor4)
        Me.GrpParameter.Controls.Add(Me.cbandor3)
        Me.GrpParameter.Controls.Add(Me.cbandor2)
        Me.GrpParameter.Controls.Add(Me.cbandor1)
        Me.GrpParameter.Controls.Add(Me.cbparam5)
        Me.GrpParameter.Controls.Add(Me.cbparam4)
        Me.GrpParameter.Controls.Add(Me.cbparam3)
        Me.GrpParameter.Controls.Add(Me.cbparam2)
        Me.GrpParameter.Controls.Add(Me.cbparam1)
        Me.GrpParameter.Controls.Add(Me.Label6)
        Me.GrpParameter.Controls.Add(Me.cbvalue5)
        Me.GrpParameter.Controls.Add(Me.cbop5)
        Me.GrpParameter.Controls.Add(Me.cbvalue4)
        Me.GrpParameter.Controls.Add(Me.cbop4)
        Me.GrpParameter.Controls.Add(Me.cbvalue3)
        Me.GrpParameter.Controls.Add(Me.cbop3)
        Me.GrpParameter.Controls.Add(Me.cbvalue2)
        Me.GrpParameter.Controls.Add(Me.cbop2)
        Me.GrpParameter.Controls.Add(Me.lblTitelWert)
        Me.GrpParameter.Controls.Add(Me.lblTitelOperator)
        Me.GrpParameter.Controls.Add(Me.lblParamTitel)
        Me.GrpParameter.Controls.Add(Me.cbvalue1)
        Me.GrpParameter.Controls.Add(Me.cbop1)
        Me.GrpParameter.Location = New System.Drawing.Point(295, 129)
        Me.GrpParameter.Name = "GrpParameter"
        Me.GrpParameter.Size = New System.Drawing.Size(425, 301)
        Me.GrpParameter.TabIndex = 1
        Me.GrpParameter.TabStop = False
        Me.GrpParameter.Text = "Parameter"
        '
        'btnDeleteSavedParam
        '
        Me.btnDeleteSavedParam.Image = CType(resources.GetObject("btnDeleteSavedParam.Image"), System.Drawing.Image)
        Me.btnDeleteSavedParam.Location = New System.Drawing.Point(399, 21)
        Me.btnDeleteSavedParam.Name = "btnDeleteSavedParam"
        Me.btnDeleteSavedParam.Size = New System.Drawing.Size(19, 21)
        Me.btnDeleteSavedParam.TabIndex = 47
        Me.btnDeleteSavedParam.UseVisualStyleBackColor = True
        '
        'ComboboxMAParameter
        '
        Me.ComboboxMAParameter.FormattingEnabled = True
        Me.ComboboxMAParameter.Location = New System.Drawing.Point(96, 21)
        Me.ComboboxMAParameter.Name = "ComboboxMAParameter"
        Me.ComboboxMAParameter.Size = New System.Drawing.Size(303, 21)
        Me.ComboboxMAParameter.TabIndex = 46
        Me.ComboboxMAParameter.Visible = False
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(15, 19)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.Size = New System.Drawing.Size(75, 23)
        Me.btnSave.TabIndex = 45
        Me.btnSave.Text = "Speichern"
        Me.btnSave.UseVisualStyleBackColor = True
        '
        'BtnParamDel6
        '
        Me.BtnParamDel6.Image = CType(resources.GetObject("BtnParamDel6.Image"), System.Drawing.Image)
        Me.BtnParamDel6.Location = New System.Drawing.Point(399, 270)
        Me.BtnParamDel6.Name = "BtnParamDel6"
        Me.BtnParamDel6.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel6.TabIndex = 44
        Me.BtnParamDel6.UseVisualStyleBackColor = True
        '
        'BtnParamDel5
        '
        Me.BtnParamDel5.Image = CType(resources.GetObject("BtnParamDel5.Image"), System.Drawing.Image)
        Me.BtnParamDel5.Location = New System.Drawing.Point(399, 244)
        Me.BtnParamDel5.Name = "BtnParamDel5"
        Me.BtnParamDel5.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel5.TabIndex = 43
        Me.BtnParamDel5.UseVisualStyleBackColor = True
        '
        'BtnParamDel4
        '
        Me.BtnParamDel4.Image = CType(resources.GetObject("BtnParamDel4.Image"), System.Drawing.Image)
        Me.BtnParamDel4.Location = New System.Drawing.Point(399, 216)
        Me.BtnParamDel4.Name = "BtnParamDel4"
        Me.BtnParamDel4.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel4.TabIndex = 42
        Me.BtnParamDel4.UseVisualStyleBackColor = True
        '
        'BtnParamDel3
        '
        Me.BtnParamDel3.Image = CType(resources.GetObject("BtnParamDel3.Image"), System.Drawing.Image)
        Me.BtnParamDel3.Location = New System.Drawing.Point(399, 189)
        Me.BtnParamDel3.Name = "BtnParamDel3"
        Me.BtnParamDel3.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel3.TabIndex = 41
        Me.BtnParamDel3.UseVisualStyleBackColor = True
        '
        'BtnParamDel2
        '
        Me.BtnParamDel2.Image = CType(resources.GetObject("BtnParamDel2.Image"), System.Drawing.Image)
        Me.BtnParamDel2.Location = New System.Drawing.Point(399, 163)
        Me.BtnParamDel2.Name = "BtnParamDel2"
        Me.BtnParamDel2.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel2.TabIndex = 40
        Me.BtnParamDel2.UseVisualStyleBackColor = True
        '
        'BtnParamDel1
        '
        Me.BtnParamDel1.Image = CType(resources.GetObject("BtnParamDel1.Image"), System.Drawing.Image)
        Me.BtnParamDel1.Location = New System.Drawing.Point(399, 136)
        Me.BtnParamDel1.Name = "BtnParamDel1"
        Me.BtnParamDel1.Size = New System.Drawing.Size(19, 21)
        Me.BtnParamDel1.TabIndex = 39
        Me.BtnParamDel1.UseVisualStyleBackColor = True
        '
        'BtnInitParam
        '
        Me.BtnInitParam.Location = New System.Drawing.Point(15, 48)
        Me.BtnInitParam.Name = "BtnInitParam"
        Me.BtnInitParam.Size = New System.Drawing.Size(75, 23)
        Me.BtnInitParam.TabIndex = 29
        Me.BtnInitParam.Text = "Initialisieren"
        Me.BtnInitParam.UseVisualStyleBackColor = True
        '
        'cbandor6
        '
        Me.cbandor6.FormattingEnabled = True
        Me.cbandor6.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor6.Location = New System.Drawing.Point(15, 271)
        Me.cbandor6.Name = "cbandor6"
        Me.cbandor6.Size = New System.Drawing.Size(52, 21)
        Me.cbandor6.TabIndex = 23
        '
        'cbparam7
        '
        Me.cbparam7.FormattingEnabled = True
        Me.cbparam7.Location = New System.Drawing.Point(79, 271)
        Me.cbparam7.Name = "cbparam7"
        Me.cbparam7.Size = New System.Drawing.Size(128, 21)
        Me.cbparam7.TabIndex = 24
        '
        'cbvalue7
        '
        Me.cbvalue7.FormattingEnabled = True
        Me.cbvalue7.Location = New System.Drawing.Point(271, 271)
        Me.cbvalue7.Name = "cbvalue7"
        Me.cbvalue7.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue7.TabIndex = 26
        '
        'cbop7
        '
        Me.cbop7.FormattingEnabled = True
        Me.cbop7.Location = New System.Drawing.Point(214, 271)
        Me.cbop7.Name = "cbop7"
        Me.cbop7.Size = New System.Drawing.Size(52, 21)
        Me.cbop7.TabIndex = 25
        '
        'cbandor5
        '
        Me.cbandor5.FormattingEnabled = True
        Me.cbandor5.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor5.Location = New System.Drawing.Point(15, 244)
        Me.cbandor5.Name = "cbandor5"
        Me.cbandor5.Size = New System.Drawing.Size(52, 21)
        Me.cbandor5.TabIndex = 19
        '
        'cbparam6
        '
        Me.cbparam6.FormattingEnabled = True
        Me.cbparam6.Location = New System.Drawing.Point(79, 244)
        Me.cbparam6.Name = "cbparam6"
        Me.cbparam6.Size = New System.Drawing.Size(128, 21)
        Me.cbparam6.TabIndex = 20
        '
        'cbvalue6
        '
        Me.cbvalue6.FormattingEnabled = True
        Me.cbvalue6.Location = New System.Drawing.Point(271, 244)
        Me.cbvalue6.Name = "cbvalue6"
        Me.cbvalue6.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue6.TabIndex = 22
        '
        'cbop6
        '
        Me.cbop6.FormattingEnabled = True
        Me.cbop6.Location = New System.Drawing.Point(214, 244)
        Me.cbop6.Name = "cbop6"
        Me.cbop6.Size = New System.Drawing.Size(52, 21)
        Me.cbop6.TabIndex = 21
        '
        'cbandor4
        '
        Me.cbandor4.FormattingEnabled = True
        Me.cbandor4.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor4.Location = New System.Drawing.Point(15, 217)
        Me.cbandor4.Name = "cbandor4"
        Me.cbandor4.Size = New System.Drawing.Size(52, 21)
        Me.cbandor4.TabIndex = 15
        '
        'cbandor3
        '
        Me.cbandor3.FormattingEnabled = True
        Me.cbandor3.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor3.Location = New System.Drawing.Point(15, 190)
        Me.cbandor3.Name = "cbandor3"
        Me.cbandor3.Size = New System.Drawing.Size(52, 21)
        Me.cbandor3.TabIndex = 11
        '
        'cbandor2
        '
        Me.cbandor2.FormattingEnabled = True
        Me.cbandor2.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor2.Location = New System.Drawing.Point(15, 163)
        Me.cbandor2.Name = "cbandor2"
        Me.cbandor2.Size = New System.Drawing.Size(52, 21)
        Me.cbandor2.TabIndex = 7
        '
        'cbandor1
        '
        Me.cbandor1.FormattingEnabled = True
        Me.cbandor1.Items.AddRange(New Object() {"und", "oder"})
        Me.cbandor1.Location = New System.Drawing.Point(15, 136)
        Me.cbandor1.Name = "cbandor1"
        Me.cbandor1.Size = New System.Drawing.Size(52, 21)
        Me.cbandor1.TabIndex = 3
        '
        'cbparam5
        '
        Me.cbparam5.FormattingEnabled = True
        Me.cbparam5.Location = New System.Drawing.Point(79, 217)
        Me.cbparam5.Name = "cbparam5"
        Me.cbparam5.Size = New System.Drawing.Size(128, 21)
        Me.cbparam5.TabIndex = 16
        '
        'cbparam4
        '
        Me.cbparam4.FormattingEnabled = True
        Me.cbparam4.Location = New System.Drawing.Point(79, 190)
        Me.cbparam4.Name = "cbparam4"
        Me.cbparam4.Size = New System.Drawing.Size(128, 21)
        Me.cbparam4.TabIndex = 12
        '
        'cbparam3
        '
        Me.cbparam3.FormattingEnabled = True
        Me.cbparam3.Location = New System.Drawing.Point(79, 163)
        Me.cbparam3.Name = "cbparam3"
        Me.cbparam3.Size = New System.Drawing.Size(128, 21)
        Me.cbparam3.TabIndex = 8
        '
        'cbparam2
        '
        Me.cbparam2.FormattingEnabled = True
        Me.cbparam2.Location = New System.Drawing.Point(79, 136)
        Me.cbparam2.Name = "cbparam2"
        Me.cbparam2.Size = New System.Drawing.Size(128, 21)
        Me.cbparam2.TabIndex = 4
        '
        'cbparam1
        '
        Me.cbparam1.FormattingEnabled = True
        Me.cbparam1.Location = New System.Drawing.Point(79, 106)
        Me.cbparam1.Name = "cbparam1"
        Me.cbparam1.Size = New System.Drawing.Size(128, 21)
        Me.cbparam1.TabIndex = 0
        '
        'Label6
        '
        Me.Label6.AutoSize = True
        Me.Label6.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label6.Location = New System.Drawing.Point(12, 88)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(59, 13)
        Me.Label6.TabIndex = 38
        Me.Label6.Text = "und/oder"
        '
        'cbvalue5
        '
        Me.cbvalue5.FormattingEnabled = True
        Me.cbvalue5.Location = New System.Drawing.Point(271, 217)
        Me.cbvalue5.Name = "cbvalue5"
        Me.cbvalue5.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue5.TabIndex = 18
        '
        'cbop5
        '
        Me.cbop5.FormattingEnabled = True
        Me.cbop5.Location = New System.Drawing.Point(214, 217)
        Me.cbop5.Name = "cbop5"
        Me.cbop5.Size = New System.Drawing.Size(52, 21)
        Me.cbop5.TabIndex = 17
        '
        'cbvalue4
        '
        Me.cbvalue4.FormattingEnabled = True
        Me.cbvalue4.Location = New System.Drawing.Point(271, 190)
        Me.cbvalue4.Name = "cbvalue4"
        Me.cbvalue4.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue4.TabIndex = 14
        '
        'cbop4
        '
        Me.cbop4.FormattingEnabled = True
        Me.cbop4.Location = New System.Drawing.Point(213, 190)
        Me.cbop4.Name = "cbop4"
        Me.cbop4.Size = New System.Drawing.Size(52, 21)
        Me.cbop4.TabIndex = 13
        '
        'cbvalue3
        '
        Me.cbvalue3.FormattingEnabled = True
        Me.cbvalue3.Location = New System.Drawing.Point(271, 163)
        Me.cbvalue3.Name = "cbvalue3"
        Me.cbvalue3.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue3.TabIndex = 10
        '
        'cbop3
        '
        Me.cbop3.FormattingEnabled = True
        Me.cbop3.Location = New System.Drawing.Point(213, 163)
        Me.cbop3.Name = "cbop3"
        Me.cbop3.Size = New System.Drawing.Size(52, 21)
        Me.cbop3.TabIndex = 9
        '
        'cbvalue2
        '
        Me.cbvalue2.FormattingEnabled = True
        Me.cbvalue2.Location = New System.Drawing.Point(271, 136)
        Me.cbvalue2.Name = "cbvalue2"
        Me.cbvalue2.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue2.TabIndex = 6
        '
        'cbop2
        '
        Me.cbop2.FormattingEnabled = True
        Me.cbop2.Location = New System.Drawing.Point(213, 136)
        Me.cbop2.Name = "cbop2"
        Me.cbop2.Size = New System.Drawing.Size(52, 21)
        Me.cbop2.TabIndex = 5
        '
        'lblTitelWert
        '
        Me.lblTitelWert.AutoSize = True
        Me.lblTitelWert.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblTitelWert.Location = New System.Drawing.Point(272, 88)
        Me.lblTitelWert.Name = "lblTitelWert"
        Me.lblTitelWert.Size = New System.Drawing.Size(34, 13)
        Me.lblTitelWert.TabIndex = 28
        Me.lblTitelWert.Text = "Wert"
        '
        'lblTitelOperator
        '
        Me.lblTitelOperator.AutoSize = True
        Me.lblTitelOperator.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblTitelOperator.Location = New System.Drawing.Point(210, 88)
        Me.lblTitelOperator.Name = "lblTitelOperator"
        Me.lblTitelOperator.Size = New System.Drawing.Size(56, 13)
        Me.lblTitelOperator.TabIndex = 27
        Me.lblTitelOperator.Text = "Operator"
        '
        'lblParamTitel
        '
        Me.lblParamTitel.AutoSize = True
        Me.lblParamTitel.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblParamTitel.Location = New System.Drawing.Point(77, 88)
        Me.lblParamTitel.Name = "lblParamTitel"
        Me.lblParamTitel.Size = New System.Drawing.Size(64, 13)
        Me.lblParamTitel.TabIndex = 26
        Me.lblParamTitel.Text = "Parameter"
        '
        'cbvalue1
        '
        Me.cbvalue1.FormatString = "N2"
        Me.cbvalue1.FormattingEnabled = True
        Me.cbvalue1.Location = New System.Drawing.Point(271, 106)
        Me.cbvalue1.Name = "cbvalue1"
        Me.cbvalue1.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue1.TabIndex = 2
        '
        'cbop1
        '
        Me.cbop1.FormattingEnabled = True
        Me.cbop1.Location = New System.Drawing.Point(213, 106)
        Me.cbop1.Name = "cbop1"
        Me.cbop1.Size = New System.Drawing.Size(52, 21)
        Me.cbop1.TabIndex = 1
        '
        'BtnAufbereitenCR
        '
        Me.BtnAufbereitenCR.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.BtnAufbereitenCR.ImageIndex = 4
        Me.BtnAufbereitenCR.ImageList = Me.ImageList1
        Me.BtnAufbereitenCR.Location = New System.Drawing.Point(6, 73)
        Me.BtnAufbereitenCR.Name = "BtnAufbereitenCR"
        Me.BtnAufbereitenCR.Size = New System.Drawing.Size(99, 23)
        Me.BtnAufbereitenCR.TabIndex = 28
        Me.BtnAufbereitenCR.Text = "Crystal-Report"
        Me.BtnAufbereitenCR.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.BtnAufbereitenCR.UseVisualStyleBackColor = True
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'grpBeschreibung
        '
        Me.grpBeschreibung.Controls.Add(Me.txtbeschreibung)
        Me.grpBeschreibung.Location = New System.Drawing.Point(295, 49)
        Me.grpBeschreibung.Name = "grpBeschreibung"
        Me.grpBeschreibung.Size = New System.Drawing.Size(425, 74)
        Me.grpBeschreibung.TabIndex = 29
        Me.grpBeschreibung.TabStop = False
        Me.grpBeschreibung.Text = "Beschreibung"
        '
        'txtbeschreibung
        '
        Me.txtbeschreibung.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.txtbeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtbeschreibung.Location = New System.Drawing.Point(3, 16)
        Me.txtbeschreibung.Multiline = True
        Me.txtbeschreibung.Name = "txtbeschreibung"
        Me.txtbeschreibung.ReadOnly = True
        Me.txtbeschreibung.Size = New System.Drawing.Size(419, 55)
        Me.txtbeschreibung.TabIndex = 0
        '
        'grpdb
        '
        Me.grpdb.Controls.Add(Me.btnAufbereitenCSV)
        Me.grpdb.Location = New System.Drawing.Point(295, 436)
        Me.grpdb.Name = "grpdb"
        Me.grpdb.Size = New System.Drawing.Size(422, 54)
        Me.grpdb.TabIndex = 30
        Me.grpdb.TabStop = False
        Me.grpdb.Text = "Resultat als Datentabelle"
        '
        'grpcr
        '
        Me.grpcr.Controls.Add(Me.checkboxprintparam)
        Me.grpcr.Controls.Add(Me.Label2)
        Me.grpcr.Controls.Add(Me.Label1)
        Me.grpcr.Controls.Add(Me.txtTitel2)
        Me.grpcr.Controls.Add(Me.txtTitel1)
        Me.grpcr.Controls.Add(Me.BtnAufbereitenCR)
        Me.grpcr.Location = New System.Drawing.Point(295, 496)
        Me.grpcr.Name = "grpcr"
        Me.grpcr.Size = New System.Drawing.Size(422, 102)
        Me.grpcr.TabIndex = 31
        Me.grpcr.TabStop = False
        Me.grpcr.Text = "Resultat als Crystal-Report"
        '
        'Label2
        '
        Me.Label2.AutoSize = True
        Me.Label2.Location = New System.Drawing.Point(8, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(46, 13)
        Me.Label2.TabIndex = 32
        Me.Label2.Text = "Titel Z2:"
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(8, 22)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(46, 13)
        Me.Label1.TabIndex = 31
        Me.Label1.Text = "Titel Z1:"
        '
        'txtTitel2
        '
        Me.txtTitel2.Location = New System.Drawing.Point(60, 45)
        Me.txtTitel2.Name = "txtTitel2"
        Me.txtTitel2.Size = New System.Drawing.Size(353, 20)
        Me.txtTitel2.TabIndex = 30
        '
        'txtTitel1
        '
        Me.txtTitel1.Location = New System.Drawing.Point(60, 19)
        Me.txtTitel1.Name = "txtTitel1"
        Me.txtTitel1.Size = New System.Drawing.Size(353, 20)
        Me.txtTitel1.TabIndex = 29
        '
        'checkboxprintparam
        '
        Me.checkboxprintparam.AutoSize = True
        Me.checkboxprintparam.Location = New System.Drawing.Point(297, 76)
        Me.checkboxprintparam.Name = "checkboxprintparam"
        Me.checkboxprintparam.Size = New System.Drawing.Size(116, 17)
        Me.checkboxprintparam.TabIndex = 33
        Me.checkboxprintparam.Text = "Parameter drucken"
        Me.checkboxprintparam.UseVisualStyleBackColor = True
        '
        'FrmReportSelect
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(720, 601)
        Me.Controls.Add(Me.grpcr)
        Me.Controls.Add(Me.grpdb)
        Me.Controls.Add(Me.grpBeschreibung)
        Me.Controls.Add(Me.GrpAuswertung)
        Me.Controls.Add(Me.GrpParameter)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmReportSelect"
        Me.Text = "Report-Auswahl"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.TreeContextMenuStrip1.ResumeLayout(False)
        Me.GrpAuswertung.ResumeLayout(False)
        Me.GrpParameter.ResumeLayout(False)
        Me.GrpParameter.PerformLayout()
        Me.grpBeschreibung.ResumeLayout(False)
        Me.grpBeschreibung.PerformLayout()
        Me.grpdb.ResumeLayout(False)
        Me.grpcr.ResumeLayout(False)
        Me.grpcr.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.ParamNr -Methode

[Visual Basic]
Private Function ParamNr( _
   ByVal s As String _
) As String

Parameter

s

Quellcode

[Visual Basic]
    Private Function ParamNr(ByVal s As String) As String
        Return s.Substring(Len(s) - 1, 1)
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        btnAbbruch_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TXP_Auswertung -Methode

[Visual Basic]
Private Sub TXP_Auswertung()

Quellcode

[Visual Basic]
    Private Sub TXP_Auswertung()
        Get_SQLWhere()
        Me.Auswertungsdaten = Me.auswertungen.Get_Auswertungsdaten(Me.auswertungen.Auswertung.sSQL.Value, SQLWhere, True)
        Dim f As New frmAuswertung(Me.TreeAuswertungen.SelectedNode.Text, Me.Auswertungsdaten)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TXP_AuswertungCR -Methode

[Visual Basic]
Private Sub TXP_AuswertungCR()

Quellcode

[Visual Basic]
    Private Sub TXP_AuswertungCR()
        Get_SQLWhere()
        Me.Auswertungsdaten = Me.auswertungen.Get_Auswertungsdaten(Me.auswertungen.Auswertung.sSQL.Value, SQLWhere, True)
        Dim f As New frmcrreporting(Me.Auswertungsdaten, Me.auswertungen.Auswertung.iAuswertungNr.Value, Me.auswertungen, Me.checkboxprintparam.Checked)
        f.MdiParent = Me.MdiParent
        Me.Cursor = Cursors.Default
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TreeAuswertungen_AfterSelect -Methode

Nach Selektion eines Nodes Parameter neu aufbereiten und Auswerungsmöglichkeit (CR/CSV) anzeigen

[Visual Basic]
Private Sub TreeAuswertungen_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeAuswertungen.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeAuswertungen_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeAuswertungen.AfterSelect
        Me.On_Load = True
        Try
            Me.txtTitel1.Text = Me.TreeAuswertungen.SelectedNode.Text
            Me.txtTitel2.Text = ""
            Me.checkboxprintparam.Checked = True
            Me.txtbeschreibung.Text = Me.TreeAuswertungen.SelectedNode.ToolTipText
            If Me.TreeAuswertungen.SelectedNode.Tag < 1 Then
                Me.GrpParameter.Enabled = False
                Me.BtnAufbereitenCR.Enabled = False
                Me.btnAufbereitenCSV.Enabled = False
                Me.grpcr.Enabled = False
                Me.grpdb.Enabled = False
                Exit Sub
            End If

            Me.auswertungen.Get_Auswertung(Me.TreeAuswertungen.SelectedNode.Tag)
            If Me.auswertungen.MitarbeiterAuswertungsparameter.Rows.Count > 0 Then
                Me.ComboboxMAParameter.Visible = True
                Try
                    Me.ComboboxMAParameter.DataSource = Nothing
                    Me.ComboboxMAParameter.DataSource = Me.auswertungen.MitarbeiterAuswertungsparameter
                    Me.ComboboxMAParameter.DisplayMember = "Beschreibung"
                    Me.ComboboxMAParameter.ValueMember = "Mitarbeiter_AuswertungsparameterNr"
                    Me.ComboboxMAParameter.SelectedIndex = -1
                Catch ex As Exception
                End Try
            Else
                Me.ComboboxMAParameter.Visible = False
            End If
            If Me.auswertungen.AuswertungParameter.Rows.Count = 0 Then
                Me.GrpParameter.Enabled = False
            Else
                Me.GrpParameter.Enabled = True
            End If
            If Me.auswertungen.Auswertung.bCR_Report.Value = True Then
                Me.BtnAufbereitenCR.Enabled = True
                Me.grpcr.Enabled = True
            Else
                Me.BtnAufbereitenCR.Enabled = False
                Me.grpcr.Enabled = False
            End If
            If Me.auswertungen.Auswertung.bCSV_Report.Value = True Then
                Me.btnAufbereitenCSV.Enabled = True
                Me.grpdb.Enabled = True
            Else
                Me.btnAufbereitenCSV.Enabled = False
                Me.grpdb.Enabled = False
            End If

            Init_Params()

        Catch ex As Exception
        End Try
        Me.On_Load = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TreeAuswertungen_DoubleClick -Methode

[Visual Basic]
Private Sub TreeAuswertungen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeAuswertungen.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeAuswertungen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeAuswertungen.DoubleClick
        'If Me.TreeAuswertungen.SelectedNode.Tag > -1 Then btnAufbereiten_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.TreeStruktur_MouseDown -Methode

Mousedown-Ereignis auf dem Tree

[Visual Basic]
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeAuswertungen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeAuswertungen.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeAuswertungen.SelectedNode = Me.TreeAuswertungen.GetNodeAt(selectPoint)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.btnAbbruch_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub btnAbbruch_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.btnAufbereiten_Click -Methode

[Visual Basic]
Private Sub btnAufbereiten_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAufbereitenCSV.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAufbereiten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAufbereitenCSV.Click
        Me.Cursor = Cursors.WaitCursor
        If Me.auswertungen.Auswertung.bTXP_Auswertung.Value = True Then
            TXP_Auswertung()
            Me.Cursor = Cursors.Default
            Exit Sub
        End If
        Get_SQLWhere()
        Me.Auswertungsdaten = Me.auswertungen.Get_Auswertungsdaten(Me.auswertungen.Auswertung.sSQL.Value, SQLWhere)
        Dim f As New frmAuswertung(Me.TreeAuswertungen.SelectedNode.Text, Me.Auswertungsdaten)
        f.MdiParent = Me.MdiParent
        Me.Cursor = Cursors.Default
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.btnDeleteSavedParam_Click -Methode

[Visual Basic]
Private Sub btnDeleteSavedParam_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnDeleteSavedParam.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnDeleteSavedParam_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDeleteSavedParam.Click
        If Me.ComboboxMAParameter.SelectedIndex = -1 Then Exit Sub

        Me.auswertungen.delete_parameter(Me.ComboboxMAParameter.SelectedValue)
        Me.Init_Params()
        Me.txtTitel1.Text = Me.TreeAuswertungen.SelectedNode.Text
        Me.txtTitel2.Text = ""
        Me.checkboxprintparam.Checked = True

        If Me.auswertungen.MitarbeiterAuswertungsparameter.Rows.Count > 0 Then
            Me.ComboboxMAParameter.Visible = True
            Me.On_Load = True
            Try
                Me.ComboboxMAParameter.DataSource = Nothing
                Me.ComboboxMAParameter.DataSource = Me.auswertungen.MitarbeiterAuswertungsparameter
                Me.ComboboxMAParameter.DisplayMember = "Beschreibung"
                Me.ComboboxMAParameter.ValueMember = "Mitarbeiter_AuswertungsparameterNr"
                Me.ComboboxMAParameter.SelectedIndex = -1
            Catch ex As Exception
            End Try
            Me.On_Load = False
        Else
            Me.ComboboxMAParameter.Visible = False
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.btnSave_Click -Methode

[Visual Basic]
Private Sub btnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        Me.On_Load = True
        Dim s As String
        CtrlList.Clear()
        Me.GetControl(Me, "cbandor*", CtrlList)
        For Each x As ComboBox In CtrlList
            s = s + ParamNr(x.Name) + "~" + x.Text + ";"
        Next
        s = s + "|"
        CtrlList.Clear()
        Me.GetControl(Me, "cbparam*", CtrlList)
        For Each x As ComboBox In CtrlList
            s = s + ParamNr(x.Name) + "~" + x.Text + ";"
        Next
        s = s + "|"
        CtrlList.Clear()
        Me.GetControl(Me, "cbop*", CtrlList)
        For Each x As ComboBox In CtrlList
            s = s + ParamNr(x.Name) + "~" + x.Text + ";"
        Next
        s = s + "|"
        CtrlList.Clear()
        Me.GetControl(Me, "cbval*", CtrlList)
        For Each x As ComboBox In CtrlList
            s = s + ParamNr(x.Name) + "~" + x.Text + ";"
        Next
        Dim Bez As String = InputBox("Bezeichnung für die Parameter:", "Auswertungsparameter sichern")
        If Bez <> "" Then Me.auswertungen.Save_MAParameter(Me.auswertungen.Auswertung.iAuswertungNr.Value, Bez, s, Me.txtTitel1.Text, Me.txtTitel2.Text, Me.checkboxprintparam.Checked)
        If Me.auswertungen.MitarbeiterAuswertungsparameter.Rows.Count > 0 Then
            Me.ComboboxMAParameter.Visible = True
            Try
                Me.ComboboxMAParameter.DataSource = Nothing
                Me.ComboboxMAParameter.DataSource = Me.auswertungen.MitarbeiterAuswertungsparameter
                Me.ComboboxMAParameter.DisplayMember = "Beschreibung"
                Me.ComboboxMAParameter.ValueMember = "Mitarbeiter_AuswertungsparameterNr"
                Me.ComboboxMAParameter.SelectedIndex = -1
            Catch ex As Exception
            End Try
        Else
            Me.ComboboxMAParameter.Visible = False
        End If
        Me.On_Load = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.cbandor1_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cbandor1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbandor1.SelectedIndexChanged, _
   cbandor2.SelectedIndexChanged, _
   cbandor3.SelectedIndexChanged, _
   cbandor3.SelectedIndexChanged, _
   cbandor4.SelectedIndexChanged, _
   cbandor5.SelectedIndexChanged, _
   cbandor6.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbandor1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbandor1.SelectedIndexChanged, _
    cbandor2.SelectedIndexChanged, cbandor3.SelectedIndexChanged, cbandor3.SelectedIndexChanged, cbandor4.SelectedIndexChanged, cbandor5.SelectedIndexChanged, _
    cbandor6.SelectedIndexChanged
        s = Me.ParamNr(sender.name)
        s = s + 1
        CtrlList.Clear()
        Me.GetControl(Me, "cbparam" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Enabled = True
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbop" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Enabled = True
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbvalue" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Enabled = True
        Next
        CtrlList.Clear()
        Me.GetControl(Me, "cbandor" + s, CtrlList)
        For Each x As ComboBox In CtrlList
            x.Enabled = True
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.cbparam1_SelectedIndexChanged -Methode

Selektion Parameter

[Visual Basic]
Private Sub cbparam1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbparam1.SelectedIndexChanged, _
   cbparam2.SelectedIndexChanged, _
   cbparam3.SelectedIndexChanged, _
   cbparam4.SelectedIndexChanged, _
   cbparam5.SelectedIndexChanged, _
   cbparam6.SelectedIndexChanged, _
   cbparam7.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbparam1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbparam1.SelectedIndexChanged, cbparam2.SelectedIndexChanged, _
                 cbparam3.SelectedIndexChanged, cbparam4.SelectedIndexChanged, cbparam5.SelectedIndexChanged, cbparam6.SelectedIndexChanged, cbparam7.SelectedIndexChanged
        Dim s As String = Paramnr(sender.name)
        Dim cbop As String = "cbop" + s
        dr = Findrow(sender.text)

        'Operatoren festlegen
        CtrlList.Clear()
        Me.GetControl(Me, "cbop" + s, CtrlList)
        For Each ob As ComboBox In CtrlList
            ob.Items.Clear()
            splits = dr.Item("Operator").ToString.Split(";")
            For Each x As String In splits
                ob.Items.Add(x)
            Next
            ob.SelectedIndex = 0
        Next

        ' Wenn ein Datenbezug ab DB oder eingegeben, dann aufbereiten
        If dr.Item("Feldbezug").ToString <> "" Then
            'Feldbezug ab DB
            If UCase(dr.Item("feldbezug").ToString.Substring(0, 3)) = "SP_" Then
                Dim fb As New DataTable
                fb = Me.auswertungen.get_rptparam_values(dr.Item("Feldbezug"))
                CtrlList.Clear()
                Me.GetControl(Me, "cbvalue" + s, CtrlList)
                For Each x As ComboBox In CtrlList
                    x.DataSource = Nothing
                    x.Items.Clear()
                    x.DataSource = fb
                    x.DisplayMember = "Bezeichnung"
                    x.ValueMember = "KeyValue"
                Next
            Else
                'Fixer Feldbezug
                If dr.Item("Feldbezug").ToString <> "" Then
                    Dim selval() As String = dr.Item("Feldbezug").ToString.Split(";")
                    Dim cbvalue As String = "cbvalue" + s
                    CtrlList.Clear()
                    Me.GetControl(Me, "cbvalue" + s, CtrlList)
                    For Each x As ComboBox In CtrlList
                        x.DataSource = Nothing
                        x.Items.Clear()
                        For Each ss As String In selval
                            x.Items.Add(ss)
                        Next
                    Next
                End If
            End If

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.cbvalue1_DropDown -Methode

[Visual Basic]
Private Sub cbvalue1_DropDown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbvalue1.DropDown, _
   cbvalue2.DropDown, _
   cbvalue3.DropDown, _
   cbvalue4.DropDown, _
   cbvalue5.DropDown, _
   cbvalue6.DropDown, _
   cbvalue7.DropDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbvalue1_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbvalue1.DropDown, cbvalue2.DropDown, _
 cbvalue3.DropDown, cbvalue4.DropDown, cbvalue5.DropDown, cbvalue6.DropDown, cbvalue7.DropDown
        Try
            Dim s As String = ParamNr(sender.name)
            Dim nr As Integer = s
            Dim param As New ComboBox
            Dim op As New ComboBox
            Dim val As New ComboBox
            CtrlList.Clear()
            Me.GetControl(Me, "cbparam" + Trim(Str(nr)), CtrlList)
            param = CtrlList.Item(0)

            CtrlList.Clear()
            Me.GetControl(Me, "cbvalue" + Trim(Str(nr)), CtrlList)
            val = CtrlList.Item(0)

            dr = Me.Findrow(param.Text)

            If dr.Item("Paramtype") = "Datum" Then
                Dim LocalMousePosition As Point
                LocalMousePosition = val.PointToClient(Cursor.Position)

                Dim f As New frmCalendar

                f.Top = Me.Top + val.Top + 200
                f.Left = Me.Left + val.Width + 399
                f.ShowDialog()
                If f.DialogResult = Windows.Forms.DialogResult.OK Then
                    CtrlList.Clear()
                    Me.GetControl(Me, "cbvalue" + Trim(Str(nr)), CtrlList)
                    param = CtrlList.Item(0)
                    param.Text = f.MonthCalendar1.SelectionRange.Start.Date
                    param.Focus()
                End If
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect.get_where -Methode

Where zusammenstellen

[Visual Basic]
Private Function get_where( _
   ByVal nr As Integer _
) As String

Parameter

nr

Quellcode

[Visual Basic]
    Private Function get_where(ByVal nr As Integer) As String
        Dim param As New ComboBox
        Dim op As New ComboBox
        Dim val As New ComboBox
        Dim wertvalue As String = ""
        Dim wertdbfeld As String = ""
        Dim wertop As String = op.Text

        CtrlList.Clear()
        Me.GetControl(Me, "cbparam" + Trim(Str(nr)), CtrlList)
        param = CtrlList.Item(0)

        CtrlList.Clear()
        Me.GetControl(Me, "cbop" + Trim(Str(nr)), CtrlList)
        op = CtrlList.Item(0)

        CtrlList.Clear()
        Me.GetControl(Me, "cbvalue" + Trim(Str(nr)), CtrlList)
        val = CtrlList.Item(0)

        dr = Me.Findrow(param.Text)

        wertop = op.Text

        Dim paramtyp As String = ""
        Dim paramsplit() As String = dr.Item("Paramtype").ToString.Split(";")

        Dim dbfeldsplit() As String = dr.Item("dbfeldname").ToString.Split(";")
        If dbfeldsplit.Length > 1 And val.SelectedIndex > -1 Then
            wertvalue = val.SelectedValue
            wertdbfeld = dbfeldsplit(0)
            paramtyp = paramsplit(0)
        Else
            wertvalue = val.Text
            If dbfeldsplit.Length > 1 Then
                wertdbfeld = dbfeldsplit(1)
                paramtyp = paramsplit(1)
            Else
                wertdbfeld = dbfeldsplit(0)
                paramtyp = paramsplit(0)
            End If
        End If

        Select Case UCase(paramtyp)
            Case "VARCHAR", "STRING", "CHAR"
                Return wertdbfeld + " " + wertop + " '" + wertvalue + "'"
            Case "INTEGER", "INT"
                Return wertdbfeld + " " + wertop + " " + wertvalue + ""
            Case "DATEPART"
                Select Case wertvalue
                    Case "letzte Woche"
                        Return "cast(datepart(week," & wertdbfeld & ") as int) " & wertop & " cast(datepart(week, getdate()) as int) - 1"
                    Case "letzer Monat"
                        Return "cast(datepart(month," & wertdbfeld & ") as int) " & wertop & " cast(datepart(month, getdate()) as int) - 1"
                    Case "letztes Quartal"
                        Return "cast(datepart(quarter," & wertdbfeld & ") as int) " & wertop & " cast(datepart(quarter, getdate()) as int) - 1"
                    Case "letztes Jahr"
                        Return "year(" & wertdbfeld & ") " & wertop & " year(getdate()) - 1"
                    Case "aktuelle Woche"
                        Return "cast(datepart(week," & wertdbfeld & ") as int) " & wertop & " cast(datepart(week, getdate()) as int)"
                    Case "aktueller Monat"
                        Return "cast(datepart(month," & wertdbfeld & ") as int) " & wertop & " cast(datepart(month, getdate()) as int)"
                    Case "aktuelles Quartal"
                        Return "cast(datepart(quarter," & wertdbfeld & ") as int) " & wertop & " cast(datepart(quarter, getdate()) as int)"
                    Case "aktuelles Jahr"
                        Return "year(" & wertdbfeld & ") " & wertop & " year(getdate())"
                End Select
            Case "DATUM"
                Select Case wertop
                    Case "="
                        Return wertdbfeld + " >  convert(datetime,'" + wertvalue + " 00:00:00',104) and " + wertdbfeld + " <  convert(datetime,'" + wertvalue + " 23:59:59',104)"
                    Case "<>"
                        Return wertdbfeld + " <  convert(datetime,'" + wertvalue + " 00:00:00',104) and " + wertdbfeld + " >  convert(datetime,'" + wertvalue + " 23:59:59',104)"
                    Case ">="
                        Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 00:00:00',104)"
                    Case ">"
                        Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 23:59:59',104)"
                    Case "<"
                        Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 00:00:00',104)"
                    Case "<="
                        Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 23:59:59',104)"
                    Case Else
                        Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 00:00:00',104)"
                End Select
            Case "DATUM+1"
                Dim d As DateTime = wertvalue
                d = DateAdd(DateInterval.Day, 1, d)
                wertvalue = d.ToString
                Return wertdbfeld + " " + wertop + " convert(datetime,'" + wertvalue + " 00:00:00',104)"
            Case "BOOLEAN"
                If UCase(wertvalue) = "TRUE" Or UCase(wertvalue) = "JA" Then
                    Return wertdbfeld + " " + wertop + " 1"
                Else
                    Return wertdbfeld + " " + wertop + " 0"
                End If
            Case Else
        End Select

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmReportSelect-Felder

FrmReportSelect Übersicht

Felder

private field Auswertungsdaten

Unterstützt von .NET Compact Framework
private field CtrlList

Unterstützt von .NET Compact Framework
private field On_Load

Unterstützt von .NET Compact Framework
private field SQLWhere

Unterstützt von .NET Compact Framework
private field auswertungen

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field dr

Unterstützt von .NET Compact Framework
private field s

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework
private field splits

Unterstützt von .NET Compact Framework
private field tt

Unterstützt von .NET Compact Framework

FrmReportSelect -Klasse


Auswertungsdaten -Feld

[Visual Basic]
Private Auswertungsdaten As DataTable

Quellcode

[Visual Basic]
    Dim Auswertungsdaten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


CtrlList -Feld

[Visual Basic]
Private CtrlList As List(Of Control)

Quellcode

[Visual Basic]
    Dim CtrlList As New List(Of Control)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


On_Load -Feld

[Visual Basic]
Private On_Load As Boolean

Quellcode

[Visual Basic]
    Dim On_Load As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


SQLWhere -Feld

[Visual Basic]
Private SQLWhere As String

Quellcode

[Visual Basic]
    Dim SQLWhere As String = ""

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


auswertungen -Feld

[Visual Basic]
Private auswertungen As clsAuswertung

Quellcode

[Visual Basic]
    Dim auswertungen As New TKB.Auswertung.clsAuswertung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


dr -Feld

[Visual Basic]
Private dr As DataRow

Quellcode

[Visual Basic]
    Dim dr As DataRow

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


s -Feld

[Visual Basic]
Private s As String

Quellcode

[Visual Basic]
    Dim s As String = ""

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


splits -Feld

[Visual Basic]
Private splits As String()

Quellcode

[Visual Basic]
    Dim splits() As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


tt -Feld

[Visual Basic]
Private tt As clsToolTips

Quellcode

[Visual Basic]
    Dim tt As New TKB.VV.Utils.clsToolTips

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReportSelect


FrmToolTipEditor -Klasse

For a list of all members of this type, see FrmToolTipEditor-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.FrmToolTipEditor

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class FrmToolTipEditor
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

FrmToolTipEditor-Member


FrmToolTipEditor-Member

FrmToolTipEditor Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_FormClosed

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_FormClosing

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_Load

Unterstützt von .NET Compact Framework
private method Get_Data

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Save_Data

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSave_Click

Unterstützt von .NET Compact Framework
private method evh_Set_ToolTip

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

FrmToolTipEditor -Klasse


FrmToolTipEditor-Methoden

FrmToolTipEditor Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_FormClosed

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_FormClosing

Unterstützt von .NET Compact Framework
private method FrmToolTipEditor_Load

Unterstützt von .NET Compact Framework
private method Get_Data

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Save_Data

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSave_Click

Unterstützt von .NET Compact Framework
private method evh_Set_ToolTip

Unterstützt von .NET Compact Framework

FrmToolTipEditor -Klasse


FrmToolTipEditor.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.FrmToolTipEditor_FormClosed -Methode

[Visual Basic]
Private Sub FrmToolTipEditor_FormClosed( _
   ByVal sender As Object, _
   ByVal e As FormClosedEventArgs _
) Handles  _
   Me.FormClosed

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmToolTipEditor_FormClosed(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosedEventArgs) Handles Me.FormClosed
        Globals.Set_ToolTips = False
        Globals.ToolTipDaten.Tables.Clear()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.FrmToolTipEditor_FormClosing -Methode

[Visual Basic]
Private Sub FrmToolTipEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmToolTipEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        Globals.Set_ToolTips = False
        Globals.ToolTipDaten.Tables.Clear()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.FrmToolTipEditor_Load -Methode

[Visual Basic]
Private Sub FrmToolTipEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmToolTipEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Globals.Set_ToolTips = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.Get_Data -Methode

[Visual Basic]
Private Function Get_Data() As Object

Quellcode

[Visual Basic]
    Private Function Get_Data()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_tooltips"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@formname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.txtFormularname.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@controlname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.txtControlname.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Tooltip", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outToolTipNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outformname", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outcontrolname", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outtooltip", SqlDbType.VarChar, 1024, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.ExecuteNonQuery()

            If scmCmdToExecute.Parameters("@outtooltip").Value <> "" Then
                Me.txtToolTip.Text = scmCmdToExecute.Parameters("@outtooltip").Value
                Return True
            Else
                Return False
            End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Connection.Close()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(FrmToolTipEditor))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.lblFormular = New System.Windows.Forms.Label
        Me.txtFormularname = New System.Windows.Forms.TextBox
        Me.txtControlname = New System.Windows.Forms.TextBox
        Me.lblControl = New System.Windows.Forms.Label
        Me.lblToolTip = New System.Windows.Forms.Label
        Me.txtToolTip = New System.Windows.Forms.TextBox
        Me.btnSave = New System.Windows.Forms.Button
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(587, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(587, 25)
        Me.ToolStrip1.TabIndex = 2
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'lblFormular
        '
        Me.lblFormular.AutoSize = True
        Me.lblFormular.Location = New System.Drawing.Point(12, 61)
        Me.lblFormular.Name = "lblFormular"
        Me.lblFormular.Size = New System.Drawing.Size(73, 13)
        Me.lblFormular.TabIndex = 3
        Me.lblFormular.Text = "Formularname"
        '
        'txtFormularname
        '
        Me.txtFormularname.Location = New System.Drawing.Point(91, 61)
        Me.txtFormularname.Name = "txtFormularname"
        Me.txtFormularname.Size = New System.Drawing.Size(210, 20)
        Me.txtFormularname.TabIndex = 4
        '
        'txtControlname
        '
        Me.txtControlname.Location = New System.Drawing.Point(91, 87)
        Me.txtControlname.Name = "txtControlname"
        Me.txtControlname.Size = New System.Drawing.Size(210, 20)
        Me.txtControlname.TabIndex = 5
        '
        'lblControl
        '
        Me.lblControl.AutoSize = True
        Me.lblControl.Location = New System.Drawing.Point(12, 90)
        Me.lblControl.Name = "lblControl"
        Me.lblControl.Size = New System.Drawing.Size(40, 13)
        Me.lblControl.TabIndex = 6
        Me.lblControl.Text = "Control"
        '
        'lblToolTip
        '
        Me.lblToolTip.AutoSize = True
        Me.lblToolTip.Location = New System.Drawing.Point(12, 126)
        Me.lblToolTip.Name = "lblToolTip"
        Me.lblToolTip.Size = New System.Drawing.Size(43, 13)
        Me.lblToolTip.TabIndex = 7
        Me.lblToolTip.Text = "ToolTip"
        '
        'txtToolTip
        '
        Me.txtToolTip.Location = New System.Drawing.Point(91, 119)
        Me.txtToolTip.Multiline = True
        Me.txtToolTip.Name = "txtToolTip"
        Me.txtToolTip.Size = New System.Drawing.Size(474, 75)
        Me.txtToolTip.TabIndex = 8
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(91, 220)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.Size = New System.Drawing.Size(75, 23)
        Me.btnSave.TabIndex = 9
        Me.btnSave.Text = "Speichern"
        Me.btnSave.UseVisualStyleBackColor = True
        '
        'FrmToolTipEditor
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(587, 262)
        Me.Controls.Add(Me.btnSave)
        Me.Controls.Add(Me.txtToolTip)
        Me.Controls.Add(Me.lblToolTip)
        Me.Controls.Add(Me.lblControl)
        Me.Controls.Add(Me.txtControlname)
        Me.Controls.Add(Me.txtFormularname)
        Me.Controls.Add(Me.lblFormular)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmToolTipEditor"
        Me.Text = "ToolTipEditor"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.Save_Data -Methode

[Visual Basic]
Private Function Save_Data() As Object

Quellcode

[Visual Basic]
    Private Function Save_Data()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_tooltips"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@formname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.txtFormularname.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@controlname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.txtControlname.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Tooltip", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.txtToolTip.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outToolTipNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outformname", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outcontrolname", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@outtooltip", SqlDbType.VarChar, 1024, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.ExecuteNonQuery()
            Return True
        Catch ex As Exception
        Finally
            scmCmdToExecute.Connection.Close()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.btnSave_Click -Methode

[Visual Basic]
Private Sub btnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        Me.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor.evh_Set_ToolTip -Methode

[Visual Basic]
Private Sub evh_Set_ToolTip( _
   ByVal formname As String, _
   ByVal ctlname As String _
) Handles  _
   evh.Set_ToolTip

Parameter

formname
ctlname

Quellcode

[Visual Basic]
    Private Sub evh_Set_ToolTip(ByVal formname As String, ByVal ctlname As String) Handles evh.Set_ToolTip
        Me.txtFormularname.Text = formname
        Me.txtControlname.Text = ctlname
        Me.txtToolTip.Text = ""
        Get_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


FrmToolTipEditor-Felder

FrmToolTipEditor Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

FrmToolTipEditor -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmToolTipEditor


form1 -Klasse

For a list of all members of this type, see form1-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.form1

[Visual Basic]
Public Class form1
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

form1-Member


form1-Member

form1 Übersicht

Öffentliche Methoden

public method saveasbitmap

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Static BitBlt

Unterstützt von .NET Compact Framework
private method GetFormImage

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnDelete_Click

Unterstützt von .NET Compact Framework
private method TSBtnSave_Click

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework
private field p

Unterstützt von .NET Compact Framework
private field p2

Unterstützt von .NET Compact Framework
private field r

Unterstützt von .NET Compact Framework
private field t

Unterstützt von .NET Compact Framework

form1 -Klasse


form1-Methoden

form1 Übersicht

Öffentliche Methoden

public method saveasbitmap

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Static BitBlt

Unterstützt von .NET Compact Framework
private method GetFormImage

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnDelete_Click

Unterstützt von .NET Compact Framework
private method TSBtnSave_Click

Unterstützt von .NET Compact Framework

form1 -Klasse


form1.BitBlt -Methode

[Visual Basic]
Private Declare Auto Function BitBlt Lib "gdi32.dll" ( _
   ByVal hdcDest As IntPtr, _
   ByVal nXDest As Integer, _
   ByVal nYDest As Integer, _
   ByVal nWidth As Integer, _
   ByVal nHeight As Integer, _
   ByVal hdcSrc As IntPtr, _
   ByVal nXSrc As Integer, _
   ByVal nYSrc As Integer, _
   ByVal dwRop As Integer _
) As Boolean

Parameter

hdcDest
nXDest
nYDest
nWidth
nHeight
hdcSrc
nXSrc
nYSrc
dwRop

Quellcode

[Visual Basic]
    Private Declare Auto Function BitBlt Lib "gdi32.dll" (ByVal _
        hdcDest As IntPtr, ByVal nXDest As Integer, ByVal _
        nYDest As Integer, ByVal nWidth As Integer, ByVal _
        nHeight As Integer, ByVal hdcSrc As IntPtr, ByVal nXSrc _
        As Integer, ByVal nYSrc As Integer, ByVal dwRop As _
        System.Int32) As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.GetFormImage -Methode

[Visual Basic]
Private Function GetFormImage() As Bitmap

Quellcode

[Visual Basic]
    Private Function GetFormImage() As Bitmap
        ' Get this form's Graphics object.
        Dim me_gr As Graphics = Me.CreateGraphics

        ' Make a Bitmap to hold the image.
        Dim bm As New Bitmap(Me.Width, _
            Me.Height, me_gr)
        Dim bm_gr As Graphics = me_gr.FromImage(bm)
        Dim bm_hdc As IntPtr = bm_gr.GetHdc

        ' Get the form's hDC. We must do this after
        ' creating the new Bitmap, which uses me_gr.
        Dim me_hdc As IntPtr = me_gr.GetHdc

        ' BitBlt the form's image onto the Bitmap.
        BitBlt(bm_hdc, 0, 0, Me.Width, _
            Me.Height, _
            me_hdc, 0, 0, SRCCOPY)
        me_gr.ReleaseHdc(me_hdc)
        bm_gr.ReleaseHdc(bm_hdc)

        ' Return the result.
        Return bm
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(form1))
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 25)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(711, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 0)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(711, 25)
        Me.ToolStrip1.TabIndex = 4
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(0, 49)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(711, 509)
        Me.C1Kontakte.TabIndex = 6
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'Form1
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(711, 558)
        Me.Controls.Add(Me.C1Kontakte)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Name = "Form1"
        Me.Text = "Form1"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.TSBtnDelete_Click -Methode

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        saveasbitmap(Me.C1Kontakte)
        t.Y = Me.MenuStrip1.Top
        t.X = Me.MenuStrip1.Left
        t.Width = Me.MenuStrip1.Width
        t.Height = Me.MenuStrip1.Height

        Dim b As New Bitmap(t.Width, t.Height)
        Me.DrawToBitmap(b, t)
        b.Save("c:\temp\menustrip1.bmp")

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.TSBtnSave_Click -Methode

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Dim bm As Bitmap = GetFormImage()
        bm.Save("c:\temp\test.bmp", System.Drawing.Imaging.ImageFormat.Bmp)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1.saveasbitmap -Methode

[Visual Basic]
Public Function saveasbitmap( _
   ByRef ctl As Control _
) As Object

Parameter

ctl

Quellcode

[Visual Basic]
    Public Function saveasbitmap(ByRef ctl As Control)
        Dim g As Graphics = ctl.CreateGraphics
        Dim b As New Bitmap(ctl.Width, ctl.Height)
        ctl.DrawToBitmap(b, New Rectangle(0, 0, ctl.Width, ctl.Height))
        b.Save("c:\temp\test.bmp", System.Drawing.Imaging.ImageFormat.Bmp)
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


form1-Felder

form1 Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field p

Unterstützt von .NET Compact Framework
private field p2

Unterstützt von .NET Compact Framework
private field r

Unterstützt von .NET Compact Framework
private field t

Unterstützt von .NET Compact Framework

form1 -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


p -Feld

[Visual Basic]
Private p As Point

Quellcode

[Visual Basic]
    Dim p As New Point

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


p2 -Feld

[Visual Basic]
Private p2 As Point

Quellcode

[Visual Basic]
    Dim p2 As New Point

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


r -Feld

[Visual Basic]
Private r As Rectangle

Quellcode

[Visual Basic]
    Dim r As New System.Drawing.Rectangle

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


t -Feld

[Visual Basic]
Private t As Rectangle

Quellcode

[Visual Basic]
    Dim t As Rectangle

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

form1


frmAbout -Klasse

For a list of all members of this type, see frmAbout-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmAbout

[Visual Basic]
Public Class frmAbout
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmAbout-Member


frmAbout-Member

frmAbout Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnOK_Click

Unterstützt von .NET Compact Framework
private method frmAbout_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmAbout -Klasse


frmAbout-Methoden

frmAbout Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnOK_Click

Unterstützt von .NET Compact Framework
private method frmAbout_Load

Unterstützt von .NET Compact Framework

frmAbout -Klasse


frmAbout.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAbout


frmAbout.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmAbout))
        Me.PictureBox1 = New System.Windows.Forms.PictureBox
        Me.btnOK = New System.Windows.Forms.Button
        Me.lblversiondatum = New System.Windows.Forms.Label
        Me.lblVersion = New System.Windows.Forms.Label
        CType(Me.PictureBox1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'PictureBox1
        '
        Me.PictureBox1.ErrorImage = CType(resources.GetObject("PictureBox1.ErrorImage"), System.Drawing.Image)
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Image)
        Me.PictureBox1.Location = New System.Drawing.Point(0, 0)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(469, 330)
        Me.PictureBox1.TabIndex = 1
        Me.PictureBox1.TabStop = False
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(201, 339)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.Size = New System.Drawing.Size(75, 23)
        Me.btnOK.TabIndex = 2
        Me.btnOK.Text = "OK"
        Me.btnOK.UseVisualStyleBackColor = True
        '
        'lblversiondatum
        '
        Me.lblversiondatum.BackColor = System.Drawing.Color.White
        Me.lblversiondatum.Font = New System.Drawing.Font("Microsoft Sans Serif", 11.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblversiondatum.Location = New System.Drawing.Point(249, 273)
        Me.lblversiondatum.Name = "lblversiondatum"
        Me.lblversiondatum.Size = New System.Drawing.Size(193, 24)
        Me.lblversiondatum.TabIndex = 4
        Me.lblversiondatum.Text = "Version "
        Me.lblversiondatum.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'lblVersion
        '
        Me.lblVersion.BackColor = System.Drawing.Color.White
        Me.lblVersion.Font = New System.Drawing.Font("Microsoft Sans Serif", 14.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblVersion.Location = New System.Drawing.Point(245, 249)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(197, 24)
        Me.lblVersion.TabIndex = 3
        Me.lblVersion.Text = "Version "
        Me.lblVersion.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'frmAbout
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(464, 374)
        Me.Controls.Add(Me.lblversiondatum)
        Me.Controls.Add(Me.lblVersion)
        Me.Controls.Add(Me.btnOK)
        Me.Controls.Add(Me.PictureBox1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmAbout"
        Me.Text = "frmAbout"
        CType(Me.PictureBox1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAbout


frmAbout.btnOK_Click -Methode

[Visual Basic]
Private Sub btnOK_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnOK.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOK.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAbout


frmAbout.frmAbout_Load -Methode

[Visual Basic]
Private Sub frmAbout_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmAbout_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.lblVersion.Text = "Version " & Globals.clsapplication.sVersion.Value
        Me.lblversiondatum.Text = Globals.Versionsdatum

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAbout


frmAbout-Felder

frmAbout Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmAbout -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAbout


frmApplSuche -Klasse

For a list of all members of this type, see frmApplSuche-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplSuche

[Visual Basic]
Public Class frmApplSuche
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplSuche-Member


frmApplSuche-Member

frmApplSuche Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSuche_Click

Unterstützt von .NET Compact Framework
private method txtSuchbegriff_KeyDown

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmApplSuche -Klasse


frmApplSuche-Methoden

frmApplSuche Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSuche_Click

Unterstützt von .NET Compact Framework
private method txtSuchbegriff_KeyDown

Unterstützt von .NET Compact Framework

frmApplSuche -Klasse


frmApplSuche.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplSuche))
        Me.lblSuchbegriff = New System.Windows.Forms.Label
        Me.txtSuchbegriff = New System.Windows.Forms.TextBox
        Me.btnSuche = New System.Windows.Forms.Button
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'lblSuchbegriff
        '
        Me.lblSuchbegriff.AutoSize = True
        Me.lblSuchbegriff.Location = New System.Drawing.Point(12, 59)
        Me.lblSuchbegriff.Name = "lblSuchbegriff"
        Me.lblSuchbegriff.Size = New System.Drawing.Size(61, 13)
        Me.lblSuchbegriff.TabIndex = 0
        Me.lblSuchbegriff.Text = "Suchbegriff"
        '
        'txtSuchbegriff
        '
        Me.txtSuchbegriff.Location = New System.Drawing.Point(79, 56)
        Me.txtSuchbegriff.Name = "txtSuchbegriff"
        Me.txtSuchbegriff.Size = New System.Drawing.Size(288, 20)
        Me.txtSuchbegriff.TabIndex = 1
        '
        'btnSuche
        '
        Me.btnSuche.Location = New System.Drawing.Point(156, 100)
        Me.btnSuche.Name = "btnSuche"
        Me.btnSuche.Size = New System.Drawing.Size(75, 23)
        Me.btnSuche.TabIndex = 11
        Me.btnSuche.Text = "Suchen"
        Me.btnSuche.UseVisualStyleBackColor = True
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(388, 24)
        Me.MenuStrip1.TabIndex = 12
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(388, 25)
        Me.ToolStrip1.TabIndex = 13
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'frmApplSuche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(388, 146)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Controls.Add(Me.btnSuche)
        Me.Controls.Add(Me.txtSuchbegriff)
        Me.Controls.Add(Me.lblSuchbegriff)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplSuche"
        Me.Text = "Applikation-Suche"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche.btnSuche_Click -Methode

[Visual Basic]
Private Sub btnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSuche.Click
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche.txtSuchbegriff_KeyDown -Methode

[Visual Basic]
Private Sub txtSuchbegriff_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtSuchbegriff.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtSuchbegriff_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtSuchbegriff.KeyDown
        If e.KeyCode = Keys.Enter Then btnSuche_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplSuche-Felder

frmApplSuche Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmApplSuche -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplSuche


frmApplikation -Klasse

For a list of all members of this type, see frmApplikation-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplikation

[Visual Basic]
Public Class frmApplikation
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplikation-Member


frmApplikation-Member

frmApplikation Übersicht

Öffentliche Konstruktoren

public constructor frmApplikation -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AbhaengigkeitAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AbhaengigkeitLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AbhaengigkeitMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method AbhaengigkeitNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Applikationsabhaengigkeit
private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method Button3_Click Unterstützt von .NET Compact Framework |
private method Button5_Click Unterstützt von .NET Compact Framework |
private method C1Abhaengigkeiten_DoubleClick Unterstützt von .NET Compact Framework |
private method C1Abhaengigkeiten_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Applikationen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Dokumenten
private method C1Dokumente_MouseDown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Drehbuch_DoubleClick Unterstützt von .NET Compact Framework |
private method C1Drehbuch_DoubleClick1 Unterstützt von .NET Compact Framework |
private method C1Drehbuch_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Lizenzkäufe_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzkäufe_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf Lizenzkauf
private method C1Lizenzkäufe_RowColChange Unterstützt von .NET Compact Framework |
private method C1Lizenzschluessel_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzschluessel_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzvertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzvertraege_MouseDown Unterstützt von .NET Compact Framework |
private method C1Lizenzvertraege_RowColChange Unterstützt von .NET Compact Framework |
private method C1ReleaseLogbuch_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen (Dialog)
private method DokumentAnzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Dokument generieren und anzeigen
private method DokumenteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method DrehbuchAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DrehbuchLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DrehbuchMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method DrehbuchNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_CheckedItems Unterstützt von .NET Compact Framework |
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method KontaktLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Disable bzw. Enable der Menueinträge
private method Lizenzkauf_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung der Grids Lizenzkauf und Lizenzschluessel
private method Lizenzschluessel_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung der Grids Lizenzkauf und Lizenzschluessel
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method MassenUpdatesToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Abhaengigkeiten Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Drehbuecher Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Lizenzen Unterstützt von .NET Compact Framework |
private method Refresh_Registerlasche Unterstützt von .NET Compact Framework | Aktuelle Registerlasche aktualisieren
private method Refresh_ReleaseLogbuch Unterstützt von .NET Compact Framework | Release aktualisieren
private method Refresh_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Applikationen aktualiseren
private method ReleaseLogbuchAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method ReleaseLogbuchLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method ReleaseLogbuchMenuStrip_Opening Unterstützt von .NET Compact Framework | Disable bzw. Enable der Menueinträge
private method ReleaseLogbuchNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method ReleaseLogbuch_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method ReleaseLogbuch_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method Set_Checkedlistbox Unterstützt von .NET Compact Framework |
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TabControlApplikation_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlApplikation
private method ToolStripButton1_Click Unterstützt von .NET Compact Framework |
private method ToolStripButton1_Click_1 Unterstützt von .NET Compact Framework |
private method TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten öffnen
private method TreeApplikationen_AfterSelect Unterstützt von .NET Compact Framework |
private method VertragsbeziehungMenuStrip_Opening Unterstützt von .NET Compact Framework | VertragsbeziehungMenuStrip Opening
private method VertragselementAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeige Vertragselement
private method btnDrehbuchanzeigen_Click Unterstützt von .NET Compact Framework |
private method btnSearchAppl_Click Unterstützt von .NET Compact Framework |
private method cbTicketXPertVerwendung_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbboxVerantwortung_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cboxNurAktive_CheckedChanged Unterstützt von .NET Compact Framework |
private method dtPickerInaktivSeit_ValueChanged Unterstützt von .NET Compact Framework |
private method evh_FormularReleaseLogbuchClosed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragselementApplikation_Closed Unterstützt von .NET Compact Framework |
private method frmApplikation_Load Unterstützt von .NET Compact Framework |
private method tstxtArchitektur_KeyDown Unterstützt von .NET Compact Framework |
private method tstxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method txtInaktivseit_Leave Unterstützt von .NET Compact Framework |

Felder

private field Aktuelle_Applikation

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikation

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field TreeParent

Unterstützt von .NET Compact Framework
private field Treeviewdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikation -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void frmApplikation();

[Visual Basic] Public Sub New(Integer, Optional Boolean)
[C#] public System.Void frmApplikation(int, bool);

[Visual Basic] Public Sub New(Boolean)
[C#] public System.Void frmApplikation(bool);

frmApplikation


frmApplikation-Methoden

frmApplikation Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AbhaengigkeitAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AbhaengigkeitLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AbhaengigkeitMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method AbhaengigkeitNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Applikationsabhaengigkeit
private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method Button3_Click Unterstützt von .NET Compact Framework |
private method Button5_Click Unterstützt von .NET Compact Framework |
private method C1Abhaengigkeiten_DoubleClick Unterstützt von .NET Compact Framework |
private method C1Abhaengigkeiten_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Applikationen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Dokumenten
private method C1Dokumente_MouseDown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Drehbuch_DoubleClick Unterstützt von .NET Compact Framework |
private method C1Drehbuch_DoubleClick1 Unterstützt von .NET Compact Framework |
private method C1Drehbuch_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Lizenzkäufe_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzkäufe_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf Lizenzkauf
private method C1Lizenzkäufe_RowColChange Unterstützt von .NET Compact Framework |
private method C1Lizenzschluessel_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1Lizenzschluessel_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzvertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Lizenzvertraege_MouseDown Unterstützt von .NET Compact Framework |
private method C1Lizenzvertraege_RowColChange Unterstützt von .NET Compact Framework |
private method C1ReleaseLogbuch_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen (Dialog)
private method DokumentAnzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Dokument generieren und anzeigen
private method DokumenteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method DrehbuchAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DrehbuchLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method DrehbuchMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method DrehbuchNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_CheckedItems Unterstützt von .NET Compact Framework |
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method KontaktLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Disable bzw. Enable der Menueinträge
private method Lizenzkauf_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung der Grids Lizenzkauf und Lizenzschluessel
private method Lizenzschluessel_Aktualisieren Unterstützt von .NET Compact Framework | Aktualiserung der Grids Lizenzkauf und Lizenzschluessel
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method MassenUpdatesToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Abhaengigkeiten Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Drehbuecher Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Lizenzen Unterstützt von .NET Compact Framework |
private method Refresh_Registerlasche Unterstützt von .NET Compact Framework | Aktuelle Registerlasche aktualisieren
private method Refresh_ReleaseLogbuch Unterstützt von .NET Compact Framework | Release aktualisieren
private method Refresh_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Applikationen aktualiseren
private method ReleaseLogbuchAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method ReleaseLogbuchLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method ReleaseLogbuchMenuStrip_Opening Unterstützt von .NET Compact Framework | Disable bzw. Enable der Menueinträge
private method ReleaseLogbuchNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method ReleaseLogbuch_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method ReleaseLogbuch_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method Set_Checkedlistbox Unterstützt von .NET Compact Framework |
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TabControlApplikation_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlApplikation
private method ToolStripButton1_Click Unterstützt von .NET Compact Framework |
private method ToolStripButton1_Click_1 Unterstützt von .NET Compact Framework |
private method TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten öffnen
private method TreeApplikationen_AfterSelect Unterstützt von .NET Compact Framework |
private method VertragsbeziehungMenuStrip_Opening Unterstützt von .NET Compact Framework | VertragsbeziehungMenuStrip Opening
private method VertragselementAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeige Vertragselement
private method btnDrehbuchanzeigen_Click Unterstützt von .NET Compact Framework |
private method btnSearchAppl_Click Unterstützt von .NET Compact Framework |
private method cbTicketXPertVerwendung_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbboxVerantwortung_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cboxNurAktive_CheckedChanged Unterstützt von .NET Compact Framework |
private method dtPickerInaktivSeit_ValueChanged Unterstützt von .NET Compact Framework |
private method evh_FormularReleaseLogbuchClosed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragselementApplikation_Closed Unterstützt von .NET Compact Framework |
private method frmApplikation_Load Unterstützt von .NET Compact Framework |
private method tstxtArchitektur_KeyDown Unterstützt von .NET Compact Framework |
private method tstxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method txtInaktivseit_Leave Unterstützt von .NET Compact Framework |

frmApplikation -Klasse


frmApplikation.AbhaengigkeitAnzeigenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AbhaengigkeitAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AbhaengigkeitAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AbhaengigkeitAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AbhaengigkeitAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmApplikationAbhaengigkeit(Me.C1Abhaengigkeiten.Columns("Applikationabhaengigkeitnr").Value, 0, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.AbhaengigkeitLoeschenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AbhaengigkeitLoeschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AbhaengigkeitLoeschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AbhaengigkeitLoeschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AbhaengigkeitLoeschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(852) = MsgBoxResult.Yes Then
                Me.Applikation.Applikationabhaengigkeit.Delete_Referenz(Me.C1Abhaengigkeiten.Columns("ApplikationAbhaengigkeitnr").Value)
                Me.Refresh_Abhaengigkeiten()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.AbhaengigkeitMenuStrip_Opening -Methode

[Visual Basic]
Private Sub AbhaengigkeitMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   AbhaengigkeitMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AbhaengigkeitMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles AbhaengigkeitMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Abhaengigkeiten)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.AbhaengigkeitNeuToolStripMenuItem_Click -Methode

Neue Applikationsabhaengigkeit

[Visual Basic]
Private Sub AbhaengigkeitNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AbhaengigkeitNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AbhaengigkeitNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AbhaengigkeitNeuToolStripMenuItem.Click
        Try
            Dim f As New frmApplikationAbhaengigkeit(0, Me.Applikation.iApplikationNr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                If c.Name <> "cboxNurAktive" Then
                    Dim ctl As CheckBox = c
                    AddHandler ctl.CheckedChanged, evh
                End If
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Button3_Click -Methode

[Visual Basic]
Private Sub Button3_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnDrehbuchspeichern.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDrehbuchspeichern.Click
        Dim f As frmDokument
        Dim i As Integer = 0
        i = Me.Applikation.Dokument.Exists_Testdrehbuch(Me.Applikation.iApplikationNr.Value)
        If i < 1 Then
            f = New frmDokument(0, 2, Me.Applikation.iApplikationNr.Value, Me.FormReadonly, True)
        Else
            f = New frmDokument(i, 2, Me.Applikation.iApplikationNr.Value, Me.FormReadonly, False)
        End If
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Button5_Click -Methode

[Visual Basic]
Private Sub Button5_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        ' Display in a message box all the items that are checked.
        Dim indexChecked As Integer
        Dim itemChecked As Object
        Const quote As String = """"

        ' First show the index and check state of all selected items.
        For Each indexChecked In lboxInstalliertals.CheckedIndices
            ' The indexChecked variable contains the index of the item.
            MessageBox.Show("Index#: " + indexChecked.ToString() + ", is checked. Checked state is:" + _
                            lboxInstalliertals.GetItemCheckState(indexChecked).ToString() + ".")
        Next

        ' Next show the object title and check state for each item selected.
        For Each itemChecked In lboxInstalliertals.CheckedItems

            ' Use the IndexOf method to get the index of an item.
            MessageBox.Show("Item with title: " + quote + itemChecked.ToString() + quote + _
                            ", is checked. Checked state is: " + _
                            lboxInstalliertals.GetItemCheckState(lboxInstalliertals.Items.IndexOf(itemChecked)).ToString() + ".")
        Next

        For Each GG As System.Data.DataRowView In Me.lboxInstalliertals.CheckedItems
            MsgBox("hALLO")

        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Abhaengigkeiten_DoubleClick -Methode

[Visual Basic]
Private Sub C1Abhaengigkeiten_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Abhaengigkeiten.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Abhaengigkeiten_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Abhaengigkeiten.DoubleClick
        Try
            Dim f As New frmApplikationAbhaengigkeit(Me.C1Abhaengigkeiten.Columns("Applikationabhaengigkeitnr").Value, 0, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Abhaengigkeiten_FetchRowStyle -Methode

[Visual Basic]
Private Sub C1Abhaengigkeiten_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Abhaengigkeiten.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Abhaengigkeiten_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Abhaengigkeiten.FetchRowStyle
        Try
            If Me.C1Abhaengigkeiten.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Applikationen_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Applikationen_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Vertragselemente.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Vertragselemente.MouseDown
        Me.C1Vertragselemente.Bookmark = Me.C1Vertragselemente.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Dokumente_DoubleClick -Methode

Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)

[Visual Basic]
Private Sub C1Dokumente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Dokumente.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button DokumentAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Dokumente.DoubleClick
        If Me.DokumentAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.DokumentAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Dokumente_FetchRowStyle -Methode

Rowstyle von inaktiven Dokumenten

[Visual Basic]
Private Sub C1Dokumente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Dokumente.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Dokumente.FetchRowStyle
        Try
            If Me.C1Dokumente.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Dokumente_MouseDown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Dokumente_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Dokumente.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Dokumente.MouseDown
        Me.C1Dokumente.Bookmark = Me.C1Dokumente.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Drehbuch_DoubleClick -Methode

[Visual Basic]
Private Sub C1Drehbuch_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Drehbuch_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs)
        Try
            Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Drehbuch_DoubleClick1 -Methode

[Visual Basic]
Private Sub C1Drehbuch_DoubleClick1( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Drehbuch.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Drehbuch_DoubleClick1(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Drehbuch.DoubleClick
        Try
            Me.Applikation.Dokument.Show_Doc(Me.C1Drehbuch.Columns("Dokumentnr").Value)
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Drehbuch_FetchRowStyle -Methode

[Visual Basic]
Private Sub C1Drehbuch_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Drehbuch.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Drehbuch_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Drehbuch.FetchRowStyle
        Try
            If Me.C1Drehbuch.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Kontakte_DoubleClick -Methode

Doppelklick auf einem Kontakt

[Visual Basic]
Private Sub C1Kontakte_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.DoubleClick

Parameter

sender
e

Hinweise

Ist der MenuEintrag KontaktAnzeigenToolStripMenuItem disabled, wird der Doppelklick ignoriert

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Kontakte.DoubleClick

        If Me.KontaktAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            Me.KontaktAnzeigenToolStripMenuItem_Click(sender, e)

        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Kontakte_FetchRowStyle -Methode

Rowstyle von inaktiven Kontakten

[Visual Basic]
Private Sub C1Kontakte_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontakte.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontakte.FetchRowStyle
        Try
            If Me.C1Kontakte.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Kontakte_MouseDown -Methode

Mousedown Kontakte

[Visual Basic]
Private Sub C1Kontakte_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontakte.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontakte.MouseDown
        Me.C1Kontakte.Bookmark = Me.C1Kontakte.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzkäufe_FetchRowStyle -Methode

Rowstyle von inaktiven Kündigungsfristen

[Visual Basic]
Private Sub C1Lizenzkäufe_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Lizenzkäufe.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Lizenzkäufe.FetchRowStyle
        Try
            If Me.C1Lizenzkäufe.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzkäufe_MouseDown -Methode

Mousedown-Ereignis auf Lizenzkauf

[Visual Basic]
Private Sub C1Lizenzkäufe_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Lizenzkäufe.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Lizenzkäufe.MouseDown
        Me.Lizenzschluessel_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzkäufe_RowColChange -Methode

[Visual Basic]
Private Sub C1Lizenzkäufe_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1Lizenzkäufe.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzkäufe_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1Lizenzkäufe.RowColChange
        Me.Lizenzschluessel_Aktualisieren()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzschluessel_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Lizenzschluessel_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Lizenzschluessel.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Lizenzschluessel.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = "DokumentAblageOrt"
        Try
            ts.Feld = Me.C1Lizenzschluessel.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzschluessel_FetchRowStyle -Methode

Rowstyle von inaktiven Kündigungsfristen

[Visual Basic]
Private Sub C1Lizenzschluessel_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Lizenzschluessel.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzschluessel_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Lizenzschluessel.FetchRowStyle
        Try
            If Me.C1Lizenzschluessel.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzvertraege_FetchRowStyle -Methode

Rowstyle von inaktiven Kündigungsfristen

[Visual Basic]
Private Sub C1Lizenzvertraege_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Lizenzvertraege.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzvertraege_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Lizenzvertraege.FetchRowStyle
        Try
            If Me.C1Lizenzvertraege.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzvertraege_MouseDown -Methode

[Visual Basic]
Private Sub C1Lizenzvertraege_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Lizenzvertraege.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzvertraege_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Lizenzvertraege.MouseDown
        Me.Lizenzkauf_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Lizenzvertraege_RowColChange -Methode

[Visual Basic]
Private Sub C1Lizenzvertraege_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1Lizenzvertraege.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Lizenzvertraege_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1Lizenzvertraege.RowColChange
        Me.Lizenzkauf_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1ReleaseLogbuch_FetchRowStyle -Methode

Rowstyle von inaktiven Kontakten

[Visual Basic]
Private Sub C1ReleaseLogbuch_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1ReleaseLogbuch.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1ReleaseLogbuch_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1ReleaseLogbuch.FetchRowStyle
        Try
            If Me.C1ReleaseLogbuch.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.C1Vertragselemente_FetchRowStyle -Methode

Rowstyle von inaktiven Pendenzen

[Visual Basic]
Private Sub C1Vertragselemente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Vertragselemente.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Vertragselemente.FetchRowStyle
        Try
            If Me.C1Vertragselemente.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then
            Return True
            Exit Function
        End If
        Me.DiagramControl1.Check_Changes()
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Me.FormDataChanged = False
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If

        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DokumentAnzeigenToolStripMenuItem_Click -Methode

Dokument anzeigen (Dialog)

[Visual Basic]
Private Sub DokumentAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(Me.C1Dokumente.Columns("Dokumentnr").Value, 1, Me.Applikation.iApplikationNr.Value, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DokumentAnzeigen_Dokument_ToolStripMenuItem_Click -Methode

Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)

[Visual Basic]
Private Sub DokumentAnzeigen_Dokument_ToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigen_Dokument_ToolStripMenuItem.Click

Parameter

sender
e

Hinweise

Ist der Button DokumentAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigen_Dokument_ToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigen_Dokument_ToolStripMenuItem.Click
        Try
            Me.Applikation.Dokument.Show_Doc(Me.C1Dokumente.Columns("Dokumentnr").Value)
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DokumentLöschenToolStripMenuItem_Click -Methode

Dokument inaktivieren

[Visual Basic]
Private Sub DokumentLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(275) = MsgBoxResult.Yes Then
                Me.Applikation.Dokument.Delete_Dokument(Me.C1Dokumente.Columns("Dokumentnr").Value)
                evh.Dokumente_Geloscht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DokumentNeuToolStripMenuItem_Click -Methode

Neues Dokument generieren und anzeigen

[Visual Basic]
Private Sub DokumentNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentNeuToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(0, 3, Me.Applikation.iApplikationNr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DokumenteMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub DokumenteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   DokumenteMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub DokumenteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles DokumenteMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Dokumente)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation | Disable_Enable_Menu


frmApplikation.DrehbuchAnzeigenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DrehbuchAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DrehbuchAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DrehbuchAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DrehbuchAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(Me.C1Drehbuch.Columns("Dokumentnr").Value, 2, Me.Applikation.iApplikationNr.Value, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DrehbuchLöschenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DrehbuchLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DrehbuchLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DrehbuchLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DrehbuchLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(275) = MsgBoxResult.Yes Then
                Me.Applikation.Dokument.Delete_Dokument(Me.C1Drehbuch.Columns("Dokumentnr").Value)
                evh.Dokumente_Geloscht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DrehbuchMenuStrip_Opening -Methode

[Visual Basic]
Private Sub DrehbuchMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   DrehbuchMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DrehbuchMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles DrehbuchMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Drehbuch)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.DrehbuchNeuToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub DrehbuchNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DrehbuchNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DrehbuchNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DrehbuchNeuToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(0, 2, Me.Applikation.iApplikationNr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Drehbuch_Anzeigen_Dokument_ToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Drehbuch_Anzeigen_Dokument_ToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Drehbuch_Anzeigen_Dokument_ToolStripMenuItem.Click
        Try
            Me.Applikation.Dokument.Show_Doc(Me.C1Drehbuch.Columns("Dokumentnr").Value)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            Applikation.dispose()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Get_CheckedItems -Methode

[Visual Basic]
Private Function Get_CheckedItems( _
   ByRef clb As CheckedListBox _
) As String

Parameter

clb

Quellcode

[Visual Basic]
    Private Function Get_CheckedItems(ByRef clb As CheckedListBox) As String
        Dim i As Integer = 0
        Dim s As String = ""
        For i = 1 To clb.CheckedItems.Count
            s = s + clb.CheckedItems(i).ToString

        Next
        Return s
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Applikationnr As Integer _
)

Parameter

Applikationnr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Applikationnr As Integer)
        Try
            Applikation.Get_Applikation(Applikationnr)
            Me.txtBezeichnung.Text = Applikation.sBezeichnung.Value
            Dim i As Integer = Me.cbboxParentTree.TreeView.Height
            Me.cbboxParentTree.TreeView.Height = 0
            Me.cbboxParentTree.TreeView.Visible = True
            Me.cbboxParentTree.SelectedNode = Me.TreeParent.FindNode(Me.cbboxParentTree.TreeView.Nodes, Applikation.iParentID.Value, "")
            Application.DoEvents()
            Me.cbboxParentTree.TreeView.Visible = False
            Me.cbboxParentTree.TreeView.Height = i
            Me.cbboxVerantwortung.SelectedValue = Applikation.iApplikationVerantwortungNr.Value
            Me.cbboxTeam.SelectedValue = Applikation.iApplikationTeamnr.Value
            Me.cbboxKategorie.SelectedValue = Applikation.iApplikationKategorieNr.Value
            Me.cbboxMarktbereich.SelectedValue = Applikation.iMarktbereichnr.Value
            Me.txtInaktivseit.Text = Applikation.daInaktivseit.ToString
            Me.txtVersion.Text = Applikation.sVersion.Value
            Me.cbalsProdukt.Checked = Applikation.bAlsProdukt.Value = True
            Me.cbLizenzerfassung.Checked = Applikation.bNurLizenz.Value = True
            Me.txtPrioWiederanlauf.Text = Applikation.sPrioWiederanlauf.Value
            Me.cboxSecurityLevel.SelectedValue = Applikation.iSecurityLevelNr.Value
            Me.cboxRFCBoard.SelectedValue = Applikation.iRfcBoardNr.Value
            Me.txterstellt_am.Text = Applikation.daErstellt_am.ToString
            Me.txtmutiert_am.Text = Applikation.daMutiert_am.ToString
            Me.txtmutierer.Text = Applikation.iMutierer.ToString
            Me.cbAktiv.Checked = Applikation.bAktiv.Value = True
            Me.cbRAS.Checked = Applikation.bRAS.Value = True
            Me.txtDBName.Text = Applikation.sDatenbankname.Value
            Me.txtAnzInstallationen.Text = Applikation.sAnzahl_Installationen.Value

            Me.txtKurzbeschreibung.Text = Applikation.sKurzbeschreibung.Value
            If Microsoft.VisualBasic.Left(Me.txtKurzbeschreibung.Text, 7) = "- Modul" Then
                Dim fnt As New Font("Courier New", 8.25)
                Me.txtKurzbeschreibung.Font = fnt
            End If

            Me.cbTicketXPertVerwendung.Checked = Applikation.bTicketXPertVerwendung.Value = True
            If Me.cbTicketXPertVerwendung.Checked = False Then
                Me.grpTicketXpert.Enabled = False
            Else
                Me.grpTicketXpert.Enabled = True
            End If

            Try
                Me.cbboxTestaufwand.SelectedValue = Applikation.sTest_Aufwand.Value.ToString
            Catch ex As Exception
                Me.cbboxTestaufwand.SelectedValue = 1
            End Try
            Me.txtTestArbeitsplaetze.Text = Applikation.sTest_Arbeitsplaetze.Value
            Me.txtAbhaengigkeiten.Text = Applikation.sTest_Abhaengigkeiten.Value
            Me.txtBemerkung.Text = Applikation.sTest_Bemerkung.Value

            Me.cbWPIAnzeigen.Checked = Applikation.bTicketXPert_WPIAnzeigen.Value = True
            Me.txtWPIPreis.Text = Applikation.sTicketXPert_Preis.Value
            Me.txtPreisEinmalig.Text = Applikation.sTicketXPert_Preis_Einmalig.Value

            Me.cbAMAnzeigen.Checked = Applikation.bTicketXPert_AMAnzeigen.Value = True
            Me.cbboxKritikalität.SelectedValue = Applikation.iTicketXPert_ApplikationKritikalitaetTypNr.Value
            Me.cbboxSLM.SelectedValue = Applikation.iTicketXPert_ApplikationSMLTypNr.Value

            Set_Checkedlistbox(Me.lboxInstalliertauf, Me.Applikation.ApplikationInstallationTyp)
            Set_Checkedlistbox(Me.lboxInstalliertals, Me.Applikation.ApplikationInstallationals)
            Set_Checkedlistbox(Me.lboxStandardFuer, Me.Applikation.ApplikationInstallationFuer)

            Me.cbSensitiveDaten.Checked = Me.Applikation.bSensitiveDaten.Value = True
            Me.txtSensitiveDaten.Text = Me.Applikation.sSensitiveDatenBemerkung.Value
            Me.cbboxAdministriertdurch.SelectedValue = Me.Applikation.iSensitiveDatenAdministriertdurch.Value
            Me.TxtUeberwachung.Text = Me.Applikation.sSensitiveDatenUeberwachungBemerkung.Value
            Me.cbboxPeriodizitaet.SelectedValue = Me.Applikation.iSensitiveDatenUeberwachungPeriodizitaet.Value
            Me.TxtUser.Text = Me.Applikation.sSensitiveDatenUserBemerkung.Value
            Me.TxtAnzComit.Text = Me.Applikation.iSensitiveDatenAnzahlComit.Value
            Me.txtAnzExterne.Text = Me.Applikation.iSensitiveDatenAnzahlExterne.Value

            Try
                Me.cbAktiv.Checked = Applikation.bAktiv.Value = True

            Catch ex As Exception
                Me.cbAktiv.Checked = True
            End Try
            If Not Anzeige And Not Me.FormReadonly Then
                For Each o As Object In Me.ToolStrip1.Items
                    If o.GetType.Name = "ToolStripButton" Then
                        o.Enabled = True
                    End If
                Next
                'For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                '    Try
                '        ctl.Enabled = True
                '    Catch
                '    End Try
                'Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
        Catch ex As Exception
            Try
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = False
                Next
            Catch
            End Try
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplikation))
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSlblSuche = New System.Windows.Forms.ToolStripLabel
        Me.tstxtSuche = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TSBtnFilterAufheben = New System.Windows.Forms.ToolStripButton
        Me.TSBtnApplReport = New System.Windows.Forms.ToolStripButton
        Me.TSLabelArchitekturSuche = New System.Windows.Forms.ToolStripLabel
        Me.tstxtArchitektur = New System.Windows.Forms.ToolStripTextBox
        Me.ToolStripButton1 = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.TreeApplikationen = New System.Windows.Forms.TreeView
        Me.TreeApplikationenContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImgListApplikationTree = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlApplikationen = New System.Windows.Forms.Panel
        Me.cboxNurAktive = New System.Windows.Forms.CheckBox
        Me.Label1 = New System.Windows.Forms.Label
        Me.TabControlApplikation = New System.Windows.Forms.TabControl
        Me.TabBasisdaten = New System.Windows.Forms.TabPage
        Me.GroupBox3 = New System.Windows.Forms.GroupBox
        Me.txtKurzbeschreibung = New System.Windows.Forms.RichTextBox
        Me.GrpAllgemeineAngaben = New System.Windows.Forms.GroupBox
        Me.cbalsProdukt = New System.Windows.Forms.CheckBox
        Me.cbLizenzerfassung = New System.Windows.Forms.CheckBox
        Me.txtPrioWiederanlauf = New System.Windows.Forms.TextBox
        Me.lblPrioWiederanlauf = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtInaktivseit = New System.Windows.Forms.MaskedTextBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.lblInaktivseit = New System.Windows.Forms.Label
        Me.dtPickerInaktivSeit = New System.Windows.Forms.DateTimePicker
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.GrpTechnischeVerantwortung = New System.Windows.Forms.GroupBox
        Me.cbboxVerantwortung = New System.Windows.Forms.ComboBox
        Me.lblVerantwortung = New System.Windows.Forms.Label
        Me.cbboxTeam = New System.Windows.Forms.ComboBox
        Me.lblTeam = New System.Windows.Forms.Label
        Me.GrpFachlicheVerantwortung = New System.Windows.Forms.GroupBox
        Me.cbboxMarktbereich = New System.Windows.Forms.ComboBox
        Me.lblMarktbereich = New System.Windows.Forms.Label
        Me.cboxRFCBoard = New System.Windows.Forms.ComboBox
        Me.Label2 = New System.Windows.Forms.Label
        Me.GrpApplikation = New System.Windows.Forms.GroupBox
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblApplikation = New System.Windows.Forms.Label
        Me.lblParentElement = New System.Windows.Forms.Label
        Me.btnSearchAppl = New System.Windows.Forms.Button
        Me.cbboxKategorie = New System.Windows.Forms.ComboBox
        Me.lblKategorie = New System.Windows.Forms.Label
        Me.lblVersion = New System.Windows.Forms.Label
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.txtmutierer = New System.Windows.Forms.TextBox
        Me.txtmutiert_am = New System.Windows.Forms.TextBox
        Me.txterstellt_am = New System.Windows.Forms.TextBox
        Me.Label13 = New System.Windows.Forms.Label
        Me.Label12 = New System.Windows.Forms.Label
        Me.Label8 = New System.Windows.Forms.Label
        Me.TabArchitektur = New System.Windows.Forms.TabPage
        Me.DiagramControl1 = New DiagramControl.DiagramControl
        Me.TabWPI = New System.Windows.Forms.TabPage
        Me.grpboxInstallation = New System.Windows.Forms.GroupBox
        Me.grpboxInstalliertauf = New System.Windows.Forms.GroupBox
        Me.lboxInstalliertauf = New System.Windows.Forms.CheckedListBox
        Me.grpDiverses = New System.Windows.Forms.GroupBox
        Me.txtAnzInstallationen = New System.Windows.Forms.TextBox
        Me.lbAnzInstallationen = New System.Windows.Forms.Label
        Me.txtDBName = New System.Windows.Forms.TextBox
        Me.lblDBName = New System.Windows.Forms.Label
        Me.cbRAS = New System.Windows.Forms.CheckBox
        Me.grpboxInstalliertals = New System.Windows.Forms.GroupBox
        Me.lboxInstalliertals = New System.Windows.Forms.CheckedListBox
        Me.grpboxStandardfuer = New System.Windows.Forms.GroupBox
        Me.lboxStandardFuer = New System.Windows.Forms.CheckedListBox
        Me.TabLizenzen = New System.Windows.Forms.TabPage
        Me.SplitContainer2 = New System.Windows.Forms.SplitContainer
        Me.SplitContainer3 = New System.Windows.Forms.SplitContainer
        Me.GrpLizenzElemente = New System.Windows.Forms.GroupBox
        Me.C1Lizenzvertraege = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpLizenzkäufe = New System.Windows.Forms.GroupBox
        Me.C1Lizenzkäufe = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpLizenzschlüssel = New System.Windows.Forms.GroupBox
        Me.C1Lizenzschluessel = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabTesting = New System.Windows.Forms.TabPage
        Me.GroupBox13 = New System.Windows.Forms.GroupBox
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.GroupBox14 = New System.Windows.Forms.GroupBox
        Me.txtAbhaengigkeiten = New System.Windows.Forms.TextBox
        Me.cbboxTestaufwand = New System.Windows.Forms.ComboBox
        Me.Label14 = New System.Windows.Forms.Label
        Me.txtTestArbeitsplaetze = New System.Windows.Forms.TextBox
        Me.Label16 = New System.Windows.Forms.Label
        Me.Label15 = New System.Windows.Forms.Label
        Me.GroupBox15 = New System.Windows.Forms.GroupBox
        Me.GrpAbhaengigkeiten = New System.Windows.Forms.GroupBox
        Me.C1Abhaengigkeiten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.AbhaengigkeitMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.AbhaengigkeitAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AbhaengigkeitNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AbhaengigkeitLoeschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.Button3 = New System.Windows.Forms.Button
        Me.Button4 = New System.Windows.Forms.Button
        Me.grpDrehbuch = New System.Windows.Forms.GroupBox
        Me.C1Drehbuch = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DrehbuchMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DrehbuchAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DrehbuchNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DrehbuchLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripSeparator1 = New System.Windows.Forms.ToolStripSeparator
        Me.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.btnDrehbuchspeichern = New System.Windows.Forms.Button
        Me.btnDrehbuchanzeigen = New System.Windows.Forms.Button
        Me.TabKontakte = New System.Windows.Forms.TabPage
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KontakteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KontaktAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.MassenUpdatesToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabReleaseLogbuch = New System.Windows.Forms.TabPage
        Me.C1ReleaseLogbuch = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ReleaseLogbuchMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ReleaseLogbuchAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReleaseLogbuchNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReleaseLogbuchInaktivierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabVertragsbeziehungen = New System.Windows.Forms.TabPage
        Me.C1Vertragselemente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.VertragsbeziehungMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.VertragselementAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabDokumente = New System.Windows.Forms.TabPage
        Me.C1Dokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DokumenteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DokumentAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem2 = New System.Windows.Forms.ToolStripSeparator
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabTicketXPert = New System.Windows.Forms.TabPage
        Me.cbTicketXPertVerwendung = New System.Windows.Forms.CheckBox
        Me.grpTicketXpert = New System.Windows.Forms.GroupBox
        Me.cbboxSLM = New System.Windows.Forms.ComboBox
        Me.cbWPIAnzeigen = New System.Windows.Forms.CheckBox
        Me.cbboxKritikalität = New System.Windows.Forms.ComboBox
        Me.lblWPIAnzeigen = New System.Windows.Forms.Label
        Me.lblSLM = New System.Windows.Forms.Label
        Me.lblWPIPreis = New System.Windows.Forms.Label
        Me.lblKritikalität = New System.Windows.Forms.Label
        Me.txtWPIPreis = New System.Windows.Forms.TextBox
        Me.lblAMAnzeigen = New System.Windows.Forms.Label
        Me.lblPreisEinmalig = New System.Windows.Forms.Label
        Me.cbAMAnzeigen = New System.Windows.Forms.CheckBox
        Me.txtPreisEinmalig = New System.Windows.Forms.TextBox
        Me.TabRisiko = New System.Windows.Forms.TabPage
        Me.GrpUser = New System.Windows.Forms.GroupBox
        Me.txtAnzExterne = New System.Windows.Forms.TextBox
        Me.Label10 = New System.Windows.Forms.Label
        Me.TxtAnzComit = New System.Windows.Forms.TextBox
        Me.Label7 = New System.Windows.Forms.Label
        Me.Label9 = New System.Windows.Forms.Label
        Me.TxtUser = New System.Windows.Forms.TextBox
        Me.GrpUeberwachung = New System.Windows.Forms.GroupBox
        Me.cbboxPeriodizitaet = New System.Windows.Forms.ComboBox
        Me.Label6 = New System.Windows.Forms.Label
        Me.Label5 = New System.Windows.Forms.Label
        Me.TxtUeberwachung = New System.Windows.Forms.TextBox
        Me.GrpSensitiveDaten = New System.Windows.Forms.GroupBox
        Me.cbboxAdministriertdurch = New System.Windows.Forms.ComboBox
        Me.Label4 = New System.Windows.Forms.Label
        Me.Label3 = New System.Windows.Forms.Label
        Me.cbSensitiveDaten = New System.Windows.Forms.CheckBox
        Me.txtSensitiveDaten = New System.Windows.Forms.TextBox
        Me.TabPage11 = New System.Windows.Forms.TabPage
        Me.TabPage10 = New System.Windows.Forms.TabPage
        Me.TabPage9 = New System.Windows.Forms.TabPage
        Me.TabPage8 = New System.Windows.Forms.TabPage
        Me.GroupBox7 = New System.Windows.Forms.GroupBox
        Me.TextBox7 = New System.Windows.Forms.TextBox
        Me.Label23 = New System.Windows.Forms.Label
        Me.TextBox6 = New System.Windows.Forms.TextBox
        Me.Label24 = New System.Windows.Forms.Label
        Me.GroupBox8 = New System.Windows.Forms.GroupBox
        Me.TextBox11 = New System.Windows.Forms.TextBox
        Me.GroupBox6 = New System.Windows.Forms.GroupBox
        Me.Label22 = New System.Windows.Forms.Label
        Me.Button1 = New System.Windows.Forms.Button
        Me.Button2 = New System.Windows.Forms.Button
        Me.ComboBox9 = New System.Windows.Forms.ComboBox
        Me.TabPage5 = New System.Windows.Forms.TabPage
        Me.GroupBox5 = New System.Windows.Forms.GroupBox
        Me.C1TrueDBGrid2 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GroupBox4 = New System.Windows.Forms.GroupBox
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1TrueDBGrid3 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ImageListeDocIcon = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.cbboxParentTree = New Vertragsverwaltung.Controls.ComboBoxTree
        Me.ToolStrip1.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.TreeApplikationenContextMenuStrip.SuspendLayout()
        Me.pnlApplikationen.SuspendLayout()
        Me.TabControlApplikation.SuspendLayout()
        Me.TabBasisdaten.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GrpAllgemeineAngaben.SuspendLayout()
        Me.GrpTechnischeVerantwortung.SuspendLayout()
        Me.GrpFachlicheVerantwortung.SuspendLayout()
        Me.GrpApplikation.SuspendLayout()
        Me.TabArchitektur.SuspendLayout()
        Me.TabWPI.SuspendLayout()
        Me.grpboxInstallation.SuspendLayout()
        Me.grpboxInstalliertauf.SuspendLayout()
        Me.grpDiverses.SuspendLayout()
        Me.grpboxInstalliertals.SuspendLayout()
        Me.grpboxStandardfuer.SuspendLayout()
        Me.TabLizenzen.SuspendLayout()
        Me.SplitContainer2.Panel1.SuspendLayout()
        Me.SplitContainer2.Panel2.SuspendLayout()
        Me.SplitContainer2.SuspendLayout()
        Me.SplitContainer3.Panel1.SuspendLayout()
        Me.SplitContainer3.Panel2.SuspendLayout()
        Me.SplitContainer3.SuspendLayout()
        Me.GrpLizenzElemente.SuspendLayout()
        CType(Me.C1Lizenzvertraege, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpLizenzkäufe.SuspendLayout()
        CType(Me.C1Lizenzkäufe, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpLizenzschlüssel.SuspendLayout()
        CType(Me.C1Lizenzschluessel, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabTesting.SuspendLayout()
        Me.GroupBox13.SuspendLayout()
        Me.GroupBox14.SuspendLayout()
        Me.GroupBox15.SuspendLayout()
        Me.GrpAbhaengigkeiten.SuspendLayout()
        CType(Me.C1Abhaengigkeiten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.AbhaengigkeitMenuStrip.SuspendLayout()
        Me.grpDrehbuch.SuspendLayout()
        CType(Me.C1Drehbuch, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DrehbuchMenuStrip.SuspendLayout()
        Me.TabKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KontakteMenuStrip.SuspendLayout()
        Me.TabReleaseLogbuch.SuspendLayout()
        CType(Me.C1ReleaseLogbuch, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ReleaseLogbuchMenuStrip.SuspendLayout()
        Me.TabVertragsbeziehungen.SuspendLayout()
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.VertragsbeziehungMenuStrip.SuspendLayout()
        Me.TabDokumente.SuspendLayout()
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DokumenteMenuStrip.SuspendLayout()
        Me.TabTicketXPert.SuspendLayout()
        Me.grpTicketXpert.SuspendLayout()
        Me.TabRisiko.SuspendLayout()
        Me.GrpUser.SuspendLayout()
        Me.GrpUeberwachung.SuspendLayout()
        Me.GrpSensitiveDaten.SuspendLayout()
        Me.TabPage8.SuspendLayout()
        Me.GroupBox7.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.TabPage5.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSlblSuche, Me.tstxtSuche, Me.TSBtnSuche, Me.TSBtnFilterAufheben, Me.TSBtnApplReport, Me.TSLabelArchitekturSuche, Me.tstxtArchitektur, Me.ToolStripButton1})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(896, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSlblSuche
        '
        Me.TSlblSuche.Name = "TSlblSuche"
        Me.TSlblSuche.Size = New System.Drawing.Size(36, 22)
        Me.TSlblSuche.Text = "Filter:"
        '
        'tstxtSuche
        '
        Me.tstxtSuche.Name = "tstxtSuche"
        Me.tstxtSuche.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'TSBtnFilterAufheben
        '
        Me.TSBtnFilterAufheben.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnFilterAufheben.Image = CType(resources.GetObject("TSBtnFilterAufheben.Image"), System.Drawing.Image)
        Me.TSBtnFilterAufheben.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnFilterAufheben.Name = "TSBtnFilterAufheben"
        Me.TSBtnFilterAufheben.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnFilterAufheben.Text = "Filter aufheben"
        '
        'TSBtnApplReport
        '
        Me.TSBtnApplReport.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnApplReport.Image = CType(resources.GetObject("TSBtnApplReport.Image"), System.Drawing.Image)
        Me.TSBtnApplReport.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnApplReport.Name = "TSBtnApplReport"
        Me.TSBtnApplReport.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnApplReport.Text = "Applikationsreport"
        '
        'TSLabelArchitekturSuche
        '
        Me.TSLabelArchitekturSuche.Name = "TSLabelArchitekturSuche"
        Me.TSLabelArchitekturSuche.Size = New System.Drawing.Size(97, 22)
        Me.TSLabelArchitekturSuche.Text = "Architektursuche"
        '
        'tstxtArchitektur
        '
        Me.tstxtArchitektur.Name = "tstxtArchitektur"
        Me.tstxtArchitektur.Size = New System.Drawing.Size(100, 25)
        '
        'ToolStripButton1
        '
        Me.ToolStripButton1.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.ToolStripButton1.Image = CType(resources.GetObject("ToolStripButton1.Image"), System.Drawing.Image)
        Me.ToolStripButton1.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.ToolStripButton1.Name = "ToolStripButton1"
        Me.ToolStripButton1.Size = New System.Drawing.Size(23, 22)
        Me.ToolStripButton1.Text = "ToolStripButton1"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(896, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "Folder.ico")
        Me.ImageList1.Images.SetKeyName(1, "book02.gif")
        Me.ImageList1.Images.SetKeyName(2, "DOC.BMP")
        Me.ImageList1.Images.SetKeyName(3, "Lupe.png")
        Me.ImageList1.Images.SetKeyName(4, "neu.png")
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.TreeApplikationen)
        Me.SplitContainer1.Panel1.Controls.Add(Me.pnlApplikationen)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.TabControlApplikation)
        Me.SplitContainer1.Size = New System.Drawing.Size(896, 500)
        Me.SplitContainer1.SplitterDistance = 227
        Me.SplitContainer1.TabIndex = 2
        '
        'TreeApplikationen
        '
        Me.TreeApplikationen.ContextMenuStrip = Me.TreeApplikationenContextMenuStrip
        Me.TreeApplikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeApplikationen.FullRowSelect = True
        Me.TreeApplikationen.HideSelection = False
        Me.TreeApplikationen.ImageIndex = 0
        Me.TreeApplikationen.ImageList = Me.ImgListApplikationTree
        Me.TreeApplikationen.Location = New System.Drawing.Point(0, 24)
        Me.TreeApplikationen.Name = "TreeApplikationen"
        Me.TreeApplikationen.SelectedImageIndex = 0
        Me.TreeApplikationen.Size = New System.Drawing.Size(227, 476)
        Me.TreeApplikationen.TabIndex = 2
        '
        'TreeApplikationenContextMenuStrip
        '
        Me.TreeApplikationenContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem, Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem})
        Me.TreeApplikationenContextMenuStrip.Name = "TreeApplikationenContextMenuStrip"
        Me.TreeApplikationenContextMenuStrip.Size = New System.Drawing.Size(192, 48)
        '
        'TreeApplikationenAlleKnotenSchliessenToolStripMenuItem
        '
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Name = "TreeApplikationenAlleKnotenSchliessenToolStripMenuItem"
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Size = New System.Drawing.Size(191, 22)
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Text = "Alle Knoten schliessen"
        '
        'TreeApplikationenAlleKnotenÖffnenToolStripMenuItem
        '
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Name = "TreeApplikationenAlleKnotenÖffnenToolStripMenuItem"
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Size = New System.Drawing.Size(191, 22)
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Text = "Alle Knoten öffnen"
        '
        'ImgListApplikationTree
        '
        Me.ImgListApplikationTree.ImageStream = CType(resources.GetObject("ImgListApplikationTree.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListApplikationTree.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListApplikationTree.Images.SetKeyName(0, "45.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(1, "Run.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(2, "Run_Deleted.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(3, "RunLiz.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(4, "Run_DeletedLic.ico")
        '
        'pnlApplikationen
        '
        Me.pnlApplikationen.Controls.Add(Me.cboxNurAktive)
        Me.pnlApplikationen.Controls.Add(Me.Label1)
        Me.pnlApplikationen.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlApplikationen.Location = New System.Drawing.Point(0, 0)
        Me.pnlApplikationen.Name = "pnlApplikationen"
        Me.pnlApplikationen.Size = New System.Drawing.Size(227, 24)
        Me.pnlApplikationen.TabIndex = 1
        '
        'cboxNurAktive
        '
        Me.cboxNurAktive.AutoSize = True
        Me.cboxNurAktive.Checked = True
        Me.cboxNurAktive.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cboxNurAktive.Location = New System.Drawing.Point(148, 4)
        Me.cboxNurAktive.Name = "cboxNurAktive"
        Me.cboxNurAktive.Size = New System.Drawing.Size(74, 17)
        Me.cboxNurAktive.TabIndex = 1
        Me.cboxNurAktive.Text = "nur Aktive"
        Me.cboxNurAktive.UseVisualStyleBackColor = True
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(6, 4)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(71, 13)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Applikationen"
        '
        'TabControlApplikation
        '
        Me.TabControlApplikation.Controls.Add(Me.TabBasisdaten)
        Me.TabControlApplikation.Controls.Add(Me.TabArchitektur)
        Me.TabControlApplikation.Controls.Add(Me.TabWPI)
        Me.TabControlApplikation.Controls.Add(Me.TabKontakte)
        Me.TabControlApplikation.Controls.Add(Me.TabTesting)
        Me.TabControlApplikation.Controls.Add(Me.TabReleaseLogbuch)
        Me.TabControlApplikation.Controls.Add(Me.TabLizenzen)
        Me.TabControlApplikation.Controls.Add(Me.TabVertragsbeziehungen)
        Me.TabControlApplikation.Controls.Add(Me.TabDokumente)
        Me.TabControlApplikation.Controls.Add(Me.TabTicketXPert)
        Me.TabControlApplikation.Controls.Add(Me.TabRisiko)
        Me.TabControlApplikation.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControlApplikation.Location = New System.Drawing.Point(0, 0)
        Me.TabControlApplikation.Name = "TabControlApplikation"
        Me.TabControlApplikation.SelectedIndex = 0
        Me.TabControlApplikation.Size = New System.Drawing.Size(665, 500)
        Me.TabControlApplikation.TabIndex = 0
        '
        'TabBasisdaten
        '
        Me.TabBasisdaten.Controls.Add(Me.GroupBox3)
        Me.TabBasisdaten.Controls.Add(Me.GrpAllgemeineAngaben)
        Me.TabBasisdaten.Controls.Add(Me.GrpTechnischeVerantwortung)
        Me.TabBasisdaten.Controls.Add(Me.GrpFachlicheVerantwortung)
        Me.TabBasisdaten.Controls.Add(Me.GrpApplikation)
        Me.TabBasisdaten.Controls.Add(Me.txtmutierer)
        Me.TabBasisdaten.Controls.Add(Me.txtmutiert_am)
        Me.TabBasisdaten.Controls.Add(Me.txterstellt_am)
        Me.TabBasisdaten.Controls.Add(Me.Label13)
        Me.TabBasisdaten.Controls.Add(Me.Label12)
        Me.TabBasisdaten.Controls.Add(Me.Label8)
        Me.TabBasisdaten.Location = New System.Drawing.Point(4, 22)
        Me.TabBasisdaten.Name = "TabBasisdaten"
        Me.TabBasisdaten.Padding = New System.Windows.Forms.Padding(3)
        Me.TabBasisdaten.Size = New System.Drawing.Size(657, 474)
        Me.TabBasisdaten.TabIndex = 0
        Me.TabBasisdaten.Text = "Basisdaten"
        Me.TabBasisdaten.UseVisualStyleBackColor = True
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.Add(Me.txtKurzbeschreibung)
        Me.GroupBox3.Location = New System.Drawing.Point(12, 246)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(632, 190)
        Me.GroupBox3.TabIndex = 135
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Kurzbeschreibung"
        '
        'txtKurzbeschreibung
        '
        Me.txtKurzbeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtKurzbeschreibung.Location = New System.Drawing.Point(3, 16)
        Me.txtKurzbeschreibung.Name = "txtKurzbeschreibung"
        Me.txtKurzbeschreibung.Size = New System.Drawing.Size(626, 171)
        Me.txtKurzbeschreibung.TabIndex = 0
        Me.txtKurzbeschreibung.Text = ""
        '
        'GrpAllgemeineAngaben
        '
        Me.GrpAllgemeineAngaben.Controls.Add(Me.cbalsProdukt)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.cbLizenzerfassung)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.txtPrioWiederanlauf)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.lblPrioWiederanlauf)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.cboxSecurityLevel)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.lblAktiv)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.txtInaktivseit)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.lblSecurityLebel)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.lblInaktivseit)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.dtPickerInaktivSeit)
        Me.GrpAllgemeineAngaben.Controls.Add(Me.cbAktiv)
        Me.GrpAllgemeineAngaben.Location = New System.Drawing.Point(12, 171)
        Me.GrpAllgemeineAngaben.Name = "GrpAllgemeineAngaben"
        Me.GrpAllgemeineAngaben.Size = New System.Drawing.Size(632, 69)
        Me.GrpAllgemeineAngaben.TabIndex = 134
        Me.GrpAllgemeineAngaben.TabStop = False
        Me.GrpAllgemeineAngaben.Text = "Allgemeine Angaben"
        '
        'cbalsProdukt
        '
        Me.cbalsProdukt.Location = New System.Drawing.Point(12, 19)
        Me.cbalsProdukt.Name = "cbalsProdukt"
        Me.cbalsProdukt.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbalsProdukt.Size = New System.Drawing.Size(159, 18)
        Me.cbalsProdukt.TabIndex = 0
        Me.cbalsProdukt.Text = "Als Produkt berücksichtigen"
        Me.cbalsProdukt.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbalsProdukt.UseVisualStyleBackColor = True
        '
        'cbLizenzerfassung
        '
        Me.cbLizenzerfassung.Location = New System.Drawing.Point(12, 43)
        Me.cbLizenzerfassung.Name = "cbLizenzerfassung"
        Me.cbLizenzerfassung.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbLizenzerfassung.Size = New System.Drawing.Size(159, 18)
        Me.cbLizenzerfassung.TabIndex = 1
        Me.cbLizenzerfassung.Text = "Nur für Lizenzerfassung"
        Me.cbLizenzerfassung.TextAlign = System.Drawing.ContentAlignment.TopRight
        Me.cbLizenzerfassung.UseVisualStyleBackColor = True
        '
        'txtPrioWiederanlauf
        '
        Me.txtPrioWiederanlauf.Location = New System.Drawing.Point(287, 17)
        Me.txtPrioWiederanlauf.Name = "txtPrioWiederanlauf"
        Me.txtPrioWiederanlauf.Size = New System.Drawing.Size(84, 20)
        Me.txtPrioWiederanlauf.TabIndex = 2
        '
        'lblPrioWiederanlauf
        '
        Me.lblPrioWiederanlauf.AutoSize = True
        Me.lblPrioWiederanlauf.Location = New System.Drawing.Point(183, 21)
        Me.lblPrioWiederanlauf.Name = "lblPrioWiederanlauf"
        Me.lblPrioWiederanlauf.Size = New System.Drawing.Size(94, 13)
        Me.lblPrioWiederanlauf.TabIndex = 115
        Me.lblPrioWiederanlauf.Text = "Prio. Wiederanlauf"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(491, 16)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(129, 21)
        Me.cboxSecurityLevel.TabIndex = 4
        '
        'lblAktiv
        '
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(439, 47)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(109, 13)
        Me.lblAktiv.TabIndex = 5
        Me.lblAktiv.Text = "Aktiv (nur zu Testzw.)"
        Me.lblAktiv.Visible = False
        '
        'txtInaktivseit
        '
        Me.txtInaktivseit.Location = New System.Drawing.Point(287, 41)
        Me.txtInaktivseit.Mask = "00/00/0000"
        Me.txtInaktivseit.Name = "txtInaktivseit"
        Me.txtInaktivseit.Size = New System.Drawing.Size(66, 20)
        Me.txtInaktivseit.TabIndex = 3
        Me.txtInaktivseit.ValidatingType = GetType(Date)
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(398, 24)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 126
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'lblInaktivseit
        '
        Me.lblInaktivseit.AutoSize = True
        Me.lblInaktivseit.Location = New System.Drawing.Point(183, 44)
        Me.lblInaktivseit.Name = "lblInaktivseit"
        Me.lblInaktivseit.Size = New System.Drawing.Size(58, 13)
        Me.lblInaktivseit.TabIndex = 101
        Me.lblInaktivseit.Text = "Inaktiv seit"
        '
        'dtPickerInaktivSeit
        '
        Me.dtPickerInaktivSeit.Location = New System.Drawing.Point(350, 41)
        Me.dtPickerInaktivSeit.Name = "dtPickerInaktivSeit"
        Me.dtPickerInaktivSeit.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerInaktivSeit.TabIndex = 8
        Me.dtPickerInaktivSeit.TabStop = False
        '
        'cbAktiv
        '
        Me.cbAktiv.AutoSize = True
        Me.cbAktiv.Enabled = False
        Me.cbAktiv.Location = New System.Drawing.Point(576, 47)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbAktiv.TabIndex = 15
        Me.cbAktiv.UseVisualStyleBackColor = True
        Me.cbAktiv.Visible = False
        '
        'GrpTechnischeVerantwortung
        '
        Me.GrpTechnischeVerantwortung.Controls.Add(Me.cbboxVerantwortung)
        Me.GrpTechnischeVerantwortung.Controls.Add(Me.lblVerantwortung)
        Me.GrpTechnischeVerantwortung.Controls.Add(Me.cbboxTeam)
        Me.GrpTechnischeVerantwortung.Controls.Add(Me.lblTeam)
        Me.GrpTechnischeVerantwortung.Location = New System.Drawing.Point(314, 92)
        Me.GrpTechnischeVerantwortung.Name = "GrpTechnischeVerantwortung"
        Me.GrpTechnischeVerantwortung.Size = New System.Drawing.Size(330, 76)
        Me.GrpTechnischeVerantwortung.TabIndex = 133
        Me.GrpTechnischeVerantwortung.TabStop = False
        Me.GrpTechnischeVerantwortung.Text = "Technische Verantwortung"
        '
        'cbboxVerantwortung
        '
        Me.cbboxVerantwortung.FormattingEnabled = True
        Me.cbboxVerantwortung.Location = New System.Drawing.Point(121, 19)
        Me.cbboxVerantwortung.Name = "cbboxVerantwortung"
        Me.cbboxVerantwortung.Size = New System.Drawing.Size(203, 21)
        Me.cbboxVerantwortung.TabIndex = 0
        '
        'lblVerantwortung
        '
        Me.lblVerantwortung.AutoSize = True
        Me.lblVerantwortung.Location = New System.Drawing.Point(7, 22)
        Me.lblVerantwortung.Name = "lblVerantwortung"
        Me.lblVerantwortung.Size = New System.Drawing.Size(102, 13)
        Me.lblVerantwortung.TabIndex = 91
        Me.lblVerantwortung.Text = "Organisationseinheit"
        '
        'cbboxTeam
        '
        Me.cbboxTeam.FormattingEnabled = True
        Me.cbboxTeam.Location = New System.Drawing.Point(120, 46)
        Me.cbboxTeam.Name = "cbboxTeam"
        Me.cbboxTeam.Size = New System.Drawing.Size(204, 21)
        Me.cbboxTeam.TabIndex = 1
        '
        'lblTeam
        '
        Me.lblTeam.AutoSize = True
        Me.lblTeam.Location = New System.Drawing.Point(7, 46)
        Me.lblTeam.Name = "lblTeam"
        Me.lblTeam.Size = New System.Drawing.Size(34, 13)
        Me.lblTeam.TabIndex = 130
        Me.lblTeam.Text = "Team"
        '
        'GrpFachlicheVerantwortung
        '
        Me.GrpFachlicheVerantwortung.Controls.Add(Me.cbboxMarktbereich)
        Me.GrpFachlicheVerantwortung.Controls.Add(Me.lblMarktbereich)
        Me.GrpFachlicheVerantwortung.Controls.Add(Me.cboxRFCBoard)
        Me.GrpFachlicheVerantwortung.Controls.Add(Me.Label2)
        Me.GrpFachlicheVerantwortung.Location = New System.Drawing.Point(14, 92)
        Me.GrpFachlicheVerantwortung.Name = "GrpFachlicheVerantwortung"
        Me.GrpFachlicheVerantwortung.Size = New System.Drawing.Size(294, 76)
        Me.GrpFachlicheVerantwortung.TabIndex = 132
        Me.GrpFachlicheVerantwortung.TabStop = False
        Me.GrpFachlicheVerantwortung.Text = "Fachliche Verantwortung"
        '
        'cbboxMarktbereich
        '
        Me.cbboxMarktbereich.FormattingEnabled = True
        Me.cbboxMarktbereich.Location = New System.Drawing.Point(140, 19)
        Me.cbboxMarktbereich.Name = "cbboxMarktbereich"
        Me.cbboxMarktbereich.Size = New System.Drawing.Size(148, 21)
        Me.cbboxMarktbereich.TabIndex = 0
        '
        'lblMarktbereich
        '
        Me.lblMarktbereich.AutoSize = True
        Me.lblMarktbereich.Location = New System.Drawing.Point(3, 22)
        Me.lblMarktbereich.Name = "lblMarktbereich"
        Me.lblMarktbereich.Size = New System.Drawing.Size(72, 13)
        Me.lblMarktbereich.TabIndex = 96
        Me.lblMarktbereich.Text = " Marktbereich"
        '
        'cboxRFCBoard
        '
        Me.cboxRFCBoard.FormattingEnabled = True
        Me.cboxRFCBoard.Location = New System.Drawing.Point(140, 46)
        Me.cboxRFCBoard.Name = "cboxRFCBoard"
        Me.cboxRFCBoard.Size = New System.Drawing.Size(148, 21)
        Me.cboxRFCBoard.TabIndex = 1
        '
        'Label2
        '
        Me.Label2.AutoSize = True
        Me.Label2.Location = New System.Drawing.Point(7, 49)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(59, 13)
        Me.Label2.TabIndex = 128
        Me.Label2.Text = "RFC-Board"
        '
        'GrpApplikation
        '
        Me.GrpApplikation.Controls.Add(Me.cbboxParentTree)
        Me.GrpApplikation.Controls.Add(Me.txtBezeichnung)
        Me.GrpApplikation.Controls.Add(Me.lblApplikation)
        Me.GrpApplikation.Controls.Add(Me.lblParentElement)
        Me.GrpApplikation.Controls.Add(Me.btnSearchAppl)
        Me.GrpApplikation.Controls.Add(Me.cbboxKategorie)
        Me.GrpApplikation.Controls.Add(Me.lblKategorie)
        Me.GrpApplikation.Controls.Add(Me.lblVersion)
        Me.GrpApplikation.Controls.Add(Me.txtVersion)
        Me.GrpApplikation.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.GrpApplikation.Location = New System.Drawing.Point(14, 10)
        Me.GrpApplikation.Name = "GrpApplikation"
        Me.GrpApplikation.Size = New System.Drawing.Size(630, 81)
        Me.GrpApplikation.TabIndex = 131
        Me.GrpApplikation.TabStop = False
        Me.GrpApplikation.Text = "Applikation / Modul"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(140, 19)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(204, 20)
        Me.txtBezeichnung.TabIndex = 0
        '
        'lblApplikation
        '
        Me.lblApplikation.AutoSize = True
        Me.lblApplikation.Location = New System.Drawing.Point(7, 22)
        Me.lblApplikation.Name = "lblApplikation"
        Me.lblApplikation.Size = New System.Drawing.Size(69, 13)
        Me.lblApplikation.TabIndex = 78
        Me.lblApplikation.Text = "Bezeichnung"
        '
        'lblParentElement
        '
        Me.lblParentElement.AutoSize = True
        Me.lblParentElement.Location = New System.Drawing.Point(7, 49)
        Me.lblParentElement.Name = "lblParentElement"
        Me.lblParentElement.Size = New System.Drawing.Size(133, 13)
        Me.lblParentElement.TabIndex = 93
        Me.lblParentElement.Text = "Übergeordnete Applikation"
        '
        'btnSearchAppl
        '
        Me.btnSearchAppl.Image = CType(resources.GetObject("btnSearchAppl.Image"), System.Drawing.Image)
        Me.btnSearchAppl.Location = New System.Drawing.Point(324, 45)
        Me.btnSearchAppl.Name = "btnSearchAppl"
        Me.btnSearchAppl.Size = New System.Drawing.Size(20, 20)
        Me.btnSearchAppl.TabIndex = 3
        Me.btnSearchAppl.TabStop = False
        Me.btnSearchAppl.Text = "Button1"
        Me.btnSearchAppl.UseVisualStyleBackColor = True
        '
        'cbboxKategorie
        '
        Me.cbboxKategorie.FormattingEnabled = True
        Me.cbboxKategorie.Location = New System.Drawing.Point(420, 18)
        Me.cbboxKategorie.Name = "cbboxKategorie"
        Me.cbboxKategorie.Size = New System.Drawing.Size(204, 21)
        Me.cbboxKategorie.TabIndex = 2
        '
        'lblKategorie
        '
        Me.lblKategorie.AutoSize = True
        Me.lblKategorie.Location = New System.Drawing.Point(362, 21)
        Me.lblKategorie.Name = "lblKategorie"
        Me.lblKategorie.Size = New System.Drawing.Size(52, 13)
        Me.lblKategorie.TabIndex = 94
        Me.lblKategorie.Text = "Kategorie"
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(362, 49)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(42, 13)
        Me.lblVersion.TabIndex = 8
        Me.lblVersion.Text = "Version"
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(420, 42)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(129, 20)
        Me.txtVersion.TabIndex = 3
        '
        'txtmutierer
        '
        Me.txtmutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtmutierer.Location = New System.Drawing.Point(392, 442)
        Me.txtmutierer.Name = "txtmutierer"
        Me.txtmutierer.ReadOnly = True
        Me.txtmutierer.Size = New System.Drawing.Size(89, 20)
        Me.txtmutierer.TabIndex = 18
        Me.txtmutierer.TabStop = False
        '
        'txtmutiert_am
        '
        Me.txtmutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtmutiert_am.Location = New System.Drawing.Point(229, 442)
        Me.txtmutiert_am.Name = "txtmutiert_am"
        Me.txtmutiert_am.ReadOnly = True
        Me.txtmutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtmutiert_am.TabIndex = 16
        Me.txtmutiert_am.TabStop = False
        '
        'txterstellt_am
        '
        Me.txterstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txterstellt_am.Location = New System.Drawing.Point(79, 442)
        Me.txterstellt_am.Name = "txterstellt_am"
        Me.txterstellt_am.ReadOnly = True
        Me.txterstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txterstellt_am.TabIndex = 14
        Me.txterstellt_am.TabStop = False
        '
        'Label13
        '
        Me.Label13.AccessibleDescription = "Name"
        Me.Label13.AutoSize = True
        Me.Label13.Location = New System.Drawing.Point(314, 445)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(72, 13)
        Me.Label13.TabIndex = 17
        Me.Label13.Text = "Mutiert durch:"
        '
        'Label12
        '
        Me.Label12.AccessibleDescription = "Name"
        Me.Label12.AutoSize = True
        Me.Label12.Location = New System.Drawing.Point(164, 445)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(59, 13)
        Me.Label12.TabIndex = 15
        Me.Label12.Text = "Mutiert am:"
        '
        'Label8
        '
        Me.Label8.AccessibleDescription = "Name"
        Me.Label8.AutoSize = True
        Me.Label8.Location = New System.Drawing.Point(11, 445)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(58, 13)
        Me.Label8.TabIndex = 82
        Me.Label8.Text = "Erstellt am:"
        '
        'TabArchitektur
        '
        Me.TabArchitektur.Controls.Add(Me.DiagramControl1)
        Me.TabArchitektur.Location = New System.Drawing.Point(4, 22)
        Me.TabArchitektur.Name = "TabArchitektur"
        Me.TabArchitektur.Size = New System.Drawing.Size(657, 474)
        Me.TabArchitektur.TabIndex = 10
        Me.TabArchitektur.Text = "Architektur"
        Me.TabArchitektur.UseVisualStyleBackColor = True
        '
        'DiagramControl1
        '
        Me.DiagramControl1.Applicationdb = Nothing
        Me.DiagramControl1.ApplikationNr = 0
        Me.DiagramControl1.ConnectionString = Nothing
        Me.DiagramControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DiagramControl1.FormReadOnly = False
        Me.DiagramControl1.Location = New System.Drawing.Point(0, 0)
        Me.DiagramControl1.Mitarbeiternr = 0
        Me.DiagramControl1.Name = "DiagramControl1"
        Me.DiagramControl1.Size = New System.Drawing.Size(657, 474)
        Me.DiagramControl1.TabIndex = 0
        Me.DiagramControl1.TempFilePath = Nothing
        '
        'TabWPI
        '
        Me.TabWPI.Controls.Add(Me.grpboxInstallation)
        Me.TabWPI.Location = New System.Drawing.Point(4, 22)
        Me.TabWPI.Name = "TabWPI"
        Me.TabWPI.Size = New System.Drawing.Size(657, 474)
        Me.TabWPI.TabIndex = 9
        Me.TabWPI.Text = "WPI"
        Me.TabWPI.UseVisualStyleBackColor = True
        '
        'grpboxInstallation
        '
        Me.grpboxInstallation.Controls.Add(Me.grpboxInstalliertauf)
        Me.grpboxInstallation.Controls.Add(Me.grpDiverses)
        Me.grpboxInstallation.Controls.Add(Me.grpboxInstalliertals)
        Me.grpboxInstallation.Controls.Add(Me.grpboxStandardfuer)
        Me.grpboxInstallation.Location = New System.Drawing.Point(16, 3)
        Me.grpboxInstallation.Name = "grpboxInstallation"
        Me.grpboxInstallation.Size = New System.Drawing.Size(633, 191)
        Me.grpboxInstallation.TabIndex = 15
        Me.grpboxInstallation.TabStop = False
        Me.grpboxInstallation.Text = "Installation"
        '
        'grpboxInstalliertauf
        '
        Me.grpboxInstalliertauf.Controls.Add(Me.lboxInstalliertauf)
        Me.grpboxInstalliertauf.Location = New System.Drawing.Point(6, 19)
        Me.grpboxInstalliertauf.Name = "grpboxInstalliertauf"
        Me.grpboxInstalliertauf.Size = New System.Drawing.Size(131, 162)
        Me.grpboxInstalliertauf.TabIndex = 0
        Me.grpboxInstalliertauf.TabStop = False
        Me.grpboxInstalliertauf.Text = "Installiert auf"
        '
        'lboxInstalliertauf
        '
        Me.lboxInstalliertauf.CheckOnClick = True
        Me.lboxInstalliertauf.Dock = System.Windows.Forms.DockStyle.Fill
        Me.lboxInstalliertauf.FormattingEnabled = True
        Me.lboxInstalliertauf.Location = New System.Drawing.Point(3, 16)
        Me.lboxInstalliertauf.Name = "lboxInstalliertauf"
        Me.lboxInstalliertauf.Size = New System.Drawing.Size(125, 139)
        Me.lboxInstalliertauf.TabIndex = 0
        '
        'grpDiverses
        '
        Me.grpDiverses.Controls.Add(Me.txtAnzInstallationen)
        Me.grpDiverses.Controls.Add(Me.lbAnzInstallationen)
        Me.grpDiverses.Controls.Add(Me.txtDBName)
        Me.grpDiverses.Controls.Add(Me.lblDBName)
        Me.grpDiverses.Controls.Add(Me.cbRAS)
        Me.grpDiverses.Location = New System.Drawing.Point(416, 19)
        Me.grpDiverses.Name = "grpDiverses"
        Me.grpDiverses.Size = New System.Drawing.Size(211, 162)
        Me.grpDiverses.TabIndex = 3
        Me.grpDiverses.TabStop = False
        Me.grpDiverses.Text = "Diverses"
        '
        'txtAnzInstallationen
        '
        Me.txtAnzInstallationen.Location = New System.Drawing.Point(106, 65)
        Me.txtAnzInstallationen.Name = "txtAnzInstallationen"
        Me.txtAnzInstallationen.Size = New System.Drawing.Size(99, 20)
        Me.txtAnzInstallationen.TabIndex = 2
        '
        'lbAnzInstallationen
        '
        Me.lbAnzInstallationen.AutoSize = True
        Me.lbAnzInstallationen.Location = New System.Drawing.Point(8, 68)
        Me.lbAnzInstallationen.Name = "lbAnzInstallationen"
        Me.lbAnzInstallationen.Size = New System.Drawing.Size(93, 13)
        Me.lbAnzInstallationen.TabIndex = 112
        Me.lbAnzInstallationen.Text = "Anz. Installationen"
        '
        'txtDBName
        '
        Me.txtDBName.Location = New System.Drawing.Point(106, 39)
        Me.txtDBName.Name = "txtDBName"
        Me.txtDBName.Size = New System.Drawing.Size(99, 20)
        Me.txtDBName.TabIndex = 1
        '
        'lblDBName
        '
        Me.lblDBName.AutoSize = True
        Me.lblDBName.Location = New System.Drawing.Point(8, 42)
        Me.lblDBName.Name = "lblDBName"
        Me.lblDBName.Size = New System.Drawing.Size(86, 13)
        Me.lblDBName.TabIndex = 110
        Me.lblDBName.Text = "Datenbankname"
        '
        'cbRAS
        '
        Me.cbRAS.Location = New System.Drawing.Point(8, 19)
        Me.cbRAS.Name = "cbRAS"
        Me.cbRAS.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbRAS.Size = New System.Drawing.Size(113, 18)
        Me.cbRAS.TabIndex = 0
        Me.cbRAS.Text = "RAS"
        Me.cbRAS.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbRAS.UseVisualStyleBackColor = True
        '
        'grpboxInstalliertals
        '
        Me.grpboxInstalliertals.Controls.Add(Me.lboxInstalliertals)
        Me.grpboxInstalliertals.Location = New System.Drawing.Point(140, 19)
        Me.grpboxInstalliertals.Name = "grpboxInstalliertals"
        Me.grpboxInstalliertals.Size = New System.Drawing.Size(131, 162)
        Me.grpboxInstalliertals.TabIndex = 1
        Me.grpboxInstalliertals.TabStop = False
        Me.grpboxInstalliertals.Text = "Installiert als"
        '
        'lboxInstalliertals
        '
        Me.lboxInstalliertals.CheckOnClick = True
        Me.lboxInstalliertals.Dock = System.Windows.Forms.DockStyle.Fill
        Me.lboxInstalliertals.FormattingEnabled = True
        Me.lboxInstalliertals.Location = New System.Drawing.Point(3, 16)
        Me.lboxInstalliertals.Name = "lboxInstalliertals"
        Me.lboxInstalliertals.Size = New System.Drawing.Size(125, 139)
        Me.lboxInstalliertals.TabIndex = 0
        '
        'grpboxStandardfuer
        '
        Me.grpboxStandardfuer.Controls.Add(Me.lboxStandardFuer)
        Me.grpboxStandardfuer.Location = New System.Drawing.Point(277, 19)
        Me.grpboxStandardfuer.Name = "grpboxStandardfuer"
        Me.grpboxStandardfuer.Size = New System.Drawing.Size(128, 162)
        Me.grpboxStandardfuer.TabIndex = 2
        Me.grpboxStandardfuer.TabStop = False
        Me.grpboxStandardfuer.Text = "Standard für"
        '
        'lboxStandardFuer
        '
        Me.lboxStandardFuer.CheckOnClick = True
        Me.lboxStandardFuer.Dock = System.Windows.Forms.DockStyle.Fill
        Me.lboxStandardFuer.FormattingEnabled = True
        Me.lboxStandardFuer.Location = New System.Drawing.Point(3, 16)
        Me.lboxStandardFuer.Name = "lboxStandardFuer"
        Me.lboxStandardFuer.Size = New System.Drawing.Size(122, 139)
        Me.lboxStandardFuer.TabIndex = 0
        '
        'TabLizenzen
        '
        Me.TabLizenzen.Controls.Add(Me.SplitContainer2)
        Me.TabLizenzen.Location = New System.Drawing.Point(4, 22)
        Me.TabLizenzen.Name = "TabLizenzen"
        Me.TabLizenzen.Size = New System.Drawing.Size(657, 474)
        Me.TabLizenzen.TabIndex = 2
        Me.TabLizenzen.Text = "Lizenzen"
        Me.TabLizenzen.UseVisualStyleBackColor = True
        '
        'SplitContainer2
        '
        Me.SplitContainer2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer2.Location = New System.Drawing.Point(0, 0)
        Me.SplitContainer2.Name = "SplitContainer2"
        Me.SplitContainer2.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer2.Panel1
        '
        Me.SplitContainer2.Panel1.Controls.Add(Me.SplitContainer3)
        '
        'SplitContainer2.Panel2
        '
        Me.SplitContainer2.Panel2.Controls.Add(Me.GrpLizenzschlüssel)
        Me.SplitContainer2.Size = New System.Drawing.Size(657, 474)
        Me.SplitContainer2.SplitterDistance = 300
        Me.SplitContainer2.TabIndex = 0
        '
        'SplitContainer3
        '
        Me.SplitContainer3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer3.Location = New System.Drawing.Point(0, 0)
        Me.SplitContainer3.Name = "SplitContainer3"
        Me.SplitContainer3.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer3.Panel1
        '
        Me.SplitContainer3.Panel1.Controls.Add(Me.GrpLizenzElemente)
        '
        'SplitContainer3.Panel2
        '
        Me.SplitContainer3.Panel2.Controls.Add(Me.GrpLizenzkäufe)
        Me.SplitContainer3.Size = New System.Drawing.Size(657, 300)
        Me.SplitContainer3.SplitterDistance = 135
        Me.SplitContainer3.TabIndex = 0
        '
        'GrpLizenzElemente
        '
        Me.GrpLizenzElemente.Controls.Add(Me.C1Lizenzvertraege)
        Me.GrpLizenzElemente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpLizenzElemente.Location = New System.Drawing.Point(0, 0)
        Me.GrpLizenzElemente.Name = "GrpLizenzElemente"
        Me.GrpLizenzElemente.Size = New System.Drawing.Size(657, 135)
        Me.GrpLizenzElemente.TabIndex = 6
        Me.GrpLizenzElemente.TabStop = False
        Me.GrpLizenzElemente.Text = "Lizenzverträge"
        '
        'C1Lizenzvertraege
        '
        Me.C1Lizenzvertraege.AlternatingRows = True
        Me.C1Lizenzvertraege.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Lizenzvertraege.FetchRowStyles = True
        Me.C1Lizenzvertraege.FilterBar = True
        Me.C1Lizenzvertraege.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Lizenzvertraege.Images.Add(CType(resources.GetObject("C1Lizenzvertraege.Images"), System.Drawing.Image))
        Me.C1Lizenzvertraege.Location = New System.Drawing.Point(3, 16)
        Me.C1Lizenzvertraege.Name = "C1Lizenzvertraege"
        Me.C1Lizenzvertraege.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Lizenzvertraege.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Lizenzvertraege.PreviewInfo.ZoomFactor = 75
        Me.C1Lizenzvertraege.PrintInfo.PageSettings = CType(resources.GetObject("C1Lizenzvertraege.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Lizenzvertraege.Size = New System.Drawing.Size(651, 116)
        Me.C1Lizenzvertraege.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Lizenzvertraege.TabIndex = 11
        Me.C1Lizenzvertraege.Text = "C1TrueDBGrid1"
        Me.C1Lizenzvertraege.PropBag = resources.GetString("C1Lizenzvertraege.PropBag")
        '
        'GrpLizenzkäufe
        '
        Me.GrpLizenzkäufe.Controls.Add(Me.C1Lizenzkäufe)
        Me.GrpLizenzkäufe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpLizenzkäufe.Location = New System.Drawing.Point(0, 0)
        Me.GrpLizenzkäufe.Name = "GrpLizenzkäufe"
        Me.GrpLizenzkäufe.Size = New System.Drawing.Size(657, 161)
        Me.GrpLizenzkäufe.TabIndex = 5
        Me.GrpLizenzkäufe.TabStop = False
        Me.GrpLizenzkäufe.Text = "Lizenzen"
        '
        'C1Lizenzkäufe
        '
        Me.C1Lizenzkäufe.AlternatingRows = True
        Me.C1Lizenzkäufe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Lizenzkäufe.FetchRowStyles = True
        Me.C1Lizenzkäufe.FilterBar = True
        Me.C1Lizenzkäufe.GroupByCaption = "Um eine Gruppierung herzustellen, den Spaltentitel in den Gruppierungsbereich zie" & _
            "hen"
        Me.C1Lizenzkäufe.Images.Add(CType(resources.GetObject("C1Lizenzkäufe.Images"), System.Drawing.Image))
        Me.C1Lizenzkäufe.Location = New System.Drawing.Point(3, 16)
        Me.C1Lizenzkäufe.Name = "C1Lizenzkäufe"
        Me.C1Lizenzkäufe.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Lizenzkäufe.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Lizenzkäufe.PreviewInfo.ZoomFactor = 75
        Me.C1Lizenzkäufe.PrintInfo.PageSettings = CType(resources.GetObject("C1Lizenzkäufe.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Lizenzkäufe.Size = New System.Drawing.Size(651, 142)
        Me.C1Lizenzkäufe.TabIndex = 4
        Me.C1Lizenzkäufe.Text = "C1TrueDBGrid1"
        Me.C1Lizenzkäufe.PropBag = resources.GetString("C1Lizenzkäufe.PropBag")
        '
        'GrpLizenzschlüssel
        '
        Me.GrpLizenzschlüssel.Controls.Add(Me.C1Lizenzschluessel)
        Me.GrpLizenzschlüssel.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpLizenzschlüssel.Location = New System.Drawing.Point(0, 0)
        Me.GrpLizenzschlüssel.Name = "GrpLizenzschlüssel"
        Me.GrpLizenzschlüssel.Size = New System.Drawing.Size(657, 170)
        Me.GrpLizenzschlüssel.TabIndex = 6
        Me.GrpLizenzschlüssel.TabStop = False
        Me.GrpLizenzschlüssel.Text = "Lizenzschlüssel"
        '
        'C1Lizenzschluessel
        '
        Me.C1Lizenzschluessel.AlternatingRows = True
        Me.C1Lizenzschluessel.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Lizenzschluessel.FetchRowStyles = True
        Me.C1Lizenzschluessel.FilterBar = True
        Me.C1Lizenzschluessel.GroupByCaption = "Um eine Gruppierung herzustellen, den Spaltentitel in den Gruppierungsbereich zie" & _
            "hen"
        Me.C1Lizenzschluessel.Images.Add(CType(resources.GetObject("C1Lizenzschluessel.Images"), System.Drawing.Image))
        Me.C1Lizenzschluessel.Location = New System.Drawing.Point(3, 16)
        Me.C1Lizenzschluessel.Name = "C1Lizenzschluessel"
        Me.C1Lizenzschluessel.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Lizenzschluessel.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Lizenzschluessel.PreviewInfo.ZoomFactor = 75
        Me.C1Lizenzschluessel.PrintInfo.PageSettings = CType(resources.GetObject("C1Lizenzschluessel.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Lizenzschluessel.Size = New System.Drawing.Size(651, 151)
        Me.C1Lizenzschluessel.TabIndex = 4
        Me.C1Lizenzschluessel.Text = "C1TrueDBGrid1"
        Me.C1Lizenzschluessel.PropBag = resources.GetString("C1Lizenzschluessel.PropBag")
        '
        'TabTesting
        '
        Me.TabTesting.Controls.Add(Me.GroupBox13)
        Me.TabTesting.Controls.Add(Me.GroupBox14)
        Me.TabTesting.Controls.Add(Me.GroupBox15)
        Me.TabTesting.Location = New System.Drawing.Point(4, 22)
        Me.TabTesting.Name = "TabTesting"
        Me.TabTesting.Size = New System.Drawing.Size(657, 474)
        Me.TabTesting.TabIndex = 3
        Me.TabTesting.Text = "Testing"
        Me.TabTesting.UseVisualStyleBackColor = True
        '
        'GroupBox13
        '
        Me.GroupBox13.Controls.Add(Me.txtBemerkung)
        Me.GroupBox13.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox13.Location = New System.Drawing.Point(0, 249)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(657, 225)
        Me.GroupBox13.TabIndex = 2
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Bemerkungen"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtBemerkung.Location = New System.Drawing.Point(3, 16)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(651, 206)
        Me.txtBemerkung.TabIndex = 0
        '
        'GroupBox14
        '
        Me.GroupBox14.Controls.Add(Me.txtAbhaengigkeiten)
        Me.GroupBox14.Controls.Add(Me.cbboxTestaufwand)
        Me.GroupBox14.Controls.Add(Me.Label14)
        Me.GroupBox14.Controls.Add(Me.txtTestArbeitsplaetze)
        Me.GroupBox14.Controls.Add(Me.Label16)
        Me.GroupBox14.Controls.Add(Me.Label15)
        Me.GroupBox14.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox14.Location = New System.Drawing.Point(0, 164)
        Me.GroupBox14.Name = "GroupBox14"
        Me.GroupBox14.Size = New System.Drawing.Size(657, 85)
        Me.GroupBox14.TabIndex = 1
        Me.GroupBox14.TabStop = False
        Me.GroupBox14.Text = "Test-Infrastruktur "
        '
        'txtAbhaengigkeiten
        '
        Me.txtAbhaengigkeiten.Location = New System.Drawing.Point(557, 19)
        Me.txtAbhaengigkeiten.Multiline = True
        Me.txtAbhaengigkeiten.Name = "txtAbhaengigkeiten"
        Me.txtAbhaengigkeiten.Size = New System.Drawing.Size(78, 60)
        Me.txtAbhaengigkeiten.TabIndex = 1
        Me.txtAbhaengigkeiten.Visible = False
        '
        'cbboxTestaufwand
        '
        Me.cbboxTestaufwand.FormattingEnabled = True
        Me.cbboxTestaufwand.Location = New System.Drawing.Point(545, 19)
        Me.cbboxTestaufwand.Name = "cbboxTestaufwand"
        Me.cbboxTestaufwand.Size = New System.Drawing.Size(110, 21)
        Me.cbboxTestaufwand.TabIndex = 0
        '
        'Label14
        '
        Me.Label14.AutoSize = True
        Me.Label14.Location = New System.Drawing.Point(485, 51)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(81, 13)
        Me.Label14.TabIndex = 97
        Me.Label14.Text = "Abhängigkeiten"
        Me.Label14.Visible = False
        '
        'txtTestArbeitsplaetze
        '
        Me.txtTestArbeitsplaetze.Location = New System.Drawing.Point(141, 19)
        Me.txtTestArbeitsplaetze.Multiline = True
        Me.txtTestArbeitsplaetze.Name = "txtTestArbeitsplaetze"
        Me.txtTestArbeitsplaetze.Size = New System.Drawing.Size(286, 60)
        Me.txtTestArbeitsplaetze.TabIndex = 0
        '
        'Label16
        '
        Me.Label16.AutoSize = True
        Me.Label16.Location = New System.Drawing.Point(433, 22)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(106, 13)
        Me.Label16.TabIndex = 97
        Me.Label16.Text = "Test-Aufwand in Std."
        '
        'Label15
        '
        Me.Label15.AutoSize = True
        Me.Label15.Location = New System.Drawing.Point(8, 22)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(91, 13)
        Me.Label15.TabIndex = 95
        Me.Label15.Text = "Test-Arbeitsplätze"
        '
        'GroupBox15
        '
        Me.GroupBox15.Controls.Add(Me.GrpAbhaengigkeiten)
        Me.GroupBox15.Controls.Add(Me.grpDrehbuch)
        Me.GroupBox15.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox15.Location = New System.Drawing.Point(0, 0)
        Me.GroupBox15.Name = "GroupBox15"
        Me.GroupBox15.Size = New System.Drawing.Size(657, 164)
        Me.GroupBox15.TabIndex = 0
        Me.GroupBox15.TabStop = False
        Me.GroupBox15.Text = "Allgemein"
        '
        'GrpAbhaengigkeiten
        '
        Me.GrpAbhaengigkeiten.Controls.Add(Me.C1Abhaengigkeiten)
        Me.GrpAbhaengigkeiten.Controls.Add(Me.Button3)
        Me.GrpAbhaengigkeiten.Controls.Add(Me.Button4)
        Me.GrpAbhaengigkeiten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpAbhaengigkeiten.Location = New System.Drawing.Point(274, 16)
        Me.GrpAbhaengigkeiten.Name = "GrpAbhaengigkeiten"
        Me.GrpAbhaengigkeiten.Size = New System.Drawing.Size(380, 145)
        Me.GrpAbhaengigkeiten.TabIndex = 99
        Me.GrpAbhaengigkeiten.TabStop = False
        Me.GrpAbhaengigkeiten.Text = "Abhängigkeiten"
        '
        'C1Abhaengigkeiten
        '
        Me.C1Abhaengigkeiten.AlternatingRows = True
        Me.C1Abhaengigkeiten.ContextMenuStrip = Me.AbhaengigkeitMenuStrip
        Me.C1Abhaengigkeiten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Abhaengigkeiten.FetchRowStyles = True
        Me.C1Abhaengigkeiten.FilterBar = True
        Me.C1Abhaengigkeiten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Abhaengigkeiten.Images.Add(CType(resources.GetObject("C1Abhaengigkeiten.Images"), System.Drawing.Image))
        Me.C1Abhaengigkeiten.Location = New System.Drawing.Point(3, 16)
        Me.C1Abhaengigkeiten.Name = "C1Abhaengigkeiten"
        Me.C1Abhaengigkeiten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Abhaengigkeiten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Abhaengigkeiten.PreviewInfo.ZoomFactor = 75
        Me.C1Abhaengigkeiten.PrintInfo.PageSettings = CType(resources.GetObject("C1Abhaengigkeiten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Abhaengigkeiten.Size = New System.Drawing.Size(374, 126)
        Me.C1Abhaengigkeiten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Abhaengigkeiten.TabIndex = 12
        Me.C1Abhaengigkeiten.Text = "C1TrueDBGrid1"
        Me.C1Abhaengigkeiten.PropBag = resources.GetString("C1Abhaengigkeiten.PropBag")
        '
        'AbhaengigkeitMenuStrip
        '
        Me.AbhaengigkeitMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.AbhaengigkeitAnzeigenToolStripMenuItem, Me.AbhaengigkeitNeuToolStripMenuItem, Me.AbhaengigkeitLoeschenToolStripMenuItem})
        Me.AbhaengigkeitMenuStrip.Name = "AbhaengigkeitMenuStrip"
        Me.AbhaengigkeitMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'AbhaengigkeitAnzeigenToolStripMenuItem
        '
        Me.AbhaengigkeitAnzeigenToolStripMenuItem.Name = "AbhaengigkeitAnzeigenToolStripMenuItem"
        Me.AbhaengigkeitAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.AbhaengigkeitAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'AbhaengigkeitNeuToolStripMenuItem
        '
        Me.AbhaengigkeitNeuToolStripMenuItem.Name = "AbhaengigkeitNeuToolStripMenuItem"
        Me.AbhaengigkeitNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.AbhaengigkeitNeuToolStripMenuItem.Text = "&Neu"
        '
        'AbhaengigkeitLoeschenToolStripMenuItem
        '
        Me.AbhaengigkeitLoeschenToolStripMenuItem.Name = "AbhaengigkeitLoeschenToolStripMenuItem"
        Me.AbhaengigkeitLoeschenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.AbhaengigkeitLoeschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(156, 106)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(112, 23)
        Me.Button3.TabIndex = 2
        Me.Button3.Text = "Drehbuch speichern"
        Me.Button3.UseVisualStyleBackColor = True
        Me.Button3.Visible = False
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(26, 106)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(112, 23)
        Me.Button4.TabIndex = 1
        Me.Button4.Text = "Drehbuch anzeigen"
        Me.Button4.UseVisualStyleBackColor = True
        Me.Button4.Visible = False
        '
        'grpDrehbuch
        '
        Me.grpDrehbuch.Controls.Add(Me.C1Drehbuch)
        Me.grpDrehbuch.Controls.Add(Me.btnDrehbuchspeichern)
        Me.grpDrehbuch.Controls.Add(Me.btnDrehbuchanzeigen)
        Me.grpDrehbuch.Dock = System.Windows.Forms.DockStyle.Left
        Me.grpDrehbuch.Location = New System.Drawing.Point(3, 16)
        Me.grpDrehbuch.Name = "grpDrehbuch"
        Me.grpDrehbuch.Size = New System.Drawing.Size(271, 145)
        Me.grpDrehbuch.TabIndex = 98
        Me.grpDrehbuch.TabStop = False
        Me.grpDrehbuch.Text = "Drehbücher"
        '
        'C1Drehbuch
        '
        Me.C1Drehbuch.AlternatingRows = True
        Me.C1Drehbuch.ContextMenuStrip = Me.DrehbuchMenuStrip
        Me.C1Drehbuch.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Drehbuch.FetchRowStyles = True
        Me.C1Drehbuch.FilterBar = True
        Me.C1Drehbuch.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Drehbuch.Images.Add(CType(resources.GetObject("C1Drehbuch.Images"), System.Drawing.Image))
        Me.C1Drehbuch.Location = New System.Drawing.Point(3, 16)
        Me.C1Drehbuch.Name = "C1Drehbuch"
        Me.C1Drehbuch.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Drehbuch.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Drehbuch.PreviewInfo.ZoomFactor = 75
        Me.C1Drehbuch.PrintInfo.PageSettings = CType(resources.GetObject("C1Drehbuch.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Drehbuch.Size = New System.Drawing.Size(265, 126)
        Me.C1Drehbuch.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Drehbuch.TabIndex = 12
        Me.C1Drehbuch.Text = "C1TrueDBGrid1"
        Me.C1Drehbuch.PropBag = resources.GetString("C1Drehbuch.PropBag")
        '
        'DrehbuchMenuStrip
        '
        Me.DrehbuchMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DrehbuchAnzeigenToolStripMenuItem, Me.DrehbuchNeuToolStripMenuItem, Me.DrehbuchLöschenToolStripMenuItem, Me.ToolStripSeparator1, Me.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem})
        Me.DrehbuchMenuStrip.Name = "DrehbuchMenuStrip"
        Me.DrehbuchMenuStrip.Size = New System.Drawing.Size(181, 98)
        '
        'DrehbuchAnzeigenToolStripMenuItem
        '
        Me.DrehbuchAnzeigenToolStripMenuItem.Name = "DrehbuchAnzeigenToolStripMenuItem"
        Me.DrehbuchAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DrehbuchAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'DrehbuchNeuToolStripMenuItem
        '
        Me.DrehbuchNeuToolStripMenuItem.Name = "DrehbuchNeuToolStripMenuItem"
        Me.DrehbuchNeuToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DrehbuchNeuToolStripMenuItem.Text = "&Neu"
        '
        'DrehbuchLöschenToolStripMenuItem
        '
        Me.DrehbuchLöschenToolStripMenuItem.Name = "DrehbuchLöschenToolStripMenuItem"
        Me.DrehbuchLöschenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DrehbuchLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStripSeparator1
        '
        Me.ToolStripSeparator1.Name = "ToolStripSeparator1"
        Me.ToolStripSeparator1.Size = New System.Drawing.Size(177, 6)
        '
        'Drehbuch_Anzeigen_Dokument_ToolStripMenuItem
        '
        Me.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem.Name = "Drehbuch_Anzeigen_Dokument_ToolStripMenuItem"
        Me.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.Drehbuch_Anzeigen_Dokument_ToolStripMenuItem.Text = "&Dokument anzeigen"
        '
        'btnDrehbuchspeichern
        '
        Me.btnDrehbuchspeichern.Location = New System.Drawing.Point(156, 106)
        Me.btnDrehbuchspeichern.Name = "btnDrehbuchspeichern"
        Me.btnDrehbuchspeichern.Size = New System.Drawing.Size(112, 23)
        Me.btnDrehbuchspeichern.TabIndex = 2
        Me.btnDrehbuchspeichern.Text = "Drehbuch speichern"
        Me.btnDrehbuchspeichern.UseVisualStyleBackColor = True
        Me.btnDrehbuchspeichern.Visible = False
        '
        'btnDrehbuchanzeigen
        '
        Me.btnDrehbuchanzeigen.Location = New System.Drawing.Point(26, 106)
        Me.btnDrehbuchanzeigen.Name = "btnDrehbuchanzeigen"
        Me.btnDrehbuchanzeigen.Size = New System.Drawing.Size(112, 33)
        Me.btnDrehbuchanzeigen.TabIndex = 1
        Me.btnDrehbuchanzeigen.Text = "Drehbuch anzeigen"
        Me.btnDrehbuchanzeigen.UseVisualStyleBackColor = True
        Me.btnDrehbuchanzeigen.Visible = False
        '
        'TabKontakte
        '
        Me.TabKontakte.Controls.Add(Me.C1Kontakte)
        Me.TabKontakte.Location = New System.Drawing.Point(4, 22)
        Me.TabKontakte.Name = "TabKontakte"
        Me.TabKontakte.Size = New System.Drawing.Size(657, 474)
        Me.TabKontakte.TabIndex = 4
        Me.TabKontakte.Text = "Kontakte"
        Me.TabKontakte.UseVisualStyleBackColor = True
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.ContextMenuStrip = Me.KontakteMenuStrip
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FetchRowStyles = True
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(657, 474)
        Me.C1Kontakte.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kontakte.TabIndex = 11
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'KontakteMenuStrip
        '
        Me.KontakteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KontaktAnzeigenToolStripMenuItem, Me.KontaktNeuToolStripMenuItem, Me.KontaktLöschenToolStripMenuItem, Me.ToolStripMenuItem1, Me.MassenUpdatesToolStripMenuItem})
        Me.KontakteMenuStrip.Name = "KontakteMenuStrip"
        Me.KontakteMenuStrip.Size = New System.Drawing.Size(163, 98)
        '
        'KontaktAnzeigenToolStripMenuItem
        '
        Me.KontaktAnzeigenToolStripMenuItem.Name = "KontaktAnzeigenToolStripMenuItem"
        Me.KontaktAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.KontaktAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KontaktNeuToolStripMenuItem
        '
        Me.KontaktNeuToolStripMenuItem.Name = "KontaktNeuToolStripMenuItem"
        Me.KontaktNeuToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.KontaktNeuToolStripMenuItem.Text = "&Neu"
        '
        'KontaktLöschenToolStripMenuItem
        '
        Me.KontaktLöschenToolStripMenuItem.Name = "KontaktLöschenToolStripMenuItem"
        Me.KontaktLöschenToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.KontaktLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(159, 6)
        '
        'MassenUpdatesToolStripMenuItem
        '
        Me.MassenUpdatesToolStripMenuItem.Name = "MassenUpdatesToolStripMenuItem"
        Me.MassenUpdatesToolStripMenuItem.Size = New System.Drawing.Size(162, 22)
        Me.MassenUpdatesToolStripMenuItem.Text = "Massen-Updates"
        '
        'TabReleaseLogbuch
        '
        Me.TabReleaseLogbuch.Controls.Add(Me.C1ReleaseLogbuch)
        Me.TabReleaseLogbuch.Location = New System.Drawing.Point(4, 22)
        Me.TabReleaseLogbuch.Name = "TabReleaseLogbuch"
        Me.TabReleaseLogbuch.Padding = New System.Windows.Forms.Padding(3)
        Me.TabReleaseLogbuch.Size = New System.Drawing.Size(657, 474)
        Me.TabReleaseLogbuch.TabIndex = 11
        Me.TabReleaseLogbuch.Text = "Release-Logbuch"
        Me.TabReleaseLogbuch.UseVisualStyleBackColor = True
        '
        'C1ReleaseLogbuch
        '
        Me.C1ReleaseLogbuch.AlternatingRows = True
        Me.C1ReleaseLogbuch.ContextMenuStrip = Me.ReleaseLogbuchMenuStrip
        Me.C1ReleaseLogbuch.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1ReleaseLogbuch.FetchRowStyles = True
        Me.C1ReleaseLogbuch.FilterBar = True
        Me.C1ReleaseLogbuch.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1ReleaseLogbuch.Images.Add(CType(resources.GetObject("C1ReleaseLogbuch.Images"), System.Drawing.Image))
        Me.C1ReleaseLogbuch.Location = New System.Drawing.Point(3, 3)
        Me.C1ReleaseLogbuch.Name = "C1ReleaseLogbuch"
        Me.C1ReleaseLogbuch.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1ReleaseLogbuch.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1ReleaseLogbuch.PreviewInfo.ZoomFactor = 75
        Me.C1ReleaseLogbuch.PrintInfo.PageSettings = CType(resources.GetObject("C1ReleaseLogbuch.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1ReleaseLogbuch.Size = New System.Drawing.Size(651, 468)
        Me.C1ReleaseLogbuch.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1ReleaseLogbuch.TabIndex = 12
        Me.C1ReleaseLogbuch.Text = "C1TrueDBGrid1"
        Me.C1ReleaseLogbuch.PropBag = resources.GetString("C1ReleaseLogbuch.PropBag")
        '
        'ReleaseLogbuchMenuStrip
        '
        Me.ReleaseLogbuchMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ReleaseLogbuchAnzeigenToolStripMenuItem, Me.ReleaseLogbuchNeuToolStripMenuItem, Me.ReleaseLogbuchInaktivierenToolStripMenuItem})
        Me.ReleaseLogbuchMenuStrip.Name = "ReleaseLogbuchMenuStrip"
        Me.ReleaseLogbuchMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'ReleaseLogbuchAnzeigenToolStripMenuItem
        '
        Me.ReleaseLogbuchAnzeigenToolStripMenuItem.Name = "ReleaseLogbuchAnzeigenToolStripMenuItem"
        Me.ReleaseLogbuchAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReleaseLogbuchAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'ReleaseLogbuchNeuToolStripMenuItem
        '
        Me.ReleaseLogbuchNeuToolStripMenuItem.Name = "ReleaseLogbuchNeuToolStripMenuItem"
        Me.ReleaseLogbuchNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReleaseLogbuchNeuToolStripMenuItem.Text = "&Neu"
        '
        'ReleaseLogbuchInaktivierenToolStripMenuItem
        '
        Me.ReleaseLogbuchInaktivierenToolStripMenuItem.Name = "ReleaseLogbuchInaktivierenToolStripMenuItem"
        Me.ReleaseLogbuchInaktivierenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReleaseLogbuchInaktivierenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'TabVertragsbeziehungen
        '
        Me.TabVertragsbeziehungen.Controls.Add(Me.C1Vertragselemente)
        Me.TabVertragsbeziehungen.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsbeziehungen.Name = "TabVertragsbeziehungen"
        Me.TabVertragsbeziehungen.Size = New System.Drawing.Size(657, 474)
        Me.TabVertragsbeziehungen.TabIndex = 5
        Me.TabVertragsbeziehungen.Text = "Vertragsbeziehungen"
        Me.TabVertragsbeziehungen.UseVisualStyleBackColor = True
        '
        'C1Vertragselemente
        '
        Me.C1Vertragselemente.AlternatingRows = True
        Me.C1Vertragselemente.ContextMenuStrip = Me.VertragsbeziehungMenuStrip
        Me.C1Vertragselemente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Vertragselemente.FetchRowStyles = True
        Me.C1Vertragselemente.FilterBar = True
        Me.C1Vertragselemente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Vertragselemente.Images.Add(CType(resources.GetObject("C1Vertragselemente.Images"), System.Drawing.Image))
        Me.C1Vertragselemente.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.Name = "C1Vertragselemente"
        Me.C1Vertragselemente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragselemente.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragselemente.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragselemente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragselemente.Size = New System.Drawing.Size(657, 474)
        Me.C1Vertragselemente.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Vertragselemente.TabIndex = 13
        Me.C1Vertragselemente.Text = "C1TrueDBGrid1"
        Me.C1Vertragselemente.PropBag = resources.GetString("C1Vertragselemente.PropBag")
        '
        'VertragsbeziehungMenuStrip
        '
        Me.VertragsbeziehungMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.VertragselementAnzeigenToolStripMenuItem})
        Me.VertragsbeziehungMenuStrip.Name = "VertragsbeziehungMenuStrip"
        Me.VertragsbeziehungMenuStrip.Size = New System.Drawing.Size(124, 26)
        '
        'VertragselementAnzeigenToolStripMenuItem
        '
        Me.VertragselementAnzeigenToolStripMenuItem.Name = "VertragselementAnzeigenToolStripMenuItem"
        Me.VertragselementAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(123, 22)
        Me.VertragselementAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'TabDokumente
        '
        Me.TabDokumente.Controls.Add(Me.C1Dokumente)
        Me.TabDokumente.Location = New System.Drawing.Point(4, 22)
        Me.TabDokumente.Name = "TabDokumente"
        Me.TabDokumente.Size = New System.Drawing.Size(657, 474)
        Me.TabDokumente.TabIndex = 6
        Me.TabDokumente.Text = "Dokumente"
        Me.TabDokumente.UseVisualStyleBackColor = True
        '
        'C1Dokumente
        '
        Me.C1Dokumente.AlternatingRows = True
        Me.C1Dokumente.ContextMenuStrip = Me.DokumenteMenuStrip
        Me.C1Dokumente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Dokumente.FetchRowStyles = True
        Me.C1Dokumente.FilterBar = True
        Me.C1Dokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Dokumente.Images.Add(CType(resources.GetObject("C1Dokumente.Images"), System.Drawing.Image))
        Me.C1Dokumente.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.Name = "C1Dokumente"
        Me.C1Dokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Dokumente.PreviewInfo.ZoomFactor = 75
        Me.C1Dokumente.PrintInfo.PageSettings = CType(resources.GetObject("C1Dokumente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Dokumente.Size = New System.Drawing.Size(657, 474)
        Me.C1Dokumente.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Dokumente.TabIndex = 12
        Me.C1Dokumente.Text = "C1TrueDBGrid1"
        Me.C1Dokumente.PropBag = resources.GetString("C1Dokumente.PropBag")
        '
        'DokumenteMenuStrip
        '
        Me.DokumenteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DokumentAnzeigenToolStripMenuItem, Me.DokumentNeuToolStripMenuItem, Me.DokumentLöschenToolStripMenuItem, Me.ToolStripMenuItem2, Me.DokumentAnzeigen_Dokument_ToolStripMenuItem})
        Me.DokumenteMenuStrip.Name = "DokumenteMenuStrip"
        Me.DokumenteMenuStrip.Size = New System.Drawing.Size(181, 98)
        '
        'DokumentAnzeigenToolStripMenuItem
        '
        Me.DokumentAnzeigenToolStripMenuItem.Name = "DokumentAnzeigenToolStripMenuItem"
        Me.DokumentAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'DokumentNeuToolStripMenuItem
        '
        Me.DokumentNeuToolStripMenuItem.Name = "DokumentNeuToolStripMenuItem"
        Me.DokumentNeuToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentNeuToolStripMenuItem.Text = "&Neu"
        '
        'DokumentLöschenToolStripMenuItem
        '
        Me.DokumentLöschenToolStripMenuItem.Name = "DokumentLöschenToolStripMenuItem"
        Me.DokumentLöschenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStripMenuItem2
        '
        Me.ToolStripMenuItem2.Name = "ToolStripMenuItem2"
        Me.ToolStripMenuItem2.Size = New System.Drawing.Size(177, 6)
        '
        'DokumentAnzeigen_Dokument_ToolStripMenuItem
        '
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Name = "DokumentAnzeigen_Dokument_ToolStripMenuItem"
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Text = "&Dokument anzeigen"
        '
        'TabTicketXPert
        '
        Me.TabTicketXPert.Controls.Add(Me.cbTicketXPertVerwendung)
        Me.TabTicketXPert.Controls.Add(Me.grpTicketXpert)
        Me.TabTicketXPert.Location = New System.Drawing.Point(4, 22)
        Me.TabTicketXPert.Name = "TabTicketXPert"
        Me.TabTicketXPert.Size = New System.Drawing.Size(657, 474)
        Me.TabTicketXPert.TabIndex = 7
        Me.TabTicketXPert.Text = "TicketXPert"
        Me.TabTicketXPert.UseVisualStyleBackColor = True
        '
        'cbTicketXPertVerwendung
        '
        Me.cbTicketXPertVerwendung.AutoSize = True
        Me.cbTicketXPertVerwendung.Location = New System.Drawing.Point(19, 19)
        Me.cbTicketXPertVerwendung.Name = "cbTicketXPertVerwendung"
        Me.cbTicketXPertVerwendung.Size = New System.Drawing.Size(15, 14)
        Me.cbTicketXPertVerwendung.TabIndex = 0
        Me.cbTicketXPertVerwendung.UseVisualStyleBackColor = True
        '
        'grpTicketXpert
        '
        Me.grpTicketXpert.Controls.Add(Me.cbboxSLM)
        Me.grpTicketXpert.Controls.Add(Me.cbWPIAnzeigen)
        Me.grpTicketXpert.Controls.Add(Me.cbboxKritikalität)
        Me.grpTicketXpert.Controls.Add(Me.lblWPIAnzeigen)
        Me.grpTicketXpert.Controls.Add(Me.lblSLM)
        Me.grpTicketXpert.Controls.Add(Me.lblWPIPreis)
        Me.grpTicketXpert.Controls.Add(Me.lblKritikalität)
        Me.grpTicketXpert.Controls.Add(Me.txtWPIPreis)
        Me.grpTicketXpert.Controls.Add(Me.lblAMAnzeigen)
        Me.grpTicketXpert.Controls.Add(Me.lblPreisEinmalig)
        Me.grpTicketXpert.Controls.Add(Me.cbAMAnzeigen)
        Me.grpTicketXpert.Controls.Add(Me.txtPreisEinmalig)
        Me.grpTicketXpert.Location = New System.Drawing.Point(40, 20)
        Me.grpTicketXpert.Name = "grpTicketXpert"
        Me.grpTicketXpert.Size = New System.Drawing.Size(300, 238)
        Me.grpTicketXpert.TabIndex = 12
        Me.grpTicketXpert.TabStop = False
        Me.grpTicketXpert.Text = "Verwendung für TicketXpert         "
        '
        'cbboxSLM
        '
        Me.cbboxSLM.FormattingEnabled = True
        Me.cbboxSLM.Location = New System.Drawing.Point(152, 188)
        Me.cbboxSLM.Name = "cbboxSLM"
        Me.cbboxSLM.Size = New System.Drawing.Size(121, 21)
        Me.cbboxSLM.TabIndex = 5
        '
        'cbWPIAnzeigen
        '
        Me.cbWPIAnzeigen.AutoSize = True
        Me.cbWPIAnzeigen.Location = New System.Drawing.Point(152, 29)
        Me.cbWPIAnzeigen.Name = "cbWPIAnzeigen"
        Me.cbWPIAnzeigen.Size = New System.Drawing.Size(15, 14)
        Me.cbWPIAnzeigen.TabIndex = 0
        Me.cbWPIAnzeigen.UseVisualStyleBackColor = True
        '
        'cbboxKritikalität
        '
        Me.cbboxKritikalität.FormattingEnabled = True
        Me.cbboxKritikalität.Location = New System.Drawing.Point(152, 161)
        Me.cbboxKritikalität.Name = "cbboxKritikalität"
        Me.cbboxKritikalität.Size = New System.Drawing.Size(121, 21)
        Me.cbboxKritikalität.TabIndex = 4
        '
        'lblWPIAnzeigen
        '
        Me.lblWPIAnzeigen.AutoSize = True
        Me.lblWPIAnzeigen.Location = New System.Drawing.Point(24, 30)
        Me.lblWPIAnzeigen.Name = "lblWPIAnzeigen"
        Me.lblWPIAnzeigen.Size = New System.Drawing.Size(75, 13)
        Me.lblWPIAnzeigen.TabIndex = 1
        Me.lblWPIAnzeigen.Text = "WPI-Anzeigen"
        '
        'lblSLM
        '
        Me.lblSLM.AutoSize = True
        Me.lblSLM.Location = New System.Drawing.Point(24, 191)
        Me.lblSLM.Name = "lblSLM"
        Me.lblSLM.Size = New System.Drawing.Size(29, 13)
        Me.lblSLM.TabIndex = 9
        Me.lblSLM.Text = "SLM"
        '
        'lblWPIPreis
        '
        Me.lblWPIPreis.AutoSize = True
        Me.lblWPIPreis.Location = New System.Drawing.Point(24, 54)
        Me.lblWPIPreis.Name = "lblWPIPreis"
        Me.lblWPIPreis.Size = New System.Drawing.Size(120, 13)
        Me.lblWPIPreis.TabIndex = 2
        Me.lblWPIPreis.Text = "WPI Preis Monat / User"
        '
        'lblKritikalität
        '
        Me.lblKritikalität.AutoSize = True
        Me.lblKritikalität.Location = New System.Drawing.Point(24, 164)
        Me.lblKritikalität.Name = "lblKritikalität"
        Me.lblKritikalität.Size = New System.Drawing.Size(52, 13)
        Me.lblKritikalität.TabIndex = 8
        Me.lblKritikalität.Text = "Kritikalität"
        '
        'txtWPIPreis
        '
        Me.txtWPIPreis.Location = New System.Drawing.Point(152, 49)
        Me.txtWPIPreis.Name = "txtWPIPreis"
        Me.txtWPIPreis.Size = New System.Drawing.Size(100, 20)
        Me.txtWPIPreis.TabIndex = 1
        '
        'lblAMAnzeigen
        '
        Me.lblAMAnzeigen.AutoSize = True
        Me.lblAMAnzeigen.Location = New System.Drawing.Point(24, 136)
        Me.lblAMAnzeigen.Name = "lblAMAnzeigen"
        Me.lblAMAnzeigen.Size = New System.Drawing.Size(70, 13)
        Me.lblAMAnzeigen.TabIndex = 7
        Me.lblAMAnzeigen.Text = "AM Anzeigen"
        '
        'lblPreisEinmalig
        '
        Me.lblPreisEinmalig.AutoSize = True
        Me.lblPreisEinmalig.Location = New System.Drawing.Point(24, 81)
        Me.lblPreisEinmalig.Name = "lblPreisEinmalig"
        Me.lblPreisEinmalig.Size = New System.Drawing.Size(71, 13)
        Me.lblPreisEinmalig.TabIndex = 4
        Me.lblPreisEinmalig.Text = "Preis einmalig"
        '
        'cbAMAnzeigen
        '
        Me.cbAMAnzeigen.AutoSize = True
        Me.cbAMAnzeigen.Location = New System.Drawing.Point(152, 135)
        Me.cbAMAnzeigen.Name = "cbAMAnzeigen"
        Me.cbAMAnzeigen.Size = New System.Drawing.Size(15, 14)
        Me.cbAMAnzeigen.TabIndex = 3
        Me.cbAMAnzeigen.UseVisualStyleBackColor = True
        '
        'txtPreisEinmalig
        '
        Me.txtPreisEinmalig.Location = New System.Drawing.Point(152, 78)
        Me.txtPreisEinmalig.Name = "txtPreisEinmalig"
        Me.txtPreisEinmalig.Size = New System.Drawing.Size(100, 20)
        Me.txtPreisEinmalig.TabIndex = 2
        '
        'TabRisiko
        '
        Me.TabRisiko.Controls.Add(Me.GrpUser)
        Me.TabRisiko.Controls.Add(Me.GrpUeberwachung)
        Me.TabRisiko.Controls.Add(Me.GrpSensitiveDaten)
        Me.TabRisiko.Location = New System.Drawing.Point(4, 22)
        Me.TabRisiko.Name = "TabRisiko"
        Me.TabRisiko.Size = New System.Drawing.Size(657, 474)
        Me.TabRisiko.TabIndex = 8
        Me.TabRisiko.Text = "Risiko-Übersicht"
        Me.TabRisiko.UseVisualStyleBackColor = True
        '
        'GrpUser
        '
        Me.GrpUser.Controls.Add(Me.txtAnzExterne)
        Me.GrpUser.Controls.Add(Me.Label10)
        Me.GrpUser.Controls.Add(Me.TxtAnzComit)
        Me.GrpUser.Controls.Add(Me.Label7)
        Me.GrpUser.Controls.Add(Me.Label9)
        Me.GrpUser.Controls.Add(Me.TxtUser)
        Me.GrpUser.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpUser.Location = New System.Drawing.Point(0, 269)
        Me.GrpUser.Name = "GrpUser"
        Me.GrpUser.Size = New System.Drawing.Size(657, 205)
        Me.GrpUser.TabIndex = 2
        Me.GrpUser.TabStop = False
        Me.GrpUser.Text = "Comit / Externe User"
        '
        'txtAnzExterne
        '
        Me.txtAnzExterne.Location = New System.Drawing.Point(111, 115)
        Me.txtAnzExterne.Name = "txtAnzExterne"
        Me.txtAnzExterne.Size = New System.Drawing.Size(100, 20)
        Me.txtAnzExterne.TabIndex = 17
        '
        'Label10
        '
        Me.Label10.AutoSize = True
        Me.Label10.Location = New System.Drawing.Point(13, 118)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(67, 13)
        Me.Label10.TabIndex = 16
        Me.Label10.Text = "Anz. Externe"
        '
        'TxtAnzComit
        '
        Me.TxtAnzComit.Location = New System.Drawing.Point(111, 88)
        Me.TxtAnzComit.Name = "TxtAnzComit"
        Me.TxtAnzComit.Size = New System.Drawing.Size(100, 20)
        Me.TxtAnzComit.TabIndex = 15
        '
        'Label7
        '
        Me.Label7.AutoSize = True
        Me.Label7.Location = New System.Drawing.Point(13, 88)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(57, 13)
        Me.Label7.TabIndex = 14
        Me.Label7.Text = "Anz. Comit"
        '
        'Label9
        '
        Me.Label9.AutoSize = True
        Me.Label9.Location = New System.Drawing.Point(13, 26)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(72, 13)
        Me.Label9.TabIndex = 13
        Me.Label9.Text = "Beschreibung"
        '
        'TxtUser
        '
        Me.TxtUser.Location = New System.Drawing.Point(111, 29)
        Me.TxtUser.Multiline = True
        Me.TxtUser.Name = "TxtUser"
        Me.TxtUser.Size = New System.Drawing.Size(502, 48)
        Me.TxtUser.TabIndex = 12
        '
        'GrpUeberwachung
        '
        Me.GrpUeberwachung.Controls.Add(Me.cbboxPeriodizitaet)
        Me.GrpUeberwachung.Controls.Add(Me.Label6)
        Me.GrpUeberwachung.Controls.Add(Me.Label5)
        Me.GrpUeberwachung.Controls.Add(Me.TxtUeberwachung)
        Me.GrpUeberwachung.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpUeberwachung.Location = New System.Drawing.Point(0, 136)
        Me.GrpUeberwachung.Name = "GrpUeberwachung"
        Me.GrpUeberwachung.Size = New System.Drawing.Size(657, 133)
        Me.GrpUeberwachung.TabIndex = 1
        Me.GrpUeberwachung.TabStop = False
        Me.GrpUeberwachung.Text = "Überwachung"
        '
        'cbboxPeriodizitaet
        '
        Me.cbboxPeriodizitaet.FormattingEnabled = True
        Me.cbboxPeriodizitaet.Location = New System.Drawing.Point(111, 83)
        Me.cbboxPeriodizitaet.Name = "cbboxPeriodizitaet"
        Me.cbboxPeriodizitaet.Size = New System.Drawing.Size(185, 21)
        Me.cbboxPeriodizitaet.TabIndex = 15
        '
        'Label6
        '
        Me.Label6.AutoSize = True
        Me.Label6.Location = New System.Drawing.Point(13, 86)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(58, 13)
        Me.Label6.TabIndex = 14
        Me.Label6.Text = "Periodizität"
        '
        'Label5
        '
        Me.Label5.AutoSize = True
        Me.Label5.Location = New System.Drawing.Point(13, 26)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(72, 13)
        Me.Label5.TabIndex = 13
        Me.Label5.Text = "Beschreibung"
        '
        'TxtUeberwachung
        '
        Me.TxtUeberwachung.Location = New System.Drawing.Point(111, 29)
        Me.TxtUeberwachung.Multiline = True
        Me.TxtUeberwachung.Name = "TxtUeberwachung"
        Me.TxtUeberwachung.Size = New System.Drawing.Size(502, 48)
        Me.TxtUeberwachung.TabIndex = 12
        '
        'GrpSensitiveDaten
        '
        Me.GrpSensitiveDaten.Controls.Add(Me.cbboxAdministriertdurch)
        Me.GrpSensitiveDaten.Controls.Add(Me.Label4)
        Me.GrpSensitiveDaten.Controls.Add(Me.Label3)
        Me.GrpSensitiveDaten.Controls.Add(Me.cbSensitiveDaten)
        Me.GrpSensitiveDaten.Controls.Add(Me.txtSensitiveDaten)
        Me.GrpSensitiveDaten.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpSensitiveDaten.Location = New System.Drawing.Point(0, 0)
        Me.GrpSensitiveDaten.Name = "GrpSensitiveDaten"
        Me.GrpSensitiveDaten.Size = New System.Drawing.Size(657, 136)
        Me.GrpSensitiveDaten.TabIndex = 0
        Me.GrpSensitiveDaten.TabStop = False
        Me.GrpSensitiveDaten.Text = "Sensitive Daten"
        '
        'cbboxAdministriertdurch
        '
        Me.cbboxAdministriertdurch.FormattingEnabled = True
        Me.cbboxAdministriertdurch.Location = New System.Drawing.Point(111, 107)
        Me.cbboxAdministriertdurch.Name = "cbboxAdministriertdurch"
        Me.cbboxAdministriertdurch.Size = New System.Drawing.Size(185, 21)
        Me.cbboxAdministriertdurch.TabIndex = 13
        '
        'Label4
        '
        Me.Label4.AutoSize = True
        Me.Label4.Location = New System.Drawing.Point(13, 110)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(93, 13)
        Me.Label4.TabIndex = 12
        Me.Label4.Text = "Administriert durch"
        '
        'Label3
        '
        Me.Label3.AutoSize = True
        Me.Label3.Location = New System.Drawing.Point(13, 49)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 13)
        Me.Label3.TabIndex = 11
        Me.Label3.Text = "Beschreibung"
        '
        'cbSensitiveDaten
        '
        Me.cbSensitiveDaten.Location = New System.Drawing.Point(11, 22)
        Me.cbSensitiveDaten.Name = "cbSensitiveDaten"
        Me.cbSensitiveDaten.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbSensitiveDaten.Size = New System.Drawing.Size(114, 18)
        Me.cbSensitiveDaten.TabIndex = 10
        Me.cbSensitiveDaten.Text = "Sensitive Daten"
        Me.cbSensitiveDaten.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbSensitiveDaten.UseVisualStyleBackColor = True
        '
        'txtSensitiveDaten
        '
        Me.txtSensitiveDaten.Location = New System.Drawing.Point(111, 52)
        Me.txtSensitiveDaten.Multiline = True
        Me.txtSensitiveDaten.Name = "txtSensitiveDaten"
        Me.txtSensitiveDaten.Size = New System.Drawing.Size(502, 48)
        Me.txtSensitiveDaten.TabIndex = 1
        '
        'TabPage11
        '
        Me.TabPage11.Location = New System.Drawing.Point(4, 22)
        Me.TabPage11.Name = "TabPage11"
        Me.TabPage11.Size = New System.Drawing.Size(722, 410)
        Me.TabPage11.TabIndex = 6
        Me.TabPage11.Text = "Dokumente"
        Me.TabPage11.UseVisualStyleBackColor = True
        '
        'TabPage10
        '
        Me.TabPage10.Location = New System.Drawing.Point(4, 22)
        Me.TabPage10.Name = "TabPage10"
        Me.TabPage10.Size = New System.Drawing.Size(722, 410)
        Me.TabPage10.TabIndex = 5
        Me.TabPage10.Text = "Vertragsbeziehungen"
        Me.TabPage10.UseVisualStyleBackColor = True
        '
        'TabPage9
        '
        Me.TabPage9.Location = New System.Drawing.Point(4, 22)
        Me.TabPage9.Name = "TabPage9"
        Me.TabPage9.Size = New System.Drawing.Size(722, 410)
        Me.TabPage9.TabIndex = 4
        Me.TabPage9.Text = "Kontakte"
        Me.TabPage9.UseVisualStyleBackColor = True
        '
        'TabPage8
        '
        Me.TabPage8.Controls.Add(Me.GroupBox7)
        Me.TabPage8.Controls.Add(Me.GroupBox8)
        Me.TabPage8.Controls.Add(Me.GroupBox6)
        Me.TabPage8.Location = New System.Drawing.Point(4, 22)
        Me.TabPage8.Name = "TabPage8"
        Me.TabPage8.Size = New System.Drawing.Size(722, 410)
        Me.TabPage8.TabIndex = 3
        Me.TabPage8.Text = "Testing"
        Me.TabPage8.UseVisualStyleBackColor = True
        '
        'GroupBox7
        '
        Me.GroupBox7.Controls.Add(Me.TextBox7)
        Me.GroupBox7.Controls.Add(Me.Label23)
        Me.GroupBox7.Controls.Add(Me.TextBox6)
        Me.GroupBox7.Controls.Add(Me.Label24)
        Me.GroupBox7.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox7.Location = New System.Drawing.Point(0, 85)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(722, 85)
        Me.GroupBox7.TabIndex = 1
        Me.GroupBox7.TabStop = False
        '
        'TextBox7
        '
        Me.TextBox7.Location = New System.Drawing.Point(433, 19)
        Me.TextBox7.Multiline = True
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.Size = New System.Drawing.Size(202, 60)
        Me.TextBox7.TabIndex = 98
        '
        'Label23
        '
        Me.Label23.AutoSize = True
        Me.Label23.Location = New System.Drawing.Point(349, 22)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(0, 13)
        Me.Label23.TabIndex = 97
        '
        'TextBox6
        '
        Me.TextBox6.Location = New System.Drawing.Point(141, 19)
        Me.TextBox6.Multiline = True
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.Size = New System.Drawing.Size(202, 60)
        Me.TextBox6.TabIndex = 96
        '
        'Label24
        '
        Me.Label24.AutoSize = True
        Me.Label24.Location = New System.Drawing.Point(8, 22)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(0, 13)
        Me.Label24.TabIndex = 95
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.Add(Me.TextBox11)
        Me.GroupBox8.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox8.Location = New System.Drawing.Point(0, 85)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(722, 325)
        Me.GroupBox8.TabIndex = 2
        Me.GroupBox8.TabStop = False
        '
        'TextBox11
        '
        Me.TextBox11.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TextBox11.Location = New System.Drawing.Point(3, 16)
        Me.TextBox11.Multiline = True
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.Size = New System.Drawing.Size(716, 306)
        Me.TextBox11.TabIndex = 96
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.Add(Me.Label22)
        Me.GroupBox6.Controls.Add(Me.Button1)
        Me.GroupBox6.Controls.Add(Me.Button2)
        Me.GroupBox6.Controls.Add(Me.ComboBox9)
        Me.GroupBox6.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox6.Location = New System.Drawing.Point(0, 0)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(722, 85)
        Me.GroupBox6.TabIndex = 0
        Me.GroupBox6.TabStop = False
        '
        'Label22
        '
        Me.Label22.AutoSize = True
        Me.Label22.Location = New System.Drawing.Point(6, 27)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(0, 13)
        Me.Label22.TabIndex = 97
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(9, 52)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(112, 23)
        Me.Button1.TabIndex = 98
        Me.Button1.Text = "Drehbuch anzeigen"
        Me.Button1.UseVisualStyleBackColor = True
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(139, 52)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(112, 23)
        Me.Button2.TabIndex = 99
        Me.Button2.Text = "Drehbuch speichern"
        Me.Button2.UseVisualStyleBackColor = True
        '
        'ComboBox9
        '
        Me.ComboBox9.FormattingEnabled = True
        Me.ComboBox9.Location = New System.Drawing.Point(139, 24)
        Me.ComboBox9.Name = "ComboBox9"
        Me.ComboBox9.Size = New System.Drawing.Size(204, 21)
        Me.ComboBox9.TabIndex = 96
        '
        'TabPage5
        '
        Me.TabPage5.Controls.Add(Me.GroupBox5)
        Me.TabPage5.Controls.Add(Me.GroupBox4)
        Me.TabPage5.Location = New System.Drawing.Point(4, 22)
        Me.TabPage5.Name = "TabPage5"
        Me.TabPage5.Size = New System.Drawing.Size(722, 410)
        Me.TabPage5.TabIndex = 2
        Me.TabPage5.Text = "Lizenzen"
        Me.TabPage5.UseVisualStyleBackColor = True
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.Add(Me.C1TrueDBGrid2)
        Me.GroupBox5.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox5.Location = New System.Drawing.Point(0, 151)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(722, 259)
        Me.GroupBox5.TabIndex = 1
        Me.GroupBox5.TabStop = False
        '
        'C1TrueDBGrid2
        '
        Me.C1TrueDBGrid2.AlternatingRows = True
        Me.C1TrueDBGrid2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid2.FilterBar = True
        Me.C1TrueDBGrid2.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid2.Images.Add(CType(resources.GetObject("C1TrueDBGrid2.Images"), System.Drawing.Image))
        Me.C1TrueDBGrid2.Location = New System.Drawing.Point(3, 16)
        Me.C1TrueDBGrid2.Name = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid2.PrintInfo.PageSettings = CType(resources.GetObject("C1TrueDBGrid2.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1TrueDBGrid2.Size = New System.Drawing.Size(716, 240)
        Me.C1TrueDBGrid2.TabIndex = 4
        Me.C1TrueDBGrid2.PropBag = resources.GetString("C1TrueDBGrid2.PropBag")
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.Add(Me.C1TrueDBGrid1)
        Me.GroupBox4.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox4.Location = New System.Drawing.Point(0, 0)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(722, 151)
        Me.GroupBox4.TabIndex = 0
        Me.GroupBox4.TabStop = False
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("C1TrueDBGrid1.Images"), System.Drawing.Image))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(3, 16)
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.PageSettings = CType(resources.GetObject("C1TrueDBGrid1.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(716, 132)
        Me.C1TrueDBGrid1.TabIndex = 4
        Me.C1TrueDBGrid1.PropBag = resources.GetString("C1TrueDBGrid1.PropBag")
        '
        'C1TrueDBGrid3
        '
        Me.C1TrueDBGrid3.AlternatingRows = True
        Me.C1TrueDBGrid3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid3.FetchRowStyles = True
        Me.C1TrueDBGrid3.FilterBar = True
        Me.C1TrueDBGrid3.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid3.Images.Add(CType(resources.GetObject("C1TrueDBGrid3.Images"), System.Drawing.Image))
        Me.C1TrueDBGrid3.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid3.Name = "C1TrueDBGrid3"
        Me.C1TrueDBGrid3.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid3.PrintInfo.PageSettings = CType(resources.GetObject("C1TrueDBGrid3.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1TrueDBGrid3.Size = New System.Drawing.Size(652, 180)
        Me.C1TrueDBGrid3.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1TrueDBGrid3.TabIndex = 10
        Me.C1TrueDBGrid3.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid3.PropBag = resources.GetString("C1TrueDBGrid3.PropBag")
        '
        'ImageListeDocIcon
        '
        Me.ImageListeDocIcon.ImageStream = CType(resources.GetObject("ImageListeDocIcon.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeDocIcon.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeDocIcon.Images.SetKeyName(0, "PDF.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(1, "Word5.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(2, "Excel1.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(3, "PowerPoint.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(4, "html.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(5, "Mail.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(6, "Document1.ico")
        '
        'cbboxParentTree
        '
        Me.cbboxParentTree.ImageList = Me.ImgListApplikationTree
        Me.cbboxParentTree.Location = New System.Drawing.Point(140, 45)
        Me.cbboxParentTree.Name = "cbboxParentTree"
        Me.cbboxParentTree.SelectedImageIndex = 0
        Me.cbboxParentTree.SelectedNode = Nothing
        Me.cbboxParentTree.Size = New System.Drawing.Size(184, 22)
        Me.cbboxParentTree.TabIndex = 1
        '
        'frmApplikation
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(896, 549)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.Name = "frmApplikation"
        Me.Text = "Applikationsverwaltung"
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.TreeApplikationenContextMenuStrip.ResumeLayout(False)
        Me.pnlApplikationen.ResumeLayout(False)
        Me.pnlApplikationen.PerformLayout()
        Me.TabControlApplikation.ResumeLayout(False)
        Me.TabBasisdaten.ResumeLayout(False)
        Me.TabBasisdaten.PerformLayout()
        Me.GroupBox3.ResumeLayout(False)
        Me.GrpAllgemeineAngaben.ResumeLayout(False)
        Me.GrpAllgemeineAngaben.PerformLayout()
        Me.GrpTechnischeVerantwortung.ResumeLayout(False)
        Me.GrpTechnischeVerantwortung.PerformLayout()
        Me.GrpFachlicheVerantwortung.ResumeLayout(False)
        Me.GrpFachlicheVerantwortung.PerformLayout()
        Me.GrpApplikation.ResumeLayout(False)
        Me.GrpApplikation.PerformLayout()
        Me.TabArchitektur.ResumeLayout(False)
        Me.TabWPI.ResumeLayout(False)
        Me.grpboxInstallation.ResumeLayout(False)
        Me.grpboxInstalliertauf.ResumeLayout(False)
        Me.grpDiverses.ResumeLayout(False)
        Me.grpDiverses.PerformLayout()
        Me.grpboxInstalliertals.ResumeLayout(False)
        Me.grpboxStandardfuer.ResumeLayout(False)
        Me.TabLizenzen.ResumeLayout(False)
        Me.SplitContainer2.Panel1.ResumeLayout(False)
        Me.SplitContainer2.Panel2.ResumeLayout(False)
        Me.SplitContainer2.ResumeLayout(False)
        Me.SplitContainer3.Panel1.ResumeLayout(False)
        Me.SplitContainer3.Panel2.ResumeLayout(False)
        Me.SplitContainer3.ResumeLayout(False)
        Me.GrpLizenzElemente.ResumeLayout(False)
        CType(Me.C1Lizenzvertraege, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpLizenzkäufe.ResumeLayout(False)
        CType(Me.C1Lizenzkäufe, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpLizenzschlüssel.ResumeLayout(False)
        CType(Me.C1Lizenzschluessel, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabTesting.ResumeLayout(False)
        Me.GroupBox13.ResumeLayout(False)
        Me.GroupBox13.PerformLayout()
        Me.GroupBox14.ResumeLayout(False)
        Me.GroupBox14.PerformLayout()
        Me.GroupBox15.ResumeLayout(False)
        Me.GrpAbhaengigkeiten.ResumeLayout(False)
        CType(Me.C1Abhaengigkeiten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.AbhaengigkeitMenuStrip.ResumeLayout(False)
        Me.grpDrehbuch.ResumeLayout(False)
        CType(Me.C1Drehbuch, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DrehbuchMenuStrip.ResumeLayout(False)
        Me.TabKontakte.ResumeLayout(False)
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KontakteMenuStrip.ResumeLayout(False)
        Me.TabReleaseLogbuch.ResumeLayout(False)
        CType(Me.C1ReleaseLogbuch, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ReleaseLogbuchMenuStrip.ResumeLayout(False)
        Me.TabVertragsbeziehungen.ResumeLayout(False)
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.VertragsbeziehungMenuStrip.ResumeLayout(False)
        Me.TabDokumente.ResumeLayout(False)
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DokumenteMenuStrip.ResumeLayout(False)
        Me.TabTicketXPert.ResumeLayout(False)
        Me.TabTicketXPert.PerformLayout()
        Me.grpTicketXpert.ResumeLayout(False)
        Me.grpTicketXpert.PerformLayout()
        Me.TabRisiko.ResumeLayout(False)
        Me.GrpUser.ResumeLayout(False)
        Me.GrpUser.PerformLayout()
        Me.GrpUeberwachung.ResumeLayout(False)
        Me.GrpUeberwachung.PerformLayout()
        Me.GrpSensitiveDaten.ResumeLayout(False)
        Me.GrpSensitiveDaten.PerformLayout()
        Me.TabPage8.ResumeLayout(False)
        Me.GroupBox7.ResumeLayout(False)
        Me.GroupBox7.PerformLayout()
        Me.GroupBox8.ResumeLayout(False)
        Me.GroupBox8.PerformLayout()
        Me.GroupBox6.ResumeLayout(False)
        Me.GroupBox6.PerformLayout()
        Me.TabPage5.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.KontaktAnzeigenToolStripMenuItem_Click -Methode

Anzeigen bzw. bearbeitnen eines Kontaktes

[Visual Basic]
Private Sub KontaktAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmApplikationskontakt(Me.C1Kontakte.Columns("Applikationkontaktnr").Value, 1, Me.Aktuelle_Applikation, False, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.KontaktLöschenToolStripMenuItem_Click -Methode

Vertragskontakt inaktivieren

[Visual Basic]
Private Sub KontaktLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(265) = MsgBoxResult.Yes Then
                Me.Applikation.Applikationskontakt.Delete_Applikationskontakt(Me.C1Kontakte.Columns("Applikationkontaktnr").Value)
                evh.Kontakte_Geloescht()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.KontaktNeuToolStripMenuItem_Click -Methode

Neuer Vertragskontakt erstellen

[Visual Basic]
Private Sub KontaktNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktNeuToolStripMenuItem.Click
        Try
            'Dim i As Integer = Me.Vertragselement.Vertragskontakt.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New frmApplikationskontakt(0, 1, Me.Aktuelle_Applikation, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.KontakteMenuStrip_Opening -Methode

Disable bzw. Enable der Menueinträge

[Visual Basic]
Private Sub KontakteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   KontakteMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontakteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles KontakteMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Kontakte)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Lizenzkauf_Aktualisieren -Methode

Aktualiserung der Grids Lizenzkauf und Lizenzschluessel

[Visual Basic]
Private Sub Lizenzkauf_Aktualisieren()

Quellcode

[Visual Basic]
    Private Sub Lizenzkauf_Aktualisieren()
        Try
            Me.Applikation.Get_Lizenzkauf(Me.C1Lizenzvertraege.Columns("Vertragselementnr").Value, Me.Aktuelle_Applikation)
            Me.C1Lizenzkäufe.DataSource = Me.Applikation.Lizenzkauf
            'Me.Applikation.Vertragselement.Lizenzinformationen.Get_Lizenzkauf(Me.C1Lizenzvertraege.Columns("Vertragselementnr").Value, Me.C1Lizenzkäufe, Me.Aktuelle_Applikation)
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Lizenzkäufe, "Lizenzkauf", Me.Applikation.Lizenzkauf)
            Me.Lizenzschluessel_Aktualisieren()
        Catch ex As Exception
            Exit Sub
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Lizenzschluessel_Aktualisieren -Methode

Aktualiserung der Grids Lizenzkauf und Lizenzschluessel

[Visual Basic]
Private Sub Lizenzschluessel_Aktualisieren()

Quellcode

[Visual Basic]
    Private Sub Lizenzschluessel_Aktualisieren()
        Try
            Me.Applikation.Get_Lizenzschluessel(Me.C1Lizenzkäufe.Columns(0).Value)
            Me.C1Lizenzschluessel.DataSource = Me.Applikation.Lizenzschluessel
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Lizenzschluessel, "Lizenzschluessel", Me.Applikation.Lizenzschluessel)
        Catch ex As Exception
            Exit Sub
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.MassenUpdatesToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub MassenUpdatesToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MassenUpdatesToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MassenUpdatesToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MassenUpdatesToolStripMenuItem.Click
        Dim f As New frmKontaktMassenupdate
        f.ShowDialog()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Abhaengigkeiten -Methode

Dokumetne_Aktualisieren

[Visual Basic]
Private Sub Refresh_Abhaengigkeiten()

Quellcode

[Visual Basic]
    Private Sub Refresh_Abhaengigkeiten()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Abhaengigkeiten.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Abhaengigkeiten.Bookmark

        Me.C1Abhaengigkeiten.Enabled = False

        Me.Applikation.Get_Applikationsabhaengigkeiten(Me.C1Abhaengigkeiten, Me.Applikation.iApplikationNr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Abhaengigkeiten, "ApplikationAbhaengigkeit", Me.Applikation.Applikationabhaengigkeiten.Tabledata)
        If filtertext <> "none" Then Me.C1Abhaengigkeiten.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)
        Try
            Me.C1Abhaengigkeiten.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Abhaengigkeiten.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Dokumente -Methode

Dokumetne_Aktualisieren

[Visual Basic]
Private Sub Refresh_Dokumente()

Quellcode

[Visual Basic]
    Private Sub Refresh_Dokumente()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Dokumente.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Dokumente.Bookmark

        Me.C1Dokumente.Enabled = False

        Me.Applikation.Get_Dokumente(Me.C1Dokumente, Me.ImageListeDocIcon)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Dokumente, "Dokument", Me.Applikation.dokumente)
        If filtertext <> "none" Then Me.C1Dokumente.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1Dokumente.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Dokumente.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Drehbuecher -Methode

Dokumetne_Aktualisieren

[Visual Basic]
Private Sub Refresh_Drehbuecher()

Quellcode

[Visual Basic]
    Private Sub Refresh_Drehbuecher()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Drehbuch.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Drehbuch.Bookmark

        Me.C1Drehbuch.Enabled = False

        Me.Applikation.Get_Drehbuecker(Me.C1Drehbuch, Me.ImageListeDocIcon)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Drehbuch, "Dokument", Me.Applikation.dokumente)
        If filtertext <> "none" Then Me.C1Drehbuch.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)
        Try
            Me.C1Drehbuch.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Drehbuch.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Kontakte -Methode

Kontakte aktualisieren

[Visual Basic]
Private Sub Refresh_Kontakte()

Quellcode

[Visual Basic]
    Private Sub Refresh_Kontakte()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Kontakte.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Kontakte.Bookmark

        Me.C1Kontakte.Enabled = False
        Me.Applikation.Get_Applikationskontakte(Me.C1Kontakte)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Vertragskontakt", Me.Applikation.Applikationskontakte.Tabledata)
        If filtertext <> "none" Then Me.C1Kontakte.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1Kontakte.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1Kontakte.Enabled = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Lizenzen -Methode

[Visual Basic]
Private Function Refresh_Lizenzen() As Object

Quellcode

[Visual Basic]
    Private Function Refresh_Lizenzen()
        Try
            Me.C1Lizenzkäufe.DataSource = Nothing
            Me.C1Lizenzschluessel.DataSource = Nothing
        Catch ex As Exception

        End Try
        Me.Applikation.Get_Vertragslizenzen(Me.C1Lizenzvertraege, Me.Aktuelle_Applikation)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Lizenzvertraege, "ApplikationLizenzvertragselement", Me.Applikation.Lizenzen)
        Me.Lizenzkauf_Aktualisieren()

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Registerlasche -Methode

Aktuelle Registerlasche aktualisieren

[Visual Basic]
Private Sub Refresh_Registerlasche()

Quellcode

[Visual Basic]
    Private Sub Refresh_Registerlasche()
        Select Case Me.TabControlApplikation.SelectedTab.Text
            Case "Vertragsinhalt", "Suchbegriffe"
            Case "Lizenzen"
                Refresh_Lizenzen()
            Case "Dokumente"
                Refresh_Dokumente()
            Case "Kontakte"
                Refresh_Kontakte()
            Case "Ereignisse"
                'Refresh_Ereignisse()
            Case "Vertragsbeziehungen"
                Refresh_Vertragsbeziehungen()
            Case "Testing"
                Refresh_Drehbuecher()
                Refresh_Abhaengigkeiten()
            Case "Architektur"
                Me.Check_Changes()
                Me.DiagramControl1.Init_Diagram()
                Me.DiagramControl1.Refresh()
                Me.DiagramControl1.TempFilePath = Globals.clsapplication.sTmp_filepath
                Me.DiagramControl1.ConnectionString = Globals.sConnectionString
                Me.DiagramControl1.ApplikationNr = Me.Applikation.iApplikationNr.Value
                Me.DiagramControl1.Mitarbeiternr = Globals.clsmitarbeiter.iMitarbeiternr.Value
                Me.FormDataChanged = False
            Case "Release-Logbuch"
                refresh_ReleaseLogbuch()
        End Select
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_ReleaseLogbuch -Methode

Release aktualisieren

[Visual Basic]
Private Sub Refresh_ReleaseLogbuch()

Quellcode

[Visual Basic]
    Private Sub Refresh_ReleaseLogbuch()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1ReleaseLogbuch.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1ReleaseLogbuch.Bookmark
        'Me.C1ReleaseLogbuch.Columns("Releasedatum").NumberFormat = "FormatText Event"
        Me.C1ReleaseLogbuch.Enabled = False
        Me.Applikation.Get_ReleaseLogbuch(Me.C1ReleaseLogbuch, Me.Aktuelle_Applikation)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1ReleaseLogbuch, "ApplikationLogbuch", Me.Applikation.ReleaseLogbooks.Tabledata)
        If filtertext <> "none" Then Me.C1ReleaseLogbuch.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1ReleaseLogbuch.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1ReleaseLogbuch.Enabled = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Refresh_Vertragsbeziehungen -Methode

Applikationen aktualiseren

[Visual Basic]
Private Sub Refresh_Vertragsbeziehungen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Vertragsbeziehungen()
        Try

            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Vertragselemente.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Vertragselemente.Bookmark

        Me.C1Vertragselemente.Enabled = False
        Dim datac1vertragselemente As New DataTable
        datac1vertragselemente = Me.Applikation.Get_Vertragselemente(Me.Applikation.iApplikationNr.Value)
        Me.C1Vertragselemente.DataSource = datac1vertragselemente
        Me.C1Vertragselemente.DataMember = datac1vertragselemente.TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Vertragselemente, "VertragselementApplikation", datac1vertragselemente)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Vertragselemente.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Vertragselemente.Bookmark = bm
        Catch ex As Exception
        End Try

        Me.C1Vertragselemente.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuchAnzeigenToolStripMenuItem_Click -Methode

Anzeigen bzw. bearbeitnen eines Kontaktes

[Visual Basic]
Private Sub ReleaseLogbuchAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReleaseLogbuchAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuchAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReleaseLogbuchAnzeigenToolStripMenuItem.Click
        Dim f As New FrmReleaseLogbuch(Me.C1ReleaseLogbuch.Columns(0).Value, Me.Aktuelle_Applikation, False, Me.FormReadonly)
        f.MdiParent = Me.MdiParent
        f.Show()
        'f.ShowDialog()
        'Me.Refresh_ReleaseLogbuch()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuchLöschenToolStripMenuItem_Click -Methode

Vertragskontakt inaktivieren

[Visual Basic]
Private Sub ReleaseLogbuchLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReleaseLogbuchInaktivierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuchLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReleaseLogbuchInaktivierenToolStripMenuItem.Click
        Try

            If msg.Show_MessageYesNo(855) = MsgBoxResult.Yes Then
                Dim al As New TKB.VV.Applikation.clsApplikationLogbuch
                al.Delete_ApplikationLogubuch(Me.C1ReleaseLogbuch.Columns("ApplikationLogbuchNr").Value)
                al.dispose()
                Me.Refresh_ReleaseLogbuch()
            End If
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuchMenuStrip_Opening -Methode

Disable bzw. Enable der Menueinträge

[Visual Basic]
Private Sub ReleaseLogbuchMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   ReleaseLogbuchMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuchMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles ReleaseLogbuchMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1ReleaseLogbuch)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuchNeuToolStripMenuItem_Click -Methode

Neuer Vertragskontakt erstellen

[Visual Basic]
Private Sub ReleaseLogbuchNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReleaseLogbuchNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuchNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReleaseLogbuchNeuToolStripMenuItem.Click
        Try
            'Dim i As Integer = Me.Vertragselement.Vertragskontakt.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New FrmReleaseLogbuch(0, Me.Aktuelle_Applikation, True, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
            'f.ShowDialog()
            'Me.Refresh_ReleaseLogbuch()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuch_DoubleClick -Methode

Doppelklick auf einem Kontakt

[Visual Basic]
Private Sub ReleaseLogbuch_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1ReleaseLogbuch.DoubleClick

Parameter

sender
e

Hinweise

Ist der MenuEintrag KontaktAnzeigenToolStripMenuItem disabled, wird der Doppelklick ignoriert

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuch_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1ReleaseLogbuch.DoubleClick

        If Me.ReleaseLogbuchAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            Me.ReleaseLogbuchAnzeigenToolStripMenuItem_Click(sender, e)

        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ReleaseLogbuch_MouseDown -Methode

Mousedown Kontakte

[Visual Basic]
Private Sub ReleaseLogbuch_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1ReleaseLogbuch.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReleaseLogbuch_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1ReleaseLogbuch.MouseDown
        Me.C1ReleaseLogbuch.Bookmark = Me.C1ReleaseLogbuch.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Applikation.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Applikation.iParentID = New SqlInt32(CType(Me.cbboxParentTree.SelectedNode.Tag, Int32))
        Applikation.iApplikationVerantwortungNr = New SqlInt32(CType(Me.cbboxVerantwortung.SelectedValue, Int32))
        Applikation.iApplikationTeamnr = New SqlInt32(CType(Me.cbboxTeam.SelectedValue, Int32))
        Applikation.iApplikationKategorieNr = New SqlInt32(CType(Me.cbboxKategorie.SelectedValue, Int32))
        Applikation.iMarktbereichnr = New SqlInt32(CType(Me.cbboxMarktbereich.SelectedValue, Int32))
        If IsDate(Me.txtInaktivseit.Text) Then
            Applikation.daInaktivseit = New SqlDateTime(CType(Me.txtInaktivseit.Text, DateTime))
        Else
            Applikation.daInaktivseit = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Applikation.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        Applikation.bAlsProdukt = New SqlBoolean(CType(Me.cbalsProdukt.Checked = True, Boolean))
        Applikation.bNurLizenz = New SqlBoolean(CType(Me.cbLizenzerfassung.Checked = True, Boolean))
        Applikation.sPrioWiederanlauf = New SqlString(CType(Me.txtPrioWiederanlauf.Text, String))
        Applikation.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
        Applikation.iRfcBoardNr = New SqlInt32(CType(Me.cboxRFCBoard.SelectedValue, Int32))
        Applikation.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked = True, Boolean))
        Applikation.bRAS = New SqlBoolean(CType(Me.cbRAS.Checked = True, Boolean))
        Applikation.sDatenbankname = New SqlString(CType(Me.txtDBName.Text, String))
        Applikation.sAnzahl_Installationen = New SqlString(CType(Me.txtAnzInstallationen.Text, String))
        Applikation.sKurzbeschreibung = New SqlString(CType(Me.txtKurzbeschreibung.Text, String))
        If Me.cbboxTestaufwand.SelectedText = "" Then Me.cbboxTestaufwand.SelectedValue = 1
        Applikation.sTest_Aufwand = New SqlString(CType(Me.cbboxTestaufwand.SelectedValue, String))
        Applikation.sTest_Arbeitsplaetze = New SqlString(CType(Me.txtTestArbeitsplaetze.Text, String))
        Applikation.sTest_Abhaengigkeiten = New SqlString(CType(Me.txtAbhaengigkeiten.Text, String))
        Applikation.sTest_Bemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Applikation.bTicketXPertVerwendung = New SqlBoolean(CType(Me.cbTicketXPertVerwendung.Checked = True, Boolean))
        Applikation.bTicketXPert_WPIAnzeigen = New SqlBoolean(CType(Me.cbWPIAnzeigen.Checked = True, Boolean))
        Applikation.sTicketXPert_Preis = New SqlString(CType(Me.txtWPIPreis.Text, String))
        Applikation.sTicketXPert_Preis_Einmalig = New SqlString(CType(Me.txtPreisEinmalig.Text, String))
        Applikation.bTicketXPert_AMAnzeigen = New SqlBoolean(CType(Me.cbAMAnzeigen.Checked = True, Boolean))
        Applikation.iTicketXPert_ApplikationKritikalitaetTypNr = New SqlInt32(CType(Me.cbboxKritikalität.SelectedValue, Int32))
        Applikation.iTicketXPert_ApplikationSMLTypNr = New SqlInt32(CType(Me.cbboxSLM.SelectedValue, Int32))

        Me.Applikation.bSensitiveDaten = New SqlBoolean(CType(Me.cbSensitiveDaten.Checked, Boolean))
        Me.Applikation.sSensitiveDatenBemerkung = New SqlString(CType(Me.txtSensitiveDaten.Text, String))
        Me.Applikation.iSensitiveDatenAdministriertdurch = New SqlInt32(CType(Me.cbboxAdministriertdurch.SelectedValue, Int32))

        Me.Applikation.sSensitiveDatenUeberwachungBemerkung = New SqlString(CType(Me.TxtUeberwachung.Text, String))
        Me.Applikation.iSensitiveDatenUeberwachungPeriodizitaet = New SqlInt32(CType(Me.cbboxPeriodizitaet.SelectedValue, Int32))
        Me.Applikation.sSensitiveDatenUserBemerkung = New SqlString(CType(Me.TxtUser.Text, String))
        Me.Applikation.iSensitiveDatenAnzahlComit = New SqlInt32(CType(Me.TxtAnzComit.Text, Int32))
        Me.Applikation.iSensitiveDatenAnzahlExterne = New SqlInt32(CType(Me.txtAnzExterne.Text, Int32))

        Applikation.Save_CheckedData(Me.lboxInstalliertauf, 1)
        Applikation.Save_CheckedData(Me.lboxInstalliertals, 2)
        Applikation.Save_CheckedData(Me.lboxStandardFuer, 3)

        Applikation.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.Set_Checkedlistbox -Methode

[Visual Basic]
Private Sub Set_Checkedlistbox( _
   ByRef clb As CheckedListBox, _
   ByRef data As DataTable _
)

Parameter

clb
data

Quellcode

[Visual Basic]
    Private Sub Set_Checkedlistbox(ByRef clb As CheckedListBox, ByRef data As DataTable)
        Dim i As Integer
        For i = 0 To clb.Items.Count - 1
            clb.SetItemCheckState(i, CheckState.Unchecked)
        Next

        Dim chk As Integer = 0
        Dim ii As Integer
        Dim oc As CheckedListBox.ObjectCollection = clb.Items
        For i = 0 To data.Rows.Count - 1
            For ii = 0 To oc.Count - 1
                If oc.Item(ii).item(0) = data.Rows(i).Item(2) Then
                    clb.SetItemCheckState(ii, CheckState.Checked)
                End If
            Next
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Applikation.Create_Copy(Me.Applikation.iApplikationNr.Value))
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(295) = MsgBoxResult.Yes Then
            Me.Applikation.Delete_Applikation(Me.Applikation.iApplikationNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnFilterAufheben_Click -Methode

[Visual Basic]
Private Sub TSBtnFilterAufheben_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnFilterAufheben.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnFilterAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnFilterAufheben.Click
        Me.tstxtSuche.Text = ""
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.cboxNurAktive.Checked)
        Try
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        Catch ex As Exception

        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Applikation.Add_New)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtmutiert_am.Text = Me.Applikation.daMutiert_am.ToString
        Me.FormDataChanged = False
        If Me.tstxtSuche.Text <> "" Then
            Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.cboxNurAktive.Checked)
        Else
            Treeviewdata.Load_Tree(Me.TreeApplikationen, False, "", Me.cboxNurAktive.Checked)
        End If
        Me.TreeApplikationen.SelectedNode = Treeviewdata.FindNode(Me.TreeApplikationen.Nodes, Me.Applikation.iApplikationNr.Value, "")
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TSBtnSuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        Dim i As Integer
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.cboxNurAktive.Checked)
        Try
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TabControlApplikation_SelectedIndexChanged -Methode

Index-Wechsel auf TabControlApplikation

[Visual Basic]
Private Sub TabControlApplikation_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabControlApplikation.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TabControlApplikation_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControlApplikation.SelectedIndexChanged
        Refresh_Registerlasche()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ToolStripButton1_Click -Methode

[Visual Basic]
Private Sub ToolStripButton1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnApplReport.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ToolStripButton1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnApplReport.Click
        Dim auswertungen As New TKB.Auswertung.clsAuswertung
        Dim SQLWhere As String = ""
        Dim Auswertungsdaten As New DataTable

        auswertungen.Get_Auswertung(999)
        Auswertungsdaten = auswertungen.Get_Auswertungsdaten(auswertungen.Auswertung.sSQL.Value, Me.Applikation.iApplikationNr.Value)
        Dim f As New frmcrreporting(Auswertungsdaten, auswertungen.Auswertung.iAuswertungNr.Value, auswertungen, False)
        f.MdiParent = Me.MdiParent
        Me.Cursor = Cursors.Default
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.ToolStripButton1_Click_1 -Methode

[Visual Basic]
Private Sub ToolStripButton1_Click_1( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ToolStripButton1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ToolStripButton1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ToolStripButton1.Click
        If Not Me.FormReadonly Then Check_Changes()
        Dim i As Integer
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtArchitektur.Text, Me.cboxNurAktive.Checked, True)
        Try
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
            Me.tstxtArchitektur.Text = ""
        Catch ex As Exception

        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Click
        Me.TreeApplikationen.CollapseAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click -Methode

Alle Knoten öffnen

[Visual Basic]
Private Sub TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Click
        Me.TreeApplikationen.ExpandAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.TreeApplikationen_AfterSelect -Methode

[Visual Basic]
Private Sub TreeApplikationen_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeApplikationen.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationen_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeApplikationen.AfterSelect
        If Me.Check_Changes = False Then Exit Sub
        If Me.TreeApplikationen.SelectedNode.Tag < 1 Then
            Me.TabControlApplikation.Enabled = False
            Exit Sub
        End If

        Me.TabControlApplikation.Enabled = True
        Me.Aktuelle_Applikation = Me.TreeApplikationen.SelectedNode.Tag
        Me.Get_Data(Me.Aktuelle_Applikation)
        Me.Refresh_Registerlasche()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.VertragsbeziehungMenuStrip_Opening -Methode

VertragsbeziehungMenuStrip Opening

[Visual Basic]
Private Sub VertragsbeziehungMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   VertragsbeziehungMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragsbeziehungMenuStrip_Opening(ByVal sender As System.Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles VertragsbeziehungMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Vertragselemente)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.VertragselementAnzeigenToolStripMenuItem_Click -Methode

Anzeige Vertragselement

[Visual Basic]
Private Sub VertragselementAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragselementAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragselementAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragselementAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragselement(Me.C1Vertragselemente.Columns(1).Value, Me.FormReadonly, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.btnDrehbuchanzeigen_Click -Methode

[Visual Basic]
Private Sub btnDrehbuchanzeigen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnDrehbuchanzeigen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnDrehbuchanzeigen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDrehbuchanzeigen.Click
        Dim i As Integer = 0
        i = Me.Applikation.Dokument.Exists_Testdrehbuch(Me.Applikation.iApplikationNr.Value)
        If i > 0 Then
            Me.Applikation.Dokument.Show_Doc(i)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.btnSearchAppl_Click -Methode

[Visual Basic]
Private Sub btnSearchAppl_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnSearchAppl.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSearchAppl_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSearchAppl.Click
        Try
            Dim f As New frmVertragselementApplikation(0, False)
            f.ShowDialog()
            If f.SelectedApplication <> 0 Then
                Me.cbboxParentTree.SelectedNode = Me.TreeParent.FindNode(Me.cbboxParentTree.TreeView.Nodes, f.SelectedApplication, "")
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.cbTicketXPertVerwendung_CheckedChanged -Methode

[Visual Basic]
Private Sub cbTicketXPertVerwendung_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbTicketXPertVerwendung.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbTicketXPertVerwendung_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbTicketXPertVerwendung.CheckedChanged
        If Me.cbTicketXPertVerwendung.Checked = False Then
            Me.grpTicketXpert.Enabled = False
        Else
            Me.grpTicketXpert.Enabled = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.cbboxVerantwortung_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cbboxVerantwortung_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbboxVerantwortung.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbboxVerantwortung_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbboxVerantwortung.SelectedIndexChanged
        Try
            Me.Applikation.Refresh_Teams(Me.cbboxVerantwortung.SelectedValue)
            If Me.Applikation.Teams.Rows.Count = 0 Then
                Me.cbboxTeam.Enabled = False
            Else
                Me.cbboxTeam.Enabled = True
                Me.cbboxTeam.DataSource = Me.Applikation.Teams
                Me.cbboxTeam.DisplayMember = "Bezeichnung"
                Me.cbboxTeam.ValueMember = "Keyvalue"
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.cboxNurAktive_CheckedChanged -Methode

[Visual Basic]
Private Sub cboxNurAktive_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxNurAktive.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxNurAktive_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxNurAktive.CheckedChanged
        If Me.Check_Changes Then
            If Me.tstxtSuche.Text <> "" Then
                Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.cboxNurAktive.Checked)
                Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
                Me.FormDataChanged = False
            Else
                Treeviewdata.Load_Tree(Me.TreeApplikationen, False, "", Me.cboxNurAktive.Checked)
                Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
                Me.FormDataChanged = False
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.dtPickerInaktivSeit_ValueChanged -Methode

[Visual Basic]
Private Sub dtPickerInaktivSeit_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerInaktivSeit.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub dtPickerInaktivSeit_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles dtPickerInaktivSeit.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next
        Me.txtInaktivseit_Leave(sender, e)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.evh_FormularReleaseLogbuchClosed -Methode

[Visual Basic]
Private Sub evh_FormularReleaseLogbuchClosed() Handles  _
   evh.FormularReleaseLogbuchClosed

Quellcode

[Visual Basic]
    Private Sub evh_FormularReleaseLogbuchClosed() Handles evh.FormularReleaseLogbuchClosed
        Me.Refresh_ReleaseLogbuch()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.evh_FormularVertragselementApplikation_Closed -Methode

[Visual Basic]
Private Sub evh_FormularVertragselementApplikation_Closed() Handles  _
   evh.Update_Uebersicht

Quellcode

[Visual Basic]
    Private Sub evh_FormularVertragselementApplikation_Closed() Handles evh.Update_Uebersicht
        Try
            Me.Refresh_Registerlasche()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.frmApplikation_Load -Methode

[Visual Basic]
Private Sub frmApplikation_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmApplikation_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, "", Me.cboxNurAktive.Checked)
        If Anzeige = True Then
            Me.FormReadonly = True
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        sec.Set_Form_Security(Me)
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        Me.cboxRFCBoard.DataSource = Applikation.RFCBoards
        Me.cboxRFCBoard.DisplayMember = "Bezeichnung"
        Me.cboxRFCBoard.ValueMember = "Keyvalue"

        Me.cbboxVerantwortung.DataSource = Applikation.Verantwortungen
        Me.cbboxVerantwortung.DisplayMember = "Bezeichnung"
        Me.cbboxVerantwortung.ValueMember = "Keyvalue"

        Me.cbboxKategorie.DataSource = Applikation.kategorien
        Me.cbboxKategorie.DisplayMember = "Bezeichnung"
        Me.cbboxKategorie.ValueMember = "ApplikationKategorieNr"

        Me.cbboxMarktbereich.DataSource = Applikation.Marktbereiche
        Me.cbboxMarktbereich.DisplayMember = "Bezeichnung"
        Me.cbboxMarktbereich.ValueMember = "Keyvalue"

        Me.cbboxKritikalität.DataSource = Applikation.Kritikalitaeten
        Me.cbboxKritikalität.DisplayMember = "Bezeichnung"
        Me.cbboxKritikalität.ValueMember = "ApplikationKritikalitaetTypNr"

        Me.cbboxSLM.DataSource = Applikation.SLMs
        Me.cbboxSLM.DisplayMember = "Bezeichnung"
        Me.cbboxSLM.ValueMember = "ApplikationSLMTypNr"

        Me.lboxInstalliertals.DataSource = Applikation.Installiertals
        Me.lboxInstalliertals.DisplayMember = "Bezeichnung"
        Me.lboxInstalliertals.ValueMember = "InstallationAlsTypNr"

        Me.lboxInstalliertauf.DataSource = Applikation.Installiertauf
        Me.lboxInstalliertauf.DisplayMember = "Bezeichnung"
        Me.lboxInstalliertauf.ValueMember = "InstallationTypNr"

        Me.lboxStandardFuer.DataSource = Applikation.InstallationStandard
        Me.lboxStandardFuer.DisplayMember = "Bezeichnung"
        Me.lboxStandardFuer.ValueMember = "ApplikationStandardTypNr"

        Me.cbboxTestaufwand.DataSource = Applikation.TestAufwendungen
        Me.cbboxTestaufwand.DisplayMember = "Bezeichnung"
        Me.cbboxTestaufwand.ValueMember = "ApplikationTestAZNr"

        Me.cbboxPeriodizitaet.DataSource = Me.Applikation.Periodizitäten
        Me.cbboxPeriodizitaet.DisplayMember = "Bezeichnung"
        Me.cbboxPeriodizitaet.ValueMember = "Periodizitaetnr"

        Me.cbboxAdministriertdurch.DataSource = Me.Applikation.SDAdministratoren
        Me.cbboxAdministriertdurch.DisplayMember = "Bezeichnung"
        Me.cbboxAdministriertdurch.ValueMember = "SDAdministratorNr"

        cbboxVerantwortung_SelectedIndexChanged(sender, e)

        TreeParent.Load_Tree(Me.cbboxParentTree.TreeView, True)

        AddChanges(Me)
        If Me.Aktuelle_Applikation <> 0 Then
            Me.TreeApplikationen.SelectedNode = Me.Treeviewdata.FindNode(Me.TreeApplikationen.Nodes, Me.Aktuelle_Applikation, "")
        End If
        '        Get_Data(Me.Aktuelle_Applikation)
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
        If Me.Aktuelle_Applikation <> 0 Then
            Me.TreeApplikationen.SelectedNode = Me.Treeviewdata.FindNode(Me.TreeApplikationen.Nodes, Me.Aktuelle_Applikation, Me.Aktuelle_Applikation)
        Else
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        End If
        Me.DiagramControl1.FormReadOnly = Me.FormReadonly
        'Me.DiagramControl1.FormReadOnly = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.tstxtArchitektur_KeyDown -Methode

[Visual Basic]
Private Sub tstxtArchitektur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   tstxtArchitektur.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tstxtArchitektur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles tstxtArchitektur.KeyDown
        If e.KeyCode = Keys.Enter Then
            ToolStripButton1_Click_1(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.tstxtSuche_KeyDown -Methode

[Visual Basic]
Private Sub tstxtSuche_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   tstxtSuche.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tstxtSuche_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles tstxtSuche.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.TSBtnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation.txtInaktivseit_Leave -Methode

[Visual Basic]
Private Sub txtInaktivseit_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtInaktivseit.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtInaktivseit_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtInaktivseit.Leave
        If Trim(Me.txtInaktivseit.Text) <> ".  ." Then
            Me.cbAktiv.Checked = False
        Else
            Me.cbAktiv.Checked = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation-Felder

frmApplikation Übersicht

Felder

private field Aktuelle_Applikation

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikation

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field TreeParent

Unterstützt von .NET Compact Framework
private field Treeviewdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikation -Klasse


Aktuelle_Applikation -Feld

[Visual Basic]
Private Aktuelle_Applikation As Integer

Quellcode

[Visual Basic]
    Dim Aktuelle_Applikation As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


Applikation -Feld

[Visual Basic]
Private Applikation As clsApplikation

Quellcode

[Visual Basic]
    Dim Applikation As New TKB.VV.Applikation.clsApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


TreeParent -Feld

[Visual Basic]
Private TreeParent As clsApplikationTree

Quellcode

[Visual Basic]
    Dim TreeParent As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


Treeviewdata -Feld

[Visual Basic]
Private Treeviewdata As clsApplikationTree

Quellcode

[Visual Basic]
    Dim Treeviewdata As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikationAbhaengigkeit -Klasse

For a list of all members of this type, see frmApplikationAbhaengigkeit-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplikationAbhaengigkeit

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmApplikationAbhaengigkeit
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplikationAbhaengigkeit-Member


frmApplikationAbhaengigkeit-Member

frmApplikationAbhaengigkeit Übersicht

Öffentliche Konstruktoren

public constructor frmApplikationAbhaengigkeit -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnApplikationSuche2_Click Unterstützt von .NET Compact Framework |
private method btnApplikationsuche1_Click Unterstützt von .NET Compact Framework |
private method frmReferenzvertraege_Load Unterstützt von .NET Compact Framework |

Felder

private field Aktuelle_Applikation1

Unterstützt von .NET Compact Framework
private field Aktuelle_Applikation2

Unterstützt von .NET Compact Framework
private field Akutelle_Referenz

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikationabhaengigkeitdata

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikationAbhaengigkeit -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void frmApplikationAbhaengigkeit();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Integer, Boolean, Optional Boolean)
[C#] public System.Void frmApplikationAbhaengigkeit(int, int, bool, bool);

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit-Methoden

frmApplikationAbhaengigkeit Übersicht

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnApplikationSuche2_Click Unterstützt von .NET Compact Framework |
private method btnApplikationsuche1_Click Unterstützt von .NET Compact Framework |
private method frmReferenzvertraege_Load Unterstützt von .NET Compact Framework |

frmApplikationAbhaengigkeit -Klasse


frmApplikationAbhaengigkeit.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.Applikationabhaengigkeitdata.Neuer_Datensatz = True Then Me.Applikationabhaengigkeitdata.Delete(Me.Applikationabhaengigkeitdata.iApplikationAbhaengigkeitNr.Value)
            Globals.MyEventHanlder.Refernzvertrag_Closed()
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Applikationabhaengigkeitnr As Integer _
)

Parameter

Applikationabhaengigkeitnr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Applikationabhaengigkeitnr As Integer)
        Try
            Me.Applikationabhaengigkeitdata.Get_Applikationabhaengigkeit(Applikationabhaengigkeitnr)
            Me.Aktuelle_Applikation1 = Me.Applikationabhaengigkeitdata.iApplikationnr1.Value
            Me.Aktuelle_Applikation2 = Me.Applikationabhaengigkeitdata.iApplikationnr2.Value

            Me.txtApplikation1.Text = Me.Applikationabhaengigkeitdata.Applname1
            Me.txtApplikation2.Text = Me.Applikationabhaengigkeitdata.Applname2

            Me.txtErstelltam.Text = Me.Applikationabhaengigkeitdata.daErstellt_am.ToString
            Me.txtMutiertam.Text = Applikationabhaengigkeitdata.daMutiert_am.ToString
            Me.txtMutierer.Text = Applikationabhaengigkeitdata.iMutierer.ToString
            Try
                Me.cbaktiv.Checked = Applikationabhaengigkeitdata.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            Me.cboxSecurityLevel.SelectedValue = Applikationabhaengigkeitdata.iSecurityLevelNr.Value

            Me.txtBemerkung.Text = Applikationabhaengigkeitdata.sBeschreibung.ToString
            If Not Anzeige Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
        End Try
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplikationAbhaengigkeit))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.btnApplikationSuche2 = New System.Windows.Forms.Button
        Me.txtApplikation2 = New System.Windows.Forms.TextBox
        Me.lblApplikation2 = New System.Windows.Forms.Label
        Me.btnApplikationsuche1 = New System.Windows.Forms.Button
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtApplikation1 = New System.Windows.Forms.TextBox
        Me.lblApplikation1 = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(645, 24)
        Me.MenuStrip1.TabIndex = 11
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(645, 25)
        Me.ToolStrip1.TabIndex = 12
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'btnApplikationSuche2
        '
        Me.btnApplikationSuche2.Image = CType(resources.GetObject("btnApplikationSuche2.Image"), System.Drawing.Image)
        Me.btnApplikationSuche2.Location = New System.Drawing.Point(407, 88)
        Me.btnApplikationSuche2.Name = "btnApplikationSuche2"
        Me.btnApplikationSuche2.Size = New System.Drawing.Size(20, 20)
        Me.btnApplikationSuche2.TabIndex = 185
        Me.btnApplikationSuche2.Text = "Button1"
        Me.btnApplikationSuche2.UseVisualStyleBackColor = True
        '
        'txtApplikation2
        '
        Me.txtApplikation2.Location = New System.Drawing.Point(143, 88)
        Me.txtApplikation2.Name = "txtApplikation2"
        Me.txtApplikation2.ReadOnly = True
        Me.txtApplikation2.Size = New System.Drawing.Size(268, 20)
        Me.txtApplikation2.TabIndex = 170
        '
        'lblApplikation2
        '
        Me.lblApplikation2.AutoSize = True
        Me.lblApplikation2.Location = New System.Drawing.Point(12, 91)
        Me.lblApplikation2.Name = "lblApplikation2"
        Me.lblApplikation2.Size = New System.Drawing.Size(65, 13)
        Me.lblApplikation2.TabIndex = 184
        Me.lblApplikation2.Text = "Applikation2"
        '
        'btnApplikationsuche1
        '
        Me.btnApplikationsuche1.Image = CType(resources.GetObject("btnApplikationsuche1.Image"), System.Drawing.Image)
        Me.btnApplikationsuche1.Location = New System.Drawing.Point(407, 64)
        Me.btnApplikationsuche1.Name = "btnApplikationsuche1"
        Me.btnApplikationsuche1.Size = New System.Drawing.Size(20, 20)
        Me.btnApplikationsuche1.TabIndex = 183
        Me.btnApplikationsuche1.Text = "Button1"
        Me.btnApplikationsuche1.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(538, 159)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 176
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(459, 162)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 182
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(538, 107)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 174
        Me.txtMutierer.TabStop = False
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(538, 84)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.ReadOnly = True
        Me.txtMutiertam.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiertam.TabIndex = 173
        Me.txtMutiertam.TabStop = False
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(538, 60)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.ReadOnly = True
        Me.txtErstelltam.Size = New System.Drawing.Size(79, 20)
        Me.txtErstelltam.TabIndex = 172
        Me.txtErstelltam.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(460, 111)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 181
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(460, 88)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 180
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(461, 63)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 179
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(457, 133)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(94, 20)
        Me.cbaktiv.TabIndex = 175
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtApplikation1
        '
        Me.txtApplikation1.Location = New System.Drawing.Point(143, 64)
        Me.txtApplikation1.Name = "txtApplikation1"
        Me.txtApplikation1.ReadOnly = True
        Me.txtApplikation1.Size = New System.Drawing.Size(268, 20)
        Me.txtApplikation1.TabIndex = 169
        '
        'lblApplikation1
        '
        Me.lblApplikation1.AutoSize = True
        Me.lblApplikation1.Location = New System.Drawing.Point(12, 67)
        Me.lblApplikation1.Name = "lblApplikation1"
        Me.lblApplikation1.Size = New System.Drawing.Size(59, 13)
        Me.lblApplikation1.TabIndex = 178
        Me.lblApplikation1.Text = "Applikation"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(143, 119)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(268, 75)
        Me.txtBemerkung.TabIndex = 171
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(12, 122)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 177
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'frmApplikationAbhaengigkeit
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(645, 206)
        Me.Controls.Add(Me.btnApplikationSuche2)
        Me.Controls.Add(Me.txtApplikation2)
        Me.Controls.Add(Me.lblApplikation2)
        Me.Controls.Add(Me.btnApplikationsuche1)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiertam)
        Me.Controls.Add(Me.txtErstelltam)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiertam)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.txtApplikation1)
        Me.Controls.Add(Me.lblApplikation1)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplikationAbhaengigkeit"
        Me.Text = "Applikationsabhängigkeit"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Me.Applikationabhaengigkeitdata.iApplikationAbhaengigkeitNr = New SqlInt32(CType(Me.Akutelle_Referenz, Int32))
        Me.Applikationabhaengigkeitdata.iApplikationnr1 = New SqlInt32(CType(Me.Aktuelle_Applikation1, Int32))
        Me.Applikationabhaengigkeitdata.iApplikationnr2 = New SqlInt32(CType(Me.Aktuelle_Applikation2, Int32))

        Me.Applikationabhaengigkeitdata.sBeschreibung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Me.Applikationabhaengigkeitdata.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Me.Applikationabhaengigkeitdata.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Applikationabhaengigkeitdata.Delete_Referenz(Me.Applikationabhaengigkeitdata.iApplikationAbhaengigkeitNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Applikationabhaengigkeitdata.Add_New(Me.Aktuelle_Applikation1))
        Me.Applikationabhaengigkeitdata.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtMutiertam.Text = Me.Applikationabhaengigkeitdata.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.btnApplikationSuche2_Click -Methode

[Visual Basic]
Private Sub btnApplikationSuche2_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnApplikationSuche2.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnApplikationSuche2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnApplikationSuche2.Click
        Dim f As New frmVertragselementApplikation(Me.Aktuelle_Applikation1, True)
        f.ShowDialog()
        If f.SelectedApplication <> 0 Then
            Me.Applikationabhaengigkeitdata.iApplikationnr2 = New SqlInt32(CType(f.SelectedApplication, Int32))
            Me.txtApplikation2.Text = Me.Applikationabhaengigkeitdata.Applname2
            Me.Aktuelle_Applikation2 = Me.Applikationabhaengigkeitdata.iApplikationnr2.Value
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.btnApplikationsuche1_Click -Methode

[Visual Basic]
Private Sub btnApplikationsuche1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnApplikationsuche1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnApplikationsuche1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnApplikationsuche1.Click
        Try
            Dim f As New frmVertragselementApplikation(Me.Aktuelle_Applikation1, True)
            f.ShowDialog()
            If f.SelectedApplication <> 0 Then
                Me.Applikationabhaengigkeitdata.iApplikationnr1 = New SqlInt32(CType(f.SelectedApplication, Int32))
                Me.txtApplikation1.Text = Me.Applikationabhaengigkeitdata.Applname1
                Me.Aktuelle_Applikation1 = Me.Applikationabhaengigkeitdata.iApplikationnr1.Value

            End If
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.frmReferenzvertraege_Load -Methode

[Visual Basic]
Private Sub frmReferenzvertraege_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmReferenzvertraege_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSave.Enabled = False
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        AddChanges(Me)
        Get_Data(Me.Akutelle_Referenz)
        If Me.Neuer_Datensatz = True Then
            Me.Applikationabhaengigkeitdata.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit-Felder

frmApplikationAbhaengigkeit Übersicht

Felder

private field Aktuelle_Applikation1

Unterstützt von .NET Compact Framework
private field Aktuelle_Applikation2

Unterstützt von .NET Compact Framework
private field Akutelle_Referenz

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field Applikationabhaengigkeitdata

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikationAbhaengigkeit -Klasse


Aktuelle_Applikation1 -Feld

[Visual Basic]
Private Aktuelle_Applikation1 As Integer

Quellcode

[Visual Basic]
    Private Aktuelle_Applikation1 As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Aktuelle_Applikation2 -Feld

[Visual Basic]
Private Aktuelle_Applikation2 As Integer

Quellcode

[Visual Basic]
    Private Aktuelle_Applikation2 As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Akutelle_Referenz -Feld

[Visual Basic]
Private Akutelle_Referenz As Integer

Quellcode

[Visual Basic]
    Private Akutelle_Referenz As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Applikationabhaengigkeitdata -Feld

[Visual Basic]
Private Applikationabhaengigkeitdata As clsApplikationsabhaengigkeit

Quellcode

[Visual Basic]
    Dim Applikationabhaengigkeitdata As New TKB.VV.Applikation.clsApplikationsabhaengigkeit

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationNeu -Klasse

For a list of all members of this type, see frmApplikationNeu-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplikationNeu

[Visual Basic]
Public Class frmApplikationNeu
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplikationNeu-Member


frmApplikationNeu-Member

frmApplikationNeu Übersicht

Öffentliche Konstruktoren

public constructor frmApplikationNeu -Konstructor

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method cbboxKategorie_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method lblKategorie_Click

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmApplikationNeu -Klasse


frmApplikationNeu -Konstructor

[Visual Basic]
Public Sub New( _
   ByRef kategorien As DataTable, _
   ByRef Tree As TreeView _
)

Parameter

kategorien
Tree

Quellcode

[Visual Basic]
    Sub New(ByRef kategorien As DataTable, ByRef Tree As TreeView)
        Me.cbboxKategorie.DataSource = kategorien
        Me.cbboxKategorie.DisplayMember = "Bezeichnung"
        Me.cbboxKategorie.ValueMember = "Kategorienr"

        'Me.cbboxParentTree.TreeView.Nodes

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationNeu-Methoden

frmApplikationNeu Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method cbboxKategorie_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method lblKategorie_Click

Unterstützt von .NET Compact Framework

frmApplikationNeu -Klasse


frmApplikationNeu.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationNeu.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplikationNeu))
        Me.cbboxParentTree = New Vertragsverwaltung.Controls.ComboBoxTree
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblKategorie = New System.Windows.Forms.Label
        Me.lblParentElement = New System.Windows.Forms.Label
        Me.cbboxKategorie = New System.Windows.Forms.ComboBox
        Me.lblApplikation = New System.Windows.Forms.Label
        Me.btnOK = New System.Windows.Forms.Button
        Me.btnAbbruch = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'cbboxParentTree
        '
        Me.cbboxParentTree.ImageIndex = -1
        Me.cbboxParentTree.ImageList = Nothing
        Me.cbboxParentTree.Location = New System.Drawing.Point(139, 40)
        Me.cbboxParentTree.Name = "cbboxParentTree"
        Me.cbboxParentTree.SelectedImageIndex = -1
        Me.cbboxParentTree.SelectedNode = Nothing
        Me.cbboxParentTree.Size = New System.Drawing.Size(204, 22)
        Me.cbboxParentTree.TabIndex = 1
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(139, 15)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(204, 20)
        Me.txtBezeichnung.TabIndex = 0
        '
        'lblKategorie
        '
        Me.lblKategorie.AutoSize = True
        Me.lblKategorie.Location = New System.Drawing.Point(6, 71)
        Me.lblKategorie.Name = "lblKategorie"
        Me.lblKategorie.Size = New System.Drawing.Size(52, 13)
        Me.lblKategorie.TabIndex = 133
        Me.lblKategorie.Text = "Kategorie"
        '
        'lblParentElement
        '
        Me.lblParentElement.AutoSize = True
        Me.lblParentElement.Location = New System.Drawing.Point(6, 44)
        Me.lblParentElement.Name = "lblParentElement"
        Me.lblParentElement.Size = New System.Drawing.Size(122, 13)
        Me.lblParentElement.TabIndex = 132
        Me.lblParentElement.Text = "übergeordnetes Element"
        '
        'cbboxKategorie
        '
        Me.cbboxKategorie.FormattingEnabled = True
        Me.cbboxKategorie.Location = New System.Drawing.Point(139, 68)
        Me.cbboxKategorie.Name = "cbboxKategorie"
        Me.cbboxKategorie.Size = New System.Drawing.Size(204, 21)
        Me.cbboxKategorie.TabIndex = 2
        '
        'lblApplikation
        '
        Me.lblApplikation.AutoSize = True
        Me.lblApplikation.Location = New System.Drawing.Point(6, 18)
        Me.lblApplikation.Name = "lblApplikation"
        Me.lblApplikation.Size = New System.Drawing.Size(93, 13)
        Me.lblApplikation.TabIndex = 129
        Me.lblApplikation.Text = "Applikation/Modul"
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(74, 119)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.Size = New System.Drawing.Size(75, 23)
        Me.btnOK.TabIndex = 3
        Me.btnOK.Text = "OK"
        Me.btnOK.UseVisualStyleBackColor = True
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(191, 119)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(75, 23)
        Me.btnAbbruch.TabIndex = 4
        Me.btnAbbruch.Text = "Abbruch"
        Me.btnAbbruch.UseVisualStyleBackColor = True
        '
        'frmApplikationNeu
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(368, 168)
        Me.Controls.Add(Me.btnAbbruch)
        Me.Controls.Add(Me.btnOK)
        Me.Controls.Add(Me.cbboxParentTree)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.lblKategorie)
        Me.Controls.Add(Me.lblParentElement)
        Me.Controls.Add(Me.cbboxKategorie)
        Me.Controls.Add(Me.lblApplikation)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplikationNeu"
        Me.Text = "Neue Applikation/Modul eröffnen"
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationNeu.cbboxKategorie_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cbboxKategorie_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbboxKategorie.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbboxKategorie_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbboxKategorie.SelectedIndexChanged

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationNeu.lblKategorie_Click -Methode

[Visual Basic]
Private Sub lblKategorie_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   lblKategorie.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub lblKategorie_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles lblKategorie.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationNeu-Felder

frmApplikationNeu Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmApplikationNeu -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationNeu


frmApplikationskontakt -Klasse

For a list of all members of this type, see frmApplikationskontakt-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplikationskontakt

[Visual Basic]
Public Class frmApplikationskontakt
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplikationskontakt-Member


frmApplikationskontakt-Member

frmApplikationskontakt Übersicht

Öffentliche Konstruktoren

public constructor frmApplikationskontakt -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontaktpersonen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontaktpersonen_MouseDown Unterstützt von .NET Compact Framework | C1Kontaktperson Mousedown
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DetailsKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson Details anzeigen
private method DetailsVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktpersonMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method Load_Rollen Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeuKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson neue Person erfassen
private method NeuVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method SuchenVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmApplikationskontakt_Load Unterstützt von .NET Compact Framework |
private method txtVertragspartner_TextChanged Unterstützt von .NET Compact Framework |

Felder

private field Applikationskontaktnr

Unterstützt von .NET Compact Framework
private field Applikationsnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field KontaktNr

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Person

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikationskontakt -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void frmApplikationskontakt();

[Visual Basic] Public Sub New(Integer, Integer, Integer, Optional Boolean, Optional Boolean)
[C#] public System.Void frmApplikationskontakt(int, int, int, bool, bool);

frmApplikationskontakt


frmApplikationskontakt-Methoden

frmApplikationskontakt Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontaktpersonen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontaktpersonen_MouseDown Unterstützt von .NET Compact Framework | C1Kontaktperson Mousedown
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DetailsKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson Details anzeigen
private method DetailsVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktpersonMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method Load_Rollen Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeuKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson neue Person erfassen
private method NeuVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method SuchenVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmApplikationskontakt_Load Unterstützt von .NET Compact Framework |
private method txtVertragspartner_TextChanged Unterstützt von .NET Compact Framework |

frmApplikationskontakt -Klasse


frmApplikationskontakt.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
            If TypeOf c Is ListBox Then
                Dim ctl As ListBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.C1Kontaktpersonen_FetchRowStyle -Methode

[Visual Basic]
Private Sub C1Kontaktpersonen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontaktpersonen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontaktpersonen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontaktpersonen.FetchRowStyle
        Try
            If Me.C1Kontaktpersonen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.C1Kontaktpersonen_MouseDown -Methode

C1Kontaktperson Mousedown

[Visual Basic]
Private Sub C1Kontaktpersonen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontaktpersonen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontaktpersonen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontaktpersonen.MouseDown
        Me.C1Kontaktpersonen.Bookmark = Me.C1Kontaktpersonen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_Data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.DetailsKontaktpersonToolStripMenuItem_Click -Methode

C1Kontaktperson Details anzeigen

[Visual Basic]
Private Sub DetailsKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsKontaktpersonToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsKontaktpersonToolStripMenuItem.Click
        Try
            Dim f As New frmPerson(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Me.VertragspartnerNr, Me.FormReadonly)
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.DetailsVertragspartnerToolStripMenuItem_Click -Methode

Vertragspartner anzeigen

[Visual Basic]
Private Sub DetailsVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsVertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner(Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.Get_Vertragspartner()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0 Or mnu.Text.IndexOf("Details") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If

        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.Kontaktperson.Neuer_Datensatz = True Then Me.Kontaktperson.Delete(Me.Kontaktperson.iApplikationKontaktnr.Value)
            Globals.MyEventHanlder.Kontakte_Closed()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Get_Data -Methode

Person laden und präsentieren

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kontaktperson.Get_Applikationskontakt(Nr)
        Me.lbRolle.SelectedValue = Me.Kontaktperson.iKontakttypNr.Value
        Me.cbIntern.Checked = Me.Kontaktperson.bIntern.Value = True
        Me.txtErstellt_am.Text = Me.Kontaktperson.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.txtBemerkung.Text = Me.Kontaktperson.sBemerkung.ToString
        Me.txtMutierer.Text = Me.Kontaktperson.iMutierer.Value
        Me.cbaktiv.Checked = Me.Kontaktperson.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kontaktperson.iSecurityLevelNr.Value

        If Me.Kontaktperson.iPersonNr.Value <> 0 Then
            Try
                Person.cpMainConnectionProvider = Globals.conn
                Person.iPersonNr = New SqlInt32(CType(Me.Kontaktperson.iPersonNr.Value, Int32))
                Person.SelectOne()
                Me.VertragspartnerNr = Person.iVertragspartnernr.Value
            Catch
            End Try
        End If

        Me.Get_Vertragspartner()

        Dim i As Integer = 0
        For i = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
            Me.C1Kontaktpersonen.Bookmark = i
            Try
                If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(i) = Me.Kontaktperson.iPersonNr.Value Then Exit For
            Catch
            End Try
        Next
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Get_Vertragspartner -Methode

[Visual Basic]
Private Function Get_Vertragspartner() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner()
        Me.txtVertragspartner.Text = Me.Vertragspartner.Get_Vertragspartnername(Me.VertragspartnerNr)
        Get_Vertragspartner_Kontakte()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Get_Vertragspartner_Kontakte -Methode

[Visual Basic]
Private Function Get_Vertragspartner_Kontakte() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner_Kontakte()
        Try
            'If Check_Changes() = False Then Exit Function
        Catch ex As Exception

        End Try
        Me.C1Kontaktpersonen.Enabled = False
        Me.Vertragspartner.Get_Kontaktpersonen(Me.C1Kontaktpersonen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontaktpersonen, "Person", Me.Vertragspartner.Kontaktpersonen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontaktpersonen.Enabled = True
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplikationskontakt))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.VertragspartnerContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.SuchenVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.KontaktpersonMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblKontaktperson = New System.Windows.Forms.Label
        Me.lblRolle = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.cbIntern = New System.Windows.Forms.CheckBox
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.lbRolle = New System.Windows.Forms.ListBox
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.C1Kontaktpersonen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.VertragspartnerContextMenuStrip.SuspendLayout()
        Me.KontaktpersonMenuStrip.SuspendLayout()
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(594, 24)
        Me.MenuStrip1.TabIndex = 8
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(594, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(368, 63)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 0
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragspartner.ContextMenuStrip = Me.VertragspartnerContextMenuStrip
        Me.txtVertragspartner.Location = New System.Drawing.Point(103, 62)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.ReadOnly = True
        Me.txtVertragspartner.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragspartner.TabIndex = 0
        '
        'VertragspartnerContextMenuStrip
        '
        Me.VertragspartnerContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsVertragspartnerToolStripMenuItem, Me.NeuVertragspartnerToolStripMenuItem, Me.ToolStripMenuItem1, Me.SuchenVertragspartnerToolStripMenuItem})
        Me.VertragspartnerContextMenuStrip.Name = "VertragspartnerContextMenuStrip"
        Me.VertragspartnerContextMenuStrip.Size = New System.Drawing.Size(112, 76)
        '
        'DetailsVertragspartnerToolStripMenuItem
        '
        Me.DetailsVertragspartnerToolStripMenuItem.Name = "DetailsVertragspartnerToolStripMenuItem"
        Me.DetailsVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.DetailsVertragspartnerToolStripMenuItem.Text = "&Details"
        '
        'NeuVertragspartnerToolStripMenuItem
        '
        Me.NeuVertragspartnerToolStripMenuItem.Name = "NeuVertragspartnerToolStripMenuItem"
        Me.NeuVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.NeuVertragspartnerToolStripMenuItem.Text = "&Neu"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(108, 6)
        '
        'SuchenVertragspartnerToolStripMenuItem
        '
        Me.SuchenVertragspartnerToolStripMenuItem.Name = "SuchenVertragspartnerToolStripMenuItem"
        Me.SuchenVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.SuchenVertragspartnerToolStripMenuItem.Text = "&Suchen"
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(12, 67)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(79, 13)
        Me.lblVertragspartner.TabIndex = 107
        Me.lblVertragspartner.Text = "Vertragspartner"
        '
        'KontaktpersonMenuStrip
        '
        Me.KontaktpersonMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsKontaktpersonToolStripMenuItem, Me.NeuKontaktpersonToolStripMenuItem})
        Me.KontaktpersonMenuStrip.Name = "KontaktpersonMenuStrip"
        Me.KontaktpersonMenuStrip.Size = New System.Drawing.Size(107, 48)
        '
        'DetailsKontaktpersonToolStripMenuItem
        '
        Me.DetailsKontaktpersonToolStripMenuItem.Name = "DetailsKontaktpersonToolStripMenuItem"
        Me.DetailsKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.DetailsKontaktpersonToolStripMenuItem.Text = "&Details"
        '
        'NeuKontaktpersonToolStripMenuItem
        '
        Me.NeuKontaktpersonToolStripMenuItem.Name = "NeuKontaktpersonToolStripMenuItem"
        Me.NeuKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.NeuKontaktpersonToolStripMenuItem.Text = "&Neu"
        '
        'lblKontaktperson
        '
        Me.lblKontaktperson.AutoSize = True
        Me.lblKontaktperson.Location = New System.Drawing.Point(12, 88)
        Me.lblKontaktperson.Name = "lblKontaktperson"
        Me.lblKontaktperson.Size = New System.Drawing.Size(76, 13)
        Me.lblKontaktperson.TabIndex = 110
        Me.lblKontaktperson.Text = "Kontaktperson"
        '
        'lblRolle
        '
        Me.lblRolle.AutoSize = True
        Me.lblRolle.Location = New System.Drawing.Point(12, 240)
        Me.lblRolle.Name = "lblRolle"
        Me.lblRolle.Size = New System.Drawing.Size(31, 13)
        Me.lblRolle.TabIndex = 112
        Me.lblRolle.Text = "Rolle"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(12, 414)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(105, 15)
        Me.cbaktiv.TabIndex = 5
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'cbIntern
        '
        Me.cbIntern.Location = New System.Drawing.Point(11, 341)
        Me.cbIntern.Name = "cbIntern"
        Me.cbIntern.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbIntern.Size = New System.Drawing.Size(105, 15)
        Me.cbIntern.TabIndex = 3
        Me.cbIntern.Text = "Intern"
        Me.cbIntern.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbIntern.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(103, 434)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 6
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(12, 437)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 132
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(408, 465)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 138
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(246, 465)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 137
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(102, 465)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 136
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(335, 468)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 135
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(185, 468)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 134
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(12, 468)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 133
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'lbRolle
        '
        Me.lbRolle.FormattingEnabled = True
        Me.lbRolle.Location = New System.Drawing.Point(103, 240)
        Me.lbRolle.Name = "lbRolle"
        Me.lbRolle.Size = New System.Drawing.Size(268, 95)
        Me.lbRolle.TabIndex = 2
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(103, 363)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(479, 45)
        Me.txtBemerkung.TabIndex = 4
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(12, 366)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 143
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'C1Kontaktpersonen
        '
        Me.C1Kontaktpersonen.AllowAddNew = True
        Me.C1Kontaktpersonen.AlternatingRows = True
        Me.C1Kontaktpersonen.ContextMenuStrip = Me.KontaktpersonMenuStrip
        Me.C1Kontaktpersonen.FetchRowStyles = True
        Me.C1Kontaktpersonen.FilterBar = True
        Me.C1Kontaktpersonen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontaktpersonen.Images.Add(CType(resources.GetObject("C1Kontaktpersonen.Images"), System.Drawing.Image))
        Me.C1Kontaktpersonen.Location = New System.Drawing.Point(103, 89)
        Me.C1Kontaktpersonen.Name = "C1Kontaktpersonen"
        Me.C1Kontaktpersonen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.ZoomFactor = 75
        Me.C1Kontaktpersonen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontaktpersonen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontaktpersonen.Size = New System.Drawing.Size(478, 145)
        Me.C1Kontaktpersonen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kontaktpersonen.TabIndex = 1
        Me.C1Kontaktpersonen.Text = "C1TrueDBGrid1"
        Me.C1Kontaktpersonen.PropBag = resources.GetString("C1Kontaktpersonen.PropBag")
        '
        'frmApplikationskontakt
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(594, 493)
        Me.Controls.Add(Me.C1Kontaktpersonen)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lbRolle)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.cbIntern)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.lblRolle)
        Me.Controls.Add(Me.lblKontaktperson)
        Me.Controls.Add(Me.btnVertragspartnersuche)
        Me.Controls.Add(Me.txtVertragspartner)
        Me.Controls.Add(Me.lblVertragspartner)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplikationskontakt"
        Me.Text = "Applikationskontakt"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.VertragspartnerContextMenuStrip.ResumeLayout(False)
        Me.KontaktpersonMenuStrip.ResumeLayout(False)
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.KontaktpersonMenuStrip_Opening -Methode

[Visual Basic]
Private Sub KontaktpersonMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   KontaktpersonMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktpersonMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles KontaktpersonMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Kontaktpersonen)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Load_Rollen -Methode

[Visual Basic]
Private Function Load_Rollen() As Object

Quellcode

[Visual Basic]
    Private Function Load_Rollen()
        Dim rollen As New TKB.VV.DB.clsKontakttyp
        Dim rollendata As New DataTable
        rollen.cpMainConnectionProvider = Globals.conn
        rollendata = rollen.SelectAll()
        Dim rv As New DataView(rollendata, "ApplikationsbereichNr=2 and aktiv=1", "", DataViewRowState.CurrentRows)
        Me.lbRolle.DataSource = rv
        Me.lbRolle.ValueMember = "KontakttypNr"
        Me.lbRolle.DisplayMember = "Bezeichnung"
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.NeuKontaktpersonToolStripMenuItem_Click -Methode

C1Kontaktperson neue Person erfassen

[Visual Basic]
Private Sub NeuKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuKontaktpersonToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuKontaktpersonToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Kontaktperson.Add_New(Me.VertragspartnerNr)
        Dim f As New frmPerson(i, Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.Dispose()
        Me.Get_Vertragspartner_Kontakte()
        Dim r As Integer = 0
        For r = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
            Me.C1Kontaktpersonen.Bookmark = r
            If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(r) = i Then Exit For
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.NeuVertragspartnerToolStripMenuItem_Click -Methode

Neuer Vertragspartner eröffnen

[Visual Basic]
Private Sub NeuVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuVertragspartnerToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Add_New
        Dim f As New frmVertragspartner(i, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.VertragspartnerNr = i
        Me.Get_Vertragspartner()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.Save_Data -Methode

Daten sichern, sofern Änderungen vorgenommen worden sind

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kontaktperson.iKontakttypNr = New SqlInt32(CType(Me.lbRolle.SelectedValue, Int32))
            Me.Kontaktperson.iPersonNr = New SqlInt32(CType(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Int32))
            Me.Kontaktperson.bIntern = New SqlBoolean(CType(Me.cbIntern.Checked, Boolean))
            Me.Kontaktperson.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked, Boolean))
            Me.Kontaktperson.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kontaktperson.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kontaktperson.Save_Data)
            Me.FormDataChanged = False
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.SuchenVertragspartnerToolStripMenuItem_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub SuchenVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SuchenVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SuchenVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SuchenVertragspartnerToolStripMenuItem.Click
        Me.btnVertragspartnersuche_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Kontaktperson.Create_Copy(Me.Kontaktperson.iApplikationKontaktnr.Value))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Kontaktperson.Delete_Applikationskontakt(Me.Kontaktperson.iApplikationKontaktnr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Kontaktperson.Add_New(Me.Applikationsnr))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.btnVertragspartnersuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        Dim f As New frmVertragspartnerSuche
        f.ShowDialog()
        If f.Vertragspartnernr <> -1 Then
            Me.VertragspartnerNr = f.Vertragspartnernr
            f.Dispose()
            Me.Get_Vertragspartner()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.frmApplikationskontakt_Load -Methode

[Visual Basic]
Private Sub frmApplikationskontakt_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmApplikationskontakt_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Load_Rollen()
        Get_Data(Me.Applikationskontaktnr)
        If Me.Neuer_Datensatz = True Then
            Me.Kontaktperson.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly = True Then
            Me.TSBtnSave.Enabled = False
            sec.Set_Form_Readonly(Me)
        End If

        Me.AddChanges(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt.txtVertragspartner_TextChanged -Methode

[Visual Basic]
Private Sub txtVertragspartner_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtVertragspartner.TextChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtVertragspartner_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtVertragspartner.TextChanged

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationskontakt-Felder

frmApplikationskontakt Übersicht

Felder

private field Applikationskontaktnr

Unterstützt von .NET Compact Framework
private field Applikationsnr

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field KontaktNr

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Person

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmApplikationskontakt -Klasse


Applikationskontaktnr -Feld

[Visual Basic]
Private Applikationskontaktnr As Integer

Quellcode

[Visual Basic]
    Private Applikationskontaktnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


Applikationsnr -Feld

[Visual Basic]
Private Applikationsnr As Integer

Quellcode

[Visual Basic]
    Private Applikationsnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


KontaktNr -Feld

[Visual Basic]
Private KontaktNr As Integer

Quellcode

[Visual Basic]
    Private KontaktNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


Kontaktperson -Feld

[Visual Basic]
Private Kontaktperson As clsKontakt

Quellcode

[Visual Basic]
    Dim Kontaktperson As New TKB.VV.Applikation.clsKontakt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


Person -Feld

[Visual Basic]
Private Person As clsPerson

Quellcode

[Visual Basic]
    Dim Person As New TKB.VV.DB.clsPerson

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


Vertragspartner -Feld

[Visual Basic]
Private Vertragspartner As clsVertragspartner

Quellcode

[Visual Basic]
    Dim Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


VertragspartnerNr -Feld

[Visual Basic]
Private VertragspartnerNr As Integer

Quellcode

[Visual Basic]
    Private VertragspartnerNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationsuebersicht -Klasse

For a list of all members of this type, see frmApplikationsuebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmApplikationsuebersicht

[Visual Basic]
Public Class frmApplikationsuebersicht
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmApplikationsuebersicht-Member


frmApplikationsuebersicht-Member

frmApplikationsuebersicht Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AnzeigenBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStipMenuItem_Click Unterstützt von .NET Compact Framework |
private method C1Applikationen_DoubleClick Unterstützt von .NET Compact Framework | Anzeige eines Applikationselementes
private method C1Applikationen_MouseDown Unterstützt von .NET Compact Framework |
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method DetailContextMenu_Opening Unterstützt von .NET Compact Framework | Detail-Contextmenu Open
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method NeueApplikationErfassenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NurAktiveToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Details Unterstützt von .NET Compact Framework |
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Applikation suchen
private method TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten schliessen
private method TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten öffnen
private method TreeApplikationen_AfterSelect Unterstützt von .NET Compact Framework | Treeview-AfterSelect
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method frmApplikationsuebersicht_Load Unterstützt von .NET Compact Framework |
private method tstxtSuche_Enter Unterstützt von .NET Compact Framework |
private method tstxtSuche_KeyDown Unterstützt von .NET Compact Framework |

Felder

private field Applikation Unterstützt von .NET Compact Framework |
private field NurAktive Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field TreeParent Unterstützt von .NET Compact Framework |
private field Treeviewdata Unterstützt von .NET Compact Framework |
private field Uebersicht Unterstützt von .NET Compact Framework |
private field c1data Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field sec Unterstützt von .NET Compact Framework | Security-Klasse
internal (Friend) field selectPoint Unterstützt von .NET Compact Framework |

frmApplikationsuebersicht -Klasse


frmApplikationsuebersicht-Methoden

frmApplikationsuebersicht Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AnzeigenBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStipMenuItem_Click Unterstützt von .NET Compact Framework |
private method C1Applikationen_DoubleClick Unterstützt von .NET Compact Framework | Anzeige eines Applikationselementes
private method C1Applikationen_MouseDown Unterstützt von .NET Compact Framework |
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method DetailContextMenu_Opening Unterstützt von .NET Compact Framework | Detail-Contextmenu Open
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method NeueApplikationErfassenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NurAktiveToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Details Unterstützt von .NET Compact Framework |
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Applikation suchen
private method TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten schliessen
private method TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten öffnen
private method TreeApplikationen_AfterSelect Unterstützt von .NET Compact Framework | Treeview-AfterSelect
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method frmApplikationsuebersicht_Load Unterstützt von .NET Compact Framework |
private method tstxtSuche_Enter Unterstützt von .NET Compact Framework |
private method tstxtSuche_KeyDown Unterstützt von .NET Compact Framework |

frmApplikationsuebersicht -Klasse


frmApplikationsuebersicht.AnzeigenBearbeitenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AnzeigenBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AnzeigenBearbeitenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AnzeigenBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AnzeigenBearbeitenToolStripMenuItem.Click
        C1Applikationen_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.BeendenToolStipMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStipMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStipMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStipMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.C1Applikationen_DoubleClick -Methode

Anzeige eines Applikationselementes

[Visual Basic]
Private Sub C1Applikationen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Applikationen.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Applikationen.DoubleClick
        Dim f As New frmApplikation(Me.C1Applikationen.Columns("Applikationnr").Value, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.C1Applikationen_MouseDown -Methode

[Visual Basic]
Private Sub C1Applikationen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Applikationen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Applikationen.MouseDown
        Me.C1Applikationen.Bookmark = Me.C1Applikationen.RowContaining(e.Y)
        Me.C1Applikationen.Bookmark = Me.C1Applikationen.RowBookmark(Me.C1Applikationen.RowContaining(e.Y))

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.C1Vertragselemente_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Vertragselemente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Applikationen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Applikationen.FetchRowStyle
        Try
            If Me.C1Applikationen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.DetailContextMenu_Opening -Methode

Detail-Contextmenu Open

[Visual Basic]
Private Sub DetailContextMenu_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   DetailContextMenu.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailContextMenu_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles DetailContextMenu.Opening
        If Me.C1Applikationen.Splits(0).Rows.Count < 1 Then
            Me.DetailContextMenu.Enabled = False
        Else
            Me.DetailContextMenu.Enabled = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmApplikationsuebersicht))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.ToolStripSeparator1 = New System.Windows.Forms.ToolStripSeparator
        Me.TSComboboxProfil = New System.Windows.Forms.ToolStripComboBox
        Me.TSlblSuche = New System.Windows.Forms.ToolStripLabel
        Me.tstxtSuche = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TSBtnFilterAufheben = New System.Windows.Forms.ToolStripButton
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.TreeApplikationen = New System.Windows.Forms.TreeView
        Me.TreeApplikationenContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.NeueApplikationErfassenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NurAktiveToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImgListApplikationTree = New System.Windows.Forms.ImageList(Me.components)
        Me.C1Applikationen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DetailContextMenu = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.AnzeigenBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.TreeApplikationenContextMenuStrip.SuspendLayout()
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DetailContextMenu.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(978, 24)
        Me.MenuStrip1.TabIndex = 6
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStipMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStipMenuItem
        '
        Me.BeendenToolStipMenuItem.Name = "BeendenToolStipMenuItem"
        Me.BeendenToolStipMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStipMenuItem.Tag = ""
        Me.BeendenToolStipMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.ToolStripSeparator1, Me.TSComboboxProfil, Me.TSlblSuche, Me.tstxtSuche, Me.TSBtnSuche, Me.TSBtnFilterAufheben})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(978, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        Me.TSBtnSave.Visible = False
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        Me.TSBtnCopy.Visible = False
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        Me.TSBtnNew.Visible = False
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        Me.TSBtnDelete.Visible = False
        '
        'ToolStripSeparator1
        '
        Me.ToolStripSeparator1.Name = "ToolStripSeparator1"
        Me.ToolStripSeparator1.Size = New System.Drawing.Size(6, 25)
        '
        'TSComboboxProfil
        '
        Me.TSComboboxProfil.Name = "TSComboboxProfil"
        Me.TSComboboxProfil.Size = New System.Drawing.Size(121, 25)
        Me.TSComboboxProfil.Visible = False
        '
        'TSlblSuche
        '
        Me.TSlblSuche.Name = "TSlblSuche"
        Me.TSlblSuche.Size = New System.Drawing.Size(36, 22)
        Me.TSlblSuche.Text = "Filter:"
        '
        'tstxtSuche
        '
        Me.tstxtSuche.Name = "tstxtSuche"
        Me.tstxtSuche.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "Suchen"
        '
        'TSBtnFilterAufheben
        '
        Me.TSBtnFilterAufheben.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnFilterAufheben.Image = CType(resources.GetObject("TSBtnFilterAufheben.Image"), System.Drawing.Image)
        Me.TSBtnFilterAufheben.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnFilterAufheben.Name = "TSBtnFilterAufheben"
        Me.TSBtnFilterAufheben.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnFilterAufheben.Text = "Filter aufheben"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.TreeApplikationen)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1Applikationen)
        Me.SplitContainer1.Size = New System.Drawing.Size(978, 491)
        Me.SplitContainer1.SplitterDistance = 195
        Me.SplitContainer1.TabIndex = 8
        '
        'TreeApplikationen
        '
        Me.TreeApplikationen.ContextMenuStrip = Me.TreeApplikationenContextMenuStrip
        Me.TreeApplikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeApplikationen.ImageIndex = 0
        Me.TreeApplikationen.ImageList = Me.ImgListApplikationTree
        Me.TreeApplikationen.Location = New System.Drawing.Point(0, 0)
        Me.TreeApplikationen.Name = "TreeApplikationen"
        Me.TreeApplikationen.SelectedImageIndex = 0
        Me.TreeApplikationen.Size = New System.Drawing.Size(195, 491)
        Me.TreeApplikationen.TabIndex = 1
        '
        'TreeApplikationenContextMenuStrip
        '
        Me.TreeApplikationenContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem, Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem, Me.ToolStripMenuItem1, Me.NeueApplikationErfassenToolStripMenuItem, Me.NurAktiveToolStripMenuItem})
        Me.TreeApplikationenContextMenuStrip.Name = "TreeApplikationenContextMenuStrip"
        Me.TreeApplikationenContextMenuStrip.Size = New System.Drawing.Size(213, 98)
        '
        'TreeApplikationenAlleKnotenSchliessenToolStripMenuItem
        '
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Name = "TreeApplikationenAlleKnotenSchliessenToolStripMenuItem"
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Size = New System.Drawing.Size(212, 22)
        Me.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Text = "Alle Knoten schliessen"
        '
        'TreeApplikationenAlleKnotenÖffnenToolStripMenuItem
        '
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Name = "TreeApplikationenAlleKnotenÖffnenToolStripMenuItem"
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Size = New System.Drawing.Size(212, 22)
        Me.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Text = "Alle Knoten öffnen"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(209, 6)
        '
        'NeueApplikationErfassenToolStripMenuItem
        '
        Me.NeueApplikationErfassenToolStripMenuItem.Name = "NeueApplikationErfassenToolStripMenuItem"
        Me.NeueApplikationErfassenToolStripMenuItem.Size = New System.Drawing.Size(212, 22)
        Me.NeueApplikationErfassenToolStripMenuItem.Text = "&Neue Applikation erfassen"
        '
        'NurAktiveToolStripMenuItem
        '
        Me.NurAktiveToolStripMenuItem.Name = "NurAktiveToolStripMenuItem"
        Me.NurAktiveToolStripMenuItem.Size = New System.Drawing.Size(212, 22)
        Me.NurAktiveToolStripMenuItem.Text = "Nur Aktive"
        '
        'ImgListApplikationTree
        '
        Me.ImgListApplikationTree.ImageStream = CType(resources.GetObject("ImgListApplikationTree.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListApplikationTree.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListApplikationTree.Images.SetKeyName(0, "45.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(1, "Run.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(2, "Run_Deleted.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(3, "RunLiz.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(4, "Run_DeletedLic.ico")
        '
        'C1Applikationen
        '
        Me.C1Applikationen.AlternatingRows = True
        Me.C1Applikationen.ContextMenuStrip = Me.DetailContextMenu
        Me.C1Applikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Applikationen.FetchRowStyles = True
        Me.C1Applikationen.FilterBar = True
        Me.C1Applikationen.GroupByCaption = "Um eine Gruppierung herzustellen, den Spaltentitel in den Gruppierungsbereich zie" & _
            "hen"
        Me.C1Applikationen.Images.Add(CType(resources.GetObject("C1Applikationen.Images"), System.Drawing.Image))
        Me.C1Applikationen.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.Name = "C1Applikationen"
        Me.C1Applikationen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Applikationen.PreviewInfo.ZoomFactor = 75
        Me.C1Applikationen.PrintInfo.PageSettings = CType(resources.GetObject("C1Applikationen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Applikationen.Size = New System.Drawing.Size(779, 491)
        Me.C1Applikationen.TabIndex = 4
        Me.C1Applikationen.Text = "C1TrueDBGrid1"
        Me.C1Applikationen.PropBag = resources.GetString("C1Applikationen.PropBag")
        '
        'DetailContextMenu
        '
        Me.DetailContextMenu.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.AnzeigenBearbeitenToolStripMenuItem})
        Me.DetailContextMenu.Name = "DetailContextMenu"
        Me.DetailContextMenu.Size = New System.Drawing.Size(191, 26)
        '
        'AnzeigenBearbeitenToolStripMenuItem
        '
        Me.AnzeigenBearbeitenToolStripMenuItem.Name = "AnzeigenBearbeitenToolStripMenuItem"
        Me.AnzeigenBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(190, 22)
        Me.AnzeigenBearbeitenToolStripMenuItem.Text = "Anzeigen / Bearbeiten"
        '
        'frmApplikationsuebersicht
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(978, 540)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplikationsuebersicht"
        Me.Text = "Applikationsübersicht"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.TreeApplikationenContextMenuStrip.ResumeLayout(False)
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DetailContextMenu.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.NeueApplikationErfassenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub NeueApplikationErfassenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeueApplikationErfassenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeueApplikationErfassenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeueApplikationErfassenToolStripMenuItem.Click
        Dim f As New frmApplikation(True)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.NurAktiveToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub NurAktiveToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NurAktiveToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NurAktiveToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NurAktiveToolStripMenuItem.Click
        If Me.NurAktiveToolStripMenuItem.Text = "Nur Aktive" Then
            Me.NurAktiveToolStripMenuItem.Text = "Aktive und Inaktive"
            Me.NurAktive = True
        Else
            Me.NurAktive = False
            Me.NurAktiveToolStripMenuItem.Text = "Nur Aktive"
        End If
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.NurAktive)
        Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.Refresh_Details -Methode

[Visual Basic]
Private Sub Refresh_Details()

Quellcode

[Visual Basic]
    Private Sub Refresh_Details()
        c1data = Uebersicht.Get_Applikationsdetails(Me.TreeApplikationen.SelectedNode.Tag, Me.tstxtSuche.Text)
        'Me.tstxtSuche.Text)
        'If Me.Profil.sV_Sort.ToString <> "" Then
        '    c1data.DefaultView.Sort = Me.Profil.sV_Sort.ToString
        'End If

        'Dim gv As C1.Win.C1TrueDBGrid.DataViewEnum
        'Dim s As New Collection
        'Dim i As Integer = -1
        'For Each g As C1.Win.C1TrueDBGrid.C1DataColumn In Me.C1Vertragselemente.GroupedColumns
        '    s.Add(g.Caption)
        '    i = i + 1
        '    '                xxx(i) = g.Caption
        'Next
        'i = Me.C1Vertragselemente.DataView
        'Me.C1Vertragselemente.Enabled = False
        Me.C1Applikationen.DataSource = c1data
        Me.C1Applikationen.DataMember = c1data.TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Applikationen, "Applikationsuebersicht", Me.c1data, "")
        '       Update_Details()
        '        Docs.Get_Layout(Me.C1Vertragselemente, 1, Me.Profil.iProfilnr.Value)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TSBtnFilterAufheben_Click -Methode

[Visual Basic]
Private Sub TSBtnFilterAufheben_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnFilterAufheben.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnFilterAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnFilterAufheben.Click
        Me.tstxtSuche.Text = ""
        Me.C1Applikationen.DataSource = Nothing
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.NurAktive)
        Try
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        Catch ex As Exception

        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TSBtnSuche_Click -Methode

Applikation suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        Me.C1Applikationen.DataSource = Nothing
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, Me.tstxtSuche.Text, Me.NurAktive)
        Try
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click -Methode

Alle Knoten schliessen

[Visual Basic]
Private Sub TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationenAlleKnotenSchliessenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeApplikationenAlleKnotenSchliessenToolStripMenuItem.Click
        Me.TreeApplikationen.CollapseAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click -Methode

Alle Knoten öffnen

[Visual Basic]
Private Sub TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationenAlleKnotenÖffnenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeApplikationenAlleKnotenÖffnenToolStripMenuItem.Click
        Me.TreeApplikationen.ExpandAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TreeApplikationen_AfterSelect -Methode

Treeview-AfterSelect

[Visual Basic]
Private Sub TreeApplikationen_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeApplikationen.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationen_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeApplikationen.AfterSelect
        Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.TreeStruktur_MouseDown -Methode

Mousedown-Ereignis auf dem Tree

[Visual Basic]
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeApplikationen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeApplikationen.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.GetNodeAt(selectPoint)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.frmApplikationsuebersicht_Load -Methode

[Visual Basic]
Private Sub frmApplikationsuebersicht_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmApplikationsuebersicht_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Treeviewdata.Load_Tree(Me.TreeApplikationen, False, "", Me.NurAktive)
        Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
        sec.Set_Form_Security(Me)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.tstxtSuche_Enter -Methode

[Visual Basic]
Private Sub tstxtSuche_Enter( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   tstxtSuche.Enter

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tstxtSuche_Enter(ByVal sender As Object, ByVal e As System.EventArgs) Handles tstxtSuche.Enter

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht.tstxtSuche_KeyDown -Methode

[Visual Basic]
Private Sub tstxtSuche_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   tstxtSuche.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tstxtSuche_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles tstxtSuche.KeyDown
        If e.KeyCode = Keys.Enter Then
            TSBtnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmApplikationsuebersicht-Felder

frmApplikationsuebersicht Übersicht

Felder

private field Applikation Unterstützt von .NET Compact Framework |
private field NurAktive Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field TreeParent Unterstützt von .NET Compact Framework |
private field Treeviewdata Unterstützt von .NET Compact Framework |
private field Uebersicht Unterstützt von .NET Compact Framework |
private field c1data Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field sec Unterstützt von .NET Compact Framework | Security-Klasse
internal (Friend) field selectPoint Unterstützt von .NET Compact Framework |

frmApplikationsuebersicht -Klasse


Applikation -Feld

[Visual Basic]
Private Applikation As clsApplikation

Quellcode

[Visual Basic]
    Dim Applikation As New TKB.VV.Applikation.clsApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


NurAktive -Feld

[Visual Basic]
Private NurAktive As Boolean

Quellcode

[Visual Basic]
    Dim NurAktive As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


TreeParent -Feld

[Visual Basic]
Private TreeParent As clsApplikationTree

Quellcode

[Visual Basic]
    Dim TreeParent As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


Treeviewdata -Feld

[Visual Basic]
Private Treeviewdata As clsApplikationTree

Quellcode

[Visual Basic]
    Dim Treeviewdata As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


Uebersicht -Feld

[Visual Basic]
Private Uebersicht As clsApplikationsuebersicht

Quellcode

[Visual Basic]
    Dim Uebersicht As New TKB.VV.Applikation.clsApplikationsuebersicht

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


c1data -Feld

[Visual Basic]
Private c1data As DataTable

Quellcode

[Visual Basic]
    Dim c1data As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


sec -Feld

Security-Klasse

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationsuebersicht


frmAuswertung -Klasse

For a list of all members of this type, see frmAuswertung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmAuswertung

[Visual Basic]
Public Class frmAuswertung
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmAuswertung-Member


frmAuswertung-Member

frmAuswertung Übersicht

Öffentliche Konstruktoren

public constructor frmAuswertung -Konstructor

Unterstützt von .NET Compact Framework

 Initialisierung des Formulars

Öffentliche Methoden

public method Static DatatableToExcel

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method C1Daten_FetchScrollTips

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnExcelExport_Click

Unterstützt von .NET Compact Framework
private method TSBtnPrint_Click

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method frmAuswertung_Load

Unterstützt von .NET Compact Framework

Felder

private field Auswertungsdaten

Unterstützt von .NET Compact Framework
private field Auswertungsname

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

frmAuswertung -Klasse


frmAuswertung -Konstructor

Initialisierung des Formulars

[Visual Basic]
Public Sub New( _
   ByVal Auswertungname As String, _
   ByRef Auswerungsdaten As DataTable _
)

Parameter

Auswertungname
Auswerungsdaten

Quellcode

[Visual Basic]
    Sub New(ByVal Auswertungname As String, ByRef Auswerungsdaten As DataTable)
        Me.InitializeComponent()
        Me.Text = Me.Text + ": " + Auswertungname
        Me.Auswertungsdaten = Auswerungsdaten
        Me.Auswertungsname = Auswertungname
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung-Methoden

frmAuswertung Übersicht

Öffentliche Methoden

public method Static DatatableToExcel

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method C1Daten_FetchScrollTips

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnExcelExport_Click

Unterstützt von .NET Compact Framework
private method TSBtnPrint_Click

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method frmAuswertung_Load

Unterstützt von .NET Compact Framework

frmAuswertung -Klasse


frmAuswertung.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.C1Daten_FetchScrollTips -Methode

[Visual Basic]
Private Sub C1Daten_FetchScrollTips( _
   ByVal sender As Object, _
   ByVal e As FetchScrollTipsEventArgs _
) Handles  _
   C1Daten.FetchScrollTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_FetchScrollTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles C1Daten.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Horizontal
                    e.ScrollTip = Me.C1Daten.Columns(e.ColIndex).Caption
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.Auswertungsdaten.Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.DatatableToExcel -Methode

[Visual Basic]
Public Shared Function DatatableToExcel( _
   ByVal aDataTable As DataTable, _
   ByVal aOutputFilename As String _
) As Boolean

Parameter

aDataTable
aOutputFilename

Quellcode

[Visual Basic]
    Public Shared Function DatatableToExcel(ByVal aDataTable As DataTable, ByVal aOutputFilename As String) As Boolean
        Application.DoEvents()
        Dim f As New FrmExcelExport
        Dim app As New Object
        Dim wb As New Object
        Dim ws As New Object
        Try
            f.Show()
            Application.DoEvents()
            f.ProgressBar1.Minimum = 0
            f.ProgressBar1.Maximum = aDataTable.Rows.Count
            app = CreateObject("Excel.application")
            'Dim wb As Object
            'Dim ws As Object
            '        Dim app As New Excel.ApplicationClass
            '       Dim wb As Excel.Workbook
            '      Dim ws As Excel.Worksheet
            wb = app.Workbooks.add()
            'wb = app.Workbooks.Add()
            ws = wb.ActiveSheet()
            Dim dc As DataColumn
            Dim dr As DataRow
            Dim colIndex As Integer
            Dim rowIndex As Integer
            ' Columns erstellen
            For Each dc In aDataTable.Columns
                colIndex += 1
                app.Cells(1, colIndex) = dc.ColumnName
            Next
            ' Rows hinzufügen
            For Each dr In aDataTable.Rows
                f.ProgressBar1.Value = rowIndex
                rowIndex += 1
                colIndex = 0
                For Each dc In aDataTable.Columns
                    colIndex += 1
                    app.Cells(rowIndex + 1, colIndex) = dr(dc.ColumnName)
                Next
            Next
            ws.Columns.AutoFit()
            wb.SaveAs(aOutputFilename)
            app.Workbooks.Open(aOutputFilename)
            ' Excel anzeigen wenn fertig exportiert
            app.Visible = True
            ws = Nothing
            wb = Nothing
            app = Nothing

            f.Close()
            Return True
        Catch ex As Exception
            f.Close()
            MsgBox(ex.Message)
        End Try

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmAuswertung))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnPrint = New System.Windows.Forms.ToolStripButton
        Me.TSBtnExcelExport = New System.Windows.Forms.ToolStripButton
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1PrintPreviewControl1 = New C1.Win.C1Preview.C1PrintPreviewControl
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.C1PrintPreviewControl1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(834, 24)
        Me.MenuStrip1.TabIndex = 3
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnPrint, Me.TSBtnExcelExport})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(834, 25)
        Me.ToolStrip1.TabIndex = 4
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnPrint
        '
        Me.TSBtnPrint.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnPrint.Image = CType(resources.GetObject("TSBtnPrint.Image"), System.Drawing.Image)
        Me.TSBtnPrint.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnPrint.Name = "TSBtnPrint"
        Me.TSBtnPrint.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnPrint.Text = "Drucken"
        '
        'TSBtnExcelExport
        '
        Me.TSBtnExcelExport.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnExcelExport.Image = CType(resources.GetObject("TSBtnExcelExport.Image"), System.Drawing.Image)
        Me.TSBtnExcelExport.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnExcelExport.Name = "TSBtnExcelExport"
        Me.TSBtnExcelExport.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnExcelExport.Text = "CSV-Export"
        '
        'C1Daten
        '
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.ScrollTips = True
        Me.C1Daten.Size = New System.Drawing.Size(834, 395)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 6
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'C1PrintPreviewControl1
        '
        Me.C1PrintPreviewControl1.Location = New System.Drawing.Point(50, 52)
        Me.C1PrintPreviewControl1.Name = "C1PrintPreviewControl1"
        '
        'C1PrintPreviewControl1.OutlineView
        '
        Me.C1PrintPreviewControl1.PreviewOutlineView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewOutlineView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewOutlineView.Name = "OutlineView"
        Me.C1PrintPreviewControl1.PreviewOutlineView.Size = New System.Drawing.Size(165, 427)
        Me.C1PrintPreviewControl1.PreviewOutlineView.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewPane
        '
        Me.C1PrintPreviewControl1.PreviewPane.IntegrateExternalTools = True
        Me.C1PrintPreviewControl1.PreviewPane.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewTextSearchPanel
        '
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Dock = System.Windows.Forms.DockStyle.Right
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Location = New System.Drawing.Point(530, 0)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.MinimumSize = New System.Drawing.Size(200, 240)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Name = "PreviewTextSearchPanel"
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Size = New System.Drawing.Size(200, 453)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Visible = False
        '
        'C1PrintPreviewControl1.ThumbnailView
        '
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Name = "ThumbnailView"
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Size = New System.Drawing.Size(165, 307)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewThumbnailView.UseImageAsThumbnail = False
        Me.C1PrintPreviewControl1.Size = New System.Drawing.Size(730, 380)
        Me.C1PrintPreviewControl1.TabIndex = 7
        Me.C1PrintPreviewControl1.Text = "C1PrintPreviewControl1"
        Me.C1PrintPreviewControl1.Visible = False
        '
        'frmAuswertung
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(834, 444)
        Me.Controls.Add(Me.C1PrintPreviewControl1)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmAuswertung"
        Me.Text = "Auswertung"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.C1PrintPreviewControl1.ResumeLayout(False)
        Me.C1PrintPreviewControl1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.TSBtnExcelExport_Click -Methode

[Visual Basic]
Private Sub TSBtnExcelExport_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnExcelExport.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnExcelExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnExcelExport.Click
        Me.SaveFileDialog1.AddExtension = True
        Me.SaveFileDialog1.DefaultExt.Insert(0, "*.csv")
        Me.SaveFileDialog1.Filter = "CSV-Dateien|*.CSV|Excel-Dateien|*.xls"

        Me.SaveFileDialog1.ShowDialog()
        If Me.SaveFileDialog1.FileName <> "" Then
            If Me.SaveFileDialog1.FileName.EndsWith("xls") Then
                Me.DatatableToExcel(Me.Auswertungsdaten, Me.SaveFileDialog1.FileName)
            Else
                Me.C1Daten.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";", "", "", True, System.Text.Encoding.Default.BodyName)
            End If
        End If

        Exit Sub

        If Me.C1Daten.Splits(0).Rows.Count > 0 Then
            Me.SaveFileDialog1.AddExtension = True
            Me.SaveFileDialog1.DefaultExt.Insert(0, "*.csv")
            Me.SaveFileDialog1.Filter = "CSV-Dateien|*.CSV"
            Me.SaveFileDialog1.ShowDialog()
            If Me.SaveFileDialog1.FileName <> "" Then
                '                Me.C1Daten.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";", "", "", "", True, System.Text.Encoding.Default.BodyName)
                Me.C1Daten.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";", "", "", True, System.Text.Encoding.Default.BodyName)
            End If

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.TSBtnPrint_Click -Methode

[Visual Basic]
Private Sub TSBtnPrint_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnPrint.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnPrint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnPrint.Click
        Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
        Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

        With Me.C1Daten.PrintInfo
            .PageHeaderStyle.Font = fontbold
            .PageSettings.Margins.Bottom = 20
            .PageSettings.Margins.Top = 80
            .PageSettings.Landscape = True
            .PageFooter = "Seite \p von \P" & vbLf & "Druckdatum " & Now()
            .PageHeader = Me.Auswertungsname
            .ShowProgressForm = True
            .UseGridColors = True
            .RepeatColumnHeaders = True
            .VarRowHeight = .RowHeightEnum.StretchToFit
            .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
            .PageBreak = .PageBreaksEnum.OnColumn
            .FillAreaWidth = .FillEmptyEnum.None
            .PrintPreview()
        End With

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung.frmAuswertung_Load -Methode

[Visual Basic]
Private Sub frmAuswertung_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmAuswertung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1Daten.DataSource = Me.Auswertungsdaten
        Me.C1Daten.DataMember = Me.Auswertungsdaten.TableName

        Dim i As Integer
        For i = 0 To Me.Auswertungsdaten.Columns.Count - 1
            Me.C1Daten.Splits(0).DisplayColumns(i).AutoSize()
            If C1Daten.Columns(i).DataType.Name = "DateTime" Then
                C1Daten.Columns(i).NumberFormat = "dd.MM.yyyy HH:mm:ss"
            End If
            If C1Daten.Columns(i).Caption = "Journaleintrag" Then
                C1Daten.Splits(0).DisplayColumns(i).Width = 250
            End If
            C1Daten.Splits(0).DisplayColumns(i).Locked = True
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertung-Felder

frmAuswertung Übersicht

Felder

private field Auswertungsdaten

Unterstützt von .NET Compact Framework
private field Auswertungsname

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

frmAuswertung -Klasse


Auswertungsdaten -Feld

[Visual Basic]
Private Auswertungsdaten As DataTable

Quellcode

[Visual Basic]
    Dim Auswertungsdaten As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


Auswertungsname -Feld

[Visual Basic]
Private Auswertungsname As String

Quellcode

[Visual Basic]
    Dim Auswertungsname As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertung


frmAuswertungsParameter -Klasse

For a list of all members of this type, see frmAuswertungsParameter-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmAuswertungsParameter

[Visual Basic]
Public Class frmAuswertungsParameter
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmAuswertungsParameter-Member


frmAuswertungsParameter-Member

frmAuswertungsParameter Übersicht

Öffentliche Konstruktoren

public constructor frmAuswertungsParameter -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property SQLWhere

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Findrow Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method btnAufbereiten_Click Unterstützt von .NET Compact Framework |
private method cboxand1_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbparam1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cbvalue1_DropDown Unterstützt von .NET Compact Framework |
private method cbvalue1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method frmAuswertungsParameter_Load Unterstützt von .NET Compact Framework |
private method frmAuswertungsParameter_MouseMove Unterstützt von .NET Compact Framework |
private method get_rptparam_values Unterstützt von .NET Compact Framework |
private method get_where Unterstützt von .NET Compact Framework |
private method init_params Unterstützt von .NET Compact Framework |

Felder

private field components

Unterstützt von .NET Compact Framework
private field l

Unterstützt von .NET Compact Framework
private field m_sqlwhere

Unterstützt von .NET Compact Framework
private field parameter

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework

frmAuswertungsParameter -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void frmAuswertungsParameter();

[Visual Basic] Public Sub New(ByRef DataTable)
[C#] public System.Void frmAuswertungsParameter(ref DataTable);

frmAuswertungsParameter


frmAuswertungsParameter-Eigenschaften

frmAuswertungsParameter Übersicht

Öffentliche Eigenschaften

public property SQLWhere

Unterstützt von .NET Compact Framework

frmAuswertungsParameter -Klasse


frmAuswertungsParameter.SQLWhere -Eigenschaft

[Visual Basic]
Public Property SQLWhere() As String

Quellcode

[Visual Basic]
    Property SQLWhere() As String
        Get
            Return m_sqlwhere
        End Get
        Set(ByVal value As String)
            m_sqlwhere = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter-Methoden

frmAuswertungsParameter Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Findrow Unterstützt von .NET Compact Framework |
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method btnAufbereiten_Click Unterstützt von .NET Compact Framework |
private method cboxand1_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbparam1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cbvalue1_DropDown Unterstützt von .NET Compact Framework |
private method cbvalue1_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method frmAuswertungsParameter_Load Unterstützt von .NET Compact Framework |
private method frmAuswertungsParameter_MouseMove Unterstützt von .NET Compact Framework |
private method get_rptparam_values Unterstützt von .NET Compact Framework |
private method get_where Unterstützt von .NET Compact Framework |
private method init_params Unterstützt von .NET Compact Framework |

frmAuswertungsParameter -Klasse


frmAuswertungsParameter.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.Findrow -Methode

[Visual Basic]
Private Function Findrow( _
   ByVal key As String _
) As DataRow

Parameter

key

Quellcode

[Visual Basic]
    Private Function Findrow(ByVal key As String) As DataRow
        For Each dr As DataRow In Me.parameter.Rows
            If dr.Item("Bezeichnung") = key Then
                Return dr
            End If
        Next
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmAuswertungsParameter))
        Me.cbop1 = New System.Windows.Forms.ComboBox
        Me.cbvalue1 = New System.Windows.Forms.ComboBox
        Me.lblParamTitel = New System.Windows.Forms.Label
        Me.lblTitelOperator = New System.Windows.Forms.Label
        Me.lblTitelWert = New System.Windows.Forms.Label
        Me.cbvalue2 = New System.Windows.Forms.ComboBox
        Me.cbop2 = New System.Windows.Forms.ComboBox
        Me.cbvalue3 = New System.Windows.Forms.ComboBox
        Me.cbop3 = New System.Windows.Forms.ComboBox
        Me.cbvalue4 = New System.Windows.Forms.ComboBox
        Me.cbop4 = New System.Windows.Forms.ComboBox
        Me.cbvalue5 = New System.Windows.Forms.ComboBox
        Me.cbop5 = New System.Windows.Forms.ComboBox
        Me.Label6 = New System.Windows.Forms.Label
        Me.cboxand1 = New System.Windows.Forms.CheckBox
        Me.cboxor1 = New System.Windows.Forms.CheckBox
        Me.cbparam1 = New System.Windows.Forms.ComboBox
        Me.cbparam2 = New System.Windows.Forms.ComboBox
        Me.cbparam3 = New System.Windows.Forms.ComboBox
        Me.cbparam4 = New System.Windows.Forms.ComboBox
        Me.cbparam5 = New System.Windows.Forms.ComboBox
        Me.cboxor2 = New System.Windows.Forms.CheckBox
        Me.cboxand2 = New System.Windows.Forms.CheckBox
        Me.cboxor3 = New System.Windows.Forms.CheckBox
        Me.cboxand3 = New System.Windows.Forms.CheckBox
        Me.cboxor4 = New System.Windows.Forms.CheckBox
        Me.cboxand4 = New System.Windows.Forms.CheckBox
        Me.btnAufbereiten = New System.Windows.Forms.Button
        Me.btnInitParams = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'cbop1
        '
        Me.cbop1.FormattingEnabled = True
        Me.cbop1.Location = New System.Drawing.Point(207, 47)
        Me.cbop1.Name = "cbop1"
        Me.cbop1.Size = New System.Drawing.Size(52, 21)
        Me.cbop1.TabIndex = 1
        '
        'cbvalue1
        '
        Me.cbvalue1.FormatString = "N2"
        Me.cbvalue1.FormattingEnabled = True
        Me.cbvalue1.Location = New System.Drawing.Point(265, 47)
        Me.cbvalue1.Name = "cbvalue1"
        Me.cbvalue1.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue1.TabIndex = 2
        '
        'lblParamTitel
        '
        Me.lblParamTitel.AutoSize = True
        Me.lblParamTitel.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblParamTitel.Location = New System.Drawing.Point(71, 17)
        Me.lblParamTitel.Name = "lblParamTitel"
        Me.lblParamTitel.Size = New System.Drawing.Size(64, 13)
        Me.lblParamTitel.TabIndex = 3
        Me.lblParamTitel.Text = "Parameter"
        '
        'lblTitelOperator
        '
        Me.lblTitelOperator.AutoSize = True
        Me.lblTitelOperator.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblTitelOperator.Location = New System.Drawing.Point(204, 17)
        Me.lblTitelOperator.Name = "lblTitelOperator"
        Me.lblTitelOperator.Size = New System.Drawing.Size(56, 13)
        Me.lblTitelOperator.TabIndex = 4
        Me.lblTitelOperator.Text = "Operator"
        '
        'lblTitelWert
        '
        Me.lblTitelWert.AutoSize = True
        Me.lblTitelWert.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblTitelWert.Location = New System.Drawing.Point(266, 17)
        Me.lblTitelWert.Name = "lblTitelWert"
        Me.lblTitelWert.Size = New System.Drawing.Size(34, 13)
        Me.lblTitelWert.TabIndex = 5
        Me.lblTitelWert.Text = "Wert"
        '
        'cbvalue2
        '
        Me.cbvalue2.FormattingEnabled = True
        Me.cbvalue2.Location = New System.Drawing.Point(265, 77)
        Me.cbvalue2.Name = "cbvalue2"
        Me.cbvalue2.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue2.TabIndex = 7
        '
        'cbop2
        '
        Me.cbop2.FormattingEnabled = True
        Me.cbop2.Location = New System.Drawing.Point(207, 77)
        Me.cbop2.Name = "cbop2"
        Me.cbop2.Size = New System.Drawing.Size(52, 21)
        Me.cbop2.TabIndex = 6
        '
        'cbvalue3
        '
        Me.cbvalue3.FormattingEnabled = True
        Me.cbvalue3.Location = New System.Drawing.Point(265, 104)
        Me.cbvalue3.Name = "cbvalue3"
        Me.cbvalue3.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue3.TabIndex = 12
        '
        'cbop3
        '
        Me.cbop3.FormattingEnabled = True
        Me.cbop3.Location = New System.Drawing.Point(207, 104)
        Me.cbop3.Name = "cbop3"
        Me.cbop3.Size = New System.Drawing.Size(52, 21)
        Me.cbop3.TabIndex = 11
        '
        'cbvalue4
        '
        Me.cbvalue4.FormattingEnabled = True
        Me.cbvalue4.Location = New System.Drawing.Point(265, 131)
        Me.cbvalue4.Name = "cbvalue4"
        Me.cbvalue4.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue4.TabIndex = 17
        '
        'cbop4
        '
        Me.cbop4.FormattingEnabled = True
        Me.cbop4.Location = New System.Drawing.Point(207, 131)
        Me.cbop4.Name = "cbop4"
        Me.cbop4.Size = New System.Drawing.Size(52, 21)
        Me.cbop4.TabIndex = 16
        '
        'cbvalue5
        '
        Me.cbvalue5.FormattingEnabled = True
        Me.cbvalue5.Location = New System.Drawing.Point(265, 158)
        Me.cbvalue5.Name = "cbvalue5"
        Me.cbvalue5.Size = New System.Drawing.Size(128, 21)
        Me.cbvalue5.TabIndex = 22
        '
        'cbop5
        '
        Me.cbop5.FormattingEnabled = True
        Me.cbop5.Location = New System.Drawing.Point(208, 158)
        Me.cbop5.Name = "cbop5"
        Me.cbop5.Size = New System.Drawing.Size(52, 21)
        Me.cbop5.TabIndex = 21
        '
        'Label6
        '
        Me.Label6.AutoSize = True
        Me.Label6.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, CType((System.Drawing.FontStyle.Bold Or System.Drawing.FontStyle.Underline), System.Drawing.FontStyle), System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label6.Location = New System.Drawing.Point(6, 17)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(59, 13)
        Me.Label6.TabIndex = 18
        Me.Label6.Text = "und/oder"
        '
        'cboxand1
        '
        Me.cboxand1.AutoSize = True
        Me.cboxand1.Location = New System.Drawing.Point(12, 77)
        Me.cboxand1.Name = "cboxand1"
        Me.cboxand1.Size = New System.Drawing.Size(15, 14)
        Me.cboxand1.TabIndex = 3
        Me.cboxand1.UseVisualStyleBackColor = True
        '
        'cboxor1
        '
        Me.cboxor1.AutoSize = True
        Me.cboxor1.Location = New System.Drawing.Point(39, 77)
        Me.cboxor1.Name = "cboxor1"
        Me.cboxor1.Size = New System.Drawing.Size(15, 14)
        Me.cboxor1.TabIndex = 4
        Me.cboxor1.UseVisualStyleBackColor = True
        '
        'cbparam1
        '
        Me.cbparam1.FormattingEnabled = True
        Me.cbparam1.Location = New System.Drawing.Point(73, 47)
        Me.cbparam1.Name = "cbparam1"
        Me.cbparam1.Size = New System.Drawing.Size(128, 21)
        Me.cbparam1.TabIndex = 0
        '
        'cbparam2
        '
        Me.cbparam2.FormattingEnabled = True
        Me.cbparam2.Location = New System.Drawing.Point(73, 77)
        Me.cbparam2.Name = "cbparam2"
        Me.cbparam2.Size = New System.Drawing.Size(128, 21)
        Me.cbparam2.TabIndex = 5
        '
        'cbparam3
        '
        Me.cbparam3.FormattingEnabled = True
        Me.cbparam3.Location = New System.Drawing.Point(73, 104)
        Me.cbparam3.Name = "cbparam3"
        Me.cbparam3.Size = New System.Drawing.Size(128, 21)
        Me.cbparam3.TabIndex = 10
        '
        'cbparam4
        '
        Me.cbparam4.FormattingEnabled = True
        Me.cbparam4.Location = New System.Drawing.Point(73, 131)
        Me.cbparam4.Name = "cbparam4"
        Me.cbparam4.Size = New System.Drawing.Size(128, 21)
        Me.cbparam4.TabIndex = 15
        '
        'cbparam5
        '
        Me.cbparam5.FormattingEnabled = True
        Me.cbparam5.Location = New System.Drawing.Point(73, 158)
        Me.cbparam5.Name = "cbparam5"
        Me.cbparam5.Size = New System.Drawing.Size(128, 21)
        Me.cbparam5.TabIndex = 20
        '
        'cboxor2
        '
        Me.cboxor2.AutoSize = True
        Me.cboxor2.Location = New System.Drawing.Point(39, 107)
        Me.cboxor2.Name = "cboxor2"
        Me.cboxor2.Size = New System.Drawing.Size(15, 14)
        Me.cboxor2.TabIndex = 9
        Me.cboxor2.UseVisualStyleBackColor = True
        '
        'cboxand2
        '
        Me.cboxand2.AutoSize = True
        Me.cboxand2.Location = New System.Drawing.Point(12, 107)
        Me.cboxand2.Name = "cboxand2"
        Me.cboxand2.Size = New System.Drawing.Size(15, 14)
        Me.cboxand2.TabIndex = 8
        Me.cboxand2.UseVisualStyleBackColor = True
        '
        'cboxor3
        '
        Me.cboxor3.AutoSize = True
        Me.cboxor3.Location = New System.Drawing.Point(39, 134)
        Me.cboxor3.Name = "cboxor3"
        Me.cboxor3.Size = New System.Drawing.Size(15, 14)
        Me.cboxor3.TabIndex = 14
        Me.cboxor3.UseVisualStyleBackColor = True
        '
        'cboxand3
        '
        Me.cboxand3.AutoSize = True
        Me.cboxand3.Location = New System.Drawing.Point(12, 134)
        Me.cboxand3.Name = "cboxand3"
        Me.cboxand3.Size = New System.Drawing.Size(15, 14)
        Me.cboxand3.TabIndex = 13
        Me.cboxand3.UseVisualStyleBackColor = True
        '
        'cboxor4
        '
        Me.cboxor4.AutoSize = True
        Me.cboxor4.Location = New System.Drawing.Point(39, 162)
        Me.cboxor4.Name = "cboxor4"
        Me.cboxor4.Size = New System.Drawing.Size(15, 14)
        Me.cboxor4.TabIndex = 19
        Me.cboxor4.UseVisualStyleBackColor = True
        '
        'cboxand4
        '
        Me.cboxand4.AutoSize = True
        Me.cboxand4.Location = New System.Drawing.Point(12, 162)
        Me.cboxand4.Name = "cboxand4"
        Me.cboxand4.Size = New System.Drawing.Size(15, 14)
        Me.cboxand4.TabIndex = 18
        Me.cboxand4.UseVisualStyleBackColor = True
        '
        'btnAufbereiten
        '
        Me.btnAufbereiten.Location = New System.Drawing.Point(318, 200)
        Me.btnAufbereiten.Name = "btnAufbereiten"
        Me.btnAufbereiten.Size = New System.Drawing.Size(75, 23)
        Me.btnAufbereiten.TabIndex = 23
        Me.btnAufbereiten.Text = "Aufbereiten"
        Me.btnAufbereiten.UseVisualStyleBackColor = True
        '
        'btnInitParams
        '
        Me.btnInitParams.Location = New System.Drawing.Point(12, 200)
        Me.btnInitParams.Name = "btnInitParams"
        Me.btnInitParams.Size = New System.Drawing.Size(75, 23)
        Me.btnInitParams.TabIndex = 24
        Me.btnInitParams.Text = "Parameter initialisieren"
        Me.btnInitParams.UseVisualStyleBackColor = True
        '
        'frmAuswertungsParameter
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(405, 234)
        Me.Controls.Add(Me.btnInitParams)
        Me.Controls.Add(Me.btnAufbereiten)
        Me.Controls.Add(Me.cboxor4)
        Me.Controls.Add(Me.cboxand4)
        Me.Controls.Add(Me.cboxor3)
        Me.Controls.Add(Me.cboxand3)
        Me.Controls.Add(Me.cboxor2)
        Me.Controls.Add(Me.cboxand2)
        Me.Controls.Add(Me.cbparam5)
        Me.Controls.Add(Me.cbparam4)
        Me.Controls.Add(Me.cbparam3)
        Me.Controls.Add(Me.cbparam2)
        Me.Controls.Add(Me.cbparam1)
        Me.Controls.Add(Me.cboxor1)
        Me.Controls.Add(Me.cboxand1)
        Me.Controls.Add(Me.Label6)
        Me.Controls.Add(Me.cbvalue5)
        Me.Controls.Add(Me.cbop5)
        Me.Controls.Add(Me.cbvalue4)
        Me.Controls.Add(Me.cbop4)
        Me.Controls.Add(Me.cbvalue3)
        Me.Controls.Add(Me.cbop3)
        Me.Controls.Add(Me.cbvalue2)
        Me.Controls.Add(Me.cbop2)
        Me.Controls.Add(Me.lblTitelWert)
        Me.Controls.Add(Me.lblTitelOperator)
        Me.Controls.Add(Me.lblParamTitel)
        Me.Controls.Add(Me.cbvalue1)
        Me.Controls.Add(Me.cbop1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmAuswertungsParameter"
        Me.Text = "Auswertungsparameter"
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.btnAufbereiten_Click -Methode

[Visual Basic]
Private Sub btnAufbereiten_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAufbereiten.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAufbereiten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAufbereiten.Click
        Dim sqlwhere As String = ""
        If Me.cbvalue1.Text = "" Then
            Me.SQLWhere = ""
            Me.DialogResult = Windows.Forms.DialogResult.OK
            Me.Close()
            Exit Sub
        End If
        sqlwhere = sqlwhere + get_where(1)
        If Me.cboxand1.Checked = True Then
            sqlwhere = sqlwhere + " and " + get_where(2)
        End If
        If Me.cboxor1.Checked = True Then
            sqlwhere = sqlwhere + " or " + get_where(2)
        End If
        If Me.cboxand2.Checked = True Then
            sqlwhere = sqlwhere + " and " + get_where(3)
        End If
        If Me.cboxor2.Checked = True Then
            sqlwhere = sqlwhere + " or " + get_where(3)
        End If
        If Me.cboxand3.Checked = True Then
            sqlwhere = sqlwhere + " and " + get_where(4)
        End If
        If Me.cboxor3.Checked = True Then
            sqlwhere = sqlwhere + " or " + get_where(4)
        End If
        If Me.cboxand4.Checked = True Then
            sqlwhere = sqlwhere + " and " + get_where(5)
        End If
        If Me.cboxor4.Checked = True Then
            sqlwhere = sqlwhere + " or " + get_where(5)
        End If
        Me.SQLWhere = sqlwhere
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.cboxand1_CheckedChanged -Methode

[Visual Basic]
Private Sub cboxand1_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxand1.CheckedChanged, _
   cboxand2.CheckedChanged, _
   cboxand3.CheckedChanged, _
   cboxand4.CheckedChanged, _
   cboxor1.CheckedChanged, _
   cboxor2.CheckedChanged, _
   cboxor3.CheckedChanged, _
   cboxor4.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxand1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxand1.CheckedChanged, _
                cboxand2.CheckedChanged, cboxand3.CheckedChanged, cboxand4.CheckedChanged, cboxor1.CheckedChanged, cboxor2.CheckedChanged, _
                cboxor3.CheckedChanged, cboxor4.CheckedChanged
        Dim s As String = sender.name
        l.Clear()
        s = s.Substring(Len(s) - 1, 1)
        Dim feld As String = ""

        If sender.name.ToString.IndexOf("and") > 0 Then feld = "cboxor" + s Else feld = "cboxand" + s
        Me.GetControl(Me, feld, l)
        For Each x As CheckBox In l
            x.Checked = False
        Next
        s = s + 1
        feld = "cbparam" + s
        l.Clear()
        Me.GetControl(Me, feld, l)
        For Each x As ComboBox In l
            x.Enabled = True
        Next
        feld = "cbop" + s
        l.Clear()
        Me.GetControl(Me, feld, l)
        For Each x As ComboBox In l
            x.Enabled = True
        Next
        feld = "cbvalue" + s
        l.Clear()
        Me.GetControl(Me, feld, l)
        For Each x As ComboBox In l
            x.Enabled = True
        Next

        feld = "cboxand" + s
        l.Clear()
        Me.GetControl(Me, feld, l)
        For Each x As ComboBox In l
            x.Enabled = True
        Next
        feld = "cboxor" + s
        l.Clear()
        Me.GetControl(Me, feld, l)
        For Each x As ComboBox In l
            x.Enabled = True
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.cbparam1_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cbparam1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbparam1.SelectedIndexChanged, _
   cbparam2.SelectedIndexChanged, _
   cbparam3.SelectedIndexChanged, _
   cbparam4.SelectedIndexChanged, _
   cbparam5.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbparam1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbparam1.SelectedIndexChanged, cbparam2.SelectedIndexChanged, _
                cbparam3.SelectedIndexChanged, cbparam4.SelectedIndexChanged, cbparam5.SelectedIndexChanged
        Dim s As String = sender.name
        Dim splits() As String

        s = s.Substring(Len(s) - 1, 1)
        Dim cbop As String = "cbop" + s

        Dim dr As DataRow
        dr = Findrow(sender.text)

        l.Clear()
        Me.GetControl(Me, cbop, l)

        For Each ob As ComboBox In l
            ob.Items.Clear()
            splits = dr.Item("Operator").ToString.Split(";")
            For Each x As String In splits
                ob.Items.Add(x)
            Next
            ob.SelectedIndex = 0
        Next
        If dr.Item("Feldbezug").ToString <> "" Then
            If UCase(dr.Item("feldbezug").ToString.Substring(0, 3)) = "SP_" Then
                Dim fb As New DataTable
                fb = get_rptparam_values(dr.Item("Feldbezug"))

                Dim cbvalue As String = "cbvalue" + s
                l.Clear()
                Me.GetControl(Me, cbvalue, l)
                For Each x As ComboBox In l
                    x.DataSource = Nothing
                    x.Items.Clear()
                    x.DataSource = fb
                    x.DisplayMember = "Bezeichnung"
                    x.ValueMember = "KeyValue"
                Next
            Else
                If dr.Item("Feldbezug").ToString <> "" Then
                    Dim selval() As String = dr.Item("Feldbezug").ToString.Split(";")
                    Dim cbvalue As String = "cbvalue" + s
                    l.Clear()
                    Me.GetControl(Me, cbvalue, l)
                    For Each x As ComboBox In l
                        x.DataSource = Nothing
                        x.Items.Clear()
                        For Each ss As String In selval
                            x.Items.Add(ss)
                        Next
                    Next
                End If
            End If

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.cbvalue1_DropDown -Methode

[Visual Basic]
Private Sub cbvalue1_DropDown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbvalue1.DropDown, _
   cbvalue2.DropDown, _
   cbvalue3.DropDown, _
   cbvalue4.DropDown, _
   cbvalue5.DropDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbvalue1_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbvalue1.DropDown, cbvalue2.DropDown, _
    cbvalue3.DropDown, cbvalue4.DropDown, cbvalue5.DropDown
        Try
            Dim s As String = sender.name
            s = s.Substring(Len(s) - 1, 1)
            Dim nr As Integer = s
            Dim param As New ComboBox

            Dim op As New ComboBox
            Dim val As New ComboBox

            Dim feld As String
            Dim dr As DataRow
            feld = "cbparam" + Trim(Str(nr))
            l.Clear()
            Me.GetControl(Me, feld, l)
            param = l.Item(0)

            feld = "cbvalue" + Trim(Str(nr))
            l.Clear()
            Me.GetControl(Me, feld, l)
            val = l.Item(0)

            dr = Me.Findrow(param.Text)

            If dr.Item("Paramtype") = "Datum" Then
                Dim f As New frmCalendar

                f.Top = val.Top + val.Height
                f.Left = val.Left + val.Width - 10
                f.ShowDialog()
                If f.DialogResult = Windows.Forms.DialogResult.OK Then
                    l.Clear()
                    feld = "cbvalue" + Trim(Str(nr))
                    l.Clear()
                    Me.GetControl(Me, feld, l)
                    param = l.Item(0)
                    param.Text = f.MonthCalendar1.SelectionRange.Start.Date
                End If
            End If
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.cbvalue1_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cbvalue1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbvalue1.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbvalue1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbvalue1.SelectedIndexChanged

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.frmAuswertungsParameter_Load -Methode

[Visual Basic]
Private Sub frmAuswertungsParameter_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmAuswertungsParameter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        init_params()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.frmAuswertungsParameter_MouseMove -Methode

[Visual Basic]
Private Sub frmAuswertungsParameter_MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   Me.MouseMove

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmAuswertungsParameter_MouseMove(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Me.MouseMove
        selectPoint.Y = e.Y
        selectPoint.X = e.X
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.get_rptparam_values -Methode

[Visual Basic]
Private Function get_rptparam_values( _
   ByVal sp As String _
) As DataTable

Parameter

sp

Quellcode

[Visual Basic]
    Private Function get_rptparam_values(ByVal sp As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = sp
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.get_where -Methode

[Visual Basic]
Private Function get_where( _
   ByVal nr As Integer _
) As String

Parameter

nr

Quellcode

[Visual Basic]
    Private Function get_where(ByVal nr As Integer) As String
        Dim param As New ComboBox
        Dim op As New ComboBox
        Dim val As New ComboBox

        l.Clear()
        Dim feld As String
        Dim dr As DataRow
        feld = "cbparam" + Trim(Str(nr))
        Me.GetControl(Me, feld, l)
        param = l.Item(0)

        l.Clear()
        feld = "cbop" + Trim(Str(nr))
        Me.GetControl(Me, feld, l)
        op = l.Item(0)

        l.Clear()
        feld = "cbvalue" + Trim(Str(nr))
        Me.GetControl(Me, feld, l)
        val = l.Item(0)

        dr = Me.Findrow(param.Text)

        Dim wertvalue As String = ""
        Dim wertdbfeld As String = ""
        Dim wertop As String = op.Text

        wertop = op.Text

        Dim paramtyp As String = ""
        Dim paramsplit() As String = dr.Item("Paramtype").ToString.Split(";")

        Dim dbfeldsplit() As String = dr.Item("dbfeldname").ToString.Split(";")
        If dbfeldsplit.Length > 1 And val.SelectedIndex > -1 Then
            wertvalue = val.SelectedValue
            wertdbfeld = dbfeldsplit(0)
            paramtyp = paramsplit(0)
        Else
            wertvalue = val.Text
            If dbfeldsplit.Length > 1 Then
                wertdbfeld = dbfeldsplit(1)
                paramtyp = paramsplit(1)
            Else
                wertdbfeld = dbfeldsplit(0)
                paramtyp = paramsplit(0)
            End If
        End If

        Select Case UCase(paramtyp)
            Case "VARCHAR", "STRING", "CHAR"
                Return wertdbfeld + " " + wertop + " '" + wertvalue + "'"
            Case "INTEGER", "INT"
                Return wertdbfeld + " " + wertop + " " + wertvalue + ""
            Case "DATUM"
                Return wertdbfeld + " " + wertop + " '" + wertvalue + " 00:00:00'"
            Case "DATUM+1"
                Dim d As DateTime = wertvalue
                d = DateAdd(DateInterval.Day, 1, d)
                wertvalue = d.ToString
                Return wertdbfeld + " " + wertop + " '" + wertvalue + " 00:00:00'"
            Case "BOOLEAN"
                If UCase(wertvalue) = "TRUE" Or UCase(wertvalue) = "JA" Then
                    Return wertdbfeld + " " + wertop + " 1"
                Else
                    Return wertdbfeld + " " + wertop + " 0"
                End If
            Case Else

        End Select

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter.init_params -Methode

[Visual Basic]
Private Sub init_params()

Quellcode

[Visual Basic]
    Private Sub init_params()

        l.Clear()
        Me.GetControl(Me, "cbox*", l)
        For Each x As CheckBox In l
            x.Checked = False
        Next
        l.Clear()
        Me.GetControl(Me, "cbp*", l)
        For Each x As ComboBox In l
            Try
                x.DataSource = Nothing
                x.Items.Clear()
            Catch ex As Exception

            End Try
        Next
        l.Clear()
        Me.GetControl(Me, "cbl*", l)
        For Each x As ComboBox In l
            Try
                x.DataSource = Nothing
                x.Items.Clear()
            Catch ex As Exception

            End Try
        Next
        l.Clear()
        Me.GetControl(Me, "cbv*", l)
        For Each x As ComboBox In l
            Try
                x.DataSource = Nothing
                x.Items.Clear()
            Catch ex As Exception

            End Try
        Next
        l.Clear()
        Me.GetControl(Me, "cb*", l)
        For Each c As Control In l
            c.Enabled = False
        Next

        Me.cboxand1.Enabled = True
        Me.cboxor1.Enabled = True
        Me.cbparam1.Enabled = True
        Me.cbop1.Enabled = True
        Me.cbvalue1.Enabled = True

        For Each dr As DataRow In parameter.Rows
            cbparam1.Items.Add(dr.Item("Bezeichnung"))
            cbparam2.Items.Add(dr.Item("Bezeichnung"))
            cbparam3.Items.Add(dr.Item("Bezeichnung"))
            cbparam4.Items.Add(dr.Item("Bezeichnung"))
            cbparam5.Items.Add(dr.Item("Bezeichnung"))
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmAuswertungsParameter-Felder

frmAuswertungsParameter Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field l

Unterstützt von .NET Compact Framework
private field m_sqlwhere

Unterstützt von .NET Compact Framework
private field parameter

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework

frmAuswertungsParameter -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


l -Feld

[Visual Basic]
Private l As List(Of Control)

Quellcode

[Visual Basic]
    Dim l As New List(Of Control)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


m_sqlwhere -Feld

[Visual Basic]
Private m_sqlwhere As String

Quellcode

[Visual Basic]
    Dim m_sqlwhere As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


parameter -Feld

[Visual Basic]
Private parameter As DataTable

Quellcode

[Visual Basic]
    Dim parameter As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


frmCalendar -Klasse

For a list of all members of this type, see frmCalendar-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmCalendar

[Visual Basic]
Public Class frmCalendar
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmCalendar-Member


frmCalendar-Member

frmCalendar Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method MonthCalendar1_DateChanged

Unterstützt von .NET Compact Framework
private method MonthCalendar1_KeyDown

Unterstützt von .NET Compact Framework
private method btnok_Click

Unterstützt von .NET Compact Framework
private method frmCalendar_KeyDown

Unterstützt von .NET Compact Framework
private method frmCalendar_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmCalendar -Klasse


frmCalendar-Methoden

frmCalendar Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method MonthCalendar1_DateChanged

Unterstützt von .NET Compact Framework
private method MonthCalendar1_KeyDown

Unterstützt von .NET Compact Framework
private method btnok_Click

Unterstützt von .NET Compact Framework
private method frmCalendar_KeyDown

Unterstützt von .NET Compact Framework
private method frmCalendar_Load

Unterstützt von .NET Compact Framework

frmCalendar -Klasse


frmCalendar.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.MonthCalendar1 = New System.Windows.Forms.MonthCalendar
        Me.btnok = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'MonthCalendar1
        '
        Me.MonthCalendar1.Dock = System.Windows.Forms.DockStyle.Top
        Me.MonthCalendar1.Location = New System.Drawing.Point(0, 0)
        Me.MonthCalendar1.Name = "MonthCalendar1"
        Me.MonthCalendar1.TabIndex = 0
        '
        'btnok
        '
        Me.btnok.Dock = System.Windows.Forms.DockStyle.Top
        Me.btnok.Location = New System.Drawing.Point(0, 163)
        Me.btnok.Name = "btnok"
        Me.btnok.Size = New System.Drawing.Size(162, 23)
        Me.btnok.TabIndex = 1
        Me.btnok.Text = "OK"
        Me.btnok.UseVisualStyleBackColor = True
        '
        'frmCalendar
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(162, 183)
        Me.Controls.Add(Me.btnok)
        Me.Controls.Add(Me.MonthCalendar1)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Name = "frmCalendar"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.Manual
        Me.Text = "Kalender"
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.MonthCalendar1_DateChanged -Methode

[Visual Basic]
Private Sub MonthCalendar1_DateChanged( _
   ByVal sender As Object, _
   ByVal e As DateRangeEventArgs _
) Handles  _
   MonthCalendar1.DateChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MonthCalendar1_DateChanged(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DateRangeEventArgs) Handles MonthCalendar1.DateChanged
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.MonthCalendar1_KeyDown -Methode

[Visual Basic]
Private Sub MonthCalendar1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   MonthCalendar1.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MonthCalendar1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles MonthCalendar1.KeyDown
        If e.KeyCode = Keys.Escape Then
            Me.DialogResult = Windows.Forms.DialogResult.Cancel
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.btnok_Click -Methode

[Visual Basic]
Private Sub btnok_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnok.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnok_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnok.Click
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.frmCalendar_KeyDown -Methode

[Visual Basic]
Private Sub frmCalendar_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   Me.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmCalendar_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles Me.KeyDown
        If e.KeyCode = Keys.Escape Then
            Me.DialogResult = Windows.Forms.DialogResult.Cancel
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar.frmCalendar_Load -Methode

[Visual Basic]
Private Sub frmCalendar_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmCalendar_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmCalendar-Felder

frmCalendar Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmCalendar -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmCalendar


frmDatenbankauswahl -Klasse

Form für die Datenbankauswahl

For a list of all members of this type, see frmDatenbankauswahl-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDatenbankauswahl

[Visual Basic]
Public Class frmDatenbankauswahl
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmDatenbankauswahl-Member


frmDatenbankauswahl-Member

frmDatenbankauswahl Übersicht

Öffentliche Konstruktoren

public constructor frmDatenbankauswahl -Konstructor

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method ListBox1_DoubleClick

Unterstützt von .NET Compact Framework
private method ListBox1_KeyDown

Unterstützt von .NET Compact Framework
private method frmDatenbankauswahl_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmDatenbankauswahl -Klasse


frmDatenbankauswahl -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl-Methoden

frmDatenbankauswahl Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Button1_Click

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method ListBox1_DoubleClick

Unterstützt von .NET Compact Framework
private method ListBox1_KeyDown

Unterstützt von .NET Compact Framework
private method frmDatenbankauswahl_Load

Unterstützt von .NET Compact Framework

frmDatenbankauswahl -Klasse


frmDatenbankauswahl.Button1_Click -Methode

[Visual Basic]
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl.Dispose -Methode

[Visual Basic]
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDatenbankauswahl))
        Me.ListBox1 = New System.Windows.Forms.ListBox
        Me.Button1 = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(232, 95)
        Me.ListBox1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(88, 128)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(75, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&OK"
        '
        'frmDatenbankauswahl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(258, 165)
        Me.Controls.Add(Me.Button1)
        Me.Controls.Add(Me.ListBox1)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDatenbankauswahl"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Vertragsverwaltung: Datebbankauswahl"
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl.ListBox1_DoubleClick -Methode

[Visual Basic]
Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox1.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl.ListBox1_KeyDown -Methode

[Visual Basic]
Private Sub ListBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   ListBox1.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ListBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles ListBox1.KeyDown
        If e.KeyCode = Keys.Enter Then Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl.frmDatenbankauswahl_Load -Methode

[Visual Basic]
Private Sub frmDatenbankauswahl_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDatenbankauswahl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDatenbankauswahl-Felder

frmDatenbankauswahl Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmDatenbankauswahl -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDatenbankauswahl


frmDokument -Klasse

For a list of all members of this type, see frmDokument-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDokument

[Visual Basic]
Public Class frmDokument
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmDokument-Member


frmDokument-Member

frmDokument Übersicht

Öffentliche Konstruktoren

public constructor frmDokument -Konstructor

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Ablage_Orte_Aktualisieren Unterstützt von .NET Compact Framework | Ablageorte für das aktuelle Dokument anzeigen
private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden. Beim Speichern werden ebenfalls allfällige Änderungen von C1DokumentAblagoeOrt durchgeführt. Wurden lediglich Änderungen bei C1Dokumentablageort vorgenommen, wird separat gefrat, ob die Änderungen gespeichert werden sollen.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method brnFileOpen_Click Unterstützt von .NET Compact Framework | Auswahl des zu speichernden Dokumentes
private method btnDokumentAnzeigen_Click Unterstützt von .NET Compact Framework | Dokument anzeigen
private method frmDokument_Load Unterstützt von .NET Compact Framework | Formular-Load
private method txtDateiname_TextChanged Unterstützt von .NET Compact Framework | Text-Change von Txt-Dateiname

Felder

private field Aktueller_Doktype Unterstützt von .NET Compact Framework | Doktype 1: Vertragselement 2: Test-Drehbuch 3: Applikationsdokument 4: Applikationlogbuch
private field Aktuelles_Dokument Unterstützt von .NET Compact Framework |
private field Aktuelles_Element Unterstützt von .NET Compact Framework |
private field Anzeige Unterstützt von .NET Compact Framework |
private field Doktype Unterstützt von .NET Compact Framework |
private field Dokument Unterstützt von .NET Compact Framework |
private field DokumentAblageTyp Unterstützt von .NET Compact Framework |
private field DokumentAblageTypen Unterstützt von .NET Compact Framework |
private field FormDataChanged Unterstützt von .NET Compact Framework |
private field FormReadonly Unterstützt von .NET Compact Framework |
private field Neuer_Datensatz Unterstützt von .NET Compact Framework |
private field SaveFileName Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field msg Unterstützt von .NET Compact Framework |
private field sec Unterstützt von .NET Compact Framework |

frmDokument -Klasse


frmDokument -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal DokumentNr As Integer, _
   ByVal Doktype As Integer, _
   Optional ByVal Elementnr As Integer = -1, _
   Optional ByVal Anzeige As Boolean = False, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

DokumentNr
Optionaler Parameter Dokumentnummer des aktuellen Dokuments
Doktype
Erforderlich.
Elementnr
Optional. Der Standardwert ist -1.
Anzeige
Optional. Der Standardwert ist False.
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal DokumentNr As Integer, ByVal Doktype As Integer, Optional ByVal Elementnr As Integer = -1, Optional ByVal Anzeige As Boolean = False, Optional ByVal CreateNew As Boolean = False)
        Me.InitializeComponent()
        If CreateNew Then
            Me.Aktuelles_Dokument = Me.Dokument.Add_New(Elementnr, DokType)
            Me.Neuer_Datensatz = True
        Else
            Me.Aktuelles_Dokument = DokumentNr
        End If
        Me.Anzeige = Anzeige
        Me.Aktuelles_Element = Elementnr
        Me.Doktype = Doktype
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument-Methoden

frmDokument Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Ablage_Orte_Aktualisieren Unterstützt von .NET Compact Framework | Ablageorte für das aktuelle Dokument anzeigen
private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden. Beim Speichern werden ebenfalls allfällige Änderungen von C1DokumentAblagoeOrt durchgeführt. Wurden lediglich Änderungen bei C1Dokumentablageort vorgenommen, wird separat gefrat, ob die Änderungen gespeichert werden sollen.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method brnFileOpen_Click Unterstützt von .NET Compact Framework | Auswahl des zu speichernden Dokumentes
private method btnDokumentAnzeigen_Click Unterstützt von .NET Compact Framework | Dokument anzeigen
private method frmDokument_Load Unterstützt von .NET Compact Framework | Formular-Load
private method txtDateiname_TextChanged Unterstützt von .NET Compact Framework | Text-Change von Txt-Dateiname

frmDokument -Klasse


frmDokument.Ablage_Orte_Aktualisieren -Methode

Ablageorte für das aktuelle Dokument anzeigen

[Visual Basic]
Private Sub Ablage_Orte_Aktualisieren()

Quellcode

[Visual Basic]
    Private Sub Ablage_Orte_Aktualisieren()
        Me.Dokument.Get_Ablageorte(Me.C1DokumentAblageOrt, Me.Dokument.iDokumentNr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DokumentAblageOrt, "Dokumentablageort", Me.Dokument.Dokumentablageort.Tabledata)

        Me.DokumentAblageTypen.Rows.Clear()
        Me.DokumentAblageTyp.cpMainConnectionProvider = Globals.conn
        Me.DokumentAblageTypen = Me.DokumentAblageTyp.SelectAll

        Me.C1DropDownDokumentablagetyp.DataSource = Me.DokumentAblageTypen
        Me.C1DropDownDokumentablagetyp.ValueMember = "Dokumentablagetypnr"
        Me.C1DropDownDokumentablagetyp.DisplayMember = "Bezeichnung"
        Me.C1DropDownDokumentablagetyp.ValueTranslate = True

        Me.C1DokumentAblageOrt.Columns("Dokumentablagetypnr").DropDown = Me.C1DropDownDokumentablagetyp
        Me.C1DokumentAblageOrt.Columns("Dokumentablagetypnr").ValueItems.Translate = True
        Dim i As Integer
        For i = 0 To Me.C1DropDownDokumentablagetyp.DisplayColumns.Count - 1
            If i <> 1 Then
                Me.C1DropDownDokumentablagetyp.DisplayColumns(i).Width = 0
            Else
                Me.C1DropDownDokumentablagetyp.DisplayColumns(1).Width = Me.C1DropDownDokumentablagetyp.Width
            End If
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.C1Daten_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Daten_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1DokumentAblageOrt.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1DokumentAblageOrt.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1DokumentAblageOrt.Columns.Count - 1
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mutiert_am" Then Me.C1DokumentAblageOrt.Columns(i).Value = Now
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mutierer" Then Me.C1DokumentAblageOrt.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1DokumentAblageOrt.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey("DokumentAblageOrt")
                Me.C1DokumentAblageOrt.Columns(0).Value = key
                For i = 0 To Me.C1DokumentAblageOrt.Columns.Count - 1
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mandantnr" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "securitylevel" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "aktiv" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "extern" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "dokumentnr" Then
                        Me.C1DokumentAblageOrt.Columns(i).Value = Me.Dokument.iDokumentNr.Value
                    End If

                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.C1Daten_AfterInsert -Methode

Aktualisierung der Default-Werte

[Visual Basic]
Private Sub C1Daten_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1DokumentAblageOrt.AfterInsert

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1DokumentAblageOrt.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1DokumentAblageOrt.Columns.Count - 1
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "aktiv" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = 1
                End If
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "dokumentnr" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = Me.Dokument.iDokumentNr.Value
                End If
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = Now
                End If
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mutierer" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mandantnr" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1DokumentAblageOrt.Columns(i).DataField) = "mandnat" Then
                    Me.C1DokumentAblageOrt.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.C1Daten_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Daten_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1DokumentAblageOrt.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1DokumentAblageOrt.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = "DokumentAblageOrt"
        Try
            ts.Feld = Me.C1DokumentAblageOrt.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden. Beim Speichern werden ebenfalls allfällige Änderungen von C1DokumentAblagoeOrt durchgeführt. Wurden lediglich Änderungen bei C1Dokumentablageort vorgenommen, wird separat gefrat, ob die Änderungen gespeichert werden sollen.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            If Me.Dokument.Dokumentablageort.Tabledata.HasChanges Then
                Dim msgboxres As MsgBoxResult
                msgboxres = msg.Show_MessageYesNoCancel(3)
                If msgboxres = MsgBoxResult.Cancel Then
                    Return True
                End If
                If msgboxres = MsgBoxResult.Yes Then
                    Me.Dokument.Dokumentablageort.Save_Data()
                    Return True
                End If
                Return True
            Else
                Return True
            End If
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerVersionsdatum.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dtPickerVersionsdatum.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.Dokument.Neuer_Datensatz = True Then Me.Dokument.Delete(Me.Dokument.iDokumentNr.Value)
            Globals.MyEventHanlder.Dokumente_Closed()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Dokumentnr As Integer _
)

Parameter

Dokumentnr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Dokumentnr As Integer)
        Try
            Dokument.Get_Dokumenttypen()
            Dokument.Get_Dokument(Dokumentnr)
            Me.txtBezeichnung.Text = Dokument.sBezeichnung.Value
            Me.cboxDokumenttyp.SelectedValue = Dokument.iDokumenttypNr.Value
            Me.txtBeschreibung.Text = Dokument.sBeschreibung.Value
            Me.txtVersion.Text = Dokument.sVersion.ToString
            Me.txtVersionsdatum.Text = Dokument.daVersionsdatum.ToString
            Me.txtDateiname.Text = Dokument.sFilename.Value
            If Me.txtDateiname.Text <> "" Then Me.btnDokumentAnzeigen.Enabled = True Else Me.btnDokumentAnzeigen.Enabled = False
            Me.txtDateiname.ReadOnly = True

            Me.SaveFileName = Me.txtDateiname.Text
            Me.txtOriginalFilename_incl_path.Text = Dokument.sOriginalFilename_incl_Path.Value
            Me.txtErstellt_am.Text = Dokument.daErstellt_am.ToString
            Me.txtMutiert_am.Text = Dokument.daMutiert_am.ToString
            Me.txtMutierer.Text = Dokument.iMutierer.Value
            Try
                Me.cbaktiv.Checked = Dokument.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            If Not Anzeige Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False

        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try

        Ablage_Orte_Aktualisieren()
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDokument))
        Dim Style1 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style2 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style3 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style4 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style5 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style6 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style7 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style8 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.lblBeschreibung = New System.Windows.Forms.Label
        Me.txtBeschreibung = New System.Windows.Forms.TextBox
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.dtPickerVersionsdatum = New System.Windows.Forms.DateTimePicker
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.lblVersionsdatum = New System.Windows.Forms.Label
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.lblDokumenttyp = New System.Windows.Forms.Label
        Me.cboxDokumenttyp = New System.Windows.Forms.ComboBox
        Me.txtFilename = New System.Windows.Forms.TextBox
        Me.lbldatei = New System.Windows.Forms.Label
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog
        Me.txtDateiname = New System.Windows.Forms.TextBox
        Me.txtOriginalFilename_incl_path = New System.Windows.Forms.TextBox
        Me.brnFileOpen = New System.Windows.Forms.Button
        Me.btnDokumentAnzeigen = New System.Windows.Forms.Button
        Me.lblEx = New System.Windows.Forms.Label
        Me.grpDokumentablageOrt = New System.Windows.Forms.GroupBox
        Me.C1DokumentAblageOrt = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1DropDownDokumentablagetyp = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.grpDokumentablageOrt.SuspendLayout()
        CType(Me.C1DokumentAblageOrt, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1DropDownDokumentablagetyp, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(579, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(579, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        Me.TSBtnSuche.Visible = False
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.AccessibleDescription = "Name"
        Me.lblBeschreibung.AutoSize = True
        Me.lblBeschreibung.Location = New System.Drawing.Point(9, 63)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(72, 13)
        Me.lblBeschreibung.TabIndex = 155
        Me.lblBeschreibung.Text = "Beschreibung"
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Location = New System.Drawing.Point(98, 60)
        Me.txtBeschreibung.Multiline = True
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(268, 45)
        Me.txtBeschreibung.TabIndex = 2
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(463, 56)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(97, 20)
        Me.txtMutierer.TabIndex = 153
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(463, 32)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(97, 20)
        Me.txtMutiert_am.TabIndex = 152
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(463, 6)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(97, 20)
        Me.txtErstellt_am.TabIndex = 151
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(392, 59)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 150
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(393, 35)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 149
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(392, 9)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 148
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(463, 110)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(97, 21)
        Me.cboxSecurityLevel.TabIndex = 11
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(391, 113)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 147
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(390, 85)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(87, 17)
        Me.cbaktiv.TabIndex = 10
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'dtPickerVersionsdatum
        '
        Me.dtPickerVersionsdatum.Location = New System.Drawing.Point(343, 110)
        Me.dtPickerVersionsdatum.Name = "dtPickerVersionsdatum"
        Me.dtPickerVersionsdatum.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVersionsdatum.TabIndex = 5
        Me.dtPickerVersionsdatum.TabStop = False
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.Location = New System.Drawing.Point(280, 110)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 4
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'lblVersionsdatum
        '
        Me.lblVersionsdatum.AutoSize = True
        Me.lblVersionsdatum.Location = New System.Drawing.Point(189, 113)
        Me.lblVersionsdatum.Name = "lblVersionsdatum"
        Me.lblVersionsdatum.Size = New System.Drawing.Size(76, 13)
        Me.lblVersionsdatum.TabIndex = 159
        Me.lblVersionsdatum.Text = "Versionsdatum"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(98, 7)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 0
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(98, 110)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(84, 20)
        Me.txtVersion.TabIndex = 3
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(9, 113)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(42, 13)
        Me.lblVersion.TabIndex = 162
        Me.lblVersion.Text = "Version"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(9, 10)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 161
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblDokumenttyp
        '
        Me.lblDokumenttyp.AutoSize = True
        Me.lblDokumenttyp.Location = New System.Drawing.Point(9, 36)
        Me.lblDokumenttyp.Name = "lblDokumenttyp"
        Me.lblDokumenttyp.Size = New System.Drawing.Size(70, 13)
        Me.lblDokumenttyp.TabIndex = 166
        Me.lblDokumenttyp.Text = "Dokumenttyp"
        '
        'cboxDokumenttyp
        '
        Me.cboxDokumenttyp.FormattingEnabled = True
        Me.cboxDokumenttyp.Location = New System.Drawing.Point(98, 33)
        Me.cboxDokumenttyp.Name = "cboxDokumenttyp"
        Me.cboxDokumenttyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxDokumenttyp.TabIndex = 1
        '
        'txtFilename
        '
        Me.txtFilename.Location = New System.Drawing.Point(98, 163)
        Me.txtFilename.Name = "txtFilename"
        Me.txtFilename.Size = New System.Drawing.Size(268, 20)
        Me.txtFilename.TabIndex = 8
        '
        'lbldatei
        '
        Me.lbldatei.AutoSize = True
        Me.lbldatei.Location = New System.Drawing.Point(9, 165)
        Me.lbldatei.Name = "lbldatei"
        Me.lbldatei.Size = New System.Drawing.Size(32, 13)
        Me.lbldatei.TabIndex = 168
        Me.lbldatei.Text = "Datei"
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.FileName = "OpenFileDialog1"
        '
        'txtDateiname
        '
        Me.txtDateiname.Location = New System.Drawing.Point(98, 136)
        Me.txtDateiname.Name = "txtDateiname"
        Me.txtDateiname.Size = New System.Drawing.Size(268, 20)
        Me.txtDateiname.TabIndex = 6
        '
        'txtOriginalFilename_incl_path
        '
        Me.txtOriginalFilename_incl_path.Location = New System.Drawing.Point(395, 136)
        Me.txtOriginalFilename_incl_path.Name = "txtOriginalFilename_incl_path"
        Me.txtOriginalFilename_incl_path.Size = New System.Drawing.Size(169, 20)
        Me.txtOriginalFilename_incl_path.TabIndex = 12
        Me.txtOriginalFilename_incl_path.Visible = False
        '
        'brnFileOpen
        '
        Me.brnFileOpen.Image = CType(resources.GetObject("brnFileOpen.Image"), System.Drawing.Image)
        Me.brnFileOpen.Location = New System.Drawing.Point(363, 162)
        Me.brnFileOpen.Name = "brnFileOpen"
        Me.brnFileOpen.Size = New System.Drawing.Size(24, 24)
        Me.brnFileOpen.TabIndex = 9
        Me.brnFileOpen.UseVisualStyleBackColor = True
        '
        'btnDokumentAnzeigen
        '
        Me.btnDokumentAnzeigen.Image = CType(resources.GetObject("btnDokumentAnzeigen.Image"), System.Drawing.Image)
        Me.btnDokumentAnzeigen.Location = New System.Drawing.Point(363, 133)
        Me.btnDokumentAnzeigen.Name = "btnDokumentAnzeigen"
        Me.btnDokumentAnzeigen.Size = New System.Drawing.Size(24, 24)
        Me.btnDokumentAnzeigen.TabIndex = 7
        Me.btnDokumentAnzeigen.UseVisualStyleBackColor = True
        '
        'lblEx
        '
        Me.lblEx.AutoSize = True
        Me.lblEx.Location = New System.Drawing.Point(9, 139)
        Me.lblEx.Name = "lblEx"
        Me.lblEx.Size = New System.Drawing.Size(59, 13)
        Me.lblEx.TabIndex = 173
        Me.lblEx.Text = "Best. Datei"
        '
        'grpDokumentablageOrt
        '
        Me.grpDokumentablageOrt.Controls.Add(Me.C1DokumentAblageOrt)
        Me.grpDokumentablageOrt.Controls.Add(Me.C1DropDownDokumentablagetyp)
        Me.grpDokumentablageOrt.Dock = System.Windows.Forms.DockStyle.Fill
        Me.grpDokumentablageOrt.Location = New System.Drawing.Point(0, 239)
        Me.grpDokumentablageOrt.Name = "grpDokumentablageOrt"
        Me.grpDokumentablageOrt.Size = New System.Drawing.Size(579, 161)
        Me.grpDokumentablageOrt.TabIndex = 174
        Me.grpDokumentablageOrt.TabStop = False
        Me.grpDokumentablageOrt.Text = "AblageOrte"
        '
        'C1DokumentAblageOrt
        '
        Me.C1DokumentAblageOrt.AllowAddNew = True
        Me.C1DokumentAblageOrt.AlternatingRows = True
        Me.C1DokumentAblageOrt.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DokumentAblageOrt.FilterBar = True
        Me.C1DokumentAblageOrt.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DokumentAblageOrt.Images.Add(CType(resources.GetObject("C1DokumentAblageOrt.Images"), System.Drawing.Image))
        Me.C1DokumentAblageOrt.Location = New System.Drawing.Point(3, 16)
        Me.C1DokumentAblageOrt.Name = "C1DokumentAblageOrt"
        Me.C1DokumentAblageOrt.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DokumentAblageOrt.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DokumentAblageOrt.PreviewInfo.ZoomFactor = 75
        Me.C1DokumentAblageOrt.PrintInfo.PageSettings = CType(resources.GetObject("C1DokumentAblageOrt.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DokumentAblageOrt.Size = New System.Drawing.Size(573, 142)
        Me.C1DokumentAblageOrt.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1DokumentAblageOrt.TabIndex = 8
        Me.C1DokumentAblageOrt.Text = "C1TrueDBGrid1"
        Me.C1DokumentAblageOrt.PropBag = resources.GetString("C1DokumentAblageOrt.PropBag")
        '
        'C1DropDownDokumentablagetyp
        '
        Me.C1DropDownDokumentablagetyp.AllowColMove = True
        Me.C1DropDownDokumentablagetyp.AllowColSelect = True
        Me.C1DropDownDokumentablagetyp.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1DropDownDokumentablagetyp.AlternatingRows = False
        Me.C1DropDownDokumentablagetyp.CaptionStyle = Style1
        Me.C1DropDownDokumentablagetyp.ColumnCaptionHeight = 17
        Me.C1DropDownDokumentablagetyp.ColumnFooterHeight = 17
        Me.C1DropDownDokumentablagetyp.EvenRowStyle = Style2
        Me.C1DropDownDokumentablagetyp.FetchRowStyles = False
        Me.C1DropDownDokumentablagetyp.FooterStyle = Style3
        Me.C1DropDownDokumentablagetyp.HeadingStyle = Style4
        Me.C1DropDownDokumentablagetyp.HighLightRowStyle = Style5
        Me.C1DropDownDokumentablagetyp.Images.Add(CType(resources.GetObject("C1DropDownDokumentablagetyp.Images"), System.Drawing.Image))
        Me.C1DropDownDokumentablagetyp.Location = New System.Drawing.Point(174, 42)
        Me.C1DropDownDokumentablagetyp.Name = "C1DropDownDokumentablagetyp"
        Me.C1DropDownDokumentablagetyp.OddRowStyle = Style6
        Me.C1DropDownDokumentablagetyp.RecordSelectorStyle = Style7
        Me.C1DropDownDokumentablagetyp.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1DropDownDokumentablagetyp.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1DropDownDokumentablagetyp.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1DropDownDokumentablagetyp.ScrollTips = False
        Me.C1DropDownDokumentablagetyp.Size = New System.Drawing.Size(231, 113)
        Me.C1DropDownDokumentablagetyp.Style = Style8
        Me.C1DropDownDokumentablagetyp.TabIndex = 7
        Me.C1DropDownDokumentablagetyp.Text = "C1TrueDBDropdown1"
        Me.C1DropDownDokumentablagetyp.Visible = False
        Me.C1DropDownDokumentablagetyp.PropBag = resources.GetString("C1DropDownDokumentablagetyp.PropBag")
        '
        'Panel1
        '
        Me.Panel1.Controls.Add(Me.cbaktiv)
        Me.Panel1.Controls.Add(Me.lblEx)
        Me.Panel1.Controls.Add(Me.lblSecurityLebel)
        Me.Panel1.Controls.Add(Me.btnDokumentAnzeigen)
        Me.Panel1.Controls.Add(Me.cboxSecurityLevel)
        Me.Panel1.Controls.Add(Me.txtOriginalFilename_incl_path)
        Me.Panel1.Controls.Add(Me.lblErstelltam)
        Me.Panel1.Controls.Add(Me.txtDateiname)
        Me.Panel1.Controls.Add(Me.lblMutiert_am)
        Me.Panel1.Controls.Add(Me.brnFileOpen)
        Me.Panel1.Controls.Add(Me.lblMutierer)
        Me.Panel1.Controls.Add(Me.txtFilename)
        Me.Panel1.Controls.Add(Me.txtErstellt_am)
        Me.Panel1.Controls.Add(Me.lbldatei)
        Me.Panel1.Controls.Add(Me.txtMutiert_am)
        Me.Panel1.Controls.Add(Me.lblDokumenttyp)
        Me.Panel1.Controls.Add(Me.txtMutierer)
        Me.Panel1.Controls.Add(Me.cboxDokumenttyp)
        Me.Panel1.Controls.Add(Me.txtBeschreibung)
        Me.Panel1.Controls.Add(Me.dtPickerVersionsdatum)
        Me.Panel1.Controls.Add(Me.lblBeschreibung)
        Me.Panel1.Controls.Add(Me.txtVersionsdatum)
        Me.Panel1.Controls.Add(Me.lblBezeichnung)
        Me.Panel1.Controls.Add(Me.lblVersionsdatum)
        Me.Panel1.Controls.Add(Me.lblVersion)
        Me.Panel1.Controls.Add(Me.txtBezeichnung)
        Me.Panel1.Controls.Add(Me.txtVersion)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 49)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(579, 190)
        Me.Panel1.TabIndex = 175
        '
        'frmDokument
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(579, 400)
        Me.Controls.Add(Me.grpDokumentablageOrt)
        Me.Controls.Add(Me.Panel1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokument"
        Me.Text = "Dokument"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.grpDokumentablageOrt.ResumeLayout(False)
        CType(Me.C1DokumentAblageOrt, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1DropDownDokumentablagetyp, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.Panel1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        'Prüfung, ob das Ausgewählte File zur Speicherung vorhanden ist
        If Me.txtFilename.Text <> "" Then
            If Not IO.File.Exists(Me.txtFilename.Text) Then
                msg.show_standardmessage(271, MsgBoxStyle.Exclamation)
                msg.show_standardmessage(273, MsgBoxStyle.Information)
                Exit Sub
            End If
        End If
        If Me.txtFilename.Text <> "" And Me.txtDateiname.Text <> "" And Me.txtDateiname.Text <> Me.SaveFileName And Me.SaveFileName <> "" Then
            If msg.Show_MessageYesNo(272) = MsgBoxResult.No Then
                msg.show_standardmessage(273, MsgBoxStyle.Information)
                Exit Sub
            End If
        End If
        Dokument.iKeyValue = New SqlInt32(CType(Me.Aktuelles_Element, Int32))
        Dokument.iDokumenttypNr = New SqlInt32(CType(Me.cboxDokumenttyp.SelectedValue, Int32))
        Dokument.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Dokument.sBeschreibung = New SqlString(CType(Me.txtBeschreibung.Text, String))
        Dokument.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        If IsDate(Me.txtVersionsdatum.Text) Then
            Dokument.daVersionsdatum = New SqlDateTime(CType(Me.txtVersionsdatum.Text, DateTime))
        Else
            Dokument.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Dokument.sFilename = New SqlString(CType(Me.txtDateiname.Text, String))
        Dokument.sOriginalFilename_incl_Path = New SqlString(CType(Me.txtOriginalFilename_incl_path.Text, String))
        Dokument.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Dokument.Save_Data()
        If Dokument.Save_File(Dokument.iDokumentNr.Value, Me.txtFilename.Text) = False Then
            msg.show_standardmessage(275, MsgBoxStyle.Exclamation)
        End If
        Me.Dokument.Dokumentablageort.Save_Data()
        Me.SaveFileName = Me.txtDateiname.Text
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Dokument.Create_Copy(Me.Dokument.iDokumentNr.Value))
        Me.Dokument.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal senderBeendenToolStripMenuItem As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

senderBeendenToolStripMenuItem
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal senderBeendenToolStripMenuItem As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(270) = MsgBoxResult.Yes Then
            Me.Dokument.Delete_Dokument(Me.Dokument.iDokumentNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Dokument.Add_New(Me.Aktuelles_Element, Me.Doktype))

        Me.txtFilename.Text = ""
        Me.Dokument.Neuer_Datensatz = True
        Me.txtBezeichnung.Focus()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtMutiert_am.Text = Me.Dokument.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.TSBtnSuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        'Dim i As Integer
        'If Me.Vertragspartnerdata.Vertragspartner_Suchen(i) = True Then
        '    Me.Get_Data(i)
        'End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.brnFileOpen_Click -Methode

Auswahl des zu speichernden Dokumentes

[Visual Basic]
Private Sub brnFileOpen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   brnFileOpen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub brnFileOpen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles brnFileOpen.Click
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then Me.txtFilename.Text = Me.OpenFileDialog1.FileName
        Me.txtOriginalFilename_incl_path.Text = Me.txtFilename.Text
        Me.txtDateiname.Text = System.IO.Path.GetFileName(Me.txtFilename.Text)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.btnDokumentAnzeigen_Click -Methode

Dokument anzeigen

[Visual Basic]
Private Sub btnDokumentAnzeigen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnDokumentAnzeigen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnDokumentAnzeigen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDokumentAnzeigen.Click
        If Trim(Me.Aktuelles_Dokument) = "" Then Exit Sub
        Try
            Me.Dokument.Show_Doc(Me.Aktuelles_Dokument)

        Catch ex As Exception
            msg.show_standardmessage(950, MsgBoxStyle.Exclamation)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.frmDokument_Load -Methode

Formular-Load

[Visual Basic]
Private Sub frmDokument_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDokument_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Dokumenttypen-Laden
        Me.Dokument.Get_Dokumenttypen()
        Me.cboxDokumenttyp.DataSource = Me.Dokument.Dokumenttypdaten
        Me.cboxDokumenttyp.DisplayMember = "Bezeichnung"
        Me.cboxDokumenttyp.ValueMember = "Dokumenttypnr"

        AddChanges(Me)
        Get_Data(Me.Aktuelles_Dokument)
        If Me.Neuer_Datensatz = True Then
            Me.Dokument.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly Then Me.sec.Set_Form_Readonly(Me)
        Me.txtBezeichnung.Focus()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument.txtDateiname_TextChanged -Methode

Text-Change von Txt-Dateiname

[Visual Basic]
Private Sub txtDateiname_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtDateiname.TextChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtDateiname_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtDateiname.TextChanged
        If Me.txtDateiname.Text <> "" Then Me.btnDokumentAnzeigen.Enabled = True Else Me.btnDokumentAnzeigen.Enabled = False
        Me.txtDateiname.ReadOnly = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDokument-Felder

frmDokument Übersicht

Felder

private field Aktueller_Doktype Unterstützt von .NET Compact Framework | Doktype 1: Vertragselement 2: Test-Drehbuch 3: Applikationsdokument 4: Applikationlogbuch
private field Aktuelles_Dokument Unterstützt von .NET Compact Framework |
private field Aktuelles_Element Unterstützt von .NET Compact Framework |
private field Anzeige Unterstützt von .NET Compact Framework |
private field Doktype Unterstützt von .NET Compact Framework |
private field Dokument Unterstützt von .NET Compact Framework |
private field DokumentAblageTyp Unterstützt von .NET Compact Framework |
private field DokumentAblageTypen Unterstützt von .NET Compact Framework |
private field FormDataChanged Unterstützt von .NET Compact Framework |
private field FormReadonly Unterstützt von .NET Compact Framework |
private field Neuer_Datensatz Unterstützt von .NET Compact Framework |
private field SaveFileName Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field msg Unterstützt von .NET Compact Framework |
private field sec Unterstützt von .NET Compact Framework |

frmDokument -Klasse


Aktueller_Doktype -Feld

Doktype 1: Vertragselement 2: Test-Drehbuch 3: Applikationsdokument 4: Applikationlogbuch

[Visual Basic]
Private Aktueller_Doktype As Integer

Quellcode

[Visual Basic]
    Dim Aktueller_Doktype As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Aktuelles_Dokument -Feld

[Visual Basic]
Private Aktuelles_Dokument As Integer

Quellcode

[Visual Basic]
    Dim Aktuelles_Dokument As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Aktuelles_Element -Feld

[Visual Basic]
Private Aktuelles_Element As Integer

Quellcode

[Visual Basic]
    Dim Aktuelles_Element As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Dim Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Doktype -Feld

[Visual Basic]
Private Doktype As Integer

Quellcode

[Visual Basic]
    Dim Doktype As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Dokument -Feld

[Visual Basic]
Private Dokument As clsDok

Quellcode

[Visual Basic]
    Dim Dokument As New TKB.VV.DMS.clsDok

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


DokumentAblageTyp -Feld

[Visual Basic]
Private DokumentAblageTyp As clsDokumentAblageTyp

Quellcode

[Visual Basic]
    Dim DokumentAblageTyp As New TKB.VV.DB.clsDokumentAblageTyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


DokumentAblageTypen -Feld

[Visual Basic]
Private DokumentAblageTypen As DataTable

Quellcode

[Visual Basic]
    Dim DokumentAblageTypen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


SaveFileName -Feld

[Visual Basic]
Private SaveFileName As String

Quellcode

[Visual Basic]
    Private SaveFileName As String = ""

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDokument


frmDomainEditor -Klasse

Form mit generalisiertem Domain-Table-Editor.

For a list of all members of this type, see frmDomainEditor-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDomainEditor

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmDomainEditor
    Inherits Form

Hinweise

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmDomainEditor-Member | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditor-Member

frmDomainEditor Übersicht

Öffentliche Konstruktoren

public constructor frmDomainEditor -Konstructor

Unterstützt von .NET Compact Framework

 Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ReportdateiDBToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ReportdateiFilesystemToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

Felder

private field Domaintable

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

Siehe auch

frmDomainEditor -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditor -Konstructor

Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

[Visual Basic]
Public Sub New( _
   ByVal tblname As String _
)

Parameter

tblname
Tabellenname der Tabelle, welche über den Domaineditor editiert werden soll

Hinweise

Benötigt werden entsprechende Stored_Procedures, welche mit LBLLGEN_2 generiert wurden pr_"Tablename"_SelectAll pr_"Tablename"_Update

Quellcode

[Visual Basic]
    Public Sub New(ByVal tblname As String)
        Domaintable = New TKB.VV.Sysadmin.DomainTable(tblname)
        Me.InitializeComponent()
        Me.Text = "Domaineditor: " & tblname
        Me.tablename = tblname
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor-Methoden

frmDomainEditor Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ReportdateiDBToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ReportdateiFilesystemToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

Siehe auch

frmDomainEditor -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditor.BeendenToolStripMenuItem_Click -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.C1Daten_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Daten_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Daten.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Daten.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am

        Dim i As Integer
        Try
            For i = 0 To Me.C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then Me.C1Daten.Columns(i).Value = Now
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Daten.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(tablename)
                Me.C1Daten.Columns(0).Value = key
                For i = 0 To Me.C1Daten.Columns.Count - 1
                    If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Daten.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                        Me.C1Daten.Columns(i).Value = 1
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.C1Daten_AfterInsert -Methode

Aktualisierung der Default-Werte

[Visual Basic]
Private Sub C1Daten_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Daten.AfterInsert

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Daten.AfterInsert
        'Dim i As Integer
        ''Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        'Try

        '    For i = 0 To C1Daten.Columns.Count - 1
        '        If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
        '            Me.C1Daten.Columns(i).Value = 1
        '        End If
        '        If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then
        '            Me.C1Daten.Columns(i).Value = Now
        '        End If
        '        If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then
        '            Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
        '        End If
        '        If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
        '            Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
        '        End If
        '        If LCase(Me.C1Daten.Columns(i).DataField) = "mandnat" Then
        '            Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
        '        End If
        '    Next
        'Catch
        'End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.C1Daten_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Daten_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Daten.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Daten.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = Me.tablename
        Try
            'ts.Feld = Me.C1Daten.Splits(0).DisplayColumns(e.ColIndex).Name
            ts.Feld = Me.C1Daten.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDomainEditor))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ContextMenuStripAuswertung = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ReportdateiDBToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReportdateiFilesystemToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ContextMenuStripAuswertung.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(556, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(556, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'C1Daten
        '
        Me.C1Daten.AllowAddNew = True
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Floating
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.Size = New System.Drawing.Size(556, 270)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 4
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'ContextMenuStripAuswertung
        '
        Me.ContextMenuStripAuswertung.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ReportdateiDBToolStripMenuItem, Me.ReportdateiFilesystemToolStripMenuItem})
        Me.ContextMenuStripAuswertung.Name = "ContextMenuStripAuswertung"
        Me.ContextMenuStripAuswertung.Size = New System.Drawing.Size(193, 48)
        '
        'ReportdateiDBToolStripMenuItem
        '
        Me.ReportdateiDBToolStripMenuItem.Name = "ReportdateiDBToolStripMenuItem"
        Me.ReportdateiDBToolStripMenuItem.Size = New System.Drawing.Size(192, 22)
        Me.ReportdateiDBToolStripMenuItem.Text = "Reportdatei -> DB"
        '
        'ReportdateiFilesystemToolStripMenuItem
        '
        Me.ReportdateiFilesystemToolStripMenuItem.Name = "ReportdateiFilesystemToolStripMenuItem"
        Me.ReportdateiFilesystemToolStripMenuItem.Size = New System.Drawing.Size(192, 22)
        Me.ReportdateiFilesystemToolStripMenuItem.Text = "Reportdatei -> Filesystem"
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.FileName = "OpenFileDialog1"
        '
        'frmDomainEditor
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(556, 319)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.Name = "frmDomainEditor"
        Me.Text = "frmDomainEditor"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ContextMenuStripAuswertung.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.ReportdateiDBToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ReportdateiDBToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReportdateiDBToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReportdateiDBToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportdateiDBToolStripMenuItem.Click
        Me.OpenFileDialog1.Filter = "Report-Dateien|*.rpt|Alle Dateien|*.*"
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then
            Dim dms As New TKB.VV.Utils.MyDocMgmt
            Me.C1Daten.Columns("CR_Filename").Value = dms.Save_RptDatei(Me.C1Daten.Columns("Auswertungnr").Value, Me.OpenFileDialog1.FileName)
            dms = Nothing

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.ReportdateiFilesystemToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ReportdateiFilesystemToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReportdateiFilesystemToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReportdateiFilesystemToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportdateiFilesystemToolStripMenuItem.Click
        Me.SaveFileDialog1.Filter = "Report-Dateien|*.rpt|Alle Dateien|*.*"
        Me.SaveFileDialog1.ShowDialog()
        If Me.SaveFileDialog1.FileName <> "" Then
            Dim dms As New TKB.VV.Utils.MyDocMgmt
            dms.Get_RptDatei(Me.C1Daten.Columns("Auswertungnr").Value, Me.SaveFileDialog1.FileName)
            dms = Nothing
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.TSBtnQuit_Click -Methode

Ruft BeendetnToolStipMenuItem_Click auf

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.TSBtnSave_Click -Methode

Sichern der Daten

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Try
            Domaintable.Save_Data()
            If UCase(Me.tablename) = "SPALTEN" Then
                Globals.Spaltendaten.Rows.Clear()
            End If
            If UCase(Me.tablename) = "TOOLTIP" Then
                Globals.ToolTipDaten.Tables.Clear()
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.frmDomainEditor_FormClosing -Methode

Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.

[Visual Basic]
Private Sub frmDomainEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.Domaintable.Tabledata.HasChanges Then
            Dim msg As New TKB.VV.Utils.MyMessage
            Dim msgboxres As MsgBoxResult
            msgboxres = msg.Show_MessageYesNoCancel(3)
            If msgboxres = MsgBoxResult.Cancel Then
                e.Cancel = True
                Exit Sub
            End If
            If msgboxres = MsgBoxResult.Yes Then
                Domaintable.Save_Data()
            End If
        End If
        If UCase(Me.tablename) = "SPALTEN" Then
            Globals.Spaltendaten.Rows.Clear()
        End If
        Domaintable.dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor.frmDomainEditor_Load -Methode

Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

[Visual Basic]
Private Sub frmDomainEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        If Me.Domaintable.Tablename = "Auswertung" Then
            Me.C1Daten.ContextMenuStrip = Me.ContextMenuStripAuswertung
        End If
        Me.C1Daten.DataSource = Domaintable.Tabledata
        Me.C1Daten.DataMember = Domaintable.Tabledata.Tables(0).TableName
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Daten, Me.tablename, Me.Domaintable.Tabledata.Tables(0))
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditor-Felder

frmDomainEditor Übersicht

Felder

private field Domaintable

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

Siehe auch

frmDomainEditor -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


Domaintable -Feld

[Visual Basic]
Private Domaintable As DomainTable

Quellcode

[Visual Basic]
    Dim Domaintable As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


tablename -Feld

[Visual Basic]
Private tablename As String

Quellcode

[Visual Basic]
    Dim tablename As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditor


frmDomainEditorExtTables -Klasse

Form mit generalisiertem Domain-Table-Editor.

For a list of all members of this type, see frmDomainEditorExtTables-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmDomainEditorExtTables

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmDomainEditorExtTables
    Inherits Form

Hinweise

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmDomainEditorExtTables-Member | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditorExtTables-Member

frmDomainEditorExtTables Übersicht

Öffentliche Konstruktoren

public constructor frmDomainEditorExtTables -Konstructor

Unterstützt von .NET Compact Framework

 Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

Felder

private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field cb

Unterstützt von .NET Compact Framework
private field co

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field ds

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

Siehe auch

frmDomainEditorExtTables -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditorExtTables -Konstructor

Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

[Visual Basic]
Public Sub New( _
   ByVal tblname As String, _
   ByVal Connectionstring As String _
)

Parameter

tblname
Tabellenname der Tabelle, welche über den Domaineditor editiert werden soll
Connectionstring

Hinweise

Benötigt werden entsprechende Stored_Procedures, welche mit LBLLGEN_2 generiert wurden pr_"Tablename"_SelectAll pr_"Tablename"_Update

Quellcode

[Visual Basic]
    Public Sub New(ByVal tblname As String, ByVal Connectionstring As String)
        '        Domaintable = New TKB.VV.Sysadmin.DomainTable(tblname)
        Me.InitializeComponent()
        '       Me.Text = "Domaineditor: " & tblname
        Me.tablename = tblname
        Me.co.ConnectionString = Connectionstring
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables-Methoden

frmDomainEditorExtTables Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

Siehe auch

frmDomainEditorExtTables -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


frmDomainEditorExtTables.BeendenToolStripMenuItem_Click -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmDomainEditorExtTables))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ContextMenuStripAuswertung = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ReportdateiDBToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReportdateiFilesystemToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ContextMenuStripAuswertung.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(556, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(556, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'C1Daten
        '
        Me.C1Daten.AllowAddNew = True
        Me.C1Daten.AllowDelete = True
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Floating
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.Size = New System.Drawing.Size(556, 270)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 4
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'ContextMenuStripAuswertung
        '
        Me.ContextMenuStripAuswertung.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ReportdateiDBToolStripMenuItem, Me.ReportdateiFilesystemToolStripMenuItem})
        Me.ContextMenuStripAuswertung.Name = "ContextMenuStripAuswertung"
        Me.ContextMenuStripAuswertung.Size = New System.Drawing.Size(200, 48)
        '
        'ReportdateiDBToolStripMenuItem
        '
        Me.ReportdateiDBToolStripMenuItem.Name = "ReportdateiDBToolStripMenuItem"
        Me.ReportdateiDBToolStripMenuItem.Size = New System.Drawing.Size(199, 22)
        Me.ReportdateiDBToolStripMenuItem.Text = "Reportdatei -> DB"
        '
        'ReportdateiFilesystemToolStripMenuItem
        '
        Me.ReportdateiFilesystemToolStripMenuItem.Name = "ReportdateiFilesystemToolStripMenuItem"
        Me.ReportdateiFilesystemToolStripMenuItem.Size = New System.Drawing.Size(199, 22)
        Me.ReportdateiFilesystemToolStripMenuItem.Text = "Reportdatei -> Filesystem"
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.FileName = "OpenFileDialog1"
        '
        'frmDomainEditorExtTables
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(556, 319)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.Name = "frmDomainEditorExtTables"
        Me.Text = "frmDomainEditor"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ContextMenuStripAuswertung.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.TSBtnQuit_Click -Methode

Ruft BeendetnToolStipMenuItem_Click auf

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.TSBtnSave_Click -Methode

Sichern der Daten

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Try
            da.Update(ds, "ExtTable")
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.frmDomainEditor_FormClosing -Methode

Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.

[Visual Basic]
Private Sub frmDomainEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.ds.HasChanges Then
            Dim msg As New TKB.VV.Utils.MyMessage
            Dim msgboxres As MsgBoxResult
            msgboxres = msg.Show_MessageYesNoCancel(3)
            If msgboxres = MsgBoxResult.Cancel Then
                e.Cancel = True
                Exit Sub
            End If
            If msgboxres = MsgBoxResult.Yes Then
                Try
                    da.Update(ds, "ExtTable")

                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try

            End If
        End If
        Try
            Me.co.Close()
            da.Dispose()
            co.Dispose()
            cb.Dispose()
            ds.Dispose()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables.frmDomainEditor_Load -Methode

Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

[Visual Basic]
Private Sub frmDomainEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            da = New SqlDataAdapter("Select * from " & Me.tablename, Me.co)
            cb = New SqlCommandBuilder(da)
            da.Fill(ds, "ExtTable")
            Me.C1Daten.DataSource = ds.Tables(0)
            Me.C1Daten.DataMember = ds.Tables(0).TableName
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmDomainEditorExtTables-Felder

frmDomainEditorExtTables Übersicht

Felder

private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field cb

Unterstützt von .NET Compact Framework
private field co

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field ds

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

Siehe auch

frmDomainEditorExtTables -Klasse | Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


cb -Feld

[Visual Basic]
Private cb As SqlCommandBuilder

Quellcode

[Visual Basic]
    Dim cb As SqlCommandBuilder

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


co -Feld

[Visual Basic]
Private co As SqlConnection

Quellcode

[Visual Basic]
    Dim co As New SqlConnection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


da -Feld

[Visual Basic]
Private da As SqlDataAdapter

Quellcode

[Visual Basic]
    Dim da As SqlDataAdapter

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


ds -Feld

[Visual Basic]
Private ds As DataSet

Quellcode

[Visual Basic]
    Dim ds As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


tablename -Feld

[Visual Basic]
Private tablename As String

Quellcode

[Visual Basic]
    Dim tablename As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmDomainEditorExtTables


frmFormSelector -Klasse

For a list of all members of this type, see frmFormSelector-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmFormSelector

[Visual Basic]
Public Class frmFormSelector
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmFormSelector-Member


frmFormSelector-Member

frmFormSelector Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method ListForms_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method frmFormSelector_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmFormSelector -Klasse


frmFormSelector-Methoden

frmFormSelector Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method ListForms_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method frmFormSelector_Load

Unterstützt von .NET Compact Framework

frmFormSelector -Klasse


frmFormSelector.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmFormSelector


frmFormSelector.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmFormSelector))
        Me.ListForms = New System.Windows.Forms.ListBox
        Me.SuspendLayout()
        '
        'ListForms
        '
        Me.ListForms.FormattingEnabled = True
        Me.ListForms.Location = New System.Drawing.Point(28, 36)
        Me.ListForms.Name = "ListForms"
        Me.ListForms.Size = New System.Drawing.Size(259, 199)
        Me.ListForms.TabIndex = 0
        '
        'frmFormSelector
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(315, 322)
        Me.Controls.Add(Me.ListForms)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmFormSelector"
        Me.Text = "Form-Selector"
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmFormSelector


frmFormSelector.ListForms_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub ListForms_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListForms.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ListForms_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListForms.DoubleClick
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmFormSelector


frmFormSelector.frmFormSelector_Load -Methode

[Visual Basic]
Private Sub frmFormSelector_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmFormSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmFormSelector


frmFormSelector-Felder

frmFormSelector Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmFormSelector -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmFormSelector


frmGremienverwaltung -Klasse

For a list of all members of this type, see frmGremienverwaltung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmGremienverwaltung

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmGremienverwaltung
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmGremienverwaltung-Member


frmGremienverwaltung-Member

frmGremienverwaltung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BtnInsert_Click Unterstützt von .NET Compact Framework |
private method C1Bereich_AfterColUpdate Unterstützt von .NET Compact Framework |
private method C1Bereich_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Bereich_RowColChange Unterstützt von .NET Compact Framework |
private method C1Gremium_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Gremium_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Gremium_RowColChange Unterstützt von .NET Compact Framework |
private method C1Grp_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Grp_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Grp_Leave Unterstützt von .NET Compact Framework |
private method C1Grp_RowColChange Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSave_Click Unterstützt von .NET Compact Framework |
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmGremienverwaltung_Load Unterstützt von .NET Compact Framework |

Felder

private field Gremienverwaltung

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmGremienverwaltung -Klasse


frmGremienverwaltung-Methoden

frmGremienverwaltung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BtnInsert_Click Unterstützt von .NET Compact Framework |
private method C1Bereich_AfterColUpdate Unterstützt von .NET Compact Framework |
private method C1Bereich_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Bereich_RowColChange Unterstützt von .NET Compact Framework |
private method C1Gremium_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Gremium_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Gremium_RowColChange Unterstützt von .NET Compact Framework |
private method C1Grp_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Grp_AfterFilter Unterstützt von .NET Compact Framework |
private method C1Grp_Leave Unterstützt von .NET Compact Framework |
private method C1Grp_RowColChange Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSave_Click Unterstützt von .NET Compact Framework |
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmGremienverwaltung_Load Unterstützt von .NET Compact Framework |

frmGremienverwaltung -Klasse


frmGremienverwaltung.BtnInsert_Click -Methode

[Visual Basic]
Private Sub BtnInsert_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnInsert.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnInsert_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnInsert.Click
        Me.Gremienverwaltung.Insert_Gremium_Person(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Me.C1Bereich.Columns("Gremiumbereichnr").Value)
        Me.C1Personen.DataSource = Nothing
        Me.C1Personen.DataSource = Gremienverwaltung.Gremiumperson.Tabledata.Tables(0)
        Me.C1Personen.DataMember = Gremienverwaltung.GremiumGruppe.Tablename
        Me.C1Personen.Columns("GremiumBereichNr").FilterText = Me.C1Bereich.Columns("GremiumBereichnr").Value.ToString
        Me.C1Personen.Columns("Aktiv").FilterText = "True"
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Personen, "GremiumPerson", Me.Gremienverwaltung.Gremiumperson.Tabledata)
        '        Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen.Tabledata.Tables(0)
        Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen
        Me.C1RolleDropDown.ValueMember = "Kontakttypnr"
        Me.C1RolleDropDown.DisplayMember = "Bezeichnung"
        Me.C1RolleDropDown.ValueTranslate = True
        Me.C1Personen.Columns("Rollenr").DropDown = Me.C1RolleDropDown
        Me.C1RolleDropDown.DisplayColumns(0).Width = 0
        Me.C1RolleDropDown.DisplayColumns(1).Width = Me.C1RolleDropDown.Width
        Me.C1RolleDropDown.Columns("ApplikationsbereichNr").FilterText = "3"
        Me.C1Personen.Columns("Rollenr").ValueItems.Translate = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Bereich_AfterColUpdate -Methode

[Visual Basic]
Private Sub C1Bereich_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Bereich.AfterColUpdate

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Bereich_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Bereich.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am

        Dim i As Integer
        Try
            For i = 0 To Me.C1Bereich.Columns.Count - 1
                If LCase(Me.C1Bereich.Columns(i).DataField) = "mutiert_am" Then Me.C1Bereich.Columns(i).Value = Now
                If LCase(Me.C1Bereich.Columns(i).DataField) = "mutierer" Then Me.C1Bereich.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Bereich.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(Me.Gremienverwaltung.GremiumBereich.Tablename)
                Me.C1Bereich.Columns(0).Value = key
                For i = 0 To Me.C1Bereich.Columns.Count - 1
                    If LCase(Me.C1Bereich.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Bereich.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Bereich.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Bereich.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Bereich.Columns(i).DataField) = "aktiv" Then
                        Me.C1Bereich.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Bereich.Columns(i).DataField) = "gremiumgruppierungnr" Then
                        Me.C1Bereich.Columns(i).Value = Me.C1Grp.Columns("Gremiumgruppierungnr").Value
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Bereich_AfterFilter -Methode

[Visual Basic]
Private Sub C1Bereich_AfterFilter( _
   ByVal sender As Object, _
   ByVal e As FilterEventArgs _
) Handles  _
   C1Bereich.AfterFilter

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Bereich_AfterFilter(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FilterEventArgs) Handles C1Bereich.AfterFilter
        Try
            Me.C1Personen.DataSource = Nothing
            Me.C1Personen.DataSource = Gremienverwaltung.Gremiumperson.Tabledata.Tables(0)
            Me.C1Personen.DataMember = Gremienverwaltung.GremiumGruppe.Tablename
            If Me.C1Bereich.Columns("GremiumBereichnr").Value.ToString = "" Then
                Me.C1Personen.Columns("GremiumBereichNr").FilterText = "-999"
            Else
                Me.C1Personen.Columns("GremiumBereichNr").FilterText = Me.C1Bereich.Columns("GremiumBereichnr").Value.ToString
            End If
            Me.C1Personen.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Personen, "GremiumPerson", Me.Gremienverwaltung.Gremiumperson.Tabledata)

            'Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen.Tabledata.Tables(0)
            Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen
            Me.C1RolleDropDown.ValueMember = "Kontakttypnr"
            Me.C1RolleDropDown.DisplayMember = "Bezeichnung"
            Me.C1Personen.Columns("Rollenr").DropDown = Me.C1RolleDropDown
            Me.C1RolleDropDown.ValueTranslate = True
            Me.C1RolleDropDown.DisplayColumns(0).Width = 0
            Me.C1RolleDropDown.Columns("ApplikationsbereichNr").FilterText = "3"
            Me.C1RolleDropDown.DisplayColumns(1).Width = Me.C1RolleDropDown.Width
            Me.C1Personen.Columns("Rollenr").ValueItems.Translate = True
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Bereich_RowColChange -Methode

[Visual Basic]
Private Sub C1Bereich_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1Bereich.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Bereich_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1Bereich.RowColChange
        Try
            Me.C1Personen.DataSource = Nothing
            Me.C1Personen.DataSource = Gremienverwaltung.Gremiumperson.Tabledata.Tables(0)
            Me.C1Personen.DataMember = Gremienverwaltung.GremiumGruppe.Tablename
            If Me.C1Bereich.Columns("GremiumBereichnr").Value.ToString = "" Then
                Me.C1Personen.Columns("GremiumBereichNr").FilterText = "-999"
            Else
                Me.C1Personen.Columns("GremiumBereichNr").FilterText = Me.C1Bereich.Columns("GremiumBereichnr").Value.ToString
            End If
            Me.C1Personen.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Personen, "GremiumPerson", Me.Gremienverwaltung.Gremiumperson.Tabledata)

            'Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen.Tabledata.Tables(0)
            Me.C1RolleDropDown.DataSource = Me.Gremienverwaltung.Rollen
            Me.C1RolleDropDown.ValueMember = "Kontakttypnr"
            Me.C1RolleDropDown.DisplayMember = "Bezeichnung"
            Me.C1Personen.Columns("Rollenr").DropDown = Me.C1RolleDropDown
            Me.C1RolleDropDown.ValueTranslate = True
            Me.C1RolleDropDown.DisplayColumns(0).Width = 0
            Me.C1RolleDropDown.Columns("ApplikationsbereichNr").FilterText = "3"
            Me.C1RolleDropDown.DisplayColumns(1).Width = Me.C1RolleDropDown.Width
            Me.C1Personen.Columns("Rollenr").ValueItems.Translate = True
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Gremium_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Gremium_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Gremium.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Gremium_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Gremium.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am

        Dim i As Integer
        Try
            For i = 0 To Me.C1Gremium.Columns.Count - 1
                If LCase(Me.C1Gremium.Columns(i).DataField) = "mutiert_am" Then Me.C1Gremium.Columns(i).Value = Now
                If LCase(Me.C1Gremium.Columns(i).DataField) = "mutierer" Then Me.C1Gremium.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Gremium.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(Me.Gremienverwaltung.Gremium.Tablename)
                Me.C1Gremium.Columns(0).Value = key
                For i = 0 To Me.C1Gremium.Columns.Count - 1
                    If LCase(Me.C1Gremium.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Gremium.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Gremium.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Gremium.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Gremium.Columns(i).DataField) = "aktiv" Then
                        Me.C1Gremium.Columns(i).Value = 1
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Gremium_AfterFilter -Methode

[Visual Basic]
Private Sub C1Gremium_AfterFilter( _
   ByVal sender As Object, _
   ByVal e As FilterEventArgs _
) Handles  _
   C1Gremium.AfterFilter

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Gremium_AfterFilter(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FilterEventArgs) Handles C1Gremium.AfterFilter
        Try
            Me.C1Grp.DataSource = Gremienverwaltung.GremiumGruppe.Tabledata.Tables(0)
            Me.C1Grp.DataMember = Gremienverwaltung.GremiumGruppe.Tablename
            Me.C1Grp.Columns("Gremiumnr").FilterText = Me.C1Gremium.Columns("Gremiumnr").Value.ToString
            Me.C1Grp.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Grp, "GremiumGruppierung", Me.Gremienverwaltung.GremiumGruppe.Tabledata)
            C1Grp_AfterFilter(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Gremium_RowColChange -Methode

[Visual Basic]
Private Sub C1Gremium_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1Gremium.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Gremium_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1Gremium.RowColChange
        Try
            Me.C1Grp.DataSource = Gremienverwaltung.GremiumGruppe.Tabledata.Tables(0)
            Me.C1Grp.DataMember = Gremienverwaltung.GremiumGruppe.Tablename
            Me.C1Grp.Columns("Gremiumnr").FilterText = Me.C1Gremium.Columns("Gremiumnr").Value.ToString
            Me.C1Grp.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Grp, "GremiumGruppierung", Me.Gremienverwaltung.GremiumGruppe.Tabledata)
            C1Grp_RowColChange(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Grp_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Grp_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Grp.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Grp_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Grp.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am

        Dim i As Integer
        Try
            For i = 0 To Me.C1Grp.Columns.Count - 1
                If LCase(Me.C1Grp.Columns(i).DataField) = "mutiert_am" Then Me.C1Grp.Columns(i).Value = Now
                If LCase(Me.C1Grp.Columns(i).DataField) = "mutierer" Then Me.C1Grp.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Grp.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(Me.Gremienverwaltung.GremiumGruppe.Tablename)
                Me.C1Grp.Columns(0).Value = key
                For i = 0 To Me.C1Grp.Columns.Count - 1
                    If LCase(Me.C1Grp.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Grp.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Grp.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Grp.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Grp.Columns(i).DataField) = "aktiv" Then
                        Me.C1Grp.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Grp.Columns(i).DataField) = "gremiumnr" Then
                        Me.C1Grp.Columns(i).Value = Me.C1Gremium.Columns("Gremiumnr").Value
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Grp_AfterFilter -Methode

[Visual Basic]
Private Sub C1Grp_AfterFilter( _
   ByVal sender As Object, _
   ByVal e As FilterEventArgs _
) Handles  _
   C1Grp.AfterFilter

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Grp_AfterFilter(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FilterEventArgs) Handles C1Grp.AfterFilter
        Try
            Me.C1Bereich.DataSource = Gremienverwaltung.GremiumBereich.Tabledata.Tables(0)
            Me.C1Bereich.DataMember = Gremienverwaltung.GremiumBereich.Tablename
            If Me.C1Grp.Columns("GremiumGruppierungNr").Value.ToString = "" Then
                Me.C1Bereich.Columns("GremiumGruppierungNr").FilterText = "-999"
            Else
                Me.C1Bereich.Columns("GremiumGruppierungNr").FilterText = Me.C1Grp.Columns("GremiumGruppierungNr").Value.ToString
            End If
            Me.C1Bereich.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Bereich, "GremiumBereich", Me.Gremienverwaltung.GremiumBereich.Tabledata)
            C1Bereich_AfterFilter(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Grp_Leave -Methode

[Visual Basic]
Private Sub C1Grp_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Grp.Leave, _
   C1Bereich.Leave, _
   C1Gremium.Leave, _
   C1Personen.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Grp_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Grp.Leave, C1Bereich.Leave, C1Gremium.Leave, C1Personen.Leave
        If Me.Gremienverwaltung.Gremium.Tabledata.HasChanges Or Me.Gremienverwaltung.GremiumGruppe.Tabledata.HasChanges Or _
        Me.Gremienverwaltung.GremiumBereich.Tabledata.HasChanges Or Me.Gremienverwaltung.GremiumPerson.Tabledata.HasChanges Then
            If msg.Show_MessageYesNo(3) = MsgBoxResult.Yes Then
                TSBtnSave_Click(sender, e)
            End If
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.C1Grp_RowColChange -Methode

[Visual Basic]
Private Sub C1Grp_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1Grp.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Grp_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1Grp.RowColChange
        Try
            Me.C1Bereich.DataSource = Gremienverwaltung.GremiumBereich.Tabledata.Tables(0)
            Me.C1Bereich.DataMember = Gremienverwaltung.GremiumBereich.Tablename
            If Me.C1Grp.Columns("GremiumGruppierungNr").Value.ToString = "" Then
                Me.C1Bereich.Columns("GremiumGruppierungNr").FilterText = "-999"
            Else
                Me.C1Bereich.Columns("GremiumGruppierungNr").FilterText = Me.C1Grp.Columns("GremiumGruppierungNr").Value.ToString
            End If
            Me.C1Bereich.Columns("Aktiv").FilterText = "True"
            Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Bereich, "GremiumBereich", Me.Gremienverwaltung.GremiumBereich.Tabledata)
            C1Bereich_RowColChange(sender, e)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.Get_Vertragspartner -Methode

[Visual Basic]
Private Function Get_Vertragspartner() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner()
        Me.txtVertragspartner.Text = Me.Vertragspartner.Get_Vertragspartnername(Me.VertragspartnerNr)
        Get_Vertragspartner_Kontakte()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.Get_Vertragspartner_Kontakte -Methode

[Visual Basic]
Private Function Get_Vertragspartner_Kontakte() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner_Kontakte()
        Try
            'If Check_Changes() = False Then Exit Function
        Catch ex As Exception
        End Try
        Me.C1Kontaktpersonen.Enabled = False
        Me.Vertragspartner.Get_Kontaktpersonen(Me.C1Kontaktpersonen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontaktpersonen, "Person", Me.Vertragspartner.Kontaktpersonen.Tabledata)
        Me.C1Kontaktpersonen.Enabled = True
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmGremienverwaltung))
        Dim Style1 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style2 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style3 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style4 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style5 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style6 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style7 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style8 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSlblSuche = New System.Windows.Forms.ToolStripLabel
        Me.tstxtSuche = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TSBtnFilterAufheben = New System.Windows.Forms.ToolStripButton
        Me.GrpGremium = New System.Windows.Forms.GroupBox
        Me.C1Gremium = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpGruppierung = New System.Windows.Forms.GroupBox
        Me.C1Grp = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpBereich = New System.Windows.Forms.GroupBox
        Me.C1Bereich = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpPersonen = New System.Windows.Forms.GroupBox
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.C1Kontaktpersonen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Panel2 = New System.Windows.Forms.Panel
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.lblPartner = New System.Windows.Forms.Label
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.BtnInsert = New System.Windows.Forms.Button
        Me.C1Personen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1RolleDropDown = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.GrpGremium.SuspendLayout()
        CType(Me.C1Gremium, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpGruppierung.SuspendLayout()
        CType(Me.C1Grp, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpBereich.SuspendLayout()
        CType(Me.C1Bereich, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpPersonen.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        Me.Panel1.SuspendLayout()
        CType(Me.C1Personen, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1RolleDropDown, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(977, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSlblSuche, Me.tstxtSuche, Me.TSBtnSuche, Me.TSBtnFilterAufheben})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(977, 25)
        Me.ToolStrip1.TabIndex = 2
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSlblSuche
        '
        Me.TSlblSuche.Name = "TSlblSuche"
        Me.TSlblSuche.Size = New System.Drawing.Size(32, 22)
        Me.TSlblSuche.Text = "Filter:"
        '
        'tstxtSuche
        '
        Me.tstxtSuche.Name = "tstxtSuche"
        Me.tstxtSuche.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'TSBtnFilterAufheben
        '
        Me.TSBtnFilterAufheben.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnFilterAufheben.Image = CType(resources.GetObject("TSBtnFilterAufheben.Image"), System.Drawing.Image)
        Me.TSBtnFilterAufheben.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnFilterAufheben.Name = "TSBtnFilterAufheben"
        Me.TSBtnFilterAufheben.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnFilterAufheben.Text = "Filter aufheben"
        '
        'GrpGremium
        '
        Me.GrpGremium.Controls.Add(Me.C1Gremium)
        Me.GrpGremium.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpGremium.Location = New System.Drawing.Point(0, 49)
        Me.GrpGremium.Name = "GrpGremium"
        Me.GrpGremium.Size = New System.Drawing.Size(977, 108)
        Me.GrpGremium.TabIndex = 3
        Me.GrpGremium.TabStop = False
        Me.GrpGremium.Text = "Gremium"
        '
        'C1Gremium
        '
        Me.C1Gremium.AllowAddNew = True
        Me.C1Gremium.AlternatingRows = True
        Me.C1Gremium.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Gremium.FetchRowStyles = True
        Me.C1Gremium.FilterBar = True
        Me.C1Gremium.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Gremium.Images.Add(CType(resources.GetObject("C1Gremium.Images"), System.Drawing.Image))
        Me.C1Gremium.Location = New System.Drawing.Point(3, 16)
        Me.C1Gremium.Name = "C1Gremium"
        Me.C1Gremium.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Gremium.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Gremium.PreviewInfo.ZoomFactor = 75
        Me.C1Gremium.PrintInfo.PageSettings = CType(resources.GetObject("C1Gremium.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Gremium.Size = New System.Drawing.Size(971, 89)
        Me.C1Gremium.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Gremium.TabIndex = 12
        Me.C1Gremium.Text = "C1TrueDBGrid1"
        Me.C1Gremium.PropBag = resources.GetString("C1Gremium.PropBag")
        '
        'GrpGruppierung
        '
        Me.GrpGruppierung.Controls.Add(Me.C1Grp)
        Me.GrpGruppierung.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpGruppierung.Location = New System.Drawing.Point(0, 157)
        Me.GrpGruppierung.Name = "GrpGruppierung"
        Me.GrpGruppierung.Size = New System.Drawing.Size(977, 111)
        Me.GrpGruppierung.TabIndex = 4
        Me.GrpGruppierung.TabStop = False
        Me.GrpGruppierung.Text = "Gruppierung"
        '
        'C1Grp
        '
        Me.C1Grp.AllowAddNew = True
        Me.C1Grp.AlternatingRows = True
        Me.C1Grp.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Grp.FetchRowStyles = True
        Me.C1Grp.FilterBar = True
        Me.C1Grp.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Grp.Images.Add(CType(resources.GetObject("C1Grp.Images"), System.Drawing.Image))
        Me.C1Grp.Location = New System.Drawing.Point(3, 16)
        Me.C1Grp.Name = "C1Grp"
        Me.C1Grp.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Grp.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Grp.PreviewInfo.ZoomFactor = 75
        Me.C1Grp.PrintInfo.PageSettings = CType(resources.GetObject("C1Grp.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Grp.Size = New System.Drawing.Size(971, 92)
        Me.C1Grp.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Grp.TabIndex = 12
        Me.C1Grp.Text = "C1TrueDBGrid1"
        Me.C1Grp.PropBag = resources.GetString("C1Grp.PropBag")
        '
        'GrpBereich
        '
        Me.GrpBereich.Controls.Add(Me.C1Bereich)
        Me.GrpBereich.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpBereich.Location = New System.Drawing.Point(0, 268)
        Me.GrpBereich.Name = "GrpBereich"
        Me.GrpBereich.Size = New System.Drawing.Size(977, 107)
        Me.GrpBereich.TabIndex = 5
        Me.GrpBereich.TabStop = False
        Me.GrpBereich.Text = "Bereich"
        '
        'C1Bereich
        '
        Me.C1Bereich.AllowAddNew = True
        Me.C1Bereich.AlternatingRows = True
        Me.C1Bereich.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Bereich.FetchRowStyles = True
        Me.C1Bereich.FilterBar = True
        Me.C1Bereich.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Bereich.Images.Add(CType(resources.GetObject("C1Bereich.Images"), System.Drawing.Image))
        Me.C1Bereich.Location = New System.Drawing.Point(3, 16)
        Me.C1Bereich.Name = "C1Bereich"
        Me.C1Bereich.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Bereich.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Bereich.PreviewInfo.ZoomFactor = 75
        Me.C1Bereich.PrintInfo.PageSettings = CType(resources.GetObject("C1Bereich.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Bereich.Size = New System.Drawing.Size(971, 88)
        Me.C1Bereich.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Bereich.TabIndex = 12
        Me.C1Bereich.Text = "C1TrueDBGrid1"
        Me.C1Bereich.PropBag = resources.GetString("C1Bereich.PropBag")
        '
        'GrpPersonen
        '
        Me.GrpPersonen.Controls.Add(Me.SplitContainer1)
        Me.GrpPersonen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpPersonen.Location = New System.Drawing.Point(0, 375)
        Me.GrpPersonen.Name = "GrpPersonen"
        Me.GrpPersonen.Size = New System.Drawing.Size(977, 305)
        Me.GrpPersonen.TabIndex = 6
        Me.GrpPersonen.TabStop = False
        Me.GrpPersonen.Text = "Personen"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(3, 16)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.C1Kontaktpersonen)
        Me.SplitContainer1.Panel1.Controls.Add(Me.Panel2)
        Me.SplitContainer1.Panel1.Controls.Add(Me.Panel1)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1RolleDropDown)
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1Personen)
        Me.SplitContainer1.Size = New System.Drawing.Size(971, 286)
        Me.SplitContainer1.SplitterDistance = 324
        Me.SplitContainer1.TabIndex = 13
        '
        'C1Kontaktpersonen
        '
        Me.C1Kontaktpersonen.AlternatingRows = True
        Me.C1Kontaktpersonen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontaktpersonen.FetchRowStyles = True
        Me.C1Kontaktpersonen.FilterBar = True
        Me.C1Kontaktpersonen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontaktpersonen.Images.Add(CType(resources.GetObject("C1Kontaktpersonen.Images"), System.Drawing.Image))
        Me.C1Kontaktpersonen.Location = New System.Drawing.Point(0, 32)
        Me.C1Kontaktpersonen.Name = "C1Kontaktpersonen"
        Me.C1Kontaktpersonen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.ZoomFactor = 75
        Me.C1Kontaktpersonen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontaktpersonen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontaktpersonen.Size = New System.Drawing.Size(288, 254)
        Me.C1Kontaktpersonen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kontaktpersonen.TabIndex = 13
        Me.C1Kontaktpersonen.Text = "C1TrueDBGrid1"
        Me.C1Kontaktpersonen.PropBag = resources.GetString("C1Kontaktpersonen.PropBag")
        '
        'Panel2
        '
        Me.Panel2.Controls.Add(Me.btnVertragspartnersuche)
        Me.Panel2.Controls.Add(Me.txtVertragspartner)
        Me.Panel2.Controls.Add(Me.lblPartner)
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Location = New System.Drawing.Point(0, 0)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(288, 32)
        Me.Panel2.TabIndex = 1
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(267, 7)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 2
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragspartner.Location = New System.Drawing.Point(54, 6)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.ReadOnly = True
        Me.txtVertragspartner.Size = New System.Drawing.Size(214, 20)
        Me.txtVertragspartner.TabIndex = 1
        '
        'lblPartner
        '
        Me.lblPartner.AutoSize = True
        Me.lblPartner.Location = New System.Drawing.Point(9, 10)
        Me.lblPartner.Name = "lblPartner"
        Me.lblPartner.Size = New System.Drawing.Size(41, 13)
        Me.lblPartner.TabIndex = 0
        Me.lblPartner.Text = "Partner"
        '
        'Panel1
        '
        Me.Panel1.Controls.Add(Me.BtnInsert)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Right
        Me.Panel1.Location = New System.Drawing.Point(288, 0)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(36, 286)
        Me.Panel1.TabIndex = 0
        '
        'BtnInsert
        '
        Me.BtnInsert.Image = CType(resources.GetObject("BtnInsert.Image"), System.Drawing.Image)
        Me.BtnInsert.Location = New System.Drawing.Point(6, 126)
        Me.BtnInsert.Name = "BtnInsert"
        Me.BtnInsert.Size = New System.Drawing.Size(26, 25)
        Me.BtnInsert.TabIndex = 0
        Me.BtnInsert.UseVisualStyleBackColor = True
        '
        'C1Personen
        '
        Me.C1Personen.AlternatingRows = True
        Me.C1Personen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Personen.FetchRowStyles = True
        Me.C1Personen.FilterBar = True
        Me.C1Personen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Personen.Images.Add(CType(resources.GetObject("C1Personen.Images"), System.Drawing.Image))
        Me.C1Personen.Location = New System.Drawing.Point(0, 0)
        Me.C1Personen.Name = "C1Personen"
        Me.C1Personen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Personen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Personen.PreviewInfo.ZoomFactor = 75
        Me.C1Personen.PrintInfo.PageSettings = CType(resources.GetObject("C1Personen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Personen.Size = New System.Drawing.Size(643, 286)
        Me.C1Personen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Personen.TabIndex = 12
        Me.C1Personen.Text = "C1TrueDBGrid1"
        Me.C1Personen.PropBag = resources.GetString("C1Personen.PropBag")
        '
        'C1RolleDropDown
        '
        Me.C1RolleDropDown.AllowColMove = True
        Me.C1RolleDropDown.AllowColSelect = True
        Me.C1RolleDropDown.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1RolleDropDown.AlternatingRows = False
        Me.C1RolleDropDown.CaptionStyle = Style1
        Me.C1RolleDropDown.ColumnCaptionHeight = 17
        Me.C1RolleDropDown.ColumnFooterHeight = 17
        Me.C1RolleDropDown.EvenRowStyle = Style2
        Me.C1RolleDropDown.FetchRowStyles = False
        Me.C1RolleDropDown.FooterStyle = Style3
        Me.C1RolleDropDown.HeadingStyle = Style4
        Me.C1RolleDropDown.HighLightRowStyle = Style5
        Me.C1RolleDropDown.Images.Add(CType(resources.GetObject("C1RolleDropDown.Images"), System.Drawing.Image))
        Me.C1RolleDropDown.Location = New System.Drawing.Point(220, 105)
        Me.C1RolleDropDown.Name = "C1RolleDropDown"
        Me.C1RolleDropDown.OddRowStyle = Style6
        Me.C1RolleDropDown.RecordSelectorStyle = Style7
        Me.C1RolleDropDown.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1RolleDropDown.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1RolleDropDown.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1RolleDropDown.ScrollTips = False
        Me.C1RolleDropDown.Size = New System.Drawing.Size(211, 150)
        Me.C1RolleDropDown.Style = Style8
        Me.C1RolleDropDown.TabIndex = 13
        Me.C1RolleDropDown.Text = "C1TrueDBDropdown1"
        Me.C1RolleDropDown.Visible = False
        Me.C1RolleDropDown.PropBag = resources.GetString("C1RolleDropDown.PropBag")
        '
        'frmGremienverwaltung
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(977, 680)
        Me.Controls.Add(Me.GrpPersonen)
        Me.Controls.Add(Me.GrpBereich)
        Me.Controls.Add(Me.GrpGruppierung)
        Me.Controls.Add(Me.GrpGremium)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmGremienverwaltung"
        Me.Text = "Gremienverwaltung"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.GrpGremium.ResumeLayout(False)
        CType(Me.C1Gremium, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpGruppierung.ResumeLayout(False)
        CType(Me.C1Grp, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpBereich.ResumeLayout(False)
        CType(Me.C1Bereich, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpPersonen.ResumeLayout(False)
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        Me.Panel2.PerformLayout()
        Me.Panel1.ResumeLayout(False)
        CType(Me.C1Personen, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1RolleDropDown, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.TSBtnSave_Click -Methode

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        If Me.Gremienverwaltung.Gremium.Tabledata.HasChanges Then Me.Gremienverwaltung.Gremium.Save_Data()
        If Me.Gremienverwaltung.GremiumGruppe.Tabledata.HasChanges Then Me.Gremienverwaltung.GremiumGruppe.Save_Data()
        If Me.Gremienverwaltung.GremiumBereich.Tabledata.HasChanges Then Me.Gremienverwaltung.GremiumBereich.Save_Data()
        If Me.Gremienverwaltung.GremiumPerson.Tabledata.HasChanges Then Me.Gremienverwaltung.GremiumPerson.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.btnVertragspartnersuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        Dim f As New frmVertragspartnerSuche
        f.ShowDialog()
        If f.Vertragspartnernr <> -1 Then
            Me.VertragspartnerNr = f.Vertragspartnernr
            f.Dispose()
            Me.Get_Vertragspartner()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung.frmGremienverwaltung_Load -Methode

[Visual Basic]
Private Sub frmGremienverwaltung_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmGremienverwaltung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1Gremium.DataSource = Gremienverwaltung.Gremium.Tabledata.Tables(0)
        Me.C1Gremium.DataMember = Gremienverwaltung.Gremium.Tablename
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Gremium, "Gremium", Me.Gremienverwaltung.Gremium.Tabledata)
        Me.VertragspartnerNr = 1
        Me.Get_Vertragspartner()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmGremienverwaltung-Felder

frmGremienverwaltung Übersicht

Felder

private field Gremienverwaltung

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmGremienverwaltung -Klasse


Gremienverwaltung -Feld

[Visual Basic]
Private Gremienverwaltung As clsGremienverwaltung

Quellcode

[Visual Basic]
    Dim Gremienverwaltung As New clsGremienverwaltung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


Vertragspartner -Feld

[Visual Basic]
Private Vertragspartner As clsVertragspartner

Quellcode

[Visual Basic]
    Dim Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


VertragspartnerNr -Feld

[Visual Basic]
Private VertragspartnerNr As Integer

Quellcode

[Visual Basic]
    Private VertragspartnerNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmGremienverwaltung


frmKontaktMassenupdate -Klasse

For a list of all members of this type, see frmKontaktMassenupdate-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmKontaktMassenupdate

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmKontaktMassenupdate
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmKontaktMassenupdate-Member


frmKontaktMassenupdate-Member

frmKontaktMassenupdate Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Applikationen_Aktualisieren

Unterstützt von .NET Compact Framework
private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method C1useraktuell_MouseUp

Unterstützt von .NET Compact Framework
private method C1useraktuell_RowColChange

Unterstützt von .NET Compact Framework
private method Get_GetData

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnzuordnen_Click

Unterstützt von .NET Compact Framework
private method cboxfunktion_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method frmKontaktMassenupdate_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmKontaktMassenupdate -Klasse


frmKontaktMassenupdate-Methoden

frmKontaktMassenupdate Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method Applikationen_Aktualisieren

Unterstützt von .NET Compact Framework
private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method C1useraktuell_MouseUp

Unterstützt von .NET Compact Framework
private method C1useraktuell_RowColChange

Unterstützt von .NET Compact Framework
private method Get_GetData

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnzuordnen_Click

Unterstützt von .NET Compact Framework
private method cboxfunktion_SelectedIndexChanged

Unterstützt von .NET Compact Framework
private method frmKontaktMassenupdate_Load

Unterstützt von .NET Compact Framework

frmKontaktMassenupdate -Klasse


frmKontaktMassenupdate.Applikationen_Aktualisieren -Methode

[Visual Basic]
Private Sub Applikationen_Aktualisieren()

Quellcode

[Visual Basic]
    Private Sub Applikationen_Aktualisieren()
        Try
            Dim tmpdata As New DataTable
            tmpdata = Me.Get_GetData(3, Me.cboxfunktion.SelectedValue, Me.C1useraktuell.Columns(0).Value, 0)
            Me.C1ZugetAppl.DataSource = tmpdata
            Me.C1useraktuell.DataMember = tmpdata.TableName
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.C1useraktuell_MouseUp -Methode

[Visual Basic]
Private Sub C1useraktuell_MouseUp( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1useraktuell.MouseUp

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1useraktuell_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1useraktuell.MouseUp
        Applikationen_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.C1useraktuell_RowColChange -Methode

[Visual Basic]
Private Sub C1useraktuell_RowColChange( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1useraktuell.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1useraktuell_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1useraktuell.RowColChange
        Applikationen_Aktualisieren()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.Get_GetData -Methode

[Visual Basic]
Private Function Get_GetData( _
   ByVal fnkt As Integer, _
   ByVal kontaktnr As Integer, _
   ByVal usernr As Integer, _
   ByVal usernrneu As Integer _
) As DataTable

Parameter

fnkt
kontaktnr
usernr
usernrneu

Quellcode

[Visual Basic]
    Private Function Get_GetData(ByVal fnkt As Integer, ByVal kontaktnr As Integer, ByVal usernr As Integer, ByVal usernrneu As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Dim CheckState As Integer
        scmCmdToExecute.CommandText = "dbo.sp_keyuser_massenupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@kontakttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, kontaktnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@usernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, usernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@usernrneu", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, usernrneu))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            conn.OpenConnection()
            sdaAdapter.Fill(dtToReturn)

            conn.CloseConnection(True)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("frmKontakt_Massenmutation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmKontaktMassenupdate))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.GroupBox1 = New System.Windows.Forms.GroupBox
        Me.C1ZugetAppl = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1useraktuell = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.lblApplikation = New System.Windows.Forms.Label
        Me.lbluserakt = New System.Windows.Forms.Label
        Me.cboxfunktion = New System.Windows.Forms.ComboBox
        Me.lblFunktion = New System.Windows.Forms.Label
        Me.GroupBox2 = New System.Windows.Forms.GroupBox
        Me.C1Mitarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Label1 = New System.Windows.Forms.Label
        Me.CachedCrystalReport11 = New Vertragsverwaltung.CachedCrystalReport1
        Me.btnzuordnen = New System.Windows.Forms.Button
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        CType(Me.C1ZugetAppl, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1useraktuell, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox2.SuspendLayout()
        CType(Me.C1Mitarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(573, 24)
        Me.MenuStrip1.TabIndex = 6
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(573, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.Add(Me.C1ZugetAppl)
        Me.GroupBox1.Controls.Add(Me.C1useraktuell)
        Me.GroupBox1.Controls.Add(Me.lblApplikation)
        Me.GroupBox1.Controls.Add(Me.lbluserakt)
        Me.GroupBox1.Controls.Add(Me.cboxfunktion)
        Me.GroupBox1.Controls.Add(Me.lblFunktion)
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Left
        Me.GroupBox1.Location = New System.Drawing.Point(0, 49)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(286, 332)
        Me.GroupBox1.TabIndex = 8
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Aktuelle Zuteilung"
        '
        'C1ZugetAppl
        '
        Me.C1ZugetAppl.AllowAddNew = True
        Me.C1ZugetAppl.AlternatingRows = True
        Me.C1ZugetAppl.FilterBar = True
        Me.C1ZugetAppl.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1ZugetAppl.Images.Add(CType(resources.GetObject("C1ZugetAppl.Images"), System.Drawing.Image))
        Me.C1ZugetAppl.Location = New System.Drawing.Point(91, 200)
        Me.C1ZugetAppl.Name = "C1ZugetAppl"
        Me.C1ZugetAppl.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1ZugetAppl.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1ZugetAppl.PreviewInfo.ZoomFactor = 75
        Me.C1ZugetAppl.PrintInfo.PageSettings = CType(resources.GetObject("V1ZugetAppl.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1ZugetAppl.Size = New System.Drawing.Size(189, 120)
        Me.C1ZugetAppl.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1ZugetAppl.TabIndex = 10
        Me.C1ZugetAppl.Text = "C1TrueDBGrid1"
        Me.C1ZugetAppl.PropBag = resources.GetString("C1ZugetAppl.PropBag")
        '
        'C1useraktuell
        '
        Me.C1useraktuell.AllowAddNew = True
        Me.C1useraktuell.AlternatingRows = True
        Me.C1useraktuell.FilterBar = True
        Me.C1useraktuell.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1useraktuell.Images.Add(CType(resources.GetObject("C1useraktuell.Images"), System.Drawing.Image))
        Me.C1useraktuell.Location = New System.Drawing.Point(91, 55)
        Me.C1useraktuell.Name = "C1useraktuell"
        Me.C1useraktuell.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1useraktuell.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1useraktuell.PreviewInfo.ZoomFactor = 75
        Me.C1useraktuell.PrintInfo.PageSettings = CType(resources.GetObject("C1useraktuell.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1useraktuell.Size = New System.Drawing.Size(189, 139)
        Me.C1useraktuell.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1useraktuell.TabIndex = 9
        Me.C1useraktuell.Text = "C1TrueDBGrid1"
        Me.C1useraktuell.PropBag = resources.GetString("C1useraktuell.PropBag")
        '
        'lblApplikation
        '
        Me.lblApplikation.AutoSize = True
        Me.lblApplikation.Location = New System.Drawing.Point(11, 200)
        Me.lblApplikation.Name = "lblApplikation"
        Me.lblApplikation.Size = New System.Drawing.Size(65, 13)
        Me.lblApplikation.TabIndex = 4
        Me.lblApplikation.Text = "Zuget. Appl."
        '
        'lbluserakt
        '
        Me.lbluserakt.AutoSize = True
        Me.lbluserakt.Location = New System.Drawing.Point(11, 55)
        Me.lbluserakt.Name = "lbluserakt"
        Me.lbluserakt.Size = New System.Drawing.Size(49, 13)
        Me.lbluserakt.TabIndex = 3
        Me.lbluserakt.Text = "Benutzer"
        '
        'cboxfunktion
        '
        Me.cboxfunktion.FormattingEnabled = True
        Me.cboxfunktion.Location = New System.Drawing.Point(91, 28)
        Me.cboxfunktion.Name = "cboxfunktion"
        Me.cboxfunktion.Size = New System.Drawing.Size(189, 21)
        Me.cboxfunktion.TabIndex = 1
        '
        'lblFunktion
        '
        Me.lblFunktion.AutoSize = True
        Me.lblFunktion.Location = New System.Drawing.Point(12, 28)
        Me.lblFunktion.Name = "lblFunktion"
        Me.lblFunktion.Size = New System.Drawing.Size(48, 13)
        Me.lblFunktion.TabIndex = 0
        Me.lblFunktion.Text = "Funktion"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.Add(Me.btnzuordnen)
        Me.GroupBox2.Controls.Add(Me.C1Mitarbeiter)
        Me.GroupBox2.Controls.Add(Me.Label1)
        Me.GroupBox2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox2.Location = New System.Drawing.Point(286, 49)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(287, 332)
        Me.GroupBox2.TabIndex = 9
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Neue Zuteilung"
        '
        'C1Mitarbeiter
        '
        Me.C1Mitarbeiter.AllowAddNew = True
        Me.C1Mitarbeiter.AlternatingRows = True
        Me.C1Mitarbeiter.FilterBar = True
        Me.C1Mitarbeiter.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Mitarbeiter.Images.Add(CType(resources.GetObject("C1Mitarbeiter.Images"), System.Drawing.Image))
        Me.C1Mitarbeiter.Location = New System.Drawing.Point(82, 31)
        Me.C1Mitarbeiter.Name = "C1Mitarbeiter"
        Me.C1Mitarbeiter.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Mitarbeiter.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Mitarbeiter.PreviewInfo.ZoomFactor = 75
        Me.C1Mitarbeiter.PrintInfo.PageSettings = CType(resources.GetObject("C1Mitarbeiter.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Mitarbeiter.Size = New System.Drawing.Size(181, 195)
        Me.C1Mitarbeiter.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Mitarbeiter.TabIndex = 12
        Me.C1Mitarbeiter.Text = "C1TrueDBGrid1"
        Me.C1Mitarbeiter.PropBag = resources.GetString("C1Mitarbeiter.PropBag")
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(15, 31)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(49, 13)
        Me.Label1.TabIndex = 6
        Me.Label1.Text = "Benutzer"
        '
        'btnzuordnen
        '
        Me.btnzuordnen.Location = New System.Drawing.Point(18, 284)
        Me.btnzuordnen.Name = "btnzuordnen"
        Me.btnzuordnen.Size = New System.Drawing.Size(75, 23)
        Me.btnzuordnen.TabIndex = 13
        Me.btnzuordnen.Text = "Zuordnen"
        Me.btnzuordnen.UseVisualStyleBackColor = True
        '
        'frmKontaktMassenupdate
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(573, 381)
        Me.Controls.Add(Me.GroupBox2)
        Me.Controls.Add(Me.GroupBox1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmKontaktMassenupdate"
        Me.Text = "Kontak-Massenupdate"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox1.PerformLayout()
        CType(Me.C1ZugetAppl, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1useraktuell, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox2.PerformLayout()
        CType(Me.C1Mitarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.btnzuordnen_Click -Methode

[Visual Basic]
Private Sub btnzuordnen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnzuordnen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnzuordnen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnzuordnen.Click
        Me.Cursor = Cursors.WaitCursor
        Dim data As New DataTable
        data = Me.Get_GetData(4, Me.cboxfunktion.SelectedValue, Me.C1useraktuell.Columns(0).Value, Me.C1Mitarbeiter.Columns(0).Value)
        Me.Cursor = Cursors.Default
        msg.show_standardmessage(853, MsgBoxStyle.Information)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.cboxfunktion_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cboxfunktion_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxfunktion.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxfunktion_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxfunktion.SelectedIndexChanged
        Try
            Dim tmpdata As New DataTable
            tmpdata = Me.Get_GetData(2, Me.cboxfunktion.SelectedValue, 0, 0)
            Me.C1useraktuell.DataSource = tmpdata
            Me.C1useraktuell.DataMember = tmpdata.TableName
            Me.C1useraktuell.Splits(0).DisplayColumns(0).Width = 0
            Me.C1useraktuell.Splits(0).DisplayColumns(1).Width = Me.C1useraktuell.Width - 40
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate.frmKontaktMassenupdate_Load -Methode

[Visual Basic]
Private Sub frmKontaktMassenupdate_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmKontaktMassenupdate_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim tmpdata As New DataTable
        tmpdata = Me.Get_GetData(1, 0, 0, 0)
        Me.cboxfunktion.DataSource = tmpdata
        Me.cboxfunktion.DisplayMember = "Bezeichnung"
        Me.cboxfunktion.ValueMember = "KontakttypNr"
        Me.cboxfunktion.Text = ""
        Dim tmpdata1 As New DataTable
        tmpdata1 = Me.Get_GetData(0, 0, 0, 0)
        Me.C1Mitarbeiter.DataSource = tmpdata1
        Me.C1Mitarbeiter.DataMember = tmpdata1.TableName
        Me.C1Mitarbeiter.Splits(0).DisplayColumns(0).Width = 0
        Me.C1Mitarbeiter.Splits(0).DisplayColumns(1).Width = Me.C1Mitarbeiter.Width - 40
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKontaktMassenupdate-Felder

frmKontaktMassenupdate Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmKontaktMassenupdate -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKontaktMassenupdate


frmKuendigungsfrist -Klasse

Person

For a list of all members of this type, see frmKuendigungsfrist-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmKuendigungsfrist

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmKuendigungsfrist
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmKuendigungsfrist-Member | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmKuendigungsfrist-Member

frmKuendigungsfrist Übersicht

Öffentliche Konstruktoren

public constructor frmKuendigungsfrist -Konstructor

Unterstützt von .NET Compact Framework

 Formular-Initialisierung

Öffentliche Eigenschaften

public property Vertragselementnr

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | löschen
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neu
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button betätigt
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save-Button geklickt
private method frmKuendigungsfrist_Load Unterstützt von .NET Compact Framework | Laden des Formulars

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Kuendigungsfrist

Unterstützt von .NET Compact Framework
private field Kuendigungsfristnr

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_vertragselementnr

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

Siehe auch

frmKuendigungsfrist -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmKuendigungsfrist -Konstructor

Formular-Initialisierung

[Visual Basic]
Public Sub New( _
   ByVal Nr As Integer, _
   ByVal Vertragselementnr As Integer, _
   Optional ByVal iReadOnly As Boolean = False, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Nr
PersonenNr
Vertragselementnr
Erforderlich.
iReadOnly
Optional. Der Standardwert ist False.
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Public Sub New(ByVal Nr As Integer, ByVal Vertragselementnr As Integer, Optional ByVal iReadOnly As Boolean = False, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        If CreateNew = True Then
            Me.Kuendigungsfristnr = Me.Kuendigungsfrist.Add_New(Vertragselementnr)
            Me.Neuer_Datensatz = True
        Else
            Kuendigungsfristnr = Nr
        End If
        Me.Vertragselementnr = Vertragselementnr
        Me.FormReadonly = iReadOnly
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist-Eigenschaften

frmKuendigungsfrist Übersicht

Öffentliche Eigenschaften

public property Vertragselementnr

Unterstützt von .NET Compact Framework

Siehe auch

frmKuendigungsfrist -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmKuendigungsfrist.Vertragselementnr -Eigenschaft

[Visual Basic]
Public Property Vertragselementnr() As Integer

Quellcode

[Visual Basic]
    Property Vertragselementnr() As Integer
        Get
            Return m_vertragselementnr
        End Get
        Set(ByVal value As Integer)
            m_vertragselementnr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist-Methoden

frmKuendigungsfrist Übersicht

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | löschen
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neu
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button betätigt
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save-Button geklickt
private method frmKuendigungsfrist_Load Unterstützt von .NET Compact Framework | Laden des Formulars

Siehe auch

frmKuendigungsfrist -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmKuendigungsfrist.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerKuendigungstermin.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dtPickerKuendigungstermin.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

Destructor Dispose

[Visual Basic] Public Overloads Sub Dispose()
[C#] public System.Void Dispose();

frmKuendigungsfrist


frmKuendigungsfrist.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Kuendigungsfrist.Neuer_Datensatz = True Then Me.Kuendigungsfrist.Delete(Me.Kuendigungsfrist.iKuendigungsfristNr.Value)
            Globals.MyEventHanlder.Kuendigungsfrist_Closed()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.Get_Data -Methode

Person laden und präsentieren

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kuendigungsfrist.Get_Kuendigungsfrist(Nr)
        Me.txtZeitspanne.Text = Me.Kuendigungsfrist.sVarZeitspanne.ToString
        Me.txtKuendigungsfrist.Text = Me.Kuendigungsfrist.sKuendigungsfirst.ToString
        Me.txtKuendigungstermin.Text = Me.Kuendigungsfrist.daKuendigungstermin.ToString
        Me.txtBemerkung.Text = Me.Kuendigungsfrist.sBemerkung.Value
        Me.txtErstellt_am.Text = Me.Kuendigungsfrist.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kuendigungsfrist.daMutiert_am.ToString
        Me.txtMutierer.Text = Me.Kuendigungsfrist.iMutierer.Value
        Me.cbAktiv.Checked = Me.Kuendigungsfrist.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kuendigungsfrist.iSecurityLevelNr.Value
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmKuendigungsfrist))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.lblZeitspanne = New System.Windows.Forms.Label
        Me.txtZeitspanne = New System.Windows.Forms.TextBox
        Me.txtKuendigungsfrist = New System.Windows.Forms.TextBox
        Me.lblKuendigungsfrist = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.dtPickerKuendigungstermin = New System.Windows.Forms.DateTimePicker
        Me.txtKuendigungstermin = New System.Windows.Forms.MaskedTextBox
        Me.lblKuendigungstermin = New System.Windows.Forms.Label
        Me.lblBeispiel = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(647, 24)
        Me.MenuStrip1.TabIndex = 8
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(647, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(88, 234)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 6
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(11, 238)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 130
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(567, 235)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 129
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(405, 235)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 128
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(261, 235)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 127
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(496, 238)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 126
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(346, 238)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 125
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(203, 238)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 124
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(14, 152)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 5
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(11, 136)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 123
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'lblZeitspanne
        '
        Me.lblZeitspanne.AutoSize = True
        Me.lblZeitspanne.Location = New System.Drawing.Point(219, 110)
        Me.lblZeitspanne.Name = "lblZeitspanne"
        Me.lblZeitspanne.Size = New System.Drawing.Size(60, 13)
        Me.lblZeitspanne.TabIndex = 131
        Me.lblZeitspanne.Text = "Zeitspanne"
        Me.lblZeitspanne.Visible = False
        '
        'txtZeitspanne
        '
        Me.txtZeitspanne.Location = New System.Drawing.Point(284, 110)
        Me.txtZeitspanne.Name = "txtZeitspanne"
        Me.txtZeitspanne.Size = New System.Drawing.Size(200, 20)
        Me.txtZeitspanne.TabIndex = 0
        Me.txtZeitspanne.Visible = False
        '
        'txtKuendigungsfrist
        '
        Me.txtKuendigungsfrist.Location = New System.Drawing.Point(109, 58)
        Me.txtKuendigungsfrist.Name = "txtKuendigungsfrist"
        Me.txtKuendigungsfrist.Size = New System.Drawing.Size(200, 20)
        Me.txtKuendigungsfrist.TabIndex = 1
        '
        'lblKuendigungsfrist
        '
        Me.lblKuendigungsfrist.AutoSize = True
        Me.lblKuendigungsfrist.Location = New System.Drawing.Point(12, 61)
        Me.lblKuendigungsfrist.Name = "lblKuendigungsfrist"
        Me.lblKuendigungsfrist.Size = New System.Drawing.Size(79, 13)
        Me.lblKuendigungsfrist.TabIndex = 133
        Me.lblKuendigungsfrist.Text = "Kündigungsfrist"
        '
        'cbAktiv
        '
        Me.cbAktiv.Location = New System.Drawing.Point(11, 110)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbAktiv.Size = New System.Drawing.Size(111, 15)
        Me.cbAktiv.TabIndex = 4
        Me.cbAktiv.Text = "Aktiv"
        Me.cbAktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'dtPickerKuendigungstermin
        '
        Me.dtPickerKuendigungstermin.Location = New System.Drawing.Point(172, 84)
        Me.dtPickerKuendigungstermin.Name = "dtPickerKuendigungstermin"
        Me.dtPickerKuendigungstermin.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerKuendigungstermin.TabIndex = 3
        '
        'txtKuendigungstermin
        '
        Me.txtKuendigungstermin.Location = New System.Drawing.Point(109, 84)
        Me.txtKuendigungstermin.Mask = "00/00/0000"
        Me.txtKuendigungstermin.Name = "txtKuendigungstermin"
        Me.txtKuendigungstermin.Size = New System.Drawing.Size(66, 20)
        Me.txtKuendigungstermin.TabIndex = 2
        Me.txtKuendigungstermin.ValidatingType = GetType(Date)
        '
        'lblKuendigungstermin
        '
        Me.lblKuendigungstermin.AutoSize = True
        Me.lblKuendigungstermin.Location = New System.Drawing.Point(12, 87)
        Me.lblKuendigungstermin.Name = "lblKuendigungstermin"
        Me.lblKuendigungstermin.Size = New System.Drawing.Size(91, 13)
        Me.lblKuendigungstermin.TabIndex = 139
        Me.lblKuendigungstermin.Text = "Kündigungstermin"
        '
        'lblBeispiel
        '
        Me.lblBeispiel.AutoSize = True
        Me.lblBeispiel.Location = New System.Drawing.Point(312, 113)
        Me.lblBeispiel.Name = "lblBeispiel"
        Me.lblBeispiel.Size = New System.Drawing.Size(256, 13)
        Me.lblBeispiel.TabIndex = 140
        Me.lblBeispiel.Text = "(z.B. erste 3 Jahre jährich, anschiessend halbjährlich)"
        Me.lblBeispiel.Visible = False
        '
        'frmKuendigungsfrist
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(647, 264)
        Me.Controls.Add(Me.lblBeispiel)
        Me.Controls.Add(Me.lblKuendigungstermin)
        Me.Controls.Add(Me.dtPickerKuendigungstermin)
        Me.Controls.Add(Me.txtKuendigungstermin)
        Me.Controls.Add(Me.cbAktiv)
        Me.Controls.Add(Me.txtKuendigungsfrist)
        Me.Controls.Add(Me.lblKuendigungsfrist)
        Me.Controls.Add(Me.txtZeitspanne)
        Me.Controls.Add(Me.lblZeitspanne)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmKuendigungsfrist"
        Me.Text = "Kündigungsfrist"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.Save_Data -Methode

Daten sichern, sofern Änderungen vorgenommen worden sind

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kuendigungsfrist.sVarZeitspanne = New SqlString(CType(Me.txtZeitspanne.Text, String))
            Me.Kuendigungsfrist.sKuendigungsfirst = New SqlString(CType(Me.txtKuendigungsfrist.Text, String))
            If IsDate(Me.txtKuendigungstermin.Text) Then Me.Kuendigungsfrist.daKuendigungstermin = New SqlDateTime(CType(Me.txtKuendigungstermin.Text, DateTime))
            Me.Kuendigungsfrist.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kuendigungsfrist.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Kuendigungsfrist.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kuendigungsfrist.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.TSBtnCopy_Click -Methode

kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        Try
            Check_Changes()
            Me.Get_Data(Kuendigungsfrist.Create_Copy(Me.Kuendigungsfrist.iKuendigungsfristNr.Value))
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.TSBtnDelete_Click -Methode

löschen

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(260) = MsgBoxResult.Yes Then
            Me.Kuendigungsfrist.Delete_Kuendigungsfrist(Me.Kuendigungsfrist.iKuendigungsfristNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.TSBtnNew_Click -Methode

Neu

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Try
            Me.Get_Data(Me.Kuendigungsfrist.Add_New(Me.Vertragselementnr))
            Me.Kuendigungsfrist.Neuer_Datensatz = True
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.TSBtnQuit_Click -Methode

Schliessen-Button betätigt

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.TSBtnSave_Click -Methode

Save-Button geklickt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist.frmKuendigungsfrist_Load -Methode

Laden des Formulars

[Visual Basic]
Private Sub frmKuendigungsfrist_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmKuendigungsfrist_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Get_Data(Kuendigungsfristnr)
        If Me.Neuer_Datensatz Then Me.Kuendigungsfrist.Neuer_Datensatz = True
        Me.AddChanges(Me)
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmKuendigungsfrist-Felder

frmKuendigungsfrist Übersicht

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Kuendigungsfrist

Unterstützt von .NET Compact Framework
private field Kuendigungsfristnr

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_vertragselementnr

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

Siehe auch

frmKuendigungsfrist -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


Kuendigungsfrist -Feld

[Visual Basic]
Private Kuendigungsfrist As clsKuendigungsfrist

Quellcode

[Visual Basic]
    Dim Kuendigungsfrist As New TKB.VV.Vertrag.clsKuendigungsfrist

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


Kuendigungsfristnr -Feld

[Visual Basic]
Private Kuendigungsfristnr As Integer

Quellcode

[Visual Basic]
    Dim Kuendigungsfristnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


m_vertragselementnr -Feld

[Visual Basic]
Private m_vertragselementnr As Integer

Quellcode

[Visual Basic]
    Dim m_vertragselementnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


frmLeistung -Klasse

For a list of all members of this type, see frmLeistung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmLeistung

[Visual Basic]
Public Class frmLeistung
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmLeistung-Member


frmLeistung-Member

frmLeistung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmLeistung -Klasse


frmLeistung-Methoden

frmLeistung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

frmLeistung -Klasse


frmLeistung.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLeistung


frmLeistung.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        components = New System.ComponentModel.Container
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.Text = "frmLeistung"
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLeistung


frmLeistung-Felder

frmLeistung Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmLeistung -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLeistung


frmLogin -Klasse

Form für den Login. Wird nur angezeigt, sofern in der Tabelle Application Show-Login = true

For a list of all members of this type, see frmLogin-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmLogin

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmLogin
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmLogin-Member


frmLogin-Member

frmLogin Übersicht

Öffentliche Eigenschaften

public property Mitarbeiternr

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnAbbruch_Click

Unterstützt von .NET Compact Framework
private method btnAnmelden_Click

Unterstützt von .NET Compact Framework
private method frmLogin_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework
private field conn

Unterstützt von .NET Compact Framework
private field m_mitarbeiternr

Unterstützt von .NET Compact Framework
private field tmp_clsmitarbeiter

Unterstützt von .NET Compact Framework
private field tmp_madaten

Unterstützt von .NET Compact Framework

frmLogin -Klasse


frmLogin-Eigenschaften

frmLogin Übersicht

Öffentliche Eigenschaften

public property Mitarbeiternr

Unterstützt von .NET Compact Framework

frmLogin -Klasse


frmLogin.Mitarbeiternr -Eigenschaft

[Visual Basic]
Public Property Mitarbeiternr() As Integer

Quellcode

[Visual Basic]
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal value As Integer)
            m_mitarbeiternr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin-Methoden

frmLogin Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnAbbruch_Click

Unterstützt von .NET Compact Framework
private method btnAnmelden_Click

Unterstützt von .NET Compact Framework
private method frmLogin_Load

Unterstützt von .NET Compact Framework

frmLogin -Klasse


frmLogin.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmLogin))
        Me.lblBitteAnmelden = New System.Windows.Forms.Label
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox
        Me.btnAbbruch = New System.Windows.Forms.Button
        Me.btnAnmelden = New System.Windows.Forms.Button
        Me.SuspendLayout()
        '
        'lblBitteAnmelden
        '
        Me.lblBitteAnmelden.Location = New System.Drawing.Point(12, 9)
        Me.lblBitteAnmelden.Name = "lblBitteAnmelden"
        Me.lblBitteAnmelden.Size = New System.Drawing.Size(136, 23)
        Me.lblBitteAnmelden.TabIndex = 3
        Me.lblBitteAnmelden.Text = "Bitte melden Sie sich an"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.AutoCompleteMode = System.Windows.Forms.AutoCompleteMode.Append
        Me.cbMitarbeiter.AutoCompleteSource = System.Windows.Forms.AutoCompleteSource.ListItems
        Me.cbMitarbeiter.FormattingEnabled = True
        Me.cbMitarbeiter.Location = New System.Drawing.Point(15, 35)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(257, 21)
        Me.cbMitarbeiter.TabIndex = 4
        '
        'btnAbbruch
        '
        Me.btnAbbruch.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnAbbruch.Location = New System.Drawing.Point(158, 76)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(104, 24)
        Me.btnAbbruch.TabIndex = 6
        Me.btnAbbruch.Text = "&Abbruch"
        '
        'btnAnmelden
        '
        Me.btnAnmelden.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnAnmelden.Location = New System.Drawing.Point(14, 76)
        Me.btnAnmelden.Name = "btnAnmelden"
        Me.btnAnmelden.Size = New System.Drawing.Size(104, 24)
        Me.btnAnmelden.TabIndex = 5
        Me.btnAnmelden.Text = "&Anmelden"
        '
        'frmLogin
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(308, 129)
        Me.Controls.Add(Me.btnAbbruch)
        Me.Controls.Add(Me.btnAnmelden)
        Me.Controls.Add(Me.cbMitarbeiter)
        Me.Controls.Add(Me.lblBitteAnmelden)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmLogin"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Benutzerauswahl TKB-Vertragsverwaltung"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin.btnAbbruch_Click -Methode

[Visual Basic]
Private Sub btnAbbruch_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAbbruch.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Mitarbeiternr = -1
        Me.DialogResult = Windows.Forms.DialogResult.Cancel
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin.btnAnmelden_Click -Methode

[Visual Basic]
Private Sub btnAnmelden_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAnmelden.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAnmelden_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAnmelden.Click
        Me.Mitarbeiternr = Me.cbMitarbeiter.SelectedValue
        Me.DialogResult = Windows.Forms.DialogResult.OK
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin.frmLogin_Load -Methode

[Visual Basic]
Private Sub frmLogin_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmLogin_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        conn = Globals.conn
        tmp_clsmitarbeiter.cpMainConnectionProvider = conn
        conn.OpenConnection()
        tmp_madaten = tmp_clsmitarbeiter.SelectAllwithFullname
        Me.cbMitarbeiter.DataSource = tmp_madaten
        Me.cbMitarbeiter.DisplayMember = "Fullname"
        Me.cbMitarbeiter.ValueMember = "Mitarbeiternr"
        conn.CloseConnection(True)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmLogin-Felder

frmLogin Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field conn

Unterstützt von .NET Compact Framework
private field m_mitarbeiternr

Unterstützt von .NET Compact Framework
private field tmp_clsmitarbeiter

Unterstützt von .NET Compact Framework
private field tmp_madaten

Unterstützt von .NET Compact Framework

frmLogin -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


conn -Feld

[Visual Basic]
Private conn As clsConnectionProvider

Quellcode

[Visual Basic]
    Dim conn As New TKB.VV.DB.clsConnectionProvider

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


m_mitarbeiternr -Feld

[Visual Basic]
Private m_mitarbeiternr As Integer

Quellcode

[Visual Basic]
    Dim m_mitarbeiternr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


tmp_clsmitarbeiter -Feld

[Visual Basic]
Private tmp_clsmitarbeiter As MyMitarbeiter

Quellcode

[Visual Basic]
    Dim tmp_clsmitarbeiter As New TKB.VV.DB.MyMitarbeiter

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


tmp_madaten -Feld

[Visual Basic]
Private tmp_madaten As DataTable

Quellcode

[Visual Basic]
    Dim tmp_madaten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmLogin


frmMAEinstellung -Klasse

For a list of all members of this type, see frmMAEinstellung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmMAEinstellung

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmMAEinstellung
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmMAEinstellung-Member


frmMAEinstellung-Member

frmMAEinstellung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSave_Click Unterstützt von .NET Compact Framework |
private method cboxAktivitaeten_Click Unterstützt von .NET Compact Framework |
private method frmMAEinstellung_FormClosing Unterstützt von .NET Compact Framework |
private method frmMAEinstellung_Load Unterstützt von .NET Compact Framework |
private method save_data Unterstützt von .NET Compact Framework |

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field ma

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmMAEinstellung -Klasse


frmMAEinstellung-Methoden

frmMAEinstellung Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSave_Click Unterstützt von .NET Compact Framework |
private method cboxAktivitaeten_Click Unterstützt von .NET Compact Framework |
private method frmMAEinstellung_FormClosing Unterstützt von .NET Compact Framework |
private method frmMAEinstellung_Load Unterstützt von .NET Compact Framework |
private method save_data Unterstützt von .NET Compact Framework |

frmMAEinstellung -Klasse


frmMAEinstellung.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Check_Changes() = False Then e.Cancel = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmMAEinstellung))
        Me.GrpStartScreen = New System.Windows.Forms.GroupBox
        Me.cboxApplikation = New System.Windows.Forms.CheckBox
        Me.cboxPendenzen = New System.Windows.Forms.CheckBox
        Me.cboxAktivitaeten = New System.Windows.Forms.CheckBox
        Me.cboxVertragsuebersicht = New System.Windows.Forms.CheckBox
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.GrpStartScreen.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'GrpStartScreen
        '
        Me.GrpStartScreen.Controls.Add(Me.cboxApplikation)
        Me.GrpStartScreen.Controls.Add(Me.cboxPendenzen)
        Me.GrpStartScreen.Controls.Add(Me.cboxAktivitaeten)
        Me.GrpStartScreen.Controls.Add(Me.cboxVertragsuebersicht)
        Me.GrpStartScreen.Location = New System.Drawing.Point(12, 52)
        Me.GrpStartScreen.Name = "GrpStartScreen"
        Me.GrpStartScreen.Size = New System.Drawing.Size(200, 139)
        Me.GrpStartScreen.TabIndex = 0
        Me.GrpStartScreen.TabStop = False
        Me.GrpStartScreen.Text = "StartBildschirm"
        '
        'cboxApplikation
        '
        Me.cboxApplikation.AutoSize = True
        Me.cboxApplikation.Location = New System.Drawing.Point(18, 97)
        Me.cboxApplikation.Name = "cboxApplikation"
        Me.cboxApplikation.Size = New System.Drawing.Size(135, 17)
        Me.cboxApplikation.TabIndex = 3
        Me.cboxApplikation.Text = "Applikationsverwaltung"
        Me.cboxApplikation.UseVisualStyleBackColor = True
        '
        'cboxPendenzen
        '
        Me.cboxPendenzen.AutoSize = True
        Me.cboxPendenzen.Location = New System.Drawing.Point(18, 74)
        Me.cboxPendenzen.Name = "cboxPendenzen"
        Me.cboxPendenzen.Size = New System.Drawing.Size(80, 17)
        Me.cboxPendenzen.TabIndex = 2
        Me.cboxPendenzen.Text = "Pendenzen"
        Me.cboxPendenzen.UseVisualStyleBackColor = True
        '
        'cboxAktivitaeten
        '
        Me.cboxAktivitaeten.AutoSize = True
        Me.cboxAktivitaeten.Location = New System.Drawing.Point(18, 51)
        Me.cboxAktivitaeten.Name = "cboxAktivitaeten"
        Me.cboxAktivitaeten.Size = New System.Drawing.Size(76, 17)
        Me.cboxAktivitaeten.TabIndex = 1
        Me.cboxAktivitaeten.Text = "Aktivitäten"
        Me.cboxAktivitaeten.UseVisualStyleBackColor = True
        '
        'cboxVertragsuebersicht
        '
        Me.cboxVertragsuebersicht.AutoSize = True
        Me.cboxVertragsuebersicht.Location = New System.Drawing.Point(18, 28)
        Me.cboxVertragsuebersicht.Name = "cboxVertragsuebersicht"
        Me.cboxVertragsuebersicht.Size = New System.Drawing.Size(108, 17)
        Me.cboxVertragsuebersicht.TabIndex = 0
        Me.cboxVertragsuebersicht.Text = "Vertragsübersicht"
        Me.cboxVertragsuebersicht.UseVisualStyleBackColor = True
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(235, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(235, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'frmMAEinstellung
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(235, 205)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Controls.Add(Me.GrpStartScreen)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmMAEinstellung"
        Me.Text = "Mitarbeitereinstellungen"
        Me.GrpStartScreen.ResumeLayout(False)
        Me.GrpStartScreen.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.TSBtnSave_Click -Methode

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        save_data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.cboxAktivitaeten_Click -Methode

[Visual Basic]
Private Sub cboxAktivitaeten_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxAktivitaeten.Click, _
   cboxApplikation.Click, _
   cboxPendenzen.Click, _
   cboxVertragsuebersicht.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxAktivitaeten_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboxAktivitaeten.Click, cboxApplikation.Click, _
    cboxPendenzen.Click, cboxVertragsuebersicht.Click
        Me.FormDataChanged = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.frmMAEinstellung_FormClosing -Methode

[Visual Basic]
Private Sub frmMAEinstellung_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmMAEinstellung_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        ma.Dispose()
        data.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.frmMAEinstellung_Load -Methode

[Visual Basic]
Private Sub frmMAEinstellung_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmMAEinstellung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        ma.cpMainConnectionProvider = Globals.conn
        ma.iMitarbeiternr = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        data = ma.SelectAllWMitarbeiternrLogic()
        If data.Rows.Count = 0 Then
            Me.cboxVertragsuebersicht.Checked = False
            Me.cboxPendenzen.Checked = False
            Me.cboxAktivitaeten.Checked = False
            Me.cboxApplikation.Checked = False
        Else
            ma.iMitarbeitereinstellungnr = New SqlInt32(CType(data.Rows(0).Item(0), Int32))
            ma.SelectOne()
            Me.cboxAktivitaeten.Checked = ma.bAktivitaeten.Value = True
            Me.cboxApplikation.Checked = ma.bApplikationsuebersicht.Value = True
            Me.cboxPendenzen.Checked = ma.bPendenzen.Value = True
            Me.cboxVertragsuebersicht.Checked = ma.bVertragsuebersicht.Value = True
        End If
        Me.sec.Set_Form_Security(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung.save_data -Methode

[Visual Basic]
Private Sub save_data()

Quellcode

[Visual Basic]
    Private Sub save_data()
        ma.cpMainConnectionProvider = Globals.conn
        ma.iMitarbeiternr = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        ma.bAktivitaeten = New SqlBoolean(CType(Me.cboxAktivitaeten.Checked, Boolean))
        ma.bApplikationsuebersicht = New SqlBoolean(CType(Me.cboxApplikation.Checked, Boolean))
        ma.bPendenzen = New SqlBoolean(CType(Me.cboxPendenzen.Checked, Boolean))
        ma.bVertragsuebersicht = New SqlBoolean(CType(Me.cboxVertragsuebersicht.Checked, Boolean))
        Globals.conn.OpenConnection()
        If data.Rows.Count = 0 Then
            ma.Insert()
        Else
            ma.Update()
        End If
        Globals.conn.CloseConnection(True)
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMAEinstellung-Felder

frmMAEinstellung Übersicht

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field ma

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmMAEinstellung -Klasse


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


data -Feld

[Visual Basic]
Private data As DataTable

Quellcode

[Visual Basic]
    Dim data As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


ma -Feld

[Visual Basic]
Private ma As clsMitarbeitereinstellung

Quellcode

[Visual Basic]
    Dim ma As New TKB.VV.DB.clsMitarbeitereinstellung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMAEinstellung


frmMain -Klasse

Hauptformular der Vertragsverwaltung als MDI-Container

For a list of all members of this type, see frmMain-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmMain

[Visual Basic]
Public Class frmMain
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmMain-Member


frmMain-Member

frmMain Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AktivitätenGenerierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AktivitätenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aktivitätenliste anzeigen
private method ApplikationToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ApplikationsübersichtToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden betätigt
private method Delete_Temp_Files Unterstützt von .NET Compact Framework | Löschen der Dateien im Temp-Verzeichnis
private method GremienverwaltungToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ImageViewerToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Init_System Unterstützt von .NET Compact Framework | System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method MitarbeitereinstellungenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NeuAnmeldenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ObjectListerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier
private method PendenzenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ReportingToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAKatalogVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufruf der Funktion für die Verwaltung der SLA-Typen
private method SLAVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAZeiteinheitenVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen
private method ServicekatalogVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ServicekatalogVerwaltenToolStripMenuItem_Click_1 Unterstützt von .NET Compact Framework |
private method StartWindows Unterstützt von .NET Compact Framework |
private method SystemadministrationToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufruf System-Administration
private method TSBtnApplikationen_Click Unterstützt von .NET Compact Framework | Applikationsübersicht über TSButton
private method TSBtnMonitoring_Click Unterstützt von .NET Compact Framework | Monitoring (Aktivitäten/Pendenzen über TS-Button)
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Quit-Button
private method TSBtnReporting_Click Unterstützt von .NET Compact Framework | Reporting über TS-Button
private method TSBtnVertragsuebersicht_Click Unterstützt von .NET Compact Framework | Vertragsübersicht über TS-Button
private method VertragselementeToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement anzeigen
private method VertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method VertragsübersichtToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsübersicht anzeigen
private method frmMain_FormClosing Unterstützt von .NET Compact Framework | Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.
private method frmMain_Load Unterstützt von .NET Compact Framework | Laden des Formulars
private method login Unterstützt von .NET Compact Framework | Login-Fenster anzeigen und neuen User anmelden
private method ÜberToolStripMenuItem_Click Unterstützt von .NET Compact Framework | About-Bildschirm anzeigen

Felder

private field ForceQuit

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field txt

Unterstützt von .NET Compact Framework

frmMain -Klasse


frmMain-Methoden

frmMain Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AktivitätenGenerierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method AktivitätenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aktivitätenliste anzeigen
private method ApplikationToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ApplikationsübersichtToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden betätigt
private method Delete_Temp_Files Unterstützt von .NET Compact Framework | Löschen der Dateien im Temp-Verzeichnis
private method GremienverwaltungToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ImageViewerToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Init_System Unterstützt von .NET Compact Framework | System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method MitarbeitereinstellungenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NeuAnmeldenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ObjectListerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier
private method PendenzenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ReportingToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAKatalogVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufruf der Funktion für die Verwaltung der SLA-Typen
private method SLAVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method SLAZeiteinheitenVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen
private method ServicekatalogVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ServicekatalogVerwaltenToolStripMenuItem_Click_1 Unterstützt von .NET Compact Framework |
private method StartWindows Unterstützt von .NET Compact Framework |
private method SystemadministrationToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aufruf System-Administration
private method TSBtnApplikationen_Click Unterstützt von .NET Compact Framework | Applikationsübersicht über TSButton
private method TSBtnMonitoring_Click Unterstützt von .NET Compact Framework | Monitoring (Aktivitäten/Pendenzen über TS-Button)
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Quit-Button
private method TSBtnReporting_Click Unterstützt von .NET Compact Framework | Reporting über TS-Button
private method TSBtnVertragsuebersicht_Click Unterstützt von .NET Compact Framework | Vertragsübersicht über TS-Button
private method VertragselementeToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement anzeigen
private method VertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method VertragsübersichtToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsübersicht anzeigen
private method frmMain_FormClosing Unterstützt von .NET Compact Framework | Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.
private method frmMain_Load Unterstützt von .NET Compact Framework | Laden des Formulars
private method login Unterstützt von .NET Compact Framework | Login-Fenster anzeigen und neuen User anmelden
private method ÜberToolStripMenuItem_Click Unterstützt von .NET Compact Framework | About-Bildschirm anzeigen

frmMain -Klasse


frmMain.AktivitätenGenerierenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub AktivitätenGenerierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AktivitätenGenerierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AktivitätenGenerierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AktivitätenGenerierenToolStripMenuItem.Click
        Dim f As New FrmGenerateActivity
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.AktivitätenToolStripMenuItem_Click -Methode

Aktivitätenliste anzeigen

[Visual Basic]
Private Sub AktivitätenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AktivitätenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AktivitätenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AktivitätenToolStripMenuItem.Click
        Dim f As New FrmAktivitaetenListe
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ApplikationToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ApplikationToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationToolStripMenuItem.Click
        Me.Cursor = Cursors.WaitCursor
        Dim f As New frmApplikation
        f.MdiParent = Me
        f.Show()
        Me.Cursor = Cursors.Default
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ApplikationsübersichtToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ApplikationsübersichtToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationsübersichtToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationsübersichtToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationsübersichtToolStripMenuItem.Click
        Dim f As New frmApplikationsuebersicht
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.BeendenToolStripMenuItem_Click -Methode

Menu Beenden betätigt

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.Delete_Temp_Files -Methode

Löschen der Dateien im Temp-Verzeichnis

[Visual Basic]
Private Sub Delete_Temp_Files()

Quellcode

[Visual Basic]
    Private Sub Delete_Temp_Files()
        Dim s As String
        For Each s In System.IO.Directory.GetFiles(Globals.clsapplication.sTmp_filepath)
            Try
                System.IO.File.Delete(s)
            Catch
            End Try
        Next s
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.GremienverwaltungToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub GremienverwaltungToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   GremienverwaltungToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GremienverwaltungToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles GremienverwaltungToolStripMenuItem.Click
        Dim f As New frmGremienverwaltung
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ImageViewerToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ImageViewerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ImageViewerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ImageViewerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ImageViewerToolStripMenuItem.Click
        If InputBox("Passwort:") = "341211" Then
            Dim f As New form1
            f.MdiParent = Me
            f.Show()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.Init_System -Methode

System-Initialosierung - Applikationsdaten auslesen - Aktueller Mitarbeiter auslesen bzw. Login-Dialog anzeigen

[Visual Basic]
Private Function Init_System() As Boolean

Quellcode

[Visual Basic]
    Private Function Init_System() As Boolean
        '       Dim dbconn As New TKB.VV.DB.DB_Connection
        '      dbconn = Nothing

        Globals.clsapplication.iApplikationsnr = 1
        Globals.clsapplication.cpMainConnectionProvider = Globals.conn
        conn.OpenConnection()
        Globals.clsapplication.SelectOne()
        conn.CloseConnection(True)

        'Show Login, sofern der Applikationsparameter gesetzt ist
        If Globals.clsapplication.bShowlogin.Value = True Then
            If Not login() Then Return False
            Me.WindowState = FormWindowState.Maximized
            If Not Directory.Exists(Globals.clsapplication.sTmp_filepath) Then
                Directory.CreateDirectory(Globals.clsapplication.sTmp_filepath)
            End If
            Dim f As New frmSplash
            f.MdiParent = Me
            f.Show()
            Application.DoEvents()
            Return True
        Else
            '14.04.2009 - Menueintrag ausblenden, sofern das Loginfenster nicht angezeigt wird
            Me.NeuAnmeldenToolStripMenuItem.Visible = False
            Dim f As New frmSplash
            f.MdiParent = Me
            f.Show()
            Application.DoEvents()
            'Prüfung mittels TG-Nummer, ob der User berechtigt ist
            Dim tmp_mitarbeiter As New TKB.VV.DB.MyMitarbeiter
            Dim tmp_mitarbeiterdata As New DataTable
            tmp_mitarbeiter.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            tmp_mitarbeiterdata = tmp_mitarbeiter.SelectWithTGNummer()
            Globals.conn.CloseConnection(True)
            Application.DoEvents()
            If tmp_mitarbeiterdata.Rows.Count < 1 Then
                txt.show_standardmessage(2, MsgBoxStyle.Exclamation)
                Me.ForceQuit = True
                Return False
                Exit Function
            End If
            Globals.clsmitarbeiter.iMitarbeiternr = New SqlInt32(CType(tmp_mitarbeiterdata.Rows(0).Item("Mitarbeiternr"), Int32))
            Globals.clsmitarbeiter.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Globals.clsmitarbeiter.SelectOne()
            Globals.conn.CloseConnection(True)
            tmp_mitarbeiter.Dispose()
            tmp_mitarbeiterdata.Dispose()
            Me.WindowState = FormWindowState.Maximized
            If Not Directory.Exists(Globals.clsapplication.sTmp_filepath) Then
                Directory.CreateDirectory(Globals.clsapplication.sTmp_filepath)
            End If
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmMain))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuAnmeldenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragsmanagementToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertragsübersichtToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem3 = New System.Windows.Forms.ToolStripSeparator
        Me.VertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ServicekatalogVerwaltenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MonitoringToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.PendenzenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AktivitätenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationsverwaltungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationsübersichtToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReportingToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ExtrasToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MitarbeitereinstellungenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SystemadministrationToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ObjectListerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageViewerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AktivitätenGenerierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.GremienverwaltungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.FensterToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KaskadierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.VertikalTeilenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.HorizontalTeilenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.HilfeToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ÜberToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnVertragsuebersicht = New System.Windows.Forms.ToolStripButton
        Me.TSBtnMonitoring = New System.Windows.Forms.ToolStripButton
        Me.TSBtnApplikationen = New System.Windows.Forms.ToolStripButton
        Me.TSBtnReporting = New System.Windows.Forms.ToolStripButton
        Me.StatusStrip1 = New System.Windows.Forms.StatusStrip
        Me.ToolStripUser = New System.Windows.Forms.ToolStripStatusLabel
        Me.ToolStripDatabase = New System.Windows.Forms.ToolStripStatusLabel
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.StatusStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem, Me.VertragsmanagementToolStripMenuItem, Me.MonitoringToolStripMenuItem, Me.ApplikationsverwaltungToolStripMenuItem, Me.ReportingToolStripMenuItem, Me.ExtrasToolStripMenuItem, Me.FensterToolStripMenuItem, Me.HilfeToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.MdiWindowListItem = Me.FensterToolStripMenuItem
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(902, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem, Me.NeuAnmeldenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(142, 22)
        Me.BeendenToolStripMenuItem.Tag = "Beenden"
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'NeuAnmeldenToolStripMenuItem
        '
        Me.NeuAnmeldenToolStripMenuItem.Name = "NeuAnmeldenToolStripMenuItem"
        Me.NeuAnmeldenToolStripMenuItem.Size = New System.Drawing.Size(142, 22)
        Me.NeuAnmeldenToolStripMenuItem.Tag = ""
        Me.NeuAnmeldenToolStripMenuItem.Text = "&Neu anmelden"
        '
        'VertragsmanagementToolStripMenuItem
        '
        Me.VertragsmanagementToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.VertragsübersichtToolStripMenuItem, Me.ToolStripMenuItem3, Me.VertragspartnerToolStripMenuItem, Me.ServicekatalogVerwaltenToolStripMenuItem})
        Me.VertragsmanagementToolStripMenuItem.Name = "VertragsmanagementToolStripMenuItem"
        Me.VertragsmanagementToolStripMenuItem.Size = New System.Drawing.Size(122, 20)
        Me.VertragsmanagementToolStripMenuItem.Tag = ""
        Me.VertragsmanagementToolStripMenuItem.Text = "&Vertragsmanagement"
        '
        'VertragsübersichtToolStripMenuItem
        '
        Me.VertragsübersichtToolStripMenuItem.Name = "VertragsübersichtToolStripMenuItem"
        Me.VertragsübersichtToolStripMenuItem.Size = New System.Drawing.Size(159, 22)
        Me.VertragsübersichtToolStripMenuItem.Text = "&Vertragsübersicht"
        '
        'ToolStripMenuItem3
        '
        Me.ToolStripMenuItem3.Name = "ToolStripMenuItem3"
        Me.ToolStripMenuItem3.Size = New System.Drawing.Size(156, 6)
        '
        'VertragspartnerToolStripMenuItem
        '
        Me.VertragspartnerToolStripMenuItem.Name = "VertragspartnerToolStripMenuItem"
        Me.VertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(159, 22)
        Me.VertragspartnerToolStripMenuItem.Tag = ""
        Me.VertragspartnerToolStripMenuItem.Text = "&Vertragspartner"
        '
        'ServicekatalogVerwaltenToolStripMenuItem
        '
        Me.ServicekatalogVerwaltenToolStripMenuItem.Name = "ServicekatalogVerwaltenToolStripMenuItem"
        Me.ServicekatalogVerwaltenToolStripMenuItem.Size = New System.Drawing.Size(159, 22)
        Me.ServicekatalogVerwaltenToolStripMenuItem.Text = "Servicekatalog"
        '
        'MonitoringToolStripMenuItem
        '
        Me.MonitoringToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.PendenzenToolStripMenuItem, Me.AktivitätenToolStripMenuItem})
        Me.MonitoringToolStripMenuItem.Name = "MonitoringToolStripMenuItem"
        Me.MonitoringToolStripMenuItem.Size = New System.Drawing.Size(69, 20)
        Me.MonitoringToolStripMenuItem.Tag = ""
        Me.MonitoringToolStripMenuItem.Text = "&Monitoring"
        '
        'PendenzenToolStripMenuItem
        '
        Me.PendenzenToolStripMenuItem.Name = "PendenzenToolStripMenuItem"
        Me.PendenzenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.PendenzenToolStripMenuItem.Text = "&Pendenzen"
        '
        'AktivitätenToolStripMenuItem
        '
        Me.AktivitätenToolStripMenuItem.Name = "AktivitätenToolStripMenuItem"
        Me.AktivitätenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.AktivitätenToolStripMenuItem.Text = "&Aktivitäten"
        '
        'ApplikationsverwaltungToolStripMenuItem
        '
        Me.ApplikationsverwaltungToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ApplikationsübersichtToolStripMenuItem, Me.ApplikationToolStripMenuItem})
        Me.ApplikationsverwaltungToolStripMenuItem.Name = "ApplikationsverwaltungToolStripMenuItem"
        Me.ApplikationsverwaltungToolStripMenuItem.Size = New System.Drawing.Size(83, 20)
        Me.ApplikationsverwaltungToolStripMenuItem.Tag = ""
        Me.ApplikationsverwaltungToolStripMenuItem.Text = "Applikationen"
        '
        'ApplikationsübersichtToolStripMenuItem
        '
        Me.ApplikationsübersichtToolStripMenuItem.Name = "ApplikationsübersichtToolStripMenuItem"
        Me.ApplikationsübersichtToolStripMenuItem.Size = New System.Drawing.Size(185, 22)
        Me.ApplikationsübersichtToolStripMenuItem.Text = "Applikationsübersicht"
        '
        'ApplikationToolStripMenuItem
        '
        Me.ApplikationToolStripMenuItem.Name = "ApplikationToolStripMenuItem"
        Me.ApplikationToolStripMenuItem.Size = New System.Drawing.Size(185, 22)
        Me.ApplikationToolStripMenuItem.Text = "Applikationsverwaltung"
        '
        'ReportingToolStripMenuItem
        '
        Me.ReportingToolStripMenuItem.Name = "ReportingToolStripMenuItem"
        Me.ReportingToolStripMenuItem.Size = New System.Drawing.Size(66, 20)
        Me.ReportingToolStripMenuItem.Tag = ""
        Me.ReportingToolStripMenuItem.Text = "&Reporting"
        '
        'ExtrasToolStripMenuItem
        '
        Me.ExtrasToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.MitarbeitereinstellungenToolStripMenuItem, Me.SystemadministrationToolStripMenuItem, Me.ObjectListerToolStripMenuItem, Me.ImageViewerToolStripMenuItem, Me.AktivitätenGenerierenToolStripMenuItem, Me.GremienverwaltungToolStripMenuItem})
        Me.ExtrasToolStripMenuItem.Name = "ExtrasToolStripMenuItem"
        Me.ExtrasToolStripMenuItem.Size = New System.Drawing.Size(50, 20)
        Me.ExtrasToolStripMenuItem.Tag = ""
        Me.ExtrasToolStripMenuItem.Text = "&Extras"
        '
        'MitarbeitereinstellungenToolStripMenuItem
        '
        Me.MitarbeitereinstellungenToolStripMenuItem.Name = "MitarbeitereinstellungenToolStripMenuItem"
        Me.MitarbeitereinstellungenToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.MitarbeitereinstellungenToolStripMenuItem.Text = "Mitarbeitereinstellungen"
        '
        'SystemadministrationToolStripMenuItem
        '
        Me.SystemadministrationToolStripMenuItem.Name = "SystemadministrationToolStripMenuItem"
        Me.SystemadministrationToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.SystemadministrationToolStripMenuItem.Text = "Systemadministration"
        '
        'ObjectListerToolStripMenuItem
        '
        Me.ObjectListerToolStripMenuItem.Name = "ObjectListerToolStripMenuItem"
        Me.ObjectListerToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.ObjectListerToolStripMenuItem.Text = "&Objektlister"
        '
        'ImageViewerToolStripMenuItem
        '
        Me.ImageViewerToolStripMenuItem.Name = "ImageViewerToolStripMenuItem"
        Me.ImageViewerToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.ImageViewerToolStripMenuItem.Text = "ImageViewer"
        Me.ImageViewerToolStripMenuItem.Visible = False
        '
        'AktivitätenGenerierenToolStripMenuItem
        '
        Me.AktivitätenGenerierenToolStripMenuItem.Name = "AktivitätenGenerierenToolStripMenuItem"
        Me.AktivitätenGenerierenToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.AktivitätenGenerierenToolStripMenuItem.Text = "Aktivitäten generieren"
        '
        'GremienverwaltungToolStripMenuItem
        '
        Me.GremienverwaltungToolStripMenuItem.Name = "GremienverwaltungToolStripMenuItem"
        Me.GremienverwaltungToolStripMenuItem.Size = New System.Drawing.Size(189, 22)
        Me.GremienverwaltungToolStripMenuItem.Text = "Gremienverwaltung"
        Me.GremienverwaltungToolStripMenuItem.Visible = False
        '
        'FensterToolStripMenuItem
        '
        Me.FensterToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KaskadierenToolStripMenuItem, Me.VertikalTeilenToolStripMenuItem, Me.HorizontalTeilenToolStripMenuItem, Me.ToolStripMenuItem1})
        Me.FensterToolStripMenuItem.Name = "FensterToolStripMenuItem"
        Me.FensterToolStripMenuItem.Size = New System.Drawing.Size(56, 20)
        Me.FensterToolStripMenuItem.Tag = ""
        Me.FensterToolStripMenuItem.Text = "&Fenster"
        '
        'KaskadierenToolStripMenuItem
        '
        Me.KaskadierenToolStripMenuItem.Name = "KaskadierenToolStripMenuItem"
        Me.KaskadierenToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.KaskadierenToolStripMenuItem.Tag = ""
        Me.KaskadierenToolStripMenuItem.Text = "&Kaskadieren"
        '
        'VertikalTeilenToolStripMenuItem
        '
        Me.VertikalTeilenToolStripMenuItem.Name = "VertikalTeilenToolStripMenuItem"
        Me.VertikalTeilenToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.VertikalTeilenToolStripMenuItem.Tag = ""
        Me.VertikalTeilenToolStripMenuItem.Text = "&Vertikal teilen"
        '
        'HorizontalTeilenToolStripMenuItem
        '
        Me.HorizontalTeilenToolStripMenuItem.Name = "HorizontalTeilenToolStripMenuItem"
        Me.HorizontalTeilenToolStripMenuItem.Size = New System.Drawing.Size(151, 22)
        Me.HorizontalTeilenToolStripMenuItem.Tag = ""
        Me.HorizontalTeilenToolStripMenuItem.Text = "&Horizontal teilen"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(148, 6)
        '
        'HilfeToolStripMenuItem
        '
        Me.HilfeToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ÜberToolStripMenuItem})
        Me.HilfeToolStripMenuItem.Name = "HilfeToolStripMenuItem"
        Me.HilfeToolStripMenuItem.Size = New System.Drawing.Size(40, 20)
        Me.HilfeToolStripMenuItem.Tag = ""
        Me.HilfeToolStripMenuItem.Text = "&Hilfe"
        '
        'ÜberToolStripMenuItem
        '
        Me.ÜberToolStripMenuItem.Name = "ÜberToolStripMenuItem"
        Me.ÜberToolStripMenuItem.Size = New System.Drawing.Size(109, 22)
        Me.ÜberToolStripMenuItem.Text = "&Über..."
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnVertragsuebersicht, Me.TSBtnMonitoring, Me.TSBtnApplikationen, Me.TSBtnReporting})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(902, 25)
        Me.ToolStrip1.TabIndex = 3
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Anwendung beenden"
        '
        'TSBtnVertragsuebersicht
        '
        Me.TSBtnVertragsuebersicht.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnVertragsuebersicht.Image = CType(resources.GetObject("TSBtnVertragsuebersicht.Image"), System.Drawing.Image)
        Me.TSBtnVertragsuebersicht.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnVertragsuebersicht.Name = "TSBtnVertragsuebersicht"
        Me.TSBtnVertragsuebersicht.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnVertragsuebersicht.Text = "Vertragsübersicht"
        '
        'TSBtnMonitoring
        '
        Me.TSBtnMonitoring.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnMonitoring.Image = CType(resources.GetObject("TSBtnMonitoring.Image"), System.Drawing.Image)
        Me.TSBtnMonitoring.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnMonitoring.Name = "TSBtnMonitoring"
        Me.TSBtnMonitoring.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnMonitoring.Text = "ToolStripButton3"
        Me.TSBtnMonitoring.ToolTipText = "Monitoring"
        '
        'TSBtnApplikationen
        '
        Me.TSBtnApplikationen.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnApplikationen.Image = CType(resources.GetObject("TSBtnApplikationen.Image"), System.Drawing.Image)
        Me.TSBtnApplikationen.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnApplikationen.Name = "TSBtnApplikationen"
        Me.TSBtnApplikationen.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnApplikationen.Text = "Applikationsverwaltung"
        '
        'TSBtnReporting
        '
        Me.TSBtnReporting.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnReporting.Image = CType(resources.GetObject("TSBtnReporting.Image"), System.Drawing.Image)
        Me.TSBtnReporting.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnReporting.Name = "TSBtnReporting"
        Me.TSBtnReporting.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnReporting.Text = "Reporting"
        '
        'StatusStrip1
        '
        Me.StatusStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripUser, Me.ToolStripDatabase})
        Me.StatusStrip1.Location = New System.Drawing.Point(0, 466)
        Me.StatusStrip1.Name = "StatusStrip1"
        Me.StatusStrip1.Size = New System.Drawing.Size(902, 22)
        Me.StatusStrip1.TabIndex = 5
        Me.StatusStrip1.Text = "StatusStrip1"
        '
        'ToolStripUser
        '
        Me.ToolStripUser.Name = "ToolStripUser"
        Me.ToolStripUser.Size = New System.Drawing.Size(0, 17)
        '
        'ToolStripDatabase
        '
        Me.ToolStripDatabase.Name = "ToolStripDatabase"
        Me.ToolStripDatabase.Size = New System.Drawing.Size(0, 17)
        '
        'frmMain
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(902, 488)
        Me.Controls.Add(Me.StatusStrip1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.IsMdiContainer = True
        Me.Name = "frmMain"
        Me.Tag = "Hauptfenster Vertragsverwaltung"
        Me.Text = "TKB IT-Service-Management"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.StatusStrip1.ResumeLayout(False)
        Me.StatusStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.MitarbeitereinstellungenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub MitarbeitereinstellungenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MitarbeitereinstellungenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MitarbeitereinstellungenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MitarbeitereinstellungenToolStripMenuItem.Click
        Dim f As New frmMAEinstellung
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.NeuAnmeldenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub NeuAnmeldenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuAnmeldenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuAnmeldenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuAnmeldenToolStripMenuItem.Click
        Login()
        sec.Set_Form_Security(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ObjectListerToolStripMenuItem_Click -Methode

Zeigt eine Liste sämtlicher offener MDI-Formulare an. Nach Auswahl wird für das selektierte Formular die Security-Objekt-Tabelle generier

[Visual Basic]
Private Sub ObjectListerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ObjectListerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ObjectListerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ObjectListerToolStripMenuItem.Click
        If InputBox("Passwort:") <> "341211" Then Exit Sub
        Dim formselector As New frmFormSelector
        formselector.ListForms.Items.Clear()
        formselector.ListForms.Items.Add(Me.Name)
        For Each x As Form In Me.MdiChildren
            formselector.ListForms.Items.Add(x.Name)
        Next
        formselector.ShowDialog()
        If formselector.DialogResult = Windows.Forms.DialogResult.OK Then
            If formselector.ListForms.SelectedItem = Me.Name Then
                sec.List_Form_Controls(Me)
                sec.Print_Screen(Me)
                Exit Sub
            End If
            For Each x As Form In Me.MdiChildren
                If x.Name = formselector.ListForms.SelectedItem Then
                    sec.List_Form_Controls(x)
                    sec.Print_Screen(x)
                End If
            Next

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain | MySecurity


frmMain.PendenzenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub PendenzenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PendenzenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PendenzenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PendenzenToolStripMenuItem.Click
        Dim f As New frmPendenzübersicht
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ReportingToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ReportingToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReportingToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReportingToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportingToolStripMenuItem.Click
        Dim f As New FrmReportSelect
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.SLAKatalogVerwaltenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub SLAKatalogVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SLAKatalogVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmSLAKatalog
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.SLAToolStripMenuItem_Click -Methode

Aufruf der Funktion für die Verwaltung der SLA-Typen

[Visual Basic]
Private Sub SLAToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SLAToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmDomainEditor("SLATyp")
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.SLAVerwaltenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub SLAVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SLAVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmVerbindungEditor("SLATyp", "SLASubTyp", "SLA", 999)
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.SLAZeiteinheitenVerwaltenToolStripMenuItem_Click -Methode

Aufrunf der Funktion für die Verwaltung der Zeiteinheittypen

[Visual Basic]
Private Sub SLAZeiteinheitenVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SLAZeiteinheitenVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmDomainEditor("Zeiteinheittyp")
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ServicekatalogVerwaltenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmServicekatalog
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ServicekatalogVerwaltenToolStripMenuItem_Click_1 -Methode

[Visual Basic]
Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click_1( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ServicekatalogVerwaltenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServicekatalogVerwaltenToolStripMenuItem_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ServicekatalogVerwaltenToolStripMenuItem.Click
        Dim f As New frmServicekatalog
        f.MdiParent = Me
        f.Show()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.StartWindows -Methode

[Visual Basic]
Private Sub StartWindows( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StartWindows(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim mae As New TKB.VV.DB.clsMitarbeitereinstellung
        Dim dat As New DataTable
        mae.cpMainConnectionProvider = Globals.conn
        mae.iMitarbeiternr = Globals.clsmitarbeiter.iMitarbeiternr.Value
        dat = mae.SelectAllWMitarbeiternrLogic
        If dat.Rows.Count > 0 Then
            mae.iMitarbeitereinstellungnr = New SqlInt32(CType(dat.Rows(0).Item(0), Int32))
            mae.SelectOne()
            Application.DoEvents()
            If mae.bVertragsuebersicht.Value = True Then
                If Me.VertragsübersichtToolStripMenuItem.Enabled = True Then
                    VertragsübersichtToolStripMenuItem_Click(sender, e)
                    Application.DoEvents()
                End If
            End If
            If mae.bApplikationsuebersicht.Value = True Then
                If Me.ApplikationsübersichtToolStripMenuItem.Enabled = True Then
                    '20091008 - neu die Applikationsverwaltung starten
                    'Me.ApplikationsübersichtToolStripMenuItem_Click(sender, e)
                    Me.ApplikationToolStripMenuItem_Click(sender, e)
                    Application.DoEvents()
                End If
            End If
            If mae.bAktivitaeten.Value = True Then
                If Me.AktivitätenToolStripMenuItem.Enabled = True Then
                    Me.AktivitätenToolStripMenuItem_Click(sender, e)
                    Application.DoEvents()
                End If
            End If
            If mae.bPendenzen.Value = True Then
                If Me.PendenzenToolStripMenuItem.Enabled = True Then
                    Me.PendenzenToolStripMenuItem_Click(sender, e)
                    Application.DoEvents()
                End If
            End If
        End If
        mae.Dispose()
        dat.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.SystemadministrationToolStripMenuItem_Click -Methode

Aufruf System-Administration

[Visual Basic]
Private Sub SystemadministrationToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SystemadministrationToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SystemadministrationToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SystemadministrationToolStripMenuItem.Click
        Dim f As New frmSysadminMenu
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.TSBtnApplikationen_Click -Methode

Applikationsübersicht über TSButton

[Visual Basic]
Private Sub TSBtnApplikationen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnApplikationen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnApplikationen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnApplikationen.Click
        'ApplikationsübersichtToolStripMenuItem_Click(sender, e)
        ApplikationToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.TSBtnMonitoring_Click -Methode

Monitoring (Aktivitäten/Pendenzen über TS-Button)

[Visual Basic]
Private Sub TSBtnMonitoring_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnMonitoring.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnMonitoring_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnMonitoring.Click
        PendenzenToolStripMenuItem_Click(sender, e)
        AktivitätenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.TSBtnQuit_Click -Methode

Quit-Button

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.TSBtnReporting_Click -Methode

Reporting über TS-Button

[Visual Basic]
Private Sub TSBtnReporting_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnReporting.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnReporting_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnReporting.Click
        ReportingToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.TSBtnVertragsuebersicht_Click -Methode

Vertragsübersicht über TS-Button

[Visual Basic]
Private Sub TSBtnVertragsuebersicht_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnVertragsuebersicht.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnVertragsuebersicht_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnVertragsuebersicht.Click
        VertragsübersichtToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.VertragselementeToolStripMenuItem_Click -Methode

Vertragselement anzeigen

[Visual Basic]
Private Sub VertragselementeToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragselementeToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New frmVertragselement
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.VertragspartnerToolStripMenuItem_Click -Methode

Vertragspartner anzeigen

[Visual Basic]
Private Sub VertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner
        f.MdiParent = Me
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.VertragsübersichtToolStripMenuItem_Click -Methode

Vertragsübersicht anzeigen

[Visual Basic]
Private Sub VertragsübersichtToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragsübersichtToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragsübersichtToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragsübersichtToolStripMenuItem.Click
        Me.Cursor = Cursors.WaitCursor
        Dim f As New frmVertragsuebersicht
        f.MdiParent = Me
        f.Show()
        Me.Cursor = Cursors.Default
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.frmMain_FormClosing -Methode

Beim schliessen des Formulars wird der User gefragt, ob die Applikation geschlossen werden soll.

[Visual Basic]
Private Sub frmMain_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmMain_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.ForceQuit Then Exit Sub

        If txt.Show_MessageYesNo(1) <> MsgBoxResult.Yes Then e.Cancel = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.frmMain_Load -Methode

Laden des Formulars

[Visual Basic]
Private Sub frmMain_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmMain_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'Globals.TTContextMenuStrip.Items.Add("Gaga")
        If Not Init_System() Then
            Me.Close()
            Exit Sub
        End If
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        sec.Set_Form_Security(Me)
        StartWindows(sender, e)
        Delete_Temp_Files()
        Me.Cursor = Cursors.Default
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.login -Methode

Login-Fenster anzeigen und neuen User anmelden

[Visual Basic]
Private Function login() As Boolean

Quellcode

[Visual Basic]
    Private Function login() As Boolean
        Dim f As New frmLogin
        f.ShowDialog()
        If f.DialogResult = Windows.Forms.DialogResult.OK Then
            Globals.clsmitarbeiter.iMitarbeiternr = f.Mitarbeiternr
            Globals.clsmitarbeiter.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Globals.clsmitarbeiter.SelectOne()
            Globals.conn.CloseConnection(True)
        Else
            Return False
        End If
        Me.ToolStripUser.Text = "U:" & Globals.clsmitarbeiter.sTgnummer.Value
        Me.ToolStripDatabase.Text = "DB:" & Globals.conn.scoDBConnection.DataSource.ToString + "." + Globals.conn.scoDBConnection.Database.ToString
        Return True

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain.ÜberToolStripMenuItem_Click -Methode

About-Bildschirm anzeigen

[Visual Basic]
Private Sub ÜberToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ÜberToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ÜberToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ÜberToolStripMenuItem.Click
        Dim f As New frmAbout
        f.ShowDialog()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMain-Felder

frmMain Übersicht

Felder

private field ForceQuit

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field txt

Unterstützt von .NET Compact Framework

frmMain -Klasse


ForceQuit -Feld

[Visual Basic]
Private ForceQuit As Boolean

Quellcode

[Visual Basic]
    Dim ForceQuit As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


txt -Feld

[Visual Basic]
Private txt As MyMessage

Quellcode

[Visual Basic]
    Dim txt As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMain


frmMsgBox -Klasse

For a list of all members of this type, see frmMsgBox-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmMsgBox

[Visual Basic]
Public Class frmMsgBox
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmMsgBox-Member


frmMsgBox-Member

frmMsgBox Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnAbbruch_Click

Unterstützt von .NET Compact Framework
private method btnOK_Click

Unterstützt von .NET Compact Framework
private method btnYes_Click

Unterstützt von .NET Compact Framework
private method btnno_Click

Unterstützt von .NET Compact Framework
private method frmMsgBox_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmMsgBox -Klasse


frmMsgBox-Methoden

frmMsgBox Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method btnAbbruch_Click

Unterstützt von .NET Compact Framework
private method btnOK_Click

Unterstützt von .NET Compact Framework
private method btnYes_Click

Unterstützt von .NET Compact Framework
private method btnno_Click

Unterstützt von .NET Compact Framework
private method frmMsgBox_Load

Unterstützt von .NET Compact Framework

frmMsgBox -Klasse


frmMsgBox.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmMsgBox))
        Me.btnYes = New System.Windows.Forms.Button
        Me.btnno = New System.Windows.Forms.Button
        Me.btnAbbruch = New System.Windows.Forms.Button
        Me.txtmsg = New System.Windows.Forms.TextBox
        Me.btnOK = New System.Windows.Forms.Button
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.imgQuestion = New System.Windows.Forms.PictureBox
        Me.imgInformation = New System.Windows.Forms.PictureBox
        Me.imgExclamation = New System.Windows.Forms.PictureBox
        Me.imgCritical = New System.Windows.Forms.PictureBox
        Me.Panel1.SuspendLayout()
        CType(Me.imgQuestion, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.imgInformation, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.imgExclamation, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.imgCritical, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'btnYes
        '
        Me.btnYes.Location = New System.Drawing.Point(71, 84)
        Me.btnYes.Name = "btnYes"
        Me.btnYes.Size = New System.Drawing.Size(75, 23)
        Me.btnYes.TabIndex = 0
        Me.btnYes.Text = "&Ja"
        Me.btnYes.UseVisualStyleBackColor = True
        '
        'btnno
        '
        Me.btnno.Location = New System.Drawing.Point(162, 84)
        Me.btnno.Name = "btnno"
        Me.btnno.Size = New System.Drawing.Size(75, 23)
        Me.btnno.TabIndex = 1
        Me.btnno.Text = "&Nein"
        Me.btnno.UseVisualStyleBackColor = True
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(254, 84)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(75, 23)
        Me.btnAbbruch.TabIndex = 2
        Me.btnAbbruch.Text = "&Abbrechen"
        Me.btnAbbruch.UseVisualStyleBackColor = True
        '
        'txtmsg
        '
        Me.txtmsg.BackColor = System.Drawing.Color.White
        Me.txtmsg.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.txtmsg.Location = New System.Drawing.Point(67, 20)
        Me.txtmsg.Multiline = True
        Me.txtmsg.Name = "txtmsg"
        Me.txtmsg.ReadOnly = True
        Me.txtmsg.Size = New System.Drawing.Size(258, 44)
        Me.txtmsg.TabIndex = 3
        Me.txtmsg.TabStop = False
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(133, 84)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.Size = New System.Drawing.Size(75, 23)
        Me.btnOK.TabIndex = 5
        Me.btnOK.Text = "&OK"
        Me.btnOK.UseVisualStyleBackColor = True
        '
        'Panel1
        '
        Me.Panel1.BackColor = System.Drawing.Color.White
        Me.Panel1.Controls.Add(Me.imgQuestion)
        Me.Panel1.Controls.Add(Me.imgInformation)
        Me.Panel1.Controls.Add(Me.imgExclamation)
        Me.Panel1.Controls.Add(Me.txtmsg)
        Me.Panel1.Controls.Add(Me.imgCritical)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 0)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(337, 78)
        Me.Panel1.TabIndex = 6
        '
        'imgQuestion
        '
        Me.imgQuestion.Image = CType(resources.GetObject("imgQuestion.Image"), System.Drawing.Image)
        Me.imgQuestion.InitialImage = CType(resources.GetObject("imgQuestion.InitialImage"), System.Drawing.Image)
        Me.imgQuestion.Location = New System.Drawing.Point(12, 20)
        Me.imgQuestion.Name = "imgQuestion"
        Me.imgQuestion.Size = New System.Drawing.Size(39, 36)
        Me.imgQuestion.TabIndex = 7
        Me.imgQuestion.TabStop = False
        '
        'imgInformation
        '
        Me.imgInformation.Image = CType(resources.GetObject("imgInformation.Image"), System.Drawing.Image)
        Me.imgInformation.InitialImage = CType(resources.GetObject("imgInformation.InitialImage"), System.Drawing.Image)
        Me.imgInformation.Location = New System.Drawing.Point(12, 20)
        Me.imgInformation.Name = "imgInformation"
        Me.imgInformation.Size = New System.Drawing.Size(39, 36)
        Me.imgInformation.TabIndex = 6
        Me.imgInformation.TabStop = False
        '
        'imgExclamation
        '
        Me.imgExclamation.Image = CType(resources.GetObject("imgExclamation.Image"), System.Drawing.Image)
        Me.imgExclamation.InitialImage = CType(resources.GetObject("imgExclamation.InitialImage"), System.Drawing.Image)
        Me.imgExclamation.Location = New System.Drawing.Point(12, 20)
        Me.imgExclamation.Name = "imgExclamation"
        Me.imgExclamation.Size = New System.Drawing.Size(39, 36)
        Me.imgExclamation.TabIndex = 5
        Me.imgExclamation.TabStop = False
        '
        'imgCritical
        '
        Me.imgCritical.Image = CType(resources.GetObject("imgCritical.Image"), System.Drawing.Image)
        Me.imgCritical.InitialImage = CType(resources.GetObject("imgCritical.InitialImage"), System.Drawing.Image)
        Me.imgCritical.Location = New System.Drawing.Point(12, 20)
        Me.imgCritical.Name = "imgCritical"
        Me.imgCritical.Size = New System.Drawing.Size(39, 36)
        Me.imgCritical.TabIndex = 4
        Me.imgCritical.TabStop = False
        '
        'frmMsgBox
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(337, 116)
        Me.Controls.Add(Me.Panel1)
        Me.Controls.Add(Me.btnOK)
        Me.Controls.Add(Me.btnAbbruch)
        Me.Controls.Add(Me.btnno)
        Me.Controls.Add(Me.btnYes)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmMsgBox"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterParent
        Me.Text = "Vertragsverwaltung"
        Me.Panel1.ResumeLayout(False)
        Me.Panel1.PerformLayout()
        CType(Me.imgQuestion, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.imgInformation, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.imgExclamation, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.imgCritical, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.btnAbbruch_Click -Methode

[Visual Basic]
Private Sub btnAbbruch_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnAbbruch.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.DialogResult = Windows.Forms.DialogResult.Cancel
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.btnOK_Click -Methode

[Visual Basic]
Private Sub btnOK_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnOK.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOK.Click
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.btnYes_Click -Methode

[Visual Basic]
Private Sub btnYes_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnYes.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnYes_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnYes.Click
        Me.DialogResult = Windows.Forms.DialogResult.Yes
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.btnno_Click -Methode

[Visual Basic]
Private Sub btnno_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnno.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnno_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnno.Click
        Me.DialogResult = Windows.Forms.DialogResult.No
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox.frmMsgBox_Load -Methode

[Visual Basic]
Private Sub frmMsgBox_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmMsgBox_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmMsgBox-Felder

frmMsgBox Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmMsgBox -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmMsgBox


frmPendenz -Klasse

For a list of all members of this type, see frmPendenz-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmPendenz

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmPendenz
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmPendenz-Member


frmPendenz-Member

frmPendenz Übersicht

Öffentliche Konstruktoren

public constructor frmPendenz -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche_Click Unterstützt von .NET Compact Framework | Vertragselement suchen und zuordnen
private method frmPendenz_Load Unterstützt von .NET Compact Framework | Load-Methode

Felder

private field Aktuelle_Pendenz

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Pendenz

Unterstützt von .NET Compact Framework
private field PendenzStatus

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmPendenz -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void frmPendenz();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Integer, Boolean, Optional Boolean)
[C#] public System.Void frmPendenz(int, int, bool, bool);

frmPendenz


frmPendenz-Methoden

frmPendenz Übersicht

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche_Click Unterstützt von .NET Compact Framework | Vertragselement suchen und zuordnen
private method frmPendenz_Load Unterstützt von .NET Compact Framework | Load-Methode

frmPendenz -Klasse


frmPendenz.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerTermin.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _
        dtPickerTermin.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmPendenz


frmPendenz.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Pendenz.Neuer_Datensatz = True Then Me.Pendenz.Delete(Me.Pendenz.iPendenzNr.Value)
            Globals.MyEventHanlder.Pendenz_Closed()
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Pendenznr As Integer _
)

Parameter

Pendenznr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Pendenznr As Integer)
        Try
            Pendenz.Get_Pendenz(Pendenznr)
            Me.txtVertragselement.Text = Pendenz.Vertragselement.sBezeichnung.ToString
            Me.txtVerantwortlich.Text = Pendenz.sVerantwortlich.Value
            Me.Aktuelles_Vertragselement = Me.Pendenz.iVertragselementNr.Value
            Me.Aktuelle_Pendenz = Me.Pendenz.iPendenzNr.Value
            Me.txtBezeichnung.Text = Me.Pendenz.sBezeichnung.Value
            Me.txtBeschreibung.Text = Me.Pendenz.sBeschreibung.Value
            Me.txtTermin.Text = Me.Pendenz.daTermin.ToString
            Me.cboxStatus.SelectedValue = Me.Pendenz.iPendenzStatusNr.Value
            Me.txtErstellt_am.Text = Pendenz.daErstellt_am.ToString
            Me.txtMutiert_am.Text = Pendenz.daMutiert_am.ToString
            Me.txtMutierer.Text = Pendenz.iMutierer.ToString
            Me.cboxSecurityLevel.SelectedValue = Me.Pendenz.iSecurityLevelNr.Value
            Me.cbaktiv.Checked = Me.Pendenz.bAktiv.Value = True
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmPendenz))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.btnVertragselementSuche = New System.Windows.Forms.Button
        Me.txtVertragselement = New System.Windows.Forms.TextBox
        Me.lblVertragselement = New System.Windows.Forms.Label
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.txtBeschreibung = New System.Windows.Forms.TextBox
        Me.lblBeschreibung = New System.Windows.Forms.Label
        Me.dtPickerTermin = New System.Windows.Forms.DateTimePicker
        Me.txtTermin = New System.Windows.Forms.MaskedTextBox
        Me.lblTermin = New System.Windows.Forms.Label
        Me.lblStatus = New System.Windows.Forms.Label
        Me.cboxStatus = New System.Windows.Forms.ComboBox
        Me.Label1 = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtVerantwortlich = New System.Windows.Forms.TextBox
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(642, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(642, 25)
        Me.ToolStrip1.TabIndex = 12
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'btnVertragselementSuche
        '
        Me.btnVertragselementSuche.Image = CType(resources.GetObject("btnVertragselementSuche.Image"), System.Drawing.Image)
        Me.btnVertragselementSuche.Location = New System.Drawing.Point(406, 52)
        Me.btnVertragselementSuche.Name = "btnVertragselementSuche"
        Me.btnVertragselementSuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragselementSuche.TabIndex = 153
        Me.btnVertragselementSuche.Text = "Button1"
        Me.btnVertragselementSuche.UseVisualStyleBackColor = True
        '
        'txtVertragselement
        '
        Me.txtVertragselement.Location = New System.Drawing.Point(142, 52)
        Me.txtVertragselement.Name = "txtVertragselement"
        Me.txtVertragselement.ReadOnly = True
        Me.txtVertragselement.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragselement.TabIndex = 0
        '
        'lblVertragselement
        '
        Me.lblVertragselement.AutoSize = True
        Me.lblVertragselement.Location = New System.Drawing.Point(11, 55)
        Me.lblVertragselement.Name = "lblVertragselement"
        Me.lblVertragselement.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragselement.TabIndex = 152
        Me.lblVertragselement.Text = "Vertragselement"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(142, 78)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 1
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(11, 81)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 151
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Location = New System.Drawing.Point(142, 104)
        Me.txtBeschreibung.Multiline = True
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(268, 75)
        Me.txtBeschreibung.TabIndex = 2
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.AutoSize = True
        Me.lblBeschreibung.Location = New System.Drawing.Point(11, 107)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(61, 13)
        Me.lblBeschreibung.TabIndex = 155
        Me.lblBeschreibung.Text = "Bemerkung"
        '
        'dtPickerTermin
        '
        Me.dtPickerTermin.Location = New System.Drawing.Point(205, 185)
        Me.dtPickerTermin.Name = "dtPickerTermin"
        Me.dtPickerTermin.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerTermin.TabIndex = 4
        '
        'txtTermin
        '
        Me.txtTermin.Location = New System.Drawing.Point(142, 185)
        Me.txtTermin.Mask = "00/00/0000"
        Me.txtTermin.Name = "txtTermin"
        Me.txtTermin.Size = New System.Drawing.Size(66, 20)
        Me.txtTermin.TabIndex = 3
        Me.txtTermin.ValidatingType = GetType(Date)
        '
        'lblTermin
        '
        Me.lblTermin.AutoSize = True
        Me.lblTermin.Location = New System.Drawing.Point(11, 188)
        Me.lblTermin.Name = "lblTermin"
        Me.lblTermin.Size = New System.Drawing.Size(39, 13)
        Me.lblTermin.TabIndex = 158
        Me.lblTermin.Text = "Termin"
        '
        'lblStatus
        '
        Me.lblStatus.AutoSize = True
        Me.lblStatus.Location = New System.Drawing.Point(12, 214)
        Me.lblStatus.Name = "lblStatus"
        Me.lblStatus.Size = New System.Drawing.Size(37, 13)
        Me.lblStatus.TabIndex = 160
        Me.lblStatus.Text = "Status"
        '
        'cboxStatus
        '
        Me.cboxStatus.FormattingEnabled = True
        Me.cboxStatus.Location = New System.Drawing.Point(142, 211)
        Me.cboxStatus.Name = "cboxStatus"
        Me.cboxStatus.Size = New System.Drawing.Size(268, 21)
        Me.cboxStatus.TabIndex = 5
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(12, 241)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(74, 13)
        Me.Label1.TabIndex = 162
        Me.Label1.Text = "Verantwortlich"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(535, 157)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 11
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(457, 160)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 173
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(535, 100)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 9
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(535, 77)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 8
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(535, 53)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 7
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(457, 104)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 171
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(457, 81)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 170
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(458, 56)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 169
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.Enabled = False
        Me.cbaktiv.Location = New System.Drawing.Point(455, 131)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(94, 15)
        Me.cbaktiv.TabIndex = 10
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtVerantwortlich
        '
        Me.txtVerantwortlich.Location = New System.Drawing.Point(142, 238)
        Me.txtVerantwortlich.Name = "txtVerantwortlich"
        Me.txtVerantwortlich.Size = New System.Drawing.Size(268, 20)
        Me.txtVerantwortlich.TabIndex = 6
        '
        'frmPendenz
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(642, 277)
        Me.Controls.Add(Me.txtVerantwortlich)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiertam)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.Label1)
        Me.Controls.Add(Me.lblStatus)
        Me.Controls.Add(Me.cboxStatus)
        Me.Controls.Add(Me.dtPickerTermin)
        Me.Controls.Add(Me.txtTermin)
        Me.Controls.Add(Me.lblTermin)
        Me.Controls.Add(Me.txtBeschreibung)
        Me.Controls.Add(Me.lblBeschreibung)
        Me.Controls.Add(Me.btnVertragselementSuche)
        Me.Controls.Add(Me.txtVertragselement)
        Me.Controls.Add(Me.lblVertragselement)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.lblBezeichnung)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPendenz"
        Me.Text = "Pendenzen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Me.Pendenz.iPendenzStatusNr = New SqlInt32(CType(Me.cboxStatus.SelectedValue, Int32))
        Me.Pendenz.iVertragselementNr = New SqlInt32(CType(Me.Aktuelles_Vertragselement, Int32))
        Me.Pendenz.sVerantwortlich = New SqlString(CType(Me.txtVerantwortlich.Text, String))
        Me.Pendenz.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Me.Pendenz.sBeschreibung = New SqlString(CType(Me.txtBeschreibung.Text, String))
        If IsDate(Me.txtTermin.Text) Then
            Me.Pendenz.daTermin = New SqlDateTime(CType(Me.txtTermin.Text, DateTime))
        Else
            Me.Pendenz.daTermin = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Me.PendenzStatus.cpMainConnectionProvider = Globals.conn
        Me.PendenzStatus.iPendenzStatusNr = New SqlInt32(CType(Me.cboxStatus.SelectedValue, Int32))
        Me.PendenzStatus.SelectOne()
        '        Me.Pendenz.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        If Me.PendenzStatus.bPendenz_Inaktivieren.Value = True Then
            Me.Pendenz.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.cbaktiv.Checked = False
            '            Me.Pendenz.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Else
            Me.Pendenz.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.cbaktiv.Checked = True
        End If
        Me.Pendenz.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
        Me.Pendenz.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Pendenz.Create_Copy(Me.Pendenz.iPendenzNr.Value))
        Me.Pendenz.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(290) = MsgBoxResult.Yes Then
            Me.Pendenz.Delete_Pendenz(Me.Pendenz.iPendenzNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Pendenz.Add_New(Me.Aktuelles_Vertragselement))
        Me.Pendenz.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Pendenz.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.btnVertragselementSuche_Click -Methode

Vertragselement suchen und zuordnen

[Visual Basic]
Private Sub btnVertragselementSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragselementSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragselementSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragselementSuche.Click
        Dim vertragselement As New TKB.VV.Vertrag.clsVertragselement
        Dim i As Integer = 0
        If vertragselement.Suchen(i) Then
            Me.Aktuelles_Vertragselement = i
            Me.txtVertragselement.Text = vertragselement.Get_Vertragselementbezeichnung(i)
            Me.FormDataChanged = True
        End If
        vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.frmPendenz_Load -Methode

Load-Methode

[Visual Basic]
Private Sub frmPendenz_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmPendenz_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Pendenzstatus laden
        Me.cboxStatus.Items.Clear()
        Me.cboxStatus.DataSource = Me.Pendenz.Pendenzstatus.Tabledata.Tables(0)
        Me.cboxStatus.DisplayMember = "Bezeichnung"
        Try
            Me.cboxStatus.ValueMember = "PendenzStatusnr"
        Catch ex As Exception
        End Try
        'Personen laden

        AddChanges(Me)
        Get_Data(Me.Aktuelle_Pendenz)
        If Me.Neuer_Datensatz Then
            Me.Pendenz.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz-Felder

frmPendenz Übersicht

Felder

private field Aktuelle_Pendenz

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Pendenz

Unterstützt von .NET Compact Framework
private field PendenzStatus

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmPendenz -Klasse


Aktuelle_Pendenz -Feld

[Visual Basic]
Private Aktuelle_Pendenz As Integer

Quellcode

[Visual Basic]
    Private Aktuelle_Pendenz As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


Aktuelles_Vertragselement -Feld

[Visual Basic]
Private Aktuelles_Vertragselement As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragselement As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


Pendenz -Feld

[Visual Basic]
Private Pendenz As clsPendenz

Quellcode

[Visual Basic]
    Dim Pendenz As New TKB.VV.Vertrag.clsPendenz

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


PendenzStatus -Feld

[Visual Basic]
Private PendenzStatus As clsPendenzstatus

Quellcode

[Visual Basic]
    Private PendenzStatus As New TKB.VV.DB.clsPendenzstatus

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenzübersicht -Klasse

For a list of all members of this type, see frmPendenzübersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmPendenzübersicht

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmPendenzübersicht
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmPendenzübersicht-Member


frmPendenzübersicht-Member

frmPendenzübersicht Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu anzeigen
private method C1Pendenzen_DoubleClick Unterstützt von .NET Compact Framework | C1Pendenz-Doubleklick
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Pendenzen_MouseDown Unterstützt von .NET Compact Framework | Mousedown im Grid
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method Get_Load_Status Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method LöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu Löschen/Inaktivieren
private method NeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu Neu
private method Refresh_Uebersicht Unterstützt von .NET Compact Framework | Aktualisieren der Pendenz-Übersicht
private method StatusToolStripComboBox_Click Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion nach Status ändern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Pendenz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neue Pendenz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method evh_FormularPendenz_Closed Unterstützt von .NET Compact Framework | Aktualisierung des Formulars
private method frmPendenzübersicht_Load Unterstützt von .NET Compact Framework | Laden des Formulars
private method tsbtnprint_Click Unterstützt von .NET Compact Framework |

Felder

private field FormReadOnly

Unterstützt von .NET Compact Framework
private field Pendenz

Unterstützt von .NET Compact Framework
private field Pendenzen

Unterstützt von .NET Compact Framework
private field Save_Status

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field StatusTable

Unterstützt von .NET Compact Framework
private field Statusdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmPendenzübersicht -Klasse


frmPendenzübersicht-Methoden

frmPendenzübersicht Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu anzeigen
private method C1Pendenzen_DoubleClick Unterstützt von .NET Compact Framework | C1Pendenz-Doubleklick
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Pendenzen_MouseDown Unterstützt von .NET Compact Framework | Mousedown im Grid
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method Get_Load_Status Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method LöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu Löschen/Inaktivieren
private method NeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menu Neu
private method Refresh_Uebersicht Unterstützt von .NET Compact Framework | Aktualisieren der Pendenz-Übersicht
private method StatusToolStripComboBox_Click Unterstützt von .NET Compact Framework |
private method StatusToolStripComboBox_SelectedIndexChanged Unterstützt von .NET Compact Framework | Selektion nach Status ändern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Pendenz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neue Pendenz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method evh_FormularPendenz_Closed Unterstützt von .NET Compact Framework | Aktualisierung des Formulars
private method frmPendenzübersicht_Load Unterstützt von .NET Compact Framework | Laden des Formulars
private method tsbtnprint_Click Unterstützt von .NET Compact Framework |

frmPendenzübersicht -Klasse


frmPendenzübersicht.AnzeigenToolStripMenuItem_Click -Methode

Context-Menu anzeigen

[Visual Basic]
Private Sub AnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AnzeigenToolStripMenuItem.Click
        Me.C1Pendenzen_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.C1Pendenzen_DoubleClick -Methode

C1Pendenz-Doubleklick

[Visual Basic]
Private Sub C1Pendenzen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Pendenzen.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Pendenzen.DoubleClick
        Try
            Dim f As New frmPendenz(Me.C1Pendenzen.Columns("Pendenznr").Value, 0, Me.FormReadOnly, False)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.C1Pendenzen_FetchRowStyle -Methode

Rowstyle von inaktiven Pendenzen

[Visual Basic]
Private Sub C1Pendenzen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Pendenzen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Pendenzen.FetchRowStyle
        Try
            If Me.C1Pendenzen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
            If Me.C1Pendenzen.Columns("PendenzStatusNr").CellValue(e.Row) < 3 Then
                If Me.C1Pendenzen.Columns("Termin").CellValue(e.Row) < Now Then
                    Dim fnt As Font = e.CellStyle.Font
                    e.CellStyle.ForeColor = Color.Red
                End If
            End If

        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.C1Pendenzen_MouseDown -Methode

Mousedown im Grid

[Visual Basic]
Private Sub C1Pendenzen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Pendenzen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Pendenzen.MouseDown
        Me.C1Pendenzen.Bookmark = Me.C1Pendenzen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.Get_Load_Status -Methode

[Visual Basic]
Private Sub Get_Load_Status()

Quellcode

[Visual Basic]
    Private Sub Get_Load_Status()
        Me.StatusToolStripComboBox.Items.Clear()
        Me.StatusToolStripComboBox.Items.Add("Alle")
        Me.StatusTable.cpMainConnectionProvider = Globals.conn
        Statusdata = Me.StatusTable.SelectAll()
        For Each dr As DataRow In Me.Statusdata.Rows
            If dr.Item("Aktiv") = True Then
                Me.StatusToolStripComboBox.Items.Add(dr.Item("Bezeichnung"))
            End If
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmPendenzübersicht))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.StatusToolStripComboBox = New System.Windows.Forms.ToolStripComboBox
        Me.tsbtnprint = New System.Windows.Forms.ToolStripButton
        Me.PendenzenContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.AnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.LöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.C1Pendenzen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.C1PrintPreviewControl1 = New C1.Win.C1Preview.C1PrintPreviewControl
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.PendenzenContextMenuStrip.SuspendLayout()
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.C1PrintPreviewControl1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(832, 24)
        Me.MenuStrip1.TabIndex = 6
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnNew, Me.TSBtnDelete, Me.StatusToolStripComboBox, Me.tsbtnprint})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(832, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        Me.TSBtnSave.Visible = False
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'StatusToolStripComboBox
        '
        Me.StatusToolStripComboBox.Items.AddRange(New Object() {"Alle Pendenzen", "Offen/In Bearbeitung", "Offen", "In Bearbeitung", "Erledigt", "Hinfällig"})
        Me.StatusToolStripComboBox.Name = "StatusToolStripComboBox"
        Me.StatusToolStripComboBox.Size = New System.Drawing.Size(121, 25)
        '
        'tsbtnprint
        '
        Me.tsbtnprint.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.tsbtnprint.Image = CType(resources.GetObject("tsbtnprint.Image"), System.Drawing.Image)
        Me.tsbtnprint.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.tsbtnprint.Name = "tsbtnprint"
        Me.tsbtnprint.Size = New System.Drawing.Size(23, 22)
        Me.tsbtnprint.Text = "Drucken"
        '
        'PendenzenContextMenuStrip
        '
        Me.PendenzenContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.AnzeigenToolStripMenuItem, Me.NeuToolStripMenuItem, Me.LöschenToolStripMenuItem})
        Me.PendenzenContextMenuStrip.Name = "PendenzenContextMenuStrip"
        Me.PendenzenContextMenuStrip.Size = New System.Drawing.Size(124, 70)
        '
        'AnzeigenToolStripMenuItem
        '
        Me.AnzeigenToolStripMenuItem.Name = "AnzeigenToolStripMenuItem"
        Me.AnzeigenToolStripMenuItem.Size = New System.Drawing.Size(123, 22)
        Me.AnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'NeuToolStripMenuItem
        '
        Me.NeuToolStripMenuItem.Name = "NeuToolStripMenuItem"
        Me.NeuToolStripMenuItem.Size = New System.Drawing.Size(123, 22)
        Me.NeuToolStripMenuItem.Text = "&Neu"
        '
        'LöschenToolStripMenuItem
        '
        Me.LöschenToolStripMenuItem.Name = "LöschenToolStripMenuItem"
        Me.LöschenToolStripMenuItem.Size = New System.Drawing.Size(123, 22)
        Me.LöschenToolStripMenuItem.Text = "&Löschen"
        Me.LöschenToolStripMenuItem.Visible = False
        '
        'C1Pendenzen
        '
        Me.C1Pendenzen.AlternatingRows = True
        Me.C1Pendenzen.ContextMenuStrip = Me.PendenzenContextMenuStrip
        Me.C1Pendenzen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Pendenzen.FetchRowStyles = True
        Me.C1Pendenzen.FilterBar = True
        Me.C1Pendenzen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Pendenzen.Images.Add(CType(resources.GetObject("C1Pendenzen.Images"), System.Drawing.Image))
        Me.C1Pendenzen.Location = New System.Drawing.Point(0, 49)
        Me.C1Pendenzen.Name = "C1Pendenzen"
        Me.C1Pendenzen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Pendenzen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Pendenzen.PreviewInfo.ZoomFactor = 75
        Me.C1Pendenzen.PrintInfo.PageSettings = CType(resources.GetObject("C1Pendenzen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Pendenzen.Size = New System.Drawing.Size(832, 469)
        Me.C1Pendenzen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Pendenzen.TabIndex = 12
        Me.C1Pendenzen.Text = "C1TrueDBGrid1"
        Me.C1Pendenzen.PropBag = resources.GetString("C1Pendenzen.PropBag")
        '
        'C1PrintPreviewControl1
        '
        Me.C1PrintPreviewControl1.Location = New System.Drawing.Point(90, 85)
        Me.C1PrintPreviewControl1.Name = "C1PrintPreviewControl1"
        '
        'C1PrintPreviewControl1.OutlineView
        '
        Me.C1PrintPreviewControl1.PreviewOutlineView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewOutlineView.LineColor = System.Drawing.Color.Empty
        Me.C1PrintPreviewControl1.PreviewOutlineView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewOutlineView.Name = "OutlineView"
        Me.C1PrintPreviewControl1.PreviewOutlineView.Size = New System.Drawing.Size(165, 427)
        Me.C1PrintPreviewControl1.PreviewOutlineView.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewPane
        '
        Me.C1PrintPreviewControl1.PreviewPane.IntegrateExternalTools = True
        Me.C1PrintPreviewControl1.PreviewPane.TabIndex = 0
        '
        'C1PrintPreviewControl1.PreviewTextSearchPanel
        '
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Dock = System.Windows.Forms.DockStyle.Right
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Location = New System.Drawing.Point(530, 0)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.MinimumSize = New System.Drawing.Size(200, 240)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Name = "PreviewTextSearchPanel"
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Size = New System.Drawing.Size(200, 453)
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewTextSearchPanel.Visible = False
        '
        'C1PrintPreviewControl1.ThumbnailView
        '
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Location = New System.Drawing.Point(0, 0)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Name = "ThumbnailView"
        Me.C1PrintPreviewControl1.PreviewThumbnailView.Size = New System.Drawing.Size(165, 348)
        Me.C1PrintPreviewControl1.PreviewThumbnailView.TabIndex = 0
        Me.C1PrintPreviewControl1.PreviewThumbnailView.UseImageAsThumbnail = False
        Me.C1PrintPreviewControl1.Size = New System.Drawing.Size(617, 421)
        Me.C1PrintPreviewControl1.TabIndex = 13
        Me.C1PrintPreviewControl1.Text = "C1PrintPreviewControl1"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Name = "btnHistoryNext"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Size = New System.Drawing.Size(32, 22)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.Tag = "C1PreviewActionEnum.HistoryNext"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryNext.ToolTipText = "Next View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Name = "btnHistoryPrev"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Size = New System.Drawing.Size(32, 22)
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.Tag = "C1PreviewActionEnum.HistoryPrev"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.HistoryPrev.ToolTipText = "Previous View"
        Me.C1PrintPreviewControl1.ToolBars.Navigation.ToolTipPageNo = Nothing
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Checked = True
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.CheckState = System.Windows.Forms.CheckState.Checked
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.Continuous.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Name = "btnPageContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.Tag = "C1PreviewActionEnum.PageContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.Continuous.ToolTipText = "Continuous View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.Facing.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Name = "btnPageFacing"
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.Tag = "C1PreviewActionEnum.PageFacing"
        Me.C1PrintPreviewControl1.ToolBars.Page.Facing.ToolTipText = "Pages Facing View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Name = "btnPageFacingContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Size = New System.Drawing.Size(23, 22)
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.Tag = "C1PreviewActionEnum.PageFacingContinuous"
        Me.C1PrintPreviewControl1.ToolBars.Page.FacingContinuous.ToolTipText = "Pages Facing Continuous View"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Text.Find.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Name = "btnFind"
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Size = New System.Drawing.Size(23, 20)
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.Tag = "C1PreviewActionEnum.Find"
        Me.C1PrintPreviewControl1.ToolBars.Text.Find.ToolTipText = "Find Text"
        '
        '
        '
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Image = CType(resources.GetObject("C1PrintPreviewControl1.ToolBars.Text.SelectText.Image"), System.Drawing.Image)
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Name = "btnSelectTextTool"
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Size = New System.Drawing.Size(23, 20)
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.Tag = "C1PreviewActionEnum.SelectTextTool"
        Me.C1PrintPreviewControl1.ToolBars.Text.SelectText.ToolTipText = "Text Select Tool"
        Me.C1PrintPreviewControl1.Visible = False
        '
        'frmPendenzübersicht
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(832, 518)
        Me.Controls.Add(Me.C1PrintPreviewControl1)
        Me.Controls.Add(Me.C1Pendenzen)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPendenzübersicht"
        Me.Text = "Pendenz-Übersicht"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.PendenzenContextMenuStrip.ResumeLayout(False)
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1PrintPreviewControl1.PreviewPane, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1PrintPreviewControl1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.C1PrintPreviewControl1.ResumeLayout(False)
        Me.C1PrintPreviewControl1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.KontakteMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub KontakteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   PendenzenContextMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub KontakteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles PendenzenContextMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Pendenzen)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht | Disable_Enable_Menu


frmPendenzübersicht.LöschenToolStripMenuItem_Click -Methode

Context-Menu Löschen/Inaktivieren

[Visual Basic]
Private Sub LöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   LöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub LöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LöschenToolStripMenuItem.Click
        Me.TSBtnDelete_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.NeuToolStripMenuItem_Click -Methode

Context-Menu Neu

[Visual Basic]
Private Sub NeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuToolStripMenuItem.Click
        Me.TSBtnNew_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.Refresh_Uebersicht -Methode

Aktualisieren der Pendenz-Übersicht

[Visual Basic]
Private Sub Refresh_Uebersicht()

Quellcode

[Visual Basic]
    Private Sub Refresh_Uebersicht()
        Me.C1Pendenzen.Enabled = False
        Try
            Dim i As Integer = -1
            For Each dr As DataRow In Me.Statusdata.Rows
                If dr.Item("Bezeichnung") = Me.StatusToolStripComboBox.SelectedItem Then i = dr.Item("Pendenzstatusnr")
            Next
            '            data = Pendenzen.Get_Pendenzuebersicht(0, Me.StatusToolStripComboBox.SelectedItem)
            data = Pendenzen.Get_Pendenzuebersicht(0, i)
            Me.Save_Status = Me.StatusToolStripComboBox.SelectedItem
        Catch ex As Exception
            Dim i1 As Integer = -1
            For Each dr As DataRow In Me.Statusdata.Rows
                If dr.Item("Bezeichnung") = Me.Save_Status Then i1 = dr.Item("Pendenzstatusnr")
            Next
            data = Pendenzen.Get_Pendenzuebersicht(0, i1)
        End Try
        Dim filtertext As String = ""
        Try
            For Each c As C1DataColumn In Me.C1Pendenzen.Columns
                If c.FilterText <> "" Then filtertext = filtertext + ";" + c.Caption + ":" + c.FilterText
            Next
        Catch ex As Exception
        End Try
        Me.C1Pendenzen.DataSource = data
        Me.C1Pendenzen.DataMember = data.TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Pendenzen, "Pendenzuebersicht", data, False)
        Try
            Dim splitter()
            splitter = filtertext.Split(";")
            If splitter.Length > 1 Then
                For Each s As String In splitter
                    Dim splitter1() As String
                    splitter1 = s.Split(":")
                    Try
                        Me.C1Pendenzen.Columns(splitter1(0)).FilterText = splitter1(1)
                    Catch ex As Exception

                    End Try
                Next
            End If
        Catch
        End Try
        Me.C1Pendenzen.Enabled = True
        sec.Set_Form_Security(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.StatusToolStripComboBox_Click -Methode

[Visual Basic]
Private Sub StatusToolStripComboBox_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   StatusToolStripComboBox.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusToolStripComboBox_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles StatusToolStripComboBox.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.StatusToolStripComboBox_SelectedIndexChanged -Methode

Selektion nach Status ändern

[Visual Basic]
Private Sub StatusToolStripComboBox_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   StatusToolStripComboBox.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub StatusToolStripComboBox_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles StatusToolStripComboBox.SelectedIndexChanged
        Refresh_Uebersicht()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.TSBtnDelete_Click -Methode

Pendenz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(290) = MsgBoxResult.Yes Then
            Me.Pendenz.Delete_Pendenz(Me.C1Pendenzen.Columns("Pendenznr").Value)
            Me.Refresh_Uebersicht()
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.TSBtnNew_Click -Methode

Neue Pendenz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Dim f As New frmPendenz(Me.Pendenz.Add_New(0), 0, Me.FormReadOnly, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.evh_FormularPendenz_Closed -Methode

Aktualisierung des Formulars

[Visual Basic]
Private Sub evh_FormularPendenz_Closed() Handles  _
   evh.FormularPendenz_Closed, _
   evh.Pendenz_Deleted

Quellcode

[Visual Basic]
    Private Sub evh_FormularPendenz_Closed() Handles evh.FormularPendenz_Closed, evh.Pendenz_Deleted
        Refresh_Uebersicht()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.frmPendenzübersicht_Load -Methode

Laden des Formulars

[Visual Basic]
Private Sub frmPendenzübersicht_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmPendenzübersicht_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_Load_Status()
        Me.StatusToolStripComboBox.SelectedIndex = 1
        Refresh_Uebersicht()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht.tsbtnprint_Click -Methode

[Visual Basic]
Private Sub tsbtnprint_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   tsbtnprint.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tsbtnprint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles tsbtnprint.Click
        Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
        Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

        With Me.C1Pendenzen.PrintInfo
            .PageHeaderStyle.Font = fontbold
            .PageSettings.Margins.Bottom = 20
            .PageSettings.Margins.Top = 20
            .PageSettings.Landscape = True
            .PageFooter = "Seite \p von \P" & vbLf & "Druckdatum " & Now()
            .PageHeader = "Pendenzen"
            .ShowProgressForm = True
            .UseGridColors = True
            .RepeatColumnHeaders = True
            .VarRowHeight = .RowHeightEnum.StretchToFit
            .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
            .PageBreak = .PageBreaksEnum.OnColumn
            .FillAreaWidth = .FillEmptyEnum.None
            .PrintPreview()
        End With

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPendenzübersicht-Felder

frmPendenzübersicht Übersicht

Felder

private field FormReadOnly

Unterstützt von .NET Compact Framework
private field Pendenz

Unterstützt von .NET Compact Framework
private field Pendenzen

Unterstützt von .NET Compact Framework
private field Save_Status

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field StatusTable

Unterstützt von .NET Compact Framework
private field Statusdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field data

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmPendenzübersicht -Klasse


FormReadOnly -Feld

[Visual Basic]
Private ReadOnly FormReadOnly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadOnly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


Pendenz -Feld

[Visual Basic]
Private Pendenz As clsPendenz

Quellcode

[Visual Basic]
    Dim Pendenz As New TKB.VV.Vertrag.clsPendenz

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


Pendenzen -Feld

[Visual Basic]
Private Pendenzen As clsPendenzUebersicht

Quellcode

[Visual Basic]
    Dim Pendenzen As New TKB.VV.Vertrag.clsPendenzUebersicht

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


Save_Status -Feld

[Visual Basic]
Private Save_Status As String

Quellcode

[Visual Basic]
    Dim Save_Status As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


StatusTable -Feld

[Visual Basic]
Private StatusTable As clsPendenzstatus

Quellcode

[Visual Basic]
    Dim StatusTable As New TKB.VV.DB.clsPendenzstatus

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


Statusdata -Feld

[Visual Basic]
Private Statusdata As DataTable

Quellcode

[Visual Basic]
    Dim Statusdata As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


data -Feld

[Visual Basic]
Private data As DataTable

Quellcode

[Visual Basic]
    Dim data As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenzübersicht


frmPerson -Klasse

Person

For a list of all members of this type, see frmPerson-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmPerson

[Visual Basic]
Public Class frmPerson
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmPerson-Member | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmPerson-Member

frmPerson Übersicht

Öffentliche Konstruktoren

public constructor frmPerson -Konstructor

Unterstützt von .NET Compact Framework

 Formular-Initialisierung

Öffentliche Eigenschaften

public property Vertragspartnernr

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Dispose Überladen.

Unterstützt von .NET Compact Framework

 Destructor Dispose

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Kontaktperson kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Kontakperson löschen
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neue Kontakperson
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button betätigt
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save-Button geklickt
private method frmPerson_Load Unterstützt von .NET Compact Framework | Laden des Formulars

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field PersonNr

Unterstützt von .NET Compact Framework
private field Personfunktion

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_vertragspartnernr

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field st

Unterstützt von .NET Compact Framework

Siehe auch

frmPerson -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmPerson -Konstructor

Formular-Initialisierung

[Visual Basic]
Public Sub New( _
   ByVal Nr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   Optional ByVal iReadOnly As Boolean = False, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Nr
PersonenNr
Vertragspartnernr
VertragspartnerNr
iReadOnly
Optional. Der Standardwert ist False.
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Public Sub New(ByVal Nr As Integer, ByVal Vertragspartnernr As Integer, Optional ByVal iReadOnly As Boolean = False, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        Me.Vertragspartnernr = Vertragspartnernr
        If CreateNew Then
            Me.PersonNr = Me.Kontaktperson.Add_New(Vertragspartnernr)
            Me.Neuer_Datensatz = True
        Else
            PersonNr = Nr
        End If
        Me.FormReadonly = iReadOnly
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson-Eigenschaften

frmPerson Übersicht

Öffentliche Eigenschaften

public property Vertragspartnernr

Unterstützt von .NET Compact Framework

Siehe auch

frmPerson -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmPerson.Vertragspartnernr -Eigenschaft

[Visual Basic]
Public Property Vertragspartnernr() As Integer

Quellcode

[Visual Basic]
    Property Vertragspartnernr() As Integer
        Get
            Return m_vertragspartnernr
        End Get
        Set(ByVal value As Integer)
            m_vertragspartnernr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson-Methoden

frmPerson Übersicht

Öffentliche Methoden

public method Dispose Überladen.

Unterstützt von .NET Compact Framework

 Destructor Dispose

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Kontaktperson kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Kontakperson löschen
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neue Kontakperson
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button betätigt
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save-Button geklickt
private method frmPerson_Load Unterstützt von .NET Compact Framework | Laden des Formulars

Siehe auch

frmPerson -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


frmPerson.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly = True Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

Destructor Dispose

[Visual Basic] Public Overloads Sub Dispose()
[C#] public System.Void Dispose();

frmPerson


frmPerson.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.Kontaktperson.Neuer_Datensatz = True Then Me.Kontaktperson.Delete(Me.Kontaktperson.iPersonNr.Value)
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.Get_Data -Methode

Person laden und präsentieren

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kontaktperson.Get_Person(Nr)
        Me.txtName_Firma1.Text = Me.Kontaktperson.sName.Value
        Me.txtVorname_Firma2.Text = Me.Kontaktperson.sVorname.Value
        Me.txtStrasse.Text = Me.Kontaktperson.sStrasse.Value
        Me.txtPostfach.Text = Me.Kontaktperson.sPostfach.Value
        Me.txtPlz.Text = Me.Kontaktperson.sPlz.Value
        Me.txtOrt.Text = Me.Kontaktperson.sOrt.Value
        Me.txtTelefon.Text = Me.Kontaktperson.sTelefon.Value
        Me.txtTelefax.Text = Me.Kontaktperson.sTelefax.Value
        Me.txtEmail.Text = Me.Kontaktperson.sEMail.Value
        Me.txtInternet.Text = Me.Kontaktperson.sInternet.Value
        Me.txtBemerkung.Text = Me.Kontaktperson.sBemerkung.Value
        Me.txtErstellt_am.Text = Me.Kontaktperson.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.txtMutierer.Text = Me.Kontaktperson.iMutierer.Value
        Me.cbAktiv.Checked = Me.Kontaktperson.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kontaktperson.iSecurityLevelNr.Value
        '20090521 - Auslesen von PersonFunktion

        Me.cbboxFunktion.SelectedValue = Me.Kontaktperson.iPersonFunktionNr.Value
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmPerson))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.txtInternet = New System.Windows.Forms.TextBox
        Me.lblInternet = New System.Windows.Forms.Label
        Me.txtEmail = New System.Windows.Forms.TextBox
        Me.lblEmail = New System.Windows.Forms.Label
        Me.txtTelefon = New System.Windows.Forms.TextBox
        Me.txtTelefax = New System.Windows.Forms.TextBox
        Me.lblTelefax = New System.Windows.Forms.Label
        Me.lblTelefon = New System.Windows.Forms.Label
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.txtPlz = New System.Windows.Forms.TextBox
        Me.lblPlzOrt = New System.Windows.Forms.Label
        Me.txtPostfach = New System.Windows.Forms.TextBox
        Me.lblPostfach = New System.Windows.Forms.Label
        Me.txtStrasse = New System.Windows.Forms.TextBox
        Me.lblStrasse = New System.Windows.Forms.Label
        Me.txtVorname_Firma2 = New System.Windows.Forms.TextBox
        Me.lblVorname = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName = New System.Windows.Forms.Label
        Me.cbboxFunktion = New System.Windows.Forms.ComboBox
        Me.lblFunktion = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(663, 24)
        Me.MenuStrip1.TabIndex = 14
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(663, 25)
        Me.ToolStrip1.TabIndex = 13
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(87, 309)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 12
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(10, 313)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 120
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'cbAktiv
        '
        Me.cbAktiv.Location = New System.Drawing.Point(399, 162)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbAktiv.Size = New System.Drawing.Size(77, 17)
        Me.cbAktiv.TabIndex = 11
        Me.cbAktiv.Text = "Aktiv"
        Me.cbAktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(566, 310)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 117
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(404, 310)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 116
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(260, 310)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 115
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(495, 313)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 114
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(345, 313)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 113
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(202, 313)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 112
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(13, 227)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 11
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(10, 211)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 110
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'txtInternet
        '
        Me.txtInternet.Location = New System.Drawing.Point(462, 133)
        Me.txtInternet.Name = "txtInternet"
        Me.txtInternet.Size = New System.Drawing.Size(177, 20)
        Me.txtInternet.TabIndex = 10
        '
        'lblInternet
        '
        Me.lblInternet.AccessibleDescription = "Name"
        Me.lblInternet.AutoSize = True
        Me.lblInternet.Location = New System.Drawing.Point(400, 136)
        Me.lblInternet.Name = "lblInternet"
        Me.lblInternet.Size = New System.Drawing.Size(43, 13)
        Me.lblInternet.TabIndex = 108
        Me.lblInternet.Text = "Internet"
        '
        'txtEmail
        '
        Me.txtEmail.Location = New System.Drawing.Point(462, 107)
        Me.txtEmail.Name = "txtEmail"
        Me.txtEmail.Size = New System.Drawing.Size(177, 20)
        Me.txtEmail.TabIndex = 9
        '
        'lblEmail
        '
        Me.lblEmail.AccessibleDescription = "Name"
        Me.lblEmail.AutoSize = True
        Me.lblEmail.Location = New System.Drawing.Point(400, 110)
        Me.lblEmail.Name = "lblEmail"
        Me.lblEmail.Size = New System.Drawing.Size(36, 13)
        Me.lblEmail.TabIndex = 106
        Me.lblEmail.Text = "E-Mail"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(462, 55)
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefon.TabIndex = 7
        '
        'txtTelefax
        '
        Me.txtTelefax.Location = New System.Drawing.Point(462, 81)
        Me.txtTelefax.Name = "txtTelefax"
        Me.txtTelefax.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefax.TabIndex = 8
        '
        'lblTelefax
        '
        Me.lblTelefax.AccessibleDescription = "Name"
        Me.lblTelefax.AutoSize = True
        Me.lblTelefax.Location = New System.Drawing.Point(400, 84)
        Me.lblTelefax.Name = "lblTelefax"
        Me.lblTelefax.Size = New System.Drawing.Size(42, 13)
        Me.lblTelefax.TabIndex = 103
        Me.lblTelefax.Text = "Telefax"
        '
        'lblTelefon
        '
        Me.lblTelefon.AccessibleDescription = "Name"
        Me.lblTelefon.AutoSize = True
        Me.lblTelefon.Location = New System.Drawing.Point(399, 58)
        Me.lblTelefon.Name = "lblTelefon"
        Me.lblTelefon.Size = New System.Drawing.Size(43, 13)
        Me.lblTelefon.TabIndex = 102
        Me.lblTelefon.Text = "Telefon"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(205, 159)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 5
        '
        'txtPlz
        '
        Me.txtPlz.Location = New System.Drawing.Point(137, 159)
        Me.txtPlz.Name = "txtPlz"
        Me.txtPlz.Size = New System.Drawing.Size(62, 20)
        Me.txtPlz.TabIndex = 4
        '
        'lblPlzOrt
        '
        Me.lblPlzOrt.AccessibleDescription = "Name"
        Me.lblPlzOrt.AutoSize = True
        Me.lblPlzOrt.Location = New System.Drawing.Point(10, 162)
        Me.lblPlzOrt.Name = "lblPlzOrt"
        Me.lblPlzOrt.Size = New System.Drawing.Size(52, 13)
        Me.lblPlzOrt.TabIndex = 99
        Me.lblPlzOrt.Text = "PLZ / Ort"
        '
        'txtPostfach
        '
        Me.txtPostfach.Location = New System.Drawing.Point(137, 133)
        Me.txtPostfach.Name = "txtPostfach"
        Me.txtPostfach.Size = New System.Drawing.Size(234, 20)
        Me.txtPostfach.TabIndex = 3
        '
        'lblPostfach
        '
        Me.lblPostfach.AccessibleDescription = "Name"
        Me.lblPostfach.AutoSize = True
        Me.lblPostfach.Location = New System.Drawing.Point(10, 136)
        Me.lblPostfach.Name = "lblPostfach"
        Me.lblPostfach.Size = New System.Drawing.Size(49, 13)
        Me.lblPostfach.TabIndex = 97
        Me.lblPostfach.Text = "Postfach"
        '
        'txtStrasse
        '
        Me.txtStrasse.Location = New System.Drawing.Point(137, 107)
        Me.txtStrasse.Name = "txtStrasse"
        Me.txtStrasse.Size = New System.Drawing.Size(234, 20)
        Me.txtStrasse.TabIndex = 2
        '
        'lblStrasse
        '
        Me.lblStrasse.AccessibleDescription = "Name"
        Me.lblStrasse.AutoSize = True
        Me.lblStrasse.Location = New System.Drawing.Point(10, 110)
        Me.lblStrasse.Name = "lblStrasse"
        Me.lblStrasse.Size = New System.Drawing.Size(42, 13)
        Me.lblStrasse.TabIndex = 95
        Me.lblStrasse.Text = "Strasse"
        '
        'txtVorname_Firma2
        '
        Me.txtVorname_Firma2.Location = New System.Drawing.Point(137, 81)
        Me.txtVorname_Firma2.Name = "txtVorname_Firma2"
        Me.txtVorname_Firma2.Size = New System.Drawing.Size(234, 20)
        Me.txtVorname_Firma2.TabIndex = 1
        '
        'lblVorname
        '
        Me.lblVorname.AccessibleDescription = "Name"
        Me.lblVorname.AutoSize = True
        Me.lblVorname.Location = New System.Drawing.Point(10, 84)
        Me.lblVorname.Name = "lblVorname"
        Me.lblVorname.Size = New System.Drawing.Size(49, 13)
        Me.lblVorname.TabIndex = 93
        Me.lblVorname.Text = "Vorname"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(137, 55)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(234, 20)
        Me.txtName_Firma1.TabIndex = 0
        '
        'lblName
        '
        Me.lblName.AccessibleDescription = "Name"
        Me.lblName.AutoSize = True
        Me.lblName.Location = New System.Drawing.Point(10, 58)
        Me.lblName.Name = "lblName"
        Me.lblName.Size = New System.Drawing.Size(35, 13)
        Me.lblName.TabIndex = 91
        Me.lblName.Text = "Name"
        '
        'cbboxFunktion
        '
        Me.cbboxFunktion.FormattingEnabled = True
        Me.cbboxFunktion.Location = New System.Drawing.Point(137, 186)
        Me.cbboxFunktion.Name = "cbboxFunktion"
        Me.cbboxFunktion.Size = New System.Drawing.Size(234, 21)
        Me.cbboxFunktion.TabIndex = 6
        '
        'lblFunktion
        '
        Me.lblFunktion.AutoSize = True
        Me.lblFunktion.Location = New System.Drawing.Point(10, 189)
        Me.lblFunktion.Name = "lblFunktion"
        Me.lblFunktion.Size = New System.Drawing.Size(48, 13)
        Me.lblFunktion.TabIndex = 122
        Me.lblFunktion.Text = "Funktion"
        '
        'frmPerson
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(663, 340)
        Me.Controls.Add(Me.cbboxFunktion)
        Me.Controls.Add(Me.lblFunktion)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.cbAktiv)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.txtInternet)
        Me.Controls.Add(Me.lblInternet)
        Me.Controls.Add(Me.txtEmail)
        Me.Controls.Add(Me.lblEmail)
        Me.Controls.Add(Me.txtTelefon)
        Me.Controls.Add(Me.txtTelefax)
        Me.Controls.Add(Me.lblTelefax)
        Me.Controls.Add(Me.lblTelefon)
        Me.Controls.Add(Me.txtOrt)
        Me.Controls.Add(Me.txtPlz)
        Me.Controls.Add(Me.lblPlzOrt)
        Me.Controls.Add(Me.txtPostfach)
        Me.Controls.Add(Me.lblPostfach)
        Me.Controls.Add(Me.txtStrasse)
        Me.Controls.Add(Me.lblStrasse)
        Me.Controls.Add(Me.txtVorname_Firma2)
        Me.Controls.Add(Me.lblVorname)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPerson"
        Me.Text = "Person"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.Save_Data -Methode

Daten sichern, sofern Änderungen vorgenommen worden sind

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kontaktperson.sName = New SqlString(CType(Me.txtName_Firma1.Text, String))
            Me.Kontaktperson.sVorname = New SqlString(CType(Me.txtVorname_Firma2.Text, String))
            Me.Kontaktperson.sStrasse = New SqlString(CType(Me.txtStrasse.Text, String))
            Me.Kontaktperson.sPostfach = New SqlString(CType(Me.txtPostfach.Text, String))
            Me.Kontaktperson.sPlz = New SqlString(CType(Me.txtPlz.Text, String))
            Me.Kontaktperson.sOrt = New SqlString(CType(Me.txtOrt.Text, String))
            Me.Kontaktperson.sTelefon = New SqlString(CType(Me.txtTelefon.Text, String))
            Me.Kontaktperson.sTelefax = New SqlString(CType(Me.txtTelefax.Text, String))
            Me.Kontaktperson.sEMail = New SqlString(CType(Me.txtEmail.Text, String))
            Me.Kontaktperson.sInternet = New SqlString(CType(Me.txtInternet.Text, String))
            Me.Kontaktperson.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kontaktperson.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Kontaktperson.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            '20090521 - Speichern von PersonFunktion
            Me.Kontaktperson.iPersonFunktionNr = New SqlInt32(CType(Me.cbboxFunktion.SelectedValue, Int32))
            Get_Data(Me.Kontaktperson.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.TSBtnCopy_Click -Methode

Kontaktperson kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        Check_Changes()
        Me.Get_Data(Kontaktperson.Create_Copy(Me.Kontaktperson.iPersonNr.Value))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.TSBtnDelete_Click -Methode

Kontakperson löschen

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(200) = MsgBoxResult.Yes Then
            Me.Kontaktperson.Delete_Kontakt(Me.Kontaktperson.iPersonNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.TSBtnNew_Click -Methode

Neue Kontakperson

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Check_Changes()
        Me.Get_Data(Me.Kontaktperson.Add_New(Me.Vertragspartnernr))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.TSBtnQuit_Click -Methode

Schliessen-Button betätigt

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.TSBtnSave_Click -Methode

Save-Button geklickt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson.frmPerson_Load -Methode

Laden des Formulars

[Visual Basic]
Private Sub frmPerson_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmPerson_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        '20090521 - PersonFunktion laden
        Personfunktion = st.Get_Stammdaten("PersonFunktion", "Bezeichnung")
        Me.cbboxFunktion.DataSource = Personfunktion
        Me.cbboxFunktion.DisplayMember = "Bezeichnung"
        Me.cbboxFunktion.ValueMember = "Personfunktionnr"

        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Get_Data(PersonNr)
        Me.AddChanges(Me)
        If Me.Neuer_Datensatz = True Then Me.Kontaktperson.Neuer_Datensatz = True
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmPerson-Felder

frmPerson Übersicht

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field PersonNr

Unterstützt von .NET Compact Framework
private field Personfunktion

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_vertragspartnernr

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field st

Unterstützt von .NET Compact Framework

Siehe auch

frmPerson -Klasse | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


Kontaktperson -Feld

[Visual Basic]
Private Kontaktperson As clsPersonen

Quellcode

[Visual Basic]
    Dim Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


PersonNr -Feld

[Visual Basic]
Private PersonNr As Integer

Quellcode

[Visual Basic]
    Dim PersonNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


Personfunktion -Feld

[Visual Basic]
Private Personfunktion As DataTable

Quellcode

[Visual Basic]
    Dim Personfunktion As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


m_vertragspartnernr -Feld

[Visual Basic]
Private m_vertragspartnernr As Integer

Quellcode

[Visual Basic]
    Dim m_vertragspartnernr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


st -Feld

[Visual Basic]
Private st As clsStammdaten

Quellcode

[Visual Basic]
    Dim st As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmProfilVerwaltung -Klasse

For a list of all members of this type, see frmProfilVerwaltung-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmProfilVerwaltung

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmProfilVerwaltung
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmProfilVerwaltung-Member


frmProfilVerwaltung-Member

frmProfilVerwaltung Übersicht

Öffentliche Konstruktoren

public constructor frmProfilVerwaltung -Konstructor

Unterstützt von .NET Compact Framework

 Initialisierung des Formulares

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method Button1_Click Unterstützt von .NET Compact Framework |
private method Button2_Click Unterstützt von .NET Compact Framework |
private method Button3_Click Unterstützt von .NET Compact Framework |
private method Button4_Click Unterstützt von .NET Compact Framework |
private method Button5_Click Unterstützt von .NET Compact Framework |
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_data Unterstützt von .NET Compact Framework | Profildaten lesen
private method Grid_Spalten Unterstützt von .NET Compact Framework | Berech Spalten aus TrueDbGrid initialisieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Save_Data Unterstützt von .NET Compact Framework | Profildaten speichern
private method Sortierung Unterstützt von .NET Compact Framework | Bereich Sortierung initialisieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TabControl_Pages Unterstützt von .NET Compact Framework | Bereich Registerlaschen initialisieren
private method btnUnselectColumn_Click Unterstützt von .NET Compact Framework |
private method frmProfilVerwaltung_Load Unterstützt von .NET Compact Framework | Formular Load
private method lbVerwendeteSpalten_DoubleClick Unterstützt von .NET Compact Framework |
private method lbVorhandeneSpalten_DoubleClick Unterstützt von .NET Compact Framework |

Felder

private field C1Data

Unterstützt von .NET Compact Framework
private field FormdataChanged

Unterstützt von .NET Compact Framework
private field Profilnr

Unterstützt von .NET Compact Framework
private field Tabctl

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field docmgmt

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field profil

Unterstützt von .NET Compact Framework

frmProfilVerwaltung -Klasse


frmProfilVerwaltung -Konstructor

Initialisierung des Formulares

[Visual Basic]
Public Sub New( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal profilnr As Integer, _
   Optional ByRef tabctl As TabControl = Nothing _
)

Parameter

c1data
Betroffenes Truedbgrid
profilnr
Aktuelle ProfilNr
tabctl
TabControl

Quellcode

[Visual Basic]
    Public Sub New(ByRef c1data As C1TrueDBGrid, ByVal profilnr As Integer, Optional ByRef tabctl As TabControl = Nothing)
        InitializeComponent()
        Me.C1Data = c1data
        Me.Profilnr = profilnr
        Me.Tabctl = tabctl
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung-Methoden

frmProfilVerwaltung Übersicht

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method Button1_Click Unterstützt von .NET Compact Framework |
private method Button2_Click Unterstützt von .NET Compact Framework |
private method Button3_Click Unterstützt von .NET Compact Framework |
private method Button4_Click Unterstützt von .NET Compact Framework |
private method Button5_Click Unterstützt von .NET Compact Framework |
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_data Unterstützt von .NET Compact Framework | Profildaten lesen
private method Grid_Spalten Unterstützt von .NET Compact Framework | Berech Spalten aus TrueDbGrid initialisieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Save_Data Unterstützt von .NET Compact Framework | Profildaten speichern
private method Sortierung Unterstützt von .NET Compact Framework | Bereich Sortierung initialisieren
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TabControl_Pages Unterstützt von .NET Compact Framework | Bereich Registerlaschen initialisieren
private method btnUnselectColumn_Click Unterstützt von .NET Compact Framework |
private method frmProfilVerwaltung_Load Unterstützt von .NET Compact Framework | Formular Load
private method lbVerwendeteSpalten_DoubleClick Unterstützt von .NET Compact Framework |
private method lbVorhandeneSpalten_DoubleClick Unterstützt von .NET Compact Framework |

frmProfilVerwaltung -Klasse


frmProfilVerwaltung.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStipMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Button1_Click -Methode

[Visual Basic]
Private Sub Button1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.lbVerwendeteSpalten_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Button2_Click -Methode

[Visual Basic]
Private Sub Button2_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button2.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim i As Integer = 0
        Dim s As Object
        Try
            i = Me.lbRegister.SelectedIndex
            If i < Me.lbRegister.Items.Count - 1 Then
                s = Me.lbRegister.SelectedItem
                Me.lbRegister.Items.Remove(s)
                i = i + 1
                Me.lbRegister.Items.Insert(i, s)
                Me.lbRegister.SelectedIndex = i
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Button3_Click -Methode

[Visual Basic]
Private Sub Button3_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button3.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim i As Integer = 0
        Dim s As Object
        Try
            i = Me.lbRegister.SelectedIndex
            If i > 0 Then
                s = Me.lbRegister.SelectedItem
                Me.lbRegister.Items.Remove(s)
                i = i - 1
                Me.lbRegister.Items.Insert(i, s)
                Me.lbRegister.SelectedIndex = i
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Button4_Click -Methode

[Visual Basic]
Private Sub Button4_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button4.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Dim s As String = Me.lbSort.SelectedItem + " | "
        Try
            If Me.lbSortDirection.SelectedIndex = 0 Then s = s + "Absteigend" Else s = s + "Aufsteigend"
        Catch ex As Exception
            s = s + "Absteigend"
        End Try
        Me.lbSortKriterien.Items.Add(s)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Button5_Click -Methode

[Visual Basic]
Private Sub Button5_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Button5.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Try
            Me.lbSortKriterien.Items.Remove(Me.lbSortKriterien.SelectedItem)
            Me.lbSortKriterien.SelectedIndex = 0
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

Formular-Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmProfilVerwaltung


frmProfilVerwaltung.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Get_data -Methode

Profildaten lesen

[Visual Basic]
Private Sub Get_data( _
   ByVal profilnr As Integer _
)

Parameter

profilnr

Quellcode

[Visual Basic]
    Private Sub Get_data(ByVal profilnr As Integer)
        profil.Get_Profil(profilnr)
        Me.txtBezeichnung.Text = profil.sBezeichnung.Value
        Me.cbStandard.Checked = profil.bStandard.Value = True
        If profil.bV_Aktiv_Vertragspartner.Value = True Then
            Me.rbAktiveVertragspartner.Checked = True
            Me.rbAlleVertragspartner.Checked = False
        Else
            Me.rbAktiveVertragspartner.Checked = False
            Me.rbAlleVertragspartner.Checked = True
        End If
        Select Case profil.sV_Aktiv_Vertragselemente.Value
            Case "True"
                Me.rbAktiveVertragselemente.Checked = True
                Me.rbAlleVertragselemente.Checked = False
                Me.rbInaktiveVertragselemente.Checked = False
            Case "False"
                Me.rbAktiveVertragselemente.Checked = False
                Me.rbAlleVertragselemente.Checked = False
                Me.rbInaktiveVertragselemente.Checked = True
            Case ""
                Me.rbAktiveVertragselemente.Checked = False
                Me.rbAlleVertragselemente.Checked = True
                Me.rbInaktiveVertragselemente.Checked = False
            Case Else
                Me.rbAktiveVertragselemente.Checked = False
                Me.rbAlleVertragselemente.Checked = False
                Me.rbInaktiveVertragselemente.Checked = False
        End Select
        Select Case profil.bV_Struktur_Details.Value
            Case True
                Me.cboxAlleElemente.Checked = True
            Case Else
                Me.cboxAlleElemente.Checked = False
        End Select
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Grid_Spalten -Methode

Berech Spalten aus TrueDbGrid initialisieren

[Visual Basic]
Private Sub Grid_Spalten()

Quellcode

[Visual Basic]
    Private Sub Grid_Spalten()
        Me.lbVorhandeneSpalten.Items.Clear()
        Me.lbVerwendeteSpalten.Items.Clear()

        Dim i As Integer
        For i = 0 To C1Data.Columns.Count - 1
            Try
                If C1Data.Splits(0).DisplayColumns(i).Visible = False Then
                    If C1Data.Splits(0).DisplayColumns(i).Name().ToString <> "" Then
                        Me.lbVorhandeneSpalten.Items.Add(C1Data.Splits(0).DisplayColumns(i).Name())
                    End If
                Else
                    Me.lbVerwendeteSpalten.Items.Add(Me.C1Data.Splits(0).DisplayColumns(i).Name())
                End If
            Catch
            End Try
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmProfilVerwaltung))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TabControlProfil = New System.Windows.Forms.TabControl
        Me.TabVertragsübersicht = New System.Windows.Forms.TabPage
        Me.TabControlVertragsuebersicht = New System.Windows.Forms.TabControl
        Me.TabAllgemein = New System.Windows.Forms.TabPage
        Me.GrpVertragspartner = New System.Windows.Forms.GroupBox
        Me.rbAlleVertragspartner = New System.Windows.Forms.RadioButton
        Me.rbAktiveVertragspartner = New System.Windows.Forms.RadioButton
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.cbStandard = New System.Windows.Forms.CheckBox
        Me.grpVertragselemente = New System.Windows.Forms.GroupBox
        Me.rbInaktiveVertragselemente = New System.Windows.Forms.RadioButton
        Me.rbAlleVertragselemente = New System.Windows.Forms.RadioButton
        Me.rbAktiveVertragselemente = New System.Windows.Forms.RadioButton
        Me.grpSpaltensortierung = New System.Windows.Forms.GroupBox
        Me.Button1 = New System.Windows.Forms.Button
        Me.lblVerwendeteSpalten = New System.Windows.Forms.Label
        Me.btnUnselectColumn = New System.Windows.Forms.Button
        Me.lblVorhandeneSpalten = New System.Windows.Forms.Label
        Me.lbVerwendeteSpalten = New System.Windows.Forms.ListBox
        Me.lbVorhandeneSpalten = New System.Windows.Forms.ListBox
        Me.TabSortierung = New System.Windows.Forms.TabPage
        Me.lblSortkriterien = New System.Windows.Forms.Label
        Me.Button5 = New System.Windows.Forms.Button
        Me.lbSortKriterien = New System.Windows.Forms.ListBox
        Me.lblSortDirection = New System.Windows.Forms.Label
        Me.lblSortFelder = New System.Windows.Forms.Label
        Me.Button4 = New System.Windows.Forms.Button
        Me.lbSort = New System.Windows.Forms.ListBox
        Me.lbSortDirection = New System.Windows.Forms.ListBox
        Me.TabRegister = New System.Windows.Forms.TabPage
        Me.lblRegisterReihenfolge = New System.Windows.Forms.Label
        Me.Button2 = New System.Windows.Forms.Button
        Me.lbRegister = New System.Windows.Forms.ListBox
        Me.Button3 = New System.Windows.Forms.Button
        Me.cboxAlleElemente = New System.Windows.Forms.CheckBox
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.TabControlProfil.SuspendLayout()
        Me.TabVertragsübersicht.SuspendLayout()
        Me.TabControlVertragsuebersicht.SuspendLayout()
        Me.TabAllgemein.SuspendLayout()
        Me.GrpVertragspartner.SuspendLayout()
        Me.grpVertragselemente.SuspendLayout()
        Me.grpSpaltensortierung.SuspendLayout()
        Me.TabSortierung.SuspendLayout()
        Me.TabRegister.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(403, 24)
        Me.MenuStrip1.TabIndex = 6
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStipMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStipMenuItem
        '
        Me.BeendenToolStipMenuItem.Name = "BeendenToolStipMenuItem"
        Me.BeendenToolStipMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStipMenuItem.Tag = ""
        Me.BeendenToolStipMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(403, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TabControlProfil
        '
        Me.TabControlProfil.Controls.Add(Me.TabVertragsübersicht)
        Me.TabControlProfil.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControlProfil.Location = New System.Drawing.Point(0, 49)
        Me.TabControlProfil.Name = "TabControlProfil"
        Me.TabControlProfil.SelectedIndex = 0
        Me.TabControlProfil.Size = New System.Drawing.Size(403, 478)
        Me.TabControlProfil.TabIndex = 8
        '
        'TabVertragsübersicht
        '
        Me.TabVertragsübersicht.Controls.Add(Me.TabControlVertragsuebersicht)
        Me.TabVertragsübersicht.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsübersicht.Name = "TabVertragsübersicht"
        Me.TabVertragsübersicht.Padding = New System.Windows.Forms.Padding(3)
        Me.TabVertragsübersicht.Size = New System.Drawing.Size(395, 452)
        Me.TabVertragsübersicht.TabIndex = 0
        Me.TabVertragsübersicht.Text = "Vertragsübersicht"
        Me.TabVertragsübersicht.UseVisualStyleBackColor = True
        '
        'TabControlVertragsuebersicht
        '
        Me.TabControlVertragsuebersicht.Controls.Add(Me.TabAllgemein)
        Me.TabControlVertragsuebersicht.Controls.Add(Me.TabSortierung)
        Me.TabControlVertragsuebersicht.Controls.Add(Me.TabRegister)
        Me.TabControlVertragsuebersicht.Location = New System.Drawing.Point(6, 6)
        Me.TabControlVertragsuebersicht.Name = "TabControlVertragsuebersicht"
        Me.TabControlVertragsuebersicht.SelectedIndex = 0
        Me.TabControlVertragsuebersicht.Size = New System.Drawing.Size(385, 445)
        Me.TabControlVertragsuebersicht.TabIndex = 21
        '
        'TabAllgemein
        '
        Me.TabAllgemein.Controls.Add(Me.GrpVertragspartner)
        Me.TabAllgemein.Controls.Add(Me.txtBezeichnung)
        Me.TabAllgemein.Controls.Add(Me.lblBezeichnung)
        Me.TabAllgemein.Controls.Add(Me.cbStandard)
        Me.TabAllgemein.Controls.Add(Me.grpVertragselemente)
        Me.TabAllgemein.Controls.Add(Me.grpSpaltensortierung)
        Me.TabAllgemein.Location = New System.Drawing.Point(4, 22)
        Me.TabAllgemein.Name = "TabAllgemein"
        Me.TabAllgemein.Padding = New System.Windows.Forms.Padding(3)
        Me.TabAllgemein.Size = New System.Drawing.Size(377, 419)
        Me.TabAllgemein.TabIndex = 0
        Me.TabAllgemein.Text = "Allgemein / Datenselektion"
        Me.TabAllgemein.UseVisualStyleBackColor = True
        '
        'GrpVertragspartner
        '
        Me.GrpVertragspartner.Controls.Add(Me.cboxAlleElemente)
        Me.GrpVertragspartner.Controls.Add(Me.rbAlleVertragspartner)
        Me.GrpVertragspartner.Controls.Add(Me.rbAktiveVertragspartner)
        Me.GrpVertragspartner.Location = New System.Drawing.Point(15, 33)
        Me.GrpVertragspartner.Name = "GrpVertragspartner"
        Me.GrpVertragspartner.Size = New System.Drawing.Size(179, 89)
        Me.GrpVertragspartner.TabIndex = 12
        Me.GrpVertragspartner.TabStop = False
        Me.GrpVertragspartner.Text = "Vertragspartner / Vertragstypen"
        '
        'rbAlleVertragspartner
        '
        Me.rbAlleVertragspartner.AutoSize = True
        Me.rbAlleVertragspartner.Location = New System.Drawing.Point(15, 42)
        Me.rbAlleVertragspartner.Name = "rbAlleVertragspartner"
        Me.rbAlleVertragspartner.Size = New System.Drawing.Size(41, 17)
        Me.rbAlleVertragspartner.TabIndex = 1
        Me.rbAlleVertragspartner.TabStop = True
        Me.rbAlleVertragspartner.Text = "alle"
        Me.rbAlleVertragspartner.UseVisualStyleBackColor = True
        '
        'rbAktiveVertragspartner
        '
        Me.rbAktiveVertragspartner.AutoSize = True
        Me.rbAktiveVertragspartner.Location = New System.Drawing.Point(15, 19)
        Me.rbAktiveVertragspartner.Name = "rbAktiveVertragspartner"
        Me.rbAktiveVertragspartner.Size = New System.Drawing.Size(72, 17)
        Me.rbAktiveVertragspartner.TabIndex = 0
        Me.rbAktiveVertragspartner.TabStop = True
        Me.rbAktiveVertragspartner.Text = "nur aktive"
        Me.rbAktiveVertragspartner.UseVisualStyleBackColor = True
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(87, 7)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(200, 20)
        Me.txtBezeichnung.TabIndex = 10
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(12, 10)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 11
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'cbStandard
        '
        Me.cbStandard.AutoSize = True
        Me.cbStandard.Location = New System.Drawing.Point(293, 9)
        Me.cbStandard.Name = "cbStandard"
        Me.cbStandard.Size = New System.Drawing.Size(69, 17)
        Me.cbStandard.TabIndex = 15
        Me.cbStandard.Text = "Standard"
        Me.cbStandard.UseVisualStyleBackColor = True
        '
        'grpVertragselemente
        '
        Me.grpVertragselemente.Controls.Add(Me.rbInaktiveVertragselemente)
        Me.grpVertragselemente.Controls.Add(Me.rbAlleVertragselemente)
        Me.grpVertragselemente.Controls.Add(Me.rbAktiveVertragselemente)
        Me.grpVertragselemente.Location = New System.Drawing.Point(200, 33)
        Me.grpVertragselemente.Name = "grpVertragselemente"
        Me.grpVertragselemente.Size = New System.Drawing.Size(162, 89)
        Me.grpVertragselemente.TabIndex = 13
        Me.grpVertragselemente.TabStop = False
        Me.grpVertragselemente.Text = "Vertragselemente"
        '
        'rbInaktiveVertragselemente
        '
        Me.rbInaktiveVertragselemente.AutoSize = True
        Me.rbInaktiveVertragselemente.Location = New System.Drawing.Point(15, 65)
        Me.rbInaktiveVertragselemente.Name = "rbInaktiveVertragselemente"
        Me.rbInaktiveVertragselemente.Size = New System.Drawing.Size(80, 17)
        Me.rbInaktiveVertragselemente.TabIndex = 2
        Me.rbInaktiveVertragselemente.TabStop = True
        Me.rbInaktiveVertragselemente.Text = "nur inaktive"
        Me.rbInaktiveVertragselemente.UseVisualStyleBackColor = True
        '
        'rbAlleVertragselemente
        '
        Me.rbAlleVertragselemente.AutoSize = True
        Me.rbAlleVertragselemente.Location = New System.Drawing.Point(15, 42)
        Me.rbAlleVertragselemente.Name = "rbAlleVertragselemente"
        Me.rbAlleVertragselemente.Size = New System.Drawing.Size(41, 17)
        Me.rbAlleVertragselemente.TabIndex = 1
        Me.rbAlleVertragselemente.TabStop = True
        Me.rbAlleVertragselemente.Text = "alle"
        Me.rbAlleVertragselemente.UseVisualStyleBackColor = True
        '
        'rbAktiveVertragselemente
        '
        Me.rbAktiveVertragselemente.AutoSize = True
        Me.rbAktiveVertragselemente.Location = New System.Drawing.Point(15, 19)
        Me.rbAktiveVertragselemente.Name = "rbAktiveVertragselemente"
        Me.rbAktiveVertragselemente.Size = New System.Drawing.Size(72, 17)
        Me.rbAktiveVertragselemente.TabIndex = 0
        Me.rbAktiveVertragselemente.TabStop = True
        Me.rbAktiveVertragselemente.Text = "nur aktive"
        Me.rbAktiveVertragselemente.UseVisualStyleBackColor = True
        '
        'grpSpaltensortierung
        '
        Me.grpSpaltensortierung.Controls.Add(Me.Button1)
        Me.grpSpaltensortierung.Controls.Add(Me.lblVerwendeteSpalten)
        Me.grpSpaltensortierung.Controls.Add(Me.btnUnselectColumn)
        Me.grpSpaltensortierung.Controls.Add(Me.lblVorhandeneSpalten)
        Me.grpSpaltensortierung.Controls.Add(Me.lbVerwendeteSpalten)
        Me.grpSpaltensortierung.Controls.Add(Me.lbVorhandeneSpalten)
        Me.grpSpaltensortierung.Location = New System.Drawing.Point(15, 128)
        Me.grpSpaltensortierung.Name = "grpSpaltensortierung"
        Me.grpSpaltensortierung.Size = New System.Drawing.Size(347, 281)
        Me.grpSpaltensortierung.TabIndex = 14
        Me.grpSpaltensortierung.TabStop = False
        Me.grpSpaltensortierung.Text = "Spaltenselektion Vertragselemente"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Image)
        Me.Button1.Location = New System.Drawing.Point(158, 146)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(36, 34)
        Me.Button1.TabIndex = 16
        Me.Button1.UseVisualStyleBackColor = True
        '
        'lblVerwendeteSpalten
        '
        Me.lblVerwendeteSpalten.AutoSize = True
        Me.lblVerwendeteSpalten.Location = New System.Drawing.Point(197, 25)
        Me.lblVerwendeteSpalten.Name = "lblVerwendeteSpalten"
        Me.lblVerwendeteSpalten.Size = New System.Drawing.Size(103, 13)
        Me.lblVerwendeteSpalten.TabIndex = 3
        Me.lblVerwendeteSpalten.Text = "Verwendete Spalten"
        '
        'btnUnselectColumn
        '
        Me.btnUnselectColumn.Image = CType(resources.GetObject("btnUnselectColumn.Image"), System.Drawing.Image)
        Me.btnUnselectColumn.Location = New System.Drawing.Point(158, 106)
        Me.btnUnselectColumn.Name = "btnUnselectColumn"
        Me.btnUnselectColumn.Size = New System.Drawing.Size(36, 34)
        Me.btnUnselectColumn.TabIndex = 15
        Me.btnUnselectColumn.UseVisualStyleBackColor = True
        '
        'lblVorhandeneSpalten
        '
        Me.lblVorhandeneSpalten.AutoSize = True
        Me.lblVorhandeneSpalten.Location = New System.Drawing.Point(17, 25)
        Me.lblVorhandeneSpalten.Name = "lblVorhandeneSpalten"
        Me.lblVorhandeneSpalten.Size = New System.Drawing.Size(104, 13)
        Me.lblVorhandeneSpalten.TabIndex = 2
        Me.lblVorhandeneSpalten.Text = "Vorhandene Spalten"
        '
        'lbVerwendeteSpalten
        '
        Me.lbVerwendeteSpalten.FormattingEnabled = True
        Me.lbVerwendeteSpalten.Location = New System.Drawing.Point(200, 41)
        Me.lbVerwendeteSpalten.Name = "lbVerwendeteSpalten"
        Me.lbVerwendeteSpalten.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.lbVerwendeteSpalten.Size = New System.Drawing.Size(138, 225)
        Me.lbVerwendeteSpalten.Sorted = True
        Me.lbVerwendeteSpalten.TabIndex = 1
        '
        'lbVorhandeneSpalten
        '
        Me.lbVorhandeneSpalten.FormattingEnabled = True
        Me.lbVorhandeneSpalten.Location = New System.Drawing.Point(15, 41)
        Me.lbVorhandeneSpalten.Name = "lbVorhandeneSpalten"
        Me.lbVorhandeneSpalten.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.lbVorhandeneSpalten.Size = New System.Drawing.Size(138, 225)
        Me.lbVorhandeneSpalten.Sorted = True
        Me.lbVorhandeneSpalten.TabIndex = 0
        '
        'TabSortierung
        '
        Me.TabSortierung.Controls.Add(Me.lblSortkriterien)
        Me.TabSortierung.Controls.Add(Me.Button5)
        Me.TabSortierung.Controls.Add(Me.lbSortKriterien)
        Me.TabSortierung.Controls.Add(Me.lblSortDirection)
        Me.TabSortierung.Controls.Add(Me.lblSortFelder)
        Me.TabSortierung.Controls.Add(Me.Button4)
        Me.TabSortierung.Controls.Add(Me.lbSort)
        Me.TabSortierung.Controls.Add(Me.lbSortDirection)
        Me.TabSortierung.Location = New System.Drawing.Point(4, 22)
        Me.TabSortierung.Name = "TabSortierung"
        Me.TabSortierung.Padding = New System.Windows.Forms.Padding(3)
        Me.TabSortierung.Size = New System.Drawing.Size(377, 419)
        Me.TabSortierung.TabIndex = 1
        Me.TabSortierung.Text = "Sortierung Vertragselemente"
        Me.TabSortierung.UseVisualStyleBackColor = True
        '
        'lblSortkriterien
        '
        Me.lblSortkriterien.AutoSize = True
        Me.lblSortkriterien.Location = New System.Drawing.Point(6, 260)
        Me.lblSortkriterien.Name = "lblSortkriterien"
        Me.lblSortkriterien.Size = New System.Drawing.Size(103, 13)
        Me.lblSortkriterien.TabIndex = 25
        Me.lblSortkriterien.Text = "Gewählte Sortierung"
        '
        'Button5
        '
        Me.Button5.Image = CType(resources.GetObject("Button5.Image"), System.Drawing.Image)
        Me.Button5.Location = New System.Drawing.Point(146, 212)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(36, 34)
        Me.Button5.TabIndex = 24
        Me.Button5.UseVisualStyleBackColor = True
        '
        'lbSortKriterien
        '
        Me.lbSortKriterien.FormattingEnabled = True
        Me.lbSortKriterien.Location = New System.Drawing.Point(6, 276)
        Me.lbSortKriterien.Name = "lbSortKriterien"
        Me.lbSortKriterien.Size = New System.Drawing.Size(269, 121)
        Me.lbSortKriterien.TabIndex = 23
        '
        'lblSortDirection
        '
        Me.lblSortDirection.AutoSize = True
        Me.lblSortDirection.Location = New System.Drawing.Point(159, 17)
        Me.lblSortDirection.Name = "lblSortDirection"
        Me.lblSortDirection.Size = New System.Drawing.Size(55, 13)
        Me.lblSortDirection.TabIndex = 22
        Me.lblSortDirection.Text = "Sortierung"
        '
        'lblSortFelder
        '
        Me.lblSortFelder.AutoSize = True
        Me.lblSortFelder.Location = New System.Drawing.Point(6, 17)
        Me.lblSortFelder.Name = "lblSortFelder"
        Me.lblSortFelder.Size = New System.Drawing.Size(91, 13)
        Me.lblSortFelder.TabIndex = 21
        Me.lblSortFelder.Text = "Verfügbare Felder"
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Image)
        Me.Button4.Location = New System.Drawing.Point(104, 212)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(36, 34)
        Me.Button4.TabIndex = 20
        Me.Button4.UseVisualStyleBackColor = True
        '
        'lbSort
        '
        Me.lbSort.FormattingEnabled = True
        Me.lbSort.Location = New System.Drawing.Point(6, 33)
        Me.lbSort.Name = "lbSort"
        Me.lbSort.Size = New System.Drawing.Size(138, 173)
        Me.lbSort.TabIndex = 17
        '
        'lbSortDirection
        '
        Me.lbSortDirection.FormattingEnabled = True
        Me.lbSortDirection.Items.AddRange(New Object() {"Absteigend", "Aufsteigend"})
        Me.lbSortDirection.Location = New System.Drawing.Point(162, 33)
        Me.lbSortDirection.Name = "lbSortDirection"
        Me.lbSortDirection.Size = New System.Drawing.Size(116, 173)
        Me.lbSortDirection.TabIndex = 18
        '
        'TabRegister
        '
        Me.TabRegister.Controls.Add(Me.lblRegisterReihenfolge)
        Me.TabRegister.Controls.Add(Me.Button2)
        Me.TabRegister.Controls.Add(Me.lbRegister)
        Me.TabRegister.Controls.Add(Me.Button3)
        Me.TabRegister.Location = New System.Drawing.Point(4, 22)
        Me.TabRegister.Name = "TabRegister"
        Me.TabRegister.Size = New System.Drawing.Size(377, 419)
        Me.TabRegister.TabIndex = 2
        Me.TabRegister.Text = "Register"
        Me.TabRegister.UseVisualStyleBackColor = True
        '
        'lblRegisterReihenfolge
        '
        Me.lblRegisterReihenfolge.AutoSize = True
        Me.lblRegisterReihenfolge.Location = New System.Drawing.Point(13, 14)
        Me.lblRegisterReihenfolge.Name = "lblRegisterReihenfolge"
        Me.lblRegisterReihenfolge.Size = New System.Drawing.Size(101, 13)
        Me.lblRegisterReihenfolge.TabIndex = 20
        Me.lblRegisterReihenfolge.Text = "Verfügbare Register"
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Image)
        Me.Button2.Location = New System.Drawing.Point(160, 83)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(36, 34)
        Me.Button2.TabIndex = 19
        Me.Button2.UseVisualStyleBackColor = True
        '
        'lbRegister
        '
        Me.lbRegister.FormattingEnabled = True
        Me.lbRegister.Location = New System.Drawing.Point(16, 30)
        Me.lbRegister.Name = "lbRegister"
        Me.lbRegister.Size = New System.Drawing.Size(138, 121)
        Me.lbRegister.TabIndex = 17
        '
        'Button3
        '
        Me.Button3.Image = CType(resources.GetObject("Button3.Image"), System.Drawing.Image)
        Me.Button3.Location = New System.Drawing.Point(160, 43)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(36, 34)
        Me.Button3.TabIndex = 18
        Me.Button3.UseVisualStyleBackColor = True
        '
        'cboxAlleElemente
        '
        Me.cboxAlleElemente.AutoSize = True
        Me.cboxAlleElemente.Location = New System.Drawing.Point(15, 65)
        Me.cboxAlleElemente.Name = "cboxAlleElemente"
        Me.cboxAlleElemente.Size = New System.Drawing.Size(128, 17)
        Me.cboxAlleElemente.TabIndex = 2
        Me.cboxAlleElemente.Text = "Alle Vertragselemente"
        Me.cboxAlleElemente.UseVisualStyleBackColor = True
        '
        'frmProfilVerwaltung
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(403, 527)
        Me.Controls.Add(Me.TabControlProfil)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmProfilVerwaltung"
        Me.Text = "Profil-Verwaltung"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.TabControlProfil.ResumeLayout(False)
        Me.TabVertragsübersicht.ResumeLayout(False)
        Me.TabControlVertragsuebersicht.ResumeLayout(False)
        Me.TabAllgemein.ResumeLayout(False)
        Me.TabAllgemein.PerformLayout()
        Me.GrpVertragspartner.ResumeLayout(False)
        Me.GrpVertragspartner.PerformLayout()
        Me.grpVertragselemente.ResumeLayout(False)
        Me.grpVertragselemente.PerformLayout()
        Me.grpSpaltensortierung.ResumeLayout(False)
        Me.grpSpaltensortierung.PerformLayout()
        Me.TabSortierung.ResumeLayout(False)
        Me.TabSortierung.PerformLayout()
        Me.TabRegister.ResumeLayout(False)
        Me.TabRegister.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Save_Data -Methode

Profildaten speichern

[Visual Basic]
Private Sub Save_Data()

Hinweise

Nach dem Speichern wird das Layout-File des Grids im Profil gespeichert

Quellcode

[Visual Basic]
    Private Sub Save_Data()
        C1Data.Enabled = False
        Me.profil.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        If Me.rbAktiveVertragspartner.Checked Then
            Me.profil.bV_Aktiv_Vertragspartner = New SqlBoolean(CType(True, Boolean))
        Else
            Me.profil.bV_Aktiv_Vertragspartner = New SqlBoolean(CType(False, Boolean))
        End If
        If Me.rbAktiveVertragselemente.Checked Then Me.profil.sV_Aktiv_Vertragselemente = New SqlString(CType("True", String))
        If Me.rbAlleVertragselemente.Checked Then Me.profil.sV_Aktiv_Vertragselemente = New SqlString(CType("", String))
        If Me.rbInaktiveVertragselemente.Checked Then Me.profil.sV_Aktiv_Vertragselemente = New SqlString(CType("False", String))
        If Me.cboxAlleElemente.Checked Then Me.profil.bV_Struktur_Details = New SqlBoolean(CType(True, Boolean)) Else Me.profil.bV_Struktur_Details = New SqlBoolean(CType(False, Boolean))

        Dim i As Integer = 0
        Dim s As String = ""
        Dim sort As String = ""
        'Sortierung sichern
        For i = 0 To Me.lbSortKriterien.Items.Count - 1
            s = Me.lbSortKriterien.Items(i)
            s = s.Replace(" | Aufsteigend", " asc")
            s = s.Replace(" | Absteigend", " desc")
            If sort <> "" Then sort = sort + ", "
            sort = sort + s
        Next
        Me.profil.sV_Sort = New SqlString(CType(sort, String))

        'Register sichern
        s = ""
        For i = 0 To Me.lbRegister.Items.Count - 1
            s = s + Me.lbRegister.Items(i) & ";"
        Next
        Me.profil.sV_Register = New SqlString(CType(s, String))

        Me.profil.Save_Data()

        'Spalten sichern
        For i = 0 To Me.lbVorhandeneSpalten.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.C1Data.Columns.Count - 1
                    If Me.C1Data.Splits(0).DisplayColumns(xx).Name = Me.lbVorhandeneSpalten.Items(i) Then
                        Me.C1Data.Splits(0).DisplayColumns(xx).Visible = False
                    End If
                Next
                '                Me.DokList.Splits(0).DisplayColumns(F.ListBox1.Items(i)).Visible = False
            Catch
            End Try
        Next
        For i = 0 To Me.lbVerwendeteSpalten.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.C1Data.Columns.Count - 1
                    If Me.C1Data.Splits(0).DisplayColumns(xx).Name = Me.lbVerwendeteSpalten.Items(i) Then
                        Me.C1Data.Splits(0).DisplayColumns(xx).Visible = True
                    End If
                Next
            Catch
            End Try
        Next
        C1Data.Enabled = True
        Me.profil.Save_Data()
        Me.docmgmt.Save_LayoutFile(C1Data, 1, Me.profil.iProfilnr.Value)
        Me.FormdataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.Sortierung -Methode

Bereich Sortierung initialisieren

[Visual Basic]
Private Sub Sortierung()

Quellcode

[Visual Basic]
    Private Sub Sortierung()
        Me.lbSort.Items.Clear()
        Dim i As Integer
        For i = 0 To C1Data.Columns.Count - 1
            Me.lbSort.Items.Add(Me.C1Data.Columns(i).Caption)
        Next

        Try
            Dim sorts() As String
            sorts = Me.profil.sV_Sort.Value.Split(", ")
            For Each s As String In sorts
                s = s.Replace(" asc", " | Aufsteigend")
                s = s.Replace(" desc", " | Absteigend")
                Me.lbSortKriterien.Items.Add(s)
            Next
        Catch ex As Exception
        End Try
        Try
            Me.lbSort.SelectedIndex = 0
            Me.lbSortDirection.SelectedIndex = 0
            Me.lbSortKriterien.SelectedIndex = 0
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.TabControl_Pages -Methode

Bereich Registerlaschen initialisieren

[Visual Basic]
Private Sub TabControl_Pages()

Quellcode

[Visual Basic]
    Private Sub TabControl_Pages()
        Me.lbRegister.Items.Clear()
        For Each page As TabPage In Me.Tabctl.TabPages
            Me.lbRegister.Items.Add(page.Text)
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.btnUnselectColumn_Click -Methode

[Visual Basic]
Private Sub btnUnselectColumn_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnUnselectColumn.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnUnselectColumn_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnUnselectColumn.Click
        Me.lbVorhandeneSpalten_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.frmProfilVerwaltung_Load -Methode

Formular Load

[Visual Basic]
Private Sub frmProfilVerwaltung_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmProfilVerwaltung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_data(Profilnr)
        Grid_Spalten()
        Sortierung()
        TabControl_Pages()
        Me.AddChanges(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.lbVerwendeteSpalten_DoubleClick -Methode

[Visual Basic]
Private Sub lbVerwendeteSpalten_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   lbVerwendeteSpalten.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub lbVerwendeteSpalten_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles lbVerwendeteSpalten.DoubleClick
        Dim i As Integer
        For i = 0 To Me.lbVerwendeteSpalten.SelectedItems.Count - 1
            Me.lbVorhandeneSpalten.Items.Add(Me.lbVerwendeteSpalten.SelectedItems(i))
        Next
        For i = 0 To Me.lbVerwendeteSpalten.SelectedItems.Count - 1
            Me.lbVerwendeteSpalten.Items.Remove(Me.lbVerwendeteSpalten.SelectedItems(0))
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung.lbVorhandeneSpalten_DoubleClick -Methode

[Visual Basic]
Private Sub lbVorhandeneSpalten_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   lbVorhandeneSpalten.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub lbVorhandeneSpalten_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles lbVorhandeneSpalten.DoubleClick
        Dim i As Integer
        For i = 0 To Me.lbVorhandeneSpalten.SelectedItems.Count - 1
            Me.lbVerwendeteSpalten.Items.Add(Me.lbVorhandeneSpalten.SelectedItems(i))
        Next
        For i = 0 To Me.lbVorhandeneSpalten.SelectedItems.Count - 1
            Me.lbVorhandeneSpalten.Items.Remove(Me.lbVorhandeneSpalten.SelectedItems(0))
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmProfilVerwaltung-Felder

frmProfilVerwaltung Übersicht

Felder

private field C1Data

Unterstützt von .NET Compact Framework
private field FormdataChanged

Unterstützt von .NET Compact Framework
private field Profilnr

Unterstützt von .NET Compact Framework
private field Tabctl

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field docmgmt

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field profil

Unterstützt von .NET Compact Framework

frmProfilVerwaltung -Klasse


C1Data -Feld

[Visual Basic]
Private C1Data As C1TrueDBGrid

Quellcode

[Visual Basic]
    Dim C1Data As C1TrueDBGrid

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


FormdataChanged -Feld

[Visual Basic]
Private FormdataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormdataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


Profilnr -Feld

[Visual Basic]
Private Profilnr As Integer

Quellcode

[Visual Basic]
    Dim Profilnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


Tabctl -Feld

[Visual Basic]
Private Tabctl As TabControl

Quellcode

[Visual Basic]
    Dim Tabctl As TabControl

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


docmgmt -Feld

[Visual Basic]
Private docmgmt As MyDocMgmt

Quellcode

[Visual Basic]
    Dim docmgmt As New TKB.VV.Utils.MyDocMgmt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


profil -Feld

[Visual Basic]
Private profil As clsProfile

Quellcode

[Visual Basic]
    Dim profil As New TKB.VV.Utils.clsProfile

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


frmReferenzvertraege -Klasse

For a list of all members of this type, see frmReferenzvertraege-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmReferenzvertraege

[Visual Basic]
Public Class frmReferenzvertraege
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmReferenzvertraege-Member


frmReferenzvertraege-Member

frmReferenzvertraege Übersicht

Öffentliche Konstruktoren

public constructor frmReferenzvertraege -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche1_Click Unterstützt von .NET Compact Framework |
private method btnVertragselementSuche2_Click Unterstützt von .NET Compact Framework |
private method frmReferenzvertraege_Load Unterstützt von .NET Compact Framework |

Felder

private field Aktuelles_Vertragselement_1

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement_2

Unterstützt von .NET Compact Framework
private field Akutelle_Referenz

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Referenzvertragdata

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmReferenzvertraege -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void frmReferenzvertraege();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Integer, Boolean, Optional Boolean)
[C#] public System.Void frmReferenzvertraege(int, int, bool, bool);

frmReferenzvertraege


frmReferenzvertraege-Methoden

frmReferenzvertraege Übersicht

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche1_Click Unterstützt von .NET Compact Framework |
private method btnVertragselementSuche2_Click Unterstützt von .NET Compact Framework |
private method frmReferenzvertraege_Load Unterstützt von .NET Compact Framework |

frmReferenzvertraege -Klasse


frmReferenzvertraege.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Referenzvertragdata.Neuer_Datensatz = True Then Me.Referenzvertragdata.Delete(Me.Referenzvertragdata.iReferenzvertragsnr.Value)
            Globals.MyEventHanlder.Refernzvertrag_Closed()
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Referenznr As Integer _
)

Parameter

Referenznr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Referenznr As Integer)
        Try
            Me.Referenzvertragdata.Get_Vertragselement_Referenz(Referenznr)
            Me.Aktuelles_Vertragselement_1 = Me.Referenzvertragdata.iVertragselementnr_1.Value
            Me.Aktuelles_Vertragselement_2 = Me.Referenzvertragdata.iVertragselementnr_2.Value
            Me.txtVertragselement1.Text = Me.Referenzvertragdata.Vertragselement_Name_1
            Me.txtVertragselement2.Text = Me.Referenzvertragdata.Vertragselement_Name_2
            Me.cboxBeziehungstyp.SelectedValue = Me.Referenzvertragdata.iBeziehungstypNr.Value
            Me.txtErstelltam.Text = Referenzvertragdata.daErstellt_am.ToString
            Me.txtMutiertam.Text = Referenzvertragdata.daMutiert_am.ToString
            Me.txtMutierer.Text = Referenzvertragdata.iMutierer.ToString
            Try
                Me.cbaktiv.Checked = Referenzvertragdata.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            Me.cboxSecurityLevel.SelectedValue = Referenzvertragdata.iSecurityLevelNr.Value

            Me.txtBemerkung.Text = Referenzvertragdata.sBemerkung.ToString
            If Not Anzeige Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
        End Try
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmReferenzvertraege))
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.btnVertragselementSuche1 = New System.Windows.Forms.Button
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtVertragselement1 = New System.Windows.Forms.TextBox
        Me.lblVertragselement1 = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.lblBeziehungsart = New System.Windows.Forms.Label
        Me.cboxBeziehungstyp = New System.Windows.Forms.ComboBox
        Me.btnVertragselementSuche2 = New System.Windows.Forms.Button
        Me.txtVertragselement2 = New System.Windows.Forms.TextBox
        Me.lblVertragselement2 = New System.Windows.Forms.Label
        Me.ToolStrip1.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(634, 25)
        Me.ToolStrip1.TabIndex = 9
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(634, 24)
        Me.MenuStrip1.TabIndex = 10
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'btnVertragselementSuche1
        '
        Me.btnVertragselementSuche1.Image = CType(resources.GetObject("btnVertragselementSuche1.Image"), System.Drawing.Image)
        Me.btnVertragselementSuche1.Location = New System.Drawing.Point(401, 62)
        Me.btnVertragselementSuche1.Name = "btnVertragselementSuche1"
        Me.btnVertragselementSuche1.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragselementSuche1.TabIndex = 165
        Me.btnVertragselementSuche1.Text = "Button1"
        Me.btnVertragselementSuche1.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(532, 157)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 8
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(453, 160)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 164
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(532, 105)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 6
        Me.txtMutierer.TabStop = False
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(532, 82)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.ReadOnly = True
        Me.txtMutiertam.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiertam.TabIndex = 5
        Me.txtMutiertam.TabStop = False
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(532, 58)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.ReadOnly = True
        Me.txtErstelltam.Size = New System.Drawing.Size(79, 20)
        Me.txtErstelltam.TabIndex = 4
        Me.txtErstelltam.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(454, 109)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 162
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(454, 86)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 161
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(455, 61)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 160
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(451, 131)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(94, 20)
        Me.cbaktiv.TabIndex = 7
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtVertragselement1
        '
        Me.txtVertragselement1.Location = New System.Drawing.Point(137, 62)
        Me.txtVertragselement1.Name = "txtVertragselement1"
        Me.txtVertragselement1.ReadOnly = True
        Me.txtVertragselement1.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragselement1.TabIndex = 0
        '
        'lblVertragselement1
        '
        Me.lblVertragselement1.AutoSize = True
        Me.lblVertragselement1.Location = New System.Drawing.Point(6, 65)
        Me.lblVertragselement1.Name = "lblVertragselement1"
        Me.lblVertragselement1.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragselement1.TabIndex = 159
        Me.lblVertragselement1.Text = "Vertragselement"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(137, 117)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(268, 75)
        Me.txtBemerkung.TabIndex = 3
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(6, 120)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 158
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'lblBeziehungsart
        '
        Me.lblBeziehungsart.AutoSize = True
        Me.lblBeziehungsart.Location = New System.Drawing.Point(12, 179)
        Me.lblBeziehungsart.Name = "lblBeziehungsart"
        Me.lblBeziehungsart.Size = New System.Drawing.Size(74, 13)
        Me.lblBeziehungsart.TabIndex = 157
        Me.lblBeziehungsart.Text = "Beziehungsart"
        Me.lblBeziehungsart.Visible = False
        '
        'cboxBeziehungstyp
        '
        Me.cboxBeziehungstyp.FormattingEnabled = True
        Me.cboxBeziehungstyp.Location = New System.Drawing.Point(67, 179)
        Me.cboxBeziehungstyp.Name = "cboxBeziehungstyp"
        Me.cboxBeziehungstyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxBeziehungstyp.TabIndex = 2
        Me.cboxBeziehungstyp.Visible = False
        '
        'btnVertragselementSuche2
        '
        Me.btnVertragselementSuche2.Image = CType(resources.GetObject("btnVertragselementSuche2.Image"), System.Drawing.Image)
        Me.btnVertragselementSuche2.Location = New System.Drawing.Point(401, 86)
        Me.btnVertragselementSuche2.Name = "btnVertragselementSuche2"
        Me.btnVertragselementSuche2.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragselementSuche2.TabIndex = 168
        Me.btnVertragselementSuche2.Text = "Button1"
        Me.btnVertragselementSuche2.UseVisualStyleBackColor = True
        '
        'txtVertragselement2
        '
        Me.txtVertragselement2.Location = New System.Drawing.Point(137, 86)
        Me.txtVertragselement2.Name = "txtVertragselement2"
        Me.txtVertragselement2.ReadOnly = True
        Me.txtVertragselement2.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragselement2.TabIndex = 1
        '
        'lblVertragselement2
        '
        Me.lblVertragselement2.AutoSize = True
        Me.lblVertragselement2.Location = New System.Drawing.Point(6, 89)
        Me.lblVertragselement2.Name = "lblVertragselement2"
        Me.lblVertragselement2.Size = New System.Drawing.Size(106, 13)
        Me.lblVertragselement2.TabIndex = 167
        Me.lblVertragselement2.Text = "Ref. Vertragselement"
        '
        'frmReferenzvertraege
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(634, 204)
        Me.Controls.Add(Me.btnVertragselementSuche2)
        Me.Controls.Add(Me.txtVertragselement2)
        Me.Controls.Add(Me.lblVertragselement2)
        Me.Controls.Add(Me.btnVertragselementSuche1)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiertam)
        Me.Controls.Add(Me.txtErstelltam)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiertam)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.txtVertragselement1)
        Me.Controls.Add(Me.lblVertragselement1)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.lblBeziehungsart)
        Me.Controls.Add(Me.cboxBeziehungstyp)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmReferenzvertraege"
        Me.Text = "Referenzverträge"
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Me.Referenzvertragdata.iReferenzvertragsnr = New SqlInt32(CType(Me.Akutelle_Referenz, Int32))
        Me.Referenzvertragdata.iVertragselementnr_1 = New SqlInt32(CType(Me.Aktuelles_Vertragselement_1, Int32))
        Me.Referenzvertragdata.iVertragselementnr_2 = New SqlInt32(CType(Me.Aktuelles_Vertragselement_2, Int32))
        Me.Referenzvertragdata.iBeziehungstypNr = New SqlInt32(CType(Me.cboxBeziehungstyp.SelectedValue, Int32))

        Me.Referenzvertragdata.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Me.Referenzvertragdata.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Me.Referenzvertragdata.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Referenzvertragdata.Delete_Referenz(Me.Referenzvertragdata.iReferenzvertragsnr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Referenzvertragdata.Add_New(Me.Aktuelles_Vertragselement_1))
        Me.Referenzvertragdata.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiertam.Text = Me.Referenzvertragdata.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.btnVertragselementSuche1_Click -Methode

[Visual Basic]
Private Sub btnVertragselementSuche1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragselementSuche1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragselementSuche1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragselementSuche1.Click
        If Me.Referenzvertragdata.Vertragselement_Suchen(Me.Aktuelles_Vertragselement_1, Me.txtVertragselement1.Text) Then

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.btnVertragselementSuche2_Click -Methode

[Visual Basic]
Private Sub btnVertragselementSuche2_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragselementSuche2.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragselementSuche2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragselementSuche2.Click
        If Me.Referenzvertragdata.Vertragselement_Suchen(Me.Aktuelles_Vertragselement_2, Me.txtVertragselement2.Text) Then

        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmReferenzvertraege


frmReferenzvertraege.frmReferenzvertraege_Load -Methode

[Visual Basic]
Private Sub frmReferenzvertraege_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmReferenzvertraege_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Anzeige = True Then
            Me.TSBtnSave.Enabled = False
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Beziehungstypen
        Me.cboxBeziehungstyp.DataSource = Me.Referenzvertragdata.Beziehungstypen.Tabledata.Tables(0)
        Me.cboxBeziehungstyp.DisplayMember = "Bezeichnung"
        Me.cboxBeziehungstyp.ValueMember = "BeziehungstypNr"
        AddChanges(Me)
        Get_Data(Me.Akutelle_Referenz)
        If Me.Neuer_Datensatz = True Then
            Me.Referenzvertragdata.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege-Felder

frmReferenzvertraege Übersicht

Felder

private field Aktuelles_Vertragselement_1

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement_2

Unterstützt von .NET Compact Framework
private field Akutelle_Referenz

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Referenzvertragdata

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmReferenzvertraege -Klasse


Aktuelles_Vertragselement_1 -Feld

[Visual Basic]
Private Aktuelles_Vertragselement_1 As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragselement_1 As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


Aktuelles_Vertragselement_2 -Feld

[Visual Basic]
Private Aktuelles_Vertragselement_2 As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragselement_2 As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


Akutelle_Referenz -Feld

[Visual Basic]
Private Akutelle_Referenz As Integer

Quellcode

[Visual Basic]
    Private Akutelle_Referenz As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


Referenzvertragdata -Feld

[Visual Basic]
Private Referenzvertragdata As clsReferenzvertrag

Quellcode

[Visual Basic]
    Dim Referenzvertragdata As New TKB.VV.Vertrag.clsReferenzvertrag

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmSLAKatalog -Klasse

SLAKatalog-Verwaltung

For a list of all members of this type, see frmSLAKatalog-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSLAKatalog

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmSLAKatalog
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmSLAKatalog-Member


frmSLAKatalog-Member

frmSLAKatalog Übersicht

Öffentliche Konstruktoren

public constructor frmSLAKatalog -Konstructor

Unterstützt von .NET Compact Framework

 Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

Felder

private field Domaintable

Unterstützt von .NET Compact Framework
private field SLA

Unterstützt von .NET Compact Framework
private field SLADaten

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Zeiteinheittyp

Unterstützt von .NET Compact Framework
private field Zeiteinheittypdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

frmSLAKatalog -Klasse


frmSLAKatalog -Konstructor

Tabellenname übernehmen und Objekt DomainTable initialisieren Initialisierung der Komponenten

[Visual Basic]
Public Sub New()

Hinweise

Benötigt werden entsprechende Stored_Procedures, welche mit LBLLGEN_2 generiert wurden pr_"Tablename"_SelectAll pr_"Tablename"_Update

Quellcode

[Visual Basic]
    Public Sub New()
        Dim tblname As String = "SLAKatalog"
        Domaintable = New TKB.VV.SLA.clsSLAKatalogdaten(tblname)
        Me.InitializeComponent()
        Me.tablename = tblname
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog-Methoden

frmSLAKatalog Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method C1Daten_AfterColUpdate Unterstützt von .NET Compact Framework | Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.
private method C1Daten_AfterInsert Unterstützt von .NET Compact Framework | Aktualisierung der Default-Werte
private method C1Daten_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Ruft BeendetnToolStipMenuItem_Click auf
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sichern der Daten
private method frmDomainEditor_FormClosing Unterstützt von .NET Compact Framework | Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.
private method frmDomainEditor_Load Unterstützt von .NET Compact Framework | Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

frmSLAKatalog -Klasse


frmSLAKatalog.BeendenToolStripMenuItem_Click -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.C1Daten_AfterColUpdate -Methode

Aktualisierung der Spalten mutiert_am und mutierern. Sofern noch kein Schlüsselwert gesetzt ist (bei neuem Datensatz) wird dieser aus der Keytabelle ausgelesen und zugewiesen.

[Visual Basic]
Private Sub C1Daten_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1Daten.AfterColUpdate

Parameter

sender
e

Hinweise

Je Domaintable ist ein Eintrag in der Key-Tabelle notwendig

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1Daten.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then Me.C1Daten.Columns(i).Value = Now
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.C1Daten.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(tablename)
                Me.C1Daten.Columns(0).Value = key
                For i = 0 To Me.C1Daten.Columns.Count - 1
                    If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                        Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "erstellt_am" Then
                        Me.C1Daten.Columns(i).Value = Now
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "securitylevel" Then
                        Me.C1Daten.Columns(i).Value = 0
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                        Me.C1Daten.Columns(i).Value = 1
                    End If
                    If LCase(Me.C1Daten.Columns(i).DataField) = "extern" Then
                        Me.C1Daten.Columns(i).Value = 0
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.C1Daten_AfterInsert -Methode

Aktualisierung der Default-Werte

[Visual Basic]
Private Sub C1Daten_AfterInsert( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Daten.AfterInsert

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_AfterInsert(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Daten.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To C1Daten.Columns.Count - 1
                If LCase(Me.C1Daten.Columns(i).DataField) = "aktiv" Then
                    Me.C1Daten.Columns(i).Value = 1
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutiert_am" Then
                    Me.C1Daten.Columns(i).Value = Now
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mutierer" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandantnr" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
                If LCase(Me.C1Daten.Columns(i).DataField) = "mandnat" Then
                    Me.C1Daten.Columns(i).Value = Globals.clsmitarbeiter.iMandantnr.Value
                End If
            Next
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.C1Daten_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1Daten_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1Daten.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Daten_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1Daten.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = Me.tablename
        Try
            ts.Feld = Me.C1Daten.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSLAKatalog))
        Dim Style17 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style18 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style19 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style20 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style21 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style22 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style23 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style24 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style25 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style26 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style27 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style28 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style29 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style30 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style31 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Dim Style32 As C1.Win.C1TrueDBGrid.Style = New C1.Win.C1TrueDBGrid.Style
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.C1DropDownSLA = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.C1DropdownZeitheinheittyp = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown
        Me.C1Daten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        CType(Me.C1DropDownSLA, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1DropdownZeitheinheittyp, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(780, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(780, 25)
        Me.ToolStrip1.TabIndex = 4
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'C1DropDownSLA
        '
        Me.C1DropDownSLA.AllowColMove = True
        Me.C1DropDownSLA.AllowColSelect = True
        Me.C1DropDownSLA.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1DropDownSLA.AlternatingRows = False
        Me.C1DropDownSLA.CaptionStyle = Style17
        Me.C1DropDownSLA.ColumnCaptionHeight = 17
        Me.C1DropDownSLA.ColumnFooterHeight = 17
        Me.C1DropDownSLA.EvenRowStyle = Style18
        Me.C1DropDownSLA.FetchRowStyles = False
        Me.C1DropDownSLA.FooterStyle = Style19
        Me.C1DropDownSLA.HeadingStyle = Style20
        Me.C1DropDownSLA.HighLightRowStyle = Style21
        Me.C1DropDownSLA.Images.Add(CType(resources.GetObject("C1DropDownSLA.Images"), System.Drawing.Image))
        Me.C1DropDownSLA.Location = New System.Drawing.Point(226, 165)
        Me.C1DropDownSLA.Name = "C1DropDownSLA"
        Me.C1DropDownSLA.OddRowStyle = Style22
        Me.C1DropDownSLA.RecordSelectorStyle = Style23
        Me.C1DropDownSLA.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1DropDownSLA.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1DropDownSLA.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1DropDownSLA.ScrollTips = False
        Me.C1DropDownSLA.Size = New System.Drawing.Size(231, 150)
        Me.C1DropDownSLA.Style = Style24
        Me.C1DropDownSLA.TabIndex = 6
        Me.C1DropDownSLA.Text = "C1TrueDBDropdown1"
        Me.C1DropDownSLA.Visible = False
        Me.C1DropDownSLA.PropBag = resources.GetString("C1DropDownSLA.PropBag")
        '
        'C1DropdownZeitheinheittyp
        '
        Me.C1DropdownZeitheinheittyp.AllowColMove = True
        Me.C1DropdownZeitheinheittyp.AllowColSelect = True
        Me.C1DropdownZeitheinheittyp.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1DropdownZeitheinheittyp.AlternatingRows = False
        Me.C1DropdownZeitheinheittyp.CaptionStyle = Style25
        Me.C1DropdownZeitheinheittyp.ColumnCaptionHeight = 17
        Me.C1DropdownZeitheinheittyp.ColumnFooterHeight = 17
        Me.C1DropdownZeitheinheittyp.EvenRowStyle = Style26
        Me.C1DropdownZeitheinheittyp.FetchRowStyles = False
        Me.C1DropdownZeitheinheittyp.FooterStyle = Style27
        Me.C1DropdownZeitheinheittyp.HeadingStyle = Style28
        Me.C1DropdownZeitheinheittyp.HighLightRowStyle = Style29
        Me.C1DropdownZeitheinheittyp.Images.Add(CType(resources.GetObject("C1DropdownZeitheinheittyp.Images"), System.Drawing.Image))
        Me.C1DropdownZeitheinheittyp.Location = New System.Drawing.Point(258, 165)
        Me.C1DropdownZeitheinheittyp.Name = "C1DropdownZeitheinheittyp"
        Me.C1DropdownZeitheinheittyp.OddRowStyle = Style30
        Me.C1DropdownZeitheinheittyp.RecordSelectorStyle = Style31
        Me.C1DropdownZeitheinheittyp.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.C1DropdownZeitheinheittyp.RowDivider.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.[Single]
        Me.C1DropdownZeitheinheittyp.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1DropdownZeitheinheittyp.ScrollTips = False
        Me.C1DropdownZeitheinheittyp.Size = New System.Drawing.Size(235, 150)
        Me.C1DropdownZeitheinheittyp.Style = Style32
        Me.C1DropdownZeitheinheittyp.TabIndex = 7
        Me.C1DropdownZeitheinheittyp.Text = "C1TrueDBDropdown1"
        Me.C1DropdownZeitheinheittyp.Visible = False
        Me.C1DropdownZeitheinheittyp.PropBag = resources.GetString("C1DropdownZeitheinheittyp.PropBag")
        '
        'C1Daten
        '
        Me.C1Daten.AllowAddNew = True
        Me.C1Daten.AlternatingRows = True
        Me.C1Daten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Daten.FetchRowStyles = True
        Me.C1Daten.FilterBar = True
        Me.C1Daten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Daten.Images.Add(CType(resources.GetObject("C1Daten.Images"), System.Drawing.Image))
        Me.C1Daten.Location = New System.Drawing.Point(0, 49)
        Me.C1Daten.Name = "C1Daten"
        Me.C1Daten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Daten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Daten.PreviewInfo.ZoomFactor = 75
        Me.C1Daten.PrintInfo.PageSettings = CType(resources.GetObject("C1Daten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Daten.Size = New System.Drawing.Size(780, 297)
        Me.C1Daten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Daten.TabIndex = 11
        Me.C1Daten.Text = "C1TrueDBGrid1"
        Me.C1Daten.PropBag = resources.GetString("C1Daten.PropBag")
        '
        'frmSLAKatalog
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(780, 346)
        Me.Controls.Add(Me.C1Daten)
        Me.Controls.Add(Me.C1DropdownZeitheinheittyp)
        Me.Controls.Add(Me.C1DropDownSLA)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSLAKatalog"
        Me.Text = "SLAKatalog"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        CType(Me.C1DropDownSLA, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1DropdownZeitheinheittyp, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1Daten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.TSBtnQuit_Click -Methode

Ruft BeendetnToolStipMenuItem_Click auf

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        BeendenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.TSBtnSave_Click -Methode

Sichern der Daten

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Try
            Domaintable.Save_Data()

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.frmDomainEditor_FormClosing -Methode

Prüfung auf allfällige Daten-Changes. Wurden Daten verändert, kann der User entscheiden, ob gespeichert, nichtgespeichert oder das Formular nicht gespeichert werden soll.

[Visual Basic]
Private Sub frmDomainEditor_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.Domaintable.Tabledata.HasChanges Then
            Dim msg As New TKB.VV.Utils.MyMessage
            Dim msgboxres As MsgBoxResult
            msgboxres = msg.Show_MessageYesNoCancel(3)
            If msgboxres = MsgBoxResult.Cancel Then
                e.Cancel = True
                Exit Sub
            End If
            If msgboxres = MsgBoxResult.Yes Then
                Domaintable.Save_Data()
            End If
        End If
        Domaintable.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog.frmDomainEditor_Load -Methode

Zuordnung der Daten aus Domaintable und Spaltentitel des Grids setzen

[Visual Basic]
Private Sub frmDomainEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1Daten.DataSource = Domaintable.Tabledata
        Me.C1Daten.DataMember = Domaintable.Tabledata.Tables(0).TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Daten, "SLAKatalog", Me.SLADaten)

        Me.Zeiteinheittypdata.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        Me.Zeiteinheittyp = Me.Zeiteinheittypdata.SelectAll_aktive
        Globals.conn.CloseConnection(True)

        Me.SLA.cpMainConnectionProvider = Globals.conn
        Me.SLADaten = SLA.SelectAll_Active

        Me.C1DropDownSLA.DataSource = Me.SLADaten
        Me.C1DropDownSLA.ValueMember = "SLANr"
        Me.C1DropDownSLA.DisplayMember = "Sla"

        Me.C1DropdownZeitheinheittyp.DataSource = Me.Zeiteinheittyp
        Me.C1DropdownZeitheinheittyp.ValueMember = "Zeiteinheittypnr"
        Me.C1DropdownZeitheinheittyp.DisplayMember = "Bezeichnung"

        Me.C1Daten.Columns("SLANr").DropDown = Me.C1DropDownSLA
        Me.C1Daten.Columns("Zeiteinheittypnr").DropDown = Me.C1DropdownZeitheinheittyp

        Me.C1Daten.Columns("SLANr").ValueItems.Translate = True
        Me.C1Daten.Columns("Zeiteinheittypnr").ValueItems.Translate = True

        Me.C1DropDownSLA.ValueTranslate = True
        Me.C1DropdownZeitheinheittyp.ValueTranslate = True

        Me.C1DropDownSLA.DisplayColumns(0).Width = 0
        Me.C1DropDownSLA.DisplayColumns(1).Width = Me.C1DropDownSLA.Width
        Me.C1DropdownZeitheinheittyp.DisplayColumns(0).Width = 0
        Me.C1DropdownZeitheinheittyp.DisplayColumns(1).Width = Me.C1DropdownZeitheinheittyp.Width

        sec.Set_Form_Security(Me)
        If Me.TSBtnSave.Visible = False Or Me.TSBtnSave.Enabled = False Then
            Me.C1Daten.AllowAddNew = False
            Me.C1Daten.AllowUpdate = False
        End If
        Dim i As Integer
        For i = 0 To Me.C1Daten.Splits(0).DisplayColumns.Count - 1
            If Me.C1Daten.Columns(i).DataField = "SLANr" Then
                Me.C1Daten.Splits(0).DisplayColumns(i).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Near
            End If
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmSLAKatalog-Felder

frmSLAKatalog Übersicht

Felder

private field Domaintable

Unterstützt von .NET Compact Framework
private field SLA

Unterstützt von .NET Compact Framework
private field SLADaten

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Zeiteinheittyp

Unterstützt von .NET Compact Framework
private field Zeiteinheittypdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
private field tablename

Unterstützt von .NET Compact Framework

frmSLAKatalog -Klasse


Domaintable -Feld

[Visual Basic]
Private Domaintable As clsSLAKatalogdaten

Quellcode

[Visual Basic]
    Dim Domaintable As TKB.VV.SLA.clsSLAKatalogdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


SLA -Feld

[Visual Basic]
Private SLA As clsSLA

Quellcode

[Visual Basic]
    Dim SLA As New TKB.VV.SLA.clsSLA

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


SLADaten -Feld

[Visual Basic]
Private SLADaten As DataTable

Quellcode

[Visual Basic]
    Dim SLADaten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


Zeiteinheittyp -Feld

[Visual Basic]
Private Zeiteinheittyp As DataTable

Quellcode

[Visual Basic]
    Dim Zeiteinheittyp As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


Zeiteinheittypdata -Feld

[Visual Basic]
Private Zeiteinheittypdata As myZeiteinheittyp

Quellcode

[Visual Basic]
    Dim Zeiteinheittypdata As New TKB.VV.DB.myZeiteinheittyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


tablename -Feld

[Visual Basic]
Private tablename As String

Quellcode

[Visual Basic]
    Dim tablename As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSLAKatalog


frmServicekatalog -Klasse

Servicekatalog-Verwaltung

For a list of all members of this type, see frmServicekatalog-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmServicekatalog

[Visual Basic]
Public Class frmServicekatalog
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmServicekatalog-Member | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogDaten | TKB.VV.SLA.clsServiceKatalogSLATree | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


frmServicekatalog-Member

frmServicekatalog Übersicht

Öffentliche Konstruktoren

public constructor frmServicekatalog -Konstructor

Unterstützt von .NET Compact Framework

 Constructor New

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BtnAddSLA_Click Unterstützt von .NET Compact Framework |
private method C1Vertragsbeziehungen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method Delete_all_Childs Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method LeistungÜbernehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menueintrag im ctxMenuTreeServicekatalog für die Übernahme der Leistung
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeueLeistungToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NeuerKatalogToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Details Unterstützt von .NET Compact Framework | Registerlaschen in TabCtrlDetails aktualisieren
private method Refresh_SLATable Unterstützt von .NET Compact Framework |
private method Refresh_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Services aktualiseren
private method Show_Data Unterstützt von .NET Compact Framework |
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Service erfassen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save Button
private method TSBtnSelect_Click Unterstützt von .NET Compact Framework | Gewählter Servicekatalog übergeben
private method TreeSLA_DoubleClick Unterstützt von .NET Compact Framework |
private method cbselaktiv_CheckedChanged Unterstützt von .NET Compact Framework |
private method check_changes Unterstützt von .NET Compact Framework | Prüfung, ob Verbindungstabelle geändert wurde.
private method frmServicekatalog_FormClosing Unterstützt von .NET Compact Framework | Schliessen des Formulares
private method frmServicekatalog_Load Unterstützt von .NET Compact Framework | Formular aufbauen
private method save_katalogdata Unterstützt von .NET Compact Framework |
private method tabctrlDetails_SelectedIndexChanged Unterstützt von .NET Compact Framework | Register-Wechsel im TabControl
private method treeServiceKatalog_AfterSelect Unterstützt von .NET Compact Framework |
private method treeServiceKatalog_MouseDown Unterstützt von .NET Compact Framework |
private method txtBezeichnung_intern_TextChanged Unterstützt von .NET Compact Framework |

Felder

private field ForSelect

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SLATreeviewdata

Unterstützt von .NET Compact Framework
private field ServiceKatalogSLAKatalog

Unterstützt von .NET Compact Framework
private field ServiceKatalognr

Unterstützt von .NET Compact Framework
private field Servicekatalogdaten

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Treeviewdata

Unterstützt von .NET Compact Framework
private field Vertragsleistungsnr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

Siehe auch

frmServicekatalog -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogDaten | TKB.VV.SLA.clsServiceKatalogSLATree | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


frmServicekatalog -Konstructor

Constructor New

[Visual Basic]
Public Sub New( _
   Optional ByVal Servicekatalognr As Integer = -1, _
   Optional ByVal FormReadonly As Boolean = False, _
   Optional ByVal SelectLeistung As Boolean = False, _
   Optional ByVal Vertragsleistungsnr As Integer = 0, _
   Optional ByRef CreateNew As Boolean =  _
)

Parameter

Servicekatalognr
Optional ServicekatalogNr = -1
FormReadonly
Optional Readonly = false
SelectLeistung
Optional SelectLeistung = falöse
Vertragsleistungsnr
Optional Vertragsleistungsnr = 0
CreateNew
Optional.

Hinweise

Die otionalen Paramter Servicekatalognr, SelectLeistung und Vertragsleistungsnummer werden benötigt, um entweder ein Leistungselement aus dem Vertragselement anzuzeigen bzw. ein Leistungselement auszuwählen

Quellcode

[Visual Basic]
    Sub New(Optional ByVal Servicekatalognr As Integer = -1, Optional ByVal FormReadonly As Boolean = False, Optional ByVal SelectLeistung As Boolean = False, Optional ByVal Vertragsleistungsnr As Integer = 0, Optional CreateNew as Boolean=False)
        InitializeComponent()
        Me.ServiceKatalognr = Servicekatalognr
        Me.Vertragsleistungsnr = Vertragsleistungsnr
        Me.FormReadonly = FormReadonly
        If CreateNew Then
            Me.Neuer_Datensatz = True
        End If
        Me.ForSelect = SelectLeistung
        If Me.ForSelect = True Then Me.FormReadonly = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog-Methoden

frmServicekatalog Übersicht

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method BtnAddSLA_Click Unterstützt von .NET Compact Framework |
private method C1Vertragsbeziehungen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method Delete_all_Childs Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method LeistungÜbernehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Context-Menueintrag im ctxMenuTreeServicekatalog für die Übernahme der Leistung
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeueLeistungToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method NeuerKatalogToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method Refresh_Details Unterstützt von .NET Compact Framework | Registerlaschen in TabCtrlDetails aktualisieren
private method Refresh_SLATable Unterstützt von .NET Compact Framework |
private method Refresh_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Services aktualiseren
private method Show_Data Unterstützt von .NET Compact Framework |
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Service erfassen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen-Button
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Save Button
private method TSBtnSelect_Click Unterstützt von .NET Compact Framework | Gewählter Servicekatalog übergeben
private method TreeSLA_DoubleClick Unterstützt von .NET Compact Framework |
private method cbselaktiv_CheckedChanged Unterstützt von .NET Compact Framework |
private method check_changes Unterstützt von .NET Compact Framework | Prüfung, ob Verbindungstabelle geändert wurde.
private method frmServicekatalog_FormClosing Unterstützt von .NET Compact Framework | Schliessen des Formulares
private method frmServicekatalog_Load Unterstützt von .NET Compact Framework | Formular aufbauen
private method save_katalogdata Unterstützt von .NET Compact Framework |
private method tabctrlDetails_SelectedIndexChanged Unterstützt von .NET Compact Framework | Register-Wechsel im TabControl
private method treeServiceKatalog_AfterSelect Unterstützt von .NET Compact Framework |
private method treeServiceKatalog_MouseDown Unterstützt von .NET Compact Framework |
private method txtBezeichnung_intern_TextChanged Unterstützt von .NET Compact Framework |

Siehe auch

frmServicekatalog -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogDaten | TKB.VV.SLA.clsServiceKatalogSLATree | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


frmServicekatalog.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.BtnAddSLA_Click -Methode

[Visual Basic]
Private Sub BtnAddSLA_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnAddSLA.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnAddSLA_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnAddSLA.Click
        TreeSLA_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.C1Vertragsbeziehungen_FetchRowStyle -Methode

[Visual Basic]
Private Sub C1Vertragsbeziehungen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Vertragsbeziehungen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragsbeziehungen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Vertragsbeziehungen.FetchRowStyle
        Try
            If Me.C1Vertragsbeziehungen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.C1Vertragselemente_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Vertragselemente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1DatenSLA.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1DatenSLA.FetchRowStyle
        Try
            If Me.C1DatenSLA.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Delete_all_Childs -Methode

[Visual Basic]
Private Sub Delete_all_Childs( _
   ByVal nodes As TreeNodeCollection _
)

Parameter

nodes

Quellcode

[Visual Basic]
    Private Sub Delete_all_Childs(ByVal nodes As TreeNodeCollection)
        For Each tn As TreeNode In nodes
            Me.Servicekatalogdaten.Delete_Servicekatalog(tn.Tag)
            tn.NodeFont = Me.Treeviewdata.fnt_Strikeout
            Delete_all_Childs(tn.Nodes)
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.FindNode -Methode

Suchen eines Knoten Treeview

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
Nodes des TreeView
SearchVal
Tag.Keyvalue
SearchString
Node.Text als Suchbegriff

Quellcode

[Visual Basic]
    Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
        Dim tmpNode As TreeNode
        For Each _child As TreeNode In _nodeCollection
            If _child.Tag = SearchVal Then Return _child
            tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
            If Not tmpNode Is Nothing Then
                Return tmpNode
            End If
        Next
        Return Nothing
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmServicekatalog))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSelect = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.pnlServicekatalog = New System.Windows.Forms.Panel
        Me.treeServiceKatalog = New System.Windows.Forms.TreeView
        Me.ctxMenuTreeServiceKatalog = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.NeuerKatalogToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeueLeistungToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuSplitter = New System.Windows.Forms.ToolStripSeparator
        Me.LeistungÜbernehmenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImgListTreeServiceKatalog = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlServicekataloglabel = New System.Windows.Forms.Panel
        Me.cbselaktiv = New System.Windows.Forms.CheckBox
        Me.lblServiceKatalog = New System.Windows.Forms.Label
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.txtmutiert_am = New System.Windows.Forms.TextBox
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.txterstellt_am = New System.Windows.Forms.TextBox
        Me.lblErstellt_am = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.cbextern = New System.Windows.Forms.CheckBox
        Me.lblextern = New System.Windows.Forms.Label
        Me.txtBezeichnung_extern = New System.Windows.Forms.TextBox
        Me.txtBezeichnung_intern = New System.Windows.Forms.TextBox
        Me.lblBezeichnungExtern = New System.Windows.Forms.Label
        Me.lblBezeichnung_intern = New System.Windows.Forms.Label
        Me.tabctrlDetails = New System.Windows.Forms.TabControl
        Me.TabSLA = New System.Windows.Forms.TabPage
        Me.C1DatenSLA = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.BtnAddSLA = New System.Windows.Forms.Button
        Me.TreeSLA = New System.Windows.Forms.TreeView
        Me.TabVertragsbeziehungen = New System.Windows.Forms.TabPage
        Me.C1Vertragsbeziehungen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.pnlServicekatalog.SuspendLayout()
        Me.ctxMenuTreeServiceKatalog.SuspendLayout()
        Me.pnlServicekataloglabel.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.tabctrlDetails.SuspendLayout()
        Me.TabSLA.SuspendLayout()
        CType(Me.C1DatenSLA, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.TabVertragsbeziehungen.SuspendLayout()
        CType(Me.C1Vertragsbeziehungen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(876, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnSelect, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(876, 25)
        Me.ToolStrip1.TabIndex = 5
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnSelect
        '
        Me.TSBtnSelect.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSelect.Image = CType(resources.GetObject("TSBtnSelect.Image"), System.Drawing.Image)
        Me.TSBtnSelect.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSelect.Name = "TSBtnSelect"
        Me.TSBtnSelect.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSelect.Text = "Leistung übernehmen"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        Me.TSBtnCopy.Visible = False
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        Me.TSBtnNew.Visible = False
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'pnlServicekatalog
        '
        Me.pnlServicekatalog.Controls.Add(Me.treeServiceKatalog)
        Me.pnlServicekatalog.Controls.Add(Me.pnlServicekataloglabel)
        Me.pnlServicekatalog.Dock = System.Windows.Forms.DockStyle.Left
        Me.pnlServicekatalog.Location = New System.Drawing.Point(0, 49)
        Me.pnlServicekatalog.Name = "pnlServicekatalog"
        Me.pnlServicekatalog.Size = New System.Drawing.Size(196, 515)
        Me.pnlServicekatalog.TabIndex = 6
        '
        'treeServiceKatalog
        '
        Me.treeServiceKatalog.ContextMenuStrip = Me.ctxMenuTreeServiceKatalog
        Me.treeServiceKatalog.Dock = System.Windows.Forms.DockStyle.Fill
        Me.treeServiceKatalog.FullRowSelect = True
        Me.treeServiceKatalog.HideSelection = False
        Me.treeServiceKatalog.HotTracking = True
        Me.treeServiceKatalog.ImageIndex = 0
        Me.treeServiceKatalog.ImageList = Me.ImgListTreeServiceKatalog
        Me.treeServiceKatalog.Location = New System.Drawing.Point(0, 29)
        Me.treeServiceKatalog.Name = "treeServiceKatalog"
        Me.treeServiceKatalog.SelectedImageIndex = 0
        Me.treeServiceKatalog.Size = New System.Drawing.Size(196, 486)
        Me.treeServiceKatalog.TabIndex = 1
        '
        'ctxMenuTreeServiceKatalog
        '
        Me.ctxMenuTreeServiceKatalog.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.NeuerKatalogToolStripMenuItem, Me.NeueLeistungToolStripMenuItem, Me.MenuSplitter, Me.LeistungÜbernehmenToolStripMenuItem})
        Me.ctxMenuTreeServiceKatalog.Name = "ctxMenuTreeServiceKatalog"
        Me.ctxMenuTreeServiceKatalog.Size = New System.Drawing.Size(177, 76)
        '
        'NeuerKatalogToolStripMenuItem
        '
        Me.NeuerKatalogToolStripMenuItem.Name = "NeuerKatalogToolStripMenuItem"
        Me.NeuerKatalogToolStripMenuItem.Size = New System.Drawing.Size(176, 22)
        Me.NeuerKatalogToolStripMenuItem.Text = "Neuer &Katalog"
        '
        'NeueLeistungToolStripMenuItem
        '
        Me.NeueLeistungToolStripMenuItem.Name = "NeueLeistungToolStripMenuItem"
        Me.NeueLeistungToolStripMenuItem.Size = New System.Drawing.Size(176, 22)
        Me.NeueLeistungToolStripMenuItem.Text = "Neue &Leistung"
        '
        'MenuSplitter
        '
        Me.MenuSplitter.Name = "MenuSplitter"
        Me.MenuSplitter.Size = New System.Drawing.Size(173, 6)
        '
        'LeistungÜbernehmenToolStripMenuItem
        '
        Me.LeistungÜbernehmenToolStripMenuItem.Name = "LeistungÜbernehmenToolStripMenuItem"
        Me.LeistungÜbernehmenToolStripMenuItem.Size = New System.Drawing.Size(176, 22)
        Me.LeistungÜbernehmenToolStripMenuItem.Text = "Leistung übernehmen"
        '
        'ImgListTreeServiceKatalog
        '
        Me.ImgListTreeServiceKatalog.ImageStream = CType(resources.GetObject("ImgListTreeServiceKatalog.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListTreeServiceKatalog.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(0, "Green Book.ico")
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(1, "paper1.png")
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(2, "BOOK10.GIF")
        Me.ImgListTreeServiceKatalog.Images.SetKeyName(3, "BOOKS10.GIF")
        '
        'pnlServicekataloglabel
        '
        Me.pnlServicekataloglabel.Controls.Add(Me.cbselaktiv)
        Me.pnlServicekataloglabel.Controls.Add(Me.lblServiceKatalog)
        Me.pnlServicekataloglabel.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlServicekataloglabel.Location = New System.Drawing.Point(0, 0)
        Me.pnlServicekataloglabel.Name = "pnlServicekataloglabel"
        Me.pnlServicekataloglabel.Size = New System.Drawing.Size(196, 29)
        Me.pnlServicekataloglabel.TabIndex = 2
        '
        'cbselaktiv
        '
        Me.cbselaktiv.AutoSize = True
        Me.cbselaktiv.Checked = True
        Me.cbselaktiv.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cbselaktiv.Location = New System.Drawing.Point(107, 8)
        Me.cbselaktiv.Name = "cbselaktiv"
        Me.cbselaktiv.Size = New System.Drawing.Size(83, 17)
        Me.cbselaktiv.TabIndex = 1
        Me.cbselaktiv.Text = "Aktive Eintr."
        Me.cbselaktiv.ThreeState = True
        Me.cbselaktiv.UseVisualStyleBackColor = True
        '
        'lblServiceKatalog
        '
        Me.lblServiceKatalog.AutoSize = True
        Me.lblServiceKatalog.Location = New System.Drawing.Point(3, 9)
        Me.lblServiceKatalog.Name = "lblServiceKatalog"
        Me.lblServiceKatalog.Size = New System.Drawing.Size(78, 13)
        Me.lblServiceKatalog.TabIndex = 0
        Me.lblServiceKatalog.Text = "Servicekatalog"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(196, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        Me.SplitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.cbaktiv)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtMutierer)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblMutierer)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtmutiert_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblMutiert_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txterstellt_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblErstellt_am)
        Me.SplitContainer1.Panel1.Controls.Add(Me.cboxSecurityLevel)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblSecurityLebel)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBemerkung)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBemerkung)
        Me.SplitContainer1.Panel1.Controls.Add(Me.cbextern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblextern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBezeichnung_extern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.txtBezeichnung_intern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBezeichnungExtern)
        Me.SplitContainer1.Panel1.Controls.Add(Me.lblBezeichnung_intern)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.tabctrlDetails)
        Me.SplitContainer1.Size = New System.Drawing.Size(680, 515)
        Me.SplitContainer1.SplitterDistance = 237
        Me.SplitContainer1.TabIndex = 7
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(435, 91)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(96, 17)
        Me.cbaktiv.TabIndex = 5
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtMutierer
        '
        Me.txtMutierer.Location = New System.Drawing.Point(517, 60)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(132, 20)
        Me.txtMutierer.TabIndex = 15
        '
        'lblMutierer
        '
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(436, 64)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 14
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'txtmutiert_am
        '
        Me.txtmutiert_am.Location = New System.Drawing.Point(517, 34)
        Me.txtmutiert_am.Name = "txtmutiert_am"
        Me.txtmutiert_am.ReadOnly = True
        Me.txtmutiert_am.Size = New System.Drawing.Size(132, 20)
        Me.txtmutiert_am.TabIndex = 13
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(436, 37)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(55, 13)
        Me.lblMutiert_am.TabIndex = 12
        Me.lblMutiert_am.Text = "Erstellt am"
        '
        'txterstellt_am
        '
        Me.txterstellt_am.Location = New System.Drawing.Point(517, 9)
        Me.txterstellt_am.Name = "txterstellt_am"
        Me.txterstellt_am.ReadOnly = True
        Me.txterstellt_am.Size = New System.Drawing.Size(132, 20)
        Me.txterstellt_am.TabIndex = 11
        '
        'lblErstellt_am
        '
        Me.lblErstellt_am.AutoSize = True
        Me.lblErstellt_am.Location = New System.Drawing.Point(436, 12)
        Me.lblErstellt_am.Name = "lblErstellt_am"
        Me.lblErstellt_am.Size = New System.Drawing.Size(55, 13)
        Me.lblErstellt_am.TabIndex = 10
        Me.lblErstellt_am.Text = "Erstellt am"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(132, 196)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(121, 21)
        Me.cboxSecurityLevel.TabIndex = 4
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(17, 199)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 8
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(132, 88)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(281, 95)
        Me.txtBemerkung.TabIndex = 3
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(17, 91)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 6
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'cbextern
        '
        Me.cbextern.AutoSize = True
        Me.cbextern.Location = New System.Drawing.Point(132, 63)
        Me.cbextern.Name = "cbextern"
        Me.cbextern.Size = New System.Drawing.Size(15, 14)
        Me.cbextern.TabIndex = 2
        Me.cbextern.UseVisualStyleBackColor = True
        '
        'lblextern
        '
        Me.lblextern.AutoSize = True
        Me.lblextern.Location = New System.Drawing.Point(17, 63)
        Me.lblextern.Name = "lblextern"
        Me.lblextern.Size = New System.Drawing.Size(37, 13)
        Me.lblextern.TabIndex = 4
        Me.lblextern.Text = "Extern"
        '
        'txtBezeichnung_extern
        '
        Me.txtBezeichnung_extern.Location = New System.Drawing.Point(132, 34)
        Me.txtBezeichnung_extern.Name = "txtBezeichnung_extern"
        Me.txtBezeichnung_extern.Size = New System.Drawing.Size(281, 20)
        Me.txtBezeichnung_extern.TabIndex = 1
        '
        'txtBezeichnung_intern
        '
        Me.txtBezeichnung_intern.Location = New System.Drawing.Point(132, 9)
        Me.txtBezeichnung_intern.Name = "txtBezeichnung_intern"
        Me.txtBezeichnung_intern.Size = New System.Drawing.Size(281, 20)
        Me.txtBezeichnung_intern.TabIndex = 0
        '
        'lblBezeichnungExtern
        '
        Me.lblBezeichnungExtern.AutoSize = True
        Me.lblBezeichnungExtern.Location = New System.Drawing.Point(17, 37)
        Me.lblBezeichnungExtern.Name = "lblBezeichnungExtern"
        Me.lblBezeichnungExtern.Size = New System.Drawing.Size(101, 13)
        Me.lblBezeichnungExtern.TabIndex = 1
        Me.lblBezeichnungExtern.Text = "Bezeichnung extern"
        '
        'lblBezeichnung_intern
        '
        Me.lblBezeichnung_intern.AutoSize = True
        Me.lblBezeichnung_intern.Location = New System.Drawing.Point(17, 12)
        Me.lblBezeichnung_intern.Name = "lblBezeichnung_intern"
        Me.lblBezeichnung_intern.Size = New System.Drawing.Size(98, 13)
        Me.lblBezeichnung_intern.TabIndex = 0
        Me.lblBezeichnung_intern.Text = "Bezeichnung intern"
        '
        'tabctrlDetails
        '
        Me.tabctrlDetails.Controls.Add(Me.TabSLA)
        Me.tabctrlDetails.Controls.Add(Me.TabVertragsbeziehungen)
        Me.tabctrlDetails.Dock = System.Windows.Forms.DockStyle.Fill
        Me.tabctrlDetails.Location = New System.Drawing.Point(0, 0)
        Me.tabctrlDetails.Name = "tabctrlDetails"
        Me.tabctrlDetails.SelectedIndex = 0
        Me.tabctrlDetails.Size = New System.Drawing.Size(680, 274)
        Me.tabctrlDetails.TabIndex = 0
        '
        'TabSLA
        '
        Me.TabSLA.Controls.Add(Me.C1DatenSLA)
        Me.TabSLA.Controls.Add(Me.Panel1)
        Me.TabSLA.Controls.Add(Me.TreeSLA)
        Me.TabSLA.Location = New System.Drawing.Point(4, 22)
        Me.TabSLA.Name = "TabSLA"
        Me.TabSLA.Padding = New System.Windows.Forms.Padding(3)
        Me.TabSLA.Size = New System.Drawing.Size(672, 248)
        Me.TabSLA.TabIndex = 0
        Me.TabSLA.Text = "SLA"
        Me.TabSLA.UseVisualStyleBackColor = True
        '
        'C1DatenSLA
        '
        Me.C1DatenSLA.AlternatingRows = True
        Me.C1DatenSLA.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenSLA.FetchRowStyles = True
        Me.C1DatenSLA.FilterBar = True
        Me.C1DatenSLA.GroupByCaption = "Um eine Gruppierung herzustellen, den Spaltentitel in den Gruppierungsbereich zie" & _
            "hen"
        Me.C1DatenSLA.Images.Add(CType(resources.GetObject("C1DatenSLA.Images"), System.Drawing.Image))
        Me.C1DatenSLA.Location = New System.Drawing.Point(190, 3)
        Me.C1DatenSLA.Name = "C1DatenSLA"
        Me.C1DatenSLA.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenSLA.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenSLA.PreviewInfo.ZoomFactor = 75
        Me.C1DatenSLA.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenSLA.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenSLA.Size = New System.Drawing.Size(479, 242)
        Me.C1DatenSLA.TabIndex = 4
        Me.C1DatenSLA.Text = "C1TrueDBGrid1"
        Me.C1DatenSLA.PropBag = resources.GetString("C1DatenSLA.PropBag")
        '
        'Panel1
        '
        Me.Panel1.Controls.Add(Me.BtnAddSLA)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(161, 3)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(29, 242)
        Me.Panel1.TabIndex = 1
        '
        'BtnAddSLA
        '
        Me.BtnAddSLA.Image = CType(resources.GetObject("BtnAddSLA.Image"), System.Drawing.Image)
        Me.BtnAddSLA.Location = New System.Drawing.Point(3, 109)
        Me.BtnAddSLA.Name = "BtnAddSLA"
        Me.BtnAddSLA.Size = New System.Drawing.Size(23, 28)
        Me.BtnAddSLA.TabIndex = 0
        Me.BtnAddSLA.UseVisualStyleBackColor = True
        '
        'TreeSLA
        '
        Me.TreeSLA.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeSLA.Location = New System.Drawing.Point(3, 3)
        Me.TreeSLA.Name = "TreeSLA"
        Me.TreeSLA.Size = New System.Drawing.Size(158, 242)
        Me.TreeSLA.TabIndex = 0
        '
        'TabVertragsbeziehungen
        '
        Me.TabVertragsbeziehungen.Controls.Add(Me.C1Vertragsbeziehungen)
        Me.TabVertragsbeziehungen.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsbeziehungen.Name = "TabVertragsbeziehungen"
        Me.TabVertragsbeziehungen.Padding = New System.Windows.Forms.Padding(3)
        Me.TabVertragsbeziehungen.Size = New System.Drawing.Size(672, 248)
        Me.TabVertragsbeziehungen.TabIndex = 1
        Me.TabVertragsbeziehungen.Text = "Vertragsbeziehungen"
        Me.TabVertragsbeziehungen.UseVisualStyleBackColor = True
        '
        'C1Vertragsbeziehungen
        '
        Me.C1Vertragsbeziehungen.AlternatingRows = True
        Me.C1Vertragsbeziehungen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Vertragsbeziehungen.FetchRowStyles = True
        Me.C1Vertragsbeziehungen.FilterBar = True
        Me.C1Vertragsbeziehungen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Vertragsbeziehungen.Images.Add(CType(resources.GetObject("C1Vertragsbeziehungen.Images"), System.Drawing.Image))
        Me.C1Vertragsbeziehungen.Location = New System.Drawing.Point(3, 3)
        Me.C1Vertragsbeziehungen.Name = "C1Vertragsbeziehungen"
        Me.C1Vertragsbeziehungen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragsbeziehungen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragsbeziehungen.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragsbeziehungen.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragsbeziehungen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragsbeziehungen.Size = New System.Drawing.Size(666, 242)
        Me.C1Vertragsbeziehungen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Vertragsbeziehungen.TabIndex = 12
        Me.C1Vertragsbeziehungen.Text = "C1TrueDBGrid1"
        Me.C1Vertragsbeziehungen.PropBag = resources.GetString("C1Vertragsbeziehungen.PropBag")
        '
        'frmServicekatalog
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(876, 564)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.pnlServicekatalog)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmServicekatalog"
        Me.Text = "Service-Katalog"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.pnlServicekatalog.ResumeLayout(False)
        Me.ctxMenuTreeServiceKatalog.ResumeLayout(False)
        Me.pnlServicekataloglabel.ResumeLayout(False)
        Me.pnlServicekataloglabel.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel1.PerformLayout()
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.tabctrlDetails.ResumeLayout(False)
        Me.TabSLA.ResumeLayout(False)
        CType(Me.C1DatenSLA, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.TabVertragsbeziehungen.ResumeLayout(False)
        CType(Me.C1Vertragsbeziehungen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.LeistungÜbernehmenToolStripMenuItem_Click -Methode

Context-Menueintrag im ctxMenuTreeServicekatalog für die Übernahme der Leistung

[Visual Basic]
Private Sub LeistungÜbernehmenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   LeistungÜbernehmenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub LeistungÜbernehmenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LeistungÜbernehmenToolStripMenuItem.Click
        TSBtnSelect_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.NeueLeistungToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub NeueLeistungToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeueLeistungToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeueLeistungToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeueLeistungToolStripMenuItem.Click
        Dim Katalogname As String = InputBox("Leistungsname", "Neue Leistung")
        If Katalogname <> "" Then
            Dim key As Integer = Me.Servicekatalogdaten.Insert_Katalogelement(Katalogname, Me.treeServiceKatalog.SelectedNode.Tag)
            Treeviewdata.Load_Tree(Me.treeServiceKatalog, Me.cbselaktiv.CheckState)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.NeuerKatalogToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub NeuerKatalogToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuerKatalogToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuerKatalogToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuerKatalogToolStripMenuItem.Click
        Dim Katalogname As String = InputBox("Katalogname", "Neuer Katalog")
        If Katalogname <> "" Then
            Dim key As Integer = Me.Servicekatalogdaten.Insert_Katalogelement(Katalogname, 0)
            Treeviewdata.Load_Tree(Me.treeServiceKatalog, Me.cbselaktiv.CheckState)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Refresh_Details -Methode

Registerlaschen in TabCtrlDetails aktualisieren

[Visual Basic]
Private Sub Refresh_Details()

Quellcode

[Visual Basic]
    Private Sub Refresh_Details()
        Select Case Me.tabctrlDetails.SelectedTab.Text
            Case "Vertragsbeziehungen"
                Refresh_Vertragsbeziehungen()
            Case Else
        End Select
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Refresh_SLATable -Methode

[Visual Basic]
Private Sub Refresh_SLATable()

Quellcode

[Visual Basic]
    Private Sub Refresh_SLATable()
        Try
            check_changes()
            Me.ServiceKatalogSLAKatalog.dispose()
        Catch
        End Try

        Dim keyvalue As String = ""
        keyvalue = Me.treeServiceKatalog.SelectedNode.Tag
        Me.C1DatenSLA.Enabled = False
        Me.ServiceKatalogSLAKatalog = New TKB.VV.Sysadmin.DomainTable("servicekatalog_slakatalog", keyvalue, Globals.clsmitarbeiter.iMitarbeiternr.Value)
        Me.C1DatenSLA.DataSource = ServiceKatalogSLAKatalog.Tabledata
        Me.C1DatenSLA.DataMember = ServiceKatalogSLAKatalog.Tabledata.Tables(0).TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DatenSLA, "servicekatalog_slakatalog", Me.ServiceKatalogSLAKatalog.Tabledata)
        Me.C1DatenSLA.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Refresh_Vertragsbeziehungen -Methode

Services aktualiseren

[Visual Basic]
Private Sub Refresh_Vertragsbeziehungen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Vertragsbeziehungen()
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Vertragsbeziehungen.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Vertragsbeziehungen.Bookmark

        Me.C1Vertragsbeziehungen.Enabled = False
        Me.Servicekatalogdaten.Get_Vertragsbeziehungen(Me.C1Vertragsbeziehungen, Me.treeServiceKatalog.SelectedNode.Tag)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Vertragsbeziehungen, "Vertragsleistung_Servicekatalog", Me.Servicekatalogdaten.Vertragsbeziehungen.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Vertragsbeziehungen.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Vertragsbeziehungen.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Vertragsbeziehungen.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.Show_Data -Methode

[Visual Basic]
Private Sub Show_Data( _
   ByVal Servicekatalognr As Integer _
)

Parameter

Servicekatalognr

Quellcode

[Visual Basic]
    Private Sub Show_Data(ByVal Servicekatalognr As Integer)
        Me.Servicekatalogdaten.Get_Data(Servicekatalognr)
        Me.txtBezeichnung_intern.Text = Me.Servicekatalogdaten.sBezeichnung_intern.Value
        Me.txtBezeichnung_extern.Text = Me.Servicekatalogdaten.sBezeichnung_extern.Value
        Me.txtBemerkung.Text = Me.Servicekatalogdaten.sBemerkung.Value
        Me.txtmutiert_am.Text = Me.Servicekatalogdaten.daMutiert_am.ToString
        Me.txterstellt_am.Text = Me.Servicekatalogdaten.daErstellt_am.ToString
        Me.txtMutierer.Text = Me.Servicekatalogdaten.iMutierer.Value
        Me.cbaktiv.Checked = Me.Servicekatalogdaten.bAktiv.Value = True
        Me.cbextern.Checked = Me.Servicekatalogdaten.bExtern.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Servicekatalogdaten.iSecurityLevelNr.Value
        Me.FormDataChanged = False
        If Me.Servicekatalogdaten.iParentID > 0 Then Me.cboxSecurityLevel.Enabled = False Else Me.cboxSecurityLevel.Enabled = True
        Refresh_SLATable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TSBtnDelete_Click -Methode

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(510) = MsgBoxResult.Yes Then
            Me.cbaktiv.Checked = False
            Me.save_katalogdata()
            'Dim i As Integer = Me.treeServiceKatalog.SelectedNode.Tag
            'Me.Servicekatalogdaten.Delete_Servicekatalog(Me.treeServiceKatalog.SelectedNode.Tag)
            'Me.treeServiceKatalog.SelectedNode.NodeFont = Me.Treeviewdata.fnt_Strikeout
            'Me.Delete_all_Childs(Me.treeServiceKatalog.SelectedNode.Nodes)
            'Treeviewdata.Load_Tree(Me.treeServiceKatalog)
            'Treeviewdata.Set_Images(Me.treeServiceKatalog)
            'Me.treeServiceKatalog.SelectedNode = FindNode(Me.treeServiceKatalog.Nodes, i, "")
            'Me.treeServiceKatalog.SelectedNode.NodeFont = Me.Treeviewdata.fnt_Strikeout
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TSBtnNew_Click -Methode

Neuer Service erfassen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        Dim f As New frmServicekatalog
        f.ShowDialog()
        frmServicekatalog_Load(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TSBtnQuit_Click -Methode

Schliessen-Button

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TSBtnSave_Click -Methode

Save Button

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        If Me.FormDataChanged Then
            save_katalogdata()
            Me.FormDataChanged = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TSBtnSelect_Click -Methode

Gewählter Servicekatalog übergeben

[Visual Basic]
Private Sub TSBtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSelect.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSelect.Click
        Me.Neuer_Datensatz = False
        Globals.MyEventHanlder.Leistung_Selektiert(Me.Vertragsleistungsnr, Me.treeServiceKatalog.SelectedNode.Tag)
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.TreeSLA_DoubleClick -Methode

[Visual Basic]
Private Sub TreeSLA_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeSLA.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeSLA_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeSLA.DoubleClick
        If TreeSLA.SelectedNode.Tag <> 0 And Not Me.FormReadonly Then
            Me.ServiceKatalogSLAKatalog.Insert_Bottom_Table("ServiceKatalognr", Me.treeServiceKatalog.SelectedNode.Tag, "slakatalognr", Me.TreeSLA.SelectedNode.Tag)
            Me.ServiceKatalogSLAKatalog.Save_Data()
            Refresh_SLATable()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.cbselaktiv_CheckedChanged -Methode

[Visual Basic]
Private Sub cbselaktiv_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbselaktiv.CheckStateChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbselaktiv_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbselaktiv.CheckStateChanged
        Treeviewdata.Load_Tree(Me.treeServiceKatalog, Me.cbselaktiv.CheckState)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.check_changes -Methode

Prüfung, ob Verbindungstabelle geändert wurde.

[Visual Basic]
Private Sub check_changes()

Quellcode

[Visual Basic]
    Private Sub check_changes()
        If Me.FormReadonly Then Exit Sub
        Dim msgres As MsgBoxResult
        If Me.ServiceKatalogSLAKatalog.Tabledata.HasChanges Then
            msgres = msg.Show_MessageYesNo(5)
            If msgres = MsgBoxResult.Yes Then
                Me.ServiceKatalogSLAKatalog.Save_Data()
            End If
        End If
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNo(3)
            If msgres = MsgBoxResult.Yes Then
                save_katalogdata()
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.frmServicekatalog_FormClosing -Methode

Schliessen des Formulares

[Visual Basic]
Private Sub frmServicekatalog_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmServicekatalog_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.Neuer_Datensatz = True Then
            Globals.MyEventHanlder.Keine_Leistung_Selektiert(Me.Vertragsleistungsnr)
        End If
        If Me.FormReadonly = True Then Exit Sub
        check_changes()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.frmServicekatalog_Load -Methode

Formular aufbauen

[Visual Basic]
Private Sub frmServicekatalog_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Hinweise

Ist der Paramter SelectLeistung = True, werden die Update-Funktionen des Formulars unterdrückt, dafür werden die Funktionen für die Leistungsauswahl aktiviert

Quellcode

[Visual Basic]
    Private Sub frmServicekatalog_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Treeviewdata.Load_Tree(Me.treeServiceKatalog, Me.cbselaktiv.CheckState)
        'Treeviewdata.Set_Images(Me.treeServiceKatalog)

        SLATreeviewdata.Load_Tree(Me.TreeSLA)
        Load_Securitylevel()

        sec.Set_Form_Security(Me)
        Me.TSBtnSelect.Visible = False
        Me.MenuSplitter.Visible = False
        Me.LeistungÜbernehmenToolStripMenuItem.Visible = False

        If Me.FormReadonly Then
            Me.TSBtnSave.Visible = False
            Me.TSBtnSelect.Visible = False
            Me.TSBtnCopy.Visible = False
            Me.TSBtnNew.Visible = False
            Me.TSBtnDelete.Visible = False
            Me.MenuSplitter.Visible = False

            Me.LeistungÜbernehmenToolStripMenuItem.Visible = False
        End If
        If Me.ForSelect = True Then
            Me.TSBtnSelect.Visible = True
            Me.TSBtnNew.Visible = True
            Me.TSBtnSelect.Visible = True
            Me.TSBtnCopy.Visible = False
            'Me.TSBtnNew.Visible = False
            Me.TSBtnDelete.Visible = False
            Me.MenuSplitter.Visible = True
            Me.LeistungÜbernehmenToolStripMenuItem.Visible = True
        End If

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.ctxMenuTreeServiceKatalog.Enabled = False
            If Me.ForSelect = True Then
                Me.LeistungÜbernehmenToolStripMenuItem.Enabled = True
            End If
        Else
            Me.FormReadonly = False
        End If
        If Me.ServiceKatalognr <> -1 Then
            Me.treeServiceKatalog.Enabled = False
            Me.treeServiceKatalog.SelectedNode = FindNode(Me.treeServiceKatalog.Nodes, ServiceKatalognr, "")
            Me.treeServiceKatalog.Enabled = True
        End If
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.save_katalogdata -Methode

[Visual Basic]
Private Sub save_katalogdata()

Quellcode

[Visual Basic]
    Private Sub save_katalogdata()
        If Me.Servicekatalogdaten.bAktiv.Value = True And Me.cbaktiv.Checked = False Then
            If msg.Show_MessageYesNo(700) = MsgBoxResult.No Then Exit Sub
        End If
        Me.Servicekatalogdaten.sBezeichnung_intern = New SqlString(CType(Me.txtBezeichnung_intern.Text, String))
        Me.Servicekatalogdaten.sBezeichnung_extern = New SqlString(CType(Me.txtBezeichnung_extern.Text, String))
        Me.Servicekatalogdaten.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Me.Servicekatalogdaten.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        Me.Servicekatalogdaten.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        Me.Servicekatalogdaten.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked, Boolean))
        Me.Servicekatalogdaten.bExtern = New SqlBoolean(CType(Me.cbextern.Checked, Boolean))
        Me.Servicekatalogdaten.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
        Me.Servicekatalogdaten.Save_Data()
        If Me.cbaktiv.Checked Then
            Me.treeServiceKatalog.SelectedNode.NodeFont = Me.Treeviewdata.fnt_normal
        Else
            Me.Servicekatalogdaten.Delete_Servicekatalog()
            Me.treeServiceKatalog.SelectedNode.NodeFont = Me.Treeviewdata.fnt_Strikeout
            Delete_all_Childs(Me.treeServiceKatalog.SelectedNode.Nodes)
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.tabctrlDetails_SelectedIndexChanged -Methode

Register-Wechsel im TabControl

[Visual Basic]
Private Sub tabctrlDetails_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   tabctrlDetails.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tabctrlDetails_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles tabctrlDetails.SelectedIndexChanged
        Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.treeServiceKatalog_AfterSelect -Methode

[Visual Basic]
Private Sub treeServiceKatalog_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   treeServiceKatalog.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub treeServiceKatalog_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles treeServiceKatalog.AfterSelect
        Show_Data(Me.treeServiceKatalog.SelectedNode.Tag)
        Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.treeServiceKatalog_MouseDown -Methode

[Visual Basic]
Private Sub treeServiceKatalog_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   treeServiceKatalog.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub treeServiceKatalog_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles treeServiceKatalog.MouseDown
        Try
            check_changes()
            Dim selectPoint As New System.Drawing.Point()

            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.treeServiceKatalog.SelectedNode = Me.treeServiceKatalog.GetNodeAt(selectPoint)
            If IsNothing(Me.treeServiceKatalog.SelectedNode) Then
                Me.NeueLeistungToolStripMenuItem.Enabled = False
            Else
                If Me.TSBtnSave.Enabled = True Then Me.NeueLeistungToolStripMenuItem.Enabled = True
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog.txtBezeichnung_intern_TextChanged -Methode

[Visual Basic]
Private Sub txtBezeichnung_intern_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtBezeichnung_intern.TextChanged, _
   txtBezeichnung_extern.TextChanged, _
   txtBemerkung.TextChanged, _
   cbaktiv.CheckedChanged, _
   cboxSecurityLevel.TextChanged, _
   cbextern.CheckedChanged, _
   cboxSecurityLevel.TextUpdate

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtBezeichnung_intern_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung_intern.TextChanged, txtBezeichnung_extern.TextChanged, txtBemerkung.TextChanged, cbaktiv.CheckedChanged, cboxSecurityLevel.TextChanged, cbextern.CheckedChanged, cboxSecurityLevel.TextUpdate
        If sender.name = "cbaktiv" Then
            Try
                If cbaktiv.Checked = True And Me.treeServiceKatalog.SelectedNode.Parent.NodeFont.Strikeout = True Then
                    Me.cbaktiv.Checked = False
                    msg.show_standardmessage(601, MsgBoxStyle.Critical)
                    Exit Sub
                End If
            Catch
            End Try
        End If
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmServicekatalog-Felder

frmServicekatalog Übersicht

Felder

private field ForSelect

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SLATreeviewdata

Unterstützt von .NET Compact Framework
private field ServiceKatalogSLAKatalog

Unterstützt von .NET Compact Framework
private field ServiceKatalognr

Unterstützt von .NET Compact Framework
private field Servicekatalogdaten

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Treeviewdata

Unterstützt von .NET Compact Framework
private field Vertragsleistungsnr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

Siehe auch

frmServicekatalog -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogDaten | TKB.VV.SLA.clsServiceKatalogSLATree | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


ForSelect -Feld

[Visual Basic]
Private ForSelect As Boolean

Quellcode

[Visual Basic]
    Dim ForSelect As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


SLATreeviewdata -Feld

[Visual Basic]
Private SLATreeviewdata As clsServiceKatalogSLATree

Quellcode

[Visual Basic]
    Dim SLATreeviewdata As New TKB.VV.SLA.clsServiceKatalogSLATree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


ServiceKatalogSLAKatalog -Feld

[Visual Basic]
Private ServiceKatalogSLAKatalog As DomainTable

Quellcode

[Visual Basic]
    Dim ServiceKatalogSLAKatalog As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


ServiceKatalognr -Feld

[Visual Basic]
Private ServiceKatalognr As Integer

Quellcode

[Visual Basic]
    Dim ServiceKatalognr As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


Servicekatalogdaten -Feld

[Visual Basic]
Private Servicekatalogdaten As clsServiceKatalogDaten

Quellcode

[Visual Basic]
    Dim Servicekatalogdaten As New TKB.VV.SLA.clsServiceKatalogDaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


Treeviewdata -Feld

[Visual Basic]
Private Treeviewdata As clsServiceKatalogTree

Quellcode

[Visual Basic]
    Dim Treeviewdata As New TKB.VV.SLA.clsServiceKatalogTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


Vertragsleistungsnr -Feld

[Visual Basic]
Private Vertragsleistungsnr As Integer

Quellcode

[Visual Basic]
    Dim Vertragsleistungsnr As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmServicekatalog


frmSplash -Klasse

For a list of all members of this type, see frmSplash-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSplash

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmSplash
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmSplash-Member


frmSplash-Member

frmSplash Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method PictureBox1_Click

Unterstützt von .NET Compact Framework
private method Timer1_Tick

Unterstützt von .NET Compact Framework
private method frmSplash_Load

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmSplash -Klasse


frmSplash-Methoden

frmSplash Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method PictureBox1_Click

Unterstützt von .NET Compact Framework
private method Timer1_Tick

Unterstützt von .NET Compact Framework
private method frmSplash_Load

Unterstützt von .NET Compact Framework

frmSplash -Klasse


frmSplash.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSplash.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSplash))
        Me.PictureBox1 = New System.Windows.Forms.PictureBox
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.lblVersion = New System.Windows.Forms.Label
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.lblversiondatum = New System.Windows.Forms.Label
        CType(Me.PictureBox1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'PictureBox1
        '
        Me.PictureBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.PictureBox1.ErrorImage = CType(resources.GetObject("PictureBox1.ErrorImage"), System.Drawing.Image)
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Image)
        Me.PictureBox1.Location = New System.Drawing.Point(0, 0)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(463, 334)
        Me.PictureBox1.TabIndex = 0
        Me.PictureBox1.TabStop = False
        '
        'Timer1
        '
        Me.Timer1.Enabled = True
        Me.Timer1.Interval = 3000
        '
        'lblVersion
        '
        Me.lblVersion.BackColor = System.Drawing.Color.White
        Me.lblVersion.Font = New System.Drawing.Font("Microsoft Sans Serif", 14.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblVersion.Location = New System.Drawing.Point(3, 0)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(197, 24)
        Me.lblVersion.TabIndex = 1
        Me.lblVersion.Text = "Version "
        Me.lblVersion.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'Panel1
        '
        Me.Panel1.BackColor = System.Drawing.Color.White
        Me.Panel1.Controls.Add(Me.lblversiondatum)
        Me.Panel1.Controls.Add(Me.lblVersion)
        Me.Panel1.Location = New System.Drawing.Point(246, 252)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(195, 48)
        Me.Panel1.TabIndex = 2
        '
        'lblversiondatum
        '
        Me.lblversiondatum.BackColor = System.Drawing.Color.White
        Me.lblversiondatum.Font = New System.Drawing.Font("Microsoft Sans Serif", 11.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblversiondatum.Location = New System.Drawing.Point(0, 24)
        Me.lblversiondatum.Name = "lblversiondatum"
        Me.lblversiondatum.Size = New System.Drawing.Size(200, 24)
        Me.lblversiondatum.TabIndex = 2
        Me.lblversiondatum.Text = "Version "
        Me.lblversiondatum.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'frmSplash
        '
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.None
        Me.ClientSize = New System.Drawing.Size(463, 334)
        Me.ControlBox = False
        Me.Controls.Add(Me.Panel1)
        Me.Controls.Add(Me.PictureBox1)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.None
        Me.Name = "frmSplash"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "frmSplash"
        CType(Me.PictureBox1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSplash.PictureBox1_Click -Methode

[Visual Basic]
Private Sub PictureBox1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PictureBox1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PictureBox1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PictureBox1.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSplash.Timer1_Tick -Methode

[Visual Basic]
Private Sub Timer1_Tick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Timer1.Tick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Timer1.Tick
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSplash.frmSplash_Load -Methode

[Visual Basic]
Private Sub frmSplash_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmSplash_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        Me.lblVersion.Text = "Version " & Globals.clsapplication.sVersion.Value
        Me.lblVersiondatum.text = Globals.Versionsdatum
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSplash-Felder

frmSplash Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmSplash -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSplash


frmSysadminMenu -Klasse

For a list of all members of this type, see frmSysadminMenu-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSysadminMenu

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmSysadminMenu
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmSysadminMenu-Member


frmSysadminMenu-Member

frmSysadminMenu Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulares
private method FrmSysadminMenu_Load Unterstützt von .NET Compact Framework | Load des Formulars
private method FrmSysadminMenu_Resize Unterstützt von .NET Compact Framework |
private method Generate_Data Unterstützt von .NET Compact Framework | Ruft die SP zur Spalten-Generierung auf
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ListNodeCollectionRecursive Unterstützt von .NET Compact Framework | Knoten rekursiv auslesen
private method ListNodeSave Unterstützt von .NET Compact Framework | einzelner Knoten sichern
private method MenuKnotenRename_Click Unterstützt von .NET Compact Framework | Umbenennen des aktuellen Menu-Eintrages
private method MnuKnotenLoeschen_Click Unterstützt von .NET Compact Framework | Eintrag im Menu löschen
private method MnuNeuerKnoten_Click Unterstützt von .NET Compact Framework | Neuer Eintrag im Menu einfügen
private method MnuSave_Click Unterstützt von .NET Compact Framework | Menu Sichern
private method SpaltentitelGenerierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle
private method SysMenuTree_AfterSelect Unterstützt von .NET Compact Framework |
private method SysMenuTree_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen
private method SysMenuTree_DragDrop Unterstützt von .NET Compact Framework |
private method SysMenuTree_ItemDrag Unterstützt von .NET Compact Framework |
private method SysMenutree_DragEnter Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Fenster schliessen

Felder

private field components

Unterstützt von .NET Compact Framework
private field itodelete

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field ssort

Unterstützt von .NET Compact Framework
private field todelete

Unterstützt von .NET Compact Framework

frmSysadminMenu -Klasse


frmSysadminMenu-Methoden

frmSysadminMenu Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Schliessen des Formulares
private method FrmSysadminMenu_Load Unterstützt von .NET Compact Framework | Load des Formulars
private method FrmSysadminMenu_Resize Unterstützt von .NET Compact Framework |
private method Generate_Data Unterstützt von .NET Compact Framework | Ruft die SP zur Spalten-Generierung auf
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method ListNodeCollectionRecursive Unterstützt von .NET Compact Framework | Knoten rekursiv auslesen
private method ListNodeSave Unterstützt von .NET Compact Framework | einzelner Knoten sichern
private method MenuKnotenRename_Click Unterstützt von .NET Compact Framework | Umbenennen des aktuellen Menu-Eintrages
private method MnuKnotenLoeschen_Click Unterstützt von .NET Compact Framework | Eintrag im Menu löschen
private method MnuNeuerKnoten_Click Unterstützt von .NET Compact Framework | Neuer Eintrag im Menu einfügen
private method MnuSave_Click Unterstützt von .NET Compact Framework | Menu Sichern
private method SpaltentitelGenerierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle
private method SysMenuTree_AfterSelect Unterstützt von .NET Compact Framework |
private method SysMenuTree_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen
private method SysMenuTree_DragDrop Unterstützt von .NET Compact Framework |
private method SysMenuTree_ItemDrag Unterstützt von .NET Compact Framework |
private method SysMenutree_DragEnter Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Fenster schliessen

frmSysadminMenu -Klasse


frmSysadminMenu.BeendenToolStripMenuItem_Click -Methode

Schliessen des Formulares

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.FrmSysadminMenu_Load -Methode

Load des Formulars

[Visual Basic]
Private Sub FrmSysadminMenu_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmSysadminMenu_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim menu As New TKB.VV.Sysadmin.clsMySysadminfunkion()
        menu.LoadTreeMenu(SysMenuTree)
        SysMenuTree.ExpandAll()
        itodelete = 0
        Me.SysMenuTree.ContextMenu = Me.ContextMenu1
        Me.Height = Me.Parent.ClientSize.Height
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.FrmSysadminMenu_Resize -Methode

[Visual Basic]
Private Sub FrmSysadminMenu_Resize( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Resize

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmSysadminMenu_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Resize
        If Me.Width > 300 Then Me.Width = 300
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.Generate_Data -Methode

Ruft die SP zur Spalten-Generierung auf

[Visual Basic]
Private Sub Generate_Data( _
   ByVal tablename As String _
)

Parameter

tablename

Quellcode

[Visual Basic]
    Private Sub Generate_Data(ByVal tablename As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dttable As New DataTable(tablename)
        scmCmdToExecute.CommandText = "dbo.[sp_update_spalten]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, tablename))
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception(msg.Get_Meldungstext(103), ex)
        Finally
            scmCmdToExecute.Connection.Close()
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSysadminMenu))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SpaltentitelGenerierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.SysMenuTree = New System.Windows.Forms.TreeView
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu
        Me.MnuNeuerKnoten = New System.Windows.Forms.MenuItem
        Me.MnuKnotenLoeschen = New System.Windows.Forms.MenuItem
        Me.MenuKnotenRename = New System.Windows.Forms.MenuItem
        Me.MenuItem4 = New System.Windows.Forms.MenuItem
        Me.MnuSave = New System.Windows.Forms.MenuItem
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem, Me.SpaltentitelGenerierenToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(299, 24)
        Me.MenuStrip1.TabIndex = 0
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'SpaltentitelGenerierenToolStripMenuItem
        '
        Me.SpaltentitelGenerierenToolStripMenuItem.Name = "SpaltentitelGenerierenToolStripMenuItem"
        Me.SpaltentitelGenerierenToolStripMenuItem.Size = New System.Drawing.Size(124, 20)
        Me.SpaltentitelGenerierenToolStripMenuItem.Text = "&Spaltentitel generieren"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(299, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'SysMenuTree
        '
        Me.SysMenuTree.AllowDrop = True
        Me.SysMenuTree.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SysMenuTree.ImageIndex = 0
        Me.SysMenuTree.ImageList = Me.ImageList1
        Me.SysMenuTree.Indent = 19
        Me.SysMenuTree.ItemHeight = 16
        Me.SysMenuTree.Location = New System.Drawing.Point(0, 49)
        Me.SysMenuTree.Name = "SysMenuTree"
        Me.SysMenuTree.SelectedImageIndex = 0
        Me.SysMenuTree.Size = New System.Drawing.Size(299, 521)
        Me.SysMenuTree.TabIndex = 2
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "")
        Me.ImageList1.Images.SetKeyName(1, "")
        Me.ImageList1.Images.SetKeyName(2, "")
        Me.ImageList1.Images.SetKeyName(3, "")
        Me.ImageList1.Images.SetKeyName(4, "")
        Me.ImageList1.Images.SetKeyName(5, "Kette3.ico")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeuerKnoten, Me.MnuKnotenLoeschen, Me.MenuKnotenRename, Me.MenuItem4, Me.MnuSave})
        '
        'MnuNeuerKnoten
        '
        Me.MnuNeuerKnoten.Index = 0
        Me.MnuNeuerKnoten.Text = "Neuer Eintrag "
        '
        'MnuKnotenLoeschen
        '
        Me.MnuKnotenLoeschen.Index = 1
        Me.MnuKnotenLoeschen.Text = "Eintrag löschen"
        '
        'MenuKnotenRename
        '
        Me.MenuKnotenRename.Index = 2
        Me.MenuKnotenRename.Text = "Eintrag umbenennen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "-"
        '
        'MnuSave
        '
        Me.MnuSave.Index = 4
        Me.MnuSave.Text = "Menu Speichern"
        '
        'frmSysadminMenu
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(299, 570)
        Me.Controls.Add(Me.SysMenuTree)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MainMenuStrip = Me.MenuStrip1
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmSysadminMenu"
        Me.Text = "FrmSysadminMenu"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.ListNodeCollectionRecursive -Methode

Knoten rekursiv auslesen

[Visual Basic]
Private Sub ListNodeCollectionRecursive( _
   ByVal tnParent As TreeNode, _
   ByRef iSort As Integer _
)

Parameter

tnParent
iSort

Quellcode

[Visual Basic]
    Private Sub ListNodeCollectionRecursive(ByVal tnParent As TreeNode, ByRef iSort As Integer)
        Dim tn As TreeNode
        If tnParent.GetNodeCount(False) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        ssort = 0
        Do Until tn Is Nothing
            iSort = iSort + 1
            ListNodeSave(tn, iSort)
            If tn.GetNodeCount(False) > 0 Then
                Call ListNodeCollectionRecursive(tn, iSort)
            End If
            tn = tn.NextNode
        Loop
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.ListNodeSave -Methode

einzelner Knoten sichern

[Visual Basic]
Private Sub ListNodeSave( _
   ByVal tn As TreeNode, _
   ByRef isort As Integer _
)

Parameter

tn
isort

Quellcode

[Visual Basic]
    Private Sub ListNodeSave(ByVal tn As TreeNode, ByRef isort As Integer)
        Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle()
        Dim t As DataTable
        Dim key As Long
        Dim i As Integer
        Dim ftop, fleft, fheight, fwidth As Integer
        Dim sDomaintable As String = ""
        Dim sKeyfields As String = ""
        Dim sysadmfnkt As New TKB.VV.DB.clsSysadminfunktion
        dbkey.cpMainConnectionProvider = conn
        sysadmfnkt.cpMainConnectionProvider = conn
        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.SelectOne()
            ftop = sysadmfnkt.iFtop.Value
            fleft = sysadmfnkt.iFleft.Value
            fwidth = sysadmfnkt.iFwidth.Value
            fheight = sysadmfnkt.iFheight.Value
            sDomaintable = sysadmfnkt.sDomaintable.Value
            sKeyfields = sysadmfnkt.sKeyFields.Value
        End If
        sysadmfnkt.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
        sysadmfnkt.sBezeichnung = New SqlString(CType(tn.Text, String))
        sysadmfnkt.sBeschreibung = New SqlString(CType("", String))
        sysadmfnkt.iParentID = New SqlInt32(CType(tn.Parent.Tag, Int32))
        sysadmfnkt.iImageIndex = New SqlInt32(CType(tn.ImageIndex, Int32))
        sysadmfnkt.iImageIndexOpen = New SqlInt32(CType(tn.SelectedImageIndex, Int32))
        sysadmfnkt.iSort = New SqlInt32(CType(isort, Int32))
        sysadmfnkt.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.bAktiv = New SqlBoolean(CType(True, Boolean))
        sysadmfnkt.iSprache = New SqlInt32(CType(1, Int32))
        sysadmfnkt.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
        sysadmfnkt.iFtop = New SqlInt32(CType(ftop, Int32))
        sysadmfnkt.iFleft = New SqlInt32(CType(fleft, Int32))
        sysadmfnkt.iFwidth = New SqlInt32(CType(fwidth, Int32))
        sysadmfnkt.iFheight = New SqlInt32(CType(fheight, Int32))
        sysadmfnkt.sDomaintable = New SqlString(CType(sDomaintable, String))
        sysadmfnkt.sKeyFields = New SqlString(CType(sKeyfields, String))

        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.Update()
        Else
            key = dbkey.get_dbkey("sysadminfunktion")
            conn.OpenConnection()
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(key, Int32))
            sysadmfnkt.Insert()
            tn.Tag = key
        End If

        For i = 1 To itodelete
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(todelete(i), Int32))
            t = sysadmfnkt.SelectOne
            If t.Rows.Count > 0 Then
                sysadmfnkt.Delete()
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.MenuKnotenRename_Click -Methode

Umbenennen des aktuellen Menu-Eintrages

[Visual Basic]
Private Sub MenuKnotenRename_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MenuKnotenRename.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MenuKnotenRename_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuKnotenRename.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.SysMenuTree.SelectedNode.Text = a
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.MnuKnotenLoeschen_Click -Methode

Eintrag im Menu löschen

[Visual Basic]
Private Sub MnuKnotenLoeschen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuKnotenLoeschen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MnuKnotenLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuKnotenLoeschen.Click
        Dim tn As New TreeNode()
        Dim tnp As New TreeNode()
        Dim i As Integer
        tn = Me.SysMenuTree.SelectedNode
        tnp = tn.Parent
        If Not (Me.SysMenuTree.SelectedNode Is Nothing) Then
            itodelete = itodelete + 1
            todelete(itodelete) = tn.Tag
            If msg.Show_MessageYesNo(101) = MsgBoxResult.Yes Then
                tn.Remove()
            End If
            If tnp.GetNodeCount(True) = 0 Then
                tnp.ImageIndex = 3
                tnp.SelectedImageIndex = 3
            End If
            Me.SysMenuTree.Refresh()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.MnuNeuerKnoten_Click -Methode

Neuer Eintrag im Menu einfügen

[Visual Basic]
Private Sub MnuNeuerKnoten_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuNeuerKnoten.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MnuNeuerKnoten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuerKnoten.Click
        Dim a As String
        Dim tn As New TreeNode()
        Dim tnnew As New TreeNode()
        a = InputBox(msg.Get_Meldungstext(100))
        If a = "" Then Exit Sub
        tn = Me.SysMenuTree.SelectedNode
        tnnew = tn.Nodes.Add(a)
        With tnnew
            .Tag() = 0
            .ImageIndex() = 3
            .SelectedImageIndex() = 3
        End With
        tn.ImageIndex = 1
        tn.SelectedImageIndex = 2
        If tn.GetNodeCount(True) > 0 Then
            tn.ImageIndex = 1
            tn.SelectedImageIndex = 2
        End If
        Me.SysMenuTree.Refresh()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.MnuSave_Click -Methode

Menu Sichern

[Visual Basic]
Private Sub MnuSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MnuSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub MnuSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSave.Click
        Dim i As Integer
        conn.OpenConnection()
        ListNodeCollectionRecursive(Me.SysMenuTree.Nodes(0), 0)
        i = conn.CloseConnection(True)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SpaltentitelGenerierenToolStripMenuItem_Click -Methode

Generiert die Spaltentitel in der Tabelle Spalten aufgrund der im Formular frmSysadminTableSelector gewählten Tabelle

[Visual Basic]
Private Sub SpaltentitelGenerierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SpaltentitelGenerierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SpaltentitelGenerierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SpaltentitelGenerierenToolStripMenuItem.Click
        Dim f As New frmSysadminTableSelector()
        Dim tablename As String
        tablename = (f.get_tablename())
        If tablename = "" Then Exit Sub
        Generate_Data(tablename)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SysMenuTree_AfterSelect -Methode

[Visual Basic]
Private Sub SysMenuTree_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   SysMenuTree.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SysMenuTree_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles SysMenuTree.AfterSelect

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SysMenuTree_DoubleClick -Methode

Doppelklick auf einen Eintrag: Es wird geprüft, ob in der Tabelle SysadminFunktion im Attribut DomainTable einen Wert vorhanden ist. Sofern dies der Fall ist, wird der generelle Domain-Table-Editor aufgerufen

[Visual Basic]
Private Sub SysMenuTree_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SysMenuTree.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SysMenuTree_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles SysMenuTree.DoubleClick
        Dim sysadmfnkt As New TKB.VV.DB.clsSysadminfunktion
        Dim wert As String
        wert = Me.SysMenuTree.SelectedNode.Tag
        If IsNumeric(wert) Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(wert, Int32))
            sysadmfnkt.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            sysadmfnkt.SelectOne()
            Globals.conn.CloseConnection(True)
            If sysadmfnkt.sDomaintable.Value.IndexOf(";") > -1 Then
                'Verbindungseditor
                Dim s As String = sysadmfnkt.sDomaintable.Value
                Dim sArray() As String = s.Split(";")
                Dim f As New FrmVerbindungEditor(sArray(0), sArray(1), sArray(2), sysadmfnkt.iSysadminfnktnr.Value)
                f.Width = sysadmfnkt.iFwidth.Value
                f.Height = sysadmfnkt.iFheight.Value
                f.Top = sysadmfnkt.iFtop.Value
                f.Left = sysadmfnkt.iFleft.Value
                f.MdiParent = Me.MdiParent
                f.Text = "Verbindungseditor: " + Me.SysMenuTree.SelectedNode.Text
                f.Show()
            Else
                '20090810 - Externe Tabellen mit dem Domaineditor mutieren
                If sysadmfnkt.sDomaintable.Value.IndexOf(":") > -1 Then
                    Dim s As String = sysadmfnkt.sDomaintable.Value
                    Dim sarray() As String = s.Split(":")
                    Dim ofile As System.IO.File
                    Dim oread As System.IO.StreamReader
                    Dim scstring As String
                    oread = ofile.OpenText(Application.StartupPath + "\" + sarray(0))
                    sCString = oread.ReadLine
                    scstring = Crypto.DecryptText(scstring, "HutterundMueller")
                    scstring = Microsoft.VisualBasic.Left(scstring, Len(scstring) - 1)
                    oread.Close()
                    Dim f As New frmDomainEditorExtTables(sarray(1), scstring)
                    f.MdiParent = Me.MdiParent
                    f.Text = "TicketXPert-Tabelle:" + sarray(1)
                    f.Show()
                Else
                    'Einzelne Domaintable
                    If sysadmfnkt.sDomaintable.Value = "SLAKatalog" Then
                        Dim f As New frmSLAKatalog
                        f.MdiParent = Me.MdiParent

                        f.Show()
                        Exit Sub
                    End If
                    If sysadmfnkt.sDomaintable.Value = "Gremienverwaltung" Then
                        Dim f As New frmGremienverwaltung
                        f.MdiParent = Me.MdiParent
                        f.Show()
                        Exit Sub
                    End If
                    If sysadmfnkt.sDomaintable.Value = "ToolTip-Editor" Then
                        Dim f As New FrmToolTipEditor
                        f.MdiParent = Me.MdiParent
                        f.Show()
                        Exit Sub
                    End If
                    If sysadmfnkt.sDomaintable.Value <> "" Then
                        Dim f As New frmDomainEditor(sysadmfnkt.sDomaintable.Value)
                        f.MdiParent = Me.MdiParent
                        f.Width = sysadmfnkt.iFwidth.Value
                        f.Height = sysadmfnkt.iFheight.Value
                        f.Top = sysadmfnkt.iFtop.Value
                        f.Left = sysadmfnkt.iFleft.Value
                        f.Text = "Tabellen-Editor: " + Me.SysMenuTree.SelectedNode.Text
                        f.Show()
                    End If
                End If
            End If
            sysadmfnkt.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SysMenuTree_DragDrop -Methode

[Visual Basic]
Private Sub SysMenuTree_DragDrop( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
) Handles  _
   SysMenuTree.DragDrop

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SysMenuTree_DragDrop(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenuTree.DragDrop
        Dim OriginationNode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", False) Then
            Dim pt As Point
            Dim DestinationNode As TreeNode
            pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
            DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
            DestinationNode.Nodes.Add(CType(OriginationNode.Clone, TreeNode))
            DestinationNode.Expand()
            If (e.KeyState And CtrlMask) <> CtrlMask Then
                OriginationNode.Remove()
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SysMenuTree_ItemDrag -Methode

[Visual Basic]
Private Sub SysMenuTree_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As ItemDragEventArgs _
) Handles  _
   SysMenuTree.ItemDrag

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SysMenuTree_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles SysMenuTree.ItemDrag
        If e.Button = MouseButtons.Left Then
            DoDragDrop(e.Item, DragDropEffects.Move Or DragDropEffects.Copy)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.SysMenutree_DragEnter -Methode

[Visual Basic]
Private Sub SysMenutree_DragEnter( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
) Handles  _
   SysMenuTree.DragEnter

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SysMenutree_DragEnter(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenuTree.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            If (e.KeyState And CtrlMask) = CtrlMask Then
                e.Effect = DragDropEffects.Copy
            Else
                e.Effect = DragDropEffects.Move
            End If
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu.TSBtnQuit_Click -Methode

Fenster schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminMenu-Felder

frmSysadminMenu Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field itodelete

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field ssort

Unterstützt von .NET Compact Framework
private field todelete

Unterstützt von .NET Compact Framework

frmSysadminMenu -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


itodelete -Feld

[Visual Basic]
Private itodelete As Integer

Quellcode

[Visual Basic]
    Dim itodelete As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


ssort -Feld

[Visual Basic]
Private ssort As Integer

Quellcode

[Visual Basic]
    Dim ssort As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


todelete -Feld

[Visual Basic]
Private todelete As Integer()

Quellcode

[Visual Basic]
    Dim todelete(50) As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminMenu


frmSysadminTableSelector -Klasse

For a list of all members of this type, see frmSysadminTableSelector-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmSysadminTableSelector

[Visual Basic]
Public Class frmSysadminTableSelector
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmSysadminTableSelector-Member


frmSysadminTableSelector-Member

frmSysadminTableSelector Übersicht

Öffentliche Konstruktoren

public constructor frmSysadminTableSelector -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method get_tablename

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method frmSysadminTableSelector_Load

Unterstützt von .NET Compact Framework
private method listbox1_dblclick

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmSysadminTableSelector -Klasse


frmSysadminTableSelector -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector-Methoden

frmSysadminTableSelector Übersicht

Öffentliche Methoden

public method get_tablename

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method frmSysadminTableSelector_Load

Unterstützt von .NET Compact Framework
private method listbox1_dblclick

Unterstützt von .NET Compact Framework

frmSysadminTableSelector -Klasse


frmSysadminTableSelector.Dispose -Methode

[Visual Basic]
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmSysadminTableSelector))
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand
        Me.DataSet1 = New System.Data.DataSet
        Me.ListBox1 = New System.Windows.Forms.ListBox
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sysobjects", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("id", "id"), New System.Data.Common.DataColumnMapping("xtype", "xtype"), New System.Data.Common.DataColumnMapping("uid", "uid"), New System.Data.Common.DataColumnMapping("info", "info"), New System.Data.Common.DataColumnMapping("status", "status"), New System.Data.Common.DataColumnMapping("base_schema_ver", "base_schema_ver"), New System.Data.Common.DataColumnMapping("replinfo", "replinfo"), New System.Data.Common.DataColumnMapping("parent_obj", "parent_obj"), New System.Data.Common.DataColumnMapping("crdate", "crdate"), New System.Data.Common.DataColumnMapping("ftcatid", "ftcatid"), New System.Data.Common.DataColumnMapping("schema_ver", "schema_ver"), New System.Data.Common.DataColumnMapping("stats_schema_ver", "stats_schema_ver"), New System.Data.Common.DataColumnMapping("type", "type"), New System.Data.Common.DataColumnMapping("userstat", "userstat"), New System.Data.Common.DataColumnMapping("sysstat", "sysstat"), New System.Data.Common.DataColumnMapping("indexdel", "indexdel"), New System.Data.Common.DataColumnMapping("refdate", "refdate"), New System.Data.Common.DataColumnMapping("version", "version"), New System.Data.Common.DataColumnMapping("deltrig", "deltrig"), New System.Data.Common.DataColumnMapping("instrig", "instrig"), New System.Data.Common.DataColumnMapping("updtrig", "updtrig"), New System.Data.Common.DataColumnMapping("seltrig", "seltrig"), New System.Data.Common.DataColumnMapping("category", "category"), New System.Data.Common.DataColumnMapping("cache", "cache")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_sysobjects_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.AddRange(New System.Data.SqlClient.SqlParameter() {New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing), New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.NVarChar, 128, "name"), New System.Data.SqlClient.SqlParameter("@id", System.Data.SqlDbType.Int, 4, "id"), New System.Data.SqlClient.SqlParameter("@xtype", System.Data.SqlDbType.VarChar, 2, "xtype"), New System.Data.SqlClient.SqlParameter("@uid", System.Data.SqlDbType.Int, 2, "uid"), New System.Data.SqlClient.SqlParameter("@info", System.Data.SqlDbType.Int, 2, "info"), New System.Data.SqlClient.SqlParameter("@status", System.Data.SqlDbType.Int, 4, "status"), New System.Data.SqlClient.SqlParameter("@base_schema_ver", System.Data.SqlDbType.Int, 4, "base_schema_ver"), New System.Data.SqlClient.SqlParameter("@replinfo", System.Data.SqlDbType.Int, 4, "replinfo"), New System.Data.SqlClient.SqlParameter("@parent_obj", System.Data.SqlDbType.Int, 4, "parent_obj"), New System.Data.SqlClient.SqlParameter("@crdate", System.Data.SqlDbType.DateTime, 8, "crdate"), New System.Data.SqlClient.SqlParameter("@ftcatid", System.Data.SqlDbType.Int, 2, "ftcatid")})
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
            "station id=SHU;packet size=4096"
        Me.SqlConnection1.FireInfoMessageEventOnUserErrors = False
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_sysobjects_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.AddRange(New System.Data.SqlClient.SqlParameter() {New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing)})
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(8, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(240, 316)
        Me.ListBox1.TabIndex = 0
        '
        'frmSysadminTableSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(256, 349)
        Me.Controls.Add(Me.ListBox1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSysadminTableSelector"
        Me.Text = "Tabelle auswählen"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector.frmSysadminTableSelector_Load -Methode

[Visual Basic]
Private Sub frmSysadminTableSelector_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmSysadminTableSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ds As New DataSet
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("", connection)
        Dim sqlcmd As New SqlCommand

        sqlcmd.CommandText = "dbo.sp_sysobjects_select"
        sqlcmd.CommandType = CommandType.StoredProcedure
        sqlcmd.Connection = connection
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.SelectCommand = sqlcmd
            da.Fill(ds, "Datatable1")
        Catch ex As Exception
        Finally
            connection.Close()
            da.Dispose()
            sqlcmd.Dispose()
        End Try

        Dim i As Integer
        For i = 0 To ds.Tables(0).Rows.Count - 1
            Me.ListBox1.Items.Add(ds.Tables(0).Rows(i)(0))
        Next
        Me.SqlConnection1.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector.get_tablename -Methode

[Visual Basic]
Public Function get_tablename() As String

Quellcode

[Visual Basic]
    Public Function get_tablename() As String
        get_tablename = ""
        Me.ShowDialog()
        Return Me.ListBox1.SelectedItem
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector.listbox1_dblclick -Methode

[Visual Basic]
Private Sub listbox1_dblclick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ListBox1.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub listbox1_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmSysadminTableSelector-Felder

frmSysadminTableSelector Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmSysadminTableSelector -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmSysadminTableSelector


frmTest -Klasse

For a list of all members of this type, see frmTest-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmTest

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmTest
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmTest-Member


frmTest-Member

frmTest Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmTest -Klasse


frmTest-Methoden

frmTest Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework

frmTest -Klasse


frmTest.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmTest


frmTest.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Me.ContextMenuStrip1 = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.Sub1ToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ContextMenuStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ContextMenuStrip1
        '
        Me.ContextMenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.Sub1ToolStripMenuItem})
        Me.ContextMenuStrip1.Name = "ContextMenuStrip1"
        Me.ContextMenuStrip1.Size = New System.Drawing.Size(99, 26)
        '
        'Sub1ToolStripMenuItem
        '
        Me.Sub1ToolStripMenuItem.Name = "Sub1ToolStripMenuItem"
        Me.Sub1ToolStripMenuItem.Size = New System.Drawing.Size(98, 22)
        Me.Sub1ToolStripMenuItem.Text = "Sub1"
        '
        'frmTest
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(292, 273)
        Me.Name = "frmTest"
        Me.Text = "frmTest"
        Me.ContextMenuStrip1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmTest


frmTest-Felder

frmTest Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmTest -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmTest


frmVerbindungEditor -Klasse

Verbindungseditor: Verbindet 2 Domain-Tables in einer dritten Tabelle.

For a list of all members of this type, see frmVerbindungEditor-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVerbindungEditor

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVerbindungEditor
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVerbindungEditor-Member | DomainTable


frmVerbindungEditor-Member

frmVerbindungEditor Übersicht

Öffentliche Konstruktoren

public constructor frmVerbindungEditor -Konstructor

Unterstützt von .NET Compact Framework

 Laden der linken und rechten Tabelle

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method BtnFocusLeft_Click Unterstützt von .NET Compact Framework | Linker Fokus-Knopf betätigt
private method BtnFocusRight_Click Unterstützt von .NET Compact Framework | Rechter Fokus-Knopf betätigt
private method BtnVerbinden_Click Unterstützt von .NET Compact Framework | Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden
private method C1DatenBottom_AfterColUpdate Unterstützt von .NET Compact Framework | Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen
private method C1DatenBottom_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1DatenLeft_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick in linken Grid
private method C1DatenRight_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick im rechten Grid
private method FrmVerbindungEditor_Load Unterstützt von .NET Compact Framework | Laden sämlticher Tabellen
private method FrmVerbindungEditor_Resize Unterstützt von .NET Compact Framework | Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Refresh_Bottomtable Unterstützt von .NET Compact Framework | Aktualiserung der Verbindungstabelle
private method TBLeft_Click Unterstützt von .NET Compact Framework | Linke Tabelle angeklickt
private method TBRight_Click Unterstützt von .NET Compact Framework | Rechte Tabelle angeklickt
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Verbindungstabelle sichern
private method check_changes Unterstützt von .NET Compact Framework | Prüfung, ob Verbindungstabelle geändert wurde.

Felder

private field Domaintableleft

Unterstützt von .NET Compact Framework
private field Domaintableright

Unterstützt von .NET Compact Framework
private field Fokus

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field SysadminfunktionNr

Unterstützt von .NET Compact Framework
private field TablenameBottom

Unterstützt von .NET Compact Framework
private field TablenameLeft

Unterstützt von .NET Compact Framework
private field TablenameRight

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field domaintablebottom

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmVerbindungEditor -Klasse | DomainTable


frmVerbindungEditor -Konstructor

Laden der linken und rechten Tabelle

[Visual Basic]
Public Sub New( _
   ByVal TableLeft As String, _
   ByVal TableRight As String, _
   ByVal TableBottom As String, _
   ByVal SysadminfnktNr As Integer _
)

Parameter

TableLeft
TableRight
TableBottom
SysadminfnktNr

Quellcode

[Visual Basic]
    Public Sub New(ByVal TableLeft As String, ByVal TableRight As String, ByVal TableBottom As String, ByVal SysadminfnktNr As Integer)
        InitializeComponent()
        Me.Domaintableleft = New TKB.VV.Sysadmin.DomainTable(TableLeft)
        Me.Domaintableright = New TKB.VV.Sysadmin.DomainTable(TableRight)
        Me.TablenameLeft = TableLeft
        Me.TablenameRight = TableRight
        Me.TablenameBottom = TableBottom
        Me.SysadminfunktionNr = SysadminfnktNr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor-Methoden

frmVerbindungEditor Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method BtnFocusLeft_Click Unterstützt von .NET Compact Framework | Linker Fokus-Knopf betätigt
private method BtnFocusRight_Click Unterstützt von .NET Compact Framework | Rechter Fokus-Knopf betätigt
private method BtnVerbinden_Click Unterstützt von .NET Compact Framework | Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden
private method C1DatenBottom_AfterColUpdate Unterstützt von .NET Compact Framework | Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen
private method C1DatenBottom_FetchCellTips Unterstützt von .NET Compact Framework | Anzeige allfälliger Cellen-Tips
private method C1DatenLeft_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick in linken Grid
private method C1DatenRight_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick im rechten Grid
private method FrmVerbindungEditor_Load Unterstützt von .NET Compact Framework | Laden sämlticher Tabellen
private method FrmVerbindungEditor_Resize Unterstützt von .NET Compact Framework | Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Refresh_Bottomtable Unterstützt von .NET Compact Framework | Aktualiserung der Verbindungstabelle
private method TBLeft_Click Unterstützt von .NET Compact Framework | Linke Tabelle angeklickt
private method TBRight_Click Unterstützt von .NET Compact Framework | Rechte Tabelle angeklickt
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Verbindungstabelle sichern
private method check_changes Unterstützt von .NET Compact Framework | Prüfung, ob Verbindungstabelle geändert wurde.

frmVerbindungEditor -Klasse | DomainTable


frmVerbindungEditor.BeendenToolStripMenuItem_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        check_changes()
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.BtnFocusLeft_Click -Methode

Linker Fokus-Knopf betätigt

[Visual Basic]
Private Sub BtnFocusLeft_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnFocusLeft.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnFocusLeft_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnFocusLeft.Click
        Fokus = 1
        Me.BtnFocusLeft.ImageIndex = 1
        Me.BtnFocusRight.ImageIndex = 2
        Refresh_Bottomtable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.BtnFocusRight_Click -Methode

Rechter Fokus-Knopf betätigt

[Visual Basic]
Private Sub BtnFocusRight_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnFocusRight.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnFocusRight_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnFocusRight.Click
        Me.Fokus = 2
        Me.BtnFocusRight.ImageIndex = 1
        Me.BtnFocusLeft.ImageIndex = 2
        Refresh_Bottomtable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.BtnVerbinden_Click -Methode

Die linke und rechte Domain-Table in der unteren Tabelle verbinden. Daten sichern und erneut laden

[Visual Basic]
Private Sub BtnVerbinden_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnVerbinden.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnVerbinden_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnVerbinden.Click
        check_changes()
        Dim ileft As Integer = Me.C1DatenLeft.SelectedRows.Count
        Dim iright As Integer = Me.C1DatenRight.SelectedRows.Count
        Dim ic As Integer = 0
        Dim Currentsel As Boolean
        Dim colrows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim keyvalueleft As Integer = 0
        Dim Keyvalueright As Integer = 0
        If (Me.Fokus = 1 And ileft > 1) Or (Me.Fokus = 2 And iright > 1) Then
            Me.msg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.Fokus = 1 Then
            ic = iright
            colrows = Me.C1DatenRight.SelectedRows
        End If
        If Me.Fokus = 2 Then
            ic = ileft
            colrows = Me.C1DatenLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        Dim i As Integer
        For i = 0 To ic - 1
            If Me.Fokus = 1 Then
                keyvalueleft = Me.C1DatenLeft.Columns(0).Value
                If Currentsel = True Then
                    Keyvalueright = Me.C1DatenRight.Columns(0).Value
                Else
                    Keyvalueright = Me.C1DatenRight.Columns(0).CellValue(colrows(i))
                End If
            Else
                Keyvalueright = Me.C1DatenRight.Columns(0).Value
                If Currentsel = True Then
                    keyvalueleft = Me.C1DatenLeft.Columns(0).Value
                Else
                    keyvalueleft = Me.C1DatenLeft.Columns(0).CellValue(colrows(i))
                End If
            End If
        Next
        Me.domaintablebottom.Insert_Bottom_Table(Me.Domaintableleft.Tabledata.Tables(0).Columns(0).ColumnName, keyvalueleft, Me.Domaintableright.Tabledata.Tables(0).Columns(0).ColumnName, Keyvalueright)
        Me.domaintablebottom.Save_Data()
        Me.Refresh_Bottomtable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.C1DatenBottom_AfterColUpdate -Methode

Nach Datenmutation der unteren Tabelle mutiert_am und mutierer nachführen

[Visual Basic]
Private Sub C1DatenBottom_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As ColEventArgs _
) Handles  _
   C1DatenBottom.AfterColUpdate

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1DatenBottom_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1DatenBottom.AfterColUpdate
        Dim i As Integer
        For i = 0 To Me.C1DatenBottom.Columns.Count - 1
            If LCase(Me.C1DatenBottom.Columns(i).DataField) = "mutiert_am" Then Me.C1DatenBottom.Columns(i).Value = Now
            If LCase(Me.C1DatenBottom.Columns(i).DataField) = "mutierer" Then Me.C1DatenBottom.Columns(i).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.C1DatenBottom_FetchCellTips -Methode

Anzeige allfälliger Cellen-Tips

[Visual Basic]
Private Sub C1DatenBottom_FetchCellTips( _
   ByVal sender As Object, _
   ByVal e As FetchCellTipsEventArgs _
) Handles  _
   C1DatenBottom.FetchCellTips

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1DatenBottom_FetchCellTips(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles C1DatenBottom.FetchCellTips
        Dim ts As New TKB.VV.Utils.Tabellenspalte
        ts.Tabelle = Me.TablenameBottom
        Try
            ts.Feld = Me.C1DatenBottom.Columns(e.ColIndex).DataField.ToString
            ts.getspalte()
            e.CellTip = ts.TipText
        Catch
        End Try
        ts = Nothing

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.C1DatenLeft_DoubleClick -Methode

Doppelklick in linken Grid

[Visual Basic]
Private Sub C1DatenLeft_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1DatenLeft.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1DatenLeft_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1DatenLeft.DoubleClick
        Try
            Me.BtnVerbinden_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.C1DatenRight_DoubleClick -Methode

Doppelklick im rechten Grid

[Visual Basic]
Private Sub C1DatenRight_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1DatenRight.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1DatenRight_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1DatenRight.DoubleClick
        Try
            Me.BtnVerbinden_Click(sender, e)
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.FrmVerbindungEditor_Load -Methode

Laden sämlticher Tabellen

[Visual Basic]
Private Sub FrmVerbindungEditor_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmVerbindungEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1DatenLeft.DataSource = Domaintableleft.Tabledata
        Me.C1DatenLeft.DataMember = Domaintableleft.Tabledata.Tables(0).TableName

        Me.C1DatenRight.DataSource = Domaintableright.Tabledata
        Me.C1DatenRight.DataMember = Domaintableright.Tabledata.Tables(0).TableName

        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DatenLeft, TablenameLeft, Me.Domaintableleft.Tabledata)
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DatenRight, TablenameRight, Me.Domaintableright.Tabledata)

        Refresh_Bottomtable()

        Me.C1DatenLeft.AllowAddNew = False
        Me.C1DatenLeft.AllowDelete = False
        Me.C1DatenLeft.AllowUpdate = False

        Me.C1DatenRight.AllowAddNew = False
        Me.C1DatenRight.AllowDelete = False
        Me.C1DatenRight.AllowUpdate = False

        Me.C1DatenBottom.AllowAddNew = False
        Me.C1DatenBottom.AllowDelete = False

        Me.GrpBoxLeft.Text = Me.TablenameLeft
        Me.GrpBoxRight.Text = Me.TablenameRight
        Me.GrpBoxBottom.Text = Me.TablenameBottom
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.FrmVerbindungEditor_Resize -Methode

Formular-Resize: Button Verbinden und Button Focus-Rechts neu positionieren

[Visual Basic]
Private Sub FrmVerbindungEditor_Resize( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Resize

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmVerbindungEditor_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Resize
        Me.BtnFocusRight.Left = Me.Width - (Me.BtnFocusRight.Width + 10)
        Me.BtnVerbinden.Left = Me.SplitContainer2.Panel1.Width - (Me.BtnVerbinden.Width / 2)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVerbindungEditor))
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.SplitContainer2 = New System.Windows.Forms.SplitContainer
        Me.GrpBoxLeft = New System.Windows.Forms.GroupBox
        Me.C1DatenLeft = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.GrpBoxRight = New System.Windows.Forms.GroupBox
        Me.C1DatenRight = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Panel1 = New System.Windows.Forms.Panel
        Me.BtnFocusRight = New System.Windows.Forms.Button
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.BtnFocusLeft = New System.Windows.Forms.Button
        Me.BtnVerbinden = New System.Windows.Forms.Button
        Me.GrpBoxBottom = New System.Windows.Forms.GroupBox
        Me.C1DatenBottom = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ToolStrip1.SuspendLayout()
        Me.MenuStrip1.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.SplitContainer2.Panel1.SuspendLayout()
        Me.SplitContainer2.Panel2.SuspendLayout()
        Me.SplitContainer2.SuspendLayout()
        Me.GrpBoxLeft.SuspendLayout()
        CType(Me.C1DatenLeft, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpBoxRight.SuspendLayout()
        CType(Me.C1DatenRight, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.GrpBoxBottom.SuspendLayout()
        CType(Me.C1DatenBottom, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(953, 25)
        Me.ToolStrip1.TabIndex = 3
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(953, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        Me.SplitContainer1.Orientation = System.Windows.Forms.Orientation.Horizontal
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.SplitContainer2)
        Me.SplitContainer1.Panel1.Controls.Add(Me.Panel1)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.GrpBoxBottom)
        Me.SplitContainer1.Size = New System.Drawing.Size(953, 466)
        Me.SplitContainer1.SplitterDistance = 276
        Me.SplitContainer1.TabIndex = 4
        '
        'SplitContainer2
        '
        Me.SplitContainer2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer2.Location = New System.Drawing.Point(0, 0)
        Me.SplitContainer2.Name = "SplitContainer2"
        '
        'SplitContainer2.Panel1
        '
        Me.SplitContainer2.Panel1.Controls.Add(Me.GrpBoxLeft)
        '
        'SplitContainer2.Panel2
        '
        Me.SplitContainer2.Panel2.Controls.Add(Me.GrpBoxRight)
        Me.SplitContainer2.Size = New System.Drawing.Size(953, 243)
        Me.SplitContainer2.SplitterDistance = 467
        Me.SplitContainer2.TabIndex = 1
        '
        'GrpBoxLeft
        '
        Me.GrpBoxLeft.Controls.Add(Me.C1DatenLeft)
        Me.GrpBoxLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxLeft.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxLeft.Name = "GrpBoxLeft"
        Me.GrpBoxLeft.Size = New System.Drawing.Size(467, 243)
        Me.GrpBoxLeft.TabIndex = 0
        Me.GrpBoxLeft.TabStop = False
        Me.GrpBoxLeft.Text = "GroupBox1"
        '
        'C1DatenLeft
        '
        Me.C1DatenLeft.AlternatingRows = True
        Me.C1DatenLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenLeft.FilterBar = True
        Me.C1DatenLeft.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenLeft.Images.Add(CType(resources.GetObject("C1DatenLeft.Images"), System.Drawing.Image))
        Me.C1DatenLeft.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenLeft.Name = "C1DatenLeft"
        Me.C1DatenLeft.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenLeft.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenLeft.PreviewInfo.ZoomFactor = 75
        Me.C1DatenLeft.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenLeft.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenLeft.Size = New System.Drawing.Size(461, 224)
        Me.C1DatenLeft.TabIndex = 4
        Me.C1DatenLeft.Text = "C1TrueDBGrid1"
        Me.C1DatenLeft.PropBag = resources.GetString("C1DatenLeft.PropBag")
        '
        'GrpBoxRight
        '
        Me.GrpBoxRight.Controls.Add(Me.C1DatenRight)
        Me.GrpBoxRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxRight.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxRight.Name = "GrpBoxRight"
        Me.GrpBoxRight.Size = New System.Drawing.Size(482, 243)
        Me.GrpBoxRight.TabIndex = 1
        Me.GrpBoxRight.TabStop = False
        Me.GrpBoxRight.Text = "GroupBox1"
        '
        'C1DatenRight
        '
        Me.C1DatenRight.AlternatingRows = True
        Me.C1DatenRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenRight.FilterBar = True
        Me.C1DatenRight.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenRight.Images.Add(CType(resources.GetObject("C1DatenRight.Images"), System.Drawing.Image))
        Me.C1DatenRight.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenRight.Name = "C1DatenRight"
        Me.C1DatenRight.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenRight.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenRight.PreviewInfo.ZoomFactor = 75
        Me.C1DatenRight.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenRight.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenRight.Size = New System.Drawing.Size(476, 224)
        Me.C1DatenRight.TabIndex = 4
        Me.C1DatenRight.Text = "C1TrueDBGrid1"
        Me.C1DatenRight.PropBag = resources.GetString("C1DatenRight.PropBag")
        '
        'Panel1
        '
        Me.Panel1.Controls.Add(Me.BtnFocusRight)
        Me.Panel1.Controls.Add(Me.BtnFocusLeft)
        Me.Panel1.Controls.Add(Me.BtnVerbinden)
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(0, 243)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(953, 33)
        Me.Panel1.TabIndex = 0
        '
        'BtnFocusRight
        '
        Me.BtnFocusRight.ImageIndex = 2
        Me.BtnFocusRight.ImageList = Me.ImageList1
        Me.BtnFocusRight.Location = New System.Drawing.Point(920, 3)
        Me.BtnFocusRight.Name = "BtnFocusRight"
        Me.BtnFocusRight.Size = New System.Drawing.Size(30, 23)
        Me.BtnFocusRight.TabIndex = 2
        Me.BtnFocusRight.UseVisualStyleBackColor = True
        '
        'ImageList1
        '
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageList1.Images.SetKeyName(0, "Kette3.ico")
        Me.ImageList1.Images.SetKeyName(1, "Haken1.ico")
        Me.ImageList1.Images.SetKeyName(2, "Haken2.ico")
        '
        'BtnFocusLeft
        '
        Me.BtnFocusLeft.ImageIndex = 1
        Me.BtnFocusLeft.ImageList = Me.ImageList1
        Me.BtnFocusLeft.Location = New System.Drawing.Point(6, 4)
        Me.BtnFocusLeft.Name = "BtnFocusLeft"
        Me.BtnFocusLeft.Size = New System.Drawing.Size(30, 23)
        Me.BtnFocusLeft.TabIndex = 1
        Me.BtnFocusLeft.UseVisualStyleBackColor = True
        '
        'BtnVerbinden
        '
        Me.BtnVerbinden.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.BtnVerbinden.ImageIndex = 0
        Me.BtnVerbinden.ImageList = Me.ImageList1
        Me.BtnVerbinden.Location = New System.Drawing.Point(430, 4)
        Me.BtnVerbinden.Name = "BtnVerbinden"
        Me.BtnVerbinden.Size = New System.Drawing.Size(84, 23)
        Me.BtnVerbinden.TabIndex = 0
        Me.BtnVerbinden.Text = "Verbinden"
        Me.BtnVerbinden.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.BtnVerbinden.UseVisualStyleBackColor = True
        '
        'GrpBoxBottom
        '
        Me.GrpBoxBottom.Controls.Add(Me.C1DatenBottom)
        Me.GrpBoxBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBoxBottom.Location = New System.Drawing.Point(0, 0)
        Me.GrpBoxBottom.Name = "GrpBoxBottom"
        Me.GrpBoxBottom.Size = New System.Drawing.Size(953, 186)
        Me.GrpBoxBottom.TabIndex = 2
        Me.GrpBoxBottom.TabStop = False
        Me.GrpBoxBottom.Text = "GroupBox1"
        '
        'C1DatenBottom
        '
        Me.C1DatenBottom.AlternatingRows = True
        Me.C1DatenBottom.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Floating
        Me.C1DatenBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1DatenBottom.FilterBar = True
        Me.C1DatenBottom.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1DatenBottom.Images.Add(CType(resources.GetObject("C1DatenBottom.Images"), System.Drawing.Image))
        Me.C1DatenBottom.Location = New System.Drawing.Point(3, 16)
        Me.C1DatenBottom.Name = "C1DatenBottom"
        Me.C1DatenBottom.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1DatenBottom.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1DatenBottom.PreviewInfo.ZoomFactor = 75
        Me.C1DatenBottom.PrintInfo.PageSettings = CType(resources.GetObject("C1DatenBottom.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1DatenBottom.Size = New System.Drawing.Size(947, 167)
        Me.C1DatenBottom.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1DatenBottom.TabIndex = 4
        Me.C1DatenBottom.Text = "C1TrueDBGrid1"
        Me.C1DatenBottom.PropBag = resources.GetString("C1DatenBottom.PropBag")
        '
        'frmVerbindungEditor
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(953, 515)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVerbindungEditor"
        Me.Text = "VerbindungEditor"
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.SplitContainer2.Panel1.ResumeLayout(False)
        Me.SplitContainer2.Panel2.ResumeLayout(False)
        Me.SplitContainer2.ResumeLayout(False)
        Me.GrpBoxLeft.ResumeLayout(False)
        CType(Me.C1DatenLeft, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpBoxRight.ResumeLayout(False)
        CType(Me.C1DatenRight, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.GrpBoxBottom.ResumeLayout(False)
        CType(Me.C1DatenBottom, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.Refresh_Bottomtable -Methode

Aktualiserung der Verbindungstabelle

[Visual Basic]
Private Sub Refresh_Bottomtable()

Quellcode

[Visual Basic]
    Private Sub Refresh_Bottomtable()
        Try
            check_changes()
            Me.domaintablebottom.dispose()
        Catch
        End Try

        Dim keyvalue As String = ""

        If Fokus = 1 Then
            keyvalue = Me.C1DatenLeft.Columns(0).Value
        Else
            keyvalue = Me.C1DatenRight.Columns(0).Value
        End If
        Me.domaintablebottom = New TKB.VV.Sysadmin.DomainTable(Me.TablenameBottom, Fokus, keyvalue)
        Me.C1DatenBottom.DataSource = domaintablebottom.Tabledata
        Me.C1DatenBottom.DataMember = domaintablebottom.Tabledata.Tables(0).TableName
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1DatenBottom, TablenameBottom, Me.domaintablebottom.Tabledata)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.TBLeft_Click -Methode

Linke Tabelle angeklickt

[Visual Basic]
Private Sub TBLeft_Click( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1DatenLeft.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1DatenLeft.RowColChange
        check_changes()
        Refresh_Bottomtable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.TBRight_Click -Methode

Rechte Tabelle angeklickt

[Visual Basic]
Private Sub TBRight_Click( _
   ByVal sender As Object, _
   ByVal e As RowColChangeEventArgs _
) Handles  _
   C1DatenRight.RowColChange

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles C1DatenRight.RowColChange
        check_changes()
        Refresh_Bottomtable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        check_changes()
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.TSBtnSave_Click -Methode

Verbindungstabelle sichern

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.domaintablebottom.Save_Data()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor.check_changes -Methode

Prüfung, ob Verbindungstabelle geändert wurde.

[Visual Basic]
Private Sub check_changes()

Quellcode

[Visual Basic]
    Private Sub check_changes()
        Dim msgres As MsgBoxResult
        If Me.domaintablebottom.Tabledata.HasChanges Then
            msgres = msg.Show_MessageYesNo(3)
            If msgres = MsgBoxResult.Yes Then
                Me.domaintablebottom.Save_Data()
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVerbindungEditor-Felder

frmVerbindungEditor Übersicht

Felder

private field Domaintableleft

Unterstützt von .NET Compact Framework
private field Domaintableright

Unterstützt von .NET Compact Framework
private field Fokus

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field SysadminfunktionNr

Unterstützt von .NET Compact Framework
private field TablenameBottom

Unterstützt von .NET Compact Framework
private field TablenameLeft

Unterstützt von .NET Compact Framework
private field TablenameRight

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field domaintablebottom

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework

frmVerbindungEditor -Klasse | DomainTable


Domaintableleft -Feld

[Visual Basic]
Private Domaintableleft As DomainTable

Quellcode

[Visual Basic]
    Dim Domaintableleft As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


Domaintableright -Feld

[Visual Basic]
Private Domaintableright As DomainTable

Quellcode

[Visual Basic]
    Dim Domaintableright As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


Fokus -Feld

[Visual Basic]
Private Fokus As Integer

Quellcode

[Visual Basic]
    Dim Fokus As Integer = 1

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


SysadminfunktionNr -Feld

[Visual Basic]
Private SysadminfunktionNr As Integer

Quellcode

[Visual Basic]
    Dim SysadminfunktionNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


TablenameBottom -Feld

[Visual Basic]
Private TablenameBottom As String

Quellcode

[Visual Basic]
    Dim TablenameBottom As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


TablenameLeft -Feld

[Visual Basic]
Private TablenameLeft As String

Quellcode

[Visual Basic]
    Dim TablenameLeft As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


TablenameRight -Feld

[Visual Basic]
Private TablenameRight As String

Quellcode

[Visual Basic]
    Dim TablenameRight As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


domaintablebottom -Feld

[Visual Basic]
Private domaintablebottom As DomainTable

Quellcode

[Visual Basic]
    Dim domaintablebottom As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVerbindungEditor


frmVertragselement -Klasse

For a list of all members of this type, see frmVertragselement-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragselement

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragselement
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragselement-Member


frmVertragselement-Member

frmVertragselement Übersicht

Öffentliche Konstruktoren

public constructor frmVertragselement -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ApplikationAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Applikation anzeigen
private method ApplikationInaktivierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Applikation inaktivieren
private method ApplikationLizenzenVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ApplikationNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Applikation hinzufügen
private method ApplikationenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Aktivitaeten_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Ereignissen
private method C1Aktivitaeten_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Applikationen_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einen Applikationseintrag
private method C1Applikationen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Applikationen
private method C1Applikationen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Dokumenten
private method C1Dokumente_MouseDown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Ereignisse_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Vertragsereignis
private method C1Ereignisse_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Ereignissen
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Kuendigungsfristen_DoubleClick Unterstützt von .NET Compact Framework | Kuendigungsfrist bearbeiten / anzeigen
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Kuendigungsfristen_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kündigungsfristen
private method C1Pendenzen_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf eine Pendenz
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Referenzvertraege_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Referenz-Eintrag
private method C1Referenzvertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Vertragsreferenzen
private method C1Referenzvertraege_MouseDown Unterstützt von .NET Compact Framework | Mousedown
private method C1Services_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf eine Pendenz
private method C1Services_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Vertragsleistungen
private method C1Services_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Vertragsereignis_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method CPendenzen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method ClosingForm Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen (Dialog)
private method DokumentAnzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen - effektives Dokument
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Dokument generieren und anzeigen
private method DokumenteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method EreignisAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsereignis anzeigen (Dialog)
private method EreignisLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method EreignisMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method EreignisNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Vertragsereignis erstellen
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method KontaktLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method KuendigungsfristBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method KuendigungsfristLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kuendigungsfrist inaktivieren
private method KuendigungsfristMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method KuendigungsfristNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist erstellen
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method PendenzAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Pendenz anzeigen
private method PendenzLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method PendenzNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Pendenz erstellen
private method PendenzenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method ReferenzAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsrefernz anzeigen
private method ReferenzLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Inaktivieren eines Eintrages
private method ReferenzNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Vertragsreferenz
private method ReferenzenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method Refresh_Aktivitaeten Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Applikationen Unterstützt von .NET Compact Framework | Applikationen aktualiseren
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_History Unterstützt von .NET Compact Framework | History Aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kündigungsfristen aktualisieren
private method Refresh_Pendenzen Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Registerlasche Unterstützt von .NET Compact Framework | Aktuelle Registerlasche aktualisieren
private method Refresh_SLATable Unterstützt von .NET Compact Framework |
private method Refresh_Services Unterstützt von .NET Compact Framework | Services aktualiseren
private method Refresh_Vertragselement_Referenzen Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Vertragsereignisse Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method ServiceAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsleistung anzeigen
private method ServiceLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsleistung inaktivieren
private method ServiceMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method ServiceNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Vertragsleistung erstellen
private method Set_Titel Unterstützt von .NET Compact Framework |
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TabControlDiverse_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlDiverse
private method ToolStripMenuItem1_Click Unterstützt von .NET Compact Framework |
private method btnSearchAppl_Click Unterstützt von .NET Compact Framework |
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen. Sofern dieser gewechselt wird, die Parentid des Vertragselementes auf 0 setzen und cbboxParentTree neu aufbauen
private method cbboxParentTree_AfterSelect Unterstützt von .NET Compact Framework | Änderung des Parent-Auswahl. Prüfung, ob das Element ausgewählt werden kann
private method cboxVertragstyp_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method evh_FormularPendenz_Closed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragselementApplikation_Closed Unterstützt von .NET Compact Framework | Ereignis bei geschlossenem Applikationsfesnter
private method frmVertragselement_Load Unterstützt von .NET Compact Framework | Load-Methode
private method frmVertragselement_Shown Unterstützt von .NET Compact Framework | Shown-Ereigns
private method txtBezeichnung_TextChanged Unterstützt von .NET Compact Framework |
private method txtVertragsende_Leave Unterstützt von .NET Compact Framework |

Felder

private field Aktueller_Vertragspartner

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field ApplTree

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field On_Load

Unterstützt von .NET Compact Framework
private field Save_ApplicationTabPage

Unterstützt von .NET Compact Framework
private field Save_LizenzTabPage

Unterstützt von .NET Compact Framework
private field Save_Vertragstyp

Unterstützt von .NET Compact Framework
private field ServiceKatalogSLAKatalog

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragselement -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void frmVertragselement();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Boolean, Optional Boolean, Optional Integer)
[C#] public System.Void frmVertragselement(int, bool, bool, int);

frmVertragselement


frmVertragselement-Methoden

frmVertragselement Übersicht

Geschützte Methoden

protected method Dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method ApplikationAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Applikation anzeigen
private method ApplikationInaktivierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Applikation inaktivieren
private method ApplikationLizenzenVerwaltenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ApplikationNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Applikation hinzufügen
private method ApplikationenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Aktivitaeten_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Ereignissen
private method C1Aktivitaeten_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Applikationen_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einen Applikationseintrag
private method C1Applikationen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Applikationen
private method C1Applikationen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Dokumenten
private method C1Dokumente_MouseDown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Ereignisse_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Vertragsereignis
private method C1Ereignisse_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Ereignissen
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Kontakt
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kontakten
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Kuendigungsfristen_DoubleClick Unterstützt von .NET Compact Framework | Kuendigungsfrist bearbeiten / anzeigen
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Kündigungsfristen
private method C1Kuendigungsfristen_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kündigungsfristen
private method C1Pendenzen_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf eine Pendenz
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Pendenzen
private method C1Referenzvertraege_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf einem Referenz-Eintrag
private method C1Referenzvertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Vertragsreferenzen
private method C1Referenzvertraege_MouseDown Unterstützt von .NET Compact Framework | Mousedown
private method C1Services_DoubleClick Unterstützt von .NET Compact Framework | Doppelklick auf eine Pendenz
private method C1Services_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Vertragsleistungen
private method C1Services_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method C1Vertragsereignis_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method CPendenzen_Mousedown Unterstützt von .NET Compact Framework | Positionierung im Grid
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method ClosingForm Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen (Dialog)
private method DokumentAnzeigen_Dokument_ToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument anzeigen - effektives Dokument
private method DokumentLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method DokumentNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Dokument generieren und anzeigen
private method DokumenteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method EreignisAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsereignis anzeigen (Dialog)
private method EreignisLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method EreignisMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method EreignisNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Vertragsereignis erstellen
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Anzeigen bzw. bearbeitnen eines Kontaktes
private method KontaktLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragskontakt inaktivieren
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragskontakt erstellen
private method KontakteMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method KuendigungsfristBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method KuendigungsfristLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kuendigungsfrist inaktivieren
private method KuendigungsfristMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method KuendigungsfristNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist erstellen
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method PendenzAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Pendenz anzeigen
private method PendenzLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument inaktivieren
private method PendenzNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Pendenz erstellen
private method PendenzenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method ReferenzAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsrefernz anzeigen
private method ReferenzLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Inaktivieren eines Eintrages
private method ReferenzNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Vertragsreferenz
private method ReferenzenMenuStrip_Opening Unterstützt von .NET Compact Framework | Handelt das Opending-Ereignis des Context-Menus
private method Refresh_Aktivitaeten Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Applikationen Unterstützt von .NET Compact Framework | Applikationen aktualiseren
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumetne_Aktualisieren
private method Refresh_History Unterstützt von .NET Compact Framework | History Aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kündigungsfristen aktualisieren
private method Refresh_Pendenzen Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Registerlasche Unterstützt von .NET Compact Framework | Aktuelle Registerlasche aktualisieren
private method Refresh_SLATable Unterstützt von .NET Compact Framework |
private method Refresh_Services Unterstützt von .NET Compact Framework | Services aktualiseren
private method Refresh_Vertragselement_Referenzen Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Refresh_Vertragsereignisse Unterstützt von .NET Compact Framework | Vertragsereignisse aktualiseren
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method ServiceAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsleistung anzeigen
private method ServiceLoeschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragsleistung inaktivieren
private method ServiceMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method ServiceNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neue Vertragsleistung erstellen
private method Set_Titel Unterstützt von .NET Compact Framework |
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TabControlDiverse_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlDiverse
private method ToolStripMenuItem1_Click Unterstützt von .NET Compact Framework |
private method btnSearchAppl_Click Unterstützt von .NET Compact Framework |
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen. Sofern dieser gewechselt wird, die Parentid des Vertragselementes auf 0 setzen und cbboxParentTree neu aufbauen
private method cbboxParentTree_AfterSelect Unterstützt von .NET Compact Framework | Änderung des Parent-Auswahl. Prüfung, ob das Element ausgewählt werden kann
private method cboxVertragstyp_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method evh_FormularPendenz_Closed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragselementApplikation_Closed Unterstützt von .NET Compact Framework | Ereignis bei geschlossenem Applikationsfesnter
private method frmVertragselement_Load Unterstützt von .NET Compact Framework | Load-Methode
private method frmVertragselement_Shown Unterstützt von .NET Compact Framework | Shown-Ereigns
private method txtBezeichnung_TextChanged Unterstützt von .NET Compact Framework |
private method txtVertragsende_Leave Unterstützt von .NET Compact Framework |

frmVertragselement -Klasse


frmVertragselement.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
        AddHandler txtBeschreibung.TextChanged, evh
        AddHandler txtSuchbegriffe.TextChanged, evh
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ApplikationAnzeigenToolStripMenuItem_Click -Methode

Applikation anzeigen

[Visual Basic]
Private Sub ApplikationAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationAnzeigenToolStripMenuItem.Click
        Dim f As New frmApplikation(Me.C1Applikationen.Columns(2).Value, False)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ApplikationInaktivierenToolStripMenuItem_Click -Methode

Applikation inaktivieren

[Visual Basic]
Private Sub ApplikationInaktivierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationInaktivierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationInaktivierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationInaktivierenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(295) = MsgBoxResult.Yes Then
                Me.Vertragselement.VertragselementApplikation.Delete_VertragselementApplikation(Me.C1Applikationen.Columns("VertragselementApplikationNr").Value)
                evh.Vertragsapplikation_Geloescht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ApplikationLizenzenVerwaltenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ApplikationLizenzenVerwaltenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationLizenzenVerwaltenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationLizenzenVerwaltenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationLizenzenVerwaltenToolStripMenuItem.Click
        Dim f As New FrmLizenz(Me.Vertragselement.iVertragselementnr.Value, Me.C1Applikationen.Columns("Applikationnr").Value, Me.FormReadonly)
        f.ShowDialog()
        Me.Refresh_Applikationen()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ApplikationNeuToolStripMenuItem_Click -Methode

Neue Applikation hinzufügen

[Visual Basic]
Private Sub ApplikationNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationNeuToolStripMenuItem.Click
        Try
            Dim f As New frmVertragselementApplikation(Me.Aktuelles_Vertragselement)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ApplikationenMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub ApplikationenMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   ApplikationenMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub ApplikationenMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles ApplikationenMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Applikationen)
        If Me.Vertragselement.Lizenzinformationen.Check_Vertragstyp_Fuer_Lizenz(Me.Save_Vertragstyp) Then
            Me.ApplikationLizenzenVerwaltenToolStripMenuItem.Visible = True
        Else
            Me.ApplikationLizenzenVerwaltenToolStripMenuItem.Visible = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Aktivitaeten_FetchRowStyle -Methode

Rowstyle von inaktiven Ereignissen

[Visual Basic]
Private Sub C1Aktivitaeten_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   c1Aktivitaeten.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Aktivitaeten_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles c1Aktivitaeten.FetchRowStyle
        Try
            If Me.c1Aktivitaeten.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Aktivitaeten_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Aktivitaeten_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   c1Aktivitaeten.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Aktivitaeten_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles c1Aktivitaeten.MouseDown
        Me.c1Aktivitaeten.Bookmark = Me.c1Aktivitaeten.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Applikationen_DoubleClick -Methode

Doppelklick auf einen Applikationseintrag

[Visual Basic]
Private Sub C1Applikationen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Applikationen.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Applikationen.DoubleClick
        If Me.ApplikationAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.ApplikationAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Applikationen_FetchRowStyle -Methode

Rowstyle von inaktiven Applikationen

[Visual Basic]
Private Sub C1Applikationen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Applikationen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Applikationen.FetchRowStyle
        Try
            If Me.C1Applikationen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Applikationen_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Applikationen_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Applikationen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Applikationen.MouseDown
        Me.C1Applikationen.Bookmark = Me.C1Applikationen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Dokumente_DoubleClick -Methode

Doppelklick eines Eintrages - Dokument-Anzeige (Dialog)

[Visual Basic]
Private Sub C1Dokumente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Dokumente.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button DokumentAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Dokumente.DoubleClick
        If Me.DokumentAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.DokumentAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Dokumente_FetchRowStyle -Methode

Rowstyle von inaktiven Dokumenten

[Visual Basic]
Private Sub C1Dokumente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Dokumente.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Dokumente.FetchRowStyle
        Try
            If Me.C1Dokumente.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Dokumente_MouseDown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Dokumente_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Dokumente.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Dokumente.MouseDown
        Me.C1Dokumente.Bookmark = Me.C1Dokumente.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Ereignisse_DoubleClick -Methode

Doppelklick auf einem Vertragsereignis

[Visual Basic]
Private Sub C1Ereignisse_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Ereignisse.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button EreignisAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Ereignisse_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Ereignisse.DoubleClick
        If Me.EreignisAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.EreignisAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Ereignisse_FetchRowStyle -Methode

Rowstyle von inaktiven Ereignissen

[Visual Basic]
Private Sub C1Ereignisse_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Ereignisse.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Ereignisse_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Ereignisse.FetchRowStyle
        Try
            If Me.C1Ereignisse.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kontakte_DoubleClick -Methode

Doppelklick auf einem Kontakt

[Visual Basic]
Private Sub C1Kontakte_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.DoubleClick

Parameter

sender
e

Hinweise

Ist der MenuEintrag KontaktAnzeigenToolStripMenuItem disabled, wird der Doppelklick ignoriert

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Kontakte.DoubleClick

        If Me.KontaktAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            Me.KontaktAnzeigenToolStripMenuItem_Click(sender, e)

        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kontakte_FetchRowStyle -Methode

Rowstyle von inaktiven Kontakten

[Visual Basic]
Private Sub C1Kontakte_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontakte.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontakte.FetchRowStyle
        Try
            If Me.C1Kontakte.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kontakte_MouseDown -Methode

Mousedown Kontakte

[Visual Basic]
Private Sub C1Kontakte_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontakte.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontakte.MouseDown
        Me.C1Kontakte.Bookmark = Me.C1Kontakte.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kuendigungsfristen_DoubleClick -Methode

Kuendigungsfrist bearbeiten / anzeigen

[Visual Basic]
Private Sub C1Kuendigungsfristen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kuendigungsfristen.DoubleClick

Parameter

sender
e

Hinweise

Ist der MenuEintrag KuendigungsfristBearbeitenToolStripMenuItem disabled, wird der Doppelklick ignoriert

Quellcode

[Visual Basic]
    Private Sub C1Kuendigungsfristen_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles C1Kuendigungsfristen.DoubleClick
        If Me.KuendigungsfristBearbeitenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            KuendigungsfristBearbeitenToolStripMenuItem_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kuendigungsfristen_FetchRowStyle -Methode

Rowstyle von inaktiven Kündigungsfristen

[Visual Basic]
Private Sub C1Kuendigungsfristen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kuendigungsfristen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kuendigungsfristen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kuendigungsfristen.FetchRowStyle
        Try
            If Me.C1Kuendigungsfristen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Kuendigungsfristen_MouseDown -Methode

Mousedown Kündigungsfristen

[Visual Basic]
Private Sub C1Kuendigungsfristen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kuendigungsfristen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kuendigungsfristen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kuendigungsfristen.MouseDown
        Me.C1Kuendigungsfristen.Bookmark = Me.C1Kuendigungsfristen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Pendenzen_DoubleClick -Methode

Doppelklick auf eine Pendenz

[Visual Basic]
Private Sub C1Pendenzen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Pendenzen.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button PendenzAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Pendenzen.DoubleClick
        If Me.PendenzAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.PendenzAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Pendenzen_FetchRowStyle -Methode

Rowstyle von inaktiven Pendenzen

[Visual Basic]
Private Sub C1Pendenzen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Pendenzen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Pendenzen.FetchRowStyle
        Try
            If Me.C1Pendenzen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
            If Me.C1Pendenzen.Columns("PendenzStatusNr").CellValue(e.Row) < 3 Then
                If Me.C1Pendenzen.Columns("Termin").CellValue(e.Row) < Now Then
                    Dim fnt As Font = e.CellStyle.Font
                    e.CellStyle.ForeColor = Color.Red
                End If
            End If

        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Referenzvertraege_DoubleClick -Methode

Doppelklick auf einem Referenz-Eintrag

[Visual Basic]
Private Sub C1Referenzvertraege_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Referenzvertraege.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button ReferenzAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Referenzvertraege_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Referenzvertraege.DoubleClick
        If Me.ReferenzAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.ReferenzAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Referenzvertraege_FetchRowStyle -Methode

Rowstyle von inaktiven Vertragsreferenzen

[Visual Basic]
Private Sub C1Referenzvertraege_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Referenzvertraege.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Referenzvertraege_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Referenzvertraege.FetchRowStyle
        If Me.C1Referenzvertraege.Columns("aktiv").CellValue(e.Row) = False Then
            Dim FNT As Font = e.CellStyle.Font
            e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            e.CellStyle.ForeColor = Color.Gray
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Referenzvertraege_MouseDown -Methode

Mousedown

[Visual Basic]
Private Sub C1Referenzvertraege_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Referenzvertraege.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Referenzvertraege_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Referenzvertraege.MouseDown
        Me.C1Referenzvertraege.Bookmark = Me.C1Referenzvertraege.RowContaining(e.Y)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Services_DoubleClick -Methode

Doppelklick auf eine Pendenz

[Visual Basic]
Private Sub C1Services_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Services.DoubleClick

Parameter

sender
e

Hinweise

Ist der Button PendenzAnzeigenToolStripMenuItem disabled, Doppelklick ignorieren

Quellcode

[Visual Basic]
    Private Sub C1Services_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Services.DoubleClick
        If Me.ServiceAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Me.ServiceAnzeigenToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Services_FetchRowStyle -Methode

Rowstyle von inaktiven Vertragsleistungen

[Visual Basic]
Private Sub C1Services_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Services.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Services_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Services.FetchRowStyle
        Try
            If Me.C1Services.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
            If Me.C1Services.Columns("PendenzStatusNr").CellValue(e.Row) < 3 Then
                If Me.C1Services.Columns("Termin").CellValue(e.Row) < Now Then
                    Dim fnt As Font = e.CellStyle.Font
                    e.CellStyle.ForeColor = Color.Red
                End If
            End If

        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Services_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Services_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Services.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Services_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Services.MouseDown
        Me.C1Services.Bookmark = Me.C1Services.RowContaining(e.Y)
        Refresh_SLATable()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.C1Vertragsereignis_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub C1Vertragsereignis_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Ereignisse.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragsereignis_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Ereignisse.MouseDown
        Me.C1Ereignisse.Bookmark = Me.C1Ereignisse.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.CPendenzen_Mousedown -Methode

Positionierung im Grid

[Visual Basic]
Private Sub CPendenzen_Mousedown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Pendenzen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub CPendenzen_Mousedown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Pendenzen.MouseDown
        Me.C1Pendenzen.Bookmark = Me.C1Pendenzen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Return True
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Me.FormDataChanged = False
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ClosingForm -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub ClosingForm( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ClosingForm(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Vertragselement.Neuer_Datensatz = True Then Me.Vertragselement.Delete(Me.Vertragselement.iVertragselementnr.Value)
            Globals.MyEventHanlder.Vertragselement_Closed(Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement)
            Me.Vertragselement.dispose()
            Me.msg.dispose()
            Me.SpaltenTitel = Nothing
            Me.sec = Nothing
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerVertragsbegin.ValueChanged, _
   dtPickerVertragsende.ValueChanged, _
   dtPickerMindestvertragsdauerbis.ValueChanged, _
   dtPickerUnterzeichnetam.ValueChanged, _
   dtPickerVersionsdatum.ValueChanged, _
   dtPickerGekuendigtam.ValueChanged, _
   dtPickerGekuendigtper.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _
        dtPickerVertragsbegin.ValueChanged, dtPickerVertragsende.ValueChanged, dtPickerMindestvertragsdauerbis.ValueChanged, _
        dtPickerUnterzeichnetam.ValueChanged, dtPickerVersionsdatum.ValueChanged, dtPickerGekuendigtam.ValueChanged, dtPickerGekuendigtper.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next
        If obj.Name = "dtPickerVertragsende" Then
            txtVertragsende_Leave(sender, e)
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If
        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmVertragselement


frmVertragselement.DokumentAnzeigenToolStripMenuItem_Click -Methode

Dokument anzeigen (Dialog)

[Visual Basic]
Private Sub DokumentAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(Me.C1Dokumente.Columns("Dokumentnr").Value, 1, Me.Aktuelles_Vertragselement, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.DokumentAnzeigen_Dokument_ToolStripMenuItem_Click -Methode

Dokument anzeigen - effektives Dokument

[Visual Basic]
Private Sub DokumentAnzeigen_Dokument_ToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigen_Dokument_ToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigen_Dokument_ToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigen_Dokument_ToolStripMenuItem.Click
        Try
            Me.Vertragselement.Dokument.Show_Doc(Me.C1Dokumente.Columns("Dokumentnr").Value)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.DokumentLöschenToolStripMenuItem_Click -Methode

Dokument inaktivieren

[Visual Basic]
Private Sub DokumentLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(275) = MsgBoxResult.Yes Then
                Me.Vertragselement.Dokument.Delete_Dokument(Me.C1Dokumente.Columns("Dokumentnr").Value)
                evh.Dokumente_Geloscht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.DokumentNeuToolStripMenuItem_Click -Methode

Neues Dokument generieren und anzeigen

[Visual Basic]
Private Sub DokumentNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentNeuToolStripMenuItem.Click
        Try
            Dim f As New frmDokument(0, 1, Me.Vertragselement.iVertragselementnr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.DokumenteMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub DokumenteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   DokumenteMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub DokumenteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles DokumenteMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Dokumente)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.EreignisAnzeigenToolStripMenuItem_Click -Methode

Vertragsereignis anzeigen (Dialog)

[Visual Basic]
Private Sub EreignisAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   EreignisAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub EreignisAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EreignisAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmVertragsereignis(Me.C1Ereignisse.Columns("Ereignisnr").Value, Me.Aktuelles_Vertragselement, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.EreignisLöschenToolStripMenuItem_Click -Methode

Dokument inaktivieren

[Visual Basic]
Private Sub EreignisLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   EreignisLöschenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub EreignisLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EreignisLöschenToolStipMenuItem.Click
        Try
            If msg.Show_MessageYesNo(280) = MsgBoxResult.Yes Then
                Me.Vertragselement.Vertragsereignis.Delete_Ereignis(Me.C1Ereignisse.Columns("Ereignisnr").Value)
                evh.Ereignis_Geloescht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.EreignisMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub EreignisMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   EreignisMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub EreignisMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles EreignisMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Ereignisse)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.EreignisNeuToolStripMenuItem_Click -Methode

Neues Vertragsereignis erstellen

[Visual Basic]
Private Sub EreignisNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   EreignisNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub EreignisNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EreignisNeuToolStripMenuItem.Click
        Try
            Dim f As New frmVertragsereignis(0, Aktuelles_Vertragselement, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Vertragselementnr As Integer _
)

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Vertragselementnr As Integer)
        If Vertragselementnr < 1 Then
            Me.pnlStammdaten.Enabled = False
            Me.TabControlDiverse.Enabled = False
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
            Me.TSBtnNew.Enabled = True
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
            Exit Sub
        End If
        Try
            Vertragselement.Get_Vertragselement(Vertragselementnr)

            Me.cbboxParentTree.TreeView.Nodes.Clear()
            Me.Vertragselement.Parentelemente.Load_ParentElemente(Me.Vertragselement.iVertragspartnerNr.Value, Me.Vertragselement.iParentID.Value, Me.cbboxParentTree.TreeView)
            Application.DoEvents()
            Me.cbboxParentTree.TreeView.Visible = False

            Me.txtVertragspartner.Text = Vertragselement.Vertragspartnername
            Me.Aktueller_Vertragspartner = Vertragselement.iVertragspartnerNr.Value
            Me.Aktuelles_Vertragselement = Vertragselement.iVertragselementnr.Value
            Me.cboxVertragstyp.SelectedValue = Vertragselement.iVertragstypNr.Value
            Me.Save_Vertragstyp = Me.cboxVertragstyp.SelectedValue
            Me.txtBezeichnung.Text = Vertragselement.sBezeichnung.ToString
            Me.txtVersion.Text = Vertragselement.sVersion.ToString
            Me.txtVertragsnummer.Text = Vertragselement.sNummer.ToString
            Me.txtVersion.Text = Vertragselement.sVersion.ToString
            Me.txtVersionsdatum.Text = Vertragselement.daVersionsdatum.ToString
            Me.txtVertragsbegin.Text = Vertragselement.daVertragsbeginn.ToString
            Me.txtVertragsende.Text = Vertragselement.daVertragsablauf.ToString
            Me.txtMindestvertragsdauerbis.Text = Vertragselement.daMindestvertragsdauer_bis.ToString
            Me.txtUnterzeichnetam.Text = Vertragselement.daUnterzeichnet_am.ToString
            Me.txtGekuendigtam.Text = Vertragselement.daGekuendigt_am.ToString
            Me.txtGekuendigtper.Text = Vertragselement.daGekuendigt_per.ToString
            Try
                Me.rbbefristet.Checked = Vertragselement.bBefristet_Unbefristet.Value = True
                If Me.rbbefristet.Checked = False Then Me.rbUnbefristet.Checked = True
            Catch
                Me.rbbefristet.Checked = False
                Me.rbUnbefristet.Checked = True
            End Try
            Me.txtErstelltam.Text = Vertragselement.daErstellt_am.ToString
            Me.txtMutiertam.Text = Vertragselement.daMutiert_am.ToString
            Me.txtMutierer.Text = Vertragselement.iMutierer.ToString
            Try
                Me.cbaktiv.Checked = Vertragselement.bAktiv.Value = True

            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
            Me.txtBeschreibung.Text = Vertragselement.sBeschreibung.ToString
            Me.txtSuchbegriffe.Text = Vertragselement.sSuchbegriffe.ToString
            Me.cboxSecurityLevel.SelectedValue = Vertragselement.iSecurityLevelNr.Value

            If Me.Vertragselement.IsLizenzElement Then
            End If

            Me.pnlStammdaten.Enabled = True
            Me.TabControlDiverse.Enabled = True
            If Not Anzeige And Not Me.FormReadonly Then
                For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                    ctl.Enabled = True
                Next
            End If
            sec.Set_Form_Security(Me)
            Me.FormDataChanged = False
            Me.TabControlDiverse_SelectedIndexChanged(Nothing, Nothing)
            set_titel()
        Catch ex As Exception
            Me.pnlStammdaten.Enabled = False
            Me.TabControlDiverse.Enabled = False
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
            Me.TSBtnNew.Enabled = True
            sec.Set_Form_Security(Me)
        End Try
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragselement))
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.pnlStammdaten = New System.Windows.Forms.Panel
        Me.ImgListApplikationTree = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageListParentTree = New System.Windows.Forms.ImageList(Me.components)
        Me.dtPickerGekuendigtper = New System.Windows.Forms.DateTimePicker
        Me.dtPickerGekuendigtam = New System.Windows.Forms.DateTimePicker
        Me.dtPickerUnterzeichnetam = New System.Windows.Forms.DateTimePicker
        Me.dtPickerMindestvertragsdauerbis = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVertragsende = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVertragsbegin = New System.Windows.Forms.DateTimePicker
        Me.dtPickerVersionsdatum = New System.Windows.Forms.DateTimePicker
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtUnterzeichnetam = New System.Windows.Forms.MaskedTextBox
        Me.txtMindestvertragsdauerbis = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsende = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsbegin = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtper = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtam = New System.Windows.Forms.MaskedTextBox
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.lblVersionsdatum = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.rbUnbefristet = New System.Windows.Forms.RadioButton
        Me.rbbefristet = New System.Windows.Forms.RadioButton
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.lblUnterzeichnetam = New System.Windows.Forms.Label
        Me.lblMindesvertragsdauer = New System.Windows.Forms.Label
        Me.lblGekuendigtper = New System.Windows.Forms.Label
        Me.lblGekuendigtam = New System.Windows.Forms.Label
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtVertragsnummer = New System.Windows.Forms.TextBox
        Me.lblVertragsnummer = New System.Windows.Forms.Label
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblVertragsende = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.lblVertragsbegin = New System.Windows.Forms.Label
        Me.lblParentElement = New System.Windows.Forms.Label
        Me.lblVertragstyp = New System.Windows.Forms.Label
        Me.cboxVertragstyp = New System.Windows.Forms.ComboBox
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.TabControlDiverse = New System.Windows.Forms.TabControl
        Me.KuendigungsfristMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KuendigungsfristBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabVertragsinhalt = New System.Windows.Forms.TabPage
        Me.txtBeschreibung = New System.Windows.Forms.RichTextBox
        Me.TabSuchbegriffe = New System.Windows.Forms.TabPage
        Me.txtSuchbegriffe = New System.Windows.Forms.RichTextBox
        Me.TabKuendigungsfristen = New System.Windows.Forms.TabPage
        Me.C1Kuendigungsfristen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabKontakte = New System.Windows.Forms.TabPage
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KontakteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KontaktAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabDokumente = New System.Windows.Forms.TabPage
        Me.C1Dokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DokumenteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DokumentAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DokumentLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem2 = New System.Windows.Forms.ToolStripSeparator
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabServices = New System.Windows.Forms.TabPage
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.C1Services = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ServiceMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ServiceAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ServiceNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ServiceLoeschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.C1SLA = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabEreignisse = New System.Windows.Forms.TabPage
        Me.C1Ereignisse = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.EreignisMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.EreignisAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.EreignisNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.EreignisLöschenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabAktivitäten = New System.Windows.Forms.TabPage
        Me.c1Aktivitaeten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.AktivitaetKontextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.TabPendenzen = New System.Windows.Forms.TabPage
        Me.C1Pendenzen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.PendenzenMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.PendenzAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.PendenzNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.PendenzLöschenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabApplikation = New System.Windows.Forms.TabPage
        Me.C1Applikationen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ApplikationenMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ApplikationNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationInaktivierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ApplikationAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabReferenzvertraege = New System.Windows.Forms.TabPage
        Me.C1Referenzvertraege = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ReferenzenMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ReferenzAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReferenzNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ReferenzLoeschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabHistory = New System.Windows.Forms.TabPage
        Me.C1History = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ImageListeReferenzVertrasege = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageListeDocIcon = New System.Windows.Forms.ImageList(Me.components)
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ApplikationLizenzenVerwaltenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.cbboxParentTree = New Vertragsverwaltung.Controls.ComboBoxTree
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.pnlStammdaten.SuspendLayout()
        Me.TabControlDiverse.SuspendLayout()
        Me.KuendigungsfristMenuStrip.SuspendLayout()
        Me.TabVertragsinhalt.SuspendLayout()
        Me.TabSuchbegriffe.SuspendLayout()
        Me.TabKuendigungsfristen.SuspendLayout()
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KontakteMenuStrip.SuspendLayout()
        Me.TabDokumente.SuspendLayout()
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DokumenteMenuStrip.SuspendLayout()
        Me.TabServices.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ServiceMenuStrip.SuspendLayout()
        CType(Me.C1SLA, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabEreignisse.SuspendLayout()
        CType(Me.C1Ereignisse, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.EreignisMenuStrip.SuspendLayout()
        Me.TabAktivitäten.SuspendLayout()
        CType(Me.c1Aktivitaeten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPendenzen.SuspendLayout()
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.PendenzenMenuStrip.SuspendLayout()
        Me.TabApplikation.SuspendLayout()
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ApplikationenMenuStrip.SuspendLayout()
        Me.TabReferenzvertraege.SuspendLayout()
        CType(Me.C1Referenzvertraege, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.ReferenzenMenuStrip.SuspendLayout()
        Me.TabHistory.SuspendLayout()
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(127, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(660, 24)
        Me.MenuStrip1.TabIndex = 1
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripMenuItem1})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(120, 22)
        Me.ToolStripMenuItem1.Tag = ""
        Me.ToolStripMenuItem1.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(660, 25)
        Me.ToolStrip1.TabIndex = 0
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "Vertragselement suchen"
        '
        'pnlStammdaten
        '
        Me.pnlStammdaten.Controls.Add(Me.cbboxParentTree)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerMindestvertragsdauerbis)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.dtPickerVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.btnVertragspartnersuche)
        Me.pnlStammdaten.Controls.Add(Me.txtUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.txtMindestvertragsdauerbis)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.txtGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.txtGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.txtVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.lblVersionsdatum)
        Me.pnlStammdaten.Controls.Add(Me.cboxSecurityLevel)
        Me.pnlStammdaten.Controls.Add(Me.lblSecurityLebel)
        Me.pnlStammdaten.Controls.Add(Me.rbUnbefristet)
        Me.pnlStammdaten.Controls.Add(Me.rbbefristet)
        Me.pnlStammdaten.Controls.Add(Me.txtMutierer)
        Me.pnlStammdaten.Controls.Add(Me.txtMutiertam)
        Me.pnlStammdaten.Controls.Add(Me.txtErstelltam)
        Me.pnlStammdaten.Controls.Add(Me.lblMutierer)
        Me.pnlStammdaten.Controls.Add(Me.lblMutiertam)
        Me.pnlStammdaten.Controls.Add(Me.lblErstelltam)
        Me.pnlStammdaten.Controls.Add(Me.lblUnterzeichnetam)
        Me.pnlStammdaten.Controls.Add(Me.lblMindesvertragsdauer)
        Me.pnlStammdaten.Controls.Add(Me.lblGekuendigtper)
        Me.pnlStammdaten.Controls.Add(Me.lblGekuendigtam)
        Me.pnlStammdaten.Controls.Add(Me.txtBezeichnung)
        Me.pnlStammdaten.Controls.Add(Me.cbaktiv)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragsnummer)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsnummer)
        Me.pnlStammdaten.Controls.Add(Me.txtVersion)
        Me.pnlStammdaten.Controls.Add(Me.lblVersion)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsende)
        Me.pnlStammdaten.Controls.Add(Me.lblBezeichnung)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragsbegin)
        Me.pnlStammdaten.Controls.Add(Me.lblParentElement)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragstyp)
        Me.pnlStammdaten.Controls.Add(Me.cboxVertragstyp)
        Me.pnlStammdaten.Controls.Add(Me.txtVertragspartner)
        Me.pnlStammdaten.Controls.Add(Me.lblVertragspartner)
        Me.pnlStammdaten.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlStammdaten.Location = New System.Drawing.Point(0, 49)
        Me.pnlStammdaten.Name = "pnlStammdaten"
        Me.pnlStammdaten.Size = New System.Drawing.Size(660, 288)
        Me.pnlStammdaten.TabIndex = 2
        '
        'ImgListApplikationTree
        '
        Me.ImgListApplikationTree.ImageStream = CType(resources.GetObject("ImgListApplikationTree.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListApplikationTree.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListApplikationTree.Images.SetKeyName(0, "45.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(1, "Run.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(2, "Run_Deleted.ico")
        '
        'ImageListParentTree
        '
        Me.ImageListParentTree.ImageStream = CType(resources.GetObject("ImageListParentTree.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListParentTree.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListParentTree.Images.SetKeyName(0, "Carisblok1.ico")
        Me.ImageListParentTree.Images.SetKeyName(1, "Carisblok3.ico")
        Me.ImageListParentTree.Images.SetKeyName(2, "Carisblok1_Deleted.ico")
        Me.ImageListParentTree.Images.SetKeyName(3, "Carisblok3_Deleted.ico")
        '
        'dtPickerGekuendigtper
        '
        Me.dtPickerGekuendigtper.Location = New System.Drawing.Point(393, 199)
        Me.dtPickerGekuendigtper.Name = "dtPickerGekuendigtper"
        Me.dtPickerGekuendigtper.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerGekuendigtper.TabIndex = 19
        Me.dtPickerGekuendigtper.TabStop = False
        '
        'dtPickerGekuendigtam
        '
        Me.dtPickerGekuendigtam.Location = New System.Drawing.Point(393, 176)
        Me.dtPickerGekuendigtam.Name = "dtPickerGekuendigtam"
        Me.dtPickerGekuendigtam.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerGekuendigtam.TabIndex = 17
        Me.dtPickerGekuendigtam.TabStop = False
        '
        'dtPickerUnterzeichnetam
        '
        Me.dtPickerUnterzeichnetam.Location = New System.Drawing.Point(209, 246)
        Me.dtPickerUnterzeichnetam.Name = "dtPickerUnterzeichnetam"
        Me.dtPickerUnterzeichnetam.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerUnterzeichnetam.TabIndex = 23
        Me.dtPickerUnterzeichnetam.TabStop = False
        '
        'dtPickerMindestvertragsdauerbis
        '
        Me.dtPickerMindestvertragsdauerbis.Location = New System.Drawing.Point(209, 225)
        Me.dtPickerMindestvertragsdauerbis.Name = "dtPickerMindestvertragsdauerbis"
        Me.dtPickerMindestvertragsdauerbis.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerMindestvertragsdauerbis.TabIndex = 21
        Me.dtPickerMindestvertragsdauerbis.TabStop = False
        '
        'dtPickerVertragsende
        '
        Me.dtPickerVertragsende.Location = New System.Drawing.Point(209, 199)
        Me.dtPickerVertragsende.Name = "dtPickerVertragsende"
        Me.dtPickerVertragsende.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVertragsende.TabIndex = 15
        Me.dtPickerVertragsende.TabStop = False
        '
        'dtPickerVertragsbegin
        '
        Me.dtPickerVertragsbegin.Location = New System.Drawing.Point(209, 173)
        Me.dtPickerVertragsbegin.Name = "dtPickerVertragsbegin"
        Me.dtPickerVertragsbegin.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVertragsbegin.TabIndex = 13
        Me.dtPickerVertragsbegin.TabStop = False
        '
        'dtPickerVersionsdatum
        '
        Me.dtPickerVersionsdatum.Location = New System.Drawing.Point(393, 145)
        Me.dtPickerVersionsdatum.Name = "dtPickerVersionsdatum"
        Me.dtPickerVersionsdatum.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerVersionsdatum.TabIndex = 11
        Me.dtPickerVersionsdatum.TabStop = False
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(411, 15)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 1
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtUnterzeichnetam
        '
        Me.txtUnterzeichnetam.Location = New System.Drawing.Point(146, 247)
        Me.txtUnterzeichnetam.Mask = "00/00/0000"
        Me.txtUnterzeichnetam.Name = "txtUnterzeichnetam"
        Me.txtUnterzeichnetam.Size = New System.Drawing.Size(66, 20)
        Me.txtUnterzeichnetam.TabIndex = 22
        Me.txtUnterzeichnetam.ValidatingType = GetType(Date)
        '
        'txtMindestvertragsdauerbis
        '
        Me.txtMindestvertragsdauerbis.Location = New System.Drawing.Point(146, 225)
        Me.txtMindestvertragsdauerbis.Mask = "00/00/0000"
        Me.txtMindestvertragsdauerbis.Name = "txtMindestvertragsdauerbis"
        Me.txtMindestvertragsdauerbis.Size = New System.Drawing.Size(66, 20)
        Me.txtMindestvertragsdauerbis.TabIndex = 20
        Me.txtMindestvertragsdauerbis.ValidatingType = GetType(Date)
        '
        'txtVertragsende
        '
        Me.txtVertragsende.Location = New System.Drawing.Point(146, 199)
        Me.txtVertragsende.Mask = "00/00/0000"
        Me.txtVertragsende.Name = "txtVertragsende"
        Me.txtVertragsende.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsende.TabIndex = 14
        Me.txtVertragsende.ValidatingType = GetType(Date)
        '
        'txtVertragsbegin
        '
        Me.txtVertragsbegin.Location = New System.Drawing.Point(146, 173)
        Me.txtVertragsbegin.Mask = "00/00/0000"
        Me.txtVertragsbegin.Name = "txtVertragsbegin"
        Me.txtVertragsbegin.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsbegin.TabIndex = 12
        Me.txtVertragsbegin.ValidatingType = GetType(Date)
        '
        'txtGekuendigtper
        '
        Me.txtGekuendigtper.Location = New System.Drawing.Point(330, 199)
        Me.txtGekuendigtper.Mask = "00/00/0000"
        Me.txtGekuendigtper.Name = "txtGekuendigtper"
        Me.txtGekuendigtper.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtper.TabIndex = 18
        Me.txtGekuendigtper.ValidatingType = GetType(Date)
        '
        'txtGekuendigtam
        '
        Me.txtGekuendigtam.Location = New System.Drawing.Point(330, 176)
        Me.txtGekuendigtam.Mask = "00/00/0000"
        Me.txtGekuendigtam.Name = "txtGekuendigtam"
        Me.txtGekuendigtam.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtam.TabIndex = 16
        Me.txtGekuendigtam.ValidatingType = GetType(Date)
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.Location = New System.Drawing.Point(330, 145)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 10
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'lblVersionsdatum
        '
        Me.lblVersionsdatum.AutoSize = True
        Me.lblVersionsdatum.Location = New System.Drawing.Point(247, 149)
        Me.lblVersionsdatum.Name = "lblVersionsdatum"
        Me.lblVersionsdatum.Size = New System.Drawing.Size(76, 13)
        Me.lblVersionsdatum.TabIndex = 6
        Me.lblVersionsdatum.Text = "Versionsdatum"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(547, 109)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 27
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(469, 112)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 104
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'rbUnbefristet
        '
        Me.rbUnbefristet.AutoSize = True
        Me.rbUnbefristet.Location = New System.Drawing.Point(249, 254)
        Me.rbUnbefristet.Name = "rbUnbefristet"
        Me.rbUnbefristet.Size = New System.Drawing.Size(76, 17)
        Me.rbUnbefristet.TabIndex = 25
        Me.rbUnbefristet.TabStop = True
        Me.rbUnbefristet.Text = "Unbefristet"
        Me.rbUnbefristet.UseVisualStyleBackColor = True
        '
        'rbbefristet
        '
        Me.rbbefristet.AutoSize = True
        Me.rbbefristet.Location = New System.Drawing.Point(249, 228)
        Me.rbbefristet.Name = "rbbefristet"
        Me.rbbefristet.Size = New System.Drawing.Size(63, 17)
        Me.rbbefristet.TabIndex = 24
        Me.rbbefristet.TabStop = True
        Me.rbbefristet.Text = "Befristet"
        Me.rbbefristet.UseVisualStyleBackColor = True
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(547, 63)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 99
        Me.txtMutierer.TabStop = False
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(547, 40)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.ReadOnly = True
        Me.txtMutiertam.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiertam.TabIndex = 98
        Me.txtMutiertam.TabStop = False
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(547, 16)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.ReadOnly = True
        Me.txtErstelltam.Size = New System.Drawing.Size(79, 20)
        Me.txtErstelltam.TabIndex = 97
        Me.txtErstelltam.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(469, 67)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 96
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(469, 44)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 95
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(470, 19)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 94
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'lblUnterzeichnetam
        '
        Me.lblUnterzeichnetam.AutoSize = True
        Me.lblUnterzeichnetam.Location = New System.Drawing.Point(15, 250)
        Me.lblUnterzeichnetam.Name = "lblUnterzeichnetam"
        Me.lblUnterzeichnetam.Size = New System.Drawing.Size(90, 13)
        Me.lblUnterzeichnetam.TabIndex = 93
        Me.lblUnterzeichnetam.Text = "Unterzeichnet am"
        '
        'lblMindesvertragsdauer
        '
        Me.lblMindesvertragsdauer.AutoSize = True
        Me.lblMindesvertragsdauer.Location = New System.Drawing.Point(15, 228)
        Me.lblMindesvertragsdauer.Name = "lblMindesvertragsdauer"
        Me.lblMindesvertragsdauer.Size = New System.Drawing.Size(125, 13)
        Me.lblMindesvertragsdauer.TabIndex = 91
        Me.lblMindesvertragsdauer.Text = "Mindestvertragsdauer bis"
        '
        'lblGekuendigtper
        '
        Me.lblGekuendigtper.AutoSize = True
        Me.lblGekuendigtper.Location = New System.Drawing.Point(246, 202)
        Me.lblGekuendigtper.Name = "lblGekuendigtper"
        Me.lblGekuendigtper.Size = New System.Drawing.Size(74, 13)
        Me.lblGekuendigtper.TabIndex = 89
        Me.lblGekuendigtper.Text = "Gekündigt per"
        '
        'lblGekuendigtam
        '
        Me.lblGekuendigtam.AutoSize = True
        Me.lblGekuendigtam.Location = New System.Drawing.Point(246, 176)
        Me.lblGekuendigtam.Name = "lblGekuendigtam"
        Me.lblGekuendigtam.Size = New System.Drawing.Size(73, 13)
        Me.lblGekuendigtam.TabIndex = 87
        Me.lblGekuendigtam.Text = "Gekündigt am"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(146, 93)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 7
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(467, 88)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(94, 15)
        Me.cbaktiv.TabIndex = 26
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtVertragsnummer
        '
        Me.txtVertragsnummer.Location = New System.Drawing.Point(146, 120)
        Me.txtVertragsnummer.Name = "txtVertragsnummer"
        Me.txtVertragsnummer.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragsnummer.TabIndex = 8
        '
        'lblVertragsnummer
        '
        Me.lblVertragsnummer.AutoSize = True
        Me.lblVertragsnummer.Location = New System.Drawing.Point(15, 120)
        Me.lblVertragsnummer.Name = "lblVertragsnummer"
        Me.lblVertragsnummer.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragsnummer.TabIndex = 82
        Me.lblVertragsnummer.Text = "Vertragsnummer"
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(146, 146)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(84, 20)
        Me.txtVersion.TabIndex = 9
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(15, 146)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(42, 13)
        Me.lblVersion.TabIndex = 80
        Me.lblVersion.Text = "Version"
        '
        'lblVertragsende
        '
        Me.lblVertragsende.AutoSize = True
        Me.lblVertragsende.Location = New System.Drawing.Point(15, 202)
        Me.lblVertragsende.Name = "lblVertragsende"
        Me.lblVertragsende.Size = New System.Drawing.Size(70, 13)
        Me.lblVertragsende.TabIndex = 79
        Me.lblVertragsende.Text = "Vertragsende"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(15, 96)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 77
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblVertragsbegin
        '
        Me.lblVertragsbegin.AutoSize = True
        Me.lblVertragsbegin.Location = New System.Drawing.Point(15, 176)
        Me.lblVertragsbegin.Name = "lblVertragsbegin"
        Me.lblVertragsbegin.Size = New System.Drawing.Size(78, 13)
        Me.lblVertragsbegin.TabIndex = 76
        Me.lblVertragsbegin.Text = "Vertragsbeginn"
        '
        'lblParentElement
        '
        Me.lblParentElement.AutoSize = True
        Me.lblParentElement.Location = New System.Drawing.Point(15, 69)
        Me.lblParentElement.Name = "lblParentElement"
        Me.lblParentElement.Size = New System.Drawing.Size(124, 13)
        Me.lblParentElement.TabIndex = 74
        Me.lblParentElement.Text = "Übergeordnetes Element"
        '
        'lblVertragstyp
        '
        Me.lblVertragstyp.AutoSize = True
        Me.lblVertragstyp.Location = New System.Drawing.Point(15, 40)
        Me.lblVertragstyp.Name = "lblVertragstyp"
        Me.lblVertragstyp.Size = New System.Drawing.Size(60, 13)
        Me.lblVertragstyp.TabIndex = 72
        Me.lblVertragstyp.Text = "Vertragstyp"
        '
        'cboxVertragstyp
        '
        Me.cboxVertragstyp.FormattingEnabled = True
        Me.cboxVertragstyp.Location = New System.Drawing.Point(146, 37)
        Me.cboxVertragstyp.Name = "cboxVertragstyp"
        Me.cboxVertragstyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxVertragstyp.TabIndex = 2
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragspartner.ForeColor = System.Drawing.Color.Black
        Me.txtVertragspartner.Location = New System.Drawing.Point(146, 14)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.ReadOnly = True
        Me.txtVertragspartner.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragspartner.TabIndex = 0
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(15, 14)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(79, 13)
        Me.lblVertragspartner.TabIndex = 67
        Me.lblVertragspartner.Text = "Vertragspartner"
        '
        'TabControlDiverse
        '
        Me.TabControlDiverse.ContextMenuStrip = Me.KuendigungsfristMenuStrip
        Me.TabControlDiverse.Controls.Add(Me.TabVertragsinhalt)
        Me.TabControlDiverse.Controls.Add(Me.TabSuchbegriffe)
        Me.TabControlDiverse.Controls.Add(Me.TabKuendigungsfristen)
        Me.TabControlDiverse.Controls.Add(Me.TabKontakte)
        Me.TabControlDiverse.Controls.Add(Me.TabDokumente)
        Me.TabControlDiverse.Controls.Add(Me.TabServices)
        Me.TabControlDiverse.Controls.Add(Me.TabEreignisse)
        Me.TabControlDiverse.Controls.Add(Me.TabAktivitäten)
        Me.TabControlDiverse.Controls.Add(Me.TabPendenzen)
        Me.TabControlDiverse.Controls.Add(Me.TabApplikation)
        Me.TabControlDiverse.Controls.Add(Me.TabReferenzvertraege)
        Me.TabControlDiverse.Controls.Add(Me.TabHistory)
        Me.TabControlDiverse.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControlDiverse.Location = New System.Drawing.Point(0, 337)
        Me.TabControlDiverse.Name = "TabControlDiverse"
        Me.TabControlDiverse.SelectedIndex = 0
        Me.TabControlDiverse.Size = New System.Drawing.Size(660, 205)
        Me.TabControlDiverse.TabIndex = 24
        '
        'KuendigungsfristMenuStrip
        '
        Me.KuendigungsfristMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KuendigungsfristBearbeitenToolStripMenuItem})
        Me.KuendigungsfristMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.KuendigungsfristMenuStrip.Size = New System.Drawing.Size(124, 26)
        '
        'KuendigungsfristBearbeitenToolStripMenuItem
        '
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Name = "KuendigungsfristBearbeitenToolStripMenuItem"
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(123, 22)
        Me.KuendigungsfristBearbeitenToolStripMenuItem.Text = "&Anzeigen"
        '
        'TabVertragsinhalt
        '
        Me.TabVertragsinhalt.Controls.Add(Me.txtBeschreibung)
        Me.TabVertragsinhalt.Location = New System.Drawing.Point(4, 22)
        Me.TabVertragsinhalt.Name = "TabVertragsinhalt"
        Me.TabVertragsinhalt.Size = New System.Drawing.Size(652, 179)
        Me.TabVertragsinhalt.TabIndex = 6
        Me.TabVertragsinhalt.Text = "Vertragsinhalt"
        Me.TabVertragsinhalt.UseVisualStyleBackColor = True
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.BackColor = System.Drawing.SystemColors.Window
        Me.txtBeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtBeschreibung.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!)
        Me.txtBeschreibung.Location = New System.Drawing.Point(0, 0)
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(652, 179)
        Me.txtBeschreibung.TabIndex = 29
        Me.txtBeschreibung.Text = ""
        '
        'TabSuchbegriffe
        '
        Me.TabSuchbegriffe.Controls.Add(Me.txtSuchbegriffe)
        Me.TabSuchbegriffe.Location = New System.Drawing.Point(4, 22)
        Me.TabSuchbegriffe.Name = "TabSuchbegriffe"
        Me.TabSuchbegriffe.Size = New System.Drawing.Size(652, 179)
        Me.TabSuchbegriffe.TabIndex = 7
        Me.TabSuchbegriffe.Text = "Suchbegriffe"
        Me.TabSuchbegriffe.UseVisualStyleBackColor = True
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(0, 0)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(652, 179)
        Me.txtSuchbegriffe.TabIndex = 30
        Me.txtSuchbegriffe.Text = ""
        '
        'TabKuendigungsfristen
        '
        Me.TabKuendigungsfristen.Controls.Add(Me.C1Kuendigungsfristen)
        Me.TabKuendigungsfristen.Location = New System.Drawing.Point(4, 22)
        Me.TabKuendigungsfristen.Name = "TabKuendigungsfristen"
        Me.TabKuendigungsfristen.Size = New System.Drawing.Size(652, 179)
        Me.TabKuendigungsfristen.TabIndex = 10
        Me.TabKuendigungsfristen.Text = "Kündigungsfristen"
        Me.TabKuendigungsfristen.UseVisualStyleBackColor = True
        '
        'C1Kuendigungsfristen
        '
        Me.C1Kuendigungsfristen.AlternatingRows = True
        Me.C1Kuendigungsfristen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kuendigungsfristen.FetchRowStyles = True
        Me.C1Kuendigungsfristen.FilterBar = True
        Me.C1Kuendigungsfristen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kuendigungsfristen.Images.Add(CType(resources.GetObject("C1Kuendigungsfristen.Images"), System.Drawing.Image))
        Me.C1Kuendigungsfristen.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.Name = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.ZoomFactor = 75
        Me.C1Kuendigungsfristen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kuendigungsfristen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kuendigungsfristen.Size = New System.Drawing.Size(652, 179)
        Me.C1Kuendigungsfristen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kuendigungsfristen.TabIndex = 9
        Me.C1Kuendigungsfristen.Text = "C1TrueDBGrid1"
        Me.C1Kuendigungsfristen.PropBag = resources.GetString("C1Kuendigungsfristen.PropBag")
        '
        'TabKontakte
        '
        Me.TabKontakte.Controls.Add(Me.C1Kontakte)
        Me.TabKontakte.Location = New System.Drawing.Point(4, 22)
        Me.TabKontakte.Name = "TabKontakte"
        Me.TabKontakte.Padding = New System.Windows.Forms.Padding(3)
        Me.TabKontakte.Size = New System.Drawing.Size(652, 179)
        Me.TabKontakte.TabIndex = 0
        Me.TabKontakte.Text = "Kontakte"
        Me.TabKontakte.UseVisualStyleBackColor = True
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.ContextMenuStrip = Me.KontakteMenuStrip
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FetchRowStyles = True
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(3, 3)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(646, 173)
        Me.C1Kontakte.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kontakte.TabIndex = 10
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'KontakteMenuStrip
        '
        Me.KontakteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KontaktAnzeigenToolStripMenuItem, Me.KontaktNeuToolStripMenuItem, Me.KontaktLöschenToolStripMenuItem})
        Me.KontakteMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.KontakteMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'KontaktAnzeigenToolStripMenuItem
        '
        Me.KontaktAnzeigenToolStripMenuItem.Name = "KontaktAnzeigenToolStripMenuItem"
        Me.KontaktAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.KontaktAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KontaktNeuToolStripMenuItem
        '
        Me.KontaktNeuToolStripMenuItem.Name = "KontaktNeuToolStripMenuItem"
        Me.KontaktNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.KontaktNeuToolStripMenuItem.Text = "&Neu"
        '
        'KontaktLöschenToolStripMenuItem
        '
        Me.KontaktLöschenToolStripMenuItem.Name = "KontaktLöschenToolStripMenuItem"
        Me.KontaktLöschenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.KontaktLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'TabDokumente
        '
        Me.TabDokumente.Controls.Add(Me.C1Dokumente)
        Me.TabDokumente.Location = New System.Drawing.Point(4, 22)
        Me.TabDokumente.Name = "TabDokumente"
        Me.TabDokumente.Size = New System.Drawing.Size(652, 179)
        Me.TabDokumente.TabIndex = 11
        Me.TabDokumente.Text = "Dokumente"
        Me.TabDokumente.UseVisualStyleBackColor = True
        '
        'C1Dokumente
        '
        Me.C1Dokumente.AlternatingRows = True
        Me.C1Dokumente.ContextMenuStrip = Me.DokumenteMenuStrip
        Me.C1Dokumente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Dokumente.FetchRowStyles = True
        Me.C1Dokumente.FilterBar = True
        Me.C1Dokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Dokumente.Images.Add(CType(resources.GetObject("C1Dokumente.Images"), System.Drawing.Image))
        Me.C1Dokumente.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.Name = "C1Dokumente"
        Me.C1Dokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Dokumente.PreviewInfo.ZoomFactor = 75
        Me.C1Dokumente.PrintInfo.PageSettings = CType(resources.GetObject("C1Dokumente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Dokumente.Size = New System.Drawing.Size(652, 179)
        Me.C1Dokumente.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Dokumente.TabIndex = 10
        Me.C1Dokumente.Text = "C1TrueDBGrid1"
        Me.C1Dokumente.PropBag = resources.GetString("C1Dokumente.PropBag")
        '
        'DokumenteMenuStrip
        '
        Me.DokumenteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DokumentAnzeigenToolStripMenuItem, Me.DokumentNeuToolStripMenuItem, Me.DokumentLöschenToolStripMenuItem, Me.ToolStripMenuItem2, Me.DokumentAnzeigen_Dokument_ToolStripMenuItem})
        Me.DokumenteMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.DokumenteMenuStrip.Size = New System.Drawing.Size(181, 98)
        '
        'DokumentAnzeigenToolStripMenuItem
        '
        Me.DokumentAnzeigenToolStripMenuItem.Name = "DokumentAnzeigenToolStripMenuItem"
        Me.DokumentAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'DokumentNeuToolStripMenuItem
        '
        Me.DokumentNeuToolStripMenuItem.Name = "DokumentNeuToolStripMenuItem"
        Me.DokumentNeuToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentNeuToolStripMenuItem.Text = "&Neu"
        '
        'DokumentLöschenToolStripMenuItem
        '
        Me.DokumentLöschenToolStripMenuItem.Name = "DokumentLöschenToolStripMenuItem"
        Me.DokumentLöschenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentLöschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStripMenuItem2
        '
        Me.ToolStripMenuItem2.Name = "ToolStripMenuItem2"
        Me.ToolStripMenuItem2.Size = New System.Drawing.Size(177, 6)
        '
        'DokumentAnzeigen_Dokument_ToolStripMenuItem
        '
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Name = "DokumentAnzeigen_Dokument_ToolStripMenuItem"
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigen_Dokument_ToolStripMenuItem.Text = "&Dokument anzeigen"
        '
        'TabServices
        '
        Me.TabServices.Controls.Add(Me.SplitContainer1)
        Me.TabServices.Location = New System.Drawing.Point(4, 22)
        Me.TabServices.Name = "TabServices"
        Me.TabServices.Padding = New System.Windows.Forms.Padding(3)
        Me.TabServices.Size = New System.Drawing.Size(652, 179)
        Me.TabServices.TabIndex = 1
        Me.TabServices.Text = "Services"
        Me.TabServices.UseVisualStyleBackColor = True
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(3, 3)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.C1Services)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1SLA)
        Me.SplitContainer1.Size = New System.Drawing.Size(646, 173)
        Me.SplitContainer1.SplitterDistance = 337
        Me.SplitContainer1.TabIndex = 0
        '
        'C1Services
        '
        Me.C1Services.AlternatingRows = True
        Me.C1Services.ContextMenuStrip = Me.ServiceMenuStrip
        Me.C1Services.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Services.FetchRowStyles = True
        Me.C1Services.FilterBar = True
        Me.C1Services.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Services.Images.Add(CType(resources.GetObject("C1Services.Images"), System.Drawing.Image))
        Me.C1Services.Location = New System.Drawing.Point(0, 0)
        Me.C1Services.Name = "C1Services"
        Me.C1Services.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Services.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Services.PreviewInfo.ZoomFactor = 75
        Me.C1Services.PrintInfo.PageSettings = CType(resources.GetObject("C1Services.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Services.Size = New System.Drawing.Size(337, 173)
        Me.C1Services.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Services.TabIndex = 11
        Me.C1Services.Text = "C1TrueDBGrid1"
        Me.C1Services.PropBag = resources.GetString("C1Services.PropBag")
        '
        'ServiceMenuStrip
        '
        Me.ServiceMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ServiceAnzeigenToolStripMenuItem, Me.ServiceNeuToolStripMenuItem, Me.ServiceLoeschenToolStripMenuItem})
        Me.ServiceMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.ServiceMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'ServiceAnzeigenToolStripMenuItem
        '
        Me.ServiceAnzeigenToolStripMenuItem.Name = "ServiceAnzeigenToolStripMenuItem"
        Me.ServiceAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ServiceAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'ServiceNeuToolStripMenuItem
        '
        Me.ServiceNeuToolStripMenuItem.Name = "ServiceNeuToolStripMenuItem"
        Me.ServiceNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ServiceNeuToolStripMenuItem.Text = "&Neu"
        '
        'ServiceLoeschenToolStripMenuItem
        '
        Me.ServiceLoeschenToolStripMenuItem.Name = "ServiceLoeschenToolStripMenuItem"
        Me.ServiceLoeschenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ServiceLoeschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'C1SLA
        '
        Me.C1SLA.AlternatingRows = True
        Me.C1SLA.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1SLA.FetchRowStyles = True
        Me.C1SLA.FilterBar = True
        Me.C1SLA.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1SLA.Images.Add(CType(resources.GetObject("C1SLA.Images"), System.Drawing.Image))
        Me.C1SLA.Location = New System.Drawing.Point(0, 0)
        Me.C1SLA.Name = "C1SLA"
        Me.C1SLA.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1SLA.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1SLA.PreviewInfo.ZoomFactor = 75
        Me.C1SLA.PrintInfo.PageSettings = CType(resources.GetObject("C1SLA.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1SLA.Size = New System.Drawing.Size(305, 173)
        Me.C1SLA.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1SLA.TabIndex = 12
        Me.C1SLA.Text = "C1TrueDBGrid1"
        Me.C1SLA.PropBag = resources.GetString("C1SLA.PropBag")
        '
        'TabEreignisse
        '
        Me.TabEreignisse.Controls.Add(Me.C1Ereignisse)
        Me.TabEreignisse.Location = New System.Drawing.Point(4, 22)
        Me.TabEreignisse.Name = "TabEreignisse"
        Me.TabEreignisse.Size = New System.Drawing.Size(652, 179)
        Me.TabEreignisse.TabIndex = 2
        Me.TabEreignisse.Text = "Ereignisse"
        Me.TabEreignisse.UseVisualStyleBackColor = True
        '
        'C1Ereignisse
        '
        Me.C1Ereignisse.AlternatingRows = True
        Me.C1Ereignisse.ContextMenuStrip = Me.EreignisMenuStrip
        Me.C1Ereignisse.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Ereignisse.FetchRowStyles = True
        Me.C1Ereignisse.FilterBar = True
        Me.C1Ereignisse.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Ereignisse.Images.Add(CType(resources.GetObject("C1Ereignisse.Images"), System.Drawing.Image))
        Me.C1Ereignisse.Location = New System.Drawing.Point(0, 0)
        Me.C1Ereignisse.Name = "C1Ereignisse"
        Me.C1Ereignisse.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Ereignisse.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Ereignisse.PreviewInfo.ZoomFactor = 75
        Me.C1Ereignisse.PrintInfo.PageSettings = CType(resources.GetObject("C1Ereignisse.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Ereignisse.Size = New System.Drawing.Size(652, 179)
        Me.C1Ereignisse.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Ereignisse.TabIndex = 10
        Me.C1Ereignisse.Text = "C1TrueDBGrid1"
        Me.C1Ereignisse.PropBag = resources.GetString("C1Ereignisse.PropBag")
        '
        'EreignisMenuStrip
        '
        Me.EreignisMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.EreignisAnzeigenToolStripMenuItem, Me.EreignisNeuToolStripMenuItem, Me.EreignisLöschenToolStipMenuItem})
        Me.EreignisMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.EreignisMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'EreignisAnzeigenToolStripMenuItem
        '
        Me.EreignisAnzeigenToolStripMenuItem.Name = "EreignisAnzeigenToolStripMenuItem"
        Me.EreignisAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.EreignisAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'EreignisNeuToolStripMenuItem
        '
        Me.EreignisNeuToolStripMenuItem.Name = "EreignisNeuToolStripMenuItem"
        Me.EreignisNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.EreignisNeuToolStripMenuItem.Text = "&Neu"
        '
        'EreignisLöschenToolStipMenuItem
        '
        Me.EreignisLöschenToolStipMenuItem.Name = "EreignisLöschenToolStipMenuItem"
        Me.EreignisLöschenToolStipMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.EreignisLöschenToolStipMenuItem.Text = "&Inaktivieren"
        '
        'TabAktivitäten
        '
        Me.TabAktivitäten.Controls.Add(Me.c1Aktivitaeten)
        Me.TabAktivitäten.Location = New System.Drawing.Point(4, 22)
        Me.TabAktivitäten.Name = "TabAktivitäten"
        Me.TabAktivitäten.Size = New System.Drawing.Size(652, 179)
        Me.TabAktivitäten.TabIndex = 9
        Me.TabAktivitäten.Text = "Aktivitäten"
        Me.TabAktivitäten.UseVisualStyleBackColor = True
        '
        'c1Aktivitaeten
        '
        Me.c1Aktivitaeten.AlternatingRows = True
        Me.c1Aktivitaeten.ContextMenuStrip = Me.AktivitaetKontextMenuStrip
        Me.c1Aktivitaeten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.c1Aktivitaeten.FetchRowStyles = True
        Me.c1Aktivitaeten.FilterBar = True
        Me.c1Aktivitaeten.GroupByCaption = "Drag a column header here to group by that column"
        Me.c1Aktivitaeten.Images.Add(CType(resources.GetObject("c1Aktivitaeten.Images"), System.Drawing.Image))
        Me.c1Aktivitaeten.Location = New System.Drawing.Point(0, 0)
        Me.c1Aktivitaeten.Name = "c1Aktivitaeten"
        Me.c1Aktivitaeten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.c1Aktivitaeten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.c1Aktivitaeten.PreviewInfo.ZoomFactor = 75
        Me.c1Aktivitaeten.PrintInfo.PageSettings = CType(resources.GetObject("c1Aktivitaeten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.c1Aktivitaeten.Size = New System.Drawing.Size(652, 179)
        Me.c1Aktivitaeten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.c1Aktivitaeten.TabIndex = 11
        Me.c1Aktivitaeten.Text = "C1TrueDBGrid1"
        Me.c1Aktivitaeten.PropBag = resources.GetString("c1Aktivitaeten.PropBag")
        '
        'AktivitaetKontextMenuStrip
        '
        Me.AktivitaetKontextMenuStrip.Name = "AktivitaetKontextMenuStrip"
        Me.AktivitaetKontextMenuStrip.Size = New System.Drawing.Size(61, 4)
        '
        'TabPendenzen
        '
        Me.TabPendenzen.Controls.Add(Me.C1Pendenzen)
        Me.TabPendenzen.Location = New System.Drawing.Point(4, 22)
        Me.TabPendenzen.Name = "TabPendenzen"
        Me.TabPendenzen.Size = New System.Drawing.Size(652, 179)
        Me.TabPendenzen.TabIndex = 3
        Me.TabPendenzen.Text = "Pendenzen"
        Me.TabPendenzen.UseVisualStyleBackColor = True
        '
        'C1Pendenzen
        '
        Me.C1Pendenzen.AlternatingRows = True
        Me.C1Pendenzen.ContextMenuStrip = Me.PendenzenMenuStrip
        Me.C1Pendenzen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Pendenzen.FetchRowStyles = True
        Me.C1Pendenzen.FilterBar = True
        Me.C1Pendenzen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Pendenzen.Images.Add(CType(resources.GetObject("C1Pendenzen.Images"), System.Drawing.Image))
        Me.C1Pendenzen.Location = New System.Drawing.Point(0, 0)
        Me.C1Pendenzen.Name = "C1Pendenzen"
        Me.C1Pendenzen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Pendenzen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Pendenzen.PreviewInfo.ZoomFactor = 75
        Me.C1Pendenzen.PrintInfo.PageSettings = CType(resources.GetObject("C1Pendenzen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Pendenzen.Size = New System.Drawing.Size(652, 179)
        Me.C1Pendenzen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Pendenzen.TabIndex = 11
        Me.C1Pendenzen.Text = "C1TrueDBGrid1"
        Me.C1Pendenzen.PropBag = resources.GetString("C1Pendenzen.PropBag")
        '
        'PendenzenMenuStrip
        '
        Me.PendenzenMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.PendenzAnzeigenToolStripMenuItem, Me.PendenzNeuToolStripMenuItem, Me.PendenzLöschenToolStipMenuItem})
        Me.PendenzenMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.PendenzenMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'PendenzAnzeigenToolStripMenuItem
        '
        Me.PendenzAnzeigenToolStripMenuItem.Name = "PendenzAnzeigenToolStripMenuItem"
        Me.PendenzAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.PendenzAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'PendenzNeuToolStripMenuItem
        '
        Me.PendenzNeuToolStripMenuItem.Name = "PendenzNeuToolStripMenuItem"
        Me.PendenzNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.PendenzNeuToolStripMenuItem.Text = "&Neu"
        '
        'PendenzLöschenToolStipMenuItem
        '
        Me.PendenzLöschenToolStipMenuItem.Name = "PendenzLöschenToolStipMenuItem"
        Me.PendenzLöschenToolStipMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.PendenzLöschenToolStipMenuItem.Text = "&Inaktivieren"
        '
        'TabApplikation
        '
        Me.TabApplikation.Controls.Add(Me.C1Applikationen)
        Me.TabApplikation.Location = New System.Drawing.Point(4, 22)
        Me.TabApplikation.Name = "TabApplikation"
        Me.TabApplikation.Size = New System.Drawing.Size(652, 179)
        Me.TabApplikation.TabIndex = 13
        Me.TabApplikation.Text = "Applikationen"
        Me.TabApplikation.UseVisualStyleBackColor = True
        '
        'C1Applikationen
        '
        Me.C1Applikationen.AlternatingRows = True
        Me.C1Applikationen.ContextMenuStrip = Me.ApplikationenMenuStrip
        Me.C1Applikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Applikationen.FetchRowStyles = True
        Me.C1Applikationen.FilterBar = True
        Me.C1Applikationen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Applikationen.Images.Add(CType(resources.GetObject("C1Applikationen.Images"), System.Drawing.Image))
        Me.C1Applikationen.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.Name = "C1Applikationen"
        Me.C1Applikationen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Applikationen.PreviewInfo.ZoomFactor = 75
        Me.C1Applikationen.PrintInfo.PageSettings = CType(resources.GetObject("C1Applikationen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Applikationen.Size = New System.Drawing.Size(652, 179)
        Me.C1Applikationen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Applikationen.TabIndex = 12
        Me.C1Applikationen.Text = "C1TrueDBGrid1"
        Me.C1Applikationen.PropBag = resources.GetString("C1Applikationen.PropBag")
        '
        'ApplikationenMenuStrip
        '
        Me.ApplikationenMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ApplikationNeuToolStripMenuItem, Me.ApplikationInaktivierenToolStripMenuItem, Me.ApplikationAnzeigenToolStripMenuItem, Me.ApplikationLizenzenVerwaltenToolStripMenuItem})
        Me.ApplikationenMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.ApplikationenMenuStrip.Size = New System.Drawing.Size(174, 114)
        '
        'ApplikationNeuToolStripMenuItem
        '
        Me.ApplikationNeuToolStripMenuItem.Name = "ApplikationNeuToolStripMenuItem"
        Me.ApplikationNeuToolStripMenuItem.Size = New System.Drawing.Size(173, 22)
        Me.ApplikationNeuToolStripMenuItem.Text = "&Neu"
        '
        'ApplikationInaktivierenToolStripMenuItem
        '
        Me.ApplikationInaktivierenToolStripMenuItem.Name = "ApplikationInaktivierenToolStripMenuItem"
        Me.ApplikationInaktivierenToolStripMenuItem.Size = New System.Drawing.Size(173, 22)
        Me.ApplikationInaktivierenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ApplikationAnzeigenToolStripMenuItem
        '
        Me.ApplikationAnzeigenToolStripMenuItem.Name = "ApplikationAnzeigenToolStripMenuItem"
        Me.ApplikationAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(173, 22)
        Me.ApplikationAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'TabReferenzvertraege
        '
        Me.TabReferenzvertraege.Controls.Add(Me.C1Referenzvertraege)
        Me.TabReferenzvertraege.Location = New System.Drawing.Point(4, 22)
        Me.TabReferenzvertraege.Name = "TabReferenzvertraege"
        Me.TabReferenzvertraege.Size = New System.Drawing.Size(652, 179)
        Me.TabReferenzvertraege.TabIndex = 5
        Me.TabReferenzvertraege.Text = "Referenzverträge"
        Me.TabReferenzvertraege.UseVisualStyleBackColor = True
        '
        'C1Referenzvertraege
        '
        Me.C1Referenzvertraege.AlternatingRows = True
        Me.C1Referenzvertraege.ContextMenuStrip = Me.ReferenzenMenuStrip
        Me.C1Referenzvertraege.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Referenzvertraege.FetchRowStyles = True
        Me.C1Referenzvertraege.FilterBar = True
        Me.C1Referenzvertraege.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Referenzvertraege.Images.Add(CType(resources.GetObject("C1Referenzvertraege.Images"), System.Drawing.Image))
        Me.C1Referenzvertraege.Location = New System.Drawing.Point(0, 0)
        Me.C1Referenzvertraege.Name = "C1Referenzvertraege"
        Me.C1Referenzvertraege.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Referenzvertraege.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Referenzvertraege.PreviewInfo.ZoomFactor = 75
        Me.C1Referenzvertraege.PrintInfo.PageSettings = CType(resources.GetObject("C1Referenzvertraege.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Referenzvertraege.Size = New System.Drawing.Size(652, 179)
        Me.C1Referenzvertraege.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Referenzvertraege.TabIndex = 13
        Me.C1Referenzvertraege.Text = "C1TrueDBGrid1"
        Me.C1Referenzvertraege.PropBag = resources.GetString("C1Referenzvertraege.PropBag")
        '
        'ReferenzenMenuStrip
        '
        Me.ReferenzenMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ReferenzAnzeigenToolStripMenuItem, Me.ReferenzNeuToolStripMenuItem, Me.ReferenzLoeschenToolStripMenuItem})
        Me.ReferenzenMenuStrip.Name = "KuendigungsfristMenuStrip"
        Me.ReferenzenMenuStrip.Size = New System.Drawing.Size(136, 70)
        '
        'ReferenzAnzeigenToolStripMenuItem
        '
        Me.ReferenzAnzeigenToolStripMenuItem.Name = "ReferenzAnzeigenToolStripMenuItem"
        Me.ReferenzAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReferenzAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'ReferenzNeuToolStripMenuItem
        '
        Me.ReferenzNeuToolStripMenuItem.Name = "ReferenzNeuToolStripMenuItem"
        Me.ReferenzNeuToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReferenzNeuToolStripMenuItem.Text = "&Neu"
        '
        'ReferenzLoeschenToolStripMenuItem
        '
        Me.ReferenzLoeschenToolStripMenuItem.Name = "ReferenzLoeschenToolStripMenuItem"
        Me.ReferenzLoeschenToolStripMenuItem.Size = New System.Drawing.Size(135, 22)
        Me.ReferenzLoeschenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'TabHistory
        '
        Me.TabHistory.Controls.Add(Me.C1History)
        Me.TabHistory.Location = New System.Drawing.Point(4, 22)
        Me.TabHistory.Name = "TabHistory"
        Me.TabHistory.Size = New System.Drawing.Size(652, 179)
        Me.TabHistory.TabIndex = 12
        Me.TabHistory.Text = "History"
        Me.TabHistory.UseVisualStyleBackColor = True
        '
        'C1History
        '
        Me.C1History.AlternatingRows = True
        Me.C1History.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1History.FetchRowStyles = True
        Me.C1History.FilterBar = True
        Me.C1History.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1History.Images.Add(CType(resources.GetObject("C1History.Images"), System.Drawing.Image))
        Me.C1History.Location = New System.Drawing.Point(0, 0)
        Me.C1History.Name = "C1History"
        Me.C1History.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1History.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1History.PreviewInfo.ZoomFactor = 75
        Me.C1History.PrintInfo.PageSettings = CType(resources.GetObject("C1History.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1History.Size = New System.Drawing.Size(652, 179)
        Me.C1History.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1History.TabIndex = 14
        Me.C1History.Text = "C1TrueDBGrid1"
        Me.C1History.PropBag = resources.GetString("C1History.PropBag")
        '
        'ImageListeReferenzVertrasege
        '
        Me.ImageListeReferenzVertrasege.ImageStream = CType(resources.GetObject("ImageListeReferenzVertrasege.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeReferenzVertrasege.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(0, "2ARROW4.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(1, "2ARROW3.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(2, "HANDAR4.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(3, "HANDAR3.GIF")
        '
        'ImageListeDocIcon
        '
        Me.ImageListeDocIcon.ImageStream = CType(resources.GetObject("ImageListeDocIcon.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeDocIcon.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeDocIcon.Images.SetKeyName(0, "PDF.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(1, "Word5.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(2, "Excel1.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(3, "PowerPoint.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(4, "html.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(5, "Mail.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(6, "Document1.ico")
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.ContextMenuStrip = Me.EreignisMenuStrip
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("C1TrueDBGrid1.Images"), System.Drawing.Image))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.PageSettings = CType(resources.GetObject("C1TrueDBGrid1.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(652, 180)
        Me.C1TrueDBGrid1.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1TrueDBGrid1.TabIndex = 10
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = resources.GetString("C1TrueDBGrid1.PropBag")
        '
        'ApplikationLizenzenVerwaltenToolStripMenuItem
        '
        Me.ApplikationLizenzenVerwaltenToolStripMenuItem.Name = "ApplikationLizenzenVerwaltenToolStripMenuItem"
        Me.ApplikationLizenzenVerwaltenToolStripMenuItem.Size = New System.Drawing.Size(173, 22)
        Me.ApplikationLizenzenVerwaltenToolStripMenuItem.Text = "Lizenzen verwalten"
        '
        'cbboxParentTree
        '
        Me.cbboxParentTree.ImageList = Me.ImageListParentTree
        Me.cbboxParentTree.Location = New System.Drawing.Point(146, 63)
        Me.cbboxParentTree.Name = "cbboxParentTree"
        Me.cbboxParentTree.SelectedImageIndex = 0
        Me.cbboxParentTree.SelectedNode = Nothing
        Me.cbboxParentTree.Size = New System.Drawing.Size(268, 22)
        Me.cbboxParentTree.TabIndex = 6
        '
        'frmVertragselement
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(660, 542)
        Me.Controls.Add(Me.TabControlDiverse)
        Me.Controls.Add(Me.pnlStammdaten)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragselement"
        Me.Text = "Vertragselement"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.pnlStammdaten.ResumeLayout(False)
        Me.pnlStammdaten.PerformLayout()
        Me.TabControlDiverse.ResumeLayout(False)
        Me.KuendigungsfristMenuStrip.ResumeLayout(False)
        Me.TabVertragsinhalt.ResumeLayout(False)
        Me.TabSuchbegriffe.ResumeLayout(False)
        Me.TabKuendigungsfristen.ResumeLayout(False)
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabKontakte.ResumeLayout(False)
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KontakteMenuStrip.ResumeLayout(False)
        Me.TabDokumente.ResumeLayout(False)
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DokumenteMenuStrip.ResumeLayout(False)
        Me.TabServices.ResumeLayout(False)
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ServiceMenuStrip.ResumeLayout(False)
        CType(Me.C1SLA, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabEreignisse.ResumeLayout(False)
        CType(Me.C1Ereignisse, System.ComponentModel.ISupportInitialize).EndInit()
        Me.EreignisMenuStrip.ResumeLayout(False)
        Me.TabAktivitäten.ResumeLayout(False)
        CType(Me.c1Aktivitaeten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPendenzen.ResumeLayout(False)
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.PendenzenMenuStrip.ResumeLayout(False)
        Me.TabApplikation.ResumeLayout(False)
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ApplikationenMenuStrip.ResumeLayout(False)
        Me.TabReferenzvertraege.ResumeLayout(False)
        CType(Me.C1Referenzvertraege, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ReferenzenMenuStrip.ResumeLayout(False)
        Me.TabHistory.ResumeLayout(False)
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KontaktAnzeigenToolStripMenuItem_Click -Methode

Anzeigen bzw. bearbeitnen eines Kontaktes

[Visual Basic]
Private Sub KontaktAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmVertragskontakt(Me.C1Kontakte.Columns("Vertragskontaktnr").Value, Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement, , Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KontaktLöschenToolStripMenuItem_Click -Methode

Vertragskontakt inaktivieren

[Visual Basic]
Private Sub KontaktLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktLöschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(265) = MsgBoxResult.Yes Then
                Me.Vertragselement.Vertragskontakt.Delete_Vertragskontakt(Me.C1Kontakte.Columns("Vertragskontaktnr").Value)
                evh.Kontakte_Geloescht()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KontaktNeuToolStripMenuItem_Click -Methode

Neuer Vertragskontakt erstellen

[Visual Basic]
Private Sub KontaktNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktNeuToolStripMenuItem.Click
        Try
            'Dim i As Integer = Me.Vertragselement.Vertragskontakt.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New frmVertragskontakt(0, Me.Aktueller_Vertragspartner, Me.Aktuelles_Vertragselement, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KontakteMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub KontakteMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   KontakteMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub KontakteMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles KontakteMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Kontakte)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.KuendigungsfristBearbeitenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub KuendigungsfristBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KuendigungsfristBearbeitenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KuendigungsfristBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KuendigungsfristBearbeitenToolStripMenuItem.Click
        Dim f As New frmVertragsereignis(Me.C1Kuendigungsfristen.Columns("Ereignisnr").Value, Me.Aktuelles_Vertragselement, Me.FormReadonly)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KuendigungsfristLöschenToolStripMenuItem_Click -Methode

Kuendigungsfrist inaktivieren

[Visual Basic]
Private Sub KuendigungsfristLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KuendigungsfristLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            If msg.Show_MessageYesNo(260) = MsgBoxResult.Yes Then
                Me.Vertragselement.Kuendigungsfrist.Delete_Kuendigungsfrist(Me.C1Kuendigungsfristen.Columns("Kuendigungsfristnr").Value)
                evh.Kuendigungsfrist_Geloescht()
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.KuendigungsfristMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub KuendigungsfristMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
)

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub KuendigungsfristMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs)
        Me.Disable_Enable_Menu(sender, Me.C1Kuendigungsfristen)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.KuendigungsfristNeuToolStripMenuItem_Click -Methode

Neue Kuendigungsfrist erstellen

[Visual Basic]
Private Sub KuendigungsfristNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KuendigungsfristNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            '            Dim i As Integer = Me.Vertragselement.Kuendigungsfrist.Add_New(Me.Vertragselement.iVertragselementnr.Value)
            Dim f As New frmKuendigungsfrist(0, Me.Vertragselement.iVertragselementnr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.PendenzAnzeigenToolStripMenuItem_Click -Methode

Pendenz anzeigen

[Visual Basic]
Private Sub PendenzAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PendenzAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PendenzAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PendenzAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmPendenz(Me.C1Pendenzen.Columns("PendenzNr").Value, Me.Aktuelles_Vertragselement, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
            Exit Sub
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.PendenzLöschenToolStripMenuItem_Click -Methode

Dokument inaktivieren

[Visual Basic]
Private Sub PendenzLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PendenzLöschenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PendenzLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PendenzLöschenToolStipMenuItem.Click
        Try
            If msg.Show_MessageYesNo(290) = MsgBoxResult.Yes Then
                Me.Vertragselement.Pendenz.Delete_Pendenz(Me.C1Pendenzen.Columns("Pendenznr").Value)
                evh.Pendenz_Geloescht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.PendenzNeuToolStripMenuItem_Click -Methode

Neue Pendenz erstellen

[Visual Basic]
Private Sub PendenzNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   PendenzNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub PendenzNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PendenzNeuToolStripMenuItem.Click
        Try
            Dim f As New frmPendenz(0, Me.Aktuelles_Vertragselement, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.PendenzenMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub PendenzenMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   PendenzenMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub PendenzenMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles PendenzenMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Pendenzen)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.ReferenzAnzeigenToolStripMenuItem_Click -Methode

Vertragsrefernz anzeigen

[Visual Basic]
Private Sub ReferenzAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReferenzAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReferenzAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReferenzAnzeigenToolStripMenuItem.Click
        Try
            Dim f As New frmReferenzvertraege(Me.C1Referenzvertraege.Columns("Referenzvertragsnr").Value, 0, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ReferenzLoeschenToolStripMenuItem_Click -Methode

Inaktivieren eines Eintrages

[Visual Basic]
Private Sub ReferenzLoeschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReferenzLoeschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReferenzLoeschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReferenzLoeschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(290) = MsgBoxResult.Yes Then
                Me.Vertragselement.Vertragselement_Referenz.Delete_Referenz(Me.C1Referenzvertraege.Columns("Referenzvertragsnr").Value)
                evh.Refernzvertrag_Geloescht()
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ReferenzNeuToolStripMenuItem_Click -Methode

Neue Vertragsreferenz

[Visual Basic]
Private Sub ReferenzNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ReferenzNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ReferenzNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReferenzNeuToolStripMenuItem.Click
        Try
            Dim f As New frmReferenzvertraege(0, Me.Vertragselement.iVertragselementnr.Value, Me.FormReadonly, True)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ReferenzenMenuStrip_Opening -Methode

Handelt das Opending-Ereignis des Context-Menus

[Visual Basic]
Private Sub ReferenzenMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   ReferenzenMenuStrip.Opening

Parameter

sender
e

Hinweise

Überi Disable_Enable_Menu werden die Menueinträge aktiviert bzw. deaktiviert

Quellcode

[Visual Basic]
    Private Sub ReferenzenMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles ReferenzenMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Referenzvertraege)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement | Disable_Enable_Menu


frmVertragselement.Refresh_Aktivitaeten -Methode

Vertragsereignisse aktualiseren

[Visual Basic]
Private Sub Refresh_Aktivitaeten()

Quellcode

[Visual Basic]
    Private Sub Refresh_Aktivitaeten()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Aktivitaeten.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Aktivitaeten.Bookmark

        Me.C1Aktivitaeten.Enabled = False
        Me.Vertragselement.Get_Aktivitaeten(Me.C1Aktivitaeten)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Aktivitaeten, "Aktivitaet", Me.Vertragselement.Aktivitaeten.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Aktivitaeten.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Aktivitaeten.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1Aktivitaeten.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Applikationen -Methode

Applikationen aktualiseren

[Visual Basic]
Private Sub Refresh_Applikationen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Applikationen()
        Try

            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Applikationen.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Applikationen.Bookmark

        Me.C1Applikationen.Enabled = False
        Me.Vertragselement.Get_Applikationen(Me.C1Applikationen, Me.Vertragselement.iVertragselementnr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Applikationen, "VertragselementApplikation", Me.Vertragselement.VertragselementApplikationen.Tabledata)
        sec.Set_Form_Security(Me)
        Try
            If filtertext <> "none" Then Me.C1Applikationen.Columns("Aktiv").FilterText = filtertext
        Catch ex As Exception
        End Try

        Try
            Me.C1Applikationen.Bookmark = bm
        Catch ex As Exception
        End Try

        Me.C1Applikationen.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Dokumente -Methode

Dokumetne_Aktualisieren

[Visual Basic]
Private Sub Refresh_Dokumente()

Quellcode

[Visual Basic]
    Private Sub Refresh_Dokumente()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Dokumente.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Dokumente.Bookmark

        Me.C1Dokumente.Enabled = False
        Me.Vertragselement.Get_Dokumente(Me.C1Dokumente, Me.ImageListeDocIcon)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Dokumente, "Dokument", Me.Vertragselement.dokumente)
        If filtertext <> "none" Then Me.C1Dokumente.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1Dokumente.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1Dokumente.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_History -Methode

History Aktualisieren

[Visual Basic]
Private Sub Refresh_History()

Quellcode

[Visual Basic]
    Private Sub Refresh_History()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1History.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1History.Bookmark

        Me.C1History.Enabled = False
        Me.Vertragselement.Get_History(Me.C1History)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1History, "History", Me.Vertragselement.History.Tabledata)
        If filtertext <> "none" Then Me.C1History.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1History.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1History.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Kontakte -Methode

Kontakte aktualisieren

[Visual Basic]
Private Sub Refresh_Kontakte()

Quellcode

[Visual Basic]
    Private Sub Refresh_Kontakte()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Kontakte.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Kontakte.Bookmark

        Me.C1Kontakte.Enabled = False
        Me.Vertragselement.Get_Vertragskontakte(Me.C1Kontakte)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Vertragskontakt", Me.Vertragselement.Vertragskontakte.Tabledata)
        If filtertext <> "none" Then Me.C1Kontakte.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1Kontakte.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1Kontakte.Enabled = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Kuendigungsfrist -Methode

Kündigungsfristen aktualisieren

[Visual Basic]
Private Sub Refresh_Kuendigungsfrist()

Quellcode

[Visual Basic]
    Private Sub Refresh_Kuendigungsfrist()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception

        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Kuendigungsfristen.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Kuendigungsfristen.Bookmark

        Me.C1Kuendigungsfristen.Enabled = False
        Me.Vertragselement.Get_Kuendigungsfristen(Me.C1Kuendigungsfristen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kuendigungsfristen, "Kuendigungsfrist", Me.Vertragselement.Kuendigungsfristen.Tabledata)
        If filtertext <> "none" Then Me.C1Kuendigungsfristen.Columns("Aktiv").FilterText = filtertext
        Disable_Enable_Menu(Me.KuendigungsfristMenuStrip, Me.C1Kuendigungsfristen)

        Try
            Me.C1Kuendigungsfristen.Bookmark = bm
        Catch ex As Exception
        End Try

        Me.C1Kuendigungsfristen.Enabled = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Pendenzen -Methode

Vertragsereignisse aktualiseren

[Visual Basic]
Private Sub Refresh_Pendenzen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Pendenzen()
        Try

            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Pendenzen.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Pendenzen.Bookmark

        Me.C1Pendenzen.Enabled = False
        Me.Vertragselement.Get_Pendenzen(Me.C1Pendenzen, Me.Vertragselement.iVertragselementnr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Pendenzen, "Pendenz", Me.Vertragselement.Pendenzen.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Pendenzen.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Pendenzen.Bookmark = bm
        Catch ex As Exception
        End Try

        Me.C1Pendenzen.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Registerlasche -Methode

Aktuelle Registerlasche aktualisieren

[Visual Basic]
Private Sub Refresh_Registerlasche()

Quellcode

[Visual Basic]
    Private Sub Refresh_Registerlasche()
        Select Case Me.TabControlDiverse.SelectedTab.Text
            Case "Vertragsinhalt", "Suchbegriffe"
            Case "Applikationen"
                Refresh_Applikationen()
            Case "Kündigungsfristen"
                Refresh_Kuendigungsfrist()
            Case "Kontakte"
                Refresh_Kontakte()
            Case "Dokumente"
                Refresh_Dokumente()
            Case "Services"
                Refresh_Services()
            Case "Ereignisse"
                Refresh_Vertragsereignisse()
            Case "Aktivitäten"
                Refresh_Aktivitaeten()
            Case "Pendenzen"
                Refresh_Pendenzen()
            Case "Referenzverträge"
                Refresh_Vertragselement_Referenzen()
            Case "History"
                Refresh_History()
        End Select

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_SLATable -Methode

[Visual Basic]
Private Sub Refresh_SLATable()

Quellcode

[Visual Basic]
    Private Sub Refresh_SLATable()
        Try
            Check_Changes()
            Me.ServiceKatalogSLAKatalog.dispose()
        Catch
        End Try

        Dim keyvalue As String = ""
        keyvalue = Me.C1Services.Columns("ServiceKatalogNr").Value
        Me.C1SLA.Enabled = False
        Me.ServiceKatalogSLAKatalog = New TKB.VV.Sysadmin.DomainTable("servicekatalog_slakatalog", keyvalue, Globals.clsmitarbeiter.iMitarbeiternr.Value)
        Me.C1SLA.DataSource = ServiceKatalogSLAKatalog.Tabledata
        Me.C1SLA.DataMember = ServiceKatalogSLAKatalog.Tabledata.Tables(0).TableName
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1SLA, "servicekatalog_slakatalog", Me.ServiceKatalogSLAKatalog.Tabledata)
        Me.C1SLA.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Services -Methode

Services aktualiseren

[Visual Basic]
Private Sub Refresh_Services()

Quellcode

[Visual Basic]
    Private Sub Refresh_Services()
        Try

            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Services.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Services.Bookmark

        Me.C1Services.Enabled = False
        Me.Vertragselement.Get_Services(Me.C1Services, Me.Vertragselement.iVertragselementnr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Services, "Vertragsleistung", Vertragselement.Services.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Services.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Services.Bookmark = bm
        Catch ex As Exception
        End Try

        'Me.C1Services.GroupedColumns.Add(Me.C1Services.Columns("Entrykey"))

        Me.C1Services.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Vertragselement_Referenzen -Methode

Vertragsereignisse aktualiseren

[Visual Basic]
Private Sub Refresh_Vertragselement_Referenzen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Vertragselement_Referenzen()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Referenzvertraege.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Referenzvertraege.Bookmark

        Me.C1Referenzvertraege.Enabled = False
        Me.Vertragselement.Get_Vertragselement_Referenzen(Me.C1Referenzvertraege, Me.Vertragselement.iVertragselementnr.Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Referenzvertraege, "Vertragselement_Referenz", Me.Vertragselement.Vertragselement_Referenzen.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Referenzvertraege.Columns("Aktiv").FilterText = filtertext
        Dim bmp0 As New Bitmap(Me.ImageListeReferenzVertrasege.Images(1))
        Dim bmp1 As New Bitmap(Me.ImageListeReferenzVertrasege.Images(0))
        Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()

        v0.DisplayValue = bmp0
        v0.Value = 0

        v1.DisplayValue = bmp1
        v1.Value = 1
        Me.C1Referenzvertraege.Columns("Owner").ValueItems.Values.Add(v0)
        Me.C1Referenzvertraege.Columns("Owner").ValueItems.Values.Add(v1)
        Me.C1Referenzvertraege.Columns("Owner").ValueItems.Translate = True
        Me.C1Referenzvertraege.Enabled = True
        Me.C1Referenzvertraege.Splits(0).DisplayColumns("Owner").Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center
        Try
            Me.C1Referenzvertraege.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1Referenzvertraege.Enabled = True

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Refresh_Vertragsereignisse -Methode

Vertragsereignisse aktualiseren

[Visual Basic]
Private Sub Refresh_Vertragsereignisse()

Quellcode

[Visual Basic]
    Private Sub Refresh_Vertragsereignisse()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1Ereignisse.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1Ereignisse.Bookmark

        Me.C1Ereignisse.Enabled = False
        Me.Vertragselement.Get_Vertragsereignisse(Me.C1Ereignisse)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Ereignisse, "Vertragsereignis", Me.Vertragselement.Vertragsereignisse.Tabledata)
        sec.Set_Form_Security(Me)
        If filtertext <> "none" Then Me.C1Ereignisse.Columns("Aktiv").FilterText = filtertext

        Try
            Me.C1Ereignisse.Bookmark = bm
        Catch ex As Exception

        End Try
        Me.C1Ereignisse.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Vertragselement.iVertragspartnerNr = New SqlInt32(CType(Me.Aktueller_Vertragspartner, Int32))
        Vertragselement.iVertragstypNr = New SqlInt32(CType(Me.cboxVertragstyp.SelectedValue, Int32))
        Vertragselement.iParentID = New SqlInt32(CType(Me.cbboxParentTree.SelectedNode.Tag, Int32))

        Vertragselement.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        Vertragselement.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        Vertragselement.sNummer = New SqlString(CType(Me.txtVertragsnummer.Text, String))

        If IsDate(Me.txtVersionsdatum.Text) Then
            Vertragselement.daVersionsdatum = New SqlDateTime(CType(Me.txtVersionsdatum.Text, DateTime))
        Else
            Vertragselement.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtVertragsbegin.Text) Then
            Vertragselement.daVertragsbeginn = New SqlDateTime(CType(Me.txtVertragsbegin.Text, DateTime))
        Else
            Vertragselement.daVertragsbeginn = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtVertragsende.Text) Then
            Vertragselement.daVertragsablauf = New SqlDateTime(CType(Me.txtVertragsende.Text, DateTime))
        Else
            Vertragselement.daVertragsablauf = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtMindestvertragsdauerbis.Text) Then
            Vertragselement.daMindestvertragsdauer_bis = New SqlDateTime(CType(Me.txtMindestvertragsdauerbis.Text, DateTime))
        Else
            Vertragselement.daMindestvertragsdauer_bis = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtUnterzeichnetam.Text) Then
            Vertragselement.daUnterzeichnet_am = New SqlDateTime(CType(Me.txtUnterzeichnetam.Text, DateTime))
        Else
            Vertragselement.daUnterzeichnet_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtGekuendigtam.Text) Then
            Vertragselement.daGekuendigt_am = New SqlDateTime(CType(Me.txtGekuendigtam.Text, DateTime))
        Else
            Vertragselement.daGekuendigt_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtGekuendigtper.Text) Then
            Vertragselement.daGekuendigt_per = New SqlDateTime(CType(Me.txtGekuendigtper.Text, DateTime))
        Else
            Vertragselement.daGekuendigt_per = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        Vertragselement.bBefristet_Unbefristet = New SqlBoolean(CType(Me.rbbefristet.Checked = True, Boolean))
        Vertragselement.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Vertragselement.sBeschreibung = New SqlString(CType(Me.txtBeschreibung.Text, String))
        Vertragselement.sSuchbegriffe = New SqlString(CType(Me.txtSuchbegriffe.Text, String))
        Vertragselement.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))

        Vertragselement.iApplikationNr = New SqlInt32(CType(0, Int32))
        Vertragselement.iLizenztypnr = New SqlInt32(CType(0, Int32))
        Vertragselement.sLizenzdetails = New SqlString(CType("", String))
        Vertragselement.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ServiceAnzeigenToolStripMenuItem_Click -Methode

Vertragsleistung anzeigen

[Visual Basic]
Private Sub ServiceAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ServiceAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServiceAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ServiceAnzeigenToolStripMenuItem.Click
        Dim f As New frmServicekatalog(Me.C1Services.Columns("Servicekatalognr").Value, True)
        f.MdiParent = Me.MdiParent
        f.Show()
        Exit Sub
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ServiceLoeschenToolStripMenuItem_Click -Methode

Vertragsleistung inaktivieren

[Visual Basic]
Private Sub ServiceLoeschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ServiceLoeschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServiceLoeschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ServiceLoeschenToolStripMenuItem.Click
        Try
            If msg.Show_MessageYesNo(305) = MsgBoxResult.Yes Then
                Me.Vertragselement.Service.Delete_Vertragsleistung(Me.C1Services.Columns("vertragsleistungnr").Value)
                evh.Service_Geloescht()
            End If
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ServiceMenuStrip_Opening -Methode

[Visual Basic]
Private Sub ServiceMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   ServiceMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServiceMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles ServiceMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Services)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ServiceNeuToolStripMenuItem_Click -Methode

Neue Vertragsleistung erstellen

[Visual Basic]
Private Sub ServiceNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ServiceNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ServiceNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ServiceNeuToolStripMenuItem.Click
        Try
            Me.Vertragselement.Add_Service(Me.Vertragselement.iVertragselementnr.Value, Me)
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.Set_Titel -Methode

[Visual Basic]
Private Sub Set_Titel()

Quellcode

[Visual Basic]
    Private Sub Set_Titel()
        Me.Text = "Vertragselement - " + Me.txtBezeichnung.Text
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Vertragselement.Create_Copy(Me.Vertragselement.iVertragselementnr.Value))
        Me.Vertragselement.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Vertragselement.Delete_Vertragselement(Me.Vertragselement.iVertragselementnr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        If Me.txtVertragspartner.Enabled = False Then
            While Vertragselement.Vertragspartner_suchen(Me.Aktueller_Vertragspartner, Me.txtVertragspartner) = False
                msg.show_standardmessage(900, MsgBoxStyle.Critical)
            End While
            Me.Aktuelles_Vertragselement = Me.Vertragselement.Add_New(Me.Aktueller_Vertragspartner)
            Me.Get_Data(Me.Vertragselement.Add_New(Me.Aktueller_Vertragspartner))
        Else
            Me.Aktuelles_Vertragselement = Me.Vertragselement.Add_New(Me.Aktueller_Vertragspartner)
        End If
        Me.Get_Data(Me.Aktuelles_Vertragselement)
        Me.Vertragselement.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_data()
        Me.txtMutiertam.Text = Me.Vertragselement.daMutiert_am.ToString
        Me.Save_Vertragstyp = Me.cboxVertragstyp.SelectedValue
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TSBtnSuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        If Not Me.FormReadonly Then Check_Changes()
        Dim i As Integer
        If Me.Vertragselement.Suchen(i) = True Then
            Me.Get_Data(i)

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.TabControlDiverse_SelectedIndexChanged -Methode

Index-Wechsel auf TabControlDiverse

[Visual Basic]
Private Sub TabControlDiverse_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabControlDiverse.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TabControlDiverse_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControlDiverse.SelectedIndexChanged
        Refresh_Registerlasche()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.ToolStripMenuItem1_Click -Methode

[Visual Basic]
Private Sub ToolStripMenuItem1_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ToolStripMenuItem1.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ToolStripMenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ToolStripMenuItem1.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.btnSearchAppl_Click -Methode

[Visual Basic]
Private Sub btnSearchAppl_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSearchAppl_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Dim f As New frmVertragselementApplikation(Me.Aktuelles_Vertragselement, True)
            f.ShowDialog()
            If f.SelectedApplication <> 0 Then
                '               Me.cbboxApplikationTree.SelectedNode = Me.ApplTree.FindNode(Me.cbboxApplikationTree.TreeView.Nodes, f.SelectedApplication, "")
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.btnVertragspartnersuche_Click -Methode

Vertragspartner suchen. Sofern dieser gewechselt wird, die Parentid des Vertragselementes auf 0 setzen und cbboxParentTree neu aufbauen

[Visual Basic]
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        If Not Me.FormReadonly Then
            If Me.Vertragselement.Check_Is_Parent_Has_Childs(Me.Aktuelles_Vertragselement) = True Then
                msg.show_standardmessage(856, MsgBoxStyle.Critical)
                Exit Sub
            End If
            If Vertragselement.Vertragspartner_suchen(Me.Aktueller_Vertragspartner, Me.txtVertragspartner) = True Then
                Me.Vertragselement.iParentID = New SqlInt32(CType(0, Int32))
                Me.cbboxParentTree.TreeView.Nodes.Clear()
                Me.Vertragselement.Parentelemente.Load_ParentElemente(Me.Vertragselement.iVertragspartnerNr.Value, Me.Vertragselement.iParentID.Value, Me.cbboxParentTree.TreeView)
                Application.DoEvents()
                Me.cbboxParentTree.TreeView.Visible = False
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.cbboxParentTree_AfterSelect -Methode

Änderung des Parent-Auswahl. Prüfung, ob das Element ausgewählt werden kann

[Visual Basic]
Private Sub cbboxParentTree_AfterSelect( _
   ByVal sender As Object _
) Handles  _
   cbboxParentTree.AfterSelect

Parameter

sender

Quellcode

[Visual Basic]
    Private Sub cbboxParentTree_AfterSelect(ByVal sender As System.Object) Handles cbboxParentTree.AfterSelect
        Try
            If cbboxParentTree.SelectedNode.Tag = Me.Vertragselement.iVertragselementnr.Value Then
                msg.show_standardmessage(306, MsgBoxStyle.Critical)
                Me.cbboxParentTree.SelectedNode = Me.Vertragselement.Parentelemente.FindNode(Me.cbboxParentTree.TreeView.Nodes, 0, "")
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.cboxVertragstyp_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cboxVertragstyp_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxVertragstyp.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxVertragstyp_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxVertragstyp.SelectedIndexChanged
        Dim TypUrsprung_Lizenzelement As Boolean = False
        Dim TypNeu_Lizenzelement As Boolean = False
        Try
            TypUrsprung_Lizenzelement = Me.Vertragselement.Lizenzinformationen.Check_Vertragstyp_Fuer_Lizenz(Me.Save_Vertragstyp)
            TypNeu_Lizenzelement = Me.Vertragselement.Lizenzinformationen.Check_Vertragstyp_Fuer_Lizenz(Me.cboxVertragstyp.SelectedValue)

            If TypUrsprung_Lizenzelement = True And TypNeu_Lizenzelement = False Then
                If Me.Check_Changes = False Then
                    Me.cboxVertragstyp.SelectedValue = Me.Save_Vertragstyp
                    Me.FormDataChanged = False
                    Exit Sub
                End If
                Dim ds As New DataSet
                If Me.Vertragselement.Lizenzinformationen.aktive_lizenzinformationen_vorhanden(Me.Aktuelles_Vertragselement) Then
                    msg.show_standardmessage(803, MsgBoxStyle.Critical)
                    Me.cboxVertragstyp.SelectedValue = Me.Save_Vertragstyp
                    Me.FormDataChanged = True
                End If
            End If

        Catch ex As Exception

        End Try
        Try
            Me.Vertragselement.IsLizenzElement = Me.Vertragselement.Lizenzinformationen.Check_Vertragstyp_Fuer_Lizenz(Me.cboxVertragstyp.SelectedValue)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.evh_FormularPendenz_Closed -Methode

[Visual Basic]
Private Sub evh_FormularPendenz_Closed() Handles  _
   evh.Update_Uebersicht

Quellcode

[Visual Basic]
    Private Sub evh_FormularPendenz_Closed() Handles evh.Update_Uebersicht
        Try
            Me.Refresh_Registerlasche()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.evh_FormularVertragselementApplikation_Closed -Methode

Ereignis bei geschlossenem Applikationsfesnter

[Visual Basic]
Private Sub evh_FormularVertragselementApplikation_Closed() Handles  _
   evh.Update_Uebersicht

Quellcode

[Visual Basic]
    Private Sub evh_FormularVertragselementApplikation_Closed() Handles evh.Update_Uebersicht
        Try
            Me.Refresh_Registerlasche()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.frmVertragselement_Load -Methode

Load-Methode

[Visual Basic]
Private Sub frmVertragselement_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragselement_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.On_Load = True
        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        sec.Set_Form_Security(Me)
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Me.Save_LizenzTabPage = Me.TabControlDiverse.TabPages("TabLizenz")
        Me.Save_ApplicationTabPage = Me.TabControlDiverse.TabPages("TabApplikation")

        Load_Securitylevel()

        'Vertragstypen laden
        Me.cboxVertragstyp.DataSource = Me.Vertragselement.Vertragstypen
        Me.cboxVertragstyp.DisplayMember = "Vertragstyp"
        Me.cboxVertragstyp.ValueMember = "VertragstypNr"

        AddChanges(Me)

        Get_Data(Me.Aktuelles_Vertragselement)

        If Me.cboxVertragstyp.SelectedValue = 4 Then
            Dim fnt As New Font("Courier New", 8.25)
            Me.txtBeschreibung.Font = fnt
        End If

        If Me.FormReadonly Then
            sec.Set_Form_Readonly(Me)
        End If
        Me.FormDataChanged = False
        Me.On_Load = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.frmVertragselement_Shown -Methode

Shown-Ereigns

[Visual Basic]
Private Sub frmVertragselement_Shown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Shown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragselement_Shown(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Shown
        'If Me.Aktuelles_Vertragselement = -1 Then
        ' TSBtnSuche_Click(sender, e)
        ' End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.txtBezeichnung_TextChanged -Methode

[Visual Basic]
Private Sub txtBezeichnung_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtBezeichnung.TextChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtBezeichnung_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung.TextChanged
        Me.set_titel()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.txtVertragsende_Leave -Methode

[Visual Basic]
Private Sub txtVertragsende_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtVertragsende.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtVertragsende_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtVertragsende.Leave
        If Trim(Me.txtVertragsende.Text) <> ".  ." Then
            Me.rbbefristet.Checked = True
            Me.rbUnbefristet.Checked = False
        Else
            Me.rbbefristet.Checked = False
            Me.rbUnbefristet.Checked = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement-Felder

frmVertragselement Übersicht

Felder

private field Aktueller_Vertragspartner

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field ApplTree

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field On_Load

Unterstützt von .NET Compact Framework
private field Save_ApplicationTabPage

Unterstützt von .NET Compact Framework
private field Save_LizenzTabPage

Unterstützt von .NET Compact Framework
private field Save_Vertragstyp

Unterstützt von .NET Compact Framework
private field ServiceKatalogSLAKatalog

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragselement -Klasse


Aktueller_Vertragspartner -Feld

[Visual Basic]
Private Aktueller_Vertragspartner As Integer

Quellcode

[Visual Basic]
    Private Aktueller_Vertragspartner As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Aktuelles_Vertragselement -Feld

[Visual Basic]
Private Aktuelles_Vertragselement As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragselement As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


ApplTree -Feld

[Visual Basic]
Private ApplTree As clsApplikationTree

Quellcode

[Visual Basic]
    Dim ApplTree As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


On_Load -Feld

[Visual Basic]
Private On_Load As Boolean

Quellcode

[Visual Basic]
    Dim On_Load As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Save_ApplicationTabPage -Feld

[Visual Basic]
Private Save_ApplicationTabPage As TabPage

Quellcode

[Visual Basic]
    Dim Save_ApplicationTabPage As TabPage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Save_LizenzTabPage -Feld

[Visual Basic]
Private Save_LizenzTabPage As TabPage

Quellcode

[Visual Basic]
    Dim Save_LizenzTabPage As TabPage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Save_Vertragstyp -Feld

[Visual Basic]
Private Save_Vertragstyp As Integer

Quellcode

[Visual Basic]
    Dim Save_Vertragstyp As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


ServiceKatalogSLAKatalog -Feld

[Visual Basic]
Private ServiceKatalogSLAKatalog As DomainTable

Quellcode

[Visual Basic]
    Dim ServiceKatalogSLAKatalog As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


Vertragselement -Feld

[Visual Basic]
Private Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
    Dim Vertragselement As New TKB.VV.Vertrag.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselementApplikation -Klasse

For a list of all members of this type, see frmVertragselementApplikation-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragselementApplikation

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragselementApplikation
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragselementApplikation-Member


frmVertragselementApplikation-Member

frmVertragselementApplikation Übersicht

Öffentliche Konstruktoren

public constructor frmVertragselementApplikation -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property SelectedApplication

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method ApplikationAuswählenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ContextMenuAuswahl_Opening Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSelect_Click Unterstützt von .NET Compact Framework |
private method TSTxtSuche_Click Unterstützt von .NET Compact Framework |
private method TSTxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method TreeApplikationen_DoubleClick Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method frmVertragselementApplikation_FormClosing Unterstützt von .NET Compact Framework |
private method frmVertragselementApplikation_Load Unterstützt von .NET Compact Framework |
private method tsbtnSuche_Click Unterstützt von .NET Compact Framework |

Felder

private field ApplTree

Unterstützt von .NET Compact Framework
private field Select_Lizenzelement

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field VertrasgelementApplikation

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_SelectedApplication

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework

frmVertragselementApplikation -Klasse


frmVertragselementApplikation -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal vertragselementnr As Integer, _
   Optional ByVal Select_Fuer_Lizenzlement As Boolean = False _
)

Parameter

vertragselementnr
Erforderlich.
Select_Fuer_Lizenzlement
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal vertragselementnr As Integer, Optional ByVal Select_Fuer_Lizenzlement As Boolean = False)
        Me.InitializeComponent()
        Me.Vertragselementnr = vertragselementnr
        Me.Select_Lizenzelement = Select_Fuer_Lizenzlement
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation-Eigenschaften

frmVertragselementApplikation Übersicht

Öffentliche Eigenschaften

public property SelectedApplication

Unterstützt von .NET Compact Framework

frmVertragselementApplikation -Klasse


frmVertragselementApplikation.SelectedApplication -Eigenschaft

[Visual Basic]
Public Property SelectedApplication() As Integer

Quellcode

[Visual Basic]
    Property SelectedApplication() As Integer
        Get
            Return m_SelectedApplication
        End Get
        Set(ByVal value As Integer)
            m_SelectedApplication = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation-Methoden

frmVertragselementApplikation Übersicht

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method ApplikationAuswählenToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method ContextMenuAuswahl_Opening Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework |
private method TSBtnSelect_Click Unterstützt von .NET Compact Framework |
private method TSTxtSuche_Click Unterstützt von .NET Compact Framework |
private method TSTxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method TreeApplikationen_DoubleClick Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method frmVertragselementApplikation_FormClosing Unterstützt von .NET Compact Framework |
private method frmVertragselementApplikation_Load Unterstützt von .NET Compact Framework |
private method tsbtnSuche_Click Unterstützt von .NET Compact Framework |

frmVertragselementApplikation -Klasse


frmVertragselementApplikation.ApplikationAuswählenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub ApplikationAuswählenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ApplikationAuswählenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ApplikationAuswählenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ApplikationAuswählenToolStripMenuItem.Click
        Me.TSBtnSelect_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.ContextMenuAuswahl_Opening -Methode

[Visual Basic]
Private Sub ContextMenuAuswahl_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   ContextMenuAuswahl.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ContextMenuAuswahl_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles ContextMenuAuswahl.Opening
        If Me.TreeApplikationen.SelectedNode.Tag < 1 Then
            Me.ApplikationAuswählenToolStripMenuItem.Enabled = False
        Else
            Me.ApplikationAuswählenToolStripMenuItem.Enabled = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.FindNode -Methode

Suchen eines Knoten Treeview

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
Nodes des TreeView
SearchVal
Tag.Keyvalue
SearchString
Node.Text als Suchbegriff

Quellcode

[Visual Basic]
    Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
        Dim tmpNode As TreeNode
        For Each _child As TreeNode In _nodeCollection
            If InStr(UCase(_child.Text), UCase(SearchString)) > 0 Then
                Return _child
            End If
            tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
            If Not tmpNode Is Nothing Then
                Return tmpNode
            End If
        Next
        Return Nothing
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragselementApplikation))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSelect = New System.Windows.Forms.ToolStripButton
        Me.TSTxtSuche = New System.Windows.Forms.ToolStripTextBox
        Me.tsbtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TreeApplikationen = New System.Windows.Forms.TreeView
        Me.ContextMenuAuswahl = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ApplikationAuswählenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImgListApplikationTree = New System.Windows.Forms.ImageList(Me.components)
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.ContextMenuAuswahl.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(320, 24)
        Me.MenuStrip1.TabIndex = 3
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSelect, Me.TSTxtSuche, Me.tsbtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(320, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSelect
        '
        Me.TSBtnSelect.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSelect.Image = CType(resources.GetObject("TSBtnSelect.Image"), System.Drawing.Image)
        Me.TSBtnSelect.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSelect.Name = "TSBtnSelect"
        Me.TSBtnSelect.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSelect.Text = "Applikation übernehmen"
        '
        'TSTxtSuche
        '
        Me.TSTxtSuche.Name = "TSTxtSuche"
        Me.TSTxtSuche.Size = New System.Drawing.Size(100, 25)
        '
        'tsbtnSuche
        '
        Me.tsbtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.tsbtnSuche.Image = CType(resources.GetObject("tsbtnSuche.Image"), System.Drawing.Image)
        Me.tsbtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.tsbtnSuche.Name = "tsbtnSuche"
        Me.tsbtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.tsbtnSuche.Text = "Suchen"
        '
        'TreeApplikationen
        '
        Me.TreeApplikationen.ContextMenuStrip = Me.ContextMenuAuswahl
        Me.TreeApplikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeApplikationen.HideSelection = False
        Me.TreeApplikationen.HotTracking = True
        Me.TreeApplikationen.ImageIndex = 0
        Me.TreeApplikationen.ImageList = Me.ImgListApplikationTree
        Me.TreeApplikationen.Location = New System.Drawing.Point(0, 49)
        Me.TreeApplikationen.Name = "TreeApplikationen"
        Me.TreeApplikationen.SelectedImageIndex = 0
        Me.TreeApplikationen.Size = New System.Drawing.Size(320, 538)
        Me.TreeApplikationen.TabIndex = 7
        '
        'ContextMenuAuswahl
        '
        Me.ContextMenuAuswahl.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ApplikationAuswählenToolStripMenuItem})
        Me.ContextMenuAuswahl.Name = "ContextMenuAuswahl"
        Me.ContextMenuAuswahl.Size = New System.Drawing.Size(181, 26)
        '
        'ApplikationAuswählenToolStripMenuItem
        '
        Me.ApplikationAuswählenToolStripMenuItem.Name = "ApplikationAuswählenToolStripMenuItem"
        Me.ApplikationAuswählenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.ApplikationAuswählenToolStripMenuItem.Text = "&Applikation auswählen"
        '
        'ImgListApplikationTree
        '
        Me.ImgListApplikationTree.ImageStream = CType(resources.GetObject("ImgListApplikationTree.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListApplikationTree.TransparentColor = System.Drawing.Color.Transparent
        Me.ImgListApplikationTree.Images.SetKeyName(0, "45.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(1, "Run.ico")
        Me.ImgListApplikationTree.Images.SetKeyName(2, "Run_Deleted.ico")
        '
        'frmVertragselementApplikation
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(320, 587)
        Me.Controls.Add(Me.TreeApplikationen)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragselementApplikation"
        Me.Text = "Auswahl Applikation"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ContextMenuAuswahl.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TSBtnSelect_Click -Methode

[Visual Basic]
Private Sub TSBtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSelect.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSelect.Click
        If Not Me.Select_Lizenzelement Then
            If Me.TreeApplikationen.SelectedNode.Tag > 0 Then
                Me.VertrasgelementApplikation.Add_New(Me.Vertragselementnr)
                Me.VertrasgelementApplikation.iApplikationnr = New SqlInt32(CType(Me.TreeApplikationen.SelectedNode.Tag, Int32))
                Me.VertrasgelementApplikation.Save_Data()
                Me.SelectedApplication = Me.TreeApplikationen.SelectedNode.Tag
                Globals.MyEventHanlder.Vertragsapplikation_Closed()
                Me.Close()
            Else
                msg.show_standardmessage(307, MsgBoxStyle.Critical)
            End If
        Else
            If Me.TreeApplikationen.SelectedNode.Tag > 0 Then
                Me.SelectedApplication = Me.TreeApplikationen.SelectedNode.Tag
                Me.Close()
            Else
                msg.show_standardmessage(307, MsgBoxStyle.Critical)
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TSTxtSuche_Click -Methode

[Visual Basic]
Private Sub TSTxtSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSTxtSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSTxtSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSTxtSuche.Click

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TSTxtSuche_KeyDown -Methode

[Visual Basic]
Private Sub TSTxtSuche_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TSTxtSuche.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSTxtSuche_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TSTxtSuche.KeyDown
        If e.KeyCode = Keys.Enter Then
            ApplTree.Load_Tree(Me.TreeApplikationen, False, Me.TSTxtSuche.Text, False)
            '            Me.TreeApplikationen.SelectedNode = Me.FindNode(Me.TreeApplikationen.Nodes, 0, Me.TSTxtSuche.Text)
            Try
                Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)
            Catch
            End Try
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TreeApplikationen_DoubleClick -Methode

[Visual Basic]
Private Sub TreeApplikationen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeApplikationen.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeApplikationen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeApplikationen.DoubleClick
        Me.TSBtnSelect_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.TreeStruktur_MouseDown -Methode

Mousedown-Ereignis auf dem Tree

[Visual Basic]
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeApplikationen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeApplikationen.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.GetNodeAt(selectPoint)

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.frmVertragselementApplikation_FormClosing -Methode

[Visual Basic]
Private Sub frmVertragselementApplikation_FormClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragselementApplikation_FormClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        Me.ApplTree = Nothing
        Me.VertrasgelementApplikation.dispose()
        msg.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.frmVertragselementApplikation_Load -Methode

[Visual Basic]
Private Sub frmVertragselementApplikation_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragselementApplikation_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        ApplTree.Load_Tree(Me.TreeApplikationen, False)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation.tsbtnSuche_Click -Methode

[Visual Basic]
Private Sub tsbtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   tsbtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub tsbtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles tsbtnSuche.Click
        ApplTree.Load_Tree(Me.TreeApplikationen, False, Me.TSTxtSuche.Text, False)
        '            Me.TreeApplikationen.SelectedNode = Me.FindNode(Me.TreeApplikationen.Nodes, 0, Me.TSTxtSuche.Text)
        Me.TreeApplikationen.SelectedNode = Me.TreeApplikationen.Nodes(0)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementApplikation-Felder

frmVertragselementApplikation Übersicht

Felder

private field ApplTree

Unterstützt von .NET Compact Framework
private field Select_Lizenzelement

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field VertrasgelementApplikation

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field m_SelectedApplication

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework

frmVertragselementApplikation -Klasse


ApplTree -Feld

[Visual Basic]
Private ApplTree As clsApplikationTree

Quellcode

[Visual Basic]
    Dim ApplTree As New TKB.VV.Applikation.clsApplikationTree

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


Select_Lizenzelement -Feld

[Visual Basic]
Private Select_Lizenzelement As Boolean

Quellcode

[Visual Basic]
    Dim Select_Lizenzelement As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


Vertragselementnr -Feld

[Visual Basic]
Private Vertragselementnr As Integer

Quellcode

[Visual Basic]
    Dim Vertragselementnr As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


VertrasgelementApplikation -Feld

[Visual Basic]
Private VertrasgelementApplikation As clsVertragselementApplikation

Quellcode

[Visual Basic]
    Dim VertrasgelementApplikation As New TKB.VV.Vertrag.clsVertragselementApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


m_SelectedApplication -Feld

[Visual Basic]
Private m_SelectedApplication As Integer

Quellcode

[Visual Basic]
    Dim m_SelectedApplication As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementApplikation


frmVertragselementSuche -Klasse

Vertragselementsuche

For a list of all members of this type, see frmVertragselementSuche-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragselementSuche

[Visual Basic]
Public Class frmVertragselementSuche
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragselementSuche-Member


frmVertragselementSuche-Member

frmVertragselementSuche Übersicht

Öffentliche Eigenschaften

public property Vertragselement_Bezeichnung

Unterstützt von .NET Compact Framework
public property Vertragselementnr

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

 Destructor Dispose

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method BtnSchliessen_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method BtnSelect_Click Unterstützt von .NET Compact Framework | BtnSelect gewählt
private method BtnSuche_Click Unterstützt von .NET Compact Framework | Suche ausführen
private method C1Vertragselementliste_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick in C1Partnerliste
private method C1Vertragselementliste_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
private method DetailsAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Details anzeigen gewählt
private method FrmVertragspartnerSuche_Load Unterstützt von .NET Compact Framework | Load des Dialogs
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Serach_data Unterstützt von .NET Compact Framework | Vertragspartner aus DB auslesen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method Vertragselement_Suchen Unterstützt von .NET Compact Framework | Vertragselement suchen
private method txt_KeyDown Unterstützt von .NET Compact Framework | Textfelder KeyDown
private method ÜberrnehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Übernehmen gewählt

Felder

private field components

Unterstützt von .NET Compact Framework
private field d

Unterstützt von .NET Compact Framework
private field m_Vertragselement_Bezeichnung

Unterstützt von .NET Compact Framework
private field m_Vertragselementnr

Unterstützt von .NET Compact Framework

frmVertragselementSuche -Klasse


frmVertragselementSuche-Eigenschaften

frmVertragselementSuche Übersicht

Öffentliche Eigenschaften

public property Vertragselement_Bezeichnung

Unterstützt von .NET Compact Framework
public property Vertragselementnr

Unterstützt von .NET Compact Framework

frmVertragselementSuche -Klasse


frmVertragselementSuche.Vertragselement_Bezeichnung -Eigenschaft

[Visual Basic]
Public Property Vertragselement_Bezeichnung() As String

Quellcode

[Visual Basic]
    Property Vertragselement_Bezeichnung() As String
        Get
            Dim ve As New TKB.VV.DB.clsVertragselement
            Try
                ve.cpMainConnectionProvider = Globals.conn
                ve.iVertragselementnr = New SqlInt32(CType(Me.Vertragselementnr, Int32))
                ve.SelectOne()
                Return ve.sBezeichnung.Value
            Catch ex As Exception
            Finally
                ve.Dispose()
            End Try
        End Get
        Set(ByVal value As String)

        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.Vertragselementnr -Eigenschaft

[Visual Basic]
Public Property Vertragselementnr() As Integer

Quellcode

[Visual Basic]
    Property Vertragselementnr() As Integer
        Get
            Return m_Vertragselementnr
        End Get
        Set(ByVal value As Integer)
            m_Vertragselementnr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche-Methoden

frmVertragselementSuche Übersicht

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

 Destructor Dispose

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method BtnSchliessen_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method BtnSelect_Click Unterstützt von .NET Compact Framework | BtnSelect gewählt
private method BtnSuche_Click Unterstützt von .NET Compact Framework | Suche ausführen
private method C1Vertragselementliste_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick in C1Partnerliste
private method C1Vertragselementliste_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
private method DetailsAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Details anzeigen gewählt
private method FrmVertragspartnerSuche_Load Unterstützt von .NET Compact Framework | Load des Dialogs
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Serach_data Unterstützt von .NET Compact Framework | Vertragspartner aus DB auslesen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method Vertragselement_Suchen Unterstützt von .NET Compact Framework | Vertragselement suchen
private method txt_KeyDown Unterstützt von .NET Compact Framework | Textfelder KeyDown
private method ÜberrnehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Übernehmen gewählt

frmVertragselementSuche -Klasse


frmVertragselementSuche.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.BtnSchliessen_Click -Methode

Schliessen des Fensters

[Visual Basic]
Private Sub BtnSchliessen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSchliessen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSchliessen.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.BtnSelect_Click -Methode

BtnSelect gewählt

[Visual Basic]
Private Sub BtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSelect.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSelect.Click
        Me.Vertragselementnr = Me.C1Vertragselementliste.Columns("Vertragselementnr").Value
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.BtnSuche_Click -Methode

Suche ausführen

[Visual Basic]
Private Sub BtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSuche.Click
        Vertragselement_suchen()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.C1Vertragselementliste_DoubleClick -Methode

Doubleklick in C1Partnerliste

[Visual Basic]
Private Sub C1Vertragselementliste_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Vertragselementliste.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselementliste_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Vertragselementliste.DoubleClick
        If Me.C1Vertragselementliste.Splits(0).Rows.Count > 0 Then
            Me.BtnSelect_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.C1Vertragselementliste_MouseDown -Methode

Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird

[Visual Basic]
Private Sub C1Vertragselementliste_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Vertragselementliste.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselementliste_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Vertragselementliste.MouseDown
        Me.C1Vertragselementliste.Bookmark = Me.C1Vertragselementliste.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.DetailsAnzeigenToolStripMenuItem_Click -Methode

Kontextmenu Details anzeigen gewählt

[Visual Basic]
Private Sub DetailsAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragselement(Me.C1Vertragselementliste.Columns("Vertragselementnr").Value, True)
        f.ShowDialog()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.FrmVertragspartnerSuche_Load -Methode

Load des Dialogs

[Visual Basic]
Private Sub FrmVertragspartnerSuche_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmVertragspartnerSuche_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Vertragselementnr = -1
        Me.BtnSelect.Enabled = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragselementSuche))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblOrt = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.BtnSuche = New System.Windows.Forms.Button
        Me.VertragspartnerMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ÜberrnehmenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DetailsAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.txtSuchbegriffe = New System.Windows.Forms.TextBox
        Me.lblFreitext = New System.Windows.Forms.Label
        Me.BtnSchliessen = New System.Windows.Forms.Button
        Me.BtnSelect = New System.Windows.Forms.Button
        Me.txtInhalt = New System.Windows.Forms.TextBox
        Me.lblInhalt = New System.Windows.Forms.Label
        Me.C1Vertragselementliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.VertragspartnerMenuStrip.SuspendLayout()
        CType(Me.C1Vertragselementliste, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(571, 24)
        Me.MenuStrip1.TabIndex = 8
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(571, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(93, 78)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(166, 20)
        Me.txtBezeichnung.TabIndex = 1
        '
        'lblOrt
        '
        Me.lblOrt.AccessibleDescription = "Name"
        Me.lblOrt.AutoSize = True
        Me.lblOrt.Location = New System.Drawing.Point(9, 81)
        Me.lblOrt.Name = "lblOrt"
        Me.lblOrt.Size = New System.Drawing.Size(69, 13)
        Me.lblOrt.TabIndex = 72
        Me.lblOrt.Text = "Bezeichnung"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(93, 52)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(166, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(9, 55)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 71
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'BtnSuche
        '
        Me.BtnSuche.Location = New System.Drawing.Point(12, 111)
        Me.BtnSuche.Name = "BtnSuche"
        Me.BtnSuche.Size = New System.Drawing.Size(75, 23)
        Me.BtnSuche.TabIndex = 4
        Me.BtnSuche.Text = "Suchen"
        Me.BtnSuche.UseVisualStyleBackColor = True
        '
        'VertragspartnerMenuStrip
        '
        Me.VertragspartnerMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ÜberrnehmenToolStripMenuItem, Me.DetailsAnzeigenToolStripMenuItem})
        Me.VertragspartnerMenuStrip.Name = "VertragspartnerMenuStrip"
        Me.VertragspartnerMenuStrip.Size = New System.Drawing.Size(153, 48)
        '
        'ÜberrnehmenToolStripMenuItem
        '
        Me.ÜberrnehmenToolStripMenuItem.Name = "ÜberrnehmenToolStripMenuItem"
        Me.ÜberrnehmenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.ÜberrnehmenToolStripMenuItem.Text = "Übe&rnehmen"
        '
        'DetailsAnzeigenToolStripMenuItem
        '
        Me.DetailsAnzeigenToolStripMenuItem.Name = "DetailsAnzeigenToolStripMenuItem"
        Me.DetailsAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.DetailsAnzeigenToolStripMenuItem.Text = "&Details anzeigen"
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(393, 74)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(166, 20)
        Me.txtSuchbegriffe.TabIndex = 3
        '
        'lblFreitext
        '
        Me.lblFreitext.AccessibleDescription = "Name"
        Me.lblFreitext.AutoSize = True
        Me.lblFreitext.Location = New System.Drawing.Point(309, 77)
        Me.lblFreitext.Name = "lblFreitext"
        Me.lblFreitext.Size = New System.Drawing.Size(67, 13)
        Me.lblFreitext.TabIndex = 76
        Me.lblFreitext.Text = "Suchbegriffe"
        '
        'BtnSchliessen
        '
        Me.BtnSchliessen.Location = New System.Drawing.Point(12, 347)
        Me.BtnSchliessen.Name = "BtnSchliessen"
        Me.BtnSchliessen.Size = New System.Drawing.Size(80, 24)
        Me.BtnSchliessen.TabIndex = 9
        Me.BtnSchliessen.Text = "Schliessen"
        '
        'BtnSelect
        '
        Me.BtnSelect.Enabled = False
        Me.BtnSelect.Location = New System.Drawing.Point(475, 347)
        Me.BtnSelect.Name = "BtnSelect"
        Me.BtnSelect.Size = New System.Drawing.Size(88, 23)
        Me.BtnSelect.TabIndex = 6
        Me.BtnSelect.Text = "Übernehmen"
        '
        'txtInhalt
        '
        Me.txtInhalt.Location = New System.Drawing.Point(393, 48)
        Me.txtInhalt.Name = "txtInhalt"
        Me.txtInhalt.Size = New System.Drawing.Size(166, 20)
        Me.txtInhalt.TabIndex = 2
        '
        'lblInhalt
        '
        Me.lblInhalt.AccessibleDescription = "Name"
        Me.lblInhalt.AutoSize = True
        Me.lblInhalt.Location = New System.Drawing.Point(309, 51)
        Me.lblInhalt.Name = "lblInhalt"
        Me.lblInhalt.Size = New System.Drawing.Size(33, 13)
        Me.lblInhalt.TabIndex = 80
        Me.lblInhalt.Text = "Inhalt"
        '
        'C1Vertragselementliste
        '
        Me.C1Vertragselementliste.AlternatingRows = True
        Me.C1Vertragselementliste.FetchRowStyles = True
        Me.C1Vertragselementliste.FilterBar = True
        Me.C1Vertragselementliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Vertragselementliste.Images.Add(CType(resources.GetObject("C1Vertragselementliste.Images"), System.Drawing.Image))
        Me.C1Vertragselementliste.Location = New System.Drawing.Point(12, 140)
        Me.C1Vertragselementliste.Name = "C1Vertragselementliste"
        Me.C1Vertragselementliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselementliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragselementliste.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragselementliste.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragselementliste.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragselementliste.Size = New System.Drawing.Size(547, 201)
        Me.C1Vertragselementliste.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Vertragselementliste.TabIndex = 5
        Me.C1Vertragselementliste.Text = "C1TrueDBGrid1"
        Me.C1Vertragselementliste.PropBag = resources.GetString("C1Vertragselementliste.PropBag")
        '
        'frmVertragselementSuche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(571, 376)
        Me.Controls.Add(Me.C1Vertragselementliste)
        Me.Controls.Add(Me.txtInhalt)
        Me.Controls.Add(Me.lblInhalt)
        Me.Controls.Add(Me.BtnSchliessen)
        Me.Controls.Add(Me.BtnSelect)
        Me.Controls.Add(Me.txtSuchbegriffe)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.lblFreitext)
        Me.Controls.Add(Me.BtnSuche)
        Me.Controls.Add(Me.lblOrt)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName_Firma1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragselementSuche"
        Me.Text = "Vertragselement suchen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.VertragspartnerMenuStrip.ResumeLayout(False)
        CType(Me.C1Vertragselementliste, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.Serach_data -Methode

Vertragspartner aus DB auslesen

[Visual Basic]
Private Function Serach_data( _
   ByVal query As String, _
   ByVal fnkt As Integer _
) As DataTable

Parameter

query
fnkt

Quellcode

[Visual Basic]
    Private Function Serach_data(ByVal query As String, ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_vertragselement_search"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 1000, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            sdaAdapter.Fill(dtToReturn)
            Return dttoreturn
        Catch ex As Exception
            Throw New Exception("clsVertragselement::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.TSBtnQuit_Click -Methode

Schliessen des Fensters

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.Vertragselement_Suchen -Methode

Vertragselement suchen

[Visual Basic]
Private Function Vertragselement_Suchen() As Object

Quellcode

[Visual Basic]
    Private Function Vertragselement_Suchen()
        If Me.txtName_Firma1.Text <> "" Then
            d = Serach_data(Me.txtName_Firma1.Text, 0)
        Else
            If Me.txtBezeichnung.Text <> "" Then
                d = Serach_data(Me.txtBezeichnung.Text, 1)
            Else
                If Me.txtInhalt.Text <> "" Then
                    d = Serach_data(Me.txtInhalt.Text, 2)
                Else
                    d = Serach_data(Me.txtSuchbegriffe.Text, 3)
                End If
            End If
        End If
        Me.C1Vertragselementliste.DataSource = d
        Me.C1Vertragselementliste.DataMember = d.TableName

        Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Vertragselementliste, "Vertragselement", d)
        SpaltenTitel = Nothing
        If d.Rows.Count > 0 Then Me.BtnSelect.Enabled = True
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

Destructor Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmVertragselementSuche


frmVertragselementSuche.txt_KeyDown -Methode

Textfelder KeyDown

[Visual Basic]
Private Sub txt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtName_Firma1.KeyDown, _
   txtBezeichnung.KeyDown, _
   txtInhalt.KeyDown, _
   txtSuchbegriffe.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtName_Firma1.KeyDown, txtBezeichnung.KeyDown, txtInhalt.KeyDown, txtSuchbegriffe.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche.ÜberrnehmenToolStripMenuItem_Click -Methode

Kontextmenu Übernehmen gewählt

[Visual Basic]
Private Sub ÜberrnehmenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ÜberrnehmenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ÜberrnehmenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ÜberrnehmenToolStripMenuItem.Click
        Me.BtnSelect_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragselementSuche-Felder

frmVertragselementSuche Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field d

Unterstützt von .NET Compact Framework
private field m_Vertragselement_Bezeichnung

Unterstützt von .NET Compact Framework
private field m_Vertragselementnr

Unterstützt von .NET Compact Framework

frmVertragselementSuche -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


d -Feld

[Visual Basic]
Private d As DataTable

Quellcode

[Visual Basic]
    Dim d As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


m_Vertragselement_Bezeichnung -Feld

[Visual Basic]
Private m_Vertragselement_Bezeichnung As String

Quellcode

[Visual Basic]
    Dim m_Vertragselement_Bezeichnung As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


m_Vertragselementnr -Feld

[Visual Basic]
Private m_Vertragselementnr As Integer

Quellcode

[Visual Basic]
    Dim m_Vertragselementnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmVertragsereignis -Klasse

For a list of all members of this type, see frmVertragsereignis-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragsereignis

[Visual Basic]
Public Class frmVertragsereignis
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragsereignis-Member


frmVertragsereignis-Member

frmVertragsereignis Übersicht

Öffentliche Konstruktoren

public constructor frmVertragsereignis -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Standard Constructore New

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Betrag Unterstützt von .NET Compact Framework | Betragswert prüfen
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Enable_Disable_Datum Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method IsNumeric Unterstützt von .NET Compact Framework | Prüfung, ob es sich um einen numerischen Wert handelt
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Refresh_History Unterstützt von .NET Compact Framework | History
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche_Click Unterstützt von .NET Compact Framework |
private method cboxEreignistyp_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cboxPeriodizität_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method frmVertragsereignis_Load Unterstützt von .NET Compact Framework | Load-Methode
private method txtBetrag_Validating Unterstützt von .NET Compact Framework | Validierung Betragsfeld

Felder

private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragsereignis

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragsereignis

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragsereignis -Klasse


New

Überladungsliste

Standard Constructore New

[Visual Basic] Public Sub New()
[C#] public System.Void frmVertragsereignis();

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Optional Integer, Optional Boolean, Optional Boolean)
[C#] public System.Void frmVertragsereignis(int, int, bool, bool);

frmVertragsereignis


frmVertragsereignis-Methoden

frmVertragsereignis Übersicht

Öffentliche Methoden

public method dispose Überladen.

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Betrag Unterstützt von .NET Compact Framework | Betragswert prüfen
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DateTimePicker_ValueChanged Unterstützt von .NET Compact Framework | Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld
private method Enable_Disable_Datum Unterstützt von .NET Compact Framework |
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Daten ab DB laden uns ins Form befüllen
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method IsNumeric Unterstützt von .NET Compact Framework | Prüfung, ob es sich um einen numerischen Wert handelt
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Refresh_History Unterstützt von .NET Compact Framework | History
private method Save_data Unterstützt von .NET Compact Framework | Daten ab Form speichern
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragselementSuche_Click Unterstützt von .NET Compact Framework |
private method cboxEreignistyp_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method cboxPeriodizität_SelectedIndexChanged Unterstützt von .NET Compact Framework |
private method frmVertragsereignis_Load Unterstützt von .NET Compact Framework | Load-Methode
private method txtBetrag_Validating Unterstützt von .NET Compact Framework | Validierung Betragsfeld

frmVertragsereignis -Klasse


frmVertragsereignis.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Check_Betrag -Methode

Betragswert prüfen

[Visual Basic]
Private Function Check_Betrag() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Betrag() As Boolean
        If Trim(Me.txtBetrag.Text) = "" Then
            Me.txtBetrag.Text = "0.00"
            Return True
        End If

        If Not IsNumeric(Me.txtBetrag.Text) Then
            msg.show_standardmessage(600, MsgBoxStyle.Critical)
            Return False
        End If

        Dim i As Integer
        i = Me.txtBetrag.Text.IndexOf(".")

        If i = -1 Then
            Me.txtBetrag.Text = Me.txtBetrag.Text + ".00"
            Exit Function
        End If

        Dim s = Me.txtBetrag.Text.Substring(i + 1)
        If Len(s) = 0 Then
            Me.txtBetrag.Text = Me.txtBetrag.Text + "00"
            Exit Function
        End If
        If Len(s) = 1 Then
            Me.txtBetrag.Text = Me.txtBetrag.Text + "0"
        End If
        If Len(s) > 2 Then
            msg.show_standardmessage(600, MsgBoxStyle.Critical)
            Return False
        End If
        Return True

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.DateTimePicker_ValueChanged -Methode

Handelt das Change-Ereignis eines Datetimepckers und stellt das ausgewählte Datum in das entsprechende Textfeld

[Visual Basic]
Private Sub DateTimePicker_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   dtPickerDatum.ValueChanged, _
   dtPickerStart.ValueChanged, _
   dtPickerEnde.ValueChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DateTimePicker_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles _
    dtPickerDatum.ValueChanged, dtPickerStart.ValueChanged, dtPickerEnde.ValueChanged
        Dim s As String
        Dim obj As DateTimePicker = sender
        s = obj.Name
        s = "txt" + s.Substring(8, s.Length - 8)
        Dim l As New List(Of Control)
        Dim txtb As MaskedTextBox
        GetControl(Me, s, l)
        For Each ctl As Control In l
            txtb = CType(ctl, MaskedTextBox)
            txtb.Text = obj.Value
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Enable_Disable_Datum -Methode

[Visual Basic]
Private Sub Enable_Disable_Datum()

Quellcode

[Visual Basic]
    Private Sub Enable_Disable_Datum()
        Try
            If Me.cboxPeriodizität.SelectedValue = 1 Then
                Me.dtPickerStart.Enabled = False
                Me.dtPickerEnde.Enabled = False
                Me.txtStart.Enabled = False
                Me.txtEnde.Enabled = False

                Me.dtPickerDatum.Enabled = True
                Me.txtDatum.Enabled = True
            Else
                Me.dtPickerStart.Enabled = True
                Me.dtPickerEnde.Enabled = True
                Me.txtStart.Enabled = True
                Me.txtEnde.Enabled = True

                Me.dtPickerDatum.Enabled = False
                Me.txtDatum.Enabled = False
            End If
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Vertragsereignis.Neuer_Datensatz = True Then Me.Vertragsereignis.Delete(Me.Vertragsereignis.iEreignisNr.Value)
            Globals.MyEventHanlder.Ereignis_Closed()
            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Get_Data -Methode

Daten ab DB laden uns ins Form befüllen

[Visual Basic]
Private Sub Get_Data( _
   ByVal Vertragsereignisnr As Integer _
)

Parameter

Vertragsereignisnr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Vertragsereignisnr As Integer)
        Try
            Vertragsereignis.Get_Ereignis(Vertragsereignisnr)
            Me.Aktuelles_Vertragselement = Me.Vertragsereignis.Vertragselement.iVertragselementnr.Value
            Me.Aktuelles_Vertragsereignis = Vertragsereignisnr
            Me.txtVertragselement.Text = Me.Vertragsereignis.Vertragselement.sBezeichnung.Value
            Me.txtBezeichnung.Text = Me.Vertragsereignis.sBezeichnung.Value
            Me.cboxEreignistyp.SelectedValue = Me.Vertragsereignis.iEreignistypNr.Value

            Me.txtDatum.Text = Me.Vertragsereignis.daDatum.ToString
            Me.txtStart.Text = Me.Vertragsereignis.daStart.ToString
            Me.txtEnde.Text = Me.Vertragsereignis.daEnde.ToString
            Me.txtVorlaufzeit.Text = Me.Vertragsereignis.iVorlaufzeit.Value
            Me.txtBetrag.Text = Me.Vertragsereignis.fBetrag.Value
            Check_Betrag()
            Me.cboxKostenart.SelectedValue = Me.Vertragsereignis.iKostenartNr.Value
            Me.cboxPeriodizität.SelectedValue = Me.Vertragsereignis.iPeriodizitaetNr.Value
            Me.txtBemerkung.Text = Me.Vertragsereignis.sBeschreibung.Value
            Me.txtErstelltam.Text = Vertragsereignis.daErstellt_am.ToString
            Me.txtMutiertam.Text = Vertragsereignis.daMutiert_am.ToString
            Me.txtMutierer.Text = Vertragsereignis.iMutierer.ToString
            Me.cboxSecurityLevel.SelectedValue = Me.Vertragsereignis.iSecurityLevelNr.Value
            Me.cbInklMwSt.Checked = Me.Vertragsereignis.bInklMwSt.Value = True
            Me.cbaktiv.Checked = Me.Vertragsereignis.bAktiv.Value = True

            Me.cboxKuendigungsfrist.SelectedValue = Me.Vertragsereignis.iKuendigungsfristnr.Value
            sec.Set_Form_Security(Me)

            Me.FormDataChanged = False
        Catch ex As Exception
            For Each ctl As ToolStripButton In Me.ToolStrip1.Items
                ctl.Enabled = False
            Next
            Me.TSBtnQuit.Enabled = True
            Me.TSBtnSuche.Enabled = True
        End Try
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragsereignis))
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.lblEreignistyp = New System.Windows.Forms.Label
        Me.cboxEreignistyp = New System.Windows.Forms.ComboBox
        Me.dtPickerEnde = New System.Windows.Forms.DateTimePicker
        Me.dtPickerStart = New System.Windows.Forms.DateTimePicker
        Me.dtPickerDatum = New System.Windows.Forms.DateTimePicker
        Me.txtEnde = New System.Windows.Forms.MaskedTextBox
        Me.txtStart = New System.Windows.Forms.MaskedTextBox
        Me.txtDatum = New System.Windows.Forms.MaskedTextBox
        Me.lblEnde = New System.Windows.Forms.Label
        Me.lblStart = New System.Windows.Forms.Label
        Me.lblDatum = New System.Windows.Forms.Label
        Me.lblPeriodizität = New System.Windows.Forms.Label
        Me.cboxPeriodizität = New System.Windows.Forms.ComboBox
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.txtVertragselement = New System.Windows.Forms.TextBox
        Me.lblVertragselement = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.btnVertragselementSuche = New System.Windows.Forms.Button
        Me.lblVorlaufzeit = New System.Windows.Forms.Label
        Me.txtVorlaufzeit = New System.Windows.Forms.MaskedTextBox
        Me.GroupBox1 = New System.Windows.Forms.GroupBox
        Me.C1History = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.Label1 = New System.Windows.Forms.Label
        Me.cboxKuendigungsfrist = New System.Windows.Forms.ComboBox
        Me.lblKostenart = New System.Windows.Forms.Label
        Me.cboxKostenart = New System.Windows.Forms.ComboBox
        Me.cbInklMwSt = New System.Windows.Forms.CheckBox
        Me.lblBetrag = New System.Windows.Forms.Label
        Me.txtBetrag = New System.Windows.Forms.MaskedTextBox
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripMenuItem1})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(116, 22)
        Me.ToolStripMenuItem1.Tag = ""
        Me.ToolStripMenuItem1.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(645, 24)
        Me.MenuStrip1.TabIndex = 21
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.TSBtnSuche})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(645, 25)
        Me.ToolStrip1.TabIndex = 20
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "ToolStripButton1"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(141, 93)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 1
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(11, 96)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 79
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblEreignistyp
        '
        Me.lblEreignistyp.AutoSize = True
        Me.lblEreignistyp.Location = New System.Drawing.Point(11, 122)
        Me.lblEreignistyp.Name = "lblEreignistyp"
        Me.lblEreignistyp.Size = New System.Drawing.Size(58, 13)
        Me.lblEreignistyp.TabIndex = 81
        Me.lblEreignistyp.Text = "Ereignistyp"
        '
        'cboxEreignistyp
        '
        Me.cboxEreignistyp.FormattingEnabled = True
        Me.cboxEreignistyp.Location = New System.Drawing.Point(141, 119)
        Me.cboxEreignistyp.Name = "cboxEreignistyp"
        Me.cboxEreignistyp.Size = New System.Drawing.Size(268, 21)
        Me.cboxEreignistyp.TabIndex = 2
        '
        'dtPickerEnde
        '
        Me.dtPickerEnde.Location = New System.Drawing.Point(329, 224)
        Me.dtPickerEnde.Name = "dtPickerEnde"
        Me.dtPickerEnde.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerEnde.TabIndex = 10
        Me.dtPickerEnde.TabStop = False
        '
        'dtPickerStart
        '
        Me.dtPickerStart.Location = New System.Drawing.Point(329, 201)
        Me.dtPickerStart.Name = "dtPickerStart"
        Me.dtPickerStart.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerStart.TabIndex = 8
        Me.dtPickerStart.TabStop = False
        '
        'dtPickerDatum
        '
        Me.dtPickerDatum.Location = New System.Drawing.Point(204, 201)
        Me.dtPickerDatum.Name = "dtPickerDatum"
        Me.dtPickerDatum.Size = New System.Drawing.Size(21, 20)
        Me.dtPickerDatum.TabIndex = 6
        Me.dtPickerDatum.TabStop = False
        '
        'txtEnde
        '
        Me.txtEnde.Location = New System.Drawing.Point(266, 224)
        Me.txtEnde.Mask = "00/00/0000"
        Me.txtEnde.Name = "txtEnde"
        Me.txtEnde.Size = New System.Drawing.Size(66, 20)
        Me.txtEnde.TabIndex = 9
        Me.txtEnde.ValidatingType = GetType(Date)
        '
        'txtStart
        '
        Me.txtStart.Location = New System.Drawing.Point(266, 200)
        Me.txtStart.Mask = "00/00/0000"
        Me.txtStart.Name = "txtStart"
        Me.txtStart.Size = New System.Drawing.Size(66, 20)
        Me.txtStart.TabIndex = 7
        Me.txtStart.ValidatingType = GetType(Date)
        '
        'txtDatum
        '
        Me.txtDatum.Location = New System.Drawing.Point(141, 201)
        Me.txtDatum.Mask = "00/00/0000"
        Me.txtDatum.Name = "txtDatum"
        Me.txtDatum.Size = New System.Drawing.Size(66, 20)
        Me.txtDatum.TabIndex = 5
        Me.txtDatum.ValidatingType = GetType(Date)
        '
        'lblEnde
        '
        Me.lblEnde.AutoSize = True
        Me.lblEnde.Location = New System.Drawing.Point(231, 227)
        Me.lblEnde.Name = "lblEnde"
        Me.lblEnde.Size = New System.Drawing.Size(32, 13)
        Me.lblEnde.TabIndex = 115
        Me.lblEnde.Text = "Ende"
        '
        'lblStart
        '
        Me.lblStart.AutoSize = True
        Me.lblStart.Location = New System.Drawing.Point(231, 203)
        Me.lblStart.Name = "lblStart"
        Me.lblStart.Size = New System.Drawing.Size(29, 13)
        Me.lblStart.TabIndex = 114
        Me.lblStart.Text = "Start"
        '
        'lblDatum
        '
        Me.lblDatum.AutoSize = True
        Me.lblDatum.Location = New System.Drawing.Point(12, 204)
        Me.lblDatum.Name = "lblDatum"
        Me.lblDatum.Size = New System.Drawing.Size(38, 13)
        Me.lblDatum.TabIndex = 113
        Me.lblDatum.Text = "Datum"
        '
        'lblPeriodizität
        '
        Me.lblPeriodizität.AutoSize = True
        Me.lblPeriodizität.Location = New System.Drawing.Point(12, 149)
        Me.lblPeriodizität.Name = "lblPeriodizität"
        Me.lblPeriodizität.Size = New System.Drawing.Size(58, 13)
        Me.lblPeriodizität.TabIndex = 123
        Me.lblPeriodizität.Text = "Periodizität"
        '
        'cboxPeriodizität
        '
        Me.cboxPeriodizität.FormattingEnabled = True
        Me.cboxPeriodizität.Location = New System.Drawing.Point(141, 146)
        Me.cboxPeriodizität.Name = "cboxPeriodizität"
        Me.cboxPeriodizität.Size = New System.Drawing.Size(119, 21)
        Me.cboxPeriodizität.TabIndex = 3
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(141, 326)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(268, 48)
        Me.txtBemerkung.TabIndex = 15
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(12, 329)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 125
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'txtVertragselement
        '
        Me.txtVertragselement.Location = New System.Drawing.Point(141, 68)
        Me.txtVertragselement.Name = "txtVertragselement"
        Me.txtVertragselement.ReadOnly = True
        Me.txtVertragselement.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragselement.TabIndex = 0
        '
        'lblVertragselement
        '
        Me.lblVertragselement.AutoSize = True
        Me.lblVertragselement.Location = New System.Drawing.Point(11, 70)
        Me.lblVertragselement.Name = "lblVertragselement"
        Me.lblVertragselement.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragselement.TabIndex = 137
        Me.lblVertragselement.Text = "Vertragselement"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(537, 158)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 20
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(458, 161)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 147
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(538, 110)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(78, 20)
        Me.txtMutierer.TabIndex = 18
        Me.txtMutierer.TabStop = False
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiertam.Location = New System.Drawing.Point(537, 87)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.ReadOnly = True
        Me.txtMutiertam.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiertam.TabIndex = 17
        Me.txtMutiertam.TabStop = False
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstelltam.Location = New System.Drawing.Point(537, 63)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.ReadOnly = True
        Me.txtErstelltam.Size = New System.Drawing.Size(79, 20)
        Me.txtErstelltam.TabIndex = 16
        Me.txtErstelltam.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(459, 114)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 142
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(459, 91)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 141
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(460, 66)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 140
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(456, 133)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(95, 21)
        Me.cbaktiv.TabIndex = 19
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'btnVertragselementSuche
        '
        Me.btnVertragselementSuche.Image = CType(resources.GetObject("btnVertragselementSuche.Image"), System.Drawing.Image)
        Me.btnVertragselementSuche.Location = New System.Drawing.Point(406, 67)
        Me.btnVertragselementSuche.Name = "btnVertragselementSuche"
        Me.btnVertragselementSuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragselementSuche.TabIndex = 148
        Me.btnVertragselementSuche.Text = "Button1"
        Me.btnVertragselementSuche.UseVisualStyleBackColor = True
        '
        'lblVorlaufzeit
        '
        Me.lblVorlaufzeit.AutoSize = True
        Me.lblVorlaufzeit.Location = New System.Drawing.Point(12, 247)
        Me.lblVorlaufzeit.Name = "lblVorlaufzeit"
        Me.lblVorlaufzeit.Size = New System.Drawing.Size(101, 13)
        Me.lblVorlaufzeit.TabIndex = 150
        Me.lblVorlaufzeit.Text = "Vorlaufzeit in Tagen"
        '
        'txtVorlaufzeit
        '
        Me.txtVorlaufzeit.Location = New System.Drawing.Point(141, 247)
        Me.txtVorlaufzeit.Mask = "999"
        Me.txtVorlaufzeit.Name = "txtVorlaufzeit"
        Me.txtVorlaufzeit.Size = New System.Drawing.Size(66, 20)
        Me.txtVorlaufzeit.TabIndex = 11
        Me.txtVorlaufzeit.ValidatingType = GetType(Date)
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.Add(Me.C1History)
        Me.GroupBox1.Location = New System.Drawing.Point(7, 411)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(626, 109)
        Me.GroupBox1.TabIndex = 153
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "History"
        '
        'C1History
        '
        Me.C1History.AlternatingRows = True
        Me.C1History.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1History.FetchRowStyles = True
        Me.C1History.FilterBar = True
        Me.C1History.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1History.Images.Add(CType(resources.GetObject("C1History.Images"), System.Drawing.Image))
        Me.C1History.Location = New System.Drawing.Point(3, 16)
        Me.C1History.Name = "C1History"
        Me.C1History.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1History.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1History.PreviewInfo.ZoomFactor = 75
        Me.C1History.PrintInfo.PageSettings = CType(resources.GetObject("C1History.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1History.Size = New System.Drawing.Size(620, 90)
        Me.C1History.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1History.TabIndex = 15
        Me.C1History.Text = "C1TrueDBGrid1"
        Me.C1History.PropBag = resources.GetString("C1History.PropBag")
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(12, 177)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(79, 13)
        Me.Label1.TabIndex = 155
        Me.Label1.Text = "Kündigungsfrist"
        '
        'cboxKuendigungsfrist
        '
        Me.cboxKuendigungsfrist.FormattingEnabled = True
        Me.cboxKuendigungsfrist.Location = New System.Drawing.Point(141, 174)
        Me.cboxKuendigungsfrist.Name = "cboxKuendigungsfrist"
        Me.cboxKuendigungsfrist.Size = New System.Drawing.Size(119, 21)
        Me.cboxKuendigungsfrist.TabIndex = 4
        '
        'lblKostenart
        '
        Me.lblKostenart.AutoSize = True
        Me.lblKostenart.Location = New System.Drawing.Point(12, 299)
        Me.lblKostenart.Name = "lblKostenart"
        Me.lblKostenart.Size = New System.Drawing.Size(52, 13)
        Me.lblKostenart.TabIndex = 152
        Me.lblKostenart.Text = "Kostenart"
        '
        'cboxKostenart
        '
        Me.cboxKostenart.FormattingEnabled = True
        Me.cboxKostenart.Location = New System.Drawing.Point(141, 296)
        Me.cboxKostenart.Name = "cboxKostenart"
        Me.cboxKostenart.Size = New System.Drawing.Size(268, 21)
        Me.cboxKostenart.TabIndex = 14
        '
        'cbInklMwSt
        '
        Me.cbInklMwSt.AutoSize = True
        Me.cbInklMwSt.Location = New System.Drawing.Point(234, 275)
        Me.cbInklMwSt.Name = "cbInklMwSt"
        Me.cbInklMwSt.Size = New System.Drawing.Size(79, 17)
        Me.cbInklMwSt.TabIndex = 13
        Me.cbInklMwSt.Text = "Inkl. MwSt."
        Me.cbInklMwSt.UseVisualStyleBackColor = True
        '
        'lblBetrag
        '
        Me.lblBetrag.AutoSize = True
        Me.lblBetrag.Location = New System.Drawing.Point(12, 273)
        Me.lblBetrag.Name = "lblBetrag"
        Me.lblBetrag.Size = New System.Drawing.Size(38, 13)
        Me.lblBetrag.TabIndex = 120
        Me.lblBetrag.Text = "Betrag"
        '
        'txtBetrag
        '
        Me.txtBetrag.Location = New System.Drawing.Point(141, 273)
        Me.txtBetrag.Name = "txtBetrag"
        Me.txtBetrag.Size = New System.Drawing.Size(84, 20)
        Me.txtBetrag.TabIndex = 12
        Me.txtBetrag.ValidatingType = GetType(Date)
        '
        'frmVertragsereignis
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(645, 532)
        Me.Controls.Add(Me.txtBetrag)
        Me.Controls.Add(Me.lblBetrag)
        Me.Controls.Add(Me.Label1)
        Me.Controls.Add(Me.cbInklMwSt)
        Me.Controls.Add(Me.cboxKuendigungsfrist)
        Me.Controls.Add(Me.cboxKostenart)
        Me.Controls.Add(Me.lblKostenart)
        Me.Controls.Add(Me.GroupBox1)
        Me.Controls.Add(Me.txtVorlaufzeit)
        Me.Controls.Add(Me.lblVorlaufzeit)
        Me.Controls.Add(Me.btnVertragselementSuche)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiertam)
        Me.Controls.Add(Me.txtErstelltam)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiertam)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.txtVertragselement)
        Me.Controls.Add(Me.lblVertragselement)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.lblPeriodizität)
        Me.Controls.Add(Me.cboxPeriodizität)
        Me.Controls.Add(Me.dtPickerEnde)
        Me.Controls.Add(Me.dtPickerStart)
        Me.Controls.Add(Me.dtPickerDatum)
        Me.Controls.Add(Me.txtEnde)
        Me.Controls.Add(Me.txtStart)
        Me.Controls.Add(Me.txtDatum)
        Me.Controls.Add(Me.lblEnde)
        Me.Controls.Add(Me.lblStart)
        Me.Controls.Add(Me.lblDatum)
        Me.Controls.Add(Me.lblEreignistyp)
        Me.Controls.Add(Me.cboxEreignistyp)
        Me.Controls.Add(Me.txtBezeichnung)
        Me.Controls.Add(Me.lblBezeichnung)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragsereignis"
        Me.Text = "Vertragsereignis"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.IsNumeric -Methode

Prüfung, ob es sich um einen numerischen Wert handelt

[Visual Basic]
Private Function IsNumeric( _
   ByVal str As String _
) As Object

Parameter

str

Quellcode

[Visual Basic]
    Private Function IsNumeric(ByVal str As String)
        Return New Regex("\d+").Match(str).Success
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Refresh_History -Methode

History

[Visual Basic]
Private Sub Refresh_History()

Quellcode

[Visual Basic]
    Private Sub Refresh_History()
        Try
            If Check_Changes() = False Then Exit Sub
        Catch ex As Exception
        End Try
        Dim filtertext As String = "none"
        Try
            filtertext = Me.C1History.Columns("Aktiv").FilterText
        Catch ex As Exception
        End Try

        Dim bm As Integer = 0
        bm = Me.C1History.Bookmark

        Me.C1History.Enabled = False
        Me.Vertragsereignis.Get_History(Me.C1History)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1History, "History", Me.Vertragsereignis.History.Tabledata)
        If filtertext <> "none" Then Me.C1History.Columns("Aktiv").FilterText = filtertext
        sec.Set_Form_Security(Me)

        Try
            Me.C1History.Bookmark = bm
        Catch ex As Exception
        End Try
        Me.C1History.Enabled = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.Save_data -Methode

Daten ab Form speichern

[Visual Basic]
Private Sub Save_data()

Quellcode

[Visual Basic]
    Private Sub Save_data()
        Me.Vertragsereignis.iEreignisNr = New SqlInt32(CType(Me.Aktuelles_Vertragsereignis, Int32))
        Me.Vertragsereignis.iEreignistypNr = New SqlInt32(CType(Me.cboxEreignistyp.SelectedValue, Int32))
        Me.Vertragsereignis.iVertragselementnr = New SqlInt32(CType(Me.Aktuelles_Vertragselement, Int32))
        Me.Vertragsereignis.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        If IsDate(Me.txtDatum.Text) Then
            Me.Vertragsereignis.daDatum = New SqlDateTime(CType(Me.txtDatum.Text, DateTime))
        Else
            Me.Vertragsereignis.daDatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtStart.Text) Then
            Me.Vertragsereignis.daStart = New SqlDateTime(CType(Me.txtStart.Text, DateTime))
        Else
            Me.Vertragsereignis.daStart = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If IsDate(Me.txtEnde.Text) Then
            Me.Vertragsereignis.daEnde = New SqlDateTime(CType(Me.txtEnde.Text, DateTime))
        Else
            Me.Vertragsereignis.daEnde = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
        End If
        If Me.txtVorlaufzeit.Text = "" Then
            Me.Vertragsereignis.iVorlaufzeit = New SqlInt32(CType(0, Int32))
        Else
            Me.Vertragsereignis.iVorlaufzeit = New SqlInt32(CType(Me.txtVorlaufzeit.Text, Int32))
        End If
        If Me.txtBetrag.Text = "" Then
            Me.Vertragsereignis.fBetrag = New SqlDouble(CType(0, Double))
        Else
            Me.Vertragsereignis.fBetrag = New SqlDouble(CType(Me.txtBetrag.Text, Double))
        End If
        Me.Vertragsereignis.iPeriodizitaetNr = New SqlInt32(CType(Me.cboxPeriodizität.SelectedValue, Int32))

        If Me.cboxKostenart.SelectedValue Is Nothing Then
            Me.Vertragsereignis.iKostenartNr = New SqlInt32(CType(-1, Int32))
        Else

            Me.Vertragsereignis.iKostenartNr = New SqlInt32(CType(Me.cboxKostenart.SelectedValue, Int32))
        End If

        Me.Vertragsereignis.iKuendigungsfristnr = New SqlInt32(CType(Me.cboxKuendigungsfrist.SelectedValue, Int32))

        Me.Vertragsereignis.bInklMwSt = New SqlBoolean(CType(Me.cbInklMwSt.Checked = True, Boolean))
        Me.Vertragsereignis.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked = True, Boolean))
        Me.Vertragsereignis.sBeschreibung = New SqlString(CType(Me.txtBemerkung.Text, String))
        Me.Vertragsereignis.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
        Me.Vertragsereignis.Save_Data()
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Vertragsereignis.Create_Copy(Me.Vertragsereignis.iVertragselementnr.Value))
        Me.Vertragsereignis.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Vertragsereignis.Delete_Ereignis(Me.Vertragsereignis.iEreignisNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Vertragsereignis.Add_New(Me.Aktuelles_Vertragselement))
        Me.Vertragsereignis.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiertam.Text = Me.Vertragsereignis.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.btnVertragselementSuche_Click -Methode

[Visual Basic]
Private Sub btnVertragselementSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragselementSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragselementSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragselementSuche.Click
        Dim vertragselement As New TKB.VV.Vertrag.clsVertragselement
        Dim i As Integer = 0
        If vertragselement.Suchen(i) Then
            Me.Aktuelles_Vertragselement = i
            Me.txtVertragselement.Text = vertragselement.Get_Vertragselementbezeichnung(i)
            Me.FormDataChanged = True
        End If
        vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.cboxEreignistyp_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cboxEreignistyp_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxEreignistyp.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxEreignistyp_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxEreignistyp.SelectedIndexChanged
        Try
            If Me.Vertragsereignis.Check_Zahlungsdaten(Me.cboxEreignistyp.SelectedValue) Then
                Me.txtBetrag.Enabled = True
                Me.cbInklMwSt.Enabled = True
                Me.cboxKostenart.Enabled = True
                Me.cboxKuendigungsfrist.Enabled = False
                Me.txtVorlaufzeit.Text = ""
                Me.txtVorlaufzeit.Enabled = False
            Else
                If Me.Vertragsereignis.Check_Kuendigungsdaten(Me.cboxEreignistyp.SelectedValue) = True Then
                    Me.cboxKuendigungsfrist.Enabled = True
                    Me.txtBetrag.Enabled = False
                    Me.cbInklMwSt.Enabled = False
                    Me.cboxKostenart.Enabled = False
                    Me.cboxKostenart.SelectedIndex = -1
                    Me.cboxKostenart.Text = ""
                    Me.txtVorlaufzeit.Enabled = True
                Else
                    Me.txtVorlaufzeit.Enabled = True
                    Me.cboxKuendigungsfrist.Enabled = False
                    Me.txtBetrag.Enabled = False
                    Me.cbInklMwSt.Enabled = False
                    Me.cboxKostenart.Enabled = False
                End If
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.cboxPeriodizität_SelectedIndexChanged -Methode

[Visual Basic]
Private Sub cboxPeriodizität_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cboxPeriodizität.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cboxPeriodizität_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboxPeriodizität.SelectedIndexChanged
        Enable_Disable_Datum()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmVertragsereignis


frmVertragsereignis.frmVertragsereignis_Load -Methode

Load-Methode

[Visual Basic]
Private Sub frmVertragsereignis_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragsereignis_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()

        'Kostenarten laden
        Me.cboxKostenart.Items.Clear()
        Me.cboxKostenart.DataSource = Me.Vertragsereignis.Kostenarten
        Me.cboxKostenart.DisplayMember = "Bezeichnung"
        Me.cboxKostenart.ValueMember = "Kostenartnr"

        'Periodizitäten laden
        Me.cboxPeriodizität.Items.Clear()
        Me.cboxPeriodizität.DataSource = Me.Vertragsereignis.Periodizitäten
        Me.cboxPeriodizität.DisplayMember = "Bezeichnung"
        Me.cboxPeriodizität.ValueMember = "Periodizitaetnr"

        Me.cboxEreignistyp.Items.Clear()
        Me.cboxEreignistyp.DataSource = Me.Vertragsereignis.Ereignistypen
        Me.cboxEreignistyp.DisplayMember = "Bezeichnung"
        Me.cboxEreignistyp.ValueMember = "Ereignistypnr"

        Me.cboxKuendigungsfrist.DataSource = Me.Vertragsereignis.Kuendigungsfrist
        Me.cboxKuendigungsfrist.DisplayMember = "Bezeichnung"
        Me.cboxKuendigungsfrist.ValueMember = "Kuendigungsfristnr"
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)

        AddChanges(Me)
        Get_Data(Me.Aktuelles_Vertragsereignis)
        If Me.Neuer_Datensatz = True Then
            Me.Vertragsereignis.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If

        Me.Refresh_History()
        Me.cboxEreignistyp_SelectedIndexChanged(sender, e)
        Enable_Disable_Datum()
        Me.FormDataChanged = False

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.txtBetrag_Validating -Methode

Validierung Betragsfeld

[Visual Basic]
Private Sub txtBetrag_Validating( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   txtBetrag.Validating

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtBetrag_Validating(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles txtBetrag.Validating
        If Not Check_Betrag() Then e.Cancel = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis-Felder

frmVertragsereignis Übersicht

Felder

private field Aktuelles_Vertragselement

Unterstützt von .NET Compact Framework
private field Aktuelles_Vertragsereignis

Unterstützt von .NET Compact Framework
private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragsereignis

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragsereignis -Klasse


Aktuelles_Vertragselement -Feld

[Visual Basic]
Private Aktuelles_Vertragselement As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragselement As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


Aktuelles_Vertragsereignis -Feld

[Visual Basic]
Private Aktuelles_Vertragsereignis As Integer

Quellcode

[Visual Basic]
    Private Aktuelles_Vertragsereignis As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


Vertragsereignis -Feld

[Visual Basic]
Private Vertragsereignis As clsVertragsereignis

Quellcode

[Visual Basic]
    Dim Vertragsereignis As New TKB.VV.Vertrag.clsVertragsereignis

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragskontakt -Klasse

For a list of all members of this type, see frmVertragskontakt-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragskontakt

[Visual Basic]
Public Class frmVertragskontakt
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragskontakt-Member


frmVertragskontakt-Member

frmVertragskontakt Übersicht

Öffentliche Konstruktoren

public constructor frmVertragskontakt -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontaktpersonen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontaktpersonen_MouseDown Unterstützt von .NET Compact Framework | C1Kontaktperson Mousedown
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DetailsKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson Details anzeigen
private method DetailsVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktpersonMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method Load_Rollen Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeuKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson neue Person erfassen
private method NeuVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method SuchenVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmVertragskontakt_Load Unterstützt von .NET Compact Framework |

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field KontaktNr

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Person

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field Vertragskontaktnr

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragskontakt -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void frmVertragskontakt();

[Visual Basic] Public Sub New(Integer, Integer, Integer, Optional Boolean, Optional Boolean)
[C#] public System.Void frmVertragskontakt(int, int, int, bool, bool);

frmVertragskontakt


frmVertragskontakt-Methoden

frmVertragskontakt Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontaktpersonen_FetchRowStyle Unterstützt von .NET Compact Framework |
private method C1Kontaktpersonen_MouseDown Unterstützt von .NET Compact Framework | C1Kontaktperson Mousedown
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method DetailsKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson Details anzeigen
private method DetailsVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Person laden und präsentieren
private method Get_Vertragspartner Unterstützt von .NET Compact Framework |
private method Get_Vertragspartner_Kontakte Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktpersonMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method Load_Rollen Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method NeuKontaktpersonToolStripMenuItem_Click Unterstützt von .NET Compact Framework | C1Kontaktperson neue Person erfassen
private method NeuVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method Save_Data Unterstützt von .NET Compact Framework | Daten sichern, sofern Änderungen vorgenommen worden sind
private method SuchenVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method btnVertragspartnersuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method frmVertragskontakt_Load Unterstützt von .NET Compact Framework |

frmVertragskontakt -Klasse


frmVertragskontakt.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
            If TypeOf c Is ListBox Then
                Dim ctl As ListBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.C1Kontaktpersonen_FetchRowStyle -Methode

[Visual Basic]
Private Sub C1Kontaktpersonen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontaktpersonen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontaktpersonen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontaktpersonen.FetchRowStyle
        Try
            If Me.C1Kontaktpersonen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.C1Kontaktpersonen_MouseDown -Methode

C1Kontaktperson Mousedown

[Visual Basic]
Private Sub C1Kontaktpersonen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontaktpersonen.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontaktpersonen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontaktpersonen.MouseDown
        Me.C1Kontaktpersonen.Bookmark = Me.C1Kontaktpersonen.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Exit Function
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_Data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.DetailsKontaktpersonToolStripMenuItem_Click -Methode

C1Kontaktperson Details anzeigen

[Visual Basic]
Private Sub DetailsKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsKontaktpersonToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsKontaktpersonToolStripMenuItem.Click
        Try
            Dim f As New frmPerson(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Me.VertragspartnerNr, Me.FormReadonly)
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.DetailsVertragspartnerToolStripMenuItem_Click -Methode

Vertragspartner anzeigen

[Visual Basic]
Private Sub DetailsVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsVertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner(Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.Get_Vertragspartner()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0 Or mnu.Text.IndexOf("Details") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If

        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If Check_Changes() = False Then
            e.Cancel = True
        Else
            If Me.Kontaktperson.Neuer_Datensatz = True Then Me.Kontaktperson.Delete(Me.Kontaktperson.iVertragsKontaktNr.Value)
            Globals.MyEventHanlder.Kontakte_Closed()
            Me.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Get_Data -Methode

Person laden und präsentieren

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Me.Kontaktperson.Get_Vertragskontakt(Nr)
        Me.lbRolle.SelectedValue = Me.Kontaktperson.iKontakttypNr.Value
        Me.cbIntern.Checked = Me.Kontaktperson.bIntern.Value = True
        Me.txtErstellt_am.Text = Me.Kontaktperson.daErstellt_am.ToString
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.txtBemerkung.Text = Me.Kontaktperson.sBemerkung.ToString
        Me.txtMutierer.Text = Me.Kontaktperson.iMutierer.Value
        Me.cbaktiv.Checked = Me.Kontaktperson.bAktiv.Value = True
        Me.cboxSecurityLevel.SelectedValue = Me.Kontaktperson.iSecurityLevelNr.Value

        If Me.Kontaktperson.iPersonNr.Value <> 0 Then
            Try
                Person.cpMainConnectionProvider = Globals.conn
                Person.iPersonNr = New SqlInt32(CType(Me.Kontaktperson.iPersonNr.Value, Int32))
                Person.SelectOne()
                Me.VertragspartnerNr = Person.iVertragspartnernr.Value
            Catch
            End Try
        End If

        Me.Get_Vertragspartner()

        Dim i As Integer = 0
        If Me.Kontaktperson.iPersonNr.Value = 0 Then
            Me.C1Kontaktpersonen.Bookmark = -1

        Else
            For i = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
                Me.C1Kontaktpersonen.Bookmark = i
                Try
                    If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(i) = Me.Kontaktperson.iPersonNr.Value Then Exit For
                Catch
                End Try
            Next
        End If
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Get_Vertragspartner -Methode

[Visual Basic]
Private Function Get_Vertragspartner() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner()
        Me.txtVertragspartner.Text = Me.Vertragspartner.Get_Vertragspartnername(Me.VertragspartnerNr)
        Get_Vertragspartner_Kontakte()
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Get_Vertragspartner_Kontakte -Methode

[Visual Basic]
Private Function Get_Vertragspartner_Kontakte() As Object

Quellcode

[Visual Basic]
    Private Function Get_Vertragspartner_Kontakte()
        Try
            'If Check_Changes() = False Then Exit Function
        Catch ex As Exception

        End Try
        Me.C1Kontaktpersonen.Enabled = False
        Me.Vertragspartner.Get_Kontaktpersonen(Me.C1Kontaktpersonen)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontaktpersonen, "Person", Me.Vertragspartner.Kontaktpersonen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontaktpersonen.Enabled = True
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragskontakt))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.btnVertragspartnersuche = New System.Windows.Forms.Button
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.VertragspartnerContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.SuchenVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.KontaktpersonMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DetailsKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuKontaktpersonToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.lblKontaktperson = New System.Windows.Forms.Label
        Me.lblRolle = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.cbIntern = New System.Windows.Forms.CheckBox
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.lbRolle = New System.Windows.Forms.ListBox
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.C1Kontaktpersonen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.VertragspartnerContextMenuStrip.SuspendLayout()
        Me.KontaktpersonMenuStrip.SuspendLayout()
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(594, 24)
        Me.MenuStrip1.TabIndex = 11
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(594, 25)
        Me.ToolStrip1.TabIndex = 10
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "ToolStripButton1"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "ToolStripButton2"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "ToolStripButton3"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "ToolStripButton3"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'btnVertragspartnersuche
        '
        Me.btnVertragspartnersuche.Image = CType(resources.GetObject("btnVertragspartnersuche.Image"), System.Drawing.Image)
        Me.btnVertragspartnersuche.Location = New System.Drawing.Point(368, 63)
        Me.btnVertragspartnersuche.Name = "btnVertragspartnersuche"
        Me.btnVertragspartnersuche.Size = New System.Drawing.Size(20, 20)
        Me.btnVertragspartnersuche.TabIndex = 108
        Me.btnVertragspartnersuche.Text = "Button1"
        Me.btnVertragspartnersuche.UseVisualStyleBackColor = True
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragspartner.ContextMenuStrip = Me.VertragspartnerContextMenuStrip
        Me.txtVertragspartner.Location = New System.Drawing.Point(103, 62)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.ReadOnly = True
        Me.txtVertragspartner.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragspartner.TabIndex = 0
        '
        'VertragspartnerContextMenuStrip
        '
        Me.VertragspartnerContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsVertragspartnerToolStripMenuItem, Me.NeuVertragspartnerToolStripMenuItem, Me.ToolStripMenuItem1, Me.SuchenVertragspartnerToolStripMenuItem})
        Me.VertragspartnerContextMenuStrip.Name = "VertragspartnerContextMenuStrip"
        Me.VertragspartnerContextMenuStrip.Size = New System.Drawing.Size(112, 76)
        '
        'DetailsVertragspartnerToolStripMenuItem
        '
        Me.DetailsVertragspartnerToolStripMenuItem.Name = "DetailsVertragspartnerToolStripMenuItem"
        Me.DetailsVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.DetailsVertragspartnerToolStripMenuItem.Text = "&Details"
        '
        'NeuVertragspartnerToolStripMenuItem
        '
        Me.NeuVertragspartnerToolStripMenuItem.Name = "NeuVertragspartnerToolStripMenuItem"
        Me.NeuVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.NeuVertragspartnerToolStripMenuItem.Text = "&Neu"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(108, 6)
        '
        'SuchenVertragspartnerToolStripMenuItem
        '
        Me.SuchenVertragspartnerToolStripMenuItem.Name = "SuchenVertragspartnerToolStripMenuItem"
        Me.SuchenVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(111, 22)
        Me.SuchenVertragspartnerToolStripMenuItem.Text = "&Suchen"
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(12, 67)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(79, 13)
        Me.lblVertragspartner.TabIndex = 107
        Me.lblVertragspartner.Text = "Vertragspartner"
        '
        'KontaktpersonMenuStrip
        '
        Me.KontaktpersonMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DetailsKontaktpersonToolStripMenuItem, Me.NeuKontaktpersonToolStripMenuItem})
        Me.KontaktpersonMenuStrip.Name = "KontaktpersonMenuStrip"
        Me.KontaktpersonMenuStrip.Size = New System.Drawing.Size(107, 48)
        '
        'DetailsKontaktpersonToolStripMenuItem
        '
        Me.DetailsKontaktpersonToolStripMenuItem.Name = "DetailsKontaktpersonToolStripMenuItem"
        Me.DetailsKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.DetailsKontaktpersonToolStripMenuItem.Text = "&Details"
        '
        'NeuKontaktpersonToolStripMenuItem
        '
        Me.NeuKontaktpersonToolStripMenuItem.Name = "NeuKontaktpersonToolStripMenuItem"
        Me.NeuKontaktpersonToolStripMenuItem.Size = New System.Drawing.Size(106, 22)
        Me.NeuKontaktpersonToolStripMenuItem.Text = "&Neu"
        '
        'lblKontaktperson
        '
        Me.lblKontaktperson.AutoSize = True
        Me.lblKontaktperson.Location = New System.Drawing.Point(12, 88)
        Me.lblKontaktperson.Name = "lblKontaktperson"
        Me.lblKontaktperson.Size = New System.Drawing.Size(76, 13)
        Me.lblKontaktperson.TabIndex = 110
        Me.lblKontaktperson.Text = "Kontaktperson"
        '
        'lblRolle
        '
        Me.lblRolle.AutoSize = True
        Me.lblRolle.Location = New System.Drawing.Point(12, 240)
        Me.lblRolle.Name = "lblRolle"
        Me.lblRolle.Size = New System.Drawing.Size(31, 13)
        Me.lblRolle.TabIndex = 112
        Me.lblRolle.Text = "Rolle"
        '
        'cbaktiv
        '
        Me.cbaktiv.Location = New System.Drawing.Point(11, 414)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbaktiv.Size = New System.Drawing.Size(106, 15)
        Me.cbaktiv.TabIndex = 5
        Me.cbaktiv.Text = "Aktiv"
        Me.cbaktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'cbIntern
        '
        Me.cbIntern.Location = New System.Drawing.Point(11, 342)
        Me.cbIntern.Name = "cbIntern"
        Me.cbIntern.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbIntern.Size = New System.Drawing.Size(106, 15)
        Me.cbIntern.TabIndex = 3
        Me.cbIntern.Text = "Intern"
        Me.cbIntern.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbIntern.UseVisualStyleBackColor = True
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(103, 434)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 6
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(12, 437)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 132
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(408, 465)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 9
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(246, 465)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 8
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(103, 465)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 7
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(337, 468)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 135
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(187, 468)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 134
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(12, 468)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 133
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'lbRolle
        '
        Me.lbRolle.FormattingEnabled = True
        Me.lbRolle.Location = New System.Drawing.Point(103, 240)
        Me.lbRolle.Name = "lbRolle"
        Me.lbRolle.Size = New System.Drawing.Size(268, 95)
        Me.lbRolle.TabIndex = 2
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(103, 363)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(479, 45)
        Me.txtBemerkung.TabIndex = 4
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(12, 366)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 143
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'C1Kontaktpersonen
        '
        Me.C1Kontaktpersonen.AllowAddNew = True
        Me.C1Kontaktpersonen.AlternatingRows = True
        Me.C1Kontaktpersonen.ContextMenuStrip = Me.KontaktpersonMenuStrip
        Me.C1Kontaktpersonen.FetchRowStyles = True
        Me.C1Kontaktpersonen.FilterBar = True
        Me.C1Kontaktpersonen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontaktpersonen.Images.Add(CType(resources.GetObject("C1Kontaktpersonen.Images"), System.Drawing.Image))
        Me.C1Kontaktpersonen.Location = New System.Drawing.Point(103, 89)
        Me.C1Kontaktpersonen.Name = "C1Kontaktpersonen"
        Me.C1Kontaktpersonen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontaktpersonen.PreviewInfo.ZoomFactor = 75
        Me.C1Kontaktpersonen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontaktpersonen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontaktpersonen.Size = New System.Drawing.Size(478, 145)
        Me.C1Kontaktpersonen.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Kontaktpersonen.TabIndex = 1
        Me.C1Kontaktpersonen.Text = "C1TrueDBGrid1"
        Me.C1Kontaktpersonen.PropBag = resources.GetString("C1Kontaktpersonen.PropBag")
        '
        'frmVertragskontakt
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(594, 493)
        Me.Controls.Add(Me.C1Kontaktpersonen)
        Me.Controls.Add(Me.lblBemerkung)
        Me.Controls.Add(Me.txtBemerkung)
        Me.Controls.Add(Me.lbRolle)
        Me.Controls.Add(Me.txtMutierer)
        Me.Controls.Add(Me.txtMutiert_am)
        Me.Controls.Add(Me.txtErstellt_am)
        Me.Controls.Add(Me.lblMutierer)
        Me.Controls.Add(Me.lblMutiert_am)
        Me.Controls.Add(Me.lblErstelltam)
        Me.Controls.Add(Me.cboxSecurityLevel)
        Me.Controls.Add(Me.lblSecurityLebel)
        Me.Controls.Add(Me.cbIntern)
        Me.Controls.Add(Me.cbaktiv)
        Me.Controls.Add(Me.lblRolle)
        Me.Controls.Add(Me.lblKontaktperson)
        Me.Controls.Add(Me.btnVertragspartnersuche)
        Me.Controls.Add(Me.txtVertragspartner)
        Me.Controls.Add(Me.lblVertragspartner)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragskontakt"
        Me.Text = "Vertragskontakt"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.VertragspartnerContextMenuStrip.ResumeLayout(False)
        Me.KontaktpersonMenuStrip.ResumeLayout(False)
        CType(Me.C1Kontaktpersonen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.KontaktpersonMenuStrip_Opening -Methode

[Visual Basic]
Private Sub KontaktpersonMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   KontaktpersonMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktpersonMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles KontaktpersonMenuStrip.Opening
        Me.Disable_Enable_Menu(sender, Me.C1Kontaktpersonen)

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Load_Rollen -Methode

[Visual Basic]
Private Function Load_Rollen() As Object

Quellcode

[Visual Basic]
    Private Function Load_Rollen()
        Dim rollen As New TKB.VV.DB.clsKontakttyp
        Dim rollendata As New DataTable
        rollen.cpMainConnectionProvider = Globals.conn
        rollendata = rollen.SelectAll()
        Dim rv As New DataView(rollendata, "ApplikationsbereichNr=1 and aktiv=1", "", DataViewRowState.CurrentRows)
        Me.lbRolle.DataSource = rv
        Me.lbRolle.ValueMember = "KontakttypNr"
        Me.lbRolle.DisplayMember = "Bezeichnung"
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.NeuKontaktpersonToolStripMenuItem_Click -Methode

C1Kontaktperson neue Person erfassen

[Visual Basic]
Private Sub NeuKontaktpersonToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuKontaktpersonToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuKontaktpersonToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuKontaktpersonToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Kontaktperson.Add_New(Me.VertragspartnerNr)
        Dim f As New frmPerson(i, Me.VertragspartnerNr, Me.FormReadonly)
        f.ShowDialog()
        f.Dispose()
        Me.Get_Vertragspartner_Kontakte()
        Dim r As Integer = 0
        For r = 0 To Me.C1Kontaktpersonen.Splits(0).Rows.Count - 1
            Me.C1Kontaktpersonen.Bookmark = r
            If Me.C1Kontaktpersonen.Columns("PersonNr").CellText(r) = i Then Exit For
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.NeuVertragspartnerToolStripMenuItem_Click -Methode

Neuer Vertragspartner eröffnen

[Visual Basic]
Private Sub NeuVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuVertragspartnerToolStripMenuItem.Click
        Dim i As Integer = Me.Vertragspartner.Add_New
        Dim f As New frmVertragspartner(i, Me.FormReadonly)
        f.ShowDialog()
        f.dispose()
        Me.VertragspartnerNr = i
        Me.Get_Vertragspartner()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.Save_Data -Methode

Daten sichern, sofern Änderungen vorgenommen worden sind

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()

        If Me.FormDataChanged Then
            Me.Kontaktperson.iKontakttypNr = New SqlInt32(CType(Me.lbRolle.SelectedValue, Int32))
            Me.Kontaktperson.iPersonNr = New SqlInt32(CType(Me.C1Kontaktpersonen.Columns("PersonNr").Value, Int32))
            Me.Kontaktperson.bIntern = New SqlBoolean(CType(Me.cbIntern.Checked, Boolean))
            Me.Kontaktperson.bAktiv = New SqlBoolean(CType(Me.cbaktiv.Checked, Boolean))
            Me.Kontaktperson.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Kontaktperson.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Kontaktperson.Save_Data)
            Me.FormDataChanged = False
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.SuchenVertragspartnerToolStripMenuItem_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub SuchenVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   SuchenVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SuchenVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SuchenVertragspartnerToolStripMenuItem.Click
        Me.btnVertragspartnersuche_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Kontaktperson.Create_Copy(Me.Kontaktperson.iVertragsKontaktNr.Value))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Kontaktperson.Delete_Vertragskontakt(Me.Kontaktperson.iVertragsKontaktNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Kontaktperson.Add_New(Me.Vertragselementnr))
        Me.Kontaktperson.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Kontaktperson.daMutiert_am.ToString
        Me.FormDataChanged = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.btnVertragspartnersuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub btnVertragspartnersuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnVertragspartnersuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnVertragspartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVertragspartnersuche.Click
        Dim f As New frmVertragspartnerSuche
        f.ShowDialog()
        If f.Vertragspartnernr <> -1 Then
            Me.VertragspartnerNr = f.Vertragspartnernr
            f.Dispose()
            Me.Get_Vertragspartner()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt.frmVertragskontakt_Load -Methode

[Visual Basic]
Private Sub frmVertragskontakt_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragskontakt_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        sec.Set_Form_Security(Me)

        If Me.FormReadonly = True Then Me.TSBtnSave.Enabled = False

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Load_Securitylevel()
        Load_Rollen()
        Get_Data(Me.Vertragskontaktnr)
        If Me.Neuer_Datensatz = True Then
            Me.Kontaktperson.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If

        Me.AddChanges(Me)
        If Me.FormReadonly = True Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt-Felder

frmVertragskontakt Übersicht

Felder

private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field KontaktNr

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Person

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragselementnr

Unterstützt von .NET Compact Framework
private field Vertragskontaktnr

Unterstützt von .NET Compact Framework
private field Vertragspartner

Unterstützt von .NET Compact Framework
private field VertragspartnerNr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework

frmVertragskontakt -Klasse


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


KontaktNr -Feld

[Visual Basic]
Private KontaktNr As Integer

Quellcode

[Visual Basic]
    Private KontaktNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Kontaktperson -Feld

[Visual Basic]
Private Kontaktperson As clsKontakt

Quellcode

[Visual Basic]
    Dim Kontaktperson As New TKB.VV.Vertrag.clsKontakt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Person -Feld

[Visual Basic]
Private Person As clsPerson

Quellcode

[Visual Basic]
    Dim Person As New TKB.VV.DB.clsPerson

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Vertragselementnr -Feld

[Visual Basic]
Private Vertragselementnr As Integer

Quellcode

[Visual Basic]
    Private Vertragselementnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Vertragskontaktnr -Feld

[Visual Basic]
Private Vertragskontaktnr As Integer

Quellcode

[Visual Basic]
    Private Vertragskontaktnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


Vertragspartner -Feld

[Visual Basic]
Private Vertragspartner As clsVertragspartner

Quellcode

[Visual Basic]
    Dim Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


VertragspartnerNr -Feld

[Visual Basic]
Private VertragspartnerNr As Integer

Quellcode

[Visual Basic]
    Private VertragspartnerNr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragspartner -Klasse

Vertragsaprtner

For a list of all members of this type, see frmVertragspartner-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragspartner

[Visual Basic]
Public Class frmVertragspartner
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmVertragspartner-Member | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


frmVertragspartner-Member

frmVertragspartner Übersicht

Öffentliche Konstruktoren

public constructor frmVertragspartner -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Constructor New

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework | Suchen eines Knoten Treeview
public method dispose Überladen. Unterstützt von .NET Compact Framework | destruction Dispose

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method AnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | KontextMenu anzeigen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontakte_Click Unterstützt von .NET Compact Framework |
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doubleclick in der Kontaktliste
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Personen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Vertragspartner laden
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktInaktivierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Delete
private method KontaktKopierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Kopieren
private method KontaktMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Neu
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Refresh_Personen Unterstützt von .NET Compact Framework | Personenliste aktualisieren
private method Refresh_Vertragspartnerliste Unterstützt von .NET Compact Framework |
private method Save_Data Unterstützt von .NET Compact Framework | Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden
private method Set_KontaktButtons Unterstützt von .NET Compact Framework | Buttons für das Kontakt-Grid abhängig der angezeigten Datensätze enablen bzw. disablen
private method Set_Titel Unterstützt von .NET Compact Framework |
private method TS2BtnCopy_Click Unterstützt von .NET Compact Framework | Kopie eines Datensatzen erstellen
private method TS2BtnDelete_Click Unterstützt von .NET Compact Framework | Kontakt löschen (inaktivieren)
private method TS2BtnNew_Click Unterstützt von .NET Compact Framework | Neuer Kontakt hinzufügen
private method TS2BtnView_Click Unterstützt von .NET Compact Framework | Personendetails anzeigen bzw. bearbeiten
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TStxtFilter_KeyDown Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method TreeVertragspartner_AfterSelect Unterstützt von .NET Compact Framework |
private method TreeVertragspartner_BackColorChanged Unterstützt von .NET Compact Framework |
private method frmVertragspartner_Load Unterstützt von .NET Compact Framework | Formular laden
private method frmVertragspartner_Shown Unterstützt von .NET Compact Framework | Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist
private method txtBemerkung_TextChanged Unterstützt von .NET Compact Framework | Änderungsvermerk sofern Änderungen vorgenommen wurden

Felder

private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field IsOnLoad

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartnerdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework
private field vpnr

Unterstützt von .NET Compact Framework

Siehe auch

frmVertragspartner -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


New

Überladungsliste

Constructor New

[Visual Basic] Public Sub New()
[C#] public System.Void frmVertragspartner();

Formualr mit Vertragspartnernr und Anzeigestatus öffnen

[Visual Basic] Public Sub New(Integer, Boolean, Optional Boolean)
[C#] public System.Void frmVertragspartner(int, bool, bool);

frmVertragspartner


frmVertragspartner-Methoden

frmVertragspartner Übersicht

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework | Suchen eines Knoten Treeview
public method dispose Überladen. Unterstützt von .NET Compact Framework | destruction Dispose

Andere Methoden

private method AddChanges Unterstützt von .NET Compact Framework | Allg Eventhandler für Chanage-Ereignise festlegen
private method AnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | KontextMenu anzeigen
private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Kontakte_Click Unterstützt von .NET Compact Framework |
private method C1Kontakte_DoubleClick Unterstützt von .NET Compact Framework | Doubleclick in der Kontaktliste
private method C1Kontakte_MouseDown Unterstützt von .NET Compact Framework | Mousedown Kontakte
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Rowstyle von inaktiven Personen
private method ChangesMade Unterstützt von .NET Compact Framework | Envent-Handler für Change-Ereignisse
private method Check_Changes Unterstützt von .NET Compact Framework | Prüfung, ob Datenänderungen vorgenommen wurden.
private method Disable_Enable_Menu Unterstützt von .NET Compact Framework | Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind
private method FormularClosing Unterstützt von .NET Compact Framework | Schliessen des Formulars
private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Get_Data Unterstützt von .NET Compact Framework | Vertragspartner laden
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method KontaktInaktivierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Delete
private method KontaktKopierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Kopieren
private method KontaktMenuStrip_Opening Unterstützt von .NET Compact Framework |
private method KontaktNeuToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Neu
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Refresh_Personen Unterstützt von .NET Compact Framework | Personenliste aktualisieren
private method Refresh_Vertragspartnerliste Unterstützt von .NET Compact Framework |
private method Save_Data Unterstützt von .NET Compact Framework | Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden
private method Set_KontaktButtons Unterstützt von .NET Compact Framework | Buttons für das Kontakt-Grid abhängig der angezeigten Datensätze enablen bzw. disablen
private method Set_Titel Unterstützt von .NET Compact Framework |
private method TS2BtnCopy_Click Unterstützt von .NET Compact Framework | Kopie eines Datensatzen erstellen
private method TS2BtnDelete_Click Unterstützt von .NET Compact Framework | Kontakt löschen (inaktivieren)
private method TS2BtnNew_Click Unterstützt von .NET Compact Framework | Neuer Kontakt hinzufügen
private method TS2BtnView_Click Unterstützt von .NET Compact Framework | Personendetails anzeigen bzw. bearbeiten
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSave_Click Unterstützt von .NET Compact Framework | Sicherungs-Button betätigt
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TStxtFilter_KeyDown Unterstützt von .NET Compact Framework |
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method TreeVertragspartner_AfterSelect Unterstützt von .NET Compact Framework |
private method TreeVertragspartner_BackColorChanged Unterstützt von .NET Compact Framework |
private method frmVertragspartner_Load Unterstützt von .NET Compact Framework | Formular laden
private method frmVertragspartner_Shown Unterstützt von .NET Compact Framework | Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist
private method txtBemerkung_TextChanged Unterstützt von .NET Compact Framework | Änderungsvermerk sofern Änderungen vorgenommen wurden

Siehe auch

frmVertragspartner -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


frmVertragspartner.AddChanges -Methode

Allg Eventhandler für Chanage-Ereignise festlegen

[Visual Basic]
Private Sub AddChanges( _
   ByVal Container As Control _
)

Parameter

Container

Quellcode

[Visual Basic]
    Private Sub AddChanges(ByVal Container As Control)
        Dim l As New List(Of Control)
        Me.GetControl(Me, "*", l)
        Dim evh As EventHandler = AddressOf ChangesMade
        For Each c As Control In l
            If TypeOf c Is TextBox Then
                Dim ctl As TextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is MaskedTextBox Then
                Dim ctl As MaskedTextBox = c
                AddHandler ctl.TextChanged, evh
            End If
            If TypeOf c Is ComboBox Then
                Dim ctl As ComboBox = c
                AddHandler ctl.SelectedValueChanged, evh
            End If
            If TypeOf c Is CheckBox Then
                Dim ctl As CheckBox = c
                AddHandler ctl.CheckedChanged, evh
            End If
        Next
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.AnzeigenToolStripMenuItem_Click -Methode

KontextMenu anzeigen

[Visual Basic]
Private Sub AnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktAnzeigenToolStripMenuItem.Click
        Try
            Me.TS2BtnView_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.C1Kontakte_Click -Methode

[Visual Basic]
Private Sub C1Kontakte_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Kontakte.Click
        Me.Set_KontaktButtons()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.C1Kontakte_DoubleClick -Methode

Doubleclick in der Kontaktliste

[Visual Basic]
Private Sub C1Kontakte_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Kontakte.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles C1Kontakte.DoubleClick
        Try
            Dim f As New frmPerson(Me.C1Kontakte.Columns("Personnr").Value, Me.Vertragspartnerdata.iVertragspartnerNr.Value, Me.FormReadonly)
            f.ShowDialog()
            Me.Refresh_Personen()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.C1Kontakte_MouseDown -Methode

Mousedown Kontakte

[Visual Basic]
Private Sub C1Kontakte_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Kontakte.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Kontakte.MouseDown
        Me.C1Kontakte.Bookmark = Me.C1Kontakte.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.C1Kuendigungsfristen_FetchRowStyle -Methode

Rowstyle von inaktiven Personen

[Visual Basic]
Private Sub C1Kuendigungsfristen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontakte.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kuendigungsfristen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontakte.FetchRowStyle
        Try
            If Me.C1Kontakte.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.ChangesMade -Methode

Envent-Handler für Change-Ereignisse

[Visual Basic]
Private Sub ChangesMade( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ChangesMade(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.FormDataChanged = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Check_Changes -Methode

Prüfung, ob Datenänderungen vorgenommen wurden.

[Visual Basic]
Private Function Check_Changes() As Boolean

Quellcode

[Visual Basic]
    Private Function Check_Changes() As Boolean
        If Me.FormReadonly Then Return True
        If Me.IsOnLoad = True Then Return True
        Dim msgres As MsgBoxResult
        If Me.FormDataChanged Then
            msgres = msg.Show_MessageYesNoCancel(3)
            Select Case msgres
                Case MsgBoxResult.Yes
                    Save_data()
                    Return True
                Case MsgBoxResult.Cancel
                    Return False
                Case MsgBoxResult.No
                    Return True
            End Select
        Else
            Return True
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Disable_Enable_Menu -Methode

Enabling bzw. Disabling der Menu-Einträge aufgrund der angezeigten Rows im Truedbgrind

[Visual Basic]
Private Function Disable_Enable_Menu( _
   ByRef menu As ContextMenuStrip, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

menu
Zu bearbeitendes Menu
c1data
Betroffenes Grid

Hinweise

Nach dem Setzen der Submenus wird sec.form_Security durchlaufen, damit allfällig standardmössig aktivierte Menueinträge aufgrund der Security-Einstellung wieder deaktiviert werden

Quellcode

[Visual Basic]
    Private Function Disable_Enable_Menu(ByRef menu As ContextMenuStrip, ByRef c1data As C1TrueDBGrid)
        If Me.FormReadonly Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If (mnu.Text.IndexOf("Anzeigen") > 0 Or mnu.Text.IndexOf("anzeigen") > 0) And c1data.Splits(0).Rows.Count > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
            sec.Set_Form_Security(Me)
            Exit Function
        End If
        If c1data.Splits(0).Rows.Count = 0 Then
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    If mnu.Text.IndexOf("Neu") > 0 Then
                        mnu.Enabled = True
                    Else
                        mnu.Enabled = False
                    End If
                End If
            Next
        Else
            For Each obj As Object In menu.Items
                Dim objtype As System.Type = obj.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    Dim mnu As ToolStripMenuItem = obj
                    mnu.Enabled = True
                End If
            Next
        End If
        sec.Set_Form_Security(Me)

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.FindNode -Methode

Suchen eines Knoten Treeview

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
Nodes des TreeView
SearchVal
Tag.Keyvalue
SearchString
Node.Text als Suchbegriff

Quellcode

[Visual Basic]
    Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
        Dim tmpNode As TreeNode
        For Each _child As TreeNode In _nodeCollection
            If _child.Tag = SearchVal Then
                Return _child
            End If
        Next
        Return Nothing
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.FormularClosing -Methode

Schliessen des Formulars

[Visual Basic]
Private Sub FormularClosing( _
   ByVal sender As Object, _
   ByVal e As FormClosingEventArgs _
) Handles  _
   Me.FormClosing

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FormularClosing(ByVal sender As Object, ByVal e As System.Windows.Forms.FormClosingEventArgs) Handles Me.FormClosing
        If Me.FormReadonly = True Then Exit Sub
        If check_changes() = False Then
            e.Cancel = True
        Else
            If Me.Vertragspartnerdata.Neuer_Datensatz = True Then Me.Vertragspartnerdata.Delete(Me.Vertragspartnerdata.iVertragspartnerNr.Value)
            Globals.MyEventHanlder.Vertragspartner_Closed(Me.Vertragspartnerdata.iVertragspartnerNr.Value)

            Me.dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
    Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
        If L Is Nothing Then L = New List(Of Control)
        Dim Gut As Boolean
        Dim ReturnFlag As Boolean = False
        If Key IsNot Nothing Then Key = Key.ToLower

        If BaseControl.HasChildren = True Then
            For Each ctl As Control In BaseControl.Controls
                Gut = False
                If Key Is Nothing Then
                    Gut = True
                Else
                    If ctl.Name.Length >= Key.Length Then
                        Key = Key.ToLower
                        If Key.StartsWith("*") Then
                            If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                        ElseIf Key.EndsWith("*") Then
                            If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                        Else
                            If Key = ctl.Name.ToLower Then Gut = True
                        End If
                    End If
                End If

                If Gut = True Then
                    L.Add(ctl)
                    If ReturnAtFirstElement = True Then ReturnFlag = True
                End If
                If ReturnFlag = False Then
                    Call GetControl(ctl, Key, L)
                End If
            Next
        End If

        If L.Count - 1 > -1 Then
            Return True
        Else
            Return False
        End If
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Get_Data -Methode

Vertragspartner laden

[Visual Basic]
Private Sub Get_Data( _
   ByVal Nr As Integer _
)

Parameter

Nr

Quellcode

[Visual Basic]
    Private Sub Get_Data(ByVal Nr As Integer)
        Try
            Me.Vertragspartnerdata.Get_Partner(Nr)
            Me.txtName_Firma1.Text = Me.Vertragspartnerdata.sNameZ1.Value
            Me.txtVorname_Firma2.Text = Me.Vertragspartnerdata.sNameZ2.Value
            Me.txtStrasse.Text = Me.Vertragspartnerdata.sStrasse.Value
            Me.txtPostfach.Text = Me.Vertragspartnerdata.sPostfach.Value
            Me.txtPlz.Text = Me.Vertragspartnerdata.sPLZ.Value
            Me.txtOrt.Text = Me.Vertragspartnerdata.sOrt.Value
            Me.txtTelefon.Text = Me.Vertragspartnerdata.sTelefon.Value
            Me.txtTelefax.Text = Me.Vertragspartnerdata.sTelefax.Value
            Me.txtEmail.Text = Me.Vertragspartnerdata.sEMail.Value
            Me.txtInternet.Text = Me.Vertragspartnerdata.sInternet.Value
            Me.txtBemerkung.Text = Me.Vertragspartnerdata.sBemerkung.Value
            Me.txtErstellt_am.Text = Me.Vertragspartnerdata.daErstellt_am.ToString
            Me.txtMutiert_am.Text = Me.Vertragspartnerdata.daMutiert_am.ToString
            Me.txtMutierer.Text = Me.Vertragspartnerdata.iMutierer.Value
            Me.cbAktiv.Checked = Me.Vertragspartnerdata.bAktiv.Value = True
            Me.cboxSecurityLevel.SelectedValue = Me.Vertragspartnerdata.iSecurityLevelNr.Value
            Set_Titel()
            Me.FormDataChanged = False
            Refresh_Personen()
            'If Not Anzeige Then
            '    Me.PnlDetails.Enabled = True
            '    Me.GrpKontakte.Enabled = True
            '    Me.TSBtnSave.Enabled = True
            '    Me.TSBtnCopy.Enabled = True
            '    Me.TSBtnNew.Enabled = True
            '    Me.TSBtnDelete.Enabled = True
            'End If
            sec.Set_Form_Security(Me)
        Catch ex As Exception
            FormDataChanged = False
            Me.PnlDetails.Enabled = False
            Me.GrpKontakte.Enabled = False
            Me.TSBtnSave.Enabled = False
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = True
            Me.TSBtnDelete.Enabled = False
            sec.Set_Form_Security(Me)
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragspartner))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.lblFilter = New System.Windows.Forms.ToolStripLabel
        Me.TStxtFilter = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TSBtnFilterAufheben = New System.Windows.Forms.ToolStripButton
        Me.PnlDetails = New System.Windows.Forms.Panel
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.cbAktiv = New System.Windows.Forms.CheckBox
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiert_am = New System.Windows.Forms.TextBox
        Me.txtErstellt_am = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiert_am = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.txtBemerkung = New System.Windows.Forms.TextBox
        Me.lblBemerkung = New System.Windows.Forms.Label
        Me.txtInternet = New System.Windows.Forms.TextBox
        Me.lblInternet = New System.Windows.Forms.Label
        Me.txtEmail = New System.Windows.Forms.TextBox
        Me.lblEmail = New System.Windows.Forms.Label
        Me.txtTelefon = New System.Windows.Forms.TextBox
        Me.txtTelefax = New System.Windows.Forms.TextBox
        Me.lblTelefax = New System.Windows.Forms.Label
        Me.lblTelefon = New System.Windows.Forms.Label
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.txtPlz = New System.Windows.Forms.TextBox
        Me.lblPlzOrt = New System.Windows.Forms.Label
        Me.txtPostfach = New System.Windows.Forms.TextBox
        Me.lblPostfach = New System.Windows.Forms.Label
        Me.txtStrasse = New System.Windows.Forms.TextBox
        Me.lblStrasse = New System.Windows.Forms.Label
        Me.txtVorname_Firma2 = New System.Windows.Forms.TextBox
        Me.lblVorname_Firma2 = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.GrpKontakte = New System.Windows.Forms.GroupBox
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.KontaktMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.KontaktAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktKopierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktNeuToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.KontaktInaktivierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip2 = New System.Windows.Forms.ToolStrip
        Me.TS2BtnView = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnNew = New System.Windows.Forms.ToolStripButton
        Me.TS2BtnDelete = New System.Windows.Forms.ToolStripButton
        Me.GrpPartner = New System.Windows.Forms.GroupBox
        Me.TreeVertragspartner = New System.Windows.Forms.TreeView
        Me.ImageListTreeImages = New System.Windows.Forms.ImageList(Me.components)
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.PnlDetails.SuspendLayout()
        Me.GrpKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.KontaktMenuStrip.SuspendLayout()
        Me.ToolStrip2.SuspendLayout()
        Me.GrpPartner.SuspendLayout()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Tag = ""
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(854, 24)
        Me.MenuStrip1.TabIndex = 2
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.lblFilter, Me.TStxtFilter, Me.TSBtnSuche, Me.TSBtnFilterAufheben})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(854, 25)
        Me.ToolStrip1.TabIndex = 1
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'lblFilter
        '
        Me.lblFilter.Name = "lblFilter"
        Me.lblFilter.Size = New System.Drawing.Size(35, 22)
        Me.lblFilter.Text = "Filter:"
        '
        'TStxtFilter
        '
        Me.TStxtFilter.Name = "TStxtFilter"
        Me.TStxtFilter.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "Suchen"
        '
        'TSBtnFilterAufheben
        '
        Me.TSBtnFilterAufheben.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnFilterAufheben.Image = CType(resources.GetObject("TSBtnFilterAufheben.Image"), System.Drawing.Image)
        Me.TSBtnFilterAufheben.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnFilterAufheben.Name = "TSBtnFilterAufheben"
        Me.TSBtnFilterAufheben.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnFilterAufheben.Text = "Filter aufheben"
        '
        'PnlDetails
        '
        Me.PnlDetails.Controls.Add(Me.cboxSecurityLevel)
        Me.PnlDetails.Controls.Add(Me.lblSecurityLebel)
        Me.PnlDetails.Controls.Add(Me.cbAktiv)
        Me.PnlDetails.Controls.Add(Me.txtMutierer)
        Me.PnlDetails.Controls.Add(Me.txtMutiert_am)
        Me.PnlDetails.Controls.Add(Me.txtErstellt_am)
        Me.PnlDetails.Controls.Add(Me.lblMutierer)
        Me.PnlDetails.Controls.Add(Me.lblMutiert_am)
        Me.PnlDetails.Controls.Add(Me.lblErstelltam)
        Me.PnlDetails.Controls.Add(Me.txtBemerkung)
        Me.PnlDetails.Controls.Add(Me.lblBemerkung)
        Me.PnlDetails.Controls.Add(Me.txtInternet)
        Me.PnlDetails.Controls.Add(Me.lblInternet)
        Me.PnlDetails.Controls.Add(Me.txtEmail)
        Me.PnlDetails.Controls.Add(Me.lblEmail)
        Me.PnlDetails.Controls.Add(Me.txtTelefon)
        Me.PnlDetails.Controls.Add(Me.txtTelefax)
        Me.PnlDetails.Controls.Add(Me.lblTelefax)
        Me.PnlDetails.Controls.Add(Me.lblTelefon)
        Me.PnlDetails.Controls.Add(Me.txtOrt)
        Me.PnlDetails.Controls.Add(Me.txtPlz)
        Me.PnlDetails.Controls.Add(Me.lblPlzOrt)
        Me.PnlDetails.Controls.Add(Me.txtPostfach)
        Me.PnlDetails.Controls.Add(Me.lblPostfach)
        Me.PnlDetails.Controls.Add(Me.txtStrasse)
        Me.PnlDetails.Controls.Add(Me.lblStrasse)
        Me.PnlDetails.Controls.Add(Me.txtVorname_Firma2)
        Me.PnlDetails.Controls.Add(Me.lblVorname_Firma2)
        Me.PnlDetails.Controls.Add(Me.txtName_Firma1)
        Me.PnlDetails.Controls.Add(Me.lblName_Firma1)
        Me.PnlDetails.Dock = System.Windows.Forms.DockStyle.Top
        Me.PnlDetails.Location = New System.Drawing.Point(205, 49)
        Me.PnlDetails.Name = "PnlDetails"
        Me.PnlDetails.Size = New System.Drawing.Size(649, 266)
        Me.PnlDetails.TabIndex = 0
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(85, 235)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 12
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(8, 239)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 89
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'cbAktiv
        '
        Me.cbAktiv.Location = New System.Drawing.Point(398, 114)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.cbAktiv.Size = New System.Drawing.Size(76, 15)
        Me.cbAktiv.TabIndex = 10
        Me.cbAktiv.Tag = ""
        Me.cbAktiv.Text = "Aktiv"
        Me.cbAktiv.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.cbAktiv.UseVisualStyleBackColor = True
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutierer.Location = New System.Drawing.Point(564, 236)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(71, 20)
        Me.txtMutierer.TabIndex = 86
        Me.txtMutierer.TabStop = False
        '
        'txtMutiert_am
        '
        Me.txtMutiert_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtMutiert_am.Location = New System.Drawing.Point(402, 236)
        Me.txtMutiert_am.Name = "txtMutiert_am"
        Me.txtMutiert_am.ReadOnly = True
        Me.txtMutiert_am.Size = New System.Drawing.Size(79, 20)
        Me.txtMutiert_am.TabIndex = 85
        Me.txtMutiert_am.TabStop = False
        '
        'txtErstellt_am
        '
        Me.txtErstellt_am.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.txtErstellt_am.Location = New System.Drawing.Point(258, 236)
        Me.txtErstellt_am.Name = "txtErstellt_am"
        Me.txtErstellt_am.ReadOnly = True
        Me.txtErstellt_am.Size = New System.Drawing.Size(79, 20)
        Me.txtErstellt_am.TabIndex = 84
        Me.txtErstellt_am.TabStop = False
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(493, 239)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(72, 13)
        Me.lblMutierer.TabIndex = 83
        Me.lblMutierer.Text = "Mutiert durch:"
        '
        'lblMutiert_am
        '
        Me.lblMutiert_am.AccessibleDescription = "Name"
        Me.lblMutiert_am.AutoSize = True
        Me.lblMutiert_am.Location = New System.Drawing.Point(343, 239)
        Me.lblMutiert_am.Name = "lblMutiert_am"
        Me.lblMutiert_am.Size = New System.Drawing.Size(59, 13)
        Me.lblMutiert_am.TabIndex = 82
        Me.lblMutiert_am.Text = "Mutiert am:"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(200, 239)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(58, 13)
        Me.lblErstelltam.TabIndex = 81
        Me.lblErstelltam.Text = "Erstellt am:"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(11, 153)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(626, 72)
        Me.txtBemerkung.TabIndex = 11
        '
        'lblBemerkung
        '
        Me.lblBemerkung.AccessibleDescription = "Name"
        Me.lblBemerkung.AutoSize = True
        Me.lblBemerkung.Location = New System.Drawing.Point(8, 137)
        Me.lblBemerkung.Name = "lblBemerkung"
        Me.lblBemerkung.Size = New System.Drawing.Size(61, 13)
        Me.lblBemerkung.TabIndex = 79
        Me.lblBemerkung.Text = "Bemerkung"
        '
        'txtInternet
        '
        Me.txtInternet.Location = New System.Drawing.Point(462, 85)
        Me.txtInternet.Name = "txtInternet"
        Me.txtInternet.Size = New System.Drawing.Size(177, 20)
        Me.txtInternet.TabIndex = 9
        '
        'lblInternet
        '
        Me.lblInternet.AccessibleDescription = "Name"
        Me.lblInternet.AutoSize = True
        Me.lblInternet.Location = New System.Drawing.Point(400, 88)
        Me.lblInternet.Name = "lblInternet"
        Me.lblInternet.Size = New System.Drawing.Size(43, 13)
        Me.lblInternet.TabIndex = 77
        Me.lblInternet.Text = "Internet"
        '
        'txtEmail
        '
        Me.txtEmail.Location = New System.Drawing.Point(462, 59)
        Me.txtEmail.Name = "txtEmail"
        Me.txtEmail.Size = New System.Drawing.Size(177, 20)
        Me.txtEmail.TabIndex = 8
        '
        'lblEmail
        '
        Me.lblEmail.AccessibleDescription = "Name"
        Me.lblEmail.AutoSize = True
        Me.lblEmail.Location = New System.Drawing.Point(400, 62)
        Me.lblEmail.Name = "lblEmail"
        Me.lblEmail.Size = New System.Drawing.Size(36, 13)
        Me.lblEmail.TabIndex = 75
        Me.lblEmail.Text = "E-Mail"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(462, 7)
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefon.TabIndex = 6
        '
        'txtTelefax
        '
        Me.txtTelefax.Location = New System.Drawing.Point(462, 33)
        Me.txtTelefax.Name = "txtTelefax"
        Me.txtTelefax.Size = New System.Drawing.Size(177, 20)
        Me.txtTelefax.TabIndex = 7
        '
        'lblTelefax
        '
        Me.lblTelefax.AccessibleDescription = "Name"
        Me.lblTelefax.AutoSize = True
        Me.lblTelefax.Location = New System.Drawing.Point(400, 36)
        Me.lblTelefax.Name = "lblTelefax"
        Me.lblTelefax.Size = New System.Drawing.Size(42, 13)
        Me.lblTelefax.TabIndex = 72
        Me.lblTelefax.Text = "Telefax"
        '
        'lblTelefon
        '
        Me.lblTelefon.AccessibleDescription = "Name"
        Me.lblTelefon.AutoSize = True
        Me.lblTelefon.Location = New System.Drawing.Point(399, 10)
        Me.lblTelefon.Name = "lblTelefon"
        Me.lblTelefon.Size = New System.Drawing.Size(43, 13)
        Me.lblTelefon.TabIndex = 71
        Me.lblTelefon.Text = "Telefon"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(205, 111)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 5
        '
        'txtPlz
        '
        Me.txtPlz.Location = New System.Drawing.Point(137, 111)
        Me.txtPlz.Name = "txtPlz"
        Me.txtPlz.Size = New System.Drawing.Size(62, 20)
        Me.txtPlz.TabIndex = 4
        '
        'lblPlzOrt
        '
        Me.lblPlzOrt.AccessibleDescription = "Name"
        Me.lblPlzOrt.AutoSize = True
        Me.lblPlzOrt.Location = New System.Drawing.Point(10, 114)
        Me.lblPlzOrt.Name = "lblPlzOrt"
        Me.lblPlzOrt.Size = New System.Drawing.Size(52, 13)
        Me.lblPlzOrt.TabIndex = 68
        Me.lblPlzOrt.Text = "PLZ / Ort"
        '
        'txtPostfach
        '
        Me.txtPostfach.Location = New System.Drawing.Point(137, 85)
        Me.txtPostfach.Name = "txtPostfach"
        Me.txtPostfach.Size = New System.Drawing.Size(234, 20)
        Me.txtPostfach.TabIndex = 3
        '
        'lblPostfach
        '
        Me.lblPostfach.AccessibleDescription = "Name"
        Me.lblPostfach.AutoSize = True
        Me.lblPostfach.Location = New System.Drawing.Point(10, 88)
        Me.lblPostfach.Name = "lblPostfach"
        Me.lblPostfach.Size = New System.Drawing.Size(49, 13)
        Me.lblPostfach.TabIndex = 66
        Me.lblPostfach.Text = "Postfach"
        '
        'txtStrasse
        '
        Me.txtStrasse.Location = New System.Drawing.Point(137, 59)
        Me.txtStrasse.Name = "txtStrasse"
        Me.txtStrasse.Size = New System.Drawing.Size(234, 20)
        Me.txtStrasse.TabIndex = 2
        '
        'lblStrasse
        '
        Me.lblStrasse.AccessibleDescription = "Name"
        Me.lblStrasse.AutoSize = True
        Me.lblStrasse.Location = New System.Drawing.Point(10, 62)
        Me.lblStrasse.Name = "lblStrasse"
        Me.lblStrasse.Size = New System.Drawing.Size(42, 13)
        Me.lblStrasse.TabIndex = 64
        Me.lblStrasse.Text = "Strasse"
        '
        'txtVorname_Firma2
        '
        Me.txtVorname_Firma2.Location = New System.Drawing.Point(137, 33)
        Me.txtVorname_Firma2.Name = "txtVorname_Firma2"
        Me.txtVorname_Firma2.Size = New System.Drawing.Size(234, 20)
        Me.txtVorname_Firma2.TabIndex = 1
        '
        'lblVorname_Firma2
        '
        Me.lblVorname_Firma2.AccessibleDescription = "Name"
        Me.lblVorname_Firma2.AutoSize = True
        Me.lblVorname_Firma2.Location = New System.Drawing.Point(10, 36)
        Me.lblVorname_Firma2.Name = "lblVorname_Firma2"
        Me.lblVorname_Firma2.Size = New System.Drawing.Size(120, 13)
        Me.lblVorname_Firma2.TabIndex = 62
        Me.lblVorname_Firma2.Text = "Vorname / Firma Zeile 2"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(137, 7)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(234, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(10, 10)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 60
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'GrpKontakte
        '
        Me.GrpKontakte.Controls.Add(Me.C1Kontakte)
        Me.GrpKontakte.Controls.Add(Me.ToolStrip2)
        Me.GrpKontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpKontakte.Location = New System.Drawing.Point(205, 315)
        Me.GrpKontakte.Name = "GrpKontakte"
        Me.GrpKontakte.Size = New System.Drawing.Size(649, 298)
        Me.GrpKontakte.TabIndex = 3
        Me.GrpKontakte.TabStop = False
        Me.GrpKontakte.Text = "Kontakte"
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.ContextMenuStrip = Me.KontaktMenuStrip
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FetchRowStyles = True
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(3, 16)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.Size = New System.Drawing.Size(643, 279)
        Me.C1Kontakte.TabIndex = 0
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'KontaktMenuStrip
        '
        Me.KontaktMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.KontaktAnzeigenToolStripMenuItem, Me.KontaktKopierenToolStripMenuItem, Me.KontaktNeuToolStripMenuItem, Me.KontaktInaktivierenToolStripMenuItem})
        Me.KontaktMenuStrip.Name = "ContextMenuStripKontakte"
        Me.KontaktMenuStrip.Size = New System.Drawing.Size(132, 92)
        '
        'KontaktAnzeigenToolStripMenuItem
        '
        Me.KontaktAnzeigenToolStripMenuItem.Name = "KontaktAnzeigenToolStripMenuItem"
        Me.KontaktAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktAnzeigenToolStripMenuItem.Text = "&Anzeigen"
        '
        'KontaktKopierenToolStripMenuItem
        '
        Me.KontaktKopierenToolStripMenuItem.Name = "KontaktKopierenToolStripMenuItem"
        Me.KontaktKopierenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktKopierenToolStripMenuItem.Text = "&Kopieren"
        '
        'KontaktNeuToolStripMenuItem
        '
        Me.KontaktNeuToolStripMenuItem.Name = "KontaktNeuToolStripMenuItem"
        Me.KontaktNeuToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktNeuToolStripMenuItem.Text = "&Neu"
        '
        'KontaktInaktivierenToolStripMenuItem
        '
        Me.KontaktInaktivierenToolStripMenuItem.Name = "KontaktInaktivierenToolStripMenuItem"
        Me.KontaktInaktivierenToolStripMenuItem.Size = New System.Drawing.Size(131, 22)
        Me.KontaktInaktivierenToolStripMenuItem.Text = "&Inaktivieren"
        '
        'ToolStrip2
        '
        Me.ToolStrip2.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TS2BtnView, Me.TS2BtnCopy, Me.TS2BtnNew, Me.TS2BtnDelete})
        Me.ToolStrip2.Location = New System.Drawing.Point(3, 16)
        Me.ToolStrip2.Name = "ToolStrip2"
        Me.ToolStrip2.Size = New System.Drawing.Size(643, 25)
        Me.ToolStrip2.TabIndex = 1
        Me.ToolStrip2.Text = "Toolstrip Kontakte"
        Me.ToolStrip2.Visible = False
        '
        'TS2BtnView
        '
        Me.TS2BtnView.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnView.Image = CType(resources.GetObject("TS2BtnView.Image"), System.Drawing.Image)
        Me.TS2BtnView.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnView.Name = "TS2BtnView"
        Me.TS2BtnView.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnView.Text = "Datensatz anzeigen"
        Me.TS2BtnView.ToolTipText = "Datensatz anzeigen"
        '
        'TS2BtnCopy
        '
        Me.TS2BtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnCopy.Image = CType(resources.GetObject("TS2BtnCopy.Image"), System.Drawing.Image)
        Me.TS2BtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnCopy.Name = "TS2BtnCopy"
        Me.TS2BtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnCopy.Text = "Datensatz kopieren"
        Me.TS2BtnCopy.ToolTipText = "Datensatz kopieren"
        '
        'TS2BtnNew
        '
        Me.TS2BtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnNew.Image = CType(resources.GetObject("TS2BtnNew.Image"), System.Drawing.Image)
        Me.TS2BtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnNew.Name = "TS2BtnNew"
        Me.TS2BtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnNew.Text = "Neuer Datensatz"
        Me.TS2BtnNew.ToolTipText = "Neuer Datensatz"
        '
        'TS2BtnDelete
        '
        Me.TS2BtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TS2BtnDelete.Image = CType(resources.GetObject("TS2BtnDelete.Image"), System.Drawing.Image)
        Me.TS2BtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TS2BtnDelete.Name = "TS2BtnDelete"
        Me.TS2BtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TS2BtnDelete.Text = "Datensatz inaktivieren"
        Me.TS2BtnDelete.ToolTipText = "Datensatz inaktivieren"
        '
        'GrpPartner
        '
        Me.GrpPartner.Controls.Add(Me.TreeVertragspartner)
        Me.GrpPartner.Dock = System.Windows.Forms.DockStyle.Left
        Me.GrpPartner.Location = New System.Drawing.Point(0, 49)
        Me.GrpPartner.Name = "GrpPartner"
        Me.GrpPartner.Size = New System.Drawing.Size(205, 564)
        Me.GrpPartner.TabIndex = 0
        Me.GrpPartner.TabStop = False
        Me.GrpPartner.Text = "Partner"
        '
        'TreeVertragspartner
        '
        Me.TreeVertragspartner.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeVertragspartner.HideSelection = False
        Me.TreeVertragspartner.HotTracking = True
        Me.TreeVertragspartner.ImageIndex = 0
        Me.TreeVertragspartner.ImageList = Me.ImageListTreeImages
        Me.TreeVertragspartner.Location = New System.Drawing.Point(3, 16)
        Me.TreeVertragspartner.Name = "TreeVertragspartner"
        Me.TreeVertragspartner.SelectedImageIndex = 0
        Me.TreeVertragspartner.Size = New System.Drawing.Size(199, 545)
        Me.TreeVertragspartner.TabIndex = 0
        '
        'ImageListTreeImages
        '
        Me.ImageListTreeImages.ImageStream = CType(resources.GetObject("ImageListTreeImages.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListTreeImages.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListTreeImages.Images.SetKeyName(0, "Personen.ico")
        Me.ImageListTreeImages.Images.SetKeyName(1, "Carisblok1.ico")
        Me.ImageListTreeImages.Images.SetKeyName(2, "Carisblok3.ico")
        Me.ImageListTreeImages.Images.SetKeyName(3, "book02.gif")
        Me.ImageListTreeImages.Images.SetKeyName(4, "DOC.BMP")
        Me.ImageListTreeImages.Images.SetKeyName(5, "Folder.ico")
        Me.ImageListTreeImages.Images.SetKeyName(6, "Personen_Inaktiv.ico")
        Me.ImageListTreeImages.Images.SetKeyName(7, "Carisblok1_Deleted.ico")
        Me.ImageListTreeImages.Images.SetKeyName(8, "Carisblok3_Deleted.ico")
        '
        'frmVertragspartner
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(854, 613)
        Me.Controls.Add(Me.GrpKontakte)
        Me.Controls.Add(Me.PnlDetails)
        Me.Controls.Add(Me.GrpPartner)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragspartner"
        Me.Text = "Vertragspartner"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.PnlDetails.ResumeLayout(False)
        Me.PnlDetails.PerformLayout()
        Me.GrpKontakte.ResumeLayout(False)
        Me.GrpKontakte.PerformLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.KontaktMenuStrip.ResumeLayout(False)
        Me.ToolStrip2.ResumeLayout(False)
        Me.ToolStrip2.PerformLayout()
        Me.GrpPartner.ResumeLayout(False)
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.KontaktInaktivierenToolStripMenuItem_Click -Methode

Kontextmenu Delete

[Visual Basic]
Private Sub KontaktInaktivierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktInaktivierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktInaktivierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktInaktivierenToolStripMenuItem.Click
        Try
            Me.TS2BtnDelete_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.KontaktKopierenToolStripMenuItem_Click -Methode

Kontextmenu Kopieren

[Visual Basic]
Private Sub KontaktKopierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktKopierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktKopierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktKopierenToolStripMenuItem.Click
        Try
            Me.TS2BtnCopy_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.KontaktMenuStrip_Opening -Methode

[Visual Basic]
Private Sub KontaktMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   KontaktMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles KontaktMenuStrip.Opening
        Disable_Enable_Menu(Me.KontaktMenuStrip, Me.C1Kontakte)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.KontaktNeuToolStripMenuItem_Click -Methode

Kontextmenu Neu

[Visual Basic]
Private Sub KontaktNeuToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   KontaktNeuToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub KontaktNeuToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles KontaktNeuToolStripMenuItem.Click
        Try
            Me.TS2BtnNew_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Refresh_Personen -Methode

Personenliste aktualisieren

[Visual Basic]
Private Sub Refresh_Personen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Personen()
        Try
            If check_changes = False Then Exit Sub
        Catch ex As Exception

        End Try
        Me.C1Kontakte.Enabled = True
        Me.Vertragspartnerdata.Get_Kontaktpersonen(Me.C1Kontakte)
        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Person", Me.Vertragspartnerdata.Kontaktpersonen.Tabledata)
        sec.Set_Form_Security(Me)
        Me.C1Kontakte.Enabled = True
        Me.Set_KontaktButtons()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Refresh_Vertragspartnerliste -Methode

[Visual Basic]
Private Sub Refresh_Vertragspartnerliste()

Quellcode

[Visual Basic]
    Private Sub Refresh_Vertragspartnerliste()

        Me.Vertragspartnerdata.Get_Vertragspartnerliste(Me.TStxtFilter.Text, Me.TreeVertragspartner)
        If Me.vpnr = -1 Then
            Me.TreeVertragspartner.SelectedNode = Me.TreeVertragspartner.Nodes(0)
            Me.vpnr = Me.TreeVertragspartner.SelectedNode.Tag
        Else
            Me.TreeVertragspartner.SelectedNode = FindNode(Me.TreeVertragspartner.Nodes, Me.vpnr, "")
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Save_Data -Methode

Vertragspartner sichern, sofern Änderungen vorgenommen wurden, anschliessend erneut laden

[Visual Basic]
Private Sub Save_Data()

Quellcode

[Visual Basic]
    Private Sub Save_Data()
        If Me.FormDataChanged Then
            Me.Vertragspartnerdata.sNameZ1 = New SqlString(CType(Me.txtName_Firma1.Text, String))
            Me.Vertragspartnerdata.sNameZ2 = New SqlString(CType(Me.txtVorname_Firma2.Text, String))
            Me.Vertragspartnerdata.sStrasse = New SqlString(CType(Me.txtStrasse.Text, String))
            Me.Vertragspartnerdata.sPostfach = New SqlString(CType(Me.txtPostfach.Text, String))
            Me.Vertragspartnerdata.sPLZ = New SqlString(CType(Me.txtPlz.Text, String))
            Me.Vertragspartnerdata.sOrt = New SqlString(CType(Me.txtOrt.Text, String))
            Me.Vertragspartnerdata.sTelefon = New SqlString(CType(Me.txtTelefon.Text, String))
            Me.Vertragspartnerdata.sTelefax = New SqlString(CType(Me.txtTelefax.Text, String))
            Me.Vertragspartnerdata.sEMail = New SqlString(CType(Me.txtEmail.Text, String))
            Me.Vertragspartnerdata.sInternet = New SqlString(CType(Me.txtInternet.Text, String))
            Me.Vertragspartnerdata.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            Me.Vertragspartnerdata.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
            Me.Vertragspartnerdata.iSecurityLevelNr = New SqlInt32(CType(Me.cboxSecurityLevel.SelectedValue, Int32))
            Get_Data(Me.Vertragspartnerdata.Save_Data)
            Me.FormDataChanged = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Set_KontaktButtons -Methode

Buttons für das Kontakt-Grid abhängig der angezeigten Datensätze enablen bzw. disablen

[Visual Basic]
Private Function Set_KontaktButtons() As Object

Quellcode

[Visual Basic]
    Private Function Set_KontaktButtons()
        If Me.C1Kontakte.Splits(0).Rows.Count = 0 Then
            Me.TS2BtnNew.Enabled = True
            Me.TS2BtnView.Enabled = False
            Me.TS2BtnCopy.Enabled = False
            Me.TS2BtnDelete.Enabled = False
        Else
            Me.TS2BtnNew.Enabled = True
            Me.TS2BtnView.Enabled = True
            Me.TS2BtnCopy.Enabled = True
            Me.TS2BtnDelete.Enabled = True
        End If
        sec.Set_Form_Security(Me)
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.Set_Titel -Methode

[Visual Basic]
Private Sub Set_Titel()

Quellcode

[Visual Basic]
    Private Sub Set_Titel()
        Me.Text = "Vertragspartner - " + Me.txtName_Firma1.Text
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TS2BtnCopy_Click -Methode

Kopie eines Datensatzen erstellen

[Visual Basic]
Private Sub TS2BtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TS2BtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnCopy.Click
        Try
            Me.Vertragspartnerdata.Kontaktperson.Create_Copy(Me.C1Kontakte.Columns("Personnr").Value)
            Me.Refresh_Personen()
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TS2BtnDelete_Click -Methode

Kontakt löschen (inaktivieren)

[Visual Basic]
Private Sub TS2BtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TS2BtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnDelete.Click
        If msg.Show_MessageYesNo(200) = MsgBoxResult.Yes Then
            Me.Vertragspartnerdata.Kontaktperson.Delete_Kontakt(Me.C1Kontakte.Columns("Personnr").Value)
            Me.Refresh_Personen()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TS2BtnNew_Click -Methode

Neuer Kontakt hinzufügen

[Visual Basic]
Private Sub TS2BtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TS2BtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnNew.Click
        Dim f As New frmPerson(0, Me.Vertragspartnerdata.iVertragspartnerNr.Value, Me.FormReadonly, True)
        f.ShowDialog()
        Me.Refresh_Personen()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TS2BtnView_Click -Methode

Personendetails anzeigen bzw. bearbeiten

[Visual Basic]
Private Sub TS2BtnView_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TS2BtnView.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TS2BtnView_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TS2BtnView.Click
        Try
            Dim f As New frmPerson(Me.C1Kontakte.Columns("Personnr").Value, Me.Vertragspartnerdata.iVertragspartnerNr.Value, Me.FormReadonly)
            f.ShowDialog()
            Me.Refresh_Personen()
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Vertragspartnerdata.Create_Copy(Me.Vertragspartnerdata.iVertragspartnerNr.Value))
        Me.Vertragspartnerdata.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
        If msg.Show_MessageYesNo(250) = MsgBoxResult.Yes Then
            Me.Vertragspartnerdata.Delete_Partner(Me.Vertragspartnerdata.iVertragspartnerNr.Value)
            Me.Close()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnFilterAufheben_Click -Methode

[Visual Basic]
Private Sub TSBtnFilterAufheben_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnFilterAufheben.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnFilterAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnFilterAufheben.Click
        Me.TStxtFilter.Text = ""
        Refresh_Vertragspartnerliste()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
        If Me.Check_Changes = False Then Exit Sub
        Me.Get_Data(Me.Vertragspartnerdata.Add_New)
        Me.Vertragspartnerdata.Neuer_Datensatz = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnSave_Click -Methode

Sicherungs-Button betätigt

[Visual Basic]
Private Sub TSBtnSave_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSave.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSave.Click
        Me.Save_Data()
        Me.txtMutiert_am.Text = Me.Vertragspartnerdata.daMutiert_am.ToString
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TSBtnSuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        Me.Refresh_Vertragspartnerliste()

        'If Not Me.FormReadonly Then Check_Changes()
        'Dim i As Integer
        'If Me.Vertragspartnerdata.Vertragspartner_Suchen(i) = True Then
        '    Me.Get_Data(i)
        'End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TStxtFilter_KeyDown -Methode

[Visual Basic]
Private Sub TStxtFilter_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TStxtFilter.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TStxtFilter_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TStxtFilter.KeyDown
        If e.KeyCode = Keys.Enter Then
            refresh_vertragspartnerliste()
        End If
        If Me.TreeVertragspartner.Nodes.Count = 1 Then
            Me.TreeVertragspartner.SelectedNode = Me.TreeVertragspartner.Nodes(0)

        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TreeStruktur_MouseDown -Methode

Mousedown-Ereignis auf dem Tree

[Visual Basic]
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeVertragspartner.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeVertragspartner.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeVertragspartner.SelectedNode = Me.TreeVertragspartner.GetNodeAt(selectPoint)

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TreeVertragspartner_AfterSelect -Methode

[Visual Basic]
Private Sub TreeVertragspartner_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeVertragspartner.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeVertragspartner_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeVertragspartner.AfterSelect
        If Me.Check_Changes = False Then Exit Sub
        Me.vpnr = Me.TreeVertragspartner.SelectedNode.Tag
        Me.IsOnLoad = True
        Me.Get_Data(Me.vpnr)
        Me.IsOnLoad = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.TreeVertragspartner_BackColorChanged -Methode

[Visual Basic]
Private Sub TreeVertragspartner_BackColorChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeVertragspartner.BackColorChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeVertragspartner_BackColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeVertragspartner.BackColorChanged

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


dispose -Methode

Überladungsliste

[Visual Basic] Protected Overrides Sub Dispose(Boolean)
[C#] protected override System.Void Dispose(bool);

destruction Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

frmVertragspartner


frmVertragspartner.frmVertragspartner_Load -Methode

Formular laden

[Visual Basic]
Private Sub frmVertragspartner_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragspartner_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        If Anzeige = True Then
            Me.TSBtnSuche.Enabled = False
            Me.TSBtnSave.Enabled = False
        Else
            Me.TSBtnSuche.Enabled = True
        End If
        sec.Set_Form_Security(Me)

        If Me.TSBtnSave.Enabled = False Or Me.TSBtnSave.Visible = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False

            Me.TS2BtnNew.Enabled = False
            Me.TS2BtnCopy.Enabled = False
            Me.TS2BtnDelete.Enabled = False

            Me.KontaktAnzeigenToolStripMenuItem.Enabled = False
            Me.KontaktKopierenToolStripMenuItem.Enabled = False
            Me.KontaktNeuToolStripMenuItem.Enabled = False
            Me.KontaktInaktivierenToolStripMenuItem.Enabled = False
        Else
            Me.FormReadonly = False
        End If

        Me.Refresh_Vertragspartnerliste()
        If Me.vpnr <> -1 Then
            Me.TreeVertragspartner.SelectedNode = Me.FindNode(Me.TreeVertragspartner.Nodes, Me.vpnr, "")
        Else
            Me.TreeVertragspartner.SelectedNode = Me.TreeVertragspartner.Nodes(0)
        End If
        Load_Securitylevel()
        Get_Data(Me.vpnr)
        If Me.Neuer_Datensatz = True Then
            Me.Vertragspartnerdata.Neuer_Datensatz = True
            Me.Neuer_Datensatz = False
        End If
        Me.AddChanges(Me)
        If Me.FormReadonly Then sec.Set_Form_Readonly(Me)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.frmVertragspartner_Shown -Methode

Anzeige des Suchformulars, wenn keine Vertragspartnernummer vorhanden ist

[Visual Basic]
Private Sub frmVertragspartner_Shown( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Shown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragspartner_Shown(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Shown
        'If Me.vpnr = -1 Then Me.TSBtnSuche_Click(sender, e)
        Me.IsOnLoad = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.txtBemerkung_TextChanged -Methode

Änderungsvermerk sofern Änderungen vorgenommen wurden

[Visual Basic]
Private Sub txtBemerkung_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtBemerkung.TextChanged, _
   cboxSecurityLevel.SelectedIndexChanged, _
   txtTelefon.TextChanged, _
   txtTelefax.TextChanged, _
   txtEmail.TextChanged, _
   txtInternet.TextChanged, _
   cbAktiv.CheckedChanged, _
   txtOrt.TextChanged, _
   txtPlz.TextChanged, _
   txtPostfach.TextChanged, _
   txtStrasse.TextChanged, _
   txtVorname_Firma2.TextChanged, _
   txtName_Firma1.TextChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtBemerkung_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtBemerkung.TextChanged, cboxSecurityLevel.SelectedIndexChanged, txtTelefon.TextChanged, _
        txtTelefax.TextChanged, txtEmail.TextChanged, txtInternet.TextChanged, cbAktiv.CheckedChanged, txtOrt.TextChanged, txtPlz.TextChanged, txtPostfach.TextChanged, _
        txtStrasse.TextChanged, txtVorname_Firma2.TextChanged, txtName_Firma1.TextChanged
        Me.FormDataChanged = True
        Set_Titel()
        If sender.name = "cbAktiv" Then
            If Not Me.IsOnLoad Then
                If Me.cbAktiv.Checked = False Then
                    msg.show_standardmessage(851, MsgBoxStyle.Critical)
                End If
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner-Felder

frmVertragspartner Übersicht

Felder

private field Anzeige

Unterstützt von .NET Compact Framework
private field FormDataChanged

Unterstützt von .NET Compact Framework
private field FormReadonly

Unterstützt von .NET Compact Framework
private field IsOnLoad

Unterstützt von .NET Compact Framework
private field Kontaktperson

Unterstützt von .NET Compact Framework
private field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field SpaltenTitel

Unterstützt von .NET Compact Framework
private field Vertragspartnerdata

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field msg

Unterstützt von .NET Compact Framework
private field sec

Unterstützt von .NET Compact Framework
internal (Friend) field selectPoint

Unterstützt von .NET Compact Framework
private field vpnr

Unterstützt von .NET Compact Framework

Siehe auch

frmVertragspartner -Klasse | TKB.VV.SLA | TKB.VV.SLA.clsServiceKatalogTree | TKB.VV.Sysadmin | TKB.VV.Sysadmin.DomainTable | TKB.VV.Utils | TKB.VV.Utils.MyMessage | TKB.VV.Utils.MySecurity | TKB.VV.Utils.Tabellenspalte


Anzeige -Feld

[Visual Basic]
Private Anzeige As Boolean

Quellcode

[Visual Basic]
    Private Anzeige As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


IsOnLoad -Feld

[Visual Basic]
Private IsOnLoad As Boolean

Quellcode

[Visual Basic]
    Dim IsOnLoad As Boolean = True

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


Kontaktperson -Feld

[Visual Basic]
Private Kontaktperson As clsPersonen

Quellcode

[Visual Basic]
    Dim Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


Neuer_Datensatz -Feld

[Visual Basic]
Private Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
    Dim Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


Vertragspartnerdata -Feld

[Visual Basic]
Private Vertragspartnerdata As clsVertragspartner

Quellcode

[Visual Basic]
    Dim Vertragspartnerdata As New TKB.VV.Vertrag.clsVertragspartner

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


msg -Feld

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


sec -Feld

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


vpnr -Feld

[Visual Basic]
Private vpnr As Integer

Quellcode

[Visual Basic]
    Private vpnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartnerSuche -Klasse

Vertragspartnersuche

For a list of all members of this type, see frmVertragspartnerSuche-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragspartnerSuche

[Visual Basic]
Public Class frmVertragspartnerSuche
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmVertragspartnerSuche-Member


frmVertragspartnerSuche-Member

frmVertragspartnerSuche Übersicht

Öffentliche Eigenschaften

public property Vertragspartnernr

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method BtnSchliessen_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method BtnSelect_Click Unterstützt von .NET Compact Framework | BtnSelect gewählt
private method BtnSuche_Click Unterstützt von .NET Compact Framework | Suche ausführen
private method C1Partnerliste_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick in C1Partnerliste
private method C1Partnerliste_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
private method DetailsAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Details anzeigen gewählt
private method FrmVertragspartnerSuche_Load Unterstützt von .NET Compact Framework | Load des Dialogs
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Partner_Suchen Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method Serach_data Unterstützt von .NET Compact Framework | Vertragspartner aus DB auslesen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method frmVertragspartnerSuche_Disposed Unterstützt von .NET Compact Framework |
private method txtName_Firma1_KeyDown Unterstützt von .NET Compact Framework | txtName_FirmaZ1 KeyDown
private method txtOrt_KeyDown Unterstützt von .NET Compact Framework | txtOrt Keydown
private method ÜberrnehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Übernehmen gewählt

Felder

private field components

Unterstützt von .NET Compact Framework
private field d

Unterstützt von .NET Compact Framework
private field m_Vertragspartnernr

Unterstützt von .NET Compact Framework

frmVertragspartnerSuche -Klasse


frmVertragspartnerSuche-Eigenschaften

frmVertragspartnerSuche Übersicht

Öffentliche Eigenschaften

public property Vertragspartnernr

Unterstützt von .NET Compact Framework

frmVertragspartnerSuche -Klasse


frmVertragspartnerSuche.Vertragspartnernr -Eigenschaft

[Visual Basic]
Public Property Vertragspartnernr() As Integer

Quellcode

[Visual Basic]
    Property Vertragspartnernr() As Integer
        Get
            Return m_Vertragspartnernr
        End Get
        Set(ByVal value As Integer)
            m_Vertragspartnernr = value
        End Set
    End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche-Methoden

frmVertragspartnerSuche Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method BtnSchliessen_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method BtnSelect_Click Unterstützt von .NET Compact Framework | BtnSelect gewählt
private method BtnSuche_Click Unterstützt von .NET Compact Framework | Suche ausführen
private method C1Partnerliste_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick in C1Partnerliste
private method C1Partnerliste_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird
private method DetailsAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Details anzeigen gewählt
private method FrmVertragspartnerSuche_Load Unterstützt von .NET Compact Framework | Load des Dialogs
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Partner_Suchen Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method Serach_data Unterstützt von .NET Compact Framework | Vertragspartner aus DB auslesen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Schliessen des Fensters
private method frmVertragspartnerSuche_Disposed Unterstützt von .NET Compact Framework |
private method txtName_Firma1_KeyDown Unterstützt von .NET Compact Framework | txtName_FirmaZ1 KeyDown
private method txtOrt_KeyDown Unterstützt von .NET Compact Framework | txtOrt Keydown
private method ÜberrnehmenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Kontextmenu Übernehmen gewählt

frmVertragspartnerSuche -Klasse


frmVertragspartnerSuche.BeendenToolStripMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.BtnSchliessen_Click -Methode

Schliessen des Fensters

[Visual Basic]
Private Sub BtnSchliessen_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSchliessen.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSchliessen.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.BtnSelect_Click -Methode

BtnSelect gewählt

[Visual Basic]
Private Sub BtnSelect_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSelect.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSelect.Click
        Me.Vertragspartnernr = Me.C1Partnerliste.Columns("Vertragspartnernr").Value
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.BtnSuche_Click -Methode

Suche ausführen

[Visual Basic]
Private Sub BtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSuche.Click
        Me.Partner_Suchen()
        If Me.C1Partnerliste.Splits(0).Rows.Count > 0 Then
            Me.C1Partnerliste.Bookmark = 0
            Me.BtnSelect.Enabled = True
            Me.VertragspartnerMenuStrip.Enabled = True
        Else
            Me.BtnSelect.Enabled = False
            Me.VertragspartnerMenuStrip.Enabled = False
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.C1Partnerliste_DoubleClick -Methode

Doubleklick in C1Partnerliste

[Visual Basic]
Private Sub C1Partnerliste_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Partnerliste.DoubleClick

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Partnerliste_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Partnerliste.DoubleClick
        If Me.C1Partnerliste.Splits(0).Rows.Count > 0 Then
            Me.BtnSelect_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.C1Partnerliste_MouseDown -Methode

Mousedown-Ereignis handeln, damit auch bei rechter Maustaste der Fokus auf den richtigen Datensatz gesetzt wird

[Visual Basic]
Private Sub C1Partnerliste_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Partnerliste.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Partnerliste_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Partnerliste.MouseDown
        Me.C1Partnerliste.Bookmark = Me.C1Partnerliste.RowContaining(e.Y)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.DetailsAnzeigenToolStripMenuItem_Click -Methode

Kontextmenu Details anzeigen gewählt

[Visual Basic]
Private Sub DetailsAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DetailsAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DetailsAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DetailsAnzeigenToolStripMenuItem.Click
        Dim f As New frmVertragspartner(Me.C1Partnerliste.Columns("Vertragspartnernr").Value, True)
        f.ShowDialog()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.FrmVertragspartnerSuche_Load -Methode

Load des Dialogs

[Visual Basic]
Private Sub FrmVertragspartnerSuche_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub FrmVertragspartnerSuche_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Vertragspartnernr = -1
        Me.BtnSelect.Enabled = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragspartnerSuche))
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.txtOrt = New System.Windows.Forms.TextBox
        Me.lblOrt = New System.Windows.Forms.Label
        Me.txtName_Firma1 = New System.Windows.Forms.TextBox
        Me.lblName_Firma1 = New System.Windows.Forms.Label
        Me.BtnSuche = New System.Windows.Forms.Button
        Me.VertragspartnerMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ÜberrnehmenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.DetailsAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.txtFreitext = New System.Windows.Forms.TextBox
        Me.lblFreitext = New System.Windows.Forms.Label
        Me.BtnSchliessen = New System.Windows.Forms.Button
        Me.BtnSelect = New System.Windows.Forms.Button
        Me.C1Partnerliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.VertragspartnerMenuStrip.SuspendLayout()
        CType(Me.C1Partnerliste, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(571, 24)
        Me.MenuStrip1.TabIndex = 7
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(571, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "ToolStripButton1"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(93, 78)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(166, 20)
        Me.txtOrt.TabIndex = 1
        '
        'lblOrt
        '
        Me.lblOrt.AccessibleDescription = "Name"
        Me.lblOrt.AutoSize = True
        Me.lblOrt.Location = New System.Drawing.Point(9, 81)
        Me.lblOrt.Name = "lblOrt"
        Me.lblOrt.Size = New System.Drawing.Size(21, 13)
        Me.lblOrt.TabIndex = 72
        Me.lblOrt.Text = "Ort"
        '
        'txtName_Firma1
        '
        Me.txtName_Firma1.Location = New System.Drawing.Point(93, 52)
        Me.txtName_Firma1.Name = "txtName_Firma1"
        Me.txtName_Firma1.Size = New System.Drawing.Size(166, 20)
        Me.txtName_Firma1.TabIndex = 0
        Me.txtName_Firma1.Tag = ""
        '
        'lblName_Firma1
        '
        Me.lblName_Firma1.AccessibleDescription = "Name"
        Me.lblName_Firma1.AutoSize = True
        Me.lblName_Firma1.Location = New System.Drawing.Point(9, 55)
        Me.lblName_Firma1.Name = "lblName_Firma1"
        Me.lblName_Firma1.Size = New System.Drawing.Size(71, 13)
        Me.lblName_Firma1.TabIndex = 71
        Me.lblName_Firma1.Text = "Name / Firma"
        '
        'BtnSuche
        '
        Me.BtnSuche.Location = New System.Drawing.Point(12, 111)
        Me.BtnSuche.Name = "BtnSuche"
        Me.BtnSuche.Size = New System.Drawing.Size(75, 23)
        Me.BtnSuche.TabIndex = 3
        Me.BtnSuche.Text = "Suchen"
        Me.BtnSuche.UseVisualStyleBackColor = True
        '
        'VertragspartnerMenuStrip
        '
        Me.VertragspartnerMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ÜberrnehmenToolStripMenuItem, Me.DetailsAnzeigenToolStripMenuItem})
        Me.VertragspartnerMenuStrip.Name = "VertragspartnerMenuStrip"
        Me.VertragspartnerMenuStrip.Size = New System.Drawing.Size(153, 48)
        '
        'ÜberrnehmenToolStripMenuItem
        '
        Me.ÜberrnehmenToolStripMenuItem.Name = "ÜberrnehmenToolStripMenuItem"
        Me.ÜberrnehmenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.ÜberrnehmenToolStripMenuItem.Text = "Übe&rnehmen"
        '
        'DetailsAnzeigenToolStripMenuItem
        '
        Me.DetailsAnzeigenToolStripMenuItem.Name = "DetailsAnzeigenToolStripMenuItem"
        Me.DetailsAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(152, 22)
        Me.DetailsAnzeigenToolStripMenuItem.Text = "&Details anzeigen"
        '
        'txtFreitext
        '
        Me.txtFreitext.Location = New System.Drawing.Point(393, 52)
        Me.txtFreitext.Name = "txtFreitext"
        Me.txtFreitext.Size = New System.Drawing.Size(166, 20)
        Me.txtFreitext.TabIndex = 2
        Me.txtFreitext.Visible = False
        '
        'lblFreitext
        '
        Me.lblFreitext.AccessibleDescription = "Name"
        Me.lblFreitext.AutoSize = True
        Me.lblFreitext.Location = New System.Drawing.Point(309, 55)
        Me.lblFreitext.Name = "lblFreitext"
        Me.lblFreitext.Size = New System.Drawing.Size(41, 13)
        Me.lblFreitext.TabIndex = 76
        Me.lblFreitext.Text = "Freitext"
        Me.lblFreitext.Visible = False
        '
        'BtnSchliessen
        '
        Me.BtnSchliessen.Location = New System.Drawing.Point(12, 347)
        Me.BtnSchliessen.Name = "BtnSchliessen"
        Me.BtnSchliessen.Size = New System.Drawing.Size(80, 24)
        Me.BtnSchliessen.TabIndex = 8
        Me.BtnSchliessen.Text = "Schliessen"
        '
        'BtnSelect
        '
        Me.BtnSelect.Enabled = False
        Me.BtnSelect.Location = New System.Drawing.Point(475, 347)
        Me.BtnSelect.Name = "BtnSelect"
        Me.BtnSelect.Size = New System.Drawing.Size(88, 23)
        Me.BtnSelect.TabIndex = 5
        Me.BtnSelect.Text = "Übernehmen"
        '
        'C1Partnerliste
        '
        Me.C1Partnerliste.AlternatingRows = True
        Me.C1Partnerliste.FetchRowStyles = True
        Me.C1Partnerliste.FilterBar = True
        Me.C1Partnerliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Partnerliste.Images.Add(CType(resources.GetObject("C1Partnerliste.Images"), System.Drawing.Image))
        Me.C1Partnerliste.Location = New System.Drawing.Point(12, 140)
        Me.C1Partnerliste.Name = "C1Partnerliste"
        Me.C1Partnerliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Partnerliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Partnerliste.PreviewInfo.ZoomFactor = 75
        Me.C1Partnerliste.PrintInfo.PageSettings = CType(resources.GetObject("C1Partnerliste.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Partnerliste.Size = New System.Drawing.Size(547, 201)
        Me.C1Partnerliste.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Partnerliste.TabIndex = 4
        Me.C1Partnerliste.Text = "C1TrueDBGrid1"
        Me.C1Partnerliste.PropBag = resources.GetString("C1Partnerliste.PropBag")
        '
        'frmVertragspartnerSuche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(571, 376)
        Me.Controls.Add(Me.C1Partnerliste)
        Me.Controls.Add(Me.BtnSchliessen)
        Me.Controls.Add(Me.BtnSelect)
        Me.Controls.Add(Me.txtFreitext)
        Me.Controls.Add(Me.lblFreitext)
        Me.Controls.Add(Me.txtOrt)
        Me.Controls.Add(Me.lblOrt)
        Me.Controls.Add(Me.BtnSuche)
        Me.Controls.Add(Me.txtName_Firma1)
        Me.Controls.Add(Me.lblName_Firma1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragspartnerSuche"
        Me.Text = "Vertragspartner suchen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.VertragspartnerMenuStrip.ResumeLayout(False)
        CType(Me.C1Partnerliste, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.Partner_Suchen -Methode

Vertragspartner suchen

[Visual Basic]
Private Function Partner_Suchen() As Object

Quellcode

[Visual Basic]
    Private Function Partner_Suchen()
        If Me.txtName_Firma1.Text <> "" Then
            d = Serach_data(Me.txtName_Firma1.Text, 0)
        Else
            If Me.txtOrt.Text <> "" Then
                d = Serach_data(Me.txtOrt.Text, 1)
            Else
                d = Serach_data("", 2)
            End If
        End If
        Me.C1Partnerliste.DataSource = d
        Me.C1Partnerliste.DataMember = d.TableName

        Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte
        SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Partnerliste, "Vertragspartner", d)
        SpaltenTitel = Nothing
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.Serach_data -Methode

Vertragspartner aus DB auslesen

[Visual Basic]
Private Function Serach_data( _
   ByVal query As String, _
   ByVal fnkt As Integer _
) As DataTable

Parameter

query
fnkt

Quellcode

[Visual Basic]
    Private Function Serach_data(ByVal query As String, ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_vertragspartner_search"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 1000, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
            sdaAdapter.Fill(dtToReturn)
            Return dttoreturn
        Catch ex As Exception
            Throw New Exception("clsVertragspartner::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.TSBtnQuit_Click -Methode

Schliessen des Fensters

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.frmVertragspartnerSuche_Disposed -Methode

[Visual Basic]
Private Sub frmVertragspartnerSuche_Disposed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   Me.Disposed

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmVertragspartnerSuche_Disposed(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Disposed
        d.Dispose()
        components.Dispose()
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.txtName_Firma1_KeyDown -Methode

txtName_FirmaZ1 KeyDown

[Visual Basic]
Private Sub txtName_Firma1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtName_Firma1.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtName_Firma1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtName_Firma1.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.txtOrt_KeyDown -Methode

txtOrt Keydown

[Visual Basic]
Private Sub txtOrt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtOrt.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtOrt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtOrt.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.BtnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche.ÜberrnehmenToolStripMenuItem_Click -Methode

Kontextmenu Übernehmen gewählt

[Visual Basic]
Private Sub ÜberrnehmenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ÜberrnehmenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ÜberrnehmenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ÜberrnehmenToolStripMenuItem.Click
        Me.BtnSelect_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragspartnerSuche-Felder

frmVertragspartnerSuche Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field d

Unterstützt von .NET Compact Framework
private field m_Vertragspartnernr

Unterstützt von .NET Compact Framework

frmVertragspartnerSuche -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


d -Feld

[Visual Basic]
Private d As DataTable

Quellcode

[Visual Basic]
    Dim d As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


m_Vertragspartnernr -Feld

[Visual Basic]
Private m_Vertragspartnernr As Integer

Quellcode

[Visual Basic]
    Dim m_Vertragspartnernr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartnerSuche


frmVertragsuebersicht -Klasse

Vertragsübersicht: Beachten: TabControl wird von TKB.VV.Utils.clsMyTabControl überschrieben

For a list of all members of this type, see frmVertragsuebersicht-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmVertragsuebersicht

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmVertragsuebersicht
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Siehe auch

frmVertragsuebersicht-Member | MyDocMgmt | MyGenericEventHandler | MyMessage | MySecurity | Tabellenspalte | Treenode_Descriptor | clsProfile | clsVertragselement | clsVertragsuebersicht_Strukturen


frmVertragsuebersicht-Member

frmVertragsuebersicht Übersicht

Öffentliche Konstruktoren

public constructor frmVertragsuebersicht -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten im Tree schliessen
private method AlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten im Tree öffnen
private method BeendenToolStipMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Aktivitaeten_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Applikationen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Dokument ab Datenbank anzeigen
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Ereignisse_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1ReferenzVertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Services_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Vertragselemente_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick auf C1Vertragselemente
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Vertragselemente_FormatText Unterstützt von .NET Compact Framework | Datum Formatieren
private method C1Vertragselemente_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument ab Datenbank anzeigen
private method EinzelnerVertragsparterToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method GruppieToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Load_Struktur Unterstützt von .NET Compact Framework | Laden der Treestruktur
private method NeuerVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method NeuesProfilToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Profil erstellen
private method NeuesVertragselementErstellenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Vertragselement laden
private method Order_Tabcontrol Unterstützt von .NET Compact Framework | Reihenfolge der Register im Tabcontrol anpassen
private method ProfilBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil Editieren
private method ProfilLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil löschen
private method Profile_Aktualisieren Unterstützt von .NET Compact Framework | Profilliste des Mitarbeiters aktualisieren
private method ProfilspeichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil speichern
private method RB_CheckedChanged Unterstützt von .NET Compact Framework | Handling RB_Changed für den Aufbau der Struktur
private method Refresh_Aktivitaeten Unterstützt von .NET Compact Framework | Aktivitäten aktualisieren
private method Refresh_All Unterstützt von .NET Compact Framework | Treeview Struktur aktualisieren
private method Refresh_Applikationen Unterstützt von .NET Compact Framework | Applikationen aktualisieren
private method Refresh_Details Unterstützt von .NET Compact Framework |
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumente aktualisieren
private method Refresh_Ereignisse Unterstützt von .NET Compact Framework | Ereignisse aktualisieren
private method Refresh_History Unterstützt von .NET Compact Framework | History aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kündigungsfristen aktualisieren
private method Refresh_Pendenzen Unterstützt von .NET Compact Framework | Pendenzen aktualisieren
private method Refresh_Referenzvertraege Unterstützt von .NET Compact Framework | Referenzverträge aktualisieren
private method Refresh_Register Unterstützt von .NET Compact Framework |
private method Refresh_services Unterstützt von .NET Compact Framework | Services aktualisieren
private method RegisterSpeichernDokumentToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method RegisterSpeichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method RootTreeNode Unterstützt von .NET Compact Framework | Toplevel-Treenode suchen
private method SpaltendarstellungSichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Spaltenlayout C1Vertragselemente speichern
private method TSBrnNeuesProfil_Click Unterstützt von .NET Compact Framework | Neues Profil erstellen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSucheInhalt_Click Unterstützt von .NET Compact Framework |
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSComboboxProfil_SelectedIndexChanged Unterstützt von .NET Compact Framework | Bestehendes Profl auswählen
private method TStxtSucheInhalt_KeyDown Unterstützt von .NET Compact Framework |
private method TStxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method TabControlDiverse_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.
private method TreeStrukturAktualisierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aktualisierung des aktuellen Knotens
private method TreeStrukturContextMenuStrip_Opening Unterstützt von .NET Compact Framework | TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen
private method TreeStrukturTreeAktualisierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vollständiger Treeview aktualisieren
private method TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen / bearbeiten
private method TreeStruktur_AfterSelect Unterstützt von .NET Compact Framework |
private method TreeStruktur_Click Unterstützt von .NET Compact Framework | Treeview-Click
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method Update_DetailInformationen Unterstützt von .NET Compact Framework | Detail-Informationen der ersten 2 TabPages aktualisieren
private method Update_Details Überladen. Unterstützt von .NET Compact Framework | Detailelemente und die allfällig ausgewählte TabPage aktualisieren
private method Update_Node Unterstützt von .NET Compact Framework |
private method VertragselementAnzeigenBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement anzeigen / bearbeiten
private method cbaktiveVertraege_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbaktiveVertraege_CheckedChanged_1 Unterstützt von .NET Compact Framework |
private method cbocInaktiv_CheckedChanged Unterstützt von .NET Compact Framework | Bei Änderung der Inaktiv-Checkbox werden die Hauptstrukturen neu geladen
private method evh_FormularVertragelement_Closed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragspartner_Closed Unterstützt von .NET Compact Framework |
private method frmVertragsuebersicht_Load Unterstützt von .NET Compact Framework | Formular-Load
private method treeStruktur_BeforeExpand Unterstützt von .NET Compact Framework | Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen
private method txtVertragsende_TextChanged Unterstützt von .NET Compact Framework |

Felder

private field Docs Unterstützt von .NET Compact Framework | Dokument-Management-Klasse
private field FormDataChanged Unterstützt von .NET Compact Framework |
private field FormReadonly Unterstützt von .NET Compact Framework |
private field IsOnLoad Unterstützt von .NET Compact Framework |
private field PartnerNode Unterstützt von .NET Compact Framework |
private field PartnerToSelect Unterstützt von .NET Compact Framework |
private field Profil Unterstützt von .NET Compact Framework |
private field Save_LizenzTabPage Unterstützt von .NET Compact Framework |
private field Services Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field Strukturen Unterstützt von .NET Compact Framework | Klasse für die Bewirtschaftung der Tree-Strukturen
private field Tag_Descriptor Unterstützt von .NET Compact Framework | Klasse für die Beschreibung der Tree-Tags
private field Vertragselement Unterstützt von .NET Compact Framework | Vertragselement
private field c1data Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field msg Unterstützt von .NET Compact Framework | Message-Klasse
private field sec Unterstützt von .NET Compact Framework | Security-Klasse
internal (Friend) field selectPoint Unterstützt von .NET Compact Framework |
private field xxx Unterstützt von .NET Compact Framework | Details aktualisieren

Siehe auch

frmVertragsuebersicht -Klasse | MyDocMgmt | MyGenericEventHandler | MyMessage | MySecurity | Tabellenspalte | Treenode_Descriptor | clsProfile | clsVertragselement | clsVertragsuebersicht_Strukturen


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void frmVertragsuebersicht();

[Visual Basic] Public Sub New(Integer)
[C#] public System.Void frmVertragsuebersicht(int);

frmVertragsuebersicht


frmVertragsuebersicht-Methoden

frmVertragsuebersicht Übersicht

Öffentliche Methoden

public method FindNode

Unterstützt von .NET Compact Framework

 Suchen eines Knoten Treeview

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method AlleKnotenSchliessenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten im Tree schliessen
private method AlleKnotenÖffnenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Alle Knoten im Tree öffnen
private method BeendenToolStipMenuItem_Click Unterstützt von .NET Compact Framework | Menu Beenden
private method C1Aktivitaeten_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Applikationen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Dokumente_DoubleClick Unterstützt von .NET Compact Framework | Dokument ab Datenbank anzeigen
private method C1Dokumente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Ereignisse_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Kontakte_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Kuendigungsfristen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Pendenzen_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1ReferenzVertraege_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Services_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Vertragselemente_DoubleClick Unterstützt von .NET Compact Framework | Doubleklick auf C1Vertragselemente
private method C1Vertragselemente_FetchRowStyle Unterstützt von .NET Compact Framework | Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen
private method C1Vertragselemente_FormatText Unterstützt von .NET Compact Framework | Datum Formatieren
private method C1Vertragselemente_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können
private method DokumentAnzeigenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Dokument ab Datenbank anzeigen
private method EinzelnerVertragsparterToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method GruppieToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method InitializeComponent Unterstützt von .NET Compact Framework |
private method Load_Securitylevel Unterstützt von .NET Compact Framework | Laden der Securitylevel-Daten in die Combobox
private method Load_Struktur Unterstützt von .NET Compact Framework | Laden der Treestruktur
private method NeuerVertragspartnerToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neuer Vertragspartner eröffnen
private method NeuesProfilToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Profil erstellen
private method NeuesVertragselementErstellenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Neues Vertragselement laden
private method Order_Tabcontrol Unterstützt von .NET Compact Framework | Reihenfolge der Register im Tabcontrol anpassen
private method ProfilBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil Editieren
private method ProfilLöschenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil löschen
private method Profile_Aktualisieren Unterstützt von .NET Compact Framework | Profilliste des Mitarbeiters aktualisieren
private method ProfilspeichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Profil speichern
private method RB_CheckedChanged Unterstützt von .NET Compact Framework | Handling RB_Changed für den Aufbau der Struktur
private method Refresh_Aktivitaeten Unterstützt von .NET Compact Framework | Aktivitäten aktualisieren
private method Refresh_All Unterstützt von .NET Compact Framework | Treeview Struktur aktualisieren
private method Refresh_Applikationen Unterstützt von .NET Compact Framework | Applikationen aktualisieren
private method Refresh_Details Unterstützt von .NET Compact Framework |
private method Refresh_Dokumente Unterstützt von .NET Compact Framework | Dokumente aktualisieren
private method Refresh_Ereignisse Unterstützt von .NET Compact Framework | Ereignisse aktualisieren
private method Refresh_History Unterstützt von .NET Compact Framework | History aktualisieren
private method Refresh_Kontakte Unterstützt von .NET Compact Framework | Kontakte aktualisieren
private method Refresh_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kündigungsfristen aktualisieren
private method Refresh_Pendenzen Unterstützt von .NET Compact Framework | Pendenzen aktualisieren
private method Refresh_Referenzvertraege Unterstützt von .NET Compact Framework | Referenzverträge aktualisieren
private method Refresh_Register Unterstützt von .NET Compact Framework |
private method Refresh_services Unterstützt von .NET Compact Framework | Services aktualisieren
private method RegisterSpeichernDokumentToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method RegisterSpeichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework |
private method RootTreeNode Unterstützt von .NET Compact Framework | Toplevel-Treenode suchen
private method SpaltendarstellungSichernToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Spaltenlayout C1Vertragselemente speichern
private method TSBrnNeuesProfil_Click Unterstützt von .NET Compact Framework | Neues Profil erstellen
private method TSBtnCopy_Click Unterstützt von .NET Compact Framework | Datensatz kopieren
private method TSBtnDelete_Click Unterstützt von .NET Compact Framework | Aktueller Datensatz inaktivieren
private method TSBtnFilterAufheben_Click Unterstützt von .NET Compact Framework |
private method TSBtnNew_Click Unterstützt von .NET Compact Framework | Neuer Datensatz erstellen
private method TSBtnQuit_Click Unterstützt von .NET Compact Framework | Formular schliessen
private method TSBtnSucheInhalt_Click Unterstützt von .NET Compact Framework |
private method TSBtnSuche_Click Unterstützt von .NET Compact Framework | Vertragspartner suchen
private method TSComboboxProfil_SelectedIndexChanged Unterstützt von .NET Compact Framework | Bestehendes Profl auswählen
private method TStxtSucheInhalt_KeyDown Unterstützt von .NET Compact Framework |
private method TStxtSuche_KeyDown Unterstützt von .NET Compact Framework |
private method TabControlDiverse_SelectedIndexChanged Unterstützt von .NET Compact Framework | Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.
private method TreeStrukturAktualisierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Aktualisierung des aktuellen Knotens
private method TreeStrukturContextMenuStrip_Opening Unterstützt von .NET Compact Framework | TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen
private method TreeStrukturTreeAktualisierenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vollständiger Treeview aktualisieren
private method TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click Unterstützt von .NET Compact Framework | Vertragspartner anzeigen / bearbeiten
private method TreeStruktur_AfterSelect Unterstützt von .NET Compact Framework |
private method TreeStruktur_Click Unterstützt von .NET Compact Framework | Treeview-Click
private method TreeStruktur_MouseDown Unterstützt von .NET Compact Framework | Mousedown-Ereignis auf dem Tree
private method Update_DetailInformationen Unterstützt von .NET Compact Framework | Detail-Informationen der ersten 2 TabPages aktualisieren
private method Update_Details Überladen. Unterstützt von .NET Compact Framework | Detailelemente und die allfällig ausgewählte TabPage aktualisieren
private method Update_Node Unterstützt von .NET Compact Framework |
private method VertragselementAnzeigenBearbeitenToolStripMenuItem_Click Unterstützt von .NET Compact Framework | Vertragselement anzeigen / bearbeiten
private method cbaktiveVertraege_CheckedChanged Unterstützt von .NET Compact Framework |
private method cbaktiveVertraege_CheckedChanged_1 Unterstützt von .NET Compact Framework |
private method cbocInaktiv_CheckedChanged Unterstützt von .NET Compact Framework | Bei Änderung der Inaktiv-Checkbox werden die Hauptstrukturen neu geladen
private method evh_FormularVertragelement_Closed Unterstützt von .NET Compact Framework |
private method evh_FormularVertragspartner_Closed Unterstützt von .NET Compact Framework |
private method frmVertragsuebersicht_Load Unterstützt von .NET Compact Framework | Formular-Load
private method treeStruktur_BeforeExpand Unterstützt von .NET Compact Framework | Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen
private method txtVertragsende_TextChanged Unterstützt von .NET Compact Framework |

Siehe auch

frmVertragsuebersicht -Klasse | MyDocMgmt | MyGenericEventHandler | MyMessage | MySecurity | Tabellenspalte | Treenode_Descriptor | clsProfile | clsVertragselement | clsVertragsuebersicht_Strukturen


frmVertragsuebersicht.AlleKnotenSchliessenToolStripMenuItem_Click -Methode

Alle Knoten im Tree schliessen

[Visual Basic]
Private Sub AlleKnotenSchliessenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AlleKnotenSchliessenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AlleKnotenSchliessenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AlleKnotenSchliessenToolStripMenuItem.Click
        Me.TreeStruktur.CollapseAll()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.AlleKnotenÖffnenToolStripMenuItem_Click -Methode

Alle Knoten im Tree öffnen

[Visual Basic]
Private Sub AlleKnotenÖffnenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   AlleKnotenÖffnenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub AlleKnotenÖffnenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles AlleKnotenÖffnenToolStripMenuItem.Click
        Me.TreeStruktur.ExpandAll()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.BeendenToolStipMenuItem_Click -Methode

Menu Beenden

[Visual Basic]
Private Sub BeendenToolStipMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStipMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStipMenuItem.Click
        Me.TSBtnQuit_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Aktivitaeten_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Aktivitaeten_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Aktivitaeten.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Aktivitaeten_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Aktivitaeten.FetchRowStyle
        Try
            If Me.C1Aktivitaeten.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Applikationen_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Applikationen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Applikationen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Applikationen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Applikationen.FetchRowStyle
        Try
            If Me.C1Applikationen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Dokumente_DoubleClick -Methode

Dokument ab Datenbank anzeigen

[Visual Basic]
Private Sub C1Dokumente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Dokumente.DoubleClick

Parameter

sender
e

Hinweise

Steht der MenuEintrag DokumentAnzeigenToolStripMenuIte nicht zur Verfügung, muss der Doppelclick ignoriert werden

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Dokumente.DoubleClick
        If Me.DokumentAnzeigenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            Me.DokumentAnzeigenToolStripMenuItem_Click(sender, e)
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Dokumente_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Dokumente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Dokumente.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Dokumente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Dokumente.FetchRowStyle
        Try
            If Me.C1Dokumente.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Ereignisse_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Ereignisse_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Ereignisse.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Ereignisse_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Ereignisse.FetchRowStyle
        Try
            If Me.C1Ereignisse.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Kontakte_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Kontakte_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kontakte.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kontakte_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kontakte.FetchRowStyle
        Try
            If Me.C1Kontakte.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Kuendigungsfristen_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Kuendigungsfristen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Kuendigungsfristen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Kuendigungsfristen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Kuendigungsfristen.FetchRowStyle
        Try
            If Me.C1Kuendigungsfristen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Pendenzen_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Pendenzen_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Pendenzen.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Pendenzen_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Pendenzen.FetchRowStyle
        Try
            If Me.C1Pendenzen.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
            If Me.C1Pendenzen.Columns("PendenzStatusNr").CellValue(e.Row) < 3 Then
                If Me.C1Pendenzen.Columns("Termin").Value < Now Then
                    Dim fnt As Font = e.CellStyle.Font
                    e.CellStyle.ForeColor = Color.Red
                End If
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1ReferenzVertraege_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1ReferenzVertraege_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1ReferenzVertraege.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1ReferenzVertraege_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1ReferenzVertraege.FetchRowStyle
        Try
            If Me.C1ReferenzVertraege.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
        'Try
        '    If Me.C1ReferenzVertraege.Columns("Owner").CellValue(e.Row) = 0 Then
        '        e.CellStyle.BackColor = Color.CadetBlue
        '    End If
        'Catch ex As Exception

        'End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Services_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Services_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Services.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Services_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Services.FetchRowStyle
        Try
            If Me.C1Services.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Vertragselemente_DoubleClick -Methode

Doubleklick auf C1Vertragselemente

[Visual Basic]
Private Sub C1Vertragselemente_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   C1Vertragselemente.DoubleClick

Parameter

sender
e

Hinweise

Steht der MenuEintrag VertragselementAnzeigenBearbeitenToolStripMenuItem nicht zur Verfügung, muss der Doppelclick ignoriert werden

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1Vertragselemente.DoubleClick
        If VertragselementAnzeigenBearbeitenToolStripMenuItem.Enabled = False Then
            Exit Sub
        End If
        Try
            Dim f As New frmVertragselement(Me.C1Vertragselemente.Columns("Vertragselementnr").Value, Me.FormReadonly, False)
            f.MdiParent = Me.MdiParent
            f.Show()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Vertragselemente_FetchRowStyle -Methode

Bei inaktiven Einträgen Schrift "grau" setzen und durchstreichen

[Visual Basic]
Private Sub C1Vertragselemente_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As FetchRowStyleEventArgs _
) Handles  _
   C1Vertragselemente.FetchRowStyle

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1Vertragselemente.FetchRowStyle
        Try
            If Me.C1Vertragselemente.Columns("aktiv").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Vertragselemente_FormatText -Methode

Datum Formatieren

[Visual Basic]
Private Sub C1Vertragselemente_FormatText( _
   ByVal sender As Object, _
   ByVal e As FormatTextEventArgs _
) Handles  _
   C1Vertragselemente.FormatText

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_FormatText(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FormatTextEventArgs) Handles C1Vertragselemente.FormatText
        If e.Column.DataType.Name = "DateTime" And e.Value = "01.01.1900 00:00:00" Then e.Value = ""
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.C1Vertragselemente_MouseDown -Methode

Mousedown-Ereignis auf C1Certragselemente, damit die Details aktualisiert werden können

[Visual Basic]
Private Sub C1Vertragselemente_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   C1Vertragselemente.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub C1Vertragselemente_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1Vertragselemente.MouseDown
        Me.C1Vertragselemente.Bookmark = Me.C1Vertragselemente.RowContaining(e.Y)
        Me.C1Vertragselemente.Bookmark = Me.C1Vertragselemente.RowBookmark(Me.C1Vertragselemente.RowContaining(e.Y))
        Update_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.DokumentAnzeigenToolStripMenuItem_Click -Methode

Dokument ab Datenbank anzeigen

[Visual Basic]
Private Sub DokumentAnzeigenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   DokumentAnzeigenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub DokumentAnzeigenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokumentAnzeigenToolStripMenuItem.Click
        Try
            Dim tmpdok As New TKB.VV.DMS.clsDok
            tmpdok.Show_Doc(Me.C1Dokumente.Columns("Dokumentnr").Value)
            tmpdok.Dispose()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.EinzelnerVertragsparterToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub EinzelnerVertragsparterToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   EinzelnerVertragsparterToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub EinzelnerVertragsparterToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles EinzelnerVertragsparterToolStripMenuItem.Click
        Dim t As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Tag
        Dim f As New frmVertragsuebersicht(t.Vertragspartnernr)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.FindNode -Methode

Suchen eines Knoten Treeview

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
Nodes des TreeView
SearchVal
Tag.Keyvalue
SearchString
Node.Text als Suchbegriff

Quellcode

[Visual Basic]
    Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
        Dim tmpNode As TreeNode
        For Each _child As TreeNode In _nodeCollection
            Dim xtag As TKB.VV.Vertrag.Treenode_Descriptor = _child.Tag
            If xtag.Keyvalue = SearchVal And SearchString = _child.Text Then
                Return _child
            End If
            tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
            If Not tmpNode Is Nothing Then
                Return tmpNode
            End If
        Next
        Return Nothing
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.GruppieToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub GruppieToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   GruppieToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub GruppieToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles GruppieToolStripMenuItem.Click
        If Me.C1Vertragselemente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal Then
            Me.C1Vertragselemente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.GroupBy
        Else
            Me.C1Vertragselemente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmVertragsuebersicht))
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSComboBoxProfilMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.ProfilBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ProfilspeichernToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuesProfilToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ProfilLöschenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.TSBtnSave = New System.Windows.Forms.ToolStripButton
        Me.TSBtnCopy = New System.Windows.Forms.ToolStripButton
        Me.TSBtnNew = New System.Windows.Forms.ToolStripButton
        Me.TSBtnDelete = New System.Windows.Forms.ToolStripButton
        Me.ToolStripSeparator1 = New System.Windows.Forms.ToolStripSeparator
        Me.TSlblProfil = New System.Windows.Forms.ToolStripLabel
        Me.TSComboboxProfil = New System.Windows.Forms.ToolStripComboBox
        Me.TSlblSuche = New System.Windows.Forms.ToolStripLabel
        Me.TStxtSuche = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSuche = New System.Windows.Forms.ToolStripButton
        Me.TSlblFilterInhalt = New System.Windows.Forms.ToolStripLabel
        Me.TStxtSucheInhalt = New System.Windows.Forms.ToolStripTextBox
        Me.TSBtnSucheInhalt = New System.Windows.Forms.ToolStripButton
        Me.TSBtnFilterAufheben = New System.Windows.Forms.ToolStripButton
        Me.SplitContainer1 = New System.Windows.Forms.SplitContainer
        Me.TreeStruktur = New System.Windows.Forms.TreeView
        Me.TreeStrukturContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.TreeStrukturAktualisierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripSeparator
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuerVertragspartnerToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem3 = New System.Windows.Forms.ToolStripSeparator
        Me.AlleKnotenSchliessenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.AlleKnotenÖffnenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.EinzelnerVertragsparterToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ImageListTreeImages = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlSort = New System.Windows.Forms.Panel
        Me.cbaktiveVertraege = New System.Windows.Forms.CheckBox
        Me.cbInaktiv = New System.Windows.Forms.CheckBox
        Me.rbSortVertragstyp = New System.Windows.Forms.RadioButton
        Me.rbSortVertragspartner = New System.Windows.Forms.RadioButton
        Me.C1Vertragselemente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DetailContextMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.NeuesVertragselementErstellenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem2 = New System.Windows.Forms.ToolStripSeparator
        Me.GruppieToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabellendarstellungSichernToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabControlDiverse = New Vertragsverwaltung.TKB.VV.Utils.clsMyTabControl
        Me.TabControlDiverseMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.RegisterSpeichernToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabElementDetails = New System.Windows.Forms.TabPage
        Me.txtVertragstyp = New System.Windows.Forms.TextBox
        Me.Label1 = New System.Windows.Forms.Label
        Me.cboxSecurityLevel = New System.Windows.Forms.ComboBox
        Me.lblSecurityLebel = New System.Windows.Forms.Label
        Me.lblAktiv = New System.Windows.Forms.Label
        Me.txtMutierer = New System.Windows.Forms.TextBox
        Me.txtMutiertam = New System.Windows.Forms.TextBox
        Me.txtErstelltam = New System.Windows.Forms.TextBox
        Me.lblMutierer = New System.Windows.Forms.Label
        Me.lblMutiertam = New System.Windows.Forms.Label
        Me.lblErstelltam = New System.Windows.Forms.Label
        Me.cbaktiv = New System.Windows.Forms.CheckBox
        Me.txtUnterzeichnetam = New System.Windows.Forms.MaskedTextBox
        Me.txtMindestvertragsdauerbis = New System.Windows.Forms.MaskedTextBox
        Me.rbUnbefristet = New System.Windows.Forms.RadioButton
        Me.rbbefristet = New System.Windows.Forms.RadioButton
        Me.lblUnterzeichnetam = New System.Windows.Forms.Label
        Me.lblMindesvertragsdauer = New System.Windows.Forms.Label
        Me.txtGekuendigtper = New System.Windows.Forms.MaskedTextBox
        Me.txtGekuendigtam = New System.Windows.Forms.MaskedTextBox
        Me.lblGekuendigtam = New System.Windows.Forms.Label
        Me.txtVertragsende = New System.Windows.Forms.MaskedTextBox
        Me.txtVertragsbegin = New System.Windows.Forms.MaskedTextBox
        Me.lblVertragsbegin = New System.Windows.Forms.Label
        Me.txtVersionsdatum = New System.Windows.Forms.MaskedTextBox
        Me.txtBezeichnung = New System.Windows.Forms.TextBox
        Me.txtVertragsnummer = New System.Windows.Forms.TextBox
        Me.lblVertragsnummer = New System.Windows.Forms.Label
        Me.txtVersion = New System.Windows.Forms.TextBox
        Me.lblVersion = New System.Windows.Forms.Label
        Me.lblBezeichnung = New System.Windows.Forms.Label
        Me.TabBeschreibung = New System.Windows.Forms.TabPage
        Me.SplitContainer2 = New System.Windows.Forms.SplitContainer
        Me.txtBeschreibung = New System.Windows.Forms.RichTextBox
        Me.pnlBeschreibung = New System.Windows.Forms.Panel
        Me.lblBeschreibung = New System.Windows.Forms.Label
        Me.txtSuchbegriffe = New System.Windows.Forms.RichTextBox
        Me.pnlSuchbegriffe = New System.Windows.Forms.Panel
        Me.lblSuchbegriffe = New System.Windows.Forms.Label
        Me.TabKuendigungsfristen = New System.Windows.Forms.TabPage
        Me.C1Kuendigungsfristen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabDokumente = New System.Windows.Forms.TabPage
        Me.C1Dokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.DokumenteMenuStrip = New System.Windows.Forms.ContextMenuStrip(Me.components)
        Me.DokumentAnzeigenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.RegisterSpeichernDokumentToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.TabKontakte = New System.Windows.Forms.TabPage
        Me.C1Kontakte = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabEreignisse = New System.Windows.Forms.TabPage
        Me.C1Ereignisse = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabAktivität = New System.Windows.Forms.TabPage
        Me.C1Aktivitaeten = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabPendenzen = New System.Windows.Forms.TabPage
        Me.C1Pendenzen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabReferenzVertraege = New System.Windows.Forms.TabPage
        Me.C1ReferenzVertraege = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabServices = New System.Windows.Forms.TabPage
        Me.C1Services = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabHistory = New System.Windows.Forms.TabPage
        Me.C1History = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.TabApplikationen = New System.Windows.Forms.TabPage
        Me.C1Applikationen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid
        Me.ImageListeReferenzVertrasege = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageListeDocIcon = New System.Windows.Forms.ImageList(Me.components)
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.TSComboBoxProfilMenuStrip.SuspendLayout()
        Me.SplitContainer1.Panel1.SuspendLayout()
        Me.SplitContainer1.Panel2.SuspendLayout()
        Me.SplitContainer1.SuspendLayout()
        Me.TreeStrukturContextMenuStrip.SuspendLayout()
        Me.pnlSort.SuspendLayout()
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DetailContextMenuStrip.SuspendLayout()
        Me.TabControlDiverse.SuspendLayout()
        Me.TabControlDiverseMenuStrip.SuspendLayout()
        Me.TabElementDetails.SuspendLayout()
        Me.TabBeschreibung.SuspendLayout()
        Me.SplitContainer2.Panel1.SuspendLayout()
        Me.SplitContainer2.Panel2.SuspendLayout()
        Me.SplitContainer2.SuspendLayout()
        Me.pnlBeschreibung.SuspendLayout()
        Me.pnlSuchbegriffe.SuspendLayout()
        Me.TabKuendigungsfristen.SuspendLayout()
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabDokumente.SuspendLayout()
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.DokumenteMenuStrip.SuspendLayout()
        Me.TabKontakte.SuspendLayout()
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabEreignisse.SuspendLayout()
        CType(Me.C1Ereignisse, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabAktivität.SuspendLayout()
        CType(Me.C1Aktivitaeten, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPendenzen.SuspendLayout()
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabReferenzVertraege.SuspendLayout()
        CType(Me.C1ReferenzVertraege, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabServices.SuspendLayout()
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabHistory.SuspendLayout()
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabApplikationen.SuspendLayout()
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(1074, 24)
        Me.MenuStrip1.TabIndex = 5
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStipMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(46, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStipMenuItem
        '
        Me.BeendenToolStipMenuItem.Name = "BeendenToolStipMenuItem"
        Me.BeendenToolStipMenuItem.Size = New System.Drawing.Size(120, 22)
        Me.BeendenToolStipMenuItem.Tag = ""
        Me.BeendenToolStipMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.ContextMenuStrip = Me.TSComboBoxProfilMenuStrip
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit, Me.TSBtnSave, Me.TSBtnCopy, Me.TSBtnNew, Me.TSBtnDelete, Me.ToolStripSeparator1, Me.TSlblProfil, Me.TSComboboxProfil, Me.TSlblSuche, Me.TStxtSuche, Me.TSBtnSuche, Me.TSlblFilterInhalt, Me.TStxtSucheInhalt, Me.TSBtnSucheInhalt, Me.TSBtnFilterAufheben})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(1074, 25)
        Me.ToolStrip1.TabIndex = 6
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSComboBoxProfilMenuStrip
        '
        Me.TSComboBoxProfilMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ProfilBearbeitenToolStripMenuItem, Me.ProfilspeichernToolStripMenuItem, Me.NeuesProfilToolStripMenuItem, Me.ProfilLöschenToolStripMenuItem})
        Me.TSComboBoxProfilMenuStrip.Name = "TSComboBoxProfilMenuStrip"
        Me.TSComboBoxProfilMenuStrip.Size = New System.Drawing.Size(162, 92)
        '
        'ProfilBearbeitenToolStripMenuItem
        '
        Me.ProfilBearbeitenToolStripMenuItem.Name = "ProfilBearbeitenToolStripMenuItem"
        Me.ProfilBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(161, 22)
        Me.ProfilBearbeitenToolStripMenuItem.Text = "Profil bearbeiten"
        '
        'ProfilspeichernToolStripMenuItem
        '
        Me.ProfilspeichernToolStripMenuItem.Name = "ProfilspeichernToolStripMenuItem"
        Me.ProfilspeichernToolStripMenuItem.Size = New System.Drawing.Size(161, 22)
        Me.ProfilspeichernToolStripMenuItem.Text = "Profil &speichern"
        '
        'NeuesProfilToolStripMenuItem
        '
        Me.NeuesProfilToolStripMenuItem.Name = "NeuesProfilToolStripMenuItem"
        Me.NeuesProfilToolStripMenuItem.Size = New System.Drawing.Size(161, 22)
        Me.NeuesProfilToolStripMenuItem.Text = "&Neues Profil"
        '
        'ProfilLöschenToolStripMenuItem
        '
        Me.ProfilLöschenToolStripMenuItem.Name = "ProfilLöschenToolStripMenuItem"
        Me.ProfilLöschenToolStripMenuItem.Size = New System.Drawing.Size(161, 22)
        Me.ProfilLöschenToolStripMenuItem.Text = "Profil &Löschen"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'TSBtnSave
        '
        Me.TSBtnSave.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSave.Image = CType(resources.GetObject("TSBtnSave.Image"), System.Drawing.Image)
        Me.TSBtnSave.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSave.Name = "TSBtnSave"
        Me.TSBtnSave.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSave.Text = "Daten speichern"
        Me.TSBtnSave.ToolTipText = "Daten speichern"
        Me.TSBtnSave.Visible = False
        '
        'TSBtnCopy
        '
        Me.TSBtnCopy.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnCopy.Image = CType(resources.GetObject("TSBtnCopy.Image"), System.Drawing.Image)
        Me.TSBtnCopy.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnCopy.Name = "TSBtnCopy"
        Me.TSBtnCopy.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnCopy.Text = "Datensatz kopieren"
        Me.TSBtnCopy.ToolTipText = "Datensatz kopieren"
        Me.TSBtnCopy.Visible = False
        '
        'TSBtnNew
        '
        Me.TSBtnNew.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnNew.Image = CType(resources.GetObject("TSBtnNew.Image"), System.Drawing.Image)
        Me.TSBtnNew.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnNew.Name = "TSBtnNew"
        Me.TSBtnNew.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnNew.Text = "Neuer Datensatz"
        Me.TSBtnNew.ToolTipText = "Neuer Datensatz"
        Me.TSBtnNew.Visible = False
        '
        'TSBtnDelete
        '
        Me.TSBtnDelete.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnDelete.Image = CType(resources.GetObject("TSBtnDelete.Image"), System.Drawing.Image)
        Me.TSBtnDelete.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnDelete.Name = "TSBtnDelete"
        Me.TSBtnDelete.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnDelete.Text = "Datensatz inaktivieren"
        Me.TSBtnDelete.ToolTipText = "Datensatz inaktivieren"
        Me.TSBtnDelete.Visible = False
        '
        'ToolStripSeparator1
        '
        Me.ToolStripSeparator1.Name = "ToolStripSeparator1"
        Me.ToolStripSeparator1.Size = New System.Drawing.Size(6, 25)
        '
        'TSlblProfil
        '
        Me.TSlblProfil.Name = "TSlblProfil"
        Me.TSlblProfil.Size = New System.Drawing.Size(38, 22)
        Me.TSlblProfil.Text = "Profil:"
        '
        'TSComboboxProfil
        '
        Me.TSComboboxProfil.Font = New System.Drawing.Font("Tahoma", 8.25!)
        Me.TSComboboxProfil.Name = "TSComboboxProfil"
        Me.TSComboboxProfil.Size = New System.Drawing.Size(121, 25)
        '
        'TSlblSuche
        '
        Me.TSlblSuche.Name = "TSlblSuche"
        Me.TSlblSuche.Size = New System.Drawing.Size(120, 22)
        Me.TSlblSuche.Text = "Filter Vertragspartner:"
        '
        'TStxtSuche
        '
        Me.TStxtSuche.Font = New System.Drawing.Font("Tahoma", 8.25!)
        Me.TStxtSuche.Name = "TStxtSuche"
        Me.TStxtSuche.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSuche
        '
        Me.TSBtnSuche.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSuche.Image = CType(resources.GetObject("TSBtnSuche.Image"), System.Drawing.Image)
        Me.TSBtnSuche.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSuche.Name = "TSBtnSuche"
        Me.TSBtnSuche.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSuche.Text = "Suche nach Vertragspartner"
        '
        'TSlblFilterInhalt
        '
        Me.TSlblFilterInhalt.Name = "TSlblFilterInhalt"
        Me.TSlblFilterInhalt.Size = New System.Drawing.Size(69, 22)
        Me.TSlblFilterInhalt.Text = "Filter Inhalt:"
        '
        'TStxtSucheInhalt
        '
        Me.TStxtSucheInhalt.Font = New System.Drawing.Font("Tahoma", 8.25!)
        Me.TStxtSucheInhalt.Name = "TStxtSucheInhalt"
        Me.TStxtSucheInhalt.Size = New System.Drawing.Size(100, 25)
        '
        'TSBtnSucheInhalt
        '
        Me.TSBtnSucheInhalt.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnSucheInhalt.Image = CType(resources.GetObject("TSBtnSucheInhalt.Image"), System.Drawing.Image)
        Me.TSBtnSucheInhalt.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnSucheInhalt.Name = "TSBtnSucheInhalt"
        Me.TSBtnSucheInhalt.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnSucheInhalt.Text = "Suche nach Vertragselement"
        '
        'TSBtnFilterAufheben
        '
        Me.TSBtnFilterAufheben.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnFilterAufheben.Image = CType(resources.GetObject("TSBtnFilterAufheben.Image"), System.Drawing.Image)
        Me.TSBtnFilterAufheben.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnFilterAufheben.Name = "TSBtnFilterAufheben"
        Me.TSBtnFilterAufheben.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnFilterAufheben.Text = "Filter aufheben"
        '
        'SplitContainer1
        '
        Me.SplitContainer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer1.Location = New System.Drawing.Point(0, 49)
        Me.SplitContainer1.Name = "SplitContainer1"
        '
        'SplitContainer1.Panel1
        '
        Me.SplitContainer1.Panel1.Controls.Add(Me.TreeStruktur)
        Me.SplitContainer1.Panel1.Controls.Add(Me.pnlSort)
        '
        'SplitContainer1.Panel2
        '
        Me.SplitContainer1.Panel2.Controls.Add(Me.C1Vertragselemente)
        Me.SplitContainer1.Panel2.Controls.Add(Me.TabControlDiverse)
        Me.SplitContainer1.Size = New System.Drawing.Size(1074, 489)
        Me.SplitContainer1.SplitterDistance = 341
        Me.SplitContainer1.TabIndex = 7
        '
        'TreeStruktur
        '
        Me.TreeStruktur.ContextMenuStrip = Me.TreeStrukturContextMenuStrip
        Me.TreeStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeStruktur.FullRowSelect = True
        Me.TreeStruktur.HideSelection = False
        Me.TreeStruktur.HotTracking = True
        Me.TreeStruktur.ImageIndex = 0
        Me.TreeStruktur.ImageList = Me.ImageListTreeImages
        Me.TreeStruktur.Location = New System.Drawing.Point(0, 39)
        Me.TreeStruktur.Name = "TreeStruktur"
        Me.TreeStruktur.SelectedImageIndex = 0
        Me.TreeStruktur.Size = New System.Drawing.Size(341, 450)
        Me.TreeStruktur.TabIndex = 2
        '
        'TreeStrukturContextMenuStrip
        '
        Me.TreeStrukturContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TreeStrukturAktualisierenToolStripMenuItem, Me.TreeStrukturTreeAktualisierenToolStripMenuItem, Me.ToolStripMenuItem1, Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem, Me.NeuerVertragspartnerToolStripMenuItem, Me.ToolStripMenuItem3, Me.AlleKnotenSchliessenToolStripMenuItem, Me.AlleKnotenÖffnenToolStripMenuItem, Me.EinzelnerVertragsparterToolStripMenuItem})
        Me.TreeStrukturContextMenuStrip.Name = "TreeStrukturContextMenuStrip"
        Me.TreeStrukturContextMenuStrip.Size = New System.Drawing.Size(273, 170)
        '
        'TreeStrukturAktualisierenToolStripMenuItem
        '
        Me.TreeStrukturAktualisierenToolStripMenuItem.Name = "TreeStrukturAktualisierenToolStripMenuItem"
        Me.TreeStrukturAktualisierenToolStripMenuItem.ShortcutKeys = System.Windows.Forms.Keys.F5
        Me.TreeStrukturAktualisierenToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.TreeStrukturAktualisierenToolStripMenuItem.Text = "&Aktueller Knoten aktualisieren"
        '
        'TreeStrukturTreeAktualisierenToolStripMenuItem
        '
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Name = "TreeStrukturTreeAktualisierenToolStripMenuItem"
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.ShortcutKeys = CType((System.Windows.Forms.Keys.Control Or System.Windows.Forms.Keys.F5), System.Windows.Forms.Keys)
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.TreeStrukturTreeAktualisierenToolStripMenuItem.Text = "Alles Aktualisieren"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(269, 6)
        '
        'TreeStrukturVertragspartnerAnzeigenToolStipMenuItem
        '
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Name = "TreeStrukturVertragspartnerAnzeigenToolStipMenuItem"
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Text = "Vertragspartner anzeigen / bearbeiten"
        '
        'NeuerVertragspartnerToolStripMenuItem
        '
        Me.NeuerVertragspartnerToolStripMenuItem.Name = "NeuerVertragspartnerToolStripMenuItem"
        Me.NeuerVertragspartnerToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.NeuerVertragspartnerToolStripMenuItem.Text = "&Neuer Vertragspartner"
        '
        'ToolStripMenuItem3
        '
        Me.ToolStripMenuItem3.Name = "ToolStripMenuItem3"
        Me.ToolStripMenuItem3.Size = New System.Drawing.Size(269, 6)
        '
        'AlleKnotenSchliessenToolStripMenuItem
        '
        Me.AlleKnotenSchliessenToolStripMenuItem.Name = "AlleKnotenSchliessenToolStripMenuItem"
        Me.AlleKnotenSchliessenToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.AlleKnotenSchliessenToolStripMenuItem.Text = "Alle Knoten schliessen"
        '
        'AlleKnotenÖffnenToolStripMenuItem
        '
        Me.AlleKnotenÖffnenToolStripMenuItem.Name = "AlleKnotenÖffnenToolStripMenuItem"
        Me.AlleKnotenÖffnenToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.AlleKnotenÖffnenToolStripMenuItem.Text = "Alle Knoten öffnen"
        Me.AlleKnotenÖffnenToolStripMenuItem.Visible = False
        '
        'EinzelnerVertragsparterToolStripMenuItem
        '
        Me.EinzelnerVertragsparterToolStripMenuItem.Name = "EinzelnerVertragsparterToolStripMenuItem"
        Me.EinzelnerVertragsparterToolStripMenuItem.Size = New System.Drawing.Size(272, 22)
        Me.EinzelnerVertragsparterToolStripMenuItem.Text = "Einzelner Vertragsparter anzeigen"
        '
        'ImageListTreeImages
        '
        Me.ImageListTreeImages.ImageStream = CType(resources.GetObject("ImageListTreeImages.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListTreeImages.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListTreeImages.Images.SetKeyName(0, "Personen.ico")
        Me.ImageListTreeImages.Images.SetKeyName(1, "Carisblok1.ico")
        Me.ImageListTreeImages.Images.SetKeyName(2, "Carisblok3.ico")
        Me.ImageListTreeImages.Images.SetKeyName(3, "book02.gif")
        Me.ImageListTreeImages.Images.SetKeyName(4, "DOC.BMP")
        Me.ImageListTreeImages.Images.SetKeyName(5, "Folder.ico")
        Me.ImageListTreeImages.Images.SetKeyName(6, "Personen_Inaktiv.ico")
        Me.ImageListTreeImages.Images.SetKeyName(7, "Carisblok1_Deleted.ico")
        Me.ImageListTreeImages.Images.SetKeyName(8, "Carisblok3_Deleted.ico")
        Me.ImageListTreeImages.Images.SetKeyName(9, "Carisblok_FS.ico")
        Me.ImageListTreeImages.Images.SetKeyName(10, "Carisblok3_Deleted_FS.ico")
        '
        'pnlSort
        '
        Me.pnlSort.Controls.Add(Me.cbaktiveVertraege)
        Me.pnlSort.Controls.Add(Me.cbInaktiv)
        Me.pnlSort.Controls.Add(Me.rbSortVertragstyp)
        Me.pnlSort.Controls.Add(Me.rbSortVertragspartner)
        Me.pnlSort.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlSort.Location = New System.Drawing.Point(0, 0)
        Me.pnlSort.Name = "pnlSort"
        Me.pnlSort.Size = New System.Drawing.Size(341, 39)
        Me.pnlSort.TabIndex = 1
        '
        'cbaktiveVertraege
        '
        Me.cbaktiveVertraege.AutoSize = True
        Me.cbaktiveVertraege.Location = New System.Drawing.Point(3, 22)
        Me.cbaktiveVertraege.Name = "cbaktiveVertraege"
        Me.cbaktiveVertraege.Size = New System.Drawing.Size(176, 17)
        Me.cbaktiveVertraege.TabIndex = 5
        Me.cbaktiveVertraege.Text = "Vertragselemente (aktiv/inaktiv)"
        Me.cbaktiveVertraege.ThreeState = True
        Me.cbaktiveVertraege.UseVisualStyleBackColor = True
        '
        'cbInaktiv
        '
        Me.cbInaktiv.AutoSize = True
        Me.cbInaktiv.Location = New System.Drawing.Point(3, 4)
        Me.cbInaktiv.Name = "cbInaktiv"
        Me.cbInaktiv.Size = New System.Drawing.Size(110, 17)
        Me.cbInaktiv.TabIndex = 4
        Me.cbInaktiv.Text = "nur aktive Partner"
        Me.cbInaktiv.UseVisualStyleBackColor = True
        '
        'rbSortVertragstyp
        '
        Me.rbSortVertragstyp.AutoSize = True
        Me.rbSortVertragstyp.Location = New System.Drawing.Point(3, 17)
        Me.rbSortVertragstyp.Name = "rbSortVertragstyp"
        Me.rbSortVertragstyp.Size = New System.Drawing.Size(156, 17)
        Me.rbSortVertragstyp.TabIndex = 3
        Me.rbSortVertragstyp.Text = "Sortierung nach Vertragstyp"
        Me.rbSortVertragstyp.UseVisualStyleBackColor = True
        Me.rbSortVertragstyp.Visible = False
        '
        'rbSortVertragspartner
        '
        Me.rbSortVertragspartner.AutoSize = True
        Me.rbSortVertragspartner.Checked = True
        Me.rbSortVertragspartner.Location = New System.Drawing.Point(3, 3)
        Me.rbSortVertragspartner.Name = "rbSortVertragspartner"
        Me.rbSortVertragspartner.Size = New System.Drawing.Size(175, 17)
        Me.rbSortVertragspartner.TabIndex = 2
        Me.rbSortVertragspartner.TabStop = True
        Me.rbSortVertragspartner.Text = "Sortierung nach Vertragspartner"
        Me.rbSortVertragspartner.UseVisualStyleBackColor = True
        Me.rbSortVertragspartner.Visible = False
        '
        'C1Vertragselemente
        '
        Me.C1Vertragselemente.AlternatingRows = True
        Me.C1Vertragselemente.ContextMenuStrip = Me.DetailContextMenuStrip
        Me.C1Vertragselemente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Vertragselemente.FetchRowStyles = True
        Me.C1Vertragselemente.FilterBar = True
        Me.C1Vertragselemente.GroupByCaption = "Um eine Gruppierung herzustellen, den Spaltentitel in den Gruppierungsbereich zie" & _
            "hen"
        Me.C1Vertragselemente.Images.Add(CType(resources.GetObject("C1Vertragselemente.Images"), System.Drawing.Image))
        Me.C1Vertragselemente.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.Name = "C1Vertragselemente"
        Me.C1Vertragselemente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Vertragselemente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Vertragselemente.PreviewInfo.ZoomFactor = 75
        Me.C1Vertragselemente.PrintInfo.PageSettings = CType(resources.GetObject("C1Vertragselemente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Vertragselemente.RecordSelectorWidth = 16
        Me.C1Vertragselemente.Size = New System.Drawing.Size(729, 246)
        Me.C1Vertragselemente.TabIndex = 3
        Me.C1Vertragselemente.Text = "C1TrueDBGrid1"
        Me.C1Vertragselemente.PropBag = resources.GetString("C1Vertragselemente.PropBag")
        '
        'DetailContextMenuStrip
        '
        Me.DetailContextMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.VertragselementAnzeigenBearbeitenToolStripMenuItem, Me.NeuesVertragselementErstellenToolStripMenuItem, Me.ToolStripMenuItem2, Me.GruppieToolStripMenuItem, Me.TabellendarstellungSichernToolStripMenuItem})
        Me.DetailContextMenuStrip.Name = "DetailContextMenuStrip"
        Me.DetailContextMenuStrip.Size = New System.Drawing.Size(278, 98)
        '
        'VertragselementAnzeigenBearbeitenToolStripMenuItem
        '
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Name = "VertragselementAnzeigenBearbeitenToolStripMenuItem"
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Size = New System.Drawing.Size(277, 22)
        Me.VertragselementAnzeigenBearbeitenToolStripMenuItem.Text = "Vertragselement anzeigen / bearbeiten"
        '
        'NeuesVertragselementErstellenToolStripMenuItem
        '
        Me.NeuesVertragselementErstellenToolStripMenuItem.Name = "NeuesVertragselementErstellenToolStripMenuItem"
        Me.NeuesVertragselementErstellenToolStripMenuItem.Size = New System.Drawing.Size(277, 22)
        Me.NeuesVertragselementErstellenToolStripMenuItem.Text = "Neues Vertragselement erstellen"
        '
        'ToolStripMenuItem2
        '
        Me.ToolStripMenuItem2.Name = "ToolStripMenuItem2"
        Me.ToolStripMenuItem2.Size = New System.Drawing.Size(274, 6)
        '
        'GruppieToolStripMenuItem
        '
        Me.GruppieToolStripMenuItem.Name = "GruppieToolStripMenuItem"
        Me.GruppieToolStripMenuItem.Size = New System.Drawing.Size(277, 22)
        Me.GruppieToolStripMenuItem.Text = "&Gruppierung anzeigen / ausblenden"
        '
        'TabellendarstellungSichernToolStripMenuItem
        '
        Me.TabellendarstellungSichernToolStripMenuItem.Name = "TabellendarstellungSichernToolStripMenuItem"
        Me.TabellendarstellungSichernToolStripMenuItem.Size = New System.Drawing.Size(277, 22)
        Me.TabellendarstellungSichernToolStripMenuItem.Text = "Tabellendarstellung sichern"
        '
        'TabControlDiverse
        '
        Me.TabControlDiverse.ContextMenuStrip = Me.TabControlDiverseMenuStrip
        Me.TabControlDiverse.Controls.Add(Me.TabElementDetails)
        Me.TabControlDiverse.Controls.Add(Me.TabBeschreibung)
        Me.TabControlDiverse.Controls.Add(Me.TabKuendigungsfristen)
        Me.TabControlDiverse.Controls.Add(Me.TabDokumente)
        Me.TabControlDiverse.Controls.Add(Me.TabKontakte)
        Me.TabControlDiverse.Controls.Add(Me.TabEreignisse)
        Me.TabControlDiverse.Controls.Add(Me.TabAktivität)
        Me.TabControlDiverse.Controls.Add(Me.TabPendenzen)
        Me.TabControlDiverse.Controls.Add(Me.TabReferenzVertraege)
        Me.TabControlDiverse.Controls.Add(Me.TabServices)
        Me.TabControlDiverse.Controls.Add(Me.TabHistory)
        Me.TabControlDiverse.Controls.Add(Me.TabApplikationen)
        Me.TabControlDiverse.Cursor = System.Windows.Forms.Cursors.Default
        Me.TabControlDiverse.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TabControlDiverse.Location = New System.Drawing.Point(0, 246)
        Me.TabControlDiverse.Name = "TabControlDiverse"
        Me.TabControlDiverse.SelectedIndex = 0
        Me.TabControlDiverse.Size = New System.Drawing.Size(729, 243)
        Me.TabControlDiverse.TabIndex = 0
        '
        'TabControlDiverseMenuStrip
        '
        Me.TabControlDiverseMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.RegisterSpeichernToolStripMenuItem})
        Me.TabControlDiverseMenuStrip.Name = "TabControlDiverseMenuStrip"
        Me.TabControlDiverseMenuStrip.Size = New System.Drawing.Size(171, 26)
        '
        'RegisterSpeichernToolStripMenuItem
        '
        Me.RegisterSpeichernToolStripMenuItem.Name = "RegisterSpeichernToolStripMenuItem"
        Me.RegisterSpeichernToolStripMenuItem.Size = New System.Drawing.Size(170, 22)
        Me.RegisterSpeichernToolStripMenuItem.Text = "&Register speichern"
        '
        'TabElementDetails
        '
        Me.TabElementDetails.Controls.Add(Me.txtVertragstyp)
        Me.TabElementDetails.Controls.Add(Me.Label1)
        Me.TabElementDetails.Controls.Add(Me.cboxSecurityLevel)
        Me.TabElementDetails.Controls.Add(Me.lblSecurityLebel)
        Me.TabElementDetails.Controls.Add(Me.lblAktiv)
        Me.TabElementDetails.Controls.Add(Me.txtMutierer)
        Me.TabElementDetails.Controls.Add(Me.txtMutiertam)
        Me.TabElementDetails.Controls.Add(Me.txtErstelltam)
        Me.TabElementDetails.Controls.Add(Me.lblMutierer)
        Me.TabElementDetails.Controls.Add(Me.lblMutiertam)
        Me.TabElementDetails.Controls.Add(Me.lblErstelltam)
        Me.TabElementDetails.Controls.Add(Me.cbaktiv)
        Me.TabElementDetails.Controls.Add(Me.txtUnterzeichnetam)
        Me.TabElementDetails.Controls.Add(Me.txtMindestvertragsdauerbis)
        Me.TabElementDetails.Controls.Add(Me.rbUnbefristet)
        Me.TabElementDetails.Controls.Add(Me.rbbefristet)
        Me.TabElementDetails.Controls.Add(Me.lblUnterzeichnetam)
        Me.TabElementDetails.Controls.Add(Me.lblMindesvertragsdauer)
        Me.TabElementDetails.Controls.Add(Me.txtGekuendigtper)
        Me.TabElementDetails.Controls.Add(Me.txtGekuendigtam)
        Me.TabElementDetails.Controls.Add(Me.lblGekuendigtam)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsende)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsbegin)
        Me.TabElementDetails.Controls.Add(Me.lblVertragsbegin)
        Me.TabElementDetails.Controls.Add(Me.txtVersionsdatum)
        Me.TabElementDetails.Controls.Add(Me.txtBezeichnung)
        Me.TabElementDetails.Controls.Add(Me.txtVertragsnummer)
        Me.TabElementDetails.Controls.Add(Me.lblVertragsnummer)
        Me.TabElementDetails.Controls.Add(Me.txtVersion)
        Me.TabElementDetails.Controls.Add(Me.lblVersion)
        Me.TabElementDetails.Controls.Add(Me.lblBezeichnung)
        Me.TabElementDetails.Location = New System.Drawing.Point(4, 22)
        Me.TabElementDetails.Name = "TabElementDetails"
        Me.TabElementDetails.Padding = New System.Windows.Forms.Padding(3)
        Me.TabElementDetails.Size = New System.Drawing.Size(721, 217)
        Me.TabElementDetails.TabIndex = 0
        Me.TabElementDetails.Text = "Details"
        Me.TabElementDetails.UseVisualStyleBackColor = True
        '
        'txtVertragstyp
        '
        Me.txtVertragstyp.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragstyp.ForeColor = System.Drawing.Color.Black
        Me.txtVertragstyp.Location = New System.Drawing.Point(137, 9)
        Me.txtVertragstyp.Name = "txtVertragstyp"
        Me.txtVertragstyp.ReadOnly = True
        Me.txtVertragstyp.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragstyp.TabIndex = 115
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(6, 9)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(60, 13)
        Me.Label1.TabIndex = 116
        Me.Label1.Text = "Vertragstyp"
        '
        'cboxSecurityLevel
        '
        Me.cboxSecurityLevel.Enabled = False
        Me.cboxSecurityLevel.FormattingEnabled = True
        Me.cboxSecurityLevel.Location = New System.Drawing.Point(499, 113)
        Me.cboxSecurityLevel.Name = "cboxSecurityLevel"
        Me.cboxSecurityLevel.Size = New System.Drawing.Size(101, 21)
        Me.cboxSecurityLevel.TabIndex = 106
        '
        'lblSecurityLebel
        '
        Me.lblSecurityLebel.AutoSize = True
        Me.lblSecurityLebel.Location = New System.Drawing.Point(422, 116)
        Me.lblSecurityLebel.Name = "lblSecurityLebel"
        Me.lblSecurityLebel.Size = New System.Drawing.Size(71, 13)
        Me.lblSecurityLebel.TabIndex = 114
        Me.lblSecurityLebel.Text = "SecurityLevel"
        '
        'lblAktiv
        '
        Me.lblAktiv.AccessibleDescription = "Name"
        Me.lblAktiv.AutoSize = True
        Me.lblAktiv.Location = New System.Drawing.Point(422, 87)
        Me.lblAktiv.Name = "lblAktiv"
        Me.lblAktiv.Size = New System.Drawing.Size(31, 13)
        Me.lblAktiv.TabIndex = 113
        Me.lblAktiv.Text = "Aktiv"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtMutierer.ForeColor = System.Drawing.Color.Black
        Me.txtMutierer.Location = New System.Drawing.Point(500, 56)
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(194, 20)
        Me.txtMutierer.TabIndex = 112
        '
        'txtMutiertam
        '
        Me.txtMutiertam.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtMutiertam.ForeColor = System.Drawing.Color.Black
        Me.txtMutiertam.Location = New System.Drawing.Point(499, 33)
        Me.txtMutiertam.Name = "txtMutiertam"
        Me.txtMutiertam.ReadOnly = True
        Me.txtMutiertam.Size = New System.Drawing.Size(195, 20)
        Me.txtMutiertam.TabIndex = 111
        '
        'txtErstelltam
        '
        Me.txtErstelltam.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtErstelltam.ForeColor = System.Drawing.Color.Black
        Me.txtErstelltam.Location = New System.Drawing.Point(499, 9)
        Me.txtErstelltam.Name = "txtErstelltam"
        Me.txtErstelltam.ReadOnly = True
        Me.txtErstelltam.Size = New System.Drawing.Size(195, 20)
        Me.txtErstelltam.TabIndex = 110
        '
        'lblMutierer
        '
        Me.lblMutierer.AccessibleDescription = "Name"
        Me.lblMutierer.AutoSize = True
        Me.lblMutierer.Location = New System.Drawing.Point(421, 60)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(69, 13)
        Me.lblMutierer.TabIndex = 109
        Me.lblMutierer.Text = "Mutiert durch"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.AccessibleDescription = "Name"
        Me.lblMutiertam.AutoSize = True
        Me.lblMutiertam.Location = New System.Drawing.Point(421, 37)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(56, 13)
        Me.lblMutiertam.TabIndex = 108
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'lblErstelltam
        '
        Me.lblErstelltam.AccessibleDescription = "Name"
        Me.lblErstelltam.AutoSize = True
        Me.lblErstelltam.Location = New System.Drawing.Point(422, 12)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(55, 13)
        Me.lblErstelltam.TabIndex = 107
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'cbaktiv
        '
        Me.cbaktiv.AutoSize = True
        Me.cbaktiv.Enabled = False
        Me.cbaktiv.Location = New System.Drawing.Point(499, 87)
        Me.cbaktiv.Name = "cbaktiv"
        Me.cbaktiv.Size = New System.Drawing.Size(15, 14)
        Me.cbaktiv.TabIndex = 105
        Me.cbaktiv.UseVisualStyleBackColor = True
        '
        'txtUnterzeichnetam
        '
        Me.txtUnterzeichnetam.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtUnterzeichnetam.ForeColor = System.Drawing.Color.Black
        Me.txtUnterzeichnetam.Location = New System.Drawing.Point(137, 189)
        Me.txtUnterzeichnetam.Mask = "00/00/0000"
        Me.txtUnterzeichnetam.Name = "txtUnterzeichnetam"
        Me.txtUnterzeichnetam.ReadOnly = True
        Me.txtUnterzeichnetam.Size = New System.Drawing.Size(66, 20)
        Me.txtUnterzeichnetam.TabIndex = 100
        Me.txtUnterzeichnetam.ValidatingType = GetType(Date)
        '
        'txtMindestvertragsdauerbis
        '
        Me.txtMindestvertragsdauerbis.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtMindestvertragsdauerbis.ForeColor = System.Drawing.Color.Black
        Me.txtMindestvertragsdauerbis.Location = New System.Drawing.Point(137, 167)
        Me.txtMindestvertragsdauerbis.Mask = "00/00/0000"
        Me.txtMindestvertragsdauerbis.Name = "txtMindestvertragsdauerbis"
        Me.txtMindestvertragsdauerbis.ReadOnly = True
        Me.txtMindestvertragsdauerbis.Size = New System.Drawing.Size(66, 20)
        Me.txtMindestvertragsdauerbis.TabIndex = 99
        Me.txtMindestvertragsdauerbis.ValidatingType = GetType(Date)
        '
        'rbUnbefristet
        '
        Me.rbUnbefristet.AutoSize = True
        Me.rbUnbefristet.Enabled = False
        Me.rbUnbefristet.Location = New System.Drawing.Point(212, 194)
        Me.rbUnbefristet.Name = "rbUnbefristet"
        Me.rbUnbefristet.Size = New System.Drawing.Size(76, 17)
        Me.rbUnbefristet.TabIndex = 102
        Me.rbUnbefristet.TabStop = True
        Me.rbUnbefristet.Text = "Unbefristet"
        Me.rbUnbefristet.UseVisualStyleBackColor = True
        '
        'rbbefristet
        '
        Me.rbbefristet.AutoSize = True
        Me.rbbefristet.Enabled = False
        Me.rbbefristet.Location = New System.Drawing.Point(212, 168)
        Me.rbbefristet.Name = "rbbefristet"
        Me.rbbefristet.Size = New System.Drawing.Size(63, 17)
        Me.rbbefristet.TabIndex = 101
        Me.rbbefristet.TabStop = True
        Me.rbbefristet.Text = "Befristet"
        Me.rbbefristet.UseVisualStyleBackColor = True
        '
        'lblUnterzeichnetam
        '
        Me.lblUnterzeichnetam.AutoSize = True
        Me.lblUnterzeichnetam.Location = New System.Drawing.Point(6, 192)
        Me.lblUnterzeichnetam.Name = "lblUnterzeichnetam"
        Me.lblUnterzeichnetam.Size = New System.Drawing.Size(90, 13)
        Me.lblUnterzeichnetam.TabIndex = 104
        Me.lblUnterzeichnetam.Text = "Unterzeichnet am"
        '
        'lblMindesvertragsdauer
        '
        Me.lblMindesvertragsdauer.AutoSize = True
        Me.lblMindesvertragsdauer.Location = New System.Drawing.Point(6, 170)
        Me.lblMindesvertragsdauer.Name = "lblMindesvertragsdauer"
        Me.lblMindesvertragsdauer.Size = New System.Drawing.Size(125, 13)
        Me.lblMindesvertragsdauer.TabIndex = 103
        Me.lblMindesvertragsdauer.Text = "Mindestvertragsdauer bis"
        '
        'txtGekuendigtper
        '
        Me.txtGekuendigtper.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtGekuendigtper.ForeColor = System.Drawing.Color.Black
        Me.txtGekuendigtper.Location = New System.Drawing.Point(209, 141)
        Me.txtGekuendigtper.Mask = "00/00/0000"
        Me.txtGekuendigtper.Name = "txtGekuendigtper"
        Me.txtGekuendigtper.ReadOnly = True
        Me.txtGekuendigtper.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtper.TabIndex = 97
        Me.txtGekuendigtper.ValidatingType = GetType(Date)
        '
        'txtGekuendigtam
        '
        Me.txtGekuendigtam.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtGekuendigtam.ForeColor = System.Drawing.Color.Black
        Me.txtGekuendigtam.Location = New System.Drawing.Point(137, 141)
        Me.txtGekuendigtam.Mask = "00/00/0000"
        Me.txtGekuendigtam.Name = "txtGekuendigtam"
        Me.txtGekuendigtam.ReadOnly = True
        Me.txtGekuendigtam.Size = New System.Drawing.Size(66, 20)
        Me.txtGekuendigtam.TabIndex = 96
        Me.txtGekuendigtam.ValidatingType = GetType(Date)
        '
        'lblGekuendigtam
        '
        Me.lblGekuendigtam.AutoSize = True
        Me.lblGekuendigtam.Location = New System.Drawing.Point(6, 141)
        Me.lblGekuendigtam.Name = "lblGekuendigtam"
        Me.lblGekuendigtam.Size = New System.Drawing.Size(99, 13)
        Me.lblGekuendigtam.TabIndex = 98
        Me.lblGekuendigtam.Text = "Gekündigt am / per"
        '
        'txtVertragsende
        '
        Me.txtVertragsende.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragsende.ForeColor = System.Drawing.Color.Black
        Me.txtVertragsende.Location = New System.Drawing.Point(209, 115)
        Me.txtVertragsende.Mask = "00/00/0000"
        Me.txtVertragsende.Name = "txtVertragsende"
        Me.txtVertragsende.ReadOnly = True
        Me.txtVertragsende.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsende.TabIndex = 94
        Me.txtVertragsende.ValidatingType = GetType(Date)
        '
        'txtVertragsbegin
        '
        Me.txtVertragsbegin.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragsbegin.ForeColor = System.Drawing.Color.Black
        Me.txtVertragsbegin.Location = New System.Drawing.Point(137, 115)
        Me.txtVertragsbegin.Mask = "00/00/0000"
        Me.txtVertragsbegin.Name = "txtVertragsbegin"
        Me.txtVertragsbegin.ReadOnly = True
        Me.txtVertragsbegin.Size = New System.Drawing.Size(66, 20)
        Me.txtVertragsbegin.TabIndex = 93
        Me.txtVertragsbegin.ValidatingType = GetType(Date)
        '
        'lblVertragsbegin
        '
        Me.lblVertragsbegin.AutoSize = True
        Me.lblVertragsbegin.Location = New System.Drawing.Point(6, 118)
        Me.lblVertragsbegin.Name = "lblVertragsbegin"
        Me.lblVertragsbegin.Size = New System.Drawing.Size(104, 13)
        Me.lblVertragsbegin.TabIndex = 95
        Me.lblVertragsbegin.Text = "Vertragsbegin/-ende"
        '
        'txtVersionsdatum
        '
        Me.txtVersionsdatum.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVersionsdatum.ForeColor = System.Drawing.Color.Black
        Me.txtVersionsdatum.Location = New System.Drawing.Point(209, 87)
        Me.txtVersionsdatum.Mask = "00/00/0000"
        Me.txtVersionsdatum.Name = "txtVersionsdatum"
        Me.txtVersionsdatum.ReadOnly = True
        Me.txtVersionsdatum.Size = New System.Drawing.Size(66, 20)
        Me.txtVersionsdatum.TabIndex = 87
        Me.txtVersionsdatum.ValidatingType = GetType(Date)
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtBezeichnung.ForeColor = System.Drawing.Color.Black
        Me.txtBezeichnung.Location = New System.Drawing.Point(137, 34)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(268, 20)
        Me.txtBezeichnung.TabIndex = 84
        '
        'txtVertragsnummer
        '
        Me.txtVertragsnummer.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVertragsnummer.ForeColor = System.Drawing.Color.Black
        Me.txtVertragsnummer.Location = New System.Drawing.Point(137, 61)
        Me.txtVertragsnummer.Name = "txtVertragsnummer"
        Me.txtVertragsnummer.ReadOnly = True
        Me.txtVertragsnummer.Size = New System.Drawing.Size(268, 20)
        Me.txtVertragsnummer.TabIndex = 85
        '
        'lblVertragsnummer
        '
        Me.lblVertragsnummer.AutoSize = True
        Me.lblVertragsnummer.Location = New System.Drawing.Point(6, 61)
        Me.lblVertragsnummer.Name = "lblVertragsnummer"
        Me.lblVertragsnummer.Size = New System.Drawing.Size(83, 13)
        Me.lblVertragsnummer.TabIndex = 92
        Me.lblVertragsnummer.Text = "Vertragsnummer"
        '
        'txtVersion
        '
        Me.txtVersion.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtVersion.ForeColor = System.Drawing.Color.Black
        Me.txtVersion.Location = New System.Drawing.Point(137, 87)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.ReadOnly = True
        Me.txtVersion.Size = New System.Drawing.Size(66, 20)
        Me.txtVersion.TabIndex = 86
        '
        'lblVersion
        '
        Me.lblVersion.AutoSize = True
        Me.lblVersion.Location = New System.Drawing.Point(6, 87)
        Me.lblVersion.Name = "lblVersion"
        Me.lblVersion.Size = New System.Drawing.Size(116, 13)
        Me.lblVersion.TabIndex = 91
        Me.lblVersion.Text = "Version/Versionsdatum"
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.AutoSize = True
        Me.lblBezeichnung.Location = New System.Drawing.Point(6, 34)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(69, 13)
        Me.lblBezeichnung.TabIndex = 90
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'TabBeschreibung
        '
        Me.TabBeschreibung.Controls.Add(Me.SplitContainer2)
        Me.TabBeschreibung.Location = New System.Drawing.Point(4, 22)
        Me.TabBeschreibung.Name = "TabBeschreibung"
        Me.TabBeschreibung.Padding = New System.Windows.Forms.Padding(3)
        Me.TabBeschreibung.Size = New System.Drawing.Size(721, 217)
        Me.TabBeschreibung.TabIndex = 1
        Me.TabBeschreibung.Text = "Beschreibung"
        Me.TabBeschreibung.UseVisualStyleBackColor = True
        '
        'SplitContainer2
        '
        Me.SplitContainer2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.SplitContainer2.Location = New System.Drawing.Point(3, 3)
        Me.SplitContainer2.Name = "SplitContainer2"
        '
        'SplitContainer2.Panel1
        '
        Me.SplitContainer2.Panel1.Controls.Add(Me.txtBeschreibung)
        Me.SplitContainer2.Panel1.Controls.Add(Me.pnlBeschreibung)
        '
        'SplitContainer2.Panel2
        '
        Me.SplitContainer2.Panel2.Controls.Add(Me.txtSuchbegriffe)
        Me.SplitContainer2.Panel2.Controls.Add(Me.pnlSuchbegriffe)
        Me.SplitContainer2.Size = New System.Drawing.Size(715, 211)
        Me.SplitContainer2.SplitterDistance = 347
        Me.SplitContainer2.TabIndex = 0
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtBeschreibung.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtBeschreibung.ForeColor = System.Drawing.Color.Black
        Me.txtBeschreibung.Location = New System.Drawing.Point(0, 22)
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.ReadOnly = True
        Me.txtBeschreibung.Size = New System.Drawing.Size(347, 189)
        Me.txtBeschreibung.TabIndex = 30
        Me.txtBeschreibung.Text = ""
        '
        'pnlBeschreibung
        '
        Me.pnlBeschreibung.Controls.Add(Me.lblBeschreibung)
        Me.pnlBeschreibung.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlBeschreibung.Location = New System.Drawing.Point(0, 0)
        Me.pnlBeschreibung.Name = "pnlBeschreibung"
        Me.pnlBeschreibung.Size = New System.Drawing.Size(347, 22)
        Me.pnlBeschreibung.TabIndex = 0
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.AutoSize = True
        Me.lblBeschreibung.Location = New System.Drawing.Point(5, 4)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(72, 13)
        Me.lblBeschreibung.TabIndex = 0
        Me.lblBeschreibung.Text = "Beschreibung"
        '
        'txtSuchbegriffe
        '
        Me.txtSuchbegriffe.BackColor = System.Drawing.Color.FromArgb(CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer), CType(CType(224, Byte), Integer))
        Me.txtSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtSuchbegriffe.ForeColor = System.Drawing.Color.Black
        Me.txtSuchbegriffe.Location = New System.Drawing.Point(0, 22)
        Me.txtSuchbegriffe.Name = "txtSuchbegriffe"
        Me.txtSuchbegriffe.ReadOnly = True
        Me.txtSuchbegriffe.Size = New System.Drawing.Size(364, 189)
        Me.txtSuchbegriffe.TabIndex = 31
        Me.txtSuchbegriffe.Text = ""
        '
        'pnlSuchbegriffe
        '
        Me.pnlSuchbegriffe.Controls.Add(Me.lblSuchbegriffe)
        Me.pnlSuchbegriffe.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlSuchbegriffe.Location = New System.Drawing.Point(0, 0)
        Me.pnlSuchbegriffe.Name = "pnlSuchbegriffe"
        Me.pnlSuchbegriffe.Size = New System.Drawing.Size(364, 22)
        Me.pnlSuchbegriffe.TabIndex = 1
        '
        'lblSuchbegriffe
        '
        Me.lblSuchbegriffe.AutoSize = True
        Me.lblSuchbegriffe.Location = New System.Drawing.Point(4, 5)
        Me.lblSuchbegriffe.Name = "lblSuchbegriffe"
        Me.lblSuchbegriffe.Size = New System.Drawing.Size(67, 13)
        Me.lblSuchbegriffe.TabIndex = 1
        Me.lblSuchbegriffe.Text = "Suchbegriffe"
        '
        'TabKuendigungsfristen
        '
        Me.TabKuendigungsfristen.Controls.Add(Me.C1Kuendigungsfristen)
        Me.TabKuendigungsfristen.Location = New System.Drawing.Point(4, 22)
        Me.TabKuendigungsfristen.Name = "TabKuendigungsfristen"
        Me.TabKuendigungsfristen.Size = New System.Drawing.Size(721, 217)
        Me.TabKuendigungsfristen.TabIndex = 2
        Me.TabKuendigungsfristen.Text = "Kündigungsfristen"
        Me.TabKuendigungsfristen.UseVisualStyleBackColor = True
        '
        'C1Kuendigungsfristen
        '
        Me.C1Kuendigungsfristen.AlternatingRows = True
        Me.C1Kuendigungsfristen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kuendigungsfristen.FetchRowStyles = True
        Me.C1Kuendigungsfristen.FilterBar = True
        Me.C1Kuendigungsfristen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kuendigungsfristen.Images.Add(CType(resources.GetObject("C1Kuendigungsfristen.Images"), System.Drawing.Image))
        Me.C1Kuendigungsfristen.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.Name = "C1Kuendigungsfristen"
        Me.C1Kuendigungsfristen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kuendigungsfristen.PreviewInfo.ZoomFactor = 75
        Me.C1Kuendigungsfristen.PrintInfo.PageSettings = CType(resources.GetObject("C1Kuendigungsfristen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kuendigungsfristen.RecordSelectorWidth = 16
        Me.C1Kuendigungsfristen.Size = New System.Drawing.Size(721, 217)
        Me.C1Kuendigungsfristen.TabIndex = 2
        Me.C1Kuendigungsfristen.Text = "C1TrueDBGrid1"
        Me.C1Kuendigungsfristen.PropBag = resources.GetString("C1Kuendigungsfristen.PropBag")
        '
        'TabDokumente
        '
        Me.TabDokumente.Controls.Add(Me.C1Dokumente)
        Me.TabDokumente.Location = New System.Drawing.Point(4, 22)
        Me.TabDokumente.Name = "TabDokumente"
        Me.TabDokumente.Size = New System.Drawing.Size(721, 217)
        Me.TabDokumente.TabIndex = 4
        Me.TabDokumente.Text = "Dokumente"
        Me.TabDokumente.UseVisualStyleBackColor = True
        '
        'C1Dokumente
        '
        Me.C1Dokumente.AlternatingRows = True
        Me.C1Dokumente.ContextMenuStrip = Me.DokumenteMenuStrip
        Me.C1Dokumente.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Dokumente.FetchRowStyles = True
        Me.C1Dokumente.FilterBar = True
        Me.C1Dokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Dokumente.Images.Add(CType(resources.GetObject("C1Dokumente.Images"), System.Drawing.Image))
        Me.C1Dokumente.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.Name = "C1Dokumente"
        Me.C1Dokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Dokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Dokumente.PreviewInfo.ZoomFactor = 75
        Me.C1Dokumente.PrintInfo.PageSettings = CType(resources.GetObject("C1Dokumente.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Dokumente.RecordSelectorWidth = 16
        Me.C1Dokumente.Size = New System.Drawing.Size(721, 217)
        Me.C1Dokumente.TabIndex = 2
        Me.C1Dokumente.Text = "C1TrueDBGrid1"
        Me.C1Dokumente.PropBag = resources.GetString("C1Dokumente.PropBag")
        '
        'DokumenteMenuStrip
        '
        Me.DokumenteMenuStrip.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DokumentAnzeigenToolStripMenuItem, Me.RegisterSpeichernDokumentToolStripMenuItem})
        Me.DokumenteMenuStrip.Name = "DokumenteMenuStrip"
        Me.DokumenteMenuStrip.Size = New System.Drawing.Size(181, 48)
        '
        'DokumentAnzeigenToolStripMenuItem
        '
        Me.DokumentAnzeigenToolStripMenuItem.Name = "DokumentAnzeigenToolStripMenuItem"
        Me.DokumentAnzeigenToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.DokumentAnzeigenToolStripMenuItem.Text = "&Dokument anzeigen"
        '
        'RegisterSpeichernDokumentToolStripMenuItem
        '
        Me.RegisterSpeichernDokumentToolStripMenuItem.Name = "RegisterSpeichernDokumentToolStripMenuItem"
        Me.RegisterSpeichernDokumentToolStripMenuItem.Size = New System.Drawing.Size(180, 22)
        Me.RegisterSpeichernDokumentToolStripMenuItem.Text = "Register speichern"
        '
        'TabKontakte
        '
        Me.TabKontakte.Controls.Add(Me.C1Kontakte)
        Me.TabKontakte.Location = New System.Drawing.Point(4, 22)
        Me.TabKontakte.Name = "TabKontakte"
        Me.TabKontakte.Size = New System.Drawing.Size(721, 217)
        Me.TabKontakte.TabIndex = 3
        Me.TabKontakte.Text = "Kontakte"
        Me.TabKontakte.UseVisualStyleBackColor = True
        '
        'C1Kontakte
        '
        Me.C1Kontakte.AlternatingRows = True
        Me.C1Kontakte.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Kontakte.FetchRowStyles = True
        Me.C1Kontakte.FilterBar = True
        Me.C1Kontakte.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Kontakte.Images.Add(CType(resources.GetObject("C1Kontakte.Images"), System.Drawing.Image))
        Me.C1Kontakte.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.Name = "C1Kontakte"
        Me.C1Kontakte.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Kontakte.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Kontakte.PreviewInfo.ZoomFactor = 75
        Me.C1Kontakte.PrintInfo.PageSettings = CType(resources.GetObject("C1Kontakte.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Kontakte.RecordSelectorWidth = 16
        Me.C1Kontakte.Size = New System.Drawing.Size(721, 217)
        Me.C1Kontakte.TabIndex = 2
        Me.C1Kontakte.Text = "C1TrueDBGrid1"
        Me.C1Kontakte.PropBag = resources.GetString("C1Kontakte.PropBag")
        '
        'TabEreignisse
        '
        Me.TabEreignisse.Controls.Add(Me.C1Ereignisse)
        Me.TabEreignisse.Location = New System.Drawing.Point(4, 22)
        Me.TabEreignisse.Name = "TabEreignisse"
        Me.TabEreignisse.Size = New System.Drawing.Size(721, 217)
        Me.TabEreignisse.TabIndex = 5
        Me.TabEreignisse.Text = "Ereignisse"
        Me.TabEreignisse.UseVisualStyleBackColor = True
        '
        'C1Ereignisse
        '
        Me.C1Ereignisse.AlternatingRows = True
        Me.C1Ereignisse.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Ereignisse.FetchRowStyles = True
        Me.C1Ereignisse.FilterBar = True
        Me.C1Ereignisse.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Ereignisse.Images.Add(CType(resources.GetObject("C1Ereignisse.Images"), System.Drawing.Image))
        Me.C1Ereignisse.Location = New System.Drawing.Point(0, 0)
        Me.C1Ereignisse.Name = "C1Ereignisse"
        Me.C1Ereignisse.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Ereignisse.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Ereignisse.PreviewInfo.ZoomFactor = 75
        Me.C1Ereignisse.PrintInfo.PageSettings = CType(resources.GetObject("C1Ereignisse.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Ereignisse.RecordSelectorWidth = 16
        Me.C1Ereignisse.Size = New System.Drawing.Size(721, 217)
        Me.C1Ereignisse.TabIndex = 1
        Me.C1Ereignisse.Text = "C1TrueDBGrid1"
        Me.C1Ereignisse.PropBag = resources.GetString("C1Ereignisse.PropBag")
        '
        'TabAktivität
        '
        Me.TabAktivität.Controls.Add(Me.C1Aktivitaeten)
        Me.TabAktivität.Location = New System.Drawing.Point(4, 22)
        Me.TabAktivität.Name = "TabAktivität"
        Me.TabAktivität.Size = New System.Drawing.Size(721, 217)
        Me.TabAktivität.TabIndex = 11
        Me.TabAktivität.Text = "Aktivitäten"
        Me.TabAktivität.UseVisualStyleBackColor = True
        '
        'C1Aktivitaeten
        '
        Me.C1Aktivitaeten.AlternatingRows = True
        Me.C1Aktivitaeten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Aktivitaeten.FetchRowStyles = True
        Me.C1Aktivitaeten.FilterBar = True
        Me.C1Aktivitaeten.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Aktivitaeten.Images.Add(CType(resources.GetObject("C1Aktivitaeten.Images"), System.Drawing.Image))
        Me.C1Aktivitaeten.Location = New System.Drawing.Point(0, 0)
        Me.C1Aktivitaeten.Name = "C1Aktivitaeten"
        Me.C1Aktivitaeten.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Aktivitaeten.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Aktivitaeten.PreviewInfo.ZoomFactor = 75
        Me.C1Aktivitaeten.PrintInfo.PageSettings = CType(resources.GetObject("C1Aktivitaeten.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Aktivitaeten.RecordSelectorWidth = 16
        Me.C1Aktivitaeten.Size = New System.Drawing.Size(721, 217)
        Me.C1Aktivitaeten.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1Aktivitaeten.TabIndex = 12
        Me.C1Aktivitaeten.Text = "C1TrueDBGrid1"
        Me.C1Aktivitaeten.PropBag = resources.GetString("C1Aktivitaeten.PropBag")
        '
        'TabPendenzen
        '
        Me.TabPendenzen.Controls.Add(Me.C1Pendenzen)
        Me.TabPendenzen.Location = New System.Drawing.Point(4, 22)
        Me.TabPendenzen.Name = "TabPendenzen"
        Me.TabPendenzen.Size = New System.Drawing.Size(721, 217)
        Me.TabPendenzen.TabIndex = 6
        Me.TabPendenzen.Text = "Pendenzen"
        Me.TabPendenzen.UseVisualStyleBackColor = True
        '
        'C1Pendenzen
        '
        Me.C1Pendenzen.AlternatingRows = True
        Me.C1Pendenzen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Pendenzen.FetchRowStyles = True
        Me.C1Pendenzen.FilterBar = True
        Me.C1Pendenzen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Pendenzen.Images.Add(CType(resources.GetObject("C1Pendenzen.Images"), System.Drawing.Image))
        Me.C1Pendenzen.Location = New System.Drawing.Point(0, 0)
        Me.C1Pendenzen.Name = "C1Pendenzen"
        Me.C1Pendenzen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Pendenzen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Pendenzen.PreviewInfo.ZoomFactor = 75
        Me.C1Pendenzen.PrintInfo.PageSettings = CType(resources.GetObject("C1Pendenzen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Pendenzen.RecordSelectorWidth = 16
        Me.C1Pendenzen.Size = New System.Drawing.Size(721, 217)
        Me.C1Pendenzen.TabIndex = 2
        Me.C1Pendenzen.Text = "C1TrueDBGrid1"
        Me.C1Pendenzen.PropBag = resources.GetString("C1Pendenzen.PropBag")
        '
        'TabReferenzVertraege
        '
        Me.TabReferenzVertraege.Controls.Add(Me.C1ReferenzVertraege)
        Me.TabReferenzVertraege.Location = New System.Drawing.Point(4, 22)
        Me.TabReferenzVertraege.Name = "TabReferenzVertraege"
        Me.TabReferenzVertraege.Size = New System.Drawing.Size(721, 217)
        Me.TabReferenzVertraege.TabIndex = 7
        Me.TabReferenzVertraege.Text = "Referenzverträge"
        Me.TabReferenzVertraege.UseVisualStyleBackColor = True
        '
        'C1ReferenzVertraege
        '
        Me.C1ReferenzVertraege.AlternatingRows = True
        Me.C1ReferenzVertraege.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1ReferenzVertraege.FetchRowStyles = True
        Me.C1ReferenzVertraege.FilterBar = True
        Me.C1ReferenzVertraege.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1ReferenzVertraege.Images.Add(CType(resources.GetObject("C1ReferenzVertraege.Images"), System.Drawing.Image))
        Me.C1ReferenzVertraege.Location = New System.Drawing.Point(0, 0)
        Me.C1ReferenzVertraege.Name = "C1ReferenzVertraege"
        Me.C1ReferenzVertraege.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1ReferenzVertraege.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1ReferenzVertraege.PreviewInfo.ZoomFactor = 75
        Me.C1ReferenzVertraege.PrintInfo.PageSettings = CType(resources.GetObject("C1ReferenzVertraege.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1ReferenzVertraege.RecordSelectorWidth = 16
        Me.C1ReferenzVertraege.Size = New System.Drawing.Size(721, 217)
        Me.C1ReferenzVertraege.TabIndex = 3
        Me.C1ReferenzVertraege.Text = "C1TrueDBGrid1"
        Me.C1ReferenzVertraege.PropBag = resources.GetString("C1ReferenzVertraege.PropBag")
        '
        'TabServices
        '
        Me.TabServices.Controls.Add(Me.C1Services)
        Me.TabServices.Location = New System.Drawing.Point(4, 22)
        Me.TabServices.Name = "TabServices"
        Me.TabServices.Size = New System.Drawing.Size(721, 217)
        Me.TabServices.TabIndex = 8
        Me.TabServices.Text = "Services"
        Me.TabServices.UseVisualStyleBackColor = True
        '
        'C1Services
        '
        Me.C1Services.AlternatingRows = True
        Me.C1Services.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Services.FetchRowStyles = True
        Me.C1Services.FilterBar = True
        Me.C1Services.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Services.Images.Add(CType(resources.GetObject("C1Services.Images"), System.Drawing.Image))
        Me.C1Services.Location = New System.Drawing.Point(0, 0)
        Me.C1Services.Name = "C1Services"
        Me.C1Services.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Services.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Services.PreviewInfo.ZoomFactor = 75
        Me.C1Services.PrintInfo.PageSettings = CType(resources.GetObject("C1Services.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Services.RecordSelectorWidth = 16
        Me.C1Services.Size = New System.Drawing.Size(721, 217)
        Me.C1Services.TabIndex = 4
        Me.C1Services.Text = "C1TrueDBGrid1"
        Me.C1Services.PropBag = resources.GetString("C1Services.PropBag")
        '
        'TabHistory
        '
        Me.TabHistory.Controls.Add(Me.C1History)
        Me.TabHistory.Location = New System.Drawing.Point(4, 22)
        Me.TabHistory.Name = "TabHistory"
        Me.TabHistory.Size = New System.Drawing.Size(721, 217)
        Me.TabHistory.TabIndex = 9
        Me.TabHistory.Text = "History"
        Me.TabHistory.UseVisualStyleBackColor = True
        '
        'C1History
        '
        Me.C1History.AlternatingRows = True
        Me.C1History.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1History.FetchRowStyles = True
        Me.C1History.FilterBar = True
        Me.C1History.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1History.Images.Add(CType(resources.GetObject("C1History.Images"), System.Drawing.Image))
        Me.C1History.Location = New System.Drawing.Point(0, 0)
        Me.C1History.Name = "C1History"
        Me.C1History.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1History.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1History.PreviewInfo.ZoomFactor = 75
        Me.C1History.PrintInfo.PageSettings = CType(resources.GetObject("C1History.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1History.RecordSelectorWidth = 16
        Me.C1History.Size = New System.Drawing.Size(721, 217)
        Me.C1History.TabIndex = 5
        Me.C1History.Text = "C1TrueDBGrid1"
        Me.C1History.PropBag = resources.GetString("C1History.PropBag")
        '
        'TabApplikationen
        '
        Me.TabApplikationen.Controls.Add(Me.C1Applikationen)
        Me.TabApplikationen.Location = New System.Drawing.Point(4, 22)
        Me.TabApplikationen.Name = "TabApplikationen"
        Me.TabApplikationen.Size = New System.Drawing.Size(721, 217)
        Me.TabApplikationen.TabIndex = 10
        Me.TabApplikationen.Text = "Applikationen"
        Me.TabApplikationen.UseVisualStyleBackColor = True
        '
        'C1Applikationen
        '
        Me.C1Applikationen.AlternatingRows = True
        Me.C1Applikationen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1Applikationen.FetchRowStyles = True
        Me.C1Applikationen.FilterBar = True
        Me.C1Applikationen.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1Applikationen.Images.Add(CType(resources.GetObject("C1Applikationen.Images"), System.Drawing.Image))
        Me.C1Applikationen.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.Name = "C1Applikationen"
        Me.C1Applikationen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1Applikationen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1Applikationen.PreviewInfo.ZoomFactor = 75
        Me.C1Applikationen.PrintInfo.PageSettings = CType(resources.GetObject("C1Applikationen.PrintInfo.PageSettings"), System.Drawing.Printing.PageSettings)
        Me.C1Applikationen.RecordSelectorWidth = 16
        Me.C1Applikationen.Size = New System.Drawing.Size(721, 217)
        Me.C1Applikationen.TabIndex = 3
        Me.C1Applikationen.Text = "C1Applikationen"
        Me.C1Applikationen.PropBag = resources.GetString("C1Applikationen.PropBag")
        '
        'ImageListeReferenzVertrasege
        '
        Me.ImageListeReferenzVertrasege.ImageStream = CType(resources.GetObject("ImageListeReferenzVertrasege.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeReferenzVertrasege.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(0, "2ARROW4.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(1, "2ARROW3.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(2, "HANDAR4.GIF")
        Me.ImageListeReferenzVertrasege.Images.SetKeyName(3, "HANDAR3.GIF")
        '
        'ImageListeDocIcon
        '
        Me.ImageListeDocIcon.ImageStream = CType(resources.GetObject("ImageListeDocIcon.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageListeDocIcon.TransparentColor = System.Drawing.Color.Transparent
        Me.ImageListeDocIcon.Images.SetKeyName(0, "PDF.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(1, "Word5.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(2, "Excel1.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(3, "PowerPoint.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(4, "html.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(5, "Mail.ico")
        Me.ImageListeDocIcon.Images.SetKeyName(6, "Document1.ico")
        '
        'frmVertragsuebersicht
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(1074, 538)
        Me.Controls.Add(Me.SplitContainer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVertragsuebersicht"
        Me.Text = "Vertragsübersicht"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.TSComboBoxProfilMenuStrip.ResumeLayout(False)
        Me.SplitContainer1.Panel1.ResumeLayout(False)
        Me.SplitContainer1.Panel2.ResumeLayout(False)
        Me.SplitContainer1.ResumeLayout(False)
        Me.TreeStrukturContextMenuStrip.ResumeLayout(False)
        Me.pnlSort.ResumeLayout(False)
        Me.pnlSort.PerformLayout()
        CType(Me.C1Vertragselemente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DetailContextMenuStrip.ResumeLayout(False)
        Me.TabControlDiverse.ResumeLayout(False)
        Me.TabControlDiverseMenuStrip.ResumeLayout(False)
        Me.TabElementDetails.ResumeLayout(False)
        Me.TabElementDetails.PerformLayout()
        Me.TabBeschreibung.ResumeLayout(False)
        Me.SplitContainer2.Panel1.ResumeLayout(False)
        Me.SplitContainer2.Panel2.ResumeLayout(False)
        Me.SplitContainer2.ResumeLayout(False)
        Me.pnlBeschreibung.ResumeLayout(False)
        Me.pnlBeschreibung.PerformLayout()
        Me.pnlSuchbegriffe.ResumeLayout(False)
        Me.pnlSuchbegriffe.PerformLayout()
        Me.TabKuendigungsfristen.ResumeLayout(False)
        CType(Me.C1Kuendigungsfristen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabDokumente.ResumeLayout(False)
        CType(Me.C1Dokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.DokumenteMenuStrip.ResumeLayout(False)
        Me.TabKontakte.ResumeLayout(False)
        CType(Me.C1Kontakte, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabEreignisse.ResumeLayout(False)
        CType(Me.C1Ereignisse, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabAktivität.ResumeLayout(False)
        CType(Me.C1Aktivitaeten, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPendenzen.ResumeLayout(False)
        CType(Me.C1Pendenzen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabReferenzVertraege.ResumeLayout(False)
        CType(Me.C1ReferenzVertraege, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabServices.ResumeLayout(False)
        CType(Me.C1Services, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabHistory.ResumeLayout(False)
        CType(Me.C1History, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabApplikationen.ResumeLayout(False)
        CType(Me.C1Applikationen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Load_Securitylevel -Methode

Laden der Securitylevel-Daten in die Combobox

[Visual Basic]
Private Sub Load_Securitylevel()

Quellcode

[Visual Basic]
    Private Sub Load_Securitylevel()
        Dim seclevel As New TKB.VV.DB.clsSecurityLevel
        Dim secleveldata As New DataTable

        seclevel.cpMainConnectionProvider = Globals.conn
        Globals.conn.OpenConnection()
        secleveldata = seclevel.SelectAll
        Globals.conn.CloseConnection(True)

        Me.cboxSecurityLevel.DataSource = secleveldata
        Me.cboxSecurityLevel.DisplayMember = "Bezeichnung"
        Me.cboxSecurityLevel.ValueMember = "SecurityLevelNr"

        seclevel.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Load_Struktur -Methode

Laden der Treestruktur

[Visual Basic]
Private Sub Load_Struktur( _
   Optional ByVal Partnernr As Integer = 0 _
)

Parameter

Partnernr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
    Private Sub Load_Struktur(Optional ByVal Partnernr As Integer = 0)
        Me.Cursor = Cursors.WaitCursor
        If Me.rbSortVertragspartner.Checked = True Then
            If Me.TStxtSuche.Text <> "" Then
                Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, 1, Me.TStxtSuche.Text, Partnernr)
            Else
                If Me.TStxtSucheInhalt.Text <> "" Then
                    Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, 2, Me.TStxtSucheInhalt.Text, Partnernr)
                Else
                    Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, , , Partnernr)
                End If
            End If
        End If
        If Me.rbSortVertragstyp.Checked = True Then
            Strukturen.Get_Struktur(Me.TreeStruktur, 1, Me.cbInaktiv.Checked, , , Partnernr)
        End If
        Try
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
        Catch
        End Try
        Me.Cursor = Cursors.Default
        'Me.Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.NeuerVertragspartnerToolStripMenuItem_Click -Methode

Neuer Vertragspartner eröffnen

[Visual Basic]
Private Sub NeuerVertragspartnerToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuerVertragspartnerToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuerVertragspartnerToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuerVertragspartnerToolStripMenuItem.Click
        Dim f As New frmVertragspartner(0, Me.FormReadonly, True)
        f.ShowDialog()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.NeuesProfilToolStripMenuItem_Click -Methode

Neues Profil erstellen

[Visual Basic]
Private Sub NeuesProfilToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuesProfilToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub NeuesProfilToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuesProfilToolStripMenuItem.Click
        Dim a As String = InputBox(msg.Get_Meldungstext(503))
        If a <> "" Then
            If UCase(a) = "STANDARD" Then
                msg.show_standardmessage(504, MsgBoxStyle.Information)
                Exit Sub
            End If
            Me.Profil.Set_Aktuelles_Profil(Me.Profil.Add_New(a))
            Me.ProfilspeichernToolStripMenuItem_Click(sender, e)
            Me.Profile_Aktualisieren(a)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.NeuesVertragselementErstellenToolStripMenuItem_Click -Methode

Neues Vertragselement laden

[Visual Basic]
Private Sub NeuesVertragselementErstellenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   NeuesVertragselementErstellenToolStripMenuItem.Click

Parameter

sender
e

Hinweise

Sind keine Elemente in der Vertragselement-Liste, Vertragspartner über Struktureintrag auslesen. Geht dies aufgrund der Datenkonstellation nicht, Vertragspartner 0 übergaben, damit ein Partner ausgesucht werden muss

Quellcode

[Visual Basic]
    Private Sub NeuesVertragselementErstellenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles NeuesVertragselementErstellenToolStripMenuItem.Click
        Try
            If Me.C1Vertragselemente.Splits(0).Rows.Count = 0 Then
                Dim x As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Tag
                Dim f As New frmVertragselement(-1, False, True, x.Vertragspartnernr)
                f.MdiParent = Me.MdiParent
                f.Show()
            Else
                Dim f As New frmVertragselement(-1, False, True, Me.C1Vertragselemente.Columns("Vertragspartnernr").Value)
                f.MdiParent = Me.MdiParent
                f.Show()
            End If
        Catch ex As Exception
            Dim f As New frmVertragselement(-1, False, True, 0)
            f.MdiParent = Me.MdiParent
            f.Show()
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Order_Tabcontrol -Methode

Reihenfolge der Register im Tabcontrol anpassen

[Visual Basic]
Private Sub Order_Tabcontrol()

Quellcode

[Visual Basic]
    Private Sub Order_Tabcontrol()
        Try
            If Me.Profil.sV_Register.Value = "" Then Exit Sub
            Dim tabs() As String
            Dim i As Integer = 0
            tabs = Me.Profil.sV_Register.Value.Split(";")
            For Each tb As String In tabs
                If tb = "" Then Exit For
                For Each tbp As TabPage In Me.TabControlDiverse.TabPages
                    If tbp.Text = tb Then
                        Try
                            Me.TabControlDiverse.TabPages.Remove(tbp)
                        Catch
                        End Try
                        Try
                            Me.TabControlDiverse.TabPages.Insert(i, tbp)
                        Catch
                        End Try
                        i = i + 1
                    End If
                Next
            Next
        Catch
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.ProfilBearbeitenToolStripMenuItem_Click -Methode

Profil Editieren

[Visual Basic]
Private Sub ProfilBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ProfilBearbeitenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ProfilBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ProfilBearbeitenToolStripMenuItem.Click
        Dim f As New frmProfilVerwaltung(Me.C1Vertragselemente, Me.Profil.iProfilnr.Value, Me.TabControlDiverse)
        f.ShowDialog()
        Me.Profile_Aktualisieren(f.txtBezeichnung.Text)
        Me.Profil.Get_Profil(Me.Profil.iProfilnr.Value)
        Me.Order_Tabcontrol()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.ProfilLöschenToolStripMenuItem_Click -Methode

Profil löschen

[Visual Basic]
Private Sub ProfilLöschenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ProfilLöschenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ProfilLöschenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ProfilLöschenToolStripMenuItem.Click
        If msg.Show_MessageYesNo(500) = MsgBoxResult.Yes Then
            Me.Profil.Delete_Profil(Me.Profil.iProfilnr.Value)
            Profile_Aktualisieren()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Profile_Aktualisieren -Methode

Profilliste des Mitarbeiters aktualisieren

[Visual Basic]
Private Sub Profile_Aktualisieren( _
   Optional ByVal Aktuelles_Profil As String = "" _
)

Parameter

Aktuelles_Profil
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
    Private Sub Profile_Aktualisieren(Optional ByVal Aktuelles_Profil As String = "")
        Me.Profil.Get_Profil_By_Mitarbeiter()
        Me.TSComboboxProfil.Items.Clear()
        Dim i As Integer = 0
        Dim SelIndex As Integer = -1
        For Each dr As DataRow In Me.Profil.Profildata.Rows
            Me.TSComboboxProfil.Items.Add(dr.Item("Bezeichnung"))
            If Aktuelles_Profil = dr.Item("Bezeichnung") Then SelIndex = i
            i = i + 1
        Next
        If SelIndex > -1 Then Me.TSComboboxProfil.SelectedIndex = SelIndex
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.ProfilspeichernToolStripMenuItem_Click -Methode

Profil speichern

[Visual Basic]
Private Sub ProfilspeichernToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   ProfilspeichernToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub ProfilspeichernToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ProfilspeichernToolStripMenuItem.Click
        Me.Profil.bSelektionsart = New SqlBoolean(CType(Me.rbSortVertragspartner.Checked, Boolean))
        Me.Profil.bV_Aktiv_Vertragspartner = New SqlBoolean(CType(Me.cbInaktiv.Checked, Boolean))
        Me.Profil.sV_Aktiv_Vertragselemente = New SqlString(CType(Me.C1Vertragselemente.Columns("aktiv").FilterText, String))
        Me.Profil.Save_Data()
        Me.Docs.Save_LayoutFile(Me.C1Vertragselemente, 1, Me.Profil.iProfilnr.Value)
        msg.show_standardmessage(502, MsgBoxStyle.Information)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.RB_CheckedChanged -Methode

Handling RB_Changed für den Aufbau der Struktur

[Visual Basic]
Private Sub RB_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   rbSortVertragspartner.CheckedChanged, _
   rbSortVertragstyp.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub RB_CheckedChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbSortVertragspartner.CheckedChanged, rbSortVertragstyp.CheckedChanged
        If Me.IsOnLoad Then Exit Sub
        If Me.rbSortVertragspartner.Checked = False And Me.rbSortVertragstyp.Checked = False Then Exit Sub
        Me.Load_Struktur()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Aktivitaeten -Methode

Aktivitäten aktualisieren

[Visual Basic]
Private Sub Refresh_Aktivitaeten()

Quellcode

[Visual Basic]
    Private Sub Refresh_Aktivitaeten()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Aktivitaeten.Enabled = False
        Me.Vertragselement.Get_Aktivitaeten(Me.C1Aktivitaeten, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Aktivitaeten, "Aktivitaet", Me.Vertragselement.Aktivitaeten.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Aktivitaeten.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_All -Methode

Treeview Struktur aktualisieren

[Visual Basic]
Private Sub Refresh_All()

Quellcode

[Visual Basic]
    Private Sub Refresh_All()
        Cursor = Cursors.WaitCursor

        Me.TreeStruktur.Enabled = False
        Me.TreeStruktur.BeginUpdate()

        Dim SaveTn As TreeNode = Me.TreeStruktur.SelectedNode
        Dim tmptn As TreeNode = Me.RootTreeNode(Me.TreeStruktur.SelectedNode)
        Me.TreeStruktur.Nodes.Clear()
        Me.Load_Struktur()

        Dim keyvalue As TKB.VV.Vertrag.Treenode_Descriptor = tmptn.Tag

        Me.TreeStruktur.Enabled = True
        Me.TreeStruktur.EndUpdate()
        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, keyvalue.Keyvalue, tmptn.Text)

        Me.TreeStruktur.Enabled = False
        Me.TreeStruktur.BeginUpdate()
        Me.Update_Node(tmptn, Me.Profil.bV_Struktur_Details.Value)
        Me.TreeStruktur.SelectedNode.ExpandAll()

        Me.TreeStruktur.Enabled = True
        Me.TreeStruktur.EndUpdate()

        keyvalue = SaveTn.Tag
        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, keyvalue.Keyvalue, SaveTn.Text)

        Refresh_Details()
        Cursor = Cursors.Default

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Applikationen -Methode

Applikationen aktualisieren

[Visual Basic]
Private Sub Refresh_Applikationen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Applikationen()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Applikationen.Enabled = False
        Me.Vertragselement.Get_Applikationen(Me.C1Applikationen, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Applikationen, "Vertragselementapplikation", Me.Vertragselement.VertragselementApplikationen.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Applikationen.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Details -Methode

[Visual Basic]
Private Sub Refresh_Details()

Quellcode

[Visual Basic]
    Private Sub Refresh_Details()

        Try
            Dim bm As Integer = 0
            bm = Me.C1Vertragselemente.Bookmark
            Cursor = Cursors.WaitCursor
            If Me.rbSortVertragstyp.Checked And Me.TreeStruktur.SelectedNode.Level = 0 Then
                c1data = Me.Strukturen.Update_Vertragsuebersicht(Me.TreeStruktur.SelectedNode.Tag, True, Me.TStxtSucheInhalt.Text)
            Else
                c1data = Me.Strukturen.Update_Vertragsuebersicht(Me.TreeStruktur.SelectedNode.Tag, , Me.TStxtSucheInhalt.Text)
            End If
            If Me.Profil.sV_Sort.ToString <> "" Then
                c1data.DefaultView.Sort = Me.Profil.sV_Sort.ToString
            End If
            Dim gv As C1.Win.C1TrueDBGrid.DataViewEnum
            Dim s As New Collection
            Dim i As Integer = -1
            For Each g As C1.Win.C1TrueDBGrid.C1DataColumn In Me.C1Vertragselemente.GroupedColumns
                s.Add(g.Caption)
                i = i + 1
                '                xxx(i) = g.Caption
            Next
            i = Me.C1Vertragselemente.DataView
            Me.C1Vertragselemente.Enabled = False
            Me.C1Vertragselemente.DataSource = c1data
            Me.C1Vertragselemente.DataMember = c1data.TableName
            Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Vertragselemente, "Vertragsuebersicht", Me.c1data, Me.Profil.sV_Aktiv_Vertragselemente.Value)
            Update_Details()
            Docs.Get_Layout(Me.C1Vertragselemente, 1, Me.Profil.iProfilnr.Value)
            Me.C1Vertragselemente.FetchRowStyles = True
            If i <> 0 Then
                Try
                    Me.C1Vertragselemente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal
                    Me.C1Vertragselemente.DataView = i
                    For Each ss As String In s
                        Me.C1Vertragselemente.GroupedColumns.Add(Me.C1Vertragselemente.Columns(ss))
                    Next

                Catch ex As Exception

                End Try
            End If
            s = Nothing

            Try
                Select Case Me.cbaktiveVertraege.CheckState
                    Case CheckState.Checked
                        C1Vertragselemente.Columns("aktiv").FilterText = True
                    Case CheckState.Unchecked
                        C1Vertragselemente.Columns("aktiv").FilterText = False
                    Case CheckState.Indeterminate
                        C1Vertragselemente.Columns("aktiv").FilterText = ""
                End Select
            Catch ex As Exception

            End Try
            Try
                Me.C1Vertragselemente.Bookmark = bm
            Catch ex As Exception

            End Try
            Me.C1Vertragselemente.Enabled = True
        Catch ex As Exception
        Finally
            Cursor = Cursors.Default

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Dokumente -Methode

Dokumente aktualisieren

[Visual Basic]
Private Sub Refresh_Dokumente()

Quellcode

[Visual Basic]
    Private Sub Refresh_Dokumente()
        Try
            Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
            Me.C1Dokumente.Enabled = False
            Me.Vertragselement.Get_Dokumente(Me.C1Dokumente, Me.C1Vertragselemente.Columns("Vertragselementnr").Value, Me.ImageListeDocIcon)
            '        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Dokumente, "Dokument", Me.Vertragselement.dokumente.Tabledata.Tables(0), False)
            Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Dokumente, "dokument", Me.Vertragselement.dokumente, Me.Profil.sV_Aktiv_Vertragselemente.Value)
            Me.C1Dokumente.Enabled = True
            Me.Vertragselement.dispose()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Ereignisse -Methode

Ereignisse aktualisieren

[Visual Basic]
Private Sub Refresh_Ereignisse()

Quellcode

[Visual Basic]
    Private Sub Refresh_Ereignisse()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Ereignisse.Enabled = False
        Me.Vertragselement.Get_Vertragsereignisse(Me.C1Ereignisse, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Ereignisse, "Vertragsereignis", Me.Vertragselement.Vertragsereignisse.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Ereignisse.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_History -Methode

History aktualisieren

[Visual Basic]
Private Sub Refresh_History()

Quellcode

[Visual Basic]
    Private Sub Refresh_History()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1History.Enabled = False
        Me.Vertragselement.Get_History(Me.C1History, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1History, "History", Me.Vertragselement.History.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)

        Me.C1History.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Kontakte -Methode

Kontakte aktualisieren

[Visual Basic]
Private Sub Refresh_Kontakte()

Quellcode

[Visual Basic]
    Private Sub Refresh_Kontakte()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Kontakte.Enabled = False
        Me.Vertragselement.Get_Vertragskontakte(Me.C1Kontakte, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        '        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kontakte, "Vertragskontakt", Me.Vertragselement.Vertragskontakte.Tabledata)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Kontakte, "Vertragskontakt", Me.Vertragselement.Vertragskontakte.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Kontakte.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Kuendigungsfrist -Methode

Kündigungsfristen aktualisieren

[Visual Basic]
Private Sub Refresh_Kuendigungsfrist()

Quellcode

[Visual Basic]
    Private Sub Refresh_Kuendigungsfrist()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Kuendigungsfristen.Enabled = False
        Me.Vertragselement.Get_Kuendigungsfristen(Me.C1Kuendigungsfristen, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        '        Me.SpaltenTitel.Spaltentitel_aktualisieren(Me.C1Kuendigungsfristen, "Kuendigungsfrist", Me.Vertragselement.Kuendigungsfristen.Tabledata)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Kuendigungsfristen, "Kuendigungsfrist", Me.Vertragselement.Kuendigungsfristen.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)

        Me.C1Kuendigungsfristen.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Pendenzen -Methode

Pendenzen aktualisieren

[Visual Basic]
Private Sub Refresh_Pendenzen()

Quellcode

[Visual Basic]
    Private Sub Refresh_Pendenzen()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Ereignisse.Enabled = False
        Me.Vertragselement.Get_Pendenzen(Me.C1Pendenzen, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Pendenzen, "Pendenz", Me.Vertragselement.Pendenzen.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Pendenzen.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Referenzvertraege -Methode

Referenzverträge aktualisieren

[Visual Basic]
Private Sub Refresh_Referenzvertraege()

Quellcode

[Visual Basic]
    Private Sub Refresh_Referenzvertraege()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1ReferenzVertraege.Enabled = False
        Me.Vertragselement.Get_Vertragselement_Referenzen(Me.C1ReferenzVertraege, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1ReferenzVertraege, "Vertragselement_Referenz", Me.Vertragselement.Vertragselement_Referenzen.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)

        Dim bmp0 As New Bitmap(Me.ImageListeReferenzVertrasege.Images(1))
        Dim bmp1 As New Bitmap(Me.ImageListeReferenzVertrasege.Images(0))
        Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()

        v0.DisplayValue = bmp0
        v0.Value = 0

        v1.DisplayValue = bmp1
        v1.Value = 1
        Me.C1ReferenzVertraege.Columns("Owner").ValueItems.Values.Add(v0)
        Me.C1ReferenzVertraege.Columns("Owner").ValueItems.Values.Add(v1)
        Me.C1ReferenzVertraege.Columns("Owner").ValueItems.Translate = True
        Me.C1ReferenzVertraege.Enabled = True
        Me.Vertragselement.dispose()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_Register -Methode

[Visual Basic]
Private Sub Refresh_Register() Handles  _
   evh.Update_Uebersicht

Quellcode

[Visual Basic]
    Private Sub Refresh_Register() Handles evh.Update_Uebersicht
        If Globals.clsapplication.bVertragsuebersicht_aktualisieren.Value = True Then Refresh_All()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Refresh_services -Methode

Services aktualisieren

[Visual Basic]
Private Sub Refresh_services()

Quellcode

[Visual Basic]
    Private Sub Refresh_services()
        Me.Vertragselement = New TKB.VV.Vertrag.clsVertragselement
        Me.C1Services.Enabled = False
        Me.Vertragselement.Get_Services(Me.C1Services, Me.C1Vertragselemente.Columns("Vertragselementnr").Value)
        Me.SpaltenTitel.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(Me.C1Services, "Vertragsleistung", Me.Vertragselement.Services.Tabledata.Tables(0), Me.Profil.sV_Aktiv_Vertragselemente.Value)
        sec.Set_Form_Security(Me)
        Me.C1Services.Enabled = True
        Me.Vertragselement.dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.RegisterSpeichernDokumentToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub RegisterSpeichernDokumentToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   RegisterSpeichernDokumentToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub RegisterSpeichernDokumentToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RegisterSpeichernDokumentToolStripMenuItem.Click
        RegisterSpeichernToolStripMenuItem_Click(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.RegisterSpeichernToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub RegisterSpeichernToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   RegisterSpeichernToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub RegisterSpeichernToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RegisterSpeichernToolStripMenuItem.Click
        Dim s As String = ""
        For Each tbp As TabPage In Me.TabControlDiverse.TabPages
            s = s + tbp.Text + ";"
        Next
        Me.Profil.sV_Register = New SqlString(CType(s, String))
        Me.Profil.Save_Data()
        Me.Docs.Save_LayoutFile(Me.C1Vertragselemente, 1, Me.Profil.iProfilnr.Value)
        msg.show_standardmessage_ReplaceText(505, MsgBoxStyle.Information, Me.Profil.sBezeichnung.Value, "")

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.RootTreeNode -Methode

Toplevel-Treenode suchen

[Visual Basic]
Private Function RootTreeNode( _
   ByVal tn As TreeNode _
) As TreeNode

Parameter

tn

Quellcode

[Visual Basic]
    Private Function RootTreeNode(ByVal tn As TreeNode) As TreeNode
        While Not tn.Parent Is Nothing
            tn = tn.Parent
            RootTreeNode(tn)
        End While
        Return tn
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.SpaltendarstellungSichernToolStripMenuItem_Click -Methode

Spaltenlayout C1Vertragselemente speichern

[Visual Basic]
Private Sub SpaltendarstellungSichernToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabellendarstellungSichernToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub SpaltendarstellungSichernToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabellendarstellungSichernToolStripMenuItem.Click
        Docs.Save_LayoutFile(Me.C1Vertragselemente, 1, Me.Profil.iProfilnr.Value)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBrnNeuesProfil_Click -Methode

Neues Profil erstellen

[Visual Basic]
Private Sub TSBrnNeuesProfil_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBrnNeuesProfil_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim a As String = InputBox(msg.Get_Meldungstext(503))
        If a <> "" Then
            If UCase(a) = "STANDARD" Then
                msg.show_standardmessage(504, MsgBoxStyle.Information)
                Exit Sub
            End If
            Me.Profil.Set_Aktuelles_Profil(Me.Profil.Add_New(a))
            Me.ProfilspeichernToolStripMenuItem_Click(sender, e)
            Me.Profile_Aktualisieren(a)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnCopy_Click -Methode

Datensatz kopieren

[Visual Basic]
Private Sub TSBtnCopy_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnCopy.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnCopy_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnCopy.Click
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnDelete_Click -Methode

Aktueller Datensatz inaktivieren

[Visual Basic]
Private Sub TSBtnDelete_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnDelete.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnDelete.Click
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnFilterAufheben_Click -Methode

[Visual Basic]
Private Sub TSBtnFilterAufheben_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnFilterAufheben.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnFilterAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnFilterAufheben.Click
        Me.TStxtSucheInhalt.Text = ""
        Me.TStxtSuche.Text = ""
        Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, 1, "")
        Try
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
            Me.TreeStruktur_Click(sender, e)
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnNew_Click -Methode

Neuer Datensatz erstellen

[Visual Basic]
Private Sub TSBtnNew_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnNew.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnNew.Click
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnQuit_Click -Methode

Formular schliessen

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnSucheInhalt_Click -Methode

[Visual Basic]
Private Sub TSBtnSucheInhalt_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSucheInhalt.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSucheInhalt_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSucheInhalt.Click
        Me.C1Dokumente.DataSource = Nothing
        If Me.rbSortVertragspartner.Checked = True Then
            Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, 2, Me.TStxtSucheInhalt.Text)
        Else
            Strukturen.Get_Struktur(Me.TreeStruktur, 1, Me.cbInaktiv.Checked, 2, Me.TStxtSucheInhalt.Text)
        End If
        Try
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
            Me.TreeStruktur_Click(sender, e)
            If Me.TreeStruktur.GetNodeCount(False) = 1 Then
                Try
                    Update_Node(Me.TreeStruktur.SelectedNode, Me.Profil.bV_Struktur_Details.Value)
                Catch ex As Exception

                End Try
            End If
        Catch ex As Exception
        End Try

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSBtnSuche_Click -Methode

Vertragspartner suchen

[Visual Basic]
Private Sub TSBtnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnSuche.Click
        Me.C1Dokumente.DataSource = Nothing
        If Me.rbSortVertragspartner.Checked = True Then
            Strukturen.Get_Struktur(Me.TreeStruktur, 0, Me.cbInaktiv.Checked, 1, Me.TStxtSuche.Text)
        Else
            Strukturen.Get_Struktur(Me.TreeStruktur, 1, Me.cbInaktiv.Checked, 1, Me.TStxtSuche.Text)
        End If
        Try
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
            Me.TreeStruktur_Click(sender, e)
            If Me.TreeStruktur.GetNodeCount(False) = 1 Then
                Try
                    Update_Node(Me.TreeStruktur.SelectedNode, Me.Profil.bV_Struktur_Details.Value)
                Catch ex As Exception

                End Try
            End If
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TSComboboxProfil_SelectedIndexChanged -Methode

Bestehendes Profl auswählen

[Visual Basic]
Private Sub TSComboboxProfil_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSComboboxProfil.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSComboboxProfil_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TSComboboxProfil.SelectedIndexChanged
        Me.C1Vertragselemente.DataSource = Nothing
        Me.Profil.Set_Aktuelles_Profil(Me.TSComboboxProfil.Text)
        Try
            Select Case Me.Profil.sV_Aktiv_Vertragselemente.Value
                Case "True"
                    Me.cbaktiveVertraege.CheckState = CheckState.Checked
                Case "False"
                    Me.cbaktiveVertraege.CheckState = CheckState.Unchecked
                Case Else
                    Me.cbaktiveVertraege.CheckState = CheckState.Indeterminate
            End Select
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        Me.cbInaktiv.Checked = Me.Profil.bV_Aktiv_Vertragspartner = True
        Me.rbSortVertragspartner.Checked = False
        Me.rbSortVertragstyp.Checked = False
        If Me.Profil.bSelektionsart.Value = True Then
            Me.rbSortVertragspartner.Checked = True
        Else
            Me.rbSortVertragstyp.Checked = True
        End If

        Me.TreeStruktur_Click(sender, e)
        Me.Order_Tabcontrol()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TStxtSucheInhalt_KeyDown -Methode

[Visual Basic]
Private Sub TStxtSucheInhalt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TStxtSucheInhalt.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TStxtSucheInhalt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TStxtSucheInhalt.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.TSBtnSucheInhalt_Click(sender, e)
        Else
            Me.TStxtSuche.Text = ""
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TStxtSuche_KeyDown -Methode

[Visual Basic]
Private Sub TStxtSuche_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TStxtSuche.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TStxtSuche_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TStxtSuche.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.TSBtnSuche_Click(sender, e)
        Else
            Me.TStxtSucheInhalt.Text = ""
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TabControlDiverse_SelectedIndexChanged -Methode

Index-Wechsel auf TabControlDiverse. Abhängig der gewählten Registerlasche, werden deren Daten aktualisiert.

[Visual Basic]
Private Sub TabControlDiverse_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TabControlDiverse.SelectedIndexChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TabControlDiverse_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControlDiverse.SelectedIndexChanged
        Update_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStrukturAktualisierenToolStripMenuItem_Click -Methode

Aktualisierung des aktuellen Knotens

[Visual Basic]
Private Sub TreeStrukturAktualisierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturAktualisierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStrukturAktualisierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturAktualisierenToolStripMenuItem.Click

        Cursor = Cursors.WaitCursor
        Dim SaveTn As TreeNode = Me.TreeStruktur.SelectedNode

        Me.TreeStruktur.Enabled = False
        Me.TreeStruktur.BeginUpdate()
        Dim tmptn As TreeNode = Me.RootTreeNode(Me.TreeStruktur.SelectedNode)
        tmptn.Nodes.Clear()
        tmptn.Nodes.Add("")
        Me.Update_Node(tmptn, Me.Profil.bV_Struktur_Details.Value)
        tmptn.ExpandAll()
        Dim kvalue As TKB.VV.Vertrag.Treenode_Descriptor = SaveTn.Tag

        Me.TreeStruktur.Enabled = True
        Me.TreeStruktur.EndUpdate()

        Me.TreeStruktur.SelectedNode = FindNode(Me.TreeStruktur.Nodes, kvalue.Keyvalue, SaveTn.Text)
        TreeStruktur_Click(sender, e)
        Cursor = Cursors.Default
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStrukturContextMenuStrip_Opening -Methode

TreeStrukturContetmenu anzeigen und allfällige MenuItems disablen

[Visual Basic]
Private Sub TreeStrukturContextMenuStrip_Opening( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) Handles  _
   TreeStrukturContextMenuStrip.Opening

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStrukturContextMenuStrip_Opening(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles TreeStrukturContextMenuStrip.Opening
        Try
            Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Enabled = False
            Tag_Descriptor = Me.TreeStruktur.SelectedNode.Tag
            Select Case Tag_Descriptor.Type
                Case "Vertragspartner"
                    Me.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Enabled = True
            End Select
        Catch ex As Exception

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStrukturTreeAktualisierenToolStripMenuItem_Click -Methode

Vollständiger Treeview aktualisieren

[Visual Basic]
Private Sub TreeStrukturTreeAktualisierenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturTreeAktualisierenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStrukturTreeAktualisierenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturTreeAktualisierenToolStripMenuItem.Click
        Refresh_All()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click -Methode

Vertragspartner anzeigen / bearbeiten

[Visual Basic]
Private Sub TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStrukturVertragspartnerAnzeigenToolStipMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeStrukturVertragspartnerAnzeigenToolStipMenuItem.Click
        Dim tmptag As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Tag
        If tmptag.Type = "Vertragspartner" Then
            Dim f As New frmVertragspartner(tmptag.Vertragspartnernr, Me.FormReadonly)
            f.MdiParent = Me.MdiParent
            f.Show()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStruktur_AfterSelect -Methode

[Visual Basic]
Private Sub TreeStruktur_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeStruktur.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeStruktur.AfterSelect
        Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStruktur_Click -Methode

Treeview-Click

[Visual Basic]
Private Sub TreeStruktur_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeStruktur.Click

Parameter

sender
e

Hinweise

Ist die Sortierung nach Vertragstyp und der Click auf dem Root-Entry, wird das Datenauslesen speziell behandelt, sodass sämtliche Vertragspartner berücksichtigt werden

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeStruktur.Click
        Refresh_Details()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.TreeStruktur_MouseDown -Methode

Mousedown-Ereignis auf dem Tree

[Visual Basic]
Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
) Handles  _
   TreeStruktur.MouseDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeStruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.GetNodeAt(selectPoint)

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.Update_DetailInformationen -Methode

Detail-Informationen der ersten 2 TabPages aktualisieren

[Visual Basic]
Private Sub Update_DetailInformationen()

Quellcode

[Visual Basic]
    Private Sub Update_DetailInformationen()
        Try
            Me.txtBeschreibung.Text = Me.C1Vertragselemente.Columns("Beschreibung").Value
            Me.txtVertragstyp.Text = Me.C1Vertragselemente.Columns("Vertragstyp").Value
            Me.txtBezeichnung.Text = Me.C1Vertragselemente.Columns("Bezeichnung").Value
            Me.txtSuchbegriffe.Text = Me.C1Vertragselemente.Columns("Suchbegriffe").Value
            Me.txtVersion.Text = Me.C1Vertragselemente.Columns("Version").Value
            Me.txtVertragsnummer.Text = Me.C1Vertragselemente.Columns("Nummer").Value
            If Not Me.C1Vertragselemente.Columns("Versionsdatum").Value Is System.DBNull.Value Then
                Me.txtVersionsdatum.Text = Me.C1Vertragselemente.Columns("Versionsdatum").Value
            Else
                Me.txtVersionsdatum.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Vertragsbeginn").Value Is System.DBNull.Value Then
                Me.txtVertragsbegin.Text = Me.C1Vertragselemente.Columns("Vertragsbeginn").Value
            Else
                Me.txtVertragsbegin.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Vertragsablauf").Value Is System.DBNull.Value Then
                Me.txtVertragsende.Text = Me.C1Vertragselemente.Columns("Vertragsablauf").Value
            Else
                Me.txtVertragsende.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Mindestvertragsdauer_bis").Value Is System.DBNull.Value Then
                Me.txtMindestvertragsdauerbis.Text = Me.C1Vertragselemente.Columns("Mindestvertragsdauer_bis").Value
            Else
                Me.txtMindestvertragsdauerbis.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Unterzeichnet_am").Value Is System.DBNull.Value Then
                Me.txtUnterzeichnetam.Text = Me.C1Vertragselemente.Columns("Unterzeichnet_am").Value
            Else
                Me.txtUnterzeichnetam.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Gekuendigt_am").Value Is System.DBNull.Value Then
                Me.txtGekuendigtam.Text = Me.C1Vertragselemente.Columns("Gekuendigt_am").Value
            Else
                Me.txtGekuendigtam.Text = ""
            End If
            If Not Me.C1Vertragselemente.Columns("Gekuendigt_per").Value Is System.DBNull.Value Then
                Me.txtGekuendigtper.Text = Me.C1Vertragselemente.Columns("Gekuendigt_per").Value
            Else
                Me.txtGekuendigtper.Text = ""
            End If
            Me.cboxSecurityLevel.SelectedValue = Me.C1Vertragselemente.Columns("SecurityLevelNr").Value
            Try
                Me.rbbefristet.Checked = Me.C1Vertragselemente.Columns("befristet_unbefristet").Value
                If Me.rbbefristet.Checked = False Then Me.rbUnbefristet.Checked = True
            Catch
                Me.rbbefristet.Checked = False
                Me.rbUnbefristet.Checked = True
            End Try
            Me.txtErstelltam.Text = Me.C1Vertragselemente.Columns("Erstellt_am").Value
            Me.txtMutiertam.Text = Me.C1Vertragselemente.Columns("Mutiert_am").Value
            Me.txtMutierer.Text = Me.C1Vertragselemente.Columns("Mutierername").Value
            Try
                Me.cbaktiv.Checked = Me.C1Vertragselemente.Columns("aktiv").Value = True
            Catch ex As Exception
                Me.cbaktiv.Checked = True
            End Try
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Update_Details -Methode

Überladungsliste

[Visual Basic] Private Function update_details(ByRef String, String) As Object
[C#] private object update_details(ref string, string);

Detailelemente und die allfällig ausgewählte TabPage aktualisieren

[Visual Basic] Private Sub Update_Details()
[C#] private System.Void Update_Details();

frmVertragsuebersicht


frmVertragsuebersicht.Update_Node -Methode

[Visual Basic]
Private Sub Update_Node( _
   ByRef tn As TreeNode, _
   ByVal Details As Integer _
)

Parameter

tn
Details

Quellcode

[Visual Basic]
    Private Sub Update_Node(ByRef tn As TreeNode, ByVal Details As Integer)
        Dim x As TKB.VV.Vertrag.Treenode_Descriptor = tn.Tag
        Select Case x.Type
            Case "Vertragspartner"
                tn.Nodes.Clear()
                Me.Strukturen.Load_SubStruktur(tn, Details, Me.TStxtSucheInhalt.Text, Me.cbaktiveVertraege.CheckState)
                tn.ExpandAll()
            Case "Vertragstyp"
                tn.Nodes.Clear()
                If Me.TStxtSuche.Text <> "" Then
                    Me.Strukturen.Load_SubStruktur(tn, Details, "V:" + Me.TStxtSuche.Text, Me.cbaktiveVertraege.CheckState)
                Else
                    If Me.TStxtSucheInhalt.Text <> "" Then
                        Me.Strukturen.Load_SubStruktur(tn, Details, "I:" + Me.TStxtSucheInhalt.Text, Me.cbaktiveVertraege.CheckState)
                    Else
                        Me.Strukturen.Load_SubStruktur(tn, Details, "", Me.cbaktiveVertraege.CheckState)
                    End If
                End If
                tn.ExpandAll()
        End Select
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.VertragselementAnzeigenBearbeitenToolStripMenuItem_Click -Methode

Vertragselement anzeigen / bearbeiten

[Visual Basic]
Private Sub VertragselementAnzeigenBearbeitenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   VertragselementAnzeigenBearbeitenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub VertragselementAnzeigenBearbeitenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VertragselementAnzeigenBearbeitenToolStripMenuItem.Click
        Me.C1Vertragselemente_DoubleClick(sender, e)
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.cbaktiveVertraege_CheckedChanged -Methode

[Visual Basic]
Private Sub cbaktiveVertraege_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbaktiveVertraege.CheckStateChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbaktiveVertraege_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbaktiveVertraege.CheckStateChanged
        Try
            If Me.IsOnLoad Then Exit Sub
            If Not Me.TreeStruktur.SelectedNode Is Nothing And Not Me.PartnerNode Is Nothing Then
                Me.TreeStruktur.SelectedNode = Me.PartnerNode
            End If
            TreeStrukturAktualisierenToolStripMenuItem_Click(sender, e)
            Select Case Me.cbaktiveVertraege.CheckState
                Case CheckState.Checked
                    C1Vertragselemente.Columns("aktiv").FilterText = True
                Case CheckState.Unchecked
                    C1Vertragselemente.Columns("aktiv").FilterText = False
                Case CheckState.Checked
                    C1Vertragselemente.Columns("aktiv").FilterText = ""
            End Select

        Catch ex As Exception
            Me.TreeStruktur.Enabled = False
            Me.TreeStruktur.BeginUpdate()

        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.cbaktiveVertraege_CheckedChanged_1 -Methode

[Visual Basic]
Private Sub cbaktiveVertraege_CheckedChanged_1( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbaktiveVertraege.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbaktiveVertraege_CheckedChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbaktiveVertraege.CheckedChanged

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.cbocInaktiv_CheckedChanged -Methode

Bei Änderung der Inaktiv-Checkbox werden die Hauptstrukturen neu geladen

[Visual Basic]
Private Sub cbocInaktiv_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   cbInaktiv.CheckedChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub cbocInaktiv_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbInaktiv.CheckedChanged
        Try
            Me.Load_Struktur()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.evh_FormularVertragelement_Closed -Methode

[Visual Basic]
Private Sub evh_FormularVertragelement_Closed( _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer _
) Handles  _
   evh.FormularVertragelement_Closed

Parameter

Vertragspartnernr
Vertragselementnr

Quellcode

[Visual Basic]
    Private Sub evh_FormularVertragelement_Closed(ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer) Handles evh.FormularVertragelement_Closed
        Try
            If Globals.clsapplication.bVertragsuebersicht_aktualisieren.Value = True Then Refresh_All()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.evh_FormularVertragspartner_Closed -Methode

[Visual Basic]
Private Sub evh_FormularVertragspartner_Closed( _
   ByVal Vertragspartnernr As Integer _
) Handles  _
   evh.FormularVertragspartner_Closed

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
    Private Sub evh_FormularVertragspartner_Closed(ByVal Vertragspartnernr As Integer) Handles evh.FormularVertragspartner_Closed
        Try
            If Globals.clsapplication.bVertragsuebersicht_aktualisieren.Value = True Then Refresh_All()
        Catch ex As Exception
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.frmVertragsuebersicht_Load -Methode

Formular-Load

[Visual Basic]
Private Sub frmVertragsuebersicht_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Hinweise

Wurde das Form mit einer Partnernr initialisiert, wird die Partnerstruktur geöffnet

Quellcode

[Visual Basic]
    Private Sub frmVertragsuebersicht_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Cursor = Cursors.WaitCursor
        Me.Save_LizenzTabPage = Me.TabControlDiverse.TabPages("TabLizenz")
        If Me.TSBtnSave.Enabled = False Then
            Me.FormReadonly = True
            Me.TSBtnCopy.Enabled = False
            Me.TSBtnNew.Enabled = False
            Me.TSBtnDelete.Enabled = False
        Else
            Me.FormReadonly = False
        End If
        Profile_Aktualisieren()
        Try
            Me.TSComboboxProfil.SelectedIndex = 0
        Catch
        End Try
        If PartnerToSelect <> 0 Then
            Load_Struktur(PartnerToSelect)
            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
            Me.PartnerNode = Me.TreeStruktur.SelectedNode
            Me.TreeStruktur_Click(sender, e)
            If Me.TreeStruktur.GetNodeCount(False) = 1 Then
                Me.TreeStruktur.ExpandAll()
                Try
                    Update_Node(Me.TreeStruktur.SelectedNode, Me.Profil.bV_Struktur_Details.Value)
                    Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
                Catch ex As Exception

                End Try
            End If
        Else
            Load_Struktur()
        End If
        Me.Order_Tabcontrol()
        PartnerToSelect = 0
        Me.IsOnLoad = False
        Load_Securitylevel()
        sec.Set_Form_Security(Me)

        Me.Cursor = Cursors.Default
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.treeStruktur_BeforeExpand -Methode

Aktueller Tag des gewählten Nodes auslesen und Aktualisierung aufrufen

[Visual Basic]
Private Sub treeStruktur_BeforeExpand( _
   ByVal sender As Object, _
   ByVal e As TreeViewCancelEventArgs _
) Handles  _
   TreeStruktur.BeforeExpand

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub treeStruktur_BeforeExpand(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeStruktur.BeforeExpand

        If Me.TreeStruktur.SelectedNode.GetNodeCount(True) = 1 And Me.TreeStruktur.SelectedNode.Level = 0 Then
            Dim xx As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Nodes(0).Tag
            'Dim xx As TKB.VV.Vertrag.Treenode_Descriptor = Me.TreeStruktur.SelectedNode.Tag
            If xx.Keyvalue = -99 Then
                Try
                    Me.PartnerNode = Me.TreeStruktur.SelectedNode
                    Update_Node(Me.TreeStruktur.SelectedNode, Me.Profil.bV_Struktur_Details.Value)
                Catch ex As Exception
                End Try
            End If
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.txtVertragsende_TextChanged -Methode

[Visual Basic]
Private Sub txtVertragsende_TextChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   txtVertragsende.TextChanged, _
   txtVertragsbegin.TextChanged, _
   txtVersionsdatum.TextChanged, _
   txtGekuendigtam.TextChanged, _
   txtGekuendigtper.TextChanged, _
   txtMindestvertragsdauerbis.TextChanged, _
   txtUnterzeichnetam.TextChanged

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtVertragsende_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtVertragsende.TextChanged, txtVertragsbegin.TextChanged, _
    txtVersionsdatum.TextChanged, txtGekuendigtam.TextChanged, txtGekuendigtper.TextChanged, txtMindestvertragsdauerbis.TextChanged, txtUnterzeichnetam.TextChanged
        Dim objtype As System.Type = sender.GetType
        If objtype.Name = "MaskedTextBox" Then
            Dim o As MaskedTextBox = sender
            If o.Text = "01.01.1900" Then o.Text = "  .  .    "
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht-Felder

frmVertragsuebersicht Übersicht

Felder

private field Docs Unterstützt von .NET Compact Framework | Dokument-Management-Klasse
private field FormDataChanged Unterstützt von .NET Compact Framework |
private field FormReadonly Unterstützt von .NET Compact Framework |
private field IsOnLoad Unterstützt von .NET Compact Framework |
private field PartnerNode Unterstützt von .NET Compact Framework |
private field PartnerToSelect Unterstützt von .NET Compact Framework |
private field Profil Unterstützt von .NET Compact Framework |
private field Save_LizenzTabPage Unterstützt von .NET Compact Framework |
private field Services Unterstützt von .NET Compact Framework |
private field SpaltenTitel Unterstützt von .NET Compact Framework |
private field Strukturen Unterstützt von .NET Compact Framework | Klasse für die Bewirtschaftung der Tree-Strukturen
private field Tag_Descriptor Unterstützt von .NET Compact Framework | Klasse für die Beschreibung der Tree-Tags
private field Vertragselement Unterstützt von .NET Compact Framework | Vertragselement
private field c1data Unterstützt von .NET Compact Framework |
private field components Unterstützt von .NET Compact Framework |
private field msg Unterstützt von .NET Compact Framework | Message-Klasse
private field sec Unterstützt von .NET Compact Framework | Security-Klasse
internal (Friend) field selectPoint Unterstützt von .NET Compact Framework |
private field xxx Unterstützt von .NET Compact Framework | Details aktualisieren

Siehe auch

frmVertragsuebersicht -Klasse | MyDocMgmt | MyGenericEventHandler | MyMessage | MySecurity | Tabellenspalte | Treenode_Descriptor | clsProfile | clsVertragselement | clsVertragsuebersicht_Strukturen


Docs -Feld

Dokument-Management-Klasse

[Visual Basic]
Private Docs As MyDocMgmt

Quellcode

[Visual Basic]
    Dim Docs As New TKB.VV.Utils.MyDocMgmt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


FormDataChanged -Feld

[Visual Basic]
Private FormDataChanged As Boolean

Quellcode

[Visual Basic]
    Dim FormDataChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


FormReadonly -Feld

[Visual Basic]
Private FormReadonly As Boolean

Quellcode

[Visual Basic]
    Dim FormReadonly As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


IsOnLoad -Feld

[Visual Basic]
Private IsOnLoad As Boolean

Quellcode

[Visual Basic]
    Dim IsOnLoad As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


PartnerNode -Feld

[Visual Basic]
Private PartnerNode As TreeNode

Quellcode

[Visual Basic]
    Dim PartnerNode As TreeNode

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


PartnerToSelect -Feld

[Visual Basic]
Private PartnerToSelect As Integer

Quellcode

[Visual Basic]
    Dim PartnerToSelect As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Profil -Feld

[Visual Basic]
Private Profil As clsProfile

Quellcode

[Visual Basic]
    Dim Profil As New TKB.VV.Utils.clsProfile

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Save_LizenzTabPage -Feld

[Visual Basic]
Private Save_LizenzTabPage As TabPage

Quellcode

[Visual Basic]
    Dim Save_LizenzTabPage As TabPage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Services -Feld

[Visual Basic]
Private Services As clsVertragsleistung

Quellcode

[Visual Basic]
    Dim Services As New TKB.VV.Vertrag.clsVertragsleistung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


SpaltenTitel -Feld

[Visual Basic]
Private SpaltenTitel As Tabellenspalte

Quellcode

[Visual Basic]
    Dim SpaltenTitel As New TKB.VV.Utils.Tabellenspalte

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Strukturen -Feld

Klasse für die Bewirtschaftung der Tree-Strukturen

[Visual Basic]
Private Strukturen As clsVertragsuebersicht_Strukturen

Quellcode

[Visual Basic]
    Dim Strukturen As New TKB.VV.Vertrag.clsVertragsuebersicht_Strukturen

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Tag_Descriptor -Feld

Klasse für die Beschreibung der Tree-Tags

[Visual Basic]
Private Tag_Descriptor As Treenode_Descriptor

Quellcode

[Visual Basic]
    Dim Tag_Descriptor As TKB.VV.Vertrag.Treenode_Descriptor

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


Vertragselement -Feld

Vertragselement

[Visual Basic]
Private Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
    Dim Vertragselement As TKB.VV.Vertrag.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


c1data -Feld

[Visual Basic]
Private c1data As DataTable

Quellcode

[Visual Basic]
    Dim c1data As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


msg -Feld

Message-Klasse

[Visual Basic]
Private msg As MyMessage

Quellcode

[Visual Basic]
    Dim msg As New TKB.VV.Utils.MyMessage

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


sec -Feld

Security-Klasse

[Visual Basic]
Private sec As MySecurity

Quellcode

[Visual Basic]
    Dim sec As New TKB.VV.Utils.MySecurity

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


selectPoint -Feld

[Visual Basic]
Friend selectPoint As Point

Quellcode

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


xxx -Feld

Details aktualisieren

[Visual Basic]
Private xxx As String()

Quellcode

[Visual Basic]
    Dim xxx() As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmcrreporting -Klasse

For a list of all members of this type, see frmcrreporting-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmcrreporting

[Visual Basic]
Public Class frmcrreporting
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmcrreporting-Member


frmcrreporting-Member

frmcrreporting Übersicht

Öffentliche Konstruktoren

public constructor frmcrreporting -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method DBConnection_SubReports

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method TranslateStringToCRFormula

Unterstützt von .NET Compact Framework
private method frmcrreporting_Load

Unterstützt von .NET Compact Framework

Felder

private field StandardAuswertung

Unterstützt von .NET Compact Framework
private field auswertung

Unterstützt von .NET Compact Framework
private field auswertungnr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field dms

Unterstützt von .NET Compact Framework
private field ds

Unterstützt von .NET Compact Framework
private field printparam

Unterstützt von .NET Compact Framework
private field rptfilename

Unterstützt von .NET Compact Framework

frmcrreporting -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New(ByRef DataTable, Integer)
[C#] public System.Void frmcrreporting(ref DataTable, int);

[Visual Basic] Public Sub New(ByRef DataTable, Integer, ByRef clsAuswertung, Boolean)
[C#] public System.Void frmcrreporting(ref DataTable, int, ref clsAuswertung, bool);

frmcrreporting


frmcrreporting-Methoden

frmcrreporting Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method BeendenToolStripMenuItem_Click

Unterstützt von .NET Compact Framework
private method DBConnection_SubReports

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method TranslateStringToCRFormula

Unterstützt von .NET Compact Framework
private method frmcrreporting_Load

Unterstützt von .NET Compact Framework

frmcrreporting -Klasse


frmcrreporting.BeendenToolStripMenuItem_Click -Methode

[Visual Basic]
Private Sub BeendenToolStripMenuItem_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   BeendenToolStripMenuItem.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub BeendenToolStripMenuItem_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeendenToolStripMenuItem.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.DBConnection_SubReports -Methode

[Visual Basic]
Private Sub DBConnection_SubReports( _
   ByRef cr As ReportDocument _
)

Parameter

cr

Quellcode

[Visual Basic]
    Private Sub DBConnection_SubReports(ByRef cr As ReportDocument)
        If cr.Subreports.Count < 1 Then Exit Sub

        Dim filename As String = Application.StartupPath + "\" + Me.auswertung.Auswertung.sConnectionstring_Subreport.Value
        Dim ofile As System.IO.File
        Dim oread As System.IO.StreamReader
        Dim CoInfo As SqlClient.SqlConnection

        oread = ofile.OpenText(filename)
        sConnectionString = oread.ReadLine
        sConnectionString = Crypto.DecryptText(sConnectionString, "HutterundMueller")
        sConnectionString = Microsoft.VisualBasic.Left(sConnectionString, Len(sConnectionString) - 1)

        Dim split() As String = sConnectionString.Split(";")

        Dim servername As String = split(0)
        Dim dbname As String = split(1)
        Dim userid As String = split(5)
        Dim password As String = split(6)
        split = servername.Split("=")
        servername = split(1)
        split = dbname.Split("=")
        dbname = split(1)
        split = userid.Split("=")
        userid = split(1)
        split = password.Split("=")
        password = split(1)

        Dim Lo As New TableLogOnInfos()
        For Each subreport As ReportDocument In cr.Subreports
            Dim subreportdoc As ReportDocument = subreport
            Dim logonInfo As New TableLogOnInfo()
            For Each d As CrystalDecisions.CrystalReports.Engine.Table In subreportdoc.Database.Tables
                logonInfo = d.LogOnInfo
                logonInfo.ConnectionInfo.ServerName = servername
                logonInfo.ConnectionInfo.DatabaseName = dbname
                logonInfo.ConnectionInfo.UserID = userid
                logonInfo.ConnectionInfo.Password = password
                d.ApplyLogOnInfo(logonInfo)
            Next
        Next

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmcrreporting))
        Me.CrystalReportViewer1 = New CrystalDecisions.Windows.Forms.CrystalReportViewer
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.BeendenToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'CrystalReportViewer1
        '
        Me.CrystalReportViewer1.ActiveViewIndex = -1
        Me.CrystalReportViewer1.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.CrystalReportViewer1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.CrystalReportViewer1.Location = New System.Drawing.Point(0, 49)
        Me.CrystalReportViewer1.Name = "CrystalReportViewer1"
        Me.CrystalReportViewer1.SelectionFormula = ""
        Me.CrystalReportViewer1.Size = New System.Drawing.Size(933, 487)
        Me.CrystalReportViewer1.TabIndex = 0
        Me.CrystalReportViewer1.ViewTimeSelectionFormula = ""
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(933, 24)
        Me.MenuStrip1.TabIndex = 4
        Me.MenuStrip1.Text = "MenuStrip1"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.BeendenToolStripMenuItem})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'BeendenToolStripMenuItem
        '
        Me.BeendenToolStripMenuItem.Name = "BeendenToolStripMenuItem"
        Me.BeendenToolStripMenuItem.Size = New System.Drawing.Size(116, 22)
        Me.BeendenToolStripMenuItem.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(933, 25)
        Me.ToolStrip1.TabIndex = 5
        Me.ToolStrip1.Text = "ToolStrip1"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'frmcrreporting
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(933, 536)
        Me.Controls.Add(Me.CrystalReportViewer1)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmcrreporting"
        Me.Text = "Auswertung"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.TranslateStringToCRFormula -Methode

[Visual Basic]
Private Function TranslateStringToCRFormula( _
   ByVal VBString As String _
) As String

Parameter

VBString

Quellcode

[Visual Basic]
    Private Function TranslateStringToCRFormula(ByVal VBString As String) As String

        Dim Returnstring As String = "'"

        'Split the string at every LF
        For Each SubString As String In VBString.Split(Chr(10))

            SubString = SubString.Replace("'", "' & Chr(39) & '")

            'Trim all the CR / LF characters
            SubString = SubString.Trim(vbCrLf.ToCharArray)

            'Form your string to the compatible CR Formula format. Chr(10) &nd Chr(13) should be inserted as a string, not as values!!
            Returnstring = Returnstring & "' & Chr(10) & Chr(13) & '" & SubString

        Next

        Returnstring = Returnstring & "'"

        Return Returnstring

    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting.frmcrreporting_Load -Methode

[Visual Basic]
Private Sub frmcrreporting_Load( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Load

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub frmcrreporting_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        rptfilename = dms.Get_RptDatei(Me.auswertungnr)
        Dim cr As New ReportDocument
        cr.Load(rptfilename)
        If Me.StandardAuswertung = True Then

            Try
                Dim crformulas As CrystalDecisions.CrystalReports.Engine.FormulaFieldDefinitions
                crformulas = cr.DataDefinition.FormulaFields
                If Me.printparam Then

                    Dim i As Integer
                    Dim s As String = ""

                    For i = 1 To Me.auswertung.ParamCollection.Count
                        If s <> "" Then s = s + "|"
                        s = s + Me.auswertung.ParamCollection.Item(i).ToString
                    Next
                    Try
                        crformulas.Item("Param1").Text = "'" & s & "'"
                    Catch ex As Exception

                    End Try
                End If
                Try
                    crformulas.Item("Titel1").Text = "'" & Me.auswertung.TitelZeile1 & "'"
                Catch ex As Exception
                End Try
                Try
                    crformulas.Item("Titel2").Text = "'" & Me.auswertung.TitelZeile2 & "'"
                Catch ex As Exception
                End Try
            Catch
            End Try

            'Dim myTextObjectOnReport As CrystalDecisions.CrystalReports.Engine.TextObject
            'Try
            '    myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("txtheader11"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '    myTextObjectOnReport.Text = Me.auswertung.TitelZeile1
            'Catch
            'End Try
            'Try
            '    myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("txtheader12"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '    myTextObjectOnReport.Text = Me.auswertung.TitelZeile2
            'Catch
            'End Try
            'Try
            '    myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("txtheader21"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '    myTextObjectOnReport.Text = Me.auswertung.TitelZeile1
            'Catch
            'End Try
            'End Try

            '            Try
            '        myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("txtheader22"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '        myTextObjectOnReport.Text = Me.auswertung.TitelZeile2
            '    Catch
            '    End Try
            '    If Me.printparam Then
            '        Dim i As Integer
            '        For i = 1 To Me.auswertung.ParamCollection.Count

            '            Try
            '                myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("param1" & Trim(Str(i))), CrystalDecisions.CrystalReports.Engine.TextObject)
            '                myTextObjectOnReport.Text = Me.auswertung.ParamCollection.Item(i).ToString
            '            Catch
            '            End Try
            '            Try
            '                myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("param2" & Trim(Str(i))), CrystalDecisions.CrystalReports.Engine.TextObject)
            '                myTextObjectOnReport.Text = Me.auswertung.ParamCollection.Item(i).ToString
            '            Catch
            '            End Try
            '        Next
            '        Try
            '            Dim crformulas As CrystalDecisions.CrystalReports.Engine.FormulaFieldDefinitions

            '            'myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("fullparam1"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '            'myTextObjectOnReport.Text = Me.auswertung.FullParam
            '        Catch ex As Exception
            '        End Try
            '        Try
            '            myTextObjectOnReport = CType(cr.ReportDefinition.ReportObjects.Item("fullparam2"), CrystalDecisions.CrystalReports.Engine.TextObject)
            '            myTextObjectOnReport.Text = Me.auswertung.FullParam
            '        Catch ex As Exception
            '        End Try
            '    End If
            'Catch ex As Exception
            'End Try
            cr.SetDataSource(ds)
            '20091005 - SubReport-Connection
            DBConnection_SubReports(cr)

            Dim paramfield As ParameterField
            Dim newValue As New CrystalDecisions.Shared.ParameterDiscreteValue()

            For Each paramfield In cr.ParameterFields
                Try
                    If paramfield.Name.Substring(0, 1) = "@" Then
                        paramfield.CurrentValues.Clear()
                        newValue.Value = ""
                        paramfield.CurrentValues.Add(newValue)
                    End If
                Catch
                End Try
            Next

            CrystalReportViewer1.ShowRefreshButton = False
            CrystalReportViewer1.ShowCloseButton = False
            CrystalReportViewer1.ShowGroupTreeButton = False
            CrystalReportViewer1.ReportSource = cr
            Me.Cursor = Cursors.Default
            Application.DoEvents()
        Else
            cr.SetDataSource(ds)
            '20091005 - SubReport-Connection
            DBConnection_SubReports(cr)
            CrystalReportViewer1.ShowRefreshButton = False
            CrystalReportViewer1.ShowCloseButton = False
            CrystalReportViewer1.ShowGroupTreeButton = False
            CrystalReportViewer1.ReportSource = cr
            Me.Cursor = Cursors.Default
            Application.DoEvents()
        End If

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting-Felder

frmcrreporting Übersicht

Felder

private field StandardAuswertung

Unterstützt von .NET Compact Framework
private field auswertung

Unterstützt von .NET Compact Framework
private field auswertungnr

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework
private field dms

Unterstützt von .NET Compact Framework
private field ds

Unterstützt von .NET Compact Framework
private field printparam

Unterstützt von .NET Compact Framework
private field rptfilename

Unterstützt von .NET Compact Framework

frmcrreporting -Klasse


StandardAuswertung -Feld

[Visual Basic]
Private StandardAuswertung As Boolean

Quellcode

[Visual Basic]
    Dim StandardAuswertung As Boolean = True

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


auswertung -Feld

[Visual Basic]
Private auswertung As clsAuswertung

Quellcode

[Visual Basic]
    Dim auswertung As New TKB.Auswertung.clsAuswertung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


auswertungnr -Feld

[Visual Basic]
Private auswertungnr As Integer

Quellcode

[Visual Basic]
    Dim auswertungnr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


dms -Feld

[Visual Basic]
Private dms As MyDocMgmt

Quellcode

[Visual Basic]
    Dim dms As New TKB.VV.Utils.MyDocMgmt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


ds -Feld

[Visual Basic]
Private ds As DataTable

Quellcode

[Visual Basic]
    Dim ds As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


printparam -Feld

[Visual Basic]
Private printparam As Boolean

Quellcode

[Visual Basic]
    Dim printparam As Boolean = True

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


rptfilename -Feld

[Visual Basic]
Private rptfilename As String

Quellcode

[Visual Basic]
    Dim rptfilename As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmvertragsuebersicht_Suche -Klasse

For a list of all members of this type, see frmvertragsuebersicht_Suche-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Vertragsverwaltung.frmvertragsuebersicht_Suche

[Visual Basic]
<Global.Microsoft.VisualBasic.CompilerServices.DesignerGenerated()> _
Public Class frmvertragsuebersicht_Suche
    Inherits Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

frmvertragsuebersicht_Suche-Member


frmvertragsuebersicht_Suche-Member

frmvertragsuebersicht_Suche Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSuche_Click

Unterstützt von .NET Compact Framework
private method txtVertragselement_KeyDown

Unterstützt von .NET Compact Framework
private method txtVertragspartner_KeyDown

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework

frmvertragsuebersicht_Suche -Klasse


frmvertragsuebersicht_Suche-Methoden

frmvertragsuebersicht_Suche Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method TSBtnQuit_Click

Unterstützt von .NET Compact Framework
private method btnSuche_Click

Unterstützt von .NET Compact Framework
private method txtVertragselement_KeyDown

Unterstützt von .NET Compact Framework
private method txtVertragspartner_KeyDown

Unterstützt von .NET Compact Framework

frmvertragsuebersicht_Suche -Klasse


frmvertragsuebersicht_Suche.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
    Private Sub InitializeComponent()
        Dim resources As System.ComponentModel.ComponentResourceManager = New System.ComponentModel.ComponentResourceManager(GetType(frmvertragsuebersicht_Suche))
        Me.BeendenToolStipMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.MenuStrip1 = New System.Windows.Forms.MenuStrip
        Me.DateiToolStripMenuItem = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStripMenuItem1 = New System.Windows.Forms.ToolStripMenuItem
        Me.ToolStrip1 = New System.Windows.Forms.ToolStrip
        Me.TSBtnQuit = New System.Windows.Forms.ToolStripButton
        Me.lblVertragspartner = New System.Windows.Forms.Label
        Me.txtVertragspartner = New System.Windows.Forms.TextBox
        Me.btnSuche = New System.Windows.Forms.Button
        Me.txtVertragselement = New System.Windows.Forms.TextBox
        Me.Label1 = New System.Windows.Forms.Label
        Me.MenuStrip1.SuspendLayout()
        Me.ToolStrip1.SuspendLayout()
        Me.SuspendLayout()
        '
        'BeendenToolStipMenuItem
        '
        Me.BeendenToolStipMenuItem.Name = "BeendenToolStipMenuItem"
        Me.BeendenToolStipMenuItem.Size = New System.Drawing.Size(117, 22)
        Me.BeendenToolStipMenuItem.Tag = ""
        Me.BeendenToolStipMenuItem.Text = "&Beenden"
        '
        'MenuStrip1
        '
        Me.MenuStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.DateiToolStripMenuItem})
        Me.MenuStrip1.Location = New System.Drawing.Point(0, 0)
        Me.MenuStrip1.Name = "MenuStrip1"
        Me.MenuStrip1.Size = New System.Drawing.Size(407, 24)
        Me.MenuStrip1.TabIndex = 6
        Me.MenuStrip1.Tag = ""
        Me.MenuStrip1.Text = "Hauptmenu"
        '
        'DateiToolStripMenuItem
        '
        Me.DateiToolStripMenuItem.DropDownItems.AddRange(New System.Windows.Forms.ToolStripItem() {Me.ToolStripMenuItem1})
        Me.DateiToolStripMenuItem.Name = "DateiToolStripMenuItem"
        Me.DateiToolStripMenuItem.Size = New System.Drawing.Size(44, 20)
        Me.DateiToolStripMenuItem.Tag = ""
        Me.DateiToolStripMenuItem.Text = "&Datei"
        '
        'ToolStripMenuItem1
        '
        Me.ToolStripMenuItem1.Name = "ToolStripMenuItem1"
        Me.ToolStripMenuItem1.Size = New System.Drawing.Size(117, 22)
        Me.ToolStripMenuItem1.Tag = ""
        Me.ToolStripMenuItem1.Text = "&Beenden"
        '
        'ToolStrip1
        '
        Me.ToolStrip1.Items.AddRange(New System.Windows.Forms.ToolStripItem() {Me.TSBtnQuit})
        Me.ToolStrip1.Location = New System.Drawing.Point(0, 24)
        Me.ToolStrip1.Name = "ToolStrip1"
        Me.ToolStrip1.Size = New System.Drawing.Size(407, 25)
        Me.ToolStrip1.TabIndex = 7
        Me.ToolStrip1.Text = "Toolstrip Vertragspartner"
        '
        'TSBtnQuit
        '
        Me.TSBtnQuit.DisplayStyle = System.Windows.Forms.ToolStripItemDisplayStyle.Image
        Me.TSBtnQuit.Image = CType(resources.GetObject("TSBtnQuit.Image"), System.Drawing.Image)
        Me.TSBtnQuit.ImageTransparentColor = System.Drawing.Color.Magenta
        Me.TSBtnQuit.Name = "TSBtnQuit"
        Me.TSBtnQuit.Size = New System.Drawing.Size(23, 22)
        Me.TSBtnQuit.Text = "Fenster schliessen"
        Me.TSBtnQuit.ToolTipText = "Fenster schliessen"
        '
        'lblVertragspartner
        '
        Me.lblVertragspartner.AutoSize = True
        Me.lblVertragspartner.Location = New System.Drawing.Point(12, 68)
        Me.lblVertragspartner.Name = "lblVertragspartner"
        Me.lblVertragspartner.Size = New System.Drawing.Size(135, 13)
        Me.lblVertragspartner.TabIndex = 8
        Me.lblVertragspartner.Text = "Vertragspartner (Name/Ort)"
        '
        'txtVertragspartner
        '
        Me.txtVertragspartner.Location = New System.Drawing.Point(166, 65)
        Me.txtVertragspartner.Name = "txtVertragspartner"
        Me.txtVertragspartner.Size = New System.Drawing.Size(225, 20)
        Me.txtVertragspartner.TabIndex = 9
        '
        'btnSuche
        '
        Me.btnSuche.Location = New System.Drawing.Point(166, 136)
        Me.btnSuche.Name = "btnSuche"
        Me.btnSuche.Size = New System.Drawing.Size(75, 23)
        Me.btnSuche.TabIndex = 10
        Me.btnSuche.Text = "Suchen"
        Me.btnSuche.UseVisualStyleBackColor = True
        '
        'txtVertragselement
        '
        Me.txtVertragselement.Location = New System.Drawing.Point(166, 91)
        Me.txtVertragselement.Name = "txtVertragselement"
        Me.txtVertragselement.Size = New System.Drawing.Size(225, 20)
        Me.txtVertragselement.TabIndex = 12
        '
        'Label1
        '
        Me.Label1.AutoSize = True
        Me.Label1.Location = New System.Drawing.Point(12, 94)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(83, 13)
        Me.Label1.TabIndex = 11
        Me.Label1.Text = "Vertragselement"
        '
        'frmvertragsuebersicht_Suche
        '
        Me.AutoScaleDimensions = New System.Drawing.SizeF(6.0!, 13.0!)
        Me.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font
        Me.ClientSize = New System.Drawing.Size(407, 171)
        Me.Controls.Add(Me.txtVertragselement)
        Me.Controls.Add(Me.Label1)
        Me.Controls.Add(Me.btnSuche)
        Me.Controls.Add(Me.txtVertragspartner)
        Me.Controls.Add(Me.lblVertragspartner)
        Me.Controls.Add(Me.ToolStrip1)
        Me.Controls.Add(Me.MenuStrip1)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmvertragsuebersicht_Suche"
        Me.Text = "Suchen"
        Me.MenuStrip1.ResumeLayout(False)
        Me.MenuStrip1.PerformLayout()
        Me.ToolStrip1.ResumeLayout(False)
        Me.ToolStrip1.PerformLayout()
        Me.ResumeLayout(False)
        Me.PerformLayout()

    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche.TSBtnQuit_Click -Methode

[Visual Basic]
Private Sub TSBtnQuit_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TSBtnQuit.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub TSBtnQuit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TSBtnQuit.Click
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche.btnSuche_Click -Methode

[Visual Basic]
Private Sub btnSuche_Click( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   btnSuche.Click

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub btnSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSuche.Click
        Me.DialogResult = Windows.Forms.DialogResult.OK
        Me.Close()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche.txtVertragselement_KeyDown -Methode

[Visual Basic]
Private Sub txtVertragselement_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtVertragselement.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtVertragselement_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtVertragselement.KeyDown
        If e.KeyCode = Keys.Enter Then
            btnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche.txtVertragspartner_KeyDown -Methode

[Visual Basic]
Private Sub txtVertragspartner_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   txtVertragspartner.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Sub txtVertragspartner_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtVertragspartner.KeyDown
        If e.KeyCode = Keys.Enter Then
            btnSuche_Click(sender, e)
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


frmvertragsuebersicht_Suche-Felder

frmvertragsuebersicht_Suche Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework

frmvertragsuebersicht_Suche -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmvertragsuebersicht_Suche


Crypto -Klasse

For a list of all members of this type, see Crypto-Member.

[Visual Basic]
Friend Module Crypto

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Crypto-Member


Crypto-Member

Crypto Übersicht

Öffentliche Methoden

public method Static DecryptText

Unterstützt von .NET Compact Framework
public method Static EncryptText

Unterstützt von .NET Compact Framework

Crypto -Klasse


Crypto-Methoden

Crypto Übersicht

Öffentliche Methoden

public method Static DecryptText

Unterstützt von .NET Compact Framework
public method Static EncryptText

Unterstützt von .NET Compact Framework

Crypto -Klasse


Crypto.DecryptText -Methode

[Visual Basic]
Public Shared Function DecryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
) As Object

Parameter

strText
strPwd

Quellcode

[Visual Basic]
    Public Function DecryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String
        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c - Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        DecryptText = strBuff
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Crypto


Crypto.EncryptText -Methode

[Visual Basic]
Public Shared Function EncryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
) As Object

Parameter

strText
strPwd

Quellcode

[Visual Basic]
    Public Function EncryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String

        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c + Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        EncryptText = strBuff
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Crypto


Globals -Klasse

For a list of all members of this type, see Globals-Member.

[Visual Basic]
Friend Module Globals

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Globals-Member


Globals-Member

Globals Übersicht

Öffentliche Methoden

public method Static ApplicationPath

Unterstützt von .NET Compact Framework

 Aktueller Applikationspfad

Felder

public field Static AppldataRow Unterstützt von .NET Compact Framework |
public field Static Applikationsdaten Unterstützt von .NET Compact Framework | Applikationsdaten
public field Static ConnectionFileName Unterstützt von .NET Compact Framework |
public field Static SecurityDaten Unterstützt von .NET Compact Framework |
public field Static Set_ToolTips Unterstützt von .NET Compact Framework |
public field Static Spaltendaten Unterstützt von .NET Compact Framework |
public field Static ToolTipDaten Unterstützt von .NET Compact Framework |
public field Static Version Unterstützt von .NET Compact Framework | Applikationsversion
public field Static Versionsdatum Unterstützt von .NET Compact Framework |
public field Static clsapplication Unterstützt von .NET Compact Framework | Applikationsparameter
public field Static clsmitarbeiter Unterstützt von .NET Compact Framework | Angemelderter Mitarbeiter
public field Static conn Unterstützt von .NET Compact Framework |
public field Static dbconn Unterstützt von .NET Compact Framework |
public field Static sConnectionString Unterstützt von .NET Compact Framework | DB-Verbindungsklasse

Globals -Klasse


Globals-Methoden

Globals Übersicht

Öffentliche Methoden

public method Static ApplicationPath

Unterstützt von .NET Compact Framework

 Aktueller Applikationspfad

Globals -Klasse


Globals.ApplicationPath -Methode

Aktueller Applikationspfad

[Visual Basic]
Public Shared Function ApplicationPath() As String

Quellcode

[Visual Basic]
    Public Function ApplicationPath() As String
        Return Path.GetDirectoryName([Assembly].GetEntryAssembly().Location) + "\"
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Globals-Felder

Globals Übersicht

Felder

public field Static AppldataRow Unterstützt von .NET Compact Framework |
public field Static Applikationsdaten Unterstützt von .NET Compact Framework | Applikationsdaten
public field Static ConnectionFileName Unterstützt von .NET Compact Framework |
public field Static SecurityDaten Unterstützt von .NET Compact Framework |
public field Static Set_ToolTips Unterstützt von .NET Compact Framework |
public field Static Spaltendaten Unterstützt von .NET Compact Framework |
public field Static ToolTipDaten Unterstützt von .NET Compact Framework |
public field Static Version Unterstützt von .NET Compact Framework | Applikationsversion
public field Static Versionsdatum Unterstützt von .NET Compact Framework |
public field Static clsapplication Unterstützt von .NET Compact Framework | Applikationsparameter
public field Static clsmitarbeiter Unterstützt von .NET Compact Framework | Angemelderter Mitarbeiter
public field Static conn Unterstützt von .NET Compact Framework |
public field Static dbconn Unterstützt von .NET Compact Framework |
public field Static sConnectionString Unterstützt von .NET Compact Framework | DB-Verbindungsklasse

Globals -Klasse


AppldataRow -Feld

[Visual Basic]
Public Shared AppldataRow As Integer

Quellcode

[Visual Basic]
    Public AppldataRow As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Applikationsdaten -Feld

Applikationsdaten

[Visual Basic]
Public Shared Applikationsdaten As DataTable

Quellcode

[Visual Basic]
    Public Applikationsdaten As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


ConnectionFileName -Feld

[Visual Basic]
Public Shared ConnectionFileName As String

Quellcode

[Visual Basic]
    Public ConnectionFileName As String = ""

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


SecurityDaten -Feld

[Visual Basic]
Public Shared SecurityDaten As DataSet

Quellcode

[Visual Basic]
    Public SecurityDaten As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Set_ToolTips -Feld

[Visual Basic]
Public Shared Set_ToolTips As Boolean

Quellcode

[Visual Basic]
    Public Set_ToolTips As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Spaltendaten -Feld

[Visual Basic]
Public Shared Spaltendaten As DataTable

Quellcode

[Visual Basic]
    Public Spaltendaten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


ToolTipDaten -Feld

[Visual Basic]
Public Shared ToolTipDaten As DataSet

Quellcode

[Visual Basic]
    Public ToolTipDaten As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Version -Feld

Applikationsversion

[Visual Basic]
Public Shared Version As String

Quellcode

[Visual Basic]
    Public Version As String = "1.13"

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Versionsdatum -Feld

[Visual Basic]
Public Shared Versionsdatum As String

Quellcode

[Visual Basic]
    Public Versionsdatum As String = "08. November 2009"

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


clsapplication -Feld

Applikationsparameter

[Visual Basic]
Public Shared clsapplication As clsApplication

Quellcode

[Visual Basic]
    Public clsapplication As New TKB.VV.DB.clsApplication

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


clsmitarbeiter -Feld

Angemelderter Mitarbeiter

[Visual Basic]
Public Shared clsmitarbeiter As clsMitarbeiter

Quellcode

[Visual Basic]
    Public clsmitarbeiter As New TKB.VV.DB.clsMitarbeiter

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


conn -Feld

[Visual Basic]
Public Shared conn As clsConnectionProvider

Quellcode

[Visual Basic]
    Public conn As New TKB.VV.DB.clsConnectionProvider

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


dbconn -Feld

[Visual Basic]
Public Shared dbconn As DB_Connection

Quellcode

[Visual Basic]
    Public dbconn As New TKB.VV.DB.DB_Connection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


sConnectionString -Feld

DB-Verbindungsklasse

[Visual Basic]
Public Shared sConnectionString As String

Quellcode

[Visual Basic]
    Public sConnectionString As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Globals


Readme -Klasse

For a list of all members of this type, see Readme-Member.

[Visual Basic]
Friend Module Readme

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Readme-Member


Vertragsverwaltung.Controls -Namespace

Klassen

public class ComboBoxTree

Unterstützt von .NET Compact Framework
internal (Friend) class ComboBoxTreeClass

Unterstützt von .NET Compact Framework
internal (Friend) class ComboBoxTree_ComboBox

Unterstützt von .NET Compact Framework


ComboBoxTree -Klasse

For a list of all members of this type, see ComboBoxTree-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Vertragsverwaltung.Controls.ComboBoxTree

[Visual Basic]
<ToolboxBitmap(GetType(System.Windows.Forms.ComboBox))> _
<DefaultEvent("AfterSelect") _
   )> _
Public Class ComboBoxTree
    Inherits UserControl

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboBoxTree-Member


ComboBoxTree-Member

ComboBoxTree Übersicht

Öffentliche Konstruktoren

public constructor ComboBoxTree -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property BackColor

Unterstützt von .NET Compact Framework
public property BackgroundImage

Unterstützt von .NET Compact Framework
public property ContextMenu

Unterstützt von .NET Compact Framework
public property DropDownHeight

Unterstützt von .NET Compact Framework
public property DropDownWidth

Unterstützt von .NET Compact Framework
public property DroppedDown

Unterstützt von .NET Compact Framework
public property Enabled

Unterstützt von .NET Compact Framework
public property Font

Unterstützt von .NET Compact Framework
public property ForeColor

Unterstützt von .NET Compact Framework
public property Height

Unterstützt von .NET Compact Framework
public property ImageIndex

Unterstützt von .NET Compact Framework
public property ImageList

Unterstützt von .NET Compact Framework
public property ItemHeight

Unterstützt von .NET Compact Framework
public property SelectedImageIndex

Unterstützt von .NET Compact Framework
public property SelectedNode

Unterstützt von .NET Compact Framework
public property Size

Unterstützt von .NET Compact Framework
public property Width

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method TreeView

Unterstützt von .NET Compact Framework

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnParentChanged

Unterstützt von .NET Compact Framework

Andere Methoden

private method ComboBoxTree_KeyDown

Unterstützt von .NET Compact Framework
private method ComboBoxTree_KeyPress

Unterstützt von .NET Compact Framework
private method ComboBox_AfterSelect

Unterstützt von .NET Compact Framework
private method ComboBox_BeforeSelect

Unterstützt von .NET Compact Framework
private method ComboBox_CloseUp

Unterstützt von .NET Compact Framework
private method ComboBox_DropDown

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method UserControl_Resize

Unterstützt von .NET Compact Framework

Klassen

public class SelectEventArgs

Unterstützt von .NET Compact Framework

Felder

private field components

Unterstützt von .NET Compact Framework
private field p_DropDownWidth

Unterstützt von .NET Compact Framework

ComboBoxTree -Klasse


SelectEventArgs -Klasse

For a list of all members of this type, see SelectEventArgs-Member.

System.Object
Vertragsverwaltung.Controls.ComboBoxTree.SelectEventArgs

[Visual Basic]
Public Class SelectEventArgs

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

SelectEventArgs-Member | ComboBoxTree


SelectEventArgs-Member

SelectEventArgs Übersicht

Öffentliche Konstruktoren

public constructor SelectEventArgs -Konstructor

Unterstützt von .NET Compact Framework

Felder

public field Cancel

Unterstützt von .NET Compact Framework
public field Node

Unterstützt von .NET Compact Framework

SelectEventArgs -Klasse


SelectEventArgs -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal Node As TreeNode _
)

Parameter

Node

Quellcode

[Visual Basic]
            Public Sub New(ByVal Node As TreeNode)
                Me.Node = Node
                Me.Cancel = False
            End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

SelectEventArgs


SelectEventArgs-Felder

SelectEventArgs Übersicht

Felder

public field Cancel

Unterstützt von .NET Compact Framework
public field Node

Unterstützt von .NET Compact Framework

SelectEventArgs -Klasse


Cancel -Feld

[Visual Basic]
Public Cancel As Boolean

Quellcode

[Visual Basic]
            Public Cancel As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

SelectEventArgs


Node -Feld

[Visual Basic]
Public Node As TreeNode

Quellcode

[Visual Basic]
            Public Node As TreeNode

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

SelectEventArgs


ComboBoxTree -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            MyBase.New()

            'This call is required by the Windows Form Designer.
            InitializeComponent()

            'Add any initialization after the InitializeComponent() call

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree-Eigenschaften

ComboBoxTree Übersicht

Öffentliche Eigenschaften

public property BackColor

Unterstützt von .NET Compact Framework
public property BackgroundImage

Unterstützt von .NET Compact Framework
public property ContextMenu

Unterstützt von .NET Compact Framework
public property DropDownHeight

Unterstützt von .NET Compact Framework
public property DropDownWidth

Unterstützt von .NET Compact Framework
public property DroppedDown

Unterstützt von .NET Compact Framework
public property Enabled

Unterstützt von .NET Compact Framework
public property Font

Unterstützt von .NET Compact Framework
public property ForeColor

Unterstützt von .NET Compact Framework
public property Height

Unterstützt von .NET Compact Framework
public property ImageIndex

Unterstützt von .NET Compact Framework
public property ImageList

Unterstützt von .NET Compact Framework
public property ItemHeight

Unterstützt von .NET Compact Framework
public property SelectedImageIndex

Unterstützt von .NET Compact Framework
public property SelectedNode

Unterstützt von .NET Compact Framework
public property Size

Unterstützt von .NET Compact Framework
public property Width

Unterstützt von .NET Compact Framework

ComboBoxTree -Klasse


ComboBoxTree.BackColor -Eigenschaft

[Visual Basic]
<DefaultValue(GetType(Color), "Window") _
       )> _
Public Shadows Property BackColor() As Color

Quellcode

[Visual Basic]
        > Public Shadows Property BackColor() As System.Drawing.Color
            Get
                Return MyBase.BackColor
            End Get
            Set(ByVal Value As System.Drawing.Color)
                MyBase.BackColor = Value
                Me.ComboBox.BackColor = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.BackgroundImage -Eigenschaft

[Visual Basic]
<Browsable(False) _
       )> _
Public Shadows Property BackgroundImage() As Image

Quellcode

[Visual Basic]
        > Public Shadows Property BackgroundImage() As System.Drawing.Image
            Get
                Return MyBase.BackgroundImage
            End Get
            Set(ByVal Value As System.Drawing.Image)
                MyBase.BackgroundImage = Value
                Me.ComboBox.TreeView.BackgroundImage = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ContextMenu -Eigenschaft

[Visual Basic]
Public Shadows Property ContextMenu() As ContextMenu

Quellcode

[Visual Basic]
        Public Shadows Property ContextMenu() As System.Windows.Forms.ContextMenu
            Get
                Return MyBase.ContextMenu
            End Get
            Set(ByVal Value As System.Windows.Forms.ContextMenu)
                MyBase.ContextMenu = Value
                Me.ComboBox.ContextMenu = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.DropDownHeight -Eigenschaft

[Visual Basic]
<Category("Behavior")> _
<DefaultValue(194) _
       )> _
Public Property DropDownHeight() As Integer

Quellcode

[Visual Basic]
        > Public Property DropDownHeight() As Integer
            Get
                Return Me.ComboBox.TreeView.Height
            End Get
            Set(ByVal Value As Integer)
                If Value > 0 Then
                    Me.ComboBox.TreeView.Height = Value
                Else
                    Me.ComboBox.TreeView.Height = 194
                End If
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.DropDownWidth -Eigenschaft

[Visual Basic]
<Category("Behavior")> _
<DefaultValue(-1) _
       )> _
Public Property DropDownWidth() As Integer

Quellcode

[Visual Basic]
        > Public Property DropDownWidth() As Integer
            Get
                Return p_DropDownWidth
            End Get
            Set(ByVal Value As Integer)
                If Value <= 0 Then
                    p_DropDownWidth = -1
                    Me.ComboBox.TreeView.Width = Me.Width
                Else
                    p_DropDownWidth = Value
                    Me.ComboBox.TreeView.Width = p_DropDownWidth
                End If
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.DroppedDown -Eigenschaft

[Visual Basic]
<Browsable(False)> _
<DefaultValue(False) _
       )> _
Public Property DroppedDown() As Boolean

Quellcode

[Visual Basic]
        > Public Property DroppedDown() As Boolean
            Get
                Return Me.ComboBox.DroppedDown
            End Get
            Set(ByVal Value As Boolean)
                Me.ComboBox.DroppedDown = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Enabled -Eigenschaft

[Visual Basic]
Public Shadows Property Enabled() As Boolean

Quellcode

[Visual Basic]
        Public Shadows Property Enabled() As Boolean
            Get
                Return MyBase.Enabled
            End Get
            Set(ByVal Value As Boolean)
                MyBase.Enabled = Value
                Me.ComboBox.Enabled = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Font -Eigenschaft

[Visual Basic]
Public Shadows Property Font() As Font

Quellcode

[Visual Basic]
        Public Shadows Property Font() As System.Drawing.Font
            Get
                Return MyBase.Font
            End Get
            Set(ByVal Value As System.Drawing.Font)
                MyBase.Font = Value
                Me.ComboBox.Font = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ForeColor -Eigenschaft

[Visual Basic]
Public Shadows Property ForeColor() As Color

Quellcode

[Visual Basic]
        Public Shadows Property ForeColor() As System.Drawing.Color
            Get
                Return MyBase.ForeColor
            End Get
            Set(ByVal Value As System.Drawing.Color)
                MyBase.ForeColor = Value
                Me.ComboBox.ForeColor = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Height -Eigenschaft

[Visual Basic]
Public Shadows Property Height() As Integer

Quellcode

[Visual Basic]
        Public Shadows Property Height() As Integer
            Get
                Return MyBase.Height
            End Get
            Set(ByVal Value As Integer)
                Me.ComboBox.Height = Value
                MyBase.Height = Me.ComboBox.Height
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ImageIndex -Eigenschaft

[Visual Basic]
<Category("Behavior")> _
<DefaultValue(0) _
       )> _
Public Property ImageIndex() As Integer

Quellcode

[Visual Basic]
        > Public Property ImageIndex() As Integer
            Get
                Return Me.ComboBox.TreeView.ImageIndex
            End Get
            Set(ByVal Value As Integer)
                Me.ComboBox.TreeView.ImageIndex = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ImageList -Eigenschaft

[Visual Basic]
<Category("Behavior") _
       )> _
Public Property ImageList() As ImageList

Quellcode

[Visual Basic]
        > Public Property ImageList() As ImageList
            Get
                Return Me.ComboBox.TreeView.ImageList
            End Get
            Set(ByVal Value As ImageList)
                Me.ComboBox.TreeView.ImageList = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ItemHeight -Eigenschaft

[Visual Basic]
<Category("Behavior")> _
<DefaultValue(16) _
       )> _
Public Property ItemHeight() As Integer

Quellcode

[Visual Basic]
        > Public Property ItemHeight() As Integer
            Get
                Return Me.ComboBox.ItemHeight
            End Get
            Set(ByVal Value As Integer)
                If Value <= 0 Then Value = 16
                Me.ComboBox.ItemHeight = Value
                Me.Height = Me.ComboBox.Height
                Me.Invalidate()
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.SelectedImageIndex -Eigenschaft

[Visual Basic]
<Category("Behavior")> _
<DefaultValue(1) _
       )> _
Public Property SelectedImageIndex() As Integer

Quellcode

[Visual Basic]
        > Public Property SelectedImageIndex() As Integer
            Get
                Return Me.ComboBox.TreeView.SelectedImageIndex
            End Get
            Set(ByVal Value As Integer)
                Me.ComboBox.TreeView.SelectedImageIndex = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.SelectedNode -Eigenschaft

[Visual Basic]
<Browsable(False) _
       )> _
Public Property SelectedNode() As TreeNode

Quellcode

[Visual Basic]
        > Public Property SelectedNode() As TreeNode
            Get
                Return Me.ComboBox.SelectedItem
            End Get
            Set(ByVal Value As TreeNode)
                Me.ComboBox.SelectedItem = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Size -Eigenschaft

[Visual Basic]
Public Shadows Property Size() As Size

Quellcode

[Visual Basic]
        Public Shadows Property Size() As Drawing.Size
            Get
                Return MyBase.Size
            End Get
            Set(ByVal Value As Drawing.Size)
                MyBase.Size = New Size(Value.Width, Me.ComboBox.Height)
                If p_DropDownWidth <= 0 Then Me.ComboBox.TreeView.Width = Value.Width
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Width -Eigenschaft

[Visual Basic]
Public Shadows Property Width() As Integer

Quellcode

[Visual Basic]
        Public Shadows Property Width() As Integer
            Get
                Return MyBase.Width
            End Get
            Set(ByVal Value As Integer)
                MyBase.Width = Value
                If p_DropDownWidth <= 0 Then Me.ComboBox.TreeView.Width = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree-Methoden

ComboBoxTree Übersicht

Öffentliche Methoden

public method TreeView

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnParentChanged

Unterstützt von .NET Compact Framework

Andere Methoden

private method ComboBoxTree_KeyDown

Unterstützt von .NET Compact Framework
private method ComboBoxTree_KeyPress

Unterstützt von .NET Compact Framework
private method ComboBox_AfterSelect

Unterstützt von .NET Compact Framework
private method ComboBox_BeforeSelect

Unterstützt von .NET Compact Framework
private method ComboBox_CloseUp

Unterstützt von .NET Compact Framework
private method ComboBox_DropDown

Unterstützt von .NET Compact Framework
private method InitializeComponent

Unterstützt von .NET Compact Framework
private method UserControl_Resize

Unterstützt von .NET Compact Framework

ComboBoxTree -Klasse


ComboBoxTree.ComboBoxTree_KeyDown -Methode

[Visual Basic]
Private Sub ComboBoxTree_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   MyBase.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub ComboBoxTree_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles MyBase.KeyDown

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ComboBoxTree_KeyPress -Methode

[Visual Basic]
Private Sub ComboBoxTree_KeyPress( _
   ByVal sender As Object, _
   ByVal e As KeyPressEventArgs _
) Handles  _
   MyBase.KeyPress

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub ComboBoxTree_KeyPress(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyPressEventArgs) Handles MyBase.KeyPress

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ComboBox_AfterSelect -Methode

[Visual Basic]
Private Sub ComboBox_AfterSelect() Handles  _
   ComboBox.AfterSelect

Quellcode

[Visual Basic]
        Private Sub ComboBox_AfterSelect() Handles ComboBox.AfterSelect
            RaiseEvent AfterSelect(Me)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ComboBox_BeforeSelect -Methode

[Visual Basic]
Private Sub ComboBox_BeforeSelect( _
   ByVal Node As TreeNode, _
   ByRef Cancel As Boolean _
) Handles  _
   ComboBox.BeforeSelect

Parameter

Node
Cancel

Quellcode

[Visual Basic]
        Private Sub ComboBox_BeforeSelect(ByVal Node As System.Windows.Forms.TreeNode, ByRef Cancel As Boolean) Handles ComboBox.BeforeSelect
            RaiseEvent BeforeSelect(Me, Node, Cancel)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ComboBox_CloseUp -Methode

[Visual Basic]
Private Sub ComboBox_CloseUp() Handles  _
   ComboBox.CloseUp

Quellcode

[Visual Basic]
        Private Sub ComboBox_CloseUp() Handles ComboBox.CloseUp
            RaiseEvent CloseUp(Me)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.ComboBox_DropDown -Methode

[Visual Basic]
Private Sub ComboBox_DropDown() Handles  _
   ComboBox.DropDown

Quellcode

[Visual Basic]
        Private Sub ComboBox_DropDown() Handles ComboBox.DropDown
            RaiseEvent DropDown(Me)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.Dispose -Methode

[Visual Basic]
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
        Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
            If disposing Then
                If Not (components Is Nothing) Then
                    components.Dispose()
                End If
            End If
            MyBase.Dispose(disposing)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.InitializeComponent -Methode

[Visual Basic]
<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
        <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
            Me.ComboBox = New ComboBoxTree_ComboBox
            Me.SuspendLayout()
            '
            'ComboBox
            '
            Me.ComboBox.Dock = System.Windows.Forms.DockStyle.Top
            Me.ComboBox.DrawMode = System.Windows.Forms.DrawMode.OwnerDrawFixed
            Me.ComboBox.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
            Me.ComboBox.ItemHeight = 16
            Me.ComboBox.Location = New System.Drawing.Point(0, 0)
            Me.ComboBox.Name = "ComboBox"
            Me.ComboBox.SelectedItem = Nothing
            Me.ComboBox.Size = New System.Drawing.Size(384, 22)
            Me.ComboBox.TabIndex = 0
            '
            'ComboBoxTree
            '
            Me.BackColor = System.Drawing.SystemColors.Window
            Me.Controls.Add(Me.ComboBox)
            Me.Name = "ComboBoxTree"
            Me.Size = New System.Drawing.Size(384, 72)
            Me.ResumeLayout(False)

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.OnCreateControl -Methode

[Visual Basic]
Protected Overrides Sub OnCreateControl()

Quellcode

[Visual Basic]
        Protected Overrides Sub OnCreateControl()
            MyBase.BackColor = System.Drawing.SystemColors.Window
            Me.ComboBox.BackColor = MyBase.BackColor
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.OnParentChanged -Methode

[Visual Basic]
Protected Overrides Sub OnParentChanged( _
   ByVal e As EventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnParentChanged(ByVal e As System.EventArgs)
            Me.ComboBox.TreeView.Parent = Me.Parent
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.TreeView -Methode

[Visual Basic]
Public Function TreeView() As TreeView

Quellcode

[Visual Basic]
        Public Function TreeView() As TreeView
            Return Me.ComboBox.TreeView
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree.UserControl_Resize -Methode

[Visual Basic]
Private Sub UserControl_Resize( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   MyBase.Resize

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub UserControl_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
            Me.Height = Me.ComboBox.Height
            Me.ComboBox.TreeView.Left = Me.Left
            Me.ComboBox.TreeView.Top = Me.Top + Me.Height
            If p_DropDownWidth <= 0 Then Me.ComboBox.TreeView.Width = Me.Width
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree-Ereignisse

ComboBoxTree Übersicht

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

ComboBoxTree -Klasse


AfterSelect -Ereignis

[Visual Basic]
Public Event AfterSelect( _
   ByVal sender As Object _
)

Parameter

sender

Quellcode

[Visual Basic]
        Public Event AfterSelect(ByVal sender As Object)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


BeforeSelect -Ereignis

[Visual Basic]
Public Event BeforeSelect( _
   ByVal sender As Object, _
   ByVal Node As TreeNode, _
   ByRef Cancel As Boolean _
)

Parameter

sender
Node
Cancel

Quellcode

[Visual Basic]
        Public Event BeforeSelect(ByVal sender As Object, ByVal Node As TreeNode, ByRef Cancel As Boolean)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


CloseUp -Ereignis

[Visual Basic]
Public Event CloseUp( _
   ByVal sender As Object _
)

Parameter

sender

Quellcode

[Visual Basic]
        Public Event CloseUp(ByVal sender As Object)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


DropDown -Ereignis

[Visual Basic]
Public Event DropDown( _
   ByVal sender As Object _
)

Parameter

sender

Quellcode

[Visual Basic]
        Public Event DropDown(ByVal sender As Object)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTree-Felder

ComboBoxTree Übersicht

Felder

private field components

Unterstützt von .NET Compact Framework
private field p_DropDownWidth

Unterstützt von .NET Compact Framework

ComboBoxTree -Klasse


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
        Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


p_DropDownWidth -Feld

[Visual Basic]
Private p_DropDownWidth As Integer

Quellcode

[Visual Basic]
        Private p_DropDownWidth As Integer = -1

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree


ComboBoxTreeClass -Klasse

For a list of all members of this type, see ComboBoxTreeClass-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Vertragsverwaltung.Controls.ComboBoxTreeClass

[Visual Basic]
Friend Class ComboBoxTreeClass
    Inherits ComboBox

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboBoxTreeClass-Member


ComboBoxTreeClass-Member

ComboBoxTreeClass Übersicht

Öffentliche Konstruktoren

public constructor ComboBoxTreeClass -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property DroppedDown

Unterstützt von .NET Compact Framework
public property SelectedItem

Unterstützt von .NET Compact Framework

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnClick

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnDrawItem

Unterstützt von .NET Compact Framework
protected method OnDropDown

Unterstützt von .NET Compact Framework
protected method OnKeyDown

Unterstützt von .NET Compact Framework
protected method WndProc

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Static ShowWindow

Unterstützt von .NET Compact Framework
private method TreeView_AfterSelect

Unterstützt von .NET Compact Framework
private method TreeView_BeforeSelect

Unterstützt von .NET Compact Framework
private method TreeView_KeyDown

Unterstützt von .NET Compact Framework
private method TreeView_KeyPress

Unterstützt von .NET Compact Framework
private method TreeView_Leave

Unterstützt von .NET Compact Framework
private method TreeView_MouseLeave

Unterstützt von .NET Compact Framework
private method TreeView_VisibleChanged

Unterstützt von .NET Compact Framework

Klassen

private class TreeNodeEx

Unterstützt von .NET Compact Framework

Felder

private field FocusOnMouseLeave

Unterstützt von .NET Compact Framework
private field FocusOnVisibleChanged

Unterstützt von .NET Compact Framework
private field IsDroppingDown

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

ComboBoxTreeClass -Klasse


TreeNodeEx -Klasse

For a list of all members of this type, see TreeNodeEx-Member.

System.Object
Vertragsverwaltung.Controls.ComboBoxTreeClass.TreeNodeEx

[Visual Basic]
Private Class TreeNodeEx

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

TreeNodeEx-Member | ComboBoxTreeClass


TreeNodeEx-Member

TreeNodeEx Übersicht

Öffentliche Konstruktoren

public constructor TreeNodeEx -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method ToString

Unterstützt von .NET Compact Framework

Felder

public field TreeNode

Unterstützt von .NET Compact Framework

TreeNodeEx -Klasse


TreeNodeEx -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal Node As TreeNode _
)

Parameter

Node

Quellcode

[Visual Basic]
            Public Sub New(ByVal Node As TreeNode)
                Me.TreeNode = Node
            End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TreeNodeEx


TreeNodeEx-Methoden

TreeNodeEx Übersicht

Öffentliche Methoden

public method ToString

Unterstützt von .NET Compact Framework

TreeNodeEx -Klasse


TreeNodeEx.ToString -Methode

[Visual Basic]
Public Overrides Function ToString() As String

Quellcode

[Visual Basic]
            Public Overrides Function ToString() As String
                Return Me.TreeNode.Text
            End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TreeNodeEx


TreeNodeEx-Felder

TreeNodeEx Übersicht

Felder

public field TreeNode

Unterstützt von .NET Compact Framework

TreeNodeEx -Klasse


TreeNode -Feld

[Visual Basic]
Public TreeNode As TreeNode

Quellcode

[Visual Basic]
            Public TreeNode As TreeNode

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

TreeNodeEx


ComboBoxTreeClass -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            MyBase.New()

            'This call is required by the Windows Form Designer.
            InitializeComponent()

            'Add any initialization after the InitializeComponent() call

            Me.DrawMode = DrawMode.OwnerDrawFixed
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass-Eigenschaften

ComboBoxTreeClass Übersicht

Öffentliche Eigenschaften

public property DroppedDown

Unterstützt von .NET Compact Framework
public property SelectedItem

Unterstützt von .NET Compact Framework

ComboBoxTreeClass -Klasse


ComboBoxTreeClass.DroppedDown -Eigenschaft

[Visual Basic]
Public Shadows Property DroppedDown() As Boolean

Quellcode

[Visual Basic]
        Public Shadows Property DroppedDown() As Boolean
            Get
                Return Me.TreeView.Visible
            End Get
            Set(ByVal Value As Boolean)
                If IsDroppingDown Then Exit Property
                IsDroppingDown = True
                If Value Then
                    If Not Me.TreeView.Visible Then
                        Me.TreeView.BringToFront()
                        Me.TreeView.Show()
                        Me.Focus()
                        Me.TreeView.Focus()
                        RaiseEvent DropDown()
                    End If
                ElseIf Me.TreeView.Visible Then
                    Me.TreeView.Hide()
                    RaiseEvent CloseUp()
                End If
                IsDroppingDown = False
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.SelectedItem -Eigenschaft

[Visual Basic]
Public Shadows Property SelectedItem() As TreeNode

Quellcode

[Visual Basic]
        Public Shadows Property SelectedItem() As TreeNode
            Get
                Dim CurrentSelection As TreeNodeEx = MyBase.SelectedItem
                If CurrentSelection Is Nothing Then
                    Return Nothing
                Else
                    Return CurrentSelection.TreeNode
                End If
            End Get
            Set(ByVal Value As TreeNode)
                If Value Is Nothing Then
                    Dim Cancel As Boolean = False
                    RaiseEvent BeforeSelect(Nothing, Cancel)
                    If Cancel Then Exit Property
                    Me.TreeView.SelectedNode = Nothing
                    Me.Items.Clear()
                    RaiseEvent AfterSelect()
                Else
                    Me.TreeView.SelectedNode = Value
                End If
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass-Methoden

ComboBoxTreeClass Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnClick

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnDrawItem

Unterstützt von .NET Compact Framework
protected method OnDropDown

Unterstützt von .NET Compact Framework
protected method OnKeyDown

Unterstützt von .NET Compact Framework
protected method WndProc

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Static ShowWindow

Unterstützt von .NET Compact Framework
private method TreeView_AfterSelect

Unterstützt von .NET Compact Framework
private method TreeView_BeforeSelect

Unterstützt von .NET Compact Framework
private method TreeView_KeyDown

Unterstützt von .NET Compact Framework
private method TreeView_KeyPress

Unterstützt von .NET Compact Framework
private method TreeView_Leave

Unterstützt von .NET Compact Framework
private method TreeView_MouseLeave

Unterstützt von .NET Compact Framework
private method TreeView_VisibleChanged

Unterstützt von .NET Compact Framework

ComboBoxTreeClass -Klasse


ComboBoxTreeClass.Dispose -Methode

[Visual Basic]
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
        Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
            If disposing Then
                If Not (components Is Nothing) Then
                    components.Dispose()
                End If
            End If
            MyBase.Dispose(disposing)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.InitializeComponent -Methode

[Visual Basic]
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
        Private Sub InitializeComponent()
            components = New System.ComponentModel.Container
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.OnClick -Methode

[Visual Basic]
Protected Overrides Sub OnClick( _
   ByVal e As EventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnClick(ByVal e As System.EventArgs)
            If Me.DroppedDown Then
                Me.DroppedDown = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.OnCreateControl -Methode

[Visual Basic]
Protected Overrides Sub OnCreateControl()

Quellcode

[Visual Basic]
        Protected Overrides Sub OnCreateControl()
            Me.TreeView.Visible = False
            Me.TreeView.Height = 194
            Me.TreeView.ImageIndex = 0
            Me.TreeView.SelectedImageIndex = 1
            Me.TreeView.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
            Me.TreeView.TabIndex = Me.TabIndex
            Me.TreeView.TabStop = False
            Me.TreeView.HideSelection = False
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.OnDrawItem -Methode

[Visual Basic]
Protected Overrides Sub OnDrawItem( _
   ByVal e As DrawItemEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnDrawItem(ByVal e As System.Windows.Forms.DrawItemEventArgs)
            If e.Index = -1 Then Return

            ' Draw only the combo edit box
            If (e.State And DrawItemState.ComboBoxEdit) <> DrawItemState.ComboBoxEdit Then Return

            Dim ComboBoxSelection As TreeNodeEx

            Try
                ComboBoxSelection = CType(Me.Items(e.Index), TreeNodeEx)

                e.DrawFocusRectangle()
                e.DrawBackground()

                Dim TextLeft As Integer = e.Bounds.Left

                If Not Me.TreeView.ImageList Is Nothing Then
                    Dim ImageIndex As Integer = ComboBoxSelection.TreeNode.SelectedImageIndex
                    If ImageIndex < 0 Then ImageIndex = Me.TreeView.SelectedImageIndex
                    If ImageIndex >= 0 Then
                        Dim IconRectangle As Rectangle

                        If Me.TreeView.ImageList.ImageSize.Height > Me.ItemHeight Then
                            IconRectangle = New Rectangle(e.Bounds.Left + 2, e.Bounds.Top, Me.ItemHeight, Me.ItemHeight)
                        Else
                            IconRectangle = New Rectangle(New Point(e.Bounds.Left + 2, e.Bounds.Top), Me.TreeView.ImageList.ImageSize)
                        End If

                        Me.TreeView.ImageList.Draw(e.Graphics, IconRectangle.Left, IconRectangle.Top, IconRectangle.Width, IconRectangle.Height, ImageIndex)
                        TextLeft = TextLeft + IconRectangle.Width + 2

                        IconRectangle = Nothing
                    End If
                End If

                e.Graphics.DrawString(ComboBoxSelection.TreeNode.Text, Me.Font, New SolidBrush(e.ForeColor), TextLeft, e.Bounds.Top + 2)
            Catch ex As Exception
                Throw ex
            Finally
                ComboBoxSelection = Nothing
                MyBase.OnDrawItem(e)
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.OnDropDown -Methode

[Visual Basic]
Protected Overrides Sub OnDropDown( _
   ByVal e As EventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnDropDown(ByVal e As System.EventArgs)
            If Not Me.DroppedDown Then Me.DroppedDown = True
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.OnKeyDown -Methode

[Visual Basic]
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnKeyDown(ByVal e As System.Windows.Forms.KeyEventArgs)
            If ((e.KeyCode = Keys.Up) OrElse (e.KeyCode = Keys.Down)) AndAlso (e.Modifiers = Keys.Alt) Then
                e.Handled = True
                Me.DroppedDown = True
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.ShowWindow -Methode

[Visual Basic]
Private Declare Ansi Function ShowWindow Lib "user32" ( _
   ByVal hWnd As IntPtr, _
   ByVal nCmdShow As Integer _
) As Integer

Parameter

hWnd
nCmdShow

Quellcode

[Visual Basic]
        Private Declare Function ShowWindow Lib "user32" (ByVal hWnd As IntPtr, ByVal nCmdShow As Integer) As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_AfterSelect -Methode

[Visual Basic]
Private Sub TreeView_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeView.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView.AfterSelect
            Me.Items.Clear()
            Me.Items.Add(New TreeNodeEx(e.Node))
            Me.SelectedIndex = 0

            If e.Action = TreeViewAction.ByMouse Then
                FocusOnMouseLeave = True
                Me.DroppedDown = False
            End If

            RaiseEvent AfterSelect()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_BeforeSelect -Methode

[Visual Basic]
Private Sub TreeView_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewCancelEventArgs _
) Handles  _
   TreeView.BeforeSelect

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView.BeforeSelect
            RaiseEvent BeforeSelect(e.Node, e.Cancel)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_KeyDown -Methode

[Visual Basic]
Private Sub TreeView_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TreeView.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TreeView.KeyDown
            If ((e.KeyCode = Keys.Up) OrElse (e.KeyCode = Keys.Down)) AndAlso (e.Modifiers = Keys.Alt) Then
                e.Handled = True
                FocusOnVisibleChanged = True
                Me.DroppedDown = False
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_KeyPress -Methode

[Visual Basic]
Private Sub TreeView_KeyPress( _
   ByVal sender As Object, _
   ByVal e As KeyPressEventArgs _
) Handles  _
   TreeView.KeyPress

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_KeyPress(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyPressEventArgs) Handles TreeView.KeyPress
            If (e.KeyChar = ControlChars.Cr) OrElse (e.KeyChar = ChrW(System.Windows.Forms.Keys.Escape)) Then
                e.Handled = True
                FocusOnVisibleChanged = True
                Me.DroppedDown = False
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_Leave -Methode

[Visual Basic]
Private Sub TreeView_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.Leave
            If Not Me.Focused Then Me.DroppedDown = False
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_MouseLeave -Methode

[Visual Basic]
Private Sub TreeView_MouseLeave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.MouseLeave

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_MouseLeave(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.MouseLeave
            If FocusOnMouseLeave Then
                FocusOnMouseLeave = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.TreeView_VisibleChanged -Methode

[Visual Basic]
Private Sub TreeView_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.VisibleChanged

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.VisibleChanged
            If FocusOnVisibleChanged Then
                FocusOnVisibleChanged = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass.WndProc -Methode

[Visual Basic]
Protected Overrides Sub WndProc( _
   ByRef m As Message _
)

Parameter

m

Quellcode

[Visual Basic]
        Protected Overrides Sub WndProc(ByRef m As System.Windows.Forms.Message)
            ' Hide the standard dropdown window of the combobox control
            If m.Msg = WM_CTLCOLORLISTBOX Then
                Call ShowWindow(m.LParam, SW_HIDE)
                'ElseIf m.Msg = OCM_COMMAND Then
                '    Select Case HiWord(m.WParam.ToInt32)
                '        Case CBN_CLOSEUP
                '        Case CBN_DROPDOWN
                '    End Select
            End If
            MyBase.WndProc(m)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass-Ereignisse

ComboBoxTreeClass Übersicht

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

ComboBoxTreeClass -Klasse


AfterSelect -Ereignis

[Visual Basic]
Public Event AfterSelect()

Quellcode

[Visual Basic]
        Public Event AfterSelect()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


BeforeSelect -Ereignis

[Visual Basic]
Public Event BeforeSelect( _
   ByVal Node As TreeNode, _
   ByRef Cancel As Boolean _
)

Parameter

Node
Cancel

Quellcode

[Visual Basic]
        Public Event BeforeSelect(ByVal Node As TreeNode, ByRef Cancel As Boolean)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


CloseUp -Ereignis

[Visual Basic]
Public Shadows Event CloseUp()

Quellcode

[Visual Basic]
        Public Shadows Event CloseUp()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


DropDown -Ereignis

[Visual Basic]
Public Shadows Event DropDown()

Quellcode

[Visual Basic]
        Public Shadows Event DropDown()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTreeClass-Felder

ComboBoxTreeClass Übersicht

Felder

private field FocusOnMouseLeave

Unterstützt von .NET Compact Framework
private field FocusOnVisibleChanged

Unterstützt von .NET Compact Framework
private field IsDroppingDown

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

ComboBoxTreeClass -Klasse


FocusOnMouseLeave -Feld

[Visual Basic]
Private FocusOnMouseLeave As Boolean

Quellcode

[Visual Basic]
        Private FocusOnMouseLeave As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


FocusOnVisibleChanged -Feld

[Visual Basic]
Private FocusOnVisibleChanged As Boolean

Quellcode

[Visual Basic]
        Private FocusOnVisibleChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


IsDroppingDown -Feld

[Visual Basic]
Private IsDroppingDown As Boolean

Quellcode

[Visual Basic]
        Private IsDroppingDown As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
        Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTreeClass


ComboBoxTree_ComboBox -Klasse

For a list of all members of this type, see ComboBoxTree_ComboBox-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Vertragsverwaltung.Controls.ComboBoxTree_ComboBox

[Visual Basic]
Friend Class ComboBoxTree_ComboBox
    Inherits ComboBox

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ComboBoxTree_ComboBox-Member


ComboBoxTree_ComboBox-Member

ComboBoxTree_ComboBox Übersicht

Öffentliche Konstruktoren

public constructor ComboBoxTree_ComboBox -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property DroppedDown

Unterstützt von .NET Compact Framework
public property SelectedItem

Unterstützt von .NET Compact Framework
public property SelectedValue

Unterstützt von .NET Compact Framework

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnClick

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnDrawItem

Unterstützt von .NET Compact Framework
protected method OnDropDown

Unterstützt von .NET Compact Framework
protected method OnKeyDown

Unterstützt von .NET Compact Framework
protected method WndProc

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Static ShowWindow

Unterstützt von .NET Compact Framework
private method TreeView_AfterSelect

Unterstützt von .NET Compact Framework
private method TreeView_BeforeSelect

Unterstützt von .NET Compact Framework
private method TreeView_KeyDown

Unterstützt von .NET Compact Framework
private method TreeView_KeyPress

Unterstützt von .NET Compact Framework
private method TreeView_Leave

Unterstützt von .NET Compact Framework
private method TreeView_MouseLeave

Unterstützt von .NET Compact Framework
private method TreeView_VisibleChanged

Unterstützt von .NET Compact Framework

Klassen

private class TreeNodeEx

Unterstützt von .NET Compact Framework

Felder

private field FocusOnMouseLeave

Unterstützt von .NET Compact Framework
private field FocusOnVisibleChanged

Unterstützt von .NET Compact Framework
private field IsDroppingDown

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

ComboBoxTree_ComboBox -Klasse


TreeNodeEx -Klasse

For a list of all members of this type, see TreeNodeEx-Member.

System.Object
Vertragsverwaltung.Controls.ComboBoxTree_ComboBox.TreeNodeEx

[Visual Basic]
Private Class TreeNodeEx

Forderungen

Namespace: Vertragsverwaltung.Controls

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

TreeNodeEx-Member | ComboBoxTree_ComboBox


ComboBoxTree_ComboBox -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            MyBase.New()

            'This call is required by the Windows Form Designer.
            InitializeComponent()

            'Add any initialization after the InitializeComponent() call

            Me.DrawMode = DrawMode.OwnerDrawFixed
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox-Eigenschaften

ComboBoxTree_ComboBox Übersicht

Öffentliche Eigenschaften

public property DroppedDown

Unterstützt von .NET Compact Framework
public property SelectedItem

Unterstützt von .NET Compact Framework
public property SelectedValue

Unterstützt von .NET Compact Framework

ComboBoxTree_ComboBox -Klasse


ComboBoxTree_ComboBox.DroppedDown -Eigenschaft

[Visual Basic]
Public Shadows Property DroppedDown() As Boolean

Quellcode

[Visual Basic]
        Public Shadows Property DroppedDown() As Boolean
            Get
                Return Me.TreeView.Visible
            End Get
            Set(ByVal Value As Boolean)
                If IsDroppingDown Then Exit Property
                IsDroppingDown = True
                If Value Then
                    If Not Me.TreeView.Visible Then
                        Me.TreeView.BringToFront()
                        Me.TreeView.Show()
                        Me.Focus()
                        Me.TreeView.Focus()
                        RaiseEvent DropDown()
                    End If
                ElseIf Me.TreeView.Visible Then
                    Me.TreeView.Hide()
                    RaiseEvent CloseUp()
                End If
                IsDroppingDown = False
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.SelectedItem -Eigenschaft

[Visual Basic]
Public Shadows Property SelectedItem() As TreeNode

Quellcode

[Visual Basic]
        Public Shadows Property SelectedItem() As TreeNode
            Get
                Dim CurrentSelection As TreeNodeEx = MyBase.SelectedItem
                If CurrentSelection Is Nothing Then
                    Return Nothing
                Else
                    Return CurrentSelection.TreeNode
                End If
            End Get
            Set(ByVal Value As TreeNode)
                If Value Is Nothing Then
                    Dim Cancel As Boolean = False
                    RaiseEvent BeforeSelect(Nothing, Cancel)
                    If Cancel Then Exit Property
                    Me.TreeView.SelectedNode = Nothing
                    Me.Items.Clear()
                    RaiseEvent AfterSelect()
                Else
                    Me.TreeView.SelectedNode = Value
                End If
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.SelectedValue -Eigenschaft

[Visual Basic]
Public Shadows Property SelectedValue() As Object

Quellcode

[Visual Basic]
        Public Shadows Property SelectedValue() As Object
            Get
                Dim currentselection As TreeNodeEx = MyBase.SelectedItem
                If currentselection Is Nothing Then
                    Return Nothing
                Else
                    Return currentselection.TreeNode.Tag
                End If
            End Get
            Set(ByVal value As Object)

            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox-Methoden

ComboBoxTree_ComboBox Übersicht

Geschützte Methoden

protected method Dispose

Unterstützt von .NET Compact Framework
protected method OnClick

Unterstützt von .NET Compact Framework
protected method OnCreateControl

Unterstützt von .NET Compact Framework
protected method OnDrawItem

Unterstützt von .NET Compact Framework
protected method OnDropDown

Unterstützt von .NET Compact Framework
protected method OnKeyDown

Unterstützt von .NET Compact Framework
protected method WndProc

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitializeComponent

Unterstützt von .NET Compact Framework
private method Static ShowWindow

Unterstützt von .NET Compact Framework
private method TreeView_AfterSelect

Unterstützt von .NET Compact Framework
private method TreeView_BeforeSelect

Unterstützt von .NET Compact Framework
private method TreeView_KeyDown

Unterstützt von .NET Compact Framework
private method TreeView_KeyPress

Unterstützt von .NET Compact Framework
private method TreeView_Leave

Unterstützt von .NET Compact Framework
private method TreeView_MouseLeave

Unterstützt von .NET Compact Framework
private method TreeView_VisibleChanged

Unterstützt von .NET Compact Framework

ComboBoxTree_ComboBox -Klasse


ComboBoxTree_ComboBox.Dispose -Methode

[Visual Basic]
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
        Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
            If disposing Then
                If Not (components Is Nothing) Then
                    components.Dispose()
                End If
            End If
            MyBase.Dispose(disposing)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.InitializeComponent -Methode

[Visual Basic]
Private Sub InitializeComponent()

Quellcode

[Visual Basic]
        Private Sub InitializeComponent()
            components = New System.ComponentModel.Container
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.OnClick -Methode

[Visual Basic]
Protected Overrides Sub OnClick( _
   ByVal e As EventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnClick(ByVal e As System.EventArgs)
            If Me.DroppedDown Then
                Me.DroppedDown = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.OnCreateControl -Methode

[Visual Basic]
Protected Overrides Sub OnCreateControl()

Quellcode

[Visual Basic]
        Protected Overrides Sub OnCreateControl()
            Me.TreeView.Visible = False
            Me.TreeView.Height = 194
            Me.TreeView.ImageIndex = 0
            Me.TreeView.SelectedImageIndex = 1
            Me.TreeView.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
            Me.TreeView.TabIndex = Me.TabIndex
            Me.TreeView.TabStop = False
            Me.TreeView.HideSelection = False
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.OnDrawItem -Methode

[Visual Basic]
Protected Overrides Sub OnDrawItem( _
   ByVal e As DrawItemEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnDrawItem(ByVal e As System.Windows.Forms.DrawItemEventArgs)
            If e.Index = -1 Then Return

            ' Draw only the combo edit box
            If (e.State And DrawItemState.ComboBoxEdit) <> DrawItemState.ComboBoxEdit Then Return

            Dim ComboBoxSelection As TreeNodeEx

            Try
                ComboBoxSelection = CType(Me.Items(e.Index), TreeNodeEx)

                e.DrawFocusRectangle()
                e.DrawBackground()

                Dim TextLeft As Integer = e.Bounds.Left

                If Not Me.TreeView.ImageList Is Nothing Then
                    Dim ImageIndex As Integer = ComboBoxSelection.TreeNode.SelectedImageIndex
                    If ImageIndex < 0 Then ImageIndex = Me.TreeView.SelectedImageIndex
                    If ImageIndex >= 0 Then
                        Dim IconRectangle As Rectangle

                        If Me.TreeView.ImageList.ImageSize.Height > Me.ItemHeight Then
                            IconRectangle = New Rectangle(e.Bounds.Left + 2, e.Bounds.Top, Me.ItemHeight, Me.ItemHeight)
                        Else
                            IconRectangle = New Rectangle(New Point(e.Bounds.Left + 2, e.Bounds.Top), Me.TreeView.ImageList.ImageSize)
                        End If

                        Me.TreeView.ImageList.Draw(e.Graphics, IconRectangle.Left, IconRectangle.Top, IconRectangle.Width, IconRectangle.Height, ImageIndex)
                        TextLeft = TextLeft + IconRectangle.Width + 2

                        IconRectangle = Nothing
                    End If
                End If

                e.Graphics.DrawString(ComboBoxSelection.TreeNode.Text, Me.Font, New SolidBrush(e.ForeColor), TextLeft, e.Bounds.Top + 2)
            Catch ex As Exception
                'Throw ex
            Finally
                ComboBoxSelection = Nothing
                MyBase.OnDrawItem(e)
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.OnDropDown -Methode

[Visual Basic]
Protected Overrides Sub OnDropDown( _
   ByVal e As EventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnDropDown(ByVal e As System.EventArgs)
            If Not Me.DroppedDown Then Me.DroppedDown = True
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.OnKeyDown -Methode

[Visual Basic]
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnKeyDown(ByVal e As System.Windows.Forms.KeyEventArgs)
            If ((e.KeyCode = Keys.Up) OrElse (e.KeyCode = Keys.Down)) AndAlso (e.Modifiers = Keys.Alt) Then
                e.Handled = True
                Me.DroppedDown = True
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.ShowWindow -Methode

[Visual Basic]
Private Declare Ansi Function ShowWindow Lib "user32" ( _
   ByVal hWnd As IntPtr, _
   ByVal nCmdShow As Integer _
) As Integer

Parameter

hWnd
nCmdShow

Quellcode

[Visual Basic]
        Private Declare Function ShowWindow Lib "user32" (ByVal hWnd As IntPtr, ByVal nCmdShow As Integer) As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_AfterSelect -Methode

[Visual Basic]
Private Sub TreeView_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
) Handles  _
   TreeView.AfterSelect

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView.AfterSelect
            Me.Items.Clear()
            Me.Items.Add(New TreeNodeEx(e.Node))
            Me.SelectedIndex = 0

            If e.Action = TreeViewAction.ByMouse Then
                FocusOnMouseLeave = True
                Me.DroppedDown = False
            End If

            RaiseEvent AfterSelect()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_BeforeSelect -Methode

[Visual Basic]
Private Sub TreeView_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As TreeViewCancelEventArgs _
) Handles  _
   TreeView.BeforeSelect

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView.BeforeSelect
            RaiseEvent BeforeSelect(e.Node, e.Cancel)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_KeyDown -Methode

[Visual Basic]
Private Sub TreeView_KeyDown( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
) Handles  _
   TreeView.KeyDown

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TreeView.KeyDown
            If ((e.KeyCode = Keys.Up) OrElse (e.KeyCode = Keys.Down)) AndAlso (e.Modifiers = Keys.Alt) Then
                e.Handled = True
                FocusOnVisibleChanged = True
                Me.DroppedDown = False
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_KeyPress -Methode

[Visual Basic]
Private Sub TreeView_KeyPress( _
   ByVal sender As Object, _
   ByVal e As KeyPressEventArgs _
) Handles  _
   TreeView.KeyPress

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_KeyPress(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyPressEventArgs) Handles TreeView.KeyPress
            If (e.KeyChar = ChrW(System.Windows.Forms.Keys.Enter)) OrElse (e.KeyChar = ChrW(System.Windows.Forms.Keys.Escape)) Then
                e.Handled = True
                FocusOnVisibleChanged = True
                Me.DroppedDown = False
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_Leave -Methode

[Visual Basic]
Private Sub TreeView_Leave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.Leave

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.Leave
            If Not Me.Focused Then Me.DroppedDown = False
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_MouseLeave -Methode

[Visual Basic]
Private Sub TreeView_MouseLeave( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.MouseLeave

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_MouseLeave(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.MouseLeave
            If FocusOnMouseLeave Then
                FocusOnMouseLeave = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.TreeView_VisibleChanged -Methode

[Visual Basic]
Private Sub TreeView_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
) Handles  _
   TreeView.VisibleChanged

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub TreeView_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeView.VisibleChanged
            If FocusOnVisibleChanged Then
                FocusOnVisibleChanged = False
                Me.Focus()
                Me.FindForm.Focus()
                Me.Focus()
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox.WndProc -Methode

[Visual Basic]
Protected Overrides Sub WndProc( _
   ByRef m As Message _
)

Parameter

m

Quellcode

[Visual Basic]
        Protected Overrides Sub WndProc(ByRef m As System.Windows.Forms.Message)
            ' Hide the standard dropdown window of the combobox control
            If m.Msg = WM_CTLCOLORLISTBOX Then
                Call ShowWindow(m.LParam, SW_HIDE)
                'ElseIf m.Msg = OCM_COMMAND Then
                '    Select Case HiWord(m.WParam.ToInt32)
                '        Case CBN_CLOSEUP
                '        Case CBN_DROPDOWN
                '    End Select
            End If
            MyBase.WndProc(m)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox-Ereignisse

ComboBoxTree_ComboBox Übersicht

Öffentliche Ereignisse

public event AfterSelect

Unterstützt von .NET Compact Framework
public event BeforeSelect

Unterstützt von .NET Compact Framework
public event CloseUp

Unterstützt von .NET Compact Framework
public event DropDown

Unterstützt von .NET Compact Framework

ComboBoxTree_ComboBox -Klasse


AfterSelect -Ereignis

[Visual Basic]
Public Event AfterSelect()

Quellcode

[Visual Basic]
        Public Event AfterSelect()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


BeforeSelect -Ereignis

[Visual Basic]
Public Event BeforeSelect( _
   ByVal Node As TreeNode, _
   ByRef Cancel As Boolean _
)

Parameter

Node
Cancel

Quellcode

[Visual Basic]
        Public Event BeforeSelect(ByVal Node As TreeNode, ByRef Cancel As Boolean)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


CloseUp -Ereignis

[Visual Basic]
Public Shadows Event CloseUp()

Quellcode

[Visual Basic]
        Public Shadows Event CloseUp()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


DropDown -Ereignis

[Visual Basic]
Public Shadows Event DropDown()

Quellcode

[Visual Basic]
        Public Shadows Event DropDown()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


ComboBoxTree_ComboBox-Felder

ComboBoxTree_ComboBox Übersicht

Felder

private field FocusOnMouseLeave

Unterstützt von .NET Compact Framework
private field FocusOnVisibleChanged

Unterstützt von .NET Compact Framework
private field IsDroppingDown

Unterstützt von .NET Compact Framework
private field components

Unterstützt von .NET Compact Framework

ComboBoxTree_ComboBox -Klasse


FocusOnMouseLeave -Feld

[Visual Basic]
Private FocusOnMouseLeave As Boolean

Quellcode

[Visual Basic]
        Private FocusOnMouseLeave As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


FocusOnVisibleChanged -Feld

[Visual Basic]
Private FocusOnVisibleChanged As Boolean

Quellcode

[Visual Basic]
        Private FocusOnVisibleChanged As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


IsDroppingDown -Feld

[Visual Basic]
Private IsDroppingDown As Boolean

Quellcode

[Visual Basic]
        Private IsDroppingDown As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


components -Feld

[Visual Basic]
Private components As IContainer

Quellcode

[Visual Basic]
        Private components As System.ComponentModel.IContainer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxTree_ComboBox


Vertragsverwaltung.My -Namespace

Klassen

internal (Friend) class MyApplication

Unterstützt von .NET Compact Framework
internal (Friend) class MySettings

Unterstützt von .NET Compact Framework
internal (Friend) class MySettingsProperty

Unterstützt von .NET Compact Framework


MyApplication -Klasse

For a list of all members of this type, see MyApplication-Member.

System.Object
Microsoft.VisualBasic.ApplicationServices.ApplicationBase
Microsoft.VisualBasic.ApplicationServices.ConsoleApplicationBase
Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase
Vertragsverwaltung.My.MyApplication

[Visual Basic]
Friend Class MyApplication
    Inherits WindowsFormsApplicationBase

Forderungen

Namespace: Vertragsverwaltung.My

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyApplication-Member


MyApplication-Member

MyApplication Übersicht

Öffentliche Konstruktoren

public constructor MyApplication -Konstructor

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method OnCreateMainForm

Unterstützt von .NET Compact Framework

MyApplication -Klasse


MyApplication -Konstructor

[Visual Basic]
<Global.System.Diagnostics.DebuggerStepThrough()> _
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            MyBase.New(Global.Microsoft.VisualBasic.ApplicationServices.AuthenticationMode.Windows)
            Me.IsSingleInstance = false
            Me.EnableVisualStyles = true
            Me.SaveMySettingsOnExit = true
            Me.ShutDownStyle = Global.Microsoft.VisualBasic.ApplicationServices.ShutdownMode.AfterMainFormCloses
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyApplication


MyApplication-Methoden

MyApplication Übersicht

Geschützte Methoden

protected method OnCreateMainForm

Unterstützt von .NET Compact Framework

MyApplication -Klasse


MyApplication.OnCreateMainForm -Methode

[Visual Basic]
<Global.System.Diagnostics.DebuggerStepThrough()> _
Protected Overrides Sub OnCreateMainForm()

Quellcode

[Visual Basic]
        Protected Overrides Sub OnCreateMainForm()
            Me.MainForm = Global.Vertragsverwaltung.frmMain
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyApplication


MySettings -Klasse

For a list of all members of this type, see MySettings-Member.

System.Object
System.Configuration.SettingsBase
System.Configuration.ApplicationSettingsBase
Vertragsverwaltung.My.MySettings

[Visual Basic]
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "8.0.0.0")> _
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend NotInheritable Class MySettings
    Inherits ApplicationSettingsBase

Forderungen

Namespace: Vertragsverwaltung.My

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MySettings-Member


MySettings-Member

MySettings Übersicht

Öffentliche Eigenschaften

public property Static Default

Unterstützt von .NET Compact Framework

Andere Methoden

private method Static AutoSaveSettings

Unterstützt von .NET Compact Framework

Felder

private field Static addedHandler

Unterstützt von .NET Compact Framework
private field Static addedHandlerLockObject

Unterstützt von .NET Compact Framework
private field Static defaultInstance

Unterstützt von .NET Compact Framework

MySettings -Klasse


MySettings-Eigenschaften

MySettings Übersicht

Öffentliche Eigenschaften

public property Static Default

Unterstützt von .NET Compact Framework

MySettings -Klasse


MySettings.Default -Eigenschaft

[Visual Basic]
Public ReadOnly Shared Property Default() As MySettings

Quellcode

[Visual Basic]
        Public Shared ReadOnly Property [Default]() As MySettings
            Get

#If _MyType = "WindowsForms" Then
               If Not addedHandler Then
                    SyncLock addedHandlerLockObject
                        If Not addedHandler Then
                            AddHandler My.Application.Shutdown, AddressOf AutoSaveSettings
                            addedHandler = True
                        End If
                    End SyncLock
                End If
#End If
                Return defaultInstance
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettings


MySettings-Methoden

MySettings Übersicht

Andere Methoden

private method Static AutoSaveSettings

Unterstützt von .NET Compact Framework

MySettings -Klasse


MySettings.AutoSaveSettings -Methode

[Visual Basic]
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Private Shared Sub AutoSaveSettings( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameter

sender
e

Quellcode

[Visual Basic]
    Private Shared Sub AutoSaveSettings(ByVal sender As Global.System.Object, ByVal e As Global.System.EventArgs)
        If My.Application.SaveMySettingsOnExit Then
            My.Settings.Save()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettings


MySettings-Felder

MySettings Übersicht

Felder

private field Static addedHandler

Unterstützt von .NET Compact Framework
private field Static addedHandlerLockObject

Unterstützt von .NET Compact Framework
private field Static defaultInstance

Unterstützt von .NET Compact Framework

MySettings -Klasse


addedHandler -Feld

[Visual Basic]
Private Shared addedHandler As Boolean

Quellcode

[Visual Basic]
    Private Shared addedHandler As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettings


addedHandlerLockObject -Feld

[Visual Basic]
Private Shared addedHandlerLockObject As Object

Quellcode

[Visual Basic]
    Private Shared addedHandlerLockObject As New Object

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettings


defaultInstance -Feld

[Visual Basic]
Private Shared defaultInstance As MySettings

Quellcode

[Visual Basic]
        Private Shared defaultInstance As MySettings = CType(Global.System.Configuration.ApplicationSettingsBase.Synchronized(New MySettings),MySettings)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettings


MySettingsProperty -Klasse

For a list of all members of this type, see MySettingsProperty-Member.

[Visual Basic]
<Global.Microsoft.VisualBasic.HideModuleName()> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
Friend Module MySettingsProperty

Forderungen

Namespace: Vertragsverwaltung.My

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MySettingsProperty-Member


MySettingsProperty-Member

MySettingsProperty Übersicht

Andere Eigenschaften

internal (Friend) property Static Settings

Unterstützt von .NET Compact Framework

MySettingsProperty -Klasse


MySettingsProperty-Eigenschaften

MySettingsProperty Übersicht

Andere Eigenschaften

internal (Friend) property Static Settings

Unterstützt von .NET Compact Framework

MySettingsProperty -Klasse


MySettingsProperty.Settings -Eigenschaft

[Visual Basic]
<Global.System.ComponentModel.Design.HelpKeyword("My.Settings")> _
Friend ReadOnly Shared Property Settings() As MySettings

Quellcode

[Visual Basic]
        Friend ReadOnly Property Settings() As Global.Vertragsverwaltung.My.MySettings
            Get
                Return Global.Vertragsverwaltung.My.MySettings.Default
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySettingsProperty


Vertragsverwaltung.My.Resources -Namespace

Klassen

internal (Friend) class Resources

Unterstützt von .NET Compact Framework

 Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.


Resources -Klasse

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

For a list of all members of this type, see Resources-Member.

[Visual Basic]
<Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "2.0.0.0")> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.Microsoft.VisualBasic.HideModuleName()> _
Friend Module Resources

Forderungen

Namespace: Vertragsverwaltung.My.Resources

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Resources-Member


Resources-Member

Resources Übersicht

Andere Eigenschaften

internal (Friend) property Static BackGround1 Unterstützt von .NET Compact Framework |
internal (Friend) property Static Culture Unterstützt von .NET Compact Framework | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
internal (Friend) property Static FileOpen Unterstützt von .NET Compact Framework |
internal (Friend) property Static FileOpen1 Unterstützt von .NET Compact Framework |
internal (Friend) property Static Lupe2 Unterstützt von .NET Compact Framework |
internal (Friend) property Static OpenFile2 Unterstützt von .NET Compact Framework |
internal (Friend) property Static ResourceManager Unterstützt von .NET Compact Framework | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.
internal (Friend) property Static View Unterstützt von .NET Compact Framework |

Felder

private field Static resourceCulture

Unterstützt von .NET Compact Framework
private field Static resourceMan

Unterstützt von .NET Compact Framework

Resources -Klasse


Resources-Eigenschaften

Resources Übersicht

Andere Eigenschaften

internal (Friend) property Static BackGround1 Unterstützt von .NET Compact Framework |
internal (Friend) property Static Culture Unterstützt von .NET Compact Framework | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
internal (Friend) property Static FileOpen Unterstützt von .NET Compact Framework |
internal (Friend) property Static FileOpen1 Unterstützt von .NET Compact Framework |
internal (Friend) property Static Lupe2 Unterstützt von .NET Compact Framework |
internal (Friend) property Static OpenFile2 Unterstützt von .NET Compact Framework |
internal (Friend) property Static ResourceManager Unterstützt von .NET Compact Framework | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.
internal (Friend) property Static View Unterstützt von .NET Compact Framework |

Resources -Klasse


Resources.BackGround1 -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property BackGround1() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property BackGround1() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("BackGround1", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.Culture -Eigenschaft

Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.

[Visual Basic]
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend Shared Property Culture() As CultureInfo

Quellcode

[Visual Basic]
        Friend Property Culture() As Global.System.Globalization.CultureInfo
            Get
                Return resourceCulture
            End Get
            Set
                resourceCulture = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.FileOpen -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property FileOpen() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property FileOpen() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("FileOpen", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.FileOpen1 -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property FileOpen1() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property FileOpen1() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("FileOpen1", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.Lupe2 -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property Lupe2() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property Lupe2() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("Lupe2", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.OpenFile2 -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property OpenFile2() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property OpenFile2() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("OpenFile2", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.ResourceManager -Eigenschaft

Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.

[Visual Basic]
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend ReadOnly Shared Property ResourceManager() As ResourceManager

Quellcode

[Visual Basic]
        Friend ReadOnly Property ResourceManager() As Global.System.Resources.ResourceManager
            Get
                If Object.ReferenceEquals(resourceMan, Nothing) Then
                    Dim temp As Global.System.Resources.ResourceManager = New Global.System.Resources.ResourceManager("Vertragsverwaltung.Resources", GetType(Resources).Assembly)
                    resourceMan = temp
                End If
                Return resourceMan
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources.View -Eigenschaft

[Visual Basic]
Friend ReadOnly Shared Property View() As Bitmap

Quellcode

[Visual Basic]
        Friend ReadOnly Property View() As System.Drawing.Bitmap
            Get
                Dim obj As Object = ResourceManager.GetObject("View", resourceCulture)
                Return CType(obj,System.Drawing.Bitmap)
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Resources-Felder

Resources Übersicht

Felder

private field Static resourceCulture

Unterstützt von .NET Compact Framework
private field Static resourceMan

Unterstützt von .NET Compact Framework

Resources -Klasse


resourceCulture -Feld

[Visual Basic]
Private Shared resourceCulture As CultureInfo

Quellcode

[Visual Basic]
        Private resourceCulture As Global.System.Globalization.CultureInfo

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


resourceMan -Feld

[Visual Basic]
Private Shared resourceMan As ResourceManager

Quellcode

[Visual Basic]
        Private resourceMan As Global.System.Resources.ResourceManager

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Resources


Vertragsverwaltung.TKB.Auswertung -Namespace

Klassen

public class clsAuswertung

Unterstützt von .NET Compact Framework


clsAuswertung -Klasse

For a list of all members of this type, see clsAuswertung-Member.

System.Object
Vertragsverwaltung.TKB.Auswertung.clsAuswertung

[Visual Basic]
Public Class clsAuswertung

Forderungen

Namespace: Vertragsverwaltung.TKB.Auswertung

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertung-Member


clsAuswertung-Member

clsAuswertung Übersicht

Öffentliche Eigenschaften

public property FullParam

Unterstützt von .NET Compact Framework
public property ParamCollection

Unterstützt von .NET Compact Framework
public property TitelZeile1

Unterstützt von .NET Compact Framework
public property TitelZeile2

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete_Parameter

Unterstützt von .NET Compact Framework
public method Get_Auswertung

Unterstützt von .NET Compact Framework
public method Get_Auswertungen

Unterstützt von .NET Compact Framework
public method Get_Auswertungsdaten Überladen.

Unterstützt von .NET Compact Framework
public method Get_Auswertungsparameter

Unterstützt von .NET Compact Framework
public method Get_MAParameter

Unterstützt von .NET Compact Framework
public method Save_MAParameter

Unterstützt von .NET Compact Framework
public method get_rptparam_values

Unterstützt von .NET Compact Framework

Andere Methoden

private method Get_TXP_Connection Unterstützt von .NET Compact Framework |
private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method Read_Auswertungen Unterstützt von .NET Compact Framework | Auswertungen, für welche der User berechtigt ist, auslesen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

Felder

public field Auswertung

Unterstützt von .NET Compact Framework
public field AuswertungParameter

Unterstützt von .NET Compact Framework
private field Auswertungen

Unterstützt von .NET Compact Framework
public field MitarbeiterAuswertungsparameter

Unterstützt von .NET Compact Framework
private field Mitarbeiter_Auswerungsparameter

Unterstützt von .NET Compact Framework
private field mFullparam

Unterstützt von .NET Compact Framework
private field scparamcollection

Unterstützt von .NET Compact Framework
private field sheader1

Unterstützt von .NET Compact Framework
private field sheader2

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


clsAuswertung-Eigenschaften

clsAuswertung Übersicht

Öffentliche Eigenschaften

public property FullParam

Unterstützt von .NET Compact Framework
public property ParamCollection

Unterstützt von .NET Compact Framework
public property TitelZeile1

Unterstützt von .NET Compact Framework
public property TitelZeile2

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


clsAuswertung.FullParam -Eigenschaft

[Visual Basic]
Public Property FullParam() As String

Quellcode

[Visual Basic]
        Property FullParam() As String
            Get
                Return mFullparam
            End Get
            Set(ByVal value As String)
                mFullparam = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.ParamCollection -Eigenschaft

[Visual Basic]
Public Property ParamCollection() As Collection

Quellcode

[Visual Basic]
        Property ParamCollection() As Collection
            Get
                Return scparamcollection
            End Get
            Set(ByVal value As Collection)
                scparamcollection = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.TitelZeile1 -Eigenschaft

[Visual Basic]
Public Property TitelZeile1() As String

Quellcode

[Visual Basic]
        Property TitelZeile1() As String
            Get
                Return sheader1
            End Get
            Set(ByVal value As String)
                sheader1 = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.TitelZeile2 -Eigenschaft

[Visual Basic]
Public Property TitelZeile2() As String

Quellcode

[Visual Basic]
        Property TitelZeile2() As String
            Get
                Return sheader2
            End Get
            Set(ByVal value As String)
                sheader2 = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung-Methoden

clsAuswertung Übersicht

Öffentliche Methoden

public method Delete_Parameter

Unterstützt von .NET Compact Framework
public method Get_Auswertung

Unterstützt von .NET Compact Framework
public method Get_Auswertungen

Unterstützt von .NET Compact Framework
public method Get_Auswertungsdaten Überladen.

Unterstützt von .NET Compact Framework
public method Get_Auswertungsparameter

Unterstützt von .NET Compact Framework
public method Get_MAParameter

Unterstützt von .NET Compact Framework
public method Save_MAParameter

Unterstützt von .NET Compact Framework
public method get_rptparam_values

Unterstützt von .NET Compact Framework

Andere Methoden

private method Get_TXP_Connection Unterstützt von .NET Compact Framework |
private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method Read_Auswertungen Unterstützt von .NET Compact Framework | Auswertungen, für welche der User berechtigt ist, auslesen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

clsAuswertung -Klasse


clsAuswertung.Delete_Parameter -Methode

[Visual Basic]
Public Function Delete_Parameter( _
   ByVal AuswertungParameterNr As Integer _
) As Object

Parameter

AuswertungParameterNr

Quellcode

[Visual Basic]
        Public Function Delete_Parameter(ByVal AuswertungParameterNr As Integer)
            Me.Mitarbeiter_Auswerungsparameter.iMitarbeiter_AuswertungsparameterNr = New SqlInt32(CType(AuswertungParameterNr, Int32))
            Me.Mitarbeiter_Auswerungsparameter.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Mitarbeiter_Auswerungsparameter.Delete()
            Globals.conn.CloseConnection(True)
            Me.MitarbeiterAuswertungsparameter = Me.Get_MAParameter(Me.Auswertung.iAuswertungNr.Value)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Get_Auswertung -Methode

[Visual Basic]
Public Function Get_Auswertung( _
   ByVal Auswertungnr As Integer _
) As Boolean

Parameter

Auswertungnr

Quellcode

[Visual Basic]
        Public Function Get_Auswertung(ByVal Auswertungnr As Integer) As Boolean
            Try
                Me.Auswertung.iAuswertungNr = New SqlInt32(CType(Auswertungnr, Int32))
                Me.Auswertung.cpMainConnectionProvider = Globals.conn
                Me.Auswertung.SelectOne()
                Me.AuswertungParameter = Get_Auswertungsparameter(Me.Auswertung.iAuswertungNr.Value)
                Me.MitarbeiterAuswertungsparameter = Me.Get_MAParameter(Me.Auswertung.iAuswertungNr.Value)
                Return True
            Catch ex As Exception
                Return False
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Get_Auswertungen -Methode

[Visual Basic]
Public Sub Get_Auswertungen( _
   ByRef tree As TreeView _
)

Parameter

tree

Quellcode

[Visual Basic]
        Public Sub Get_Auswertungen(ByRef tree As TreeView)
            Read_Auswertungen()
            Load_Treeview(Auswertungen, tree)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


Get_Auswertungsdaten -Methode

Überladungsliste

[Visual Basic] Public Function Get_Auswertungsdaten(String, String) As DataTable
[C#] public DataTable Get_Auswertungsdaten(string, string);

[Visual Basic] Public Function Get_Auswertungsdaten(String, String, Boolean) As DataTable
[C#] public DataTable Get_Auswertungsdaten(string, string, bool);

clsAuswertung | Vertragsverwaltung.TKB.Auswertung


clsAuswertung.Get_Auswertungsparameter -Methode

[Visual Basic]
Public Function Get_Auswertungsparameter( _
   ByVal Auswertungnr As Integer _
) As DataTable

Parameter

Auswertungnr

Quellcode

[Visual Basic]
        Public Function Get_Auswertungsparameter(ByVal Auswertungnr As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_rpt_get_auswertungparameter"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Auswertungnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Auswertungnr))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Get_MAParameter -Methode

[Visual Basic]
Public Function Get_MAParameter( _
   ByVal Auswertungnr As Integer _
) As DataTable

Parameter

Auswertungnr

Quellcode

[Visual Basic]
        Public Function Get_MAParameter(ByVal Auswertungnr As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_mitarbeiter_auswertungparamter_selectall"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Auswertungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Auswertungnr))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Get_TXP_Connection -Methode

[Visual Basic]
Private Function Get_TXP_Connection() As String

Quellcode

[Visual Basic]
        Private Function Get_TXP_Connection() As String
            Dim sCstr As String = ""
            Dim txpfile As System.IO.File
            Dim txpread As System.IO.StreamReader
            txpread = txpfile.OpenText(Application.StartupPath + "\TXPConn.cfg")
            sCstr = txpread.ReadLine
            sCstr = Crypto.DecryptText(sCstr, "HutterundMueller")
            sCstr = Left(sCstr, Len(sCstr) - 1)
            txpread.Close()

            Return sCstr
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.LoadTreeView -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadTreeView( _
   ByVal oDS As DataSet, _
   ByRef oTreeview As TreeView _
)

Parameter

oDS
oTreeview

Quellcode

[Visual Basic]
        Private Sub LoadTreeView(ByVal oDS As DataSet, ByRef oTreeview As TreeView)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        Dim oNode As New TreeNode()
                        oNode.Text = oDataRow("Bezeichnung").ToString()
                        oNode.Tag = oDataRow("auswertungnr").ToString
                        oNode.ToolTipText = oDataRow("Beschreibung").ToString
                        oNode.ImageIndex = 0
                        oNode.SelectedImageIndex = 0
                        oNode.StateImageIndex = 0
                        oTreeview.Nodes.Add(oNode)
                        RecursivelyLoadTree(oDataRow, oNode)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Load_Treeview -Methode

Interne Relation aufbauen und Tree aufbauen

[Visual Basic]
Private Sub Load_Treeview( _
   ByVal oSourceData As DataSet, _
   ByRef tree As TreeView _
)

Parameter

oSourceData
tree

Quellcode

[Visual Basic]
        Private Sub Load_Treeview(ByVal oSourceData As DataSet, ByRef tree As TreeView)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.Tables(0).DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("id"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadTreeView(oDS, tree)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Read_Auswertungen -Methode

Auswertungen, für welche der User berechtigt ist, auslesen

[Visual Basic]
Private Function Read_Auswertungen() As DataTable

Quellcode

[Visual Basic]
        Private Function Read_Auswertungen() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_Auswertung_Get_Auswertungen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Auswertungen.Tables.Clear()
                Auswertungen.Tables.Add(dtToReturn)
            Catch ex As Exception
                Throw New Exception("clsAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.RecursivelyLoadTree -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadTree( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode _
)

Parameter

oDataRow
oNode

Quellcode

[Visual Basic]
        Private Sub RecursivelyLoadTree(ByVal oDataRow As DataRow, ByRef oNode As TreeNode)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = oChildRow("Auswertungnr").ToString()
                If oChildRow("Auswertungnr") = 0 Then
                    oChildNode.ImageIndex = 0
                    oChildNode.SelectedImageIndex = 0
                    oChildNode.StateImageIndex = 0
                    oChildNode.ToolTipText = oChildRow("Beschreibung").ToString
                Else
                    oChildNode.ImageIndex = 1
                    oChildNode.SelectedImageIndex = 1
                    oChildNode.StateImageIndex = 1
                    oChildNode.ToolTipText = oChildRow("Beschreibung").ToString
                End If
                oNode.Nodes.Add(oChildNode)
                RecursivelyLoadTree(oChildRow, oChildNode)
            Next oChildRow
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Save_MAParameter -Methode

[Visual Basic]
Public Function Save_MAParameter( _
   ByVal auswertungnr As Integer, _
   ByVal Bezeichnung As String, _
   ByVal Parameter As String, _
   ByVal Titel1 As String, _
   ByVal Titel2 As String, _
   ByVal PrintParam As Boolean _
) As Object

Parameter

auswertungnr
Bezeichnung
Parameter
Titel1
Titel2
PrintParam

Quellcode

[Visual Basic]
        Public Function Save_MAParameter(ByVal auswertungnr As Integer, ByVal Bezeichnung As String, ByVal Parameter As String, ByVal Titel1 As String, ByVal Titel2 As String, ByVal PrintParam As Boolean)
            Me.Mitarbeiter_Auswerungsparameter.cpMainConnectionProvider = Globals.conn
            Me.Mitarbeiter_Auswerungsparameter.iAuswertungNr = New SqlInt32(CType(auswertungnr, Int32))
            Me.Mitarbeiter_Auswerungsparameter.iMitarbeiterNr = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.Mitarbeiter_Auswerungsparameter.sBeschreibung = New SqlString(CType(Bezeichnung, String))
            Me.Mitarbeiter_Auswerungsparameter.sParameterdaten = New SqlString(CType(Parameter, String))
            Me.Mitarbeiter_Auswerungsparameter.sTitelzeile1 = New SqlString(CType(Titel1, String))
            Me.Mitarbeiter_Auswerungsparameter.sTitelzeile2 = New SqlString(CType(Titel2, String))
            If PrintParam = True Then
                Me.Mitarbeiter_Auswerungsparameter.bParamPrint = New SqlBoolean(CType(True, Boolean))
            Else
                Me.Mitarbeiter_Auswerungsparameter.bParamPrint = New SqlBoolean(CType(False, Boolean))
            End If
            Globals.conn.OpenConnection()
            Me.Mitarbeiter_Auswerungsparameter.Insert()
            Globals.conn.CloseConnection(True)
            Me.MitarbeiterAuswertungsparameter = Me.Get_MAParameter(auswertungnr)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.get_rptparam_values -Methode

[Visual Basic]
Public Function get_rptparam_values( _
   ByVal sp As String _
) As DataTable

Parameter

sp

Quellcode

[Visual Basic]
        Public Function get_rptparam_values(ByVal sp As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = sp
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung-Felder

clsAuswertung Übersicht

Felder

public field Auswertung

Unterstützt von .NET Compact Framework
public field AuswertungParameter

Unterstützt von .NET Compact Framework
private field Auswertungen

Unterstützt von .NET Compact Framework
public field MitarbeiterAuswertungsparameter

Unterstützt von .NET Compact Framework
private field Mitarbeiter_Auswerungsparameter

Unterstützt von .NET Compact Framework
private field mFullparam

Unterstützt von .NET Compact Framework
private field scparamcollection

Unterstützt von .NET Compact Framework
private field sheader1

Unterstützt von .NET Compact Framework
private field sheader2

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


Auswertung -Feld

[Visual Basic]
Public Auswertung As clsAuswertung

Quellcode

[Visual Basic]
        Public Auswertung As New TKB.VV.DB.clsAuswertung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


AuswertungParameter -Feld

[Visual Basic]
Public AuswertungParameter As DataTable

Quellcode

[Visual Basic]
        Public AuswertungParameter As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


Auswertungen -Feld

[Visual Basic]
Private Auswertungen As DataSet

Quellcode

[Visual Basic]
        Private Auswertungen As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


MitarbeiterAuswertungsparameter -Feld

[Visual Basic]
Public MitarbeiterAuswertungsparameter As DataTable

Quellcode

[Visual Basic]
        Public MitarbeiterAuswertungsparameter As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


Mitarbeiter_Auswerungsparameter -Feld

[Visual Basic]
Private Mitarbeiter_Auswerungsparameter As clsMitarbeiter_Auswertungsparameter

Quellcode

[Visual Basic]
        Private Mitarbeiter_Auswerungsparameter As New TKB.VV.DB.clsMitarbeiter_Auswertungsparameter

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


mFullparam -Feld

[Visual Basic]
Private mFullparam As String

Quellcode

[Visual Basic]
        Dim mFullparam As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


scparamcollection -Feld

[Visual Basic]
Private scparamcollection As Collection

Quellcode

[Visual Basic]
        Dim scparamcollection As New Collection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


sheader1 -Feld

[Visual Basic]
Private sheader1 As String

Quellcode

[Visual Basic]
        Dim sheader1 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


sheader2 -Feld

[Visual Basic]
Private sheader2 As String

Quellcode

[Visual Basic]
        Dim sheader2 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


Vertragsverwaltung.TKB.VV.Applikation -Namespace

Klassen

public class clsApplikation

Unterstützt von .NET Compact Framework
public class clsApplikationLogbuch

Unterstützt von .NET Compact Framework
public class clsApplikationTree

Unterstützt von .NET Compact Framework
public class clsApplikationsabhaengigkeit

Unterstützt von .NET Compact Framework
public class clsApplikationsuebersicht

Unterstützt von .NET Compact Framework
public class clsKontakt

Unterstützt von .NET Compact Framework


clsApplikation -Klasse

For a list of all members of this type, see clsApplikation-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikation
Vertragsverwaltung.TKB.VV.Applikation.clsApplikation

[Visual Basic]
Public Class clsApplikation
    Inherits clsApplikation

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikation-Member


clsApplikation-Member

clsApplikation Übersicht

Öffentliche Konstruktoren

public constructor clsApplikation -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bAlsProdukt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bNurLizenz (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bRAS (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bSensitiveDaten (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPertVerwendung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPert_AMAnzeigen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPert_WPIAnzeigen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property daInaktivseit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationTeamnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iRfcBoardNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAdministriertdurch (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlComit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlExterne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenUeberwachungPeriodizitaet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationKritikalitaetTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationSMLTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sAnzahl_Installationen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDatenbankname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sKurzbeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sPrioWiederanlauf (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUeberwachungBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUserBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Abhaengigkeiten (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Arbeitsplaetze (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Aufwand (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Bemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis_Einmalig (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Applikation einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Applikation Unterstützt von .NET Compact Framework | Löschen eines Datensatzes
public method Get_Applikation Unterstützt von .NET Compact Framework | Applikation lesen
public method Get_Applikationsabhaengigkeiten Unterstützt von .NET Compact Framework | Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Get_Applikationskontakte Überladen. Unterstützt von .NET Compact Framework | Kontakte auslesen und dem TrueDBGrid übergeben
public method Get_Dokumente Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Drehbuecker Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Lizenzkauf Unterstützt von .NET Compact Framework |
public method Get_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method Get_ReleaseLogbuch Unterstützt von .NET Compact Framework |
public method Get_Vertragselemente Überladen. Unterstützt von .NET Compact Framework | Applikationen lesen und dem Grid übergeben
public method Get_Vertragslizenzen Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Read_Lizenzen Unterstützt von .NET Compact Framework |
public method Refresh_Teams Unterstützt von .NET Compact Framework |
public method Save_CheckedData Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework | Applikation sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Update_Data Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues

Unterstützt von .NET Compact Framework

Felder

public field Applikation

Unterstützt von .NET Compact Framework
public field ApplikationInstallationFuer

Unterstützt von .NET Compact Framework
public field ApplikationInstallationTyp

Unterstützt von .NET Compact Framework
public field ApplikationInstallationals

Unterstützt von .NET Compact Framework
public field Applikation_InstallationFuer

Unterstützt von .NET Compact Framework
public field Applikation_Installationals

Unterstützt von .NET Compact Framework
public field Applikation_Installationtyp

Unterstützt von .NET Compact Framework
public field Applikationabhaengigkeit

Unterstützt von .NET Compact Framework
public field Applikationabhaengigkeiten

Unterstützt von .NET Compact Framework
public field Applikationskontakt

Unterstützt von .NET Compact Framework
public field Applikationskontakte

Unterstützt von .NET Compact Framework
public field Dokument

Unterstützt von .NET Compact Framework
public field InstallationStandard

Unterstützt von .NET Compact Framework
private field Installation_Standard

Unterstützt von .NET Compact Framework
private field Installiert_als

Unterstützt von .NET Compact Framework
private field Installiert_auf

Unterstützt von .NET Compact Framework
public field Installiertals

Unterstützt von .NET Compact Framework
public field Installiertauf

Unterstützt von .NET Compact Framework
public field Kritikalitaeten

Unterstützt von .NET Compact Framework
public field Lizenzen

Unterstützt von .NET Compact Framework
public field Lizenzkauf

Unterstützt von .NET Compact Framework
public field Lizenzschluessel

Unterstützt von .NET Compact Framework
public field Marktbereiche

Unterstützt von .NET Compact Framework
public field Parentelemente

Unterstützt von .NET Compact Framework
public field Periodizitäten

Unterstützt von .NET Compact Framework
public field RFCBoards

Unterstützt von .NET Compact Framework
public field ReleaseLogbooks

Unterstützt von .NET Compact Framework
public field SDAdministratoren

Unterstützt von .NET Compact Framework
public field SLMs

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field Teams

Unterstützt von .NET Compact Framework
public field TestAufwendungen

Unterstützt von .NET Compact Framework
private field Testaufwand

Unterstützt von .NET Compact Framework
public field Verantwortungen

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
public field VertragselementApplikation

Unterstützt von .NET Compact Framework
public field VertragselementApplikationen

Unterstützt von .NET Compact Framework
public field daten

Unterstützt von .NET Compact Framework
public field dokumente

Unterstützt von .NET Compact Framework
public field kategorien

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


clsApplikation -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            Me.cpMainConnectionProvider = Globals.conn
            'Verantwortung.cpMainConnectionProvider = Globals.conn
            'Verantwortungen = Verantwortung.SelectAll

            'Verantwortungen = Stammdaten.Get_Stammdaten("ApplikationVerantwortung", "Bezeichnung")
            Verantwortungen = Stammdaten.Get_Gremium(1, 0)
            RFCBoards = Stammdaten.Get_Gremium(4, 0)

            'Kategorie.cpMainConnectionProvider = Globals.conn
            'Kategorien = Kategorie.SelectAll
            kategorien = stammdaten.Get_Stammdaten("Applikationkategorie", "Bezeichnung")

            'Marktbereich.cpMainConnectionProvider = Globals.conn
            'Marktbereiche = Marktbereich.SelectAll
            Marktbereiche = Stammdaten.Get_Stammdaten("Marktbereich", "Bezeichnung")
            Marktbereiche = Stammdaten.Get_Gremium(3, 0)

            'Kritikalitaet.cpMainConnectionProvider = Globals.conn
            'Kritikalitaeten = Kritikalitaet.SelectAll
            Kritikalitaeten = stammdaten.Get_Stammdaten("ApplikationKritikalitaetTyp", "Bezeichnung")

            'SLM.cpMainConnectionProvider = Globals.conn
            'SLMs = SLM.SelectAll
            SLMs = stammdaten.Get_Stammdaten("ApplikationSLMTyp", "Bezeichnung")

            Installiert_auf.cpMainConnectionProvider = Globals.conn
            Installiertauf = Installiert_auf.SelectAll

            Installiert_als.cpMainConnectionProvider = Globals.conn
            Installiertals = Installiert_als.SelectAll

            Installation_Standard.cpMainConnectionProvider = Globals.conn
            InstallationStandard = Installation_Standard.SelectAll

            Testaufwand.cpMainConnectionProvider = Globals.conn
            TestAufwendungen = Testaufwand.SelectAll

            Teams = Stammdaten.Get_Stammdaten("ApplikationTeam", "Bezeichnung")
            Periodizitäten = Stammdaten.Get_Stammdaten("Periodizitaet", "Sort")
            SDAdministratoren = Stammdaten.Get_Stammdaten("SDAdministrator", "Bezeichnung")

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation-Eigenschaften

clsApplikation Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bAlsProdukt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bNurLizenz (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bRAS (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bSensitiveDaten (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPertVerwendung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPert_AMAnzeigen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property bTicketXPert_WPIAnzeigen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property daInaktivseit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationTeamnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iRfcBoardNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAdministriertdurch (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlComit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlExterne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iSensitiveDatenUeberwachungPeriodizitaet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationKritikalitaetTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationSMLTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sAnzahl_Installationen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDatenbankname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sKurzbeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sPrioWiederanlauf (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUeberwachungBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUserBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Abhaengigkeiten (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Arbeitsplaetze (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Aufwand (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTest_Bemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis_Einmalig (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation)

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


clsApplikation.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bAlsProdukt -Eigenschaft

[Visual Basic]
Public Property bAlsProdukt() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAlsProdukt]() As SqlBoolean
            Get
                Return m_bAlsProdukt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAlsProdukt = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bNurLizenz -Eigenschaft

[Visual Basic]
Public Property bNurLizenz() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bNurLizenz]() As SqlBoolean
            Get
                Return m_bNurLizenz
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bNurLizenz = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bRAS -Eigenschaft

[Visual Basic]
Public Property bRAS() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bRAS]() As SqlBoolean
            Get
                Return m_bRAS
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bRAS = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bSensitiveDaten -Eigenschaft

[Visual Basic]
Public Property bSensitiveDaten() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bSensitiveDaten]() As SqlBoolean
            Get
                Return m_bSensitiveDaten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSensitiveDaten = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bTicketXPertVerwendung -Eigenschaft

[Visual Basic]
Public Property bTicketXPertVerwendung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bTicketXPertVerwendung]() As SqlBoolean
            Get
                Return m_bTicketXPertVerwendung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bTicketXPertVerwendung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bTicketXPert_AMAnzeigen -Eigenschaft

[Visual Basic]
Public Property bTicketXPert_AMAnzeigen() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bTicketXPert_AMAnzeigen]() As SqlBoolean
            Get
                Return m_bTicketXPert_AMAnzeigen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bTicketXPert_AMAnzeigen = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.bTicketXPert_WPIAnzeigen -Eigenschaft

[Visual Basic]
Public Property bTicketXPert_WPIAnzeigen() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bTicketXPert_WPIAnzeigen]() As SqlBoolean
            Get
                Return m_bTicketXPert_WPIAnzeigen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bTicketXPert_WPIAnzeigen = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsDBInteractionBase.cpMainConnectionProvider -Eigenschaft

[Visual Basic]
Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider

Quellcode

[Visual Basic]
        Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider
            Set(ByVal Value As clsConnectionProvider)
                If Value Is Nothing Then
                    ' // Invalid value
                    Throw New ArgumentNullException("cpMainConnectionProvider", "Nothing passed as value to this property which is not allowed.")
                End If

                ' // A connection provider object is passed to this class.
                ' // Retrieve the SqlConnection object, if present and create a
                ' // reference to it. If there is already a MainConnection object
                ' // referenced by the membervar, destroy that one or simply
                ' // remove the reference, based on the flag.
                If Not (m_scoMainConnection Is Nothing) Then
                    ' // First get rid of current connection object. Caller is responsible
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Is local created object, close it and dispose it.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                    End If
                    ' // Remove reference.
                    m_scoMainConnection = Nothing
                End If
                m_cpMainConnectionProvider = CType(Value, clsConnectionProvider)
                m_scoMainConnection = m_cpMainConnectionProvider.scoDBConnection
                m_bMainConnectionIsCreatedLocal = False
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsApplikation.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.daInaktivseit -Eigenschaft

[Visual Basic]
Public Property daInaktivseit() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daInaktivseit]() As SqlDateTime
            Get
                Return m_daInaktivseit
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daInaktivseit = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iApplikationKategorieNr -Eigenschaft

[Visual Basic]
Public Property iApplikationKategorieNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationKategorieNr]() As SqlInt32
            Get
                Return m_iApplikationKategorieNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationKategorieNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationNrTmp As SqlInt32 = Value
                If iApplikationNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationNr", "iApplikationNr can't be NULL")
                End If
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iApplikationTeamnr -Eigenschaft

[Visual Basic]
Public Property iApplikationTeamnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationTeamnr]() As SqlInt32
            Get
                Return m_iApplikationTeamnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationTeamnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iApplikationVerantwortungNr -Eigenschaft

[Visual Basic]
Public Property iApplikationVerantwortungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationVerantwortungNr]() As SqlInt32
            Get
                Return m_iApplikationVerantwortungNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationVerantwortungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsDBInteractionBase.iErrorCode -Eigenschaft

[Visual Basic]
Public ReadOnly Property iErrorCode() As SqlInt32

Quellcode

[Visual Basic]
        Public ReadOnly Property iErrorCode() As SqlInt32
            Get
                Return m_iErrorCode
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsApplikation.iMarktbereichnr -Eigenschaft

[Visual Basic]
Public Property iMarktbereichnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMarktbereichnr]() As SqlInt32
            Get
                Return m_iMarktbereichnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMarktbereichnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iParentID -Eigenschaft

[Visual Basic]
Public Property iParentID() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iRfcBoardNr -Eigenschaft

[Visual Basic]
Public Property iRfcBoardNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRfcBoardNr]() As SqlInt32
            Get
                Return m_iRfcBoardNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRfcBoardNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsDBInteractionBase.iRowsAffected -Eigenschaft

[Visual Basic]
Public ReadOnly Property iRowsAffected() As Integer

Quellcode

[Visual Basic]
        Public Readonly Property iRowsAffected() As Integer
            Get
                Return m_iRowsAffected
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsApplikation.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iSensitiveDatenAdministriertdurch -Eigenschaft

[Visual Basic]
Public Property iSensitiveDatenAdministriertdurch() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSensitiveDatenAdministriertdurch]() As SqlInt32
            Get
                Return m_iSensitiveDatenAdministriertdurch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSensitiveDatenAdministriertdurch = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iSensitiveDatenAnzahlComit -Eigenschaft

[Visual Basic]
Public Property iSensitiveDatenAnzahlComit() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSensitiveDatenAnzahlComit]() As SqlInt32
            Get
                Return m_iSensitiveDatenAnzahlComit
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSensitiveDatenAnzahlComit = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iSensitiveDatenAnzahlExterne -Eigenschaft

[Visual Basic]
Public Property iSensitiveDatenAnzahlExterne() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSensitiveDatenAnzahlExterne]() As SqlInt32
            Get
                Return m_iSensitiveDatenAnzahlExterne
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSensitiveDatenAnzahlExterne = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iSensitiveDatenUeberwachungPeriodizitaet -Eigenschaft

[Visual Basic]
Public Property iSensitiveDatenUeberwachungPeriodizitaet() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSensitiveDatenUeberwachungPeriodizitaet]() As SqlInt32
            Get
                Return m_iSensitiveDatenUeberwachungPeriodizitaet
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSensitiveDatenUeberwachungPeriodizitaet = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iTicketXPert_ApplikationKritikalitaetTypNr -Eigenschaft

[Visual Basic]
Public Property iTicketXPert_ApplikationKritikalitaetTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iTicketXPert_ApplikationKritikalitaetTypNr]() As SqlInt32
            Get
                Return m_iTicketXPert_ApplikationKritikalitaetTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTicketXPert_ApplikationKritikalitaetTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.iTicketXPert_ApplikationSMLTypNr -Eigenschaft

[Visual Basic]
Public Property iTicketXPert_ApplikationSMLTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iTicketXPert_ApplikationSMLTypNr]() As SqlInt32
            Get
                Return m_iTicketXPert_ApplikationSMLTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTicketXPert_ApplikationSMLTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sAnzahl_Installationen -Eigenschaft

[Visual Basic]
Public Property sAnzahl_Installationen() As SqlString

Quellcode

[Visual Basic]
        Public Property [sAnzahl_Installationen]() As SqlString
            Get
                Return m_sAnzahl_Installationen
            End Get
            Set(ByVal Value As SqlString)
                m_sAnzahl_Installationen = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsDBInteractionBase.sConnectionString -Eigenschaft

[Visual Basic]
Public Property sConnectionString() As String

Quellcode

[Visual Basic]
        Public Property sConnectionString() As String
            Get
                Return m_sConnectionString
            End Get
            Set (ByVal Value As String)
                m_sConnectionString = Value
                m_scoMainConnection.ConnectionString = m_sConnectionString
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsApplikation.sDatenbankname -Eigenschaft

[Visual Basic]
Public Property sDatenbankname() As SqlString

Quellcode

[Visual Basic]
        Public Property [sDatenbankname]() As SqlString
            Get
                Return m_sDatenbankname
            End Get
            Set(ByVal Value As SqlString)
                m_sDatenbankname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sKurzbeschreibung -Eigenschaft

[Visual Basic]
Public Property sKurzbeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKurzbeschreibung]() As SqlString
            Get
                Return m_sKurzbeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sKurzbeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sPrioWiederanlauf -Eigenschaft

[Visual Basic]
Public Property sPrioWiederanlauf() As SqlString

Quellcode

[Visual Basic]
        Public Property [sPrioWiederanlauf]() As SqlString
            Get
                Return m_sPrioWiederanlauf
            End Get
            Set(ByVal Value As SqlString)
                m_sPrioWiederanlauf = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sSensitiveDatenBemerkung -Eigenschaft

[Visual Basic]
Public Property sSensitiveDatenBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSensitiveDatenBemerkung]() As SqlString
            Get
                Return m_sSensitiveDatenBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sSensitiveDatenBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sSensitiveDatenUeberwachungBemerkung -Eigenschaft

[Visual Basic]
Public Property sSensitiveDatenUeberwachungBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSensitiveDatenUeberwachungBemerkung]() As SqlString
            Get
                Return m_sSensitiveDatenUeberwachungBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sSensitiveDatenUeberwachungBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sSensitiveDatenUserBemerkung -Eigenschaft

[Visual Basic]
Public Property sSensitiveDatenUserBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSensitiveDatenUserBemerkung]() As SqlString
            Get
                Return m_sSensitiveDatenUserBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sSensitiveDatenUserBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTest_Abhaengigkeiten -Eigenschaft

[Visual Basic]
Public Property sTest_Abhaengigkeiten() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTest_Abhaengigkeiten]() As SqlString
            Get
                Return m_sTest_Abhaengigkeiten
            End Get
            Set(ByVal Value As SqlString)
                m_sTest_Abhaengigkeiten = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTest_Arbeitsplaetze -Eigenschaft

[Visual Basic]
Public Property sTest_Arbeitsplaetze() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTest_Arbeitsplaetze]() As SqlString
            Get
                Return m_sTest_Arbeitsplaetze
            End Get
            Set(ByVal Value As SqlString)
                m_sTest_Arbeitsplaetze = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTest_Aufwand -Eigenschaft

[Visual Basic]
Public Property sTest_Aufwand() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTest_Aufwand]() As SqlString
            Get
                Return m_sTest_Aufwand
            End Get
            Set(ByVal Value As SqlString)
                m_sTest_Aufwand = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTest_Bemerkung -Eigenschaft

[Visual Basic]
Public Property sTest_Bemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTest_Bemerkung]() As SqlString
            Get
                Return m_sTest_Bemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sTest_Bemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTicketXPert_Preis -Eigenschaft

[Visual Basic]
Public Property sTicketXPert_Preis() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTicketXPert_Preis]() As SqlString
            Get
                Return m_sTicketXPert_Preis
            End Get
            Set(ByVal Value As SqlString)
                m_sTicketXPert_Preis = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sTicketXPert_Preis_Einmalig -Eigenschaft

[Visual Basic]
Public Property sTicketXPert_Preis_Einmalig() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTicketXPert_Preis_Einmalig]() As SqlString
            Get
                Return m_sTicketXPert_Preis_Einmalig
            End Get
            Set(ByVal Value As SqlString)
                m_sTicketXPert_Preis_Einmalig = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.sVersion -Eigenschaft

[Visual Basic]
Public Property sVersion() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation-Methoden

clsApplikation Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Applikation einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Applikation Unterstützt von .NET Compact Framework | Löschen eines Datensatzes
public method Get_Applikation Unterstützt von .NET Compact Framework | Applikation lesen
public method Get_Applikationsabhaengigkeiten Unterstützt von .NET Compact Framework | Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Get_Applikationskontakte Überladen. Unterstützt von .NET Compact Framework | Kontakte auslesen und dem TrueDBGrid übergeben
public method Get_Dokumente Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Drehbuecker Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Lizenzkauf Unterstützt von .NET Compact Framework |
public method Get_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method Get_ReleaseLogbuch Unterstützt von .NET Compact Framework |
public method Get_Vertragselemente Überladen. Unterstützt von .NET Compact Framework | Applikationen lesen und dem Grid übergeben
public method Get_Vertragslizenzen Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Read_Lizenzen Unterstützt von .NET Compact Framework |
public method Refresh_Teams Unterstützt von .NET Compact Framework |
public method Save_CheckedData Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework | Applikation sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikation) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Update_Data Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


clsApplikation.Add_New -Methode

Neue Applikation einfügen

[Visual Basic]
Public Function Add_New() As Integer

Quellcode

[Visual Basic]
        Public Function Add_New() As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Applikation")
            db.Dispose()
            Me.iApplikationNr = New SqlInt32(CType(newkey, Int32))
            Me.iApplikationKategorieNr = New SqlInt32(CType(1, Int32))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.sKurzbeschreibung = New SqlString(CType("", String))
            Me.sDatenbankname = New SqlString(CType("", String))
            Me.sAnzahl_Installationen = New SqlString(CType("", String))
            Me.iApplikationVerantwortungNr = New SqlInt32(CType(0, Int32))
            Me.iApplikationTeamNr = New SqlInt32(CType(0, Int32))
            Me.iMarktbereichnr = New SqlInt32(CType(0, Int32))
            Me.iParentID = New SqlInt32(CType(0, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.iTicketXPert_ApplikationKritikalitaetTypNr = New SqlInt32(CType(0, Int32))
            Me.iTicketXPert_ApplikationSMLTypNr = New SqlInt32(CType(0, Int32))
            Me.sVersion = New SqlString(CType("", String))
            Me.bAlsProdukt = New SqlBoolean(CType(False, Boolean))
            Me.bNurLizenz = New SqlBoolean(CType(False, Boolean))
            Me.bRAS = New SqlBoolean(CType(False, Boolean))
            Me.bTicketXPert_AMAnzeigen = New SqlBoolean(CType(False, Boolean))
            Me.bTicketXPert_WPIAnzeigen = New SqlBoolean(CType(False, Boolean))
            Me.sKurzbeschreibung = New SqlString(CType("", String))
            Me.sPrioWiederanlauf = New SqlString(CType("", String))
            Me.sTest_Abhaengigkeiten = New SqlString(CType("", String))
            Me.sTest_Arbeitsplaetze = New SqlString(CType("", String))
            Me.sTest_Aufwand = New SqlString(CType("0", String))
            Me.sTest_Bemerkung = New SqlString(CType("", String))
            Me.sTest_Bemerkung = New SqlString(CType("", String))
            Me.bTicketXPertVerwendung = New SqlBoolean(CType(False, Boolean))
            Me.sTicketXPert_Preis = New SqlString(CType("", String))
            Me.sTicketXPert_Preis_Einmalig = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iRfcBoardNr = New SqlInt32(CType(0, Int32))

            Me.bSensitiveDaten = New SqlBoolean(CType(False, Boolean))
            Me.sSensitiveDatenBemerkung = New SqlString(CType("", String))
            Me.iSensitiveDatenAdministriertdurch = New SqlInt32(CType(0, Int32))

            Me.sSensitiveDatenUeberwachungBemerkung = New SqlString(CType("", String))
            Me.iSensitiveDatenUeberwachungPeriodizitaet = New SqlInt32(CType(0, Int32))
            Me.sSensitiveDatenUserBemerkung = New SqlString(CType("", String))
            Me.iSensitiveDatenAnzahlComit = New SqlInt32(CType(0, Int32))
            Me.iSensitiveDatenAnzahlExterne = New SqlInt32(CType(0, Int32))

            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Applikation(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Applikation")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationNr = New SqlInt32(CType(newkey, Int32))
            Me.sBezeichnung = New SqlString(CType("Kopie - " + Me.sBezeichnung.Value.ToString, String))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikation_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Delete_Applikation -Methode

Löschen eines Datensatzes

[Visual Basic]
Public Function Delete_Applikation( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Applikatoin: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Delete_Applikation(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Applikation(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.daInaktivseit = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Applikation -Methode

Applikation lesen

[Visual Basic]
Public Sub Get_Applikation( _
   ByVal nr As Integer _
)

Parameter

nr

Quellcode

[Visual Basic]
        Public Sub Get_Applikation(ByVal nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationNr = New SqlInt32(CType(nr, Int32))
            Globals.conn.OpenConnection()
            Me.daten = Me.SelectOne()
            Applikation_Installationtyp.cpMainConnectionProvider = Globals.conn
            Applikation_Installationtyp.iApplikationNr = New SqlInt32(CType(nr, Int32))
            ApplikationInstallationTyp = Applikation_Installationtyp.SelectAllWApplikationNrLogic

            Applikation_Installationals.cpMainConnectionProvider = Globals.conn
            Applikation_Installationals.iApplikationNr = New SqlInt32(CType(nr, Int32))
            ApplikationInstallationals = Applikation_Installationals.SelectAllWApplikationNrLogic

            Applikation_InstallationFuer.cpMainConnectionProvider = Globals.conn
            Applikation_InstallationFuer.iApplikationNr = New SqlInt32(CType(nr, Int32))
            applikationinstallationfuer = Applikation_InstallationFuer.SelectAllWApplikationNrLogic
            Globals.conn.CloseConnection(True)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Applikationsabhaengigkeiten -Methode

Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_Applikationsabhaengigkeiten( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Applikationnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Applikationnr

Quellcode

[Visual Basic]
        Public Function Get_Applikationsabhaengigkeiten(ByRef c1data As C1TrueDBGrid, ByVal Applikationnr As Integer)
            Me.Get_Applikation(Applikationnr)
            Me.Applikationabhaengigkeiten = New TKB.VV.Sysadmin.DomainTable("ApplikationAbhaengigkeit", Me.iApplikationNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = Applikationabhaengigkeiten.Tabledata
            c1data.DataMember = Applikationabhaengigkeiten.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Get_Applikationskontakte -Methode

Überladungsliste

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic] Public Function Get_Applikationskontakte(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Applikationskontakte(ref C1TrueDBGrid);

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic] Public Function Get_Applikationskontakte(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Applikationskontakte(ref C1TrueDBGrid, int);

clsApplikation | Vertragsverwaltung.TKB.VV.Applikation


Get_Dokumente -Methode

Überladungsliste

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic] Public Function Get_Dokumente(ByRef C1TrueDBGrid, Integer, Optional ImageList) As Object
[C#] public object Get_Dokumente(ref C1TrueDBGrid, int, ImageList);

Dokumente lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Dokumente(ByRef C1TrueDBGrid, Optional ImageList) As Object
[C#] public object Get_Dokumente(ref C1TrueDBGrid, ImageList);

clsApplikation | Vertragsverwaltung.TKB.VV.Applikation


clsApplikation.Get_Drehbuecker -Methode

Dokumente lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Drehbuecker( _
   ByRef c1data As C1TrueDBGrid, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Drehbuecker(ByRef c1data As C1TrueDBGrid, Optional ByVal ImgList As ImageList = Nothing)
            Try
                dokumente.Dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            dokumente = Dokument.Get_Dokumente(Me.iApplikationNr.Value, 2)
            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Lizenzkauf -Methode

[Visual Basic]
Public Function Get_Lizenzkauf( _
   ByVal vertragselementnr As Integer, _
   ByVal Applikationnr As Integer _
) As Object

Parameter

vertragselementnr
Applikationnr

Quellcode

[Visual Basic]
        Public Function Get_Lizenzkauf(ByVal vertragselementnr As Integer, ByVal Applikationnr As Integer)
            Me.Lizenzkauf.Rows.Clear()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_lizenzkauf"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Vertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Applikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Applikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                conn.OpenConnection()
                sdaAdapter.Fill(Me.Lizenzkauf)
                conn.CloseConnection(True)
            Catch ex As Exception
                Throw New Exception("clsApplikation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Lizenzschluessel -Methode

[Visual Basic]
Public Function Get_Lizenzschluessel( _
   ByVal LizenzkaufNr As Integer _
) As Object

Parameter

LizenzkaufNr

Quellcode

[Visual Basic]
        Public Function Get_Lizenzschluessel(ByVal LizenzkaufNr As Integer)
            Me.Lizenzschluessel.Rows.Clear()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_lizenzschluessel"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Lizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, LizenzkaufNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                conn.OpenConnection()
                sdaAdapter.Fill(Me.Lizenzschluessel)
                conn.CloseConnection(True)
            Catch ex As Exception
                Throw New Exception("clsApplikation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_ReleaseLogbuch -Methode

[Visual Basic]
Public Function Get_ReleaseLogbuch( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal applikationnr As Integer _
) As Object

Parameter

c1data
applikationnr

Quellcode

[Visual Basic]
        Public Function Get_ReleaseLogbuch(ByRef c1data As C1TrueDBGrid, ByVal applikationnr As Integer)
            Application.DoEvents()
            Try
                ReleaseLogbooks.dispose()
                ReleaseLogbooks = Nothing
            Catch ex As Exception
            End Try
            ReleaseLogbooks = New TKB.VV.Sysadmin.DomainTable("ApplikationLogbuch", applikationnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = ReleaseLogbooks.Tabledata
            c1data.DataMember = ReleaseLogbooks.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Get_Vertragselemente -Methode

Überladungsliste

Applikationen lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Vertragselemente(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Vertragselemente(ref C1TrueDBGrid);

Applikationen auslesen und dem Truedbgrid übergeben.

[Visual Basic] Public Function Get_Vertragselemente(Integer) As Object
[C#] public object Get_Vertragselemente(int);

clsApplikation | Vertragsverwaltung.TKB.VV.Applikation


clsApplikation.Get_Vertragslizenzen -Methode

[Visual Basic]
Public Sub Get_Vertragslizenzen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal applikationnr As Integer _
)

Parameter

c1data
applikationnr

Quellcode

[Visual Basic]
        Public Sub Get_Vertragslizenzen(ByRef c1data As C1TrueDBGrid, ByVal applikationnr As Integer)
            Try
                Lizenzen.Rows.Clear()
            Catch ex As Exception

            End Try
            Lizenzen = Read_Lizenzen(applikationnr)
            c1data.DataSource = Lizenzen
            c1data.DataMember = Lizenzen.TableName

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iApplikationVerantwortungNr. May be SqlInt32.Null</LI> <LI>iApplikationKategorieNr. May be SqlInt32.Null</LI> <LI>iApplikationTeamnr. May be SqlInt32.Null</LI> <LI>iMarktbereichnr. May be SqlInt32.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bAlsProdukt. May be SqlBoolean.Null</LI> <LI>bNurLizenz. May be SqlBoolean.Null</LI> <LI>sPrioWiederanlauf. May be SqlString.Null</LI> <LI>sKurzbeschreibung. May be SqlString.Null</LI> <LI>daInaktivseit. May be SqlDateTime.Null</LI> <LI>bRAS. May be SqlBoolean.Null</LI> <LI>sDatenbankname. May be SqlString.Null</LI> <LI>sAnzahl_Installationen. May be SqlString.Null</LI> <LI>sTest_Aufwand. May be SqlString.Null</LI> <LI>sTest_Arbeitsplaetze. May be SqlString.Null</LI> <LI>sTest_Abhaengigkeiten. May be SqlString.Null</LI> <LI>sTest_Bemerkung. May be SqlString.Null</LI> <LI>bTicketXPertVerwendung. May be SqlBoolean.Null</LI> <LI>bTicketXPert_WPIAnzeigen. May be SqlBoolean.Null</LI> <LI>sTicketXPert_Preis. May be SqlString.Null</LI> <LI>sTicketXPert_Preis_Einmalig. May be SqlString.Null</LI> <LI>bTicketXPert_AMAnzeigen. May be SqlBoolean.Null</LI> <LI>iTicketXPert_ApplikationKritikalitaetTypNr. May be SqlInt32.Null</LI> <LI>iTicketXPert_ApplikationSMLTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iRfcBoardNr. May be SqlInt32.Null</LI> <LI>bSensitiveDaten. May be SqlBoolean.Null</LI> <LI>sSensitiveDatenBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenAdministriertdurch. May be SqlInt32.Null</LI> <LI>sSensitiveDatenUeberwachungBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenUeberwachungPeriodizitaet. May be SqlInt32.Null</LI> <LI>sSensitiveDatenUserBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenAnzahlComit. May be SqlInt32.Null</LI> <LI>iSensitiveDatenAnzahlExterne. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikation_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTeamnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAlsProdukt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAlsProdukt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bNurLizenz", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bNurLizenz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPrioWiederanlauf", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrioWiederanlauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKurzbeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzbeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daInaktivseit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daInaktivseit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bRAS", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bRAS))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDatenbankname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDatenbankname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAnzahl_Installationen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnzahl_Installationen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Aufwand", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Aufwand))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Arbeitsplaetze", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Arbeitsplaetze))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Abhaengigkeiten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Abhaengigkeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Bemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPertVerwendung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPertVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPert_WPIAnzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPert_WPIAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTicketXPert_Preis", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTicketXPert_Preis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTicketXPert_Preis_Einmalig", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTicketXPert_Preis_Einmalig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPert_AMAnzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPert_AMAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTicketXPert_ApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTicketXPert_ApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTicketXPert_ApplikationSMLTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTicketXPert_ApplikationSMLTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSensitiveDaten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bSensitiveDaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAdministriertdurch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAdministriertdurch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenUeberwachungBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenUeberwachungBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenUeberwachungPeriodizitaet", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenUeberwachungPeriodizitaet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenUserBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenUserBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAnzahlComit", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAnzahlComit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAnzahlExterne", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAnzahlExterne))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Read_Lizenzen -Methode

[Visual Basic]
Public Function Read_Lizenzen( _
   ByVal applikationnr As Integer _
) As DataTable

Parameter

applikationnr

Quellcode

[Visual Basic]
        Public Function Read_Lizenzen(ByVal applikationnr As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Dim CheckState As Integer
            scmCmdToExecute.CommandText = "dbo.sp_applikation_get_vertragselemente"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@applikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, applikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                conn.OpenConnection()
                sdaAdapter.Fill(dtToReturn)

                conn.CloseConnection(True)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsApplikation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Refresh_Teams -Methode

[Visual Basic]
Public Function Refresh_Teams( _
   ByVal Verantwortungnr As Integer _
) As Object

Parameter

Verantwortungnr

Quellcode

[Visual Basic]
        Public Function Refresh_Teams(ByVal Verantwortungnr As Integer)
            Me.Teams = Me.Stammdaten.Get_Gremium(2, Verantwortungnr)

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Save_CheckedData -Methode

[Visual Basic]
Public Sub Save_CheckedData( _
   ByRef clb As CheckedListBox, _
   ByVal typ As Integer _
)

Parameter

clb
typ

Quellcode

[Visual Basic]
        Public Sub Save_CheckedData(ByRef clb As CheckedListBox, ByVal typ As Integer)
            Dim i As Integer
            Dim oc As CheckedListBox.ObjectCollection = clb.Items
            For i = 0 To oc.Count - 1
                Update_Data(oc.Item(i).item(0), clb.GetItemChecked(i), typ)
            Next
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Save_Data -Methode

Applikation sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikation_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationNr</LI> <LI>sBezeichnung</LI> <LI>iParentID</LI> <LI>iApplikationVerantwortungNr</LI> <LI>iApplikationKategorieNr</LI> <LI>iApplikationTeamnr</LI> <LI>iMarktbereichnr</LI> <LI>sVersion</LI> <LI>bAlsProdukt</LI> <LI>bNurLizenz</LI> <LI>sPrioWiederanlauf</LI> <LI>sKurzbeschreibung</LI> <LI>daInaktivseit</LI> <LI>bRAS</LI> <LI>sDatenbankname</LI> <LI>sAnzahl_Installationen</LI> <LI>sTest_Aufwand</LI> <LI>sTest_Arbeitsplaetze</LI> <LI>sTest_Abhaengigkeiten</LI> <LI>sTest_Bemerkung</LI> <LI>bTicketXPertVerwendung</LI> <LI>bTicketXPert_WPIAnzeigen</LI> <LI>sTicketXPert_Preis</LI> <LI>sTicketXPert_Preis_Einmalig</LI> <LI>bTicketXPert_AMAnzeigen</LI> <LI>iTicketXPert_ApplikationKritikalitaetTypNr</LI> <LI>iTicketXPert_ApplikationSMLTypNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iSecurityLevelNr</LI> <LI>iRfcBoardNr</LI> <LI>bSensitiveDaten</LI> <LI>sSensitiveDatenBemerkung</LI> <LI>iSensitiveDatenAdministriertdurch</LI> <LI>sSensitiveDatenUeberwachungBemerkung</LI> <LI>iSensitiveDatenUeberwachungPeriodizitaet</LI> <LI>sSensitiveDatenUserBemerkung</LI> <LI>iSensitiveDatenAnzahlComit</LI> <LI>iSensitiveDatenAnzahlExterne</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikation_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationVerantwortungNr") Is System.DBNull.Value Then
                        m_iApplikationVerantwortungNr = SqlInt32.Null
                    Else
                        m_iApplikationVerantwortungNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationVerantwortungNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationKategorieNr") Is System.DBNull.Value Then
                        m_iApplikationKategorieNr = SqlInt32.Null
                    Else
                        m_iApplikationKategorieNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationKategorieNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationTeamnr") Is System.DBNull.Value Then
                        m_iApplikationTeamnr = SqlInt32.Null
                    Else
                        m_iApplikationTeamnr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationTeamnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Marktbereichnr") Is System.DBNull.Value Then
                        m_iMarktbereichnr = SqlInt32.Null
                    Else
                        m_iMarktbereichnr = New SqlInt32(CType(dtToReturn.Rows(0)("Marktbereichnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("Version"), String))
                    End If
                    If dtToReturn.Rows(0)("AlsProdukt") Is System.DBNull.Value Then
                        m_bAlsProdukt = SqlBoolean.Null
                    Else
                        m_bAlsProdukt = New SqlBoolean(CType(dtToReturn.Rows(0)("AlsProdukt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("NurLizenz") Is System.DBNull.Value Then
                        m_bNurLizenz = SqlBoolean.Null
                    Else
                        m_bNurLizenz = New SqlBoolean(CType(dtToReturn.Rows(0)("NurLizenz"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("PrioWiederanlauf") Is System.DBNull.Value Then
                        m_sPrioWiederanlauf = SqlString.Null
                    Else
                        m_sPrioWiederanlauf = New SqlString(CType(dtToReturn.Rows(0)("PrioWiederanlauf"), String))
                    End If
                    If dtToReturn.Rows(0)("Kurzbeschreibung") Is System.DBNull.Value Then
                        m_sKurzbeschreibung = SqlString.Null
                    Else
                        m_sKurzbeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Kurzbeschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Inaktivseit") Is System.DBNull.Value Then
                        m_daInaktivseit = SqlDateTime.Null
                    Else
                        m_daInaktivseit = New SqlDateTime(CType(dtToReturn.Rows(0)("Inaktivseit"), Date))
                    End If
                    If dtToReturn.Rows(0)("RAS") Is System.DBNull.Value Then
                        m_bRAS = SqlBoolean.Null
                    Else
                        m_bRAS = New SqlBoolean(CType(dtToReturn.Rows(0)("RAS"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Datenbankname") Is System.DBNull.Value Then
                        m_sDatenbankname = SqlString.Null
                    Else
                        m_sDatenbankname = New SqlString(CType(dtToReturn.Rows(0)("Datenbankname"), String))
                    End If
                    If dtToReturn.Rows(0)("Anzahl_Installationen") Is System.DBNull.Value Then
                        m_sAnzahl_Installationen = SqlString.Null
                    Else
                        m_sAnzahl_Installationen = New SqlString(CType(dtToReturn.Rows(0)("Anzahl_Installationen"), String))
                    End If
                    If dtToReturn.Rows(0)("Test_Aufwand") Is System.DBNull.Value Then
                        m_sTest_Aufwand = SqlString.Null
                    Else
                        m_sTest_Aufwand = New SqlString(CType(dtToReturn.Rows(0)("Test_Aufwand"), String))
                    End If
                    If dtToReturn.Rows(0)("Test_Arbeitsplaetze") Is System.DBNull.Value Then
                        m_sTest_Arbeitsplaetze = SqlString.Null
                    Else
                        m_sTest_Arbeitsplaetze = New SqlString(CType(dtToReturn.Rows(0)("Test_Arbeitsplaetze"), String))
                    End If
                    If dtToReturn.Rows(0)("Test_Abhaengigkeiten") Is System.DBNull.Value Then
                        m_sTest_Abhaengigkeiten = SqlString.Null
                    Else
                        m_sTest_Abhaengigkeiten = New SqlString(CType(dtToReturn.Rows(0)("Test_Abhaengigkeiten"), String))
                    End If
                    If dtToReturn.Rows(0)("Test_Bemerkung") Is System.DBNull.Value Then
                        m_sTest_Bemerkung = SqlString.Null
                    Else
                        m_sTest_Bemerkung = New SqlString(CType(dtToReturn.Rows(0)("Test_Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("TicketXPertVerwendung") Is System.DBNull.Value Then
                        m_bTicketXPertVerwendung = SqlBoolean.Null
                    Else
                        m_bTicketXPertVerwendung = New SqlBoolean(CType(dtToReturn.Rows(0)("TicketXPertVerwendung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_WPIAnzeigen") Is System.DBNull.Value Then
                        m_bTicketXPert_WPIAnzeigen = SqlBoolean.Null
                    Else
                        m_bTicketXPert_WPIAnzeigen = New SqlBoolean(CType(dtToReturn.Rows(0)("TicketXPert_WPIAnzeigen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_Preis") Is System.DBNull.Value Then
                        m_sTicketXPert_Preis = SqlString.Null
                    Else
                        m_sTicketXPert_Preis = New SqlString(CType(dtToReturn.Rows(0)("TicketXPert_Preis"), String))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_Preis_Einmalig") Is System.DBNull.Value Then
                        m_sTicketXPert_Preis_Einmalig = SqlString.Null
                    Else
                        m_sTicketXPert_Preis_Einmalig = New SqlString(CType(dtToReturn.Rows(0)("TicketXPert_Preis_Einmalig"), String))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_AMAnzeigen") Is System.DBNull.Value Then
                        m_bTicketXPert_AMAnzeigen = SqlBoolean.Null
                    Else
                        m_bTicketXPert_AMAnzeigen = New SqlBoolean(CType(dtToReturn.Rows(0)("TicketXPert_AMAnzeigen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_ApplikationKritikalitaetTypNr") Is System.DBNull.Value Then
                        m_iTicketXPert_ApplikationKritikalitaetTypNr = SqlInt32.Null
                    Else
                        m_iTicketXPert_ApplikationKritikalitaetTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("TicketXPert_ApplikationKritikalitaetTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("TicketXPert_ApplikationSMLTypNr") Is System.DBNull.Value Then
                        m_iTicketXPert_ApplikationSMLTypNr = SqlInt32.Null
                    Else
                        m_iTicketXPert_ApplikationSMLTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("TicketXPert_ApplikationSMLTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("RfcBoardNr") Is System.DBNull.Value Then
                        m_iRfcBoardNr = SqlInt32.Null
                    Else
                        m_iRfcBoardNr = New SqlInt32(CType(dtToReturn.Rows(0)("RfcBoardNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDaten") Is System.DBNull.Value Then
                        m_bSensitiveDaten = SqlBoolean.Null
                    Else
                        m_bSensitiveDaten = New SqlBoolean(CType(dtToReturn.Rows(0)("SensitiveDaten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenBemerkung") Is System.DBNull.Value Then
                        m_sSensitiveDatenBemerkung = SqlString.Null
                    Else
                        m_sSensitiveDatenBemerkung = New SqlString(CType(dtToReturn.Rows(0)("SensitiveDatenBemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenAdministriertdurch") Is System.DBNull.Value Then
                        m_iSensitiveDatenAdministriertdurch = SqlInt32.Null
                    Else
                        m_iSensitiveDatenAdministriertdurch = New SqlInt32(CType(dtToReturn.Rows(0)("SensitiveDatenAdministriertdurch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenUeberwachungBemerkung") Is System.DBNull.Value Then
                        m_sSensitiveDatenUeberwachungBemerkung = SqlString.Null
                    Else
                        m_sSensitiveDatenUeberwachungBemerkung = New SqlString(CType(dtToReturn.Rows(0)("SensitiveDatenUeberwachungBemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenUeberwachungPeriodizitaet") Is System.DBNull.Value Then
                        m_iSensitiveDatenUeberwachungPeriodizitaet = SqlInt32.Null
                    Else
                        m_iSensitiveDatenUeberwachungPeriodizitaet = New SqlInt32(CType(dtToReturn.Rows(0)("SensitiveDatenUeberwachungPeriodizitaet"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenUserBemerkung") Is System.DBNull.Value Then
                        m_sSensitiveDatenUserBemerkung = SqlString.Null
                    Else
                        m_sSensitiveDatenUserBemerkung = New SqlString(CType(dtToReturn.Rows(0)("SensitiveDatenUserBemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenAnzahlComit") Is System.DBNull.Value Then
                        m_iSensitiveDatenAnzahlComit = SqlInt32.Null
                    Else
                        m_iSensitiveDatenAnzahlComit = New SqlInt32(CType(dtToReturn.Rows(0)("SensitiveDatenAnzahlComit"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SensitiveDatenAnzahlExterne") Is System.DBNull.Value Then
                        m_iSensitiveDatenAnzahlExterne = SqlInt32.Null
                    Else
                        m_iSensitiveDatenAnzahlExterne = New SqlInt32(CType(dtToReturn.Rows(0)("SensitiveDatenAnzahlExterne"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Set_Imagevalues -Methode

[Visual Basic]
Private Sub Set_Imagevalues( _
   ByRef c1data As C1TrueDBGrid, _
   ByRef imglist As ImageList _
)

Parameter

c1data
imglist

Quellcode

[Visual Basic]
        Private Sub Set_Imagevalues(ByRef c1data As C1TrueDBGrid, ByRef imglist As ImageList)

            Dim i As Integer
            Dim s As String
            For i = 0 To dokumente.Rows.Count - 1
                s = dokumente.Rows(i).Item("Filename")
                If Len(s) < 4 Then s = ".div"
                Select Case UCase(s.Substring(Len(s) - 4, 4))
                    Case ".PDF"
                        dokumente.Rows(i).Item("DokIcon") = 0
                    Case ".DOC"
                        dokumente.Rows(i).Item("DokIcon") = 1
                    Case ".XLS"
                        dokumente.Rows(i).Item("DokIcon") = 2
                    Case ".PPT"
                        dokumente.Rows(i).Item("DokIcon") = 3
                    Case ".HTM", "TML", "XML"
                        dokumente.Rows(i).Item("DokIcon") = 4
                    Case ".MSG"
                        dokumente.Rows(i).Item("DokIcon") = 5
                    Case Else
                        dokumente.Rows(i).Item("DokIcon") = 6
                End Select
            Next

            Dim bmp0 As New Bitmap(imglist.Images(0))
            Dim bmp1 As New Bitmap(imglist.Images(1))
            Dim bmp2 As New Bitmap(imglist.Images(2))
            Dim bmp3 As New Bitmap(imglist.Images(3))
            Dim bmp4 As New Bitmap(imglist.Images(4))
            Dim bmp5 As New Bitmap(imglist.Images(5))
            Dim bmp6 As New Bitmap(imglist.Images(6))
            Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v4 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v5 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v6 As New C1.Win.C1TrueDBGrid.ValueItem()

            v0.DisplayValue = bmp0
            v0.Value = 0

            v1.DisplayValue = bmp1
            v1.Value = 1

            v2.DisplayValue = bmp2
            v2.Value = 2

            v3.DisplayValue = bmp3
            v3.Value = 3

            v4.DisplayValue = bmp4
            v4.Value = 4

            v5.DisplayValue = bmp5
            v5.Value = 5

            v6.DisplayValue = bmp6
            v6.Value = 6

            c1data.Columns("dokicon").ValueItems.Values.Add(v0)
            c1data.Columns("dokicon").ValueItems.Values.Add(v1)
            c1data.Columns("dokicon").ValueItems.Values.Add(v2)
            c1data.Columns("dokicon").ValueItems.Values.Add(v3)
            c1data.Columns("dokicon").ValueItems.Values.Add(v4)
            c1data.Columns("dokicon").ValueItems.Values.Add(v5)
            c1data.Columns("dokicon").ValueItems.Values.Add(v6)
            c1data.Columns("dokicon").ValueItems.Translate = True

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iApplikationVerantwortungNr. May be SqlInt32.Null</LI> <LI>iApplikationKategorieNr. May be SqlInt32.Null</LI> <LI>iApplikationTeamnr. May be SqlInt32.Null</LI> <LI>iMarktbereichnr. May be SqlInt32.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bAlsProdukt. May be SqlBoolean.Null</LI> <LI>bNurLizenz. May be SqlBoolean.Null</LI> <LI>sPrioWiederanlauf. May be SqlString.Null</LI> <LI>sKurzbeschreibung. May be SqlString.Null</LI> <LI>daInaktivseit. May be SqlDateTime.Null</LI> <LI>bRAS. May be SqlBoolean.Null</LI> <LI>sDatenbankname. May be SqlString.Null</LI> <LI>sAnzahl_Installationen. May be SqlString.Null</LI> <LI>sTest_Aufwand. May be SqlString.Null</LI> <LI>sTest_Arbeitsplaetze. May be SqlString.Null</LI> <LI>sTest_Abhaengigkeiten. May be SqlString.Null</LI> <LI>sTest_Bemerkung. May be SqlString.Null</LI> <LI>bTicketXPertVerwendung. May be SqlBoolean.Null</LI> <LI>bTicketXPert_WPIAnzeigen. May be SqlBoolean.Null</LI> <LI>sTicketXPert_Preis. May be SqlString.Null</LI> <LI>sTicketXPert_Preis_Einmalig. May be SqlString.Null</LI> <LI>bTicketXPert_AMAnzeigen. May be SqlBoolean.Null</LI> <LI>iTicketXPert_ApplikationKritikalitaetTypNr. May be SqlInt32.Null</LI> <LI>iTicketXPert_ApplikationSMLTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iRfcBoardNr. May be SqlInt32.Null</LI> <LI>bSensitiveDaten. May be SqlBoolean.Null</LI> <LI>sSensitiveDatenBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenAdministriertdurch. May be SqlInt32.Null</LI> <LI>sSensitiveDatenUeberwachungBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenUeberwachungPeriodizitaet. May be SqlInt32.Null</LI> <LI>sSensitiveDatenUserBemerkung. May be SqlString.Null</LI> <LI>iSensitiveDatenAnzahlComit. May be SqlInt32.Null</LI> <LI>iSensitiveDatenAnzahlExterne. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikation_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTeamnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAlsProdukt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAlsProdukt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bNurLizenz", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bNurLizenz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPrioWiederanlauf", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrioWiederanlauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKurzbeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzbeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daInaktivseit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daInaktivseit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bRAS", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bRAS))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDatenbankname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDatenbankname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAnzahl_Installationen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnzahl_Installationen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Aufwand", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Aufwand))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Arbeitsplaetze", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Arbeitsplaetze))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Abhaengigkeiten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Abhaengigkeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTest_Bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTest_Bemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPertVerwendung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPertVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPert_WPIAnzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPert_WPIAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTicketXPert_Preis", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTicketXPert_Preis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTicketXPert_Preis_Einmalig", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTicketXPert_Preis_Einmalig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTicketXPert_AMAnzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTicketXPert_AMAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTicketXPert_ApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTicketXPert_ApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTicketXPert_ApplikationSMLTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTicketXPert_ApplikationSMLTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSensitiveDaten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bSensitiveDaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAdministriertdurch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAdministriertdurch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenUeberwachungBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenUeberwachungBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenUeberwachungPeriodizitaet", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenUeberwachungPeriodizitaet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSensitiveDatenUserBemerkung", SqlDbType.VarChar, 500, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSensitiveDatenUserBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAnzahlComit", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAnzahlComit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSensitiveDatenAnzahlExterne", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSensitiveDatenAnzahlExterne))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Update_Data -Methode

[Visual Basic]
Public Sub Update_Data( _
   ByVal Key As Integer, _
   ByVal checked As Boolean, _
   ByVal typ As Integer _
)

Parameter

Key
checked
typ

Quellcode

[Visual Basic]
        Public Sub Update_Data(ByVal Key As Integer, ByVal checked As Boolean, ByVal typ As Integer)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Dim CheckState As Integer
            If checked Then CheckState = 1 Else CheckState = 0
            scmCmdToExecute.CommandText = "dbo.sp_update_CheckedListBoxData"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Key))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Applikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.iApplikationNr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, typ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Checked", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, CheckState))
                conn.OpenConnection()
                scmCmdToExecute.ExecuteNonQuery()
                conn.CloseConnection(True)
            Catch ex As Exception
                Throw New Exception("clsApplikation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

clsApplikation | Vertragsverwaltung.TKB.VV.Applikation


clsApplikation-Felder

clsApplikation Übersicht

Felder

public field Applikation

Unterstützt von .NET Compact Framework
public field ApplikationInstallationFuer

Unterstützt von .NET Compact Framework
public field ApplikationInstallationTyp

Unterstützt von .NET Compact Framework
public field ApplikationInstallationals

Unterstützt von .NET Compact Framework
public field Applikation_InstallationFuer

Unterstützt von .NET Compact Framework
public field Applikation_Installationals

Unterstützt von .NET Compact Framework
public field Applikation_Installationtyp

Unterstützt von .NET Compact Framework
public field Applikationabhaengigkeit

Unterstützt von .NET Compact Framework
public field Applikationabhaengigkeiten

Unterstützt von .NET Compact Framework
public field Applikationskontakt

Unterstützt von .NET Compact Framework
public field Applikationskontakte

Unterstützt von .NET Compact Framework
public field Dokument

Unterstützt von .NET Compact Framework
public field InstallationStandard

Unterstützt von .NET Compact Framework
private field Installation_Standard

Unterstützt von .NET Compact Framework
private field Installiert_als

Unterstützt von .NET Compact Framework
private field Installiert_auf

Unterstützt von .NET Compact Framework
public field Installiertals

Unterstützt von .NET Compact Framework
public field Installiertauf

Unterstützt von .NET Compact Framework
public field Kritikalitaeten

Unterstützt von .NET Compact Framework
public field Lizenzen

Unterstützt von .NET Compact Framework
public field Lizenzkauf

Unterstützt von .NET Compact Framework
public field Lizenzschluessel

Unterstützt von .NET Compact Framework
public field Marktbereiche

Unterstützt von .NET Compact Framework
public field Parentelemente

Unterstützt von .NET Compact Framework
public field Periodizitäten

Unterstützt von .NET Compact Framework
public field RFCBoards

Unterstützt von .NET Compact Framework
public field ReleaseLogbooks

Unterstützt von .NET Compact Framework
public field SDAdministratoren

Unterstützt von .NET Compact Framework
public field SLMs

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field Teams

Unterstützt von .NET Compact Framework
public field TestAufwendungen

Unterstützt von .NET Compact Framework
private field Testaufwand

Unterstützt von .NET Compact Framework
public field Verantwortungen

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
public field VertragselementApplikation

Unterstützt von .NET Compact Framework
public field VertragselementApplikationen

Unterstützt von .NET Compact Framework
public field daten

Unterstützt von .NET Compact Framework
public field dokumente

Unterstützt von .NET Compact Framework
public field kategorien

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


Applikation -Feld

[Visual Basic]
Public Applikation As clsApplikation

Quellcode

[Visual Basic]
        Public Applikation As TKB.VV.DB.clsApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


ApplikationInstallationFuer -Feld

[Visual Basic]
Public ApplikationInstallationFuer As DataTable

Quellcode

[Visual Basic]
        Public ApplikationInstallationFuer As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


ApplikationInstallationTyp -Feld

[Visual Basic]
Public ApplikationInstallationTyp As DataTable

Quellcode

[Visual Basic]
        Public ApplikationInstallationTyp As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


ApplikationInstallationals -Feld

[Visual Basic]
Public ApplikationInstallationals As DataTable

Quellcode

[Visual Basic]
        Public ApplikationInstallationals As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikation_InstallationFuer -Feld

[Visual Basic]
Public Applikation_InstallationFuer As clsApplikationInstallationFuer

Quellcode

[Visual Basic]
        Public Applikation_InstallationFuer As New TKB.VV.DB.clsApplikationInstallationFuer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikation_Installationals -Feld

[Visual Basic]
Public Applikation_Installationals As clsApplikationInstallationAls

Quellcode

[Visual Basic]
        Public Applikation_Installationals As New TKB.VV.DB.clsApplikationInstallationAls

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikation_Installationtyp -Feld

[Visual Basic]
Public Applikation_Installationtyp As clsApplikationInstallationTyp

Quellcode

[Visual Basic]
        Public Applikation_Installationtyp As New TKB.VV.DB.clsApplikationInstallationTyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikationabhaengigkeit -Feld

[Visual Basic]
Public Applikationabhaengigkeit As clsApplikationsabhaengigkeit

Quellcode

[Visual Basic]
        Public Applikationabhaengigkeit As New TKB.VV.Applikation.clsApplikationsabhaengigkeit

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikationabhaengigkeiten -Feld

[Visual Basic]
Public Applikationabhaengigkeiten As DomainTable

Quellcode

[Visual Basic]
        Public Applikationabhaengigkeiten As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikationskontakt -Feld

[Visual Basic]
Public Applikationskontakt As clsKontakt

Quellcode

[Visual Basic]
        Public Applikationskontakt As New TKB.VV.Applikation.clsKontakt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Applikationskontakte -Feld

[Visual Basic]
Public Applikationskontakte As DomainTable

Quellcode

[Visual Basic]
        Public Applikationskontakte As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Dokument -Feld

[Visual Basic]
Public Dokument As clsDok

Quellcode

[Visual Basic]
        Public Dokument As New TKB.VV.DMS.clsDok

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


InstallationStandard -Feld

[Visual Basic]
Public InstallationStandard As DataTable

Quellcode

[Visual Basic]
        Public InstallationStandard As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Installation_Standard -Feld

[Visual Basic]
Private Installation_Standard As clsApplikationStandardTyp

Quellcode

[Visual Basic]
        Private Installation_Standard As New TKB.VV.DB.clsApplikationStandardTyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Installiert_als -Feld

[Visual Basic]
Private Installiert_als As clsInstallationAlsTyp

Quellcode

[Visual Basic]
        Private Installiert_als As New TKB.VV.DB.clsInstallationAlsTyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Installiert_auf -Feld

[Visual Basic]
Private Installiert_auf As clsInstallationTyp

Quellcode

[Visual Basic]
        Private Installiert_auf As New TKB.VV.DB.clsInstallationTyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Installiertals -Feld

[Visual Basic]
Public Installiertals As DataTable

Quellcode

[Visual Basic]
        Public Installiertals As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Installiertauf -Feld

[Visual Basic]
Public Installiertauf As DataTable

Quellcode

[Visual Basic]
        Public Installiertauf As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Kritikalitaeten -Feld

[Visual Basic]
Public Kritikalitaeten As DataTable

Quellcode

[Visual Basic]
        Public Kritikalitaeten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Lizenzen -Feld

[Visual Basic]
Public Lizenzen As DataTable

Quellcode

[Visual Basic]
        Public Lizenzen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Lizenzkauf -Feld

[Visual Basic]
Public Lizenzkauf As DataTable

Quellcode

[Visual Basic]
        Public Lizenzkauf As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Lizenzschluessel -Feld

[Visual Basic]
Public Lizenzschluessel As DataTable

Quellcode

[Visual Basic]
        Public Lizenzschluessel As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Marktbereiche -Feld

[Visual Basic]
Public Marktbereiche As DataTable

Quellcode

[Visual Basic]
        Public Marktbereiche As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Parentelemente -Feld

[Visual Basic]
Public Parentelemente As clsParentelemente

Quellcode

[Visual Basic]
        Public Parentelemente As New TKB.VV.Vertrag.clsParentelemente

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Periodizitäten -Feld

[Visual Basic]
Public Periodizitäten As DataTable

Quellcode

[Visual Basic]
        Public Periodizitäten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


RFCBoards -Feld

[Visual Basic]
Public RFCBoards As DataTable

Quellcode

[Visual Basic]
        Public RFCBoards As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


ReleaseLogbooks -Feld

[Visual Basic]
Public ReleaseLogbooks As DomainTable

Quellcode

[Visual Basic]
        Public ReleaseLogbooks As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


SDAdministratoren -Feld

[Visual Basic]
Public SDAdministratoren As DataTable

Quellcode

[Visual Basic]
        Public SDAdministratoren As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


SLMs -Feld

[Visual Basic]
Public SLMs As DataTable

Quellcode

[Visual Basic]
        Public SLMs As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Stammdaten -Feld

[Visual Basic]
Private Stammdaten As clsStammdaten

Quellcode

[Visual Basic]
        Private Stammdaten As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Teams -Feld

[Visual Basic]
Public Teams As DataTable

Quellcode

[Visual Basic]
        Public Teams As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


TestAufwendungen -Feld

[Visual Basic]
Public TestAufwendungen As DataTable

Quellcode

[Visual Basic]
        Public TestAufwendungen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Testaufwand -Feld

[Visual Basic]
Private Testaufwand As clsApplikationTestAZ

Quellcode

[Visual Basic]
        Private Testaufwand As New TKB.VV.DB.clsApplikationTestAZ

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Verantwortungen -Feld

[Visual Basic]
Public Verantwortungen As DataTable

Quellcode

[Visual Basic]
        Public Verantwortungen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


Vertragselement -Feld

[Visual Basic]
Public Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
        Public Vertragselement As New TKB.VV.Vertrag.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


VertragselementApplikation -Feld

[Visual Basic]
Public VertragselementApplikation As clsVertragselementApplikation

Quellcode

[Visual Basic]
        Public VertragselementApplikation As New TKB.VV.Vertrag.clsVertragselementApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


VertragselementApplikationen -Feld

[Visual Basic]
Public VertragselementApplikationen As DomainTable

Quellcode

[Visual Basic]
        Public VertragselementApplikationen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


daten -Feld

[Visual Basic]
Public daten As DataTable

Quellcode

[Visual Basic]
        Public daten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


dokumente -Feld

[Visual Basic]
Public dokumente As DataTable

Quellcode

[Visual Basic]
        Public dokumente As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


kategorien -Feld

[Visual Basic]
Public kategorien As DataTable

Quellcode

[Visual Basic]
        Public kategorien As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bMainConnectionIsCreatedLocal -Feld

[Visual Basic]
Protected m_bMainConnectionIsCreatedLocal As Boolean

Quellcode

[Visual Basic]
        Protected	m_bMainConnectionIsCreatedLocal As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


m_cpMainConnectionProvider -Feld

[Visual Basic]
Protected m_cpMainConnectionProvider As clsConnectionProvider

Quellcode

[Visual Basic]
        Protected	m_cpMainConnectionProvider As clsConnectionProvider

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


m_iErrorCode -Feld

[Visual Basic]
Protected m_iErrorCode As SqlInt32

Quellcode

[Visual Basic]
        Protected	m_iErrorCode As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


m_iRowsAffected -Feld

[Visual Basic]
Protected m_iRowsAffected As Integer

Quellcode

[Visual Basic]
        Protected	m_iRowsAffected As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


m_scoMainConnection -Feld

[Visual Basic]
Protected m_scoMainConnection As SqlConnection

Quellcode

[Visual Basic]
        Protected	m_scoMainConnection As SqlConnection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsApplikationLogbuch -Klasse

For a list of all members of this type, see clsApplikationLogbuch-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationLogbuch

[Visual Basic]
Public Class clsApplikationLogbuch
    Inherits clsApplikationLogbuch

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationLogbuch-Member


clsApplikationLogbuch-Member

clsApplikationLogbuch Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationLogbuch -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAbnahmeFBDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daAbnahmeTecDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daFreigabeDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daReleasedatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iAbnahmeFBPerson (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iAbnahmeTecPerson (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iApplikationLogbuchNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFreigabedurch (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iReleaseartnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_ApplikationLogubuch Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Get_ApplikationLogbuch Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Get_Dokumente Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues

Unterstützt von .NET Compact Framework

Felder

public field Dokument

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Personen

Unterstützt von .NET Compact Framework
public field Personen1

Unterstützt von .NET Compact Framework
public field Personen2

Unterstützt von .NET Compact Framework
public field Releasearten

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field dokumente

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


clsApplikationLogbuch -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            Releasearten = Stammdaten.Get_Stammdaten("Releaseart", "Bezeichnung")
            Personen = Stammdaten.Get_Stammdaten("Person", "Name")
            Personen1 = Stammdaten.Get_Stammdaten("Person1", "Name")
            Personen2 = Stammdaten.Get_Stammdaten("Person2", "Name")
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch-Eigenschaften

clsApplikationLogbuch Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAbnahmeFBDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daAbnahmeTecDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daFreigabeDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property daReleasedatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iAbnahmeFBPerson (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iAbnahmeTecPerson (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iApplikationLogbuchNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFreigabedurch (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iReleaseartnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


clsApplikationLogbuch.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daAbnahmeFBDatum -Eigenschaft

[Visual Basic]
Public Property daAbnahmeFBDatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daAbnahmeFBDatum]() As SqlDateTime
            Get
                Return m_daAbnahmeFBDatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daAbnahmeFBDatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daAbnahmeTecDatum -Eigenschaft

[Visual Basic]
Public Property daAbnahmeTecDatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daAbnahmeTecDatum]() As SqlDateTime
            Get
                Return m_daAbnahmeTecDatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daAbnahmeTecDatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daFreigabeDatum -Eigenschaft

[Visual Basic]
Public Property daFreigabeDatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daFreigabeDatum]() As SqlDateTime
            Get
                Return m_daFreigabeDatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daFreigabeDatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.daReleasedatum -Eigenschaft

[Visual Basic]
Public Property daReleasedatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daReleasedatum]() As SqlDateTime
            Get
                Return m_daReleasedatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daReleasedatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iAbnahmeFBPerson -Eigenschaft

[Visual Basic]
Public Property iAbnahmeFBPerson() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAbnahmeFBPerson]() As SqlInt32
            Get
                Return m_iAbnahmeFBPerson
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAbnahmeFBPerson = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iAbnahmeTecPerson -Eigenschaft

[Visual Basic]
Public Property iAbnahmeTecPerson() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAbnahmeTecPerson]() As SqlInt32
            Get
                Return m_iAbnahmeTecPerson
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAbnahmeTecPerson = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iApplikationLogbuchNr -Eigenschaft

[Visual Basic]
Public Property iApplikationLogbuchNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationLogbuchNr]() As SqlInt32
            Get
                Return m_iApplikationLogbuchNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationLogbuchNrTmp As SqlInt32 = Value
                If iApplikationLogbuchNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationLogbuchNr", "iApplikationLogbuchNr can't be NULL")
                End If
                m_iApplikationLogbuchNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iFreigabedurch -Eigenschaft

[Visual Basic]
Public Property iFreigabedurch() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFreigabedurch]() As SqlInt32
            Get
                Return m_iFreigabedurch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFreigabedurch = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.iReleaseartnr -Eigenschaft

[Visual Basic]
Public Property iReleaseartnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReleaseartnr]() As SqlInt32
            Get
                Return m_iReleaseartnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReleaseartnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch-Methoden

clsApplikationLogbuch Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_ApplikationLogubuch Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Get_ApplikationLogbuch Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Get_Dokumente Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


clsApplikationLogbuch.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Applikationnr As Integer _
) As Integer

Parameter

Applikationnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Applikationnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("ApplikationLogbuch")
            db.Dispose()
            Me.iApplikationLogbuchNr = New SqlInt32(CType(newkey, Int32))
            Me.iApplikationNr = New SqlInt32(CType(Applikationnr, Int32))
            Me.daFreigabeDatum = New SqlDateTime(CType("01.01.1900", SqlDateTime))
            Me.daReleasedatum = New SqlDateTime(CType("01.01.1900", SqlDateTime))
            Me.daAbnahmeTecDatum = New SqlDateTime(CType("01.01.1900", SqlDateTime))
            Me.iReleaseartnr = New SqlInt32(CType(0, Int32))
            Me.daAbnahmeFBDatum = New SqlDateTime(CType("01.01.1900", SqlDateTime))
            Me.iFreigabedurch = New SqlInt32(CType(0, Int32))
            Me.iAbnahmeFBPerson = New SqlInt32(CType(0, Int32))
            Me.iAbnahmeTecPerson = New SqlInt32(CType(0, Int32))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

Siehe auch

clsApplikationLogbuch | Vertragsverwaltung.TKB.VV.Applikation


clsApplikationLogbuch.Delete_ApplikationLogubuch -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_ApplikationLogubuch( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_ApplikationLogubuch(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_ApplikationLogbuch(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Me.Neuer_Datensatz = False
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Get_ApplikationLogbuch -Methode

Kuendigungsfrist lesen

[Visual Basic]
Public Function Get_ApplikationLogbuch( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_ApplikationLogbuch(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationLogbuchNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Get_Dokumente -Methode

Dokumente lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Dokumente( _
   ByRef c1data As C1TrueDBGrid, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByRef c1data As C1TrueDBGrid, Optional ByVal ImgList As ImageList = Nothing)
            Try
                dokumente.Dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            dokumente = Dokument.Get_Dokumente(Me.iApplikationLogbuchNr.Value, 4)
            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationLogbuchNr</LI> <LI>daReleasedatum. May be SqlDateTime.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iReleaseartnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iAbnahmeFBPerson. May be SqlInt32.Null</LI> <LI>daAbnahmeFBDatum. May be SqlDateTime.Null</LI> <LI>iAbnahmeTecPerson. May be SqlInt32.Null</LI> <LI>daAbnahmeTecDatum. May be SqlDateTime.Null</LI> <LI>iFreigabedurch. May be SqlInt32.Null</LI> <LI>daFreigabeDatum. May be SqlDateTime.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationLogbuch_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationLogbuchNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationLogbuchNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daReleasedatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daReleasedatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAbnahmeFBPerson", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAbnahmeFBPerson))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAbnahmeFBDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAbnahmeFBDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAbnahmeTecPerson", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAbnahmeTecPerson))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAbnahmeTecDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAbnahmeTecDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFreigabedurch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabedurch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daFreigabeDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daFreigabeDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationLogbuch_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationLogbuch::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iApplikationLogbuchNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationLogbuch_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationLogbuch")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationLogbuch_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationLogbuch::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationLogbuchNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationLogbuchNr</LI> <LI>daReleasedatum</LI> <LI>sBezeichnung</LI> <LI>iReleaseartnr</LI> <LI>sBemerkung</LI> <LI>iAbnahmeFBPerson</LI> <LI>daAbnahmeFBDatum</LI> <LI>iAbnahmeTecPerson</LI> <LI>daAbnahmeTecDatum</LI> <LI>iFreigabedurch</LI> <LI>daFreigabeDatum</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iApplikationNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationLogbuch_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationLogbuch")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationLogbuchNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationLogbuchNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationLogbuch_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationLogbuchNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationLogbuchNr"), Integer))
                    If dtToReturn.Rows(0)("Releasedatum") Is System.DBNull.Value Then
                        m_daReleasedatum = SqlDateTime.Null
                    Else
                        m_daReleasedatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Releasedatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Releaseartnr") Is System.DBNull.Value Then
                        m_iReleaseartnr = SqlInt32.Null
                    Else
                        m_iReleaseartnr = New SqlInt32(CType(dtToReturn.Rows(0)("Releaseartnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("AbnahmeFBPerson") Is System.DBNull.Value Then
                        m_iAbnahmeFBPerson = SqlInt32.Null
                    Else
                        m_iAbnahmeFBPerson = New SqlInt32(CType(dtToReturn.Rows(0)("AbnahmeFBPerson"), Integer))
                    End If
                    If dtToReturn.Rows(0)("AbnahmeFBDatum") Is System.DBNull.Value Then
                        m_daAbnahmeFBDatum = SqlDateTime.Null
                    Else
                        m_daAbnahmeFBDatum = New SqlDateTime(CType(dtToReturn.Rows(0)("AbnahmeFBDatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("AbnahmeTecPerson") Is System.DBNull.Value Then
                        m_iAbnahmeTecPerson = SqlInt32.Null
                    Else
                        m_iAbnahmeTecPerson = New SqlInt32(CType(dtToReturn.Rows(0)("AbnahmeTecPerson"), Integer))
                    End If
                    If dtToReturn.Rows(0)("AbnahmeTecDatum") Is System.DBNull.Value Then
                        m_daAbnahmeTecDatum = SqlDateTime.Null
                    Else
                        m_daAbnahmeTecDatum = New SqlDateTime(CType(dtToReturn.Rows(0)("AbnahmeTecDatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Freigabedurch") Is System.DBNull.Value Then
                        m_iFreigabedurch = SqlInt32.Null
                    Else
                        m_iFreigabedurch = New SqlInt32(CType(dtToReturn.Rows(0)("Freigabedurch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("FreigabeDatum") Is System.DBNull.Value Then
                        m_daFreigabeDatum = SqlDateTime.Null
                    Else
                        m_daFreigabeDatum = New SqlDateTime(CType(dtToReturn.Rows(0)("FreigabeDatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationLogbuch::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Set_Imagevalues -Methode

[Visual Basic]
Private Sub Set_Imagevalues( _
   ByRef c1data As C1TrueDBGrid, _
   ByRef imglist As ImageList _
)

Parameter

c1data
imglist

Quellcode

[Visual Basic]
        Private Sub Set_Imagevalues(ByRef c1data As C1TrueDBGrid, ByRef imglist As ImageList)

            Dim i As Integer
            Dim s As String
            For i = 0 To dokumente.Rows.Count - 1
                s = dokumente.Rows(i).Item("Filename")
                If Len(s) < 4 Then s = ".div"
                Select Case UCase(s.Substring(Len(s) - 4, 4))
                    Case ".PDF"
                        dokumente.Rows(i).Item("DokIcon") = 0
                    Case ".DOC"
                        dokumente.Rows(i).Item("DokIcon") = 1
                    Case ".XLS"
                        dokumente.Rows(i).Item("DokIcon") = 2
                    Case ".PPT"
                        dokumente.Rows(i).Item("DokIcon") = 3
                    Case ".HTM", "TML", "XML"
                        dokumente.Rows(i).Item("DokIcon") = 4
                    Case ".MSG"
                        dokumente.Rows(i).Item("DokIcon") = 5
                    Case Else
                        dokumente.Rows(i).Item("DokIcon") = 6
                End Select
            Next

            Dim bmp0 As New Bitmap(imglist.Images(0))
            Dim bmp1 As New Bitmap(imglist.Images(1))
            Dim bmp2 As New Bitmap(imglist.Images(2))
            Dim bmp3 As New Bitmap(imglist.Images(3))
            Dim bmp4 As New Bitmap(imglist.Images(4))
            Dim bmp5 As New Bitmap(imglist.Images(5))
            Dim bmp6 As New Bitmap(imglist.Images(6))
            Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v4 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v5 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v6 As New C1.Win.C1TrueDBGrid.ValueItem()

            v0.DisplayValue = bmp0
            v0.Value = 0

            v1.DisplayValue = bmp1
            v1.Value = 1

            v2.DisplayValue = bmp2
            v2.Value = 2

            v3.DisplayValue = bmp3
            v3.Value = 3

            v4.DisplayValue = bmp4
            v4.Value = 4

            v5.DisplayValue = bmp5
            v5.Value = 5

            v6.DisplayValue = bmp6
            v6.Value = 6

            c1data.Columns("dokicon").ValueItems.Values.Add(v0)
            c1data.Columns("dokicon").ValueItems.Values.Add(v1)
            c1data.Columns("dokicon").ValueItems.Values.Add(v2)
            c1data.Columns("dokicon").ValueItems.Values.Add(v3)
            c1data.Columns("dokicon").ValueItems.Values.Add(v4)
            c1data.Columns("dokicon").ValueItems.Values.Add(v5)
            c1data.Columns("dokicon").ValueItems.Values.Add(v6)
            c1data.Columns("dokicon").ValueItems.Translate = True

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationLogbuchNr</LI> <LI>daReleasedatum. May be SqlDateTime.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iReleaseartnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iAbnahmeFBPerson. May be SqlInt32.Null</LI> <LI>daAbnahmeFBDatum. May be SqlDateTime.Null</LI> <LI>iAbnahmeTecPerson. May be SqlInt32.Null</LI> <LI>daAbnahmeTecDatum. May be SqlDateTime.Null</LI> <LI>iFreigabedurch. May be SqlInt32.Null</LI> <LI>daFreigabeDatum. May be SqlDateTime.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationLogbuch_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationLogbuchNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationLogbuchNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daReleasedatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daReleasedatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAbnahmeFBPerson", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAbnahmeFBPerson))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAbnahmeFBDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAbnahmeFBDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAbnahmeTecPerson", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAbnahmeTecPerson))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAbnahmeTecDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAbnahmeTecDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFreigabedurch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabedurch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daFreigabeDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daFreigabeDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationLogbuch_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationLogbuch::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

Siehe auch

clsApplikationLogbuch | Vertragsverwaltung.TKB.VV.Applikation


clsApplikationLogbuch-Felder

clsApplikationLogbuch Übersicht

Felder

public field Dokument

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Personen

Unterstützt von .NET Compact Framework
public field Personen1

Unterstützt von .NET Compact Framework
public field Personen2

Unterstützt von .NET Compact Framework
public field Releasearten

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field dokumente

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


Dokument -Feld

[Visual Basic]
Public Dokument As clsDok

Quellcode

[Visual Basic]
        Public Dokument As New TKB.VV.DMS.clsDok

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Personen -Feld

[Visual Basic]
Public Personen As DataTable

Quellcode

[Visual Basic]
        Public Personen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Personen1 -Feld

[Visual Basic]
Public Personen1 As DataTable

Quellcode

[Visual Basic]
        Public Personen1 As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Personen2 -Feld

[Visual Basic]
Public Personen2 As DataTable

Quellcode

[Visual Basic]
        Public Personen2 As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Releasearten -Feld

[Visual Basic]
Public Releasearten As DataTable

Quellcode

[Visual Basic]
        Public Releasearten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


Stammdaten -Feld

[Visual Basic]
Private Stammdaten As clsStammdaten

Quellcode

[Visual Basic]
        Private Stammdaten As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


dokumente -Feld

[Visual Basic]
Public dokumente As DataTable

Quellcode

[Visual Basic]
        Public dokumente As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationTree -Klasse

For a list of all members of this type, see clsApplikationTree-Member.

System.Object
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationTree

[Visual Basic]
Public Class clsApplikationTree

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationTree-Member


clsApplikationTree-Member

clsApplikationTree Übersicht

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework |
public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treedata Überladen. Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

Felder

private field Treedata

Unterstützt von .NET Compact Framework

clsApplikationTree -Klasse


clsApplikationTree-Methoden

clsApplikationTree Übersicht

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework |
public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treedata Überladen. Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

clsApplikationTree -Klasse


clsApplikationTree.FindNode -Methode

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
SearchVal
SearchString

Quellcode

[Visual Basic]
        Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
            Dim tmpNode As TreeNode
            For Each _child As TreeNode In _nodeCollection
                If _child.Tag = SearchVal Then

                    Return _child
                End If
                tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
                If Not tmpNode Is Nothing Then
                    Return tmpNode
                End If
            Next
            Return Nothing
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationTree.LoadTreeView -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadTreeView( _
   ByVal oDS As DataSet, _
   ByRef oTreeview As TreeView _
)

Parameter

oDS
oTreeview

Quellcode

[Visual Basic]
        Private Sub LoadTreeView(ByVal oDS As DataSet, ByRef oTreeview As TreeView)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode As New TreeNode()
                        oNode.Text = oDataRow("Bezeichnung").ToString()
                        oNode.Tag = oDataRow("applikationsnr").ToString
                        If oNode.Tag < 0 Then
                            oNode.ImageIndex = 0
                            oNode.SelectedImageIndex = 0
                            oNode.StateImageIndex = 0
                        Else
                            If oDataRow.Item("Aktiv") = 0 Then
                                oNode.ImageIndex = 2
                                oNode.SelectedImageIndex = 2
                                oNode.StateImageIndex = 2
                                'If oDataRow.Item("Lic") = True Then
                                '    oNode.ImageIndex = 4
                                '    oNode.SelectedImageIndex = 4
                                '    oNode.StateImageIndex = 4
                                'End If
                            Else
                                oNode.ImageIndex = 1
                                oNode.SelectedImageIndex = 1
                                oNode.StateImageIndex = 1
                                'If oDataRow.Item("Lic") = True Then
                                '    oNode.ImageIndex = 3
                                '    oNode.SelectedImageIndex = 3
                                '    oNode.StateImageIndex = 3
                                'End If
                                End If
                        End If
                        oTreeview.Nodes.Add(oNode)
                        RecursivelyLoadTree(oDataRow, oNode)
                    End If
                    End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationTree.Load_Tree -Methode

Laden der Treedaten und Tree aufbauen

[Visual Basic]
Public Function Load_Tree( _
   ByRef tree As TreeView, _
   Optional ByVal Insert_Initial_Entry As Boolean = False, _
   Optional ByVal suchstring As String = "", _
   Optional ByVal nuraktive As Boolean = False, _
   Optional ByVal Archivobjekte As Boolean = False _
) As Object

Parameter

tree
Erforderlich.
Insert_Initial_Entry
Optional. Der Standardwert ist False.
suchstring
Optional. Der Standardwert ist "".
nuraktive
Optional. Der Standardwert ist False.
Archivobjekte
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
        Public Function Load_Tree(ByRef tree As TreeView, Optional ByVal Insert_Initial_Entry As Boolean = False, Optional ByVal suchstring As String = "", Optional ByVal nuraktive As Boolean = False, Optional ByVal Archivobjekte As Boolean = False)
            tree.Enabled = False
            tree.BeginUpdate()

            If suchstring <> "" Then
                Load_Treedata(suchstring, nuraktive, Archivobjekte)
            Else
                Load_Treedata(nuraktive)
            End If
            tree.Nodes.Clear()
            If Insert_Initial_Entry Then
                Dim tn As TreeNode = tree.Nodes.Add("--- Keine ---")
                tn.Tag = 0
            End If
            Load_Treeview(Treedata, tree)
            tree.ExpandAll()
            tree.EndUpdate()
            tree.Enabled = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


Load_Treedata -Methode

Überladungsliste

[Visual Basic] Private Function Load_Treedata(String, Boolean, Boolean) As DataTable
[C#] private DataTable Load_Treedata(string, bool, bool);

Treedaten ab Datenbank laden

[Visual Basic] Private Function Load_Treedata(Boolean) As DataTable
[C#] private DataTable Load_Treedata(bool);

clsApplikationTree | Vertragsverwaltung.TKB.VV.Applikation


clsApplikationTree.Load_Treeview -Methode

Interne Relation aufbauen und Tree aufbauen

[Visual Basic]
Private Sub Load_Treeview( _
   ByVal oSourceData As DataSet, _
   ByRef tree As TreeView _
)

Parameter

oSourceData
tree

Quellcode

[Visual Basic]
        Private Sub Load_Treeview(ByVal oSourceData As DataSet, ByRef tree As TreeView)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.Tables(0).DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("applikationsnr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadTreeView(oDS, tree)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationTree.RecursivelyLoadTree -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadTree( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode _
)

Parameter

oDataRow
oNode

Quellcode

[Visual Basic]
        Private Sub RecursivelyLoadTree(ByVal oDataRow As DataRow, ByRef oNode As TreeNode)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = oChildRow("applikationsnr").ToString()
                If oChildRow.Item("Aktiv") = False Then
                    oChildNode.ImageIndex = 2
                    oChildNode.SelectedImageIndex = 2
                    oChildNode.StateImageIndex = 2
                    If oChildRow.Item("Lic") = True Then
                        oChildNode.ImageIndex = 4
                        oChildNode.SelectedImageIndex = 4
                        oChildNode.StateImageIndex = 4
                    End If
                Else
                    oChildNode.ImageIndex = 1
                    oChildNode.SelectedImageIndex = 1
                    oChildNode.StateImageIndex = 1
                    If oChildRow.Item("Lic") = True Then
                        oChildNode.ImageIndex = 3
                        oChildNode.SelectedImageIndex = 3
                        oChildNode.StateImageIndex = 3
                    End If
                End If

                oNode.Nodes.Add(oChildNode)
                RecursivelyLoadTree(oChildRow, oChildNode)
            Next oChildRow
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationTree-Felder

clsApplikationTree Übersicht

Felder

private field Treedata

Unterstützt von .NET Compact Framework

clsApplikationTree -Klasse


Treedata -Feld

[Visual Basic]
Private Treedata As DataSet

Quellcode

[Visual Basic]
        Dim Treedata As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationsabhaengigkeit -Klasse

For a list of all members of this type, see clsApplikationsabhaengigkeit-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationsabhaengigkeit

[Visual Basic]
Public Class clsApplikationsabhaengigkeit
    Inherits clsApplikationabhaengigkeit

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationsabhaengigkeit-Member


clsApplikationsabhaengigkeit-Member

clsApplikationsabhaengigkeit Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationsabhaengigkeit -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Applname1

Unterstützt von .NET Compact Framework
public property Applname2

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationAbhaengigkeitNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationnr1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationnr2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_Referenz Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_Applikationabhaengigkeit Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragselement_Suchen Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field sApplname1

Unterstützt von .NET Compact Framework
private field sapplname2

Unterstützt von .NET Compact Framework

clsApplikationsabhaengigkeit -Klasse


clsApplikationsabhaengigkeit -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            MyBase.New()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationsabhaengigkeit-Eigenschaften

clsApplikationsabhaengigkeit Übersicht

Öffentliche Eigenschaften

public property Applname1

Unterstützt von .NET Compact Framework
public property Applname2

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationAbhaengigkeitNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationnr1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iApplikationnr2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationsabhaengigkeit -Klasse


clsApplikationsabhaengigkeit.Applname1 -Eigenschaft

[Visual Basic]
Public ReadOnly Property Applname1() As String

Quellcode

[Visual Basic]
        ReadOnly Property Applname1() As String
            Get
                Dim ap As New TKB.VV.DB.clsApplikation
                Try
                    ap.cpMainConnectionProvider = Globals.conn
                    ap.iApplikationNr = Me.iApplikationnr1.Value
                    ap.SelectOne()
                    Return ap.sBezeichnung.Value
                Catch
                    Return ""
                Finally
                    ap.Dispose()
                End Try

                Return sApplname1
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationsabhaengigkeit.Applname2 -Eigenschaft

[Visual Basic]
Public ReadOnly Property Applname2() As String

Quellcode

[Visual Basic]
        ReadOnly Property Applname2() As String
            Get
                Dim ap As New TKB.VV.DB.clsApplikation
                Try
                    ap.cpMainConnectionProvider = Globals.conn
                    ap.iApplikationNr = Me.iApplikationnr2.Value
                    ap.SelectOne()
                    Return ap.sBezeichnung.Value
                Catch
                    Return ""
                Finally
                    ap.Dispose()
                End Try

                Return sApplname1
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationabhaengigkeit.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.iApplikationAbhaengigkeitNr -Eigenschaft

[Visual Basic]
Public Property iApplikationAbhaengigkeitNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationAbhaengigkeitNr]() As SqlInt32
            Get
                Return m_iApplikationAbhaengigkeitNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationAbhaengigkeitNrTmp As SqlInt32 = Value
                If iApplikationAbhaengigkeitNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationAbhaengigkeitNr", "iApplikationAbhaengigkeitNr can't be NULL")
                End If
                m_iApplikationAbhaengigkeitNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.iApplikationnr1 -Eigenschaft

[Visual Basic]
Public Property iApplikationnr1() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationnr1]() As SqlInt32
            Get
                Return m_iApplikationnr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationnr1 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.iApplikationnr2 -Eigenschaft

[Visual Basic]
Public Property iApplikationnr2() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationnr2]() As SqlInt32
            Get
                Return m_iApplikationnr2
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationnr2 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationsabhaengigkeit-Methoden

clsApplikationsabhaengigkeit Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_Referenz Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_Applikationabhaengigkeit Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragselement_Suchen Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

clsApplikationsabhaengigkeit -Klasse


clsApplikationsabhaengigkeit.Add_New -Methode

Neue Vertragselement_Referenz erstellen

[Visual Basic]
Public Function Add_New( _
   ByVal Applikationnr As Integer _
) As Integer

Parameter

Applikationnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Applikationnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("ApplikationAbhaengigkeit")
            db.Dispose()
            Me.iApplikationAbhaengigkeitNr = New SqlInt32(CType(newkey, Int32))
            Me.iApplikationnr1 = New SqlInt32(CType(Applikationnr, Int32))
            Me.iApplikationnr2 = New SqlInt32(CType(0, Int32))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes.

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

Siehe auch

clsApplikationsabhaengigkeit | Vertragsverwaltung.TKB.VV.Applikation


clsApplikationsabhaengigkeit.Delete_Referenz -Methode

Löschen eines Datensatzes.

[Visual Basic]
Public Function Delete_Referenz( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Referenz(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Applikationabhaengigkeit(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationsabhaengigkeit.Get_Applikationabhaengigkeit -Methode

Vertragselement_Referenz lesen

[Visual Basic]
Public Function Get_Applikationabhaengigkeit( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Applikationabhaengigkeit(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationAbhaengigkeitNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationabhaengigkeit.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationAbhaengigkeitNr</LI> <LI>iApplikationnr1. May be SqlInt32.Null</LI> <LI>iApplikationnr2. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikationabhaengigkeit_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationAbhaengigkeitNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationAbhaengigkeitNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr2", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikationabhaengigkeit_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationabhaengigkeit::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationsabhaengigkeit.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iApplikationAbhaengigkeitNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationabhaengigkeit.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikationabhaengigkeit_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Applikationabhaengigkeit")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikationabhaengigkeit_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationabhaengigkeit::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationAbhaengigkeitNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationAbhaengigkeitNr</LI> <LI>iApplikationnr1</LI> <LI>iApplikationnr2</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikationabhaengigkeit_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Applikationabhaengigkeit")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationAbhaengigkeitNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationAbhaengigkeitNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikationabhaengigkeit_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationAbhaengigkeitNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationAbhaengigkeitNr"), Integer))
                    If dtToReturn.Rows(0)("Applikationnr1") Is System.DBNull.Value Then
                        m_iApplikationnr1 = SqlInt32.Null
                    Else
                        m_iApplikationnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("Applikationnr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Applikationnr2") Is System.DBNull.Value Then
                        m_iApplikationnr2 = SqlInt32.Null
                    Else
                        m_iApplikationnr2 = New SqlInt32(CType(dtToReturn.Rows(0)("Applikationnr2"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationabhaengigkeit::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationAbhaengigkeitNr</LI> <LI>iApplikationnr1. May be SqlInt32.Null</LI> <LI>iApplikationnr2. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikationabhaengigkeit_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationAbhaengigkeitNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationAbhaengigkeitNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr2", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikationabhaengigkeit_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationabhaengigkeit::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationsabhaengigkeit.Vertragselement_Suchen -Methode

[Visual Basic]
Public Function Vertragselement_Suchen( _
   ByRef Vertragselementnr As Integer, _
   ByRef Vertragselement_Bezeichngung As String _
) As Boolean

Parameter

Vertragselementnr
Vertragselement_Bezeichngung

Quellcode

[Visual Basic]
        Public Function Vertragselement_Suchen(ByRef Vertragselementnr As Integer, ByRef Vertragselement_Bezeichngung As String) As Boolean
            Dim vesuche As New frmVertragselementSuche
            vesuche.ShowDialog()
            Try
                If vesuche.DialogResult = DialogResult.OK Then
                    Vertragselementnr = vesuche.Vertragselementnr
                    Vertragselement_Bezeichngung = vesuche.Vertragselement_Bezeichnung
                    Return True
                Else
                    Vertragselementnr = -1
                    Vertragselement_Bezeichngung = ""
                    Return False
                End If
            Catch ex As Exception
                Vertragselementnr = -1
                Vertragselement_Bezeichngung = ""
                Return False
            Finally
                vesuche.dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

Siehe auch

clsApplikationsabhaengigkeit | Vertragsverwaltung.TKB.VV.Applikation


clsApplikationsabhaengigkeit-Felder

clsApplikationsabhaengigkeit Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field sApplname1

Unterstützt von .NET Compact Framework
private field sapplname2

Unterstützt von .NET Compact Framework

clsApplikationsabhaengigkeit -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


sApplname1 -Feld

[Visual Basic]
Private sApplname1 As String

Quellcode

[Visual Basic]
        Dim sApplname1 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


sapplname2 -Feld

[Visual Basic]
Private sapplname2 As String

Quellcode

[Visual Basic]
        Dim sapplname2 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationsuebersicht -Klasse

For a list of all members of this type, see clsApplikationsuebersicht-Member.

System.Object
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationsuebersicht

[Visual Basic]
Public Class clsApplikationsuebersicht

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationsuebersicht-Member


clsApplikationsuebersicht-Member

clsApplikationsuebersicht Übersicht

Öffentliche Methoden

public method Get_Applikationsdetails

Unterstützt von .NET Compact Framework

clsApplikationsuebersicht -Klasse


clsApplikationsuebersicht-Methoden

clsApplikationsuebersicht Übersicht

Öffentliche Methoden

public method Get_Applikationsdetails

Unterstützt von .NET Compact Framework

clsApplikationsuebersicht -Klasse


clsApplikationsuebersicht.Get_Applikationsdetails -Methode

[Visual Basic]
Public Function Get_Applikationsdetails( _
   ByVal EntryRoot As Integer, _
   ByVal Suchstring As String _
) As DataTable

Parameter

EntryRoot
Suchstring

Quellcode

[Visual Basic]
        Public Function Get_Applikationsdetails(ByVal EntryRoot As Integer, ByVal Suchstring As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_applikationsuebersicht_get_details"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@EntryRoot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, EntryRoot))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Suchstring))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsApplikationsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsuebersicht


clsKontakt -Klasse

For a list of all members of this type, see clsKontakt-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt
Vertragsverwaltung.TKB.VV.Applikation.clsKontakt

[Visual Basic]
Public Class clsKontakt
    Inherits clsApplikationKontakt

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Applikation

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKontakt-Member


clsKontakt-Member

clsKontakt Übersicht

Öffentliche Konstruktoren

public constructor clsKontakt -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property bIntern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iApplikationKontaktnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_Applikationskontakt Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Applikationskontakt Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakt -Klasse


clsApplikationKontakt -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsKontakt-Eigenschaften

clsKontakt Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property bIntern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iApplikationKontaktnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakt -Klasse


clsApplikationKontakt.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.bIntern -Eigenschaft

[Visual Basic]
Public Property bIntern() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bIntern]() As SqlBoolean
            Get
                Return m_bIntern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bIntern = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iApplikationKontaktnr -Eigenschaft

[Visual Basic]
Public Property iApplikationKontaktnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationKontaktnr]() As SqlInt32
            Get
                Return m_iApplikationKontaktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationKontaktnrTmp As SqlInt32 = Value
                If iApplikationKontaktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationKontaktnr", "iApplikationKontaktnr can't be NULL")
                End If
                m_iApplikationKontaktnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iApplikationnr -Eigenschaft

[Visual Basic]
Public Property iApplikationnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationnr]() As SqlInt32
            Get
                Return m_iApplikationnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iKontakttypNr -Eigenschaft

[Visual Basic]
Public Property iKontakttypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKontakttypNr]() As SqlInt32
            Get
                Return m_iKontakttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKontakttypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iPersonNr -Eigenschaft

[Visual Basic]
Public Property iPersonNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsKontakt-Methoden

clsKontakt Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_Applikationskontakt Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Applikationskontakt Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKontakt -Klasse


clsKontakt.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Applikationnr As Integer _
) As Integer

Parameter

Applikationnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Applikationnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Applikationkontakt")
            db.Dispose()
            Me.iApplikationKontaktnr = New SqlInt32(CType(newkey, Int32))
            Me.iApplikationnr = New SqlInt32(CType(ApplikationNr, Int32))
            Me.iKontakttypNr = New SqlInt32(CType(0, Int32))
            Me.iPersonNr = New SqlInt32(CType(0, Int32))
            Me.bIntern = New SqlBoolean(CType(False, Boolean))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsKontakt.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Applikationskontakt(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Applikationkontakt")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationKontaktnr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsKontakt | Vertragsverwaltung.TKB.VV.Applikation


clsKontakt.Delete_Applikationskontakt -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_Applikationskontakt( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Applikationskontakt(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Applikationskontakt(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Me.Neuer_Datensatz = False
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


Dispose -Methode

Überladungsliste

[Visual Basic] Public Overloads Sub Dispose()
[C#] public System.Void Dispose();

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

clsDBInteractionBase | Vertragsverwaltung.TKB.VV.DB


clsKontakt.Get_Applikationskontakt -Methode

Kuendigungsfrist lesen

[Visual Basic]
Public Function Get_Applikationskontakt( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Applikationskontakt(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iApplikationKontaktnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsApplikationKontakt.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKontaktnr</LI> <LI>iApplikationnr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKontakt_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKontaktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKontaktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKontakt_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKontakt::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsKontakt.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iApplikationKontaktnr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsApplikationKontakt.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKontakt_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKontakt_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKontakt::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKontaktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationKontaktnr</LI> <LI>iApplikationnr</LI> <LI>iPersonNr</LI> <LI>iKontakttypNr</LI> <LI>bIntern</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKontakt_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationKontaktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKontaktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKontakt_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationKontaktnr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationKontaktnr"), Integer))
                    If dtToReturn.Rows(0)("Applikationnr") Is System.DBNull.Value Then
                        m_iApplikationnr = SqlInt32.Null
                    Else
                        m_iApplikationnr = New SqlInt32(CType(dtToReturn.Rows(0)("Applikationnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PersonNr") Is System.DBNull.Value Then
                        m_iPersonNr = SqlInt32.Null
                    Else
                        m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("KontakttypNr") Is System.DBNull.Value Then
                        m_iKontakttypNr = SqlInt32.Null
                    Else
                        m_iKontakttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("KontakttypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Intern") Is System.DBNull.Value Then
                        m_bIntern = SqlBoolean.Null
                    Else
                        m_bIntern = New SqlBoolean(CType(dtToReturn.Rows(0)("Intern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKontakt::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKontaktnr</LI> <LI>iApplikationnr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKontakt_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKontaktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKontaktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKontakt_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKontakt::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsKontakt-Felder

clsKontakt Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakt -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


Vertragsverwaltung.TKB.VV.DB -Namespace

Klassen

public class DB_Connection Unterstützt von .NET Compact Framework | Dynamische Datenbank-Verbindung aufbauen. Verwendet wird standardmässig Vertragsverwaltung.cfg. Sollen Datenbank-Verbindungen zur Auswahl angezeigt werden, werden sämntliche Datenbank-Verbindungsdateien mit dem Namen "Vertragsverwaltung....cfg" berücksichtigt
public class MyMitarbeiter Unterstützt von .NET Compact Framework |
public class clsAktivitaet Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Aktivitaet'.
public class clsAktivitaetStatus Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'AktivitaetStatus'.
public class clsApplication Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Application'.
public class clsApplikation Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Applikation'.
public class clsApplikationInstallationAls Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationInstallationAls'.
public class clsApplikationInstallationFuer Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationInstallationFuer'.
public class clsApplikationInstallationTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationInstallationTyp'.
public class clsApplikationKategorie Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationKategorie'.
public class clsApplikationKontakt Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationKontakt'.
public class clsApplikationKritikalitaetTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationKritikalitaetTyp'.
public class clsApplikationLogbuch Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationLogbuch'.
public class clsApplikationSLMTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationSLMTyp'.
public class clsApplikationStandardTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationStandardTyp'.
public class clsApplikationTeam Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationTeam'.
public class clsApplikationTestAZ Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationTestAZ'.
public class clsApplikationVerantwortung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ApplikationVerantwortung'.
public class clsApplikationabhaengigkeit Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Applikationabhaengigkeit'.
public class clsAuswertung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Auswertung'.
public class clsAuswertungAuswertungParameter Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'AuswertungAuswertungParameter'.
public class clsAuswertungGruppe Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'AuswertungGruppe'.
public class clsAuswertungGruppeAuswertung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'AuswertungGruppeAuswertung'.
public class clsAuswertungsparameter Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Auswertungsparameter'.
public class clsBeziehungstyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Beziehungstyp'.
public class clsConnectionProvider Unterstützt von .NET Compact Framework |
public class clsDBInteractionBase Unterstützt von .NET Compact Framework |
public class clsDokument Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Dokument'.
public class clsDokumentAblageTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'DokumentAblageTyp'.
public class clsDokumentAblageort Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'DokumentAblageort'.
public class clsDokumenttyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Dokumenttyp'.
public class clsEreignistyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Ereignistyp'.
public class clsFunktionsgruppe Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'funktionsgruppe'.
public class clsFunktionsgruppe_rolle Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'funktionsgruppe_rolle'.
public class clsGremium Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Gremium'.
public class clsGremiumBereich Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'GremiumBereich'.
public class clsGremiumGruppierung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'GremiumGruppierung'.
public class clsGremiumPerson Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'GremiumPerson'.
public class clsHistory Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'History'.
public class clsHistoryTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'HistoryTyp'.
public class clsInstallationAlsTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'InstallationAlsTyp'.
public class clsInstallationTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'InstallationTyp'.
public class clsKey_tabelle Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'key_tabelle'.
public class clsKontakttyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Kontakttyp'.
public class clsKostenart Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Kostenart'.
public class clsKuendigungsfrist Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Kuendigungsfrist'.
public class clsKuendigungsfristen Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Kuendigungsfristen'.
public class clsLizenzkauf Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Lizenzkauf'.
public class clsLizenzschluessel Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Lizenzschluessel'.
public class clsLizenztyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Lizenztyp'.
public class clsMandant Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'mandant'.
public class clsMarktbereich Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Marktbereich'.
public class clsMeldungstexte Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'meldungstexte'.
public class clsMitarbeiter Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'mitarbeiter'.
public class clsMitarbeiter_Auswertungsparameter Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Mitarbeiter_Auswertungsparameter'.
public class clsMitarbeiter_funktionsgruppe Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'mitarbeiter_funktionsgruppe'.
public class clsMitarbeitereinstellung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Mitarbeitereinstellung'.
public class clsMyKey_Tabelle Unterstützt von .NET Compact Framework |
public class clsPendenz Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Pendenz'.
public class clsPendenzstatus Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Pendenzstatus'.
public class clsPerson Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Person'.
public class clsPersonFunktion Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'PersonFunktion'.
public class clsProfil Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Profil'.
public class clsReleaseArt Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ReleaseArt'.
public class clsRfcBoard Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'RfcBoard'.
public class clsRfcBoard_Mitarbeiter Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'RfcBoard_Mitarbeiter'.
public class clsRolle Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'rolle'.
public class clsRolle_SecurityObject Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Rolle_SecurityObject'.
public class clsRolle_securitylevel Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'rolle_securitylevel'.
public class clsRolle_sysadminfunktion Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'rolle_sysadminfunktion'.
public class clsSLA Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SLA'.
public class clsSLAKatalog Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SLAKatalog'.
public class clsSLASubTyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SLASubTyp'.
public class clsSLATyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SLATyp'.
public class clsSecurityLevel Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SecurityLevel'.
public class clsSecurityObject Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'SecurityObject'.
public class clsServiceKatalog Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ServiceKatalog'.
public class clsServiceKatalog_SLAKatalog Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'ServiceKatalog_SLAKatalog'.
public class clsSpalten Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'spalten'.
public class clsSysadminfunktion Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'sysadminfunktion'.
public class clsTooltip Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Tooltip'.
public class clsVertragselement Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragselement'.
public class clsVertragselementApplikation Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'VertragselementApplikation'.
public class clsVertragselement_Referenz Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragselement_Referenz'.
public class clsVertragsereignis Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragsereignis'.
public class clsVertragskontakt Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragskontakt'.
public class clsVertragsleistung Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragsleistung'.
public class clsVertragspartner Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragspartner'.
public class clsVertragstyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Vertragstyp'.
public class clsZeiteinheittyp Unterstützt von .NET Compact Framework | Purpose: Data Access class for the table 'Zeiteinheittyp'.
public class mySLATyp Unterstützt von .NET Compact Framework |
public class myZeiteinheittyp Unterstützt von .NET Compact Framework |

Schnittstellen

public interface ICommonDBAccess

Unterstützt von .NET Compact Framework

Enumerationen

public enumeration LLBLError

Unterstützt von .NET Compact Framework


DB_Connection -Klasse

Dynamische Datenbank-Verbindung aufbauen. Verwendet wird standardmässig Vertragsverwaltung.cfg. Sollen Datenbank-Verbindungen zur Auswahl angezeigt werden, werden sämntliche Datenbank-Verbindungsdateien mit dem Namen "Vertragsverwaltung....cfg" berücksichtigt

For a list of all members of this type, see DB_Connection-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.DB_Connection

[Visual Basic]
Public Class DB_Connection

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

DB_Connection-Member


DB_Connection-Member

DB_Connection Übersicht

Andere Konstruktoren

private constructor Static DB_Connection -Konstructor

Unterstützt von .NET Compact Framework

 Liest sämtlcihe CFG-Dateien mit dem Namen "Vertragsverwaltung...". Sind meherere Dateien vorhanden, wird ein Auswahldialog zur Datenbank-Selektion angezeigt. Standardmässig wird Vertragsverwaltung.cfg als CFG-Datei benutzt. Die CFG-Datei ist verschlüsselt und wird über die Crypto-Funktionen entschlüsselt.

DB_Connection -Klasse


DB_Connection -Konstructor

Liest sämtlcihe CFG-Dateien mit dem Namen "Vertragsverwaltung...". Sind meherere Dateien vorhanden, wird ein Auswahldialog zur Datenbank-Selektion angezeigt. Standardmässig wird Vertragsverwaltung.cfg als CFG-Datei benutzt. Die CFG-Datei ist verschlüsselt und wird über die Crypto-Funktionen entschlüsselt.

[Visual Basic]
Private Shared Sub New()

Quellcode

[Visual Basic]
        Shared Sub New()
            Dim fc As Integer = 0
            If Globals.ConnectionFileName.Length = 0 Then
                Dim Dir As DirectoryInfo = New DirectoryInfo(Application.StartupPath)
                Try
                    Dim f As New frmDatenbankauswahl()
                    Dim ChildFile As FileInfo
                    For Each ChildFile In Dir.GetFiles()
                        If UCase(Left(ChildFile.Name, 18)) = "VERTRAGSVERWALTUNG" And UCase(ChildFile.Extension) = ".CFG" Then
                            f.ListBox1.Items.Add(ChildFile.Name)
                            fc = fc + 1
                        End If
                    Next
                    If fc > 1 Then
                        f.ListBox1.SelectedIndex = 0
                        f.ListBox1.Select()
                        f.ShowDialog()
                        Globals.ConnectionFileName = f.ListBox1.SelectedItem
                        f.Dispose()
                    End If
                Catch except As Exception
                    fc = 0
                    Exit Sub
                End Try
            End If
            If fc < 2 Then Globals.ConnectionFileName = "Vertragsverwaltung.cfg"
            Dim ofile As System.IO.File
            Dim oread As System.IO.StreamReader
            oread = ofile.OpenText(Application.StartupPath + "\" + Globals.ConnectionFileName)
            sConnectionString = oread.ReadLine
            sConnectionString = Crypto.DecryptText(sConnectionString, "HutterundMueller")
            sConnectionString = Left(sConnectionString, Len(sConnectionString) - 1)
            Globals.sConnectionString = sConnectionString
            Globals.conn.sConnectionString = sConnectionString
            oread.Close()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DB_Connection


MyMitarbeiter -Klasse

For a list of all members of this type, see MyMitarbeiter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.MyMitarbeiter

[Visual Basic]
Public Class MyMitarbeiter
    Inherits clsMitarbeiter

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyMitarbeiter-Member


MyMitarbeiter-Member

MyMitarbeiter Übersicht

Öffentliche Konstruktoren

public constructor MyMitarbeiter -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEmail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sName (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sTgnummer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sVorname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllwithFullname Unterstützt von .NET Compact Framework | Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method SelectWithTGNummer Unterstützt von .NET Compact Framework | Mitarbeiter mittels TGNummer auslesen
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Andere Methoden

private method Get_Username

Unterstützt von .NET Compact Framework

 Windows-User auslesen

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
private field ouser Unterstützt von .NET Compact Framework | Security-Deklaration zum Auslesen der UserID vom Windows-User

MyMitarbeiter -Klasse


clsMitarbeiter -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter-Eigenschaften

MyMitarbeiter Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEmail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sName (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sTgnummer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework
public property sVorname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter)

Unterstützt von .NET Compact Framework

MyMitarbeiter -Klasse


clsMitarbeiter.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.iMitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.sEmail -Eigenschaft

[Visual Basic]
Public Property sEmail() As SqlString

Quellcode

[Visual Basic]
        Public Property [sEmail]() As SqlString
            Get
                Return m_sEmail
            End Get
            Set(ByVal Value As SqlString)
                m_sEmail = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.sName -Eigenschaft

[Visual Basic]
Public Property sName() As SqlString

Quellcode

[Visual Basic]
        Public Property [sName]() As SqlString
            Get
                Return m_sName
            End Get
            Set(ByVal Value As SqlString)
                m_sName = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.sTgnummer -Eigenschaft

[Visual Basic]
Public Property sTgnummer() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTgnummer]() As SqlString
            Get
                Return m_sTgnummer
            End Get
            Set(ByVal Value As SqlString)
                m_sTgnummer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.sVorname -Eigenschaft

[Visual Basic]
Public Property sVorname() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVorname]() As SqlString
            Get
                Return m_sVorname
            End Get
            Set(ByVal Value As SqlString)
                m_sVorname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter-Methoden

MyMitarbeiter Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllwithFullname Unterstützt von .NET Compact Framework | Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method SelectWithTGNummer Unterstützt von .NET Compact Framework | Mitarbeiter mittels TGNummer auslesen
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Andere Methoden

private method Get_Username

Unterstützt von .NET Compact Framework

 Windows-User auslesen

MyMitarbeiter -Klasse


clsMitarbeiter.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter.Get_Username -Methode

Windows-User auslesen

[Visual Basic]
Private Function Get_Username() As String

Quellcode

[Visual Basic]
        Private Function Get_Username() As String
            With ouser.Identity.Name
                Return (.Substring(.IndexOf("\") + 1))
            End With
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMitarbeiter


clsMitarbeiter.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sTgnummer. May be SqlString.Null</LI> <LI>sEmail. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter.SelectAllwithFullname -Methode

Alle Mitarbeiter inkl. vollständigem Name (Fullname) auslesen

[Visual Basic]
Public Function SelectAllwithFullname() As DataTable

Rückgabewert

Datatable

Quellcode

[Visual Basic]
        Public Function SelectAllwithFullname() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMitarbeiter


clsMitarbeiter.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeiternr</LI> <LI>sVorname</LI> <LI>sName</LI> <LI>sTgnummer</LI> <LI>sEmail</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("vorname") Is System.DBNull.Value Then
                        m_sVorname = SqlString.Null
                    Else
                        m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("vorname"), String))
                    End If
                    If dtToReturn.Rows(0)("name") Is System.DBNull.Value Then
                        m_sName = SqlString.Null
                    Else
                        m_sName = New SqlString(CType(dtToReturn.Rows(0)("name"), String))
                    End If
                    If dtToReturn.Rows(0)("tgnummer") Is System.DBNull.Value Then
                        m_sTgnummer = SqlString.Null
                    Else
                        m_sTgnummer = New SqlString(CType(dtToReturn.Rows(0)("tgnummer"), String))
                    End If
                    If dtToReturn.Rows(0)("email") Is System.DBNull.Value Then
                        m_sEmail = SqlString.Null
                    Else
                        m_sEmail = New SqlString(CType(dtToReturn.Rows(0)("email"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter.SelectWithTGNummer -Methode

Mitarbeiter mittels TGNummer auslesen

[Visual Basic]
Public Function SelectWithTGNummer() As DataTable

Rückgabewert

Datatable

Quellcode

[Visual Basic]
        Public Function SelectWithTGNummer() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_mitarbeiter_SelectWithTGNummer]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try

                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Get_Username))

                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAllWithTGNummer' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If
                Return dtToReturn
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectWithTGNummer::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMitarbeiter


clsMitarbeiter.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sTgnummer. May be SqlString.Null</LI> <LI>sEmail. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


MyMitarbeiter-Felder

MyMitarbeiter Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
private field ouser Unterstützt von .NET Compact Framework | Security-Deklaration zum Auslesen der UserID vom Windows-User

MyMitarbeiter -Klasse


ouser -Feld

Security-Deklaration zum Auslesen der UserID vom Windows-User

[Visual Basic]
Private ouser As WindowsPrincipal

Quellcode

[Visual Basic]
        Dim ouser As New WindowsPrincipal(WindowsIdentity.GetCurrent)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMitarbeiter


clsAktivitaet -Klasse

Purpose: Data Access class for the table 'Aktivitaet'.

For a list of all members of this type, see clsAktivitaet-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAktivitaet
Vertragsverwaltung.tkb.vv.vertrag.clsAktivitaet

[Visual Basic]
Public Class clsAktivitaet
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAktivitaet-Member


clsAktivitaet-Member

clsAktivitaet Übersicht

Öffentliche Konstruktoren

public constructor clsAktivitaet -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAusgeloest_am

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property fBetrag

Unterstützt von .NET Compact Framework
public property iAktivitaetNr

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
public property iEreignisnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPeriodizitaetnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecuritylevelnr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEreignis

Unterstützt von .NET Compact Framework
public property sKostenart

Unterstützt von .NET Compact Framework
public property sKuendigungsfrist

Unterstützt von .NET Compact Framework
public property sTermin

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daAusgeloest_am

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_fBetrag

Unterstützt von .NET Compact Framework
private field m_iAktivitaetNr

Unterstützt von .NET Compact Framework
private field m_iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
private field m_iEreignisnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPeriodizitaetnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecuritylevelnr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sEreignis

Unterstützt von .NET Compact Framework
private field m_sKostenart

Unterstützt von .NET Compact Framework
private field m_sKuendigungsfrist

Unterstützt von .NET Compact Framework
private field m_sTermin

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


clsAktivitaet -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet-Eigenschaften

clsAktivitaet Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAusgeloest_am

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property fBetrag

Unterstützt von .NET Compact Framework
public property iAktivitaetNr

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
public property iEreignisnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPeriodizitaetnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecuritylevelnr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEreignis

Unterstützt von .NET Compact Framework
public property sKostenart

Unterstützt von .NET Compact Framework
public property sKuendigungsfrist

Unterstützt von .NET Compact Framework
public property sTermin

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


clsAktivitaet.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.daAusgeloest_am -Eigenschaft

[Visual Basic]
Public Property daAusgeloest_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daAusgeloest_am]() As SqlDateTime
            Get
                Return m_daAusgeloest_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daAusgeloest_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.fBetrag -Eigenschaft

[Visual Basic]
Public Property fBetrag() As SqlDouble

Quellcode

[Visual Basic]
        Public Property [fBetrag]() As SqlDouble
            Get
                Return m_fBetrag
            End Get
            Set(ByVal Value As SqlDouble)
                m_fBetrag = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iAktivitaetNr -Eigenschaft

[Visual Basic]
Public Property iAktivitaetNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAktivitaetNr]() As SqlInt32
            Get
                Return m_iAktivitaetNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAktivitaetNrTmp As SqlInt32 = Value
                If iAktivitaetNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAktivitaetNr", "iAktivitaetNr can't be NULL")
                End If
                m_iAktivitaetNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iAktivitaetStatusNr -Eigenschaft

[Visual Basic]
Public Property iAktivitaetStatusNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAktivitaetStatusNr]() As SqlInt32
            Get
                Return m_iAktivitaetStatusNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAktivitaetStatusNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iEreignisnr -Eigenschaft

[Visual Basic]
Public Property iEreignisnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEreignisnr]() As SqlInt32
            Get
                Return m_iEreignisnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iEreignisnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iPeriodizitaetnr -Eigenschaft

[Visual Basic]
Public Property iPeriodizitaetnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPeriodizitaetnr]() As SqlInt32
            Get
                Return m_iPeriodizitaetnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPeriodizitaetnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.iSecuritylevelnr -Eigenschaft

[Visual Basic]
Public Property iSecuritylevelnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecuritylevelnr]() As SqlInt32
            Get
                Return m_iSecuritylevelnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecuritylevelnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sEreignis -Eigenschaft

[Visual Basic]
Public Property sEreignis() As SqlString

Quellcode

[Visual Basic]
        Public Property [sEreignis]() As SqlString
            Get
                Return m_sEreignis
            End Get
            Set(ByVal Value As SqlString)
                m_sEreignis = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sKostenart -Eigenschaft

[Visual Basic]
Public Property sKostenart() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKostenart]() As SqlString
            Get
                Return m_sKostenart
            End Get
            Set(ByVal Value As SqlString)
                m_sKostenart = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sKuendigungsfrist -Eigenschaft

[Visual Basic]
Public Property sKuendigungsfrist() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKuendigungsfrist]() As SqlString
            Get
                Return m_sKuendigungsfrist
            End Get
            Set(ByVal Value As SqlString)
                m_sKuendigungsfrist = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.sTermin -Eigenschaft

[Visual Basic]
Public Property sTermin() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTermin]() As SqlString
            Get
                Return m_sTermin
            End Get
            Set(ByVal Value As SqlString)
                m_sTermin = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet-Methoden

clsAktivitaet Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAktivitaet -Klasse


clsAktivitaet.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Aktivitaet_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Aktivitaet_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaet::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignisnr. May be SqlInt32.Null</LI> <LI>iAktivitaetStatusNr. May be SqlInt32.Null</LI> <LI>iPeriodizitaetnr. May be SqlInt32.Null</LI> <LI>daAusgeloest_am. May be SqlDateTime.Null</LI> <LI>sEreignis. May be SqlString.Null</LI> <LI>sKostenart. May be SqlString.Null</LI> <LI>fBetrag. May be SqlDouble.Null</LI> <LI>sTermin. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecuritylevelnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sKuendigungsfrist. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iAktivitaetNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Aktivitaet_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignisnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignisnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPeriodizitaetnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaetnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAusgeloest_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAusgeloest_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEreignis", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEreignis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKostenart", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKostenart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fBetrag", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fBetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTermin", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecuritylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecuritylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfrist", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfrist))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAktivitaetNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iAktivitaetNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iAktivitaetNr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Aktivitaet_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaet::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Aktivitaet_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Aktivitaet")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Aktivitaet_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaet::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAktivitaetNr</LI> <LI>iEreignisnr</LI> <LI>iAktivitaetStatusNr</LI> <LI>iPeriodizitaetnr</LI> <LI>daAusgeloest_am</LI> <LI>sEreignis</LI> <LI>sKostenart</LI> <LI>fBetrag</LI> <LI>sTermin</LI> <LI>sBeschreibung</LI> <LI>sBemerkung</LI> <LI>iSecuritylevelnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sKuendigungsfrist</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Aktivitaet_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Aktivitaet")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAktivitaetNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Aktivitaet_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAktivitaetNr = New SqlInt32(CType(dtToReturn.Rows(0)("AktivitaetNr"), Integer))
                    If dtToReturn.Rows(0)("Ereignisnr") Is System.DBNull.Value Then
                        m_iEreignisnr = SqlInt32.Null
                    Else
                        m_iEreignisnr = New SqlInt32(CType(dtToReturn.Rows(0)("Ereignisnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("AktivitaetStatusNr") Is System.DBNull.Value Then
                        m_iAktivitaetStatusNr = SqlInt32.Null
                    Else
                        m_iAktivitaetStatusNr = New SqlInt32(CType(dtToReturn.Rows(0)("AktivitaetStatusNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Periodizitaetnr") Is System.DBNull.Value Then
                        m_iPeriodizitaetnr = SqlInt32.Null
                    Else
                        m_iPeriodizitaetnr = New SqlInt32(CType(dtToReturn.Rows(0)("Periodizitaetnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Ausgeloest_am") Is System.DBNull.Value Then
                        m_daAusgeloest_am = SqlDateTime.Null
                    Else
                        m_daAusgeloest_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Ausgeloest_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Ereignis") Is System.DBNull.Value Then
                        m_sEreignis = SqlString.Null
                    Else
                        m_sEreignis = New SqlString(CType(dtToReturn.Rows(0)("Ereignis"), String))
                    End If
                    If dtToReturn.Rows(0)("Kostenart") Is System.DBNull.Value Then
                        m_sKostenart = SqlString.Null
                    Else
                        m_sKostenart = New SqlString(CType(dtToReturn.Rows(0)("Kostenart"), String))
                    End If
                    If dtToReturn.Rows(0)("Betrag") Is System.DBNull.Value Then
                        m_fBetrag = SqlDouble.Null
                    Else
                        m_fBetrag = New SqlDouble(CType(dtToReturn.Rows(0)("Betrag"), Double))
                    End If
                    If dtToReturn.Rows(0)("Termin") Is System.DBNull.Value Then
                        m_sTermin = SqlString.Null
                    Else
                        m_sTermin = New SqlString(CType(dtToReturn.Rows(0)("Termin"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Securitylevelnr") Is System.DBNull.Value Then
                        m_iSecuritylevelnr = SqlInt32.Null
                    Else
                        m_iSecuritylevelnr = New SqlInt32(CType(dtToReturn.Rows(0)("Securitylevelnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungsfrist") Is System.DBNull.Value Then
                        m_sKuendigungsfrist = SqlString.Null
                    Else
                        m_sKuendigungsfrist = New SqlString(CType(dtToReturn.Rows(0)("Kuendigungsfrist"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaet::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetNr</LI> <LI>iEreignisnr. May be SqlInt32.Null</LI> <LI>iAktivitaetStatusNr. May be SqlInt32.Null</LI> <LI>iPeriodizitaetnr. May be SqlInt32.Null</LI> <LI>daAusgeloest_am. May be SqlDateTime.Null</LI> <LI>sEreignis. May be SqlString.Null</LI> <LI>sKostenart. May be SqlString.Null</LI> <LI>fBetrag. May be SqlDouble.Null</LI> <LI>sTermin. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecuritylevelnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sKuendigungsfrist. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Aktivitaet_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignisnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignisnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPeriodizitaetnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaetnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daAusgeloest_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daAusgeloest_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEreignis", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEreignis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKostenart", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKostenart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fBetrag", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fBetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTermin", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecuritylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecuritylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfrist", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfrist))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Aktivitaet_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaet::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet-Felder

clsAktivitaet Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daAusgeloest_am

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_fBetrag

Unterstützt von .NET Compact Framework
private field m_iAktivitaetNr

Unterstützt von .NET Compact Framework
private field m_iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
private field m_iEreignisnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPeriodizitaetnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecuritylevelnr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sEreignis

Unterstützt von .NET Compact Framework
private field m_sKostenart

Unterstützt von .NET Compact Framework
private field m_sKuendigungsfrist

Unterstützt von .NET Compact Framework
private field m_sTermin

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_daAusgeloest_am -Feld

[Visual Basic]
Private m_daAusgeloest_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAusgeloest_am, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAusgeloest_am, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAusgeloest_am, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_fBetrag -Feld

[Visual Basic]
Private m_fBetrag As SqlDouble

Quellcode

[Visual Basic]
        Private 		m_fBetrag As SqlDouble

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iAktivitaetNr -Feld

[Visual Basic]
Private m_iAktivitaetNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iAktivitaetStatusNr -Feld

[Visual Basic]
Private m_iAktivitaetStatusNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iEreignisnr -Feld

[Visual Basic]
Private m_iEreignisnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iPeriodizitaetnr -Feld

[Visual Basic]
Private m_iPeriodizitaetnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_iSecuritylevelnr -Feld

[Visual Basic]
Private m_iSecuritylevelnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iEreignisnr, m_iAktivitaetNr, m_iAktivitaetStatusNr, m_iSecuritylevelnr, m_iPeriodizitaetnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sEreignis -Feld

[Visual Basic]
Private m_sEreignis As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sKostenart -Feld

[Visual Basic]
Private m_sKostenart As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sKuendigungsfrist -Feld

[Visual Basic]
Private m_sKuendigungsfrist As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


m_sTermin -Feld

[Visual Basic]
Private m_sTermin As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKuendigungsfrist, m_sKostenart, m_sEreignis, m_sTermin, m_sBemerkung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaetStatus -Klasse

Purpose: Data Access class for the table 'AktivitaetStatus'.

For a list of all members of this type, see clsAktivitaetStatus-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAktivitaetStatus

[Visual Basic]
Public Class clsAktivitaetStatus
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAktivitaetStatus-Member


clsAktivitaetStatus-Member

clsAktivitaetStatus Übersicht

Öffentliche Konstruktoren

public constructor clsAktivitaetStatus -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAktivitaet_Aktivieren

Unterstützt von .NET Compact Framework
public property bAktivitaet_Inaktivieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAktivitaet_Aktivieren

Unterstützt von .NET Compact Framework
private field m_bAktivitaet_Inaktivieren

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaetStatus -Klasse


clsAktivitaetStatus -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus-Eigenschaften

clsAktivitaetStatus Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAktivitaet_Aktivieren

Unterstützt von .NET Compact Framework
public property bAktivitaet_Inaktivieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaetStatus -Klasse


clsAktivitaetStatus.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.bAktivitaet_Aktivieren -Eigenschaft

[Visual Basic]
Public Property bAktivitaet_Aktivieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktivitaet_Aktivieren]() As SqlBoolean
            Get
                Return m_bAktivitaet_Aktivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktivitaet_Aktivieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.bAktivitaet_Inaktivieren -Eigenschaft

[Visual Basic]
Public Property bAktivitaet_Inaktivieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktivitaet_Inaktivieren]() As SqlBoolean
            Get
                Return m_bAktivitaet_Inaktivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktivitaet_Inaktivieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.iAktivitaetStatusNr -Eigenschaft

[Visual Basic]
Public Property iAktivitaetStatusNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAktivitaetStatusNr]() As SqlInt32
            Get
                Return m_iAktivitaetStatusNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAktivitaetStatusNrTmp As SqlInt32 = Value
                If iAktivitaetStatusNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAktivitaetStatusNr", "iAktivitaetStatusNr can't be NULL")
                End If
                m_iAktivitaetStatusNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus-Methoden

clsAktivitaetStatus Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAktivitaetStatus -Klasse


clsAktivitaetStatus.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetStatusNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AktivitaetStatus_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AktivitaetStatus_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaetStatus::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetStatusNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktivitaet_Aktivieren. May be SqlBoolean.Null</LI> <LI>bAktivitaet_Inaktivieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AktivitaetStatus_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaet_Aktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaet_Aktivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaet_Inaktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaet_Inaktivieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AktivitaetStatus_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaetStatus::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AktivitaetStatus_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AktivitaetStatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AktivitaetStatus_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaetStatus::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetStatusNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAktivitaetStatusNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktivitaet_Aktivieren</LI> <LI>bAktivitaet_Inaktivieren</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AktivitaetStatus_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AktivitaetStatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AktivitaetStatus_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAktivitaetStatusNr = New SqlInt32(CType(dtToReturn.Rows(0)("AktivitaetStatusNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktivitaet_Aktivieren") Is System.DBNull.Value Then
                        m_bAktivitaet_Aktivieren = SqlBoolean.Null
                    Else
                        m_bAktivitaet_Aktivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktivitaet_Aktivieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktivitaet_Inaktivieren") Is System.DBNull.Value Then
                        m_bAktivitaet_Inaktivieren = SqlBoolean.Null
                    Else
                        m_bAktivitaet_Inaktivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktivitaet_Inaktivieren"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaetStatus::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAktivitaetStatusNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktivitaet_Aktivieren. May be SqlBoolean.Null</LI> <LI>bAktivitaet_Inaktivieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AktivitaetStatus_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAktivitaetStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaet_Aktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaet_Aktivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaet_Inaktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaet_Inaktivieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AktivitaetStatus_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAktivitaetStatus::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsAktivitaetStatus-Felder

clsAktivitaetStatus Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAktivitaet_Aktivieren

Unterstützt von .NET Compact Framework
private field m_bAktivitaet_Inaktivieren

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAktivitaetStatusNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaetStatus -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaet_Aktivieren, m_bAktivitaet_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_bAktivitaet_Aktivieren -Feld

[Visual Basic]
Private m_bAktivitaet_Aktivieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaet_Aktivieren, m_bAktivitaet_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_bAktivitaet_Inaktivieren -Feld

[Visual Basic]
Private m_bAktivitaet_Inaktivieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaet_Aktivieren, m_bAktivitaet_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_iAktivitaetStatusNr -Feld

[Visual Basic]
Private m_iAktivitaetStatusNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iAktivitaetStatusNr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iAktivitaetStatusNr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaetStatus


clsApplication -Klasse

Purpose: Data Access class for the table 'Application'.

For a list of all members of this type, see clsApplication-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplication

[Visual Basic]
Public Class clsApplication
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplication-Member


clsApplication-Member

clsApplication Übersicht

Öffentliche Konstruktoren

public constructor clsApplication -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bShowlogin

Unterstützt von .NET Compact Framework
public property bVertragsuebersicht_aktualisieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationsnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sTmp_filepath

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bShowlogin

Unterstützt von .NET Compact Framework
private field m_bVertragsuebersicht_aktualisieren

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationsnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sTmp_filepath

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplication -Klasse


clsApplication -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication-Eigenschaften

clsApplication Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bShowlogin

Unterstützt von .NET Compact Framework
public property bVertragsuebersicht_aktualisieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationsnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sTmp_filepath

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

clsApplication -Klasse


clsApplication.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.bShowlogin -Eigenschaft

[Visual Basic]
Public Property bShowlogin() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bShowlogin]() As SqlBoolean
            Get
                Return m_bShowlogin
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bShowlogin = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.bVertragsuebersicht_aktualisieren -Eigenschaft

[Visual Basic]
Public Property bVertragsuebersicht_aktualisieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bVertragsuebersicht_aktualisieren]() As SqlBoolean
            Get
                Return m_bVertragsuebersicht_aktualisieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertragsuebersicht_aktualisieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.iApplikationsnr -Eigenschaft

[Visual Basic]
Public Property iApplikationsnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationsnr]() As SqlInt32
            Get
                Return m_iApplikationsnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationsnrTmp As SqlInt32 = Value
                If iApplikationsnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationsnr", "iApplikationsnr can't be NULL")
                End If
                m_iApplikationsnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.sTmp_filepath -Eigenschaft

[Visual Basic]
Public Property sTmp_filepath() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTmp_filepath]() As SqlString
            Get
                Return m_sTmp_filepath
            End Get
            Set(ByVal Value As SqlString)
                m_sTmp_filepath = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.sVersion -Eigenschaft

[Visual Basic]
Public Property sVersion() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication-Methoden

clsApplication Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplication -Klasse


clsApplication.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Application_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Application_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplication::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bShowlogin. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sTmp_filepath. May be SqlString.Null</LI> <LI>bVertragsuebersicht_aktualisieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Application_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stmp_filepath", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTmp_filepath))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bVertragsuebersicht_aktualisieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bVertragsuebersicht_aktualisieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Application_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplication::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Application_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Application")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Application_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplication::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationsnr</LI> <LI>sVersion</LI> <LI>bShowlogin</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sTmp_filepath</LI> <LI>bVertragsuebersicht_aktualisieren</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Application_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Application")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Application_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationsnr = New SqlInt32(CType(dtToReturn.Rows(0)("applikationsnr"), Integer))
                    If dtToReturn.Rows(0)("version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("version"), String))
                    End If
                    If dtToReturn.Rows(0)("showlogin") Is System.DBNull.Value Then
                        m_bShowlogin = SqlBoolean.Null
                    Else
                        m_bShowlogin = New SqlBoolean(CType(dtToReturn.Rows(0)("showlogin"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tmp_filepath") Is System.DBNull.Value Then
                        m_sTmp_filepath = SqlString.Null
                    Else
                        m_sTmp_filepath = New SqlString(CType(dtToReturn.Rows(0)("tmp_filepath"), String))
                    End If
                    If dtToReturn.Rows(0)("Vertragsuebersicht_aktualisieren") Is System.DBNull.Value Then
                        m_bVertragsuebersicht_aktualisieren = SqlBoolean.Null
                    Else
                        m_bVertragsuebersicht_aktualisieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Vertragsuebersicht_aktualisieren"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplication::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationsnr</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>bShowlogin. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sTmp_filepath. May be SqlString.Null</LI> <LI>bVertragsuebersicht_aktualisieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Application_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stmp_filepath", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTmp_filepath))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bVertragsuebersicht_aktualisieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bVertragsuebersicht_aktualisieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Application_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplication::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplication-Felder

clsApplication Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bShowlogin

Unterstützt von .NET Compact Framework
private field m_bVertragsuebersicht_aktualisieren

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationsnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sTmp_filepath

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplication -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bShowlogin, m_bVertragsuebersicht_aktualisieren, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_bShowlogin -Feld

[Visual Basic]
Private m_bShowlogin As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bShowlogin, m_bVertragsuebersicht_aktualisieren, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_bVertragsuebersicht_aktualisieren -Feld

[Visual Basic]
Private m_bVertragsuebersicht_aktualisieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bShowlogin, m_bVertragsuebersicht_aktualisieren, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_iApplikationsnr -Feld

[Visual Basic]
Private m_iApplikationsnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_sTmp_filepath -Feld

[Visual Basic]
Private m_sTmp_filepath As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sTmp_filepath As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


m_sVersion -Feld

[Visual Basic]
Private m_sVersion As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sTmp_filepath As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplication


clsApplikation -Klasse

Purpose: Data Access class for the table 'Applikation'.

For a list of all members of this type, see clsApplikation-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikation
Vertragsverwaltung.TKB.VV.Applikation.clsApplikation

[Visual Basic]
Public Class clsApplikation
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikation-Member


clsApplikation-Member

clsApplikation Übersicht

Öffentliche Konstruktoren

public constructor clsApplikation -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsProdukt

Unterstützt von .NET Compact Framework
public property bNurLizenz

Unterstützt von .NET Compact Framework
public property bRAS

Unterstützt von .NET Compact Framework
public property bSensitiveDaten

Unterstützt von .NET Compact Framework
public property bTicketXPertVerwendung

Unterstützt von .NET Compact Framework
public property bTicketXPert_AMAnzeigen

Unterstützt von .NET Compact Framework
public property bTicketXPert_WPIAnzeigen

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daInaktivseit

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationTeamnr

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAdministriertdurch

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlComit

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlExterne

Unterstützt von .NET Compact Framework
public property iSensitiveDatenUeberwachungPeriodizitaet

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationSMLTypNr

Unterstützt von .NET Compact Framework
public property sAnzahl_Installationen

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDatenbankname

Unterstützt von .NET Compact Framework
public property sKurzbeschreibung

Unterstützt von .NET Compact Framework
public property sPrioWiederanlauf

Unterstützt von .NET Compact Framework
public property sSensitiveDatenBemerkung

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUeberwachungBemerkung

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUserBemerkung

Unterstützt von .NET Compact Framework
public property sTest_Abhaengigkeiten

Unterstützt von .NET Compact Framework
public property sTest_Arbeitsplaetze

Unterstützt von .NET Compact Framework
public property sTest_Aufwand

Unterstützt von .NET Compact Framework
public property sTest_Bemerkung

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis_Einmalig

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsProdukt

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bNurLizenz

Unterstützt von .NET Compact Framework
private field m_bRAS

Unterstützt von .NET Compact Framework
private field m_bSensitiveDaten

Unterstützt von .NET Compact Framework
private field m_bTicketXPertVerwendung

Unterstützt von .NET Compact Framework
private field m_bTicketXPert_AMAnzeigen

Unterstützt von .NET Compact Framework
private field m_bTicketXPert_WPIAnzeigen

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daInaktivseit

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKategorieNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationTeamnr

Unterstützt von .NET Compact Framework
private field m_iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMarktbereichnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAdministriertdurch

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAnzahlComit

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAnzahlExterne

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenUeberwachungPeriodizitaet

Unterstützt von .NET Compact Framework
private field m_iTicketXPert_ApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
private field m_iTicketXPert_ApplikationSMLTypNr

Unterstützt von .NET Compact Framework
private field m_sAnzahl_Installationen

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sDatenbankname

Unterstützt von .NET Compact Framework
private field m_sKurzbeschreibung

Unterstützt von .NET Compact Framework
private field m_sPrioWiederanlauf

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenBemerkung

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenUeberwachungBemerkung

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenUserBemerkung

Unterstützt von .NET Compact Framework
private field m_sTest_Abhaengigkeiten

Unterstützt von .NET Compact Framework
private field m_sTest_Arbeitsplaetze

Unterstützt von .NET Compact Framework
private field m_sTest_Aufwand

Unterstützt von .NET Compact Framework
private field m_sTest_Bemerkung

Unterstützt von .NET Compact Framework
private field m_sTicketXPert_Preis

Unterstützt von .NET Compact Framework
private field m_sTicketXPert_Preis_Einmalig

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


clsApplikation -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation-Eigenschaften

clsApplikation Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsProdukt

Unterstützt von .NET Compact Framework
public property bNurLizenz

Unterstützt von .NET Compact Framework
public property bRAS

Unterstützt von .NET Compact Framework
public property bSensitiveDaten

Unterstützt von .NET Compact Framework
public property bTicketXPertVerwendung

Unterstützt von .NET Compact Framework
public property bTicketXPert_AMAnzeigen

Unterstützt von .NET Compact Framework
public property bTicketXPert_WPIAnzeigen

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daInaktivseit

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationTeamnr

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAdministriertdurch

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlComit

Unterstützt von .NET Compact Framework
public property iSensitiveDatenAnzahlExterne

Unterstützt von .NET Compact Framework
public property iSensitiveDatenUeberwachungPeriodizitaet

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
public property iTicketXPert_ApplikationSMLTypNr

Unterstützt von .NET Compact Framework
public property sAnzahl_Installationen

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDatenbankname

Unterstützt von .NET Compact Framework
public property sKurzbeschreibung

Unterstützt von .NET Compact Framework
public property sPrioWiederanlauf

Unterstützt von .NET Compact Framework
public property sSensitiveDatenBemerkung

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUeberwachungBemerkung

Unterstützt von .NET Compact Framework
public property sSensitiveDatenUserBemerkung

Unterstützt von .NET Compact Framework
public property sTest_Abhaengigkeiten

Unterstützt von .NET Compact Framework
public property sTest_Arbeitsplaetze

Unterstützt von .NET Compact Framework
public property sTest_Aufwand

Unterstützt von .NET Compact Framework
public property sTest_Bemerkung

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis

Unterstützt von .NET Compact Framework
public property sTicketXPert_Preis_Einmalig

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


clsApplikation-Methoden

clsApplikation Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikation -Klasse


clsApplikation-Felder

clsApplikation Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsProdukt

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bNurLizenz

Unterstützt von .NET Compact Framework
private field m_bRAS

Unterstützt von .NET Compact Framework
private field m_bSensitiveDaten

Unterstützt von .NET Compact Framework
private field m_bTicketXPertVerwendung

Unterstützt von .NET Compact Framework
private field m_bTicketXPert_AMAnzeigen

Unterstützt von .NET Compact Framework
private field m_bTicketXPert_WPIAnzeigen

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daInaktivseit

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKategorieNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationTeamnr

Unterstützt von .NET Compact Framework
private field m_iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMarktbereichnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAdministriertdurch

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAnzahlComit

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenAnzahlExterne

Unterstützt von .NET Compact Framework
private field m_iSensitiveDatenUeberwachungPeriodizitaet

Unterstützt von .NET Compact Framework
private field m_iTicketXPert_ApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
private field m_iTicketXPert_ApplikationSMLTypNr

Unterstützt von .NET Compact Framework
private field m_sAnzahl_Installationen

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sDatenbankname

Unterstützt von .NET Compact Framework
private field m_sKurzbeschreibung

Unterstützt von .NET Compact Framework
private field m_sPrioWiederanlauf

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenBemerkung

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenUeberwachungBemerkung

Unterstützt von .NET Compact Framework
private field m_sSensitiveDatenUserBemerkung

Unterstützt von .NET Compact Framework
private field m_sTest_Abhaengigkeiten

Unterstützt von .NET Compact Framework
private field m_sTest_Arbeitsplaetze

Unterstützt von .NET Compact Framework
private field m_sTest_Aufwand

Unterstützt von .NET Compact Framework
private field m_sTest_Bemerkung

Unterstützt von .NET Compact Framework
private field m_sTicketXPert_Preis

Unterstützt von .NET Compact Framework
private field m_sTicketXPert_Preis_Einmalig

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikation -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bAlsProdukt -Feld

[Visual Basic]
Private m_bAlsProdukt As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bNurLizenz -Feld

[Visual Basic]
Private m_bNurLizenz As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bRAS -Feld

[Visual Basic]
Private m_bRAS As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bSensitiveDaten -Feld

[Visual Basic]
Private m_bSensitiveDaten As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bTicketXPertVerwendung -Feld

[Visual Basic]
Private m_bTicketXPertVerwendung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bTicketXPert_AMAnzeigen -Feld

[Visual Basic]
Private m_bTicketXPert_AMAnzeigen As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_bTicketXPert_WPIAnzeigen -Feld

[Visual Basic]
Private m_bTicketXPert_WPIAnzeigen As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bRAS, m_bNurLizenz, m_bAlsProdukt, m_bTicketXPert_WPIAnzeigen, m_bTicketXPert_AMAnzeigen, m_bAktiv, m_bSensitiveDaten, m_bTicketXPertVerwendung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daInaktivseit, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_daInaktivseit -Feld

[Visual Basic]
Private m_daInaktivseit As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daInaktivseit, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daInaktivseit, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iApplikationKategorieNr -Feld

[Visual Basic]
Private m_iApplikationKategorieNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iApplikationTeamnr -Feld

[Visual Basic]
Private m_iApplikationTeamnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iApplikationVerantwortungNr -Feld

[Visual Basic]
Private m_iApplikationVerantwortungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iMarktbereichnr -Feld

[Visual Basic]
Private m_iMarktbereichnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iParentID -Feld

[Visual Basic]
Private m_iParentID As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iRfcBoardNr -Feld

[Visual Basic]
Private m_iRfcBoardNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iSensitiveDatenAdministriertdurch -Feld

[Visual Basic]
Private m_iSensitiveDatenAdministriertdurch As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iSensitiveDatenAnzahlComit -Feld

[Visual Basic]
Private m_iSensitiveDatenAnzahlComit As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iSensitiveDatenAnzahlExterne -Feld

[Visual Basic]
Private m_iSensitiveDatenAnzahlExterne As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iSensitiveDatenUeberwachungPeriodizitaet -Feld

[Visual Basic]
Private m_iSensitiveDatenUeberwachungPeriodizitaet As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iTicketXPert_ApplikationKritikalitaetTypNr -Feld

[Visual Basic]
Private m_iTicketXPert_ApplikationKritikalitaetTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_iTicketXPert_ApplikationSMLTypNr -Feld

[Visual Basic]
Private m_iTicketXPert_ApplikationSMLTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iTicketXPert_ApplikationKritikalitaetTypNr, m_iTicketXPert_ApplikationSMLTypNr, m_iRfcBoardNr, m_iSensitiveDatenAnzahlExterne, m_iSensitiveDatenAnzahlComit, m_iSensitiveDatenAdministriertdurch, m_iMutierer, m_iSecurityLevelNr, m_iSensitiveDatenUeberwachungPeriodizitaet, m_iApplikationNr, m_iApplikationVerantwortungNr, m_iApplikationTeamnr, m_iApplikationKategorieNr, m_iMarktbereichnr, m_iParentID As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sAnzahl_Installationen -Feld

[Visual Basic]
Private m_sAnzahl_Installationen As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sDatenbankname -Feld

[Visual Basic]
Private m_sDatenbankname As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sKurzbeschreibung -Feld

[Visual Basic]
Private m_sKurzbeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sPrioWiederanlauf -Feld

[Visual Basic]
Private m_sPrioWiederanlauf As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sSensitiveDatenBemerkung -Feld

[Visual Basic]
Private m_sSensitiveDatenBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sSensitiveDatenUeberwachungBemerkung -Feld

[Visual Basic]
Private m_sSensitiveDatenUeberwachungBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sSensitiveDatenUserBemerkung -Feld

[Visual Basic]
Private m_sSensitiveDatenUserBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTest_Abhaengigkeiten -Feld

[Visual Basic]
Private m_sTest_Abhaengigkeiten As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTest_Arbeitsplaetze -Feld

[Visual Basic]
Private m_sTest_Arbeitsplaetze As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTest_Aufwand -Feld

[Visual Basic]
Private m_sTest_Aufwand As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTest_Bemerkung -Feld

[Visual Basic]
Private m_sTest_Bemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTicketXPert_Preis -Feld

[Visual Basic]
Private m_sTicketXPert_Preis As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sTicketXPert_Preis_Einmalig -Feld

[Visual Basic]
Private m_sTicketXPert_Preis_Einmalig As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


m_sVersion -Feld

[Visual Basic]
Private m_sVersion As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sSensitiveDatenBemerkung, m_sBezeichnung, m_sSensitiveDatenUserBemerkung, m_sSensitiveDatenUeberwachungBemerkung, m_sTest_Abhaengigkeiten, m_sTest_Arbeitsplaetze, m_sTicketXPert_Preis_Einmalig, m_sTest_Bemerkung, m_sTicketXPert_Preis, m_sKurzbeschreibung, m_sPrioWiederanlauf, m_sDatenbankname, m_sTest_Aufwand, m_sAnzahl_Installationen As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikationInstallationAls -Klasse

Purpose: Data Access class for the table 'ApplikationInstallationAls'.

For a list of all members of this type, see clsApplikationInstallationAls-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationAls

[Visual Basic]
Public Class clsApplikationInstallationAls
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationInstallationAls-Member


clsApplikationInstallationAls-Member

clsApplikationInstallationAls Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationInstallationAls -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationAlsTypNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationalsTypNr

Unterstützt von .NET Compact Framework
public property iInstallationalsTypNrOld

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationalsTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationalsTypNr' in all rows which have as value for this field the value as set in property 'iInstallationalsTypNrOld' to the value as set in property 'iInstallationalsTypNr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationAlsTypNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationalsTypNr

Unterstützt von .NET Compact Framework
private field m_iInstallationalsTypNrOld

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationAls -Klasse


clsApplikationInstallationAls -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls-Eigenschaften

clsApplikationInstallationAls Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationAlsTypNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationalsTypNr

Unterstützt von .NET Compact Framework
public property iInstallationalsTypNrOld

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationAls -Klasse


clsApplikationInstallationAls.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iApplikationInstallationAlsTypNr -Eigenschaft

[Visual Basic]
Public Property iApplikationInstallationAlsTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationInstallationAlsTypNr]() As SqlInt32
            Get
                Return m_iApplikationInstallationAlsTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationInstallationAlsTypNrTmp As SqlInt32 = Value
                If iApplikationInstallationAlsTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationInstallationAlsTypNr", "iApplikationInstallationAlsTypNr can't be NULL")
                End If
                m_iApplikationInstallationAlsTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iApplikationNrOld -Eigenschaft

[Visual Basic]
Public Property iApplikationNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNrOld]() As SqlInt32
            Get
                Return m_iApplikationNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iInstallationalsTypNr -Eigenschaft

[Visual Basic]
Public Property iInstallationalsTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationalsTypNr]() As SqlInt32
            Get
                Return m_iInstallationalsTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iInstallationalsTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iInstallationalsTypNrOld -Eigenschaft

[Visual Basic]
Public Property iInstallationalsTypNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationalsTypNrOld]() As SqlInt32
            Get
                Return m_iInstallationalsTypNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iInstallationalsTypNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls-Methoden

clsApplikationInstallationAls Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWInstallationalsTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationalsTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationalsTypNr' in all rows which have as value for this field the value as set in property 'iInstallationalsTypNrOld' to the value as set in property 'iInstallationalsTypNr'.

clsApplikationInstallationAls -Klasse


clsApplikationInstallationAls.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationAlsTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.DeleteAllWApplikationNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function DeleteAllWApplikationNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_DeleteAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_DeleteAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::DeleteAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.DeleteAllWInstallationalsTypNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'

[Visual Basic]
Public Function DeleteAllWInstallationalsTypNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iInstallationalsTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWInstallationalsTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_DeleteAllWInstallationalsTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationalsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iInstallationalsTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationalsTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_DeleteAllWInstallationalsTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::DeleteAllWInstallationalsTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iInstallationalsTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iApplikationInstallationAlsTypNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationalsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationInstallationAlsTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationInstallationAlsTypNr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationAls")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.SelectAllWApplikationNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function SelectAllWApplikationNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWApplikationNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_SelectAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationAls")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_SelectAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::SelectAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.SelectAllWInstallationalsTypNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationalsTypNr'

[Visual Basic]
Public Function SelectAllWInstallationalsTypNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationalsTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWInstallationalsTypNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_SelectAllWInstallationalsTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationAls")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationalsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iInstallationalsTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationalsTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_SelectAllWInstallationalsTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::SelectAllWInstallationalsTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationAlsTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationInstallationAlsTypNr</LI> <LI>iApplikationNr</LI> <LI>iInstallationalsTypNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationAls")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationInstallationAlsTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationInstallationAlsTypNr"), Integer))
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("InstallationalsTypNr") Is System.DBNull.Value Then
                        m_iInstallationalsTypNr = SqlInt32.Null
                    Else
                        m_iInstallationalsTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("InstallationalsTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationAlsTypNr</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iInstallationalsTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationalsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.UpdateAllWApplikationNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.

[Visual Basic]
Public Function UpdateAllWApplikationNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iApplikationNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_UpdateAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_UpdateAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::UpdateAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls.UpdateAllWInstallationalsTypNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationalsTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationalsTypNr' in all rows which have as value for this field the value as set in property 'iInstallationalsTypNrOld' to the value as set in property 'iInstallationalsTypNr'.

[Visual Basic]
Public Function UpdateAllWInstallationalsTypNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationalsTypNr. May be SqlInt32.Null</LI> <LI>iInstallationalsTypNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWInstallationalsTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationAls_UpdateAllWInstallationalsTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationalsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationalsTypNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationalsTypNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iInstallationalsTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationalsTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationAls_UpdateAllWInstallationalsTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationAls::UpdateAllWInstallationalsTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationAls-Felder

clsApplikationInstallationAls Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationAlsTypNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationalsTypNr

Unterstützt von .NET Compact Framework
private field m_iInstallationalsTypNrOld

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationAls -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iApplikationInstallationAlsTypNr -Feld

[Visual Basic]
Private m_iApplikationInstallationAlsTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iApplikationNrOld -Feld

[Visual Basic]
Private m_iApplikationNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iInstallationalsTypNr -Feld

[Visual Basic]
Private m_iInstallationalsTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iInstallationalsTypNrOld -Feld

[Visual Basic]
Private m_iInstallationalsTypNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationalsTypNr, m_iInstallationalsTypNrOld, m_iApplikationInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationAls


clsApplikationInstallationFuer -Klasse

Purpose: Data Access class for the table 'ApplikationInstallationFuer'.

For a list of all members of this type, see clsApplikationInstallationFuer-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationFuer

[Visual Basic]
Public Class clsApplikationInstallationFuer
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationInstallationFuer-Member


clsApplikationInstallationFuer-Member

clsApplikationInstallationFuer Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationInstallationFuer -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationFuerNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationStandardTypNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationStandardTypNr' in all rows which have as value for this field the value as set in property 'iApplikationStandardTypNrOld' to the value as set in property 'iApplikationStandardTypNr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationFuerNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationFuer -Klasse


clsApplikationInstallationFuer -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer-Eigenschaften

clsApplikationInstallationFuer Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationFuerNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationFuer -Klasse


clsApplikationInstallationFuer.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iApplikationInstallationFuerNr -Eigenschaft

[Visual Basic]
Public Property iApplikationInstallationFuerNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationInstallationFuerNr]() As SqlInt32
            Get
                Return m_iApplikationInstallationFuerNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationInstallationFuerNrTmp As SqlInt32 = Value
                If iApplikationInstallationFuerNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationInstallationFuerNr", "iApplikationInstallationFuerNr can't be NULL")
                End If
                m_iApplikationInstallationFuerNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iApplikationNrOld -Eigenschaft

[Visual Basic]
Public Property iApplikationNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNrOld]() As SqlInt32
            Get
                Return m_iApplikationNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iApplikationStandardTypNr -Eigenschaft

[Visual Basic]
Public Property iApplikationStandardTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationStandardTypNr]() As SqlInt32
            Get
                Return m_iApplikationStandardTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationStandardTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iApplikationStandardTypNrOld -Eigenschaft

[Visual Basic]
Public Property iApplikationStandardTypNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationStandardTypNrOld]() As SqlInt32
            Get
                Return m_iApplikationStandardTypNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationStandardTypNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer-Methoden

clsApplikationInstallationFuer Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWApplikationStandardTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationStandardTypNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationStandardTypNr' in all rows which have as value for this field the value as set in property 'iApplikationStandardTypNrOld' to the value as set in property 'iApplikationStandardTypNr'.

clsApplikationInstallationFuer -Klasse


clsApplikationInstallationFuer.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationFuerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationFuerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationFuerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.DeleteAllWApplikationNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function DeleteAllWApplikationNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_DeleteAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_DeleteAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::DeleteAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.DeleteAllWApplikationStandardTypNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'

[Visual Basic]
Public Function DeleteAllWApplikationStandardTypNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWApplikationStandardTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_DeleteAllWApplikationStandardTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationStandardTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationStandardTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_DeleteAllWApplikationStandardTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::DeleteAllWApplikationStandardTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iApplikationStandardTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iApplikationInstallationFuerNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationFuerNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationFuerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationInstallationFuerNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationInstallationFuerNr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationFuer")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.SelectAllWApplikationNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function SelectAllWApplikationNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWApplikationNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_SelectAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationFuer")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_SelectAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::SelectAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.SelectAllWApplikationStandardTypNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationStandardTypNr'

[Visual Basic]
Public Function SelectAllWApplikationStandardTypNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWApplikationStandardTypNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_SelectAllWApplikationStandardTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationFuer")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iApplikationStandardTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationStandardTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_SelectAllWApplikationStandardTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::SelectAllWApplikationStandardTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationFuerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationInstallationFuerNr</LI> <LI>iApplikationNr</LI> <LI>iApplikationStandardTypNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationFuer")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationFuerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationFuerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationInstallationFuerNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationInstallationFuerNr"), Integer))
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationStandardTypNr") Is System.DBNull.Value Then
                        m_iApplikationStandardTypNr = SqlInt32.Null
                    Else
                        m_iApplikationStandardTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationStandardTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationFuerNr</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iApplikationStandardTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationFuerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationFuerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.UpdateAllWApplikationNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.

[Visual Basic]
Public Function UpdateAllWApplikationNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iApplikationNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_UpdateAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_UpdateAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::UpdateAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer.UpdateAllWApplikationStandardTypNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationStandardTypNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationStandardTypNr' in all rows which have as value for this field the value as set in property 'iApplikationStandardTypNrOld' to the value as set in property 'iApplikationStandardTypNr'.

[Visual Basic]
Public Function UpdateAllWApplikationStandardTypNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr. May be SqlInt32.Null</LI> <LI>iApplikationStandardTypNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWApplikationStandardTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationFuer_UpdateAllWApplikationStandardTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationStandardTypNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationStandardTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationStandardTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationFuer_UpdateAllWApplikationStandardTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationFuer::UpdateAllWApplikationStandardTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationFuer-Felder

clsApplikationInstallationFuer Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationFuerNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationFuer -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iApplikationInstallationFuerNr -Feld

[Visual Basic]
Private m_iApplikationInstallationFuerNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iApplikationNrOld -Feld

[Visual Basic]
Private m_iApplikationNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iApplikationStandardTypNr -Feld

[Visual Basic]
Private m_iApplikationStandardTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iApplikationStandardTypNrOld -Feld

[Visual Basic]
Private m_iApplikationStandardTypNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iApplikationStandardTypNr, m_iApplikationStandardTypNrOld, m_iApplikationInstallationFuerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationFuer


clsApplikationInstallationTyp -Klasse

Purpose: Data Access class for the table 'ApplikationInstallationTyp'.

For a list of all members of this type, see clsApplikationInstallationTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationTyp

[Visual Basic]
Public Class clsApplikationInstallationTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationInstallationTyp-Member


clsApplikationInstallationTyp-Member

clsApplikationInstallationTyp Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationInstallationTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationTypNr

Unterstützt von .NET Compact Framework
public property iInstallationTypNrOld

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationTypNr' in all rows which have as value for this field the value as set in property 'iInstallationTypNrOld' to the value as set in property 'iInstallationTypNr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNr

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNrOld

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationTyp -Klasse


clsApplikationInstallationTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp-Eigenschaften

clsApplikationInstallationTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationInstallationNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iApplikationNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationTypNr

Unterstützt von .NET Compact Framework
public property iInstallationTypNrOld

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationTyp -Klasse


clsApplikationInstallationTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iApplikationInstallationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationInstallationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationInstallationNr]() As SqlInt32
            Get
                Return m_iApplikationInstallationNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationInstallationNrTmp As SqlInt32 = Value
                If iApplikationInstallationNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationInstallationNr", "iApplikationInstallationNr can't be NULL")
                End If
                m_iApplikationInstallationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iApplikationNrOld -Eigenschaft

[Visual Basic]
Public Property iApplikationNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNrOld]() As SqlInt32
            Get
                Return m_iApplikationNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iInstallationTypNr -Eigenschaft

[Visual Basic]
Public Property iInstallationTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationTypNr]() As SqlInt32
            Get
                Return m_iInstallationTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iInstallationTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iInstallationTypNrOld -Eigenschaft

[Visual Basic]
Public Property iInstallationTypNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationTypNrOld]() As SqlInt32
            Get
                Return m_iInstallationTypNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iInstallationTypNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp-Methoden

clsApplikationInstallationTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method DeleteAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationTypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'
public method SelectAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationTypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWApplikationNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.
public method UpdateAllWInstallationTypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationTypNr' in all rows which have as value for this field the value as set in property 'iInstallationTypNrOld' to the value as set in property 'iInstallationTypNr'.

clsApplikationInstallationTyp -Klasse


clsApplikationInstallationTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.DeleteAllWApplikationNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function DeleteAllWApplikationNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_DeleteAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_DeleteAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::DeleteAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.DeleteAllWInstallationTypNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'InstallationTypNr'

[Visual Basic]
Public Function DeleteAllWInstallationTypNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWInstallationTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_DeleteAllWInstallationTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iInstallationTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_DeleteAllWInstallationTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::DeleteAllWInstallationTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iInstallationTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iApplikationInstallationNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationInstallationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationInstallationNr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.SelectAllWApplikationNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'ApplikationNr'

[Visual Basic]
Public Function SelectAllWApplikationNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWApplikationNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_SelectAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_SelectAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::SelectAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.SelectAllWInstallationTypNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'InstallationTypNr'

[Visual Basic]
Public Function SelectAllWInstallationTypNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWInstallationTypNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_SelectAllWInstallationTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iInstallationTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_SelectAllWInstallationTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::SelectAllWInstallationTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationInstallationNr</LI> <LI>iApplikationNr</LI> <LI>iInstallationTypNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationInstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationInstallationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationInstallationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationInstallationNr"), Integer))
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("InstallationTypNr") Is System.DBNull.Value Then
                        m_iInstallationTypNr = SqlInt32.Null
                    Else
                        m_iInstallationTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("InstallationTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationInstallationNr</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iInstallationTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationInstallationNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationInstallationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.UpdateAllWApplikationNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'ApplikationNr. This method will Update one or more existing rows in the database. It will reset the field 'ApplikationNr' in all rows which have as value for this field the value as set in property 'iApplikationNrOld' to the value as set in property 'iApplikationNr'.

[Visual Basic]
Public Function UpdateAllWApplikationNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iApplikationNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWApplikationNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_UpdateAllWApplikationNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iApplikationNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iApplikationNr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_UpdateAllWApplikationNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::UpdateAllWApplikationNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp.UpdateAllWInstallationTypNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'InstallationTypNr. This method will Update one or more existing rows in the database. It will reset the field 'InstallationTypNr' in all rows which have as value for this field the value as set in property 'iInstallationTypNrOld' to the value as set in property 'iInstallationTypNr'.

[Visual Basic]
Public Function UpdateAllWInstallationTypNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr. May be SqlInt32.Null</LI> <LI>iInstallationTypNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWInstallationTypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationInstallationTyp_UpdateAllWInstallationTypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationTypNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iInstallationTypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iInstallationTypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationInstallationTyp_UpdateAllWInstallationTypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationInstallationTyp::UpdateAllWInstallationTypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationInstallationTyp-Felder

clsApplikationInstallationTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationInstallationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNr

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNrOld

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationInstallationTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iApplikationInstallationNr -Feld

[Visual Basic]
Private m_iApplikationInstallationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iApplikationNrOld -Feld

[Visual Basic]
Private m_iApplikationNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iInstallationTypNr -Feld

[Visual Basic]
Private m_iInstallationTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iInstallationTypNrOld -Feld

[Visual Basic]
Private m_iInstallationTypNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationNr, m_iApplikationNrOld, m_iInstallationTypNr, m_iInstallationTypNrOld, m_iApplikationInstallationNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationInstallationTyp


clsApplikationKategorie -Klasse

Purpose: Data Access class for the table 'ApplikationKategorie'.

For a list of all members of this type, see clsApplikationKategorie-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationKategorie

[Visual Basic]
Public Class clsApplikationKategorie
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationKategorie-Member


clsApplikationKategorie-Member

clsApplikationKategorie Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationKategorie -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutier_am

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutier_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKategorieNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKategorie -Klasse


clsApplikationKategorie -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie-Eigenschaften

clsApplikationKategorie Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutier_am

Unterstützt von .NET Compact Framework
public property iApplikationKategorieNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKategorie -Klasse


clsApplikationKategorie.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.daMutier_am -Eigenschaft

[Visual Basic]
Public Property daMutier_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutier_am]() As SqlDateTime
            Get
                Return m_daMutier_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutier_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.iApplikationKategorieNr -Eigenschaft

[Visual Basic]
Public Property iApplikationKategorieNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationKategorieNr]() As SqlInt32
            Get
                Return m_iApplikationKategorieNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationKategorieNrTmp As SqlInt32 = Value
                If iApplikationKategorieNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationKategorieNr", "iApplikationKategorieNr can't be NULL")
                End If
                m_iApplikationKategorieNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie-Methoden

clsApplikationKategorie Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationKategorie -Klasse


clsApplikationKategorie.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKategorieNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKategorie_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKategorie_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKategorie::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKategorieNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutier_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKategorie_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutier_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutier_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKategorie_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKategorie::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKategorie_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKategorie")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKategorie_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKategorie::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKategorieNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationKategorieNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutier_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKategorie_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKategorie")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKategorie_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationKategorieNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationKategorieNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutier_am") Is System.DBNull.Value Then
                        m_daMutier_am = SqlDateTime.Null
                    Else
                        m_daMutier_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutier_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKategorie::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKategorieNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutier_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKategorie_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKategorieNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKategorieNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutier_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutier_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKategorie_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKategorie::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKategorie-Felder

clsApplikationKategorie Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutier_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKategorieNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKategorie -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutier_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_daMutier_am -Feld

[Visual Basic]
Private m_daMutier_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutier_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_iApplikationKategorieNr -Feld

[Visual Basic]
Private m_iApplikationKategorieNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationKategorieNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationKategorieNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKategorie


clsApplikationKontakt -Klasse

Purpose: Data Access class for the table 'ApplikationKontakt'.

For a list of all members of this type, see clsApplikationKontakt-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt
Vertragsverwaltung.TKB.VV.Applikation.clsKontakt

[Visual Basic]
Public Class clsApplikationKontakt
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationKontakt-Member


clsApplikationKontakt-Member

clsApplikationKontakt Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationKontakt -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bIntern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKontaktnr

Unterstützt von .NET Compact Framework
public property iApplikationnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bIntern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKontaktnr

Unterstützt von .NET Compact Framework
private field m_iApplikationnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKontakt -Klasse


clsApplikationKontakt-Eigenschaften

clsApplikationKontakt Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bIntern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKontaktnr

Unterstützt von .NET Compact Framework
public property iApplikationnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKontakt -Klasse


clsApplikationKontakt-Methoden

clsApplikationKontakt Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationKontakt -Klasse


clsApplikationKontakt.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKontaktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKontakt_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKontaktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKontaktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKontakt_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKontakt::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKontakt-Felder

clsApplikationKontakt Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bIntern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKontaktnr

Unterstützt von .NET Compact Framework
private field m_iApplikationnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKontakt -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_bIntern -Feld

[Visual Basic]
Private m_bIntern As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iApplikationKontaktnr -Feld

[Visual Basic]
Private m_iApplikationKontaktnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iApplikationnr -Feld

[Visual Basic]
Private m_iApplikationnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iKontakttypNr -Feld

[Visual Basic]
Private m_iKontakttypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iPersonNr -Feld

[Visual Basic]
Private m_iPersonNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iApplikationnr, m_iApplikationKontaktnr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKontakt


clsApplikationKritikalitaetTyp -Klasse

Purpose: Data Access class for the table 'ApplikationKritikalitaetTyp'.

For a list of all members of this type, see clsApplikationKritikalitaetTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationKritikalitaetTyp

[Visual Basic]
Public Class clsApplikationKritikalitaetTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationKritikalitaetTyp-Member


clsApplikationKritikalitaetTyp-Member

clsApplikationKritikalitaetTyp Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationKritikalitaetTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKritikalitaetTyp -Klasse


clsApplikationKritikalitaetTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp-Eigenschaften

clsApplikationKritikalitaetTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKritikalitaetTyp -Klasse


clsApplikationKritikalitaetTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.iApplikationKritikalitaetTypNr -Eigenschaft

[Visual Basic]
Public Property iApplikationKritikalitaetTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationKritikalitaetTypNr]() As SqlInt32
            Get
                Return m_iApplikationKritikalitaetTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationKritikalitaetTypNrTmp As SqlInt32 = Value
                If iApplikationKritikalitaetTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationKritikalitaetTypNr", "iApplikationKritikalitaetTypNr can't be NULL")
                End If
                m_iApplikationKritikalitaetTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp-Methoden

clsApplikationKritikalitaetTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationKritikalitaetTyp -Klasse


clsApplikationKritikalitaetTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKritikalitaetTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKritikalitaetTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKritikalitaetTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKritikalitaetTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKritikalitaetTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKritikalitaetTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKritikalitaetTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKritikalitaetTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKritikalitaetTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKritikalitaetTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKritikalitaetTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKritikalitaetTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKritikalitaetTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationKritikalitaetTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKritikalitaetTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationKritikalitaetTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKritikalitaetTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationKritikalitaetTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationKritikalitaetTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKritikalitaetTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationKritikalitaetTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationKritikalitaetTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationKritikalitaetTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationKritikalitaetTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationKritikalitaetTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationKritikalitaetTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationKritikalitaetTyp-Felder

clsApplikationKritikalitaetTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationKritikalitaetTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationKritikalitaetTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_iApplikationKritikalitaetTypNr -Feld

[Visual Basic]
Private m_iApplikationKritikalitaetTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationKritikalitaetTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationKritikalitaetTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationKritikalitaetTyp


clsApplikationLogbuch -Klasse

Purpose: Data Access class for the table 'ApplikationLogbuch'.

For a list of all members of this type, see clsApplikationLogbuch-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationLogbuch

[Visual Basic]
Public Class clsApplikationLogbuch
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationLogbuch-Member


clsApplikationLogbuch-Member

clsApplikationLogbuch Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationLogbuch -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAbnahmeFBDatum

Unterstützt von .NET Compact Framework
public property daAbnahmeTecDatum

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daFreigabeDatum

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daReleasedatum

Unterstützt von .NET Compact Framework
public property iAbnahmeFBPerson

Unterstützt von .NET Compact Framework
public property iAbnahmeTecPerson

Unterstützt von .NET Compact Framework
public property iApplikationLogbuchNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFreigabedurch

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReleaseartnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daAbnahmeFBDatum

Unterstützt von .NET Compact Framework
private field m_daAbnahmeTecDatum

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daFreigabeDatum

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daReleasedatum

Unterstützt von .NET Compact Framework
private field m_iAbnahmeFBPerson

Unterstützt von .NET Compact Framework
private field m_iAbnahmeTecPerson

Unterstützt von .NET Compact Framework
private field m_iApplikationLogbuchNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFreigabedurch

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReleaseartnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


clsApplikationLogbuch -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch-Eigenschaften

clsApplikationLogbuch Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAbnahmeFBDatum

Unterstützt von .NET Compact Framework
public property daAbnahmeTecDatum

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daFreigabeDatum

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daReleasedatum

Unterstützt von .NET Compact Framework
public property iAbnahmeFBPerson

Unterstützt von .NET Compact Framework
public property iAbnahmeTecPerson

Unterstützt von .NET Compact Framework
public property iApplikationLogbuchNr

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFreigabedurch

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReleaseartnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


clsApplikationLogbuch-Methoden

clsApplikationLogbuch Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationLogbuch -Klasse


clsApplikationLogbuch.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationLogbuchNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationLogbuch_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationLogbuchNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationLogbuchNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationLogbuch_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationLogbuch::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch-Felder

clsApplikationLogbuch Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daAbnahmeFBDatum

Unterstützt von .NET Compact Framework
private field m_daAbnahmeTecDatum

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daFreigabeDatum

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daReleasedatum

Unterstützt von .NET Compact Framework
private field m_iAbnahmeFBPerson

Unterstützt von .NET Compact Framework
private field m_iAbnahmeTecPerson

Unterstützt von .NET Compact Framework
private field m_iApplikationLogbuchNr

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFreigabedurch

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReleaseartnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationLogbuch -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daAbnahmeFBDatum -Feld

[Visual Basic]
Private m_daAbnahmeFBDatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daAbnahmeTecDatum -Feld

[Visual Basic]
Private m_daAbnahmeTecDatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daFreigabeDatum -Feld

[Visual Basic]
Private m_daFreigabeDatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_daReleasedatum -Feld

[Visual Basic]
Private m_daReleasedatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daAbnahmeTecDatum, m_daFreigabeDatum, m_daAbnahmeFBDatum, m_daReleasedatum, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iAbnahmeFBPerson -Feld

[Visual Basic]
Private m_iAbnahmeFBPerson As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iAbnahmeTecPerson -Feld

[Visual Basic]
Private m_iAbnahmeTecPerson As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iApplikationLogbuchNr -Feld

[Visual Basic]
Private m_iApplikationLogbuchNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iFreigabedurch -Feld

[Visual Basic]
Private m_iFreigabedurch As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_iReleaseartnr -Feld

[Visual Basic]
Private m_iReleaseartnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iFreigabedurch, m_iApplikationLogbuchNr, m_iReleaseartnr, m_iAbnahmeTecPerson, m_iAbnahmeFBPerson As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationSLMTyp -Klasse

Purpose: Data Access class for the table 'ApplikationSLMTyp'.

For a list of all members of this type, see clsApplikationSLMTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationSLMTyp

[Visual Basic]
Public Class clsApplikationSLMTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationSLMTyp-Member


clsApplikationSLMTyp-Member

clsApplikationSLMTyp Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationSLMTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationSLMTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationSLMTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationSLMTyp -Klasse


clsApplikationSLMTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp-Eigenschaften

clsApplikationSLMTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationSLMTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationSLMTyp -Klasse


clsApplikationSLMTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.iApplikationSLMTypNr -Eigenschaft

[Visual Basic]
Public Property iApplikationSLMTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationSLMTypNr]() As SqlInt32
            Get
                Return m_iApplikationSLMTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationSLMTypNrTmp As SqlInt32 = Value
                If iApplikationSLMTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationSLMTypNr", "iApplikationSLMTypNr can't be NULL")
                End If
                m_iApplikationSLMTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp-Methoden

clsApplikationSLMTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationSLMTyp -Klasse


clsApplikationSLMTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationSLMTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationSLMTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationSLMTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationSLMTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationSLMTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationSLMTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationSLMTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationSLMTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationSLMTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationSLMTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationSLMTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationSLMTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationSLMTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationSLMTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationSLMTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationSLMTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationSLMTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationSLMTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationSLMTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationSLMTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationSLMTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationSLMTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationSLMTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationSLMTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationSLMTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationSLMTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationSLMTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationSLMTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationSLMTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationSLMTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationSLMTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationSLMTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationSLMTyp-Felder

clsApplikationSLMTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationSLMTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationSLMTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_iApplikationSLMTypNr -Feld

[Visual Basic]
Private m_iApplikationSLMTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationSLMTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationSLMTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationSLMTyp


clsApplikationStandardTyp -Klasse

Purpose: Data Access class for the table 'ApplikationStandardTyp'.

For a list of all members of this type, see clsApplikationStandardTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationStandardTyp

[Visual Basic]
Public Class clsApplikationStandardTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationStandardTyp-Member


clsApplikationStandardTyp-Member

clsApplikationStandardTyp Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationStandardTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationStandardTyp -Klasse


clsApplikationStandardTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp-Eigenschaften

clsApplikationStandardTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationStandardTyp -Klasse


clsApplikationStandardTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.iApplikationStandardTypNr -Eigenschaft

[Visual Basic]
Public Property iApplikationStandardTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationStandardTypNr]() As SqlInt32
            Get
                Return m_iApplikationStandardTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationStandardTypNrTmp As SqlInt32 = Value
                If iApplikationStandardTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationStandardTypNr", "iApplikationStandardTypNr can't be NULL")
                End If
                m_iApplikationStandardTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp-Methoden

clsApplikationStandardTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationStandardTyp -Klasse


clsApplikationStandardTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationStandardTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationStandardTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationStandardTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationStandardTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationStandardTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationStandardTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationStandardTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationStandardTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationStandardTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationStandardTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationStandardTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationStandardTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationStandardTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationStandardTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationStandardTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationStandardTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationStandardTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationStandardTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationStandardTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationStandardTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationStandardTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationStandardTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationStandardTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationStandardTyp-Felder

clsApplikationStandardTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationStandardTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationStandardTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_iApplikationStandardTypNr -Feld

[Visual Basic]
Private m_iApplikationStandardTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationStandardTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationStandardTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationStandardTyp


clsApplikationTeam -Klasse

Purpose: Data Access class for the table 'ApplikationTeam'.

For a list of all members of this type, see clsApplikationTeam-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationTeam

[Visual Basic]
Public Class clsApplikationTeam
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationTeam-Member


clsApplikationTeam-Member

clsApplikationTeam Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationTeam -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationTeamNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationTeamNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTeam -Klasse


clsApplikationTeam -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam-Eigenschaften

clsApplikationTeam Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationTeamNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTeam -Klasse


clsApplikationTeam.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.iApplikationTeamNr -Eigenschaft

[Visual Basic]
Public Property iApplikationTeamNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationTeamNr]() As SqlInt32
            Get
                Return m_iApplikationTeamNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationTeamNrTmp As SqlInt32 = Value
                If iApplikationTeamNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationTeamNr", "iApplikationTeamNr can't be NULL")
                End If
                m_iApplikationTeamNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam-Methoden

clsApplikationTeam Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationTeam -Klasse


clsApplikationTeam.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTeamNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTeam_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTeamNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTeam_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTeam::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTeamNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTeam_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTeamNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTeam_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTeam::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTeam_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationTeam")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTeam_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTeam::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTeamNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationTeamNr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTeam_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationTeam")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationTeamNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTeam_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationTeamNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationTeamNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTeam::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTeamNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTeam_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTeamNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTeamNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTeam_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTeam::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTeam-Felder

clsApplikationTeam Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationTeamNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTeam -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


m_iApplikationTeamNr -Feld

[Visual Basic]
Private m_iApplikationTeamNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationTeamNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationTeamNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTeam


clsApplikationTestAZ -Klasse

Purpose: Data Access class for the table 'ApplikationTestAZ'.

For a list of all members of this type, see clsApplikationTestAZ-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationTestAZ

[Visual Basic]
Public Class clsApplikationTestAZ
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationTestAZ-Member


clsApplikationTestAZ-Member

clsApplikationTestAZ Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationTestAZ -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationTestAZnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationTestAZnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTestAZ -Klasse


clsApplikationTestAZ -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ-Eigenschaften

clsApplikationTestAZ Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationTestAZnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTestAZ -Klasse


clsApplikationTestAZ.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.iApplikationTestAZnr -Eigenschaft

[Visual Basic]
Public Property iApplikationTestAZnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationTestAZnr]() As SqlInt32
            Get
                Return m_iApplikationTestAZnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationTestAZnrTmp As SqlInt32 = Value
                If iApplikationTestAZnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationTestAZnr", "iApplikationTestAZnr can't be NULL")
                End If
                m_iApplikationTestAZnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ-Methoden

clsApplikationTestAZ Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationTestAZ -Klasse


clsApplikationTestAZ.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTestAZnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTestAZ_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTestAZnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTestAZnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTestAZ_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTestAZ::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTestAZnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTestAZ_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTestAZnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTestAZnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTestAZ_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTestAZ::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTestAZ_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationTestAZ")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTestAZ_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTestAZ::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTestAZnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationTestAZnr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTestAZ_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationTestAZ")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationTestAZnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTestAZnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTestAZ_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationTestAZnr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationTestAZnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTestAZ::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationTestAZnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationTestAZ_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationTestAZnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationTestAZnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationTestAZ_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationTestAZ::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationTestAZ-Felder

clsApplikationTestAZ Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationTestAZnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationTestAZ -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


m_iApplikationTestAZnr -Feld

[Visual Basic]
Private m_iApplikationTestAZnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationTestAZnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationTestAZnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTestAZ


clsApplikationVerantwortung -Klasse

Purpose: Data Access class for the table 'ApplikationVerantwortung'.

For a list of all members of this type, see clsApplikationVerantwortung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationVerantwortung

[Visual Basic]
Public Class clsApplikationVerantwortung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationVerantwortung-Member


clsApplikationVerantwortung-Member

clsApplikationVerantwortung Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationVerantwortung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationVerantwortung -Klasse


clsApplikationVerantwortung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung-Eigenschaften

clsApplikationVerantwortung Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationVerantwortung -Klasse


clsApplikationVerantwortung.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.iApplikationVerantwortungNr -Eigenschaft

[Visual Basic]
Public Property iApplikationVerantwortungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationVerantwortungNr]() As SqlInt32
            Get
                Return m_iApplikationVerantwortungNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationVerantwortungNrTmp As SqlInt32 = Value
                If iApplikationVerantwortungNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationVerantwortungNr", "iApplikationVerantwortungNr can't be NULL")
                End If
                m_iApplikationVerantwortungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung-Methoden

clsApplikationVerantwortung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationVerantwortung -Klasse


clsApplikationVerantwortung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationVerantwortungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationVerantwortung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationVerantwortung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationVerantwortung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationVerantwortungNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationVerantwortung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationVerantwortung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationVerantwortung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationVerantwortung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationVerantwortung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationVerantwortung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationVerantwortung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationVerantwortungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iApplikationVerantwortungNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationVerantwortung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ApplikationVerantwortung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationVerantwortung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationVerantwortungNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationVerantwortungNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationVerantwortung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationVerantwortungNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ApplikationVerantwortung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationVerantwortungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationVerantwortungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ApplikationVerantwortung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationVerantwortung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationVerantwortung-Felder

clsApplikationVerantwortung Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationVerantwortungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationVerantwortung -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_iApplikationVerantwortungNr -Feld

[Visual Basic]
Private m_iApplikationVerantwortungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationVerantwortungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iApplikationVerantwortungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationVerantwortung


clsApplikationabhaengigkeit -Klasse

Purpose: Data Access class for the table 'Applikationabhaengigkeit'.

For a list of all members of this type, see clsApplikationabhaengigkeit-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit
Vertragsverwaltung.TKB.VV.Applikation.clsApplikationsabhaengigkeit

[Visual Basic]
Public Class clsApplikationabhaengigkeit
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsApplikationabhaengigkeit-Member


clsApplikationabhaengigkeit-Member

clsApplikationabhaengigkeit Übersicht

Öffentliche Konstruktoren

public constructor clsApplikationabhaengigkeit -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationAbhaengigkeitNr

Unterstützt von .NET Compact Framework
public property iApplikationnr1

Unterstützt von .NET Compact Framework
public property iApplikationnr2

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationAbhaengigkeitNr

Unterstützt von .NET Compact Framework
private field m_iApplikationnr1

Unterstützt von .NET Compact Framework
private field m_iApplikationnr2

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationabhaengigkeit -Klasse


clsApplikationabhaengigkeit -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit-Eigenschaften

clsApplikationabhaengigkeit Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationAbhaengigkeitNr

Unterstützt von .NET Compact Framework
public property iApplikationnr1

Unterstützt von .NET Compact Framework
public property iApplikationnr2

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationabhaengigkeit -Klasse


clsApplikationabhaengigkeit-Methoden

clsApplikationabhaengigkeit Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsApplikationabhaengigkeit -Klasse


clsApplikationabhaengigkeit.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iApplikationAbhaengigkeitNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Applikationabhaengigkeit_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationAbhaengigkeitNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationAbhaengigkeitNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Applikationabhaengigkeit_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikationabhaengigkeit::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsApplikationabhaengigkeit-Felder

clsApplikationabhaengigkeit Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationAbhaengigkeitNr

Unterstützt von .NET Compact Framework
private field m_iApplikationnr1

Unterstützt von .NET Compact Framework
private field m_iApplikationnr2

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsApplikationabhaengigkeit -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_iApplikationAbhaengigkeitNr -Feld

[Visual Basic]
Private m_iApplikationAbhaengigkeitNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iApplikationnr2, m_iApplikationnr1, m_iApplikationAbhaengigkeitNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_iApplikationnr1 -Feld

[Visual Basic]
Private m_iApplikationnr1 As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iApplikationnr2, m_iApplikationnr1, m_iApplikationAbhaengigkeitNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_iApplikationnr2 -Feld

[Visual Basic]
Private m_iApplikationnr2 As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iApplikationnr2, m_iApplikationnr1, m_iApplikationAbhaengigkeitNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iApplikationnr2, m_iApplikationnr1, m_iApplikationAbhaengigkeitNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iApplikationnr2, m_iApplikationnr1, m_iApplikationAbhaengigkeitNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationabhaengigkeit


clsAuswertung -Klasse

Purpose: Data Access class for the table 'Auswertung'.

For a list of all members of this type, see clsAuswertung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAuswertung

[Visual Basic]
Public Class clsAuswertung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertung-Member


clsAuswertung-Member

clsAuswertung Übersicht

Öffentliche Konstruktoren

public constructor clsAuswertung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bCR_Report

Unterstützt von .NET Compact Framework
public property bCSV_Report

Unterstützt von .NET Compact Framework
public property bTXP_Auswertung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sCR_Filename

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionstring_Subreport

Unterstützt von .NET Compact Framework
public property sSQL

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bCR_Report

Unterstützt von .NET Compact Framework
private field m_bCSV_Report

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bTXP_Auswertung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sCR_Filename

Unterstützt von .NET Compact Framework
private field m_sConnectionstring_Subreport

Unterstützt von .NET Compact Framework
private field m_sSQL

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


clsAuswertung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung-Eigenschaften

clsAuswertung Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bCR_Report

Unterstützt von .NET Compact Framework
public property bCSV_Report

Unterstützt von .NET Compact Framework
public property bTXP_Auswertung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sCR_Filename

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionstring_Subreport

Unterstützt von .NET Compact Framework
public property sSQL

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


clsAuswertung.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.bCR_Report -Eigenschaft

[Visual Basic]
Public Property bCR_Report() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bCR_Report]() As SqlBoolean
            Get
                Return m_bCR_Report
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bCR_Report = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.bCSV_Report -Eigenschaft

[Visual Basic]
Public Property bCSV_Report() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bCSV_Report]() As SqlBoolean
            Get
                Return m_bCSV_Report
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bCSV_Report = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.bTXP_Auswertung -Eigenschaft

[Visual Basic]
Public Property bTXP_Auswertung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bTXP_Auswertung]() As SqlBoolean
            Get
                Return m_bTXP_Auswertung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bTXP_Auswertung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.iAuswertungNr -Eigenschaft

[Visual Basic]
Public Property iAuswertungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungNr]() As SqlInt32
            Get
                Return m_iAuswertungNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuswertungNrTmp As SqlInt32 = Value
                If iAuswertungNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuswertungNr", "iAuswertungNr can't be NULL")
                End If
                m_iAuswertungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.sCR_Filename -Eigenschaft

[Visual Basic]
Public Property sCR_Filename() As SqlString

Quellcode

[Visual Basic]
        Public Property [sCR_Filename]() As SqlString
            Get
                Return m_sCR_Filename
            End Get
            Set(ByVal Value As SqlString)
                m_sCR_Filename = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.sConnectionstring_Subreport -Eigenschaft

[Visual Basic]
Public Property sConnectionstring_Subreport() As SqlString

Quellcode

[Visual Basic]
        Public Property [sConnectionstring_Subreport]() As SqlString
            Get
                Return m_sConnectionstring_Subreport
            End Get
            Set(ByVal Value As SqlString)
                m_sConnectionstring_Subreport = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.sSQL -Eigenschaft

[Visual Basic]
Public Property sSQL() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSQL]() As SqlString
            Get
                Return m_sSQL
            End Get
            Set(ByVal Value As SqlString)
                m_sSQL = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung-Methoden

clsAuswertung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAuswertung -Klasse


clsAuswertung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bCR_Report. May be SqlBoolean.Null</LI> <LI>sCR_Filename. May be SqlString.Null</LI> <LI>bCSV_Report. May be SqlBoolean.Null</LI> <LI>sSQL. May be SqlString.Null</LI> <LI>bTXP_Auswertung. May be SqlBoolean.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sConnectionstring_Subreport. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCR_Report", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bCR_Report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCR_Filename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCR_Filename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCSV_Report", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bCSV_Report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSQL", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSQL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTXP_Auswertung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTXP_Auswertung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sConnectionstring_Subreport", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sConnectionstring_Subreport))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Auswertung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAuswertungNr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bCR_Report</LI> <LI>sCR_Filename</LI> <LI>bCSV_Report</LI> <LI>sSQL</LI> <LI>bTXP_Auswertung</LI> <LI>sBeschreibung</LI> <LI>sConnectionstring_Subreport</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Auswertung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuswertungNr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("CR_Report") Is System.DBNull.Value Then
                        m_bCR_Report = SqlBoolean.Null
                    Else
                        m_bCR_Report = New SqlBoolean(CType(dtToReturn.Rows(0)("CR_Report"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("CR_Filename") Is System.DBNull.Value Then
                        m_sCR_Filename = SqlString.Null
                    Else
                        m_sCR_Filename = New SqlString(CType(dtToReturn.Rows(0)("CR_Filename"), String))
                    End If
                    If dtToReturn.Rows(0)("CSV_Report") Is System.DBNull.Value Then
                        m_bCSV_Report = SqlBoolean.Null
                    Else
                        m_bCSV_Report = New SqlBoolean(CType(dtToReturn.Rows(0)("CSV_Report"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("SQL") Is System.DBNull.Value Then
                        m_sSQL = SqlString.Null
                    Else
                        m_sSQL = New SqlString(CType(dtToReturn.Rows(0)("SQL"), String))
                    End If
                    If dtToReturn.Rows(0)("TXP_Auswertung") Is System.DBNull.Value Then
                        m_bTXP_Auswertung = SqlBoolean.Null
                    Else
                        m_bTXP_Auswertung = New SqlBoolean(CType(dtToReturn.Rows(0)("TXP_Auswertung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Connectionstring_Subreport") Is System.DBNull.Value Then
                        m_sConnectionstring_Subreport = SqlString.Null
                    Else
                        m_sConnectionstring_Subreport = New SqlString(CType(dtToReturn.Rows(0)("Connectionstring_Subreport"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bCR_Report. May be SqlBoolean.Null</LI> <LI>sCR_Filename. May be SqlString.Null</LI> <LI>bCSV_Report. May be SqlBoolean.Null</LI> <LI>sSQL. May be SqlString.Null</LI> <LI>bTXP_Auswertung. May be SqlBoolean.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sConnectionstring_Subreport. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCR_Report", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bCR_Report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCR_Filename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCR_Filename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCSV_Report", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bCSV_Report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSQL", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSQL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bTXP_Auswertung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bTXP_Auswertung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sConnectionstring_Subreport", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sConnectionstring_Subreport))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung-Felder

clsAuswertung Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bCR_Report

Unterstützt von .NET Compact Framework
private field m_bCSV_Report

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bTXP_Auswertung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sCR_Filename

Unterstützt von .NET Compact Framework
private field m_sConnectionstring_Subreport

Unterstützt von .NET Compact Framework
private field m_sSQL

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertung -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bCSV_Report, m_bCR_Report, m_bTXP_Auswertung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_bCR_Report -Feld

[Visual Basic]
Private m_bCR_Report As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bCSV_Report, m_bCR_Report, m_bTXP_Auswertung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_bCSV_Report -Feld

[Visual Basic]
Private m_bCSV_Report As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bCSV_Report, m_bCR_Report, m_bTXP_Auswertung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_bTXP_Auswertung -Feld

[Visual Basic]
Private m_bTXP_Auswertung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bCSV_Report, m_bCR_Report, m_bTXP_Auswertung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_iAuswertungNr -Feld

[Visual Basic]
Private m_iAuswertungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iAuswertungNr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iAuswertungNr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sConnectionstring_Subreport, m_sBezeichnung, m_sCR_Filename, m_sSQL As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sConnectionstring_Subreport, m_sBezeichnung, m_sCR_Filename, m_sSQL As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_sCR_Filename -Feld

[Visual Basic]
Private m_sCR_Filename As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sConnectionstring_Subreport, m_sBezeichnung, m_sCR_Filename, m_sSQL As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_sConnectionstring_Subreport -Feld

[Visual Basic]
Private m_sConnectionstring_Subreport As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sConnectionstring_Subreport, m_sBezeichnung, m_sCR_Filename, m_sSQL As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


m_sSQL -Feld

[Visual Basic]
Private m_sSQL As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sConnectionstring_Subreport, m_sBezeichnung, m_sCR_Filename, m_sSQL As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertungAuswertungParameter -Klasse

Purpose: Data Access class for the table 'AuswertungAuswertungParameter'.

For a list of all members of this type, see clsAuswertungAuswertungParameter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAuswertungAuswertungParameter

[Visual Basic]
Public Class clsAuswertungAuswertungParameter
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertungAuswertungParameter-Member


clsAuswertungAuswertungParameter-Member

clsAuswertungAuswertungParameter Übersicht

Öffentliche Konstruktoren

public constructor clsAuswertungAuswertungParameter -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iAuswertungnr

Unterstützt von .NET Compact Framework
public property iAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDBfeldname

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungAuswertungparameternr

Unterstützt von .NET Compact Framework
private field m_iAuswertungnr

Unterstützt von .NET Compact Framework
private field m_iAuswertungparameternr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sDBfeldname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungAuswertungParameter -Klasse


clsAuswertungAuswertungParameter -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter-Eigenschaften

clsAuswertungAuswertungParameter Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iAuswertungnr

Unterstützt von .NET Compact Framework
public property iAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDBfeldname

Unterstützt von .NET Compact Framework

clsAuswertungAuswertungParameter -Klasse


clsAuswertungAuswertungParameter.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.iAuswertungAuswertungparameternr -Eigenschaft

[Visual Basic]
Public Property iAuswertungAuswertungparameternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungAuswertungparameternr]() As SqlInt32
            Get
                Return m_iAuswertungAuswertungparameternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuswertungAuswertungparameternrTmp As SqlInt32 = Value
                If iAuswertungAuswertungparameternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuswertungAuswertungparameternr", "iAuswertungAuswertungparameternr can't be NULL")
                End If
                m_iAuswertungAuswertungparameternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.iAuswertungnr -Eigenschaft

[Visual Basic]
Public Property iAuswertungnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungnr]() As SqlInt32
            Get
                Return m_iAuswertungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuswertungnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.iAuswertungparameternr -Eigenschaft

[Visual Basic]
Public Property iAuswertungparameternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungparameternr]() As SqlInt32
            Get
                Return m_iAuswertungparameternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuswertungparameternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.iReihenfolge -Eigenschaft

[Visual Basic]
Public Property iReihenfolge() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.sDBfeldname -Eigenschaft

[Visual Basic]
Public Property sDBfeldname() As SqlString

Quellcode

[Visual Basic]
        Public Property [sDBfeldname]() As SqlString
            Get
                Return m_sDBfeldname
            End Get
            Set(ByVal Value As SqlString)
                m_sDBfeldname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter-Methoden

clsAuswertungAuswertungParameter Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAuswertungAuswertungParameter -Klasse


clsAuswertungAuswertungParameter.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungAuswertungparameternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungAuswertungParameter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungAuswertungParameter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungAuswertungParameter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungAuswertungparameternr</LI> <LI>iAuswertungnr. May be SqlInt32.Null</LI> <LI>iAuswertungparameternr. May be SqlInt32.Null</LI> <LI>sDBfeldname. May be SqlString.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungAuswertungParameter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDBfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDBfeldname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungAuswertungParameter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungAuswertungParameter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungAuswertungParameter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungAuswertungParameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungAuswertungParameter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungAuswertungParameter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungAuswertungparameternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAuswertungAuswertungparameternr</LI> <LI>iAuswertungnr</LI> <LI>iAuswertungparameternr</LI> <LI>sDBfeldname</LI> <LI>iReihenfolge</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungAuswertungParameter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungAuswertungParameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAuswertungAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungAuswertungParameter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuswertungAuswertungparameternr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungAuswertungparameternr"), Integer))
                    If dtToReturn.Rows(0)("Auswertungnr") Is System.DBNull.Value Then
                        m_iAuswertungnr = SqlInt32.Null
                    Else
                        m_iAuswertungnr = New SqlInt32(CType(dtToReturn.Rows(0)("Auswertungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Auswertungparameternr") Is System.DBNull.Value Then
                        m_iAuswertungparameternr = SqlInt32.Null
                    Else
                        m_iAuswertungparameternr = New SqlInt32(CType(dtToReturn.Rows(0)("Auswertungparameternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DBfeldname") Is System.DBNull.Value Then
                        m_sDBfeldname = SqlString.Null
                    Else
                        m_sDBfeldname = New SqlString(CType(dtToReturn.Rows(0)("DBfeldname"), String))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungAuswertungParameter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungAuswertungparameternr</LI> <LI>iAuswertungnr. May be SqlInt32.Null</LI> <LI>iAuswertungparameternr. May be SqlInt32.Null</LI> <LI>sDBfeldname. May be SqlString.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungAuswertungParameter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDBfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDBfeldname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungAuswertungParameter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungAuswertungParameter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungAuswertungParameter-Felder

clsAuswertungAuswertungParameter Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungAuswertungparameternr

Unterstützt von .NET Compact Framework
private field m_iAuswertungnr

Unterstützt von .NET Compact Framework
private field m_iAuswertungparameternr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sDBfeldname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungAuswertungParameter -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_iAuswertungAuswertungparameternr -Feld

[Visual Basic]
Private m_iAuswertungAuswertungparameternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iAuswertungnr, m_iAuswertungAuswertungparameternr, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_iAuswertungnr -Feld

[Visual Basic]
Private m_iAuswertungnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iAuswertungnr, m_iAuswertungAuswertungparameternr, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_iAuswertungparameternr -Feld

[Visual Basic]
Private m_iAuswertungparameternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iAuswertungnr, m_iAuswertungAuswertungparameternr, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iAuswertungnr, m_iAuswertungAuswertungparameternr, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_iReihenfolge -Feld

[Visual Basic]
Private m_iReihenfolge As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iAuswertungnr, m_iAuswertungAuswertungparameternr, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


m_sDBfeldname -Feld

[Visual Basic]
Private m_sDBfeldname As SqlString

Quellcode

[Visual Basic]
        Private 		m_sDBfeldname As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungAuswertungParameter


clsAuswertungGruppe -Klasse

Purpose: Data Access class for the table 'AuswertungGruppe'.

For a list of all members of this type, see clsAuswertungGruppe-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAuswertungGruppe

[Visual Basic]
Public Class clsAuswertungGruppe
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertungGruppe-Member


clsAuswertungGruppe-Member

clsAuswertungGruppe Übersicht

Öffentliche Konstruktoren

public constructor clsAuswertungGruppe -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentid

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentid

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppe -Klasse


clsAuswertungGruppe -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe-Eigenschaften

clsAuswertungGruppe Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentid

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppe -Klasse


clsAuswertungGruppe.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.iAuswertungGruppeNr -Eigenschaft

[Visual Basic]
Public Property iAuswertungGruppeNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungGruppeNr]() As SqlInt32
            Get
                Return m_iAuswertungGruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuswertungGruppeNrTmp As SqlInt32 = Value
                If iAuswertungGruppeNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuswertungGruppeNr", "iAuswertungGruppeNr can't be NULL")
                End If
                m_iAuswertungGruppeNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.iParentid -Eigenschaft

[Visual Basic]
Public Property iParentid() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iParentid]() As SqlInt32
            Get
                Return m_iParentid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentid = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe-Methoden

clsAuswertungGruppe Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAuswertungGruppe -Klasse


clsAuswertungGruppe.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iParentid. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungGruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAuswertungGruppeNr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iParentid</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungGruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuswertungGruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungGruppeNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Parentid") Is System.DBNull.Value Then
                        m_iParentid = SqlInt32.Null
                    Else
                        m_iParentid = New SqlInt32(CType(dtToReturn.Rows(0)("Parentid"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iParentid. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppe-Felder

clsAuswertungGruppe Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentid

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppe -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_iAuswertungGruppeNr -Feld

[Visual Basic]
Private m_iAuswertungGruppeNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iParentid, m_iMutierer, m_iAuswertungGruppeNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iParentid, m_iMutierer, m_iAuswertungGruppeNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_iParentid -Feld

[Visual Basic]
Private m_iParentid As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iParentid, m_iMutierer, m_iAuswertungGruppeNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppe


clsAuswertungGruppeAuswertung -Klasse

Purpose: Data Access class for the table 'AuswertungGruppeAuswertung'.

For a list of all members of this type, see clsAuswertungGruppeAuswertung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAuswertungGruppeAuswertung

[Visual Basic]
Public Class clsAuswertungGruppeAuswertung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertungGruppeAuswertung-Member


clsAuswertungGruppeAuswertung-Member

clsAuswertungGruppeAuswertung Übersicht

Öffentliche Konstruktoren

public constructor clsAuswertungGruppeAuswertung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstllt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeAuswertungNr

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
public property iAuswertungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstllt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeAuswertungNr

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
private field m_iAuswertungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppeAuswertung -Klasse


clsAuswertungGruppeAuswertung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung-Eigenschaften

clsAuswertungGruppeAuswertung Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstllt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeAuswertungNr

Unterstützt von .NET Compact Framework
public property iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
public property iAuswertungNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppeAuswertung -Klasse


clsAuswertungGruppeAuswertung.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.daErstllt_am -Eigenschaft

[Visual Basic]
Public Property daErstllt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstllt_am]() As SqlDateTime
            Get
                Return m_daErstllt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstllt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.iAuswertungGruppeAuswertungNr -Eigenschaft

[Visual Basic]
Public Property iAuswertungGruppeAuswertungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungGruppeAuswertungNr]() As SqlInt32
            Get
                Return m_iAuswertungGruppeAuswertungNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuswertungGruppeAuswertungNrTmp As SqlInt32 = Value
                If iAuswertungGruppeAuswertungNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuswertungGruppeAuswertungNr", "iAuswertungGruppeAuswertungNr can't be NULL")
                End If
                m_iAuswertungGruppeAuswertungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.iAuswertungGruppeNr -Eigenschaft

[Visual Basic]
Public Property iAuswertungGruppeNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungGruppeNr]() As SqlInt32
            Get
                Return m_iAuswertungGruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuswertungGruppeNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.iAuswertungNr -Eigenschaft

[Visual Basic]
Public Property iAuswertungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungNr]() As SqlInt32
            Get
                Return m_iAuswertungNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuswertungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung-Methoden

clsAuswertungGruppeAuswertung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAuswertungGruppeAuswertung -Klasse


clsAuswertungGruppeAuswertung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeAuswertungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppeAuswertung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeAuswertungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppeAuswertung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppeAuswertung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeAuswertungNr</LI> <LI>iAuswertungGruppeNr. May be SqlInt32.Null</LI> <LI>iAuswertungNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstllt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppeAuswertung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstllt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstllt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppeAuswertung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppeAuswertung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppeAuswertung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungGruppeAuswertung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppeAuswertung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppeAuswertung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeAuswertungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAuswertungGruppeAuswertungNr</LI> <LI>iAuswertungGruppeNr</LI> <LI>iAuswertungNr</LI> <LI>bAktiv</LI> <LI>daErstllt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppeAuswertung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("AuswertungGruppeAuswertung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAuswertungGruppeAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeAuswertungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppeAuswertung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuswertungGruppeAuswertungNr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungGruppeAuswertungNr"), Integer))
                    If dtToReturn.Rows(0)("AuswertungGruppeNr") Is System.DBNull.Value Then
                        m_iAuswertungGruppeNr = SqlInt32.Null
                    Else
                        m_iAuswertungGruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungGruppeNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("AuswertungNr") Is System.DBNull.Value Then
                        m_iAuswertungNr = SqlInt32.Null
                    Else
                        m_iAuswertungNr = New SqlInt32(CType(dtToReturn.Rows(0)("AuswertungNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstllt_am") Is System.DBNull.Value Then
                        m_daErstllt_am = SqlDateTime.Null
                    Else
                        m_daErstllt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstllt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppeAuswertung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungGruppeAuswertungNr</LI> <LI>iAuswertungGruppeNr. May be SqlInt32.Null</LI> <LI>iAuswertungNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstllt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_AuswertungGruppeAuswertung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungGruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungGruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstllt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstllt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_AuswertungGruppeAuswertung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungGruppeAuswertung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungGruppeAuswertung-Felder

clsAuswertungGruppeAuswertung Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstllt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeAuswertungNr

Unterstützt von .NET Compact Framework
private field m_iAuswertungGruppeNr

Unterstützt von .NET Compact Framework
private field m_iAuswertungNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungGruppeAuswertung -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_daErstllt_am -Feld

[Visual Basic]
Private m_daErstllt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstllt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstllt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_iAuswertungGruppeAuswertungNr -Feld

[Visual Basic]
Private m_iAuswertungGruppeAuswertungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungGruppeNr, m_iAuswertungNr, m_iAuswertungGruppeAuswertungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_iAuswertungGruppeNr -Feld

[Visual Basic]
Private m_iAuswertungGruppeNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungGruppeNr, m_iAuswertungNr, m_iAuswertungGruppeAuswertungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_iAuswertungNr -Feld

[Visual Basic]
Private m_iAuswertungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungGruppeNr, m_iAuswertungNr, m_iAuswertungGruppeAuswertungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungGruppeNr, m_iAuswertungNr, m_iAuswertungGruppeAuswertungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungGruppeAuswertung


clsAuswertungsparameter -Klasse

Purpose: Data Access class for the table 'Auswertungsparameter'.

For a list of all members of this type, see clsAuswertungsparameter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAuswertungsparameter

[Visual Basic]
Public Class clsAuswertungsparameter
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAuswertungsparameter-Member


clsAuswertungsparameter-Member

clsAuswertungsparameter Übersicht

Öffentliche Konstruktoren

public constructor clsAuswertungsparameter -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFeldbezug

Unterstützt von .NET Compact Framework
public property sOperator

Unterstützt von .NET Compact Framework
public property sParamName

Unterstützt von .NET Compact Framework
public property sParamType

Unterstützt von .NET Compact Framework
public property sWert

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungparameternr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sFeldbezug

Unterstützt von .NET Compact Framework
private field m_sOperator

Unterstützt von .NET Compact Framework
private field m_sParamName

Unterstützt von .NET Compact Framework
private field m_sParamType

Unterstützt von .NET Compact Framework
private field m_sWert

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungsparameter -Klasse


clsAuswertungsparameter -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter-Eigenschaften

clsAuswertungsparameter Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAuswertungparameternr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFeldbezug

Unterstützt von .NET Compact Framework
public property sOperator

Unterstützt von .NET Compact Framework
public property sParamName

Unterstützt von .NET Compact Framework
public property sParamType

Unterstützt von .NET Compact Framework
public property sWert

Unterstützt von .NET Compact Framework

clsAuswertungsparameter -Klasse


clsAuswertungsparameter.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.iAuswertungparameternr -Eigenschaft

[Visual Basic]
Public Property iAuswertungparameternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungparameternr]() As SqlInt32
            Get
                Return m_iAuswertungparameternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuswertungparameternrTmp As SqlInt32 = Value
                If iAuswertungparameternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuswertungparameternr", "iAuswertungparameternr can't be NULL")
                End If
                m_iAuswertungparameternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sFeldbezug -Eigenschaft

[Visual Basic]
Public Property sFeldbezug() As SqlString

Quellcode

[Visual Basic]
        Public Property [sFeldbezug]() As SqlString
            Get
                Return m_sFeldbezug
            End Get
            Set(ByVal Value As SqlString)
                m_sFeldbezug = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sOperator -Eigenschaft

[Visual Basic]
Public Property sOperator() As SqlString

Quellcode

[Visual Basic]
        Public Property [sOperator]() As SqlString
            Get
                Return m_sOperator
            End Get
            Set(ByVal Value As SqlString)
                m_sOperator = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sParamName -Eigenschaft

[Visual Basic]
Public Property sParamName() As SqlString

Quellcode

[Visual Basic]
        Public Property [sParamName]() As SqlString
            Get
                Return m_sParamName
            End Get
            Set(ByVal Value As SqlString)
                m_sParamName = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sParamType -Eigenschaft

[Visual Basic]
Public Property sParamType() As SqlString

Quellcode

[Visual Basic]
        Public Property [sParamType]() As SqlString
            Get
                Return m_sParamType
            End Get
            Set(ByVal Value As SqlString)
                m_sParamType = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.sWert -Eigenschaft

[Visual Basic]
Public Property sWert() As SqlString

Quellcode

[Visual Basic]
        Public Property [sWert]() As SqlString
            Get
                Return m_sWert
            End Get
            Set(ByVal Value As SqlString)
                m_sWert = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter-Methoden

clsAuswertungsparameter Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAuswertungsparameter -Klasse


clsAuswertungsparameter.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungparameternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertungsparameter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertungsparameter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungsparameter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungparameternr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sOperator. May be SqlString.Null</LI> <LI>sFeldbezug. May be SqlString.Null</LI> <LI>sWert. May be SqlString.Null</LI> <LI>sParamName. May be SqlString.Null</LI> <LI>sParamType. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertungsparameter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOperator", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOperator))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFeldbezug", SqlDbType.VarChar, 200, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldbezug))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sWert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParamName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParamName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParamType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParamType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertungsparameter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungsparameter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertungsparameter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Auswertungsparameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertungsparameter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungsparameter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungparameternr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iAuswertungparameternr</LI> <LI>sBezeichnung</LI> <LI>sOperator</LI> <LI>sFeldbezug</LI> <LI>sWert</LI> <LI>sParamName</LI> <LI>sParamType</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertungsparameter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Auswertungsparameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertungsparameter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuswertungparameternr = New SqlInt32(CType(dtToReturn.Rows(0)("Auswertungparameternr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Operator") Is System.DBNull.Value Then
                        m_sOperator = SqlString.Null
                    Else
                        m_sOperator = New SqlString(CType(dtToReturn.Rows(0)("Operator"), String))
                    End If
                    If dtToReturn.Rows(0)("Feldbezug") Is System.DBNull.Value Then
                        m_sFeldbezug = SqlString.Null
                    Else
                        m_sFeldbezug = New SqlString(CType(dtToReturn.Rows(0)("Feldbezug"), String))
                    End If
                    If dtToReturn.Rows(0)("Wert") Is System.DBNull.Value Then
                        m_sWert = SqlString.Null
                    Else
                        m_sWert = New SqlString(CType(dtToReturn.Rows(0)("Wert"), String))
                    End If
                    If dtToReturn.Rows(0)("ParamName") Is System.DBNull.Value Then
                        m_sParamName = SqlString.Null
                    Else
                        m_sParamName = New SqlString(CType(dtToReturn.Rows(0)("ParamName"), String))
                    End If
                    If dtToReturn.Rows(0)("ParamType") Is System.DBNull.Value Then
                        m_sParamType = SqlString.Null
                    Else
                        m_sParamType = New SqlString(CType(dtToReturn.Rows(0)("ParamType"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungsparameter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iAuswertungparameternr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sOperator. May be SqlString.Null</LI> <LI>sFeldbezug. May be SqlString.Null</LI> <LI>sWert. May be SqlString.Null</LI> <LI>sParamName. May be SqlString.Null</LI> <LI>sParamType. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Auswertungsparameter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungparameternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungparameternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOperator", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOperator))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFeldbezug", SqlDbType.VarChar, 200, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldbezug))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sWert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParamName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParamName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParamType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParamType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Auswertungsparameter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAuswertungsparameter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsAuswertungsparameter-Felder

clsAuswertungsparameter Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAuswertungparameternr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sFeldbezug

Unterstützt von .NET Compact Framework
private field m_sOperator

Unterstützt von .NET Compact Framework
private field m_sParamName

Unterstützt von .NET Compact Framework
private field m_sParamType

Unterstützt von .NET Compact Framework
private field m_sWert

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAuswertungsparameter -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_iAuswertungparameternr -Feld

[Visual Basic]
Private m_iAuswertungparameternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iAuswertungparameternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sFeldbezug -Feld

[Visual Basic]
Private m_sFeldbezug As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sOperator -Feld

[Visual Basic]
Private m_sOperator As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sParamName -Feld

[Visual Basic]
Private m_sParamName As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sParamType -Feld

[Visual Basic]
Private m_sParamType As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


m_sWert -Feld

[Visual Basic]
Private m_sWert As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sParamName, m_sOperator, m_sWert, m_sFeldbezug, m_sParamType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertungsparameter


clsBeziehungstyp -Klasse

Purpose: Data Access class for the table 'Beziehungstyp'.

For a list of all members of this type, see clsBeziehungstyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsBeziehungstyp

[Visual Basic]
Public Class clsBeziehungstyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsBeziehungstyp-Member


clsBeziehungstyp-Member

clsBeziehungstyp Übersicht

Öffentliche Konstruktoren

public constructor clsBeziehungstyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sBezeichnung2

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBeziehungstypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung2

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsBeziehungstyp -Klasse


clsBeziehungstyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp-Eigenschaften

clsBeziehungstyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sBezeichnung2

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsBeziehungstyp -Klasse


clsBeziehungstyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.iBeziehungstypNr -Eigenschaft

[Visual Basic]
Public Property iBeziehungstypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iBeziehungstypNr]() As SqlInt32
            Get
                Return m_iBeziehungstypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBeziehungstypNrTmp As SqlInt32 = Value
                If iBeziehungstypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBeziehungstypNr", "iBeziehungstypNr can't be NULL")
                End If
                m_iBeziehungstypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.sBezeichnung2 -Eigenschaft

[Visual Basic]
Public Property sBezeichnung2() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung2]() As SqlString
            Get
                Return m_sBezeichnung2
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung2 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp-Methoden

clsBeziehungstyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsBeziehungstyp -Klasse


clsBeziehungstyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iBeziehungstypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Beziehungstyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Beziehungstyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBeziehungstyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iBeziehungstypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBezeichnung2. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Beziehungstyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Beziehungstyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBeziehungstyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Beziehungstyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Beziehungstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Beziehungstyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBeziehungstyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iBeziehungstypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iBeziehungstypNr</LI> <LI>sBezeichnung</LI> <LI>sBezeichnung2</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Beziehungstyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Beziehungstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Beziehungstyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBeziehungstypNr = New SqlInt32(CType(dtToReturn.Rows(0)("BeziehungstypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung2") Is System.DBNull.Value Then
                        m_sBezeichnung2 = SqlString.Null
                    Else
                        m_sBezeichnung2 = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung2"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBeziehungstyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iBeziehungstypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBezeichnung2. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Beziehungstyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Beziehungstyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBeziehungstyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsBeziehungstyp-Felder

clsBeziehungstyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBeziehungstypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung2

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsBeziehungstyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_iBeziehungstypNr -Feld

[Visual Basic]
Private m_iBeziehungstypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iBeziehungstypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iBeziehungstypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iBeziehungstypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBezeichnung2 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


m_sBezeichnung2 -Feld

[Visual Basic]
Private m_sBezeichnung2 As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBezeichnung2 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsBeziehungstyp


clsConnectionProvider -Klasse

For a list of all members of this type, see clsConnectionProvider-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsConnectionProvider

[Visual Basic]
Public Class clsConnectionProvider

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsConnectionProvider-Member


clsConnectionProvider-Member

clsConnectionProvider Übersicht

Öffentliche Konstruktoren

public constructor clsConnectionProvider -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property bIsTransactionPending

Unterstützt von .NET Compact Framework
public property sConnectionString

Unterstützt von .NET Compact Framework
public property scoDBConnection

Unterstützt von .NET Compact Framework
public property stCurrentTransaction

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method BeginTransaction

Unterstützt von .NET Compact Framework
public method CloseConnection

Unterstützt von .NET Compact Framework
public method CommitTransaction

Unterstützt von .NET Compact Framework
public method Dispose Überladen.

Unterstützt von .NET Compact Framework
public method OpenConnection

Unterstützt von .NET Compact Framework
public method RollbackTransaction

Unterstützt von .NET Compact Framework
public method SaveTransaction

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitClass

Unterstützt von .NET Compact Framework

Felder

private field m_alSavePoints

Unterstützt von .NET Compact Framework
private field m_bIsDisposed

Unterstützt von .NET Compact Framework
private field m_bIsTransactionPending

Unterstützt von .NET Compact Framework
private field m_scoDBConnection

Unterstützt von .NET Compact Framework
private field m_stCurrentTransaction

Unterstützt von .NET Compact Framework

clsConnectionProvider -Klasse


clsConnectionProvider -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Init the class
            InitClass()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider-Eigenschaften

clsConnectionProvider Übersicht

Öffentliche Eigenschaften

public property bIsTransactionPending

Unterstützt von .NET Compact Framework
public property sConnectionString

Unterstützt von .NET Compact Framework
public property scoDBConnection

Unterstützt von .NET Compact Framework
public property stCurrentTransaction

Unterstützt von .NET Compact Framework

clsConnectionProvider -Klasse


clsConnectionProvider.bIsTransactionPending -Eigenschaft

[Visual Basic]
Public ReadOnly Property bIsTransactionPending() As Boolean

Quellcode

[Visual Basic]
        Public ReadOnly Property bIsTransactionPending() As Boolean
            Get
                Return m_bIsTransactionPending
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.sConnectionString -Eigenschaft

[Visual Basic]
Public WriteOnly Property sConnectionString() As String

Quellcode

[Visual Basic]
        Public WriteOnly Property sConnectionString() As String
            Set (ByVal Value As String)
                m_scoDBConnection.ConnectionString = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.scoDBConnection -Eigenschaft

[Visual Basic]
Public ReadOnly Property scoDBConnection() As SqlConnection

Quellcode

[Visual Basic]
        Public ReadOnly Property scoDBConnection() As SqlConnection
            Get
                Return m_scoDBConnection
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.stCurrentTransaction -Eigenschaft

[Visual Basic]
Public ReadOnly Property stCurrentTransaction() As SqlTransaction

Quellcode

[Visual Basic]
        Public ReadOnly Property stCurrentTransaction() As SqlTransaction
            Get
                Return m_stCurrentTransaction
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider-Methoden

clsConnectionProvider Übersicht

Öffentliche Methoden

public method BeginTransaction

Unterstützt von .NET Compact Framework
public method CloseConnection

Unterstützt von .NET Compact Framework
public method CommitTransaction

Unterstützt von .NET Compact Framework
public method Dispose Überladen.

Unterstützt von .NET Compact Framework
public method OpenConnection

Unterstützt von .NET Compact Framework
public method RollbackTransaction

Unterstützt von .NET Compact Framework
public method SaveTransaction

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitClass

Unterstützt von .NET Compact Framework

clsConnectionProvider -Klasse


clsConnectionProvider.BeginTransaction -Methode

[Visual Basic]
Public Function BeginTransaction( _
   ByRef sTransactionName As String _
) As Boolean

Parameter

sTransactionName

Quellcode

[Visual Basic]
        Public Function BeginTransaction(sTransactionName As String) As Boolean
            Try
                If m_bIsTransactionPending Then
                    ' // no nested transactions allowed.
                    Throw New Exception("BeginTransaction::Already transaction pending. Nesting not allowed")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("BeginTransaction::Connection is not open.")
                End If
                ' // begin the transaction and store the transaction object.
                m_stCurrentTransaction = m_scoDBConnection.BeginTransaction(IsolationLevel.ReadCommitted, sTransactionName)
                m_bIsTransactionPending = True
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.CloseConnection -Methode

[Visual Basic]
Public Function CloseConnection( _
   ByRef bCommitPendingTransaction As Boolean _
) As Boolean

Parameter

bCommitPendingTransaction

Quellcode

[Visual Basic]
        Public Function CloseConnection(bCommitPendingTransaction As Boolean) As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // No open connection
                    Return False
                End If
                If m_bIsTransactionPending Then
                    If bCommitPendingTransaction Then
                        ' // Commit the pending transaction
                        m_stCurrentTransaction.Commit()
                    Else
                        ' // Rollback the pending transaction
                        m_stCurrentTransaction.Rollback()
                    End If
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                ' // close the connection
                m_scoDBConnection.Close()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.CommitTransaction -Methode

[Visual Basic]
Public Function CommitTransaction() As Boolean

Quellcode

[Visual Basic]
        Public Function CommitTransaction() As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("CommitTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("CommitTransaction::Connection is not open.")
                End if
                ' // commit the transaction
                m_stCurrentTransaction.Commit()
                m_bIsTransactionPending = False
                m_stCurrentTransaction.Dispose()
                m_stCurrentTransaction = Nothing
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


Dispose -Methode

Überladungsliste

[Visual Basic] Public Overloads Sub Dispose()
[C#] public System.Void Dispose();

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

clsConnectionProvider | Vertragsverwaltung.TKB.VV.DB


clsConnectionProvider.InitClass -Methode

[Visual Basic]
Private Sub InitClass()

Quellcode

[Visual Basic]
        Private Sub InitClass()
            ' // Create all the objects and initialize other members.
            m_scoDBConnection = new SqlConnection()
            m_bIsDisposed = False
            m_stCurrentTransaction = Nothing
            m_bIsTransactionPending = False
            m_alSavePoints = new ArrayList()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.OpenConnection -Methode

[Visual Basic]
Public Function OpenConnection() As Boolean

Quellcode

[Visual Basic]
        Public Function OpenConnection() As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) > 0 Then
                    ' // It's already open.
                    Throw New Exception("OpenConnection::Connection is already open.")
                End If
                m_scoDBConnection.Open()
                m_bIsTransactionPending = False
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.RollbackTransaction -Methode

[Visual Basic]
Public Function RollbackTransaction( _
   ByRef sTransactionToRollback As String _
) As Boolean

Parameter

sTransactionToRollback

Quellcode

[Visual Basic]
        Public Function RollbackTransaction(sTransactionToRollback As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("RollbackTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("RollbackTransaction::Connection is not open.")
                End If
                ' // rollback the transaction
                m_stCurrentTransaction.Rollback(sTransactionToRollback)
                ' // if this wasn't a savepoint, we've rolled back the complete transaction, so we
                ' // can clean it up.
                If Not m_alSavePoints.Contains(sTransactionToRollback) Then
                    ' // it's not a savepoint
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.SaveTransaction -Methode

[Visual Basic]
Public Function SaveTransaction( _
   ByRef sSavePointName As String _
) As Boolean

Parameter

sSavePointName

Quellcode

[Visual Basic]
        Public Function SaveTransaction(sSavePointName As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("SaveTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("SaveTransaction::Connection is not open.")
                End If
                ' // save the transaction
                m_stCurrentTransaction.Save(sSavePointName)
                ' // Store the savepoint in the list.
                m_alSavePoints.Add(sSavePointName)
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider-Felder

clsConnectionProvider Übersicht

Felder

private field m_alSavePoints

Unterstützt von .NET Compact Framework
private field m_bIsDisposed

Unterstützt von .NET Compact Framework
private field m_bIsTransactionPending

Unterstützt von .NET Compact Framework
private field m_scoDBConnection

Unterstützt von .NET Compact Framework
private field m_stCurrentTransaction

Unterstützt von .NET Compact Framework

clsConnectionProvider -Klasse


m_alSavePoints -Feld

[Visual Basic]
Private m_alSavePoints As ArrayList

Quellcode

[Visual Basic]
        Private		m_alSavePoints As ArrayList

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


m_bIsDisposed -Feld

[Visual Basic]
Private m_bIsDisposed As Boolean

Quellcode

[Visual Basic]
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


m_bIsTransactionPending -Feld

[Visual Basic]
Private m_bIsTransactionPending As Boolean

Quellcode

[Visual Basic]
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


m_scoDBConnection -Feld

[Visual Basic]
Private m_scoDBConnection As SqlConnection

Quellcode

[Visual Basic]
        Private		m_scoDBConnection As SqlConnection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


m_stCurrentTransaction -Feld

[Visual Basic]
Private m_stCurrentTransaction As SqlTransaction

Quellcode

[Visual Basic]
        Private		m_stCurrentTransaction As SqlTransaction

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsDBInteractionBase -Klasse

For a list of all members of this type, see clsDBInteractionBase-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAktivitaet
Vertragsverwaltung.TKB.VV.DB.clsAktivitaetStatus
Vertragsverwaltung.TKB.VV.DB.clsApplication
Vertragsverwaltung.TKB.VV.DB.clsApplikation
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationAls
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationFuer
Vertragsverwaltung.TKB.VV.DB.clsApplikationInstallationTyp
Vertragsverwaltung.TKB.VV.DB.clsApplikationKategorie
Vertragsverwaltung.TKB.VV.DB.clsApplikationKontakt
Vertragsverwaltung.TKB.VV.DB.clsApplikationKritikalitaetTyp
Vertragsverwaltung.TKB.VV.DB.clsApplikationLogbuch
Vertragsverwaltung.TKB.VV.DB.clsApplikationSLMTyp
Vertragsverwaltung.TKB.VV.DB.clsApplikationStandardTyp
Vertragsverwaltung.TKB.VV.DB.clsApplikationTeam
Vertragsverwaltung.TKB.VV.DB.clsApplikationTestAZ
Vertragsverwaltung.TKB.VV.DB.clsApplikationVerantwortung
Vertragsverwaltung.TKB.VV.DB.clsApplikationabhaengigkeit
Vertragsverwaltung.TKB.VV.DB.clsAuswertung
Vertragsverwaltung.TKB.VV.DB.clsAuswertungAuswertungParameter
Vertragsverwaltung.TKB.VV.DB.clsAuswertungGruppe
Vertragsverwaltung.TKB.VV.DB.clsAuswertungGruppeAuswertung
Vertragsverwaltung.TKB.VV.DB.clsAuswertungsparameter
Vertragsverwaltung.TKB.VV.DB.clsBeziehungstyp
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.DB.clsDokumentAblageTyp
Vertragsverwaltung.TKB.VV.DB.clsDokumentAblageort
Vertragsverwaltung.TKB.VV.DB.clsDokumenttyp
Vertragsverwaltung.TKB.VV.DB.clsEreignistyp
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe_rolle
Vertragsverwaltung.TKB.VV.DB.clsGremium
Vertragsverwaltung.TKB.VV.DB.clsGremiumBereich
Vertragsverwaltung.TKB.VV.DB.clsGremiumGruppierung
Vertragsverwaltung.TKB.VV.DB.clsGremiumPerson
Vertragsverwaltung.TKB.VV.DB.clsHistory
Vertragsverwaltung.TKB.VV.DB.clsHistoryTyp
Vertragsverwaltung.TKB.VV.DB.clsInstallationAlsTyp
Vertragsverwaltung.TKB.VV.DB.clsInstallationTyp
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsKontakttyp
Vertragsverwaltung.TKB.VV.DB.clsKostenart
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfristen
Vertragsverwaltung.TKB.VV.DB.clsLizenzkauf
Vertragsverwaltung.TKB.VV.DB.clsLizenzschluessel
Vertragsverwaltung.TKB.VV.DB.clsLizenztyp
Vertragsverwaltung.TKB.VV.DB.clsMandant
Vertragsverwaltung.TKB.VV.DB.clsMarktbereich
Vertragsverwaltung.TKB.VV.DB.clsMeldungstexte
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_Auswertungsparameter
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_funktionsgruppe
Vertragsverwaltung.TKB.VV.DB.clsMitarbeitereinstellung
Vertragsverwaltung.TKB.VV.DB.clsPendenz
Vertragsverwaltung.TKB.VV.DB.clsPendenzstatus
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.DB.clsPersonFunktion
Vertragsverwaltung.TKB.VV.DB.clsProfil
Vertragsverwaltung.TKB.VV.DB.clsReleaseArt
Vertragsverwaltung.TKB.VV.DB.clsRfcBoard
Vertragsverwaltung.TKB.VV.DB.clsRfcBoard_Mitarbeiter
Vertragsverwaltung.TKB.VV.DB.clsRolle
Vertragsverwaltung.TKB.VV.DB.clsRolle_SecurityObject
Vertragsverwaltung.TKB.VV.DB.clsRolle_securitylevel
Vertragsverwaltung.TKB.VV.DB.clsRolle_sysadminfunktion
Vertragsverwaltung.TKB.VV.DB.clsSLA
Vertragsverwaltung.TKB.VV.DB.clsSLAKatalog
Vertragsverwaltung.TKB.VV.DB.clsSLASubTyp
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.clsSecurityLevel
Vertragsverwaltung.TKB.VV.DB.clsSecurityObject
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog_SLAKatalog
Vertragsverwaltung.TKB.VV.DB.clsSpalten
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.DB.clsTooltip
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation
Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz
Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.DB.clsVertragstyp
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp

[Visual Basic]
Public MustInherit Class clsDBInteractionBase
    Implements ICommonDBAccess

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDBInteractionBase-Member


clsDBInteractionBase-Member

clsDBInteractionBase Übersicht

Öffentliche Konstruktoren

public constructor clsDBInteractionBase -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property cpMainConnectionProvider

Unterstützt von .NET Compact Framework
public property iErrorCode

Unterstützt von .NET Compact Framework
public property iRowsAffected

Unterstützt von .NET Compact Framework
public property sConnectionString

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete

Unterstützt von .NET Compact Framework
public method Dispose Überladen.

Unterstützt von .NET Compact Framework
public method Insert

Unterstützt von .NET Compact Framework
public method SelectAll

Unterstützt von .NET Compact Framework
public method SelectOne

Unterstützt von .NET Compact Framework
public method Update

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitClass

Unterstützt von .NET Compact Framework

Felder

private field m_bIsDisposed

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider

Unterstützt von .NET Compact Framework
protected field m_iErrorCode

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected

Unterstützt von .NET Compact Framework
private field m_sConnectionString

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection

Unterstützt von .NET Compact Framework

clsDBInteractionBase -Klasse


clsDBInteractionBase -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Initialize the class' members.
            InitClass()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase-Eigenschaften

clsDBInteractionBase Übersicht

Öffentliche Eigenschaften

public property cpMainConnectionProvider

Unterstützt von .NET Compact Framework
public property iErrorCode

Unterstützt von .NET Compact Framework
public property iRowsAffected

Unterstützt von .NET Compact Framework
public property sConnectionString

Unterstützt von .NET Compact Framework

clsDBInteractionBase -Klasse


clsDBInteractionBase-Methoden

clsDBInteractionBase Übersicht

Öffentliche Methoden

public method Delete

Unterstützt von .NET Compact Framework
public method Dispose Überladen.

Unterstützt von .NET Compact Framework
public method Insert

Unterstützt von .NET Compact Framework
public method SelectAll

Unterstützt von .NET Compact Framework
public method SelectOne

Unterstützt von .NET Compact Framework
public method Update

Unterstützt von .NET Compact Framework

Andere Methoden

private method InitClass

Unterstützt von .NET Compact Framework

clsDBInteractionBase -Klasse


clsDBInteractionBase.Delete -Methode

[Visual Basic]
Public Overridable Function Delete() As Boolean Implements  _
   ICommonDBAccess.Delete

Quellcode

[Visual Basic]
        Public Overridable Function Delete() As Boolean Implements ICommonDBAccess.Delete
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.InitClass -Methode

[Visual Basic]
Private Sub InitClass()

Quellcode

[Visual Basic]
        Private Sub InitClass()
            ' // create all the objects and initialize other members.
            m_scoMainConnection = new SqlConnection()
            m_bMainConnectionIsCreatedLocal = True
            m_cpMainConnectionProvider = Nothing
            m_iErrorCode = New SqlInt32(LLBLError.AllOk)
            m_bIsDisposed = False
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.Insert -Methode

[Visual Basic]
Public Overridable Function Insert() As Boolean Implements  _
   ICommonDBAccess.Insert

Quellcode

[Visual Basic]
        Public Overridable Function Insert() As Boolean Implements ICommonDBAccess.Insert
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.SelectAll -Methode

[Visual Basic]
Public Overridable Function SelectAll() As DataTable Implements  _
   ICommonDBAccess.SelectAll

Quellcode

[Visual Basic]
        Public Overridable Function SelectAll() As DataTable Implements ICommonDBAccess.SelectAll
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.SelectOne -Methode

[Visual Basic]
Public Overridable Function SelectOne() As DataTable Implements  _
   ICommonDBAccess.SelectOne

Quellcode

[Visual Basic]
        Public Overridable Function SelectOne() As DataTable Implements ICommonDBAccess.SelectOne
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.Update -Methode

[Visual Basic]
Public Overridable Function Update() As Boolean Implements  _
   ICommonDBAccess.Update

Quellcode

[Visual Basic]
        Public Overridable Function Update() As Boolean Implements ICommonDBAccess.Update
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase-Felder

clsDBInteractionBase Übersicht

Felder

private field m_bIsDisposed

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider

Unterstützt von .NET Compact Framework
protected field m_iErrorCode

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected

Unterstützt von .NET Compact Framework
private field m_sConnectionString

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection

Unterstützt von .NET Compact Framework

clsDBInteractionBase -Klasse


m_bIsDisposed -Feld

[Visual Basic]
Private m_bIsDisposed As Boolean

Quellcode

[Visual Basic]
        Private		m_bIsDisposed As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


m_sConnectionString -Feld

[Visual Basic]
Private m_sConnectionString As String

Quellcode

[Visual Basic]
        Private		m_sConnectionString As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDokument -Klasse

Purpose: Data Access class for the table 'Dokument'.

For a list of all members of this type, see clsDokument-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.DMS.clsDok

[Visual Basic]
Public Class clsDokument
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDokument-Member


clsDokument-Member

clsDokument Übersicht

Öffentliche Konstruktoren

public constructor clsDokument -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property blobDocImage

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daVersionsdatum

Unterstützt von .NET Compact Framework
public property iDokType

Unterstützt von .NET Compact Framework
public property iDokumentNr

Unterstützt von .NET Compact Framework
public property iDokumenttypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKeyValue

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFilename

Unterstützt von .NET Compact Framework
public property sOriginalFilename_incl_Path

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework
public property sVersionsNr

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_blobDocImage

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daVersionsdatum

Unterstützt von .NET Compact Framework
private field m_iDokType

Unterstützt von .NET Compact Framework
private field m_iDokumentNr

Unterstützt von .NET Compact Framework
private field m_iDokumenttypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKeyValue

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sFilename

Unterstützt von .NET Compact Framework
private field m_sOriginalFilename_incl_Path

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
private field m_sVersionsNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokument -Klasse


clsDokument -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument-Eigenschaften

clsDokument Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property blobDocImage

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daVersionsdatum

Unterstützt von .NET Compact Framework
public property iDokType

Unterstützt von .NET Compact Framework
public property iDokumentNr

Unterstützt von .NET Compact Framework
public property iDokumenttypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKeyValue

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFilename

Unterstützt von .NET Compact Framework
public property sOriginalFilename_incl_Path

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework
public property sVersionsNr

Unterstützt von .NET Compact Framework

clsDokument -Klasse


clsDokument.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.blobDocImage -Eigenschaft

[Visual Basic]
Public Property blobDocImage() As SqlBinary

Quellcode

[Visual Basic]
        Public Property [blobDocImage]() As SqlBinary
            Get
                Return m_blobDocImage
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobDocImage = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.daVersionsdatum -Eigenschaft

[Visual Basic]
Public Property daVersionsdatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daVersionsdatum]() As SqlDateTime
            Get
                Return m_daVersionsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVersionsdatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iDokType -Eigenschaft

[Visual Basic]
Public Property iDokType() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokType]() As SqlInt32
            Get
                Return m_iDokType
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokType = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iDokumentNr -Eigenschaft

[Visual Basic]
Public Property iDokumentNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumentNr]() As SqlInt32
            Get
                Return m_iDokumentNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentNrTmp As SqlInt32 = Value
                If iDokumentNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentNr", "iDokumentNr can't be NULL")
                End If
                m_iDokumentNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iDokumenttypNr -Eigenschaft

[Visual Basic]
Public Property iDokumenttypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumenttypNr]() As SqlInt32
            Get
                Return m_iDokumenttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iKeyValue -Eigenschaft

[Visual Basic]
Public Property iKeyValue() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKeyValue]() As SqlInt32
            Get
                Return m_iKeyValue
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKeyValue = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sFilename -Eigenschaft

[Visual Basic]
Public Property sFilename() As SqlString

Quellcode

[Visual Basic]
        Public Property [sFilename]() As SqlString
            Get
                Return m_sFilename
            End Get
            Set(ByVal Value As SqlString)
                m_sFilename = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sOriginalFilename_incl_Path -Eigenschaft

[Visual Basic]
Public Property sOriginalFilename_incl_Path() As SqlString

Quellcode

[Visual Basic]
        Public Property [sOriginalFilename_incl_Path]() As SqlString
            Get
                Return m_sOriginalFilename_incl_Path
            End Get
            Set(ByVal Value As SqlString)
                m_sOriginalFilename_incl_Path = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sVersion -Eigenschaft

[Visual Basic]
Public Property sVersion() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.sVersionsNr -Eigenschaft

[Visual Basic]
Public Property sVersionsNr() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVersionsNr]() As SqlString
            Get
                Return m_sVersionsNr
            End Get
            Set(ByVal Value As SqlString)
                m_sVersionsNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument-Methoden

clsDokument Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsDokument -Klasse


clsDokument.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentNr</LI> <LI>iKeyValue. May be SqlInt32.Null</LI> <LI>iDokType. May be SqlInt32.Null</LI> <LI>iDokumenttypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sFilename. May be SqlString.Null</LI> <LI>sOriginalFilename_incl_Path. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>sVersionsNr. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>blobDocImage. May be SqlBinary.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKeyValue", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKeyValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokType", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFilename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFilename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOriginalFilename_incl_Path", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOriginalFilename_incl_Path))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersionsNr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersionsNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                Dim	iLength As Integer = 0
                If Not m_blobDocImage.IsNull Then
                    iLength = m_blobDocImage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobDocImage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDocImage))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumentNr</LI> <LI>iKeyValue</LI> <LI>iDokType</LI> <LI>iDokumenttypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sFilename</LI> <LI>sOriginalFilename_incl_Path</LI> <LI>sVersion</LI> <LI>sVersionsNr</LI> <LI>daVersionsdatum</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> <LI>iSecurityLevelNr</LI> <LI>blobDocImage</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentNr"), Integer))
                    If dtToReturn.Rows(0)("KeyValue") Is System.DBNull.Value Then
                        m_iKeyValue = SqlInt32.Null
                    Else
                        m_iKeyValue = New SqlInt32(CType(dtToReturn.Rows(0)("KeyValue"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DokType") Is System.DBNull.Value Then
                        m_iDokType = SqlInt32.Null
                    Else
                        m_iDokType = New SqlInt32(CType(dtToReturn.Rows(0)("DokType"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DokumenttypNr") Is System.DBNull.Value Then
                        m_iDokumenttypNr = SqlInt32.Null
                    Else
                        m_iDokumenttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumenttypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Filename") Is System.DBNull.Value Then
                        m_sFilename = SqlString.Null
                    Else
                        m_sFilename = New SqlString(CType(dtToReturn.Rows(0)("Filename"), String))
                    End If
                    If dtToReturn.Rows(0)("OriginalFilename_incl_Path") Is System.DBNull.Value Then
                        m_sOriginalFilename_incl_Path = SqlString.Null
                    Else
                        m_sOriginalFilename_incl_Path = New SqlString(CType(dtToReturn.Rows(0)("OriginalFilename_incl_Path"), String))
                    End If
                    If dtToReturn.Rows(0)("Version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("Version"), String))
                    End If
                    If dtToReturn.Rows(0)("VersionsNr") Is System.DBNull.Value Then
                        m_sVersionsNr = SqlString.Null
                    Else
                        m_sVersionsNr = New SqlString(CType(dtToReturn.Rows(0)("VersionsNr"), String))
                    End If
                    If dtToReturn.Rows(0)("Versionsdatum") Is System.DBNull.Value Then
                        m_daVersionsdatum = SqlDateTime.Null
                    Else
                        m_daVersionsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Versionsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DocImage") Is System.DBNull.Value Then
                        m_blobDocImage = SqlBinary.Null
                    Else
                        m_blobDocImage = New SqlBinary(CType(dtToReturn.Rows(0)("DocImage"), Byte()))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentNr</LI> <LI>iKeyValue. May be SqlInt32.Null</LI> <LI>iDokType. May be SqlInt32.Null</LI> <LI>iDokumenttypNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sFilename. May be SqlString.Null</LI> <LI>sOriginalFilename_incl_Path. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>sVersionsNr. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>blobDocImage. May be SqlBinary.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokument_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKeyValue", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKeyValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokType", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFilename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFilename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOriginalFilename_incl_Path", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOriginalFilename_incl_Path))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersionsNr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersionsNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                Dim	iLength As Integer = 0
                If Not m_blobDocImage.IsNull Then
                    iLength = m_blobDocImage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobDocImage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDocImage))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokument-Felder

clsDokument Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_blobDocImage

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daVersionsdatum

Unterstützt von .NET Compact Framework
private field m_iDokType

Unterstützt von .NET Compact Framework
private field m_iDokumentNr

Unterstützt von .NET Compact Framework
private field m_iDokumenttypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKeyValue

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sFilename

Unterstützt von .NET Compact Framework
private field m_sOriginalFilename_incl_Path

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
private field m_sVersionsNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokument -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_blobDocImage -Feld

[Visual Basic]
Private m_blobDocImage As SqlBinary

Quellcode

[Visual Basic]
        Private 		m_blobDocImage As SqlBinary

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVersionsdatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVersionsdatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_daVersionsdatum -Feld

[Visual Basic]
Private m_daVersionsdatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVersionsdatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iDokType -Feld

[Visual Basic]
Private m_iDokType As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iDokumentNr -Feld

[Visual Basic]
Private m_iDokumentNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iDokumenttypNr -Feld

[Visual Basic]
Private m_iDokumenttypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iKeyValue -Feld

[Visual Basic]
Private m_iKeyValue As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumentNr, m_iSecurityLevelNr, m_iMutierer, m_iDokType, m_iDokumenttypNr, m_iKeyValue As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sFilename -Feld

[Visual Basic]
Private m_sFilename As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sOriginalFilename_incl_Path -Feld

[Visual Basic]
Private m_sOriginalFilename_incl_Path As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sVersion -Feld

[Visual Basic]
Private m_sVersion As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


m_sVersionsNr -Feld

[Visual Basic]
Private m_sVersionsNr As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVersion, m_sBezeichnung, m_sVersionsNr, m_sOriginalFilename_incl_Path, m_sBeschreibung, m_sFilename As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokument


clsDokumentAblageTyp -Klasse

Purpose: Data Access class for the table 'DokumentAblageTyp'.

For a list of all members of this type, see clsDokumentAblageTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokumentAblageTyp

[Visual Basic]
Public Class clsDokumentAblageTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDokumentAblageTyp-Member


clsDokumentAblageTyp-Member

clsDokumentAblageTyp Übersicht

Öffentliche Konstruktoren

public constructor clsDokumentAblageTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumentAblageTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumentAblageTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageTyp -Klasse


clsDokumentAblageTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp-Eigenschaften

clsDokumentAblageTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumentAblageTypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageTyp -Klasse


clsDokumentAblageTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.iDokumentAblageTypNr -Eigenschaft

[Visual Basic]
Public Property iDokumentAblageTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumentAblageTypNr]() As SqlInt32
            Get
                Return m_iDokumentAblageTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentAblageTypNrTmp As SqlInt32 = Value
                If iDokumentAblageTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentAblageTypNr", "iDokumentAblageTypNr can't be NULL")
                End If
                m_iDokumentAblageTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp-Methoden

clsDokumentAblageTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsDokumentAblageTyp -Klasse


clsDokumentAblageTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentAblageTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentAblageTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentAblageTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentAblageTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentAblageTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentAblageTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("DokumentAblageTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentAblageTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumentAblageTypNr</LI> <LI>sBezeichnung</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("DokumentAblageTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumentAblageTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentAblageTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentAblageTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentAblageTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentAblageTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentAblageTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentAblageTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageTyp-Felder

clsDokumentAblageTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumentAblageTypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_iDokumentAblageTypNr -Feld

[Visual Basic]
Private m_iDokumentAblageTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iDokumentAblageTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iDokumentAblageTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iDokumentAblageTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageTyp


clsDokumentAblageort -Klasse

Purpose: Data Access class for the table 'DokumentAblageort'.

For a list of all members of this type, see clsDokumentAblageort-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokumentAblageort

[Visual Basic]
Public Class clsDokumentAblageort
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDokumentAblageort-Member


clsDokumentAblageort-Member

clsDokumentAblageort Übersicht

Öffentliche Konstruktoren

public constructor clsDokumentAblageort -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumentNr

Unterstützt von .NET Compact Framework
public property iDokumentablageortNr

Unterstützt von .NET Compact Framework
public property iDokumentablagetypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sAblageort

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumentNr

Unterstützt von .NET Compact Framework
private field m_iDokumentablageortNr

Unterstützt von .NET Compact Framework
private field m_iDokumentablagetypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sAblageort

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageort -Klasse


clsDokumentAblageort -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort-Eigenschaften

clsDokumentAblageort Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumentNr

Unterstützt von .NET Compact Framework
public property iDokumentablageortNr

Unterstützt von .NET Compact Framework
public property iDokumentablagetypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sAblageort

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageort -Klasse


clsDokumentAblageort.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.iDokumentNr -Eigenschaft

[Visual Basic]
Public Property iDokumentNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumentNr]() As SqlInt32
            Get
                Return m_iDokumentNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.iDokumentablageortNr -Eigenschaft

[Visual Basic]
Public Property iDokumentablageortNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumentablageortNr]() As SqlInt32
            Get
                Return m_iDokumentablageortNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentablageortNrTmp As SqlInt32 = Value
                If iDokumentablageortNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentablageortNr", "iDokumentablageortNr can't be NULL")
                End If
                m_iDokumentablageortNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.iDokumentablagetypNr -Eigenschaft

[Visual Basic]
Public Property iDokumentablagetypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumentablagetypNr]() As SqlInt32
            Get
                Return m_iDokumentablagetypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentablagetypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.sAblageort -Eigenschaft

[Visual Basic]
Public Property sAblageort() As SqlString

Quellcode

[Visual Basic]
        Public Property [sAblageort]() As SqlString
            Get
                Return m_sAblageort
            End Get
            Set(ByVal Value As SqlString)
                m_sAblageort = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort-Methoden

clsDokumentAblageort Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsDokumentAblageort -Klasse


clsDokumentAblageort.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentablageortNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageort_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentablageortNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablageortNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageort_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageort::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentablageortNr</LI> <LI>iDokumentablagetypNr. May be SqlInt32.Null</LI> <LI>iDokumentNr. May be SqlInt32.Null</LI> <LI>sAblageort. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageort_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentablageortNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablageortNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentablagetypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablagetypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAblageort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAblageort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageort_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageort::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageort_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("DokumentAblageort")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageort_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageort::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentablageortNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumentablageortNr</LI> <LI>iDokumentablagetypNr</LI> <LI>iDokumentNr</LI> <LI>sAblageort</LI> <LI>sBeschreibung</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageort_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("DokumentAblageort")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumentablageortNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablageortNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageort_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentablageortNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentablageortNr"), Integer))
                    If dtToReturn.Rows(0)("DokumentablagetypNr") Is System.DBNull.Value Then
                        m_iDokumentablagetypNr = SqlInt32.Null
                    Else
                        m_iDokumentablagetypNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentablagetypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("DokumentNr") Is System.DBNull.Value Then
                        m_iDokumentNr = SqlInt32.Null
                    Else
                        m_iDokumentNr = New SqlInt32(CType(dtToReturn.Rows(0)("DokumentNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Ablageort") Is System.DBNull.Value Then
                        m_sAblageort = SqlString.Null
                    Else
                        m_sAblageort = New SqlString(CType(dtToReturn.Rows(0)("Ablageort"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageort::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumentablageortNr</LI> <LI>iDokumentablagetypNr. May be SqlInt32.Null</LI> <LI>iDokumentNr. May be SqlInt32.Null</LI> <LI>sAblageort. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_DokumentAblageort_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentablageortNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablageortNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentablagetypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentablagetypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAblageort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAblageort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_DokumentAblageort_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentAblageort::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumentAblageort-Felder

clsDokumentAblageort Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumentNr

Unterstützt von .NET Compact Framework
private field m_iDokumentablageortNr

Unterstützt von .NET Compact Framework
private field m_iDokumentablagetypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sAblageort

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumentAblageort -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_iDokumentNr -Feld

[Visual Basic]
Private m_iDokumentNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iDokumentablageortNr, m_iDokumentNr, m_iDokumentablagetypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_iDokumentablageortNr -Feld

[Visual Basic]
Private m_iDokumentablageortNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iDokumentablageortNr, m_iDokumentNr, m_iDokumentablagetypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_iDokumentablagetypNr -Feld

[Visual Basic]
Private m_iDokumentablagetypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iDokumentablageortNr, m_iDokumentNr, m_iDokumentablagetypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iDokumentablageortNr, m_iDokumentNr, m_iDokumentablagetypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iDokumentablageortNr, m_iDokumentNr, m_iDokumentablagetypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_sAblageort -Feld

[Visual Basic]
Private m_sAblageort As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sAblageort As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sAblageort As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumentAblageort


clsDokumenttyp -Klasse

Purpose: Data Access class for the table 'Dokumenttyp'.

For a list of all members of this type, see clsDokumenttyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokumenttyp

[Visual Basic]
Public Class clsDokumenttyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDokumenttyp-Member


clsDokumenttyp-Member

clsDokumenttyp Übersicht

Öffentliche Konstruktoren

public constructor clsDokumenttyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumenttypnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumenttypnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumenttyp -Klasse


clsDokumenttyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp-Eigenschaften

clsDokumenttyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iDokumenttypnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumenttyp -Klasse


clsDokumenttyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.iDokumenttypnr -Eigenschaft

[Visual Basic]
Public Property iDokumenttypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumenttypnrTmp As SqlInt32 = Value
                If iDokumenttypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumenttypnr", "iDokumenttypnr can't be NULL")
                End If
                m_iDokumenttypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp-Methoden

clsDokumenttyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsDokumenttyp -Klasse


clsDokumenttyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iDokumenttypnr</LI> <LI>sBezeichnung</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Dokumenttypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iDokumenttypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumenttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsDokumenttyp-Felder

clsDokumenttyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iDokumenttypnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDokumenttyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


m_iDokumenttypnr -Feld

[Visual Basic]
Private m_iDokumenttypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDokumenttyp


clsEreignistyp -Klasse

Purpose: Data Access class for the table 'Ereignistyp'.

For a list of all members of this type, see clsEreignistyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsEreignistyp

[Visual Basic]
Public Class clsEreignistyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsEreignistyp-Member


clsEreignistyp-Member

clsEreignistyp Übersicht

Öffentliche Konstruktoren

public constructor clsEreignistyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAktivitaeten_generieren

Unterstützt von .NET Compact Framework
public property bKuendigung

Unterstützt von .NET Compact Framework
public property bZahlung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iEreignistypnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAktivitaeten_generieren

Unterstützt von .NET Compact Framework
private field m_bKuendigung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bZahlung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iEreignistypnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsEreignistyp -Klasse


clsEreignistyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp-Eigenschaften

clsEreignistyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAktivitaeten_generieren

Unterstützt von .NET Compact Framework
public property bKuendigung

Unterstützt von .NET Compact Framework
public property bZahlung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iEreignistypnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsEreignistyp -Klasse


clsEreignistyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.bAktivitaeten_generieren -Eigenschaft

[Visual Basic]
Public Property bAktivitaeten_generieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktivitaeten_generieren]() As SqlBoolean
            Get
                Return m_bAktivitaeten_generieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktivitaeten_generieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.bKuendigung -Eigenschaft

[Visual Basic]
Public Property bKuendigung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bKuendigung]() As SqlBoolean
            Get
                Return m_bKuendigung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bKuendigung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.bZahlung -Eigenschaft

[Visual Basic]
Public Property bZahlung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bZahlung]() As SqlBoolean
            Get
                Return m_bZahlung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZahlung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.iEreignistypnr -Eigenschaft

[Visual Basic]
Public Property iEreignistypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEreignistypnr]() As SqlInt32
            Get
                Return m_iEreignistypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEreignistypnrTmp As SqlInt32 = Value
                If iEreignistypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEreignistypnr", "iEreignistypnr can't be NULL")
                End If
                m_iEreignistypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp-Methoden

clsEreignistyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsEreignistyp -Klasse


clsEreignistyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Ereignistyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignistypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Ereignistyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEreignistyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktivitaeten_generieren. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bKuendigung. May be SqlBoolean.Null</LI> <LI>bZahlung. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Ereignistyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignistypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaeten_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaeten_generieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bKuendigung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bKuendigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bZahlung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bZahlung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Ereignistyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEreignistyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Ereignistyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Ereignistyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Ereignistyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEreignistyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iEreignistypnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktivitaeten_generieren</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>bKuendigung</LI> <LI>bZahlung</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Ereignistyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Ereignistyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignistypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Ereignistyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEreignistypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Ereignistypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktivitaeten_generieren") Is System.DBNull.Value Then
                        m_bAktivitaeten_generieren = SqlBoolean.Null
                    Else
                        m_bAktivitaeten_generieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktivitaeten_generieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Kuendigung") Is System.DBNull.Value Then
                        m_bKuendigung = SqlBoolean.Null
                    Else
                        m_bKuendigung = New SqlBoolean(CType(dtToReturn.Rows(0)("Kuendigung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Zahlung") Is System.DBNull.Value Then
                        m_bZahlung = SqlBoolean.Null
                    Else
                        m_bZahlung = New SqlBoolean(CType(dtToReturn.Rows(0)("Zahlung"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEreignistyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktivitaeten_generieren. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bKuendigung. May be SqlBoolean.Null</LI> <LI>bZahlung. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Ereignistyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignistypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaeten_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaeten_generieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bKuendigung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bKuendigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bZahlung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bZahlung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Ereignistyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEreignistyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsEreignistyp-Felder

clsEreignistyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAktivitaeten_generieren

Unterstützt von .NET Compact Framework
private field m_bKuendigung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bZahlung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iEreignistypnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsEreignistyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaeten_generieren, m_bZahlung, m_bKuendigung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_bAktivitaeten_generieren -Feld

[Visual Basic]
Private m_bAktivitaeten_generieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaeten_generieren, m_bZahlung, m_bKuendigung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_bKuendigung -Feld

[Visual Basic]
Private m_bKuendigung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaeten_generieren, m_bZahlung, m_bKuendigung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_bZahlung -Feld

[Visual Basic]
Private m_bZahlung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bAktivitaeten_generieren, m_bZahlung, m_bKuendigung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_iEreignistypnr -Feld

[Visual Basic]
Private m_iEreignistypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iEreignistypnr, m_iMutierer, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iEreignistypnr, m_iMutierer, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iEreignistypnr, m_iMutierer, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsEreignistyp


clsFunktionsgruppe -Klasse

Purpose: Data Access class for the table 'funktionsgruppe'.

For a list of all members of this type, see clsFunktionsgruppe-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe

[Visual Basic]
Public Class clsFunktionsgruppe
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsFunktionsgruppe-Member


clsFunktionsgruppe-Member

clsFunktionsgruppe Übersicht

Öffentliche Konstruktoren

public constructor clsFunktionsgruppe -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bBarcodeetiketten

Unterstützt von .NET Compact Framework
public property bBlv

Unterstützt von .NET Compact Framework
public property bDokumentreaktivierung

Unterstützt von .NET Compact Framework
public property bEdokapartner

Unterstützt von .NET Compact Framework
public property bFunktionszuweisung

Unterstützt von .NET Compact Framework
public property bPartnerzusammenlegung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sZugehoerigkeit

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bBarcodeetiketten

Unterstützt von .NET Compact Framework
private field m_bBlv

Unterstützt von .NET Compact Framework
private field m_bDokumentreaktivierung

Unterstützt von .NET Compact Framework
private field m_bEdokapartner

Unterstützt von .NET Compact Framework
private field m_bFunktionszuweisung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPartnerzusammenlegung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sZugehoerigkeit

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsFunktionsgruppe -Klasse


clsFunktionsgruppe -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe-Eigenschaften

clsFunktionsgruppe Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bBarcodeetiketten

Unterstützt von .NET Compact Framework
public property bBlv

Unterstützt von .NET Compact Framework
public property bDokumentreaktivierung

Unterstützt von .NET Compact Framework
public property bEdokapartner

Unterstützt von .NET Compact Framework
public property bFunktionszuweisung

Unterstützt von .NET Compact Framework
public property bPartnerzusammenlegung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sZugehoerigkeit

Unterstützt von .NET Compact Framework

clsFunktionsgruppe -Klasse


clsFunktionsgruppe.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bBarcodeetiketten -Eigenschaft

[Visual Basic]
Public Property bBarcodeetiketten() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bBarcodeetiketten]() As SqlBoolean
            Get
                Return m_bBarcodeetiketten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBarcodeetiketten = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bBlv -Eigenschaft

[Visual Basic]
Public Property bBlv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bBlv]() As SqlBoolean
            Get
                Return m_bBlv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBlv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bDokumentreaktivierung -Eigenschaft

[Visual Basic]
Public Property bDokumentreaktivierung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bDokumentreaktivierung]() As SqlBoolean
            Get
                Return m_bDokumentreaktivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokumentreaktivierung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bEdokapartner -Eigenschaft

[Visual Basic]
Public Property bEdokapartner() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bEdokapartner]() As SqlBoolean
            Get
                Return m_bEdokapartner
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEdokapartner = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bFunktionszuweisung -Eigenschaft

[Visual Basic]
Public Property bFunktionszuweisung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bFunktionszuweisung]() As SqlBoolean
            Get
                Return m_bFunktionszuweisung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFunktionszuweisung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.bPartnerzusammenlegung -Eigenschaft

[Visual Basic]
Public Property bPartnerzusammenlegung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bPartnerzusammenlegung]() As SqlBoolean
            Get
                Return m_bPartnerzusammenlegung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bPartnerzusammenlegung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.iFunktionsgruppenr -Eigenschaft

[Visual Basic]
Public Property iFunktionsgruppenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgruppenrTmp As SqlInt32 = Value
                If iFunktionsgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgruppenr", "iFunktionsgruppenr can't be NULL")
                End If
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.sZugehoerigkeit -Eigenschaft

[Visual Basic]
Public Property sZugehoerigkeit() As SqlString

Quellcode

[Visual Basic]
        Public Property [sZugehoerigkeit]() As SqlString
            Get
                Return m_sZugehoerigkeit
            End Get
            Set(ByVal Value As SqlString)
                m_sZugehoerigkeit = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe-Methoden

clsFunktionsgruppe Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsFunktionsgruppe -Klasse


clsFunktionsgruppe.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sZugehoerigkeit. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bFunktionszuweisung. May be SqlBoolean.Null</LI> <LI>bBarcodeetiketten. May be SqlBoolean.Null</LI> <LI>bEdokapartner. May be SqlBoolean.Null</LI> <LI>bDokumentreaktivierung. May be SqlBoolean.Null</LI> <LI>bPartnerzusammenlegung. May be SqlBoolean.Null</LI> <LI>bBlv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szugehoerigkeit", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZugehoerigkeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionszuweisung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionszuweisung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbarcodeetiketten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBarcodeetiketten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedokapartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokapartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokumentreaktivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokumentreaktivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPartnerzusammenlegung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bPartnerzusammenlegung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bblv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBlv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sZugehoerigkeit</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bFunktionszuweisung</LI> <LI>bBarcodeetiketten</LI> <LI>bEdokapartner</LI> <LI>bDokumentreaktivierung</LI> <LI>bPartnerzusammenlegung</LI> <LI>bBlv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("zugehoerigkeit") Is System.DBNull.Value Then
                        m_sZugehoerigkeit = SqlString.Null
                    Else
                        m_sZugehoerigkeit = New SqlString(CType(dtToReturn.Rows(0)("zugehoerigkeit"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionszuweisung") Is System.DBNull.Value Then
                        m_bFunktionszuweisung = SqlBoolean.Null
                    Else
                        m_bFunktionszuweisung = New SqlBoolean(CType(dtToReturn.Rows(0)("funktionszuweisung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("barcodeetiketten") Is System.DBNull.Value Then
                        m_bBarcodeetiketten = SqlBoolean.Null
                    Else
                        m_bBarcodeetiketten = New SqlBoolean(CType(dtToReturn.Rows(0)("barcodeetiketten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("edokapartner") Is System.DBNull.Value Then
                        m_bEdokapartner = SqlBoolean.Null
                    Else
                        m_bEdokapartner = New SqlBoolean(CType(dtToReturn.Rows(0)("edokapartner"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Dokumentreaktivierung") Is System.DBNull.Value Then
                        m_bDokumentreaktivierung = SqlBoolean.Null
                    Else
                        m_bDokumentreaktivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokumentreaktivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Partnerzusammenlegung") Is System.DBNull.Value Then
                        m_bPartnerzusammenlegung = SqlBoolean.Null
                    Else
                        m_bPartnerzusammenlegung = New SqlBoolean(CType(dtToReturn.Rows(0)("Partnerzusammenlegung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("blv") Is System.DBNull.Value Then
                        m_bBlv = SqlBoolean.Null
                    Else
                        m_bBlv = New SqlBoolean(CType(dtToReturn.Rows(0)("blv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgruppenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sZugehoerigkeit. May be SqlString.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bFunktionszuweisung. May be SqlBoolean.Null</LI> <LI>bBarcodeetiketten. May be SqlBoolean.Null</LI> <LI>bEdokapartner. May be SqlBoolean.Null</LI> <LI>bDokumentreaktivierung. May be SqlBoolean.Null</LI> <LI>bPartnerzusammenlegung. May be SqlBoolean.Null</LI> <LI>bBlv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szugehoerigkeit", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZugehoerigkeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionszuweisung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionszuweisung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbarcodeetiketten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBarcodeetiketten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedokapartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokapartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokumentreaktivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokumentreaktivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPartnerzusammenlegung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bPartnerzusammenlegung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bblv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBlv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe-Felder

clsFunktionsgruppe Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bBarcodeetiketten

Unterstützt von .NET Compact Framework
private field m_bBlv

Unterstützt von .NET Compact Framework
private field m_bDokumentreaktivierung

Unterstützt von .NET Compact Framework
private field m_bEdokapartner

Unterstützt von .NET Compact Framework
private field m_bFunktionszuweisung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPartnerzusammenlegung

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sZugehoerigkeit

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsFunktionsgruppe -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bBarcodeetiketten -Feld

[Visual Basic]
Private m_bBarcodeetiketten As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bBlv -Feld

[Visual Basic]
Private m_bBlv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bDokumentreaktivierung -Feld

[Visual Basic]
Private m_bDokumentreaktivierung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bEdokapartner -Feld

[Visual Basic]
Private m_bEdokapartner As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bFunktionszuweisung -Feld

[Visual Basic]
Private m_bFunktionszuweisung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_bPartnerzusammenlegung -Feld

[Visual Basic]
Private m_bPartnerzusammenlegung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bBarcodeetiketten, m_bAktiv, m_bFunktionszuweisung, m_bEdokapartner, m_bBlv, m_bPartnerzusammenlegung, m_bDokumentreaktivierung As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_iFunktionsgruppenr -Feld

[Visual Basic]
Private m_iFunktionsgruppenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFunktionsgruppenr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


m_sZugehoerigkeit -Feld

[Visual Basic]
Private m_sZugehoerigkeit As SqlString

Quellcode

[Visual Basic]
        Private 		m_sZugehoerigkeit, m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe


clsFunktionsgruppe_rolle -Klasse

Purpose: Data Access class for the table 'funktionsgruppe_rolle'.

For a list of all members of this type, see clsFunktionsgruppe_rolle-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsFunktionsgruppe_rolle

[Visual Basic]
Public Class clsFunktionsgruppe_rolle
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsFunktionsgruppe_rolle-Member


clsFunktionsgruppe_rolle-Member

clsFunktionsgruppe_rolle Übersicht

Öffentliche Konstruktoren

public constructor clsFunktionsgruppe_rolle -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iFunktionsgrupperollenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iFunktionsgrupperollenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsFunktionsgruppe_rolle -Klasse


clsFunktionsgruppe_rolle -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle-Eigenschaften

clsFunktionsgruppe_rolle Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iFunktionsgrupperollenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsFunktionsgruppe_rolle -Klasse


clsFunktionsgruppe_rolle.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iFunktionsgruppenr -Eigenschaft

[Visual Basic]
Public Property iFunktionsgruppenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iFunktionsgrupperollenr -Eigenschaft

[Visual Basic]
Public Property iFunktionsgrupperollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFunktionsgrupperollenr]() As SqlInt32
            Get
                Return m_iFunktionsgrupperollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgrupperollenrTmp As SqlInt32 = Value
                If iFunktionsgrupperollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgrupperollenr", "iFunktionsgrupperollenr can't be NULL")
                End If
                m_iFunktionsgrupperollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iRollenr -Eigenschaft

[Visual Basic]
Public Property iRollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle-Methoden

clsFunktionsgruppe_rolle Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsFunktionsgruppe_rolle -Klasse


clsFunktionsgruppe_rolle.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr</LI> <LI>iRollenr</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgrupperollenr = New SqlInt32(CType(dtToReturn.Rows(0)("Funktionsgrupperollenr"), Integer))
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iFunktionsgrupperollenr</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle-Felder

clsFunktionsgruppe_rolle Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iFunktionsgrupperollenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsFunktionsgruppe_rolle -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_iFunktionsgruppenr -Feld

[Visual Basic]
Private m_iFunktionsgruppenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_iFunktionsgrupperollenr -Feld

[Visual Basic]
Private m_iFunktionsgrupperollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


m_iRollenr -Feld

[Visual Basic]
Private m_iRollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsFunktionsgruppe_rolle


clsGremium -Klasse

Purpose: Data Access class for the table 'Gremium'.

For a list of all members of this type, see clsGremium-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsGremium

[Visual Basic]
Public Class clsGremium
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsGremium-Member


clsGremium-Member

clsGremium Übersicht

Öffentliche Konstruktoren

public constructor clsGremium -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bRFC_Board

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bRFC_Board

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremium -Klasse


clsGremium -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium-Eigenschaften

clsGremium Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bRFC_Board

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremium -Klasse


clsGremium.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.bRFC_Board -Eigenschaft

[Visual Basic]
Public Property bRFC_Board() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bRFC_Board]() As SqlBoolean
            Get
                Return m_bRFC_Board
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bRFC_Board = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.iGremiumNr -Eigenschaft

[Visual Basic]
Public Property iGremiumNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumNr]() As SqlInt32
            Get
                Return m_iGremiumNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iGremiumNrTmp As SqlInt32 = Value
                If iGremiumNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iGremiumNr", "iGremiumNr can't be NULL")
                End If
                m_iGremiumNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium-Methoden

clsGremium Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsGremium -Klasse


clsGremium.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Gremium_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Gremium_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremium::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bRFC_Board. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Gremium_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bRFC_Board", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bRFC_Board))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Gremium_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremium::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Gremium_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Gremium")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Gremium_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremium::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iGremiumNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bRFC_Board</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Gremium_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Gremium")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Gremium_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iGremiumNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("RFC_Board") Is System.DBNull.Value Then
                        m_bRFC_Board = SqlBoolean.Null
                    Else
                        m_bRFC_Board = New SqlBoolean(CType(dtToReturn.Rows(0)("RFC_Board"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremium::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bRFC_Board. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Gremium_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bRFC_Board", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bRFC_Board))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Gremium_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremium::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremium-Felder

clsGremium Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bRFC_Board

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremium -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bRFC_Board As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_bRFC_Board -Feld

[Visual Basic]
Private m_bRFC_Board As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bRFC_Board As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_iGremiumNr -Feld

[Visual Basic]
Private m_iGremiumNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iGremiumNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iGremiumNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremium


clsGremiumBereich -Klasse

Purpose: Data Access class for the table 'GremiumBereich'.

For a list of all members of this type, see clsGremiumBereich-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsGremiumBereich

[Visual Basic]
Public Class clsGremiumBereich
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsGremiumBereich-Member


clsGremiumBereich-Member

clsGremiumBereich Übersicht

Öffentliche Konstruktoren

public constructor clsGremiumBereich -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumBereichNr

Unterstützt von .NET Compact Framework
public property iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSortierung

Unterstützt von .NET Compact Framework
public property sBereich

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumBereichNr

Unterstützt von .NET Compact Framework
private field m_iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSortierung

Unterstützt von .NET Compact Framework
private field m_sBereich

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumBereich -Klasse


clsGremiumBereich -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich-Eigenschaften

clsGremiumBereich Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumBereichNr

Unterstützt von .NET Compact Framework
public property iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSortierung

Unterstützt von .NET Compact Framework
public property sBereich

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumBereich -Klasse


clsGremiumBereich.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.iGremiumBereichNr -Eigenschaft

[Visual Basic]
Public Property iGremiumBereichNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumBereichNr]() As SqlInt32
            Get
                Return m_iGremiumBereichNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iGremiumBereichNrTmp As SqlInt32 = Value
                If iGremiumBereichNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iGremiumBereichNr", "iGremiumBereichNr can't be NULL")
                End If
                m_iGremiumBereichNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.iGremiumGruppierungNr -Eigenschaft

[Visual Basic]
Public Property iGremiumGruppierungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumGruppierungNr]() As SqlInt32
            Get
                Return m_iGremiumGruppierungNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGremiumGruppierungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.iSortierung -Eigenschaft

[Visual Basic]
Public Property iSortierung() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSortierung]() As SqlInt32
            Get
                Return m_iSortierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSortierung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.sBereich -Eigenschaft

[Visual Basic]
Public Property sBereich() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBereich]() As SqlString
            Get
                Return m_sBereich
            End Get
            Set(ByVal Value As SqlString)
                m_sBereich = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich-Methoden

clsGremiumBereich Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsGremiumBereich -Klasse


clsGremiumBereich.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumBereichNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumBereich_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumBereich_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumBereich::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumBereichNr</LI> <LI>iGremiumGruppierungNr. May be SqlInt32.Null</LI> <LI>sBereich. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iSortierung. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumBereich_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBereich", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBereich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSortierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSortierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumBereich_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumBereich::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumBereich_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumBereich")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumBereich_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumBereich::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumBereichNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iGremiumBereichNr</LI> <LI>iGremiumGruppierungNr</LI> <LI>sBereich</LI> <LI>sBeschreibung</LI> <LI>iSortierung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumBereich_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumBereich")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumBereich_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iGremiumBereichNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumBereichNr"), Integer))
                    If dtToReturn.Rows(0)("GremiumGruppierungNr") Is System.DBNull.Value Then
                        m_iGremiumGruppierungNr = SqlInt32.Null
                    Else
                        m_iGremiumGruppierungNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumGruppierungNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bereich") Is System.DBNull.Value Then
                        m_sBereich = SqlString.Null
                    Else
                        m_sBereich = New SqlString(CType(dtToReturn.Rows(0)("Bereich"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Sortierung") Is System.DBNull.Value Then
                        m_iSortierung = SqlInt32.Null
                    Else
                        m_iSortierung = New SqlInt32(CType(dtToReturn.Rows(0)("Sortierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumBereich::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumBereichNr</LI> <LI>iGremiumGruppierungNr. May be SqlInt32.Null</LI> <LI>sBereich. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iSortierung. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumBereich_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBereich", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBereich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSortierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSortierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumBereich_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumBereich::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumBereich-Felder

clsGremiumBereich Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumBereichNr

Unterstützt von .NET Compact Framework
private field m_iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSortierung

Unterstützt von .NET Compact Framework
private field m_sBereich

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumBereich -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_iGremiumBereichNr -Feld

[Visual Basic]
Private m_iGremiumBereichNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSortierung, m_iGremiumGruppierungNr, m_iGremiumBereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_iGremiumGruppierungNr -Feld

[Visual Basic]
Private m_iGremiumGruppierungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSortierung, m_iGremiumGruppierungNr, m_iGremiumBereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSortierung, m_iGremiumGruppierungNr, m_iGremiumBereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_iSortierung -Feld

[Visual Basic]
Private m_iSortierung As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSortierung, m_iGremiumGruppierungNr, m_iGremiumBereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_sBereich -Feld

[Visual Basic]
Private m_sBereich As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBereich As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBereich As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumBereich


clsGremiumGruppierung -Klasse

Purpose: Data Access class for the table 'GremiumGruppierung'.

For a list of all members of this type, see clsGremiumGruppierung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsGremiumGruppierung

[Visual Basic]
Public Class clsGremiumGruppierung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsGremiumGruppierung-Member


clsGremiumGruppierung-Member

clsGremiumGruppierung Übersicht

Öffentliche Konstruktoren

public constructor clsGremiumGruppierung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
public property iGremiumNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sGruppierungsbegriff

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
private field m_iGremiumNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sGruppierungsbegriff

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumGruppierung -Klasse


clsGremiumGruppierung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung-Eigenschaften

clsGremiumGruppierung Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
public property iGremiumNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sGruppierungsbegriff

Unterstützt von .NET Compact Framework

clsGremiumGruppierung -Klasse


clsGremiumGruppierung.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.iGremiumGruppierungNr -Eigenschaft

[Visual Basic]
Public Property iGremiumGruppierungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumGruppierungNr]() As SqlInt32
            Get
                Return m_iGremiumGruppierungNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iGremiumGruppierungNrTmp As SqlInt32 = Value
                If iGremiumGruppierungNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iGremiumGruppierungNr", "iGremiumGruppierungNr can't be NULL")
                End If
                m_iGremiumGruppierungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.iGremiumNr -Eigenschaft

[Visual Basic]
Public Property iGremiumNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumNr]() As SqlInt32
            Get
                Return m_iGremiumNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGremiumNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.iReihenfolge -Eigenschaft

[Visual Basic]
Public Property iReihenfolge() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.sGruppierungsbegriff -Eigenschaft

[Visual Basic]
Public Property sGruppierungsbegriff() As SqlString

Quellcode

[Visual Basic]
        Public Property [sGruppierungsbegriff]() As SqlString
            Get
                Return m_sGruppierungsbegriff
            End Get
            Set(ByVal Value As SqlString)
                m_sGruppierungsbegriff = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung-Methoden

clsGremiumGruppierung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsGremiumGruppierung -Klasse


clsGremiumGruppierung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumGruppierungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumGruppierung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumGruppierung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumGruppierung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumGruppierungNr</LI> <LI>iGremiumNr. May be SqlInt32.Null</LI> <LI>sGruppierungsbegriff. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumGruppierung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sGruppierungsbegriff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sGruppierungsbegriff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumGruppierung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumGruppierung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumGruppierung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumGruppierung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumGruppierung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumGruppierung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumGruppierungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iGremiumGruppierungNr</LI> <LI>iGremiumNr</LI> <LI>sGruppierungsbegriff</LI> <LI>sBeschreibung</LI> <LI>iReihenfolge</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumGruppierung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumGruppierung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumGruppierung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iGremiumGruppierungNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumGruppierungNr"), Integer))
                    If dtToReturn.Rows(0)("GremiumNr") Is System.DBNull.Value Then
                        m_iGremiumNr = SqlInt32.Null
                    Else
                        m_iGremiumNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Gruppierungsbegriff") Is System.DBNull.Value Then
                        m_sGruppierungsbegriff = SqlString.Null
                    Else
                        m_sGruppierungsbegriff = New SqlString(CType(dtToReturn.Rows(0)("Gruppierungsbegriff"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumGruppierung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGremiumGruppierungNr</LI> <LI>iGremiumNr. May be SqlInt32.Null</LI> <LI>sGruppierungsbegriff. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumGruppierung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumGruppierungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGremiumGruppierungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sGruppierungsbegriff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sGruppierungsbegriff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumGruppierung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumGruppierung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumGruppierung-Felder

clsGremiumGruppierung Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGremiumGruppierungNr

Unterstützt von .NET Compact Framework
private field m_iGremiumNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sGruppierungsbegriff

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumGruppierung -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_iGremiumGruppierungNr -Feld

[Visual Basic]
Private m_iGremiumGruppierungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iGremiumNr, m_iGremiumGruppierungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_iGremiumNr -Feld

[Visual Basic]
Private m_iGremiumNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iGremiumNr, m_iGremiumGruppierungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iGremiumNr, m_iGremiumGruppierungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_iReihenfolge -Feld

[Visual Basic]
Private m_iReihenfolge As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReihenfolge, m_iGremiumNr, m_iGremiumGruppierungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sGruppierungsbegriff As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


m_sGruppierungsbegriff -Feld

[Visual Basic]
Private m_sGruppierungsbegriff As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sGruppierungsbegriff As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumGruppierung


clsGremiumPerson -Klasse

Purpose: Data Access class for the table 'GremiumPerson'.

For a list of all members of this type, see clsGremiumPerson-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsGremiumPerson

[Visual Basic]
Public Class clsGremiumPerson
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsGremiumPerson-Member


clsGremiumPerson-Member

clsGremiumPerson Übersicht

Öffentliche Konstruktoren

public constructor clsGremiumPerson -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bLeitung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGreminPersonNr

Unterstützt von .NET Compact Framework
public property iGremiumBereichNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRolleNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bLeitung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGreminPersonNr

Unterstützt von .NET Compact Framework
private field m_iGremiumBereichNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
private field m_iRolleNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumPerson -Klasse


clsGremiumPerson -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson-Eigenschaften

clsGremiumPerson Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bLeitung

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iGreminPersonNr

Unterstützt von .NET Compact Framework
public property iGremiumBereichNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRolleNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumPerson -Klasse


clsGremiumPerson.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.bLeitung -Eigenschaft

[Visual Basic]
Public Property bLeitung() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bLeitung]() As SqlBoolean
            Get
                Return m_bLeitung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bLeitung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.iGreminPersonNr -Eigenschaft

[Visual Basic]
Public Property iGreminPersonNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGreminPersonNr]() As SqlInt32
            Get
                Return m_iGreminPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iGreminPersonNrTmp As SqlInt32 = Value
                If iGreminPersonNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iGreminPersonNr", "iGreminPersonNr can't be NULL")
                End If
                m_iGreminPersonNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.iGremiumBereichNr -Eigenschaft

[Visual Basic]
Public Property iGremiumBereichNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iGremiumBereichNr]() As SqlInt32
            Get
                Return m_iGremiumBereichNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGremiumBereichNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.iPersonNr -Eigenschaft

[Visual Basic]
Public Property iPersonNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.iRolleNr -Eigenschaft

[Visual Basic]
Public Property iRolleNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRolleNr]() As SqlInt32
            Get
                Return m_iRolleNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRolleNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson-Methoden

clsGremiumPerson Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsGremiumPerson -Klasse


clsGremiumPerson.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGreminPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumPerson_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGreminPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGreminPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumPerson_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumPerson::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGreminPersonNr</LI> <LI>iGremiumBereichNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>bLeitung. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iRolleNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumPerson_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGreminPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGreminPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bLeitung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bLeitung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRolleNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRolleNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumPerson_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumPerson::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumPerson_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumPerson")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumPerson_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumPerson::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGreminPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iGreminPersonNr</LI> <LI>iGremiumBereichNr</LI> <LI>iPersonNr</LI> <LI>bLeitung</LI> <LI>bAktiv</LI> <LI>iRolleNr</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sBeschreibung</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumPerson_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("GremiumPerson")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iGreminPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGreminPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumPerson_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iGreminPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("GreminPersonNr"), Integer))
                    If dtToReturn.Rows(0)("GremiumBereichNr") Is System.DBNull.Value Then
                        m_iGremiumBereichNr = SqlInt32.Null
                    Else
                        m_iGremiumBereichNr = New SqlInt32(CType(dtToReturn.Rows(0)("GremiumBereichNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PersonNr") Is System.DBNull.Value Then
                        m_iPersonNr = SqlInt32.Null
                    Else
                        m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Leitung") Is System.DBNull.Value Then
                        m_bLeitung = SqlBoolean.Null
                    Else
                        m_bLeitung = New SqlBoolean(CType(dtToReturn.Rows(0)("Leitung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("RolleNr") Is System.DBNull.Value Then
                        m_iRolleNr = SqlInt32.Null
                    Else
                        m_iRolleNr = New SqlInt32(CType(dtToReturn.Rows(0)("RolleNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumPerson::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iGreminPersonNr</LI> <LI>iGremiumBereichNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>bLeitung. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iRolleNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_GremiumPerson_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGreminPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iGreminPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iGremiumBereichNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGremiumBereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bLeitung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bLeitung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRolleNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRolleNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_GremiumPerson_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsGremiumPerson::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsGremiumPerson-Felder

clsGremiumPerson Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bLeitung

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iGreminPersonNr

Unterstützt von .NET Compact Framework
private field m_iGremiumBereichNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
private field m_iRolleNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsGremiumPerson -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bLeitung, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_bLeitung -Feld

[Visual Basic]
Private m_bLeitung As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bLeitung, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_iGreminPersonNr -Feld

[Visual Basic]
Private m_iGreminPersonNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRolleNr, m_iGremiumBereichNr, m_iPersonNr, m_iGreminPersonNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_iGremiumBereichNr -Feld

[Visual Basic]
Private m_iGremiumBereichNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRolleNr, m_iGremiumBereichNr, m_iPersonNr, m_iGreminPersonNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRolleNr, m_iGremiumBereichNr, m_iPersonNr, m_iGreminPersonNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_iPersonNr -Feld

[Visual Basic]
Private m_iPersonNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRolleNr, m_iGremiumBereichNr, m_iPersonNr, m_iGreminPersonNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_iRolleNr -Feld

[Visual Basic]
Private m_iRolleNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRolleNr, m_iGremiumBereichNr, m_iPersonNr, m_iGreminPersonNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsGremiumPerson


clsHistory -Klasse

Purpose: Data Access class for the table 'History'.

For a list of all members of this type, see clsHistory-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsHistory

[Visual Basic]
Public Class clsHistory
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsHistory-Member


clsHistory-Member

clsHistory Übersicht

Öffentliche Konstruktoren

public constructor clsHistory -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iHistoryNr

Unterstützt von .NET Compact Framework
public property iHistoryTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sAlter_Wert

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sHistoryObject

Unterstützt von .NET Compact Framework
public property sHistoryObjectDetails

Unterstützt von .NET Compact Framework
public property sHistoryObjekctKey

Unterstützt von .NET Compact Framework
public property sNeuer_Wert

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iHistoryNr

Unterstützt von .NET Compact Framework
private field m_iHistoryTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sAlter_Wert

Unterstützt von .NET Compact Framework
private field m_sHistoryObject

Unterstützt von .NET Compact Framework
private field m_sHistoryObjectDetails

Unterstützt von .NET Compact Framework
private field m_sHistoryObjekctKey

Unterstützt von .NET Compact Framework
private field m_sNeuer_Wert

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsHistory -Klasse


clsHistory -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory-Eigenschaften

clsHistory Übersicht

Öffentliche Eigenschaften

public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iHistoryNr

Unterstützt von .NET Compact Framework
public property iHistoryTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sAlter_Wert

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sHistoryObject

Unterstützt von .NET Compact Framework
public property sHistoryObjectDetails

Unterstützt von .NET Compact Framework
public property sHistoryObjekctKey

Unterstützt von .NET Compact Framework
public property sNeuer_Wert

Unterstützt von .NET Compact Framework

clsHistory -Klasse


clsHistory.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.iHistoryNr -Eigenschaft

[Visual Basic]
Public Property iHistoryNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iHistoryNr]() As SqlInt32
            Get
                Return m_iHistoryNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHistoryNrTmp As SqlInt32 = Value
                If iHistoryNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHistoryNr", "iHistoryNr can't be NULL")
                End If
                m_iHistoryNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.iHistoryTypNr -Eigenschaft

[Visual Basic]
Public Property iHistoryTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iHistoryTypNr]() As SqlInt32
            Get
                Return m_iHistoryTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iHistoryTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.sAlter_Wert -Eigenschaft

[Visual Basic]
Public Property sAlter_Wert() As SqlString

Quellcode

[Visual Basic]
        Public Property [sAlter_Wert]() As SqlString
            Get
                Return m_sAlter_Wert
            End Get
            Set(ByVal Value As SqlString)
                m_sAlter_Wert = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.sHistoryObject -Eigenschaft

[Visual Basic]
Public Property sHistoryObject() As SqlString

Quellcode

[Visual Basic]
        Public Property [sHistoryObject]() As SqlString
            Get
                Return m_sHistoryObject
            End Get
            Set(ByVal Value As SqlString)
                m_sHistoryObject = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.sHistoryObjectDetails -Eigenschaft

[Visual Basic]
Public Property sHistoryObjectDetails() As SqlString

Quellcode

[Visual Basic]
        Public Property [sHistoryObjectDetails]() As SqlString
            Get
                Return m_sHistoryObjectDetails
            End Get
            Set(ByVal Value As SqlString)
                m_sHistoryObjectDetails = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.sHistoryObjekctKey -Eigenschaft

[Visual Basic]
Public Property sHistoryObjekctKey() As SqlString

Quellcode

[Visual Basic]
        Public Property [sHistoryObjekctKey]() As SqlString
            Get
                Return m_sHistoryObjekctKey
            End Get
            Set(ByVal Value As SqlString)
                m_sHistoryObjekctKey = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.sNeuer_Wert -Eigenschaft

[Visual Basic]
Public Property sNeuer_Wert() As SqlString

Quellcode

[Visual Basic]
        Public Property [sNeuer_Wert]() As SqlString
            Get
                Return m_sNeuer_Wert
            End Get
            Set(ByVal Value As SqlString)
                m_sNeuer_Wert = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory-Methoden

clsHistory Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsHistory -Klasse


clsHistory.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistoryNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_History_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistoryNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistoryNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_History_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistory::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistoryTypNr. May be SqlInt32.Null</LI> <LI>sHistoryObject. May be SqlString.Null</LI> <LI>sHistoryObjekctKey. May be SqlString.Null</LI> <LI>sHistoryObjectDetails. May be SqlString.Null</LI> <LI>sAlter_Wert. May be SqlString.Null</LI> <LI>sNeuer_Wert. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iHistoryNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_History_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistoryTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHistoryTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObjekctKey", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObjekctKey))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObjectDetails", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObjectDetails))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAlter_Wert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAlter_Wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNeuer_Wert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNeuer_Wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iHistoryNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iHistoryNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iHistoryNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iHistoryNr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_History_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistory::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_History_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("History")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_History_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistory::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistoryNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iHistoryNr</LI> <LI>iHistoryTypNr</LI> <LI>sHistoryObject</LI> <LI>sHistoryObjekctKey</LI> <LI>sHistoryObjectDetails</LI> <LI>sAlter_Wert</LI> <LI>sNeuer_Wert</LI> <LI>daErstellt_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_History_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("History")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iHistoryNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistoryNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_History_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iHistoryNr = New SqlInt32(CType(dtToReturn.Rows(0)("HistoryNr"), Integer))
                    If dtToReturn.Rows(0)("HistoryTypNr") Is System.DBNull.Value Then
                        m_iHistoryTypNr = SqlInt32.Null
                    Else
                        m_iHistoryTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("HistoryTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("HistoryObject") Is System.DBNull.Value Then
                        m_sHistoryObject = SqlString.Null
                    Else
                        m_sHistoryObject = New SqlString(CType(dtToReturn.Rows(0)("HistoryObject"), String))
                    End If
                    If dtToReturn.Rows(0)("HistoryObjekctKey") Is System.DBNull.Value Then
                        m_sHistoryObjekctKey = SqlString.Null
                    Else
                        m_sHistoryObjekctKey = New SqlString(CType(dtToReturn.Rows(0)("HistoryObjekctKey"), String))
                    End If
                    If dtToReturn.Rows(0)("HistoryObjectDetails") Is System.DBNull.Value Then
                        m_sHistoryObjectDetails = SqlString.Null
                    Else
                        m_sHistoryObjectDetails = New SqlString(CType(dtToReturn.Rows(0)("HistoryObjectDetails"), String))
                    End If
                    If dtToReturn.Rows(0)("Alter_Wert") Is System.DBNull.Value Then
                        m_sAlter_Wert = SqlString.Null
                    Else
                        m_sAlter_Wert = New SqlString(CType(dtToReturn.Rows(0)("Alter_Wert"), String))
                    End If
                    If dtToReturn.Rows(0)("Neuer_Wert") Is System.DBNull.Value Then
                        m_sNeuer_Wert = SqlString.Null
                    Else
                        m_sNeuer_Wert = New SqlString(CType(dtToReturn.Rows(0)("Neuer_Wert"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistory::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistoryNr</LI> <LI>iHistoryTypNr. May be SqlInt32.Null</LI> <LI>sHistoryObject. May be SqlString.Null</LI> <LI>sHistoryObjekctKey. May be SqlString.Null</LI> <LI>sHistoryObjectDetails. May be SqlString.Null</LI> <LI>sAlter_Wert. May be SqlString.Null</LI> <LI>sNeuer_Wert. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_History_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistoryNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistoryNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistoryTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHistoryTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObjekctKey", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObjekctKey))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sHistoryObjectDetails", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHistoryObjectDetails))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sAlter_Wert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAlter_Wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNeuer_Wert", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNeuer_Wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_History_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistory::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistory-Felder

clsHistory Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iHistoryNr

Unterstützt von .NET Compact Framework
private field m_iHistoryTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sAlter_Wert

Unterstützt von .NET Compact Framework
private field m_sHistoryObject

Unterstützt von .NET Compact Framework
private field m_sHistoryObjectDetails

Unterstützt von .NET Compact Framework
private field m_sHistoryObjekctKey

Unterstützt von .NET Compact Framework
private field m_sNeuer_Wert

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsHistory -Klasse


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_iHistoryNr -Feld

[Visual Basic]
Private m_iHistoryNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iHistoryTypNr, m_iHistoryNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_iHistoryTypNr -Feld

[Visual Basic]
Private m_iHistoryTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iHistoryTypNr, m_iHistoryNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iHistoryTypNr, m_iHistoryNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_sAlter_Wert -Feld

[Visual Basic]
Private m_sAlter_Wert As SqlString

Quellcode

[Visual Basic]
        Private 		m_sNeuer_Wert, m_sHistoryObjectDetails, m_sHistoryObject, m_sHistoryObjekctKey, m_sAlter_Wert As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_sHistoryObject -Feld

[Visual Basic]
Private m_sHistoryObject As SqlString

Quellcode

[Visual Basic]
        Private 		m_sNeuer_Wert, m_sHistoryObjectDetails, m_sHistoryObject, m_sHistoryObjekctKey, m_sAlter_Wert As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_sHistoryObjectDetails -Feld

[Visual Basic]
Private m_sHistoryObjectDetails As SqlString

Quellcode

[Visual Basic]
        Private 		m_sNeuer_Wert, m_sHistoryObjectDetails, m_sHistoryObject, m_sHistoryObjekctKey, m_sAlter_Wert As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_sHistoryObjekctKey -Feld

[Visual Basic]
Private m_sHistoryObjekctKey As SqlString

Quellcode

[Visual Basic]
        Private 		m_sNeuer_Wert, m_sHistoryObjectDetails, m_sHistoryObject, m_sHistoryObjekctKey, m_sAlter_Wert As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


m_sNeuer_Wert -Feld

[Visual Basic]
Private m_sNeuer_Wert As SqlString

Quellcode

[Visual Basic]
        Private 		m_sNeuer_Wert, m_sHistoryObjectDetails, m_sHistoryObject, m_sHistoryObjekctKey, m_sAlter_Wert As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistory


clsHistoryTyp -Klasse

Purpose: Data Access class for the table 'HistoryTyp'.

For a list of all members of this type, see clsHistoryTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsHistoryTyp

[Visual Basic]
Public Class clsHistoryTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsHistoryTyp-Member


clsHistoryTyp-Member

clsHistoryTyp Übersicht

Öffentliche Konstruktoren

public constructor clsHistoryTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iHistorytypnr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iHistorytypnr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsHistoryTyp -Klasse


clsHistoryTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp-Eigenschaften

clsHistoryTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iHistorytypnr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsHistoryTyp -Klasse


clsHistoryTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.iHistorytypnr -Eigenschaft

[Visual Basic]
Public Property iHistorytypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iHistorytypnr]() As SqlInt32
            Get
                Return m_iHistorytypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHistorytypnrTmp As SqlInt32 = Value
                If iHistorytypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHistorytypnr", "iHistorytypnr can't be NULL")
                End If
                m_iHistorytypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp-Methoden

clsHistoryTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsHistoryTyp -Klasse


clsHistoryTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistorytypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_HistoryTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistorytypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistorytypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_HistoryTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistoryTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistorytypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_HistoryTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistorytypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistorytypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_HistoryTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistoryTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_HistoryTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("HistoryTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_HistoryTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistoryTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistorytypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iHistorytypnr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_HistoryTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("HistoryTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iHistorytypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistorytypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_HistoryTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iHistorytypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Historytypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistoryTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iHistorytypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_HistoryTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iHistorytypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHistorytypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_HistoryTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsHistoryTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsHistoryTyp-Felder

clsHistoryTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iHistorytypnr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsHistoryTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_iHistorytypnr -Feld

[Visual Basic]
Private m_iHistorytypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iHistorytypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iHistorytypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantNr, m_iMutierer, m_iHistorytypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsHistoryTyp


clsInstallationAlsTyp -Klasse

Purpose: Data Access class for the table 'InstallationAlsTyp'.

For a list of all members of this type, see clsInstallationAlsTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsInstallationAlsTyp

[Visual Basic]
Public Class clsInstallationAlsTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsInstallationAlsTyp-Member


clsInstallationAlsTyp-Member

clsInstallationAlsTyp Übersicht

Öffentliche Konstruktoren

public constructor clsInstallationAlsTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationAlsTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationAlsTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationAlsTyp -Klasse


clsInstallationAlsTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp-Eigenschaften

clsInstallationAlsTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationAlsTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationAlsTyp -Klasse


clsInstallationAlsTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.iInstallationAlsTypNr -Eigenschaft

[Visual Basic]
Public Property iInstallationAlsTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationAlsTypNr]() As SqlInt32
            Get
                Return m_iInstallationAlsTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iInstallationAlsTypNrTmp As SqlInt32 = Value
                If iInstallationAlsTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iInstallationAlsTypNr", "iInstallationAlsTypNr can't be NULL")
                End If
                m_iInstallationAlsTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp-Methoden

clsInstallationAlsTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsInstallationAlsTyp -Klasse


clsInstallationAlsTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationAlsTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationAlsTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationAlsTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationAlsTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationAlsTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationAlsTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationAlsTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationAlsTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationAlsTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("InstallationAlsTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationAlsTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationAlsTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationAlsTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iInstallationAlsTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationAlsTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("InstallationAlsTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationAlsTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iInstallationAlsTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("InstallationAlsTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationAlsTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationAlsTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationAlsTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationAlsTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationAlsTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationAlsTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationAlsTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationAlsTyp-Felder

clsInstallationAlsTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationAlsTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationAlsTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_iInstallationAlsTypNr -Feld

[Visual Basic]
Private m_iInstallationAlsTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iInstallationAlsTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationAlsTyp


clsInstallationTyp -Klasse

Purpose: Data Access class for the table 'InstallationTyp'.

For a list of all members of this type, see clsInstallationTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsInstallationTyp

[Visual Basic]
Public Class clsInstallationTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsInstallationTyp-Member


clsInstallationTyp-Member

clsInstallationTyp Übersicht

Öffentliche Konstruktoren

public constructor clsInstallationTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstllt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstllt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationTyp -Klasse


clsInstallationTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp-Eigenschaften

clsInstallationTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstllt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iInstallationTypNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationTyp -Klasse


clsInstallationTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.daErstllt_am -Eigenschaft

[Visual Basic]
Public Property daErstllt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstllt_am]() As SqlDateTime
            Get
                Return m_daErstllt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstllt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.iInstallationTypNr -Eigenschaft

[Visual Basic]
Public Property iInstallationTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iInstallationTypNr]() As SqlInt32
            Get
                Return m_iInstallationTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iInstallationTypNrTmp As SqlInt32 = Value
                If iInstallationTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iInstallationTypNr", "iInstallationTypNr can't be NULL")
                End If
                m_iInstallationTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp-Methoden

clsInstallationTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsInstallationTyp -Klasse


clsInstallationTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstllt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstllt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstllt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("InstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iInstallationTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstllt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("InstallationTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iInstallationTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("InstallationTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstllt_am") Is System.DBNull.Value Then
                        m_daErstllt_am = SqlDateTime.Null
                    Else
                        m_daErstllt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstllt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iInstallationTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstllt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_InstallationTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iInstallationTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iInstallationTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstllt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstllt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_InstallationTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsInstallationTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsInstallationTyp-Felder

clsInstallationTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstllt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iInstallationTypNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsInstallationTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_daErstllt_am -Feld

[Visual Basic]
Private m_daErstllt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstllt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstllt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_iInstallationTypNr -Feld

[Visual Basic]
Private m_iInstallationTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iInstallationTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iInstallationTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsInstallationTyp


clsKey_tabelle -Klasse

Purpose: Data Access class for the table 'key_tabelle'.

For a list of all members of this type, see clsKey_tabelle-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsMyKey_Tabelle

[Visual Basic]
Public Class clsKey_tabelle
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKey_tabelle-Member


clsKey_tabelle-Member

clsKey_tabelle Übersicht

Öffentliche Konstruktoren

public constructor clsKey_tabelle -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKey_wert

Unterstützt von .NET Compact Framework
public property iKeynr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKey_wert

Unterstützt von .NET Compact Framework
private field m_iKeynr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKey_tabelle -Klasse


clsKey_tabelle -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle-Eigenschaften

clsKey_tabelle Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKey_wert

Unterstützt von .NET Compact Framework
public property iKeynr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKey_tabelle -Klasse


clsKey_tabelle.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.iKey_wert -Eigenschaft

[Visual Basic]
Public Property iKey_wert() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKey_wert]() As SqlInt32
            Get
                Return m_iKey_wert
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKey_wertTmp As SqlInt32 = Value
                If iKey_wertTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKey_wert", "iKey_wert can't be NULL")
                End If
                m_iKey_wert = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.iKeynr -Eigenschaft

[Visual Basic]
Public Property iKeynr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKeynr]() As SqlInt32
            Get
                Return m_iKeynr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKeynrTmp As SqlInt32 = Value
                If iKeynrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKeynr", "iKeynr can't be NULL")
                End If
                m_iKeynr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBeschreibungTmp As SqlString = Value
                If sBeschreibungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
                End If
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle-Methoden

clsKey_tabelle Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKey_tabelle -Klasse


clsKey_tabelle.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKeynr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iKeynr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iKeynr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@ikeynr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKeynr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKeynr</LI> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKeynr = New SqlInt32(CType(dtToReturn.Rows(0)("keynr"), Integer))
                    m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    m_iKey_wert = New SqlInt32(CType(dtToReturn.Rows(0)("key_wert"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKeynr</LI> <LI>sBeschreibung</LI> <LI>iKey_wert</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKey_tabelle-Felder

clsKey_tabelle Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKey_wert

Unterstützt von .NET Compact Framework
private field m_iKeynr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKey_tabelle -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_iKey_wert -Feld

[Visual Basic]
Private m_iKey_wert As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_iKeynr -Feld

[Visual Basic]
Private m_iKeynr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKey_tabelle


clsKontakttyp -Klasse

Purpose: Data Access class for the table 'Kontakttyp'.

For a list of all members of this type, see clsKontakttyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKontakttyp

[Visual Basic]
Public Class clsKontakttyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKontakttyp-Member


clsKontakttyp-Member

clsKontakttyp Übersicht

Öffentliche Konstruktoren

public constructor clsKontakttyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationsbereichNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationsbereichNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakttyp -Klasse


clsKontakttyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp-Eigenschaften

clsKontakttyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationsbereichNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakttyp -Klasse


clsKontakttyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.iApplikationsbereichNr -Eigenschaft

[Visual Basic]
Public Property iApplikationsbereichNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationsbereichNr]() As SqlInt32
            Get
                Return m_iApplikationsbereichNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationsbereichNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.iKontakttypNr -Eigenschaft

[Visual Basic]
Public Property iKontakttypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKontakttypNr]() As SqlInt32
            Get
                Return m_iKontakttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKontakttypNrTmp As SqlInt32 = Value
                If iKontakttypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKontakttypNr", "iKontakttypNr can't be NULL")
                End If
                m_iKontakttypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp-Methoden

clsKontakttyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKontakttyp -Klasse


clsKontakttyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iApplikationsbereichNr. May be SqlInt32.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationsbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsbereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kontakttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKontakttypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>iApplikationsbereichNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kontakttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKontakttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("KontakttypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("ApplikationsbereichNr") Is System.DBNull.Value Then
                        m_iApplikationsbereichNr = SqlInt32.Null
                    Else
                        m_iApplikationsbereichNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationsbereichNr"), Integer))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKontakttypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iApplikationsbereichNr. May be SqlInt32.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kontakttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationsbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsbereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kontakttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKontakttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKontakttyp-Felder

clsKontakttyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationsbereichNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakttyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_iApplikationsbereichNr -Feld

[Visual Basic]
Private m_iApplikationsbereichNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsbereichNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_iKontakttypNr -Feld

[Visual Basic]
Private m_iKontakttypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsbereichNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsbereichNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iApplikationsbereichNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakttyp


clsKostenart -Klasse

Purpose: Data Access class for the table 'Kostenart'.

For a list of all members of this type, see clsKostenart-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKostenart

[Visual Basic]
Public Class clsKostenart
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKostenart-Member


clsKostenart-Member

clsKostenart Übersicht

Öffentliche Konstruktoren

public constructor clsKostenart -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKostenartNr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKostenart -Klasse


clsKostenart -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart-Eigenschaften

clsKostenart Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKostenart -Klasse


clsKostenart.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.iKostenartNr -Eigenschaft

[Visual Basic]
Public Property iKostenartNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKostenartNr]() As SqlInt32
            Get
                Return m_iKostenartNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKostenartNrTmp As SqlInt32 = Value
                If iKostenartNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKostenartNr", "iKostenartNr can't be NULL")
                End If
                m_iKostenartNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart-Methoden

clsKostenart Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKostenart -Klasse


clsKostenart.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kostenart_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kostenart_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenart::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kostenart_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kostenart_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenart::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kostenart_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kostenart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kostenart_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenart::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKostenartNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kostenart_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kostenart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kostenart_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKostenartNr = New SqlInt32(CType(dtToReturn.Rows(0)("KostenartNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenart::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kostenart_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kostenart_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenart::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKostenart-Felder

clsKostenart Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKostenartNr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKostenart -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_iKostenartNr -Feld

[Visual Basic]
Private m_iKostenartNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iKostenartNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iKostenartNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iKostenartNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKostenart


clsKuendigungsfrist -Klasse

Purpose: Data Access class for the table 'Kuendigungsfrist'.

For a list of all members of this type, see clsKuendigungsfrist-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.Vertrag.clsKuendigungsfrist

[Visual Basic]
Public Class clsKuendigungsfrist
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKuendigungsfrist-Member


clsKuendigungsfrist-Member

clsKuendigungsfrist Übersicht

Öffentliche Konstruktoren

public constructor clsKuendigungsfrist -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daKuendigungstermin

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property iVertragselementNrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKuendigungsfirst

Unterstützt von .NET Compact Framework
public property sVarZeitspanne

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daKuendigungstermin

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sKuendigungsfirst

Unterstützt von .NET Compact Framework
private field m_sVarZeitspanne

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


clsKuendigungsfrist -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist-Eigenschaften

clsKuendigungsfrist Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daKuendigungstermin

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property iVertragselementNrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKuendigungsfirst

Unterstützt von .NET Compact Framework
public property sVarZeitspanne

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


clsKuendigungsfrist.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.daKuendigungstermin -Eigenschaft

[Visual Basic]
Public Property daKuendigungstermin() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daKuendigungstermin]() As SqlDateTime
            Get
                Return m_daKuendigungstermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daKuendigungstermin = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.iKuendigungsfristNr -Eigenschaft

[Visual Basic]
Public Property iKuendigungsfristNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKuendigungsfristNr]() As SqlInt32
            Get
                Return m_iKuendigungsfristNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKuendigungsfristNrTmp As SqlInt32 = Value
                If iKuendigungsfristNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKuendigungsfristNr", "iKuendigungsfristNr can't be NULL")
                End If
                m_iKuendigungsfristNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.iVertragselementNr -Eigenschaft

[Visual Basic]
Public Property iVertragselementNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.iVertragselementNrOld -Eigenschaft

[Visual Basic]
Public Property iVertragselementNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementNrOld]() As SqlInt32
            Get
                Return m_iVertragselementNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.sKuendigungsfirst -Eigenschaft

[Visual Basic]
Public Property sKuendigungsfirst() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKuendigungsfirst]() As SqlString
            Get
                Return m_sKuendigungsfirst
            End Get
            Set(ByVal Value As SqlString)
                m_sKuendigungsfirst = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.sVarZeitspanne -Eigenschaft

[Visual Basic]
Public Property sVarZeitspanne() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVarZeitspanne]() As SqlString
            Get
                Return m_sVarZeitspanne
            End Get
            Set(ByVal Value As SqlString)
                m_sVarZeitspanne = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist-Methoden

clsKuendigungsfrist Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

clsKuendigungsfrist -Klasse


clsKuendigungsfrist.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.DeleteAllWVertragselementNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'

[Visual Basic]
Public Function DeleteAllWVertragselementNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragselementNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_DeleteAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_DeleteAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::DeleteAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVarZeitspanne. May be SqlString.Null</LI> <LI>sKuendigungsfirst. May be SqlString.Null</LI> <LI>daKuendigungstermin. May be SqlDateTime.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVarZeitspanne", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVarZeitspanne))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfirst", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfirst))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKuendigungstermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daKuendigungstermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.SelectAllWVertragselementNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'

[Visual Basic]
Public Function SelectAllWVertragselementNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragselementNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr</LI> <LI>sVarZeitspanne</LI> <LI>sKuendigungsfirst</LI> <LI>daKuendigungstermin</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfrist")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKuendigungsfristNr = New SqlInt32(CType(dtToReturn.Rows(0)("KuendigungsfristNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("VarZeitspanne") Is System.DBNull.Value Then
                        m_sVarZeitspanne = SqlString.Null
                    Else
                        m_sVarZeitspanne = New SqlString(CType(dtToReturn.Rows(0)("VarZeitspanne"), String))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungsfirst") Is System.DBNull.Value Then
                        m_sKuendigungsfirst = SqlString.Null
                    Else
                        m_sKuendigungsfirst = New SqlString(CType(dtToReturn.Rows(0)("Kuendigungsfirst"), String))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungstermin") Is System.DBNull.Value Then
                        m_daKuendigungstermin = SqlDateTime.Null
                    Else
                        m_daKuendigungstermin = New SqlDateTime(CType(dtToReturn.Rows(0)("Kuendigungstermin"), Date))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVarZeitspanne. May be SqlString.Null</LI> <LI>sKuendigungsfirst. May be SqlString.Null</LI> <LI>daKuendigungstermin. May be SqlDateTime.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVarZeitspanne", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVarZeitspanne))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKuendigungsfirst", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKuendigungsfirst))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKuendigungstermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daKuendigungstermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.UpdateAllWVertragselementNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

[Visual Basic]
Public Function UpdateAllWVertragselementNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iVertragselementNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragselementNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfrist_UpdateAllWVertragselementNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfrist_UpdateAllWVertragselementNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfrist::UpdateAllWVertragselementNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist-Felder

clsKuendigungsfrist Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daKuendigungstermin

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sKuendigungsfirst

Unterstützt von .NET Compact Framework
private field m_sVarZeitspanne

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_daKuendigungstermin -Feld

[Visual Basic]
Private m_daKuendigungstermin As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daKuendigungstermin, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_iKuendigungsfristNr -Feld

[Visual Basic]
Private m_iKuendigungsfristNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_iVertragselementNr -Feld

[Visual Basic]
Private m_iVertragselementNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_iVertragselementNrOld -Feld

[Visual Basic]
Private m_iVertragselementNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iVertragselementNr, m_iVertragselementNrOld, m_iKuendigungsfristNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_sKuendigungsfirst -Feld

[Visual Basic]
Private m_sKuendigungsfirst As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


m_sVarZeitspanne -Feld

[Visual Basic]
Private m_sVarZeitspanne As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sKuendigungsfirst, m_sVarZeitspanne As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfristen -Klasse

Purpose: Data Access class for the table 'Kuendigungsfristen'.

For a list of all members of this type, see clsKuendigungsfristen-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfristen

[Visual Basic]
Public Class clsKuendigungsfristen
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKuendigungsfristen-Member


clsKuendigungsfristen-Member

clsKuendigungsfristen Übersicht

Öffentliche Konstruktoren

public constructor clsKuendigungsfristen -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iTage

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iTage

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfristen -Klasse


clsKuendigungsfristen -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen-Eigenschaften

clsKuendigungsfristen Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iTage

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfristen -Klasse


clsKuendigungsfristen.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.iKuendigungsfristNr -Eigenschaft

[Visual Basic]
Public Property iKuendigungsfristNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKuendigungsfristNr]() As SqlInt32
            Get
                Return m_iKuendigungsfristNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKuendigungsfristNrTmp As SqlInt32 = Value
                If iKuendigungsfristNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKuendigungsfristNr", "iKuendigungsfristNr can't be NULL")
                End If
                m_iKuendigungsfristNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.iTage -Eigenschaft

[Visual Basic]
Public Property iTage() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iTage]() As SqlInt32
            Get
                Return m_iTage
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTage = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen-Methoden

clsKuendigungsfristen Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKuendigungsfristen -Klasse


clsKuendigungsfristen.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfristen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfristen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfristen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iTage. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfristen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTage", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfristen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfristen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfristen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfristen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfristen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfristen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iKuendigungsfristNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>iTage</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfristen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Kuendigungsfristen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfristen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKuendigungsfristNr = New SqlInt32(CType(dtToReturn.Rows(0)("KuendigungsfristNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Tage") Is System.DBNull.Value Then
                        m_iTage = SqlInt32.Null
                    Else
                        m_iTage = New SqlInt32(CType(dtToReturn.Rows(0)("Tage"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfristen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKuendigungsfristNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iTage. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Kuendigungsfristen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iTage", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Kuendigungsfristen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKuendigungsfristen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsKuendigungsfristen-Felder

clsKuendigungsfristen Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iTage

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfristen -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_iKuendigungsfristNr -Feld

[Visual Basic]
Private m_iKuendigungsfristNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKuendigungsfristNr, m_iTage As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKuendigungsfristNr, m_iTage As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_iTage -Feld

[Visual Basic]
Private m_iTage As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iKuendigungsfristNr, m_iTage As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfristen


clsLizenzkauf -Klasse

Purpose: Data Access class for the table 'Lizenzkauf'.

For a list of all members of this type, see clsLizenzkauf-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsLizenzkauf

[Visual Basic]
Public Class clsLizenzkauf
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsLizenzkauf-Member


clsLizenzkauf-Member

clsLizenzkauf Übersicht

Öffentliche Konstruktoren

public constructor clsLizenzkauf -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daGueltigbis

Unterstützt von .NET Compact Framework
public property daKaufdatum

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAnzahl

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenzkaufNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iStatusnr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKGNummer

Unterstützt von .NET Compact Framework
public property sSAPNummer

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daGueltigbis

Unterstützt von .NET Compact Framework
private field m_daKaufdatum

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAnzahl

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iStatusnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sKGNummer

Unterstützt von .NET Compact Framework
private field m_sSAPNummer

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenzkauf -Klasse


clsLizenzkauf -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf-Eigenschaften

clsLizenzkauf Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daGueltigbis

Unterstützt von .NET Compact Framework
public property daKaufdatum

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iAnzahl

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenzkaufNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iStatusnr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKGNummer

Unterstützt von .NET Compact Framework
public property sSAPNummer

Unterstützt von .NET Compact Framework

clsLizenzkauf -Klasse


clsLizenzkauf.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.daGueltigbis -Eigenschaft

[Visual Basic]
Public Property daGueltigbis() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daGueltigbis]() As SqlDateTime
            Get
                Return m_daGueltigbis
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGueltigbis = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.daKaufdatum -Eigenschaft

[Visual Basic]
Public Property daKaufdatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daKaufdatum]() As SqlDateTime
            Get
                Return m_daKaufdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daKaufdatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iAnzahl -Eigenschaft

[Visual Basic]
Public Property iAnzahl() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAnzahl]() As SqlInt32
            Get
                Return m_iAnzahl
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnzahl = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iLizenzkaufNr -Eigenschaft

[Visual Basic]
Public Property iLizenzkaufNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenzkaufNr]() As SqlInt32
            Get
                Return m_iLizenzkaufNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iLizenzkaufNrTmp As SqlInt32 = Value
                If iLizenzkaufNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iLizenzkaufNr", "iLizenzkaufNr can't be NULL")
                End If
                m_iLizenzkaufNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iStatusnr -Eigenschaft

[Visual Basic]
Public Property iStatusnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iStatusnr]() As SqlInt32
            Get
                Return m_iStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatusnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iVertragselementnr -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr]() As SqlInt32
            Get
                Return m_iVertragselementnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.iVertragselementnrOld -Eigenschaft

[Visual Basic]
Public Property iVertragselementnrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnrOld]() As SqlInt32
            Get
                Return m_iVertragselementnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.sKGNummer -Eigenschaft

[Visual Basic]
Public Property sKGNummer() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKGNummer]() As SqlString
            Get
                Return m_sKGNummer
            End Get
            Set(ByVal Value As SqlString)
                m_sKGNummer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.sSAPNummer -Eigenschaft

[Visual Basic]
Public Property sSAPNummer() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSAPNummer]() As SqlString
            Get
                Return m_sSAPNummer
            End Get
            Set(ByVal Value As SqlString)
                m_sSAPNummer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf-Methoden

clsLizenzkauf Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

clsLizenzkauf -Klasse


clsLizenzkauf.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzkaufNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.DeleteAllWVertragselementnrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'

[Visual Basic]
Public Function DeleteAllWVertragselementnrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragselementnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_DeleteAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_DeleteAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::DeleteAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufNr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iAnzahl. May be SqlInt32.Null</LI> <LI>daKaufdatum. May be SqlDateTime.Null</LI> <LI>sKGNummer. May be SqlString.Null</LI> <LI>sSAPNummer. May be SqlString.Null</LI> <LI>daGueltigbis. May be SqlDateTime.Null</LI> <LI>iStatusnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzkaufNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKaufdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daKaufdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKGNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKGNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAPNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAPNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGueltigbis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGueltigbis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzkauf")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.SelectAllWVertragselementnrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'

[Visual Basic]
Public Function SelectAllWVertragselementnrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragselementnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_SelectAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzkauf")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_SelectAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::SelectAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iLizenzkaufNr</LI> <LI>iVertragselementnr</LI> <LI>iAnzahl</LI> <LI>daKaufdatum</LI> <LI>sKGNummer</LI> <LI>sSAPNummer</LI> <LI>daGueltigbis</LI> <LI>iStatusnr</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iApplikationNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzkauf")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzkaufNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iLizenzkaufNr = New SqlInt32(CType(dtToReturn.Rows(0)("LizenzkaufNr"), Integer))
                    If dtToReturn.Rows(0)("Vertragselementnr") Is System.DBNull.Value Then
                        m_iVertragselementnr = SqlInt32.Null
                    Else
                        m_iVertragselementnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Anzahl") Is System.DBNull.Value Then
                        m_iAnzahl = SqlInt32.Null
                    Else
                        m_iAnzahl = New SqlInt32(CType(dtToReturn.Rows(0)("Anzahl"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Kaufdatum") Is System.DBNull.Value Then
                        m_daKaufdatum = SqlDateTime.Null
                    Else
                        m_daKaufdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Kaufdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("KGNummer") Is System.DBNull.Value Then
                        m_sKGNummer = SqlString.Null
                    Else
                        m_sKGNummer = New SqlString(CType(dtToReturn.Rows(0)("KGNummer"), String))
                    End If
                    If dtToReturn.Rows(0)("SAPNummer") Is System.DBNull.Value Then
                        m_sSAPNummer = SqlString.Null
                    Else
                        m_sSAPNummer = New SqlString(CType(dtToReturn.Rows(0)("SAPNummer"), String))
                    End If
                    If dtToReturn.Rows(0)("Gueltigbis") Is System.DBNull.Value Then
                        m_daGueltigbis = SqlDateTime.Null
                    Else
                        m_daGueltigbis = New SqlDateTime(CType(dtToReturn.Rows(0)("Gueltigbis"), Date))
                    End If
                    If dtToReturn.Rows(0)("Statusnr") Is System.DBNull.Value Then
                        m_iStatusnr = SqlInt32.Null
                    Else
                        m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("Statusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufNr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iAnzahl. May be SqlInt32.Null</LI> <LI>daKaufdatum. May be SqlDateTime.Null</LI> <LI>sKGNummer. May be SqlString.Null</LI> <LI>sSAPNummer. May be SqlString.Null</LI> <LI>daGueltigbis. May be SqlDateTime.Null</LI> <LI>iStatusnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzkaufNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daKaufdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daKaufdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKGNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKGNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAPNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAPNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGueltigbis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGueltigbis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf.UpdateAllWVertragselementnrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

[Visual Basic]
Public Function UpdateAllWVertragselementnrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iVertragselementnrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragselementnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzkauf_UpdateAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzkauf_UpdateAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzkauf::UpdateAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzkauf-Felder

clsLizenzkauf Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daGueltigbis

Unterstützt von .NET Compact Framework
private field m_daKaufdatum

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iAnzahl

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iStatusnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sKGNummer

Unterstützt von .NET Compact Framework
private field m_sSAPNummer

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenzkauf -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daGueltigbis, m_daKaufdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_daGueltigbis -Feld

[Visual Basic]
Private m_daGueltigbis As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daGueltigbis, m_daKaufdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_daKaufdatum -Feld

[Visual Basic]
Private m_daKaufdatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daGueltigbis, m_daKaufdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daGueltigbis, m_daKaufdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iAnzahl -Feld

[Visual Basic]
Private m_iAnzahl As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iLizenzkaufNr -Feld

[Visual Basic]
Private m_iLizenzkaufNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iStatusnr -Feld

[Visual Basic]
Private m_iStatusnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iVertragselementnr -Feld

[Visual Basic]
Private m_iVertragselementnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_iVertragselementnrOld -Feld

[Visual Basic]
Private m_iVertragselementnrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iApplikationNr, m_iMutierer, m_iStatusnr, m_iAnzahl, m_iLizenzkaufNr, m_iVertragselementnr, m_iVertragselementnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sSAPNummer, m_sKGNummer As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_sKGNummer -Feld

[Visual Basic]
Private m_sKGNummer As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sSAPNummer, m_sKGNummer As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


m_sSAPNummer -Feld

[Visual Basic]
Private m_sSAPNummer As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sSAPNummer, m_sKGNummer As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzkauf


clsLizenzschluessel -Klasse

Purpose: Data Access class for the table 'Lizenzschluessel'.

For a list of all members of this type, see clsLizenzschluessel-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsLizenzschluessel

[Visual Basic]
Public Class clsLizenzschluessel
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsLizenzschluessel-Member


clsLizenzschluessel-Member

clsLizenzschluessel Übersicht

Öffentliche Konstruktoren

public constructor clsLizenzschluessel -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenzkaufnr

Unterstützt von .NET Compact Framework
public property iLizenzkaufnrOld

Unterstützt von .NET Compact Framework
public property iLizenzschluesselnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzschluessel

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Lizenzkaufnr. This method will Update one or more existing rows in the database. It will reset the field 'Lizenzkaufnr' in all rows which have as value for this field the value as set in property 'iLizenzkaufnrOld' to the value as set in property 'iLizenzkaufnr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufnr

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufnrOld

Unterstützt von .NET Compact Framework
private field m_iLizenzschluesselnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sLizenzschluessel

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenzschluessel -Klasse


clsLizenzschluessel -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel-Eigenschaften

clsLizenzschluessel Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenzkaufnr

Unterstützt von .NET Compact Framework
public property iLizenzkaufnrOld

Unterstützt von .NET Compact Framework
public property iLizenzschluesselnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzschluessel

Unterstützt von .NET Compact Framework

clsLizenzschluessel -Klasse


clsLizenzschluessel.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.iLizenzkaufnr -Eigenschaft

[Visual Basic]
Public Property iLizenzkaufnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenzkaufnr]() As SqlInt32
            Get
                Return m_iLizenzkaufnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iLizenzkaufnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.iLizenzkaufnrOld -Eigenschaft

[Visual Basic]
Public Property iLizenzkaufnrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenzkaufnrOld]() As SqlInt32
            Get
                Return m_iLizenzkaufnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iLizenzkaufnrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.iLizenzschluesselnr -Eigenschaft

[Visual Basic]
Public Property iLizenzschluesselnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenzschluesselnr]() As SqlInt32
            Get
                Return m_iLizenzschluesselnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iLizenzschluesselnrTmp As SqlInt32 = Value
                If iLizenzschluesselnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iLizenzschluesselnr", "iLizenzschluesselnr can't be NULL")
                End If
                m_iLizenzschluesselnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.sLizenzschluessel -Eigenschaft

[Visual Basic]
Public Property sLizenzschluessel() As SqlString

Quellcode

[Visual Basic]
        Public Property [sLizenzschluessel]() As SqlString
            Get
                Return m_sLizenzschluessel
            End Get
            Set(ByVal Value As SqlString)
                m_sLizenzschluessel = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel-Methoden

clsLizenzschluessel Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWLizenzkaufnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Lizenzkaufnr. This method will Update one or more existing rows in the database. It will reset the field 'Lizenzkaufnr' in all rows which have as value for this field the value as set in property 'iLizenzkaufnrOld' to the value as set in property 'iLizenzkaufnr'.

clsLizenzschluessel -Klasse


clsLizenzschluessel.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzschluesselnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzschluesselnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzschluesselnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.DeleteAllWLizenzkaufnrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'

[Visual Basic]
Public Function DeleteAllWLizenzkaufnrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWLizenzkaufnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_DeleteAllWLizenzkaufnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iLizenzkaufnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iLizenzkaufnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_DeleteAllWLizenzkaufnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::DeleteAllWLizenzkaufnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzschluesselnr</LI> <LI>iLizenzkaufnr. May be SqlInt32.Null</LI> <LI>sLizenzschluessel. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzschluesselnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzschluesselnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sLizenzschluessel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLizenzschluessel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzschluessel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.SelectAllWLizenzkaufnrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Lizenzkaufnr'

[Visual Basic]
Public Function SelectAllWLizenzkaufnrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWLizenzkaufnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_SelectAllWLizenzkaufnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzschluessel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iLizenzkaufnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iLizenzkaufnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_SelectAllWLizenzkaufnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::SelectAllWLizenzkaufnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzschluesselnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iLizenzschluesselnr</LI> <LI>iLizenzkaufnr</LI> <LI>sLizenzschluessel</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenzschluessel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzschluesselnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzschluesselnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iLizenzschluesselnr = New SqlInt32(CType(dtToReturn.Rows(0)("Lizenzschluesselnr"), Integer))
                    If dtToReturn.Rows(0)("Lizenzkaufnr") Is System.DBNull.Value Then
                        m_iLizenzkaufnr = SqlInt32.Null
                    Else
                        m_iLizenzkaufnr = New SqlInt32(CType(dtToReturn.Rows(0)("Lizenzkaufnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Lizenzschluessel") Is System.DBNull.Value Then
                        m_sLizenzschluessel = SqlString.Null
                    Else
                        m_sLizenzschluessel = New SqlString(CType(dtToReturn.Rows(0)("Lizenzschluessel"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzschluesselnr</LI> <LI>iLizenzkaufnr. May be SqlInt32.Null</LI> <LI>sLizenzschluessel. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzschluesselnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenzschluesselnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sLizenzschluessel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLizenzschluessel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel.UpdateAllWLizenzkaufnrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'Lizenzkaufnr. This method will Update one or more existing rows in the database. It will reset the field 'Lizenzkaufnr' in all rows which have as value for this field the value as set in property 'iLizenzkaufnrOld' to the value as set in property 'iLizenzkaufnr'.

[Visual Basic]
Public Function UpdateAllWLizenzkaufnrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenzkaufnr. May be SqlInt32.Null</LI> <LI>iLizenzkaufnrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWLizenzkaufnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenzschluessel_UpdateAllWLizenzkaufnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzkaufnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenzkaufnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenzkaufnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iLizenzkaufnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iLizenzkaufnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenzschluessel_UpdateAllWLizenzkaufnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenzschluessel::UpdateAllWLizenzkaufnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenzschluessel-Felder

clsLizenzschluessel Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufnr

Unterstützt von .NET Compact Framework
private field m_iLizenzkaufnrOld

Unterstützt von .NET Compact Framework
private field m_iLizenzschluesselnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sLizenzschluessel

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenzschluessel -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_iLizenzkaufnr -Feld

[Visual Basic]
Private m_iLizenzkaufnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenzschluesselnr, m_iLizenzkaufnr, m_iLizenzkaufnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_iLizenzkaufnrOld -Feld

[Visual Basic]
Private m_iLizenzkaufnrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenzschluesselnr, m_iLizenzkaufnr, m_iLizenzkaufnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_iLizenzschluesselnr -Feld

[Visual Basic]
Private m_iLizenzschluesselnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenzschluesselnr, m_iLizenzkaufnr, m_iLizenzkaufnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenzschluesselnr, m_iLizenzkaufnr, m_iLizenzkaufnrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sLizenzschluessel As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


m_sLizenzschluessel -Feld

[Visual Basic]
Private m_sLizenzschluessel As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sLizenzschluessel As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzschluessel


clsLizenztyp -Klasse

Purpose: Data Access class for the table 'Lizenztyp'.

For a list of all members of this type, see clsLizenztyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsLizenztyp

[Visual Basic]
Public Class clsLizenztyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsLizenztyp-Member


clsLizenztyp-Member

clsLizenztyp Übersicht

Öffentliche Konstruktoren

public constructor clsLizenztyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenztypnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenztyp -Klasse


clsLizenztyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp-Eigenschaften

clsLizenztyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenztyp -Klasse


clsLizenztyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.iLizenztypnr -Eigenschaft

[Visual Basic]
Public Property iLizenztypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenztypnr]() As SqlInt32
            Get
                Return m_iLizenztypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iLizenztypnrTmp As SqlInt32 = Value
                If iLizenztypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iLizenztypnr", "iLizenztypnr can't be NULL")
                End If
                m_iLizenztypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp-Methoden

clsLizenztyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsLizenztyp -Klasse


clsLizenztyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenztypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenztyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenztyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenztyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenztypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenztyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenztyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenztyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenztyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenztyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenztyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenztyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenztypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iLizenztypnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenztyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Lizenztyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenztyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iLizenztypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Lizenztypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenztyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iLizenztypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Lizenztyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Lizenztyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLizenztyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsLizenztyp-Felder

clsLizenztyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenztypnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsLizenztyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_iLizenztypnr -Feld

[Visual Basic]
Private m_iLizenztypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenztypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iLizenztypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenztyp


clsMandant -Klasse

Purpose: Data Access class for the table 'mandant'.

For a list of all members of this type, see clsMandant-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMandant

[Visual Basic]
Public Class clsMandant
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMandant-Member


clsMandant-Member

clsMandant Übersicht

Öffentliche Konstruktoren

public constructor clsMandant -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMandantnr1

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMandantnr1

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMandant -Klasse


clsMandant -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant-Eigenschaften

clsMandant Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMandantnr1

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMandant -Klasse


clsMandant.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.iMandantnr1 -Eigenschaft

[Visual Basic]
Public Property iMandantnr1() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr1]() As SqlInt32
            Get
                Return m_iMandantnr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr1 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant-Methoden

clsMandant Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMandant -Klasse


clsMandant.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMandantnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMandantnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr1. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMandantnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMandantnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>iMandantnr1</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr1") Is System.DBNull.Value Then
                        m_iMandantnr1 = SqlInt32.Null
                    Else
                        m_iMandantnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMandantnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr1. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMandant-Felder

clsMandant Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMandantnr1

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMandant -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_iMandantnr1 -Feld

[Visual Basic]
Private m_iMandantnr1 As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMandant


clsMarktbereich -Klasse

Purpose: Data Access class for the table 'Marktbereich'.

For a list of all members of this type, see clsMarktbereich-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMarktbereich

[Visual Basic]
Public Class clsMarktbereich
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMarktbereich-Member


clsMarktbereich-Member

clsMarktbereich Übersicht

Öffentliche Konstruktoren

public constructor clsMarktbereich -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMarktbereichNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMarktbereich -Klasse


clsMarktbereich -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich-Eigenschaften

clsMarktbereich Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMarktbereichNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMarktbereich -Klasse


clsMarktbereich.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.iMarktbereichNr -Eigenschaft

[Visual Basic]
Public Property iMarktbereichNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMarktbereichNr]() As SqlInt32
            Get
                Return m_iMarktbereichNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMarktbereichNrTmp As SqlInt32 = Value
                If iMarktbereichNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMarktbereichNr", "iMarktbereichNr can't be NULL")
                End If
                m_iMarktbereichNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich-Methoden

clsMarktbereich Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMarktbereich -Klasse


clsMarktbereich.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMarktbereichNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Marktbereich_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMarktbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Marktbereich_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMarktbereich::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMarktbereichNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Marktbereich_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMarktbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Marktbereich_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMarktbereich::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Marktbereich_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Marktbereich")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Marktbereich_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMarktbereich::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMarktbereichNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMarktbereichNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Marktbereich_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Marktbereich")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMarktbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Marktbereich_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMarktbereichNr = New SqlInt32(CType(dtToReturn.Rows(0)("MarktbereichNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMarktbereich::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMarktbereichNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Marktbereich_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMarktbereichNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Marktbereich_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMarktbereich::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMarktbereich-Felder

clsMarktbereich Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMarktbereichNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMarktbereich -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_iMarktbereichNr -Feld

[Visual Basic]
Private m_iMarktbereichNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMarktbereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMarktbereichNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMarktbereich


clsMeldungstexte -Klasse

Purpose: Data Access class for the table 'meldungstexte'.

For a list of all members of this type, see clsMeldungstexte-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMeldungstexte

[Visual Basic]
Public Class clsMeldungstexte
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMeldungstexte-Member


clsMeldungstexte-Member

clsMeldungstexte Übersicht

Öffentliche Konstruktoren

public constructor clsMeldungstexte -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMeldungstextnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSprache

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sInhalt

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMeldungstextnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSprache

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sInhalt

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMeldungstexte -Klasse


clsMeldungstexte -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte-Eigenschaften

clsMeldungstexte Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMeldungstextnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSprache

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sInhalt

Unterstützt von .NET Compact Framework

clsMeldungstexte -Klasse


clsMeldungstexte.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.iMeldungstextnr -Eigenschaft

[Visual Basic]
Public Property iMeldungstextnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMeldungstextnr]() As SqlInt32
            Get
                Return m_iMeldungstextnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMeldungstextnrTmp As SqlInt32 = Value
                If iMeldungstextnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMeldungstextnr", "iMeldungstextnr can't be NULL")
                End If
                m_iMeldungstextnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.iSprache -Eigenschaft

[Visual Basic]
Public Property iSprache() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.sInhalt -Eigenschaft

[Visual Basic]
Public Property sInhalt() As SqlString

Quellcode

[Visual Basic]
        Public Property [sInhalt]() As SqlString
            Get
                Return m_sInhalt
            End Get
            Set(ByVal Value As SqlString)
                m_sInhalt = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte-Methoden

clsMeldungstexte Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMeldungstexte -Klasse


clsMeldungstexte.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>sInhalt. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMeldungstextnr</LI> <LI>iSprache</LI> <LI>sInhalt</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMeldungstextnr = New SqlInt32(CType(dtToReturn.Rows(0)("meldungstextnr"), Integer))
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("inhalt") Is System.DBNull.Value Then
                        m_sInhalt = SqlString.Null
                    Else
                        m_sInhalt = New SqlString(CType(dtToReturn.Rows(0)("inhalt"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMeldungstextnr</LI> <LI>iSprache. May be SqlInt32.Null</LI> <LI>sInhalt. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMeldungstexte-Felder

clsMeldungstexte Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMeldungstextnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSprache

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sInhalt

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMeldungstexte -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_iMeldungstextnr -Feld

[Visual Basic]
Private m_iMeldungstextnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_iSprache -Feld

[Visual Basic]
Private m_iSprache As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSprache, m_iMeldungstextnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sInhalt As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


m_sInhalt -Feld

[Visual Basic]
Private m_sInhalt As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sInhalt As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMeldungstexte


clsMitarbeiter -Klasse

Purpose: Data Access class for the table 'mitarbeiter'.

For a list of all members of this type, see clsMitarbeiter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter
Vertragsverwaltung.TKB.VV.DB.MyMitarbeiter

[Visual Basic]
Public Class clsMitarbeiter
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMitarbeiter-Member


clsMitarbeiter-Member

clsMitarbeiter Übersicht

Öffentliche Konstruktoren

public constructor clsMitarbeiter -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEmail

Unterstützt von .NET Compact Framework
public property sName

Unterstützt von .NET Compact Framework
public property sTgnummer

Unterstützt von .NET Compact Framework
public property sVorname

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sEmail

Unterstützt von .NET Compact Framework
private field m_sName

Unterstützt von .NET Compact Framework
private field m_sTgnummer

Unterstützt von .NET Compact Framework
private field m_sVorname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter -Klasse


clsMitarbeiter-Eigenschaften

clsMitarbeiter Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEmail

Unterstützt von .NET Compact Framework
public property sName

Unterstützt von .NET Compact Framework
public property sTgnummer

Unterstützt von .NET Compact Framework
public property sVorname

Unterstützt von .NET Compact Framework

clsMitarbeiter -Klasse


clsMitarbeiter-Methoden

clsMitarbeiter Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMitarbeiter -Klasse


clsMitarbeiter-Felder

clsMitarbeiter Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sEmail

Unterstützt von .NET Compact Framework
private field m_sName

Unterstützt von .NET Compact Framework
private field m_sTgnummer

Unterstützt von .NET Compact Framework
private field m_sVorname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_iMitarbeiternr -Feld

[Visual Basic]
Private m_iMitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_sEmail -Feld

[Visual Basic]
Private m_sEmail As SqlString

Quellcode

[Visual Basic]
        Private 		m_sEmail, m_sVorname, m_sTgnummer, m_sName As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_sName -Feld

[Visual Basic]
Private m_sName As SqlString

Quellcode

[Visual Basic]
        Private 		m_sEmail, m_sVorname, m_sTgnummer, m_sName As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_sTgnummer -Feld

[Visual Basic]
Private m_sTgnummer As SqlString

Quellcode

[Visual Basic]
        Private 		m_sEmail, m_sVorname, m_sTgnummer, m_sName As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


m_sVorname -Feld

[Visual Basic]
Private m_sVorname As SqlString

Quellcode

[Visual Basic]
        Private 		m_sEmail, m_sVorname, m_sTgnummer, m_sName As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter


clsMitarbeiter_Auswertungsparameter -Klasse

Purpose: Data Access class for the table 'Mitarbeiter_Auswertungsparameter'.

For a list of all members of this type, see clsMitarbeiter_Auswertungsparameter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_Auswertungsparameter

[Visual Basic]
Public Class clsMitarbeiter_Auswertungsparameter
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMitarbeiter_Auswertungsparameter-Member


clsMitarbeiter_Auswertungsparameter-Member

clsMitarbeiter_Auswertungsparameter Übersicht

Öffentliche Konstruktoren

public constructor clsMitarbeiter_Auswertungsparameter -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bParamPrint

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iAuswertungnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiter_AuswertungsparameterNr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sParameterdaten

Unterstützt von .NET Compact Framework
public property sTitelzeile1

Unterstützt von .NET Compact Framework
public property sTitelzeile2

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bParamPrint

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iAuswertungnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeiter_AuswertungsparameterNr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sParameterdaten

Unterstützt von .NET Compact Framework
private field m_sTitelzeile1

Unterstützt von .NET Compact Framework
private field m_sTitelzeile2

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter_Auswertungsparameter -Klasse


clsMitarbeiter_Auswertungsparameter -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter-Eigenschaften

clsMitarbeiter_Auswertungsparameter Übersicht

Öffentliche Eigenschaften

public property bParamPrint

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iAuswertungnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiter_AuswertungsparameterNr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sParameterdaten

Unterstützt von .NET Compact Framework
public property sTitelzeile1

Unterstützt von .NET Compact Framework
public property sTitelzeile2

Unterstützt von .NET Compact Framework

clsMitarbeiter_Auswertungsparameter -Klasse


clsMitarbeiter_Auswertungsparameter.bParamPrint -Eigenschaft

[Visual Basic]
Public Property bParamPrint() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bParamPrint]() As SqlBoolean
            Get
                Return m_bParamPrint
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bParamPrint = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.iAuswertungnr -Eigenschaft

[Visual Basic]
Public Property iAuswertungnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iAuswertungnr]() As SqlInt32
            Get
                Return m_iAuswertungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuswertungnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.iMitarbeiter_AuswertungsparameterNr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiter_AuswertungsparameterNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiter_AuswertungsparameterNr]() As SqlInt32
            Get
                Return m_iMitarbeiter_AuswertungsparameterNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiter_AuswertungsparameterNrTmp As SqlInt32 = Value
                If iMitarbeiter_AuswertungsparameterNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiter_AuswertungsparameterNr", "iMitarbeiter_AuswertungsparameterNr can't be NULL")
                End If
                m_iMitarbeiter_AuswertungsparameterNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.iMitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.sParameterdaten -Eigenschaft

[Visual Basic]
Public Property sParameterdaten() As SqlString

Quellcode

[Visual Basic]
        Public Property [sParameterdaten]() As SqlString
            Get
                Return m_sParameterdaten
            End Get
            Set(ByVal Value As SqlString)
                m_sParameterdaten = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.sTitelzeile1 -Eigenschaft

[Visual Basic]
Public Property sTitelzeile1() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTitelzeile1]() As SqlString
            Get
                Return m_sTitelzeile1
            End Get
            Set(ByVal Value As SqlString)
                m_sTitelzeile1 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.sTitelzeile2 -Eigenschaft

[Visual Basic]
Public Property sTitelzeile2() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTitelzeile2]() As SqlString
            Get
                Return m_sTitelzeile2
            End Get
            Set(ByVal Value As SqlString)
                m_sTitelzeile2 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter-Methoden

clsMitarbeiter_Auswertungsparameter Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMitarbeiter_Auswertungsparameter -Klasse


clsMitarbeiter_Auswertungsparameter.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_AuswertungsparameterNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeiter_Auswertungsparameter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiter_AuswertungsparameterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_AuswertungsparameterNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeiter_Auswertungsparameter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_Auswertungsparameter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iAuswertungnr. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sParameterdaten. May be SqlString.Null</LI> <LI>sTitelzeile1. May be SqlString.Null</LI> <LI>sTitelzeile2. May be SqlString.Null</LI> <LI>bParamPrint. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iMitarbeiter_AuswertungsparameterNr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeiter_Auswertungsparameter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterdaten", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterdaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTitelzeile1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTitelzeile1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTitelzeile2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTitelzeile2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bParamPrint", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bParamPrint))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiter_AuswertungsparameterNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_AuswertungsparameterNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iMitarbeiter_AuswertungsparameterNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iMitarbeiter_AuswertungsparameterNr").Value, SqlInt32))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeiter_Auswertungsparameter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_Auswertungsparameter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeiter_Auswertungsparameter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Mitarbeiter_Auswertungsparameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeiter_Auswertungsparameter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_Auswertungsparameter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_AuswertungsparameterNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeiter_AuswertungsparameterNr</LI> <LI>iMitarbeiternr</LI> <LI>iAuswertungnr</LI> <LI>sBeschreibung</LI> <LI>sParameterdaten</LI> <LI>sTitelzeile1</LI> <LI>sTitelzeile2</LI> <LI>bParamPrint</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeiter_Auswertungsparameter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Mitarbeiter_Auswertungsparameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiter_AuswertungsparameterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_AuswertungsparameterNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeiter_Auswertungsparameter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiter_AuswertungsparameterNr = New SqlInt32(CType(dtToReturn.Rows(0)("Mitarbeiter_AuswertungsparameterNr"), Integer))
                    If dtToReturn.Rows(0)("Mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("Mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Auswertungnr") Is System.DBNull.Value Then
                        m_iAuswertungnr = SqlInt32.Null
                    Else
                        m_iAuswertungnr = New SqlInt32(CType(dtToReturn.Rows(0)("Auswertungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Parameterdaten") Is System.DBNull.Value Then
                        m_sParameterdaten = SqlString.Null
                    Else
                        m_sParameterdaten = New SqlString(CType(dtToReturn.Rows(0)("Parameterdaten"), String))
                    End If
                    If dtToReturn.Rows(0)("Titelzeile1") Is System.DBNull.Value Then
                        m_sTitelzeile1 = SqlString.Null
                    Else
                        m_sTitelzeile1 = New SqlString(CType(dtToReturn.Rows(0)("Titelzeile1"), String))
                    End If
                    If dtToReturn.Rows(0)("Titelzeile2") Is System.DBNull.Value Then
                        m_sTitelzeile2 = SqlString.Null
                    Else
                        m_sTitelzeile2 = New SqlString(CType(dtToReturn.Rows(0)("Titelzeile2"), String))
                    End If
                    If dtToReturn.Rows(0)("ParamPrint") Is System.DBNull.Value Then
                        m_bParamPrint = SqlBoolean.Null
                    Else
                        m_bParamPrint = New SqlBoolean(CType(dtToReturn.Rows(0)("ParamPrint"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_Auswertungsparameter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_AuswertungsparameterNr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iAuswertungnr. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sParameterdaten. May be SqlString.Null</LI> <LI>sTitelzeile1. May be SqlString.Null</LI> <LI>sTitelzeile2. May be SqlString.Null</LI> <LI>bParamPrint. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeiter_Auswertungsparameter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiter_AuswertungsparameterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_AuswertungsparameterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAuswertungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuswertungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterdaten", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterdaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTitelzeile1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTitelzeile1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTitelzeile2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTitelzeile2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bParamPrint", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bParamPrint))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeiter_Auswertungsparameter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_Auswertungsparameter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_Auswertungsparameter-Felder

clsMitarbeiter_Auswertungsparameter Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bParamPrint

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iAuswertungnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeiter_AuswertungsparameterNr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sParameterdaten

Unterstützt von .NET Compact Framework
private field m_sTitelzeile1

Unterstützt von .NET Compact Framework
private field m_sTitelzeile2

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter_Auswertungsparameter -Klasse


m_bParamPrint -Feld

[Visual Basic]
Private m_bParamPrint As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bParamPrint As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_iAuswertungnr -Feld

[Visual Basic]
Private m_iAuswertungnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeiter_AuswertungsparameterNr, m_iAuswertungnr, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_iMitarbeiter_AuswertungsparameterNr -Feld

[Visual Basic]
Private m_iMitarbeiter_AuswertungsparameterNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeiter_AuswertungsparameterNr, m_iAuswertungnr, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_iMitarbeiternr -Feld

[Visual Basic]
Private m_iMitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeiter_AuswertungsparameterNr, m_iAuswertungnr, m_iMitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTitelzeile2, m_sBeschreibung, m_sParameterdaten, m_sTitelzeile1 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_sParameterdaten -Feld

[Visual Basic]
Private m_sParameterdaten As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTitelzeile2, m_sBeschreibung, m_sParameterdaten, m_sTitelzeile1 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_sTitelzeile1 -Feld

[Visual Basic]
Private m_sTitelzeile1 As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTitelzeile2, m_sBeschreibung, m_sParameterdaten, m_sTitelzeile1 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


m_sTitelzeile2 -Feld

[Visual Basic]
Private m_sTitelzeile2 As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTitelzeile2, m_sBeschreibung, m_sParameterdaten, m_sTitelzeile1 As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_Auswertungsparameter


clsMitarbeiter_funktionsgruppe -Klasse

Purpose: Data Access class for the table 'mitarbeiter_funktionsgruppe'.

For a list of all members of this type, see clsMitarbeiter_funktionsgruppe-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeiter_funktionsgruppe

[Visual Basic]
Public Class clsMitarbeiter_funktionsgruppe
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMitarbeiter_funktionsgruppe-Member


clsMitarbeiter_funktionsgruppe-Member

clsMitarbeiter_funktionsgruppe Übersicht

Öffentliche Konstruktoren

public constructor clsMitarbeiter_funktionsgruppe -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMitarbeiter_funktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiter_funktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter_funktionsgruppe -Klasse


clsMitarbeiter_funktionsgruppe -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe-Eigenschaften

clsMitarbeiter_funktionsgruppe Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFunktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMitarbeiter_funktionsgruppenr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter_funktionsgruppe -Klasse


clsMitarbeiter_funktionsgruppe.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iFunktionsgruppenr -Eigenschaft

[Visual Basic]
Public Property iFunktionsgruppenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMitarbeiter_funktionsgruppenr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiter_funktionsgruppenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiter_funktionsgruppenr]() As SqlInt32
            Get
                Return m_iMitarbeiter_funktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiter_funktionsgruppenrTmp As SqlInt32 = Value
                If iMitarbeiter_funktionsgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiter_funktionsgruppenr", "iMitarbeiter_funktionsgruppenr can't be NULL")
                End If
                m_iMitarbeiter_funktionsgruppenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe-Methoden

clsMitarbeiter_funktionsgruppe Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMitarbeiter_funktionsgruppe -Klasse


clsMitarbeiter_funktionsgruppe.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr</LI> <LI>iFunktionsgruppenr</LI> <LI>bAktiv</LI> <LI>iMandantnr</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiter_funktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiter_funktionsgruppenr"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiter_funktionsgruppenr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iFunktionsgruppenr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe-Felder

clsMitarbeiter_funktionsgruppe Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFunktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiter_funktionsgruppenr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeiter_funktionsgruppe -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_iFunktionsgruppenr -Feld

[Visual Basic]
Private m_iFunktionsgruppenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_iMitarbeiter_funktionsgruppenr -Feld

[Visual Basic]
Private m_iMitarbeiter_funktionsgruppenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_iMitarbeiternr -Feld

[Visual Basic]
Private m_iMitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeiter_funktionsgruppe


clsMitarbeitereinstellung -Klasse

Purpose: Data Access class for the table 'Mitarbeitereinstellung'.

For a list of all members of this type, see clsMitarbeitereinstellung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsMitarbeitereinstellung

[Visual Basic]
Public Class clsMitarbeitereinstellung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMitarbeitereinstellung-Member


clsMitarbeitereinstellung-Member

clsMitarbeitereinstellung Übersicht

Öffentliche Konstruktoren

public constructor clsMitarbeitereinstellung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktivitaeten

Unterstützt von .NET Compact Framework
public property bApplikationsuebersicht

Unterstützt von .NET Compact Framework
public property bPendenzen

Unterstützt von .NET Compact Framework
public property bVertragsuebersicht

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeitereinstellungnr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMitarbeiternrOld

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Mitarbeiternr. This method will Update one or more existing rows in the database. It will reset the field 'Mitarbeiternr' in all rows which have as value for this field the value as set in property 'iMitarbeiternrOld' to the value as set in property 'iMitarbeiternr'.

Felder

private field m_bAktivitaeten

Unterstützt von .NET Compact Framework
private field m_bApplikationsuebersicht

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPendenzen

Unterstützt von .NET Compact Framework
private field m_bVertragsuebersicht

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeitereinstellungnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternrOld

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeitereinstellung -Klasse


clsMitarbeitereinstellung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung-Eigenschaften

clsMitarbeitereinstellung Übersicht

Öffentliche Eigenschaften

public property bAktivitaeten

Unterstützt von .NET Compact Framework
public property bApplikationsuebersicht

Unterstützt von .NET Compact Framework
public property bPendenzen

Unterstützt von .NET Compact Framework
public property bVertragsuebersicht

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeitereinstellungnr

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMitarbeiternrOld

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeitereinstellung -Klasse


clsMitarbeitereinstellung.bAktivitaeten -Eigenschaft

[Visual Basic]
Public Property bAktivitaeten() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktivitaeten]() As SqlBoolean
            Get
                Return m_bAktivitaeten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktivitaeten = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.bApplikationsuebersicht -Eigenschaft

[Visual Basic]
Public Property bApplikationsuebersicht() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bApplikationsuebersicht]() As SqlBoolean
            Get
                Return m_bApplikationsuebersicht
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bApplikationsuebersicht = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.bPendenzen -Eigenschaft

[Visual Basic]
Public Property bPendenzen() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bPendenzen]() As SqlBoolean
            Get
                Return m_bPendenzen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bPendenzen = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.bVertragsuebersicht -Eigenschaft

[Visual Basic]
Public Property bVertragsuebersicht() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bVertragsuebersicht]() As SqlBoolean
            Get
                Return m_bVertragsuebersicht
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertragsuebersicht = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.iMitarbeitereinstellungnr -Eigenschaft

[Visual Basic]
Public Property iMitarbeitereinstellungnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeitereinstellungnr]() As SqlInt32
            Get
                Return m_iMitarbeitereinstellungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeitereinstellungnrTmp As SqlInt32 = Value
                If iMitarbeitereinstellungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeitereinstellungnr", "iMitarbeitereinstellungnr can't be NULL")
                End If
                m_iMitarbeitereinstellungnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.iMitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.iMitarbeiternrOld -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternrOld]() As SqlInt32
            Get
                Return m_iMitarbeiternrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung-Methoden

clsMitarbeitereinstellung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWMitarbeiternrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Mitarbeiternr. This method will Update one or more existing rows in the database. It will reset the field 'Mitarbeiternr' in all rows which have as value for this field the value as set in property 'iMitarbeiternrOld' to the value as set in property 'iMitarbeiternr'.

clsMitarbeitereinstellung -Klasse


clsMitarbeitereinstellung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeitereinstellungnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeitereinstellungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeitereinstellungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.DeleteAllWMitarbeiternrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'

[Visual Basic]
Public Function DeleteAllWMitarbeiternrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWMitarbeiternrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_DeleteAllWMitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iMitarbeiternr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iMitarbeiternr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_DeleteAllWMitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::DeleteAllWMitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>bVertragsuebersicht. May be SqlBoolean.Null</LI> <LI>bPendenzen. May be SqlBoolean.Null</LI> <LI>bAktivitaeten. May be SqlBoolean.Null</LI> <LI>bApplikationsuebersicht. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iMitarbeitereinstellungnr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bVertragsuebersicht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bVertragsuebersicht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenzen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaeten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaeten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bApplikationsuebersicht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bApplikationsuebersicht))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeitereinstellungnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeitereinstellungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iMitarbeitereinstellungnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iMitarbeitereinstellungnr").Value, SqlInt32))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Mitarbeitereinstellung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.SelectAllWMitarbeiternrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Mitarbeiternr'

[Visual Basic]
Public Function SelectAllWMitarbeiternrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWMitarbeiternrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_SelectAllWMitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Mitarbeitereinstellung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iMitarbeiternr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iMitarbeiternr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_SelectAllWMitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::SelectAllWMitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeitereinstellungnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iMitarbeitereinstellungnr</LI> <LI>iMitarbeiternr</LI> <LI>bVertragsuebersicht</LI> <LI>bPendenzen</LI> <LI>bAktivitaeten</LI> <LI>bApplikationsuebersicht</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Mitarbeitereinstellung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeitereinstellungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeitereinstellungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeitereinstellungnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mitarbeitereinstellungnr"), Integer))
                    If dtToReturn.Rows(0)("Mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("Mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Vertragsuebersicht") Is System.DBNull.Value Then
                        m_bVertragsuebersicht = SqlBoolean.Null
                    Else
                        m_bVertragsuebersicht = New SqlBoolean(CType(dtToReturn.Rows(0)("Vertragsuebersicht"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Pendenzen") Is System.DBNull.Value Then
                        m_bPendenzen = SqlBoolean.Null
                    Else
                        m_bPendenzen = New SqlBoolean(CType(dtToReturn.Rows(0)("Pendenzen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aktivitaeten") Is System.DBNull.Value Then
                        m_bAktivitaeten = SqlBoolean.Null
                    Else
                        m_bAktivitaeten = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktivitaeten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Applikationsuebersicht") Is System.DBNull.Value Then
                        m_bApplikationsuebersicht = SqlBoolean.Null
                    Else
                        m_bApplikationsuebersicht = New SqlBoolean(CType(dtToReturn.Rows(0)("Applikationsuebersicht"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeitereinstellungnr</LI> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>bVertragsuebersicht. May be SqlBoolean.Null</LI> <LI>bPendenzen. May be SqlBoolean.Null</LI> <LI>bAktivitaeten. May be SqlBoolean.Null</LI> <LI>bApplikationsuebersicht. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeitereinstellungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeitereinstellungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bVertragsuebersicht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bVertragsuebersicht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenzen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktivitaeten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktivitaeten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bApplikationsuebersicht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bApplikationsuebersicht))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung.UpdateAllWMitarbeiternrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'Mitarbeiternr. This method will Update one or more existing rows in the database. It will reset the field 'Mitarbeiternr' in all rows which have as value for this field the value as set in property 'iMitarbeiternrOld' to the value as set in property 'iMitarbeiternr'.

[Visual Basic]
Public Function UpdateAllWMitarbeiternrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr. May be SqlInt32.Null</LI> <LI>iMitarbeiternrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWMitarbeiternrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Mitarbeitereinstellung_UpdateAllWMitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iMitarbeiternrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iMitarbeiternr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iMitarbeiternr").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Mitarbeitereinstellung_UpdateAllWMitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeitereinstellung::UpdateAllWMitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMitarbeitereinstellung-Felder

clsMitarbeitereinstellung Übersicht

Felder

private field m_bAktivitaeten

Unterstützt von .NET Compact Framework
private field m_bApplikationsuebersicht

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPendenzen

Unterstützt von .NET Compact Framework
private field m_bVertragsuebersicht

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeitereinstellungnr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternrOld

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMitarbeitereinstellung -Klasse


m_bAktivitaeten -Feld

[Visual Basic]
Private m_bAktivitaeten As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bPendenzen, m_bAktivitaeten, m_bApplikationsuebersicht, m_bVertragsuebersicht As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_bApplikationsuebersicht -Feld

[Visual Basic]
Private m_bApplikationsuebersicht As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bPendenzen, m_bAktivitaeten, m_bApplikationsuebersicht, m_bVertragsuebersicht As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_bPendenzen -Feld

[Visual Basic]
Private m_bPendenzen As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bPendenzen, m_bAktivitaeten, m_bApplikationsuebersicht, m_bVertragsuebersicht As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_bVertragsuebersicht -Feld

[Visual Basic]
Private m_bVertragsuebersicht As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bPendenzen, m_bAktivitaeten, m_bApplikationsuebersicht, m_bVertragsuebersicht As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_iMitarbeitereinstellungnr -Feld

[Visual Basic]
Private m_iMitarbeitereinstellungnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeitereinstellungnr, m_iMitarbeiternr, m_iMitarbeiternrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_iMitarbeiternr -Feld

[Visual Basic]
Private m_iMitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeitereinstellungnr, m_iMitarbeiternr, m_iMitarbeiternrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


m_iMitarbeiternrOld -Feld

[Visual Basic]
Private m_iMitarbeiternrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMitarbeitereinstellungnr, m_iMitarbeiternr, m_iMitarbeiternrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMitarbeitereinstellung


clsMyKey_Tabelle -Klasse

For a list of all members of this type, see clsMyKey_Tabelle-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle
Vertragsverwaltung.TKB.VV.DB.clsMyKey_Tabelle

[Visual Basic]
Public Class clsMyKey_Tabelle
    Inherits clsKey_tabelle

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMyKey_Tabelle-Member


clsMyKey_Tabelle-Member

clsMyKey_Tabelle Übersicht

Öffentliche Konstruktoren

public constructor clsMyKey_Tabelle -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKey_wert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iKeynr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method get_dbkey Unterstützt von .NET Compact Framework |

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMyKey_Tabelle -Klasse


clsMyKey_Tabelle-Eigenschaften

clsMyKey_Tabelle Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKey_wert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iKeynr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMyKey_Tabelle -Klasse


clsMyKey_Tabelle-Methoden

clsMyKey_Tabelle Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKey_tabelle) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method get_dbkey Unterstützt von .NET Compact Framework |

clsMyKey_Tabelle -Klasse


clsMyKey_Tabelle.get_dbkey -Methode

[Visual Basic]
Public Function get_dbkey( _
   ByVal Tablename As String _
) As Long

Parameter

Tablename

Quellcode

[Visual Basic]
        Public Function get_dbkey(ByVal Tablename As String) As Long
            Dim m_dbkey As Long
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_dbkey]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Tablename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dbkey", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_dbkey))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                Try
                    scmCmdToExecute.Connection.Open()
                Catch ex As Exception
                Finally
                End Try

                scmCmdToExecute.ExecuteNonQuery()
                m_dbkey = scmCmdToExecute.Parameters.Item("@dbkey").Value
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))
                scmCmdToExecute.Connection.Close()

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_get_dbkey' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return m_dbkey
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::get_dbkey::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyKey_Tabelle


clsMyKey_Tabelle-Felder

clsMyKey_Tabelle Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMyKey_Tabelle -Klasse


clsPendenz -Klasse

Purpose: Data Access class for the table 'Pendenz'.

For a list of all members of this type, see clsPendenz-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPendenz
Vertragsverwaltung.TKB.VV.Vertrag.clsPendenz

[Visual Basic]
Public Class clsPendenz
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPendenz-Member


clsPendenz-Member

clsPendenz Übersicht

Öffentliche Konstruktoren

public constructor clsPendenz -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daTermin

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPendenzNr

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVerantwortlich

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daTermin

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPendenzNr

Unterstützt von .NET Compact Framework
private field m_iPendenzStatusNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sVerantwortlich

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


clsPendenz -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz-Eigenschaften

clsPendenz Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daTermin

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPendenzNr

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVerantwortlich

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


clsPendenz.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.daTermin -Eigenschaft

[Visual Basic]
Public Property daTermin() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daTermin]() As SqlDateTime
            Get
                Return m_daTermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTermin = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iPendenzNr -Eigenschaft

[Visual Basic]
Public Property iPendenzNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPendenzNr]() As SqlInt32
            Get
                Return m_iPendenzNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPendenzNrTmp As SqlInt32 = Value
                If iPendenzNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPendenzNr", "iPendenzNr can't be NULL")
                End If
                m_iPendenzNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iPendenzStatusNr -Eigenschaft

[Visual Basic]
Public Property iPendenzStatusNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPendenzStatusNr]() As SqlInt32
            Get
                Return m_iPendenzStatusNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPendenzStatusNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.iVertragselementNr -Eigenschaft

[Visual Basic]
Public Property iVertragselementNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.sVerantwortlich -Eigenschaft

[Visual Basic]
Public Property sVerantwortlich() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVerantwortlich]() As SqlString
            Get
                Return m_sVerantwortlich
            End Get
            Set(ByVal Value As SqlString)
                m_sVerantwortlich = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz-Methoden

clsPendenz Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsPendenz -Klasse


clsPendenz.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenz_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenz_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenz::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVerantwortlich. May be SqlString.Null</LI> <LI>iPendenzStatusNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>daTermin. May be SqlDateTime.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenz_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVerantwortlich", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenz_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenz::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenz_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Pendenz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenz_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenz::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iPendenzNr</LI> <LI>iVertragselementNr</LI> <LI>sVerantwortlich</LI> <LI>iPendenzStatusNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>daTermin</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenz_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Pendenz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iPendenzNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenz_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPendenzNr = New SqlInt32(CType(dtToReturn.Rows(0)("PendenzNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Verantwortlich") Is System.DBNull.Value Then
                        m_sVerantwortlich = SqlString.Null
                    Else
                        m_sVerantwortlich = New SqlString(CType(dtToReturn.Rows(0)("Verantwortlich"), String))
                    End If
                    If dtToReturn.Rows(0)("PendenzStatusNr") Is System.DBNull.Value Then
                        m_iPendenzStatusNr = SqlInt32.Null
                    Else
                        m_iPendenzStatusNr = New SqlInt32(CType(dtToReturn.Rows(0)("PendenzStatusNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Termin") Is System.DBNull.Value Then
                        m_daTermin = SqlDateTime.Null
                    Else
                        m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("Termin"), Date))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenz::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>sVerantwortlich. May be SqlString.Null</LI> <LI>iPendenzStatusNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>daTermin. May be SqlDateTime.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenz_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVerantwortlich", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenz_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenz::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz-Felder

clsPendenz Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daTermin

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPendenzNr

Unterstützt von .NET Compact Framework
private field m_iPendenzStatusNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sVerantwortlich

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daTermin As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daTermin As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_daTermin -Feld

[Visual Basic]
Private m_daTermin As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am, m_daTermin As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iPendenzNr -Feld

[Visual Basic]
Private m_iPendenzNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iPendenzStatusNr -Feld

[Visual Basic]
Private m_iPendenzStatusNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_iVertragselementNr -Feld

[Visual Basic]
Private m_iVertragselementNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iSecurityLevelNr, m_iMandantNr, m_iVertragselementNr, m_iPendenzStatusNr, m_iPendenzNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sVerantwortlich, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sVerantwortlich, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


m_sVerantwortlich -Feld

[Visual Basic]
Private m_sVerantwortlich As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sVerantwortlich, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenzstatus -Klasse

Purpose: Data Access class for the table 'Pendenzstatus'.

For a list of all members of this type, see clsPendenzstatus-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPendenzstatus

[Visual Basic]
Public Class clsPendenzstatus
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPendenzstatus-Member


clsPendenzstatus-Member

clsPendenzstatus Übersicht

Öffentliche Konstruktoren

public constructor clsPendenzstatus -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bPendenz_Aktivieren

Unterstützt von .NET Compact Framework
public property bPendenz_Inaktivieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPendenz_Aktivieren

Unterstützt von .NET Compact Framework
private field m_bPendenz_Inaktivieren

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPendenzStatusNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenzstatus -Klasse


clsPendenzstatus -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus-Eigenschaften

clsPendenzstatus Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bPendenz_Aktivieren

Unterstützt von .NET Compact Framework
public property bPendenz_Inaktivieren

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenzstatus -Klasse


clsPendenzstatus.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.bPendenz_Aktivieren -Eigenschaft

[Visual Basic]
Public Property bPendenz_Aktivieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bPendenz_Aktivieren]() As SqlBoolean
            Get
                Return m_bPendenz_Aktivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bPendenz_Aktivieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.bPendenz_Inaktivieren -Eigenschaft

[Visual Basic]
Public Property bPendenz_Inaktivieren() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bPendenz_Inaktivieren]() As SqlBoolean
            Get
                Return m_bPendenz_Inaktivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bPendenz_Inaktivieren = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.iPendenzStatusNr -Eigenschaft

[Visual Basic]
Public Property iPendenzStatusNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPendenzStatusNr]() As SqlInt32
            Get
                Return m_iPendenzStatusNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPendenzStatusNrTmp As SqlInt32 = Value
                If iPendenzStatusNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPendenzStatusNr", "iPendenzStatusNr can't be NULL")
                End If
                m_iPendenzStatusNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus-Methoden

clsPendenzstatus Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsPendenzstatus -Klasse


clsPendenzstatus.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzStatusNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenzstatus_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenzstatus_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenzstatus::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzStatusNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bPendenz_Aktivieren. May be SqlBoolean.Null</LI> <LI>bPendenz_Inaktivieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenzstatus_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenz_Aktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenz_Aktivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenz_Inaktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenz_Inaktivieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenzstatus_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenzstatus::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenzstatus_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Pendenzstatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenzstatus_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenzstatus::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzStatusNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iPendenzStatusNr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>bPendenz_Aktivieren</LI> <LI>bPendenz_Inaktivieren</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenzstatus_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Pendenzstatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenzstatus_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPendenzStatusNr = New SqlInt32(CType(dtToReturn.Rows(0)("PendenzStatusNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Pendenz_Aktivieren") Is System.DBNull.Value Then
                        m_bPendenz_Aktivieren = SqlBoolean.Null
                    Else
                        m_bPendenz_Aktivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Pendenz_Aktivieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Pendenz_Inaktivieren") Is System.DBNull.Value Then
                        m_bPendenz_Inaktivieren = SqlBoolean.Null
                    Else
                        m_bPendenz_Inaktivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("Pendenz_Inaktivieren"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenzstatus::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPendenzStatusNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bPendenz_Aktivieren. May be SqlBoolean.Null</LI> <LI>bPendenz_Inaktivieren. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Pendenzstatus_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPendenzStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPendenzStatusNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenz_Aktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenz_Aktivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bPendenz_Inaktivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bPendenz_Inaktivieren))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Pendenzstatus_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPendenzstatus::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPendenzstatus-Felder

clsPendenzstatus Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bPendenz_Aktivieren

Unterstützt von .NET Compact Framework
private field m_bPendenz_Inaktivieren

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPendenzStatusNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenzstatus -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bPendenz_Aktivieren, m_bPendenz_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_bPendenz_Aktivieren -Feld

[Visual Basic]
Private m_bPendenz_Aktivieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bPendenz_Aktivieren, m_bPendenz_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_bPendenz_Inaktivieren -Feld

[Visual Basic]
Private m_bPendenz_Inaktivieren As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bPendenz_Aktivieren, m_bPendenz_Inaktivieren As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPendenzStatusNr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPendenzStatusNr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_iPendenzStatusNr -Feld

[Visual Basic]
Private m_iPendenzStatusNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPendenzStatusNr, m_iMandantnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzstatus


clsPerson -Klasse

Purpose: Data Access class for the table 'Person'.

For a list of all members of this type, see clsPerson-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.Vertrag.clsPersonen

[Visual Basic]
Public Class clsPerson
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPerson-Member


clsPerson-Member

clsPerson Übersicht

Öffentliche Konstruktoren

public constructor clsPerson -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragspartnernr

Unterstützt von .NET Compact Framework
public property iVertragspartnernrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail

Unterstützt von .NET Compact Framework
public property sInternet

Unterstützt von .NET Compact Framework
public property sName

Unterstützt von .NET Compact Framework
public property sOrt

Unterstützt von .NET Compact Framework
public property sPlz

Unterstützt von .NET Compact Framework
public property sPostfach

Unterstützt von .NET Compact Framework
public property sStrasse

Unterstützt von .NET Compact Framework
public property sTelefax

Unterstützt von .NET Compact Framework
public property sTelefon

Unterstützt von .NET Compact Framework
public property sVorname

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragspartnernr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragspartnernr' in all rows which have as value for this field the value as set in property 'iVertragspartnernrOld' to the value as set in property 'iVertragspartnernr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonFunktionNr

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnernr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnernrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sEMail

Unterstützt von .NET Compact Framework
private field m_sInternet

Unterstützt von .NET Compact Framework
private field m_sName

Unterstützt von .NET Compact Framework
private field m_sOrt

Unterstützt von .NET Compact Framework
private field m_sPlz

Unterstützt von .NET Compact Framework
private field m_sPostfach

Unterstützt von .NET Compact Framework
private field m_sStrasse

Unterstützt von .NET Compact Framework
private field m_sTelefax

Unterstützt von .NET Compact Framework
private field m_sTelefon

Unterstützt von .NET Compact Framework
private field m_sVorname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPerson -Klasse


clsPerson -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson-Eigenschaften

clsPerson Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragspartnernr

Unterstützt von .NET Compact Framework
public property iVertragspartnernrOld

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail

Unterstützt von .NET Compact Framework
public property sInternet

Unterstützt von .NET Compact Framework
public property sName

Unterstützt von .NET Compact Framework
public property sOrt

Unterstützt von .NET Compact Framework
public property sPlz

Unterstützt von .NET Compact Framework
public property sPostfach

Unterstützt von .NET Compact Framework
public property sStrasse

Unterstützt von .NET Compact Framework
public property sTelefax

Unterstützt von .NET Compact Framework
public property sTelefon

Unterstützt von .NET Compact Framework
public property sVorname

Unterstützt von .NET Compact Framework

clsPerson -Klasse


clsPerson.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iPersonFunktionNr -Eigenschaft

[Visual Basic]
Public Property iPersonFunktionNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonFunktionNr]() As SqlInt32
            Get
                Return m_iPersonFunktionNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonFunktionNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iPersonNr -Eigenschaft

[Visual Basic]
Public Property iPersonNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPersonNrTmp As SqlInt32 = Value
                If iPersonNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPersonNr", "iPersonNr can't be NULL")
                End If
                m_iPersonNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iVertragspartnernr -Eigenschaft

[Visual Basic]
Public Property iVertragspartnernr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragspartnernr]() As SqlInt32
            Get
                Return m_iVertragspartnernr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnernr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.iVertragspartnernrOld -Eigenschaft

[Visual Basic]
Public Property iVertragspartnernrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragspartnernrOld]() As SqlInt32
            Get
                Return m_iVertragspartnernrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnernrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sEMail -Eigenschaft

[Visual Basic]
Public Property sEMail() As SqlString

Quellcode

[Visual Basic]
        Public Property [sEMail]() As SqlString
            Get
                Return m_sEMail
            End Get
            Set(ByVal Value As SqlString)
                m_sEMail = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sInternet -Eigenschaft

[Visual Basic]
Public Property sInternet() As SqlString

Quellcode

[Visual Basic]
        Public Property [sInternet]() As SqlString
            Get
                Return m_sInternet
            End Get
            Set(ByVal Value As SqlString)
                m_sInternet = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sName -Eigenschaft

[Visual Basic]
Public Property sName() As SqlString

Quellcode

[Visual Basic]
        Public Property [sName]() As SqlString
            Get
                Return m_sName
            End Get
            Set(ByVal Value As SqlString)
                m_sName = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sOrt -Eigenschaft

[Visual Basic]
Public Property sOrt() As SqlString

Quellcode

[Visual Basic]
        Public Property [sOrt]() As SqlString
            Get
                Return m_sOrt
            End Get
            Set(ByVal Value As SqlString)
                m_sOrt = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sPlz -Eigenschaft

[Visual Basic]
Public Property sPlz() As SqlString

Quellcode

[Visual Basic]
        Public Property [sPlz]() As SqlString
            Get
                Return m_sPlz
            End Get
            Set(ByVal Value As SqlString)
                m_sPlz = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sPostfach -Eigenschaft

[Visual Basic]
Public Property sPostfach() As SqlString

Quellcode

[Visual Basic]
        Public Property [sPostfach]() As SqlString
            Get
                Return m_sPostfach
            End Get
            Set(ByVal Value As SqlString)
                m_sPostfach = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sStrasse -Eigenschaft

[Visual Basic]
Public Property sStrasse() As SqlString

Quellcode

[Visual Basic]
        Public Property [sStrasse]() As SqlString
            Get
                Return m_sStrasse
            End Get
            Set(ByVal Value As SqlString)
                m_sStrasse = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sTelefax -Eigenschaft

[Visual Basic]
Public Property sTelefax() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTelefax]() As SqlString
            Get
                Return m_sTelefax
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefax = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sTelefon -Eigenschaft

[Visual Basic]
Public Property sTelefon() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.sVorname -Eigenschaft

[Visual Basic]
Public Property sVorname() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVorname]() As SqlString
            Get
                Return m_sVorname
            End Get
            Set(ByVal Value As SqlString)
                m_sVorname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson-Methoden

clsPerson Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnernrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragspartnernr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragspartnernr' in all rows which have as value for this field the value as set in property 'iVertragspartnernrOld' to the value as set in property 'iVertragspartnernr'.

clsPerson -Klasse


clsPerson.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.DeleteAllWVertragspartnernrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'

[Visual Basic]
Public Function DeleteAllWVertragspartnernrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragspartnernrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_DeleteAllWVertragspartnernrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragspartnernr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnernr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_DeleteAllWVertragspartnernrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::DeleteAllWVertragspartnernrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonNr</LI> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPlz. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iPersonFunktionNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPlz", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Person")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.SelectAllWVertragspartnernrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'

[Visual Basic]
Public Function SelectAllWVertragspartnernrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragspartnernrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_SelectAllWVertragspartnernrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Person")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragspartnernr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnernr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_SelectAllWVertragspartnernrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::SelectAllWVertragspartnernrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iPersonNr</LI> <LI>iVertragspartnernr</LI> <LI>sName</LI> <LI>sVorname</LI> <LI>sStrasse</LI> <LI>sPostfach</LI> <LI>sPlz</LI> <LI>sOrt</LI> <LI>sTelefon</LI> <LI>sTelefax</LI> <LI>sEMail</LI> <LI>sInternet</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> <LI>iSecurityLevelNr</LI> <LI>iPersonFunktionNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Person")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    If dtToReturn.Rows(0)("Vertragspartnernr") Is System.DBNull.Value Then
                        m_iVertragspartnernr = SqlInt32.Null
                    Else
                        m_iVertragspartnernr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragspartnernr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Name") Is System.DBNull.Value Then
                        m_sName = SqlString.Null
                    Else
                        m_sName = New SqlString(CType(dtToReturn.Rows(0)("Name"), String))
                    End If
                    If dtToReturn.Rows(0)("Vorname") Is System.DBNull.Value Then
                        m_sVorname = SqlString.Null
                    Else
                        m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("Vorname"), String))
                    End If
                    If dtToReturn.Rows(0)("Strasse") Is System.DBNull.Value Then
                        m_sStrasse = SqlString.Null
                    Else
                        m_sStrasse = New SqlString(CType(dtToReturn.Rows(0)("Strasse"), String))
                    End If
                    If dtToReturn.Rows(0)("Postfach") Is System.DBNull.Value Then
                        m_sPostfach = SqlString.Null
                    Else
                        m_sPostfach = New SqlString(CType(dtToReturn.Rows(0)("Postfach"), String))
                    End If
                    If dtToReturn.Rows(0)("Plz") Is System.DBNull.Value Then
                        m_sPlz = SqlString.Null
                    Else
                        m_sPlz = New SqlString(CType(dtToReturn.Rows(0)("Plz"), String))
                    End If
                    If dtToReturn.Rows(0)("Ort") Is System.DBNull.Value Then
                        m_sOrt = SqlString.Null
                    Else
                        m_sOrt = New SqlString(CType(dtToReturn.Rows(0)("Ort"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("Telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefax") Is System.DBNull.Value Then
                        m_sTelefax = SqlString.Null
                    Else
                        m_sTelefax = New SqlString(CType(dtToReturn.Rows(0)("Telefax"), String))
                    End If
                    If dtToReturn.Rows(0)("EMail") Is System.DBNull.Value Then
                        m_sEMail = SqlString.Null
                    Else
                        m_sEMail = New SqlString(CType(dtToReturn.Rows(0)("EMail"), String))
                    End If
                    If dtToReturn.Rows(0)("Internet") Is System.DBNull.Value Then
                        m_sInternet = SqlString.Null
                    Else
                        m_sInternet = New SqlString(CType(dtToReturn.Rows(0)("Internet"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PersonFunktionNr") Is System.DBNull.Value Then
                        m_iPersonFunktionNr = SqlInt32.Null
                    Else
                        m_iPersonFunktionNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonFunktionNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonNr</LI> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> <LI>sName. May be SqlString.Null</LI> <LI>sVorname. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPlz. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iPersonFunktionNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPlz", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson.UpdateAllWVertragspartnernrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragspartnernr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragspartnernr' in all rows which have as value for this field the value as set in property 'iVertragspartnernrOld' to the value as set in property 'iVertragspartnernr'.

[Visual Basic]
Public Function UpdateAllWVertragspartnernrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnernr. May be SqlInt32.Null</LI> <LI>iVertragspartnernrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragspartnernrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Person_UpdateAllWVertragspartnernrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnernrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnernrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragspartnernr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnernr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Person_UpdateAllWVertragspartnernrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPerson::UpdateAllWVertragspartnernrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPerson-Felder

clsPerson Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonFunktionNr

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnernr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnernrOld

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sEMail

Unterstützt von .NET Compact Framework
private field m_sInternet

Unterstützt von .NET Compact Framework
private field m_sName

Unterstützt von .NET Compact Framework
private field m_sOrt

Unterstützt von .NET Compact Framework
private field m_sPlz

Unterstützt von .NET Compact Framework
private field m_sPostfach

Unterstützt von .NET Compact Framework
private field m_sStrasse

Unterstützt von .NET Compact Framework
private field m_sTelefax

Unterstützt von .NET Compact Framework
private field m_sTelefon

Unterstützt von .NET Compact Framework
private field m_sVorname

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPerson -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iPersonFunktionNr -Feld

[Visual Basic]
Private m_iPersonFunktionNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iPersonNr -Feld

[Visual Basic]
Private m_iPersonNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iVertragspartnernr -Feld

[Visual Basic]
Private m_iVertragspartnernr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_iVertragspartnernrOld -Feld

[Visual Basic]
Private m_iVertragspartnernrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iPersonFunktionNr, m_iMandantNr, m_iMutierer, m_iSecurityLevelNr, m_iPersonNr, m_iVertragspartnernr, m_iVertragspartnernrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sEMail -Feld

[Visual Basic]
Private m_sEMail As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sInternet -Feld

[Visual Basic]
Private m_sInternet As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sName -Feld

[Visual Basic]
Private m_sName As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sOrt -Feld

[Visual Basic]
Private m_sOrt As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sPlz -Feld

[Visual Basic]
Private m_sPlz As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sPostfach -Feld

[Visual Basic]
Private m_sPostfach As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sStrasse -Feld

[Visual Basic]
Private m_sStrasse As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sTelefax -Feld

[Visual Basic]
Private m_sTelefax As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sTelefon -Feld

[Visual Basic]
Private m_sTelefon As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


m_sVorname -Feld

[Visual Basic]
Private m_sVorname As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVorname, m_sStrasse, m_sTelefax, m_sName, m_sPostfach, m_sPlz, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPerson


clsPersonFunktion -Klasse

Purpose: Data Access class for the table 'PersonFunktion'.

For a list of all members of this type, see clsPersonFunktion-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPersonFunktion

[Visual Basic]
Public Class clsPersonFunktion
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPersonFunktion-Member


clsPersonFunktion-Member

clsPersonFunktion Übersicht

Öffentliche Konstruktoren

public constructor clsPersonFunktion -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonFunktionNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPersonFunktion -Klasse


clsPersonFunktion -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion-Eigenschaften

clsPersonFunktion Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPersonFunktion -Klasse


clsPersonFunktion.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.iPersonFunktionNr -Eigenschaft

[Visual Basic]
Public Property iPersonFunktionNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonFunktionNr]() As SqlInt32
            Get
                Return m_iPersonFunktionNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPersonFunktionNrTmp As SqlInt32 = Value
                If iPersonFunktionNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPersonFunktionNr", "iPersonFunktionNr can't be NULL")
                End If
                m_iPersonFunktionNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion-Methoden

clsPersonFunktion Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsPersonFunktion -Klasse


clsPersonFunktion.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonFunktionNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PersonFunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PersonFunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPersonFunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonFunktionNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PersonFunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PersonFunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPersonFunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PersonFunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("PersonFunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PersonFunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPersonFunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonFunktionNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iPersonFunktionNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PersonFunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("PersonFunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PersonFunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPersonFunktionNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonFunktionNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPersonFunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iPersonFunktionNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PersonFunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonFunktionNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPersonFunktionNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PersonFunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPersonFunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsPersonFunktion-Felder

clsPersonFunktion Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonFunktionNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPersonFunktion -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iPersonFunktionNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_iPersonFunktionNr -Feld

[Visual Basic]
Private m_iPersonFunktionNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iPersonFunktionNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonFunktion


clsProfil -Klasse

Purpose: Data Access class for the table 'Profil'.

For a list of all members of this type, see clsProfil-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsProfil
Vertragsverwaltung.TKB.VV.Utils.clsProfile

[Visual Basic]
Public Class clsProfil
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsProfil-Member


clsProfil-Member

clsProfil Übersicht

Öffentliche Konstruktoren

public constructor clsProfil -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bSelektionsart

Unterstützt von .NET Compact Framework
public property bStandard

Unterstützt von .NET Compact Framework
public property bV_Aktiv_Vertragspartner

Unterstützt von .NET Compact Framework
public property bV_Struktur_Details

Unterstützt von .NET Compact Framework
public property blobV_Uebersicht

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iProfilnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sV_Aktiv_Vertragselemente

Unterstützt von .NET Compact Framework
public property sV_Register

Unterstützt von .NET Compact Framework
public property sV_Sort

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bSelektionsart

Unterstützt von .NET Compact Framework
private field m_bStandard

Unterstützt von .NET Compact Framework
private field m_bV_Aktiv_Vertragspartner

Unterstützt von .NET Compact Framework
private field m_bV_Struktur_Details

Unterstützt von .NET Compact Framework
private field m_blobV_Uebersicht

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iProfilnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sV_Aktiv_Vertragselemente

Unterstützt von .NET Compact Framework
private field m_sV_Register

Unterstützt von .NET Compact Framework
private field m_sV_Sort

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsProfil -Klasse


clsProfil -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil-Eigenschaften

clsProfil Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bSelektionsart

Unterstützt von .NET Compact Framework
public property bStandard

Unterstützt von .NET Compact Framework
public property bV_Aktiv_Vertragspartner

Unterstützt von .NET Compact Framework
public property bV_Struktur_Details

Unterstützt von .NET Compact Framework
public property blobV_Uebersicht

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iProfilnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sV_Aktiv_Vertragselemente

Unterstützt von .NET Compact Framework
public property sV_Register

Unterstützt von .NET Compact Framework
public property sV_Sort

Unterstützt von .NET Compact Framework

clsProfil -Klasse


clsProfil.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.bSelektionsart -Eigenschaft

[Visual Basic]
Public Property bSelektionsart() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bSelektionsart]() As SqlBoolean
            Get
                Return m_bSelektionsart
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSelektionsart = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.bStandard -Eigenschaft

[Visual Basic]
Public Property bStandard() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bStandard]() As SqlBoolean
            Get
                Return m_bStandard
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bStandard = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.bV_Aktiv_Vertragspartner -Eigenschaft

[Visual Basic]
Public Property bV_Aktiv_Vertragspartner() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bV_Aktiv_Vertragspartner]() As SqlBoolean
            Get
                Return m_bV_Aktiv_Vertragspartner
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bV_Aktiv_Vertragspartner = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.bV_Struktur_Details -Eigenschaft

[Visual Basic]
Public Property bV_Struktur_Details() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bV_Struktur_Details]() As SqlBoolean
            Get
                Return m_bV_Struktur_Details
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bV_Struktur_Details = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.blobV_Uebersicht -Eigenschaft

[Visual Basic]
Public Property blobV_Uebersicht() As SqlBinary

Quellcode

[Visual Basic]
        Public Property [blobV_Uebersicht]() As SqlBinary
            Get
                Return m_blobV_Uebersicht
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobV_Uebersicht = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.iMitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iMitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.iProfilnr -Eigenschaft

[Visual Basic]
Public Property iProfilnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iProfilnr]() As SqlInt32
            Get
                Return m_iProfilnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iProfilnrTmp As SqlInt32 = Value
                If iProfilnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iProfilnr", "iProfilnr can't be NULL")
                End If
                m_iProfilnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.sV_Aktiv_Vertragselemente -Eigenschaft

[Visual Basic]
Public Property sV_Aktiv_Vertragselemente() As SqlString

Quellcode

[Visual Basic]
        Public Property [sV_Aktiv_Vertragselemente]() As SqlString
            Get
                Return m_sV_Aktiv_Vertragselemente
            End Get
            Set(ByVal Value As SqlString)
                m_sV_Aktiv_Vertragselemente = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.sV_Register -Eigenschaft

[Visual Basic]
Public Property sV_Register() As SqlString

Quellcode

[Visual Basic]
        Public Property [sV_Register]() As SqlString
            Get
                Return m_sV_Register
            End Get
            Set(ByVal Value As SqlString)
                m_sV_Register = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.sV_Sort -Eigenschaft

[Visual Basic]
Public Property sV_Sort() As SqlString

Quellcode

[Visual Basic]
        Public Property [sV_Sort]() As SqlString
            Get
                Return m_sV_Sort
            End Get
            Set(ByVal Value As SqlString)
                m_sV_Sort = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil-Methoden

clsProfil Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsProfil -Klasse


clsProfil.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iProfilnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Profil_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Profil_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iMitarbeiternr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>blobV_Uebersicht. May be SqlBinary.Null</LI> <LI>sV_Aktiv_Vertragselemente. May be SqlString.Null</LI> <LI>bV_Aktiv_Vertragspartner. May be SqlBoolean.Null</LI> <LI>bV_Struktur_Details. May be SqlBoolean.Null</LI> <LI>bSelektionsart. May be SqlBoolean.Null</LI> <LI>bStandard. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>sV_Sort. May be SqlString.Null</LI> <LI>sV_Register. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iProfilnr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Profil_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                Dim	iLength As Integer = 0
                If Not m_blobV_Uebersicht.IsNull Then
                    iLength = m_blobV_Uebersicht.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobV_Uebersicht", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobV_Uebersicht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Aktiv_Vertragselemente", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Aktiv_Vertragselemente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bV_Aktiv_Vertragspartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bV_Aktiv_Vertragspartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bV_Struktur_Details", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bV_Struktur_Details))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSelektionsart", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bSelektionsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bStandard", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Sort", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Sort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Register", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Register))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iProfilnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iProfilnr").Value, SqlInt32))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Profil_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Profil_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Profil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Profil_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iProfilnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iProfilnr</LI> <LI>iMitarbeiternr</LI> <LI>sBezeichnung</LI> <LI>blobV_Uebersicht</LI> <LI>sV_Aktiv_Vertragselemente</LI> <LI>bV_Aktiv_Vertragspartner</LI> <LI>bV_Struktur_Details</LI> <LI>bSelektionsart</LI> <LI>bStandard</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> <LI>sV_Sort</LI> <LI>sV_Register</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Profil_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Profil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Profil_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iProfilnr = New SqlInt32(CType(dtToReturn.Rows(0)("Profilnr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("Mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("V_Uebersicht") Is System.DBNull.Value Then
                        m_blobV_Uebersicht = SqlBinary.Null
                    Else
                        m_blobV_Uebersicht = New SqlBinary(CType(dtToReturn.Rows(0)("V_Uebersicht"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("V_Aktiv_Vertragselemente") Is System.DBNull.Value Then
                        m_sV_Aktiv_Vertragselemente = SqlString.Null
                    Else
                        m_sV_Aktiv_Vertragselemente = New SqlString(CType(dtToReturn.Rows(0)("V_Aktiv_Vertragselemente"), String))
                    End If
                    If dtToReturn.Rows(0)("V_Aktiv_Vertragspartner") Is System.DBNull.Value Then
                        m_bV_Aktiv_Vertragspartner = SqlBoolean.Null
                    Else
                        m_bV_Aktiv_Vertragspartner = New SqlBoolean(CType(dtToReturn.Rows(0)("V_Aktiv_Vertragspartner"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("V_Struktur_Details") Is System.DBNull.Value Then
                        m_bV_Struktur_Details = SqlBoolean.Null
                    Else
                        m_bV_Struktur_Details = New SqlBoolean(CType(dtToReturn.Rows(0)("V_Struktur_Details"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Selektionsart") Is System.DBNull.Value Then
                        m_bSelektionsart = SqlBoolean.Null
                    Else
                        m_bSelektionsart = New SqlBoolean(CType(dtToReturn.Rows(0)("Selektionsart"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Standard") Is System.DBNull.Value Then
                        m_bStandard = SqlBoolean.Null
                    Else
                        m_bStandard = New SqlBoolean(CType(dtToReturn.Rows(0)("Standard"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("V_Sort") Is System.DBNull.Value Then
                        m_sV_Sort = SqlString.Null
                    Else
                        m_sV_Sort = New SqlString(CType(dtToReturn.Rows(0)("V_Sort"), String))
                    End If
                    If dtToReturn.Rows(0)("V_Register") Is System.DBNull.Value Then
                        m_sV_Register = SqlString.Null
                    Else
                        m_sV_Register = New SqlString(CType(dtToReturn.Rows(0)("V_Register"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iProfilnr</LI> <LI>iMitarbeiternr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>blobV_Uebersicht. May be SqlBinary.Null</LI> <LI>sV_Aktiv_Vertragselemente. May be SqlString.Null</LI> <LI>bV_Aktiv_Vertragspartner. May be SqlBoolean.Null</LI> <LI>bV_Struktur_Details. May be SqlBoolean.Null</LI> <LI>bSelektionsart. May be SqlBoolean.Null</LI> <LI>bStandard. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>sV_Sort. May be SqlString.Null</LI> <LI>sV_Register. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Profil_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                Dim	iLength As Integer = 0
                If Not m_blobV_Uebersicht.IsNull Then
                    iLength = m_blobV_Uebersicht.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobV_Uebersicht", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobV_Uebersicht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Aktiv_Vertragselemente", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Aktiv_Vertragselemente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bV_Aktiv_Vertragspartner", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bV_Aktiv_Vertragspartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bV_Struktur_Details", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bV_Struktur_Details))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSelektionsart", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bSelektionsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bStandard", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Sort", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Sort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sV_Register", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sV_Register))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Profil_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsProfil-Felder

clsProfil Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bSelektionsart

Unterstützt von .NET Compact Framework
private field m_bStandard

Unterstützt von .NET Compact Framework
private field m_bV_Aktiv_Vertragspartner

Unterstützt von .NET Compact Framework
private field m_bV_Struktur_Details

Unterstützt von .NET Compact Framework
private field m_blobV_Uebersicht

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMitarbeiternr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iProfilnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sV_Aktiv_Vertragselemente

Unterstützt von .NET Compact Framework
private field m_sV_Register

Unterstützt von .NET Compact Framework
private field m_sV_Sort

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsProfil -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bStandard, m_bV_Aktiv_Vertragspartner, m_bV_Struktur_Details, m_bSelektionsart, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_bSelektionsart -Feld

[Visual Basic]
Private m_bSelektionsart As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bStandard, m_bV_Aktiv_Vertragspartner, m_bV_Struktur_Details, m_bSelektionsart, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_bStandard -Feld

[Visual Basic]
Private m_bStandard As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bStandard, m_bV_Aktiv_Vertragspartner, m_bV_Struktur_Details, m_bSelektionsart, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_bV_Aktiv_Vertragspartner -Feld

[Visual Basic]
Private m_bV_Aktiv_Vertragspartner As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bStandard, m_bV_Aktiv_Vertragspartner, m_bV_Struktur_Details, m_bSelektionsart, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_bV_Struktur_Details -Feld

[Visual Basic]
Private m_bV_Struktur_Details As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bStandard, m_bV_Aktiv_Vertragspartner, m_bV_Struktur_Details, m_bSelektionsart, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_blobV_Uebersicht -Feld

[Visual Basic]
Private m_blobV_Uebersicht As SqlBinary

Quellcode

[Visual Basic]
        Private 		m_blobV_Uebersicht As SqlBinary

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_iMitarbeiternr -Feld

[Visual Basic]
Private m_iMitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iProfilnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iProfilnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_iProfilnr -Feld

[Visual Basic]
Private m_iProfilnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iProfilnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sV_Register, m_sV_Sort, m_sV_Aktiv_Vertragselemente, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_sV_Aktiv_Vertragselemente -Feld

[Visual Basic]
Private m_sV_Aktiv_Vertragselemente As SqlString

Quellcode

[Visual Basic]
        Private 		m_sV_Register, m_sV_Sort, m_sV_Aktiv_Vertragselemente, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_sV_Register -Feld

[Visual Basic]
Private m_sV_Register As SqlString

Quellcode

[Visual Basic]
        Private 		m_sV_Register, m_sV_Sort, m_sV_Aktiv_Vertragselemente, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


m_sV_Sort -Feld

[Visual Basic]
Private m_sV_Sort As SqlString

Quellcode

[Visual Basic]
        Private 		m_sV_Register, m_sV_Sort, m_sV_Aktiv_Vertragselemente, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfil


clsReleaseArt -Klasse

Purpose: Data Access class for the table 'ReleaseArt'.

For a list of all members of this type, see clsReleaseArt-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsReleaseArt

[Visual Basic]
Public Class clsReleaseArt
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsReleaseArt-Member


clsReleaseArt-Member

clsReleaseArt Übersicht

Öffentliche Konstruktoren

public constructor clsReleaseArt -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReleaseartnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReleaseartnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsReleaseArt -Klasse


clsReleaseArt -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt-Eigenschaften

clsReleaseArt Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReleaseartnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsReleaseArt -Klasse


clsReleaseArt.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.iReleaseartnr -Eigenschaft

[Visual Basic]
Public Property iReleaseartnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReleaseartnr]() As SqlInt32
            Get
                Return m_iReleaseartnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReleaseartnrTmp As SqlInt32 = Value
                If iReleaseartnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReleaseartnr", "iReleaseartnr can't be NULL")
                End If
                m_iReleaseartnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt-Methoden

clsReleaseArt Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsReleaseArt -Klasse


clsReleaseArt.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReleaseartnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReleaseArt_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReleaseArt_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReleaseArt::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReleaseartnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReleaseArt_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReleaseArt_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReleaseArt::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReleaseArt_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ReleaseArt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReleaseArt_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReleaseArt::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReleaseartnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iReleaseartnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReleaseArt_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ReleaseArt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReleaseArt_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReleaseartnr = New SqlInt32(CType(dtToReturn.Rows(0)("Releaseartnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReleaseArt::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReleaseartnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReleaseArt_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReleaseartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReleaseartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReleaseArt_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReleaseArt::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsReleaseArt-Felder

clsReleaseArt Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReleaseartnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsReleaseArt -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReleaseartnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_iReleaseartnr -Feld

[Visual Basic]
Private m_iReleaseartnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iReleaseartnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReleaseArt


clsRfcBoard -Klasse

Purpose: Data Access class for the table 'RfcBoard'.

For a list of all members of this type, see clsRfcBoard-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRfcBoard

[Visual Basic]
Public Class clsRfcBoard
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRfcBoard-Member


clsRfcBoard-Member

clsRfcBoard Übersicht

Öffentliche Konstruktoren

public constructor clsRfcBoard -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard -Klasse


clsRfcBoard -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard-Eigenschaften

clsRfcBoard Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard -Klasse


clsRfcBoard.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.iRfcBoardNr -Eigenschaft

[Visual Basic]
Public Property iRfcBoardNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRfcBoardNr]() As SqlInt32
            Get
                Return m_iRfcBoardNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRfcBoardNrTmp As SqlInt32 = Value
                If iRfcBoardNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRfcBoardNr", "iRfcBoardNr can't be NULL")
                End If
                m_iRfcBoardNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard-Methoden

clsRfcBoard Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsRfcBoard -Klasse


clsRfcBoard.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRfcBoardNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRfcBoardNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("RfcBoard")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRfcBoardNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRfcBoardNr</LI> <LI>sBezeichnung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("RfcBoard")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRfcBoardNr = New SqlInt32(CType(dtToReturn.Rows(0)("RfcBoardNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRfcBoardNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard-Felder

clsRfcBoard Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


m_iRfcBoardNr -Feld

[Visual Basic]
Private m_iRfcBoardNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard


clsRfcBoard_Mitarbeiter -Klasse

Purpose: Data Access class for the table 'RfcBoard_Mitarbeiter'.

For a list of all members of this type, see clsRfcBoard_Mitarbeiter-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRfcBoard_Mitarbeiter

[Visual Basic]
Public Class clsRfcBoard_Mitarbeiter
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRfcBoard_Mitarbeiter-Member


clsRfcBoard_Mitarbeiter-Member

clsRfcBoard_Mitarbeiter Übersicht

Öffentliche Konstruktoren

public constructor clsRfcBoard_Mitarbeiter -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bLeiter

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonnr

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRfcBoard_Mitarbeiternr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bLeiter

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonnr

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
private field m_iRfcBoard_Mitarbeiternr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard_Mitarbeiter -Klasse


clsRfcBoard_Mitarbeiter -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter-Eigenschaften

clsRfcBoard_Mitarbeiter Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bLeiter

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonnr

Unterstützt von .NET Compact Framework
public property iRfcBoardNr

Unterstützt von .NET Compact Framework
public property iRfcBoard_Mitarbeiternr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard_Mitarbeiter -Klasse


clsRfcBoard_Mitarbeiter.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.bLeiter -Eigenschaft

[Visual Basic]
Public Property bLeiter() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bLeiter]() As SqlBoolean
            Get
                Return m_bLeiter
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bLeiter = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.iPersonnr -Eigenschaft

[Visual Basic]
Public Property iPersonnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonnr]() As SqlInt32
            Get
                Return m_iPersonnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.iRfcBoardNr -Eigenschaft

[Visual Basic]
Public Property iRfcBoardNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRfcBoardNr]() As SqlInt32
            Get
                Return m_iRfcBoardNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRfcBoardNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.iRfcBoard_Mitarbeiternr -Eigenschaft

[Visual Basic]
Public Property iRfcBoard_Mitarbeiternr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRfcBoard_Mitarbeiternr]() As SqlInt32
            Get
                Return m_iRfcBoard_Mitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRfcBoard_Mitarbeiternr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter-Methoden

clsRfcBoard_Mitarbeiter Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |

clsRfcBoard_Mitarbeiter -Klasse


clsRfcBoard_Mitarbeiter.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRfcBoard_Mitarbeiternr. May be SqlInt32.Null</LI> <LI>iRfcBoardNr. May be SqlInt32.Null</LI> <LI>iPersonnr. May be SqlInt32.Null</LI> <LI>bLeiter. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_Mitarbeiter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoard_Mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoard_Mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRfcBoardNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRfcBoardNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bLeiter", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bLeiter))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_Mitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard_Mitarbeiter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_RfcBoard_Mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("RfcBoard_Mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_RfcBoard_Mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRfcBoard_Mitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRfcBoard_Mitarbeiter-Felder

clsRfcBoard_Mitarbeiter Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bLeiter

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonnr

Unterstützt von .NET Compact Framework
private field m_iRfcBoardNr

Unterstützt von .NET Compact Framework
private field m_iRfcBoard_Mitarbeiternr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRfcBoard_Mitarbeiter -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bLeiter As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_bLeiter -Feld

[Visual Basic]
Private m_bLeiter As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bLeiter As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr, m_iPersonnr, m_iRfcBoard_Mitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_iPersonnr -Feld

[Visual Basic]
Private m_iPersonnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr, m_iPersonnr, m_iRfcBoard_Mitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_iRfcBoardNr -Feld

[Visual Basic]
Private m_iRfcBoardNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr, m_iPersonnr, m_iRfcBoard_Mitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


m_iRfcBoard_Mitarbeiternr -Feld

[Visual Basic]
Private m_iRfcBoard_Mitarbeiternr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRfcBoardNr, m_iPersonnr, m_iRfcBoard_Mitarbeiternr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRfcBoard_Mitarbeiter


clsRolle -Klasse

Purpose: Data Access class for the table 'rolle'.

For a list of all members of this type, see clsRolle-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle

[Visual Basic]
Public Class clsRolle
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRolle-Member


clsRolle-Member

clsRolle Übersicht

Öffentliche Konstruktoren

public constructor clsRolle -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bSysadminrolle

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bSysadminrolle

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle -Klasse


clsRolle -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle-Eigenschaften

clsRolle Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bSysadminrolle

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle -Klasse


clsRolle.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.bSysadminrolle -Eigenschaft

[Visual Basic]
Public Property bSysadminrolle() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bSysadminrolle]() As SqlBoolean
            Get
                Return m_bSysadminrolle
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSysadminrolle = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.iRollenr -Eigenschaft

[Visual Basic]
Public Property iRollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRollenrTmp As SqlInt32 = Value
                If iRollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRollenr", "iRollenr can't be NULL")
                End If
                m_iRollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle-Methoden

clsRolle Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsRolle -Klasse


clsRolle.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRollenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bSysadminrolle. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsysadminrolle", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSysadminrolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRollenr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRollenr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bSysadminrolle</LI> <LI>iMandantnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("sysadminrolle") Is System.DBNull.Value Then
                        m_bSysadminrolle = SqlBoolean.Null
                    Else
                        m_bSysadminrolle = New SqlBoolean(CType(dtToReturn.Rows(0)("sysadminrolle"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRollenr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bSysadminrolle. May be SqlBoolean.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsysadminrolle", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSysadminrolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle-Felder

clsRolle Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bSysadminrolle

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bSysadminrolle, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_bSysadminrolle -Feld

[Visual Basic]
Private m_bSysadminrolle As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bSysadminrolle, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_iRollenr -Feld

[Visual Basic]
Private m_iRollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle


clsRolle_SecurityObject -Klasse

Purpose: Data Access class for the table 'Rolle_SecurityObject'.

For a list of all members of this type, see clsRolle_SecurityObject-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_SecurityObject

[Visual Basic]
Public Class clsRolle_SecurityObject
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRolle_SecurityObject-Member


clsRolle_SecurityObject-Member

clsRolle_SecurityObject Übersicht

Öffentliche Konstruktoren

public constructor clsRolle_SecurityObject -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bInvisible

Unterstützt von .NET Compact Framework
public property bReadonly

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_securityobjectnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityobjectnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bInvisible

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bReadonly

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_securityobjectnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityobjectnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_SecurityObject -Klasse


clsRolle_SecurityObject -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject-Eigenschaften

clsRolle_SecurityObject Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bInvisible

Unterstützt von .NET Compact Framework
public property bReadonly

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_securityobjectnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityobjectnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_SecurityObject -Klasse


clsRolle_SecurityObject.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.bInvisible -Eigenschaft

[Visual Basic]
Public Property bInvisible() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bInvisible]() As SqlBoolean
            Get
                Return m_bInvisible
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInvisible = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.bReadonly -Eigenschaft

[Visual Basic]
Public Property bReadonly() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bReadonly]() As SqlBoolean
            Get
                Return m_bReadonly
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bReadonly = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.iRolle_securityobjectnr -Eigenschaft

[Visual Basic]
Public Property iRolle_securityobjectnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRolle_securityobjectnr]() As SqlInt32
            Get
                Return m_iRolle_securityobjectnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_securityobjectnrTmp As SqlInt32 = Value
                If iRolle_securityobjectnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_securityobjectnr", "iRolle_securityobjectnr can't be NULL")
                End If
                m_iRolle_securityobjectnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.iRollenr -Eigenschaft

[Visual Basic]
Public Property iRollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.iSecurityobjectnr -Eigenschaft

[Visual Basic]
Public Property iSecurityobjectnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityobjectnr]() As SqlInt32
            Get
                Return m_iSecurityobjectnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityobjectnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject-Methoden

clsRolle_SecurityObject Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsRolle_SecurityObject -Klasse


clsRolle_SecurityObject.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityobjectnr. May be SqlInt32.Null</LI> <LI>bReadonly. May be SqlBoolean.Null</LI> <LI>bInvisible. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isecurityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@breadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binvisible", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInvisible))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Rolle_SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr</LI> <LI>iSecurityobjectnr</LI> <LI>bReadonly</LI> <LI>bInvisible</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Rolle_SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_securityobjectnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_securityobjectnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("securityobjectnr") Is System.DBNull.Value Then
                        m_iSecurityobjectnr = SqlInt32.Null
                    Else
                        m_iSecurityobjectnr = New SqlInt32(CType(dtToReturn.Rows(0)("securityobjectnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("readonly") Is System.DBNull.Value Then
                        m_bReadonly = SqlBoolean.Null
                    Else
                        m_bReadonly = New SqlBoolean(CType(dtToReturn.Rows(0)("readonly"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("invisible") Is System.DBNull.Value Then
                        m_bInvisible = SqlBoolean.Null
                    Else
                        m_bInvisible = New SqlBoolean(CType(dtToReturn.Rows(0)("invisible"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securityobjectnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityobjectnr. May be SqlInt32.Null</LI> <LI>bReadonly. May be SqlBoolean.Null</LI> <LI>bInvisible. May be SqlBoolean.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Rolle_SecurityObject_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isecurityobjectnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityobjectnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@breadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binvisible", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInvisible))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Rolle_SecurityObject_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_SecurityObject::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_SecurityObject-Felder

clsRolle_SecurityObject Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bInvisible

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bReadonly

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_securityobjectnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityobjectnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_SecurityObject -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_bInvisible -Feld

[Visual Basic]
Private m_bInvisible As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_bReadonly -Feld

[Visual Basic]
Private m_bReadonly As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAktiv, m_bInvisible As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_iRolle_securityobjectnr -Feld

[Visual Basic]
Private m_iRolle_securityobjectnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_iRollenr -Feld

[Visual Basic]
Private m_iRollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


m_iSecurityobjectnr -Feld

[Visual Basic]
Private m_iSecurityobjectnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityobjectnr, m_iRolle_securityobjectnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_SecurityObject


clsRolle_securitylevel -Klasse

Purpose: Data Access class for the table 'rolle_securitylevel'.

For a list of all members of this type, see clsRolle_securitylevel-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_securitylevel

[Visual Basic]
Public Class clsRolle_securitylevel
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRolle_securitylevel-Member


clsRolle_securitylevel-Member

clsRolle_securitylevel Übersicht

Öffentliche Konstruktoren

public constructor clsRolle_securitylevel -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_securitylevelnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_securitylevelnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_securitylevel -Klasse


clsRolle_securitylevel -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel-Eigenschaften

clsRolle_securitylevel Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_securitylevelnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_securitylevel -Klasse


clsRolle_securitylevel.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.iRolle_securitylevelnr -Eigenschaft

[Visual Basic]
Public Property iRolle_securitylevelnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRolle_securitylevelnr]() As SqlInt32
            Get
                Return m_iRolle_securitylevelnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_securitylevelnrTmp As SqlInt32 = Value
                If iRolle_securitylevelnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_securitylevelnr", "iRolle_securitylevelnr can't be NULL")
                End If
                m_iRolle_securitylevelnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.iRollenr -Eigenschaft

[Visual Basic]
Public Property iRollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel-Methoden

clsRolle_securitylevel Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsRolle_securitylevel -Klasse


clsRolle_securitylevel.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_securitylevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_securitylevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_securitylevelnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_securitylevelnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_securitylevelnr</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_securitylevel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_securitylevelnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_securitylevelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_securitylevel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_securitylevel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_securitylevel-Felder

clsRolle_securitylevel Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_securitylevelnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_securitylevel -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_iRolle_securitylevelnr -Feld

[Visual Basic]
Private m_iRolle_securitylevelnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_iRollenr -Feld

[Visual Basic]
Private m_iRollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iRollenr, m_iSecurityLevelNr, m_iRolle_securitylevelnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_securitylevel


clsRolle_sysadminfunktion -Klasse

Purpose: Data Access class for the table 'rolle_sysadminfunktion'.

For a list of all members of this type, see clsRolle_sysadminfunktion-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsRolle_sysadminfunktion

[Visual Basic]
Public Class clsRolle_sysadminfunktion
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsRolle_sysadminfunktion-Member


clsRolle_sysadminfunktion-Member

clsRolle_sysadminfunktion Übersicht

Öffentliche Konstruktoren

public constructor clsRolle_sysadminfunktion -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandant

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_sysadminfnktnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandant

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_sysadminfnktnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSysadminfnktnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_sysadminfunktion -Klasse


clsRolle_sysadminfunktion -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion-Eigenschaften

clsRolle_sysadminfunktion Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandant

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRolle_sysadminfnktnr

Unterstützt von .NET Compact Framework
public property iRollenr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_sysadminfunktion -Klasse


clsRolle_sysadminfunktion.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iMandant -Eigenschaft

[Visual Basic]
Public Property iMandant() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandant]() As SqlInt32
            Get
                Return m_iMandant
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandant = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iRolle_sysadminfnktnr -Eigenschaft

[Visual Basic]
Public Property iRolle_sysadminfnktnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRolle_sysadminfnktnr]() As SqlInt32
            Get
                Return m_iRolle_sysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_sysadminfnktnrTmp As SqlInt32 = Value
                If iRolle_sysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_sysadminfnktnr", "iRolle_sysadminfnktnr can't be NULL")
                End If
                m_iRolle_sysadminfnktnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iRollenr -Eigenschaft

[Visual Basic]
Public Property iRollenr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iSysadminfnktnr -Eigenschaft

[Visual Basic]
Public Property iSysadminfnktnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSysadminfnktnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion-Methoden

clsRolle_sysadminfunktion Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsRolle_sysadminfunktion -Klasse


clsRolle_sysadminfunktion.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSysadminfnktnr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandant. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iSysadminfnktnr</LI> <LI>iRollenr</LI> <LI>iMandant</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_sysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sysadminfnktnr") Is System.DBNull.Value Then
                        m_iSysadminfnktnr = SqlInt32.Null
                    Else
                        m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandant") Is System.DBNull.Value Then
                        m_iMandant = SqlInt32.Null
                    Else
                        m_iMandant = New SqlInt32(CType(dtToReturn.Rows(0)("mandant"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iRolle_sysadminfnktnr</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iSysadminfnktnr. May be SqlInt32.Null</LI> <LI>iRollenr. May be SqlInt32.Null</LI> <LI>iMandant. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion-Felder

clsRolle_sysadminfunktion Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandant

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iRolle_sysadminfnktnr

Unterstützt von .NET Compact Framework
private field m_iRollenr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSysadminfnktnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsRolle_sysadminfunktion -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_iMandant -Feld

[Visual Basic]
Private m_iMandant As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_iRolle_sysadminfnktnr -Feld

[Visual Basic]
Private m_iRolle_sysadminfnktnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_iRollenr -Feld

[Visual Basic]
Private m_iRollenr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


m_iSysadminfnktnr -Feld

[Visual Basic]
Private m_iSysadminfnktnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iRollenr, m_iMandant, m_iSysadminfnktnr, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsRolle_sysadminfunktion


clsSLA -Klasse

Purpose: Data Access class for the table 'SLA'.

For a list of all members of this type, see clsSLA-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLA
Vertragsverwaltung.TKB.VV.SLA.clsSLA

[Visual Basic]
Public Class clsSLA
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLA-Member


clsSLA-Member

clsSLA Übersicht

Öffentliche Konstruktoren

public constructor clsSLA -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLANr

Unterstützt von .NET Compact Framework
public property iSLASubTypNr

Unterstützt von .NET Compact Framework
public property iSLATypNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLANr

Unterstützt von .NET Compact Framework
private field m_iSLASubTypNr

Unterstützt von .NET Compact Framework
private field m_iSLATypNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


clsSLA -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA-Eigenschaften

clsSLA Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLANr

Unterstützt von .NET Compact Framework
public property iSLASubTypNr

Unterstützt von .NET Compact Framework
public property iSLATypNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


clsSLA.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.iSLANr -Eigenschaft

[Visual Basic]
Public Property iSLANr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLANr]() As SqlInt32
            Get
                Return m_iSLANr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLANrTmp As SqlInt32 = Value
                If iSLANrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLANr", "iSLANr can't be NULL")
                End If
                m_iSLANr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.iSLASubTypNr -Eigenschaft

[Visual Basic]
Public Property iSLASubTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLASubTypNr]() As SqlInt32
            Get
                Return m_iSLASubTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLASubTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.iSLATypNr -Eigenschaft

[Visual Basic]
Public Property iSLATypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLATypNr]() As SqlInt32
            Get
                Return m_iSLATypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLATypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA-Methoden

clsSLA Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSLA -Klasse


clsSLA.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLANr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLA_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLA_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLA::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLANr</LI> <LI>iSLATypNr. May be SqlInt32.Null</LI> <LI>iSLASubTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLA_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLA_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLA::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLA_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLA")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLA_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLA::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLANr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLANr</LI> <LI>iSLATypNr</LI> <LI>iSLASubTypNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLA_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLA")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLA_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLANr = New SqlInt32(CType(dtToReturn.Rows(0)("SLANr"), Integer))
                    If dtToReturn.Rows(0)("SLATypNr") Is System.DBNull.Value Then
                        m_iSLATypNr = SqlInt32.Null
                    Else
                        m_iSLATypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLATypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SLASubTypNr") Is System.DBNull.Value Then
                        m_iSLASubTypNr = SqlInt32.Null
                    Else
                        m_iSLASubTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLASubTypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLA::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLANr</LI> <LI>iSLATypNr. May be SqlInt32.Null</LI> <LI>iSLASubTypNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLA_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLA_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLA::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLA-Felder

clsSLA Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLANr

Unterstützt von .NET Compact Framework
private field m_iSLASubTypNr

Unterstützt von .NET Compact Framework
private field m_iSLATypNr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iSLATypNr, m_iSLASubTypNr, m_iSLANr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iSLATypNr, m_iSLASubTypNr, m_iSLANr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_iSLANr -Feld

[Visual Basic]
Private m_iSLANr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iSLATypNr, m_iSLASubTypNr, m_iSLANr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_iSLASubTypNr -Feld

[Visual Basic]
Private m_iSLASubTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iSLATypNr, m_iSLASubTypNr, m_iSLANr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


m_iSLATypNr -Feld

[Visual Basic]
Private m_iSLATypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantNr, m_iSLATypNr, m_iSLASubTypNr, m_iSLANr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsSLAKatalog -Klasse

Purpose: Data Access class for the table 'SLAKatalog'.

For a list of all members of this type, see clsSLAKatalog-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLAKatalog

[Visual Basic]
Public Class clsSLAKatalog
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLAKatalog-Member


clsSLAKatalog-Member

clsSLAKatalog Übersicht

Öffentliche Konstruktoren

public constructor clsSLAKatalog -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property fZeit

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLAKatalogNr

Unterstützt von .NET Compact Framework
public property iSLANr

Unterstützt von .NET Compact Framework
public property iSecurityLevel

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_fZeit

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLAKatalogNr

Unterstützt von .NET Compact Framework
private field m_iSLANr

Unterstützt von .NET Compact Framework
private field m_iSecurityLevel

Unterstützt von .NET Compact Framework
private field m_iZeiteinheittypnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLAKatalog -Klasse


clsSLAKatalog -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog-Eigenschaften

clsSLAKatalog Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property fZeit

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLAKatalogNr

Unterstützt von .NET Compact Framework
public property iSLANr

Unterstützt von .NET Compact Framework
public property iSecurityLevel

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLAKatalog -Klasse


clsSLAKatalog.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.fZeit -Eigenschaft

[Visual Basic]
Public Property fZeit() As SqlDouble

Quellcode

[Visual Basic]
        Public Property [fZeit]() As SqlDouble
            Get
                Return m_fZeit
            End Get
            Set(ByVal Value As SqlDouble)
                m_fZeit = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iSLAKatalogNr -Eigenschaft

[Visual Basic]
Public Property iSLAKatalogNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLAKatalogNr]() As SqlInt32
            Get
                Return m_iSLAKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLAKatalogNrTmp As SqlInt32 = Value
                If iSLAKatalogNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLAKatalogNr", "iSLAKatalogNr can't be NULL")
                End If
                m_iSLAKatalogNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iSLANr -Eigenschaft

[Visual Basic]
Public Property iSLANr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLANr]() As SqlInt32
            Get
                Return m_iSLANr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLANr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iSecurityLevel -Eigenschaft

[Visual Basic]
Public Property iSecurityLevel() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevel]() As SqlInt32
            Get
                Return m_iSecurityLevel
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevel = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.iZeiteinheittypnr -Eigenschaft

[Visual Basic]
Public Property iZeiteinheittypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iZeiteinheittypnr]() As SqlInt32
            Get
                Return m_iZeiteinheittypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZeiteinheittypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog-Methoden

clsSLAKatalog Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSLAKatalog -Klasse


clsSLAKatalog.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> <LI>iSLANr. May be SqlInt32.Null</LI> <LI>fZeit. May be SqlDouble.Null</LI> <LI>iZeiteinheittypnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevel. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fZeit", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fZeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevel))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLAKatalogNr</LI> <LI>iSLANr</LI> <LI>fZeit</LI> <LI>iZeiteinheittypnr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevel</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLAKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLAKatalogNr"), Integer))
                    If dtToReturn.Rows(0)("SLANr") Is System.DBNull.Value Then
                        m_iSLANr = SqlInt32.Null
                    Else
                        m_iSLANr = New SqlInt32(CType(dtToReturn.Rows(0)("SLANr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Zeit") Is System.DBNull.Value Then
                        m_fZeit = SqlDouble.Null
                    Else
                        m_fZeit = New SqlDouble(CType(dtToReturn.Rows(0)("Zeit"), Double))
                    End If
                    If dtToReturn.Rows(0)("Zeiteinheittypnr") Is System.DBNull.Value Then
                        m_iZeiteinheittypnr = SqlInt32.Null
                    Else
                        m_iZeiteinheittypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Zeiteinheittypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevel") Is System.DBNull.Value Then
                        m_iSecurityLevel = SqlInt32.Null
                    Else
                        m_iSecurityLevel = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevel"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLAKatalogNr</LI> <LI>iSLANr. May be SqlInt32.Null</LI> <LI>fZeit. May be SqlDouble.Null</LI> <LI>iZeiteinheittypnr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevel. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLAKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLANr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLANr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fZeit", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fZeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevel))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLAKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLAKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLAKatalog-Felder

clsSLAKatalog Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_fZeit

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLAKatalogNr

Unterstützt von .NET Compact Framework
private field m_iSLANr

Unterstützt von .NET Compact Framework
private field m_iSecurityLevel

Unterstützt von .NET Compact Framework
private field m_iZeiteinheittypnr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLAKatalog -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_fZeit -Feld

[Visual Basic]
Private m_fZeit As SqlDouble

Quellcode

[Visual Basic]
        Private 		m_fZeit As SqlDouble

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iSLAKatalogNr -Feld

[Visual Basic]
Private m_iSLAKatalogNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iSLANr -Feld

[Visual Basic]
Private m_iSLANr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iSecurityLevel -Feld

[Visual Basic]
Private m_iSecurityLevel As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


m_iZeiteinheittypnr -Feld

[Visual Basic]
Private m_iZeiteinheittypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevel, m_iMutierer, m_iSLANr, m_iZeiteinheittypnr, m_iSLAKatalogNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalog


clsSLASubTyp -Klasse

Purpose: Data Access class for the table 'SLASubTyp'.

For a list of all members of this type, see clsSLASubTyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLASubTyp

[Visual Basic]
Public Class clsSLASubTyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLASubTyp-Member


clsSLASubTyp-Member

clsSLASubTyp Übersicht

Öffentliche Konstruktoren

public constructor clsSLASubTyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLASubTypNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLASubTypNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLASubTyp -Klasse


clsSLASubTyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp-Eigenschaften

clsSLASubTyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLASubTypNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLASubTyp -Klasse


clsSLASubTyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.iSLASubTypNr -Eigenschaft

[Visual Basic]
Public Property iSLASubTypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLASubTypNr]() As SqlInt32
            Get
                Return m_iSLASubTypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLASubTypNrTmp As SqlInt32 = Value
                If iSLASubTypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLASubTypNr", "iSLASubTypNr can't be NULL")
                End If
                m_iSLASubTypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp-Methoden

clsSLASubTyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSLASubTyp -Klasse


clsSLASubTyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLASubTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLASubTyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLASubTyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLASubTyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLASubTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLASubTyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLASubTyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLASubTyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLASubTyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLASubTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLASubTyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLASubTyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLASubTypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLASubTypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLASubTyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLASubTyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLASubTyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLASubTypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLASubTypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLASubTyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLASubTypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLASubTyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLASubTypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLASubTypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLASubTyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLASubTyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLASubTyp-Felder

clsSLASubTyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLASubTypNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLASubTyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLASubTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLASubTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_iSLASubTypNr -Feld

[Visual Basic]
Private m_iSLASubTypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLASubTypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLASubTyp


clsSLATyp -Klasse

Purpose: Data Access class for the table 'SLATyp'.

For a list of all members of this type, see clsSLATyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.mySLATyp

[Visual Basic]
Public Class clsSLATyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLATyp-Member


clsSLATyp-Member

clsSLATyp Übersicht

Öffentliche Konstruktoren

public constructor clsSLATyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLATypNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLATypNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLATyp -Klasse


clsSLATyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp-Eigenschaften

clsSLATyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLATypNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLATyp -Klasse


clsSLATyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.iSLATypNr -Eigenschaft

[Visual Basic]
Public Property iSLATypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLATypNr]() As SqlInt32
            Get
                Return m_iSLATypNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSLATypNrTmp As SqlInt32 = Value
                If iSLATypNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSLATypNr", "iSLATypNr can't be NULL")
                End If
                m_iSLATypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp-Methoden

clsSLATyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSLATyp -Klasse


clsSLATyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLATypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLATypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLATypNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSLATypNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSLATypNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLATypNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSLATypNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLATypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSLATypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSLATyp-Felder

clsSLATyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLATypNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLATyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_iSLATypNr -Feld

[Visual Basic]
Private m_iSLATypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSLATypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLATyp


clsSecurityLevel -Klasse

Purpose: Data Access class for the table 'SecurityLevel'.

For a list of all members of this type, see clsSecurityLevel-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSecurityLevel

[Visual Basic]
Public Class clsSecurityLevel
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSecurityLevel-Member


clsSecurityLevel-Member

clsSecurityLevel Übersicht

Öffentliche Konstruktoren

public constructor clsSecurityLevel -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSecurityLevel -Klasse


clsSecurityLevel -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel-Eigenschaften

clsSecurityLevel Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSecurityLevel -Klasse


clsSecurityLevel.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSecurityLevelNrTmp As SqlInt32 = Value
                If iSecurityLevelNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSecurityLevelNr", "iSecurityLevelNr can't be NULL")
                End If
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel-Methoden

clsSecurityLevel Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSecurityLevel -Klasse


clsSecurityLevel.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityLevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityLevel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityLevelNr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityLevel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityLevel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityLevel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityLevel-Felder

clsSecurityLevel Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSecurityLevel -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSecurityLevelNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityLevel


clsSecurityObject -Klasse

Purpose: Data Access class for the table 'SecurityObject'.

For a list of all members of this type, see clsSecurityObject-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSecurityObject

[Visual Basic]
Public Class clsSecurityObject
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSecurityObject-Member


clsSecurityObject-Member

clsSecurityObject Übersicht

Öffentliche Konstruktoren

public constructor clsSecurityObject -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLevel

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityObjectNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSecurityForm

Unterstützt von .NET Compact Framework
public property sSecurityObject

Unterstützt von .NET Compact Framework
public property sSecurityObjectDescriotion

Unterstützt von .NET Compact Framework
public property sSecurityObjectItem

Unterstützt von .NET Compact Framework
public property sSecurityObjectType

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLevel

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityObjectNr

Unterstützt von .NET Compact Framework
private field m_sSecurityForm

Unterstützt von .NET Compact Framework
private field m_sSecurityObject

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectDescriotion

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectItem

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectType

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSecurityObject -Klasse


clsSecurityObject -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject-Eigenschaften

clsSecurityObject Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLevel

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityObjectNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSecurityForm

Unterstützt von .NET Compact Framework
public property sSecurityObject

Unterstützt von .NET Compact Framework
public property sSecurityObjectDescriotion

Unterstützt von .NET Compact Framework
public property sSecurityObjectItem

Unterstützt von .NET Compact Framework
public property sSecurityObjectType

Unterstützt von .NET Compact Framework

clsSecurityObject -Klasse


clsSecurityObject.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.iLevel -Eigenschaft

[Visual Basic]
Public Property iLevel() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLevel]() As SqlInt32
            Get
                Return m_iLevel
            End Get
            Set(ByVal Value As SqlInt32)
                m_iLevel = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.iSecurityObjectNr -Eigenschaft

[Visual Basic]
Public Property iSecurityObjectNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityObjectNr]() As SqlInt32
            Get
                Return m_iSecurityObjectNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSecurityObjectNrTmp As SqlInt32 = Value
                If iSecurityObjectNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSecurityObjectNr", "iSecurityObjectNr can't be NULL")
                End If
                m_iSecurityObjectNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.sSecurityForm -Eigenschaft

[Visual Basic]
Public Property sSecurityForm() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSecurityForm]() As SqlString
            Get
                Return m_sSecurityForm
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityForm = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.sSecurityObject -Eigenschaft

[Visual Basic]
Public Property sSecurityObject() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSecurityObject]() As SqlString
            Get
                Return m_sSecurityObject
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObject = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.sSecurityObjectDescriotion -Eigenschaft

[Visual Basic]
Public Property sSecurityObjectDescriotion() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSecurityObjectDescriotion]() As SqlString
            Get
                Return m_sSecurityObjectDescriotion
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectDescriotion = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.sSecurityObjectItem -Eigenschaft

[Visual Basic]
Public Property sSecurityObjectItem() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSecurityObjectItem]() As SqlString
            Get
                Return m_sSecurityObjectItem
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectItem = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.sSecurityObjectType -Eigenschaft

[Visual Basic]
Public Property sSecurityObjectType() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSecurityObjectType]() As SqlString
            Get
                Return m_sSecurityObjectType
            End Get
            Set(ByVal Value As SqlString)
                m_sSecurityObjectType = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject-Methoden

clsSecurityObject Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSecurityObject -Klasse


clsSecurityObject.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm. May be SqlString.Null</LI> <LI>sSecurityObjectType. May be SqlString.Null</LI> <LI>sSecurityObject. May be SqlString.Null</LI> <LI>sSecurityObjectItem. May be SqlString.Null</LI> <LI>sSecurityObjectDescriotion. May be SqlString.Null</LI> <LI>iLevel. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityForm", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityForm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectItem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectDescriotion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectDescriotion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLevel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm</LI> <LI>sSecurityObjectType</LI> <LI>sSecurityObject</LI> <LI>sSecurityObjectItem</LI> <LI>sSecurityObjectDescriotion</LI> <LI>iLevel</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("SecurityObject")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSecurityObjectNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityObjectNr"), Integer))
                    If dtToReturn.Rows(0)("SecurityForm") Is System.DBNull.Value Then
                        m_sSecurityForm = SqlString.Null
                    Else
                        m_sSecurityForm = New SqlString(CType(dtToReturn.Rows(0)("SecurityForm"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectType") Is System.DBNull.Value Then
                        m_sSecurityObjectType = SqlString.Null
                    Else
                        m_sSecurityObjectType = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectType"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObject") Is System.DBNull.Value Then
                        m_sSecurityObject = SqlString.Null
                    Else
                        m_sSecurityObject = New SqlString(CType(dtToReturn.Rows(0)("SecurityObject"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectItem") Is System.DBNull.Value Then
                        m_sSecurityObjectItem = SqlString.Null
                    Else
                        m_sSecurityObjectItem = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectItem"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityObjectDescriotion") Is System.DBNull.Value Then
                        m_sSecurityObjectDescriotion = SqlString.Null
                    Else
                        m_sSecurityObjectDescriotion = New SqlString(CType(dtToReturn.Rows(0)("SecurityObjectDescriotion"), String))
                    End If
                    If dtToReturn.Rows(0)("Level") Is System.DBNull.Value Then
                        m_iLevel = SqlInt32.Null
                    Else
                        m_iLevel = New SqlInt32(CType(dtToReturn.Rows(0)("Level"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSecurityObjectNr</LI> <LI>sSecurityForm. May be SqlString.Null</LI> <LI>sSecurityObjectType. May be SqlString.Null</LI> <LI>sSecurityObject. May be SqlString.Null</LI> <LI>sSecurityObjectItem. May be SqlString.Null</LI> <LI>sSecurityObjectDescriotion. May be SqlString.Null</LI> <LI>iLevel. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SecurityObject_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityObjectNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSecurityObjectNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityForm", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityForm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectType", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectType))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObject", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectItem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSecurityObjectDescriotion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSecurityObjectDescriotion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLevel", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLevel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SecurityObject_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSecurityObject::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsSecurityObject-Felder

clsSecurityObject Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLevel

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityObjectNr

Unterstützt von .NET Compact Framework
private field m_sSecurityForm

Unterstützt von .NET Compact Framework
private field m_sSecurityObject

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectDescriotion

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectItem

Unterstützt von .NET Compact Framework
private field m_sSecurityObjectType

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSecurityObject -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_iLevel -Feld

[Visual Basic]
Private m_iLevel As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_iSecurityObjectNr -Feld

[Visual Basic]
Private m_iSecurityObjectNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iLevel, m_iMutierer, m_iMandantnr, m_iSecurityObjectNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_sSecurityForm -Feld

[Visual Basic]
Private m_sSecurityForm As SqlString

Quellcode

[Visual Basic]
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_sSecurityObject -Feld

[Visual Basic]
Private m_sSecurityObject As SqlString

Quellcode

[Visual Basic]
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_sSecurityObjectDescriotion -Feld

[Visual Basic]
Private m_sSecurityObjectDescriotion As SqlString

Quellcode

[Visual Basic]
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_sSecurityObjectItem -Feld

[Visual Basic]
Private m_sSecurityObjectItem As SqlString

Quellcode

[Visual Basic]
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


m_sSecurityObjectType -Feld

[Visual Basic]
Private m_sSecurityObjectType As SqlString

Quellcode

[Visual Basic]
        Private 		m_sSecurityForm, m_sSecurityObjectDescriotion, m_sSecurityObjectItem, m_sSecurityObject, m_sSecurityObjectType As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSecurityObject


clsServiceKatalog -Klasse

Purpose: Data Access class for the table 'ServiceKatalog'.

For a list of all members of this type, see clsServiceKatalog-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogDaten

[Visual Basic]
Public Class clsServiceKatalog
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsServiceKatalog-Member


clsServiceKatalog-Member

clsServiceKatalog Übersicht

Öffentliche Konstruktoren

public constructor clsServiceKatalog -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bExtern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iServiceKatalogNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBezeichnung_extern

Unterstützt von .NET Compact Framework
public property sBezeichnung_intern

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bExtern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalogNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung_extern

Unterstützt von .NET Compact Framework
private field m_sBezeichnung_intern

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog -Klasse


clsServiceKatalog -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog-Eigenschaften

clsServiceKatalog Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bExtern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iServiceKatalogNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sBezeichnung_extern

Unterstützt von .NET Compact Framework
public property sBezeichnung_intern

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog -Klasse


clsServiceKatalog.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.bExtern -Eigenschaft

[Visual Basic]
Public Property bExtern() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bExtern]() As SqlBoolean
            Get
                Return m_bExtern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bExtern = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.iParentID -Eigenschaft

[Visual Basic]
Public Property iParentID() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.iServiceKatalogNr -Eigenschaft

[Visual Basic]
Public Property iServiceKatalogNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iServiceKatalogNr]() As SqlInt32
            Get
                Return m_iServiceKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iServiceKatalogNrTmp As SqlInt32 = Value
                If iServiceKatalogNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iServiceKatalogNr", "iServiceKatalogNr can't be NULL")
                End If
                m_iServiceKatalogNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.sBezeichnung_extern -Eigenschaft

[Visual Basic]
Public Property sBezeichnung_extern() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung_extern]() As SqlString
            Get
                Return m_sBezeichnung_extern
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung_extern = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.sBezeichnung_intern -Eigenschaft

[Visual Basic]
Public Property sBezeichnung_intern() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung_intern]() As SqlString
            Get
                Return m_sBezeichnung_intern
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung_intern = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog-Methoden

clsServiceKatalog Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsServiceKatalog -Klasse


clsServiceKatalog.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung_intern. May be SqlString.Null</LI> <LI>sBezeichnung_extern. May be SqlString.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_intern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_intern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_extern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_extern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bextern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iServiceKatalogNr</LI> <LI>iParentID</LI> <LI>sBezeichnung_intern</LI> <LI>sBezeichnung_extern</LI> <LI>bExtern</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iServiceKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalogNr"), Integer))
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung_intern") Is System.DBNull.Value Then
                        m_sBezeichnung_intern = SqlString.Null
                    Else
                        m_sBezeichnung_intern = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung_intern"), String))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung_extern") Is System.DBNull.Value Then
                        m_sBezeichnung_extern = SqlString.Null
                    Else
                        m_sBezeichnung_extern = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung_extern"), String))
                    End If
                    If dtToReturn.Rows(0)("extern") Is System.DBNull.Value Then
                        m_bExtern = SqlBoolean.Null
                    Else
                        m_bExtern = New SqlBoolean(CType(dtToReturn.Rows(0)("extern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalogNr</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung_intern. May be SqlString.Null</LI> <LI>sBezeichnung_extern. May be SqlString.Null</LI> <LI>bExtern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_intern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_intern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung_extern", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung_extern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bextern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bExtern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog-Felder

clsServiceKatalog Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bExtern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalogNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung_extern

Unterstützt von .NET Compact Framework
private field m_sBezeichnung_intern

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_bExtern -Feld

[Visual Basic]
Private m_bExtern As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bExtern As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_iParentID -Feld

[Visual Basic]
Private m_iParentID As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_iServiceKatalogNr -Feld

[Visual Basic]
Private m_iServiceKatalogNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iMutierer, m_iServiceKatalogNr, m_iParentID, m_iMandantnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_sBezeichnung_extern -Feld

[Visual Basic]
Private m_sBezeichnung_extern As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


m_sBezeichnung_intern -Feld

[Visual Basic]
Private m_sBezeichnung_intern As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung, m_sBezeichnung_extern, m_sBezeichnung_intern As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog


clsServiceKatalog_SLAKatalog -Klasse

Purpose: Data Access class for the table 'ServiceKatalog_SLAKatalog'.

For a list of all members of this type, see clsServiceKatalog_SLAKatalog-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog_SLAKatalog

[Visual Basic]
Public Class clsServiceKatalog_SLAKatalog
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsServiceKatalog_SLAKatalog-Member


clsServiceKatalog_SLAKatalog-Member

clsServiceKatalog_SLAKatalog Übersicht

Öffentliche Konstruktoren

public constructor clsServiceKatalog_SLAKatalog -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLAKatalogNr

Unterstützt von .NET Compact Framework
public property iServiceKatalog_SLAKatalognr

Unterstützt von .NET Compact Framework
public property iServiceKatalognr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLAKatalogNr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalog_SLAKatalognr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalognr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog_SLAKatalog -Klasse


clsServiceKatalog_SLAKatalog -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog-Eigenschaften

clsServiceKatalog_SLAKatalog Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLAKatalogNr

Unterstützt von .NET Compact Framework
public property iServiceKatalog_SLAKatalognr

Unterstützt von .NET Compact Framework
public property iServiceKatalognr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog_SLAKatalog -Klasse


clsServiceKatalog_SLAKatalog.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.iSLAKatalogNr -Eigenschaft

[Visual Basic]
Public Property iSLAKatalogNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSLAKatalogNr]() As SqlInt32
            Get
                Return m_iSLAKatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSLAKatalogNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.iServiceKatalog_SLAKatalognr -Eigenschaft

[Visual Basic]
Public Property iServiceKatalog_SLAKatalognr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iServiceKatalog_SLAKatalognr]() As SqlInt32
            Get
                Return m_iServiceKatalog_SLAKatalognr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iServiceKatalog_SLAKatalognrTmp As SqlInt32 = Value
                If iServiceKatalog_SLAKatalognrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iServiceKatalog_SLAKatalognr", "iServiceKatalog_SLAKatalognr can't be NULL")
                End If
                m_iServiceKatalog_SLAKatalognr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.iServiceKatalognr -Eigenschaft

[Visual Basic]
Public Property iServiceKatalognr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iServiceKatalognr]() As SqlInt32
            Get
                Return m_iServiceKatalognr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iServiceKatalognr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog-Methoden

clsServiceKatalog_SLAKatalog Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsServiceKatalog_SLAKatalog -Klasse


clsServiceKatalog_SLAKatalog.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr. May be SqlInt32.Null</LI> <LI>iSLAKatalogNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog_SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr</LI> <LI>iSLAKatalogNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ServiceKatalog_SLAKatalog")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iServiceKatalog_SLAKatalognr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalog_SLAKatalognr"), Integer))
                    If dtToReturn.Rows(0)("ServiceKatalognr") Is System.DBNull.Value Then
                        m_iServiceKatalognr = SqlInt32.Null
                    Else
                        m_iServiceKatalognr = New SqlInt32(CType(dtToReturn.Rows(0)("ServiceKatalognr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SLAKatalogNr") Is System.DBNull.Value Then
                        m_iSLAKatalogNr = SqlInt32.Null
                    Else
                        m_iSLAKatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("SLAKatalogNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iServiceKatalog_SLAKatalognr</LI> <LI>iServiceKatalognr. May be SqlInt32.Null</LI> <LI>iSLAKatalogNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ServiceKatalog_SLAKatalog_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalog_SLAKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalog_SLAKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServiceKatalognr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServiceKatalognr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSLAKatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSLAKatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ServiceKatalog_SLAKatalog_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServiceKatalog_SLAKatalog::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsServiceKatalog_SLAKatalog-Felder

clsServiceKatalog_SLAKatalog Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSLAKatalogNr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalog_SLAKatalognr

Unterstützt von .NET Compact Framework
private field m_iServiceKatalognr

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalog_SLAKatalog -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_iSLAKatalogNr -Feld

[Visual Basic]
Private m_iSLAKatalogNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_iServiceKatalog_SLAKatalognr -Feld

[Visual Basic]
Private m_iServiceKatalog_SLAKatalognr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


m_iServiceKatalognr -Feld

[Visual Basic]
Private m_iServiceKatalognr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iServiceKatalognr, m_iSLAKatalogNr, m_iServiceKatalog_SLAKatalognr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalog_SLAKatalog


clsSpalten -Klasse

Purpose: Data Access class for the table 'spalten'.

For a list of all members of this type, see clsSpalten-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSpalten
Vertragsverwaltung.TKB.VV.Utils.clsSpalten

[Visual Basic]
Public Class clsSpalten
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSpalten-Member


clsSpalten-Member

clsSpalten Übersicht

Öffentliche Konstruktoren

public constructor clsSpalten -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsHacken

Unterstützt von .NET Compact Framework
public property bReadonly

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBreite

Unterstützt von .NET Compact Framework
public property iEintragnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSpalte

Unterstützt von .NET Compact Framework
public property sTabelle

Unterstützt von .NET Compact Framework
public property sTabellenspalte

Unterstützt von .NET Compact Framework
public property sTiptext

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsHacken

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bReadonly

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBreite

Unterstützt von .NET Compact Framework
private field m_iEintragnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sSpalte

Unterstützt von .NET Compact Framework
private field m_sTabelle

Unterstützt von .NET Compact Framework
private field m_sTabellenspalte

Unterstützt von .NET Compact Framework
private field m_sTiptext

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


clsSpalten -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten-Eigenschaften

clsSpalten Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsHacken

Unterstützt von .NET Compact Framework
public property bReadonly

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBreite

Unterstützt von .NET Compact Framework
public property iEintragnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReihenfolge

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSpalte

Unterstützt von .NET Compact Framework
public property sTabelle

Unterstützt von .NET Compact Framework
public property sTabellenspalte

Unterstützt von .NET Compact Framework
public property sTiptext

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


clsSpalten.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.bAlsHacken -Eigenschaft

[Visual Basic]
Public Property bAlsHacken() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAlsHacken]() As SqlBoolean
            Get
                Return m_bAlsHacken
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAlsHackenTmp As SqlBoolean = Value
                If bAlsHackenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAlsHacken", "bAlsHacken can't be NULL")
                End If
                m_bAlsHacken = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.bReadonly -Eigenschaft

[Visual Basic]
Public Property bReadonly() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bReadonly]() As SqlBoolean
            Get
                Return m_bReadonly
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bReadonlyTmp As SqlBoolean = Value
                If bReadonlyTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bReadonly", "bReadonly can't be NULL")
                End If
                m_bReadonly = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.iBreite -Eigenschaft

[Visual Basic]
Public Property iBreite() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iBreite]() As SqlInt32
            Get
                Return m_iBreite
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBreite = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.iEintragnr -Eigenschaft

[Visual Basic]
Public Property iEintragnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEintragnr]() As SqlInt32
            Get
                Return m_iEintragnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEintragnrTmp As SqlInt32 = Value
                If iEintragnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEintragnr", "iEintragnr can't be NULL")
                End If
                m_iEintragnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.iReihenfolge -Eigenschaft

[Visual Basic]
Public Property iReihenfolge() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.sSpalte -Eigenschaft

[Visual Basic]
Public Property sSpalte() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSpalte]() As SqlString
            Get
                Return m_sSpalte
            End Get
            Set(ByVal Value As SqlString)
                m_sSpalte = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.sTabelle -Eigenschaft

[Visual Basic]
Public Property sTabelle() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTabelle]() As SqlString
            Get
                Return m_sTabelle
            End Get
            Set(ByVal Value As SqlString)
                m_sTabelle = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.sTabellenspalte -Eigenschaft

[Visual Basic]
Public Property sTabellenspalte() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTabellenspalte]() As SqlString
            Get
                Return m_sTabellenspalte
            End Get
            Set(ByVal Value As SqlString)
                m_sTabellenspalte = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.sTiptext -Eigenschaft

[Visual Basic]
Public Property sTiptext() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTiptext]() As SqlString
            Get
                Return m_sTiptext
            End Get
            Set(ByVal Value As SqlString)
                m_sTiptext = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten-Methoden

clsSpalten Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSpalten -Klasse


clsSpalten.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEintragnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEintragnr</LI> <LI>sTabelle. May be SqlString.Null</LI> <LI>sTabellenspalte. May be SqlString.Null</LI> <LI>sSpalte. May be SqlString.Null</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite. May be SqlInt32.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>sTiptext. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEintragnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iEintragnr</LI> <LI>sTabelle</LI> <LI>sTabellenspalte</LI> <LI>sSpalte</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite</LI> <LI>iReihenfolge</LI> <LI>sTiptext</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEintragnr = New SqlInt32(CType(dtToReturn.Rows(0)("eintragnr"), Integer))
                    If dtToReturn.Rows(0)("tabelle") Is System.DBNull.Value Then
                        m_sTabelle = SqlString.Null
                    Else
                        m_sTabelle = New SqlString(CType(dtToReturn.Rows(0)("tabelle"), String))
                    End If
                    If dtToReturn.Rows(0)("tabellenspalte") Is System.DBNull.Value Then
                        m_sTabellenspalte = SqlString.Null
                    Else
                        m_sTabellenspalte = New SqlString(CType(dtToReturn.Rows(0)("tabellenspalte"), String))
                    End If
                    If dtToReturn.Rows(0)("spalte") Is System.DBNull.Value Then
                        m_sSpalte = SqlString.Null
                    Else
                        m_sSpalte = New SqlString(CType(dtToReturn.Rows(0)("spalte"), String))
                    End If
                    m_bReadonly = New SqlBoolean(CType(dtToReturn.Rows(0)("Readonly"), Boolean))
                    m_bAlsHacken = New SqlBoolean(CType(dtToReturn.Rows(0)("alsHacken"), Boolean))
                    If dtToReturn.Rows(0)("Breite") Is System.DBNull.Value Then
                        m_iBreite = SqlInt32.Null
                    Else
                        m_iBreite = New SqlInt32(CType(dtToReturn.Rows(0)("Breite"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tiptext") Is System.DBNull.Value Then
                        m_sTiptext = SqlString.Null
                    Else
                        m_sTiptext = New SqlString(CType(dtToReturn.Rows(0)("tiptext"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEintragnr</LI> <LI>sTabelle. May be SqlString.Null</LI> <LI>sTabellenspalte. May be SqlString.Null</LI> <LI>sSpalte. May be SqlString.Null</LI> <LI>bReadonly</LI> <LI>bAlsHacken</LI> <LI>iBreite. May be SqlInt32.Null</LI> <LI>iReihenfolge. May be SqlInt32.Null</LI> <LI>sTiptext. May be SqlString.Null</LI> <LI>bAktiv</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten-Felder

clsSpalten Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsHacken

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_bReadonly

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBreite

Unterstützt von .NET Compact Framework
private field m_iEintragnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReihenfolge

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_sSpalte

Unterstützt von .NET Compact Framework
private field m_sTabelle

Unterstützt von .NET Compact Framework
private field m_sTabellenspalte

Unterstützt von .NET Compact Framework
private field m_sTiptext

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_bAlsHacken -Feld

[Visual Basic]
Private m_bAlsHacken As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_bReadonly -Feld

[Visual Basic]
Private m_bReadonly As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_iBreite -Feld

[Visual Basic]
Private m_iBreite As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_iEintragnr -Feld

[Visual Basic]
Private m_iEintragnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_iReihenfolge -Feld

[Visual Basic]
Private m_iReihenfolge As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_sSpalte -Feld

[Visual Basic]
Private m_sSpalte As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_sTabelle -Feld

[Visual Basic]
Private m_sTabelle As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_sTabellenspalte -Feld

[Visual Basic]
Private m_sTabellenspalte As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


m_sTiptext -Feld

[Visual Basic]
Private m_sTiptext As SqlString

Quellcode

[Visual Basic]
        Private 		m_sTabelle, m_sTiptext, m_sSpalte, m_sTabellenspalte As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSysadminfunktion -Klasse

Purpose: Data Access class for the table 'sysadminfunktion'.

For a list of all members of this type, see clsSysadminfunktion-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.Sysadmin.clsMySysadminfunkion

[Visual Basic]
Public Class clsSysadminfunktion
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSysadminfunktion-Member


clsSysadminfunktion-Member

clsSysadminfunktion Übersicht

Öffentliche Konstruktoren

public constructor clsSysadminfunktion -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFheight

Unterstützt von .NET Compact Framework
public property iFleft

Unterstützt von .NET Compact Framework
public property iFtop

Unterstützt von .NET Compact Framework
public property iFwidth

Unterstützt von .NET Compact Framework
public property iImageIndex

Unterstützt von .NET Compact Framework
public property iImageIndexOpen

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSort

Unterstützt von .NET Compact Framework
public property iSprache

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDomaintable

Unterstützt von .NET Compact Framework
public property sKeyFields

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFheight

Unterstützt von .NET Compact Framework
private field m_iFleft

Unterstützt von .NET Compact Framework
private field m_iFtop

Unterstützt von .NET Compact Framework
private field m_iFwidth

Unterstützt von .NET Compact Framework
private field m_iImageIndex

Unterstützt von .NET Compact Framework
private field m_iImageIndexOpen

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSort

Unterstützt von .NET Compact Framework
private field m_iSprache

Unterstützt von .NET Compact Framework
private field m_iSysadminfnktnr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sDomaintable

Unterstützt von .NET Compact Framework
private field m_sKeyFields

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSysadminfunktion -Klasse


clsSysadminfunktion -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion-Eigenschaften

clsSysadminfunktion Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFheight

Unterstützt von .NET Compact Framework
public property iFleft

Unterstützt von .NET Compact Framework
public property iFtop

Unterstützt von .NET Compact Framework
public property iFwidth

Unterstützt von .NET Compact Framework
public property iImageIndex

Unterstützt von .NET Compact Framework
public property iImageIndexOpen

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSort

Unterstützt von .NET Compact Framework
public property iSprache

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDomaintable

Unterstützt von .NET Compact Framework
public property sKeyFields

Unterstützt von .NET Compact Framework

clsSysadminfunktion -Klasse


clsSysadminfunktion.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iFheight -Eigenschaft

[Visual Basic]
Public Property iFheight() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFheight]() As SqlInt32
            Get
                Return m_iFheight
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFheight = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iFleft -Eigenschaft

[Visual Basic]
Public Property iFleft() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFleft]() As SqlInt32
            Get
                Return m_iFleft
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFleft = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iFtop -Eigenschaft

[Visual Basic]
Public Property iFtop() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFtop]() As SqlInt32
            Get
                Return m_iFtop
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFtop = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iFwidth -Eigenschaft

[Visual Basic]
Public Property iFwidth() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iFwidth]() As SqlInt32
            Get
                Return m_iFwidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFwidth = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iImageIndex -Eigenschaft

[Visual Basic]
Public Property iImageIndex() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iImageIndex]() As SqlInt32
            Get
                Return m_iImageIndex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndex = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iImageIndexOpen -Eigenschaft

[Visual Basic]
Public Property iImageIndexOpen() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iImageIndexOpen]() As SqlInt32
            Get
                Return m_iImageIndexOpen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndexOpen = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iParentID -Eigenschaft

[Visual Basic]
Public Property iParentID() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iSort -Eigenschaft

[Visual Basic]
Public Property iSort() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iSprache -Eigenschaft

[Visual Basic]
Public Property iSprache() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSpracheTmp As SqlInt32 = Value
                If iSpracheTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSprache", "iSprache can't be NULL")
                End If
                m_iSprache = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.iSysadminfnktnr -Eigenschaft

[Visual Basic]
Public Property iSysadminfnktnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSysadminfnktnrTmp As SqlInt32 = Value
                If iSysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSysadminfnktnr", "iSysadminfnktnr can't be NULL")
                End If
                m_iSysadminfnktnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.sDomaintable -Eigenschaft

[Visual Basic]
Public Property sDomaintable() As SqlString

Quellcode

[Visual Basic]
        Public Property [sDomaintable]() As SqlString
            Get
                Return m_sDomaintable
            End Get
            Set(ByVal Value As SqlString)
                m_sDomaintable = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.sKeyFields -Eigenschaft

[Visual Basic]
Public Property sKeyFields() As SqlString

Quellcode

[Visual Basic]
        Public Property [sKeyFields]() As SqlString
            Get
                Return m_sKeyFields
            End Get
            Set(ByVal Value As SqlString)
                m_sKeyFields = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion-Methoden

clsSysadminfunktion Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSysadminfunktion -Klasse


clsSysadminfunktion.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iSort. May be SqlInt32.Null</LI> <LI>iImageIndex. May be SqlInt32.Null</LI> <LI>iImageIndexOpen. May be SqlInt32.Null</LI> <LI>iFtop. May be SqlInt32.Null</LI> <LI>iFleft. May be SqlInt32.Null</LI> <LI>iFwidth. May be SqlInt32.Null</LI> <LI>iFheight. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sDomaintable. May be SqlString.Null</LI> <LI>sKeyFields. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDomaintable", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDomaintable))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKeyFields", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKeyFields))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung</LI> <LI>iParentID</LI> <LI>iSort</LI> <LI>iImageIndex</LI> <LI>iImageIndexOpen</LI> <LI>iFtop</LI> <LI>iFleft</LI> <LI>iFwidth</LI> <LI>iFheight</LI> <LI>sBeschreibung</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>sDomaintable</LI> <LI>sKeyFields</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("Sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndex") Is System.DBNull.Value Then
                        m_iImageIndex = SqlInt32.Null
                    Else
                        m_iImageIndex = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndexOpen") Is System.DBNull.Value Then
                        m_iImageIndexOpen = SqlInt32.Null
                    Else
                        m_iImageIndexOpen = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndexOpen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ftop") Is System.DBNull.Value Then
                        m_iFtop = SqlInt32.Null
                    Else
                        m_iFtop = New SqlInt32(CType(dtToReturn.Rows(0)("ftop"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fleft") Is System.DBNull.Value Then
                        m_iFleft = SqlInt32.Null
                    Else
                        m_iFleft = New SqlInt32(CType(dtToReturn.Rows(0)("fleft"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fwidth") Is System.DBNull.Value Then
                        m_iFwidth = SqlInt32.Null
                    Else
                        m_iFwidth = New SqlInt32(CType(dtToReturn.Rows(0)("fwidth"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fheight") Is System.DBNull.Value Then
                        m_iFheight = SqlInt32.Null
                    Else
                        m_iFheight = New SqlInt32(CType(dtToReturn.Rows(0)("fheight"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Domaintable") Is System.DBNull.Value Then
                        m_sDomaintable = SqlString.Null
                    Else
                        m_sDomaintable = New SqlString(CType(dtToReturn.Rows(0)("Domaintable"), String))
                    End If
                    If dtToReturn.Rows(0)("KeyFields") Is System.DBNull.Value Then
                        m_sKeyFields = SqlString.Null
                    Else
                        m_sKeyFields = New SqlString(CType(dtToReturn.Rows(0)("KeyFields"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iSysadminfnktnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>iSort. May be SqlInt32.Null</LI> <LI>iImageIndex. May be SqlInt32.Null</LI> <LI>iImageIndexOpen. May be SqlInt32.Null</LI> <LI>iFtop. May be SqlInt32.Null</LI> <LI>iFleft. May be SqlInt32.Null</LI> <LI>iFwidth. May be SqlInt32.Null</LI> <LI>iFheight. May be SqlInt32.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>iMandantnr</LI> <LI>iSprache</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>sDomaintable. May be SqlString.Null</LI> <LI>sKeyFields. May be SqlString.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDomaintable", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDomaintable))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sKeyFields", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKeyFields))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsSysadminfunktion-Felder

clsSysadminfunktion Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iFheight

Unterstützt von .NET Compact Framework
private field m_iFleft

Unterstützt von .NET Compact Framework
private field m_iFtop

Unterstützt von .NET Compact Framework
private field m_iFwidth

Unterstützt von .NET Compact Framework
private field m_iImageIndex

Unterstützt von .NET Compact Framework
private field m_iImageIndexOpen

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSort

Unterstützt von .NET Compact Framework
private field m_iSprache

Unterstützt von .NET Compact Framework
private field m_iSysadminfnktnr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sDomaintable

Unterstützt von .NET Compact Framework
private field m_sKeyFields

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSysadminfunktion -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iFheight -Feld

[Visual Basic]
Private m_iFheight As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iFleft -Feld

[Visual Basic]
Private m_iFleft As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iFtop -Feld

[Visual Basic]
Private m_iFtop As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iFwidth -Feld

[Visual Basic]
Private m_iFwidth As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iImageIndex -Feld

[Visual Basic]
Private m_iImageIndex As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iImageIndexOpen -Feld

[Visual Basic]
Private m_iImageIndexOpen As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iParentID -Feld

[Visual Basic]
Private m_iParentID As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iSort -Feld

[Visual Basic]
Private m_iSort As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iSprache -Feld

[Visual Basic]
Private m_iSprache As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_iSysadminfnktnr -Feld

[Visual Basic]
Private m_iSysadminfnktnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_sDomaintable -Feld

[Visual Basic]
Private m_sDomaintable As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


m_sKeyFields -Feld

[Visual Basic]
Private m_sKeyFields As SqlString

Quellcode

[Visual Basic]
        Private 		m_sKeyFields, m_sDomaintable, m_sBeschreibung, m_sBezeichnung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSysadminfunktion


clsTooltip -Klasse

Purpose: Data Access class for the table 'Tooltip'.

For a list of all members of this type, see clsTooltip-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsTooltip

[Visual Basic]
Public Class clsTooltip
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsTooltip-Member


clsTooltip-Member

clsTooltip Übersicht

Öffentliche Konstruktoren

public constructor clsTooltip -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iToolTipNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sControlName

Unterstützt von .NET Compact Framework
public property sFormularname

Unterstützt von .NET Compact Framework
public property sToolTip

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iToolTipNr

Unterstützt von .NET Compact Framework
private field m_sControlName

Unterstützt von .NET Compact Framework
private field m_sFormularname

Unterstützt von .NET Compact Framework
private field m_sToolTip

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsTooltip -Klasse


clsTooltip -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip-Eigenschaften

clsTooltip Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iToolTipNr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sControlName

Unterstützt von .NET Compact Framework
public property sFormularname

Unterstützt von .NET Compact Framework
public property sToolTip

Unterstützt von .NET Compact Framework

clsTooltip -Klasse


clsTooltip.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.iToolTipNr -Eigenschaft

[Visual Basic]
Public Property iToolTipNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iToolTipNr]() As SqlInt32
            Get
                Return m_iToolTipNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iToolTipNrTmp As SqlInt32 = Value
                If iToolTipNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iToolTipNr", "iToolTipNr can't be NULL")
                End If
                m_iToolTipNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.sControlName -Eigenschaft

[Visual Basic]
Public Property sControlName() As SqlString

Quellcode

[Visual Basic]
        Public Property [sControlName]() As SqlString
            Get
                Return m_sControlName
            End Get
            Set(ByVal Value As SqlString)
                m_sControlName = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.sFormularname -Eigenschaft

[Visual Basic]
Public Property sFormularname() As SqlString

Quellcode

[Visual Basic]
        Public Property [sFormularname]() As SqlString
            Get
                Return m_sFormularname
            End Get
            Set(ByVal Value As SqlString)
                m_sFormularname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.sToolTip -Eigenschaft

[Visual Basic]
Public Property sToolTip() As SqlString

Quellcode

[Visual Basic]
        Public Property [sToolTip]() As SqlString
            Get
                Return m_sToolTip
            End Get
            Set(ByVal Value As SqlString)
                m_sToolTip = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip-Methoden

clsTooltip Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsTooltip -Klasse


clsTooltip.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iToolTipNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tooltip_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iToolTipNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iToolTipNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tooltip_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTooltip::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iToolTipNr</LI> <LI>sFormularname. May be SqlString.Null</LI> <LI>sControlName. May be SqlString.Null</LI> <LI>sToolTip. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tooltip_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iToolTipNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iToolTipNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFormularname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFormularname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sControlName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sControlName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sToolTip", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sToolTip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tooltip_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTooltip::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tooltip_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tooltip")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tooltip_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTooltip::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iToolTipNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iToolTipNr</LI> <LI>sFormularname</LI> <LI>sControlName</LI> <LI>sToolTip</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tooltip_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tooltip")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iToolTipNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iToolTipNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tooltip_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iToolTipNr = New SqlInt32(CType(dtToReturn.Rows(0)("ToolTipNr"), Integer))
                    If dtToReturn.Rows(0)("Formularname") Is System.DBNull.Value Then
                        m_sFormularname = SqlString.Null
                    Else
                        m_sFormularname = New SqlString(CType(dtToReturn.Rows(0)("Formularname"), String))
                    End If
                    If dtToReturn.Rows(0)("ControlName") Is System.DBNull.Value Then
                        m_sControlName = SqlString.Null
                    Else
                        m_sControlName = New SqlString(CType(dtToReturn.Rows(0)("ControlName"), String))
                    End If
                    If dtToReturn.Rows(0)("ToolTip") Is System.DBNull.Value Then
                        m_sToolTip = SqlString.Null
                    Else
                        m_sToolTip = New SqlString(CType(dtToReturn.Rows(0)("ToolTip"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTooltip::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iToolTipNr</LI> <LI>sFormularname. May be SqlString.Null</LI> <LI>sControlName. May be SqlString.Null</LI> <LI>sToolTip. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tooltip_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iToolTipNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iToolTipNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFormularname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFormularname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sControlName", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sControlName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sToolTip", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sToolTip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tooltip_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTooltip::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsTooltip-Felder

clsTooltip Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iToolTipNr

Unterstützt von .NET Compact Framework
private field m_sControlName

Unterstützt von .NET Compact Framework
private field m_sFormularname

Unterstützt von .NET Compact Framework
private field m_sToolTip

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsTooltip -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iToolTipNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_iToolTipNr -Feld

[Visual Basic]
Private m_iToolTipNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iToolTipNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_sControlName -Feld

[Visual Basic]
Private m_sControlName As SqlString

Quellcode

[Visual Basic]
        Private 		m_sToolTip, m_sControlName, m_sFormularname As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_sFormularname -Feld

[Visual Basic]
Private m_sFormularname As SqlString

Quellcode

[Visual Basic]
        Private 		m_sToolTip, m_sControlName, m_sFormularname As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


m_sToolTip -Feld

[Visual Basic]
Private m_sToolTip As SqlString

Quellcode

[Visual Basic]
        Private 		m_sToolTip, m_sControlName, m_sFormularname As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsTooltip


clsVertragselement -Klasse

Purpose: Data Access class for the table 'Vertragselement'.

For a list of all members of this type, see clsVertragselement-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselement

[Visual Basic]
Public Class clsVertragselement
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragselement-Member


clsVertragselement-Member

clsVertragselement Übersicht

Öffentliche Konstruktoren

public constructor clsVertragselement -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bBefristet_Unbefristet

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daGekuendigt_am

Unterstützt von .NET Compact Framework
public property daGekuendigt_per

Unterstützt von .NET Compact Framework
public property daMindestvertragsdauer_bis

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daUnterzeichnet_am

Unterstützt von .NET Compact Framework
public property daVersionsdatum

Unterstützt von .NET Compact Framework
public property daVertragsablauf

Unterstützt von .NET Compact Framework
public property daVertragsbeginn

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNrOld

Unterstützt von .NET Compact Framework
public property iVertragstypNr

Unterstützt von .NET Compact Framework
public property iVertragstypNrOld

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzdetails

Unterstützt von .NET Compact Framework
public property sNummer

Unterstützt von .NET Compact Framework
public property sSuchbegriffe

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method DeleteAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method SelectAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragspartnerNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragspartnerNr' in all rows which have as value for this field the value as set in property 'iVertragspartnerNrOld' to the value as set in property 'iVertragspartnerNr'.
public method UpdateAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragstypNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragstypNr' in all rows which have as value for this field the value as set in property 'iVertragstypNrOld' to the value as set in property 'iVertragstypNr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bBefristet_Unbefristet

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daGekuendigt_am

Unterstützt von .NET Compact Framework
private field m_daGekuendigt_per

Unterstützt von .NET Compact Framework
private field m_daMindestvertragsdauer_bis

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daUnterzeichnet_am

Unterstützt von .NET Compact Framework
private field m_daVersionsdatum

Unterstützt von .NET Compact Framework
private field m_daVertragsablauf

Unterstützt von .NET Compact Framework
private field m_daVertragsbeginn

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenztypnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNrOld

Unterstützt von .NET Compact Framework
private field m_iVertragstypNr

Unterstützt von .NET Compact Framework
private field m_iVertragstypNrOld

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sLizenzdetails

Unterstützt von .NET Compact Framework
private field m_sNummer

Unterstützt von .NET Compact Framework
private field m_sSuchbegriffe

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselement -Klasse


clsVertragselement -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement-Eigenschaften

clsVertragselement Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bBefristet_Unbefristet

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daGekuendigt_am

Unterstützt von .NET Compact Framework
public property daGekuendigt_per

Unterstützt von .NET Compact Framework
public property daMindestvertragsdauer_bis

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daUnterzeichnet_am

Unterstützt von .NET Compact Framework
public property daVersionsdatum

Unterstützt von .NET Compact Framework
public property daVertragsablauf

Unterstützt von .NET Compact Framework
public property daVertragsbeginn

Unterstützt von .NET Compact Framework
public property iApplikationNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iParentID

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNrOld

Unterstützt von .NET Compact Framework
public property iVertragstypNr

Unterstützt von .NET Compact Framework
public property iVertragstypNrOld

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzdetails

Unterstützt von .NET Compact Framework
public property sNummer

Unterstützt von .NET Compact Framework
public property sSuchbegriffe

Unterstützt von .NET Compact Framework
public property sVersion

Unterstützt von .NET Compact Framework

clsVertragselement -Klasse


clsVertragselement.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.bBefristet_Unbefristet -Eigenschaft

[Visual Basic]
Public Property bBefristet_Unbefristet() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bBefristet_Unbefristet]() As SqlBoolean
            Get
                Return m_bBefristet_Unbefristet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBefristet_Unbefristet = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daGekuendigt_am -Eigenschaft

[Visual Basic]
Public Property daGekuendigt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daGekuendigt_am]() As SqlDateTime
            Get
                Return m_daGekuendigt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGekuendigt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daGekuendigt_per -Eigenschaft

[Visual Basic]
Public Property daGekuendigt_per() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daGekuendigt_per]() As SqlDateTime
            Get
                Return m_daGekuendigt_per
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGekuendigt_per = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daMindestvertragsdauer_bis -Eigenschaft

[Visual Basic]
Public Property daMindestvertragsdauer_bis() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMindestvertragsdauer_bis]() As SqlDateTime
            Get
                Return m_daMindestvertragsdauer_bis
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMindestvertragsdauer_bis = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daUnterzeichnet_am -Eigenschaft

[Visual Basic]
Public Property daUnterzeichnet_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daUnterzeichnet_am]() As SqlDateTime
            Get
                Return m_daUnterzeichnet_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daUnterzeichnet_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daVersionsdatum -Eigenschaft

[Visual Basic]
Public Property daVersionsdatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daVersionsdatum]() As SqlDateTime
            Get
                Return m_daVersionsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVersionsdatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daVertragsablauf -Eigenschaft

[Visual Basic]
Public Property daVertragsablauf() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daVertragsablauf]() As SqlDateTime
            Get
                Return m_daVertragsablauf
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVertragsablauf = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.daVertragsbeginn -Eigenschaft

[Visual Basic]
Public Property daVertragsbeginn() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daVertragsbeginn]() As SqlDateTime
            Get
                Return m_daVertragsbeginn
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daVertragsbeginn = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iApplikationNr -Eigenschaft

[Visual Basic]
Public Property iApplikationNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationNr]() As SqlInt32
            Get
                Return m_iApplikationNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iLizenztypnr -Eigenschaft

[Visual Basic]
Public Property iLizenztypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iLizenztypnr]() As SqlInt32
            Get
                Return m_iLizenztypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iLizenztypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iParentID -Eigenschaft

[Visual Basic]
Public Property iParentID() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iVertragselementnr -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr]() As SqlInt32
            Get
                Return m_iVertragselementnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragselementnrTmp As SqlInt32 = Value
                If iVertragselementnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragselementnr", "iVertragselementnr can't be NULL")
                End If
                m_iVertragselementnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iVertragspartnerNr -Eigenschaft

[Visual Basic]
Public Property iVertragspartnerNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragspartnerNr]() As SqlInt32
            Get
                Return m_iVertragspartnerNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnerNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iVertragspartnerNrOld -Eigenschaft

[Visual Basic]
Public Property iVertragspartnerNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragspartnerNrOld]() As SqlInt32
            Get
                Return m_iVertragspartnerNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragspartnerNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iVertragstypNr -Eigenschaft

[Visual Basic]
Public Property iVertragstypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragstypNr]() As SqlInt32
            Get
                Return m_iVertragstypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragstypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.iVertragstypNrOld -Eigenschaft

[Visual Basic]
Public Property iVertragstypNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragstypNrOld]() As SqlInt32
            Get
                Return m_iVertragstypNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragstypNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sLizenzdetails -Eigenschaft

[Visual Basic]
Public Property sLizenzdetails() As SqlString

Quellcode

[Visual Basic]
        Public Property [sLizenzdetails]() As SqlString
            Get
                Return m_sLizenzdetails
            End Get
            Set(ByVal Value As SqlString)
                m_sLizenzdetails = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sNummer -Eigenschaft

[Visual Basic]
Public Property sNummer() As SqlString

Quellcode

[Visual Basic]
        Public Property [sNummer]() As SqlString
            Get
                Return m_sNummer
            End Get
            Set(ByVal Value As SqlString)
                m_sNummer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sSuchbegriffe -Eigenschaft

[Visual Basic]
Public Property sSuchbegriffe() As SqlString

Quellcode

[Visual Basic]
        Public Property [sSuchbegriffe]() As SqlString
            Get
                Return m_sSuchbegriffe
            End Get
            Set(ByVal Value As SqlString)
                m_sSuchbegriffe = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.sVersion -Eigenschaft

[Visual Basic]
Public Property sVersion() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement-Methoden

clsVertragselement Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method DeleteAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method SelectAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnerNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragspartnerNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragspartnerNr' in all rows which have as value for this field the value as set in property 'iVertragspartnerNrOld' to the value as set in property 'iVertragspartnerNr'.
public method UpdateAllWVertragstypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragstypNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragstypNr' in all rows which have as value for this field the value as set in property 'iVertragstypNrOld' to the value as set in property 'iVertragstypNr'.

clsVertragselement -Klasse


clsVertragselement.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.DeleteAllWVertragspartnerNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'

[Visual Basic]
Public Function DeleteAllWVertragspartnerNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragspartnerNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_DeleteAllWVertragspartnerNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragspartnerNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnerNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_DeleteAllWVertragspartnerNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::DeleteAllWVertragspartnerNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.DeleteAllWVertragstypNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragstypNr'

[Visual Basic]
Public Function DeleteAllWVertragstypNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragstypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_DeleteAllWVertragstypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragstypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_DeleteAllWVertragstypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::DeleteAllWVertragstypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> <LI>iVertragstypNr. May be SqlInt32.Null</LI> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>sNummer. May be SqlString.Null</LI> <LI>daUnterzeichnet_am. May be SqlDateTime.Null</LI> <LI>daVertragsbeginn. May be SqlDateTime.Null</LI> <LI>daVertragsablauf. May be SqlDateTime.Null</LI> <LI>bBefristet_Unbefristet. May be SqlBoolean.Null</LI> <LI>daMindestvertragsdauer_bis. May be SqlDateTime.Null</LI> <LI>daGekuendigt_am. May be SqlDateTime.Null</LI> <LI>daGekuendigt_per. May be SqlDateTime.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>sSuchbegriffe. May be SqlString.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iLizenztypnr. May be SqlInt32.Null</LI> <LI>sLizenzdetails. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daUnterzeichnet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daUnterzeichnet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsbeginn", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVertragsbeginn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsablauf", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVertragsablauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBefristet_Unbefristet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bBefristet_Unbefristet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMindestvertragsdauer_bis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMindestvertragsdauer_bis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGekuendigt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_per", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGekuendigt_per))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSuchbegriffe", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSuchbegriffe))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sLizenzdetails", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLizenzdetails))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.SelectAllWVertragspartnerNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'

[Visual Basic]
Public Function SelectAllWVertragspartnerNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragspartnerNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectAllWVertragspartnerNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragspartnerNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnerNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectAllWVertragspartnerNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectAllWVertragspartnerNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.SelectAllWVertragstypNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragstypNr'

[Visual Basic]
Public Function SelectAllWVertragstypNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragstypNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectAllWVertragstypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragstypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectAllWVertragstypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectAllWVertragstypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragselementnr</LI> <LI>iVertragstypNr</LI> <LI>iVertragspartnerNr</LI> <LI>iParentID</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>sVersion</LI> <LI>daVersionsdatum</LI> <LI>sNummer</LI> <LI>daUnterzeichnet_am</LI> <LI>daVertragsbeginn</LI> <LI>daVertragsablauf</LI> <LI>bBefristet_Unbefristet</LI> <LI>daMindestvertragsdauer_bis</LI> <LI>daGekuendigt_am</LI> <LI>daGekuendigt_per</LI> <LI>iSecurityLevelNr</LI> <LI>sSuchbegriffe</LI> <LI>iApplikationNr</LI> <LI>iLizenztypnr</LI> <LI>sLizenzdetails</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragselementnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr"), Integer))
                    If dtToReturn.Rows(0)("VertragstypNr") Is System.DBNull.Value Then
                        m_iVertragstypNr = SqlInt32.Null
                    Else
                        m_iVertragstypNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragstypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("VertragspartnerNr") Is System.DBNull.Value Then
                        m_iVertragspartnerNr = SqlInt32.Null
                    Else
                        m_iVertragspartnerNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragspartnerNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("Version"), String))
                    End If
                    If dtToReturn.Rows(0)("Versionsdatum") Is System.DBNull.Value Then
                        m_daVersionsdatum = SqlDateTime.Null
                    Else
                        m_daVersionsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Versionsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Nummer") Is System.DBNull.Value Then
                        m_sNummer = SqlString.Null
                    Else
                        m_sNummer = New SqlString(CType(dtToReturn.Rows(0)("Nummer"), String))
                    End If
                    If dtToReturn.Rows(0)("Unterzeichnet_am") Is System.DBNull.Value Then
                        m_daUnterzeichnet_am = SqlDateTime.Null
                    Else
                        m_daUnterzeichnet_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Unterzeichnet_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Vertragsbeginn") Is System.DBNull.Value Then
                        m_daVertragsbeginn = SqlDateTime.Null
                    Else
                        m_daVertragsbeginn = New SqlDateTime(CType(dtToReturn.Rows(0)("Vertragsbeginn"), Date))
                    End If
                    If dtToReturn.Rows(0)("Vertragsablauf") Is System.DBNull.Value Then
                        m_daVertragsablauf = SqlDateTime.Null
                    Else
                        m_daVertragsablauf = New SqlDateTime(CType(dtToReturn.Rows(0)("Vertragsablauf"), Date))
                    End If
                    If dtToReturn.Rows(0)("Befristet_Unbefristet") Is System.DBNull.Value Then
                        m_bBefristet_Unbefristet = SqlBoolean.Null
                    Else
                        m_bBefristet_Unbefristet = New SqlBoolean(CType(dtToReturn.Rows(0)("Befristet_Unbefristet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Mindestvertragsdauer_bis") Is System.DBNull.Value Then
                        m_daMindestvertragsdauer_bis = SqlDateTime.Null
                    Else
                        m_daMindestvertragsdauer_bis = New SqlDateTime(CType(dtToReturn.Rows(0)("Mindestvertragsdauer_bis"), Date))
                    End If
                    If dtToReturn.Rows(0)("Gekuendigt_am") Is System.DBNull.Value Then
                        m_daGekuendigt_am = SqlDateTime.Null
                    Else
                        m_daGekuendigt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Gekuendigt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Gekuendigt_per") Is System.DBNull.Value Then
                        m_daGekuendigt_per = SqlDateTime.Null
                    Else
                        m_daGekuendigt_per = New SqlDateTime(CType(dtToReturn.Rows(0)("Gekuendigt_per"), Date))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Suchbegriffe") Is System.DBNull.Value Then
                        m_sSuchbegriffe = SqlString.Null
                    Else
                        m_sSuchbegriffe = New SqlString(CType(dtToReturn.Rows(0)("Suchbegriffe"), String))
                    End If
                    If dtToReturn.Rows(0)("ApplikationNr") Is System.DBNull.Value Then
                        m_iApplikationNr = SqlInt32.Null
                    Else
                        m_iApplikationNr = New SqlInt32(CType(dtToReturn.Rows(0)("ApplikationNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Lizenztypnr") Is System.DBNull.Value Then
                        m_iLizenztypnr = SqlInt32.Null
                    Else
                        m_iLizenztypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Lizenztypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Lizenzdetails") Is System.DBNull.Value Then
                        m_sLizenzdetails = SqlString.Null
                    Else
                        m_sLizenzdetails = New SqlString(CType(dtToReturn.Rows(0)("Lizenzdetails"), String))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr</LI> <LI>iVertragstypNr. May be SqlInt32.Null</LI> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> <LI>iParentID. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>sVersion. May be SqlString.Null</LI> <LI>daVersionsdatum. May be SqlDateTime.Null</LI> <LI>sNummer. May be SqlString.Null</LI> <LI>daUnterzeichnet_am. May be SqlDateTime.Null</LI> <LI>daVertragsbeginn. May be SqlDateTime.Null</LI> <LI>daVertragsablauf. May be SqlDateTime.Null</LI> <LI>bBefristet_Unbefristet. May be SqlBoolean.Null</LI> <LI>daMindestvertragsdauer_bis. May be SqlDateTime.Null</LI> <LI>daGekuendigt_am. May be SqlDateTime.Null</LI> <LI>daGekuendigt_per. May be SqlDateTime.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>sSuchbegriffe. May be SqlString.Null</LI> <LI>iApplikationNr. May be SqlInt32.Null</LI> <LI>iLizenztypnr. May be SqlInt32.Null</LI> <LI>sLizenzdetails. May be SqlString.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVersion", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVersionsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVersionsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daUnterzeichnet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daUnterzeichnet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsbeginn", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVertragsbeginn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daVertragsablauf", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daVertragsablauf))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBefristet_Unbefristet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bBefristet_Unbefristet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMindestvertragsdauer_bis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMindestvertragsdauer_bis))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGekuendigt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGekuendigt_per", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daGekuendigt_per))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSuchbegriffe", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSuchbegriffe))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iLizenztypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iLizenztypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sLizenzdetails", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLizenzdetails))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.UpdateAllWVertragspartnerNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'VertragspartnerNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragspartnerNr' in all rows which have as value for this field the value as set in property 'iVertragspartnerNrOld' to the value as set in property 'iVertragspartnerNr'.

[Visual Basic]
Public Function UpdateAllWVertragspartnerNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr. May be SqlInt32.Null</LI> <LI>iVertragspartnerNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragspartnerNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_UpdateAllWVertragspartnerNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragspartnerNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragspartnerNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_UpdateAllWVertragspartnerNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::UpdateAllWVertragspartnerNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.UpdateAllWVertragstypNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'VertragstypNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragstypNr' in all rows which have as value for this field the value as set in property 'iVertragstypNrOld' to the value as set in property 'iVertragstypNr'.

[Visual Basic]
Public Function UpdateAllWVertragstypNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypNr. May be SqlInt32.Null</LI> <LI>iVertragstypNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragstypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_UpdateAllWVertragstypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragstypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_UpdateAllWVertragstypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement::UpdateAllWVertragstypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement-Felder

clsVertragselement Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bBefristet_Unbefristet

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daGekuendigt_am

Unterstützt von .NET Compact Framework
private field m_daGekuendigt_per

Unterstützt von .NET Compact Framework
private field m_daMindestvertragsdauer_bis

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daUnterzeichnet_am

Unterstützt von .NET Compact Framework
private field m_daVersionsdatum

Unterstützt von .NET Compact Framework
private field m_daVertragsablauf

Unterstützt von .NET Compact Framework
private field m_daVertragsbeginn

Unterstützt von .NET Compact Framework
private field m_iApplikationNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iLizenztypnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iParentID

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNrOld

Unterstützt von .NET Compact Framework
private field m_iVertragstypNr

Unterstützt von .NET Compact Framework
private field m_iVertragstypNrOld

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
private field m_sLizenzdetails

Unterstützt von .NET Compact Framework
private field m_sNummer

Unterstützt von .NET Compact Framework
private field m_sSuchbegriffe

Unterstützt von .NET Compact Framework
private field m_sVersion

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselement -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bBefristet_Unbefristet As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_bBefristet_Unbefristet -Feld

[Visual Basic]
Private m_bBefristet_Unbefristet As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv, m_bBefristet_Unbefristet As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daGekuendigt_am -Feld

[Visual Basic]
Private m_daGekuendigt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daGekuendigt_per -Feld

[Visual Basic]
Private m_daGekuendigt_per As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daMindestvertragsdauer_bis -Feld

[Visual Basic]
Private m_daMindestvertragsdauer_bis As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daUnterzeichnet_am -Feld

[Visual Basic]
Private m_daUnterzeichnet_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daVersionsdatum -Feld

[Visual Basic]
Private m_daVersionsdatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daVertragsablauf -Feld

[Visual Basic]
Private m_daVertragsablauf As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_daVertragsbeginn -Feld

[Visual Basic]
Private m_daVertragsbeginn As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daVertragsbeginn, m_daUnterzeichnet_am, m_daGekuendigt_per, m_daGekuendigt_am, m_daMindestvertragsdauer_bis, m_daVertragsablauf, m_daErstellt_am, m_daMutiert_am, m_daVersionsdatum As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iApplikationNr -Feld

[Visual Basic]
Private m_iApplikationNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iLizenztypnr -Feld

[Visual Basic]
Private m_iLizenztypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iParentID -Feld

[Visual Basic]
Private m_iParentID As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iVertragselementnr -Feld

[Visual Basic]
Private m_iVertragselementnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iVertragspartnerNr -Feld

[Visual Basic]
Private m_iVertragspartnerNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iVertragspartnerNrOld -Feld

[Visual Basic]
Private m_iVertragspartnerNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iVertragstypNr -Feld

[Visual Basic]
Private m_iVertragstypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_iVertragstypNrOld -Feld

[Visual Basic]
Private m_iVertragstypNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragselementnr, m_iApplikationNr, m_iMutierer, m_iLizenztypnr, m_iSecurityLevelNr, m_iVertragspartnerNr, m_iVertragspartnerNrOld, m_iParentID, m_iVertragstypNr, m_iVertragstypNrOld As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sLizenzdetails -Feld

[Visual Basic]
Private m_sLizenzdetails As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sNummer -Feld

[Visual Basic]
Private m_sNummer As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sSuchbegriffe -Feld

[Visual Basic]
Private m_sSuchbegriffe As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


m_sVersion -Feld

[Visual Basic]
Private m_sVersion As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sLizenzdetails, m_sBeschreibung, m_sNummer, m_sVersion, m_sSuchbegriffe As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselementApplikation -Klasse

Purpose: Data Access class for the table 'VertragselementApplikation'.

For a list of all members of this type, see clsVertragselementApplikation-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselementApplikation

[Visual Basic]
Public Class clsVertragselementApplikation
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragselementApplikation-Member


clsVertragselementApplikation-Member

clsVertragselementApplikation Übersicht

Öffentliche Konstruktoren

public constructor clsVertragselementApplikation -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragselementApplikationnr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iVertragselementApplikationnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


clsVertragselementApplikation -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation-Eigenschaften

clsVertragselementApplikation Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iApplikationnr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragselementApplikationnr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


clsVertragselementApplikation.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.iApplikationnr -Eigenschaft

[Visual Basic]
Public Property iApplikationnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iApplikationnr]() As SqlInt32
            Get
                Return m_iApplikationnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iApplikationnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.iVertragselementApplikationnr -Eigenschaft

[Visual Basic]
Public Property iVertragselementApplikationnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementApplikationnr]() As SqlInt32
            Get
                Return m_iVertragselementApplikationnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragselementApplikationnrTmp As SqlInt32 = Value
                If iVertragselementApplikationnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragselementApplikationnr", "iVertragselementApplikationnr can't be NULL")
                End If
                m_iVertragselementApplikationnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.iVertragselementnr -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr]() As SqlInt32
            Get
                Return m_iVertragselementnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation-Methoden

clsVertragselementApplikation Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragselementApplikation -Klasse


clsVertragselementApplikation.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementApplikationnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VertragselementApplikation_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementApplikationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VertragselementApplikation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselementApplikation::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementApplikationnr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iApplikationnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VertragselementApplikation_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VertragselementApplikation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselementApplikation::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VertragselementApplikation_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("VertragselementApplikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VertragselementApplikation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselementApplikation::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementApplikationnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragselementApplikationnr</LI> <LI>iVertragselementnr</LI> <LI>iApplikationnr</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VertragselementApplikation_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("VertragselementApplikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementApplikationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VertragselementApplikation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragselementApplikationnr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementApplikationnr"), Integer))
                    If dtToReturn.Rows(0)("Vertragselementnr") Is System.DBNull.Value Then
                        m_iVertragselementnr = SqlInt32.Null
                    Else
                        m_iVertragselementnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Applikationnr") Is System.DBNull.Value Then
                        m_iApplikationnr = SqlInt32.Null
                    Else
                        m_iApplikationnr = New SqlInt32(CType(dtToReturn.Rows(0)("Applikationnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselementApplikation::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementApplikationnr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iApplikationnr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VertragselementApplikation_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iApplikationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iApplikationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VertragselementApplikation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselementApplikation::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation-Felder

clsVertragselementApplikation Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iApplikationnr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iVertragselementApplikationnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_iApplikationnr -Feld

[Visual Basic]
Private m_iApplikationnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iVertragselementApplikationnr, m_iVertragselementnr, m_iApplikationnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iVertragselementApplikationnr, m_iVertragselementnr, m_iApplikationnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_iVertragselementApplikationnr -Feld

[Visual Basic]
Private m_iVertragselementApplikationnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iVertragselementApplikationnr, m_iVertragselementnr, m_iApplikationnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_iVertragselementnr -Feld

[Visual Basic]
Private m_iVertragselementnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iVertragselementApplikationnr, m_iVertragselementnr, m_iApplikationnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselement_Referenz -Klasse

Purpose: Data Access class for the table 'Vertragselement_Referenz'.

For a list of all members of this type, see clsVertragselement_Referenz-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz
Vertragsverwaltung.TKB.VV.Vertrag.clsReferenzvertrag

[Visual Basic]
Public Class clsVertragselement_Referenz
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragselement_Referenz-Member


clsVertragselement_Referenz-Member

clsVertragselement_Referenz Übersicht

Öffentliche Konstruktoren

public constructor clsVertragselement_Referenz -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReferenzvertragsnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr_1

Unterstützt von .NET Compact Framework
public property iVertragselementnr_2

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBeziehungstypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReferenzvertragsnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr_1

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr_2

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselement_Referenz -Klasse


clsVertragselement_Referenz -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz-Eigenschaften

clsVertragselement_Referenz Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iReferenzvertragsnr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr_1

Unterstützt von .NET Compact Framework
public property iVertragselementnr_2

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselement_Referenz -Klasse


clsVertragselement_Referenz.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iBeziehungstypNr -Eigenschaft

[Visual Basic]
Public Property iBeziehungstypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iBeziehungstypNr]() As SqlInt32
            Get
                Return m_iBeziehungstypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBeziehungstypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iReferenzvertragsnr -Eigenschaft

[Visual Basic]
Public Property iReferenzvertragsnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iReferenzvertragsnr]() As SqlInt32
            Get
                Return m_iReferenzvertragsnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReferenzvertragsnrTmp As SqlInt32 = Value
                If iReferenzvertragsnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReferenzvertragsnr", "iReferenzvertragsnr can't be NULL")
                End If
                m_iReferenzvertragsnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iVertragselementnr_1 -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr_1() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr_1]() As SqlInt32
            Get
                Return m_iVertragselementnr_1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnr_1 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.iVertragselementnr_2 -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr_2() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr_2]() As SqlInt32
            Get
                Return m_iVertragselementnr_2
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnr_2 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz-Methoden

clsVertragselement_Referenz Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragselement_Referenz -Klasse


clsVertragselement_Referenz.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReferenzvertragsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Referenz_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReferenzvertragsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReferenzvertragsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Referenz_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement_Referenz::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReferenzvertragsnr</LI> <LI>iVertragselementnr_1. May be SqlInt32.Null</LI> <LI>iVertragselementnr_2. May be SqlInt32.Null</LI> <LI>iBeziehungstypNr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Referenz_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReferenzvertragsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReferenzvertragsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr_1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr_1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr_2", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr_2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Referenz_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement_Referenz::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Referenz_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement_Referenz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Referenz_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement_Referenz::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReferenzvertragsnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iReferenzvertragsnr</LI> <LI>iVertragselementnr_1</LI> <LI>iVertragselementnr_2</LI> <LI>iBeziehungstypNr</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Referenz_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragselement_Referenz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReferenzvertragsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReferenzvertragsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Referenz_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReferenzvertragsnr = New SqlInt32(CType(dtToReturn.Rows(0)("Referenzvertragsnr"), Integer))
                    If dtToReturn.Rows(0)("Vertragselementnr_1") Is System.DBNull.Value Then
                        m_iVertragselementnr_1 = SqlInt32.Null
                    Else
                        m_iVertragselementnr_1 = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr_1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Vertragselementnr_2") Is System.DBNull.Value Then
                        m_iVertragselementnr_2 = SqlInt32.Null
                    Else
                        m_iVertragselementnr_2 = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr_2"), Integer))
                    End If
                    If dtToReturn.Rows(0)("BeziehungstypNr") Is System.DBNull.Value Then
                        m_iBeziehungstypNr = SqlInt32.Null
                    Else
                        m_iBeziehungstypNr = New SqlInt32(CType(dtToReturn.Rows(0)("BeziehungstypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement_Referenz::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iReferenzvertragsnr</LI> <LI>iVertragselementnr_1. May be SqlInt32.Null</LI> <LI>iVertragselementnr_2. May be SqlInt32.Null</LI> <LI>iBeziehungstypNr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragselement_Referenz_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReferenzvertragsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReferenzvertragsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr_1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr_1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr_2", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr_2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBeziehungstypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBeziehungstypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragselement_Referenz_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragselement_Referenz::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragselement_Referenz-Felder

clsVertragselement_Referenz Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_iBeziehungstypNr

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iReferenzvertragsnr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr_1

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr_2

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselement_Referenz -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iBeziehungstypNr -Feld

[Visual Basic]
Private m_iBeziehungstypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iReferenzvertragsnr -Feld

[Visual Basic]
Private m_iReferenzvertragsnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iVertragselementnr_1 -Feld

[Visual Basic]
Private m_iVertragselementnr_1 As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_iVertragselementnr_2 -Feld

[Visual Basic]
Private m_iVertragselementnr_2 As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragselementnr_2, m_iVertragselementnr_1, m_iBeziehungstypNr, m_iReferenzvertragsnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement_Referenz


clsVertragsereignis -Klasse

Purpose: Data Access class for the table 'Vertragsereignis'.

For a list of all members of this type, see clsVertragsereignis-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsereignis

[Visual Basic]
Public Class clsVertragsereignis
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragsereignis-Member


clsVertragsereignis-Member

clsVertragsereignis Übersicht

Öffentliche Konstruktoren

public constructor clsVertragsereignis -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bInklMwSt

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daDatum

Unterstützt von .NET Compact Framework
public property daEnde

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daStart

Unterstützt von .NET Compact Framework
public property fBetrag

Unterstützt von .NET Compact Framework
public property iEreignisNr

Unterstützt von .NET Compact Framework
public property iEreignistypNr

Unterstützt von .NET Compact Framework
public property iEreignistypNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr

Unterstützt von .NET Compact Framework
public property iKostenartNrOld

Unterstützt von .NET Compact Framework
public property iKuendigungsfristnr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPeriodizitaetNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld

Unterstützt von .NET Compact Framework
public property iVorlaufzeit

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method DeleteAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method DeleteAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method SelectAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method SelectAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'EreignistypNr. This method will Update one or more existing rows in the database. It will reset the field 'EreignistypNr' in all rows which have as value for this field the value as set in property 'iEreignistypNrOld' to the value as set in property 'iEreignistypNr'.
public method UpdateAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'KostenartNr. This method will Update one or more existing rows in the database. It will reset the field 'KostenartNr' in all rows which have as value for this field the value as set in property 'iKostenartNrOld' to the value as set in property 'iKostenartNr'.
public method UpdateAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bInklMwSt

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daDatum

Unterstützt von .NET Compact Framework
private field m_daEnde

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daStart

Unterstützt von .NET Compact Framework
private field m_fBetrag

Unterstützt von .NET Compact Framework
private field m_iEreignisNr

Unterstützt von .NET Compact Framework
private field m_iEreignistypNr

Unterstützt von .NET Compact Framework
private field m_iEreignistypNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKostenartNr

Unterstützt von .NET Compact Framework
private field m_iKostenartNrOld

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristnr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPeriodizitaetNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnrOld

Unterstützt von .NET Compact Framework
private field m_iVorlaufzeit

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


clsVertragsereignis -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis-Eigenschaften

clsVertragsereignis Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bInklMwSt

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daDatum

Unterstützt von .NET Compact Framework
public property daEnde

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property daStart

Unterstützt von .NET Compact Framework
public property fBetrag

Unterstützt von .NET Compact Framework
public property iEreignisNr

Unterstützt von .NET Compact Framework
public property iEreignistypNr

Unterstützt von .NET Compact Framework
public property iEreignistypNrOld

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr

Unterstützt von .NET Compact Framework
public property iKostenartNrOld

Unterstützt von .NET Compact Framework
public property iKuendigungsfristnr

Unterstützt von .NET Compact Framework
public property iMandantNr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPeriodizitaetNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragselementnr

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld

Unterstützt von .NET Compact Framework
public property iVorlaufzeit

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


clsVertragsereignis.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.bInklMwSt -Eigenschaft

[Visual Basic]
Public Property bInklMwSt() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bInklMwSt]() As SqlBoolean
            Get
                Return m_bInklMwSt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklMwSt = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.daDatum -Eigenschaft

[Visual Basic]
Public Property daDatum() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daDatum]() As SqlDateTime
            Get
                Return m_daDatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.daEnde -Eigenschaft

[Visual Basic]
Public Property daEnde() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daEnde]() As SqlDateTime
            Get
                Return m_daEnde
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daEnde = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.daStart -Eigenschaft

[Visual Basic]
Public Property daStart() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daStart]() As SqlDateTime
            Get
                Return m_daStart
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daStart = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.fBetrag -Eigenschaft

[Visual Basic]
Public Property fBetrag() As SqlDouble

Quellcode

[Visual Basic]
        Public Property [fBetrag]() As SqlDouble
            Get
                Return m_fBetrag
            End Get
            Set(ByVal Value As SqlDouble)
                m_fBetrag = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iEreignisNr -Eigenschaft

[Visual Basic]
Public Property iEreignisNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEreignisNr]() As SqlInt32
            Get
                Return m_iEreignisNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEreignisNrTmp As SqlInt32 = Value
                If iEreignisNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEreignisNr", "iEreignisNr can't be NULL")
                End If
                m_iEreignisNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iEreignistypNr -Eigenschaft

[Visual Basic]
Public Property iEreignistypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEreignistypNr]() As SqlInt32
            Get
                Return m_iEreignistypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iEreignistypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iEreignistypNrOld -Eigenschaft

[Visual Basic]
Public Property iEreignistypNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iEreignistypNrOld]() As SqlInt32
            Get
                Return m_iEreignistypNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iEreignistypNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iKostenartNr -Eigenschaft

[Visual Basic]
Public Property iKostenartNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKostenartNr]() As SqlInt32
            Get
                Return m_iKostenartNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKostenartNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iKostenartNrOld -Eigenschaft

[Visual Basic]
Public Property iKostenartNrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKostenartNrOld]() As SqlInt32
            Get
                Return m_iKostenartNrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKostenartNrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iKuendigungsfristnr -Eigenschaft

[Visual Basic]
Public Property iKuendigungsfristnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKuendigungsfristnr]() As SqlInt32
            Get
                Return m_iKuendigungsfristnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKuendigungsfristnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iMandantNr -Eigenschaft

[Visual Basic]
Public Property iMandantNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantNr]() As SqlInt32
            Get
                Return m_iMandantNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iPeriodizitaetNr -Eigenschaft

[Visual Basic]
Public Property iPeriodizitaetNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPeriodizitaetNr]() As SqlInt32
            Get
                Return m_iPeriodizitaetNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPeriodizitaetNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iVertragselementnr -Eigenschaft

[Visual Basic]
Public Property iVertragselementnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnr]() As SqlInt32
            Get
                Return m_iVertragselementnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iVertragselementnrOld -Eigenschaft

[Visual Basic]
Public Property iVertragselementnrOld() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementnrOld]() As SqlInt32
            Get
                Return m_iVertragselementnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementnrOld = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.iVorlaufzeit -Eigenschaft

[Visual Basic]
Public Property iVorlaufzeit() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVorlaufzeit]() As SqlInt32
            Get
                Return m_iVorlaufzeit
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlaufzeit = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis-Methoden

clsVertragsereignis Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method DeleteAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method DeleteAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method DeleteAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method SelectAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method SelectAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWEreignistypNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'EreignistypNr. This method will Update one or more existing rows in the database. It will reset the field 'EreignistypNr' in all rows which have as value for this field the value as set in property 'iEreignistypNrOld' to the value as set in property 'iEreignistypNr'.
public method UpdateAllWKostenartNrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'KostenartNr. This method will Update one or more existing rows in the database. It will reset the field 'KostenartNr' in all rows which have as value for this field the value as set in property 'iKostenartNrOld' to the value as set in property 'iKostenartNr'.
public method UpdateAllWVertragselementnrLogic Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

clsVertragsereignis -Klasse


clsVertragsereignis.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignisNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignisNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignisNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.DeleteAllWEreignistypNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'EreignistypNr'

[Visual Basic]
Public Function DeleteAllWEreignistypNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWEreignistypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_DeleteAllWEreignistypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignistypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iEreignistypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iEreignistypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_DeleteAllWEreignistypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::DeleteAllWEreignistypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.DeleteAllWKostenartNrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'KostenartNr'

[Visual Basic]
Public Function DeleteAllWKostenartNrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWKostenartNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_DeleteAllWKostenartNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iKostenartNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iKostenartNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_DeleteAllWKostenartNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::DeleteAllWKostenartNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.DeleteAllWVertragselementnrLogic -Methode

Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'

[Visual Basic]
Public Function DeleteAllWVertragselementnrLogic() As Boolean

Rückgabewert

true if succeeded, false otherwise

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function DeleteAllWVertragselementnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_DeleteAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_DeleteAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::DeleteAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignisNr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iEreignistypNr. May be SqlInt32.Null</LI> <LI>iPeriodizitaetNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>fBetrag. May be SqlDouble.Null</LI> <LI>bInklMwSt. May be SqlBoolean.Null</LI> <LI>daDatum. May be SqlDateTime.Null</LI> <LI>daStart. May be SqlDateTime.Null</LI> <LI>daEnde. May be SqlDateTime.Null</LI> <LI>iVorlaufzeit. May be SqlInt32.Null</LI> <LI>iKostenartNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iKuendigungsfristnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignisNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignisNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignistypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPeriodizitaetNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaetNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fBetrag", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fBetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bInklMwSt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bInklMwSt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daStart", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daStart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daEnde", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daEnde))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVorlaufzeit", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlaufzeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsereignis")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.SelectAllWEreignistypNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'EreignistypNr'

[Visual Basic]
Public Function SelectAllWEreignistypNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWEreignistypNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_SelectAllWEreignistypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsereignis")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignistypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iEreignistypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iEreignistypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_SelectAllWEreignistypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::SelectAllWEreignistypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.SelectAllWKostenartNrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'KostenartNr'

[Visual Basic]
Public Function SelectAllWKostenartNrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWKostenartNrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_SelectAllWKostenartNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsereignis")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iKostenartNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iKostenartNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_SelectAllWKostenartNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::SelectAllWKostenartNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.SelectAllWVertragselementnrLogic -Methode

Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'

[Visual Basic]
Public Function SelectAllWVertragselementnrLogic() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAllWVertragselementnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_SelectAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsereignis")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_SelectAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::SelectAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignisNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iEreignisNr</LI> <LI>iVertragselementnr</LI> <LI>iEreignistypNr</LI> <LI>iPeriodizitaetNr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>fBetrag</LI> <LI>bInklMwSt</LI> <LI>daDatum</LI> <LI>daStart</LI> <LI>daEnde</LI> <LI>iVorlaufzeit</LI> <LI>iKostenartNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantNr</LI> <LI>iSecurityLevelNr</LI> <LI>iKuendigungsfristnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsereignis")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignisNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignisNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEreignisNr = New SqlInt32(CType(dtToReturn.Rows(0)("EreignisNr"), Integer))
                    If dtToReturn.Rows(0)("Vertragselementnr") Is System.DBNull.Value Then
                        m_iVertragselementnr = SqlInt32.Null
                    Else
                        m_iVertragselementnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragselementnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("EreignistypNr") Is System.DBNull.Value Then
                        m_iEreignistypNr = SqlInt32.Null
                    Else
                        m_iEreignistypNr = New SqlInt32(CType(dtToReturn.Rows(0)("EreignistypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PeriodizitaetNr") Is System.DBNull.Value Then
                        m_iPeriodizitaetNr = SqlInt32.Null
                    Else
                        m_iPeriodizitaetNr = New SqlInt32(CType(dtToReturn.Rows(0)("PeriodizitaetNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Betrag") Is System.DBNull.Value Then
                        m_fBetrag = SqlDouble.Null
                    Else
                        m_fBetrag = New SqlDouble(CType(dtToReturn.Rows(0)("Betrag"), Double))
                    End If
                    If dtToReturn.Rows(0)("InklMwSt") Is System.DBNull.Value Then
                        m_bInklMwSt = SqlBoolean.Null
                    Else
                        m_bInklMwSt = New SqlBoolean(CType(dtToReturn.Rows(0)("InklMwSt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Datum") Is System.DBNull.Value Then
                        m_daDatum = SqlDateTime.Null
                    Else
                        m_daDatum = New SqlDateTime(CType(dtToReturn.Rows(0)("Datum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Start") Is System.DBNull.Value Then
                        m_daStart = SqlDateTime.Null
                    Else
                        m_daStart = New SqlDateTime(CType(dtToReturn.Rows(0)("Start"), Date))
                    End If
                    If dtToReturn.Rows(0)("Ende") Is System.DBNull.Value Then
                        m_daEnde = SqlDateTime.Null
                    Else
                        m_daEnde = New SqlDateTime(CType(dtToReturn.Rows(0)("Ende"), Date))
                    End If
                    If dtToReturn.Rows(0)("Vorlaufzeit") Is System.DBNull.Value Then
                        m_iVorlaufzeit = SqlInt32.Null
                    Else
                        m_iVorlaufzeit = New SqlInt32(CType(dtToReturn.Rows(0)("Vorlaufzeit"), Integer))
                    End If
                    If dtToReturn.Rows(0)("KostenartNr") Is System.DBNull.Value Then
                        m_iKostenartNr = SqlInt32.Null
                    Else
                        m_iKostenartNr = New SqlInt32(CType(dtToReturn.Rows(0)("KostenartNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("MandantNr") Is System.DBNull.Value Then
                        m_iMandantNr = SqlInt32.Null
                    Else
                        m_iMandantNr = New SqlInt32(CType(dtToReturn.Rows(0)("MandantNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Kuendigungsfristnr") Is System.DBNull.Value Then
                        m_iKuendigungsfristnr = SqlInt32.Null
                    Else
                        m_iKuendigungsfristnr = New SqlInt32(CType(dtToReturn.Rows(0)("Kuendigungsfristnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignisNr</LI> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iEreignistypNr. May be SqlInt32.Null</LI> <LI>iPeriodizitaetNr. May be SqlInt32.Null</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>fBetrag. May be SqlDouble.Null</LI> <LI>bInklMwSt. May be SqlBoolean.Null</LI> <LI>daDatum. May be SqlDateTime.Null</LI> <LI>daStart. May be SqlDateTime.Null</LI> <LI>daEnde. May be SqlDateTime.Null</LI> <LI>iVorlaufzeit. May be SqlInt32.Null</LI> <LI>iKostenartNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantNr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>iKuendigungsfristnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignisNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEreignisNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iEreignistypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPeriodizitaetNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaetNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fBetrag", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fBetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bInklMwSt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bInklMwSt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daDatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daStart", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daStart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daEnde", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daEnde))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVorlaufzeit", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlaufzeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKuendigungsfristnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKuendigungsfristnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.UpdateAllWEreignistypNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'EreignistypNr. This method will Update one or more existing rows in the database. It will reset the field 'EreignistypNr' in all rows which have as value for this field the value as set in property 'iEreignistypNrOld' to the value as set in property 'iEreignistypNr'.

[Visual Basic]
Public Function UpdateAllWEreignistypNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iEreignistypNr. May be SqlInt32.Null</LI> <LI>iEreignistypNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWEreignistypNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_UpdateAllWEreignistypNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignistypNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iEreignistypNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iEreignistypNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iEreignistypNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iEreignistypNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_UpdateAllWEreignistypNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::UpdateAllWEreignistypNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.UpdateAllWKostenartNrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'KostenartNr. This method will Update one or more existing rows in the database. It will reset the field 'KostenartNr' in all rows which have as value for this field the value as set in property 'iKostenartNrOld' to the value as set in property 'iKostenartNr'.

[Visual Basic]
Public Function UpdateAllWKostenartNrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iKostenartNr. May be SqlInt32.Null</LI> <LI>iKostenartNrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWKostenartNrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_UpdateAllWKostenartNrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKostenartNr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iKostenartNrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenartNrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iKostenartNr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iKostenartNr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_UpdateAllWKostenartNrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::UpdateAllWKostenartNrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.UpdateAllWVertragselementnrLogic -Methode

Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.

[Visual Basic]
Public Function UpdateAllWVertragselementnrLogic() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragselementnr. May be SqlInt32.Null</LI> <LI>iVertragselementnrOld. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function UpdateAllWVertragselementnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsereignis_UpdateAllWVertragselementnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragselementnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragselementnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragselementnr").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsereignis_UpdateAllWVertragselementnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsereignis::UpdateAllWVertragselementnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis-Felder

clsVertragsereignis Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bInklMwSt

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daDatum

Unterstützt von .NET Compact Framework
private field m_daEnde

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
private field m_daStart

Unterstützt von .NET Compact Framework
private field m_fBetrag

Unterstützt von .NET Compact Framework
private field m_iEreignisNr

Unterstützt von .NET Compact Framework
private field m_iEreignistypNr

Unterstützt von .NET Compact Framework
private field m_iEreignistypNrOld

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKostenartNr

Unterstützt von .NET Compact Framework
private field m_iKostenartNrOld

Unterstützt von .NET Compact Framework
private field m_iKuendigungsfristnr

Unterstützt von .NET Compact Framework
private field m_iMandantNr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPeriodizitaetNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnr

Unterstützt von .NET Compact Framework
private field m_iVertragselementnrOld

Unterstützt von .NET Compact Framework
private field m_iVorlaufzeit

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bInklMwSt, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_bInklMwSt -Feld

[Visual Basic]
Private m_bInklMwSt As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bInklMwSt, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_daDatum -Feld

[Visual Basic]
Private m_daDatum As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daDatum, m_daEnde, m_daStart, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_daEnde -Feld

[Visual Basic]
Private m_daEnde As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daDatum, m_daEnde, m_daStart, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daDatum, m_daEnde, m_daStart, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daDatum, m_daEnde, m_daStart, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_daStart -Feld

[Visual Basic]
Private m_daStart As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daDatum, m_daEnde, m_daStart, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_fBetrag -Feld

[Visual Basic]
Private m_fBetrag As SqlDouble

Quellcode

[Visual Basic]
        Private 		m_fBetrag As SqlDouble

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iEreignisNr -Feld

[Visual Basic]
Private m_iEreignisNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iEreignistypNr -Feld

[Visual Basic]
Private m_iEreignistypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iEreignistypNrOld -Feld

[Visual Basic]
Private m_iEreignistypNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iKostenartNr -Feld

[Visual Basic]
Private m_iKostenartNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iKostenartNrOld -Feld

[Visual Basic]
Private m_iKostenartNrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iKuendigungsfristnr -Feld

[Visual Basic]
Private m_iKuendigungsfristnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iMandantNr -Feld

[Visual Basic]
Private m_iMandantNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iPeriodizitaetNr -Feld

[Visual Basic]
Private m_iPeriodizitaetNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iVertragselementnr -Feld

[Visual Basic]
Private m_iVertragselementnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iVertragselementnrOld -Feld

[Visual Basic]
Private m_iVertragselementnrOld As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_iVorlaufzeit -Feld

[Visual Basic]
Private m_iVorlaufzeit As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iSecurityLevelNr, m_iKuendigungsfristnr, m_iMutierer, m_iMandantNr, m_iKostenartNr, m_iKostenartNrOld, m_iVertragselementnr, m_iVertragselementnrOld, m_iPeriodizitaetNr, m_iEreignistypNr, m_iEreignistypNrOld, m_iVorlaufzeit, m_iEreignisNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragskontakt -Klasse

Purpose: Data Access class for the table 'Vertragskontakt'.

For a list of all members of this type, see clsVertragskontakt-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.Vertrag.clsKontakt

[Visual Basic]
Public Class clsVertragskontakt
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragskontakt-Member


clsVertragskontakt-Member

clsVertragskontakt Übersicht

Öffentliche Konstruktoren

public constructor clsVertragskontakt -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bIntern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragsKontaktNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bIntern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragsKontaktNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragskontakt -Klasse


clsVertragskontakt -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt-Eigenschaften

clsVertragskontakt Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bIntern

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iPersonNr

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragsKontaktNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragskontakt -Klasse


clsVertragskontakt.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.bIntern -Eigenschaft

[Visual Basic]
Public Property bIntern() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bIntern]() As SqlBoolean
            Get
                Return m_bIntern
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bIntern = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iKontakttypNr -Eigenschaft

[Visual Basic]
Public Property iKontakttypNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iKontakttypNr]() As SqlInt32
            Get
                Return m_iKontakttypNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKontakttypNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iPersonNr -Eigenschaft

[Visual Basic]
Public Property iPersonNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iPersonNr]() As SqlInt32
            Get
                Return m_iPersonNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPersonNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iVertragsKontaktNr -Eigenschaft

[Visual Basic]
Public Property iVertragsKontaktNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragsKontaktNr]() As SqlInt32
            Get
                Return m_iVertragsKontaktNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragsKontaktNrTmp As SqlInt32 = Value
                If iVertragsKontaktNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragsKontaktNr", "iVertragsKontaktNr can't be NULL")
                End If
                m_iVertragsKontaktNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.iVertragselementNr -Eigenschaft

[Visual Basic]
Public Property iVertragselementNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt-Methoden

clsVertragskontakt Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragskontakt -Klasse


clsVertragskontakt.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragskontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr</LI> <LI>iPersonNr</LI> <LI>iKontakttypNr</LI> <LI>bIntern</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragskontakt")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragsKontaktNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragsKontaktNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("PersonNr") Is System.DBNull.Value Then
                        m_iPersonNr = SqlInt32.Null
                    Else
                        m_iPersonNr = New SqlInt32(CType(dtToReturn.Rows(0)("PersonNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("KontakttypNr") Is System.DBNull.Value Then
                        m_iKontakttypNr = SqlInt32.Null
                    Else
                        m_iKontakttypNr = New SqlInt32(CType(dtToReturn.Rows(0)("KontakttypNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Intern") Is System.DBNull.Value Then
                        m_bIntern = SqlBoolean.Null
                    Else
                        m_bIntern = New SqlBoolean(CType(dtToReturn.Rows(0)("Intern"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsKontaktNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iPersonNr. May be SqlInt32.Null</LI> <LI>iKontakttypNr. May be SqlInt32.Null</LI> <LI>bIntern. May be SqlBoolean.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragskontakt_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsKontaktNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsKontaktNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iPersonNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPersonNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iKontakttypNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKontakttypNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIntern", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIntern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragskontakt_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragskontakt::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragskontakt-Felder

clsVertragskontakt Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bIntern

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iKontakttypNr

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
private field m_iPersonNr

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragsKontaktNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragskontakt -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_bIntern -Feld

[Visual Basic]
Private m_bIntern As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bIntern, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iKontakttypNr -Feld

[Visual Basic]
Private m_iKontakttypNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iPersonNr -Feld

[Visual Basic]
Private m_iPersonNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iVertragsKontaktNr -Feld

[Visual Basic]
Private m_iVertragsKontaktNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_iVertragselementNr -Feld

[Visual Basic]
Private m_iVertragselementNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iVertragselementNr, m_iVertragsKontaktNr, m_iPersonNr, m_iSecurityLevelNr, m_iKontakttypNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragskontakt


clsVertragsleistung -Klasse

Purpose: Data Access class for the table 'Vertragsleistung'.

For a list of all members of this type, see clsVertragsleistung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsleistung

[Visual Basic]
Public Class clsVertragsleistung
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragsleistung-Member


clsVertragsleistung-Member

clsVertragsleistung Übersicht

Öffentliche Konstruktoren

public constructor clsVertragsleistung -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iServicekatalogNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property iVertragsleistungNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iServicekatalogNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_iVertragsleistungNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


clsVertragsleistung -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung-Eigenschaften

clsVertragsleistung Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iServicekatalogNr

Unterstützt von .NET Compact Framework
public property iVertragselementNr

Unterstützt von .NET Compact Framework
public property iVertragsleistungNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


clsVertragsleistung.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iServicekatalogNr -Eigenschaft

[Visual Basic]
Public Property iServicekatalogNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iServicekatalogNr]() As SqlInt32
            Get
                Return m_iServicekatalogNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iServicekatalogNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iVertragselementNr -Eigenschaft

[Visual Basic]
Public Property iVertragselementNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragselementNr]() As SqlInt32
            Get
                Return m_iVertragselementNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVertragselementNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.iVertragsleistungNr -Eigenschaft

[Visual Basic]
Public Property iVertragsleistungNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragsleistungNr]() As SqlInt32
            Get
                Return m_iVertragsleistungNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragsleistungNrTmp As SqlInt32 = Value
                If iVertragsleistungNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragsleistungNr", "iVertragsleistungNr can't be NULL")
                End If
                m_iVertragsleistungNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung-Methoden

clsVertragsleistung Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragsleistung -Klasse


clsVertragsleistung.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsleistungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsleistung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsleistungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsleistungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsleistung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsleistung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsleistungNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iServicekatalogNr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsleistung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsleistungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsleistungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServicekatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServicekatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsleistung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsleistung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsleistung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsleistung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsleistung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsleistung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsleistungNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragsleistungNr</LI> <LI>iVertragselementNr</LI> <LI>iServicekatalogNr</LI> <LI>sBemerkung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> <LI>iSecurityLevelNr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsleistung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragsleistung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragsleistungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsleistungNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsleistung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragsleistungNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragsleistungNr"), Integer))
                    If dtToReturn.Rows(0)("VertragselementNr") Is System.DBNull.Value Then
                        m_iVertragselementNr = SqlInt32.Null
                    Else
                        m_iVertragselementNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragselementNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ServicekatalogNr") Is System.DBNull.Value Then
                        m_iServicekatalogNr = SqlInt32.Null
                    Else
                        m_iServicekatalogNr = New SqlInt32(CType(dtToReturn.Rows(0)("ServicekatalogNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsleistung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragsleistungNr</LI> <LI>iVertragselementNr. May be SqlInt32.Null</LI> <LI>iServicekatalogNr. May be SqlInt32.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragsleistung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragsleistungNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragsleistungNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragselementNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragselementNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iServicekatalogNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iServicekatalogNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragsleistung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragsleistung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung-Felder

clsVertragsleistung Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iServicekatalogNr

Unterstützt von .NET Compact Framework
private field m_iVertragselementNr

Unterstützt von .NET Compact Framework
private field m_iVertragsleistungNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iServicekatalogNr -Feld

[Visual Basic]
Private m_iServicekatalogNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iVertragselementNr -Feld

[Visual Basic]
Private m_iVertragselementNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_iVertragsleistungNr -Feld

[Visual Basic]
Private m_iVertragsleistungNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iServicekatalogNr, m_iVertragselementNr, m_iVertragsleistungNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBemerkung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragspartner -Klasse

Purpose: Data Access class for the table 'Vertragspartner'.

For a list of all members of this type, see clsVertragspartner-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragspartner

[Visual Basic]
Public Class clsVertragspartner
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragspartner-Member


clsVertragspartner-Member

clsVertragspartner Übersicht

Öffentliche Konstruktoren

public constructor clsVertragspartner -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail

Unterstützt von .NET Compact Framework
public property sInternet

Unterstützt von .NET Compact Framework
public property sNameZ1

Unterstützt von .NET Compact Framework
public property sNameZ2

Unterstützt von .NET Compact Framework
public property sOrt

Unterstützt von .NET Compact Framework
public property sPLZ

Unterstützt von .NET Compact Framework
public property sPostfach

Unterstützt von .NET Compact Framework
public property sStrasse

Unterstützt von .NET Compact Framework
public property sTelefax

Unterstützt von .NET Compact Framework
public property sTelefon

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sEMail

Unterstützt von .NET Compact Framework
private field m_sInternet

Unterstützt von .NET Compact Framework
private field m_sNameZ1

Unterstützt von .NET Compact Framework
private field m_sNameZ2

Unterstützt von .NET Compact Framework
private field m_sOrt

Unterstützt von .NET Compact Framework
private field m_sPLZ

Unterstützt von .NET Compact Framework
private field m_sPostfach

Unterstützt von .NET Compact Framework
private field m_sStrasse

Unterstützt von .NET Compact Framework
private field m_sTelefax

Unterstützt von .NET Compact Framework
private field m_sTelefon

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


clsVertragspartner -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner-Eigenschaften

clsVertragspartner Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr

Unterstützt von .NET Compact Framework
public property sBemerkung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail

Unterstützt von .NET Compact Framework
public property sInternet

Unterstützt von .NET Compact Framework
public property sNameZ1

Unterstützt von .NET Compact Framework
public property sNameZ2

Unterstützt von .NET Compact Framework
public property sOrt

Unterstützt von .NET Compact Framework
public property sPLZ

Unterstützt von .NET Compact Framework
public property sPostfach

Unterstützt von .NET Compact Framework
public property sStrasse

Unterstützt von .NET Compact Framework
public property sTelefax

Unterstützt von .NET Compact Framework
public property sTelefon

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


clsVertragspartner.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.iSecurityLevelNr -Eigenschaft

[Visual Basic]
Public Property iSecurityLevelNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iSecurityLevelNr]() As SqlInt32
            Get
                Return m_iSecurityLevelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSecurityLevelNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.iVertragspartnerNr -Eigenschaft

[Visual Basic]
Public Property iVertragspartnerNr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragspartnerNr]() As SqlInt32
            Get
                Return m_iVertragspartnerNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragspartnerNrTmp As SqlInt32 = Value
                If iVertragspartnerNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragspartnerNr", "iVertragspartnerNr can't be NULL")
                End If
                m_iVertragspartnerNr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sBemerkung -Eigenschaft

[Visual Basic]
Public Property sBemerkung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sEMail -Eigenschaft

[Visual Basic]
Public Property sEMail() As SqlString

Quellcode

[Visual Basic]
        Public Property [sEMail]() As SqlString
            Get
                Return m_sEMail
            End Get
            Set(ByVal Value As SqlString)
                m_sEMail = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sInternet -Eigenschaft

[Visual Basic]
Public Property sInternet() As SqlString

Quellcode

[Visual Basic]
        Public Property [sInternet]() As SqlString
            Get
                Return m_sInternet
            End Get
            Set(ByVal Value As SqlString)
                m_sInternet = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sNameZ1 -Eigenschaft

[Visual Basic]
Public Property sNameZ1() As SqlString

Quellcode

[Visual Basic]
        Public Property [sNameZ1]() As SqlString
            Get
                Return m_sNameZ1
            End Get
            Set(ByVal Value As SqlString)
                m_sNameZ1 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sNameZ2 -Eigenschaft

[Visual Basic]
Public Property sNameZ2() As SqlString

Quellcode

[Visual Basic]
        Public Property [sNameZ2]() As SqlString
            Get
                Return m_sNameZ2
            End Get
            Set(ByVal Value As SqlString)
                m_sNameZ2 = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sOrt -Eigenschaft

[Visual Basic]
Public Property sOrt() As SqlString

Quellcode

[Visual Basic]
        Public Property [sOrt]() As SqlString
            Get
                Return m_sOrt
            End Get
            Set(ByVal Value As SqlString)
                m_sOrt = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sPLZ -Eigenschaft

[Visual Basic]
Public Property sPLZ() As SqlString

Quellcode

[Visual Basic]
        Public Property [sPLZ]() As SqlString
            Get
                Return m_sPLZ
            End Get
            Set(ByVal Value As SqlString)
                m_sPLZ = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sPostfach -Eigenschaft

[Visual Basic]
Public Property sPostfach() As SqlString

Quellcode

[Visual Basic]
        Public Property [sPostfach]() As SqlString
            Get
                Return m_sPostfach
            End Get
            Set(ByVal Value As SqlString)
                m_sPostfach = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sStrasse -Eigenschaft

[Visual Basic]
Public Property sStrasse() As SqlString

Quellcode

[Visual Basic]
        Public Property [sStrasse]() As SqlString
            Get
                Return m_sStrasse
            End Get
            Set(ByVal Value As SqlString)
                m_sStrasse = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sTelefax -Eigenschaft

[Visual Basic]
Public Property sTelefax() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTelefax]() As SqlString
            Get
                Return m_sTelefax
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefax = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.sTelefon -Eigenschaft

[Visual Basic]
Public Property sTelefon() As SqlString

Quellcode

[Visual Basic]
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner-Methoden

clsVertragspartner Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragspartner -Klasse


clsVertragspartner.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> <LI>sNameZ1. May be SqlString.Null</LI> <LI>sNameZ2. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPLZ. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPLZ", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPLZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragspartner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragspartnerNr</LI> <LI>sNameZ1</LI> <LI>sNameZ2</LI> <LI>sStrasse</LI> <LI>sPostfach</LI> <LI>sPLZ</LI> <LI>sOrt</LI> <LI>sTelefon</LI> <LI>sTelefax</LI> <LI>sEMail</LI> <LI>sInternet</LI> <LI>sBemerkung</LI> <LI>iSecurityLevelNr</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragspartner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragspartnerNr = New SqlInt32(CType(dtToReturn.Rows(0)("VertragspartnerNr"), Integer))
                    If dtToReturn.Rows(0)("NameZ1") Is System.DBNull.Value Then
                        m_sNameZ1 = SqlString.Null
                    Else
                        m_sNameZ1 = New SqlString(CType(dtToReturn.Rows(0)("NameZ1"), String))
                    End If
                    If dtToReturn.Rows(0)("NameZ2") Is System.DBNull.Value Then
                        m_sNameZ2 = SqlString.Null
                    Else
                        m_sNameZ2 = New SqlString(CType(dtToReturn.Rows(0)("NameZ2"), String))
                    End If
                    If dtToReturn.Rows(0)("Strasse") Is System.DBNull.Value Then
                        m_sStrasse = SqlString.Null
                    Else
                        m_sStrasse = New SqlString(CType(dtToReturn.Rows(0)("Strasse"), String))
                    End If
                    If dtToReturn.Rows(0)("Postfach") Is System.DBNull.Value Then
                        m_sPostfach = SqlString.Null
                    Else
                        m_sPostfach = New SqlString(CType(dtToReturn.Rows(0)("Postfach"), String))
                    End If
                    If dtToReturn.Rows(0)("PLZ") Is System.DBNull.Value Then
                        m_sPLZ = SqlString.Null
                    Else
                        m_sPLZ = New SqlString(CType(dtToReturn.Rows(0)("PLZ"), String))
                    End If
                    If dtToReturn.Rows(0)("Ort") Is System.DBNull.Value Then
                        m_sOrt = SqlString.Null
                    Else
                        m_sOrt = New SqlString(CType(dtToReturn.Rows(0)("Ort"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("Telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("Telefax") Is System.DBNull.Value Then
                        m_sTelefax = SqlString.Null
                    Else
                        m_sTelefax = New SqlString(CType(dtToReturn.Rows(0)("Telefax"), String))
                    End If
                    If dtToReturn.Rows(0)("EMail") Is System.DBNull.Value Then
                        m_sEMail = SqlString.Null
                    Else
                        m_sEMail = New SqlString(CType(dtToReturn.Rows(0)("EMail"), String))
                    End If
                    If dtToReturn.Rows(0)("Internet") Is System.DBNull.Value Then
                        m_sInternet = SqlString.Null
                    Else
                        m_sInternet = New SqlString(CType(dtToReturn.Rows(0)("Internet"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("SecurityLevelNr") Is System.DBNull.Value Then
                        m_iSecurityLevelNr = SqlInt32.Null
                    Else
                        m_iSecurityLevelNr = New SqlInt32(CType(dtToReturn.Rows(0)("SecurityLevelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragspartnerNr</LI> <LI>sNameZ1. May be SqlString.Null</LI> <LI>sNameZ2. May be SqlString.Null</LI> <LI>sStrasse. May be SqlString.Null</LI> <LI>sPostfach. May be SqlString.Null</LI> <LI>sPLZ. May be SqlString.Null</LI> <LI>sOrt. May be SqlString.Null</LI> <LI>sTelefon. May be SqlString.Null</LI> <LI>sTelefax. May be SqlString.Null</LI> <LI>sEMail. May be SqlString.Null</LI> <LI>sInternet. May be SqlString.Null</LI> <LI>sBemerkung. May be SqlString.Null</LI> <LI>iSecurityLevelNr. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragspartner_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragspartnerNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragspartnerNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNameZ2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNameZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sStrasse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStrasse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPostfach", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPostfach))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPLZ", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPLZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sOrt", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTelefax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sEMail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEMail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sInternet", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInternet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSecurityLevelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSecurityLevelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragspartner_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragspartner::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner-Felder

clsVertragspartner Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iSecurityLevelNr

Unterstützt von .NET Compact Framework
private field m_iVertragspartnerNr

Unterstützt von .NET Compact Framework
private field m_sBemerkung

Unterstützt von .NET Compact Framework
private field m_sEMail

Unterstützt von .NET Compact Framework
private field m_sInternet

Unterstützt von .NET Compact Framework
private field m_sNameZ1

Unterstützt von .NET Compact Framework
private field m_sNameZ2

Unterstützt von .NET Compact Framework
private field m_sOrt

Unterstützt von .NET Compact Framework
private field m_sPLZ

Unterstützt von .NET Compact Framework
private field m_sPostfach

Unterstützt von .NET Compact Framework
private field m_sStrasse

Unterstützt von .NET Compact Framework
private field m_sTelefax

Unterstützt von .NET Compact Framework
private field m_sTelefon

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_iSecurityLevelNr -Feld

[Visual Basic]
Private m_iSecurityLevelNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_iVertragspartnerNr -Feld

[Visual Basic]
Private m_iVertragspartnerNr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMandantnr, m_iSecurityLevelNr, m_iMutierer, m_iVertragspartnerNr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sBemerkung -Feld

[Visual Basic]
Private m_sBemerkung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sEMail -Feld

[Visual Basic]
Private m_sEMail As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sInternet -Feld

[Visual Basic]
Private m_sInternet As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sNameZ1 -Feld

[Visual Basic]
Private m_sNameZ1 As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sNameZ2 -Feld

[Visual Basic]
Private m_sNameZ2 As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sOrt -Feld

[Visual Basic]
Private m_sOrt As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sPLZ -Feld

[Visual Basic]
Private m_sPLZ As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sPostfach -Feld

[Visual Basic]
Private m_sPostfach As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sStrasse -Feld

[Visual Basic]
Private m_sStrasse As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sTelefax -Feld

[Visual Basic]
Private m_sTelefax As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


m_sTelefon -Feld

[Visual Basic]
Private m_sTelefon As SqlString

Quellcode

[Visual Basic]
        Private 		m_sStrasse, m_sPostfach, m_sNameZ2, m_sTelefax, m_sNameZ1, m_sPLZ, m_sTelefon, m_sOrt, m_sBemerkung, m_sInternet, m_sEMail As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragstyp -Klasse

Purpose: Data Access class for the table 'Vertragstyp'.

For a list of all members of this type, see clsVertragstyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragstyp

[Visual Basic]
Public Class clsVertragstyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragstyp-Member


clsVertragstyp-Member

clsVertragstyp Übersicht

Öffentliche Konstruktoren

public constructor clsVertragstyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsLizenz

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragstypnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVertragstyp

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsLizenz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iVertragstypnr

Unterstützt von .NET Compact Framework
private field m_sVertragstyp

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragstyp -Klasse


clsVertragstyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp-Eigenschaften

clsVertragstyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property bAlsLizenz

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragstypnr

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVertragstyp

Unterstützt von .NET Compact Framework

clsVertragstyp -Klasse


clsVertragstyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.bAlsLizenz -Eigenschaft

[Visual Basic]
Public Property bAlsLizenz() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAlsLizenz]() As SqlBoolean
            Get
                Return m_bAlsLizenz
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAlsLizenz = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.iVertragstypnr -Eigenschaft

[Visual Basic]
Public Property iVertragstypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iVertragstypnr]() As SqlInt32
            Get
                Return m_iVertragstypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVertragstypnrTmp As SqlInt32 = Value
                If iVertragstypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVertragstypnr", "iVertragstypnr can't be NULL")
                End If
                m_iVertragstypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.sVertragstyp -Eigenschaft

[Visual Basic]
Public Property sVertragstyp() As SqlString

Quellcode

[Visual Basic]
        Public Property [sVertragstyp]() As SqlString
            Get
                Return m_sVertragstyp
            End Get
            Set(ByVal Value As SqlString)
                m_sVertragstyp = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp-Methoden

clsVertragstyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragstyp -Klasse


clsVertragstyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>sVertragstyp. May be SqlString.Null</LI> <LI>bAlsLizenz. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iVertragstypnr</LI> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVertragstyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVertragstyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAlsLizenz", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAlsLizenz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iVertragstypnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iVertragstypnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iVertragstypnr</LI> <LI>sVertragstyp</LI> <LI>bAlsLizenz</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>bAktiv</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Vertragstyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVertragstypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Vertragstypnr"), Integer))
                    If dtToReturn.Rows(0)("Vertragstyp") Is System.DBNull.Value Then
                        m_sVertragstyp = SqlString.Null
                    Else
                        m_sVertragstyp = New SqlString(CType(dtToReturn.Rows(0)("Vertragstyp"), String))
                    End If
                    If dtToReturn.Rows(0)("AlsLizenz") Is System.DBNull.Value Then
                        m_bAlsLizenz = SqlBoolean.Null
                    Else
                        m_bAlsLizenz = New SqlBoolean(CType(dtToReturn.Rows(0)("AlsLizenz"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iVertragstypnr</LI> <LI>sVertragstyp. May be SqlString.Null</LI> <LI>bAlsLizenz. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Vertragstyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iVertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVertragstypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVertragstyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVertragstyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAlsLizenz", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAlsLizenz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Vertragstyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVertragstyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsVertragstyp-Felder

clsVertragstyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
private field m_bAlsLizenz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iVertragstypnr

Unterstützt von .NET Compact Framework
private field m_sVertragstyp

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragstyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAlsLizenz, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_bAlsLizenz -Feld

[Visual Basic]
Private m_bAlsLizenz As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAlsLizenz, m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragstypnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_iVertragstypnr -Feld

[Visual Basic]
Private m_iVertragstypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iVertragstypnr, m_iMutierer As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


m_sVertragstyp -Feld

[Visual Basic]
Private m_sVertragstyp As SqlString

Quellcode

[Visual Basic]
        Private 		m_sVertragstyp As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragstyp


clsZeiteinheittyp -Klasse

Purpose: Data Access class for the table 'Zeiteinheittyp'.

For a list of all members of this type, see clsZeiteinheittyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp
Vertragsverwaltung.TKB.VV.DB.myZeiteinheittyp

[Visual Basic]
Public Class clsZeiteinheittyp
    Inherits clsDBInteractionBase

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsZeiteinheittyp-Member


clsZeiteinheittyp-Member

clsZeiteinheittyp Übersicht

Öffentliche Konstruktoren

public constructor clsZeiteinheittyp -Konstructor

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iZeiteinheittypnr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsZeiteinheittyp -Klasse


clsZeiteinheittyp -Konstructor

Purpose: Class constructor.

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp-Eigenschaften

clsZeiteinheittyp Übersicht

Öffentliche Eigenschaften

public property bAktiv

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am

Unterstützt von .NET Compact Framework
public property daMutiert_am

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr

Unterstützt von .NET Compact Framework
public property iMutierer

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr

Unterstützt von .NET Compact Framework
public property sBeschreibung

Unterstützt von .NET Compact Framework
public property sBezeichnung

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsZeiteinheittyp -Klasse


clsZeiteinheittyp.bAktiv -Eigenschaft

[Visual Basic]
Public Property bAktiv() As SqlBoolean

Quellcode

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.daErstellt_am -Eigenschaft

[Visual Basic]
Public Property daErstellt_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.daMutiert_am -Eigenschaft

[Visual Basic]
Public Property daMutiert_am() As SqlDateTime

Quellcode

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.iMandantnr -Eigenschaft

[Visual Basic]
Public Property iMandantnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.iMutierer -Eigenschaft

[Visual Basic]
Public Property iMutierer() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.iZeiteinheittypnr -Eigenschaft

[Visual Basic]
Public Property iZeiteinheittypnr() As SqlInt32

Quellcode

[Visual Basic]
        Public Property [iZeiteinheittypnr]() As SqlInt32
            Get
                Return m_iZeiteinheittypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iZeiteinheittypnrTmp As SqlInt32 = Value
                If iZeiteinheittypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iZeiteinheittypnr", "iZeiteinheittypnr can't be NULL")
                End If
                m_iZeiteinheittypnr = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.sBeschreibung -Eigenschaft

[Visual Basic]
Public Property sBeschreibung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.sBezeichnung -Eigenschaft

[Visual Basic]
Public Property sBezeichnung() As SqlString

Quellcode

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp-Methoden

clsZeiteinheittyp Übersicht

Öffentliche Methoden

public method Delete Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsZeiteinheittyp -Klasse


clsZeiteinheittyp.Delete -Methode

Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function Delete() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.Insert -Methode

Purpose: Insert method. This method will insert one new row into the database.

[Visual Basic]
Public Overrides Function Insert() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.SelectAll -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Overrides Function SelectAll() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.SelectOne -Methode

Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.

[Visual Basic]
Public Overrides Function SelectOne() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung</LI> <LI>sBeschreibung</LI> <LI>bAktiv</LI> <LI>daErstellt_am</LI> <LI>daMutiert_am</LI> <LI>iMutierer</LI> <LI>iMandantnr</LI> </UL> Will fill all properties corresponding with a field in the table with the value of the row selected.

Quellcode

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iZeiteinheittypnr = New SqlInt32(CType(dtToReturn.Rows(0)("Zeiteinheittypnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("Beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("Beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp.Update -Methode

Purpose: Update method. This method will Update one existing row in the database.

[Visual Basic]
Public Overrides Function Update() As Boolean

Rückgabewert

True if succeeded, otherwise an Exception is thrown.

Hinweise

Properties needed for this method: <UL> <LI>iZeiteinheittypnr</LI> <LI>sBezeichnung. May be SqlString.Null</LI> <LI>sBeschreibung. May be SqlString.Null</LI> <LI>bAktiv. May be SqlBoolean.Null</LI> <LI>daErstellt_am. May be SqlDateTime.Null</LI> <LI>daMutiert_am. May be SqlDateTime.Null</LI> <LI>iMutierer. May be SqlInt32.Null</LI> <LI>iMandantnr. May be SqlInt32.Null</LI> </UL> Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeiteinheittypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iZeiteinheittypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                m_iRowsAffected = scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


clsZeiteinheittyp-Felder

clsZeiteinheittyp Übersicht

Felder

private field m_bAktiv

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_daErstellt_am

Unterstützt von .NET Compact Framework
private field m_daMutiert_am

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iMandantnr

Unterstützt von .NET Compact Framework
private field m_iMutierer

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field m_iZeiteinheittypnr

Unterstützt von .NET Compact Framework
private field m_sBeschreibung

Unterstützt von .NET Compact Framework
private field m_sBezeichnung

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsZeiteinheittyp -Klasse


m_bAktiv -Feld

[Visual Basic]
Private m_bAktiv As SqlBoolean

Quellcode

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_daErstellt_am -Feld

[Visual Basic]
Private m_daErstellt_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_daMutiert_am -Feld

[Visual Basic]
Private m_daMutiert_am As SqlDateTime

Quellcode

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_iMandantnr -Feld

[Visual Basic]
Private m_iMandantnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_iMutierer -Feld

[Visual Basic]
Private m_iMutierer As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_iZeiteinheittypnr -Feld

[Visual Basic]
Private m_iZeiteinheittypnr As SqlInt32

Quellcode

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iZeiteinheittypnr As SqlInt32

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_sBeschreibung -Feld

[Visual Basic]
Private m_sBeschreibung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


m_sBezeichnung -Feld

[Visual Basic]
Private m_sBezeichnung As SqlString

Quellcode

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsZeiteinheittyp


mySLATyp -Klasse

For a list of all members of this type, see mySLATyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLATyp
Vertragsverwaltung.TKB.VV.DB.mySLATyp

[Visual Basic]
Public Class mySLATyp
    Inherits clsSLATyp

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

mySLATyp-Member


mySLATyp-Member

mySLATyp Übersicht

Öffentliche Konstruktoren

public constructor mySLATyp -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLATypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_Aktive Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

mySLATyp -Klasse


mySLATyp-Eigenschaften

mySLATyp Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLATypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

mySLATyp -Klasse


mySLATyp-Methoden

mySLATyp Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_Aktive Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLATyp) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

mySLATyp -Klasse


mySLATyp.SelectAll_Aktive -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Function SelectAll_Aktive() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAll_Aktive() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_SLATyp_SelectAll_Aktive]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("SLATyp")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_SLATyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSLATyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

mySLATyp


mySLATyp-Felder

mySLATyp Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

mySLATyp -Klasse


myZeiteinheittyp -Klasse

For a list of all members of this type, see myZeiteinheittyp-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp
Vertragsverwaltung.TKB.VV.DB.myZeiteinheittyp

[Visual Basic]
Public Class myZeiteinheittyp
    Inherits clsZeiteinheittyp

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

myZeiteinheittyp-Member


myZeiteinheittyp-Member

myZeiteinheittyp Übersicht

Öffentliche Konstruktoren

public constructor myZeiteinheittyp -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_aktive Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

myZeiteinheittyp -Klasse


myZeiteinheittyp-Eigenschaften

myZeiteinheittyp Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iZeiteinheittypnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

myZeiteinheittyp -Klasse


myZeiteinheittyp-Methoden

myZeiteinheittyp Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_aktive Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsZeiteinheittyp) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

myZeiteinheittyp -Klasse


myZeiteinheittyp.SelectAll_aktive -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Function SelectAll_aktive() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function SelectAll_aktive() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Zeiteinheittyp_SelectAll_aktive]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Zeiteinheittyp")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Zeiteinheittyp_SelectAll_Aktive' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsZeiteinheittyp::SelectAll_Aktive::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

myZeiteinheittyp


myZeiteinheittyp-Felder

myZeiteinheittyp Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

myZeiteinheittyp -Klasse


ICommonDBAccess -Schnittstelle

For a list of all members of this type, see ICommonDBAccess-Member.

[Visual Basic]
Public Interface ICommonDBAccess

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

ICommonDBAccess-Member


ICommonDBAccess-Member

ICommonDBAccess Übersicht

Öffentliche Methoden

public method Delete

Unterstützt von .NET Compact Framework
public method Insert

Unterstützt von .NET Compact Framework
public method SelectAll

Unterstützt von .NET Compact Framework
public method SelectOne

Unterstützt von .NET Compact Framework
public method Update

Unterstützt von .NET Compact Framework

ICommonDBAccess -Schnittstelle


ICommonDBAccess-Methoden

ICommonDBAccess Übersicht

Öffentliche Methoden

public method Delete

Unterstützt von .NET Compact Framework
public method Insert

Unterstützt von .NET Compact Framework
public method SelectAll

Unterstützt von .NET Compact Framework
public method SelectOne

Unterstützt von .NET Compact Framework
public method Update

Unterstützt von .NET Compact Framework

ICommonDBAccess -Schnittstelle


ICommonDBAccess.Delete -Methode

[Visual Basic]
Function Delete() As Boolean

Quellcode

[Visual Basic]
        Function	Delete() As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ICommonDBAccess


ICommonDBAccess.Insert -Methode

[Visual Basic]
Function Insert() As Boolean

Quellcode

[Visual Basic]
        Function	Insert() As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ICommonDBAccess


ICommonDBAccess.SelectAll -Methode

[Visual Basic]
Function SelectAll() As DataTable

Quellcode

[Visual Basic]
        Function	SelectAll() As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ICommonDBAccess


ICommonDBAccess.SelectOne -Methode

[Visual Basic]
Function SelectOne() As DataTable

Quellcode

[Visual Basic]
        Function	SelectOne() As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ICommonDBAccess


ICommonDBAccess.Update -Methode

[Visual Basic]
Function Update() As Boolean

Quellcode

[Visual Basic]
        Function	Update() As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ICommonDBAccess


LLBLError -Enumeration

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DB

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)


Vertragsverwaltung.TKB.VV.DMS -Namespace

Klassen

public class clsDok

Unterstützt von .NET Compact Framework


clsDok -Klasse

For a list of all members of this type, see clsDok-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsDokument
Vertragsverwaltung.TKB.VV.DMS.clsDok

[Visual Basic]
Public Class clsDok
    Inherits clsDokument

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.DMS

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsDok-Member


clsDok-Member

clsDok Übersicht

Öffentliche Konstruktoren

public constructor clsDok -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property blobDocImage (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property daVersionsdatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokType (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokumentNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokumenttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKeyValue (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFilename (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sOriginalFilename_incl_Path (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sVersionsNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Datensatz physisch löschen
public method Delete_Dokument Unterstützt von .NET Compact Framework | Datensatz inaktivieren
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Exists_Testdrehbuch Unterstützt von .NET Compact Framework |
public method Get_Ablageorte Unterstützt von .NET Compact Framework |
public method Get_Dokument Unterstützt von .NET Compact Framework | Dokument laden
public method Get_Dokumente Unterstützt von .NET Compact Framework |
public method Get_Dokumenttypen Unterstützt von .NET Compact Framework | Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Person sichern
public method Save_File Unterstützt von .NET Compact Framework | Datei im Dokument speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Show_Doc Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

private field DocMgmt

Unterstützt von .NET Compact Framework
public field Dokumentablageort

Unterstützt von .NET Compact Framework
public field Dokumente

Unterstützt von .NET Compact Framework
private field Dokumenttyp

Unterstützt von .NET Compact Framework
public field Dokumenttypdaten

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDok -Klasse


clsDok-Eigenschaften

clsDok Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property blobDocImage (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property daVersionsdatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokType (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokumentNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iDokumenttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKeyValue (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sFilename (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sOriginalFilename_incl_Path (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework
public property sVersionsNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument)

Unterstützt von .NET Compact Framework

clsDok -Klasse


clsDok-Methoden

clsDok Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Datensatz physisch löschen
public method Delete_Dokument Unterstützt von .NET Compact Framework | Datensatz inaktivieren
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Exists_Testdrehbuch Unterstützt von .NET Compact Framework |
public method Get_Ablageorte Unterstützt von .NET Compact Framework |
public method Get_Dokument Unterstützt von .NET Compact Framework | Dokument laden
public method Get_Dokumente Unterstützt von .NET Compact Framework |
public method Get_Dokumenttypen Unterstützt von .NET Compact Framework | Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Person sichern
public method Save_File Unterstützt von .NET Compact Framework | Datei im Dokument speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Show_Doc Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDokument) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsDok -Klasse


clsDok.Add_New -Methode

Neue Person einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Elementnr As Integer, _
   ByVal doktype As Integer _
) As Integer

Parameter

Elementnr
doktype

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Elementnr As Integer, ByVal doktype As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Dokument")
            db.Dispose()
            Me.iDokumentNr = New SqlInt32(CType(newkey, Int32))
            Me.iKeyValue = New SqlInt32(CType(Elementnr, Int32))
            Me.iDokType = New SqlInt32(CType(doktype, Int32))
            Me.iDokumenttypNr = New SqlInt32(CType(1, Int32))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sFilename = New SqlString(CType("", String))
            Me.sOriginalFilename_incl_Path = New SqlString(CType("", String))
            Me.sVersion = New SqlString(CType("", String))
            Me.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Dokument(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Dokument")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iDokumentNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Delete -Methode

Überladungsliste

Datensatz physisch löschen

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsDok | Vertragsverwaltung.TKB.VV.DMS


clsDok.Delete_Dokument -Methode

Datensatz inaktivieren

[Visual Basic]
Public Function Delete_Dokument( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Delete_Dokument(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Dokument(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Exists_Testdrehbuch -Methode

[Visual Basic]
Public Function Exists_Testdrehbuch( _
   ByVal Applikationnr As Integer _
) As Integer

Parameter

Applikationnr

Quellcode

[Visual Basic]
        Public Function Exists_Testdrehbuch(ByVal Applikationnr As Integer) As Integer
            Dim tmpdata As New DataTable
            tmpdata = Get_Dokumente(Applikationnr, 2)
            If tmpdata.Rows.Count = 0 Then
                tmpdata.Dispose()
                Return -1
            Else
                Return tmpdata.Rows(0).Item("Dokumentnr")
                tmpdata.Dispose()
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Get_Ablageorte -Methode

[Visual Basic]
Public Function Get_Ablageorte( _
   ByVal c1data As C1TrueDBGrid, _
   ByVal Dokumentnr As Integer _
) As Object

Parameter

c1data
Dokumentnr

Quellcode

[Visual Basic]
        Public Function Get_Ablageorte(ByVal c1data As C1TrueDBGrid, ByVal Dokumentnr As Integer)
            Dokumentablageort = New TKB.VV.Sysadmin.DomainTable("Dokumentablageort", Str(Dokumentnr), Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Dokumentablageort.Tabledata
            c1data.DataMember = Dokumentablageort.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Get_Dokument -Methode

Dokument laden

[Visual Basic]
Public Function Get_Dokument( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr
PersonNr

Quellcode

[Visual Basic]
        Public Function Get_Dokument(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iDokumentNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Get_Dokumente -Methode

[Visual Basic]
Public Function Get_Dokumente( _
   ByVal Keyvalue As Integer, _
   ByVal Doktype As Integer _
) As DataTable

Parameter

Keyvalue
Doktype

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByVal Keyvalue As Integer, ByVal Doktype As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_dokumente"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@keyvalue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Keyvalue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doktype", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Doktype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsDok::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Get_Dokumenttypen -Methode

Dokumenttypen laden und in der Datatable Dokumenttypdaten bereit stellen

[Visual Basic]
Public Function Get_Dokumenttypen() As DataTable

Quellcode

[Visual Basic]
        Public Function Get_Dokumenttypen() As DataTable
            Me.Dokumenttyp.cpMainConnectionProvider = Globals.conn
            Me.Dokumenttypdaten = Stammdaten.Get_Stammdaten("Dokumenttyp", "Bezeichnung")
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Save_Data -Methode

Person sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iDokumentNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Save_File -Methode

Datei im Dokument speichern

[Visual Basic]
Public Function Save_File( _
   ByVal DokumentNr As Integer, _
   ByVal Filename As String _
) As Boolean

Parameter

DokumentNr
Filename

Quellcode

[Visual Basic]
        Public Function Save_File(ByVal DokumentNr As Integer, ByVal Filename As String) As Boolean
            If Filename = "" Then Return True
            If Me.DocMgmt.Save_Document(DokumentNr, Filename) = False Then
                Return False
            Else
                Return True
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok.Show_Doc -Methode

[Visual Basic]
Public Function Show_Doc( _
   ByVal dokumentnr As Integer _
) As Object

Parameter

dokumentnr

Quellcode

[Visual Basic]
        Public Function Show_Doc(ByVal dokumentnr As Integer)
            Me.DocMgmt.Show_Document(dokumentnr)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


clsDok-Felder

clsDok Übersicht

Felder

private field DocMgmt

Unterstützt von .NET Compact Framework
public field Dokumentablageort

Unterstützt von .NET Compact Framework
public field Dokumente

Unterstützt von .NET Compact Framework
private field Dokumenttyp

Unterstützt von .NET Compact Framework
public field Dokumenttypdaten

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsDok -Klasse


DocMgmt -Feld

[Visual Basic]
Private DocMgmt As MyDocMgmt

Quellcode

[Visual Basic]
        Private DocMgmt As New TKB.VV.Utils.MyDocMgmt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Dokumentablageort -Feld

[Visual Basic]
Public Dokumentablageort As DomainTable

Quellcode

[Visual Basic]
        Public Dokumentablageort As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Dokumente -Feld

[Visual Basic]
Public Dokumente As DataTable

Quellcode

[Visual Basic]
        Public Dokumente As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Dokumenttyp -Feld

[Visual Basic]
Private Dokumenttyp As clsDokumenttyp

Quellcode

[Visual Basic]
        Private Dokumenttyp As New TKB.VV.DB.clsDokumenttyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Dokumenttypdaten -Feld

[Visual Basic]
Public Dokumenttypdaten As DataTable

Quellcode

[Visual Basic]
        Public Dokumenttypdaten As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Stammdaten -Feld

[Visual Basic]
Private Stammdaten As clsStammdaten

Quellcode

[Visual Basic]
        Private Stammdaten As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Vertragsverwaltung.TKB.VV.SLA -Namespace

Klassen

public class clsSLA Unterstützt von .NET Compact Framework |
public class clsSLAKatalogdaten Unterstützt von .NET Compact Framework | Laden der Daten für die SLA-Katalogverwaltung
public class clsServiceKatalogDaten Unterstützt von .NET Compact Framework |
public class clsServiceKatalogSLATree Unterstützt von .NET Compact Framework | TreeDatenklasse für den Servicekatalog-Tree
public class clsServiceKatalogTree Unterstützt von .NET Compact Framework | TreeDatenklasse für den Servicekatalog-Tree


clsSLA -Klasse

For a list of all members of this type, see clsSLA-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSLA
Vertragsverwaltung.TKB.VV.SLA.clsSLA

[Visual Basic]
Public Class clsSLA
    Inherits clsSLA

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.SLA

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLA-Member


clsSLA-Member

clsSLA Übersicht

Öffentliche Konstruktoren

public constructor clsSLA -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLANr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iSLASubTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iSLATypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_Active Unterstützt von .NET Compact Framework |
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


clsSLA-Eigenschaften

clsSLA Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSLANr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iSLASubTypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property iSLATypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


clsSLA-Methoden

clsSLA Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAll_Active Unterstützt von .NET Compact Framework |
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSLA) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

clsSLA -Klasse


clsSLA.SelectAll_Active -Methode

[Visual Basic]
Public Function SelectAll_Active() As DataTable

Quellcode

[Visual Basic]
        Public Function SelectAll_Active() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.pr_sla_selectall_active"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSlaKatalogDaten::SLA::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


dispose -Methode

Überladungsliste

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

clsSLA | Vertragsverwaltung.TKB.VV.SLA


clsSLA-Felder

clsSLA Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSLA -Klasse


clsSLAKatalogdaten -Klasse

Laden der Daten für die SLA-Katalogverwaltung

For a list of all members of this type, see clsSLAKatalogdaten-Member.

System.Object
Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable
Vertragsverwaltung.TKB.VV.SLA.clsSLAKatalogdaten

[Visual Basic]
Public Class clsSLAKatalogdaten
    Inherits DomainTable

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.SLA

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSLAKatalogdaten-Member


clsSLAKatalogdaten-Member

clsSLAKatalogdaten Übersicht

Öffentliche Konstruktoren

public constructor clsSLAKatalogdaten -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Insert_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Insert_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable2 (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Tabledata (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Tablename (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Update_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Update_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Insert_Bottom_Table (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
public method Load_Bootom_Table (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Load der Verbindungstabelle
public method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
public method Load_Data_2Key (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Load_Data_MA (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Load_Data_MA_Fokus (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Save_Data (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
public method dispose (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Dispose von Tabledata

clsSLAKatalogdaten -Klasse


New

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

[Visual Basic] Public Sub New(String, Integer, String, Integer, String)
[C#] public System.Void DomainTable(string, int, string, int, string);

(Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

[Visual Basic] Public Sub New(String, Integer, String, Integer)
[C#] public System.Void DomainTable(string, int, string, int);

(Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

[Visual Basic] Public Sub New(String, String, Integer)
[C#] public System.Void DomainTable(string, string, int);

Tabellenname übernehmen und Daten ab DB laden (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

[Visual Basic] Public Sub New(String, Optional Integer, Optional String)
[C#] public System.Void DomainTable(string, int, string);

[Visual Basic] Public Sub New(String)
[C#] public System.Void clsSLAKatalogdaten(string);

clsSLAKatalogdaten | Vertragsverwaltung.TKB.VV.SLA


clsSLAKatalogdaten-Eigenschaften

clsSLAKatalogdaten Übersicht

Öffentliche Eigenschaften

public property Insert_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Insert_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable2 (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Tabledata (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Tablename (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Update_Proc (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework
public property Update_Proc_Bottomtable (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable)

Unterstützt von .NET Compact Framework

clsSLAKatalogdaten -Klasse


DomainTable.Insert_Proc -Eigenschaft

[Visual Basic]
Public Property Insert_Proc() As String

Quellcode

[Visual Basic]
        Property Insert_Proc() As String
            Get
                Return "pr_" & Tablename & "_Insert"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Insert_Proc_Bottomtable -Eigenschaft

[Visual Basic]
Public Property Insert_Proc_Bottomtable() As String

Quellcode

[Visual Basic]
        Property Insert_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_Insert_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update_bottomtable"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Select_Proc -Eigenschaft

[Visual Basic]
Public Property Select_Proc() As String

Quellcode

[Visual Basic]
        Property Select_Proc() As String
            Get
                Return "pr_" & Tablename & "_selectall"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_selectall"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Select_Proc_Bottomtable -Eigenschaft

[Visual Basic]
Public Property Select_Proc_Bottomtable() As String

Quellcode

[Visual Basic]
        Property Select_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_selectall_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_selectall_bottomtable"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Select_Proc_Bottomtable2 -Eigenschaft

[Visual Basic]
Public Property Select_Proc_Bottomtable2() As String

Quellcode

[Visual Basic]
        Property Select_Proc_Bottomtable2() As String
            Get
                Return "pr_" & Tablename & "_selectall_bottomtable2"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_selectall_bottomtable2"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Tabledata -Eigenschaft

[Visual Basic]
Public Property Tabledata() As DataSet

Quellcode

[Visual Basic]
        Property Tabledata() As DataSet
            Get
                Return m_Tabledata
            End Get
            Set(ByVal value As DataSet)
                m_Tabledata = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Tablename -Eigenschaft

[Visual Basic]
Public Property Tablename() As String

Quellcode

[Visual Basic]
        Property Tablename() As String
            Get
                Return m_tablename
            End Get
            Set(ByVal value As String)
                m_tablename = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Update_Proc -Eigenschaft

[Visual Basic]
Public Property Update_Proc() As String

Quellcode

[Visual Basic]
        Property Update_Proc() As String
            Get
                Return "pr_" & Tablename & "_Update"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Update_Proc_Bottomtable -Eigenschaft

[Visual Basic]
Public Property Update_Proc_Bottomtable() As String

Quellcode

[Visual Basic]
        Property Update_Proc_Bottomtable() As String
            Get
                Return "pr_" & Tablename & "_Update_bottomtable"
            End Get
            Set(ByVal value As String)
                m_selectproc = "pr_" & Tablename & "_Update_bottomtable"
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


clsSLAKatalogdaten-Methoden

clsSLAKatalogdaten Übersicht

Öffentliche Methoden

public method Insert_Bottom_Table (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
public method Load_Bootom_Table (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Load der Verbindungstabelle
public method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
public method Load_Data_2Key (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Load_Data_MA (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Load_Data_MA_Fokus (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework |
public method Save_Data (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
public method dispose (Geerbt von: Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable) Unterstützt von .NET Compact Framework | Dispose von Tabledata

clsSLAKatalogdaten -Klasse


DomainTable.Insert_Bottom_Table -Methode

Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.

[Visual Basic]
Public Sub Insert_Bottom_Table( _
   ByVal key1 As String, _
   ByVal keyvalue1 As Integer, _
   ByVal key2 As String, _
   ByVal keyvalue2 As String _
)

Parameter

key1
keyvalue1
key2
keyvalue2

Quellcode

[Visual Basic]
        Public Sub Insert_Bottom_Table(ByVal key1 As String, ByVal keyvalue1 As Integer, ByVal key2 As String, ByVal keyvalue2 As String)
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            Dim newkey As Integer = dbkey.get_dbkey(Me.Tablename)
            conn.CloseConnection(True)
            dbkey.Dispose()
            Dim dr As DataRow
            dr = Me.Tabledata.Tables(0).NewRow
            dr.Item(0) = newkey
            Dim i As Integer
            For i = 1 To Me.Tabledata.Tables(0).Columns.Count - 1
                Select Case UCase(Me.Tabledata.Tables(0).Columns(i).ColumnName)
                    Case "AKTIV"
                        dr.Item(i) = 1
                    Case "ERSTELLT_AM"
                        dr.Item(i) = Now
                    Case "MUTIERT_AM"
                        dr.Item(i) = Now
                    Case "MUTIERER"
                        dr.Item(i) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    Case "MANDANTNR"
                        dr.Item(i) = Globals.clsmitarbeiter.iMandantnr.Value
                    Case "MANDANT"
                        dr.Item(i) = Globals.clsmitarbeiter.iMandantnr.Value
                    Case UCase(key1)
                        dr.Item(i) = keyvalue1
                    Case UCase(key2)
                        dr.Item(i) = keyvalue2
                    Case Else
                        Select Case Type.GetTypeCode(Me.Tabledata.Tables(0).Columns(i).DataType)
                            Case TypeCode.DateTime
                                dr.Item(i) = Now
                            Case TypeCode.Double
                                dr.Item(i) = 0
                            Case TypeCode.String
                                dr.Item(i) = ""
                            Case TypeCode.Int32
                                dr.Item(i) = 0
                            Case TypeCode.Boolean
                                dr.Item(i) = True
                            Case TypeCode.Int16
                                dr.Item(i) = 0
                            Case TypeCode.Int32
                                dr.Item(i) = 0
                            Case TypeCode.Int64
                                dr.Item(i) = 0
                        End Select
                End Select
            Next
            Me.Tabledata.Tables(0).Rows.Add(dr)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Load_Bootom_Table -Methode

Load der Verbindungstabelle

[Visual Basic]
Public Sub Load_Bootom_Table( _
   ByVal tablename As String, _
   ByVal Fokus As Integer, _
   ByVal KeyValue As String _
)

Parameter

tablename
Fokus
KeyValue

Quellcode

[Visual Basic]
        Public Sub Load_Bootom_Table(ByVal tablename As String, ByVal Fokus As Integer, ByVal KeyValue As String)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_bottomtable
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = Fokus
            sqlcmd.Parameters(2).Value = KeyValue

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


clsSLAKatalogdaten.Load_Data -Methode

Daten ab Datenbank laden

[Visual Basic]
Public Overrides Sub Load_Data()

Quellcode

[Visual Basic]
        Public Overrides Sub Load_Data()
            Tabledata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = Me.Select_Proc & "_Level"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            selectcommand.Parameters(1).Value = 0

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalogdaten


DomainTable.Load_Data_2Key -Methode

[Visual Basic]
Public Sub Load_Data_2Key( _
   ByVal tablename As String, _
   ByVal KeyValue As String, _
   ByVal mitarbeiternr As Integer, _
   ByVal KeyValue2 As String _
)

Parameter

tablename
KeyValue
mitarbeiternr
KeyValue2

Quellcode

[Visual Basic]
        Public Sub Load_Data_2Key(ByVal tablename As String, ByVal KeyValue As String, ByVal mitarbeiternr As Integer, ByVal KeyValue2 As String)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_Bottomtable2
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@KeyValue2", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@mitarbeiternr", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = 0
            sqlcmd.Parameters(2).Value = KeyValue
            sqlcmd.Parameters(3).Value = KeyValue2
            sqlcmd.Parameters(4).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Load_Data_MA -Methode

[Visual Basic]
Public Sub Load_Data_MA( _
   ByVal tablename As String, _
   ByVal KeyValue As String, _
   ByVal mitarbeiternr As Integer _
)

Parameter

tablename
KeyValue
mitarbeiternr

Quellcode

[Visual Basic]
        Public Sub Load_Data_MA(ByVal tablename As String, ByVal KeyValue As String, ByVal mitarbeiternr As Integer)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_Bottomtable
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@mitarbeiternr", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = 0
            sqlcmd.Parameters(2).Value = KeyValue
            sqlcmd.Parameters(3).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Load_Data_MA_Fokus -Methode

[Visual Basic]
Public Sub Load_Data_MA_Fokus( _
   ByVal tablename As String, _
   ByVal Fokus As Integer, _
   ByVal KeyValue As String, _
   ByVal mitarbeiternr As Integer _
)

Parameter

tablename
Fokus
KeyValue
mitarbeiternr

Quellcode

[Visual Basic]
        Public Sub Load_Data_MA_Fokus(ByVal tablename As String, ByVal Fokus As Integer, ByVal KeyValue As String, ByVal mitarbeiternr As Integer)
            Tabledata.Tables.Clear()
            Dim sqlcmd As New SqlCommand
            sqlcmd.CommandText = Me.Select_Proc_Bottomtable
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@Fokus", SqlDbType.Int, 4)
            sqlcmd.Parameters.Add("@KeyValue", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@mitarbeiternr", SqlDbType.VarChar, 255)
            sqlcmd.Parameters(0).Value = 0
            sqlcmd.Parameters(1).Value = Fokus
            sqlcmd.Parameters(2).Value = KeyValue
            sqlcmd.Parameters(3).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Save_Data -Methode

Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert

[Visual Basic]
Public Sub Save_Data()

Quellcode

[Visual Basic]
        Public Sub Save_Data()
            Load_BaseData()
            Generate_Update_Statement()
            Generate_Insert_Statement()
            Try
                da.Update(Me.Tabledata, Me.Tabledata.Tables(0).TableName)

            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.dispose -Methode

Dispose von Tabledata

[Visual Basic]
Public Sub dispose()

Quellcode

[Visual Basic]
        Public Sub dispose()
            Me.Tabledata.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


clsServiceKatalogDaten -Klasse

For a list of all members of this type, see clsServiceKatalogDaten-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogDaten

[Visual Basic]
Public Class clsServiceKatalogDaten
    Inherits clsServiceKatalog

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.SLA

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsServiceKatalogDaten-Member


clsServiceKatalogDaten-Member

clsServiceKatalogDaten Übersicht

Öffentliche Konstruktoren

public constructor clsServiceKatalogDaten -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property bExtern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iServiceKatalogNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBezeichnung_extern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBezeichnung_intern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Servicekatalog Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Data Unterstützt von .NET Compact Framework |
public method Get_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Insert_Katalogelement Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework |
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Vertragsbeziehungen

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalogDaten -Klasse


clsServiceKatalogDaten-Eigenschaften

clsServiceKatalogDaten Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property bExtern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property iServiceKatalogNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBezeichnung_extern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sBezeichnung_intern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalogDaten -Klasse


clsServiceKatalogDaten-Methoden

clsServiceKatalogDaten Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Servicekatalog Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Data Unterstützt von .NET Compact Framework |
public method Get_Vertragsbeziehungen Unterstützt von .NET Compact Framework | Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Insert_Katalogelement Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework |
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsServiceKatalog) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsServiceKatalogDaten -Klasse


clsServiceKatalogDaten.Delete_Servicekatalog -Methode

[Visual Basic]
Public Function Delete_Servicekatalog( _
   Optional ByVal basenr As Integer = 0 _
) As Object

Parameter

basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Servicekatalog(Optional ByVal basenr As Integer = 0)
            If basenr <> 0 Then
                Get_Data(basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogDaten.Get_Data -Methode

[Visual Basic]
Public Function Get_Data( _
   ByVal Servicekatalognr As Integer _
) As Object

Parameter

Servicekatalognr

Quellcode

[Visual Basic]
        Public Function Get_Data(ByVal Servicekatalognr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.iServiceKatalogNr = New SqlInt32(CType(Servicekatalognr, Int32))
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogDaten.Get_Vertragsbeziehungen -Methode

Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_Vertragsbeziehungen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal ServiceKatalogNr As Integer _
) As Object

Parameter

c1data
TruedbGrid
ServiceKatalogNr

Quellcode

[Visual Basic]
        Public Function Get_Vertragsbeziehungen(ByRef c1data As C1TrueDBGrid, ByVal ServiceKatalogNr As Integer)
            Vertragsbeziehungen = New TKB.VV.Sysadmin.DomainTable("Vertragsleistung", 1, Trim(Str(ServiceKatalogNr)), Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = Vertragsbeziehungen.Tabledata
            c1data.DataMember = Vertragsbeziehungen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogDaten.Insert_Katalogelement -Methode

[Visual Basic]
Public Function Insert_Katalogelement( _
   ByVal Katalogname As String, _
   ByVal parentid As String _
) As Object

Parameter

Katalogname
parentid

Quellcode

[Visual Basic]
        Public Function Insert_Katalogelement(ByVal Katalogname As String, ByVal parentid As String)
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            Dim newkey = dbkey.get_dbkey("Servicekatalog")

            Me.iServiceKatalogNr = New SqlInt32(CType(newkey, Int32))
            Me.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.bExtern = New SqlBoolean(CType(False, Boolean))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.sBezeichnung_intern = New SqlString(CType(Katalogname, String))
            Me.sBezeichnung_extern = New SqlString(CType(Katalogname, String))
            Me.iParentID = New SqlInt32(CType(parentid, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogDaten.Save_Data -Methode

[Visual Basic]
Public Function Save_Data() As Object

Quellcode

[Visual Basic]
        Public Function Save_Data()
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogDaten-Felder

clsServiceKatalogDaten Übersicht

Felder

public field Vertragsbeziehungen

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsServiceKatalogDaten -Klasse


Vertragsbeziehungen -Feld

[Visual Basic]
Public Vertragsbeziehungen As DomainTable

Quellcode

[Visual Basic]
        Public Vertragsbeziehungen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogDaten


clsServiceKatalogSLATree -Klasse

TreeDatenklasse für den Servicekatalog-Tree

For a list of all members of this type, see clsServiceKatalogSLATree-Member.

System.Object
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogSLATree

[Visual Basic]
Public Class clsServiceKatalogSLATree

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.SLA

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsServiceKatalogSLATree-Member


clsServiceKatalogSLATree-Member

clsServiceKatalogSLATree Übersicht

Öffentliche Methoden

public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen
public method Set_Images Unterstützt von .NET Compact Framework |

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework |
private method Load_Treedata Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method RecurseNodes Unterstützt von .NET Compact Framework |

Felder

private field Treedata

Unterstützt von .NET Compact Framework

clsServiceKatalogSLATree -Klasse


clsServiceKatalogSLATree-Methoden

clsServiceKatalogSLATree Übersicht

Öffentliche Methoden

public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen
public method Set_Images Unterstützt von .NET Compact Framework |

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework |
private method Load_Treedata Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method RecurseNodes Unterstützt von .NET Compact Framework |

clsServiceKatalogSLATree -Klasse


clsServiceKatalogSLATree.LoadTreeView -Methode

[Visual Basic]
Private Function LoadTreeView( _
   ByVal ds As DataSet, _
   ByRef tree As TreeView _
) As Object

Parameter

ds
tree

Quellcode

[Visual Basic]
        Private Function LoadTreeView(ByVal ds As DataSet, ByRef tree As TreeView)
            Dim sroot As String = ""
            Dim tchild As New TreeNode
            Dim tchild1 As New TreeNode
            Dim i As Integer
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If sroot <> ds.Tables(0).Rows(i).Item(1) Then
                    tchild = tree.Nodes.Add(ds.Tables(0).Rows(i).Item(1))
                    tchild.Tag = 0
                    sroot = ds.Tables(0).Rows(i).Item(1)
                End If
                tchild1 = tchild.Nodes.Add(ds.Tables(0).Rows(i).Item(2))
                tchild1.Tag = ds.Tables(0).Rows(i).Item(0)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogSLATree.Load_Tree -Methode

Laden der Treedaten und Tree aufbauen

[Visual Basic]
Public Function Load_Tree( _
   ByRef tree As TreeView _
) As Object

Parameter

tree

Quellcode

[Visual Basic]
        Public Function Load_Tree(ByRef tree As TreeView)
            tree.Enabled = False
            Load_Treedata()
            tree.Nodes.Clear()
            LoadTreeView(Treedata, tree)
            tree.ExpandAll()
            tree.Enabled = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogSLATree.Load_Treedata -Methode

Treedaten ab Datenbank laden

[Visual Basic]
Private Function Load_Treedata() As DataTable

Quellcode

[Visual Basic]
        Private Function Load_Treedata() As DataTable
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "my_servicekatalog_sla_struktur"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogSLATree.RecurseNodes -Methode

[Visual Basic]
Private Function RecurseNodes( _
   ByVal Node As TreeNodeCollection _
) As Object

Parameter

Node

Quellcode

[Visual Basic]
        Private Function RecurseNodes(ByVal Node As TreeNodeCollection)
            For Each tn As TreeNode In Node
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 1
                    tn.SelectedImageIndex = 2
                Else
                    tn.ImageIndex = 3
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogSLATree.Set_Images -Methode

[Visual Basic]
Public Function Set_Images( _
   ByRef tree As TreeView _
) As Object

Parameter

tree

Quellcode

[Visual Basic]
        Public Function Set_Images(ByRef tree As TreeView)
            Dim tn As TreeNode
            For Each tn In tree.Nodes
                MsgBox(tn.Parent.Text)
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 1
                    tn.SelectedImageIndex = 2
                Else
                    tn.ImageIndex = 3
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogSLATree-Felder

clsServiceKatalogSLATree Übersicht

Felder

private field Treedata

Unterstützt von .NET Compact Framework

clsServiceKatalogSLATree -Klasse


Treedata -Feld

[Visual Basic]
Private Treedata As DataSet

Quellcode

[Visual Basic]
        Dim Treedata As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogSLATree


clsServiceKatalogTree -Klasse

TreeDatenklasse für den Servicekatalog-Tree

For a list of all members of this type, see clsServiceKatalogTree-Member.

System.Object
Vertragsverwaltung.TKB.VV.SLA.clsServiceKatalogTree

[Visual Basic]
Public Class clsServiceKatalogTree

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.SLA

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsServiceKatalogTree-Member


clsServiceKatalogTree-Member

clsServiceKatalogTree Übersicht

Öffentliche Methoden

public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen
public method Set_Images Unterstützt von .NET Compact Framework | Images auf den Nodes des TreeVies setzen

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treedata Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method RecurseNodes Unterstützt von .NET Compact Framework | Nodes rekursiv lesen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

Felder

private field Treedata

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework

clsServiceKatalogTree -Klasse


clsServiceKatalogTree-Methoden

clsServiceKatalogTree Übersicht

Öffentliche Methoden

public method Load_Tree Unterstützt von .NET Compact Framework | Laden der Treedaten und Tree aufbauen
public method Set_Images Unterstützt von .NET Compact Framework | Images auf den Nodes des TreeVies setzen

Andere Methoden

private method LoadTreeView Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Treedata Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden
private method Load_Treeview Unterstützt von .NET Compact Framework | Interne Relation aufbauen und Tree aufbauen
private method RecurseNodes Unterstützt von .NET Compact Framework | Nodes rekursiv lesen
private method RecursivelyLoadTree Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen

clsServiceKatalogTree -Klasse


clsServiceKatalogTree.LoadTreeView -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadTreeView( _
   ByVal oDS As DataSet, _
   ByRef oTreeview As TreeView _
)

Parameter

oDS
oTreeview

Quellcode

[Visual Basic]
        Private Sub LoadTreeView(ByVal oDS As DataSet, ByRef oTreeview As TreeView)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            fnt_Strikeout = New System.Drawing.Font(oTreeview.Font.FontFamily, oTreeview.Font.Size, FontStyle.Strikeout)
            fnt_normal = New System.Drawing.Font(oTreeview.Font.FontFamily, oTreeview.Font.Size, FontStyle.Regular)
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode As New TreeNode()
                        oNode.Text = oDataRow("Bezeichnung").ToString()
                        oNode.Tag = oDataRow("Servicekatalognr").ToString
                        oNode.SelectedImageIndex = 0
                        oNode.StateImageIndex = 0
                        oNode.ImageIndex = 0
                        If oDataRow("Aktiv") = False Then
                            oNode.NodeFont = fnt_Strikeout
                        End If
                        oTreeview.Nodes.Add(oNode)
                        RecursivelyLoadTree(oDataRow, oNode)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.Load_Tree -Methode

Laden der Treedaten und Tree aufbauen

[Visual Basic]
Public Function Load_Tree( _
   ByRef tree As TreeView, _
   Optional ByVal CheckState As Integer = 0 _
) As Object

Parameter

tree
Erforderlich.
CheckState
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Load_Tree(ByRef tree As TreeView, Optional ByVal CheckState As Integer = 0)
            Load_Treedata(CheckState)
            tree.Nodes.Clear()
            Load_Treeview(Treedata, tree)

            tree.ExpandAll()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.Load_Treedata -Methode

Treedaten ab Datenbank laden

[Visual Basic]
Private Function Load_Treedata( _
   ByVal Checkstate As Object _
) As DataTable

Parameter

Checkstate

Quellcode

[Visual Basic]
        Private Function Load_Treedata(ByVal Checkstate) As DataTable
            Treedata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "my_servicekatalog_struktur"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@CheckState", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            selectcommand.Parameters(1).Value = Checkstate

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.Load_Treeview -Methode

Interne Relation aufbauen und Tree aufbauen

[Visual Basic]
Private Sub Load_Treeview( _
   ByVal oSourceData As DataSet, _
   ByRef tree As TreeView _
)

Parameter

oSourceData
tree

Quellcode

[Visual Basic]
        Private Sub Load_Treeview(ByVal oSourceData As DataSet, ByRef tree As TreeView)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.Tables(0).DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("Servicekatalognr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadTreeView(oDS, tree)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.RecurseNodes -Methode

Nodes rekursiv lesen

[Visual Basic]
Private Function RecurseNodes( _
   ByVal Node As TreeNodeCollection _
) As Object

Parameter

Node

Quellcode

[Visual Basic]
        Private Function RecurseNodes(ByVal Node As TreeNodeCollection)
            For Each tn As TreeNode In Node
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 0
                    tn.StateImageIndex = 0
                    tn.SelectedImageIndex = 0
                Else
                    tn.ImageIndex = 1
                    tn.StateImageIndex = 1
                    tn.SelectedImageIndex = 1
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.RecursivelyLoadTree -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadTree( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode _
)

Parameter

oDataRow
oNode

Quellcode

[Visual Basic]
        Private Sub RecursivelyLoadTree(ByVal oDataRow As DataRow, ByRef oNode As TreeNode)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = oChildRow("Servicekatalognr").ToString()
                If oChildRow("Aktiv") = False Then
                    oChildNode.NodeFont = fnt_Strikeout
                End If

                oNode.Nodes.Add(oChildNode)
                RecursivelyLoadTree(oChildRow, oChildNode)
            Next oChildRow
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree.Set_Images -Methode

Images auf den Nodes des TreeVies setzen

[Visual Basic]
Public Function Set_Images( _
   ByRef tree As TreeView _
) As Object

Parameter

tree

Quellcode

[Visual Basic]
        Public Function Set_Images(ByRef tree As TreeView)
            Dim tn As TreeNode
            For Each tn In tree.Nodes
                If tn.Nodes.Count > 0 Then
                    tn.ImageIndex = 0
                    tn.StateImageIndex = 0
                    tn.SelectedImageIndex = 0
                Else
                    tn.ImageIndex = 1
                    tn.StateImageIndex = 1
                    tn.SelectedImageIndex = 1
                End If
                RecurseNodes(tn.Nodes)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


clsServiceKatalogTree-Felder

clsServiceKatalogTree Übersicht

Felder

private field Treedata

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework

clsServiceKatalogTree -Klasse


Treedata -Feld

[Visual Basic]
Private Treedata As DataSet

Quellcode

[Visual Basic]
        Dim Treedata As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


fnt_Strikeout -Feld

[Visual Basic]
Public fnt_Strikeout As Font

Quellcode

[Visual Basic]
        Public fnt_Strikeout As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


fnt_normal -Feld

[Visual Basic]
Public fnt_normal As Font

Quellcode

[Visual Basic]
        Public fnt_normal As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsServiceKatalogTree


Vertragsverwaltung.TKB.VV.Stammdaten -Namespace

Klassen

public class clsStammdaten

Unterstützt von .NET Compact Framework


clsStammdaten -Klasse

For a list of all members of this type, see clsStammdaten-Member.

System.Object
Vertragsverwaltung.TKB.VV.Stammdaten.clsStammdaten

[Visual Basic]
Public Class clsStammdaten

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Stammdaten

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsStammdaten-Member


clsStammdaten-Member

clsStammdaten Übersicht

Öffentliche Methoden

public method Get_Gremium

Unterstützt von .NET Compact Framework
public method Get_Stammdaten

Unterstützt von .NET Compact Framework

clsStammdaten -Klasse


clsStammdaten-Methoden

clsStammdaten Übersicht

Öffentliche Methoden

public method Get_Gremium

Unterstützt von .NET Compact Framework
public method Get_Stammdaten

Unterstützt von .NET Compact Framework

clsStammdaten -Klasse


clsStammdaten.Get_Gremium -Methode

[Visual Basic]
Public Function Get_Gremium( _
   ByVal type As Integer, _
   ByVal subtype As Integer _
) As DataTable

Parameter

type
subtype

Quellcode

[Visual Basic]
        Public Function Get_Gremium(ByVal type As Integer, ByVal subtype As Integer) As DataTable
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)
            Dim ds As New DataSet
            selectcommand.CommandText = "dbo.sp_get_gremium"
            selectcommand.Parameters.Add("@type", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@subtype", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = type
            selectcommand.Parameters(1).Value = subtype

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(ds)
                Return ds.Tables(0)
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                ds.Dispose()
                selectcommand.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsStammdaten


clsStammdaten.Get_Stammdaten -Methode

[Visual Basic]
Public Function Get_Stammdaten( _
   ByVal Tabelle As String, _
   ByVal orderby As String _
) As DataTable

Parameter

Tabelle
orderby

Quellcode

[Visual Basic]
        Public Function Get_Stammdaten(ByVal Tabelle As String, ByVal orderby As String) As DataTable
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)
            Dim ds As New DataSet
            selectcommand.CommandText = "sp_get_stammdaten"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@Tabelle", SqlDbType.VarChar, 255)
            selectcommand.Parameters.Add("@Orderby", SqlDbType.VarChar, 255)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            selectcommand.Parameters(1).Value = Tabelle
            selectcommand.Parameters(2).Value = orderby

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(ds)
                Return ds.Tables(0)
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                ds.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsStammdaten


Vertragsverwaltung.TKB.VV.Sysadmin -Namespace

Klassen

public class DomainTable

Unterstützt von .NET Compact Framework
public class clsMySysadminfunkion

Unterstützt von .NET Compact Framework


DomainTable -Klasse

For a list of all members of this type, see DomainTable-Member.

System.Object
Vertragsverwaltung.TKB.VV.Sysadmin.DomainTable
Vertragsverwaltung.TKB.VV.SLA.clsSLAKatalogdaten

[Visual Basic]
Public Class DomainTable

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

DomainTable-Member


DomainTable-Member

DomainTable Übersicht

Öffentliche Konstruktoren

public constructor DomainTable -Konstructor Überladen.

Unterstützt von .NET Compact Framework

 Tabellenname übernehmen und Daten ab DB laden

Öffentliche Eigenschaften

public property Insert_Proc

Unterstützt von .NET Compact Framework
public property Insert_Proc_Bottomtable

Unterstützt von .NET Compact Framework
public property Select_Proc

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable2

Unterstützt von .NET Compact Framework
public property Tabledata

Unterstützt von .NET Compact Framework
public property Tablename

Unterstützt von .NET Compact Framework
public property Update_Proc

Unterstützt von .NET Compact Framework
public property Update_Proc_Bottomtable

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Insert_Bottom_Table Unterstützt von .NET Compact Framework | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
public method Load_Bootom_Table Unterstützt von .NET Compact Framework | Load der Verbindungstabelle
public method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
public method Load_Data_2Key Unterstützt von .NET Compact Framework |
public method Load_Data_MA Unterstützt von .NET Compact Framework |
public method Load_Data_MA_Fokus Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
public method dispose Unterstützt von .NET Compact Framework | Dispose von Tabledata

Andere Methoden

private method Generate_Insert_Statement Unterstützt von .NET Compact Framework | Insert-Statement dynamisch für das InsertCommand generieren
private method Generate_Update_Statement Unterstützt von .NET Compact Framework | Update-Statement dynamisch für das UpdateCommand generieren
private method Get_Data_Fieldlen Unterstützt von .NET Compact Framework | Feldlänge für den SP-Übergabeparemter festlegen
private method Get_Prefix Unterstützt von .NET Compact Framework | Prefixt für den SP-Übergabeparameter generieren
private method Get_SqlDBType Unterstützt von .NET Compact Framework | SQL-DB-Type für den SP-Übergabeparameter festlegen
private method Load_BaseData Unterstützt von .NET Compact Framework | Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt

Felder

private field BaseData

Unterstützt von .NET Compact Framework
private field InsertCommand

Unterstützt von .NET Compact Framework
private field UpdateCommand

Unterstützt von .NET Compact Framework
private field connection

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field m_Tabledata

Unterstützt von .NET Compact Framework
private field m_selectproc

Unterstützt von .NET Compact Framework
private field m_tablename

Unterstützt von .NET Compact Framework
private field selectcommand

Unterstützt von .NET Compact Framework

DomainTable -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New(String, Integer, String, Integer, String)
[C#] public System.Void DomainTable(string, int, string, int, string);

[Visual Basic] Public Sub New(String, Integer, String, Integer)
[C#] public System.Void DomainTable(string, int, string, int);

[Visual Basic] Public Sub New(String, String, Integer)
[C#] public System.Void DomainTable(string, string, int);

Tabellenname übernehmen und Daten ab DB laden

[Visual Basic] Public Sub New(String, Optional Integer, Optional String)
[C#] public System.Void DomainTable(string, int, string);

DomainTable | Vertragsverwaltung.TKB.VV.Sysadmin


DomainTable-Eigenschaften

DomainTable Übersicht

Öffentliche Eigenschaften

public property Insert_Proc

Unterstützt von .NET Compact Framework
public property Insert_Proc_Bottomtable

Unterstützt von .NET Compact Framework
public property Select_Proc

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable

Unterstützt von .NET Compact Framework
public property Select_Proc_Bottomtable2

Unterstützt von .NET Compact Framework
public property Tabledata

Unterstützt von .NET Compact Framework
public property Tablename

Unterstützt von .NET Compact Framework
public property Update_Proc

Unterstützt von .NET Compact Framework
public property Update_Proc_Bottomtable

Unterstützt von .NET Compact Framework

DomainTable -Klasse


DomainTable-Methoden

DomainTable Übersicht

Öffentliche Methoden

public method Insert_Bottom_Table Unterstützt von .NET Compact Framework | Neuer Eintrag in der Tabelle eintragen. Sind neben den Defaultwerten weitere Attribute vorhanden, werde diese abhängig vom Datentype mit Defaultwerten befüllt.
public method Load_Bootom_Table Unterstützt von .NET Compact Framework | Load der Verbindungstabelle
public method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
public method Load_Data_2Key Unterstützt von .NET Compact Framework |
public method Load_Data_MA Unterstützt von .NET Compact Framework |
public method Load_Data_MA_Fokus Unterstützt von .NET Compact Framework |
public method Save_Data Unterstützt von .NET Compact Framework | Datesichern. Dabei wird das Update- sowie das Insert-Statement dynamisch generiert
public method dispose Unterstützt von .NET Compact Framework | Dispose von Tabledata

Andere Methoden

private method Generate_Insert_Statement Unterstützt von .NET Compact Framework | Insert-Statement dynamisch für das InsertCommand generieren
private method Generate_Update_Statement Unterstützt von .NET Compact Framework | Update-Statement dynamisch für das UpdateCommand generieren
private method Get_Data_Fieldlen Unterstützt von .NET Compact Framework | Feldlänge für den SP-Übergabeparemter festlegen
private method Get_Prefix Unterstützt von .NET Compact Framework | Prefixt für den SP-Übergabeparameter generieren
private method Get_SqlDBType Unterstützt von .NET Compact Framework | SQL-DB-Type für den SP-Übergabeparameter festlegen
private method Load_BaseData Unterstützt von .NET Compact Framework | Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt

DomainTable -Klasse


DomainTable.Generate_Insert_Statement -Methode

Insert-Statement dynamisch für das InsertCommand generieren

[Visual Basic]
Private Sub Generate_Insert_Statement()

Quellcode

[Visual Basic]
        Private Sub Generate_Insert_Statement()
            Dim col As DataColumn
            Dim col1 As DataColumn
            Dim UseCol As Boolean = False

            InsertCommand.CommandText = Me.Insert_Proc
            InsertCommand.CommandType = System.Data.CommandType.StoredProcedure
            InsertCommand.Connection = connection

            InsertCommand.Parameters.Clear()
            For Each col In Me.Tabledata.Tables(0).Columns
                UseCol = False
                For Each col1 In Me.BaseData.Tables(0).Columns
                    If col.ColumnName = col1.ColumnName Then
                        UseCol = True
                        Exit For
                    End If
                Next
                If UseCol Then InsertCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter(Get_Prefix(col) & col.ColumnName, Get_SqlDBType(col), Get_Data_Fieldlen(col), col.ColumnName))
            Next
            InsertCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter("@iErrorcode", SqlDbType.Int, 4))
            InsertCommand.Parameters("@iErrorcode").Value = 0
            da.InsertCommand = InsertCommand
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Generate_Update_Statement -Methode

Update-Statement dynamisch für das UpdateCommand generieren

[Visual Basic]
Private Sub Generate_Update_Statement()

Quellcode

[Visual Basic]
        Private Sub Generate_Update_Statement()
            Dim col As DataColumn
            Dim col1 As DataColumn
            Dim UseCol As Boolean = False

            UpdateCommand.CommandText = Me.Update_Proc
            UpdateCommand.CommandType = System.Data.CommandType.StoredProcedure
            UpdateCommand.Connection = connection

            UpdateCommand.Parameters.Clear()
            For Each col In Me.Tabledata.Tables(0).Columns
                UseCol = False
                For Each col1 In Me.BaseData.Tables(0).Columns
                    If col.ColumnName = col1.ColumnName Then
                        UseCol = True
                        Exit For
                    End If
                Next
                If UseCol Then UpdateCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter(Get_Prefix(col) & col.ColumnName, Get_SqlDBType(col), Get_Data_Fieldlen(col), col.ColumnName))
            Next
            UpdateCommand.Parameters.Add(New System.Data.SqlClient.SqlParameter("@iErrorcode", SqlDbType.Int, 4))
            UpdateCommand.Parameters("@iErrorcode").Value = 0
            da.UpdateCommand = UpdateCommand
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Get_Data_Fieldlen -Methode

Feldlänge für den SP-Übergabeparemter festlegen

[Visual Basic]
Private Function Get_Data_Fieldlen( _
   ByVal col As DataColumn _
) As Integer

Parameter

col
Aktulle Column

Rückgabewert

Feldlänge

Quellcode

[Visual Basic]
        Private Function Get_Data_Fieldlen(ByVal col As DataColumn) As Integer
            Return col.MaxLength
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Get_Prefix -Methode

Prefixt für den SP-Übergabeparameter generieren

[Visual Basic]
Private Function Get_Prefix( _
   ByVal col As DataColumn _
) As String

Parameter

col
Aktuelle Columnt

Rückgabewert

Prefis für SP-Übergabeparameter

Quellcode

[Visual Basic]
        Private Function Get_Prefix(ByVal col As DataColumn) As String
            If col.DataType.Name = "DateTime" Then Return "@da"
            If col.DataType.Name = "Double" Then Return "@f"
            Return "@" & col.DataType.Name.Substring(0, 1)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Get_SqlDBType -Methode

SQL-DB-Type für den SP-Übergabeparameter festlegen

[Visual Basic]
Private Function Get_SqlDBType( _
   ByVal col As DataColumn _
) As SqlDbType

Parameter

col
Aktuelle Column

Rückgabewert

SQLDBType

Quellcode

[Visual Basic]
        Private Function Get_SqlDBType(ByVal col As DataColumn) As SqlDbType
            If col.DataType.Name = "Integer" Then Return SqlDbType.Int
            If col.DataType.Name = "Int32" Then Return SqlDbType.Int
            If col.DataType.Name = "String" Then Return SqlDbType.VarChar
            If col.DataType.Name = "Boolean" Then Return SqlDbType.Bit
            If col.DataType.Name = "DateTime" Then Return SqlDbType.DateTime
            If col.DataType.Name = "Double" Then Return SqlDbType.Float
            MsgBox(col.DataType.Name)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Load_BaseData -Methode

Basis-Datentabelle laden. Diese wird für die dynamische Generierung der Insert- und Update-Statements benötigt

[Visual Basic]
Private Sub Load_BaseData()

Quellcode

[Visual Basic]
        Private Sub Load_BaseData()
            BaseData.Tables.Clear()
            Dim sqlcmd As New SqlCommand

            sqlcmd.CommandText = Me.Select_Proc
            sqlcmd.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            sqlcmd.Parameters(0).Value = 0

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(BaseData, "Basedata")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable.Load_Data -Methode

Daten ab Datenbank laden

[Visual Basic]
Public Overridable Sub Load_Data()

Quellcode

[Visual Basic]
        Public Overridable Sub Load_Data()
            Tabledata.Tables.Clear()

            selectcommand.CommandText = Me.Select_Proc
            selectcommand.Parameters.Add("@iErrorCode", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = 0

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Tabledata, "Domaintable")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable-Felder

DomainTable Übersicht

Felder

private field BaseData

Unterstützt von .NET Compact Framework
private field InsertCommand

Unterstützt von .NET Compact Framework
private field UpdateCommand

Unterstützt von .NET Compact Framework
private field connection

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field m_Tabledata

Unterstützt von .NET Compact Framework
private field m_selectproc

Unterstützt von .NET Compact Framework
private field m_tablename

Unterstützt von .NET Compact Framework
private field selectcommand

Unterstützt von .NET Compact Framework

DomainTable -Klasse


BaseData -Feld

[Visual Basic]
Private BaseData As DataSet

Quellcode

[Visual Basic]
        Dim BaseData As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


InsertCommand -Feld

[Visual Basic]
Private InsertCommand As SqlCommand

Quellcode

[Visual Basic]
        Dim InsertCommand As New SqlCommand

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


UpdateCommand -Feld

[Visual Basic]
Private UpdateCommand As SqlCommand

Quellcode

[Visual Basic]
        Dim UpdateCommand As New SqlCommand

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


connection -Feld

[Visual Basic]
Private connection As SqlConnection

Quellcode

[Visual Basic]
        Dim connection As New SqlConnection()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


da -Feld

[Visual Basic]
Private da As SqlDataAdapter

Quellcode

[Visual Basic]
        Dim da As New SqlDataAdapter("", connection)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


m_Tabledata -Feld

[Visual Basic]
Private m_Tabledata As DataSet

Quellcode

[Visual Basic]
        Dim m_Tabledata As New DataSet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


m_selectproc -Feld

[Visual Basic]
Private m_selectproc As String

Quellcode

[Visual Basic]
        Dim m_selectproc As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


m_tablename -Feld

[Visual Basic]
Private m_tablename As String

Quellcode

[Visual Basic]
        Dim m_tablename As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


selectcommand -Feld

[Visual Basic]
Private selectcommand As SqlCommand

Quellcode

[Visual Basic]
        Dim selectcommand As New SqlCommand

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


clsMySysadminfunkion -Klasse

For a list of all members of this type, see clsMySysadminfunkion-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion
Vertragsverwaltung.TKB.VV.Sysadmin.clsMySysadminfunkion

[Visual Basic]
Public Class clsMySysadminfunkion
    Inherits clsSysadminfunktion

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Sysadmin

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMySysadminfunkion-Member


clsMySysadminfunkion-Member

clsMySysadminfunkion Übersicht

Öffentliche Konstruktoren

public constructor clsMySysadminfunkion -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFheight (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFleft (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFtop (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFwidth (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iImageIndex (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iImageIndexOpen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSort (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iSprache (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDomaintable (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sKeyFields (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method LoadTreeMenu Unterstützt von .NET Compact Framework |
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectHierarchy Unterstützt von .NET Compact Framework |
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMySysadminfunkion -Klasse


clsMySysadminfunkion-Eigenschaften

clsMySysadminfunkion Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iFheight (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFleft (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFtop (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iFwidth (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iImageIndex (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iImageIndexOpen (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSort (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iSprache (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property iSysadminfnktnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sDomaintable (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework
public property sKeyFields (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion)

Unterstützt von .NET Compact Framework

clsMySysadminfunkion -Klasse


clsMySysadminfunkion-Methoden

clsMySysadminfunkion Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method LoadTreeMenu Unterstützt von .NET Compact Framework |
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectHierarchy Unterstützt von .NET Compact Framework |
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSysadminfunktion) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsMySysadminfunkion -Klasse


clsMySysadminfunkion.LoadTreeMenu -Methode

[Visual Basic]
Public Sub LoadTreeMenu( _
   ByVal otv As TreeView _
)

Parameter

otv

Quellcode

[Visual Basic]
        Public Sub LoadTreeMenu(ByVal otv As TreeView)
            Dim menueintraege As New clsMySysadminfunkion()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode

            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()

            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("sysadminfnktnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("sysadminfnktnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMySysadminfunkion


clsMySysadminfunkion.SelectHierarchy -Methode

[Visual Basic]
Public Function SelectHierarchy() As DataTable

Quellcode

[Visual Basic]
        Public Function SelectHierarchy() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            'scmCmdToExecute.CommandText = "dbo.[sp_sysadminfunktion_hierarchie]"
            scmCmdToExecute.CommandText = "dbo.[sp_get_sysadmin_tree]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iroot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMandantnr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(TKB.VV.DB.LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMySysadminfunkion


clsMySysadminfunkion-Felder

clsMySysadminfunkion Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsMySysadminfunkion -Klasse


Vertragsverwaltung.TKB.VV.Utils -Namespace

Namesace TKB.VV.Utils fasst die Utility-Klassen für die Vertragsverwaltung zusammen.

Klassen

public class MyDocMgmt Unterstützt von .NET Compact Framework | Klasse für das Speichern bzw. Auslesen von Image-Dateien in der Datenbank
public class MyFormControls Unterstützt von .NET Compact Framework | Klasse für ein Control-Objekt
public class MyMessage Unterstützt von .NET Compact Framework | Standard-Messages in div. Formatenm
public class MySecurity Unterstützt von .NET Compact Framework | Formular-Security-Objekte auslesen und auf DB schreiben bzw. Formular-Security zur Laufzeit setzen
public class MySpaltenTitel Unterstützt von .NET Compact Framework |
public class Tabellenspalte Unterstützt von .NET Compact Framework |
public class clsMyTabControl Unterstützt von .NET Compact Framework |
public class clsProfile Unterstützt von .NET Compact Framework | Klasse, um die Profile eines Mitarbeiters zu handeln
public class clsSpalten Unterstützt von .NET Compact Framework |
public class clsToolTips Unterstützt von .NET Compact Framework |

Siehe auch

MyDocMgmt | MyFormControls | MyMessage | MySecurity | MySpaltenTitel | Tabellenspalte | clsMyTabControl | clsProfile


MyDocMgmt -Klasse

Klasse für das Speichern bzw. Auslesen von Image-Dateien in der Datenbank

For a list of all members of this type, see MyDocMgmt-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyDocMgmt

[Visual Basic]
Public Class MyDocMgmt

Hinweise

Es werden folgende Datebanktabellen berücksichtigt:

  • Dokument Attribut DocImage
  • Profile Attribut V_Uebersicht (Profillayout des C1TrueDBGrids der Vertragsübersicht|Vertragselemente

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyDocMgmt-Member


MyDocMgmt-Member

MyDocMgmt Übersicht

Öffentliche Methoden

public method Get_Architekturfile Unterstützt von .NET Compact Framework |
public method Get_Dokument Unterstützt von .NET Compact Framework | Liest das Dokument aus der DB und speichert dieses unter einem temporären Filenamen ab
public method Get_Layout Unterstützt von .NET Compact Framework |
public method Get_RptDatei Unterstützt von .NET Compact Framework |
public method OpenSystemFile Unterstützt von .NET Compact Framework |
public method RptName Unterstützt von .NET Compact Framework |
public method Save_Architekturfile Unterstützt von .NET Compact Framework |
public method Save_Document Unterstützt von .NET Compact Framework | Dokument in der Tabelle Dokument speichern
public method Save_LayoutFile Unterstützt von .NET Compact Framework | Grid-Layoutfile speichern
public method Save_RptDatei Unterstützt von .NET Compact Framework |
public method Show_Document Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_Layoutfile_from_db

Unterstützt von .NET Compact Framework

MyDocMgmt -Klasse


MyDocMgmt-Methoden

MyDocMgmt Übersicht

Öffentliche Methoden

public method Get_Architekturfile Unterstützt von .NET Compact Framework |
public method Get_Dokument Unterstützt von .NET Compact Framework | Liest das Dokument aus der DB und speichert dieses unter einem temporären Filenamen ab
public method Get_Layout Unterstützt von .NET Compact Framework |
public method Get_RptDatei Unterstützt von .NET Compact Framework |
public method OpenSystemFile Unterstützt von .NET Compact Framework |
public method RptName Unterstützt von .NET Compact Framework |
public method Save_Architekturfile Unterstützt von .NET Compact Framework |
public method Save_Document Unterstützt von .NET Compact Framework | Dokument in der Tabelle Dokument speichern
public method Save_LayoutFile Unterstützt von .NET Compact Framework | Grid-Layoutfile speichern
public method Save_RptDatei Unterstützt von .NET Compact Framework |
public method Show_Document Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_Layoutfile_from_db

Unterstützt von .NET Compact Framework

MyDocMgmt -Klasse


MyDocMgmt.Get_Architekturfile -Methode

[Visual Basic]
Public Function Get_Architekturfile( _
   ByVal Applikationnr As String, _
   Optional ByVal fname As String = "" _
) As String

Parameter

Applikationnr
Erforderlich.
fname
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Public Function Get_Architekturfile(ByVal Applikationnr As String, Optional ByVal fname As String = "") As String
            Dim connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from ApplikationArchitektur where applikationnr = " & Str(Applikationnr), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim Filename As String = ""
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                DA.Fill(ds, "RptFile")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                Filename = Globals.clsapplication.sTmp_filepath + "\architekturfile.xml"
                If fname <> "" Then
                    Filename = fname
                End If
                MyData = myRow.Item(1)
                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(Filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                Return ""
            End Try
            CB = Nothing
            ds = Nothing
            DA = Nothing
            connection.Close()
            connection = Nothing
            Return Filename
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Get_Dokument -Methode

Liest das Dokument aus der DB und speichert dieses unter einem temporären Filenamen ab

[Visual Basic]
Public Function Get_Dokument( _
   ByVal DokumentNr As Integer _
) As String

Parameter

DokumentNr

Quellcode

[Visual Basic]
        Public Function Get_Dokument(ByVal DokumentNr As Integer) As String
            Dim Filename As String = Globals.clsapplication.sTmp_filepath
            If Right(Filename, 1) <> "\" Then Filename = Filename + "\"

            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From Dokument where DokumentNr=" + Str(DokumentNr), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "Dokument")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                MyData = myRow.Item(16)

                Dim K As Long
                K = UBound(MyData)
                Filename = Filename + myRow.Item(6)
                Dim fs As New FileStream(Filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                MsgBox(ex.Message, MsgBoxStyle.Critical)
                Return ""
            Finally
                connection.Close()
                connection = Nothing
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            Return Filename
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Get_Layout -Methode

[Visual Basic]
Public Function Get_Layout( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal GridNo As Integer, _
   ByVal Profilnr As Integer _
) As Boolean

Parameter

c1data
GridNo
Profilnr

Quellcode

[Visual Basic]
        Public Function Get_Layout(ByRef c1data As C1TrueDBGrid, ByVal GridNo As Integer, ByVal Profilnr As Integer) As Boolean
            Dim filename As String = Globals.clsapplication.sTmp_filepath + Trim(Str(Profilnr)) + Trim(Str(GridNo)) + ".lyt"
            If File.Exists(filename) Then
                c1data.LoadLayout(filename)
                Return True
            End If
            If Get_Layoutfile_from_db(filename, GridNo, Profilnr) Then
                c1data.LoadLayout(filename)
                Return True
            End If
            Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Get_Layoutfile_from_db -Methode

[Visual Basic]
Private Function Get_Layoutfile_from_db( _
   ByVal filename As String, _
   ByVal GridNo As Integer, _
   ByVal Profilnr As Integer _
) As Boolean

Parameter

filename
GridNo
Profilnr

Quellcode

[Visual Basic]
        Private Function Get_Layoutfile_from_db(ByVal filename As String, ByVal GridNo As Integer, ByVal Profilnr As Integer) As Boolean
            'Exit Function
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From profil where profilnr=" & Str(Profilnr), connection)
            'mitarbeiternr=" + Str(Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                Select Case GridNo
                    Case 1
                        MyData = myRow.Item(3)

                End Select

                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
                Return True
            Catch ex As Exception
                Return False
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Get_RptDatei -Methode

[Visual Basic]
Public Function Get_RptDatei( _
   ByVal Auswertungnr As String, _
   Optional ByVal fname As String = "" _
) As String

Parameter

Auswertungnr
Erforderlich.
fname
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Public Function Get_RptDatei(ByVal Auswertungnr As String, Optional ByVal fname As String = "") As String
            Dim connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from AuswertungRptDatei where AuswertungDateiNr = " & Str(Auswertungnr), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim Filename As String = ""
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                DA.Fill(ds, "RptFile")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                Filename = Globals.clsapplication.sTmp_filepath + "\" + myRow.Item(2).ToString
                If fname <> "" Then
                    Filename = fname
                End If
                MyData = myRow.Item(3)
                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(Filename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                Return ""
            End Try
            CB = Nothing
            ds = Nothing
            DA = Nothing
            connection.Close()
            connection = Nothing
            Return filename
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.OpenSystemFile -Methode

[Visual Basic]
Public Function OpenSystemFile( _
   ByVal sFileName As String _
) As Boolean

Parameter

sFileName

Quellcode

[Visual Basic]
        Public Function OpenSystemFile(ByVal sFileName As String) As Boolean
            If Len(sFileName) > 0 Then
                System.Diagnostics.Process.Start(sFileName)
                '
                '               ShellExecute(GetDesktopWindow(), vbNullString, sFileName, vbNullString, vbNullString, vbNormalFocus)
                Return True
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.RptName -Methode

[Visual Basic]
Public Function RptName( _
   ByVal path As String _
) As String

Parameter

path

Quellcode

[Visual Basic]
        Public Function RptName(ByVal path As String) As String
            Dim i As Integer
            Dim file As String = path
            i = InStrRev(file.Trim, "\")
            If i = 0 Then
                Return file.Trim
            Else
                Return Right(file.Trim, Len(file.Trim) - i)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Save_Architekturfile -Methode

[Visual Basic]
Public Function Save_Architekturfile( _
   ByVal Applikationnr As Integer, _
   ByVal iFilename As String _
) As Object

Parameter

Applikationnr
iFilename

Quellcode

[Visual Basic]
        Public Function Save_Architekturfile(ByVal Applikationnr As Integer, ByVal iFilename As String)
            Dim filename As String = iFilename
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from ApplikationArchitektur where applikationnr = " & Str(Applikationnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "RptFile")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Datei speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Applikationnr
                    myRow.Item(1) = mydata
                    '                    myRow.Item(4) = Now
                    '                   myRow.Item(5) = Now
                    '                  myRow.Item(6) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "RptFile")
                Else
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(1) = mydata
                    '                    myRow.Item(2) = RptName(AuswertungName)
                    '                   myRow.Item(3) = mydata
                    '                  myRow.Item(5) = Now
                    '                 myRow.Item(6) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    DA.Update(ds, "RptFile")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Save_Document -Methode

Dokument in der Tabelle Dokument speichern

[Visual Basic]
Public Function Save_Document( _
   ByVal Dokumentnr As Integer, _
   ByVal Filename As String _
) As Boolean

Parameter

Dokumentnr
Nummer des Dokument-Datensatzes
Filename
Zu speichender Dateiname

Quellcode

[Visual Basic]
        Public Function Save_Document(ByVal Dokumentnr As Integer, ByVal Filename As String) As Boolean
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from dokument where dokumentnr =" + Str(dokumentnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "Dokument")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    Return False
                Else
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(16) = mydata
                    DA.Update(ds, "Dokument")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
            Return True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Save_LayoutFile -Methode

Grid-Layoutfile speichern

[Visual Basic]
Public Function Save_LayoutFile( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal GridNo As Integer, _
   ByVal Profilnr As Integer _
) As Boolean

Parameter

c1data
C1Truedbgrind, von welchem das Layout gespeichert werden soll
GridNo
Profilnr

Quellcode

[Visual Basic]
        Public Function Save_LayoutFile(ByRef c1data As C1TrueDBGrid, ByVal GridNo As Integer, ByVal Profilnr As Integer) As Boolean
            Dim filename As String = Globals.clsapplication.sTmp_filepath + Trim(Str(Profilnr)) + Trim(Str(GridNo)) + ".lyt"
            c1data.SaveLayout(filename)

            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from profil where profilnr = " & Str(Profilnr), Connection)
            'mitarbeiternr=" + Str(Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "profil")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Profil sepeichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(1) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    myRow.Item(2) = ""
                    Select Case GridNo
                        Case 1
                            myRow.Item(3) = mydata
                    End Select
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "profil")
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Select Case GridNo
                        Case 1
                            myRow.Item(3) = mydata
                    End Select
                    DA.Update(ds, "profil")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
            Return True

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Save_RptDatei -Methode

[Visual Basic]
Public Function Save_RptDatei( _
   ByVal Auswertungnr As Integer, _
   ByVal AuswertungName As String _
) As String

Parameter

Auswertungnr
AuswertungName

Quellcode

[Visual Basic]
        Public Function Save_RptDatei(ByVal Auswertungnr As Integer, ByVal AuswertungName As String) As String
            Dim filename As String = AuswertungName
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from AuswertungRptDatei where AuswertungDateiNr = " & Str(Auswertungnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "RptFile")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Datei speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Auswertungnr
                    myRow.Item(1) = AuswertungName
                    myRow.Item(2) = RptName(AuswertungName)
                    myRow.Item(3) = mydata
                    myRow.Item(4) = Now
                    myRow.Item(5) = Now
                    myRow.Item(6) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "RptFile")
                Else
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(1) = AuswertungName
                    myRow.Item(2) = RptName(AuswertungName)
                    myRow.Item(3) = mydata
                    myRow.Item(5) = Now
                    myRow.Item(6) = Globals.clsmitarbeiter.iMitarbeiternr.Value
                    DA.Update(ds, "RptFile")
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
            Return RptName(AuswertungName)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyDocMgmt.Show_Document -Methode

[Visual Basic]
Public Function Show_Document( _
   ByVal Dokumentnr As Integer _
) As Boolean

Parameter

Dokumentnr

Quellcode

[Visual Basic]
        Public Function Show_Document(ByVal Dokumentnr As Integer) As Boolean
            Dim tmpfilename As String = Me.Get_Dokument(Dokumentnr)
            If tmpfilename <> "" Then
                OpenSystemFile(tmpfilename)
                Return True
            End If
            Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyDocMgmt


MyFormControls -Klasse

Klasse für ein Control-Objekt

For a list of all members of this type, see MyFormControls-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyFormControls

[Visual Basic]
Public Class MyFormControls

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyFormControls-Member


MyFormControls-Member

MyFormControls Übersicht

Öffentliche Konstruktoren

public constructor MyFormControls -Konstructor

Unterstützt von .NET Compact Framework

 Neue Instanz erstellen

Öffentliche Methoden

public method Write_Object_to_DB

Unterstützt von .NET Compact Framework

 Schreibt einen Datnsatz in die Tabelle SecurityObjects

Andere Methoden

private method Get_Description Unterstützt von .NET Compact Framework |
private method Objexists Unterstützt von .NET Compact Framework | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

Felder

public field MyControl

Unterstützt von .NET Compact Framework
public field MyDescription

Unterstützt von .NET Compact Framework
public field MyFormname

Unterstützt von .NET Compact Framework
public field MyLevel

Unterstützt von .NET Compact Framework
public field MySecurityObject

Unterstützt von .NET Compact Framework
public field MySecurityObjectItem

Unterstützt von .NET Compact Framework
public field MySecurityObjecttype

Unterstützt von .NET Compact Framework

MyFormControls -Klasse


MyFormControls -Konstructor

Neue Instanz erstellen

[Visual Basic]
Public Sub New( _
   ByVal ctl As Object, _
   ByVal Formname As String, _
   ByVal securityobjecttype As String, _
   ByVal Securityobject As String, _
   ByVal SecurityObjectItem As String, _
   Optional ByVal level As Integer = 0, _
   Optional ByVal desc As String = "" _
)

Parameter

ctl
Control-Objekt
Formname
Betroffenes Formular
securityobjecttype
Objekttyp
Securityobject
Objektname
SecurityObjectItem
Unterobjekt (z.B. bei Menus, Spalten von C1TrueDBGrids)
level
Optional. Der Standardwert ist 0.
desc
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Sub New(ByVal ctl As Object, ByVal Formname As String, ByVal securityobjecttype As String, ByVal Securityobject As String, ByVal SecurityObjectItem As String, Optional ByVal level As Integer = 0, Optional ByVal desc As String = "")
            MyControl = ctl
            MySecurityObjecttype = securityobjecttype
            MyFormname = Formname
            MySecurityObject = Securityobject
            MySecurityObjectItem = SecurityObjectItem
            If desc = "" Then
                MyDescription = Get_Description(ctl)
            Else
                MyDescription = desc
            End If
            Try
                MyDescription = MyDescription.Replace("&", "")
            Catch ex As Exception
            End Try
            MyLevel = level
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyFormControls-Methoden

MyFormControls Übersicht

Öffentliche Methoden

public method Write_Object_to_DB

Unterstützt von .NET Compact Framework

 Schreibt einen Datnsatz in die Tabelle SecurityObjects

Andere Methoden

private method Get_Description Unterstützt von .NET Compact Framework |
private method Objexists Unterstützt von .NET Compact Framework | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

MyFormControls -Klasse


MyFormControls.Get_Description -Methode

[Visual Basic]
Private Function Get_Description( _
   ByRef ctl As Object _
) As String

Parameter

ctl

Quellcode

[Visual Basic]
        Private Function Get_Description(ByRef ctl As Object) As String
            Dim typ As System.Type = ctl.GetType
            Select Case LCase(typ.Name)
                Case "menustrip", "toolstripmenuitem", "toolstrip", "toolstripbutton", "contextmenustrip", "tabpage", "c1truedbgrid", "label"
                    Return ctl.Text
                Case Else
                    Return ctl.Name
            End Select

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyFormControls.Objexists -Methode

Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

[Visual Basic]
Private Function Objexists() As Boolean

Quellcode

[Visual Basic]
        Private Function Objexists() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_security_check_entry]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@form", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MyFormname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objecttype", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObjecttype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@object", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objectitem", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Me.MySecurityObjectItem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objexists", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                If scmCmdToExecute.Parameters("@objexists").Value > 0 Then
                    Return True
                Else
                    Return False
                End If
            Catch ex As Exception
            Finally
                scmCmdToExecute.Connection.Close()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyFormControls.Write_Object_to_DB -Methode

Schreibt einen Datnsatz in die Tabelle SecurityObjects

[Visual Basic]
Public Function Write_Object_to_DB() As Object

Quellcode

[Visual Basic]
        Public Function Write_Object_to_DB()
            If Objexists() Then Exit Function
            Dim sectbl As New TKB.VV.DB.clsSecurityObject
            Dim dbkey As New TKB.VV.DB.clsMyKey_Tabelle
            dbkey.cpMainConnectionProvider = Globals.conn
            Dim newkey As Integer = dbkey.get_dbkey("SecurityObject")

            sectbl.cpMainConnectionProvider = Globals.conn
            conn.OpenConnection()
            sectbl.iSecurityObjectNr = New SqlInt32(CType(newkey, Int32))
            sectbl.sSecurityForm = New SqlString(CType(MyFormname, String))
            sectbl.sSecurityObjectType = New SqlString(CType(Me.MySecurityObjecttype, String))
            sectbl.sSecurityObject = New SqlString(CType(Me.MySecurityObject, String))
            sectbl.sSecurityObjectItem = New SqlString(CType(Me.MySecurityObjectItem, String))
            sectbl.bAktiv = New SqlBoolean(CType(True, Boolean))
            sectbl.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            sectbl.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            sectbl.sSecurityObjectDescriotion = New SqlString(CType(Me.MyDescription, String))
            sectbl.iLevel = New SqlInt32(CType(Me.MyLevel, Int32))
            sectbl.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            sectbl.iMandantnr = New SqlInt32(CType(Globals.clsmitarbeiter.iMandantnr.Value, Int32))
            sectbl.Insert()
            conn.CloseConnection(True)
            sectbl.Dispose()
            dbkey.Dispose()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyFormControls-Felder

MyFormControls Übersicht

Felder

public field MyControl

Unterstützt von .NET Compact Framework
public field MyDescription

Unterstützt von .NET Compact Framework
public field MyFormname

Unterstützt von .NET Compact Framework
public field MyLevel

Unterstützt von .NET Compact Framework
public field MySecurityObject

Unterstützt von .NET Compact Framework
public field MySecurityObjectItem

Unterstützt von .NET Compact Framework
public field MySecurityObjecttype

Unterstützt von .NET Compact Framework

MyFormControls -Klasse


MyControl -Feld

[Visual Basic]
Public MyControl As Object

Quellcode

[Visual Basic]
        Public MyControl As Object

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyDescription -Feld

[Visual Basic]
Public MyDescription As String

Quellcode

[Visual Basic]
        Public MyDescription As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyFormname -Feld

[Visual Basic]
Public MyFormname As String

Quellcode

[Visual Basic]
        Public MyFormname As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyLevel -Feld

[Visual Basic]
Public MyLevel As Integer

Quellcode

[Visual Basic]
        Public MyLevel As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MySecurityObject -Feld

[Visual Basic]
Public MySecurityObject As String

Quellcode

[Visual Basic]
        Public MySecurityObject As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MySecurityObjectItem -Feld

[Visual Basic]
Public MySecurityObjectItem As String

Quellcode

[Visual Basic]
        Public MySecurityObjectItem As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MySecurityObjecttype -Feld

[Visual Basic]
Public MySecurityObjecttype As String

Quellcode

[Visual Basic]
        Public MySecurityObjecttype As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyFormControls


MyMessage -Klasse

Standard-Messages in div. Formatenm

For a list of all members of this type, see MyMessage-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.MyMessage

[Visual Basic]
Public Class MyMessage

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MyMessage-Member


MyMessage-Member

MyMessage Übersicht

Öffentliche Methoden

public method Get_Meldungstext Unterstützt von .NET Compact Framework | Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet
public method ReplaceTextinMSG Unterstützt von .NET Compact Framework | Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2
public method ShowMyDialog Unterstützt von .NET Compact Framework | Zeig den eigenen Messagebox-Dialog
public method Show_MessageYesNo Unterstützt von .NET Compact Framework | Yes-No-Meldung
public method Show_MessageYesNoCancel Unterstützt von .NET Compact Framework | Meldung Yes-No-Cancel
public method dispose Unterstützt von .NET Compact Framework |
public method show_MessageYesNo_ReplaceText Unterstützt von .NET Compact Framework | Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
public method show_standardmessage Unterstützt von .NET Compact Framework | Standardmessage
public method show_standardmessage_ReplaceText Unterstützt von .NET Compact Framework | Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

Felder

private field meldungstexte

Unterstützt von .NET Compact Framework

 Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen

MyMessage -Klasse


MyMessage-Methoden

MyMessage Übersicht

Öffentliche Methoden

public method Get_Meldungstext Unterstützt von .NET Compact Framework | Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet
public method ReplaceTextinMSG Unterstützt von .NET Compact Framework | Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2
public method ShowMyDialog Unterstützt von .NET Compact Framework | Zeig den eigenen Messagebox-Dialog
public method Show_MessageYesNo Unterstützt von .NET Compact Framework | Yes-No-Meldung
public method Show_MessageYesNoCancel Unterstützt von .NET Compact Framework | Meldung Yes-No-Cancel
public method dispose Unterstützt von .NET Compact Framework |
public method show_MessageYesNo_ReplaceText Unterstützt von .NET Compact Framework | Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2
public method show_standardmessage Unterstützt von .NET Compact Framework | Standardmessage
public method show_standardmessage_ReplaceText Unterstützt von .NET Compact Framework | Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

MyMessage -Klasse


MyMessage.Get_Meldungstext -Methode

Meldungen aus der Datenbanklesen, sofern diese noch nicht ausgelesen worden sind. Nach dem ersten Lesen werden die Daten aus der Tabelle Meldungstexte ohne erneutem DB-Zugriff verwendet

[Visual Basic]
Public Function Get_Meldungstext( _
   ByVal i As Integer _
) As String

Parameter

i

Quellcode

[Visual Basic]
        Public Function Get_Meldungstext(ByVal i As Integer) As String
            Dim meldungen As New TKB.VV.DB.clsMeldungstexte
            Dim res As Integer
            meldungen.cpMainConnectionProvider = conn
            If Me.meldungstexte.Count = 0 Then
                Me.meldungstexte.Table = meldungen.SelectAll
            End If
            meldungstexte.Sort = "meldungstextnr"
            res = meldungstexte.Find(i)
            Try
                Get_Meldungstext = Me.meldungstexte(res).Item(2)
            Catch
                Get_Meldungstext = ""
            End Try
            meldungen.Dispose()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.ReplaceTextinMSG -Methode

Ausgabe der Meldung, welche übergeben wird. Als Option können 2 Texte zum Ersetzen übergeben werden. Parameter im Meldungstext #1 oder #2

[Visual Basic]
Public Function ReplaceTextinMSG( _
   ByVal OrgText As String, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As String

Parameter

OrgText
Meldungstext
Text1
erster Text zum ersetzen
Text2
zweiter Text zum ersetzen

Quellcode

[Visual Basic]
        Public Function ReplaceTextinMSG(ByVal OrgText As String, ByVal Text1 As String, ByVal Text2 As String) As String
            OrgText = OrgText.Replace("#1", Text1)
            OrgText = OrgText.Replace("#2", Text2)
            ReplaceTextinMSG = OrgText
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.ShowMyDialog -Methode

Zeig den eigenen Messagebox-Dialog

[Visual Basic]
Public Function ShowMyDialog( _
   ByVal msgtext As String, _
   ByVal ImageStyle As MsgBoxStyle, _
   ByVal Buttons As MsgBoxStyle _
) As MsgBoxResult

Parameter

msgtext
ImageStyle
Buttons

Quellcode

[Visual Basic]
        Public Function ShowMyDialog(ByVal msgtext As String, ByVal ImageStyle As MsgBoxStyle, ByVal Buttons As MsgBoxStyle) As MsgBoxResult
            Dim f As New frmMsgBox
            f.btnno.Visible = False
            f.btnAbbruch.Visible = False
            f.btnYes.Visible = False
            f.btnOK.Visible = False
            Select Case Buttons
                Case MsgBoxStyle.OkCancel
                    f.btnYes.Visible = True
                    f.btnAbbruch.Visible = True
                Case MsgBoxStyle.YesNo
                    f.btnYes.Visible = True
                    f.btnno.Visible = True
                Case MsgBoxStyle.YesNoCancel
                    f.btnYes.Visible = True
                    f.btnno.Visible = True
                    f.btnAbbruch.Visible = True
                Case MsgBoxStyle.OkOnly
                    f.btnOK.Visible = True
            End Select
            f.imgCritical.Visible = False
            f.imgExclamation.Visible = False
            f.imgInformation.Visible = False
            f.imgQuestion.Visible = False
            Select Case ImageStyle
                Case MsgBoxStyle.Critical
                    f.imgCritical.Visible = True
                Case MsgBoxStyle.Exclamation
                    f.imgExclamation.Visible = True
                Case MsgBoxStyle.Information
                    f.imgInformation.Visible = True
                Case MsgBoxStyle.Question
                    f.imgQuestion.Visible = True
            End Select
            f.txtmsg.Text = msgtext
            'f.btnYes.Visible = True
            'f.btnno.Visible = True
            f.ShowDialog()
            Select Case f.DialogResult
                Case DialogResult.Abort, DialogResult.Cancel
                    Return MsgBoxResult.Cancel
                Case DialogResult.No
                    Return MsgBoxResult.No
                Case DialogResult.Yes
                    Return MsgBoxResult.Yes
                Case Else

            End Select
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.Show_MessageYesNo -Methode

Yes-No-Meldung

[Visual Basic]
Public Function Show_MessageYesNo( _
   ByVal i As Integer _
) As MsgBoxResult

Parameter

i
Meldungsnr

Rückgabewert

MsgboxResult

Quellcode

[Visual Basic]
        Public Function Show_MessageYesNo(ByVal i As Integer) As MsgBoxResult
            Return Me.ShowMyDialog(Get_Meldungstext(i), MsgBoxStyle.Question, MsgBoxStyle.YesNo)
            'Show_MessageYesNo = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.Show_MessageYesNoCancel -Methode

Meldung Yes-No-Cancel

[Visual Basic]
Public Function Show_MessageYesNoCancel( _
   ByVal i As Integer _
) As MsgBoxResult

Parameter

i

Quellcode

[Visual Basic]
        Public Function Show_MessageYesNoCancel(ByVal i As Integer) As MsgBoxResult
            Return Me.ShowMyDialog(Get_Meldungstext(i), MsgBoxStyle.Question, MsgBoxStyle.YesNoCancel)
            'Show_MessageYesNoCancel = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNoCancel + MsgBoxStyle.Question)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.dispose -Methode

[Visual Basic]
Public Sub dispose()

Quellcode

[Visual Basic]
        Sub dispose()
            meldungstexte.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.show_MessageYesNo_ReplaceText -Methode

Yes-No-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

[Visual Basic]
Public Function show_MessageYesNo_ReplaceText( _
   ByVal i As Integer, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As MsgBoxResult

Parameter

i
MeldungsNr
Text1
erster Text zum ersetzen
Text2
zweiter Text zum ersetzen

Quellcode

[Visual Basic]
        Public Function show_MessageYesNo_ReplaceText(ByVal i As Integer, ByVal Text1 As String, ByVal Text2 As String) As MsgBoxResult
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            Return Me.ShowMyDialog(s, MsgBoxStyle.Question, MsgBoxStyle.YesNo)
            'show_MessageYesNo_ReplaceText = MsgBox(s, MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.show_standardmessage -Methode

Standardmessage

[Visual Basic]
Public Function show_standardmessage( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle _
) As Integer

Parameter

i
Messagenr
typ
Messagetyp

Quellcode

[Visual Basic]
        Public Function show_standardmessage(ByVal i As Integer, ByVal typ As MsgBoxStyle) As Integer
            Me.ShowMyDialog(Get_Meldungstext(i), typ, MsgBoxStyle.OkOnly)
            'MsgBox(Get_Meldungstext(i), typ)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage.show_standardmessage_ReplaceText -Methode

Standard-Meldung, welcher 2 Strings als Parameter übergeben werden, damit diese im Meldungstext ersetzt werden können. Parameter im Meldungstext #1 oder #2

[Visual Basic]
Public Function show_standardmessage_ReplaceText( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As Integer

Parameter

i
typ
Text1
Text2

Quellcode

[Visual Basic]
        Public Function show_standardmessage_ReplaceText(ByVal i As Integer, ByVal typ As MsgBoxStyle, ByVal Text1 As String, ByVal Text2 As String) As Integer
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            Return Me.ShowMyDialog(s, typ, MsgBoxStyle.OkOnly)
            '            MsgBox(s, typ)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MyMessage-Felder

MyMessage Übersicht

Felder

private field meldungstexte

Unterstützt von .NET Compact Framework

 Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen

MyMessage -Klasse


meldungstexte -Feld

Dataview Meldungstexte um Textelemente für die Ausgabe zu suchen

[Visual Basic]
Private meldungstexte As DataView

Quellcode

[Visual Basic]
        Private meldungstexte As New DataView()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MyMessage


MySecurity -Klasse

Formular-Security-Objekte auslesen und auf DB schreiben bzw. Formular-Security zur Laufzeit setzen

For a list of all members of this type, see MySecurity-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.MySecurity

[Visual Basic]
Public Class MySecurity

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MySecurity-Member


MySecurity-Member

MySecurity Übersicht

Öffentliche Methoden

public method Generate_HTML Unterstützt von .NET Compact Framework |
public method List_Form_Controls Unterstützt von .NET Compact Framework | Alle Controls des Formulars zusammensuchen und auf der DB speichern
public method Print_Screen Unterstützt von .NET Compact Framework |
public method Set_Form_Readonly Unterstützt von .NET Compact Framework |
public method Set_Form_Security Unterstützt von .NET Compact Framework | Formularsecurity setzen
public method saveasbitmap Unterstützt von .NET Compact Framework |

Andere Methoden

private method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
private method Objectanalysis Unterstützt von .NET Compact Framework | Sämtliche Controls vom Formular auslesen
private method Objectanalysis_readonly Unterstützt von .NET Compact Framework |
private method Objexists Unterstützt von .NET Compact Framework | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
private method ReadContextMenu Unterstützt von .NET Compact Framework | Auslesen von ContextMenuItems
private method ReadMenu Unterstützt von .NET Compact Framework |
private method Set_Preferences Unterstützt von .NET Compact Framework | Security-Einstellungen setzen
private method Set_Security Unterstützt von .NET Compact Framework | Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt
private method get_all_menus Unterstützt von .NET Compact Framework | Auslesen von Menu-Subitems

Felder

private field IntForm Unterstützt von .NET Compact Framework |
private field SecurityData Unterstützt von .NET Compact Framework |
private field connection Unterstützt von .NET Compact Framework |
private field ctlcol Unterstützt von .NET Compact Framework |
private field da Unterstützt von .NET Compact Framework |
private field formname Unterstützt von .NET Compact Framework |
private field level Unterstützt von .NET Compact Framework | Auslesen von MenuItems
private field tmpmenuname Unterstützt von .NET Compact Framework |
private field tt Unterstützt von .NET Compact Framework |

MySecurity -Klasse


MySecurity-Methoden

MySecurity Übersicht

Öffentliche Methoden

public method Generate_HTML Unterstützt von .NET Compact Framework |
public method List_Form_Controls Unterstützt von .NET Compact Framework | Alle Controls des Formulars zusammensuchen und auf der DB speichern
public method Print_Screen Unterstützt von .NET Compact Framework |
public method Set_Form_Readonly Unterstützt von .NET Compact Framework |
public method Set_Form_Security Unterstützt von .NET Compact Framework | Formularsecurity setzen
public method saveasbitmap Unterstützt von .NET Compact Framework |

Andere Methoden

private method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
private method Objectanalysis Unterstützt von .NET Compact Framework | Sämtliche Controls vom Formular auslesen
private method Objectanalysis_readonly Unterstützt von .NET Compact Framework |
private method Objexists Unterstützt von .NET Compact Framework | Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist
private method ReadContextMenu Unterstützt von .NET Compact Framework | Auslesen von ContextMenuItems
private method ReadMenu Unterstützt von .NET Compact Framework |
private method Set_Preferences Unterstützt von .NET Compact Framework | Security-Einstellungen setzen
private method Set_Security Unterstützt von .NET Compact Framework | Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt
private method get_all_menus Unterstützt von .NET Compact Framework | Auslesen von Menu-Subitems

MySecurity -Klasse


MySecurity.Generate_HTML -Methode

[Visual Basic]
Public Function Generate_HTML() As Object

Quellcode

[Visual Basic]
        Public Function Generate_HTML()
            saveasbitmap(Me.IntForm, "testform")
            'Exit Function
            'Dim x As MyFormControls
            'For Each x In ctlcol
            '    Try
            '        saveasbitmap(x.MyControl, x.MyFormname & "_" & x.MySecurityObject & "_" & x.MySecurityObjectItem)
            '        If x.MySecurityObjecttype = "ToolStrip" And x.MySecurityObjectItem = "" Then
            '            Dim gaga As ToolStrip = x.MyControl
            '            For Each c As ToolStripButton In gaga.Items
            '                Dim xxx As Control = CType(c, Control)

            '                xxx = CType(c, Control)
            '                saveasbitmap(xxx, "xxx")
            '            Next
            '        End If
            '    Catch ex As Exception
            '        MsgBox(ex.Message)
            '    End Try
            'Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.List_Form_Controls -Methode

Alle Controls des Formulars zusammensuchen und auf der DB speichern

[Visual Basic]
Public Function List_Form_Controls( _
   ByRef f As Form _
) As Object

Parameter

f
Betroffenes Formular

Quellcode

[Visual Basic]
        Public Function List_Form_Controls(ByRef f As Form)
            Me.ctlcol.Clear()
            formname = f.Name
            For Each ctl As Control In f.Controls
                Objectanalysis(ctl)
            Next
            Dim i As Integer
            For i = 1 To ctlcol.Count
                Dim secobj As MyFormControls = ctlcol(i)
                secobj.Write_Object_to_DB()
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Load_Data -Methode

Daten ab Datenbank laden

[Visual Basic]
Private Sub Load_Data( _
   ByVal Formname As String _
)

Parameter

Formname

Quellcode

[Visual Basic]
        Private Sub Load_Data(ByVal Formname As String)
            Try
                'xxx
                If SecurityData.Tables.Count > 0 Then
                    SecurityData.Tables.Clear()
                End If
                '                Exit Sub
            Catch ex As Exception
            End Try
            SecurityData.Tables.Clear()
            Dim sqlcmd As New SqlCommand

            sqlcmd.CommandText = "dbo.my_security_get_data"
            sqlcmd.Parameters.Add("@FormName", SqlDbType.VarChar, 255)
            sqlcmd.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            sqlcmd.Parameters(0).Value = Formname
            sqlcmd.Parameters(1).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(SecurityData, "SecurityTable")
                Globals.SecurityDaten.Tables.Add(SecurityData.Tables(0).Copy)
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Objectanalysis -Methode

Sämtliche Controls vom Formular auslesen

[Visual Basic]
Private Function Objectanalysis( _
   ByRef ctl As Object _
) As String

Parameter

ctl

Quellcode

[Visual Basic]
        Private Function Objectanalysis(ByRef ctl As Object) As String
            Dim typ As System.Type = ctl.GetType
            Select Case LCase(typ.Name)
                Case "menustrip"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    tmpmenuname = ctl.name
                    ReadMenu(ctl)
                Case "contextmenustrip"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    tmpmenuname = ctl.name
                    ReadContextMenu(ctl)
                Case "toolstrip"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptoolstrop As ToolStrip = ctl
                    Try
                        Dim ic As Integer
                        For ic = 0 To tmptoolstrop.Items.Count - 1
                            Try
                                Dim subobj As ToolStripButton
                                subobj = tmptoolstrop.Items(ic)
                                ctlcol.Add(New MyFormControls(subobj, formname, typ.Name, ctl.Name, subobj.Name, 1))
                            Catch ex As Exception

                            End Try

                        Next
                        'For Each subobj As ToolStripButton In tmptoolstrop.Items
                        'ctlcol.Add(New MyFormControls(subobj, formname, typ.Name, ctl.Name, subobj.Name, 1))
                        'Next
                    Catch
                    End Try
                Case "splitcontainer"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmpsplit As SplitContainer = ctl
                    For Each ctrl As Object In tmpsplit.Panel1.Controls
                        Objectanalysis(ctrl)
                    Next
                    For Each ctrl As Object In tmpsplit.Panel2.Controls
                        Objectanalysis(ctrl)
                    Next
                Case "tabcontrol", "clsmytabcontrol"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabcontrol As TabControl = ctl
                    For Each ctl In tmptabcontrol.TabPages
                        Objectanalysis(ctl)
                    Next
                Case "tabpage"
                    Dim tmptabpage As TabPage = ctl
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, tmptabpage.Parent.Name, 1))

                    For Each ctl In tmptabpage.Controls
                        Objectanalysis(ctl)
                    Next
                Case "groupbox"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabpage As GroupBox = ctl
                    For Each ctl In tmptabpage.Controls
                        Objectanalysis(ctl)
                    Next
                Case "panel"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmppanel As Panel = ctl
                    For Each ctl In tmppanel.Controls
                        Objectanalysis(ctl)
                    Next
                Case "c1truedbgrid"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim ctrl As C1TrueDBGrid = ctl
                    Dim i As Integer
                    For i = 0 To ctrl.Columns.Count - 1
                        ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ctrl.Columns(i).Caption, 0, ctrl.Columns(i).Caption))
                    Next
                    Try
                        If ctrl.ContextMenuStrip.Name <> "" Then
                            Dim x As ContextMenuStrip = ctrl.ContextMenuStrip
                            Objectanalysis(x)
                        End If
                    Catch ex As Exception

                    End Try
                    For Each xctl As Object In ctrl.Controls
                        Objectanalysis(xctl)
                    Next
                Case "treeview"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim ctrl As TreeView = ctl
                    Try

                        If ctrl.ContextMenuStrip.Name <> "" Then
                            Dim x As ContextMenuStrip = ctrl.ContextMenuStrip
                            Objectanalysis(x)
                        End If

                    Catch ex As Exception

                    End Try

                Case Else
                    If ctl.name = "TreeStruktur" Then
                    End If
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
            End Select
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Objectanalysis_readonly -Methode

[Visual Basic]
Private Function Objectanalysis_readonly( _
   ByRef ctl As Object _
) As String

Parameter

ctl

Quellcode

[Visual Basic]
        Private Function Objectanalysis_readonly(ByRef ctl As Object) As String
            Dim typ As System.Type = ctl.GetType
            Select Case LCase(typ.Name)
                Case "splitcontainer"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmpsplit As SplitContainer = ctl
                    For Each ctrl As Object In tmpsplit.Panel1.Controls
                        Objectanalysis_readonly(ctrl)
                    Next
                    For Each ctrl As Object In tmpsplit.Panel2.Controls
                        Objectanalysis_readonly(ctrl)
                    Next
                Case "tabcontrol", "clsmytabcontrol"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabcontrol As TabControl = ctl
                    For Each ctl In tmptabcontrol.TabPages
                        Objectanalysis_readonly(ctl)
                    Next
                Case "tabpage"
                    Dim tmptabpage As TabPage = ctl
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, tmptabpage.Parent.Name, 1))

                    For Each ctl In tmptabpage.Controls
                        Objectanalysis_readonly(ctl)
                    Next
                Case "groupbox"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmptabpage As GroupBox = ctl
                    For Each ctl In tmptabpage.Controls
                        Objectanalysis_readonly(ctl)
                    Next
                Case "panel"
                    ctlcol.Add(New MyFormControls(ctl, formname, typ.Name, ctl.Name, ""))
                    Dim tmppanel As Panel = ctl
                    For Each ctl In tmppanel.Controls
                        Objectanalysis_readonly(ctl)
                    Next
                Case "textbox"
                    Dim x As TextBox = ctl
                    x.BackColor = Color.LightGray
                    x.ForeColor = Color.Black
                    x.ReadOnly = True
                Case "maskedtextbox"
                    Dim x As MaskedTextBox = ctl
                    x.BackColor = Color.LightGray
                    x.ForeColor = Color.Black
                    x.ReadOnly = True
                Case "combobox"
                    Dim x As ComboBox = ctl
                    x.Enabled = False
                    x.BackColor = Color.LightGray
                    x.ForeColor = Color.Black
                Case "checkbox"
                    Dim x As CheckBox = ctl
                    x.Enabled = False
                Case "radiobutton"
                    Dim x As RadioButton = ctl
                    x.Enabled = False
                Case "comboboxtree"
                    Dim x As Object = ctl
                    x.enabled = False
                    x.BackColor = Color.LightGray
                    x.ForeColor = Color.Black
                Case "richtextbox"
                    Dim x As Object = ctl
                    x.BackColor = Color.LightGray
                    x.ForeColor = Color.Black
                    x.ReadOnly = True
                Case "button"
                    Dim x As Button = ctl
                    x.Enabled = False
                Case "listbox"
                    Dim x As Object = ctl
                    ctl.enabled = False
                Case "checkedlistbox"
                    Dim x As Object = ctl
                    ctl.enabled = False
                Case Else
            End Select
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Objexists -Methode

Prüft, ob das Security-Objekt bereits auf der DB vorhanden ist

[Visual Basic]
Private Function Objexists( _
   ByVal securityform As String, _
   ByVal securityobjecttype As String, _
   ByVal securityobject As String, _
   ByVal securityobjectitem As String _
) As Boolean

Parameter

securityform
Formular
securityobjecttype
Objekttyp
securityobject
Objektname
securityobjectitem
Objektitem

Quellcode

[Visual Basic]
        Private Function Objexists(ByVal securityform As String, ByVal securityobjecttype As String, ByVal securityobject As String, ByVal securityobjectitem As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[my_security_check_entry]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@form", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityform))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objecttype", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobjecttype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@object", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobject))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objectitem", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, securityobjectitem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@objexists", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                If scmCmdToExecute.Parameters("@objexists").Value > 0 Then
                    Return True
                Else
                    Return False
                End If
            Catch ex As Exception
            Finally
                scmCmdToExecute.Connection.Close()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Print_Screen -Methode

[Visual Basic]
Public Function Print_Screen( _
   ByRef ctl As Control _
) As Object

Parameter

ctl

Quellcode

[Visual Basic]
        Public Function Print_Screen(ByRef ctl As Control)
            saveasbitmap(ctl, ctl.Name)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.ReadContextMenu -Methode

Auslesen von ContextMenuItems

[Visual Basic]
Private Function ReadContextMenu( _
   ByRef x As Object _
) As Object

Parameter

x

Quellcode

[Visual Basic]
        Private Function ReadContextMenu(ByRef x As Object)
            Dim tmpmnu As ContextMenuStrip = x
            level = 0
            Try
                For Each xx As Object In tmpmnu.Items
                    Dim objtype As System.Type = xx.GetType
                    If LCase(objtype.Name) = "toolstripmenuitem" Then
                        ctlcol.Add(New MyFormControls(xx, formname, "menustrip", tmpmenuname, xx.Name, level))
                        get_all_menus(xx)
                    End If
                    '                    ctlcol.Add(New MyFormControls(xx, formname, "contextmenustrip", tmpmenuname, xx.Name, level))
                    '                   get_all_menus(xx)
                Next
            Catch ex As Exception
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.ReadMenu -Methode

[Visual Basic]
Private Function ReadMenu( _
   ByRef x As Object _
) As Object

Parameter

x

Quellcode

[Visual Basic]
        Private Function ReadMenu(ByRef x As Object)
            Dim tmpmnu As MenuStrip = x
            level = 0
            For Each xx As Object In tmpmnu.Items
                Dim objtype As System.Type = xx.GetType
                If LCase(objtype.Name) = "toolstripmenuitem" Then
                    ctlcol.Add(New MyFormControls(xx, formname, "menustrip", tmpmenuname, xx.Name, level))
                    get_all_menus(xx)
                End If
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Set_Form_Readonly -Methode

[Visual Basic]
Public Function Set_Form_Readonly( _
   ByRef f As Form _
) As Object

Parameter

f

Quellcode

[Visual Basic]
        Public Function Set_Form_Readonly(ByRef f As Form)
            IntForm = f
            Me.formname = f.Name
            Load_Data(f.Name)
            Me.ctlcol.Clear()
            For Each ctl As Control In f.Controls
                Objectanalysis_readonly(ctl)
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Set_Form_Security -Methode

Formularsecurity setzen

[Visual Basic]
Public Function Set_Form_Security( _
   ByRef f As Form _
) As Object

Parameter

f
Aktuelles Formular

Quellcode

[Visual Basic]
        Public Function Set_Form_Security(ByRef f As Form)
            IntForm = f
            formname = f.Name
            'Load form DB
            Load_Data(f.Name)
            'Load FormObjects
            Me.ctlcol.Clear()
            formname = f.Name
            For Each ctl As Control In f.Controls
                Objectanalysis(ctl)
                '               AddHandler ctl.HelpRequested, AddressOf Object_MouseDown
                'ctl.ContextMenuStrip = Globals.TTContextMenuStrip
                'AddHandler ctl.KeyDown, AddressOf Object_MouseDown
            Next
            Set_Security()
            If Globals.Set_ToolTips = True Then
                tt.Edit_Tooltips(f, ctlcol)
            Else
                tt.Set_ToolTips(f)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Set_Preferences -Methode

Security-Einstellungen setzen

[Visual Basic]
Private Sub Set_Preferences( _
   ByRef obj As Object, _
   ByVal read_only As Boolean, _
   ByVal invisible As Boolean, _
   ByVal SecurityObjectItem As String _
)

Parameter

obj
Betroffenes Objeckt (Menuitem, Conrol usw.)
read_only
Readonly ja/nein
invisible
Sichtbar ja/nein
SecurityObjectItem
Name des Unterobjektes - wird für die Spalteneinstellungen von C1TruedbGrids verwendet

Quellcode

[Visual Basic]
        Private Sub Set_Preferences(ByRef obj As Object, ByVal read_only As Boolean, ByVal invisible As Boolean, ByVal SecurityObjectItem As String)
            Dim objtype As System.Type = obj.GetType
            Select Case LCase(objtype.Name)
                Case "toolstripmenuitem"
                    Dim ctl As ToolStripMenuItem = obj
                    If read_only Then ctl.Enabled = False
                    If invisible Then
                        ctl.Visible = False
                        ctl.Enabled = False
                    End If
                Case "textbox", "label", "combobox", "checkbox", "toolstripbutton", "panel"
                    If read_only Then obj.Enabled = False
                    If invisible Then obj.Visible = False
                Case "tabpage"
                    If invisible Then
                        Dim tbp As TabPage = obj
                        For Each x As MyFormControls In Me.ctlcol
                            If x.MySecurityObject = tbp.Parent.Name Then
                                Dim tb As TabControl = x.MyControl
                                tb.TabPages.Remove(tbp)
                                Exit Sub
                            End If
                        Next
                    End If
                    If read_only Then obj.enabled = False

                Case "c1truedbgrid"
                    Dim ctl As C1TrueDBGrid = obj
                    If SecurityObjectItem = "" Then
                        If read_only Then ctl.Enabled = False
                        If invisible Then obj.Visible = False
                    Else
                        If read_only Then ctl.Splits(0).DisplayColumns(SecurityObjectItem).Locked = True
                        If invisible Then ctl.Splits(0).DisplayColumns(SecurityObjectItem).Visible = False
                    End If

            End Select
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.Set_Security -Methode

Prüft die DB-Einträge mit den Formcontrols und bei Übereinstimmung werden die Security-Einstellungen gesetzt

[Visual Basic]
Private Sub Set_Security()

Quellcode

[Visual Basic]
        Private Sub Set_Security()
            Dim i As Integer
            For i = 0 To Me.SecurityData.Tables(0).Rows.Count - 1
                Dim SecurityObject As String = Me.SecurityData.Tables(0).Rows(i).Item("SecurityObject")
                Dim SecurityObjectitem As String = Me.SecurityData.Tables(0).Rows(i).Item("SecurityObjectItem")
                Dim read_only As Boolean = Me.SecurityData.Tables(0).Rows(i).Item("readonly")
                Dim invisible As Boolean = Me.SecurityData.Tables(0).Rows(i).Item("invisible")
                Dim ii As Integer
                For ii = 1 To ctlcol.Count
                    Dim secobj As MyFormControls = ctlcol(ii)
                    If secobj.MySecurityObject = SecurityObject And secobj.MySecurityObjectItem = SecurityObjectitem Then
                        Set_Preferences(secobj.MyControl, read_only, invisible, SecurityObjectitem)
                    End If
                Next
            Next
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.get_all_menus -Methode

Auslesen von Menu-Subitems

[Visual Basic]
Private Function get_all_menus( _
   ByRef xx As ToolStripMenuItem _
) As Object

Parameter

xx

Quellcode

[Visual Basic]
        Private Function get_all_menus(ByRef xx As ToolStripMenuItem)
            level = level + 1
            For Each subobj As Object In xx.DropDownItems
                If LCase(subobj.GetType.Name) = "toolstripmenuitem" Then
                    ctlcol.Add(New MyFormControls(subobj, formname, "menustrip", tmpmenuname, subobj.Name, level))
                    get_all_menus(subobj)
                End If
            Next
            level = level - 1
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity.saveasbitmap -Methode

[Visual Basic]
Public Function saveasbitmap( _
   ByRef ctl As Control, _
   ByVal filename As String _
) As Object

Parameter

ctl
filename

Quellcode

[Visual Basic]
        Public Function saveasbitmap(ByRef ctl As Control, ByVal filename As String)
            Dim g As Graphics = ctl.CreateGraphics
            Dim b As New Bitmap(ctl.Width, ctl.Height)
            ctl.DrawToBitmap(b, New Rectangle(0, 0, ctl.Width, ctl.Height))
            b.Save("E:\Software-Projekte\Vertragsverwaltung\Screens\" & filename & ".jpg", System.Drawing.Imaging.ImageFormat.Jpeg)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySecurity-Felder

MySecurity Übersicht

Felder

private field IntForm Unterstützt von .NET Compact Framework |
private field SecurityData Unterstützt von .NET Compact Framework |
private field connection Unterstützt von .NET Compact Framework |
private field ctlcol Unterstützt von .NET Compact Framework |
private field da Unterstützt von .NET Compact Framework |
private field formname Unterstützt von .NET Compact Framework |
private field level Unterstützt von .NET Compact Framework | Auslesen von MenuItems
private field tmpmenuname Unterstützt von .NET Compact Framework |
private field tt Unterstützt von .NET Compact Framework |

MySecurity -Klasse


IntForm -Feld

[Visual Basic]
Private IntForm As Form

Quellcode

[Visual Basic]
        Dim IntForm As Form

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


SecurityData -Feld

[Visual Basic]
Private SecurityData As DataSet

Quellcode

[Visual Basic]
        Dim SecurityData As DataSet = Globals.SecurityDaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


connection -Feld

[Visual Basic]
Private connection As SqlConnection

Quellcode

[Visual Basic]
        Dim connection As New SqlConnection()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


ctlcol -Feld

[Visual Basic]
Private ctlcol As Collection

Quellcode

[Visual Basic]
        Dim ctlcol As New Collection

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


da -Feld

[Visual Basic]
Private da As SqlDataAdapter

Quellcode

[Visual Basic]
        Dim da As New SqlDataAdapter("", connection)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


formname -Feld

[Visual Basic]
Private formname As String

Quellcode

[Visual Basic]
        Dim formname As String = ""

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


level -Feld

Auslesen von MenuItems

[Visual Basic]
Private level As Integer

Quellcode

[Visual Basic]
        Dim level As Integer = 0

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


tmpmenuname -Feld

[Visual Basic]
Private tmpmenuname As String

Quellcode

[Visual Basic]
        Dim tmpmenuname As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


tt -Feld

[Visual Basic]
Private tt As clsToolTips

Quellcode

[Visual Basic]
        Dim tt As New TKB.VV.Utils.clsToolTips

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySecurity


MySpaltenTitel -Klasse

For a list of all members of this type, see MySpaltenTitel-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.MySpaltenTitel

[Visual Basic]
Public Class MySpaltenTitel

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

MySpaltenTitel-Member


MySpaltenTitel-Member

MySpaltenTitel Übersicht

Öffentliche Konstruktoren

public constructor MySpaltenTitel -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method dispose

Unterstützt von .NET Compact Framework
public method getspalte

Unterstützt von .NET Compact Framework
public method load_data

Unterstützt von .NET Compact Framework

Felder

private field spaltendata

Unterstützt von .NET Compact Framework

MySpaltenTitel -Klasse


MySpaltenTitel -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            load_data()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySpaltenTitel


MySpaltenTitel-Methoden

MySpaltenTitel Übersicht

Öffentliche Methoden

public method dispose

Unterstützt von .NET Compact Framework
public method getspalte

Unterstützt von .NET Compact Framework
public method load_data

Unterstützt von .NET Compact Framework

MySpaltenTitel -Klasse


MySpaltenTitel.dispose -Methode

[Visual Basic]
Public Sub dispose()

Quellcode

[Visual Basic]
        Sub dispose()
            spaltendata.Dispose()
            Me.dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySpaltenTitel


MySpaltenTitel.getspalte -Methode

[Visual Basic]
Public Function getspalte( _
   ByVal tabelle As String, _
   ByVal feld As String, _
   ByRef spaltenname As String, _
   ByRef locked As Boolean, _
   ByRef colwidth As Integer, _
   ByRef order As Integer, _
   ByRef alshacken As Boolean, _
   ByRef tiptext As String, _
   ByRef numberformat As String _
) As Object

Parameter

tabelle
feld
spaltenname
locked
colwidth
order
alshacken
tiptext
numberformat

Quellcode

[Visual Basic]
        Public Function getspalte(ByVal tabelle As String, ByVal feld As String, ByRef spaltenname As String, ByRef locked As Boolean, _
        ByRef colwidth As Integer, ByRef order As Integer, ByRef alshacken As Boolean, ByRef tiptext As String, ByRef numberformat As String)
            If spaltendata.Rows.Count = 0 Then load_data()
            Dim dv() As DataRow
            Dim dr As DataRow
            dv = spaltendata.Select("Tabelle='" & tabelle & "' and tabellenspalte='" & feld & "'", "Reihenfolge, Eintragnr")
            If dv.Length = 0 Then
                spaltenname = ""
                locked = True
                colwidth = 0
                order = 0
                alshacken = False
                tiptext = ""
                numberformat = ""
            End If
            For Each dr In dv
                spaltenname = dr.Item(3)
                locked = dr.Item(4)
                colwidth = dr.Item(6)
                order = dr.Item(7)
                alshacken = dr.Item(5)
                tiptext = dr.Item(8)
                numberformat = dr.Item(14).ToString
            Next
            'Dim i As Integer
            'For i = 0 To spaltendata.Rows.Count - 1

            '    If UCase(spaltendata.Rows(i).Item(1)) = UCase(tabelle) And UCase(spaltendata.Rows(i).Item(2)) = UCase(feld) Then
            '        spaltenname = spaltendata.Rows(i).Item(3)
            '        locked = spaltendata.Rows(i).Item(4)
            '        colwidth = spaltendata.Rows(i).Item(6)
            '        order = spaltendata.Rows(i).Item(7)
            '        alshacken = spaltendata.Rows(i).Item(5)
            '        tiptext = spaltendata.Rows(i).Item(8)
            '        Exit Function
            '    End If
            'Next

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySpaltenTitel


MySpaltenTitel.load_data -Methode

[Visual Basic]
Public Sub load_data()

Quellcode

[Visual Basic]
        Public Sub load_data()
            If Me.spaltendata.Rows.Count > 0 Then Exit Sub
            Dim spalten As New TKB.VV.Utils.clsSpalten()
            spaltendata.Rows.Clear()
            spalten.cpMainConnectionProvider = conn
            spaltendata = spalten.Select_All_Aktiv
            Globals.Spaltendaten = spaltendata
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySpaltenTitel


MySpaltenTitel-Felder

MySpaltenTitel Übersicht

Felder

private field spaltendata

Unterstützt von .NET Compact Framework

MySpaltenTitel -Klasse


spaltendata -Feld

[Visual Basic]
Private spaltendata As DataTable

Quellcode

[Visual Basic]
        Private spaltendata As DataTable = Globals.Spaltendaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

MySpaltenTitel


Tabellenspalte -Klasse

For a list of all members of this type, see Tabellenspalte-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.Tabellenspalte

[Visual Basic]
Public Class Tabellenspalte

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Tabellenspalte-Member


Tabellenspalte-Member

Tabellenspalte Übersicht

Öffentliche Konstruktoren

public constructor Tabellenspalte -Konstructor Überladen.

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property AlsHacken

Unterstützt von .NET Compact Framework
public property ColWith

Unterstützt von .NET Compact Framework
public property Feld

Unterstützt von .NET Compact Framework
public property Numberformat

Unterstützt von .NET Compact Framework
public property Order

Unterstützt von .NET Compact Framework
public property Tabelle

Unterstützt von .NET Compact Framework
public property TipText

Unterstützt von .NET Compact Framework
public property locked

Unterstützt von .NET Compact Framework
public property spaltenname

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method ColumnOrder Unterstützt von .NET Compact Framework | Sortierung der in der DB-Tabelle Spalaten festgelegten Reihenfolge
public method Spaltentitel_aktualisieren Überladen. Unterstützt von .NET Compact Framework |
public method Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer Unterstützt von .NET Compact Framework |
public method getspalte Unterstützt von .NET Compact Framework |

Felder

private field m_Order

Unterstützt von .NET Compact Framework
private field m_Width

Unterstützt von .NET Compact Framework
private field m_alsHacken

Unterstützt von .NET Compact Framework
private field m_field

Unterstützt von .NET Compact Framework
private field m_locked

Unterstützt von .NET Compact Framework
private field m_numberformat

Unterstützt von .NET Compact Framework
private field m_spaltenname

Unterstützt von .NET Compact Framework
private field m_table

Unterstützt von .NET Compact Framework
private field m_tiptext

Unterstützt von .NET Compact Framework

Tabellenspalte -Klasse


New

Überladungsliste

[Visual Basic] Public Sub New()
[C#] public System.Void Tabellenspalte();

[Visual Basic] Public Sub New(ByRef Object, ByRef String, ByRef DataSet)
[C#] public System.Void Tabellenspalte(ref object, ref string, ref DataSet);

Tabellenspalte | Vertragsverwaltung.TKB.VV.Utils


Tabellenspalte-Eigenschaften

Tabellenspalte Übersicht

Öffentliche Eigenschaften

public property AlsHacken

Unterstützt von .NET Compact Framework
public property ColWith

Unterstützt von .NET Compact Framework
public property Feld

Unterstützt von .NET Compact Framework
public property Numberformat

Unterstützt von .NET Compact Framework
public property Order

Unterstützt von .NET Compact Framework
public property Tabelle

Unterstützt von .NET Compact Framework
public property TipText

Unterstützt von .NET Compact Framework
public property locked

Unterstützt von .NET Compact Framework
public property spaltenname

Unterstützt von .NET Compact Framework

Tabellenspalte -Klasse


Tabellenspalte.AlsHacken -Eigenschaft

[Visual Basic]
Public Property AlsHacken() As Boolean

Quellcode

[Visual Basic]
        Property AlsHacken() As Boolean
            Get
                Return m_alsHacken
            End Get
            Set(ByVal Value As Boolean)
                m_alsHacken = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.ColWith -Eigenschaft

[Visual Basic]
Public Property ColWith() As Integer

Quellcode

[Visual Basic]
        Property ColWith() As Integer
            Get
                Return m_Width
            End Get
            Set(ByVal Value As Integer)
                m_Width = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Feld -Eigenschaft

[Visual Basic]
Public Property Feld() As String

Quellcode

[Visual Basic]
        Property Feld() As String
            Get
                Return m_field
            End Get
            Set(ByVal Value As String)
                m_field = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Numberformat -Eigenschaft

[Visual Basic]
Public Property Numberformat() As String

Quellcode

[Visual Basic]
        Property Numberformat() As String
            Get
                Return m_numberformat
            End Get
            Set(ByVal value As String)
                m_numberformat = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Order -Eigenschaft

[Visual Basic]
Public Property Order() As Integer

Quellcode

[Visual Basic]
        Property Order() As Integer
            Get
                Return m_Order
            End Get
            Set(ByVal Value As Integer)
                m_Order = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Tabelle -Eigenschaft

[Visual Basic]
Public Property Tabelle() As String

Quellcode

[Visual Basic]
        Property Tabelle() As String
            Get
                Return m_table
            End Get
            Set(ByVal Value As String)
                m_table = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.TipText -Eigenschaft

[Visual Basic]
Public Property TipText() As String

Quellcode

[Visual Basic]
        Property TipText() As String
            Get
                Return m_tiptext
            End Get
            Set(ByVal Value As String)
                m_tiptext = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.locked -Eigenschaft

[Visual Basic]
Public Property locked() As Boolean

Quellcode

[Visual Basic]
        Property locked() As Boolean
            Get
                Return m_locked
            End Get
            Set(ByVal Value As Boolean)
                m_locked = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.spaltenname -Eigenschaft

[Visual Basic]
Public Property spaltenname() As String

Quellcode

[Visual Basic]
        Property spaltenname() As String
            Get
                Return m_spaltenname
            End Get
            Set(ByVal Value As String)
                m_spaltenname = Value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte-Methoden

Tabellenspalte Übersicht

Öffentliche Methoden

public method ColumnOrder Unterstützt von .NET Compact Framework | Sortierung der in der DB-Tabelle Spalaten festgelegten Reihenfolge
public method Spaltentitel_aktualisieren Überladen. Unterstützt von .NET Compact Framework |
public method Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer Unterstützt von .NET Compact Framework |
public method getspalte Unterstützt von .NET Compact Framework |

Tabellenspalte -Klasse


Tabellenspalte.ColumnOrder -Methode

Sortierung der in der DB-Tabelle Spalaten festgelegten Reihenfolge

[Visual Basic]
Public Function ColumnOrder( _
   ByVal Tablename As String, _
   ByRef Data As C1TrueDBGrid _
) As Object

Parameter

Tablename
Data

Quellcode

[Visual Basic]
        Public Function ColumnOrder(ByVal Tablename As String, ByRef Data As C1TrueDBGrid)
            Dim spaltendata As DataTable = Globals.Spaltendaten
            Dim dv() As DataRow
            Dim dr As DataRow
            Dim dc As New Collection
            dv = spaltendata.Select("Tabelle='" & Tablename & "'", "Reihenfolge desc, Eintragnr")
            For Each c As C1DisplayColumn In Data.Splits(0).DisplayColumns
                dc.Add(c)
            Next
            While Data.Splits(0).DisplayColumns.Count > 0
                Data.Splits(0).DisplayColumns.RemoveAt(0)
            End While

            For Each dr In dv
                For Each e As C1DisplayColumn In dc
                    If e.Name = dr.Item(3) Then
                        Data.Splits(0).DisplayColumns.Insert(0, e)
                    End If
                Next
            Next

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Spaltentitel_aktualisieren -Methode

Überladungsliste

[Visual Basic] Public Function Spaltentitel_aktualisieren(ByRef Object, ByRef String, ByRef DataSet) As Object
[C#] public object Spaltentitel_aktualisieren(ref object, ref string, ref DataSet);

[Visual Basic] Public Function Spaltentitel_aktualisieren(ByRef Object, ByRef String, ByRef DataTable, Optional Boolean) As Object
[C#] public object Spaltentitel_aktualisieren(ref object, ref string, ref DataTable, bool);

Tabellenspalte | Vertragsverwaltung.TKB.VV.Utils


Tabellenspalte.Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer -Methode

[Visual Basic]
Public Function Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef dt As DataTable, _
   Optional ByVal Aktiv_Filter As String = "" _
) As Object

Parameter

daten
Erforderlich.
tablename
Erforderlich.
dt
Erforderlich.
Aktiv_Filter
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Public Function Spaltentitel_aktualisieren_Optionaler_Aktiv_Filer(ByRef daten As Object, ByRef tablename As String, ByRef dt As DataTable, Optional ByVal Aktiv_Filter As String = "")
            Dim anzcols As Integer
            Dim i As Integer
            Dim t As New DataTable()
            Dim s As String
            anzcols = daten.Splits(0).DisplayColumns.Count
            t = dt
            Me.Tabelle = tablename
            For i = 0 To daten.Columns.Count - 1
                s = daten.Columns(i).DataField

                Me.Feld = s
                Me.getspalte()
                If Me.spaltenname = "" Then
                    daten.Splits(0).DisplayColumns(i).Width = 0
                Else
                    daten.Columns(i).Caption = Me.spaltenname

                    If Me.ColWith = 0 Then
                        daten.Splits(0).DisplayColumns(i).Width = 0
                        daten.Splits(0).DisplayColumns(i).Visible = False
                    Else
                        daten.Splits(0).DisplayColumns(i).Width = Me.ColWith
                    End If

                    If Me.locked Then
                        daten.Splits(0).DisplayColumns(i).Locked = True
                    End If

                    If Me.AlsHacken Then
                        daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If

                    'Präsentation von aktiv
                    If LCase(daten.Columns(i).DataField) = "aktiv" And Aktiv_Filter <> "" Then
                        daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        daten.Columns(i).ValueItems.DefaultItem = True
                        daten.Columns(i).DefaultValue = True
                        daten.Columns(i).FilterText = Aktiv_Filter
                    End If
                    Select Case LCase(daten.Columns(i).DataField)
                        Case "erstellt_am", "erstelltam"
                            daten.Columns(i).DefaultValue = Now
                    End Select
                    If daten.Columns(i).DataType.Name = "DateTime" Then
                        daten.Columns(i).NumberFormat = "dd.MM.yyyy HH:mm:ss"
                    End If
                    If Me.Numberformat <> "" Then
                        daten.columns(i).numberformat = Me.Numberformat
                    End If
                End If
            Next
            ColumnOrder(tablename, daten)
            daten.HeadingStyle.WrapText = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.getspalte -Methode

[Visual Basic]
Public Function getspalte() As Object

Quellcode

[Visual Basic]
        Public Function getspalte()
            Try
                Dim myspalten As New MySpaltenTitel()
                myspalten.getspalte(Me.Tabelle, Me.Feld, Me.spaltenname, Me.locked, Me.ColWith, Me.Order, Me.AlsHacken, Me.TipText, Me.Numberformat)
            Catch ex As Exception
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte-Felder

Tabellenspalte Übersicht

Felder

private field m_Order

Unterstützt von .NET Compact Framework
private field m_Width

Unterstützt von .NET Compact Framework
private field m_alsHacken

Unterstützt von .NET Compact Framework
private field m_field

Unterstützt von .NET Compact Framework
private field m_locked

Unterstützt von .NET Compact Framework
private field m_numberformat

Unterstützt von .NET Compact Framework
private field m_spaltenname

Unterstützt von .NET Compact Framework
private field m_table

Unterstützt von .NET Compact Framework
private field m_tiptext

Unterstützt von .NET Compact Framework

Tabellenspalte -Klasse


m_Order -Feld

[Visual Basic]
Private m_Order As Integer

Quellcode

[Visual Basic]
        Private m_Order As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_Width -Feld

[Visual Basic]
Private m_Width As Integer

Quellcode

[Visual Basic]
        Private m_Width As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_alsHacken -Feld

[Visual Basic]
Private m_alsHacken As Boolean

Quellcode

[Visual Basic]
        Private m_alsHacken As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_field -Feld

[Visual Basic]
Private m_field As String

Quellcode

[Visual Basic]
        Private m_field As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_locked -Feld

[Visual Basic]
Private m_locked As Boolean

Quellcode

[Visual Basic]
        Private m_locked As Boolean

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_numberformat -Feld

[Visual Basic]
Private m_numberformat As String

Quellcode

[Visual Basic]
        Private m_numberformat As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_spaltenname -Feld

[Visual Basic]
Private m_spaltenname As String

Quellcode

[Visual Basic]
        Private m_spaltenname As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_table -Feld

[Visual Basic]
Private m_table As String

Quellcode

[Visual Basic]
        Private m_table As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


m_tiptext -Feld

[Visual Basic]
Private m_tiptext As String

Quellcode

[Visual Basic]
        Private m_tiptext As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


clsMyTabControl -Klasse

For a list of all members of this type, see clsMyTabControl-Member.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TabControl
Vertragsverwaltung.TKB.VV.Utils.clsMyTabControl

[Visual Basic]
Public Class clsMyTabControl
    Inherits TabControl

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsMyTabControl-Member


clsMyTabControl-Member

clsMyTabControl Übersicht

Öffentliche Konstruktoren

public constructor clsMyTabControl -Konstructor

Unterstützt von .NET Compact Framework

Geschützte Methoden

protected method OnMouseDown

Unterstützt von .NET Compact Framework
protected method OnMouseMove

Unterstützt von .NET Compact Framework
protected method OnMouseUp

Unterstützt von .NET Compact Framework

Andere Methoden

private method GetTabPageFromXY

Unterstützt von .NET Compact Framework

Felder

private field _SourceTabPage

Unterstützt von .NET Compact Framework

clsMyTabControl -Klasse


clsMyTabControl -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()
            MyBase.New()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsMyTabControl-Methoden

clsMyTabControl Übersicht

Geschützte Methoden

protected method OnMouseDown

Unterstützt von .NET Compact Framework
protected method OnMouseMove

Unterstützt von .NET Compact Framework
protected method OnMouseUp

Unterstützt von .NET Compact Framework

Andere Methoden

private method GetTabPageFromXY

Unterstützt von .NET Compact Framework

clsMyTabControl -Klasse


clsMyTabControl.GetTabPageFromXY -Methode

[Visual Basic]
Private Function GetTabPageFromXY( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TabPage

Parameter

x
y

Quellcode

[Visual Basic]
        Private Function GetTabPageFromXY(ByVal x As Integer, ByVal y As Integer) As TabPage
            For i As Integer = 0 To MyBase.TabPages.Count - 1
                If MyBase.GetTabRect(i).Contains(x, y) Then
                    Return MyBase.TabPages(i)
                End If
            Next
            Return Nothing
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsMyTabControl.OnMouseDown -Methode

[Visual Basic]
Protected Overrides Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnMouseDown(ByVal e As MouseEventArgs)
            If (e.Button = Windows.Forms.MouseButtons.Left) AndAlso (MyBase.SelectedTab IsNot Nothing) AndAlso (Not MyBase.GetTabRect(MyBase.SelectedIndex).IsEmpty) Then
                Me._SourceTabPage = MyBase.SelectedTab
            End If
            MyBase.OnMouseDown(e)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsMyTabControl.OnMouseMove -Methode

[Visual Basic]
Protected Overrides Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnMouseMove(ByVal e As MouseEventArgs)
            If (e.Button = Windows.Forms.MouseButtons.Left) AndAlso (Me._SourceTabPage IsNot Nothing) Then
                Dim currTabPage As System.Windows.Forms.TabPage = GetTabPageFromXY(e.X, e.Y)
                If (currTabPage IsNot Nothing) Then
                    Dim currRect As Drawing.Rectangle = MyBase.GetTabRect(MyBase.TabPages.IndexOf(currTabPage))
                    If (MyBase.TabPages.IndexOf(currTabPage) < MyBase.TabPages.IndexOf(Me._SourceTabPage)) Then
                        MyBase.Cursor = Cursors.PanWest
                    ElseIf (MyBase.TabPages.IndexOf(currTabPage) > MyBase.TabPages.IndexOf(Me._SourceTabPage)) Then
                        MyBase.Cursor = Cursors.PanEast
                    Else 'tab is same as current
                        MyBase.Cursor = Cursors.Default
                    End If
                Else 'no tab selected
                    Me.Cursor = Cursors.No
                End If
            Else
                Me.Cursor = Cursors.Default
            End If
            MyBase.OnMouseMove(e)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsMyTabControl.OnMouseUp -Methode

[Visual Basic]
Protected Overrides Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)

Parameter

e

Quellcode

[Visual Basic]
        Protected Overrides Sub OnMouseUp(ByVal e As MouseEventArgs)
            If (e.Button = Windows.Forms.MouseButtons.Left) AndAlso (Me._SourceTabPage IsNot Nothing) Then
                Dim currTabPage As System.Windows.Forms.TabPage = GetTabPageFromXY(e.X, e.Y)
                If (currTabPage IsNot Nothing) AndAlso (Not currTabPage.Equals(Me._SourceTabPage)) Then
                    Dim currRect As Drawing.Rectangle = MyBase.GetTabRect(MyBase.TabPages.IndexOf(currTabPage))
                    If (MyBase.TabPages.IndexOf(currTabPage) < MyBase.TabPages.IndexOf(Me._SourceTabPage)) Then
                        MyBase.TabPages.Remove(Me._SourceTabPage)
                        MyBase.TabPages.Insert(MyBase.TabPages.IndexOf(currTabPage), Me._SourceTabPage)
                        MyBase.SelectedTab = Me._SourceTabPage
                    ElseIf (MyBase.TabPages.IndexOf(currTabPage) > MyBase.TabPages.IndexOf(Me._SourceTabPage)) Then
                        MyBase.TabPages.Remove(Me._SourceTabPage)
                        MyBase.TabPages.Insert(MyBase.TabPages.IndexOf(currTabPage) + 1, Me._SourceTabPage)
                        MyBase.SelectedTab = Me._SourceTabPage
                    End If
                End If
            End If
            Me._SourceTabPage = Nothing
            MyBase.Cursor = Cursors.Default
            MyBase.OnMouseUp(e)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsMyTabControl-Felder

clsMyTabControl Übersicht

Felder

private field _SourceTabPage

Unterstützt von .NET Compact Framework

clsMyTabControl -Klasse


_SourceTabPage -Feld

[Visual Basic]
Private _SourceTabPage As TabPage

Quellcode

[Visual Basic]
        Private _SourceTabPage As System.Windows.Forms.TabPage = Nothing

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsMyTabControl


clsProfile -Klasse

Klasse, um die Profile eines Mitarbeiters zu handeln

For a list of all members of this type, see clsProfile-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsProfil
Vertragsverwaltung.TKB.VV.Utils.clsProfile

[Visual Basic]
Public Class clsProfile
    Inherits clsProfil

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsProfile-Member


clsProfile-Member

clsProfile Übersicht

Öffentliche Konstruktoren

public constructor clsProfile -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bSelektionsart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bStandard (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bV_Aktiv_Vertragspartner (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bV_Struktur_Details (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property blobV_Uebersicht (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iProfilnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sV_Aktiv_Vertragselemente (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sV_Register (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sV_Sort (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Profil Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Profil Unterstützt von .NET Compact Framework |
public method Get_Profil_By_Mitarbeiter Unterstützt von .NET Compact Framework | Profile des aktuellen Mitarbeiters auselesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Profil sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Set_Aktuelles_Profil Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Profildata

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsProfile -Klasse


clsProfile-Eigenschaften

clsProfile Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bSelektionsart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bStandard (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bV_Aktiv_Vertragspartner (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property bV_Struktur_Details (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property blobV_Uebersicht (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMitarbeiternr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iProfilnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sV_Aktiv_Vertragselemente (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sV_Register (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework
public property sV_Sort (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil)

Unterstützt von .NET Compact Framework

clsProfile -Klasse


clsProfile-Methoden

clsProfile Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Profil Unterstützt von .NET Compact Framework |
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Profil Unterstützt von .NET Compact Framework |
public method Get_Profil_By_Mitarbeiter Unterstützt von .NET Compact Framework | Profile des aktuellen Mitarbeiters auselesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Profil sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Set_Aktuelles_Profil Unterstützt von .NET Compact Framework |
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsProfil) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsProfile -Klasse


clsProfile.Add_New -Methode

Neue Person einfügen

[Visual Basic]
Public Function Add_New( _
   Optional ByVal Bezeichnung As String = "" _
) As Integer

Parameter

Bezeichnung
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Public Function Add_New(Optional ByVal Bezeichnung As String = "") As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Profil")
            db.Dispose()
            Me.iProfilnr = New SqlInt32(CType(newkey, Int32))
            Me.sBezeichnung = New SqlString(CType(Bezeichnung, String))
            Me.iMitarbeiternr = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.sV_Aktiv_Vertragselemente = New SqlString(CType("", String))
            Me.bV_Aktiv_Vertragspartner = New SqlBoolean(CType(False, Boolean))
            Me.sV_Sort = New SqlString(CType("", String))
            Me.sV_Register = New SqlString(CType("", String))
            Me.bStandard = New SqlBoolean(CType(False, Boolean))
            Me.bSelektionsart = New SqlBoolean(CType(True, Boolean))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile.Delete_Profil -Methode

[Visual Basic]
Public Function Delete_Profil( _
   ByVal Profilnr As Integer _
) As Boolean

Parameter

Profilnr

Quellcode

[Visual Basic]
        Public Function Delete_Profil(ByVal Profilnr As Integer) As Boolean
            Try
                Me.cpMainConnectionProvider = Globals.conn
                Globals.conn.OpenConnection()
                Me.Delete()
                Globals.conn.CloseConnection(True)
                Return True
            Catch
                Return False
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile.Get_Profil -Methode

[Visual Basic]
Public Function Get_Profil( _
   ByVal nr As Integer _
) As Object

Parameter

nr

Quellcode

[Visual Basic]
        Public Function Get_Profil(ByVal nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iProfilnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile.Get_Profil_By_Mitarbeiter -Methode

Profile des aktuellen Mitarbeiters auselesen

[Visual Basic]
Public Function Get_Profil_By_Mitarbeiter() As DataTable

Quellcode

[Visual Basic]
        Public Function Get_Profil_By_Mitarbeiter() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_ma_profile"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Me.Profildata = dtToReturn
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsProfile::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile.Save_Data -Methode

Profil sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iProfilnr
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile.Set_Aktuelles_Profil -Methode

[Visual Basic]
Public Function Set_Aktuelles_Profil( _
   ByVal Profilname As String _
) As Object

Parameter

Profilname

Quellcode

[Visual Basic]
        Public Function Set_Aktuelles_Profil(ByVal Profilname As String)
            For Each dr As DataRow In Me.Profildata.Rows
                If dr("Bezeichnung") = Profilname Then
                    Me.cpMainConnectionProvider = Globals.conn
                    Me.iProfilnr = New SqlInt32(CType(dr("Profilnr"), Int32))
                    Me.SelectOne()
                End If
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsProfile-Felder

clsProfile Übersicht

Felder

public field Profildata

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsProfile -Klasse


Profildata -Feld

[Visual Basic]
Public Profildata As DataTable

Quellcode

[Visual Basic]
        Public Profildata As DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsProfile


clsSpalten -Klasse

For a list of all members of this type, see clsSpalten-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsSpalten
Vertragsverwaltung.TKB.VV.Utils.clsSpalten

[Visual Basic]
Public Class clsSpalten
    Inherits clsSpalten

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsSpalten-Member


clsSpalten-Member

clsSpalten Übersicht

Öffentliche Konstruktoren

public constructor clsSpalten -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property bAlsHacken (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property bReadonly (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iBreite (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iEintragnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iReihenfolge (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSpalte (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTabelle (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTabellenspalte (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTiptext (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Select_All_Aktiv Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


clsSpalten-Eigenschaften

clsSpalten Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property bAlsHacken (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property bReadonly (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iBreite (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iEintragnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iReihenfolge (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sSpalte (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTabelle (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTabellenspalte (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework
public property sTiptext (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten)

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


clsSpalten-Methoden

clsSpalten Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Select_All_Aktiv Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsSpalten) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsSpalten -Klasse


clsSpalten.Select_All_Aktiv -Methode

Purpose: SelectAll method. This method will Select all rows from the table.

[Visual Basic]
Public Function Select_All_Aktiv() As DataTable

Rückgabewert

DataTable object if succeeded, otherwise an Exception is thrown.

Hinweise

Properties set after a succesful call of this method: <UL> <LI>iErrorCode</LI> </UL>

Quellcode

[Visual Basic]
        Public Function Select_All_Aktiv() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectAll_Aktiv]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

                If Not m_iErrorCode.Equals(New SqlInt32(0)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSpalten


clsSpalten-Felder

clsSpalten Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsSpalten -Klasse


clsToolTips -Klasse

For a list of all members of this type, see clsToolTips-Member.

System.Object
Vertragsverwaltung.TKB.VV.Utils.clsToolTips

[Visual Basic]
Public Class clsToolTips

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Utils

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsToolTips-Member


clsToolTips-Member

clsToolTips Übersicht

Öffentliche Methoden

public method Edit_ToolTips

Unterstützt von .NET Compact Framework
public method Set_ToolTips

Unterstützt von .NET Compact Framework

Andere Methoden

private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
private method MyTooltip_Popup Unterstützt von .NET Compact Framework |

Felder

private field ToolTipData

Unterstützt von .NET Compact Framework
private field connection

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field l

Unterstützt von .NET Compact Framework

clsToolTips -Klasse


clsToolTips-Methoden

clsToolTips Übersicht

Öffentliche Methoden

public method Edit_ToolTips

Unterstützt von .NET Compact Framework
public method Set_ToolTips

Unterstützt von .NET Compact Framework

Andere Methoden

private method GetControl Unterstützt von .NET Compact Framework | Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung
private method Load_Data Unterstützt von .NET Compact Framework | Daten ab Datenbank laden
private method MyTooltip_Popup Unterstützt von .NET Compact Framework |

clsToolTips -Klasse


clsToolTips.Edit_ToolTips -Methode

[Visual Basic]
Public Function Edit_ToolTips( _
   ByRef frm As Form, _
   ByRef ctlcol As Collection _
) As Object

Parameter

frm
ctlcol

Quellcode

[Visual Basic]
        Public Function Edit_ToolTips(ByRef frm As Form, ByRef ctlcol As Collection)
            Me.Load_Data()
            l.Clear()
            Me.GetControl(frm, "*", l)
            For Each s As Control In l
                Try
                    MyTooltip.SetToolTip(s, frm.Name + "|" + s.Name)
                    MyTooltip.Tag = frm.Name
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try
            Next
            'For Each ctl As Control In ctlcol
            '    Try
            '        MyTooltip.SetToolTip(ctl, "SetToolTip")
            '        MyTooltip.Tag = frm.Name + "|" + ctl.Name
            '    Catch ex As Exception
            '    End Try
            'Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


clsToolTips.GetControl -Methode

Sucht in den Base-Controls sämtliche Controls mit dem Namen in "Key" (Wildcards * möglich) und listet die gefundnen Controls in der Liste L zur weiteren Bearbeitung

[Visual Basic]
Private Function GetControl( _
   ByVal BaseControl As Control, _
   ByVal Key As String, _
   ByRef L As List(Of Control), _
   Optional ByVal ReturnAtFirstElement As Boolean = False _
) As Boolean

Parameter

BaseControl
Base-Contrlo (z.B. aktuelles Formular
Key
Schlüssel welcher gesucht werden soll
L
Liste der gefundenen Objekte
ReturnAtFirstElement
Optional. Der Standardwert ist False.

Rückgabewert

True wenn eines oder mehr Controls gefunden wurden, false wenn kein Control gefunden wurde.

Quellcode

[Visual Basic]
        Private Function GetControl(ByVal BaseControl As Control, ByVal Key As String, ByRef L As List(Of Control), Optional ByVal ReturnAtFirstElement As Boolean = False) As Boolean
            If L Is Nothing Then L = New List(Of Control)
            Dim Gut As Boolean
            Dim ReturnFlag As Boolean = False
            If Key IsNot Nothing Then Key = Key.ToLower

            If BaseControl.HasChildren = True Then
                For Each ctl As Control In BaseControl.Controls
                    Gut = False
                    If Key Is Nothing Then
                        Gut = True
                    Else
                        If ctl.Name.Length >= Key.Length Then
                            Key = Key.ToLower
                            If Key.StartsWith("*") Then
                                If Key.Substring(1) = ctl.Name.ToLower.Substring(ctl.Name.Length - (Key.Length - 1), Key.Length - 1) Then Gut = True
                            ElseIf Key.EndsWith("*") Then
                                If Key.Substring(0, Key.Length - 1) = ctl.Name.ToLower.Substring(0, Key.Length - 1) Then Gut = True
                            Else
                                If Key = ctl.Name.ToLower Then Gut = True
                            End If
                        End If
                    End If

                    If Gut = True Then
                        L.Add(ctl)
                        If ReturnAtFirstElement = True Then ReturnFlag = True
                    End If
                    If ReturnFlag = False Then
                        Call GetControl(ctl, Key, L)
                    End If
                Next
            End If

            If L.Count - 1 > -1 Then
                Return True
            Else
                Return False
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


clsToolTips.Load_Data -Methode

Daten ab Datenbank laden

[Visual Basic]
Private Sub Load_Data()

Quellcode

[Visual Basic]
        Private Sub Load_Data()
            Try
                If ToolTipData.Tables.Count < 1 Then
                    ToolTipData.Tables.Clear()
                Else
                    Exit Sub
                End If
            Catch ex As Exception
            End Try
            ToolTipData.Tables.Clear()
            Dim sqlcmd As New SqlCommand

            sqlcmd.CommandText = "dbo.my_tooltip_get_data"
            'sqlcmd.Parameters(1).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value

            sqlcmd.CommandType = CommandType.StoredProcedure
            sqlcmd.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = sqlcmd
                da.Fill(ToolTipData, "Tooltips")
                Globals.SecurityDaten.Tables.Add(ToolTipData.Tables(0).Copy)
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                sqlcmd.Dispose()
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


clsToolTips.MyTooltip_Popup -Methode

[Visual Basic]
Private Sub MyTooltip_Popup( _
   ByVal sender As Object, _
   ByVal e As PopupEventArgs _
) Handles  _
   MyTooltip.Popup

Parameter

sender
e

Quellcode

[Visual Basic]
        Private Sub MyTooltip_Popup(ByVal sender As Object, ByVal e As System.Windows.Forms.PopupEventArgs) Handles MyTooltip.Popup
            'MsgBox(e.AssociatedControl.Name)
            evh.Edit_Tooltip(MyTooltip.Tag, e.AssociatedControl.Name)
            'Dim s As String = MyTooltip.Tag
            'Dim sp() As String
            'sp = s.Split("|")
            'evh.Edit_Tooltip(sp(0), sp(1))

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


clsToolTips.Set_ToolTips -Methode

[Visual Basic]
Public Function Set_ToolTips( _
   ByRef frm As Form _
) As Object

Parameter

frm

Quellcode

[Visual Basic]
        Public Function Set_ToolTips(ByRef frm As Form)
            Me.Load_Data()
            'MyTooltip.ToolTipIcon = ToolTipIcon.Info
            MyTooltip.IsBalloon = True
            MyTooltip.UseFading = True
            MyTooltip.UseAnimation = True
            Dim dv As New DataView(ToolTipData.Tables(0), "Aktiv = 1 and (Formularname='" & frm.Name & "' or Formularname='Allgemein')", "", DataViewRowState.CurrentRows)
            For Each dr As DataRowView In dv
                l.Clear()
                Me.GetControl(frm, dr.Item("Controlname"), l)
                Try
                    For Each ctl As Control In l
                        Try
                            MyTooltip.SetToolTip(ctl, dr.Item("ToolTip"))
                        Catch
                        End Try
                    Next
                Catch ex As Exception
                End Try
            Next
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


clsToolTips-Felder

clsToolTips Übersicht

Felder

private field ToolTipData

Unterstützt von .NET Compact Framework
private field connection

Unterstützt von .NET Compact Framework
private field da

Unterstützt von .NET Compact Framework
private field l

Unterstützt von .NET Compact Framework

clsToolTips -Klasse


ToolTipData -Feld

[Visual Basic]
Private ToolTipData As DataSet

Quellcode

[Visual Basic]
        Dim ToolTipData As DataSet = Globals.ToolTipDaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


connection -Feld

[Visual Basic]
Private connection As SqlConnection

Quellcode

[Visual Basic]
        Dim connection As New SqlConnection()

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


da -Feld

[Visual Basic]
Private da As SqlDataAdapter

Quellcode

[Visual Basic]
        Dim da As New SqlDataAdapter("", connection)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


l -Feld

[Visual Basic]
Private l As List(Of Control)

Quellcode

[Visual Basic]
        Dim l As New List(Of Control)

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsToolTips


Vertragsverwaltung.TKB.VV.Vertrag -Namespace

Klassen

public class Treenode_Descriptor Unterstützt von .NET Compact Framework | Treenode-Descriptor zur Befüllung des Tree-Node-Tags
public class clsKontakt Unterstützt von .NET Compact Framework |
public class clsKuendigungsfrist Unterstützt von .NET Compact Framework |
public class clsLizenzinformationen Unterstützt von .NET Compact Framework | Klasse für die Verwaltung der Lizenzinformationen eines Vertragselementes bzw. einer Applikation
public class clsParentelemente Unterstützt von .NET Compact Framework |
public class clsPendenz Unterstützt von .NET Compact Framework |
public class clsPendenzUebersicht Unterstützt von .NET Compact Framework |
public class clsPersonen Unterstützt von .NET Compact Framework |
public class clsReferenzvertrag Unterstützt von .NET Compact Framework |
public class clsVertragselement Unterstützt von .NET Compact Framework |
public class clsVertragselementApplikation Unterstützt von .NET Compact Framework |
public class clsVertragsereignis Unterstützt von .NET Compact Framework |
public class clsVertragsleistung Unterstützt von .NET Compact Framework |
public class clsVertragspartner Unterstützt von .NET Compact Framework |
public class clsVertragsuebersicht_Strukturen Unterstützt von .NET Compact Framework |


Treenode_Descriptor -Klasse

Treenode-Descriptor zur Befüllung des Tree-Node-Tags

For a list of all members of this type, see Treenode_Descriptor-Member.

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.Treenode_Descriptor

[Visual Basic]
Public Class Treenode_Descriptor

Hinweise

Treenode-Tags werden mit den 2 Elementen (Type und Keyvalue) befüllt: Type: Vertragspartner, Vertragstyp Keyvalue: Primary-Key des Elementes

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

Treenode_Descriptor-Member


Treenode_Descriptor.Vertragstypnr -Eigenschaft

[Visual Basic]
Public Property Vertragstypnr() As Integer

Quellcode

[Visual Basic]
        Property Vertragstypnr() As Integer
            Get
                If m_vertragstypnr < 0 Then
                    Return m_vertragstypnr / -100
                Else
                    Return m_vertragstypnr
                End If
            End Get
            Set(ByVal value As Integer)
                m_vertragstypnr = value
            End Set
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Treenode_Descriptor


clsKontakt -Klasse

For a list of all members of this type, see clsKontakt-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt
Vertragsverwaltung.TKB.VV.Vertrag.clsKontakt

[Visual Basic]
Public Class clsKontakt
    Inherits clsVertragskontakt

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKontakt-Member


clsKontakt-Member

clsKontakt Übersicht

Öffentliche Konstruktoren

public constructor clsKontakt -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property bIntern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iVertragsKontaktNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_Vertragskontakt Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Vertragskontakt Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakt -Klasse


clsKontakt-Eigenschaften

clsKontakt Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property bIntern (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKontakttypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iVertragsKontaktNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKontakt -Klasse


clsKontakt-Methoden

clsKontakt Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method Delete_Vertragskontakt Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Vertragskontakt Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragskontakt) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsKontakt -Klasse


clsKontakt.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragskontakt")
            db.Dispose()
            Me.iVertragsKontaktNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iKontakttypNr = New SqlInt32(CType(0, Int32))
            Me.iPersonNr = New SqlInt32(CType(0, Int32))
            Me.bIntern = New SqlBoolean(CType(False, Boolean))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsKontakt.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragskontakt(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragskontakt")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragsKontaktNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsKontakt | Vertragsverwaltung.TKB.VV.Vertrag


clsKontakt.Delete_Vertragskontakt -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_Vertragskontakt( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Vertragskontakt(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragskontakt(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Me.Neuer_Datensatz = False
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsKontakt.Get_Vertragskontakt -Methode

Kuendigungsfrist lesen

[Visual Basic]
Public Function Get_Vertragskontakt( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Vertragskontakt(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragsKontaktNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsKontakt.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iVertragsKontaktNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsKuendigungsfrist -Klasse

For a list of all members of this type, see clsKuendigungsfrist-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist
Vertragsverwaltung.TKB.VV.Vertrag.clsKuendigungsfrist

[Visual Basic]
Public Class clsKuendigungsfrist
    Inherits clsKuendigungsfrist

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsKuendigungsfrist-Member


clsKuendigungsfrist-Member

clsKuendigungsfrist Übersicht

Öffentliche Konstruktoren

public constructor clsKuendigungsfrist -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property daKuendigungstermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iVertragselementNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKuendigungsfirst (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sVarZeitspanne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method DeleteAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method Delete_Kuendigungsfrist Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


clsKuendigungsfrist-Eigenschaften

clsKuendigungsfrist Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property daKuendigungstermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property iVertragselementNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sKuendigungsfirst (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework
public property sVarZeitspanne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist)

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


clsKuendigungsfrist-Methoden

clsKuendigungsfrist Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes erstellen.
public method DeleteAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method Delete_Kuendigungsfrist Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Kuendigungsfrist Unterstützt von .NET Compact Framework | Kuendigungsfrist lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragselementNr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragselementNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsKuendigungsfrist) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragselementNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragselementNr' in all rows which have as value for this field the value as set in property 'iVertragselementNrOld' to the value as set in property 'iVertragselementNr'.

clsKuendigungsfrist -Klasse


clsKuendigungsfrist.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Kuendigungsfrist")
            db.Dispose()
            Me.iKuendigungsfristNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.sVarZeitspanne = New SqlString(CType("", String))
            Me.sKuendigungsfirst = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Kuendigungsfrist(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Kuendigungsfrist")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iKuendigungsfristNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsKuendigungsfrist | Vertragsverwaltung.TKB.VV.Vertrag


clsKuendigungsfrist.Delete_Kuendigungsfrist -Methode

Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_Kuendigungsfrist( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Kuendigungsfrist(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Kuendigungsfrist(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Me.Neuer_Datensatz = False
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.Get_Kuendigungsfrist -Methode

Kuendigungsfrist lesen

[Visual Basic]
Public Function Get_Kuendigungsfrist( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Kuendigungsfrist(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iKuendigungsfristNr = New SqlInt32(CType(nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iKuendigungsfristNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsKuendigungsfrist-Felder

clsKuendigungsfrist Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsKuendigungsfrist -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


clsLizenzinformationen -Klasse

Klasse für die Verwaltung der Lizenzinformationen eines Vertragselementes bzw. einer Applikation

For a list of all members of this type, see clsLizenzinformationen-Member.

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsLizenzinformationen

[Visual Basic]
Public Class clsLizenzinformationen

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsLizenzinformationen-Member


clsLizenzinformationen-Member

clsLizenzinformationen Übersicht

Öffentliche Methoden

public method Check_Vertragstyp_Fuer_Lizenz Unterstützt von .NET Compact Framework |
public method Dispose Unterstützt von .NET Compact Framework | Destructor Dispose für umd die beiden Domaintables frei zu geben
public method Get_Lizenzkauf Unterstützt von .NET Compact Framework | Laufinformationen eines Lizenz-Vertragselementes auslesen und dem Grid übergeben
public method Get_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method Save_Lizenzkauf Unterstützt von .NET Compact Framework | Daten der Domaintable Lizenzkauf sichern
public method Save_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method aktive_lizenzinformationen_vorhanden Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_Lizenzen

Unterstützt von .NET Compact Framework

Felder

public field Lizenzkauf Unterstützt von .NET Compact Framework | Domaintable für Lizenkauf
public field Lizenzschluessel Unterstützt von .NET Compact Framework | Domaintable für Lizenzschlüssel

clsLizenzinformationen -Klasse


clsLizenzinformationen-Methoden

clsLizenzinformationen Übersicht

Öffentliche Methoden

public method Check_Vertragstyp_Fuer_Lizenz Unterstützt von .NET Compact Framework |
public method Dispose Unterstützt von .NET Compact Framework | Destructor Dispose für umd die beiden Domaintables frei zu geben
public method Get_Lizenzkauf Unterstützt von .NET Compact Framework | Laufinformationen eines Lizenz-Vertragselementes auslesen und dem Grid übergeben
public method Get_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method Save_Lizenzkauf Unterstützt von .NET Compact Framework | Daten der Domaintable Lizenzkauf sichern
public method Save_Lizenzschluessel Unterstützt von .NET Compact Framework |
public method aktive_lizenzinformationen_vorhanden Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_Lizenzen

Unterstützt von .NET Compact Framework

clsLizenzinformationen -Klasse


clsLizenzinformationen.Check_Vertragstyp_Fuer_Lizenz -Methode

[Visual Basic]
Public Function Check_Vertragstyp_Fuer_Lizenz( _
   ByVal Vertragstypnr As Integer _
) As Boolean

Parameter

Vertragstypnr

Quellcode

[Visual Basic]
        Public Function Check_Vertragstyp_Fuer_Lizenz(ByVal Vertragstypnr As Integer) As Boolean
            Dim vertragstyp As New TKB.VV.DB.clsVertragstyp
            vertragstyp.cpMainConnectionProvider = Globals.conn
            vertragstyp.iVertragstypnr = New SqlInt32(CType(Vertragstypnr, Int32))
            vertragstyp.SelectOne()
            If vertragstyp.bAlsLizenz.Value = True Then Return True Else Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Dispose -Methode

Destructor Dispose für umd die beiden Domaintables frei zu geben

[Visual Basic]
Public Sub Dispose()

Quellcode

[Visual Basic]
        Sub Dispose()
            If Me.Lizenzkauf.Tabledata.HasChanges Then
                Dim msg As New TKB.VV.Utils.MyMessage
                If msg.Show_MessageYesNoCancel(800) = MsgBoxResult.Yes Then
                    Me.Lizenzkauf.Save_Data()
                End If
                msg.dispose()
            End If
            Me.Lizenzkauf.dispose()
            Me.Lizenzkauf = Nothing
            If Me.Lizenzschluessel.Tabledata.HasChanges Then
                Dim msg As New TKB.VV.Utils.MyMessage
                If msg.Show_MessageYesNoCancel(801) = MsgBoxResult.Yes Then
                    Me.Lizenzkauf.Save_Data()
                End If
                msg.dispose()
            End If
            Me.Lizenzschluessel.dispose()
            Me.Lizenzschluessel = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Get_Lizenzen -Methode

[Visual Basic]
Private Function Get_Lizenzen( _
   ByVal vertragselementnr As Integer _
) As Integer

Parameter

vertragselementnr

Quellcode

[Visual Basic]
        Private Function Get_Lizenzen(ByVal vertragselementnr As Integer) As Integer
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_Check_lizenzkauf"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertragselementnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                Return scmCmdToExecute.Parameters("@anzahl").Value
            Catch ex As Exception
                Throw New Exception("clsParentelemente::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Get_Lizenzkauf -Methode

Laufinformationen eines Lizenz-Vertragselementes auslesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Lizenzkauf( _
   ByVal Vertragselementnr As Integer, _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Applikationnr As Integer _
) As Object

Parameter

Vertragselementnr
Nr. Des Lizenz-Vertragselementes
c1data
C1TrueDBGrid
Applikationnr

Quellcode

[Visual Basic]
        Public Function Get_Lizenzkauf(ByVal Vertragselementnr As Integer, ByRef c1data As C1TrueDBGrid, ByVal Applikationnr As Integer)
            Try
                Me.Lizenzkauf.dispose()
                Me.Lizenzkauf = Nothing
            Catch ex As Exception
            End Try
            Me.Lizenzkauf = New TKB.VV.Sysadmin.DomainTable("Lizenzkauf", 0, Vertragselementnr, Globals.clsmitarbeiter.iMitarbeiternr.Value, Applikationnr)
            c1data.DataSource = Me.Lizenzkauf.Tabledata
            c1data.DataMember = Me.Lizenzkauf.Tabledata.Tables(0).TableName
            c1data.AllowAddNew = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Get_Lizenzschluessel -Methode

[Visual Basic]
Public Function Get_Lizenzschluessel( _
   ByVal Lizenzkaufnr As Integer, _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

Lizenzkaufnr
c1data

Quellcode

[Visual Basic]
        Public Function Get_Lizenzschluessel(ByVal Lizenzkaufnr As Integer, ByRef c1data As C1TrueDBGrid)
            Try
                Me.Lizenzschluessel.dispose()
                Me.Lizenzschluessel = Nothing
            Catch ex As Exception

            End Try
            Me.Lizenzschluessel = New TKB.VV.Sysadmin.DomainTable("Lizenzschluessel", 0, Lizenzkaufnr, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Me.Lizenzschluessel.Tabledata
            c1data.DataMember = Me.Lizenzschluessel.Tabledata.Tables(0).TableName
            c1data.AllowAddNew = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Save_Lizenzkauf -Methode

Daten der Domaintable Lizenzkauf sichern

[Visual Basic]
Public Sub Save_Lizenzkauf()

Quellcode

[Visual Basic]
        Public Sub Save_Lizenzkauf()
            Me.Lizenzkauf.Save_Data()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.Save_Lizenzschluessel -Methode

[Visual Basic]
Public Sub Save_Lizenzschluessel()

Quellcode

[Visual Basic]
        Public Sub Save_Lizenzschluessel()
            Me.Lizenzkauf.Save_Data()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen.aktive_lizenzinformationen_vorhanden -Methode

[Visual Basic]
Public Function aktive_lizenzinformationen_vorhanden( _
   ByVal vertragselement As Integer _
) As Boolean

Parameter

vertragselement

Quellcode

[Visual Basic]
        Public Function aktive_lizenzinformationen_vorhanden(ByVal vertragselement As Integer) As Boolean
            If Get_Lizenzen(vertragselement) > 0 Then Return True Else Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsLizenzinformationen-Felder

clsLizenzinformationen Übersicht

Felder

public field Lizenzkauf Unterstützt von .NET Compact Framework | Domaintable für Lizenkauf
public field Lizenzschluessel Unterstützt von .NET Compact Framework | Domaintable für Lizenzschlüssel

clsLizenzinformationen -Klasse


Lizenzkauf -Feld

Domaintable für Lizenkauf

[Visual Basic]
Public Lizenzkauf As DomainTable

Quellcode

[Visual Basic]
        Public Lizenzkauf As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


Lizenzschluessel -Feld

Domaintable für Lizenzschlüssel

[Visual Basic]
Public Lizenzschluessel As DomainTable

Quellcode

[Visual Basic]
        Public Lizenzschluessel As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsLizenzinformationen


clsParentelemente -Klasse

For a list of all members of this type, see clsParentelemente-Member.

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsParentelemente

[Visual Basic]
Public Class clsParentelemente

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsParentelemente-Member


clsParentelemente-Member

clsParentelemente Übersicht

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework | Suchen eines Knoten Treeview
public method Load_ParentElemente Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

Felder

private field fnt_Strikeout Unterstützt von .NET Compact Framework |
private field fnt_normal Unterstützt von .NET Compact Framework |
private field xvertragspartnernr Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden

clsParentelemente -Klasse


clsParentelemente-Methoden

clsParentelemente Übersicht

Öffentliche Methoden

public method FindNode Unterstützt von .NET Compact Framework | Suchen eines Knoten Treeview
public method Load_ParentElemente Unterstützt von .NET Compact Framework |

Andere Methoden

private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

clsParentelemente -Klasse


clsParentelemente.FindNode -Methode

Suchen eines Knoten Treeview

[Visual Basic]
Public Function FindNode( _
   ByVal _nodeCollection As TreeNodeCollection, _
   ByVal SearchVal As Integer, _
   ByVal SearchString As String _
) As TreeNode

Parameter

_nodeCollection
Nodes des TreeView
SearchVal
Tag.Keyvalue
SearchString
Node.Text als Suchbegriff

Quellcode

[Visual Basic]
        Public Function FindNode(ByVal _nodeCollection As TreeNodeCollection, ByVal SearchVal As Integer, ByVal SearchString As String) As TreeNode
            Dim tmpNode As TreeNode
            For Each _child As TreeNode In _nodeCollection
                If _child.Tag = SearchVal Then

                    Return _child
                End If
                tmpNode = FindNode(_child.Nodes, SearchVal, SearchString)
                If Not tmpNode Is Nothing Then
                    Return tmpNode
                End If
            Next
            Return Nothing
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente.Get_SubStruktur -Methode

Laden der Substruktur

[Visual Basic]
Private Function Get_SubStruktur( _
   ByVal vertragstypnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Details_anzeigen As Integer _
) As DataTable

Parameter

vertragstypnr
Vertragspartnernr
Nummer des aktuellen Vertragspartners
Details_anzeigen

Quellcode

[Visual Basic]
        Private Function Get_SubStruktur(ByVal vertragstypnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Details_anzeigen As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragselement_parent_struktur"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsParentelemente::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente.LoadNode -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadNode( _
   ByVal oDS As DataSet, _
   ByRef oNode As TreeView _
)

Parameter

oDS
Input-Dataset
oNode
Aktueller Node

Quellcode

[Visual Basic]
        Private Sub LoadNode(ByVal oDS As DataSet, ByRef oNode As TreeView)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode1 As New TreeNode()
                        oNode1.Text = oDataRow("Bezeichnung").ToString()
                        oNode1.Tag = oDataRow("vertragselementnr").ToString
                        If oDataRow.Item("aktiv") = 0 Then
                            oNode1.NodeFont = Me.fnt_Strikeout
                            oNode1.ImageIndex = 3
                            oNode1.SelectedImageIndex = 3
                            oNode1.StateImageIndex = 3
                        Else
                            oNode1.NodeFont = Me.fnt_normal
                            oNode1.ImageIndex = 1
                            oNode1.SelectedImageIndex = 1
                            oNode1.StateImageIndex = 1
                        End If
                        oNode.Nodes.Add(oNode1)
                        RecursivelyLoadNode(oDataRow, oNode1)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente.Load_ParentElemente -Methode

[Visual Basic]
Public Function Load_ParentElemente( _
   ByVal vertragspartnernr As Integer, _
   ByVal Parentid As Integer, _
   ByRef Tree As TreeView _
) As Object

Parameter

vertragspartnernr
Parentid
Tree

Quellcode

[Visual Basic]
        Public Function Load_ParentElemente(ByVal vertragspartnernr As Integer, ByVal Parentid As Integer, ByRef Tree As TreeView)
            Dim dt As New DataTable
            fnt_Strikeout = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Strikeout)
            fnt_normal = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Regular)

            Dim tn As New TreeNode
            dt = Me.Get_SubStruktur(0, vertragspartnernr, 1)

            Tree.ShowLines = True
            Tree.ShowRootLines = False
            Tree.SuspendLayout()
            Tree.Visible = True
            Tree.Nodes.Clear()

            tn = Tree.Nodes.Add("--- kein übergeordnetes Element ---")
            tn.Tag = 0

            Me.Update_Node(dt, Tree)
            Tree.ExpandAll()
            Tree.SelectedNode = Me.FindNode(Tree.Nodes, Parentid, "")
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente.RecursivelyLoadNode -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadNode( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode _
)

Parameter

oDataRow
oNode

Quellcode

[Visual Basic]
        Private Sub RecursivelyLoadNode(ByVal oDataRow As DataRow, ByRef oNode As TreeNode)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                oChildNode.Tag = oChildRow("Vertragselementnr").ToString
                If oChildRow.Item("aktiv") = 0 Then
                    oChildNode.NodeFont = Me.fnt_Strikeout
                    oChildNode.ImageIndex = 3
                    oChildNode.SelectedImageIndex = 3
                    oChildNode.StateImageIndex = 3
                Else
                    oChildNode.NodeFont = Me.fnt_normal
                    oChildNode.ImageIndex = 1
                    oChildNode.SelectedImageIndex = 1
                    oChildNode.StateImageIndex = 1
                End If
                oNode.Nodes.Add(oChildNode)
                If oNode.ImageIndex = 3 Then
                    oNode.ImageIndex = 2
                    oNode.StateImageIndex = 2
                    oNode.SelectedImageIndex = 2
                Else
                    oNode.ImageIndex = 0
                    oNode.StateImageIndex = 0
                    oNode.SelectedImageIndex = 0
                End If
                RecursivelyLoadNode(oChildRow, oChildNode)
            Next oChildRow
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente.Update_Node -Methode

Parent-Beziehung herstellen und Struktur abfüllen

[Visual Basic]
Private Sub Update_Node( _
   ByVal oSourceData As DataTable, _
   ByVal Tree As TreeView _
)

Parameter

oSourceData
Tree

Quellcode

[Visual Basic]
        Private Sub Update_Node(ByVal oSourceData As DataTable, ByVal Tree As TreeView)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("Vertragselementnr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadNode(oDS, Tree)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsParentelemente-Felder

clsParentelemente Übersicht

Felder

private field fnt_Strikeout Unterstützt von .NET Compact Framework |
private field fnt_normal Unterstützt von .NET Compact Framework |
private field xvertragspartnernr Unterstützt von .NET Compact Framework | Treedaten ab Datenbank laden

clsParentelemente -Klasse


fnt_Strikeout -Feld

[Visual Basic]
Private fnt_Strikeout As Font

Quellcode

[Visual Basic]
        Private fnt_Strikeout As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


fnt_normal -Feld

[Visual Basic]
Private fnt_normal As Font

Quellcode

[Visual Basic]
        Private fnt_normal As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


xvertragspartnernr -Feld

Treedaten ab Datenbank laden

[Visual Basic]
Private xvertragspartnernr As Integer

Quellcode

[Visual Basic]
        Dim xvertragspartnernr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsParentelemente


clsPendenz -Klasse

For a list of all members of this type, see clsPendenz-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPendenz
Vertragsverwaltung.TKB.VV.Vertrag.clsPendenz

[Visual Basic]
Public Class clsPendenz
    Inherits clsPendenz

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPendenz-Member


clsPendenz-Member

clsPendenz Übersicht

Öffentliche Konstruktoren

public constructor clsPendenz -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property daTermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iPendenzNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVerantwortlich (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Datensatz physisch löschen
public method Delete_Pendenz Unterstützt von .NET Compact Framework | Datensatz löschen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Pendenz Unterstützt von .NET Compact Framework | Pendenz lesen lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Pendenzstatus

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


clsPendenz-Eigenschaften

clsPendenz Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property daTermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iPendenzNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iPendenzStatusNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sVerantwortlich (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz)

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


clsPendenz-Methoden

clsPendenz Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Datensatz physisch löschen
public method Delete_Pendenz Unterstützt von .NET Compact Framework | Datensatz löschen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Pendenz Unterstützt von .NET Compact Framework | Pendenz lesen lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPendenz) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsPendenz -Klasse


clsPendenz.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Pendenz")
            db.Dispose()
            Me.iPendenzNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iPendenzStatusNr = New SqlInt32(CType(1, Int32))
            Me.sVerantwortlich = New SqlString(CType("", String))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daTermin = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Pendenz(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Pendenz")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iPendenzNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


Delete -Methode

Überladungsliste

Datensatz physisch löschen

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsPendenz | Vertragsverwaltung.TKB.VV.Vertrag


clsPendenz.Delete_Pendenz -Methode

Datensatz löschen.

[Visual Basic]
Public Function Delete_Pendenz( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Pendenz(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Pendenz(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iPendenzStatusNr = New SqlInt32(CType(4, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.Get_Pendenz -Methode

Pendenz lesen lesen

[Visual Basic]
Public Function Get_Pendenz( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Pendenz(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iPendenzNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Vertragselement.iVertragselementnr = Me.iVertragselementNr.Value
            Vertragselement.cpMainConnectionProvider = Globals.conn
            Vertragselement.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iPendenzNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenz-Felder

clsPendenz Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Pendenzstatus

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPendenz -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


Pendenzstatus -Feld

[Visual Basic]
Public Pendenzstatus As DomainTable

Quellcode

[Visual Basic]
        Public Pendenzstatus As New TKB.VV.Sysadmin.DomainTable("Pendenzstatus")

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


Vertragselement -Feld

[Visual Basic]
Public Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
        Public Vertragselement As New TKB.VV.DB.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


clsPendenzUebersicht -Klasse

For a list of all members of this type, see clsPendenzUebersicht-Member.

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsPendenzUebersicht

[Visual Basic]
Public Class clsPendenzUebersicht

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPendenzUebersicht-Member


clsPendenzUebersicht-Member

clsPendenzUebersicht Übersicht

Öffentliche Methoden

public method Get_Pendenzuebersicht

Unterstützt von .NET Compact Framework

 Liefert sämtrliche gem. Param. Pendenzstatus gewählten Pendenzen

clsPendenzUebersicht -Klasse


clsPendenzUebersicht-Methoden

clsPendenzUebersicht Übersicht

Öffentliche Methoden

public method Get_Pendenzuebersicht

Unterstützt von .NET Compact Framework

 Liefert sämtrliche gem. Param. Pendenzstatus gewählten Pendenzen

clsPendenzUebersicht -Klasse


clsPendenzUebersicht.Get_Pendenzuebersicht -Methode

Liefert sämtrliche gem. Param. Pendenzstatus gewählten Pendenzen

[Visual Basic]
Public Function Get_Pendenzuebersicht( _
   ByVal PendenzStatusNr As Integer, _
   ByVal pendenzstatus As String _
) As DataTable

Parameter

PendenzStatusNr
pendenzstatus

Quellcode

[Visual Basic]
        Public Function Get_Pendenzuebersicht(ByVal PendenzStatusNr As Integer, ByVal pendenzstatus As String) As DataTable
            Dim PendStatusnr As Integer = 0
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsverwaltung_pendenzenliste"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                If pendenzstatus = "Alle" Then
                    PendStatusnr = -1
                Else
                    PendStatusnr = pendenzstatus
                End If

                'Select Case pendenzstatus
                '    Case "Alle Pendenzen"
                '        PendStatusnr = -1
                '    Case "Offen/In Bearbeitung"
                '        PendStatusnr = -2
                '    Case "In Bearbeitung"
                '        PendStatusnr = 2
                '    Case "Offen"
                '        PendStatusnr = 1
                '    Case "Erledigt"
                '        PendStatusnr = 3
                '    Case "Hinfällig"
                '        PendStatusnr = 4
                '    Case Else
                '        PendStatusnr = -1
                'End Select
                scmCmdToExecute.Parameters.Add(New SqlParameter("@pendenzstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, PendStatusnr))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsPendenzübersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenzUebersicht


clsPersonen -Klasse

For a list of all members of this type, see clsPersonen-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsPerson
Vertragsverwaltung.TKB.VV.Vertrag.clsPersonen

[Visual Basic]
Public Class clsPersonen
    Inherits clsPerson

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsPersonen-Member


clsPersonen-Member

clsPersonen Übersicht

Öffentliche Konstruktoren

public constructor clsPersonen -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iVertragspartnernr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iVertragspartnernrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sInternet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sName (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sOrt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sPlz (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sPostfach (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sStrasse (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sTelefax (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sTelefon (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sVorname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Kontakt löschen
public method DeleteAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method Delete_Kontakt Unterstützt von .NET Compact Framework | Kontakt inaktivieren.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Person Unterstützt von .NET Compact Framework | Person lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Person sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragspartnernr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragspartnernr' in all rows which have as value for this field the value as set in property 'iVertragspartnernrOld' to the value as set in property 'iVertragspartnernr'.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPersonen -Klasse


clsPersonen-Eigenschaften

clsPersonen Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iPersonFunktionNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iPersonNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iVertragspartnernr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property iVertragspartnernrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sInternet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sName (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sOrt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sPlz (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sPostfach (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sStrasse (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sTelefax (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sTelefon (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework
public property sVorname (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson)

Unterstützt von .NET Compact Framework

clsPersonen -Klasse


clsPersonen-Methoden

clsPersonen Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Kontakt löschen
public method DeleteAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method Delete_Kontakt Unterstützt von .NET Compact Framework | Kontakt inaktivieren.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Person Unterstützt von .NET Compact Framework | Person lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Person sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragspartnernr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnernrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsPerson) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragspartnernr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragspartnernr' in all rows which have as value for this field the value as set in property 'iVertragspartnernrOld' to the value as set in property 'iVertragspartnernr'.

clsPersonen -Klasse


clsPersonen.Add_New -Methode

Neue Person einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragspartnernr As Integer _
) As Integer

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragspartnernr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Person")
            db.Dispose()
            Me.iPersonNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragspartnernr = New SqlInt32(CType(Vertragspartnernr, Int32))
            Me.sName = New SqlString(CType("", String))
            Me.sVorname = New SqlString(CType("", String))
            Me.sStrasse = New SqlString(CType("", String))
            Me.sPostfach = New SqlString(CType("", String))
            Me.sPlz = New SqlString(CType("", String))
            Me.sOrt = New SqlString(CType("", String))
            Me.sTelefon = New SqlString(CType("", String))
            Me.sTelefax = New SqlString(CType("", String))
            Me.sEMail = New SqlString(CType("", String))
            Me.sInternet = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.iPersonFunktionNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn

            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsPersonen.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Person(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Person")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iPersonNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


Delete -Methode

Überladungsliste

Kontakt löschen

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsPersonen | Vertragsverwaltung.TKB.VV.Vertrag


clsPersonen.Delete_Kontakt -Methode

Kontakt inaktivieren.

[Visual Basic]
Public Function Delete_Kontakt( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Delete_Kontakt(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Person(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsPersonen.Get_Person -Methode

Person lesen

[Visual Basic]
Public Function Get_Person( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr
PersonNr

Quellcode

[Visual Basic]
        Public Function Get_Person(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iPersonNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsPersonen.Save_Data -Methode

Person sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iPersonNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsPersonen-Felder

clsPersonen Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsPersonen -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsReferenzvertrag -Klasse

For a list of all members of this type, see clsReferenzvertrag-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz
Vertragsverwaltung.TKB.VV.Vertrag.clsReferenzvertrag

[Visual Basic]
Public Class clsReferenzvertrag
    Inherits clsVertragselement_Referenz

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsReferenzvertrag-Member


clsReferenzvertrag-Member

clsReferenzvertrag Übersicht

Öffentliche Konstruktoren

public constructor clsReferenzvertrag -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Vertragselement_Name_1

Unterstützt von .NET Compact Framework
public property Vertragselement_Name_2

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iReferenzvertragsnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iVertragselementnr_1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iVertragselementnr_2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_Referenz Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_Vertragselement_Referenz Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragselement_Suchen Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Felder

private field Beziehungstyp

Unterstützt von .NET Compact Framework
public field Beziehungstypen

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field sVertragselement_Name_1

Unterstützt von .NET Compact Framework
private field sVertragselement_Name_2

Unterstützt von .NET Compact Framework

clsReferenzvertrag -Klasse


clsReferenzvertrag -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            MyBase.New()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag-Eigenschaften

clsReferenzvertrag Übersicht

Öffentliche Eigenschaften

public property Vertragselement_Name_1

Unterstützt von .NET Compact Framework
public property Vertragselement_Name_2

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iBeziehungstypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iReferenzvertragsnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iVertragselementnr_1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property iVertragselementnr_2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsReferenzvertrag -Klasse


clsReferenzvertrag.Vertragselement_Name_1 -Eigenschaft

[Visual Basic]
Public ReadOnly Property Vertragselement_Name_1() As String

Quellcode

[Visual Basic]
        ReadOnly Property Vertragselement_Name_1() As String
            Get
                Dim ve As New TKB.VV.DB.clsVertragselement
                Try
                    ve.cpMainConnectionProvider = Globals.conn
                    ve.iVertragselementnr = Me.iVertragselementnr_1
                    ve.SelectOne()
                    Return ve.sBezeichnung.Value
                Catch
                    Return ""
                Finally
                    ve.Dispose()
                End Try
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag.Vertragselement_Name_2 -Eigenschaft

[Visual Basic]
Public ReadOnly Property Vertragselement_Name_2() As String

Quellcode

[Visual Basic]
        ReadOnly Property Vertragselement_Name_2() As String
            Get
                Dim ve As New TKB.VV.DB.clsVertragselement
                Try
                    ve.cpMainConnectionProvider = Globals.conn
                    ve.iVertragselementnr = Me.iVertragselementnr_2
                    ve.SelectOne()
                    Return ve.sBezeichnung.Value
                Catch
                    Return ""
                Finally
                    ve.Dispose()
                End Try
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag-Methoden

clsReferenzvertrag Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_Referenz Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_Vertragselement_Referenz Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement_Referenz) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragselement_Suchen Unterstützt von .NET Compact Framework |
public method dispose Überladen. Unterstützt von .NET Compact Framework |

clsReferenzvertrag -Klasse


clsReferenzvertrag.Add_New -Methode

Neue Vertragselement_Referenz erstellen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement_Referenz")
            db.Dispose()
            Me.iReferenzvertragsnr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementnr_1 = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iVertragselementnr_2 = New SqlInt32(CType(0, Int32))
            Me.iBeziehungstypNr = New SqlInt32(CType(1, Int32))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes.

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsReferenzvertrag | Vertragsverwaltung.TKB.VV.Vertrag


clsReferenzvertrag.Delete_Referenz -Methode

Löschen eines Datensatzes.

[Visual Basic]
Public Function Delete_Referenz( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Referenz(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragselement_Referenz(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag.Get_Vertragselement_Referenz -Methode

Vertragselement_Referenz lesen

[Visual Basic]
Public Function Get_Vertragselement_Referenz( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Vertragselement_Referenz(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iReferenzvertragsnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
            Me.Vertragselement.Dispose()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iReferenzvertragsnr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsReferenzvertrag.Vertragselement_Suchen -Methode

[Visual Basic]
Public Function Vertragselement_Suchen( _
   ByRef Vertragselementnr As Integer, _
   ByRef Vertragselement_Bezeichngung As String _
) As Boolean

Parameter

Vertragselementnr
Vertragselement_Bezeichngung

Quellcode

[Visual Basic]
        Public Function Vertragselement_Suchen(ByRef Vertragselementnr As Integer, ByRef Vertragselement_Bezeichngung As String) As Boolean
            Dim vesuche As New frmVertragselementSuche
            vesuche.ShowDialog()
            Try
                If vesuche.DialogResult = DialogResult.OK Then
                    Vertragselementnr = vesuche.Vertragselementnr
                    Vertragselement_Bezeichngung = vesuche.Vertragselement_Bezeichnung
                    Return True
                Else
                    Vertragselementnr = -1
                    Vertragselement_Bezeichngung = ""
                    Return False
                End If
            Catch ex As Exception
                Vertragselementnr = -1
                Vertragselement_Bezeichngung = ""
                Return False
            Finally
                vesuche.dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

clsReferenzvertrag | Vertragsverwaltung.TKB.VV.Vertrag


clsReferenzvertrag-Felder

clsReferenzvertrag Übersicht

Felder

private field Beziehungstyp

Unterstützt von .NET Compact Framework
public field Beziehungstypen

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
private field Vertragselement

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
private field sVertragselement_Name_1

Unterstützt von .NET Compact Framework
private field sVertragselement_Name_2

Unterstützt von .NET Compact Framework

clsReferenzvertrag -Klasse


Beziehungstyp -Feld

[Visual Basic]
Private Beziehungstyp As clsBeziehungstyp

Quellcode

[Visual Basic]
        Private Beziehungstyp As New TKB.VV.DB.clsBeziehungstyp

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


Beziehungstypen -Feld

[Visual Basic]
Public Beziehungstypen As DomainTable

Quellcode

[Visual Basic]
        Public Beziehungstypen As New TKB.VV.Sysadmin.DomainTable("Beziehungstyp")

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


Vertragselement -Feld

[Visual Basic]
Private Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
        Private Vertragselement As New TKB.VV.DB.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


sVertragselement_Name_1 -Feld

[Visual Basic]
Private sVertragselement_Name_1 As String

Quellcode

[Visual Basic]
        Dim sVertragselement_Name_1 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


sVertragselement_Name_2 -Feld

[Visual Basic]
Private sVertragselement_Name_2 As String

Quellcode

[Visual Basic]
        Dim sVertragselement_Name_2 As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


clsVertragselement -Klasse

For a list of all members of this type, see clsVertragselement-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselement
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselement

[Visual Basic]
Public Class clsVertragselement
    Inherits clsVertragselement

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragselement-Member


clsVertragselement-Member

clsVertragselement Übersicht

Öffentliche Konstruktoren

public constructor clsVertragselement -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property Vertragspartnername

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property bBefristet_Unbefristet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daGekuendigt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daGekuendigt_per (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daMindestvertragsdauer_bis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daUnterzeichnet_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVersionsdatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVertragsablauf (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVertragsbeginn (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragstypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragstypNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzdetails (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sNummer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sSuchbegriffe (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Add_Service Unterstützt von .NET Compact Framework | Neuer Serice/Leistung als Vertragsleistung hinzufügen
public method Check_Is_Parent_Has_Childs Unterstützt von .NET Compact Framework |
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method DeleteAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method DeleteAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method Delete_Vertragselement Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Get_Aktivitaeten Überladen. Unterstützt von .NET Compact Framework | Aktivitaeten lesen und dem Grid übergeben
public method Get_Applikationen Überladen. Unterstützt von .NET Compact Framework | Applikationen lesen und dem Grid übergeben
public method Get_Dokumente Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_History Überladen. Unterstützt von .NET Compact Framework | History lesen und dem Grid übergeben
public method Get_Kuendigungsfristen Überladen. Unterstützt von .NET Compact Framework | Kündiguntsfristen lasen und dem Grid übergeben
public method Get_Pedenzen Unterstützt von .NET Compact Framework | Referenzverträge lesen und dem Grid übergeben
public method Get_Pendenzen Unterstützt von .NET Compact Framework | Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Get_Services Überladen. Unterstützt von .NET Compact Framework | Vertragsleistungen lesen und dem Grid übergeben
public method Get_Vertragselement Unterstützt von .NET Compact Framework |
public method Get_Vertragselement_Referenzen Überladen. Unterstützt von .NET Compact Framework | Referenzverträge lesen und dem Grid übergeben
public method Get_Vertragselementbezeichnung Unterstützt von .NET Compact Framework | Gibt die Bezeichnung eines Vertragselementes zurück
public method Get_Vertragsereignisse Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Vertragskontakte Überladen. Unterstützt von .NET Compact Framework | Kontakte auslesen und dem TrueDBGrid übergeben
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Vertragselement sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method SelectAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Suchen Unterstützt von .NET Compact Framework | Suchen eines Vertragselementes
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragspartnerNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragspartnerNr' in all rows which have as value for this field the value as set in property 'iVertragspartnerNrOld' to the value as set in property 'iVertragspartnerNr'.
public method UpdateAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragstypNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragstypNr' in all rows which have as value for this field the value as set in property 'iVertragstypNrOld' to the value as set in property 'iVertragstypNr'.
public method Vertragspartner_suchen Unterstützt von .NET Compact Framework | Vertragspartner für das Vertragselement suchen
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues Unterstützt von .NET Compact Framework |
private method evh_KeineLeistungSelektiert Unterstützt von .NET Compact Framework | Vertragsleistung physisch löschen, wenn keine Leistung selektiert wurde
private method evh_LeistungSelektiert Unterstützt von .NET Compact Framework | Speichert das Vertragsleistungselement aufgrund der Auswahl im frmServicekaltalog

Felder

public field Aktivitaeten Unterstützt von .NET Compact Framework |
public field Applikationen Unterstützt von .NET Compact Framework |
public field Dokument Unterstützt von .NET Compact Framework |
public field History Unterstützt von .NET Compact Framework |
public field IsLizenzElement Unterstützt von .NET Compact Framework |
public field Kuendigungsfrist Unterstützt von .NET Compact Framework |
public field Kuendigungsfristen Unterstützt von .NET Compact Framework |
public field Lizenzinformationen Unterstützt von .NET Compact Framework |
public field Lizenztypen Unterstützt von .NET Compact Framework |
public field Neuer_Datensatz Unterstützt von .NET Compact Framework |
public field Parentelemente Unterstützt von .NET Compact Framework |
public field Pendenz Unterstützt von .NET Compact Framework |
public field Pendenzen Unterstützt von .NET Compact Framework |
public field Service Unterstützt von .NET Compact Framework |
public field Services Unterstützt von .NET Compact Framework |
private field Stammdaten Unterstützt von .NET Compact Framework |
public field Vertragselement Unterstützt von .NET Compact Framework |
public field VertragselementApplikation Unterstützt von .NET Compact Framework |
public field VertragselementApplikationen Unterstützt von .NET Compact Framework |
public field Vertragselement_Referenz Unterstützt von .NET Compact Framework |
public field Vertragselement_Referenzen Unterstützt von .NET Compact Framework |
public field Vertragsereignis Unterstützt von .NET Compact Framework |
public field Vertragsereignisse Unterstützt von .NET Compact Framework |
public field Vertragskontakt Unterstützt von .NET Compact Framework |
public field Vertragskontakte Unterstützt von .NET Compact Framework |
private field Vertragspartner Unterstützt von .NET Compact Framework |
public field Vertragstypen Unterstützt von .NET Compact Framework |
public field aktivitaet Unterstützt von .NET Compact Framework |
public field daten Unterstützt von .NET Compact Framework | Vertragselement lesen
public field dokumente Unterstützt von .NET Compact Framework |
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |

clsVertragselement -Klasse


clsVertragselement -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            '        vertragstyp.cpMainConnectionProvider = Globals.conn
            '       Vertragstypen = vertragstyp.SelectAll
            Vertragstypen = Stammdaten.Get_Stammdaten("Vertragstyp", "Vertragstyp")

            '          Applikation.cpMainConnectionProvider = Globals.conn
            '         Applikationen = Applikation.SelectAll()
            Applikationen = Stammdaten.Get_Stammdaten("Applikation", "Bezeichnung")

            '            Lizenztyp.cpMainConnectionProvider = Globals.conn
            '           Lizenztypen = Lizenztyp.SelectAll
            Lizenztypen = Stammdaten.Get_Stammdaten("Lizenztyp", "Bezeichnung")

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement-Eigenschaften

clsVertragselement Übersicht

Öffentliche Eigenschaften

public property Vertragspartnername

Unterstützt von .NET Compact Framework
public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property bBefristet_Unbefristet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daGekuendigt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daGekuendigt_per (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daMindestvertragsdauer_bis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daUnterzeichnet_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVersionsdatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVertragsablauf (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property daVertragsbeginn (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iApplikationNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iLizenztypnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iParentID (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragstypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property iVertragstypNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sLizenzdetails (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sNummer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sSuchbegriffe (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework
public property sVersion (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement)

Unterstützt von .NET Compact Framework

clsVertragselement -Klasse


clsVertragselement.Vertragspartnername -Eigenschaft

[Visual Basic]
Public ReadOnly Property Vertragspartnername() As String

Quellcode

[Visual Basic]
        ReadOnly Property Vertragspartnername() As String
            Get
                Try
                    Return Vertragspartner.Get_Vertragspartnername(Me.iVertragspartnerNr.Value)
                Catch ex As Exception
                    Return ""
                End Try
            End Get
        End Property

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement-Methoden

clsVertragselement Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Person einfügen
public method Add_Service Unterstützt von .NET Compact Framework | Neuer Serice/Leistung als Vertragsleistung hinzufügen
public method Check_Is_Parent_Has_Childs Unterstützt von .NET Compact Framework |
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Datensatzes erstellen.
public method Delete Überladen. Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method DeleteAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method DeleteAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method Delete_Vertragselement Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Get_Aktivitaeten Überladen. Unterstützt von .NET Compact Framework | Aktivitaeten lesen und dem Grid übergeben
public method Get_Applikationen Überladen. Unterstützt von .NET Compact Framework | Applikationen lesen und dem Grid übergeben
public method Get_Dokumente Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_History Überladen. Unterstützt von .NET Compact Framework | History lesen und dem Grid übergeben
public method Get_Kuendigungsfristen Überladen. Unterstützt von .NET Compact Framework | Kündiguntsfristen lasen und dem Grid übergeben
public method Get_Pedenzen Unterstützt von .NET Compact Framework | Referenzverträge lesen und dem Grid übergeben
public method Get_Pendenzen Unterstützt von .NET Compact Framework | Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt
public method Get_Services Überladen. Unterstützt von .NET Compact Framework | Vertragsleistungen lesen und dem Grid übergeben
public method Get_Vertragselement Unterstützt von .NET Compact Framework |
public method Get_Vertragselement_Referenzen Überladen. Unterstützt von .NET Compact Framework | Referenzverträge lesen und dem Grid übergeben
public method Get_Vertragselementbezeichnung Unterstützt von .NET Compact Framework | Gibt die Bezeichnung eines Vertragselementes zurück
public method Get_Vertragsereignisse Überladen. Unterstützt von .NET Compact Framework | Dokumente lesen und dem Grid übergeben
public method Get_Vertragskontakte Überladen. Unterstützt von .NET Compact Framework | Kontakte auslesen und dem TrueDBGrid übergeben
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Vertragselement sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragspartnerNr'
public method SelectAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'VertragstypNr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Suchen Unterstützt von .NET Compact Framework | Suchen eines Vertragselementes
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWVertragspartnerNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragspartnerNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragspartnerNr' in all rows which have as value for this field the value as set in property 'iVertragspartnerNrOld' to the value as set in property 'iVertragspartnerNr'.
public method UpdateAllWVertragstypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselement) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'VertragstypNr. This method will Update one or more existing rows in the database. It will reset the field 'VertragstypNr' in all rows which have as value for this field the value as set in property 'iVertragstypNrOld' to the value as set in property 'iVertragstypNr'.
public method Vertragspartner_suchen Unterstützt von .NET Compact Framework | Vertragspartner für das Vertragselement suchen
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Andere Methoden

private method Set_Imagevalues Unterstützt von .NET Compact Framework |
private method evh_KeineLeistungSelektiert Unterstützt von .NET Compact Framework | Vertragsleistung physisch löschen, wenn keine Leistung selektiert wurde
private method evh_LeistungSelektiert Unterstützt von .NET Compact Framework | Speichert das Vertragsleistungselement aufgrund der Auswahl im frmServicekaltalog

clsVertragselement -Klasse


clsVertragselement.Add_New -Methode

Neue Person einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragspartnernr As Integer _
) As Integer

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragspartnernr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement")
            db.Dispose()
            Me.iVertragselementnr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragstypNr = New SqlInt32(CType(1, Int32))
            Me.iVertragspartnerNr = New SqlInt32(CType(Vertragspartnernr, Int32))
            Me.iParentID = New SqlInt32(CType(0, Int32))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sVersion = New SqlString(CType("", String))
            Me.daVersionsdatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daVertragsbeginn = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daVertragsablauf = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daMindestvertragsdauer_bis = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daUnterzeichnet_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daGekuendigt_am = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daGekuendigt_per = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.sNummer = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn

            Me.iApplikationNr = New SqlInt32(CType(0, Int32))
            Me.iLizenztypnr = New SqlInt32(CType(0, Int32))

            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Add_Service -Methode

Neuer Serice/Leistung als Vertragsleistung hinzufügen

[Visual Basic]
Public Function Add_Service( _
   ByRef vertragselementnr As Integer, _
   ByRef ParentForm As Form _
) As Object

Parameter

vertragselementnr
Nr des aktuellen Vertragselementes
ParentForm
Formular welches für die MDI.Parent-Eigenschaft benötigt wird

Quellcode

[Visual Basic]
        Public Function Add_Service(ByRef vertragselementnr As Integer, ByRef ParentForm As Form)
            Dim i As Integer = Service.Add_New(vertragselementnr)
            Dim f As New frmServicekatalog(Service.iServicekatalogNr.Value, False, True, i, True)
            f.MdiParent = ParentForm.MdiParent
            f.Show()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Check_Is_Parent_Has_Childs -Methode

[Visual Basic]
Public Function Check_Is_Parent_Has_Childs( _
   ByVal id As Integer _
) As Boolean

Parameter

id

Quellcode

[Visual Basic]
        Public Function Check_Is_Parent_Has_Childs(ByVal id As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_Vertragselement_check_parent_child"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragselementnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, id))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@anzahl").Value > 0 Then Return True Else Return False
            Catch ex As Exception
                Throw New Exception("sp_Check_Vertragselement::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Create_Copy -Methode

Kopie eines Datensatzes erstellen.

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragselement(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragselementnr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Delete -Methode

Überladungsliste

Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.Delete_Vertragselement -Methode

Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_Vertragselement( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Function Delete_Vertragselement(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragselement(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Get_Aktivitaeten -Methode

Überladungsliste

Aktivitaeten lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Aktivitaeten(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Aktivitaeten(ref C1TrueDBGrid);

Aktivitaeten auslesen und dem Truedbgrid übergeben.

[Visual Basic] Public Function Get_Aktivitaeten(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Aktivitaeten(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


Get_Applikationen -Methode

Überladungsliste

Applikationen lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Applikationen(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Applikationen(ref C1TrueDBGrid);

Applikationen auslesen und dem Truedbgrid übergeben.

[Visual Basic] Public Function Get_Applikationen(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Applikationen(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


Get_Dokumente -Methode

Überladungsliste

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic] Public Function Get_Dokumente(ByRef C1TrueDBGrid, Integer, Optional ImageList) As Object
[C#] public object Get_Dokumente(ref C1TrueDBGrid, int, ImageList);

Dokumente lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Dokumente(ByRef C1TrueDBGrid, Optional ImageList) As Object
[C#] public object Get_Dokumente(ref C1TrueDBGrid, ImageList);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


Get_History -Methode

Überladungsliste

History lesen und dem Grid übergeben

[Visual Basic] Public Function Get_History(ByRef C1TrueDBGrid) As Object
[C#] public object Get_History(ref C1TrueDBGrid);

Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic] Public Function Get_History(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_History(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


Get_Kuendigungsfristen -Methode

Überladungsliste

Kündiguntsfristen lasen und dem Grid übergeben

[Visual Basic] Public Function Get_Kuendigungsfristen(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Kuendigungsfristen(ref C1TrueDBGrid);

Kündiguntsfristen lasen und dem Grid übergeben

[Visual Basic] Public Function Get_Kuendigungsfristen(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Kuendigungsfristen(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.Get_Pedenzen -Methode

Referenzverträge lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Pedenzen( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Pedenzen(ByRef c1data As C1TrueDBGrid)
            Try
                Pendenz.Dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            Pendenzen = New TKB.VV.Sysadmin.DomainTable("Pendenz", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Pendenzen.Tabledata
            c1data.DataMember = Pendenzen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Pendenzen -Methode

Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_Pendenzen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Pendenzen(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Pendenzen = New TKB.VV.Sysadmin.DomainTable("Pendenz", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            For i = 0 To Pendenzen.Tabledata.Tables(0).Rows.Count - 1
                If Pendenzen.Tabledata.Tables(0).Rows(i).Item("Termin") = "01.01.1900" Then
                    Pendenzen.Tabledata.Tables(0).Rows(i).Item("Termin") = System.DBNull.Value
                End If
            Next
            c1data.DataSource = Pendenzen.Tabledata
            c1data.DataMember = Pendenzen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Get_Services -Methode

Überladungsliste

Vertragsleistungen lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Services(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Services(ref C1TrueDBGrid);

Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic] Public Function Get_Services(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Services(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.Get_Vertragselement -Methode

[Visual Basic]
Public Function Get_Vertragselement( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Vertragselement(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragselementnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.daten = Me.SelectOne()
            Me.IsLizenzElement = Me.Lizenzinformationen.Check_Vertragstyp_Fuer_Lizenz(Me.iVertragstypNr.Value)
            Globals.conn.CloseConnection(True)
            Try
                Vertragspartner.Get_Partner(Me.iVertragspartnerNr.Value)
            Catch ex As Exception
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Get_Vertragselement_Referenzen -Methode

Überladungsliste

Referenzverträge lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Vertragselement_Referenzen(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Vertragselement_Referenzen(ref C1TrueDBGrid);

Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic] Public Function Get_Vertragselement_Referenzen(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Vertragselement_Referenzen(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.Get_Vertragselementbezeichnung -Methode

Gibt die Bezeichnung eines Vertragselementes zurück

[Visual Basic]
Public Function Get_Vertragselementbezeichnung( _
   ByVal Vertragselementnr As Integer _
) As String

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Get_Vertragselementbezeichnung(ByVal Vertragselementnr As Integer) As String
            Me.iVertragselementnr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Me.SelectOne()
            Return Me.sBezeichnung.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Get_Vertragsereignisse -Methode

Überladungsliste

Dokumente lesen und dem Grid übergeben

[Visual Basic] Public Function Get_Vertragsereignisse(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Vertragsereignisse(ref C1TrueDBGrid);

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic] Public Function Get_Vertragsereignisse(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Vertragsereignisse(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


Get_Vertragskontakte -Methode

Überladungsliste

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic] Public Function Get_Vertragskontakte(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Vertragskontakte(ref C1TrueDBGrid);

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic] Public Function Get_Vertragskontakte(ByRef C1TrueDBGrid, Integer) As Object
[C#] public object Get_Vertragskontakte(ref C1TrueDBGrid, int);

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.Save_Data -Methode

Vertragselement sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Set_Imagevalues -Methode

[Visual Basic]
Private Sub Set_Imagevalues( _
   ByRef c1data As C1TrueDBGrid, _
   ByRef imglist As ImageList _
)

Parameter

c1data
imglist

Quellcode

[Visual Basic]
        Private Sub Set_Imagevalues(ByRef c1data As C1TrueDBGrid, ByRef imglist As ImageList)

            Dim i As Integer
            Dim s As String
            For i = 0 To dokumente.Rows.Count - 1
                s = dokumente.Rows(i).Item("Filename")
                If Len(s) < 4 Then s = ".div"
                Select Case UCase(s.Substring(Len(s) - 4, 4))
                    Case ".PDF"
                        dokumente.Rows(i).Item("DokIcon") = 0
                    Case ".DOC"
                        dokumente.Rows(i).Item("DokIcon") = 1
                    Case ".XLS"
                        dokumente.Rows(i).Item("DokIcon") = 2
                    Case ".PPT"
                        dokumente.Rows(i).Item("DokIcon") = 3
                    Case ".HTM", "TML", "XML"
                        dokumente.Rows(i).Item("DokIcon") = 4
                    Case ".MSG"
                        dokumente.Rows(i).Item("DokIcon") = 5
                    Case Else
                        dokumente.Rows(i).Item("DokIcon") = 6
                End Select
            Next

            Dim bmp0 As New Bitmap(imglist.Images(0))
            Dim bmp1 As New Bitmap(imglist.Images(1))
            Dim bmp2 As New Bitmap(imglist.Images(2))
            Dim bmp3 As New Bitmap(imglist.Images(3))
            Dim bmp4 As New Bitmap(imglist.Images(4))
            Dim bmp5 As New Bitmap(imglist.Images(5))
            Dim bmp6 As New Bitmap(imglist.Images(6))
            Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v4 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v5 As New C1.Win.C1TrueDBGrid.ValueItem()
            Dim v6 As New C1.Win.C1TrueDBGrid.ValueItem()

            v0.DisplayValue = bmp0
            v0.Value = 0

            v1.DisplayValue = bmp1
            v1.Value = 1

            v2.DisplayValue = bmp2
            v2.Value = 2

            v3.DisplayValue = bmp3
            v3.Value = 3

            v4.DisplayValue = bmp4
            v4.Value = 4

            v5.DisplayValue = bmp5
            v5.Value = 5

            v6.DisplayValue = bmp6
            v6.Value = 6

            c1data.Columns("dokicon").ValueItems.Values.Add(v0)
            c1data.Columns("dokicon").ValueItems.Values.Add(v1)
            c1data.Columns("dokicon").ValueItems.Values.Add(v2)
            c1data.Columns("dokicon").ValueItems.Values.Add(v3)
            c1data.Columns("dokicon").ValueItems.Values.Add(v4)
            c1data.Columns("dokicon").ValueItems.Values.Add(v5)
            c1data.Columns("dokicon").ValueItems.Values.Add(v6)
            c1data.Columns("dokicon").ValueItems.Translate = True

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Suchen -Methode

Suchen eines Vertragselementes

[Visual Basic]
Public Function Suchen( _
   ByRef Vertragselementnr As Integer _
) As Boolean

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Suchen(ByRef Vertragselementnr As Integer) As Boolean
            Dim vesuche As New frmVertragselementSuche
            vesuche.ShowDialog()
            Try
                If vesuche.DialogResult = DialogResult.OK Then
                    Vertragselementnr = vesuche.Vertragselementnr
                    Return True
                Else
                    Vertragselementnr = -1
                    Return False
                End If
            Catch ex As Exception
                Return False
            Finally
                vesuche.dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Vertragspartner_suchen -Methode

Vertragspartner für das Vertragselement suchen

[Visual Basic]
Public Function Vertragspartner_suchen( _
   ByRef Vertragspartnernummer As Integer, _
   ByRef Partnername As TextBox _
) As Boolean

Parameter

Vertragspartnernummer
Partnername

Quellcode

[Visual Basic]
        Public Function Vertragspartner_suchen(ByRef Vertragspartnernummer As Integer, ByRef Partnername As TextBox) As Boolean
            Dim save_Vertragspartnernr As Integer = Vertragspartnernummer
            If Me.Vertragspartner.Vertragspartner_Suchen(Vertragspartnernummer) = True Then
                Me.iVertragspartnerNr = New SqlInt32(CType(Vertragspartnernummer, Int32))
                Partnername.Text = Me.Vertragspartnername
                If Me.iVertragspartnerNr.Value <> save_Vertragspartnernr Then Return True Else Return False
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

clsVertragselement | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselement.evh_KeineLeistungSelektiert -Methode

Vertragsleistung physisch löschen, wenn keine Leistung selektiert wurde

[Visual Basic]
Private Sub evh_KeineLeistungSelektiert( _
   ByVal Vertragsleistungsnr As Integer _
) Handles  _
   evh.KeineLeistungSelektiert

Parameter

Vertragsleistungsnr

Quellcode

[Visual Basic]
        Private Sub evh_KeineLeistungSelektiert(ByVal Vertragsleistungsnr As Integer) Handles evh.KeineLeistungSelektiert
            Service.Delete(Vertragsleistungsnr)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.evh_LeistungSelektiert -Methode

Speichert das Vertragsleistungselement aufgrund der Auswahl im frmServicekaltalog

[Visual Basic]
Private Sub evh_LeistungSelektiert( _
   ByVal Vertragsleistungsnr As Integer, _
   ByVal Servicekatalognr As Integer _
) Handles  _
   evh.LeistungSelektiert

Parameter

Vertragsleistungsnr
Vertragsleistungsnummer
Servicekatalognr
Gewählte ServicekatalogNr

Quellcode

[Visual Basic]
        Private Sub evh_LeistungSelektiert(ByVal Vertragsleistungsnr As Integer, ByVal Servicekatalognr As Integer) Handles evh.LeistungSelektiert
            Service.Get_Vertragsleistung(Vertragsleistungsnr)
            Service.iServicekatalogNr = New SqlInt32(CType(Servicekatalognr, Int32))
            Service.Save_Data()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement | frmServicekatalog


clsVertragselement-Felder

clsVertragselement Übersicht

Felder

public field Aktivitaeten Unterstützt von .NET Compact Framework |
public field Applikationen Unterstützt von .NET Compact Framework |
public field Dokument Unterstützt von .NET Compact Framework |
public field History Unterstützt von .NET Compact Framework |
public field IsLizenzElement Unterstützt von .NET Compact Framework |
public field Kuendigungsfrist Unterstützt von .NET Compact Framework |
public field Kuendigungsfristen Unterstützt von .NET Compact Framework |
public field Lizenzinformationen Unterstützt von .NET Compact Framework |
public field Lizenztypen Unterstützt von .NET Compact Framework |
public field Neuer_Datensatz Unterstützt von .NET Compact Framework |
public field Parentelemente Unterstützt von .NET Compact Framework |
public field Pendenz Unterstützt von .NET Compact Framework |
public field Pendenzen Unterstützt von .NET Compact Framework |
public field Service Unterstützt von .NET Compact Framework |
public field Services Unterstützt von .NET Compact Framework |
private field Stammdaten Unterstützt von .NET Compact Framework |
public field Vertragselement Unterstützt von .NET Compact Framework |
public field VertragselementApplikation Unterstützt von .NET Compact Framework |
public field VertragselementApplikationen Unterstützt von .NET Compact Framework |
public field Vertragselement_Referenz Unterstützt von .NET Compact Framework |
public field Vertragselement_Referenzen Unterstützt von .NET Compact Framework |
public field Vertragsereignis Unterstützt von .NET Compact Framework |
public field Vertragsereignisse Unterstützt von .NET Compact Framework |
public field Vertragskontakt Unterstützt von .NET Compact Framework |
public field Vertragskontakte Unterstützt von .NET Compact Framework |
private field Vertragspartner Unterstützt von .NET Compact Framework |
public field Vertragstypen Unterstützt von .NET Compact Framework |
public field aktivitaet Unterstützt von .NET Compact Framework |
public field daten Unterstützt von .NET Compact Framework | Vertragselement lesen
public field dokumente Unterstützt von .NET Compact Framework |
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |

clsVertragselement -Klasse


Aktivitaeten -Feld

[Visual Basic]
Public Aktivitaeten As DomainTable

Quellcode

[Visual Basic]
        Public Aktivitaeten As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Applikationen -Feld

[Visual Basic]
Public Applikationen As DataTable

Quellcode

[Visual Basic]
        Public Applikationen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Dokument -Feld

[Visual Basic]
Public Dokument As clsDok

Quellcode

[Visual Basic]
        Public Dokument As New TKB.VV.DMS.clsDok

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


History -Feld

[Visual Basic]
Public History As DomainTable

Quellcode

[Visual Basic]
        Public History As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


IsLizenzElement -Feld

[Visual Basic]
Public IsLizenzElement As Boolean

Quellcode

[Visual Basic]
        Public IsLizenzElement As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Kuendigungsfrist -Feld

[Visual Basic]
Public Kuendigungsfrist As clsKuendigungsfrist

Quellcode

[Visual Basic]
        Public Kuendigungsfrist As New TKB.VV.Vertrag.clsKuendigungsfrist

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Kuendigungsfristen -Feld

[Visual Basic]
Public Kuendigungsfristen As DomainTable

Quellcode

[Visual Basic]
        Public Kuendigungsfristen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Lizenzinformationen -Feld

[Visual Basic]
Public Lizenzinformationen As clsLizenzinformationen

Quellcode

[Visual Basic]
        Public Lizenzinformationen As New clsLizenzinformationen

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Lizenztypen -Feld

[Visual Basic]
Public Lizenztypen As DataTable

Quellcode

[Visual Basic]
        Public Lizenztypen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Parentelemente -Feld

[Visual Basic]
Public Parentelemente As clsParentelemente

Quellcode

[Visual Basic]
        Public Parentelemente As New TKB.VV.Vertrag.clsParentelemente

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Pendenz -Feld

[Visual Basic]
Public Pendenz As clsPendenz

Quellcode

[Visual Basic]
        Public Pendenz As New TKB.VV.Vertrag.clsPendenz

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Pendenzen -Feld

[Visual Basic]
Public Pendenzen As DomainTable

Quellcode

[Visual Basic]
        Public Pendenzen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Service -Feld

[Visual Basic]
Public Service As clsVertragsleistung

Quellcode

[Visual Basic]
        Public Service As New TKB.VV.Vertrag.clsVertragsleistung

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Services -Feld

[Visual Basic]
Public Services As DomainTable

Quellcode

[Visual Basic]
        Public Services As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Stammdaten -Feld

[Visual Basic]
Private Stammdaten As clsStammdaten

Quellcode

[Visual Basic]
        Private Stammdaten As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragselement -Feld

[Visual Basic]
Public Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
        Public Vertragselement As TKB.VV.DB.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


VertragselementApplikation -Feld

[Visual Basic]
Public VertragselementApplikation As clsVertragselementApplikation

Quellcode

[Visual Basic]
        Public VertragselementApplikation As New TKB.VV.Vertrag.clsVertragselementApplikation

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


VertragselementApplikationen -Feld

[Visual Basic]
Public VertragselementApplikationen As DomainTable

Quellcode

[Visual Basic]
        Public VertragselementApplikationen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragselement_Referenz -Feld

[Visual Basic]
Public Vertragselement_Referenz As clsReferenzvertrag

Quellcode

[Visual Basic]
        Public Vertragselement_Referenz As New TKB.VV.Vertrag.clsReferenzvertrag

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragselement_Referenzen -Feld

[Visual Basic]
Public Vertragselement_Referenzen As DomainTable

Quellcode

[Visual Basic]
        Public Vertragselement_Referenzen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragsereignis -Feld

[Visual Basic]
Public Vertragsereignis As clsVertragsereignis

Quellcode

[Visual Basic]
        Public Vertragsereignis As New TKB.VV.Vertrag.clsVertragsereignis

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragsereignisse -Feld

[Visual Basic]
Public Vertragsereignisse As DomainTable

Quellcode

[Visual Basic]
        Public Vertragsereignisse As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragskontakt -Feld

[Visual Basic]
Public Vertragskontakt As clsKontakt

Quellcode

[Visual Basic]
        Public Vertragskontakt As New TKB.VV.Vertrag.clsKontakt

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragskontakte -Feld

[Visual Basic]
Public Vertragskontakte As DomainTable

Quellcode

[Visual Basic]
        Public Vertragskontakte As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragspartner -Feld

[Visual Basic]
Private Vertragspartner As clsVertragspartner

Quellcode

[Visual Basic]
        Private Vertragspartner As New TKB.VV.Vertrag.clsVertragspartner

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


Vertragstypen -Feld

[Visual Basic]
Public Vertragstypen As DataTable

Quellcode

[Visual Basic]
        Public Vertragstypen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


aktivitaet -Feld

[Visual Basic]
Public aktivitaet As clsAktivitaet

Quellcode

[Visual Basic]
        Public aktivitaet As New TKB.VV.DB.clsAktivitaet

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


daten -Feld

Vertragselement lesen

[Visual Basic]
Public daten As DataTable

Quellcode

[Visual Basic]
        Public daten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


dokumente -Feld

[Visual Basic]
Public dokumente As DataTable

Quellcode

[Visual Basic]
        Public dokumente As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselementApplikation -Klasse

For a list of all members of this type, see clsVertragselementApplikation-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragselementApplikation

[Visual Basic]
Public Class clsVertragselementApplikation
    Inherits clsVertragselementApplikation

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragselementApplikation-Member


clsVertragselementApplikation-Member

clsVertragselementApplikation Übersicht

Öffentliche Konstruktoren

public constructor clsVertragselementApplikation -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragselementApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_VertragselementApplikation Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_VertragselementApplikation Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


clsVertragselementApplikation -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            MyBase.new()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation-Eigenschaften

clsVertragselementApplikation Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iVertragselementApplikationnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


clsVertragselementApplikation-Methoden

clsVertragselementApplikation Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Vertragselement_Referenz erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Physisches Löschen eines Datensatzes.
public method Delete_VertragselementApplikation Unterstützt von .NET Compact Framework | Löschen eines Datensatzes.
public method Get_VertragselementApplikation Unterstützt von .NET Compact Framework | Vertragselement_Referenz lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragselementApplikation) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method dispose Überladen. Unterstützt von .NET Compact Framework |

clsVertragselementApplikation -Klasse


clsVertragselementApplikation.Add_New -Methode

Neue Vertragselement_Referenz erstellen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragselement_Referenz")
            db.Dispose()
            Me.iVertragselementApplikationnr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementnr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


Delete -Methode

Überladungsliste

Physisches Löschen eines Datensatzes.

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

Siehe auch

clsVertragselementApplikation | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselementApplikation.Delete_VertragselementApplikation -Methode

Löschen eines Datensatzes.

[Visual Basic]
Public Function Delete_VertragselementApplikation( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_VertragselementApplikation(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_VertragselementApplikation(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.Get_VertragselementApplikation -Methode

Vertragselement_Referenz lesen

[Visual Basic]
Public Function Get_VertragselementApplikation( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_VertragselementApplikation(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragselementApplikationnr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iVertragselementApplikationnr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


dispose -Methode

Überladungsliste

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

Siehe auch

clsVertragselementApplikation | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragselementApplikation-Felder

clsVertragselementApplikation Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragselementApplikation -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragsereignis -Klasse

For a list of all members of this type, see clsVertragsereignis-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsereignis

[Visual Basic]
Public Class clsVertragsereignis
    Inherits clsVertragsereignis

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragsereignis-Member


clsVertragsereignis-Member

clsVertragsereignis Übersicht

Öffentliche Konstruktoren

public constructor clsVertragsereignis -Konstructor

Unterstützt von .NET Compact Framework

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property bInklMwSt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daEnde (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daStart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property fBetrag (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignisNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignistypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignistypNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iKostenartNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iPeriodizitaetNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVorlaufzeit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neues VertragsEreignis
public method Check_Kuendigungsdaten Unterstützt von .NET Compact Framework |
public method Check_Zahlungsdaten Unterstützt von .NET Compact Framework |
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines VertragsEreignisses erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | VertragsEreignis inaktivieren
public method DeleteAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method DeleteAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method DeleteAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Delete_Ereignis Unterstützt von .NET Compact Framework | VertragsEreignis inaktivieren
public method Get_Ereignis Unterstützt von .NET Compact Framework | Vertragsereignis auslesen
public method Get_History Unterstützt von .NET Compact Framework | History lesen und dem Grid übergeben
public method Get_Vertragsereignisse Überladen. Unterstützt von .NET Compact Framework | Vertragsereignis zu einem Vertragselement auselesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | VertragsEreignis speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method SelectAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method SelectAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'EreignistypNr. This method will Update one or more existing rows in the database. It will reset the field 'EreignistypNr' in all rows which have as value for this field the value as set in property 'iEreignistypNrOld' to the value as set in property 'iEreignistypNr'.
public method UpdateAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'KostenartNr. This method will Update one or more existing rows in the database. It will reset the field 'KostenartNr' in all rows which have as value for this field the value as set in property 'iKostenartNrOld' to the value as set in property 'iKostenartNr'.
public method UpdateAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.
public method dispose Überladen. Unterstützt von .NET Compact Framework | Destructor Dispose

Andere Methoden

private method Delete_Vertragsereignisse

Unterstützt von .NET Compact Framework

 Inaktivieren aller aktiven Vertragsereignisse zu einem Vertragselement

Felder

public field Ereignistypen

Unterstützt von .NET Compact Framework
public field History

Unterstützt von .NET Compact Framework
public field Kostenarten

Unterstützt von .NET Compact Framework
public field Kuendigungsfrist

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Periodizitäten

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
public field Vertragsereignis

Unterstützt von .NET Compact Framework
public field Vertragsereignisse

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


clsVertragsereignis -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Sub New()
            Kuendigungsfrist = Stammdaten.Get_Stammdaten("Kuendigungsfristen", "Sort")
            Periodizitäten = Stammdaten.Get_Stammdaten("Periodizitaet", "Sort")
            Ereignistypen = Stammdaten.Get_Stammdaten("Ereignistyp", "Bezeichnung")
            Kostenarten = Stammdaten.Get_Stammdaten("Kostenart", "Bezeichnung")
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis-Eigenschaften

clsVertragsereignis Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property bInklMwSt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daDatum (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daEnde (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property daStart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property fBetrag (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignisNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignistypNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iEreignistypNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iKostenartNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iKostenartNrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iKuendigungsfristnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iMandantNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iPeriodizitaetNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVertragselementnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVertragselementnrOld (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property iVorlaufzeit (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sBezeichnung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


clsVertragsereignis-Methoden

clsVertragsereignis Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neues VertragsEreignis
public method Check_Kuendigungsdaten Unterstützt von .NET Compact Framework |
public method Check_Zahlungsdaten Unterstützt von .NET Compact Framework |
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines VertragsEreignisses erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | VertragsEreignis inaktivieren
public method DeleteAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method DeleteAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method DeleteAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Delete method for a foreign key. This method will Delete one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method Delete_Ereignis Unterstützt von .NET Compact Framework | VertragsEreignis inaktivieren
public method Get_Ereignis Unterstützt von .NET Compact Framework | Vertragsereignis auslesen
public method Get_History Unterstützt von .NET Compact Framework | History lesen und dem Grid übergeben
public method Get_Vertragsereignisse Überladen. Unterstützt von .NET Compact Framework | Vertragsereignis zu einem Vertragselement auselesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | VertragsEreignis speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'EreignistypNr'
public method SelectAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'KostenartNr'
public method SelectAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method for a foreign key. This method will Select one or more rows from the database, based on the Foreign Key 'Vertragselementnr'
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method UpdateAllWEreignistypNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'EreignistypNr. This method will Update one or more existing rows in the database. It will reset the field 'EreignistypNr' in all rows which have as value for this field the value as set in property 'iEreignistypNrOld' to the value as set in property 'iEreignistypNr'.
public method UpdateAllWKostenartNrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'KostenartNr. This method will Update one or more existing rows in the database. It will reset the field 'KostenartNr' in all rows which have as value for this field the value as set in property 'iKostenartNrOld' to the value as set in property 'iKostenartNr'.
public method UpdateAllWVertragselementnrLogic (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsereignis) Unterstützt von .NET Compact Framework | Purpose: Update method for updating one or more rows using the Foreign Key 'Vertragselementnr. This method will Update one or more existing rows in the database. It will reset the field 'Vertragselementnr' in all rows which have as value for this field the value as set in property 'iVertragselementnrOld' to the value as set in property 'iVertragselementnr'.
public method dispose Überladen. Unterstützt von .NET Compact Framework | Destructor Dispose

Andere Methoden

private method Delete_Vertragsereignisse

Unterstützt von .NET Compact Framework

 Inaktivieren aller aktiven Vertragsereignisse zu einem Vertragselement

clsVertragsereignis -Klasse


clsVertragsereignis.Add_New -Methode

Neues VertragsEreignis

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Rückgabewert

Key des neuen VertragsEreigniss

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Ereignis")
            db.Dispose()
            Me.iEreignisNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementnr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iEreignistypNr = New SqlInt32(CType(1, Int32))
            Me.iKostenartNr = New SqlInt32(CType(1, Int32))
            Me.iPeriodizitaetNr = New SqlInt32(CType(1, Int32))
            Me.daDatum = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daEnde = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.daStart = New SqlDateTime(CType(SqlDateTime.Null, DateTime))
            Me.iVorlaufzeit = New SqlInt32(CType(0, Int32))
            Me.fBetrag = New SqlDouble(CType(0, Double))
            Me.sBeschreibung = New SqlString(CType("", String))
            Me.sBezeichnung = New SqlString(CType("", String))
            Me.bInklMwSt = New SqlBoolean(CType(False, Boolean))

            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Me.iKuendigungsfristnr = New SqlInt32(CType(Me.Kuendigungsfrist.Rows(0).Item(0), Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Check_Kuendigungsdaten -Methode

[Visual Basic]
Public Function Check_Kuendigungsdaten( _
   ByVal Key As Integer _
) As Boolean

Parameter

Key

Quellcode

[Visual Basic]
        Public Function Check_Kuendigungsdaten(ByVal Key As Integer) As Boolean
            For Each dr As DataRow In Me.Ereignistypen.Rows
                If dr.Item("Ereignistypnr") = Key And dr.Item("Kuendigung") = True Then
                    Return True
                End If
            Next
            Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Check_Zahlungsdaten -Methode

[Visual Basic]
Public Function Check_Zahlungsdaten( _
   ByVal Key As Integer _
) As Boolean

Parameter

Key

Quellcode

[Visual Basic]
        Public Function Check_Zahlungsdaten(ByVal Key As Integer) As Boolean
            For Each dr As DataRow In Me.Ereignistypen.Rows
                If dr.Item("Ereignistypnr") = Key And dr.Item("Zahlung") = True Then
                    Return True
                End If
            Next
            Return False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Create_Copy -Methode

Kopie eines VertragsEreignisses erstellen

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Ereignis(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Ereignis")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iEreignisNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Delete -Methode

Überladungsliste

VertragsEreignis inaktivieren

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsVertragsereignis | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragsereignis.Delete_Ereignis -Methode

VertragsEreignis inaktivieren

[Visual Basic]
Public Function Delete_Ereignis( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Ereignis(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Ereignis(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Delete_Vertragsereignisse()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Delete_Vertragsereignisse -Methode

Inaktivieren aller aktiven Vertragsereignisse zu einem Vertragselement

[Visual Basic]
Private Sub Delete_Vertragsereignisse()

Quellcode

[Visual Basic]
        Private Sub Delete_Vertragsereignisse()
            Dim i As Integer
            For i = 0 To Me.Vertragsereignisse.Tabledata.Tables(0).Rows.Count - 1
                If Me.Vertragsereignisse.Tabledata.Tables(0).Rows(i).Item("Aktiv") = True Then
                    Me.Delete_Ereignis(Me.Vertragsereignisse.Tabledata.Tables(0).Rows(i).Item("Ereignisnr"))
                End If
            Next
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Get_Ereignis -Methode

Vertragsereignis auslesen

[Visual Basic]
Public Function Get_Ereignis( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr
Nr des VertragsEreigniss

Quellcode

[Visual Basic]
        Public Function Get_Ereignis(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iEreignisNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
            Vertragselement.cpMainConnectionProvider = Globals.conn
            Vertragselement.iVertragselementnr = New SqlInt32(CType(Me.iVertragselementnr.Value, Int32))
            Vertragselement.SelectOne()
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Get_History -Methode

History lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_History( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit History

Quellcode

[Visual Basic]
        Public Function Get_History(ByRef c1data As C1TrueDBGrid)
            Try
                History = Nothing
            Catch ex As Exception

            End Try
            History = New TKB.VV.Sysadmin.DomainTable("History_Ereignis", Me.iEreignisNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = History.Tabledata
            c1data.DataMember = History.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Get_Vertragsereignisse -Methode

Überladungsliste

Kontaktpersonen zu einem VertragsEreignis auslesen

[Visual Basic] Public Function Get_Vertragsereignisse() As DataSet
[C#] public DataSet Get_Vertragsereignisse();

Vertragsereignis zu einem Vertragselement auselesen

[Visual Basic] Public Function Get_Vertragsereignisse(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Vertragsereignisse(ref C1TrueDBGrid);

clsVertragsereignis | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragsereignis.Save_Data -Methode

VertragsEreignis speichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iEreignisNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


dispose -Methode

Überladungsliste

Destructor Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

clsVertragsereignis | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragsereignis-Felder

clsVertragsereignis Übersicht

Felder

public field Ereignistypen

Unterstützt von .NET Compact Framework
public field History

Unterstützt von .NET Compact Framework
public field Kostenarten

Unterstützt von .NET Compact Framework
public field Kuendigungsfrist

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Periodizitäten

Unterstützt von .NET Compact Framework
private field Stammdaten

Unterstützt von .NET Compact Framework
public field Vertragselement

Unterstützt von .NET Compact Framework
public field Vertragsereignis

Unterstützt von .NET Compact Framework
public field Vertragsereignisse

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsereignis -Klasse


Ereignistypen -Feld

[Visual Basic]
Public Ereignistypen As DataTable

Quellcode

[Visual Basic]
        Public Ereignistypen As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


History -Feld

[Visual Basic]
Public History As DomainTable

Quellcode

[Visual Basic]
        Public History As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Kostenarten -Feld

[Visual Basic]
Public Kostenarten As DataTable

Quellcode

[Visual Basic]
        Public Kostenarten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Kuendigungsfrist -Feld

[Visual Basic]
Public Kuendigungsfrist As DataTable

Quellcode

[Visual Basic]
        Public Kuendigungsfrist As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Periodizitäten -Feld

[Visual Basic]
Public Periodizitäten As DataTable

Quellcode

[Visual Basic]
        Public Periodizitäten As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Stammdaten -Feld

[Visual Basic]
Private Stammdaten As clsStammdaten

Quellcode

[Visual Basic]
        Private Stammdaten As New TKB.VV.Stammdaten.clsStammdaten

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Vertragselement -Feld

[Visual Basic]
Public Vertragselement As clsVertragselement

Quellcode

[Visual Basic]
        Public Vertragselement As New TKB.VV.DB.clsVertragselement

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Vertragsereignis -Feld

[Visual Basic]
Public Vertragsereignis As clsVertragsereignis

Quellcode

[Visual Basic]
        Public Vertragsereignis As New TKB.VV.DB.clsVertragsereignis

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


Vertragsereignisse -Feld

[Visual Basic]
Public Vertragsereignisse As DomainTable

Quellcode

[Visual Basic]
        Public Vertragsereignisse As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsleistung -Klasse

For a list of all members of this type, see clsVertragsleistung-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsleistung

[Visual Basic]
Public Class clsVertragsleistung
    Inherits clsVertragsleistung

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragsleistung-Member


clsVertragsleistung-Member

clsVertragsleistung Übersicht

Öffentliche Konstruktoren

public constructor clsVertragsleistung -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iServicekatalogNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iVertragsleistungNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Delete_Vertragsleistung Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Vertragsleistung Unterstützt von .NET Compact Framework | Vertragsleistung lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


clsVertragsleistung-Eigenschaften

clsVertragsleistung Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iServicekatalogNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iVertragselementNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property iVertragsleistungNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


clsVertragsleistung-Methoden

clsVertragsleistung Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neue Kuendigungsfrist einfügen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Delete_Vertragsleistung Unterstützt von .NET Compact Framework | Löschen eines Datensatzes erstellen.
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Vertragsleistung Unterstützt von .NET Compact Framework | Vertragsleistung lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Daten sichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragsleistung) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsVertragsleistung -Klasse


clsVertragsleistung.Add_New -Methode

Neue Kuendigungsfrist einfügen

[Visual Basic]
Public Function Add_New( _
   ByVal Vertragselementnr As Integer _
) As Integer

Parameter

Vertragselementnr

Quellcode

[Visual Basic]
        Public Function Add_New(ByVal Vertragselementnr As Integer) As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragsleistung")
            db.Dispose()
            Me.iVertragsleistungNr = New SqlInt32(CType(newkey, Int32))
            Me.iVertragselementNr = New SqlInt32(CType(Vertragselementnr, Int32))
            Me.iServicekatalogNr = New SqlInt32(CType(1, Int32))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


Delete -Methode

Überladungsliste

Löschen eines Datensatzes erstellen.

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsVertragsleistung | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragsleistung.Delete_Vertragsleistung -Methode

Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Function Delete_Vertragsleistung( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Vertragsleistung(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragsleistung(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.Get_Vertragsleistung -Methode

Vertragsleistung lesen

[Visual Basic]
Public Function Get_Vertragsleistung( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Vertragsleistung(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragsleistungNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung.Save_Data -Methode

Daten sichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Return Me.iVertragsleistungNr.Value
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragsleistung-Felder

clsVertragsleistung Übersicht

Felder

public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragsleistung -Klasse


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsVertragspartner -Klasse

For a list of all members of this type, see clsVertragspartner-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsVertragspartner
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragspartner

[Visual Basic]
Public Class clsVertragspartner
    Inherits clsVertragspartner

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragspartner-Member


clsVertragspartner-Member

clsVertragspartner Übersicht

Öffentliche Konstruktoren

public constructor clsVertragspartner -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sInternet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sNameZ1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sNameZ2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sOrt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sPLZ (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sPostfach (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sStrasse (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sTelefax (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sTelefon (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neuer Vertragspartner
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Vertragspartners erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Vertragspartner physisch löschen
public method Delete_Partner Unterstützt von .NET Compact Framework | Vertragspartner inaktivieren
public method Get_Kontaktpersonen Überladen. Unterstützt von .NET Compact Framework | Kontaktpersonen zu einem Vertragspartner auslesen
public method Get_Partner Unterstützt von .NET Compact Framework | Vertragspartener auslesen
public method Get_Vertragspartnerliste Unterstützt von .NET Compact Framework |
public method Get_Vertragspartnername Unterstützt von .NET Compact Framework | Standard-Vertragspartnername auslesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Vertragspartner speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragspartner_Suchen Unterstützt von .NET Compact Framework | Vertragspartner suchen
public method dispose Überladen. Unterstützt von .NET Compact Framework | Destructor Dispose

Andere Methoden

private method Delete_Kontaktpersonen Unterstützt von .NET Compact Framework | Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner
private method Load_Tree Unterstützt von .NET Compact Framework | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen

Felder

public field Kontaktperson

Unterstützt von .NET Compact Framework
public field Kontaktpersonen

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Vertragspartnerliste

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


clsVertragspartner-Eigenschaften

clsVertragspartner Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMandantnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecurityLevelNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property iVertragspartnerNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEMail (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sInternet (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sNameZ1 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sNameZ2 (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sOrt (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sPLZ (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sPostfach (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sStrasse (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sTelefax (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework
public property sTelefon (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner)

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


clsVertragspartner-Methoden

clsVertragspartner Übersicht

Öffentliche Methoden

public method Add_New Unterstützt von .NET Compact Framework | Neuer Vertragspartner
public method Create_Copy Unterstützt von .NET Compact Framework | Kopie eines Vertragspartners erstellen
public method Delete Überladen. Unterstützt von .NET Compact Framework | Vertragspartner physisch löschen
public method Delete_Partner Unterstützt von .NET Compact Framework | Vertragspartner inaktivieren
public method Get_Kontaktpersonen Überladen. Unterstützt von .NET Compact Framework | Kontaktpersonen zu einem Vertragspartner auslesen
public method Get_Partner Unterstützt von .NET Compact Framework | Vertragspartener auslesen
public method Get_Vertragspartnerliste Unterstützt von .NET Compact Framework |
public method Get_Vertragspartnername Unterstützt von .NET Compact Framework | Standard-Vertragspartnername auslesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method Save_Data Unterstützt von .NET Compact Framework | Vertragspartner speichern
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsVertragspartner) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.
public method Vertragspartner_Suchen Unterstützt von .NET Compact Framework | Vertragspartner suchen
public method dispose Überladen. Unterstützt von .NET Compact Framework | Destructor Dispose

Andere Methoden

private method Delete_Kontaktpersonen Unterstützt von .NET Compact Framework | Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner
private method Load_Tree Unterstützt von .NET Compact Framework | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen

clsVertragspartner -Klasse


clsVertragspartner.Add_New -Methode

Neuer Vertragspartner

[Visual Basic]
Public Function Add_New() As Integer

Rückgabewert

Key des neuen Vertragspartners

Quellcode

[Visual Basic]
        Public Function Add_New() As Integer
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragspartner")
            db.Dispose()
            Me.iVertragspartnerNr = New SqlInt32(CType(newkey, Int32))
            Me.sNameZ1 = New SqlString(CType("", String))
            Me.sNameZ2 = New SqlString(CType("", String))
            Me.sStrasse = New SqlString(CType("", String))
            Me.sPostfach = New SqlString(CType("", String))
            Me.sPLZ = New SqlString(CType("", String))
            Me.sOrt = New SqlString(CType("", String))
            Me.sTelefon = New SqlString(CType("", String))
            Me.sTelefax = New SqlString(CType("", String))
            Me.sEMail = New SqlString(CType("", String))
            Me.sInternet = New SqlString(CType("", String))
            Me.sBemerkung = New SqlString(CType("", String))
            Me.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.iSecurityLevelNr = New SqlInt32(CType(0, Int32))
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Create_Copy -Methode

Kopie eines Vertragspartners erstellen

[Visual Basic]
Public Function Create_Copy( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Create_Copy(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Partner(Basenr)
            End If
            Dim db As New TKB.VV.DB.clsMyKey_Tabelle
            db.cpMainConnectionProvider = Globals.conn
            Dim newkey = db.get_dbkey("Vertragspartner")
            db.Dispose()

            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragspartnerNr = New SqlInt32(CType(newkey, Int32))
            Me.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Insert()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = True
            Return newkey
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


Delete -Methode

Überladungsliste

Vertragspartner physisch löschen

[Visual Basic] Public Overloads Function Delete(Optional Integer) As Integer
[C#] public int Delete(int);

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Public Overridable Function Delete() As Boolean
[C#] public virtual bool Delete();

clsVertragspartner | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragspartner.Delete_Kontaktpersonen -Methode

Inaktivieren aller aktiven Kontaktpersonen zu einem Vertragspartner

[Visual Basic]
Private Sub Delete_Kontaktpersonen()

Quellcode

[Visual Basic]
        Private Sub Delete_Kontaktpersonen()
            Dim i As Integer
            For i = 0 To Me.Kontaktpersonen.Tabledata.Tables(0).Rows.Count - 1
                If Me.Kontaktpersonen.Tabledata.Tables(0).Rows(i).Item("Aktiv") = True Then
                    Me.Kontaktperson.Delete_Kontakt(Me.Kontaktpersonen.Tabledata.Tables(0).Rows(i).Item("PersonNr"))
                End If
            Next
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Delete_Partner -Methode

Vertragspartner inaktivieren

[Visual Basic]
Public Function Delete_Partner( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Delete_Partner(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Partner(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Delete_Kontaktpersonen()
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


Get_Kontaktpersonen -Methode

Überladungsliste

Kontaktpersonen zu einem Vertragspartner auslesen

[Visual Basic] Public Function Get_Kontaktpersonen() As DataSet
[C#] public DataSet Get_Kontaktpersonen();

Kontaktpersonen zu einem Vertragspartner auslesen

[Visual Basic] Public Function Get_Kontaktpersonen(ByRef C1TrueDBGrid) As Object
[C#] public object Get_Kontaktpersonen(ref C1TrueDBGrid);

clsVertragspartner | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragspartner.Get_Partner -Methode

Vertragspartener auslesen

[Visual Basic]
Public Function Get_Partner( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr
Nr des Vertragspartners

Quellcode

[Visual Basic]
        Public Function Get_Partner(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iVertragspartnerNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Get_Vertragspartnerliste -Methode

[Visual Basic]
Public Function Get_Vertragspartnerliste( _
   ByVal Suchstring As String, _
   ByRef tree As TreeView _
) As Object

Parameter

Suchstring
tree

Quellcode

[Visual Basic]
        Public Function Get_Vertragspartnerliste(ByVal Suchstring As String, ByRef tree As TreeView)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_vertragspartner"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@SuchString", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Suchstring))
                sdaAdapter.Fill(dtToReturn)
                Load_Tree(tree, dtToReturn)
                Me.Vertragspartnerliste = dtToReturn
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Get_Vertragspartnername -Methode

Standard-Vertragspartnername auslesen

[Visual Basic]
Public Function Get_Vertragspartnername( _
   ByVal Vertragspartnernr As Integer _
) As String

Parameter

Vertragspartnernr
Nummer des Vertragspartners

Rückgabewert

Name des Vertragspartners

Quellcode

[Visual Basic]
        Public Function Get_Vertragspartnername(ByVal Vertragspartnernr As Integer) As String
            Get_Partner(Vertragspartnernr)
            Try
                Return Me.sNameZ1 + " " + Me.sNameZ2 + ", " + Me.sOrt
            Catch ex As Exception
                Return ""
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Load_Tree -Methode

Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen

[Visual Basic]
Private Function Load_Tree( _
   ByRef Tree As TreeView, _
   ByVal dt As DataTable _
) As Object

Parameter

Tree
dt

Quellcode

[Visual Basic]
        Private Function Load_Tree(ByRef Tree As TreeView, ByVal dt As DataTable)
            fnt_Strikeout = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Strikeout)
            fnt_normal = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Regular)

            Tree.Enabled = False
            Tree.Nodes.Clear()
            For Each dr As DataRow In dt.Rows
                Dim tn As New TreeNode
                tn.Text = dr.Item("Description")
                tn.Tag = dr.Item("Vertragspartnernr")
                If dr.Item("aktiv") = True Then
                    tn.ImageIndex = 0
                    tn.SelectedImageIndex = 0
                    tn.StateImageIndex = 0
                Else
                    tn.ImageIndex = 6
                    tn.SelectedImageIndex = 6
                    tn.StateImageIndex = 6
                End If
                Tree.Nodes.Add(tn)
            Next
            Tree.Enabled = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Save_Data -Methode

Vertragspartner speichern

[Visual Basic]
Public Function Save_Data() As Integer

Quellcode

[Visual Basic]
        Public Function Save_Data() As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
            Return Me.iVertragspartnerNr.Value
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Vertragspartner_Suchen -Methode

Vertragspartner suchen

[Visual Basic]
Public Function Vertragspartner_Suchen( _
   ByRef Vertragspartnernr As Integer _
) As Boolean

Parameter

Vertragspartnernr

Quellcode

[Visual Basic]
        Public Function Vertragspartner_Suchen(ByRef Vertragspartnernr As Integer) As Boolean
            Dim vpsuche As New frmVertragspartnerSuche
            vpsuche.ShowDialog()
            Try
                If vpsuche.DialogResult = DialogResult.OK Then
                    Vertragspartnernr = vpsuche.Vertragspartnernr
                    Return True
                Else
                    Vertragspartnernr = -1
                    Return False
                End If
            Catch ex As Exception
                Return False
            Finally
                vpsuche.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


dispose -Methode

Überladungsliste

Destructor Dispose

[Visual Basic] Public Overloads Sub dispose()
[C#] public System.Void dispose();

(Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

[Visual Basic] Protected Overloads Overridable Sub Dispose(Boolean)
[C#] protected virtual System.Void Dispose(bool);

clsVertragspartner | Vertragsverwaltung.TKB.VV.Vertrag


clsVertragspartner-Felder

clsVertragspartner Übersicht

Felder

public field Kontaktperson

Unterstützt von .NET Compact Framework
public field Kontaktpersonen

Unterstützt von .NET Compact Framework
public field Neuer_Datensatz

Unterstützt von .NET Compact Framework
public field Vertragspartnerliste

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework
protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsVertragspartner -Klasse


Kontaktperson -Feld

[Visual Basic]
Public Kontaktperson As clsPersonen

Quellcode

[Visual Basic]
        Public Kontaktperson As New TKB.VV.Vertrag.clsPersonen

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


Kontaktpersonen -Feld

[Visual Basic]
Public Kontaktpersonen As DomainTable

Quellcode

[Visual Basic]
        Public Kontaktpersonen As TKB.VV.Sysadmin.DomainTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


Neuer_Datensatz -Feld

[Visual Basic]
Public Neuer_Datensatz As Boolean

Quellcode

[Visual Basic]
        Public Neuer_Datensatz As Boolean = False

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


Vertragspartnerliste -Feld

[Visual Basic]
Public Vertragspartnerliste As DataTable

Quellcode

[Visual Basic]
        Public Vertragspartnerliste As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


fnt_Strikeout -Feld

[Visual Basic]
Public fnt_Strikeout As Font

Quellcode

[Visual Basic]
        Public fnt_Strikeout As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


fnt_normal -Feld

[Visual Basic]
Public fnt_normal As Font

Quellcode

[Visual Basic]
        Public fnt_normal As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragsuebersicht_Strukturen -Klasse

For a list of all members of this type, see clsVertragsuebersicht_Strukturen-Member.

System.Object
Vertragsverwaltung.TKB.VV.Vertrag.clsVertragsuebersicht_Strukturen

[Visual Basic]
Public Class clsVertragsuebersicht_Strukturen

Forderungen

Namespace: Vertragsverwaltung.TKB.VV.Vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsVertragsuebersicht_Strukturen-Member


clsVertragsuebersicht_Strukturen-Member

clsVertragsuebersicht_Strukturen Übersicht

Öffentliche Methoden

public method Get_Struktur Unterstützt von .NET Compact Framework | Treedaten auselsen
public method Load_SubStruktur Unterstützt von .NET Compact Framework | Datenstruktur für den Tree lasen
public method Update_Vertragsuebersicht Unterstützt von .NET Compact Framework | Vertrasgdetail abhängig des gewählten Nodes auslesen

Andere Methoden

private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method Get_Treedata Unterstützt von .NET Compact Framework | Auslesen der Partner für die Vertragsuebersicht
private method Get_Vertragsdetails Unterstützt von .NET Compact Framework | Laden der Substruktur
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Tree Unterstützt von .NET Compact Framework | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

Felder

private field SelectionType

Unterstützt von .NET Compact Framework
private field TreeData

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework
private field xVertragspartnernr

Unterstützt von .NET Compact Framework

clsVertragsuebersicht_Strukturen -Klasse


clsVertragsuebersicht_Strukturen-Methoden

clsVertragsuebersicht_Strukturen Übersicht

Öffentliche Methoden

public method Get_Struktur Unterstützt von .NET Compact Framework | Treedaten auselsen
public method Load_SubStruktur Unterstützt von .NET Compact Framework | Datenstruktur für den Tree lasen
public method Update_Vertragsuebersicht Unterstützt von .NET Compact Framework | Vertrasgdetail abhängig des gewählten Nodes auslesen

Andere Methoden

private method Get_SubStruktur Unterstützt von .NET Compact Framework | Laden der Substruktur
private method Get_Treedata Unterstützt von .NET Compact Framework | Auslesen der Partner für die Vertragsuebersicht
private method Get_Vertragsdetails Unterstützt von .NET Compact Framework | Laden der Substruktur
private method LoadNode Unterstützt von .NET Compact Framework | Tree aufbauen
private method Load_Tree Unterstützt von .NET Compact Framework | Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen
private method RecursivelyLoadNode Unterstützt von .NET Compact Framework | Child-Nodes hinzufügen
private method Update_Node Unterstützt von .NET Compact Framework | Parent-Beziehung herstellen und Struktur abfüllen

clsVertragsuebersicht_Strukturen -Klasse


clsVertragsuebersicht_Strukturen.Get_Struktur -Methode

Treedaten auselsen

[Visual Basic]
Public Function Get_Struktur( _
   ByRef tree As TreeView, _
   Optional ByVal SelectionType As Integer = 0, _
   Optional ByVal Aktiv As Boolean = True, _
   Optional ByVal suchtype As Integer = 0, _
   Optional ByVal suchstring As String = "", _
   Optional ByVal partnernr As Integer = 0 _
) As Object

Parameter

tree
Erforderlich.
SelectionType
Neu: Nur noc Selectiontype "Vertragspartner"
Aktiv
1: Nur aktive Partner 0: Alle partner
suchtype
1: Suche nach Vertragspartner 2: Suche nach Vertragselement
suchstring
Optional. Der Standardwert ist "".
partnernr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Function Get_Struktur(ByRef tree As TreeView, Optional ByVal SelectionType As Integer = 0, Optional ByVal Aktiv As Boolean = True, Optional ByVal suchtype As Integer = 0, Optional ByVal suchstring As String = "", Optional ByVal partnernr As Integer = 0)
            Me.TreeData = Get_Treedata(SelectionType, Aktiv, suchtype, suchstring, partnernr)
            Select Case SelectionType
                Case 0
                    Me.SelectionType = "Vertragspartner"
                Case 1
                    Me.SelectionType = "Vertragstyp"
                Case Else
                    Me.SelectionType = "Unknown"
            End Select
            Load_Tree(tree)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Get_SubStruktur -Methode

Laden der Substruktur

[Visual Basic]
Private Function Get_SubStruktur( _
   ByVal vertragstypnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Details_anzeigen As Integer, _
   ByVal Suchstring As String _
) As DataTable

Parameter

vertragstypnr
Vertragspartnernr
Nummer des aktuellen Vertragspartners
Details_anzeigen
Suchstring

Quellcode

[Visual Basic]
        Private Function Get_SubStruktur(ByVal vertragstypnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Details_anzeigen As Integer, ByVal Suchstring As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_struktur"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragstypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertragstypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Details", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Details_anzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Suchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Suchstring))

                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Get_Treedata -Methode

Auslesen der Partner für die Vertragsuebersicht

[Visual Basic]
Private Function Get_Treedata( _
   ByVal Selectiontype As Integer, _
   ByVal aktiv As Boolean, _
   Optional ByVal suchtype As Integer = 0, _
   Optional ByVal suchstring As String = "", _
   Optional ByVal Partnernr As Integer = 0 _
) As DataTable

Parameter

Selectiontype
Vertragspartner oder Vertragstyp
aktiv
Aktiv=0
suchtype
Optional. Der Standardwert ist 0.
suchstring
Optional. Der Standardwert ist "".
Partnernr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Private Function Get_Treedata(ByVal Selectiontype As Integer, ByVal aktiv As Boolean, Optional ByVal suchtype As Integer = 0, Optional ByVal suchstring As String = "", Optional ByVal Partnernr As Integer = 0) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_TreeRoot"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@SelectionType", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Selectiontype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, aktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Suchtype", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, suchtype))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@SuchString", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, suchstring))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Get_Vertragsdetails -Methode

Laden der Substruktur

[Visual Basic]
Private Function Get_Vertragsdetails( _
   ByVal Elementtyp As String, _
   ByVal EntryRoot As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Suchstring As String _
) As Object

Parameter

Elementtyp
EntryRoot
Vertragspartnernr
Nummer des aktuellen Vertragspartners
Suchstring

Quellcode

[Visual Basic]
        Private Function Get_Vertragsdetails(ByVal Elementtyp As String, ByVal EntryRoot As Integer, ByVal Vertragspartnernr As Integer, ByVal Suchstring As String)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_vertragsuebersicht_get_Details"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Elementtyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Elementtyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@EntryRoot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, EntryRoot))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertragspartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Vertragspartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Suchstring))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsVertragsuebersicht::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.LoadNode -Methode

Tree aufbauen

[Visual Basic]
Private Sub LoadNode( _
   ByVal oDS As DataSet, _
   ByRef oNode As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer, _
   ByVal AktiveVertraege As CheckState _
)

Parameter

oDS
Input-Dataset
oNode
Aktueller Node
type
Type Vertragspartner oder Vertragstyp
Details
AktiveVertraege

Quellcode

[Visual Basic]
        Private Sub LoadNode(ByVal oDS As DataSet, ByRef oNode As TreeNode, ByVal type As String, ByVal Details As Integer, ByVal AktiveVertraege As CheckState)
            'Dim oTreeView As TreeView = New TreeView()
            Dim oDataRow As DataRow
            For Each oDataRow In oDS.Tables(0).Rows
                If Not oDataRow.IsNull("Parentid") Then
                    If oDataRow.Item("Parentid") = 0 Then
                        'If oDataRow.IsNull("Parentid") Then
                        Dim oNode1 As New TreeNode()
                        oNode1.Text = oDataRow("Bezeichnung").ToString()
                        Select Case type
                            Case "Vertragspartner"
                                oNode1.Tag = New Treenode_Descriptor("Vertragstyp", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                If oDataRow("Aktiv") = 0 Then
                                    oNode1.ImageIndex = 7
                                    oNode1.SelectedImageIndex = 7
                                    oNode1.StateImageIndex = 7
                                    oNode1.NodeFont = Me.fnt_Strikeout
                                Else
                                    oNode1.NodeFont = Me.fnt_normal
                                    oNode1.ImageIndex = 1
                                    oNode1.SelectedImageIndex = 1
                                    oNode1.StateImageIndex = 1
                                End If
                            Case "Vertragstyp"
                                If oDataRow("aktiv") = True Then
                                    oNode1.Tag = New Treenode_Descriptor("Vertragspartner", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                    oNode1.ImageIndex = 0
                                    oNode1.SelectedImageIndex = 0
                                    oNode1.StateImageIndex = 0
                                Else
                                    oNode1.Tag = New Treenode_Descriptor("Vertragspartner", oDataRow("vertragselementnr").ToString, xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                                    oNode1.ImageIndex = 4
                                    oNode1.SelectedImageIndex = 4
                                    oNode1.StateImageIndex = 4
                                End If
                        End Select
                        oNode.Nodes.Add(oNode1)
                        RecursivelyLoadNode(oDataRow, oNode1, type, Details, AktiveVertraege)
                    End If
                End If
            Next oDataRow
            oDS.Dispose()
            oDS = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Load_SubStruktur -Methode

Datenstruktur für den Tree lasen

[Visual Basic]
Public Function Load_SubStruktur( _
   ByRef Node As TreeNode, _
   ByVal Details As Integer, _
   ByVal Suchstring As String, _
   ByVal AktiveVertraege As CheckState _
) As Object

Parameter

Node
Parent-Node
Details
Suchstring
AktiveVertraege

Hinweise

Abhängig vom Type wird die Struktur nach Vertragspartner oder Vertragstyp aufgebaut

Quellcode

[Visual Basic]
        Public Function Load_SubStruktur(ByRef Node As TreeNode, ByVal Details As Integer, ByVal Suchstring As String, ByVal AktiveVertraege As CheckState)
            Dim x As Treenode_Descriptor = Node.Tag
            Dim substrukturdata As New DataTable
            Select Case x.Type
                Case "Vertragspartner"
                    Me.xVertragspartnernr = x.Vertragspartnernr
                    substrukturdata = Get_SubStruktur(0, x.Vertragspartnernr, Details, Suchstring)
                Case "Vertragstyp"
                    substrukturdata = Get_SubStruktur(x.Vertragstypnr, 0, Details, Suchstring)
            End Select
            Update_Node(substrukturdata, Node, x.Type, Details, AktiveVertraege)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Load_Tree -Methode

Treeview laden und je eintrag einen "Dummy-Eintrag" erstellen

[Visual Basic]
Private Function Load_Tree( _
   ByRef Tree As TreeView _
) As Object

Parameter

Tree

Quellcode

[Visual Basic]
        Private Function Load_Tree(ByRef Tree As TreeView)
            fnt_Strikeout = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Strikeout)
            fnt_normal = New System.Drawing.Font(Tree.Font.FontFamily, Tree.Font.Size, FontStyle.Regular)

            Tree.Enabled = False
            Tree.Nodes.Clear()
            For Each dr As DataRow In Me.TreeData.Rows
                Dim tn As New TreeNode
                tn.Text = dr.Item("Description")
                tn.Tag = New Treenode_Descriptor(Me.SelectionType, dr.Item("KeyValue"), dr.Item("KeyValue"), dr.Item("KeyValue"))
                Select Case Me.SelectionType
                    Case "Vertragspartner"
                        If dr.Item("aktiv") = True Then
                            tn.ImageIndex = 0
                            tn.SelectedImageIndex = 0
                            tn.StateImageIndex = 0
                        Else
                            tn.ImageIndex = 6
                            tn.SelectedImageIndex = 6
                            tn.StateImageIndex = 6
                        End If
                    Case "Vertragstyp"
                        tn.ImageIndex = 1
                        tn.SelectedImageIndex = 1
                        tn.StateImageIndex = 1
                End Select
                Tree.Nodes.Add(tn)
                Dim subtn As New TreeNode
                subtn.Tag = New Treenode_Descriptor("", -99, 0, 0)
                tn.Nodes.Add(subtn)
            Next
            Tree.Enabled = True
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.RecursivelyLoadNode -Methode

Child-Nodes hinzufügen

[Visual Basic]
Private Sub RecursivelyLoadNode( _
   ByVal oDataRow As DataRow, _
   ByRef oNode As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer, _
   ByVal AktiveVertraege As CheckState _
)

Parameter

oDataRow
oNode
type
Details
AktiveVertraege

Quellcode

[Visual Basic]
        Private Sub RecursivelyLoadNode(ByVal oDataRow As DataRow, ByRef oNode As TreeNode, ByVal type As String, ByVal Details As Integer, ByVal AktiveVertraege As CheckState)
            Dim oChildRow As DataRow
            For Each oChildRow In oDataRow.GetChildRows("SelfRefenceRelation")
                Dim oChildNode As New TreeNode()
                Dim Fremdstruktur As Boolean = False
                oChildNode.Text = oChildRow("Bezeichnung").ToString()
                Dim i As Integer = oChildRow("vertragselementnr")
                Try

                    If oChildRow("vertragstypnr") <> oChildRow("basevertragstypnr") * -100 Then Fremdstruktur = True
                    If i > 100000 Then
                        'Fremdstruktur = True
                        i = oChildRow("vertragselementnr")
                        i = i - 100000
                        i = oChildRow("vertragselementnrursprung")
                        oChildNode.Tag = New Treenode_Descriptor("Vertragselement", i.ToString(), xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                        oChildNode.ToolTipText = oChildRow("Vertragselementnr")
                    Else
                        oChildNode.Tag = New Treenode_Descriptor("Vertragselement", oChildRow("Vertragselementnr").ToString(), xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                        oChildNode.ToolTipText = oChildRow("Vertragselementnr")
                    End If
                Catch
                    oChildNode.Tag = New Treenode_Descriptor("Vertragselement", oChildRow("Vertragselementnr").ToString(), xVertragspartnernr, oDataRow("vertragstypnr").ToString)
                End Try
                If oChildRow("Aktiv") = 0 Then
                    If Fremdstruktur Then
                        oChildNode.ImageIndex = 10
                        oChildNode.SelectedImageIndex = 10
                        oChildNode.StateImageIndex = 10
                    Else
                        oChildNode.ImageIndex = 8
                        oChildNode.SelectedImageIndex = 8
                        oChildNode.StateImageIndex = 8
                    End If
                    oChildNode.NodeFont = Me.fnt_Strikeout
                Else
                    If Fremdstruktur Then
                        oChildNode.ImageIndex = 9
                        oChildNode.SelectedImageIndex = 9
                        oChildNode.StateImageIndex = 9
                    Else
                        oChildNode.ImageIndex = 2
                        oChildNode.SelectedImageIndex = 2
                        oChildNode.StateImageIndex = 2

                    End If
                    oChildNode.NodeFont = Me.fnt_normal
                End If
                Select Case AktiveVertraege
                    Case CheckState.Checked
                        If oChildRow("Aktiv") = True Then oNode.Nodes.Add(oChildNode)
                    Case CheckState.Unchecked
                        If oChildRow("Aktiv") = False Then oNode.Nodes.Add(oChildNode)
                    Case Else
                        oNode.Nodes.Add(oChildNode)
                End Select
                RecursivelyLoadNode(oChildRow, oChildNode, type, Details, AktiveVertraege)
            Next oChildRow
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Update_Node -Methode

Parent-Beziehung herstellen und Struktur abfüllen

[Visual Basic]
Private Sub Update_Node( _
   ByVal oSourceData As DataTable, _
   ByRef node As TreeNode, _
   ByVal type As String, _
   ByVal Details As Integer, _
   ByVal AktiveVertrage As CheckState _
)

Parameter

oSourceData
node
type
Details
AktiveVertrage

Quellcode

[Visual Basic]
        Private Sub Update_Node(ByVal oSourceData As DataTable, ByRef node As TreeNode, ByVal type As String, ByVal Details As Integer, ByVal AktiveVertrage As CheckState)
            If Not (oSourceData Is Nothing) Then
                Dim oView As DataView = oSourceData.DefaultView
                Dim oTable As DataTable = oView.Table
                Dim oDS As DataSet = New DataSet()
                oDS.Tables.Add(oTable.Copy())

                If oDS.Relations.Contains("SelfRefenceRelation") = False Then
                    oDS.Relations.Add("SelfRefenceRelation", _
                        oDS.Tables(0).Columns("Vertragselementnr"), _
                        oDS.Tables(0).Columns("Parentid"))
                End If
                oTable.Dispose()
                oTable = Nothing
                LoadNode(oDS, node, type, Details, AktiveVertrage)
                oDS.Dispose()
                oDS = Nothing
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen.Update_Vertragsuebersicht -Methode

Vertrasgdetail abhängig des gewählten Nodes auslesen

[Visual Basic]
Public Function Update_Vertragsuebersicht( _
   ByVal SelectedTag As Object, _
   Optional ByVal SelNachVertragstyp As Boolean = False, _
   Optional ByVal Suchstring As String = "" _
) As DataTable

Parameter

SelectedTag
Erforderlich.
SelNachVertragstyp
Optional. Der Standardwert ist False.
Suchstring
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Public Function Update_Vertragsuebersicht(ByVal SelectedTag As Object, Optional ByVal SelNachVertragstyp As Boolean = False, Optional ByVal Suchstring As String = "") As DataTable
            Dim x As Treenode_Descriptor = SelectedTag
            'MsgBox(x.Keyvalue)
            Select Case x.Type
                Case "Vertragspartner"
                    Return Get_Vertragsdetails(x.Type, 0, x.Vertragspartnernr, Suchstring)
                Case "Vertragstyp"
                    If SelNachVertragstyp = True Then
                        Return Get_Vertragsdetails(x.Type, x.Vertragstypnr, 0, Suchstring)
                    Else
                        Return Get_Vertragsdetails(x.Type, x.Vertragstypnr, x.Vertragspartnernr, Suchstring)
                    End If
                Case "Vertragselement"
                    Return Get_Vertragsdetails(x.Type, x.Keyvalue, x.Vertragspartnernr, Suchstring)
            End Select

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


clsVertragsuebersicht_Strukturen-Felder

clsVertragsuebersicht_Strukturen Übersicht

Felder

private field SelectionType

Unterstützt von .NET Compact Framework
private field TreeData

Unterstützt von .NET Compact Framework
public field fnt_Strikeout

Unterstützt von .NET Compact Framework
public field fnt_normal

Unterstützt von .NET Compact Framework
private field xVertragspartnernr

Unterstützt von .NET Compact Framework

clsVertragsuebersicht_Strukturen -Klasse


SelectionType -Feld

[Visual Basic]
Private SelectionType As String

Quellcode

[Visual Basic]
        Dim SelectionType As String

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


TreeData -Feld

[Visual Basic]
Private TreeData As DataTable

Quellcode

[Visual Basic]
        Dim TreeData As New DataTable

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


fnt_Strikeout -Feld

[Visual Basic]
Public fnt_Strikeout As Font

Quellcode

[Visual Basic]
        Public fnt_Strikeout As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


fnt_normal -Feld

[Visual Basic]
Public fnt_normal As Font

Quellcode

[Visual Basic]
        Public fnt_normal As Font

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


xVertragspartnernr -Feld

[Visual Basic]
Private xVertragspartnernr As Integer

Quellcode

[Visual Basic]
        Dim xVertragspartnernr As Integer

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsuebersicht_Strukturen


Vertragsverwaltung.tkb.vv.vertrag -Namespace

Klassen

public class clsAktivitaet

Unterstützt von .NET Compact Framework
public class clsAktivitaeten

Unterstützt von .NET Compact Framework


clsAktivitaet -Klasse

For a list of all members of this type, see clsAktivitaet-Member.

System.Object
Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase
Vertragsverwaltung.TKB.VV.DB.clsAktivitaet
Vertragsverwaltung.tkb.vv.vertrag.clsAktivitaet

[Visual Basic]
Public Class clsAktivitaet
    Inherits clsAktivitaet

Forderungen

Namespace: Vertragsverwaltung.tkb.vv.vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAktivitaet-Member


clsAktivitaet-Member

clsAktivitaet Übersicht

Öffentliche Konstruktoren

public constructor clsAktivitaet -Konstructor (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework

 Purpose: Class constructor.

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAusgeloest_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property fBetrag (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iAktivitaetNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iEreignisnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iPeriodizitaetnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecuritylevelnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEreignis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sKostenart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sKuendigungsfrist (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sTermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Aktivitaet Unterstützt von .NET Compact Framework | Aktivitaet inaktivieren
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Aktivitaet Unterstützt von .NET Compact Framework | Aktivitaet lesen lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Status_Wechsel Unterstützt von .NET Compact Framework | Statuswechsel einer Aktivät durchführen
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


clsAktivitaet-Eigenschaften

clsAktivitaet Übersicht

Öffentliche Eigenschaften

public property bAktiv (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property daAusgeloest_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property daErstellt_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property daMutiert_am (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property fBetrag (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iAktivitaetNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iAktivitaetStatusNr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iEreignisnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iMutierer (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iPeriodizitaetnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property iSecuritylevelnr (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sBemerkung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sBeschreibung (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sConnectionString (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
public property sEreignis (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sKostenart (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sKuendigungsfrist (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework
public property sTermin (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet)

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


clsAktivitaet-Methoden

clsAktivitaet Übersicht

Öffentliche Methoden

public method Delete (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Delete method. This method will Delete one existing row in the database, based on the Primary Key.
public method Delete_Aktivitaet Unterstützt von .NET Compact Framework | Aktivitaet inaktivieren
public method Dispose Überladen. (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase) Unterstützt von .NET Compact Framework |
public method Get_Aktivitaet Unterstützt von .NET Compact Framework | Aktivitaet lesen lesen
public method Insert (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Insert method. This method will insert one new row into the database.
public method SelectAll (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: SelectAll method. This method will Select all rows from the table.
public method SelectOne (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Select method. This method will Select one existing row from the database, based on the Primary Key.
public method Status_Wechsel Unterstützt von .NET Compact Framework | Statuswechsel einer Aktivät durchführen
public method Update (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsAktivitaet) Unterstützt von .NET Compact Framework | Purpose: Update method. This method will Update one existing row in the database.

clsAktivitaet -Klasse


clsAktivitaet.Delete_Aktivitaet -Methode

Aktivitaet inaktivieren

[Visual Basic]
Public Sub Delete_Aktivitaet( _
   ByVal Basenr As Integer _
)

Parameter

Basenr

Quellcode

[Visual Basic]
        Public Sub Delete_Aktivitaet(ByVal Basenr As Integer)
            If Basenr <> 0 Then
                Me.Get_Aktivitaet(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.bAktiv = New SqlBoolean(CType(False, Boolean))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.Get_Aktivitaet -Methode

Aktivitaet lesen lesen

[Visual Basic]
Public Function Get_Aktivitaet( _
   ByVal Nr As Integer _
) As Object

Parameter

Nr

Quellcode

[Visual Basic]
        Public Function Get_Aktivitaet(ByVal Nr As Integer)
            Me.cpMainConnectionProvider = Globals.conn
            Me.iAktivitaetNr = New SqlInt32(CType(Nr, Int32))
            Globals.conn.OpenConnection()
            Me.SelectOne()
            Globals.conn.CloseConnection(True)
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet.Status_Wechsel -Methode

Statuswechsel einer Aktivät durchführen

[Visual Basic]
Public Sub Status_Wechsel( _
   ByVal BaseNr As Integer, _
   ByVal Statusnr As Integer, _
   ByVal aktiv As Boolean _
)

Parameter

BaseNr
Statusnr
aktiv

Quellcode

[Visual Basic]
        Public Sub Status_Wechsel(ByVal BaseNr As Integer, ByVal Statusnr As Integer, ByVal aktiv As Boolean)
            If BaseNr <> 0 Then
                Me.Get_Aktivitaet(BaseNr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Me.iAktivitaetStatusNr = New SqlInt32(CType(Statusnr, Int32))
            Me.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.iMutierer = New SqlInt32(CType(Globals.clsmitarbeiter.iMitarbeiternr.Value, Int32))
            Me.bAktiv = New SqlBoolean(CType(aktiv, Boolean))
            Globals.conn.OpenConnection()
            Me.Update()
            Globals.conn.CloseConnection(True)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaet


clsAktivitaet-Felder

clsAktivitaet Übersicht

Felder

protected field m_bMainConnectionIsCreatedLocal (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_cpMainConnectionProvider (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iErrorCode (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_iRowsAffected (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework
protected field m_scoMainConnection (Geerbt von: Vertragsverwaltung.TKB.VV.DB.clsDBInteractionBase)

Unterstützt von .NET Compact Framework

clsAktivitaet -Klasse


clsAktivitaeten -Klasse

For a list of all members of this type, see clsAktivitaeten-Member.

System.Object
Vertragsverwaltung.tkb.vv.vertrag.clsAktivitaeten

[Visual Basic]
Public Class clsAktivitaeten

Forderungen

Namespace: Vertragsverwaltung.tkb.vv.vertrag

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Assembly: IT-Service-Management (in IT-Service-Management.exe)

clsAktivitaeten-Member


clsAktivitaeten-Member

clsAktivitaeten Übersicht

Öffentliche Methoden

public method Get_Aktivitaetenliste

Unterstützt von .NET Compact Framework

 Aktivitätenliste auslesen

clsAktivitaeten -Klasse


clsAktivitaeten-Methoden

clsAktivitaeten Übersicht

Öffentliche Methoden

public method Get_Aktivitaetenliste

Unterstützt von .NET Compact Framework

 Aktivitätenliste auslesen

clsAktivitaeten -Klasse


clsAktivitaeten.Get_Aktivitaetenliste -Methode

Aktivitätenliste auslesen

[Visual Basic]
Public Function Get_Aktivitaetenliste( _
   ByVal AktivitaetStatus As String _
) As DataTable

Parameter

AktivitaetStatus

Quellcode

[Visual Basic]
        Public Function Get_Aktivitaetenliste(ByVal AktivitaetStatus As String) As DataTable
            Dim PendStatusnr As Integer = 0
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_aktivitaetliste"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                'Select Case AktivitaetStatus
                '    Case "Alle"
                '        PendStatusnr = -1
                '    Case "Pendent"
                '        PendStatusnr = 1
                '    Case "In Bearbeitung"
                '        PendStatusnr = 2
                '    Case "Erledigt"
                '        PendStatusnr = 3
                '    Case Else
                '        PendStatusnr = -1
                'End Select
                PendStatusnr = AktivitaetStatus
                scmCmdToExecute.Parameters.Add(New SqlParameter("@AktivitaetStatusNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, PendStatusnr))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsAktivitaeten::Get_Aktivitaetenliste::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAktivitaeten


FrmLizenz.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


clsApplikationsabhaengigkeit.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


clsApplikationsabhaengigkeit.Delete -Methode

Physisches Löschen eines Datensatzes.

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationsabhaengigkeit


frmcrreporting -Konstructor (System.Data.DataTable, System.Int32, Vertragsverwaltung.TKB.Auswertung.clsAuswertung, System.Boolean)

[Visual Basic]
Public Sub New( _
   ByRef ds As DataTable, _
   ByVal Auswertungnr As Integer, _
   ByRef auswertung As clsAuswertung, _
   ByVal printparam As Boolean _
)

Parameter

ds
Auswertungnr
auswertung
printparam

Quellcode

[Visual Basic]
    Sub New(ByRef ds As DataTable, ByVal Auswertungnr As Integer, ByRef auswertung As TKB.Auswertung.clsAuswertung, ByVal printparam As Boolean)
        InitializeComponent()
        Me.ds = ds
        Me.auswertungnr = Auswertungnr
        Me.auswertung = auswertung
        Me.printparam = printparam
        Me.StandardAuswertung = True
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


frmcrreporting -Konstructor (System.Data.DataTable, System.Int32)

[Visual Basic]
Public Sub New( _
   ByRef ds As DataTable, _
   ByVal Auswertungnr As Integer _
)

Parameter

ds
Auswertungnr

Quellcode

[Visual Basic]
    Sub New(ByRef ds As DataTable, ByVal Auswertungnr As Integer)
        InitializeComponent()
        Me.ds = ds
        Me.auswertungnr = Auswertungnr
        Me.StandardAuswertung = False
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmcrreporting


clsSLAKatalogdaten -Konstructor

[Visual Basic]
Public Sub New( _
   ByVal tblname As String _
)

Parameter

tblname

Quellcode

[Visual Basic]
        Sub New(ByVal tblname As String)
            MyBase.New(tblname)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLAKatalogdaten


clsSLA.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Overloads Sub dispose()
            Me.dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsSLA


clsDBInteractionBase.Dispose -Methode

Quellcode

[Visual Basic]
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


clsDBInteractionBase.Dispose (System.Boolean) -Methode

[Visual Basic]
Protected Overloads Overridable Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)

Parameter

bIsDisposing

Quellcode

[Visual Basic]
        Overridable  Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Object is created in this class, so destroy it here.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                        m_bMainConnectionIsCreatedLocal = True
                    End If
                    m_cpMainConnectionProvider = Nothing
                    m_scoMainConnection = Nothing
                End If
            End If
            m_bIsDisposed = True
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDBInteractionBase


frmVertragsereignis -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
        Me.Aktuelles_Vertragsereignis = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis -Konstructor (System.Int32, System.Int32, System.Boolean, System.Boolean)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal Vertragsereignisnr As Integer, _
   Optional ByVal vertragselementnr As Integer = 0, _
   Optional ByVal Anzeige As Boolean = False, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Vertragsereignisnr
Erforderlich.
vertragselementnr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Vertragsereignisnr As Integer, Optional ByVal vertragselementnr As Integer = 0, Optional ByVal Anzeige As Boolean = False, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        InitializeComponent()
        Me.Anzeige = Anzeige
        If CreateNew Then
            Me.Aktuelles_Vertragsereignis = Me.Vertragsereignis.Add_New(vertragselementnr)
            Me.Neuer_Datensatz = True
        Else
            Me.Aktuelles_Vertragsereignis = Vertragsereignisnr
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmVertragsereignis.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Vertragsereignis.dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmAuswertungsParameter -Konstructor (System.Data.DataTable)

[Visual Basic]
Public Sub New( _
   ByRef Params As DataTable _
)

Parameter

Params

Quellcode

[Visual Basic]
    Sub New(ByRef Params As DataTable)
        InitializeComponent()
        Me.parameter = Params
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


clsKontakt.Delete -Methode

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   ByVal Basenr As Integer _
) As Integer

Parameter

Basenr

Quellcode

[Visual Basic]
        Public Overloads Function Delete(ByVal Basenr As Integer) As Integer
            If Basenr <> 0 Then
                Me.Get_Applikationskontakt(Basenr)
            End If
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsConnectionProvider.Dispose -Methode

Quellcode

[Visual Basic]
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


clsConnectionProvider.Dispose (System.Boolean) -Methode

[Visual Basic]
Protected Overloads Overridable Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)

Parameter

bIsDisposing

Quellcode

[Visual Basic]
        Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If Not (m_stCurrentTransaction Is Nothing) Then
                        m_stCurrentTransaction.Dispose()
                        m_stCurrentTransaction = Nothing
                    End If
                    If Not (m_scoDBConnection Is Nothing) Then
                        ' // closing the connection will abort (rollback) any pending transactions
                        m_scoDBConnection.Close()
                        m_scoDBConnection.Dispose()
                        m_scoDBConnection = Nothing
                    End If
                End If
            End If
            m_bIsDisposed = True
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsConnectionProvider


frmVertragselement.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmAuswertungsParameter -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmAuswertungsParameter


clsAuswertung.Get_Auswertungsdaten (System.String, System.String) -Methode

[Visual Basic]
Public Function Get_Auswertungsdaten( _
   ByVal sp As String, _
   ByVal sqlwhere As String _
) As DataTable

Parameter

sp
sqlwhere

Quellcode

[Visual Basic]
        Public Function Get_Auswertungsdaten(ByVal sp As String, ByVal sqlwhere As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = sp
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sqlwhere", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, sqlwhere))
                'scmCmdToExecute.Parameters.Add(New SqlParameter("@Rolle", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, ""))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


clsAuswertung.Get_Auswertungsdaten (System.String, System.String, System.Boolean) -Methode

[Visual Basic]
Public Function Get_Auswertungsdaten( _
   ByVal sp As String, _
   ByVal sqlwhere As String, _
   ByVal txp As Boolean _
) As DataTable

Parameter

sp
sqlwhere
txp

Quellcode

[Visual Basic]
        Public Function Get_Auswertungsdaten(ByVal sp As String, ByVal sqlwhere As String, ByVal txp As Boolean) As DataTable

            Dim con As New SqlConnection(Get_TXP_Connection)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = sp
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = con
            scmCmdToExecute.CommandTimeout = 30000

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sqlwhere", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, sqlwhere))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("frmAuswertung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                con.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                con.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsAuswertung


frmVertragsereignis.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsereignis


frmApplikation -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation -Konstructor (System.Int32, System.Boolean)

[Visual Basic]
Public Sub New( _
   ByVal Applikationsnr As Integer, _
   Optional ByVal Anzeige As Boolean = False _
)

Parameter

Applikationsnr
Erforderlich.
Anzeige
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Applikationsnr As Integer, Optional ByVal Anzeige As Boolean = False)
        InitializeComponent()
        Me.Aktuelle_Applikation = Applikationsnr
        Me.FormReadonly = Anzeige
        If Me.Aktuelle_Applikation <> 0 Then
            Dim app As New TKB.VV.DB.clsApplikation
            app.cpMainConnectionProvider = Globals.conn
            app.iApplikationNr = New SqlInt32(CType(Me.Aktuelle_Applikation, Int32))
            app.SelectOne()
            If app.bAktiv.Value = False Then
                Me.cboxNurAktive.Checked = False
            End If
            app.Dispose()
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmApplikation -Konstructor (System.Boolean)

[Visual Basic]
Public Sub New( _
   ByVal CreateNew As Boolean _
)

Parameter

CreateNew

Quellcode

[Visual Basic]
    Sub New(ByVal CreateNew As Boolean)
        InitializeComponent()
        If CreateNew Then
            Me.Aktuelle_Applikation = Me.Applikation.Add_New
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikation


frmPerson.Dispose (System.Boolean) -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmKuendigungsfrist.Dispose (System.Boolean) -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


FrmLizenz -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz -Konstructor (System.Int32, System.Int32, System.Boolean)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal vertragselementnr As Integer, _
   ByVal applikationnr As Integer, _
   ByVal anzeige As Boolean _
)

Parameter

vertragselementnr
Nr des Vertragspartners
applikationnr
anzeige
True=Readonly, False=normal

Quellcode

[Visual Basic]
    Sub New(ByVal vertragselementnr As Integer, ByVal applikationnr As Integer, ByVal anzeige As Boolean)
        MyBase.New()
        InitializeComponent()
        Me.Vertragselementnr = vertragselementnr
        Me.Applikationnr = applikationnr
        Me.Anzeige = anzeige
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


FrmLizenz.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Vertragselement.dispose()
        Me.Vertragselement = Nothing
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmLizenz


frmVertragselementSuche.dispose -Methode

Destructor Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Overloads Sub dispose()
        d.Dispose()
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


clsApplikation.Get_Dokumente (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32, System.Windows.Forms.ImageList) -Methode

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic]
Public Function Get_Dokumente( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Applikationnr As Integer, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
TruedbGrid
Applikationnr
Erforderlich.
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByRef c1data As C1TrueDBGrid, ByVal Applikationnr As Integer, Optional ByVal ImgList As ImageList = Nothing)
            Me.Get_Applikation(Applikationnr)
            dokumente = Dokument.Get_Dokumente(Me.iApplikationNr.Value, 3)
            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Me.Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Applikationskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic]
Public Function Get_Applikationskontakte( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid

Quellcode

[Visual Basic]
        Public Function Get_Applikationskontakte(ByRef c1data As C1TrueDBGrid)
            Try
                Applikationskontakte.dispose()
                Applikationskontakte = Nothing
            Catch ex As Exception

            End Try
            Applikationskontakte = New TKB.VV.Sysadmin.DomainTable("Applikationkontakt", Me.iApplikationNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Applikationskontakte.Tabledata
            c1data.DataMember = Applikationskontakte.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Applikationskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic]
Public Function Get_Applikationskontakte( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Applikationnr As Integer _
) As Object

Parameter

c1data
C1TrueDBGrid
Applikationnr

Quellcode

[Visual Basic]
        Public Function Get_Applikationskontakte(ByRef c1data As C1TrueDBGrid, ByVal Applikationnr As Integer)
            Me.Get_Applikation(Applikationnr)
            Applikationskontakte = New TKB.VV.Sysadmin.DomainTable("Vertragskontakt", Me.iApplikationNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Applikationskontakte.Tabledata
            c1data.DataMember = Applikationskontakte.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Vertragselemente (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Applikationen lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Vertragselemente( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Vertragselemente(ByRef c1data As C1TrueDBGrid)
            Try
                VertragselementApplikationen.dispose()
                VertragselementApplikationen = Nothing
            Catch ex As Exception

            End Try
            VertragselementApplikationen = New TKB.VV.Sysadmin.DomainTable("VertragselementApplikation", 1, Me.iApplikationNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = VertragselementApplikationen.Tabledata
            c1data.DataMember = VertragselementApplikationen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikation.Get_Vertragselemente (System.Int32) -Methode

Applikationen auslesen und dem Truedbgrid übergeben.

[Visual Basic]
Public Function Get_Vertragselemente( _
   ByVal Applikationnr As Integer _
) As Object

Parameter

Applikationnr

Quellcode

[Visual Basic]
        Public Function Get_Vertragselemente(ByVal Applikationnr As Integer)
            Me.Get_Applikation(Applikationnr)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_vertragselement_applikation"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@keyvalue", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.iApplikationNr.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.clsmitarbeiter.iMitarbeiternr.Value))
                conn.OpenConnection()
                sdaAdapter.Fill(dtToReturn)
                conn.CloseConnection(True)
                Return dtToReturn
            Catch ex As Exception
                Throw New Exception("clsApplikation::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
            '            VertragselementApplikationen = New TKB.VV.Sysadmin.DomainTable("VertragselementApplikation", 1, Me.iApplikationNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            '           Dim i As Integer = 0
            '          c1data.DataSource = VertragselementApplikationen.Tabledata
            '         c1data.DataMember = VertragselementApplikationen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


clsApplikationTree.Load_Treedata (System.Boolean) -Methode

Treedaten ab Datenbank laden

[Visual Basic]
Private Function Load_Treedata( _
   ByVal nuraktive As Boolean _
) As DataTable

Parameter

nuraktive

Quellcode

[Visual Basic]
        Private Function Load_Treedata(ByVal nuraktive As Boolean) As DataTable
            Treedata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "sp_get_applstruktur"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@NurAktive", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            If nuraktive = True Then
                selectcommand.Parameters(1).Value = 1
            Else
                selectcommand.Parameters(1).Value = 0
            End If

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationTree.Load_Treedata (System.String, System.Boolean, System.Boolean) -Methode

[Visual Basic]
Private Function Load_Treedata( _
   ByVal Suchstring As String, _
   ByVal nuraktive As Boolean, _
   ByVal Archivobjekte As Boolean _
) As DataTable

Parameter

Suchstring
nuraktive
Archivobjekte

Quellcode

[Visual Basic]
        Private Function Load_Treedata(ByVal Suchstring As String, ByVal nuraktive As Boolean, ByVal Archivobjekte As Boolean) As DataTable
            Treedata.Tables.Clear()
            Dim selectcommand As New SqlCommand
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("", connection)

            selectcommand.CommandText = "sp_get_applstruktur_suche"
            selectcommand.Parameters.Add("@Mitarbeiternr", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@suchstring", SqlDbType.VarChar, 255)
            selectcommand.Parameters.Add("@NurAktive", SqlDbType.Int, 4)
            selectcommand.Parameters.Add("@arcobject", SqlDbType.Int, 4)
            selectcommand.Parameters(0).Value = Globals.clsmitarbeiter.iMitarbeiternr.Value
            selectcommand.Parameters(1).Value = Suchstring
            If nuraktive = True Then
                selectcommand.Parameters(2).Value = 1
            Else
                selectcommand.Parameters(2).Value = 0
            End If
            If Archivobjekte = True Then
                selectcommand.Parameters(3).Value = 1
            End If

            selectcommand.CommandType = CommandType.StoredProcedure
            selectcommand.Connection = connection
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.SelectCommand = selectcommand
                da.Fill(Treedata, "Tree")
            Catch ex As Exception
            Finally
                connection.Close()
                da.Dispose()
                selectcommand.Dispose()
            End Try

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationTree


clsApplikationLogbuch.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()
            Try
                'vertragstyp.Dispose()
                Releasearten.Dispose()
                'Applikation.Dispose()
                Personen.Dispose()
                Personen1.Dispose()
                Personen2.Dispose()
                'Lizenztyp.Dispose()
            Catch
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsApplikationLogbuch.Delete -Methode

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   ByVal Basenr As Integer _
) As Integer

Parameter

Basenr

Quellcode

[Visual Basic]
        Public Overloads Function Delete(ByVal Basenr As Integer) As Integer
            If Basenr <> 0 Then
                Me.Get_ApplikationLogbuch(Basenr)
            End If
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikationLogbuch


clsDok.Delete -Methode

Datensatz physisch löschen

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Dokument(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsDok


Tabellenspalte -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
        Public Sub New()

        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte -Konstructor (System.Object, System.String, System.Data.DataSet)

[Visual Basic]
Public Sub New( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef ds As DataSet _
)

Parameter

daten
tablename
ds

Quellcode

[Visual Basic]
        Public Sub New(ByRef daten As Object, ByRef tablename As String, ByRef ds As DataSet)
            Spaltentitel_aktualisieren(daten, tablename, ds)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataSet) -Methode

[Visual Basic]
Public Function Spaltentitel_aktualisieren( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef ds As DataSet _
) As Object

Parameter

daten
tablename
ds

Quellcode

[Visual Basic]
        Public Function Spaltentitel_aktualisieren(ByRef daten As Object, ByRef tablename As String, ByRef ds As DataSet)
            Dim anzcols As Integer
            Dim i As Integer
            Dim s As String
            anzcols = daten.Splits(0).DisplayColumns.Count
            Me.Tabelle = tablename
            For i = 0 To daten.Columns.Count - 1
                s = daten.Columns(i).DataField
                Me.Feld = s
                Me.getspalte()
                daten.Columns(i).Caption = Me.spaltenname

                If Me.ColWith = 0 Then
                    daten.Splits(0).DisplayColumns(i).Width = 0
                    daten.Splits(0).DisplayColumns(i).Visible = False
                Else
                    daten.Splits(0).DisplayColumns(i).Width = Me.ColWith
                End If

                If Me.locked Then
                    daten.Splits(0).DisplayColumns(i).Locked = True
                End If

                If Me.AlsHacken Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If LCase(daten.Columns(i).DataField) = "aktiv" Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    daten.Columns(i).ValueItems.DefaultItem = True
                    daten.Columns(i).DefaultValue = True
                    daten.Columns(i).FilterText = True
                    'Dim items As C1.Win.C1TrueDBGrid.ValueItems = daten.Columns("aktiv").ValueItems
                    'items.Values.Clear()
                    'items.Values.Add(New C1.Win.C1TrueDBGrid.ValueItem("False", False)) ' unchecked
                    'items.Values.Add(New C1.Win.C1TrueDBGrid.ValueItem("True", True)) ' checked
                    'items.Values.Add(New C1.Win.C1TrueDBGrid.ValueItem("", "INDETERMINATE")) ' indeterminate state

                End If
                Select Case LCase(daten.Columns(i).DataField)
                    Case "erstellt_am", "erstelltam"
                        daten.Columns(i).DefaultValue = Now
                End Select
                If daten.Columns(i).DataType.Name = "DateTime" Then
                    daten.Columns(i).NumberFormat = "dd.MM.yyyy HH:mm:ss"
                End If
                If Me.Numberformat <> "" Then
                    daten.columns(i).numberformat = Me.Numberformat
                End If
            Next
            ColumnOrder(tablename, daten)
            daten.HeadingStyle.WrapText = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


Tabellenspalte.Spaltentitel_aktualisieren (System.Object, System.String, System.Data.DataTable, System.Boolean) -Methode

[Visual Basic]
Public Function Spaltentitel_aktualisieren( _
   ByRef daten As Object, _
   ByRef tablename As String, _
   ByRef dt As DataTable, _
   Optional ByVal Aktiv_Spalte_True_Setzen As Boolean = True _
) As Object

Parameter

daten
Erforderlich.
tablename
Erforderlich.
dt
Erforderlich.
Aktiv_Spalte_True_Setzen
Optional. Der Standardwert ist True.

Quellcode

[Visual Basic]
        Public Function Spaltentitel_aktualisieren(ByRef daten As Object, ByRef tablename As String, ByRef dt As DataTable, Optional ByVal Aktiv_Spalte_True_Setzen As Boolean = True)
            Dim anzcols As Integer
            Dim i As Integer
            Dim t As New DataTable()
            Dim s As String
            anzcols = daten.Splits(0).DisplayColumns.Count
            t = dt
            Me.Tabelle = tablename
            For i = 0 To daten.Columns.Count - 1
                s = daten.Columns(i).DataField
                Me.Feld = s
                Me.getspalte()
                daten.Columns(i).Caption = Me.spaltenname

                If Me.ColWith = 0 Then
                    daten.Splits(0).DisplayColumns(i).Width = 0
                    daten.Splits(0).DisplayColumns(i).Visible = False
                Else
                    daten.Splits(0).DisplayColumns(i).Width = Me.ColWith
                End If

                If Me.locked Then
                    daten.Splits(0).DisplayColumns(i).Locked = True
                End If

                If Me.AlsHacken Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If LCase(daten.Columns(i).DataField) = "aktiv" And Aktiv_Spalte_True_Setzen = True Then
                    daten.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    daten.Columns(i).ValueItems.DefaultItem = True
                    daten.Columns(i).DefaultValue = True
                    daten.Columns(i).FilterText = True
                End If
                Select Case LCase(daten.Columns(i).DataField)
                    Case "erstellt_am", "erstelltam"
                        daten.Columns(i).DefaultValue = Now
                End Select
                If daten.Columns(i).DataType.Name = "DateTime" Then
                    daten.Columns(i).NumberFormat = "dd.MM.yyyy HH:mm:ss"
                End If
                If Me.Numberformat <> "" Then
                    daten.columns(i).numberformat = Me.Numberformat
                End If
            Next
            ColumnOrder(tablename, daten)
            daten.HeadingStyle.WrapText = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

Tabellenspalte


clsPendenz.Delete -Methode

Datensatz physisch löschen

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Pendenz(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPendenz


frmReferenzvertraege.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmVertragselement -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
        Me.Aktuelles_Vertragselement = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement -Konstructor (System.Int32, System.Boolean, System.Boolean, System.Int32)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal Vertragselementnr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False, _
   Optional ByVal Vertragspartnernr As Integer = 0 _
)

Parameter

Vertragselementnr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.
Vertragspartnernr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
    Sub New(ByVal Vertragselementnr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False, Optional ByVal Vertragspartnernr As Integer = 0)
        MyBase.New()
        InitializeComponent()
        Me.Aktuelles_Vertragselement = Vertragselementnr
        Me.Anzeige = Anzeige
        If CreateNew Then
            If Vertragspartnernr = 0 Then
                While Vertragselement.Vertragspartner_suchen(Me.Aktueller_Vertragspartner, Me.txtVertragspartner) = False
                    msg.show_standardmessage(900, MsgBoxStyle.Critical)
                End While
                Me.Aktuelles_Vertragselement = Me.Vertragselement.Add_New(Me.Aktueller_Vertragspartner)
            Else
                Me.Aktueller_Vertragspartner = Vertragspartnernr
                Me.Aktuelles_Vertragselement = Me.Vertragselement.Add_New(Me.Aktueller_Vertragspartner)

            End If
            Me.Neuer_Datensatz = True
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmVertragselement.dispose -Methode

Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Vertragselement.dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselement


frmKuendigungsfrist.Dispose -Methode

Destructor Dispose

[Visual Basic]
Public Overloads Sub Dispose()

Quellcode

[Visual Basic]
    Overloads Sub Dispose()
        Me.Kuendigungsfrist.Dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmKuendigungsfrist


clsVertragselement.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()
            Try
                'vertragstyp.Dispose()
                Vertragstypen.Dispose()
                'Applikation.Dispose()
                Applikationen.Dispose()
                'Lizenztyp.Dispose()
                Lizenztypen.Dispose()
                Vertragspartner.dispose()
                Me.Lizenzinformationen.Dispose()
            Catch
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Delete -Methode

Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragselement(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


ComboBoxIconItem -Konstructor (System.String, System.Int32)

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageIndex As Integer _
)

Parameter

text
imageIndex

Quellcode

[Visual Basic]
    Public Sub New(ByVal text As String, ByVal imageIndex As Integer)
        _text = text
        _imageIndex = imageIndex
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


frmVertragsuebersicht.Update_Details -Methode

Detailelemente und die allfällig ausgewählte TabPage aktualisieren

[Visual Basic]
Private Sub Update_Details()

Quellcode

[Visual Basic]
    Private Sub Update_Details()
        If Me.C1Vertragselemente.Splits(0).Rows.Count < 1 Then
            Me.TabControlDiverse.Enabled = False
            Exit Sub
        End If
        Me.TabControlDiverse.Enabled = True
        Update_DetailInformationen()
        Select Case Me.TabControlDiverse.SelectedTab.Text
            Case "Vertragsinhalt", "Suchbegriffe"
            Case "Kündigungsfristen"
                Refresh_Kuendigungsfrist()
            Case "Kontakte"
                Refresh_Kontakte()
            Case "Dokumente"
                Refresh_Dokumente()
            Case "Services"
                Refresh_services()
            Case "Ereignisse"
                Refresh_Ereignisse()
            Case "Aktivitäten"
                Refresh_Aktivitaeten()
            Case "Pendenzen"
                Refresh_Pendenzen()
            Case "Referenzverträge"
                Refresh_Referenzvertraege()
            Case "History"
                Refresh_History()
            Case "Applikationen"
                Refresh_Applikationen()
        End Select
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht.update_details -Methode

[Visual Basic]
Private Function update_details( _
   ByRef s As String, _
   ByVal c1element As String _
) As Object

Parameter

s
c1element

Quellcode

[Visual Basic]
    Private Function update_details(ByRef s As String, ByVal c1element As String)
        Try
            If Not Me.C1Vertragselemente.Columns(c1element).Value Is System.DBNull.Value Then
                s = Me.C1Vertragselemente.Columns(c1element).Value
            Else
                s = ""
            End If
        Catch ex As Exception
            s = ""
        End Try
    End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


clsVertragspartner.dispose -Methode

Destructor Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Overloads Sub dispose()
            Kontaktpersonen = Nothing
            Kontaktperson.Dispose()
            MyBase.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Get_Kontaktpersonen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Kontaktpersonen zu einem Vertragspartner auslesen

[Visual Basic]
Public Function Get_Kontaktpersonen( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
Datagrid, welches die Kontaktpersonen anzeigt

Quellcode

[Visual Basic]
        Public Function Get_Kontaktpersonen(ByRef c1data As C1TrueDBGrid)
            Try
                Kontaktpersonen.dispose()
                Kontaktpersonen = Nothing
            Catch ex As Exception
            End Try
            Kontaktpersonen = New TKB.VV.Sysadmin.DomainTable("Person", Me.iVertragspartnerNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kontaktpersonen.Tabledata
            c1data.DataMember = Kontaktpersonen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Get_Kontaktpersonen -Methode

Kontaktpersonen zu einem Vertragspartner auslesen

[Visual Basic]
Public Function Get_Kontaktpersonen() As DataSet

Quellcode

[Visual Basic]
        Public Function Get_Kontaktpersonen() As DataSet
            Try
                Kontaktpersonen.dispose()
                Kontaktpersonen = Nothing
            Catch ex As Exception
            End Try
            Kontaktpersonen = New TKB.VV.Sysadmin.DomainTable("Person", Me.iVertragspartnerNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Return Kontaktpersonen.Tabledata
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


clsVertragspartner.Delete -Methode

Vertragspartner physisch löschen

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Partner(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragspartner


FrmReleaseLogbuch -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


FrmReleaseLogbuch -Konstructor (System.Int32, System.Int32, System.Boolean, System.Boolean)

[Visual Basic]
Public Sub New( _
   ByVal ApplikationLogbuchNr As Integer, _
   ByVal Applikationsnr As Integer, _
   Optional ByVal CreateNew As Boolean = False, _
   Optional ByVal FormReadOnly As Boolean = False _
)

Parameter

ApplikationLogbuchNr
Erforderlich.
Applikationsnr
Erforderlich.
CreateNew
Optional. Der Standardwert ist False.
FormReadOnly
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal ApplikationLogbuchNr As Integer, ByVal Applikationsnr As Integer, Optional ByVal CreateNew As Boolean = False, Optional ByVal FormReadOnly As Boolean = False)
        InitializeComponent()
        Me.FormReadonly = FormReadOnly
        If CreateNew = True Then
            Me.ApplikationLogbuchNr = Me.ApplikationLogbuch.Add_New(Applikationsnr)
            Me.Neuer_Datensatz = True
        Else
            Me.ApplikationLogbuchNr = ApplikationLogbuchNr
        End If
        Me.Applikationsnr = Applikationsnr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

FrmReleaseLogbuch


clsApplikation.Get_Dokumente (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Windows.Forms.ImageList) -Methode

Dokumente lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Dokumente( _
   ByRef c1data As C1TrueDBGrid, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByRef c1data As C1TrueDBGrid, Optional ByVal ImgList As ImageList = Nothing)
            Try
                dokumente.dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            dokumente = Dokument.Get_Dokumente(Me.iApplikationNr.Value, 3)
            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


frmPerson.Dispose -Methode

Destructor Dispose

[Visual Basic]
Public Overloads Sub Dispose()

Quellcode

[Visual Basic]
    Overloads Sub Dispose()
        Kontaktperson.Dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPerson


frmVertragspartner.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


clsReferenzvertrag.Delete -Methode

Physisches Löschen eines Datensatzes.

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragselement_Referenz(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


frmReferenzvertraege -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
        Me.Akutelle_Referenz = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmApplikationskontakt -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmVertragselementSuche.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragselementSuche


frmProfilVerwaltung.dispose -Methode

Formular-Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Overloads Sub dispose()
        Me.profil.Dispose()
        Me.msg.dispose()
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic]
Public Function Get_Vertragskontakte( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
C1TrueDBGrid
Vertragselementnr
Vertragselement, für welches die Kontakte ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Vertragskontakte(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Vertragskontakte = New TKB.VV.Sysadmin.DomainTable("Vertragskontakt", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragskontakte.Tabledata
            c1data.DataMember = Vertragskontakte.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Dokumente (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Windows.Forms.ImageList) -Methode

Dokumente lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Dokumente( _
   ByRef c1data As C1TrueDBGrid, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByRef c1data As C1TrueDBGrid, Optional ByVal ImgList As ImageList = Nothing)
            Try
                dokumente.dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            'dokumente = Dokument.get
            dokumente = Dokument.Get_Dokumente(Me.iVertragselementnr.Value, 1)
            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Dokumente (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32, System.Windows.Forms.ImageList) -Methode

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic]
Public Function Get_Dokumente( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer, _
   Optional ByVal ImgList As ImageList = Nothing _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden
ImgList
Optional. Der Standardwert ist Nothing.

Quellcode

[Visual Basic]
        Public Function Get_Dokumente(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer, Optional ByVal ImgList As ImageList = Nothing)
            Me.Get_Vertragselement(Vertragselementnr)
            dokumente = Dokument.Get_Dokumente(Me.iVertragselementnr.Value, 1)

            c1data.DataSource = dokumente
            c1data.DataMember = dokumente.TableName
            If Not ImgList Is Nothing Then
                Me.Set_Imagevalues(c1data, ImgList)
            End If
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Vertragselement_Referenzen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Referenzverträge lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Vertragselement_Referenzen( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Vertragselement_Referenzen(ByRef c1data As C1TrueDBGrid)
            Try
                Vertragselement_Referenz.dispose()
                Vertragselement_Referenzen = Nothing
            Catch ex As Exception

            End Try
            Vertragselement_Referenzen = New TKB.VV.Sysadmin.DomainTable("Vertragselement_Referenz", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragselement_Referenzen.Tabledata
            c1data.DataMember = Vertragselement_Referenzen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Vertragselement_Referenzen (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Pendenzen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_Vertragselement_Referenzen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Vertragselement_Referenzen(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Vertragselement_Referenzen = New TKB.VV.Sysadmin.DomainTable("Vertragselement_Referenz", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = Vertragselement_Referenzen.Tabledata
            c1data.DataMember = Vertragselement_Referenzen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Services (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Vertragsleistungen lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Services( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Services(ByRef c1data As C1TrueDBGrid)
            Try
                Service.Dispose()
                Services = Nothing
            Catch ex As Exception

            End Try
            Services = New TKB.VV.Sysadmin.DomainTable("Vertragsleistung", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Services.Tabledata
            c1data.DataMember = Services.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Applikationen (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Applikationen auslesen und dem Truedbgrid übergeben.

[Visual Basic]
Public Function Get_Applikationen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Applikationen(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            VertragselementApplikationen = New TKB.VV.Sysadmin.DomainTable("VertragselementApplikation", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = VertragselementApplikationen.Tabledata
            c1data.DataMember = VertragselementApplikationen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Aktivitaeten (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Aktivitaeten lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Aktivitaeten( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Aktivitaeten(ByRef c1data As C1TrueDBGrid)
            Try
                Aktivitaeten.dispose()
                Aktivitaeten = Nothing
            Catch ex As Exception

            End Try
            Aktivitaeten = New TKB.VV.Sysadmin.DomainTable("Aktivitaet", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Aktivitaeten.Tabledata
            c1data.DataMember = Aktivitaeten.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Aktivitaeten (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Aktivitaeten auslesen und dem Truedbgrid übergeben.

[Visual Basic]
Public Function Get_Aktivitaeten( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Aktivitaeten(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Aktivitaeten = New TKB.VV.Sysadmin.DomainTable("Aktivitaet", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = Aktivitaeten.Tabledata
            c1data.DataMember = Aktivitaeten.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


ComboBoxIconItem -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Public Sub New()
        _text = ""
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


ComboBoxIconItem -Konstructor (System.String)

[Visual Basic]
Public Sub New( _
   ByVal text As String _
)

Parameter

text

Quellcode

[Visual Basic]
    Public Sub New(ByVal text As String)
        _text = text
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

ComboBoxIconItem


frmVertragsuebersicht -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        Me.IsOnLoad = True
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


frmVertragsuebersicht -Konstructor (System.Int32)

[Visual Basic]
Public Sub New( _
   ByVal Partnernr As Integer _
)

Parameter

Partnernr

Quellcode

[Visual Basic]
    Sub New(ByVal Partnernr As Integer)
        Me.IsOnLoad = True
        InitializeComponent()
        Me.PartnerToSelect = Partnernr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragsuebersicht


clsVertragsereignis.dispose -Methode

Destructor Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Overloads Sub dispose()
            Vertragsereignisse = Nothing
            Vertragsereignis.Dispose()
            Ereignistypen.dispose()
            Kostenarten.dispose()
            Periodizitäten.dispose()
            MyBase.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Get_Vertragsereignisse (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Vertragsereignis zu einem Vertragselement auselesen

[Visual Basic]
Public Function Get_Vertragsereignisse( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
Datagrid, welches die Kontaktpersonen anzeigt

Quellcode

[Visual Basic]
        Public Function Get_Vertragsereignisse(ByRef c1data As C1TrueDBGrid)
            Try
                Vertragsereignisse.dispose()
                Vertragsereignis = Nothing
            Catch ex As Exception
            End Try
            Vertragsereignisse = New TKB.VV.Sysadmin.DomainTable("Ereignis", Me.iEreignisNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragsereignisse.Tabledata
            c1data.DataMember = Vertragsereignisse.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Get_Vertragsereignisse -Methode

Kontaktpersonen zu einem VertragsEreignis auslesen

[Visual Basic]
Public Function Get_Vertragsereignisse() As DataSet

Quellcode

[Visual Basic]
        Public Function Get_Vertragsereignisse() As DataSet
            Try
                Vertragsereignisse.dispose()
                Vertragsereignis = Nothing
            Catch ex As Exception
            End Try
            Vertragsereignisse = New TKB.VV.Sysadmin.DomainTable("Vertragsereignis", Me.iEreignisNr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Return Vertragsereignisse.Tabledata
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsereignis.Delete -Methode

VertragsEreignis inaktivieren

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_Ereignis(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsereignis


clsVertragsleistung.Delete -Methode

Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Vertragsleistung(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragsleistung


clsKuendigungsfrist.Delete -Methode

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   ByVal Basenr As Integer _
) As Integer

Parameter

Basenr

Quellcode

[Visual Basic]
        Public Overloads Function Delete(ByVal Basenr As Integer) As Integer
            If Basenr <> 0 Then
                Get_Kuendigungsfrist(Basenr)
            End If
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKuendigungsfrist


Readme-Member

Readme Übersicht

Readme -Klasse


clsKontakt.Delete -Methode

Physisches Löschen eines Datensatzes erstellen.

[Visual Basic]
Public Overloads Function Delete( _
   ByVal Basenr As Integer _
) As Integer

Parameter

Basenr

Quellcode

[Visual Basic]
        Public Overloads Function Delete(ByVal Basenr As Integer) As Integer
            If Basenr <> 0 Then
                Me.Get_Vertragskontakt(Basenr)
            End If
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsKontakt


clsPersonen.Delete -Methode

Kontakt löschen

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Ursprungs-Person: Ist dieser Wert nicht 0, werden die Daten mit BaseNr zuerst gelesen

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Get_Person(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsPersonen


clsApplikation.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()
            Try
                Applikation.Dispose()
                Verantwortungen.Dispose()
                'Verantwortung.Dispose()
                Kategorien.Dispose()
                'Kategorie.Dispose()
                Marktbereiche.Dispose()
                'Marktbereich.Dispose()
                Kritikalitaeten.Dispose()
                'Kritikalitaet.Dispose()
                SLMs.Dispose()
                'SLM.Dispose()
                Installiert_auf.Dispose()
                Installiertauf.Dispose()
                Installiert_als.Dispose()
                Installiertals.Dispose()
                Installation_Standard.Dispose()
                InstallationStandard.Dispose()
                Applikation_Installationtyp.Dispose()
                ApplikationInstallationTyp.Dispose()
                Applikation_Installationals.Dispose()
                ApplikationInstallationals.Dispose()
                Applikation_InstallationFuer.Dispose()
                ApplikationInstallationFuer.Dispose()
                Vertragselement.dispose()
                TestAufwendungen.Dispose()
                Testaufwand.Dispose()
                Dokument.Dispose()
                dokumente.Dispose()
                RFCBoards.Dispose()
                Teams.Dispose()
                Periodizitäten.Dispose()
                SDAdministratoren.Dispose()
                Me.Applikationabhaengigkeit.dispose()
                Me.Applikationabhaengigkeiten.dispose()
                Me.Lizenzkauf.Dispose()
                Me.Lizenzschluessel.Dispose()
                Applikation = Nothing
            Catch
            End Try
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsApplikation


frmVertragspartner -Konstructor

Constructor New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        MyBase.New()
        Me.InitializeComponent()
        Me.vpnr = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner -Konstructor (System.Int32, System.Boolean, System.Boolean)

Formualr mit Vertragspartnernr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal vertragspartnernr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

vertragspartnernr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal vertragspartnernr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        Me.InitializeComponent()
        Me.Anzeige = Anzeige
        If CreateNew Then
            Me.vpnr = Me.Vertragspartnerdata.Add_New
            Me.txtName_Firma1.Text = "*** Neuer Vertragspartner ***"
            Me.txtName_Firma1.SelectAll()
        Else
            Me.vpnr = vertragspartnernr
        End If
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragspartner.dispose -Methode

destruction Dispose

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Overloads Sub dispose()
        Vertragspartnerdata.dispose()
        Kontaktperson.Dispose()
        sec = Nothing
        msg = Nothing
        SpaltenTitel = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragspartner


frmVertragskontakt -Konstructor

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmVertragskontakt -Konstructor (System.Int32, System.Int32, System.Int32, System.Boolean, System.Boolean)

[Visual Basic]
Public Sub New( _
   ByVal Vertragskontaktnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Vertragselementnr As Integer, _
   Optional ByVal CreateNew As Boolean = False, _
   Optional ByVal FormReadOnly As Boolean = False _
)

Parameter

Vertragskontaktnr
Erforderlich.
Vertragspartnernr
Erforderlich.
Vertragselementnr
Erforderlich.
CreateNew
Optional. Der Standardwert ist False.
FormReadOnly
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Vertragskontaktnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Vertragselementnr As Integer, Optional ByVal CreateNew As Boolean = False, Optional ByVal FormReadOnly As Boolean = False)
        Me.FormReadonly = FormReadOnly
        InitializeComponent()
        If CreateNew = True Then
            Me.Vertragskontaktnr = Me.Kontaktperson.Add_New(Vertragselementnr)
            Me.Neuer_Datensatz = True
        Else
            Me.Vertragskontaktnr = Vertragskontaktnr
        End If
        Me.VertragspartnerNr = Vertragspartnernr
        Me.Vertragselementnr = Vertragselementnr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmVertragskontakt


frmPendenz.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


clsVertragselementApplikation.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsVertragselementApplikation.Delete -Methode

Physisches Löschen eines Datensatzes.

[Visual Basic]
Public Overloads Function Delete( _
   Optional ByVal Basenr As Integer = 0 _
) As Integer

Parameter

Basenr
Optional. Der Standardwert ist 0.

Quellcode

[Visual Basic]
        Public Overloads Function Delete(Optional ByVal Basenr As Integer = 0) As Integer
            If Basenr <> 0 Then
                Me.Get_VertragselementApplikation(Basenr)
            End If
            Me.cpMainConnectionProvider = Globals.conn
            Globals.conn.OpenConnection()
            MyBase.Delete()
            Globals.conn.CloseConnection(True)
            Me.Neuer_Datensatz = False
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselementApplikation


clsReferenzvertrag.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
        Public Overloads Sub dispose()
            MyBase.Dispose()

            Beziehungstyp.Dispose()
            Beziehungstyp = Nothing
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsReferenzvertrag


frmReferenzvertraege -Konstructor (System.Int32, System.Int32, System.Boolean, System.Boolean)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal Referenznr As Integer, _
   ByVal Vertragselementnr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Referenznr
Erforderlich.
Vertragselementnr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Referenznr As Integer, ByVal Vertragselementnr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        InitializeComponent()
        If CreateNew Then
            Me.Akutelle_Referenz = Me.Referenzvertragdata.Add_New(Vertragselementnr)
            Me.Neuer_Datensatz = True
        Else
            Me.Akutelle_Referenz = Referenznr
        End If
        Me.Anzeige = Anzeige
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmReferenzvertraege.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Referenzvertragdata.dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmReferenzvertraege


frmApplikationskontakt -Konstructor (System.Int32, System.Int32, System.Int32, System.Boolean, System.Boolean)

[Visual Basic]
Public Sub New( _
   ByVal Applikationskontaktnr As Integer, _
   ByVal Vertragspartnernr As Integer, _
   ByVal Applikationsnr As Integer, _
   Optional ByVal CreateNew As Boolean = False, _
   Optional ByVal FormReadOnly As Boolean = False _
)

Parameter

Applikationskontaktnr
Erforderlich.
Vertragspartnernr
Erforderlich.
Applikationsnr
Erforderlich.
CreateNew
Optional. Der Standardwert ist False.
FormReadOnly
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Applikationskontaktnr As Integer, ByVal Vertragspartnernr As Integer, ByVal Applikationsnr As Integer, Optional ByVal CreateNew As Boolean = False, Optional ByVal FormReadOnly As Boolean = False)
        InitializeComponent()
        Me.FormReadonly = FormReadOnly
        If CreateNew = True Then
            Me.Applikationskontaktnr = Me.Kontaktperson.Add_New(Applikationsnr)
            Me.Neuer_Datensatz = True
        Else
            Me.Applikationskontaktnr = Applikationskontaktnr
        End If
        Me.VertragspartnerNr = Vertragspartnernr
        Me.Applikationsnr = Applikationsnr
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationskontakt


frmApplikationAbhaengigkeit.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


DomainTable -Konstructor (System.String, System.Int32, System.String)

Tabellenname übernehmen und Daten ab DB laden

[Visual Basic]
Public Sub New( _
   ByVal tablename As String, _
   Optional ByVal Fokus As Integer = 0, _
   Optional ByVal Keyvalue As String = "" _
)

Parameter

tablename
Erforderlich.
Fokus
Optional. Der Standardwert ist 0.
Keyvalue
Optional. Der Standardwert ist "".

Quellcode

[Visual Basic]
        Sub New(ByVal tablename As String, Optional ByVal Fokus As Integer = 0, Optional ByVal Keyvalue As String = "")
            Me.Tablename = tablename
            If Keyvalue = "" Then
                Load_Data()
            Else
                Load_Bootom_Table(tablename, Fokus, Keyvalue)
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable -Konstructor (System.String, System.Int32, System.String, System.Int32)

[Visual Basic]
Public Sub New( _
   ByVal tablename As String, _
   ByVal Fokus As Integer, _
   ByVal Keyvalue As String, _
   ByVal mitarbeiternr As Integer _
)

Parameter

tablename
Fokus
Keyvalue
mitarbeiternr

Quellcode

[Visual Basic]
        Sub New(ByVal tablename As String, ByVal Fokus As Integer, ByVal Keyvalue As String, ByVal mitarbeiternr As Integer)
            Me.Tablename = tablename
            If Keyvalue = "" Then
                Load_Data()
            Else
                Load_Data_MA_Fokus(tablename, Fokus, Keyvalue, mitarbeiternr)
            End If
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable -Konstructor (System.String, System.String, System.Int32)

[Visual Basic]
Public Sub New( _
   ByVal tablename As String, _
   ByVal keyvalue As String, _
   ByVal mitarbeiternr As Integer _
)

Parameter

tablename
keyvalue
mitarbeiternr

Quellcode

[Visual Basic]
        Sub New(ByVal tablename As String, ByVal keyvalue As String, ByVal mitarbeiternr As Integer)
            Me.Tablename = tablename
            Load_Data_MA(tablename, keyvalue, mitarbeiternr)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


DomainTable -Konstructor (System.String, System.Int32, System.String, System.Int32, System.String)

[Visual Basic]
Public Sub New( _
   ByVal tablename As String, _
   ByVal Focus As Integer, _
   ByVal keyvalue As String, _
   ByVal mitarbeiternr As Integer, _
   ByVal Key2 As String _
)

Parameter

tablename
Focus
keyvalue
mitarbeiternr
Key2

Quellcode

[Visual Basic]
        Sub New(ByVal tablename As String, ByVal Focus As Integer, ByVal keyvalue As String, ByVal mitarbeiternr As Integer, ByVal Key2 As String)
            Me.Tablename = tablename
            Load_Data_2Key(tablename, keyvalue, mitarbeiternr, Key2)
        End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

DomainTable


frmProfilVerwaltung.Dispose -Methode

[Visual Basic]
<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameter

disposing

Quellcode

[Visual Basic]
    Protected Overrides Sub Dispose(ByVal disposing As Boolean)
        Try
            If disposing AndAlso components IsNot Nothing Then
                components.Dispose()
            End If
        Finally
            MyBase.Dispose(disposing)
        End Try
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmProfilVerwaltung


clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Kündiguntsfristen lasen und dem Grid übergeben

[Visual Basic]
Public Function Get_Kuendigungsfristen( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Kündigungsfristen

Quellcode

[Visual Basic]
        Public Function Get_Kuendigungsfristen(ByRef c1data As C1TrueDBGrid)
            Try
                Kuendigungsfristen.dispose()
                Kuendigungsfristen = Nothing
            Catch ex As Exception

            End Try
            Kuendigungsfristen = New TKB.VV.Sysadmin.DomainTable("Kuendigungsfrist", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kuendigungsfristen.Tabledata
            c1data.DataMember = Kuendigungsfristen.Tabledata.Tables(0).TableName

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Kuendigungsfristen (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Kündiguntsfristen lasen und dem Grid übergeben

[Visual Basic]
Public Function Get_Kuendigungsfristen( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
C1TrueDBGrid mit Kündigungsfristen
Vertragselementnr
Vertragselement, für welches die Kündigungsfristen geladen werden sollen

Quellcode

[Visual Basic]
        Public Function Get_Kuendigungsfristen(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            If Vertragselementnr <> -1 Then Me.Get_Vertragselement(Vertragselementnr)

            Try
                Kuendigungsfristen.dispose()
                Kuendigungsfristen = Nothing
            Catch ex As Exception

            End Try
            If Vertragselementnr <> -1 Then
                Me.Get_Vertragselement(Vertragselementnr)
            End If
            Kuendigungsfristen = New TKB.VV.Sysadmin.DomainTable("Kuendigungsfrist", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Kuendigungsfristen.Tabledata
            c1data.DataMember = Kuendigungsfristen.Tabledata.Tables(0).TableName

        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Vertragskontakte (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Kontakte auslesen und dem TrueDBGrid übergeben

[Visual Basic]
Public Function Get_Vertragskontakte( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid

Quellcode

[Visual Basic]
        Public Function Get_Vertragskontakte(ByRef c1data As C1TrueDBGrid)
            Try
                Vertragskontakte.dispose()
                Vertragskontakte = Nothing
            Catch ex As Exception

            End Try
            Vertragskontakte = New TKB.VV.Sysadmin.DomainTable("Vertragskontakt", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragskontakte.Tabledata
            c1data.DataMember = Vertragskontakte.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Vertragsereignisse (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Dokumente lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Vertragsereignisse( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Vertragsereignisse(ByRef c1data As C1TrueDBGrid)
            Try
                Vertragsereignis.dispose()
                dokumente = Nothing
            Catch ex As Exception

            End Try
            Vertragsereignisse = New TKB.VV.Sysadmin.DomainTable("Vertragsereignis", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragsereignisse.Tabledata
            c1data.DataMember = Vertragsereignisse.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Vertragsereignisse (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Kontakte auslesen und dem Truedbgrid übergeben

[Visual Basic]
Public Function Get_Vertragsereignisse( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Vertragsereignisse(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Vertragsereignisse = New TKB.VV.Sysadmin.DomainTable("Vertragsereignis", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = Vertragsereignisse.Tabledata
            c1data.DataMember = Vertragsereignisse.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Services (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_Services( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_Services(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            Services = New TKB.VV.Sysadmin.DomainTable("Vertragsleistung", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = Services.Tabledata
            c1data.DataMember = Services.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_History (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

History lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_History( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit History

Quellcode

[Visual Basic]
        Public Function Get_History(ByRef c1data As C1TrueDBGrid)
            Try
                History = Nothing
            Catch ex As Exception

            End Try
            History = New TKB.VV.Sysadmin.DomainTable("History", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = History.Tabledata
            c1data.DataMember = History.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_History (C1.Win.C1TrueDBGrid.C1TrueDBGrid, System.Int32) -Methode

Services / Vertragsleistungen auslesen und dem Truedbgrid übergeben. Ist im Feld Termin der Wert "01.01.1900" wird dieser durch NULL ersetzt

[Visual Basic]
Public Function Get_History( _
   ByRef c1data As C1TrueDBGrid, _
   ByVal Vertragselementnr As Integer _
) As Object

Parameter

c1data
TruedbGrid
Vertragselementnr
Vertragselement, für welches die Dokumente ausgelesen werden

Quellcode

[Visual Basic]
        Public Function Get_History(ByRef c1data As C1TrueDBGrid, ByVal Vertragselementnr As Integer)
            Me.Get_Vertragselement(Vertragselementnr)
            History = New TKB.VV.Sysadmin.DomainTable("History", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            Dim i As Integer = 0
            c1data.DataSource = History.Tabledata
            c1data.DataMember = History.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


clsVertragselement.Get_Applikationen (C1.Win.C1TrueDBGrid.C1TrueDBGrid) -Methode

Applikationen lesen und dem Grid übergeben

[Visual Basic]
Public Function Get_Applikationen( _
   ByRef c1data As C1TrueDBGrid _
) As Object

Parameter

c1data
C1TrueDBGrid mit Dokumente

Quellcode

[Visual Basic]
        Public Function Get_Applikationen(ByRef c1data As C1TrueDBGrid)
            Try
                VertragselementApplikationen.dispose()
                VertragselementApplikationen = Nothing
            Catch ex As Exception

            End Try
            VertragselementApplikationen = New TKB.VV.Sysadmin.DomainTable("VertragselementApplikation", Me.iVertragselementnr.ToString, Globals.clsmitarbeiter.iMitarbeiternr.Value)
            c1data.DataSource = VertragselementApplikationen.Tabledata
            c1data.DataMember = VertragselementApplikationen.Tabledata.Tables(0).TableName
        End Function

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

clsVertragselement


frmApplikationAbhaengigkeit -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
        Me.Akutelle_Referenz = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit -Konstructor (System.Int32, System.Int32, System.Boolean, System.Boolean)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal Referenznr As Integer, _
   ByVal Vertragselementnr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Referenznr
Erforderlich.
Vertragselementnr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Referenznr As Integer, ByVal Vertragselementnr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        InitializeComponent()
        If CreateNew Then
            Me.Akutelle_Referenz = Me.Applikationabhaengigkeitdata.Add_New(Vertragselementnr)
            Me.Neuer_Datensatz = True
        Else
            Me.Akutelle_Referenz = Referenznr
        End If
        Me.Anzeige = Anzeige
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmApplikationAbhaengigkeit.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Applikationabhaengigkeitdata.dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmApplikationAbhaengigkeit


frmPendenz -Konstructor

Standard Constructore New

[Visual Basic]
Public Sub New()

Quellcode

[Visual Basic]
    Sub New()
        InitializeComponent()
        Me.Aktuelle_Pendenz = -1
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz -Konstructor (System.Int32, System.Int32, System.Boolean, System.Boolean)

Formualr mit Vertragselementnr und Anzeigestatus öffnen

[Visual Basic]
Public Sub New( _
   ByVal Pendenznr As Integer, _
   ByVal vertragselementnr As Integer, _
   ByVal Anzeige As Boolean, _
   Optional ByVal CreateNew As Boolean = False _
)

Parameter

Pendenznr
Erforderlich.
vertragselementnr
Nr des Vertragspartners
Anzeige
True=Readonly, False=normal
CreateNew
Optional. Der Standardwert ist False.

Quellcode

[Visual Basic]
    Sub New(ByVal Pendenznr As Integer, ByVal vertragselementnr As Integer, ByVal Anzeige As Boolean, Optional ByVal CreateNew As Boolean = False)
        MyBase.New()
        InitializeComponent()
        If CreateNew Then
            Me.Aktuelle_Pendenz = Me.Pendenz.Add_New(vertragselementnr)
            Me.Pendenz.Neuer_Datensatz = True
        Else
            Me.Aktuelle_Pendenz = Pendenznr
        End If
        Aktuelles_Vertragselement = vertragselementnr
        Me.Anzeige = Anzeige
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz


frmPendenz.dispose -Methode

[Visual Basic]
Public Overloads Sub dispose()

Quellcode

[Visual Basic]
    Public Overloads Sub dispose()
        Me.Pendenz.Dispose()
        sec = Nothing
        msg = Nothing
        MyBase.Dispose()
    End Sub

Forderungen

Plattformen: Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

frmPendenz